What's New

dotConnect for Oracle Documentation
What's New
support@devart.com

dotConnect for Oracle 9.2 new features:

  • The 'Do not install assemblies in the GAC' check box that allows disabling placing the provider assemblies to the GAC is added to the Install Wizard
  • Oracle ANYDATA type is supported in the Direct mode
  • The InitialLobFetchSize property of OracleCommand is supported in the Direct mode
  • The behaviour is changed: the OracleArray constructor now verifies that OracleArray is not created for a UDT that is not VARRAY

LinqConnect (formerly known as LINQ to Oracle)

  • The exception message for invoking CreateDatabase() for the model which includes an association with missing end is improved

Entity Developer

  • The possibility to choose whether to add new entities to a diagram or not in Update From Database Wizard is implemented
  • The behaviour is changed: now the DbContext template generates an additional partial class for the context class when "File Per Class" and "Generate Partial Class" are set to True (Entity Framework models)

Entity Framework support

  • Entity Framework Core 1.1.0 is supported
  • The Scaffold-DbContext NuGet command of Package Manager Console for generating a model basing on the existing database schema is supported in EF Core
  • Batch Updates support in EF Core is added
  • The OracleJsonFunctions class is implemented in EF4/EF5/EF6 to use JSON functions and operators in LINQ to Entities queries
  • Signed versions of NetTopologySuite GIS library are supported in EF5/EF6
  • NetTopologySuite 1.14 is supported in EF5/EF6
  • GeoAPI 1.7.4 is supported in EF5/EF6
  • The NetTopologySuiteSigned and NetTopologySuiteUnsigned members are added to the SpatialServiceType enum in EF5/EF6
  • The config.DatabaseScript.Schema.DeleteDatabaseBehaviour option is supported in EF Core
  • The behaviour is changed: the functionality of SpatialServiceType.NetTopologySuiteSigned is moved to Devart.Data.Oracle.Entity.EF5.dll / Devart.Data.Oracle.Entity.EF6.dll
  • The behaviour is changed: the errors thrown by executing SQL statement CREATE/DROP USER are ignored now

dotConnect for Oracle 9.1 new features:

  • Microsoft SQL Server Data Tools Business Intelligence (SSDT-BI) project templates for Analysis Services, Reporting Services, and Integration Services (mapping wizards) in Visual Studio 2015 are supported
  • Microsoft SQL Server 2016 is supported in SSIS DataFlow components
  • The IEnumerable<OracleSqlStatement>, ICollection<OracleSqlStatement>, and IList<OracleSqlStatement> interfaces are implemented in the OracleSqlStatementCollection class
  • New CharLength and CharUsed columns have been added to the Columns collection of the OracleConnection.GetSchema method
  • The execution of OracleScript with the PL/SQL declaration sections in the WITH clause in Oracle 12c is supported
  • The alternative quoting mechanism for string literals (string literals with the Q prefix) of Oracle 10g and higher is supported in the OracleScript class
  • The binary serialization is added to OracleString, OracleBinary, OracleNumber, OracleDate, OracleIntervalDS, and OracleIntervalYM structures
  • The output of the domain to the "machine" column and output of the "process" column values in the Direct mode are supported
  • The Data Encryption and Data Integrity feature in the Direct mode is supported
  • The EZCONNECT format is supported in the Direct mode
  • The performance using a default value (changed to 8192) of DirectUtils.PacketSize in the Direct mode via VPN connection is improved
  • The performance of inserting CLOB data is improved
  • The performance of retrieving metadata for stored procedures in the Direct mode is improved
  • The performance of retrieving data in the Direct mode is improved

Entity Developer

  • Entity Framework Core 1.0 RTM is supported
  • The possibility to set values of stored procedure parameters for getting metadata to generate automatically the corresponding complex type is implemented
  • The generation of static methods by the EntityObject template is supported via the new property Direct Call of EntityMethod (Entity Framework models)
  • The behaviour is changed: the ObservableCollection navigation properties are initialized now in a default class constructor (Entity Framework models)

Entity Framework support

  • Entity Framework Core 1.0.1 is supported
  • The OracleConventionSetBuilder class is implemented in the Entity Framework Core support
  • The SqlFunctions.DatePart method is supported in LINQ to Entities for the following modifiers: year, month, day, hour, minute, second, millisecond, tzoffset
  • OracleCSharpMigrationCodeGenerator and OracleVisualBasicMigrationCodeGenerator for code-based migrations are implemented for EF4, EF5, EF6
  • The CheckConstraintColumnRestriction property of the OracleAddColumnConfiguration class for customization of the AddColumn operation in EF4, EF5, EF6 Code-First Migrations is implemented
  • The OracleColumnAnnotations class for customization of creating columns in the CreateTable operation in EF6 Code-First Migrations is implemented
  • The DatabaseFacade.GetOracleConnection() extension method, which returns OracleConnection, is implemented in EF Core
  • The config.SpatialOptions.ReadAs2D configuration option (default value is False) is implemented for EF5 / EF6 to treat 3D SDO_GEOMETRY objects as 2D
  • The new optional parameter Action<OracleDbContextOptionsBuilder> is added to UseOracle() extension method of DbContextOptionsBuilder in EF Core
  • The behaviour is changed: FK constraints within CREATE TABLE are named now in Code-First Migrations

dotConnect for Oracle 9.0 new features:

  • HA Events from Oracle RAC are supported
  • Connection pool performance counters are implemented
  • The PartitionName property, specifying the name of the partitioned table partition to load data into, is added to the OracleLoader class
  • The new LoadTable overloads for loading data from a IDataReader, array of rows, or only rows with a specific RowState from a DataTable are added to the OracleLoader class
  • The Options property of the new OracleLoaderOptions type that allows configuring OracleLoader behavior is added to the OracleLoader class
  • The RowsCopied event that allows tracking data loading progress and correctly break the data loading operation is added to the OracleLoader class
  • When loading data in the OCI mode using array binding, OracleLoader now adds the /* APPEND_VALUES */ hint to the generated SQL for Oracle 11g Release 2 and higher
  • The OracleLogicalTransaction property is added to the OracleConnection class and the new OracleLogicalTransaction class is created for better support of Oracle Transaction Guard
  • All DbTypes are supported
  • Truncate member that represents the TRUNCATE TABLE statement is added to the SqlStatementType enum
  • The GetMappedType method that returns the result .NET type for the specified precision and scale and allows testing specified number mapping configuration is added to the OracleNumberMappingCollection class
  • Oracle objects in array binding in the Direct mode are supported
  • The OracleLob class is improved
  • The OracleXml class is improved
  • The OracleNumber structure is improved
  • The OracleDate structure is improved
  • The OracleTimeStamp structure is improved
  • The OracleBoolean structure is improved
  • The OracleCursor class is improved
  • The OracleString class is improved
  • The OracleRef class is improved
  • The OracleHomeCollection class is improved
  • Support for binary representation of Oracle data types is improved in OracleDate and OracleString structures
  • The Run Once Command connection string parameter, which specifies a command or several commands to execute when the connection is opened the first time and not executed when the connection is taken from the pool, is added
  • The Initialization Command connection string parameter is improved: now it can contain several commands
  • The implementation of DML arrays in output parameters in the Direct mode is improved
  • The exception message when the source value is out of range for a .NET Framework type is improved: now it also contains the name of column that caused the issue
  • The behavior is changed: the CreateColumns method of the OracleLoader class now does not add GENERATED ALWAYS AS IDENTITY columns to the collection in the OCI mode
  • The behavior is changed: now the ORA-01805 error is ignored when Oracle Client and server have timezone files of different versions and a value of a TIMESTAMP WITH TIME ZONE with time zone explicitly specified by name is read
  • The behavior is changed: number mappings in the connection string now influence the code generated by Oracle Package Wizard

LinqConnect (formerly known as LINQ to Oracle)

  • Bitwise And, Or, and Xor operators are supported in LINQ queries for integer operands

Entity Developer

  • Entity Framework Core support is added
  • The DbProviderFactory provider registration in application's *.config is supported by the Entity Developer version integrated into Visual Studio

Entity Framework support

  • Entity Framework Core RC2 is supported
  • Entity Framework-related assemblies are renamed
  • The config.QueryOptions.OrderByNullBehavior option is added to specify whether to add NULLS FIRST or NULLS LAST to the ORDER BY clause
  • Upgrade Wizard is improved for upgrading projects with the Entity Framework functionality

dotConnect for Oracle 8.5 new features:

  • Visual Studio 2015 is supported
  • The type of the "details" and "sessionitems" columns of the "aspnet_webevent_events" and "aspnet_sessions" tables respectively is changed from LONG to CLOB in the InstallWebTables.sql file
  • The largest possible value of DirectUtils.PacketSize is increased to 32768
  • The possibility to create an unsafe pointer to an OracleIntervalDS structure is added

LinqConnect (formerly known as LINQ to Oracle)

  • The possibility to use .IsRowVersion() method for properties with non-binary data types when using the fluent mapping approach is added
  • The Parent property is added to the IInheritanceConfiguration interface

Entity Developer

  • The support for materialized views is implemented
  • The Use ObservableCollection property of the DbContext template is implemented (Entity Framework models)
  • The behaviour is changed: now the 1:1 and 1:0..1 associations are displayed differently on the diagram (LinqConnect models)

Entity Framework support

  • The overloads for Contains and Matches methods are added to the OracleTextFunctions class for using full-text search with the binary columns
  • The config.QueryOptions.TrueValueNumber configuration option is added to specify SQL generation for True values (either equal to 1 or not equal to 0)
  • The spatial constant functionality is implemented

dotConnect for Oracle 8.4 new features:

  • Visual Studio 2015 Release Candidate is supported
  • Oracle TimesTen 11g Release 1 and Oracle TimesTen 11g Release 2 are supported in the OCI mode on 32-bit and 64-bit platforms
  • The ServerType property of the OracleServerType type is added to the OracleConnection class
  • A enum OracleServerType is added; it contains the following elements: Oracle, TimesTen, Undefined
  • The Oracle TimesTen-specific data types are supported: TT_TINYINT, TT_SMALLINT, TT_INTEGER, TT_BIGINT, TT_DATE, TT_TIMESTAMP, TIME, BINARY and VARBINARY
  • New elements are added to the OracleDbType enum for better support of the Oracle TimesTen-specific TT_TINYINT, TT_SMALLINT, and TT_BIGINT data types: Byte, Int16, and Int64
  • Getting metadata with the GetSchema() method of OracleConnection, connecting to an Oracle database using Windows Authentication, is supported
  • Server Explorer integration for Windows Authentication connections to Oracle database is supported
  • Server Explorer integration for Oracle TimesTen is supported
  • The Managed ODP.NET support is added to Migration Wizard
  • ADO.NET implementation of ASP.NET Identity 2.0 support is improved
    • The new IUserStore<T>, IUserClaimStore<T>, IUserLoginStore<T>, IUserPasswordStore<T>, IUserRoleStore<T>, IUserEmailStore<T>, IUserPhoneNumberStore<T> interfaces are implemented in the OracleUserStore and OracleUserStore<TIdentityUser, TIdentityRole> classes
    • The new IRoleStore<T> interface is supported in the OracleRoleStore and OracleRoleStore<TIdentityUser, TIdentityRole> classes
    • The new IQueryableUserStore interface is implemented in the UserStore class
    • The new IQueryableRoleStore interface is implemented in the RoleStore class
  • The Enterprise Library 6 support is added; all previous versions of Enterprise Library are no longer maintained
  • The new \Web\ASP.NET 45\Devart.Data.Oracle.Web.dll assembly (its revision number is 5) is added to the provider installation folder to support SimpleMembership in MVC5
  • The enableExpiredSessionAutoDeletion and expiredSessionAutoDeletionInterval options for deleting expired sessions are added to the session-state store provider definition in the web.config file
  • The InitialLobFetchSize property, that specifies the amount of data OracleDataReader initially fetches for LOB columns, is added to the OracleCommand
  • Microsoft SQL Server Data Tools Business Intelligence (SSDT-BI) project templates for Analysis Services and Integration Services in Visual Studio 2013 are supported
  • SSIS DataFlow Source and Destination components are supported in SSDT-BI for Visual Studio 2013
  • The IPv6 protocol is supported in the Direct mode
  • dotConnect for Oracle is now FIPS compliant on .NET Framework 3.5 in the Direct mode
  • The performance of the Update method of the OracleDataAdapter and OracleDataTable classes when using the UpdateBatchSize property is improved
  • The behaviour is changed: the OracleMonitor now hides information about the password connection string parameter
  • The behaviour is changed: SYS_EXTRACT_UTC(SYSTIMESTAMP) is used now in WF Services scripts for the date columns
  • The behaviour is changed: OracleDataReader now returns ReadOnly=True in the schema table for the GENERATED ALWAYS AS IDENTITY columns (for Oracle 12c)
  • The behaviour is changed: the data are inserted in the config_data column of the scopeconfig table via the CLOB parameter (instead of dynamic SQL) in Sync Framework

LinqConnect (formerly known as LINQ to Oracle)

  • The OpenConnection() method is added to the DataContext class
  • The dependency on the System.Windows.Forms.dll assembly is removed

Entity Developer

  • The View Generation option of the model with Entity Framework version = Entity Framework 6 is supported for the DbContext (only with XML mapping), EntityObject, POCO, and Self-Tracking Entities templates (Entity Framework models)
  • The possibility to use relative paths to assemblies in code generation templates is implemented
  • The Implement Equals property is added to the DbContext, ObjectContext, and POCO Entity templates (Entity Framework models)
  • The Remove Invalid Characters option (by default, True) is added to the Model Naming rules; if it is set to False, all invalid characters will be replaced with underscores
  • The Enable WinForms Data Binding property of the DbContext template is implemented (Entity Framework models)
  • The Property Change Partial Methods property of the DbContext template is implemented for generating partial methods On%PropertyName%Changing and On%PropertyName%Changed for each primitive property of entity classes (Entity Framework models)
  • The support of ID generators for primary keys in the Fluent Mapping template is added (LinqConnect models)
  • The possibility of setting default values for enum properties is implemented (LinqConnect models)
  • The behaviour is changed: now partial configuration classes are generated when DbContext template is used with Fluent Mapping=True and Mapping Generation Strategy=UseConfigurationClasses options (Entity Framework models)
  • The behaviour is changed: now the default value for the 'File Per Class' option of the DbContext template is True (Entity Framework models)
  • The behaviour is changed: Generate Database Script From Model saves the output in ASCII format if there are no unicode symbols in the script; UTF-8 is used otherwise
  • The behaviour is changed: now the default values are not set for string properties, that correspond to fields with the default values like expressions (Entity Framework models)

Entity Framework support

  • Oracle TimesTen 11g Release 1 and Oracle TimesTen 11g Release 2 are supported in the run-time of Entity Framework provider versions for EF1, EF4, EF5, and EF6
  • Oracle TimesTen is supported in EDM Wizard/EDM Designer of VS 2008 SP1/VS 2010/VS 2012 and EF Tools for VS 2012/VS 2013 in the Database-First approach for creating Entity Framework models
  • Code-First CreateDatabase()/DatabaseExists()/DeleteDatabase() functionality is supported for Oracle TimesTen
  • Code-First Migrations feature is supported for Oracle TimesTen
  • Oracle TimesTen-specific data types are supported in Code-First / Code-First Migrations
  • The support of boolean properties, when the corresponding column is NUMBER(1, 0), is improved
  • The config.SpatialOptions.PrecisionModel configuration option is added to specify the NetTopologySuite precision model scale factors
  • The Devart.Data.Oracle.Entity.INDEX_HINT function for specifying Oracle INDEX hint without the explicitly specified table's alias in EntitySQL is added
  • The OracleFunctions.IndexHint method for specifying Oracle INDEX hint without the explicitly specified table's alias in LINQ to Entities is added
  • The config.DatabaseScript.Table.Tablespace configuration option is added to specify the tablespace for tables created via the Code-First approach
  • The config.DatabaseScript.Index.Tablespace configuration option is added to specify the tablespace for indexes created via the Code-First approach
  • The compatibility with SQL*Plus is improved: binary literals are now divided into fractions with 2000 symbols each when inserting data into MigrationHistory table
  • The SQL generation for LINQ queries with comparison based on the RAW(16) column is improved: explicit cast to RAW(16) is used now to make Oracle Server employ an existing index created for the RAW(16) column in Oracle execution plan
  • The performance of generating SQL for Enumerable.Contains in LINQ queries is improved by supporting a new expression type, DbInExpression, in Entity Framework 6
  • The behaviour is changed: Code-First/Code-First Migrations generate BINARY_FLOAT / BINARY_DOUBLE columns for the Single / Double class properties correspondingly for Oracle 10g and higher

dotConnect for Oracle 8.3 new features:

  • The ADO.NET implementation of ASP.NET Identity support is added

    • The ICloneable interface is implemented in the IdentityUser and IdentityRole classes
    • The User_Id column in the AspNetUserClaims table is renamed to UserId

  • The ADO.NET implementation of ASP.NET Identity 2.0 support is added

    • The new \Web\ASP.NET Identity 2\Devart.Data.Oracle.Web.Identity.dll assembly (its revision number is 2) is added to the provider installation folder
    • The new \Web\ASP.NET Identity 2\Install_identity_tables.sql and \Web\ASP.NET Identity 2\Uninstall_identity_tables.sql files are added to the provider installation folder
    • The new \Web\ASP.NET Identity 2\Upgrade_identity_tables_from_v1_to_v2.sql file is added to the provider installation folder
    • The new IUserEmailStore<TIdentityUser, TKey>, IUserPhoneNumberStore<TIdentityUser, TKey>, IUserTwoFactorStore<TIdentityUser, TKey>, IUserLockoutStore<TIdentityUser, TKey> interfaces are implemented in the UserStore class
  • The IDataReader interface is implemented in the OracleCursor class
  • The implementation of the OracleCommand.CommandTimeout property in the Direct mode is improved
  • The \Web\ASP.NET Identity 1\Install_identity_tables.sql file is updated: now user-friendly foreign key names are used
  • The possibility of assigning System.Guid to OracleParameter.Value without explicitly specified OracleParameter.OracleDbType is implemented
  • The script for updating Workflow Instance Store schema from .NET Framework 4.0 to .NET Framework 4.5 is added to the provider installation folder
  • The OracleConnection.ClearAllPools(bool force) method is added
  • The implementation of the ConnectionTimeout parameter of connection string in the OCI mode is improved
  • The OracleScript.Cancel() method is added to stop query execution
  • The behaviour is changed: the Errors property of the OracleException class is never null now and always has at least one element
  • The behaviour is changed: the Message property of the OracleException class now contains all distinct error messages returned by Oracle when using OracleLoader in the array binding mode and when calling ExecuteArray
  • The behaviour is changed: when using OracleLoader in the array binding mode, the table constraints are disabled for the time of data loading and is enabled again only when closing the OracleLoader object
  • The behaviour is changed: the instance_id field of the wf_activity_info table in Workflow Tracking implementation is of varchar(1000) type now

LinqConnect (formerly known as LINQ to Oracle)

  • The CommandTimeout property is added to the DataProvider class
  • The behaviour is changed: the new "OUTER APPLY is not supported by Oracle Database 11g and lower. Oracle 12c or higher is required to run this LINQ statement correctly. If you need to run this statement with Oracle Database 11g or lower, rewrite it so that it can be converted to SQL, supported by the version of Oracle you use." exception is added

Entity Developer

  • The information message about availability of NuGet Package Manager on the workstation is added in the Entity Developer version integrated into Visual Studio (Entity Framework models)
  • The override modifier for DbSet class properties generated by DbContext templates is added (Entity Framework models)
  • The behaviour is changed: now paths to assemblies with attributes (Model Settings -> Model -> Attributes) are saved and used as relative paths
  • The behaviour is changed: now a property in the generated code is initialized basing on the default value in CSDL only (instead of default values in any of SSDL and CSDL; Entity Framework models)

Entity Framework support

  • SharpMap 1.1 is supported
  • NTS Topology Suite 1.13.2 is supported
  • Entity Framework 6.1.0 RTM is supported
  • Entity Framework 6.1.0 Tools for Visual Studio 2012 & 2013 are supported
  • The UpdateDatabaseOperation operation in Code-First Migrations for Entity Framework 6.x is supported
  • The RenameIndexOperation operation in Code-First Migrations for Entity Framework 6.1 is supported
  • Multiple EntityContainers in the Code-First CreateDatabase()/CreateDatabaseScript()/DeleteDatabase() functionality are supported
  • The Database.Delete(DbConnection) functionality is supported: all objects in the current schema (specified in User Id or set with Initialization Command connection string parameter) are removed if DatabaseScript.Schema.DeleteDatabaseBehaviour = AllSchemaObjects
  • The Database.Exists(DbConnection) functionality is supported: the method returns true if DatabaseScript.Schema.DeleteDatabaseBehaviour = AllSchemaObjects and at least one table or sequence exists in the current schema (specified in User Id or set with Initialization Command connection string parameter)
  • Determining correct datatypes of data retrieved by EntitySQL queries with UNION ALL and similar constructions is improved
  • The compatibility with Hibernating Rhinos EntityFramework Profiler is improved
  • The releasing of memory, which was allocated for commands and readers of ObjectContext / DbContext, is improved
  • The database server version is added to the generated Code-First Migrations script
  • The functionality of setting the CodeFirstOptions.ColumnTypeCasingConventionCompatibility option via provider manifest token for a particular Entity Framework model is implemented for possibility of using both Database-First/Model-First model with XML mapping and Code-First model with fluent/attribute mapping in the same AppDomain
  • The config.DatabaseScript.Column.MaxStringSize configuration option (default value is OracleMaxStringSize.Standard) is added to provide the possibility of determining a default size of the VARCHAR2 and NVARCHAR2 columns for Oracle 12c if it was not set explicitly in the Code-First CreateDatabase()/Code-First Migrations functionality
  • The NumericIdentityBehavior.ImplicitSequence enumeration value of config.DatabaseScript.Column.NumericIdentityBehavior for Oracle 12c is now deprecated and not recommended to use; use the new NumericIdentityBehavior.GeneratedAlwaysAsIdentity, NumericIdentityBehavior.GeneratedByDefaultAsIdentity, NumericIdentityBehavior.GeneratedByDefaultOnNullAsIdentity values instead
  • The behaviour is changed: now Database.Delete(DbConnection), when config.DatabaseScript.Schema.DeleteDatabaseBehaviour = AllSchemaObjects, removes sequences in the current schema of Oracle 12c only if config.DatabaseScript.Column.NumericIdentityBehavior = ExplicitTriggerAndSequence
  • The behaviour is changed: now Database.Exists(DbConnection), when config.DatabaseScript.Schema.DeleteDatabaseBehaviour = AllSchemaObjects, checks an existence of sequences in the current schema of Oracle 12c only if config.DatabaseScript.Column.NumericIdentityBehavior = ExplicitTriggerAndSequence
  • The behaviour is changed: now by default the Code-First CreateDatabase()/CreateDatabaseScript()/Code-First Migrations functionality generates the VARCHAR2(4000) and NVARCHAR2(2000) columns for Oracle 12c if the size of the corresponding columns is not set explicitly
  • The behaviour is changed: now the TIMESTAMP WITH TIME ZONE column is mapped to DateTimeOffset instead of DateTime by EDM Wizard / Lightswitch / Entity Framework 6 Tools
  • The behaviour is changed: now SQL is generated without additional sorting in a subquery when working with Oracle 11g/10g/9i and during the work with paging operations with .OrderBy().Skip().Take()
  • The behaviour is changed: now a slash after the very last statement is generated in the Code-First CreateDatabaseScript() functionality
  • The behaviour is changed: now the Code-First CreateDatabase()/CreateDatabaseScript()/Code-First Migrations functionality for Oracle 12c generates 'GENERATED BY DEFAULT ON NULL AS IDENTITY' instead of 'GENERATED ALWAYS AS IDENTITY' for autoincrement identity columns when config.DatabaseScript.Column.NumericIdentityBehavior = Default

dotConnect for Oracle 8.2 new features:

  • The functionality of starting and stopping an Oracle database instance is implemented in the OracleDatabase class (only in the OCI mode)
  • Working with XMLTYPE in the OCI mode when Unicode = True is fully supported
  • Specifying proxy connection via the connection string with the new connection string parameters "Proxy User Id" and "Proxy Password" is supported (only in the OCI mode)
  • DBMS_APPLICATION_INFO package features are supported via the new properties of the OracleConnection class: ModuleName, ActionName, ClientInfo, and the SetDbmsApplicationInfo method
  • OCI Statement Caching support is improved: caching is now also supported in case when Unicode = True or "Oci Connection Pool" = True
  • OCI Statement Cache cleaning when returning a connection to a pool is implemented via the new "Statement Cache Purge" connection string parameter (Default value is False)
  • OCI Statement Cache cleaning on user request is implemented via the new PurgeStatementCache() method of the OracleConnection class
  • The possibility to speed up the stored procedure execution with the ExecuteReader()/ExecuteScalar() methods of OracleCommand, when using CommandType.StoredProcedure, is implemented via the new connection string parameter "Describe Stored Procedure" (Default value is True) and the new ImplicitRefCursors and IsTableValuedFunction properties of the OracleCommand class
  • Execution of non-pipelined table function with CommandType.StoredProcedure is supported when the IsTableValuedFunction property of OracleCommand equals to True
  • The TableValuedResultType property of OracleCommand is now deprecated and not recommended to use. Use the IsTableValuedFunction property instead
  • Additional overloads of the OracleCommand constructor and CreateCommand method of OracleConnection class are added to decrease the code for creating an OracleCommand instance
  • Additional overloads of the GetValues(), GetOracleValues(), and GetProviderSpecificValues() methods that don't require the user to create an array of the required size beforehand are added to the OracleDataReader class to ease data retrieving, for example only a single record is read
  • The return type of the Clone() method of OracleConnection, OracleCommand, and OracleParameter classes is now the same as the type of the object, for which the method is implemented, instead of System.Object
  • DbType.Xml now can be assigned to the DbType property of OracleParameter (it means the same as oracleParameter.OracleDbType = OracleDbType.Xml) in order to ease working with XMLTYPE when using base ADO.NET without using provider-specific features
  • Retrieving version of the Oracle database, a connection is made to, is improved: the new ShortServerVersion property of the Version type is implemented in the OracleConnection class
  • The performance of the Update method of OracleDataAdapter and OracleDataTable classes is improved
  • The performance when working with parameters is improved
  • The performance of reading and writing OracleObject attributes in the OCI mode is significantly improved
  • The behaviour is changed: IndexOutOfRangeException is generated now instead of InvalidOperationException when OracleDataReader.GetOrdinal(String name) finds nothing in the result set

LinqConnect (formerly known as LINQ to Oracle)

  • The behaviour is changed: now the script is generated with "ON DELETE NO ACTION" when using the CreateDatabase() method and the "Delete Rule" for the association is set to "NO ACTION"
  • The behaviour is changed: now the CreateDatabase() method uses the same algorithm for naming foreign keys as in Entity Developer

Entity Developer

  • The "WCF DataMember Attribute on Navigation Properties" property is added to the Data Transfer Object template for pointing the end (-s) where the attribute should be generated (Entity Framework models)
  • More information messages, when validating EF6 models basing on the EntityFramework.dll functionality, are added (Entity Framework models)
  • The behaviour is changed: the validation of EF6 models depends on the EntityFramework.dll functionality only (.NET Framework 4.5 is not required any more) (Entity Framework models)

Entity Framework support

  • The Acos, Asin, Ascii, Atan, Atan2, Char, Cos, CurrentUser, DataLength, Exp, Rand, Sign, Sin, SoundCode, SquareRoot, StringConvert, Tan methods of the SqlFunctions class in LINQ to Entities are supported to be converted to Oracle-specific SQL statements in runtime
  • The generation of SQL literals for DateTimeOffset and TimeSpan values is improved: shortened form is used now if possible

dotConnect for Oracle 8.1 new features:

  • Visual Studio 2013 is supported
  • Oracle Object Wizard is supported in Direct mode
  • Reduced memory usage for some operations with CLOB/NCLOB/BLOB values
  • Reduced memory usage for CommandBehavior.SequentialAccess
  • Performance of the operation of assigning TIMESTAMP and INTERVAL values to In parameters is improved, and memory leak in this operation is fixed
  • The behaviour is changed: installation with the /VERYSILENT install parameter will uninstall the other version of the provider without any dialog box if it is installed
  • The behaviour is changed: there is no more max count for parameters for stored procedure in the Direct mode

LinqConnect (formerly known as LINQ to Oracle)

  • The possibility to inherit from the data provider classes is added

Entity Developer

  • Entity Framework 6 is supported
  • The new "Provider Manifest Token" model property is implemented to identify the target server (Entity Framework models)
  • The predefined templates (POCO Entity and LinqConnect) are improved: new template setting, "Generate Dummy Comments", is added (LinqConnect models)
  • The behaviour is changed: the values of "Target Server" and "Server Version" can be reset via the Model Settings > Synchronization > Mapping dialog despite the fact whether connection is specified in Database Explorer or not

Entity Framework support

  • The 6.0.0 and 6.0.1 versions of Entity Framework are supported
  • The compatibility of Entity Framework provider for EF v1, v4, v5 with medium trust level environment is improved
  • The behaviour is changed: Entity Data Model Wizard shows a more detailed error message in case of connecting to unsupported database or using incorrect provider manifest tokens
  • The behaviour is changed: Code-First Migrations generates DEFAULT values for new NOT NULL columns of Boolean, Guid, DateTime, DateTimeOffset, TimeSpan types when adding them in the existing table

dotConnect for Oracle 8.0 new features:

  • Oracle 12c is supported
  • Auto increment identity columns are supported (only in the OCI-mode, and only for Oracle 12c)
  • Returning of affected row count for each array element when using array binding is supported (only in the OCI-mode, and only for Oracle 12c)
  • Implicit result sets are supported (only in the OCI-mode, and only for Oracle 12c)
  • Transaction Guard is supported (only in the OCI-mode, and only for Oracle 12c)
  • New connection modes are supported: SYSBACKUP, SYSDG and SYSKM
  • Microsoft Sync Framework support is implemented
  • The OracleDate.IsValidDateTime property is implemented for checking if a valid DateTime will be returned for the Value property
  • The overload for constructor of OracleNumber class with System.Single type parameter is added

LinqConnect (formerly known as LINQ to Oracle)

  • The Collate method of the SqlMethods class is implemented
  • VARCHAR2/NVARCHAR2/RAW types with length increased to 32KB are supported for Oracle 12c
  • Oracle 12c specific SQL generation for paging is supported
  • The behaviour is changed: CreateDatabase functionality generates columns with the identity clause 'GENERATED AS IDENTITY' for primary key properties with 'IsDbGenerated=True' (only for Oracle 12c)

Entity Developer

  • The predefined templates are improved: new template setting, "Use Compiled Query Cache", is added (LinqConnect models)
  • The behaviour is changed: "Generate Database Script"/"Update Database From Model" wizards generate columns with the identity clause 'GENERATED AS IDENTITY' for properties with 'Store Generated Pattern=Identity' (only for Oracle 12c, Entity Framework models)
  • The behaviour is changed: "Generate Database Script"/"Update Database From Model" wizards generate columns with the identity clause 'GENERATED AS IDENTITY' for properties with 'Auto Generated Value=True' (only for Oracle 12c, LinqConnect models)

Entity Framework support

  • Generation of OUTER APPLY statement in Entity Framework is supported for Oracle 12c
  • Oracle 12c specific SQL generation for paging is supported
  • VARCHAR2/NVARCHAR2/RAW types with length increased to 32KB are supported for Oracle 12c
  • The behaviour is changed: Code-First/Code-First Migrations generate columns with the identity clause 'GENERATED AS IDENTITY' for entity key properties with 'Store Generated Pattern=Identity' (only for Oracle 12c)
  • The behaviour is changed: Code-First Migrations generates DEFAULT 0 for new NOT NULL columns of numeric types when adding them in the existing table
  • The behaviour is changed: Code-First Migrations generates DEFAULT EMPTY_CLOB() for new NOT NULL columns of CLOB/NCLOB types when adding them in the existing table
  • The behaviour is changed: Code-First Migrations generates DEFAULT '' for new NOT NULL columns of CHAR/NCHAR/VARCHAR2/NVARCHAR2 types when adding them in the existing table

dotConnect for Oracle 7.9 new features:

  • Visual Studio 2013 Release Candidate is supported
  • SSIS DataFlow Source and Destination components for Oracle are implemented
  • OracleLoader is supported in the direct mode
  • The behaviour is changed: OracleLoader now uses direct path load if columns of supported types are used and if the connection uses OCI mode; otherwise, array binding is used

LinqConnect (formerly known as LINQ to Oracle)

  • The possibility to use the extension method AsQueryable() in LINQ queries is added
  • The support for correct retrieving of the TimeSpan and DateTimeOffset values while materializing is added
  • The implementation for the DatabaseExists method, which checks the existance of the tables in the database, is added
  • The possibility of creating Oracle schemas (users) for mapped model classes via the CreateDatabase(false,true)/CreateDatabase(true, true) method of the DataContext class is implemented
  • The possibility of deleting Oracle schemas (users) for mapped model classes via the DeleteDatabase(false,true)/DeleteDatabase(true, true) method of the DataContext class is implemented
Entity Developer
  • The "Close the window when the generation completes successfully" option in the Generation Process window is implemented in the standalone Entity Developer
  • The "Rewrite connection string during regeneration" option (default value is True) of model settings is added to provide the possibility to turn off modifying connection string in *.config after model is saved first time (Entity Framework models)
  • The design time support for model-defined functions is added (Entity Framework models)
  • The behaviour is changed: now connection string is configured with the name of the assembly, where the model is located, in case when the context class is located in another assembly (Entity Framework models)
Entity Framework
  • Entity Framework 6 Release Candidate 1 is supported
  • The config.DmlOptions.UseReturningClause configuration option (default value is True) is added to provide the possibility to turn off generation of RETURNING clause when obtaining database-generated values with INSERT/UPDATE commands
  • SharpMap 1.0 RTM is supported
  • NetTopologySuite 1.13.1 is supported
  • Devart.Data.Oracle.Entity.SharpMap.dll assembly is renamed to Devart.Data.Oracle.Entity.Spatials.dll

dotConnect for Oracle 7.8 new features:

  • SQL Server 2012 Reporting Services is supported
Entity Developer
  • The "Model Name As Files Prefix" property is implemented for the templates which generate classes for model entities
  • The possibility of adding custom attributes to enum members is implemented
  • The behaviour is changed: a default value for the "Detect Table Per Type inheritances" option in Model settings is set to False
  • The behaviour is changed: the possibility to exclude the generation of keys (primary, foreign) in "Update Database From Model" and "Generate Database Script From Model " wizards is added
  • The behaviour is changed: the possibility to add one-to-one associations with nullable foreign key properties is added (LinqConnect models)
  • The behaviour is changed: now by default MVC Controller template generates files in the model folder, MVC View Advanced template creates files in the Views model subfolder
Entity Framework
  • NetTopologySuite GIS library support in Entity Framework 5 and 6 is added
  • The OracleSpatialFunctions class for working with Oracle Spatials functions in LINQ to Entities is added
  • The config.SpatialOptions.AlwaysUseGeometryDefaultSrid configuration option (default value is False) is added to provide the possibility to use the config.SpatialOptions.GeometryDefaultSrid value instead of reading the actual SRID for the DbGeometry spatial from the database
  • The config.SpatialOptions.AlwaysUseGeographyDefaultSrid configuration option (default value is False) is added to provide the possibility to use the config.SpatialOptions.GeographyDefaultSrid value instead of reading the actual SRID for the DbGeometry spatial from the database
  • The config.Workarounds.UseInvariantProviderManifestToken configuration option (default value is False) is added to provide the possibility of returning the invariant string literal as the provider manifest token
  • The config.SqlFormatting.Identation option is renamed to config.SqlFormatting.Indenting

dotConnect for Oracle 7.7 new features:

  • Workflow Foundation 4.5 is supported
  • The behaviour is changed: provider's build action is installed on the target workstation, on which .NET Framework is available, without Visual Studio integration

LinqConnect (formerly known as LINQ to Oracle)

  • LINQPad integration is supported
  • The possibility to disable query cache via the DataContext's 'EntityCachingMode' property is added
  • Creation of auto-incrementing sequences and triggers for Oracle models is supported
  • The performance when working with the TPT-inheritance and retrieving descendants via OfType<> is improved
Entity Developer
  • A new MVC Controller template, generating a ASP.NET MVC controller with data access code, is added
  • A new MVC View Advanced template, generating an ASP.NET MVC view based in Twitter Bootstrap, is added
  • A new Data Transfer Object template for DTO classes generation is implemented
  • A new Data Annotation Metadata template, generating Data Annotation metadata classes and decorating classes and properties with data annotation attributes for validation, presentation and defining metadata, is added
  • A new WCF RIA Domain Service template, generating a WCF RIA Services domain service class for a Devart Entity Framework model is added
  • A new WCF RIA Domain Service template, generating a WCF RIA Services domain service class for a Devart LinqConnect model is added
  • Add Template dialog box is improved
  • The Namespace property of class, complex type, enum is implemented
  • The Entity Container Namespace properties of the model is implemented (Entity Framework models)
  • The support for enums declared in external assemblies is implemented
  • The capability for setting special rules for generating default names of database objects when using the Model First approach is implemented (a new Advanced page is added to the Synchronization->Database Naming section of the Model Settings dialog box)
  • The capability to customize properties that are automatically added when creating a new entity, and options that are automatically set when creating a new property is added (a new Initialization page is added to the Model->General section of the Model Settings dialog box)
  • The Refresh option in the Attributes tab of the Model Settings window is implemented; it updates the list of available attributes types in the referenced assemblies
  • The capability to modify custom attributes for several selected entities or properties at the same time is implemented
  • Automatic adding of references to Entity Framework specific assemblies when adding a new Devart Entity model to a project is implemented
  • The capability to cancel metadata reading in wizards and Database Explorer is added
  • The "Recreate Database Tables" check box, which allows to drop and recreate database tables, is added to the "Update To Database" wizard
  • New setting "Detect Table Per Type inheritances", which enables automatic detection of TPT inheritances, is added for Create Model Wizard and model
  • The "Include Drop" check box for including DROP commands for database objects to the generated script is added to Generate Database Script Wizard
  • A new shortcut menu command "Include Related", which allows making a copy of the related objects in the specified diagram, is added
  • A new shortcut menu command "Add To Model with Related", which allows adding tables, related to the selected one, to the model, is added to the shortcut menu of tables in Database Explorer
  • A new shortcut menu command "Add On Diagram With Related", which allows creating an object and all the objects related to it on a diagram, is added to the shortcut menu of classes, complex types, and enums in Model Explorer
  • New "Simple" diagram skin is added for displaying a diagram in metro style
  • The "Default Width" diagram property for specifying the default width for newly created diagram shapes (entities, complex types and enums) is added
  • The Save and Refresh buttons for persisting and reloading changes to / from a database is added to the Retrieve Data grid
  • Devart.Data.Linq.Binary type is added to the "Type Mapping Rule Editor" (LinqConnect models)
  • The "WCF DataMember Attribute on Navigation Properties" property is added to the DbContext and POCO templates for pointing the end (-s) where the attribute should be generated
  • The "Rewrite connection string during regeneration" check box of Model Settings is implemented to determine whether to overwrite the connection string in the project config file with the one, currently set in Entity Developer for the model, each time when regenerating code for the model (LinqConnect models)
  • The "Regenerate Storage and Mapping" option for regenerating model parts, specific to the database server, is added to the diagram shortcut menu
  • DbContext template is improved: a "WCF Data Contract Attributes" setting for generation of DataContract, KnownType, and DataMember attributes for classes and properties is added (Entity Framework models)
  • DbContext template is improved: "Implement INotifyPropertyChanging" and "Implement INotifyPropertyChanged" template settings are added (Entity Framework models)
  • DbContext template is improved: a new "Mapping Generation Strategy" property that determines the method of mapping generation is implemented (Entity Framework models)
  • POCO template is improved: a new "WCF Data Contract Attributes" setting for generating DataContract, KnownType, and DataMember attributes for classes and properties is added (Entity Framework models)
  • POCO template is improved: "Proxy Creation Enabled" setting is implemented (Entity Framework models)
  • POCO template is improved: new template settings, "Implement INotifyPropertyChanging" and "Implement INotifyPropertyChanged", are added (Entity Framework models)
  • POCO Entity template is improved: new template setting, "Property Change Notifiers", is added (LinqConnect models)
  • Create Model Wizard is improved: it is now able to download and install the required 'EnityFramework' Nuget package for Entity Framework 6 models, and for models for Entity Framework 4 and 5 in case they use the DbContext template
  • The Storage Column Editor dialog box is improved: the possibility to specify different settings that were previously available only in the Properties docking window are implemented (Entity Framework models)
  • Class Editor is improved: the capability to edit extended property settings, such as validation, presentation, and facets, is added
  • Type Editor is improved: the capability to edit extended property settings, such as validation, presentation, and facets, is added
  • Storage Entity Editor is improved: the capability to edit extended columns settings, such as facets, is added (Entity Framework models)
  • The behaviour is changed: "Save connection string in App.Config as" check box in Model Settings dialog box is renamed to "Use connection string from App.Config as" (LinqConnect models)
  • The behaviour is changed: now, when creating a new TPH discriminator column in Inheritance Editor, it has the string type by default
  • The behaviour is changed: the error is generated if the Abstract inheritance modifier is set for the class which is involved in the Table Per Type inheritance
  • The behaviour is changed: empty value is used in property editors instead of -1 for marking facets of class property without assigned value
  • The behaviour is changed: a string default value for the property can be set without quotes in the Properties window
  • The behaviour is changed: the validation error is not generated when an abstract class is used in Table Per Type inheritance (Entity Framework models)
  • The behaviour is changed: auto-implemented properties are generated when DbContext template is used with ImplementINotifyPropertyChanged=False and ImplementINotifyPropertyChanging=False (Entity Framework models)
  • The behaviour is changed: DatabaseGeneratedOption is always generated for EntityKey properties when using fluent mapping (Entity Framework models)
Entity Framework
  • Entity Framework 6 Beta 1 is supported
  • The complex type generation for a return result set of a stored procedure is supported in EDM Wizard / Designer
  • The config.DatabaseScript.ForeignKey.Enabled option (default value is True) is added to turn on/off generation of foreign key constraints
  • The error messages about long identifiers when using CreateDatabase/DropDatabase are improved
  • The behaviour is changed: CreateDatabase()/Code-First with DeleteDatabaseBehaviour.Schema does not try to create a schema (user) if it exists

dotConnect for Oracle 7.6 new features:

  • ExtendedMembership (SimpleMembership) provider support is added
  • The behaviour is changed: array with the length over 2000 bytes now is not automatically trimmed when sending a parameter value of the OracleDbType.Raw type
Entity Developer
  • The possibility of setting enum values via predefined dropdown list in the Retrieve Data window is implemented
Entity Framework
  • Entity Framework 6 Alpha 3 is supported

dotConnect for Oracle 7.5 new features:

  • The behaviour is changed: ORA-01403 is treated as an information message only for select statements
Entity Developer
  • The behaviour is changed: the serializing property and corresponding methods are not generated when using 'Fluent Mapping'/'POCO Entity' templates and Unidirectional mode (LinqConnect models)
  • The behaviour is changed: warnings about tables/views without primary keys are written to Error List window when generating a model (Entity Framework models)
  • The behaviour is changed: the EntityKey attribute is not assigned to each property of the class if there is no primary key in the corresponding table/view (Entity Framework models)
  • The behaviour is changed: empty value is used in property editors instead of -1 for marking facets of Storage Column without assigned value (Entity Framework models)
Entity Framework
  • Entity Framework 6 Alpha 2 is supported
  • Devart.Data.Oracle.Entity.dll assembly compiled with EntityFramework.dll 6.0 and NET Framework 4.0 is added
  • Devart.Data.Oracle.Entity.SharpMap.dll assembly compiled with EntityFramework.dll 6.0 and NET Framework 4.0 is added
  • Support for mapping CHAR(1) to System.Boolean is added
  • Support of custom filters when using the System.Data.Entity.Design functionality in the config.QueryOptions.AdvancedMetadataQuery mode is implemented
  • The behaviour is changed: the constraint name is ignored when a table primary key is deleted when running Code-First Migrations, that allows successful deletion of automatically named primary key

dotConnect for Oracle 7.4 new features:

Entity Developer
  • Support for spatial data types in Entity Framework 5 models is added
  • Model Refactoring feature is implemented; it speeds up creating complex types and Table Per Type and Table Per Concrete Type inheritances from several model entities
  • Create Storage and Mapping command, that allows automatically creating of the corresponding storage part object and defining mapping, is added to the shortcut menu of classes, properties, and associations (Entity Framework models)
  • Select Storage Object command, that allows quick navigation to the corresponding storage part object, is added to the shortcut menu of classes, properties, associations, and methods (Entity Framework models)
  • The possibility to delete the corresponding storage part objects automatically when deleting conceptual model objects is added (Entity Framework models)
  • The functionality of ignoring columns in the database in the "Update To/From Database" wizards if they were omitted once before is implemented
  • The Property Editor dialog is improved: fast access to the editor of the corresponding storage object and the possibility to specify different settings that were previously available only in the Properties docking window are implemented (Entity Framework models)
  • The Inheritance Editor dialog is improved: specifying Discriminator column for Table Per Hierarchy inheritance in the editor is implemented (Entity Framework models)
  • The Class Editor dialog is improved: fast access to the editor of the corresponding storage object is implemented (Entity Framework models)
  • The Method Editor dialog is improved: fast access to the editor of the corresponding storage object is implemented (Entity Framework models)
  • The naming algorithm for the newly-created columns, which correspond to complex type's properties, when using the Model First approach is improved (Entity Framework models)
  • Warnings about objects that are not mapped are added
  • A SHIFT+DELETE keyboard shortcut for deleting entity, complex type, or enum from diagram only is added
  • An INSERT keyboard shortcut for creating a new entity, adding property to the selected entity/complex type or new member to enum is added
  • The possibility to view notes, added through the "Documentation" property, for all the diagram objects via hints is implemented
  • Hints for diagram objects are improved
  • The behaviour is changed: Configure Behaviour dialog is renamed to Stored Procedure Mapping; options for hiding innapropriate and mapped stored procedures are added (Entity Framework models)
  • The behaviour is changed: Table Editor dialog is renamed to Storage Entity Editor (Entity Framework models)
  • The behaviour is changed: Stored Procedure Editor dialog is renamed to Storage Procedure Editor (Entity Framework models)
  • The behaviour is changed: Configure Behaviour dialog is renamed to Stored Procedure Mapping (LinqConnect models)

dotConnect for Oracle 7.3 new features:

LinqConnect (formerly known as LINQ to Oracle)

  • The fluent mapping is improved: support of the ID generators for primary keys is added
Entity Developer
  • The possibility to set different namespaces for the context and its entities when using the DbContext template is implemented (Entity Framework models)
Entity Framework
  • Support for spatial data types in Entity Framework 5 is added
  • Oracle Spatial MDSYS.SDO_GEOMETRY support in Entity Framework 5 is added
  • SharpMap GIS library support in Entity Framework 5 is added (new Devart.Data.Oracle.Entity.SharpMap.dll assembly is added)
  • Devart.Data.Oracle.Entity.Migrations.dll assembly built with the 5.0 version of EntityFramework.dll is added
  • Devart.Data.Oracle.Entity.dll assembly built with the 4.5 version of .NET Framework is added
  • The config.QueryOptions.AdvancedMetadataQuery option (default value is False) is added to turn on the advanced metadata query mode like the one which is used by Visual Studio Entity Data Model Wizard

dotConnect for Oracle 7.2 new features:

  • Visual Studio 2012 is supported
  • The possibility to send/retrieve XMLTYPE in Oracle Advanced Queue is implemented: the OracleQueueMessage.XmlPayload property is added
  • Array binding memory usage with VarChar/NVarChar parameters is reduced
  • The Lob Block Size connection string parameter is implemented to determine the size of a block (in megabytes) to read/write CLOB or NCLOB data in the OCI mode when working with Unicode server
  • The behaviour is changed: the quote symbols will be ignored in the password value in the Direct mode
Entity Developer
  • Support for ADO.NET Entity Framework 5 is added
  • Predefined template for generating Repositories and Unit of Work classes is added
  • Integration with Visual Studio refactoring for renaming model objects is implemented
  • The "Use Database Comments" option of Model Settings is implemented to determine whether comments for database objects, if supported by DBMS, will be used for model objects Documentation initialization and taken into account when executing model or database update operations
  • The "Implement IClonable" option for the generated classes based on the model entities is added to all templates
  • The 'Entity Base' class property, which allows specifying the ancestor class/interface for a particular entity type, is implemented (LinqConnect models)
  • The behaviour is changed: the "Save connection string in App.Config as" option is available for LinqConnect models in the standalone version Entity Developer (the entry in App.Config must be added manually afterwards)
  • The behaviour is changed: when preserving schema name is disabled, schema name is no more saved for Oracle package functions/procedures (LinqConnect models)
  • The behaviour is changed: only particular (not all) property characteristics are regenerated when using Update Model From Database wizard after the metadata of the corresponding column have been changed (LinqConnect models)
Entity Framework
  • ADO.NET Entity Framework 5 is supported
  • The config.CodeFirstOptions.UseNonLobStrings option (default value is False) is added in order to treat string properties without an explicitly specified server data type as non-LOB
  • The config.CodeFirstOptions.UseDateTimeAsDate option (default value is False) is added to treat DateTime properties without an explicitly specified server data type as DATE
  • The SQL generation for the .Substring(startIndex) method is optimized
  • The behaviour is changed: Devart.Data.Oracle.Entity.Migrations.dll is built with the 4.4 version of EntityFramework.dll now

dotConnect for Oracle 7.1 new features:

Entity Developer
  • The possibility to unload assemblies from the main application domain by using separate application domain is implemented
  • The possibility to disable such Database First Settings as type mapping rules is implemented
  • The design time copy/cut/paste functionality for enum members is added
  • The overloaded stored procedures and functions are supported
  • The behaviour is changed: the warning, related to the missing property setter, is disabled (LinqConnect models)
  • The behaviour is changed: for the association, in which the many-side entity hasn't the primary key, the code and the mapping are not generated (LinqConnect models)
  • The behaviour is changed: the properties, that correspond autoincrement fields, are generated with a ReadOnly keyword in VB.NET (LinqConnect models)
Entity Framework
  • The support of the Oracle Text full-text search functionality is implemented
  • The OracleTextFunctions class for working with Oracle Text functions in LINQ to Entities is added
  • The OracleCtxDdlPackage class for working with Oracle Text stored procedures of the CTX_DDL package is added
  • The OracleCreateIndexConfiguration class for customizing the CreateIndex operation in Code-First Migrations is improved
  • The OracleDropIndexConfiguration class is added for customizing the DropIndex operation (deleting Oracle Text indexes) in Code-First Migrations
  • The existing configuration classes for customizing the Code-First Migrations operations are renamed - the "Oracle" prefix is added (for example, the CreateTableConfiguration class was renamed to OracleCreateTableConfiguration); derived classes with the old names are added for backward compatibility
  • Creating indexes for FK columns in Code-First CreateDatabase functionality is implemented
  • The config.DatabaseScript.ForeignKey.IndexCreation configuration option is added (default value is True)
  • The config.DatabaseScript.ForeignKey.IndexTablespace configuration option is added to provide the possibility of setting the TABLESPACE, in which the index, created for the columns being parts of the foreign key, should be placed
  • The option of setting ConcurrencyCheck for CLOB/NCLOB columns (for better support of LightSwitch) is implemented
    • Overloads for the ToChar/ToNchar methods of the OracleFunctions class are added
  • The possibility of setting configuration options via the application config file is implemented
  • The Devart.Data.Oracle.Entity.xsd file is added to the installation in order to simplify setting and validating the application config file settings when using the XML Editor
  • Code-First Migrations now supports specifying the schema (database) the table belongs to
  • The config.Workarounds.IgnoreDboSchemaName configuration option is added. The option is automatically set to True, if Code-First (Migrations) EF v4.x/5.x is used
  • The ColumnTypeCasingConventionCompatibility configuration option is moved from Workarounds to CodeFirstOptions (now it is config.CodeFirstOptions.ColumnTypeCasingConventionCompatibility). For the backward compatibility a wrapper property remains in Workarounds
  • The config.CodeFirstOptions.UseNonUnicodeStrings configuration option (default value is False) is added in order to treat string properties without an explicitly specified server data type, as non-unicode
  • The config.CodeFirstOptions.TruncateLongDefaultNames configuration option is added (default value is False) to provide the possibility of truncating long default names of indexes, primary keys, foreign keys, triggers, and sequences generated by Code-First Migrations
  • The config.QueryOptions.UseCSharpNullComparisonBehavior configuration option for checking for NULL when comparing a nullable property (column) or an expression with a variable (parameter) in LINQ to Entities is implemented (by default, false)
  • The config.QueryOptions.CaseInsensitiveComparison option is implemented to manage the compare behaviour when using Linq to Entities comparison expression such as "a == b" (by default, false)
  • The overloaded stored procedures and functions are supported in Entity Framework runtime
  • CASE generation is improved
  • The behaviour is changed: Substring() in LINQ queries is now translated to DBMS_LOB.SUBSTR for LOBs
  • The behaviour is changed: the ColumnTypeCasingConventionCompatibility configuration option is automatically set to True for EF v4.3.x & 5.x. If you use DbContext with XML mapping (in EF v4.1 & v4.2), from now on you should explicitly set ColumnTypeCasingConventionCompatibility=False
  • The behaviour is changed: in case of using Code-First (Migrations) EF v4.x/5.x the schema name 'dbo' will be ignored by default

dotConnect for Oracle 7.0 new features:

  • Visual Studio 2012 Release Candidate is supported
  • The support for executing PL/SQL blocks using the OracleCommand.ExecuteArray method in the Direct mode is added
  • The support for the Batch Errors mode in the OracleCommand.ExecuteArray method in the Direct mode is added
  • The Initialization Command connection string parameter is implemented
  • The behaviour is changed: the 'sender' parameter in MonitorEventHandler is a connection and the MonitorEventArgs.ExtraInfo property is filled with the connection string
  • The behaviour is changed: now the general exception is not added to the OracleException.Errors collection when executing a DML array
  • The behaviour is changed: an existing internal connection is used now if connections with the same connection string are opened and closed several times in scope of a distributed transaction for the case when there are several connections with different connection strings in the transaction
  • The behaviour is changed: the access modifier of the connectionString field of web provider classes is changed from private to protected

LinqConnect (formerly known as LINQ to Oracle)

  • References to System.Data.Linq are removed; now LinqConnect uses only its own classes
  • Upgrade wizard for upgrading projects to the new version of LinqConnect automatically is added
  • The possibility to choose cache mode (classic mode for cases when DataContext is used as a unit of work, and self-cleaning mode for cases when DataContext is a long-lived object) is added
  • The possibility to map stored procedure out parameters of the CURSOR type to IEnumerable parameters of the corresponding methods is added
  • Tracking of complex object graphs with chains of parent-child objects is optimized
  • Number of database calls required for managing objects with a many-to-many association is reduced
  • Delete rule performance is improved
  • Compilation performance is improved
  • Materialization performance is improved
  • Compiled query cache is improved
Entity Developer
  • The precision facet for DateTime and DateTimeOffset properties is supported
  • The sticker notes for adding comments to diagrams are implemented
  • The possibility to add a stamp, specifying diagram author, company, version, copyrights, project name, and date, to a diagram is implemented
  • New Collapse All and Expand All menu commands for collapsing and expanding diagram shapes are added
  • The behaviour is changed: context menu commands for working with diagram are grouped to the Diagram submenu of the context menu
  • The "Pluralize collection navigation properties" option for the possibility to turn off the pluralization of the many-end names of associations is implemented
  • The "sealed override" inheritance modifier for methods based on stored procedures and functions is added (LinqConnect models)
  • The behaviour is changed: System.Int64 is mapped to Number(19) now when using Model First approach
  • The behaviour is changed: the possibility to change diagram shape color via the corresponding Shape -> Color context menu command is added
  • The behaviour is changed: when pasting a copied entity to a new diagram, a new entity is not created, the existing entity is added to this diagram
  • The behaviour is changed: when cutting an entity from the diagram, the entity is not cut from the model, only from the diagram
  • The behaviour is changed: "Update Model From Database" wizard places newly added properties to the base abstract class now instead of putting them into child classes where the mapping is (Entity Framework models)
  • The behaviour is changed: System.Double is mapped to Number now when using Model First approach (Entity Framework models)
Entity Framework
  • The config.CodeFirstOptions.RemoveSchemaFromDefaultConstraintName option for removing schema name from the default constraint name is implemented in Code-First Migrations (by default, true)
  • The config.CodeFirstOptions.AddTableNameInDefaultIndexName option for adding a table name to the default index name is implemented in Code-First Migrations (by default, true)
  • The config.CodeFirstOptions.DisableIndexQuoting option is implemented for a backward compatibility with migrations which use indexes, generated and applied in the 6.xx versions
  • The support of fractional seconds for TIMESTAMP, TIMESTAMP WITH TIME ZONE, and TIMESTAMP WITH LOCAL TIME ZONE in Entity Data Model Wizard/Generate Database Wizard and Code-First CreateDatabase functionality is added
  • The behaviour is changed: by default in Model-First and Code-First approaches the DateTime property is not TIMESTAMP anymore, but TIMESTAMP(7), and the DateTimeOffset property is TIMESTAMP(7) WITH TIME ZONE
  • The behaviour is changed: the comparison of a column and an empty string literal in LINQ to Entities (column == "") is translated into the check if the column is equal to NULL in SQL (column IS NULL) now

dotConnect for Oracle 6.80 new features:

  • Visual Studio 11 Beta is supported
  • The OracleNotificationRequest.QueryBasedNotificationMode property for selecting the best-effort or guaranteed query result notification mode is added
  • The OracleNotificationRequest.Operations property for the selection of operations, for which notifications should come, has been added
  • The DirectUtils.OldAuthMode property for using the old password encryption algorithm during authentication in the Direct mode is added
  • Usage of any symbols in the OracleParameter.ParameterName property for the stored procedure is supported
  • The behaviour is changed: the best-effort query result notification mode is used by default in OracleDependency
  • The handling of empty options in the connection string is improved
  • The performance of OracleDataAdapter when using MissingSchemaAction.AddWithKey is improved
Entity Developer
  • The copy/cut/paste functionality is added for objects of the conceptual part of a model
  • The possibility to drag&drop properties between classes in Model Explorer is implemented
  • The "HeaderTimestampVersionControlTag" generation template option is added for improving integration with version-control systems
  • The multiline popup editor for the Documentation.Summary property is implemented
  • The behaviour is changed: the Migrate option is added to the context menu of property in Model Explorer
  • The behaviour is changed: entities and enums on the designer surface are more resizable now
Entity Framework
  • Entity Framework 5.0 Beta 2 is supported
  • The OracleFunctions.SysExtractUtc(DateTimeOffset?) overload is added
  • SQL generation for .Any method in LINQ to Entities is improved
  • The possibility to specify the sequence and trigger names via CreateTableConfiguration and DropTableConfiguration classes in Code-First Migrations is implemented
  • The behaviour is changed: Devart.Data.Oracle.Entity.Migrations.dll is built with the 4.3.1 version of EntityFramework.dll now

dotConnect for Oracle 6.70 new features:

  • The support for OBJECT, TABLE, VARRAY, REF, XMLTYPE data types in Direct mode is added
  • The support for Oracle 9i, Oracle 10g, and Oracle 11g authentication in the Direct mode is added
  • The support for username/password containing national characters in the Direct mode is added
  • The OracleTrackingBehavior and OracleTrackingElement classes for enabling Oracle Workflow Tracking using a configuration file are added
  • The OracleTrackingBehavior and OracleTrackingElement classes for enabling Oracle Workflow Tracking using a configuration file are added
  • The promoted properties feature of Oracle Workflow Instance Store is implemented
  • The support for BINARY_DOUBLE and BINARY_FLOAT data types in Direct mode is added
  • The behaviour is changed: one internal connection is used now if connections with the same connection string are opened and closed several times in scope of a distributed transaction
  • The behaviour is changed: The Value property of PL/SQL array output parameters now returns an array with the length equal to the length of the value, returned by Oracle
Entity Developer
  • The validation of method parameters in LinqConnect models is added
  • The context menu options for unchecking changed/added/dropped tables are implemented for the root nodes in the "Update To/From Database" wizards
  • The possibility to rename the storage part of the model in Model Explorer is implemented (Entity Framework models)
  • The diagram design is changed: an arrow (instead of a triangle) is used on the tip of an association now
  • Materialized view support is added
  • The documentation generation for navigation properties is implemented
  • The "Recreate Model" option, allowing to rebuild the model from a scratch, is added to the "Update Model From Database" wizard
  • The "GeneratePartialClass" template property to generate a partial class, which will not be overwritten by the designer, for each class in the model is added
  • The stored procedures support in DbContext template in case of XML mapping is implemented (Entity Framework models)
  • The behaviour is changed: database column comments are transfered to the Summary attribute of the Documentation property now
Entity Framework
  • Entity Framework 4.3 (Code First Migrations) is supported
  • Oracle-specific Code First Migration customizations are implemented
  • The validation of identifier name length in Code-First Migrations is implemented
  • The conversion of .StartsWith, .Contains, .EndsWith to LIKE clause in the generated SQL for the case of expression-based condition is supported
  • The Code-First Migrations behaviour is changed: if the nullable value of the property in migration is not set explicitly, the corresponding column will be created nullable

dotConnect for Oracle 6.60 new features:

  • Workflow Tracking support is implemented
  • Enabling Persistence for WAS-Hosted Workflow Services that use the WorkflowServiceHost using a Configuration File is supported
Entity Developer
  • Capability for customizing the default Type Mapping Rules is implemented
  • Capability for setting diagram options either globally for all diagram documents or separately for a particular one is implemented: the Diagram Appearance and Printing options can now be set through the Options dialog box
  • Capability for setting such options as Environment, Diagram and Servers' to adjust the Entity Developer behavior, Model diagram behavior and Type Mapping Rules to your needs is implemented
  • Capability for setting and defining the class property validation rules based on different engines (Data Annotation, Enterprise Library, NHibernate Validator) is added
  • The 'Numeric Primary Key As Identity' Oracle option is added: if this option is checked, the "StoreGeneratedPattern" will be set to Identity by default for Number primary keys
  • The HasStream attribute of entity types, used retrieve binary data as a stream via Open Data Protocol, is supported (Entity Framework models)
  • The documentation generation for Enum members is implemented
  • The "Detect function-based column default value" option for automatic setting StoreGeneratedPattern to Identity for corresponding columns is implemented for Entity Framework models (by default, false)
  • The algorithm for forming the Navigation Properties names, when there are several FOREIGN KEY constraints between the same tables, is changed
  • The behaviour is changed: the Navigation Property will not be displayed on the diagram and in Model Explorer if "Generate" is set to false for the appropriate association end
  • The behaviour is changed: the Validate Max Length attribute is synchronized with the Max Length attribute of Property by default now
  • The behaviour is changed: the Validate Required attribute is synchronized with the Nullable attribute of Property by default now
  • The behaviour is changed: when selecting a property in the Model Explorer, the corresponding entity on the diagram does not expand if it is collapsed
Entity Framework
  • The PL/SQL BOOLEAN parameters of stored procedures are supported in Entity Data Model Wizard
  • The behavior of the Database.Delete code-first method is changed: the constraints are now disabled when database objects are deleted
  • The config.QueryOptions.NoEscapeLike and CaseInsensitiveLike options are implemented to manage LIKE behaviour when using Linq to Entities extention methods .Contains() .EndsWith() .StartsWith()
  • The possibility of using Oracle optimizer hints in LINQ to Entities queries is implemented
  • The behaviour is changed: the BINARY_FLOAT and BINARY_DOUBLE data types are mapped to Single and Double correspondingly in Entity Data Model Wizard
  • The behaviour is changed: if an output cursor parameter of a stored procedure is not specified in the "Result Set Parameter" property, it will now be processed automatically

dotConnect for Oracle 6.50 new features:

  • The 'OraMts' connection string parameter for distributed transactions support through OraMTS is added
  • Devart.Data.Oracle.DurableInstancing assembly and namespace were renamed to Devart.Data.Oracle.WorkflowFoundation
  • The possibility of choosing connections that are created with Oracle Object Wizard and Oracle Package Wizard is implemented for different project types
  • Behaviour is changed: pending operations on a connection are rolled back before returning the connection to pool

LinqConnect (formerly known as LINQ to Oracle)

  • Fluent Mapping support is added
Entity Developer
  • Fluent Mapping template for LinqConnect models is added
  • Support for enumerated types ("enums") in LinqConnect and Entity Framework June 2011 CTP models is implemented
  • Import for selected stored procedures into the context model for Entity Framework models is implemented
  • New skins to improve the apllication appearance are implemented
  • Selection driven highlighting is implemented
  • Capability for changing the shape color for entities, complex types and enums is implemented
  • Capability for selecting the diagram skin type is implemented
  • Disabling facets that are not applicable to the current field type is implemented (LinqConnect models)
  • The possibility of specifying the name of the connection string to be saved in the application configuration file is implemented
  • Default behaviour changed: now the Update To Database Wizard does not drop foreign keys of a table if the 'master' one is not represented in the LinqConnect model
  • The default attribute mapping source for LinqConnect models is made static
  • Behaviour is changed: table is not marked as "Changed" in Update Wizard if DefaultValue is set for its expression column
Entity Framework
  • The generation of DATE/TIMESTAMP parameters in LINQ queries is improved
  • The possibility to turn off generation of fake updates for parent entities is implemented
  • The REGEXP Oracle functions for working with regular expressions are supported
  • The code generation is improved to distinguish DATE from TIMESTAMP when using database independent fluent mapping
  • Changed behaviour: the CHAR and VARCHAR2 columns are created with the CHAR semantics for EF Code-First CreateDatabase()

dotConnect for Oracle 6.30 new features:

  • Oracle Workflow Instance Store is implemented
  • Support for the Oracle TimesTen database is implemented
  • DbTransactionBase class is added
  • TransactionStateChanging and TransactionStateChanged events are added to the DbConnectionBase class
  • The OracleConnectMode.SYSASM privilege is supported
  • Policy file for the Devart.Data.Oracle.Entity assembly is added
  • The License Information Wizard is improved: it now generates licenses for projects that have Entity Framework models or refer to Devart.Data.Oracle.Web, but have no direct references to Devart.Data.Oracle.dll
  • The support of events which occur when connections are taken and returned to pool for processing OracleMonitor.TraceEvent is added
  • The "Use schema name" check box is added to DataSet Wizard

LinqConnect (formerly known as LINQ to Oracle)

  • Eager loading is implemented in case the related entities collection is referenced in the select clause of the query
  • IFetch mode customization for eager loading of related entities is implemented
  • Performance of ordered queries with the Skip() and Take() methods is improved: the 'rownum' pseudo-column is now used instead of the 'row_number' function
  • The 'IsReference' mode of entity serialization is supported
Entity Developer
  • New Templates are added:
    • LinqConnect: POCO template with XML mapping generation
    • Entity Framework: POCO template, Self-Tracking template, DbContext template with fluent mapping generation
  • Templates usability is improved
  • Template Editor is significantly improved
  • Ability to declare additional properties for model objects is added
  • Ability to specify .NET attributes for model objects is added
  • The possibility to export the diagram into an image file was added
  • The possibility to restrict adding the connection string information to the application configuration file is added
  • The changes in the Entity name are now preserved by Update From Database Wizard (Entity Framework models)
  • The Entity Key handling for Views in Update From Database Wizard in Entity Framework models is improved
  • The pluralization algorithm is improved when Naming rules are defined
  • Runtime support for literals specified in the 'Default Value' entity field property for LinqConnect models is implemented
  • The "Preserve schema name in storage" option is added
  • Behaviour is changed: string entity fields are now mapped to varchar2(4000) by default
Entity Framework
  • Entity Framework 4.2 June 2011 CTP is supported
  • Batch Updates support is added
  • Adjustable SQL Formatting for DML commands is added
  • Ability to configure the NULL values inserting behaviour is added
  • The "raw guid as string" SSDL type is implemented for text presentation of binary Guids
  • The processing of LINQ expressions which work with literals is improved
  • IgnoreSchemaName workaround (mainly for Code First) is added
  • DisableQuoting workaround is added
  • OracleFunctions.Like support (including LINQ to Entities) is added
  • Configurable schema deletion and creation support is added
  • Number Mappings support in Entity Data Model Wizard and Update From Database Wizard is added
  • Multiple Include support is improved
  • The handling of the StoreGeneratedPattern in Update From Database Wizard is improved
  • Processing of Edm.StartsWith, Edm.Contains, and Edm.EndsWith is improved
  • Redundant casts for the DATE and TIMESTAMP columns are excluded from the generated query

dotConnect for Oracle 6.10 new features:

  • Supported Visual Studio 2010 Service Pack 1
  • Added DDEX support in Express Edition
  • Supported SQL Server Reporting Services x64
  • Supported Oracle Database Resident Connection Pooling (DRCP)
  • Added 'Connection Class' connection string parameter and OracleConnectionStringBuilder.ConnectionClass property for DRCP support
  • Improved public interface of OracleNumberMappingCollection class
  • Implemented support for the TIMESTAMP, INTERVAL, CLOB, and BLOB Oracle data types in the OracleLoader component
  • Implemented support for the OracleCommand.CommandTimeout and OracleConnection.ConnectionTimeout properties in the OCI connection mode
  • Added possibility to use overloaded stored procedures which do not return result set with ExecuteScalar()/ExecuteNonQuery() without setting a number of overload when parameters are added manually
  • Improved Oracle Objects Wizard: now it generates a constructor receiving non-typed OracleObject
  • Implemented generation of UDT method wrappers in the Oracle Object wizard
  • Added BeginTransaction value to the MonitorEventType enum
  • Implemented the DbMonitor.EventQueueLimit property which allows to set the maximal allowed number of messages waiting for being processed by the dbMonitor application
  • Changed behaviour in OracleClient compatibility mode: stored procedures are called with named parameters now
  • Changed behaviour: OracleDbType.VarChar parameter's max size is increased from 4000 to 32767 symbols

LinqConnect (formerly known as LINQ to Oracle)

  • Implemented the Attach(object entity, object original) method of the Devart.Data.Linq.ITable interface
  • Implemented implicit sorting by the entity key in queries with defined LoadWith rules
Entity Developer
  • Added possibility to split model into several diagrams for better handling of large models
  • Supported automatic generation of sequences and triggers for Autoincrement properties
  • Implemented possibility to disable automatic recognition of many-to-many associations
  • Added ConstraintSet property for Constraints in the Store part of the Entity Framework model
  • Added mapping for Function Import result types (Entity Framework v4 only)
  • Changed behaviour: when adding two related entities with the corresponding properties having different types, an invalid association is created now
  • Changed behaviour: when retrieving metadata for Oracle servers 9.2.0.5 and prior, the JOIN syntax of Oracle 8 is used now
Entity Framework
  • Entity Framework 4.1 RTW supported
  • Improved TPT inheritance support in case of updating the inherited entities
  • Added new column generation based on Unicode and non-Unicode columns union in queries
  • Improved performance for Visual Studio LightSwitch Beta 1 integration
  • Microsoft Generate Database from Model Wizard: Changed Date type to Timestamp type for DateTime properties
  • Improved Skip/Take performance
  • Improved performance by removing the unnecessary CAST statements

dotConnect for Oracle 6.00 new features

  • Supported Visual Studio 2010 Service Pack 1 Beta
  • Supported OracleConnection.ChangePassword() in Direct mode
  • Added "Transaction Scope Local" connection string option that enables the support for non-distributed transactions in the TransactionScope implementation
  • Improved interface in DbLoader class - added string and integer indexers
  • Added overloads for methods of DbDataReaderBase class with column name parameter
  • Implemented returning the error code of SocketExceptions thrown on network errors occurring when opening Direct connections
  • The NumberMapping and NumberMappingCollection classes renamed to OracleNumberMapping and OracleNumberMappingCollection
  • Implemented the OracleCommand.PassParametersByName property and the 'Pass Parameters By Name' connection string parameter
  • Implemented the OracleLob.NullNClob property returning an empty OracleLob of the NClob type
  • The OracleLob.Null property declared deprecated; it was left for the reason of compatibility with the System.Data.OracleClient data provider
  • Added the 'Number Mappings' connection string parameter that allows to change default mappings of Oracle Number and Float types to .NET number types
  • Added Statement Cache Size connection string parameter and OracleConnectionStringBuilder.StatementCacheSize property
  • Supported connection in Direct mode with service name instead of database instance name (SID and Service Name connection string parameters have different meanings now)
  • Added advanced connection string parameters to the connection dialogs of Object and Package wizards
  • Added ServiceName property to OracleConnectionStringBuilder class
  • Added the 'Validate Connection' connection string parameter to validate connection on its retrieving from pool
  • Added the TryParse method to the classes and structures representing native Oracle data types
  • Implemented possibility of changing the OracleLob.Cached property to disable buffering entire LOB into the memory
  • Changed behaviour: in the OracleClient compatibility mode, it is no longer allowed to create update and delete commands via OracleCommandBuilder for a result set with no primary key
  • Changed behaviour: the colon is no longer removed from OracleParameter.ParameterName in the OracleClient compatibility mode
  • Changed behaviour: setting the DbDataTable.Connection property sets the InsertCommand.Connection, UpdateCommand.Connection, and DeleteCommand.Connection properties
  • Changed default value of OracleCommand.Cached to true
  • Changed behaviour: when clearing the pool, the number of connections specified in 'Min Pool Size' is never removed

LinqConnect (formerly known as LINQ to Oracle)

  • Ability to execute DML statements in batches on SubmitChanges added
  • Table Per Type inheritance supported
  • Supported ASP.NET Dynamic Data with ASP.NET Dynamic Data project templates
  • PLINQ support added (connection manager redesigned for thread safety)
  • Supported Visual Studio Debugger Visualizer with SQL syntax highlighting for the DataQuery objects
  • Implemented support for custom type arguments in LinqConnect compiled queries
  • Changed behaviour: retrieving master entity from details one now generates left outer join instead of inner join

Entity Developer

  • Update To Database with Storage Synchronization functionality added
  • Added possibility for changing the UpdateCheck property for several fields at once
  • Added Update Model From Database functionality
  • Added multiselect support for properties
  • Improved large models handling

Entity Framework

  • Entity Data Model Wizard and Update Model from Database Wizard in Visual Studio 2010 Service Pack 1 Beta supported
  • Improved SQL generation for IN (Entity SQL) and Contains (LINQ to Entities) clauses
  • Improved performance for DateTime literals

dotConnect for Oracle 5.70 new features

  • Supported password salt in ASP.NET membership provider
  • Implemented capability of extending base functionality of ASP.NET providers
  • Added ClientId connection parameter
  • Improved Upgrade wizard
  • Added support for Enterprise Library 5
  • Implemented integration with Visual Web Developer 2008 and 2010 Express editions
  • Added support for user-defined types with sys.xmltype fields
  • Added Trim Fixed Char connection string parameter
  • Added additional overloads of OracleParameterCollection.Add() method
  • Implemented additional constructors for OracleParameter class
  • Implemented explicit disposing of OracleCommands used in the Enqueue/Dequeue methods of the OracleQueue components
  • Added possibility for handling the ORA-01403 informational message
  • Implemented host option for current process in dbMonitor
  • Added possibility for tracing the distributed transactions in DBMonitor
  • Changed behaviour: OracleParameter.OracleDbType will be set by default to OracleDbType.Clob for the values which are longer than 4000 symbols
  • Changed the primary key of the aspnet_sessions table for ASP.NET Web providers (the ApplicationName column added)
  • Added functionality for setting size of packets sent on command execution
  • Changed generation of overloaded procedures names in Oracle Package Wizard
  • Changed default behaviour of OracleTransaction without explicit Commit/Rollback call (RollBack now)

LinqConnect (formerly known as LINQ to Oracle)

  • LINQ to Oracle support is renamed to LinqConnect
  • Added support for Complex type
  • Added support for different configurable algorithms for primary key generation
  • Automatic configurable compiled query caching supported
  • Performance improved
  • DateTimeFormat is set in accordance with session parameters
  • Changed DataContext.Log output format for Microsoft compatibility reasons
  • Improved transaction behaviour in case when exception is thrown
  • DataContext class is now CLS-Compilant
  • Changed behaviour: Substring() in LINQ queries is now translated to DBMS_LOB.SUBSTR for LOBs
  • Added the client NLS settings support in the TO_NUMBER function
  • Added implementation of the ITable interface for the Table class

Entity Developer

  • Added possibility of renaming associations in the model
  • Improved code generation for procedures returning several cursors
  • Added default bindings to entity fields in Insert(Update/Delete) MethodMappings

Entity Framework

  • Model First support improved
    • Added more settings in Devart SSDLToOracle.tt file
    • DROP statements generation added
    • Schema name is not generated before each object
    • Generated scripts are now SQLPlus-compatible
  • Added implementation for the DatabaseExists method
  • Improved select performance in case of specific double values

dotConnect for Oracle 5.60 new features:

  • Supported Visual Studio 2010
  • Install Wizard improved (ability to automatically uninstall previous version added)
  • ADO.NET Data Services v1.5 CTP2 supported
  • Added possibility to avoid connecting to dbMonitor.exe when using DbMonitor ancestors
  • Transaction rollback timeout changed from ConnectionTimeout to DefaultCommandTimeout
LinqConnect (formerly known as LINQ to Oracle)
  • Added support for specific dynamic expressions
Entity Developer
  • Support for ADO.NET Entity Framework 4 added
  • Support for multi-result set methods added
  • Improved dialogs for editing model objects
  • Full integration with Visual Studio implemented
  • Added full support for ModificationFunctionMapping
  • Strongly typed reference cursors supported
  • Improved Find in Model functionality
  • Strongly typed reference cursors supported
  • Improved One-To-One associations handling
Entity Framework
  • Supported ADO.NET Entity Framework 4
    • Support for new Canonical aggregate and scalar functions added
    • Ability to use standard DBMS functions in LINQ queries added)
    • Support for Model First (templates for DB generation) added
    • Full support for Entity Data Model Wizard/Update Wizard added
  • Added support for methods creating and deleting the database (EF v1 and EF v4)

dotConnect for Oracle 5.35 new features:

  • Integration with improved dbMonitor added
  • Implemented DefaultCommandTimeout parameter in connection string (by default, set to 0)
  • Added orderid column for Site Map provider for custom map node ordering
  • Added some DataSet Wizard design-time improvements
LinqConnect (formerly known as LINQ to Oracle)
  • Devart DbLinqDataSource component added
  • Linq performance improved
  • Supported navigation using properties (not only keys)
Entity Developer
  • New T4 like template engine with powerful editor added
  • Updated code generation
    • Ability to generate separate files for classes added
    • Entity Framework Pregenerated Views support added
    • Improved null handling code generation
  • Ability to execute LINQ and Entity SQL queries with data and native sql preview added
  • Ability to preview and edit data displayed in Database Explorer added
  • Table splitting added (emulation of deferred loading for "large" datatypes in EF)
  • OnDelete support for associations added
Entity Framework
  • Added support for handling nulls as empty strings for character columns
  • DateTimeOffset data type supported

dotConnect for Oracle 5.25 new features:

  • Visual Studio 2010 Beta supported
  • ASP.NET Web Providers: Added requiresUniqueEmail functionality
  • Performance improvements in Direct mode when executing DML commands
LinqConnect (formerly known as LINQ to Oracle)
  • Added support of the String.IsNullOrEmpty() method
Entity Developer
  • Advanced mapping with Entity Framework QueryView supported
  • Oracle packages supported
  • Displaying of Navigation properties on diagram and project explorer implemented
  • Ability to change properties order added
  • Ability to edit Referential constraints added
  • Ability to set OnDelete action added
  • Ability to set Rows Affected parameter added
  • Added dialogs for suitable storage model editing
  • Added advanced search on the model
  • Added support for storing connections in the configuration files
  • Added Entity Set Pluralization Naming Rule

dotConnect for Oracle 5.20 new features:

LINQ to Oracle
  • Supported extended errors processing
  • Supported DataLoadOptions class and Include method for tuning data loading
  • Supported DeferredLoadingEnable functionality
  • Supported function import
  • Supported stored procedures as insert/update/delete behavior
  • Supported user-defined functions in selection part of a query
  • Supported CreateDatabase() and DeleteDatabase() methods
  • Supported SqlMethods class
  • Supported returning new Dictionary from query
  • Removed redundant TRIM() function calls
Entity Developer 2.00
  • Supported Entity Framework
  • Supported stored procedures and functions for LINQ to SQL
  • Added naming rules for database objects
  • Added Visual Studio integration
  • Validation schema improved
  • Entity Framework Complex Type supported
  • Entity Framework Storage Model editing supported
  • Many-to-Many associations retrieving added
  • Usability improvements
  • Stability and performance improvements

dotConnect for Oracle 5.00 new features:

  • OraDirect .NET renamed to dotConnect for Oracle
  • Supported LINQ to Oracle
  • Added Schema Modeler for LINQ to Oracle
  • Added free Express Edition with basic connectivity features
  • Added Developer Edition, which is equivalent to the Professional Edition plus OraDeveloper Tools
  • TransactionScope supported
  • Support for .NET Framework 1.x is discontinued
  • Renamed assemblies, namespaces, and classes (for information on upgrading your projects please refer to FAQ, section Subscriptions and Upgrades)

dotConnect for Oracle 4.75 new features:

  • Supported .NET Framework 3.5 Service Pack 1
  • Supported Visual Studio 2008 Service Pack 1
Entity Framework support
  • Supported inserting, updating, and deleting entities with stored procedures
  • Supported Create Function Import dialog
  • Supported REF CURSORs
  • Supported user-defined SQL queries as functions in SSDL
  • Oracle type INTERVAL DAY TO SECOND is now mapped to System.TimeSpan

dotConnect for Oracle 4.70 new features:

  • Supported .NET Framework 3.5 Service Pack 1 Beta
  • Supported Visual Studio 2008 Service Pack 1 Beta
  • Improved support for ADO.NET Entity Framework

dotConnect for Oracle 4.60 new features:

  • Supported Visual Studio designers for Entity Framework
  • Improved Entity Framework run time support

dotConnect for Oracle 4.50 new features:

  • Oracle ANYDATA type supported
  • Added DB server-based data paging for web applications
  • OracleDataSource design time improvements
  • ASP.NET demo pack added
  • OracleSelectStatement.TryParse method added
  • OracleXml class changed
  • DataLink.DataSource property can refer to another DataLink component

dotConnect for Oracle 4.35 new features:

  • Visual Studio 2008 supported
  • Entity Framework Beta 3 supported
  • Added Licensing Information dialog

dotConnect for Oracle 4.30 new features:

  • Oracle version 11g supported

dotConnect for Oracle 4.25 new features:

  • .NET Entity Framework Beta 2 supported
  • Visual Studio 2008 Beta 2 supported

dotConnect for Oracle 4.20 new features:

  • Supported Visual Studio codename Orcas Beta 1
  • Supported .NET Entity Framework
  • Supported Proxy Authentication
  • Supported OCI Pooling
  • Enhanced command builder with generation of row refresh statements
  • Added detailed warning information to OracleInfoMessageEventArgs class
  • Added DbCommand.GetRecordCount() method to determine rows count of a request
  • Added INullable interface for provider specific types
  • Improved LOBs performance in Direct mode
  • Added capability to store connection strings in application settings
  • Improved integration with OraDeveloper Tools
  • Extended drag'n'drop capabilities in DataSet Manager
  • Add-in menu moved to Visual Studio package
  • Demo projects reorganized
  • Added CRM (Customer Relationship Management) demo project
  • Added Ping demo project for Mobile Edition

dotConnect for Oracle 4.00 new features:

Application development enhancement
  • Added DataSet Manager to control dataset instances in the project
  • Added DataSet Editor for convenient datasets manipulation
  • New OracleDataSet class to use with OracleDataTable
  • New component DataLink added for flexible data binding
  • New capabilities added to OracleDataTable class
  • Added capability for cross-form components cooperation
  • Design time visualization extended
  • Supported addin, DataSet Wizard, and OraDeveloper Tools integration with Borland Developer Studio
.NET 2 features
  • Added OracleDependency class to support Database Change Notification
  • Added OracleDataSourceEnumerator class to support Server Enumeration feature
  • Added support for Batch Update in OracleDataAdapter
  • Added support for returning provider-specific types in OracleDataReader and OracleDataAdapter
Advanced Oracle features
  • LOBs and Oracle Objects now entirely support the disconnected model
  • Supported Oracle Advanced Queue technology
  • New OracleAlerter component added
  • New OraclePipe component added
  • New OracleTrace component added
  • Oracle Client Software x64 supported
  • Added support for custom UDT classes
  • Added support for IN and IN/OUT REF CURSORs
  • OracleDataAdapter now supports sequential fetch
  • Added new class OracleGlobalization for managing culture settings
Other features
  • SQL Server 2005 Business Intelligence Solutions supported
  • Added OracleSelectStatement class for building SELECT statements
  • Added list of servers in connection form and connection properties
  • Added OracleLoader.LoadTable method
  • Added DbLoader class that serves to load external data into database
  • Added dotConnect for Oracle information to Visual Studio 2005 splash screen and About box
  • Base level classes moved to the new assembly Devart.Data.dll
  • New demo projects added
OraDeveloper Tools 2.00 improvements
  • Added PL/SQL and SQL script debuggers
  • Added a project management framework for bookmarking related scripts and organizing database developments
  • Enhanced SQL Editor with context-sensitive code completion, code navigation, incremental search, and more
  • Enhanced working with data, including possibility to print data directly from data editor
  • Added search in object data and source code
  • Added an extensive collection of SQL and PL/SQL code templates
  • Completely redesigned Security Manager for controlling user accounts
  • Added a Session Manager for controlling and analyzing user sessions
  • Added an Event Monitor for exchanging signals between database connections
  • Extended Oracle schema object support, including support for XML Schemas, Materialized Views, and Materialized View Logs

dotConnect for Oracle 3.55 new features:

  • Windows Vista support added

dotConnect for Oracle 3.50 new features:

  • Implemented advanced integration with Visual Studio 2005, including Server Explorer, Data Source wizard, TableAdapter configuration, Query Builder and configuring web component SqlDataSource
  • Mono support added
  • Borland Delphi 2006 support added
  • Added streaming support for OracleScript
  • Added list of Frequently Asked Questions
  • Capability to call dotConnect for Oracle runtime assemblies by partially trusted code added
Professional Edition new features:
  • Enterprise Library Data Access Application Block support added
  • ASP.NET 2.0 providers added: Membership Provider, Role provider, Session State Provider, Profile provider
  • Dataset Wizard added
  • OraDeveloper Tools installation separated from dotConnect for Oracle Professional Edition
  • dotConnect for Oracle is now compatible with version 1.70 of OraDeveloper Tools

dotConnect for Oracle 3.20 new features:

  • Supported .NET Framework 2.0 release version
  • Supported Visual Studio 2005 release version
  • Compact .NET Framework 2.0 supported
  • Supported Oracle Express Edition (XE) server

dotConnect for Oracle 3.01 new features:

  • OracleCommandBuilder.UpdatingFields property added
  • OracleLoader is now inherited from DbLoader class

dotConnect for Oracle 3.00 new features:

  • Access to Oracle server without Oracle client software with Direct mode
  • Support for .NET Compact Framework added with Mobile edition
  • OracleDataTable component greatly enhanced with OracleObject and Arrays advanced data binding and update capabilities
  • New functionality added to OracleScript component
  • Oracle warning support added to OracleConnection.InfoMessage event
  • Interface enhanced for OraclePackage component
  • Publisher policy file added for versions compatibility
  • Support for Microsoft Visual Studio 2005 Beta 2 added
Design-time tools are completely revised, extended and called OraDeveloper Tools (Professional edition only):
  • Visual editors for Oracle schema objects added
  • Query Builder tool rewritten and improved
  • SQL editor tool improved
  • Execution plan visualization tool added
  • Ability to drag connections, tables and stored procedures from DbExplorer to Form Designer added
  • Component designers more tightly integrated with OraDeveloper Tools

dotConnect for Oracle 2.50 new features:

  • Support for .NET Framework 2.0 added with ADO.NET 2 features
  • Support for Metadata Schemas added
  • The Base-Class-Based provider model used
  • Connection pooling enhancements functionality added, that allows you to programmatically "drain" the connection pool
  • New OracleConnectionStringBuilder component to build connection strings to represent data sources
  • Documentation improved
  • Visual Studio 2005 support added
  • Borland Delphi 2005 support added

dotConnect for Oracle 2.40 new features:

  • Performance increased
  • New component OracleDataTable added
  • New methods for asynchronous working added
  • Support for paginal access to query result added
  • Support for multiple ExecuteReader added
  • Retrieve ROWID to dataset 'ROWID' column added
  • Parameter editor extended for Array and Table datatypes
  • Datatype conversions ability extended for OracleParameter.Value

dotConnect for Oracle 2.30 new features:

  • Oracle 10g support added
  • Multiple home environment
  • XMLType support
  • Oracle 10g Instant Client support added
  • Dynamic fetch size
  • Statement caching (Oracle 10g only)
  • Transparent Application Failover (TAF) support
  • Overloaded stored procedures
  • RECORD data type as parameters type
  • Schema table for REF cursor's and nested tables
  • Working with VARRAY and TABLE data types as native .NET array types
  • OracleDataReader.HasRows property added
  • OracleCommand.GetRowId method for native Oracle ROWID
  • OracleCommand.Cancel method supported
  • OracleError and OracleErrorCollection for Array Binding errors
  • OraclePermission class and attribute added

dotConnect for Oracle 2.01 new features:

  • Support for Borland Delphi 8 and Borland C#Builder 1.0 added

dotConnect for Oracle 2.00 new features:

  • Fully rewritten 100% managed code
  • Available Standard and Professional editions
  • Support Oracle 9i types such as TIMESTAMP, INTERVAL
  • Support Oracle object types OBJECT, VARRAY, TABLE, REF
  • Native classes and structures to represent Oracle types
  • Connection pooling support
  • Unicode support added
  • Array binding feature support
  • PL/SQL tables support
  • Fill DataSet with several REF CURSOR
  • OS authentication enabled
  • DBA privileges to open a session with
  • Controlling automatic commit data for the connection
  • Enables changing expired password
  • Transaction savepoints support added
  • Optimization fetching data with OracleCommand.FetchSize property
  • Getting offset of the error in SQL statement
  • dotConnect for Oracle help integrated into Visual Studio .NET
  • XML documentation for code completion added
  • Migration wizard from MS OracleClient and ODP.NET
  • Typed Oracle package wizard
  • New sample applications added

dotConnect for Oracle 1.55 new features:

  • Visual Studio .NET 2003 support added
  • Property editors for OracleCommandBuilder.KeyFields and OracleCommandBuilder.UpdatingTable added

dotConnect for Oracle 1.50 new features:

  • New component OracleScript added. Serves to execute series of SQL statements separated by special symbols, like SQL*Plus scripts
  • New component OracleLoader added. Serves to load external data into the Oracle database. Uses direct path load interface to speed up loading
  • New component OracleMonitor added. Allows you to monitor dynamic SQL execution in applications that use dotConnect for Oracle. Extended monitoring capabilities are provided with DBMonitor application
  • New component OraclePackage added. Provides access to packages stored in Oracle database
  • OracleConnection.Home property added to support Oracle Homes
  • OracleConnection.Error event added
  • OracleConnection.GetServerList() static method added
  • Performance greatly increased
  • Designer form for OracleDataAdapter component setup added
  • OracleCommand component designer functionality extended
  • Typed dataset generation mechanism enabled for OracleDataAdapter
  • Automatic component registration (in toolbox) mechanism added
  • OraDesigner, OraExplorer, OraBuilder and OraDebugger are now embedded into dotConnect for Oracle
  • BlobPictures, Loader, Pictures, StoredProc samples added
  • Visual Basic .NET samples added

dotConnect for Oracle 1.20 new features:

  • ASP.NET sample project added
  • MasterDetail sample project added

dotConnect for Oracle 1.10 new features:

  • DataSet sample project added
  • DataReader sample project added
  • Table sample project added
  • "Designer..." verb added to OracleConnection ComponentDesigner

© 2002 - 2016 Devart. All rights reserved.


%%ItemTitle%%

Getting Started
support@devart.com

Glossary Item Box

This section introduces dotConnect for Oracle. It contains the information on how to install dotConnect for Oracle, quick walkthroughs to get started developing applications with it, information on technical dotConnect licensing and deployment, and brief description of its documentation and samples.

  • Installation
  • Logging onto the Server
  • Creating Database Objects
  • Inserting Data into Tables
  • Retrieving and Modifying Data
  • Working with Oracle Stored Procedures
  • Using Transactions
  • Licensing
  • Deployment
  • Documentation
  • Samples


Installation

Installation
support@devart.com

dotConnect for Oracle is provided as a single setup package that contains all required files and documentation.

By default dotConnect for Oracle installs all files in "Program Files\Devart\dotConnect\Oracle" folder. The setup program also adds the necessary assemblies to the Global Assembly Cache by default. You can omit adding asemblies to GAC by clearing the Do not install assemblies in the GAC check box on the Additional Tasks installation wizard page. To install only *.dll files needed to run applications that use dotConnect for Oracle, you can select "Minimal" install in the setup program.

Some files are shared by Devart data providers. These assemblies are copied to the "\Program Files\Common Files\Devart\dotConnect\5.00\Net2\" folder. If you have several Devart data providers, make sure they use same version of the Devart.Data.dll assembly.

There are some limitations in Express Editions of Visual Studio. Particularly, the automatic toolbox components registration and Server Explorer integration are not available. You can, however, install components into toolbox manually as described below. As an exclusion, Visual Web Developer supports Server Explorer integration features.

Command Line Installation Keys

dotConnect for Oracle installation package is created with Inno Setup. Its standard setup command line parameters article is available at http://www.jrsoftware.org/ishelp/topic_setupcmdline.htm.

Also there are additional installation keys:

  • /nomachineconfig - no provider factory registration in DbProviderFactories section of machine.config.
  • /verysilent and /silent - besides standard Inno Setup functionality, no FAQ page is shown after installation is finished.
  • /nofeedback - no Feedback page is opened after uninstall.
  • /nomergepackage - not install menu item and toolbox components into Visual Studio.
  • /mergehelp - merge Devart documentation to MS Help collection.

Example:

  • the minimal type installation (only run-time assemblies and registration in machine.config)
     dcoracle.exe /TYPE=COMPACT /VERYSILENT /NOICONS
  • uninstall
    \Program Files\Devart\dotConnect\Oracle\Uninstall\unins000.exe /VERYSILENT /NOFEEDBACK
The following table contains the list of components, that can be used with the /COMPONENTS key.
Component name | Parameter
Visual Studio integration * | VsIntegration
Support for ADO.NET Entity Framework | Entity
LINQ | LinqRuntime
Entity Developer | ModelerTool
ASP.NET Web Providers | WebProviders
SQL Server Business Intelligence Solutions | SSIS
Workflow Instance Store | WFInstanceStore
Enterprise Library Data Access Block | EntLib
Samples | Samples
Help files | HelpFiles

* The VsIntegration parameter integrates the provider to all the installed Visual Studio versions, which are supported by dotConnect for Oracle. To install it only to Visual Studio 2010, for example, use "VsIntegration\VS2010" parameter.

Microsoft Visual Studio

dotConnect for Oracle components are automatically registered in Toolbox when you start the Visual Studio first time after successful installation of dotConnect for Oracle. If automatic registration fails, do the following steps to install the components manually:

  • In Visual Studio open the Toolbox window;
  • Add a 'Oracle Data' tab by right-clicking the Toolbox window and then clicking Add Tab;
  • Right-click the added tab and then click Choose Items...;
  • In the opened Choose Toolbox Items dialog box switch to the .NET Framework Components tab;;
  • Select the components the Namespace column of which starts with "Devart";
  • Click OK.

Since now dotConnect for Oracle components are available from toolbox.

CodeGear Delphi 2007

Because of the IDE restrictions design time is not available.


Logging Onto The Server

dotConnect for Oracle Tutorials Documentation
Logging Onto The Server
support@devart.com

This tutorial describes how to connect to Oracle server.

In this walkthrough:

  • Requirements
  • General information
  • Creating OracleConnection
  • Opening connection
  • Closing connection
  • Modifying connection
  • Additional information

Requirements

In order to connect to Oracle server you need the server itself running, dotConnect for Oracle installed and IDE running. If you have Oracle Client Software installed and want to use it, you need to know TNS alias name, login and password. If you do not wish to use OCI, you have to know host name or IP address, SID (or ServiceName), port, login and password.

Note that if you do not use design-time (specifically, if you do not place the OracleConnection component from the toolbox on a form designer), you have to embed licensing information manually. This is described in the Licensing topic.

General information

To establish a connection to server you have to provide some connection parameters to dotConnect for Oracle. This information is used by the OracleConnection component to find the server and login with credentials of your account. The parameters are represented as connection string. You can compose the connection string manually or have dotConnect for Oracle construct it for you.

There are two ways to connect to server: with and without Oracle Client Interface. This is controlled by Direct property. It indicates whether the Oracle Client Interface will be used for connecting to server. By default Direct mode is disabled to preserve maximal functionality. Switch to Direct mode if you want to work in a system without Oracle Client Software installed.

Note: In order to use OCI mode, you must have the Oracle Client of the same bitness as your application. For 32bit application, you must have 32bit Oracle Client installed, and for 64bit application you must have 64bit Oracle Client installed.

Creating OracleConnection

Design time creation

The following assumes that you have IDE running, and you are currently focused on a form designer.

  1. Open Toolbox and find OracleConnection component in dotConnect for Oracle category.
  2. Double-click the component. Note that new object appears on the designer underneath the form. If this is first time you create OracleConnection in this application, it is named oracleConnection1.
  3. Click on the oracleConnection1 object and press F4 to focus on object's properties.
  4. If you connect through OCI, in the Server property provide TNS alias of the server.
  5. If you use Direct mode, perform the following assignments:
    • set Direct to true
    • in the Server property provide DNS name or IP address of the computer where Oracle server resides
    • in the Sid property provide service name
    • In the Port property specify the port that the server listens to (usually this is 1521).
  6. In the UserId property specify your login. For example, scott.
  7. In the Password property specify your password. For example, tiger.
  8. Note that as you assign values to these properties the ConnectionString property is automatically updated to reflect your settings. Now it contains something like User Id=scott;Password=tiger;Server=OraServer; (example given for OCI mode).

Run time creation

Same operations performed in runtime look as follows (note that you have to add references to Devart.Data.Oracle.dll and Devart.Data.dll assemblies):

C#csharp Copy Code
using Devart.Data.Oracle;
...
OracleConnection oracleConnection1 = new OracleConnection();
oracleConnection1.Server = "OraServer";
oracleConnection1.UserId = "scott";
oracleConnection1.Password = "tiger";
Visual Basic Copy Code
Imports Devart.Data.Oracle
...
Dim OracleConnection1 As OracleConnection = New OracleConnection()
OracleConnection1.Server = "OraServer"
OracleConnection1.UserId = "scott"
OracleConnection1.Password = "tiger"

You can do this all in single assignment. It actually does not matter whether connection string is assigned directly or composed with particular properties. After you assign a value to ConnectionString property all other properties are populated with parsed values. So you can choose what is more convenient for you.

C#csharp Copy Code
oracleConnection1.ConnectionString = "User Id=scott;Password=tiger;Server=OraServer;";
Visual Basic Copy Code
oracleConnection1.ConnectionString = "User Id=scott;Password=tiger;Server=OraServer;"

Using connection string builder

If you decide to setup a connection by assigning values to several properties, consider using the the OracleConnectionStringBuilder class. It has all of the possible connection settings exposed as properties, thus allowing you to customize the connection at full extent. The following example demonstrates how to compose a more complex connection string:

C#csharp Copy Code
OracleConnectionStringBuilder oraCSB = new OracleConnectionStringBuilder();
oraCSB.Direct = true;
oraCSB.Server = "192.168.0.1";
oraCSB.Port = 1251;
oraCSB.Sid = "OracleSid";
oraCSB.UserId = "scott";
oraCSB.Password = "tiger";
oraCSB.MaxPoolSize = 150;
oraCSB.ConnectionTimeout = 30;
OracleConnection myConnection = new OracleConnection(oraCSB.ConnectionString);
Visual Basic Copy Code
Dim oraCSB As OracleConnectionStringBuilder = New OracleConnectionStringBuilder
oraCSB.Direct = true
oraCSB.Server = "192.168.0.1"
oraCSB.Port = 1251
oraCSB.Sid = "OracleSid"
oraCSB.UserId = "scott"
oraCSB.Password = "tiger"
oraCSB.MaxPoolSize = 150
oraCSB.ConnectionTimeout = 30
Dim myConnection As OracleConnection = New OracleConnection(oraCSB.ConnectionString)

Note that in this example we used OracleConnection constructor that accepts connection string as argument.

For the information on arguments are allowed in the connection string, refer to the description of the OracleConnection.ConnectionString property.

Opening connection

Opening a connection is as simple as that:

C#csharp Copy Code
oracleConnection1.Open();
Visual Basic Copy Code
OracleConnection1.Open()

Of course, OracleConnection1 must have a valid connection string assigned earlier. When you call Open, dotConnect for Oracle tries to find the host and connect to server. If any problem occurs it raises an exception with brief explanation on what is wrong. If no problem is encountered dotConnect for Oracle tries to establish the connection during ConnectionTimeout interval. Finally, when connection is established, the Open method returns and State property is changed to Open.

In design time you can connect to server in few steps:

  1. Right-click on oracleConnection1 object in designer.
  2. Select Connect from the popup menu.
  3. In the dialog window provide necessary logon information.
  4. Click the Connect button to establish connection.

Or you can simply change the State property to Open in the Properties window to establish a connection using the current connection string.

Closing connection

To close a connection call its Close method, or set its State property to Closed.

The following example summarizes aforementioned information and shows how to create, setup, open, use and then close the connection.

C#csharp Copy Code
OracleConnection myConn = new OracleConnection();
myConn.ConnectionString = "User Id=scott;Password=tiger;Server=OraServer;";
myConn.Open();
MessageBox.Show(myConn.ServerVersion);
myConn.Close();
Visual Basic Copy Code
Dim myConn As OracleConnection = New OracleConnection()
myConn.ConnectionString = "User Id=scott;Password=tiger;Server=OraServer;"
myConn.Open()
MessageBox.Show(myConn.ServerVersion)
myConn.Close()

The sample code connects to a server, shows its version and then closes the connection. This actually is rare usage, because in real applications connections are used by other objects like OracleCommand, OracleDataTable and others. For more information on this, please see the corresponding tutorials or the reference information.

Modifying connection

You can modify connection by changing properties of OracleConnection object. Keep in mind that while some of the properties can be altered freely, most of them close connection when new value is assigned. For example, if you change Server property, it gets closed immediately, and you have to reopen it manually.

Additional information

dotConnect for Oracle has wide set of features you can take advantage of. The following list enumerates some of them so you can explore the advanced techniques to achieve better performance, balance network load or enable additional capabilities.

  • Asynchronous connection opening
  • Connection pooling (refer to MSDN documentation for information about connection pooling)

See Also

Getting Started | Connecting to Oracle with Proxy Authentication | OracleConnection Class


Creating Database Objects

dotConnect for Oracle Tutorials Documentation
Creating Database Objects
support@devart.com

This tutorial describes how to create tables, stored procedures and other objects at Oracle server.

In this walkthrough:

  • Requirements
  • General information
  • Using SQL*Plus
  • Using dbForge Fusion for Oracle
  • Additional information

Requirements

In order to create database objects you have to connect to server. This process is described in details in the tutorial Logging onto the server.

General information

Database objects are created using Data Definition Language (DDL), which is a part of SQL. The DDL statements can be executed on server by account that has necessary privileges.

There are two ways to manipulate a database. You can build DDL statements manually and run them within Oracle SQL*Plus or component like OracleCommand. Another way is to use IDE - visual shells that provide graphical user interface to manage database. We will discuss both ways.

Using SQL*Plus

  1. Launch the SQL*Plus and authorize yourself.
  2. Type:
    CREATE TABLE dept (
  deptno INT PRIMARY KEY,
  dname VARCHAR(14),
  loc VARCHAR(13)
)
/
    Press Enter. This will create first of the tables we'll use for tutorial purposes.
  3. Run the following query:
    CREATE TABLE emp (
  empno INT PRIMARY KEY,
  ename VARCHAR(10),
  job VARCHAR(9),
  mgr INT,
  hiredate DATE,
  sal FLOAT,
  comm FLOAT,
  deptno INT REFERENCES dept
)
/
    This is another table we'll use.
  4. These two tables are enough to demonstrate basic functionality. Now you can type exit to exit the SQL*Plus.

Using dbForge Fusion for Oracle

Things are much simpler when you control them visually. The same statements can be executed without writing a line of code. This section describes how to manipulate database objects visually in dbForge Fusion for Oracle.

  1. Open the Database Explorer toolwindow if it is not open yet. To do this, in View menu point to Devart Developer Tools, and then click Database Explorer item.
  2. Click on the New Connection button on Database Explorer or the toolbar.
  3. In the Database Connection Properties dialog specify connection parameters and click OK.
  4. Right-click on Tables node.
  5. Choose New Table from popup menu.
  6. Input name of the table: dept, press OK.
  7. In Table menu, choose New Column.
  8. In the Column Editor describe first column and press OK.
  9. Repeat steps 7 and 8 for every column in the table.
  10. Press Ctrl+S to save the document. The table will be created in the database.

Note that dbForge Fusion for Oracle has its own comprehensive documentation with tutorials. See contents of Visual Studio Help Collection for more information on using dbForge Fusion for Oracle.

Additional information

Actually there are lots of ways to create tables on server. Any tool or component that is capable of running a SQL query, can be used to manage database objects. For example, OracleCommand suits fine for creating objects one by one, while OracleScript is designed for executing series of DDL/DML statements. For information on DDL statements syntax refer to Oracle documentation.

See Also

Getting Started | Using dbForge Fusion for Oracle | OracleCommand Class | OracleScript Class


Inserting Data Into Tables

dotConnect for Oracle Tutorials Documentation
Inserting Data Into Tables
support@devart.com

This tutorial describes how to use OracleCommand component to insert data into tables by means of executing SQL queries.

In this walkthrough:

  • Requirements
  • General information
  • Inserting data in run time
  • Design time setup
  • Using dbForge Fusion for Oracle
  • Additional information

Requirements

This walkthrough supposes that you know how to connect to server (tutorial Logging onto the server) and that necessary objects are already created on the server (tutorial Creating database objects).

Note that if you do not use design-time (specifically, if you do not place on a designer OracleConnection component from toolbox), you have to embed licensing information manually. This is described in topic Licensing.

General information

Data on server can be modified (inserted, changed or deleted) using Data Manipulation Language (DML), which is a part of SQL. The DML statements can be executed on server by account that has necessary privileges.

There are two ways to manipulate a database. You can build DML statements manually and run them within some component like OracleCommand. Another way is to use design-time features that provide graphical user interface to manage database. We will discuss both ways.

The goal of this tutorial is to insert the following data into tables dept and emp:

Table dept

deptno | dname | loc
10 | Accounting | New York
20 | Sales | Dallas
30 | Sales2 | Chicago

Table emp

empno | ename | job | mgr | hiredate | sal | comm | deptno
7369 | Smith | Clerk | 7566 | 1980-12-17 | 800 | Null | 20
7499 | Allen | Salesman | 7698 | 1981-02-20 | 1600 | 300 | 30
7521 | Ward | Salesman | 7698 | 1981-02-22 | 1250 | 500 | 30
7566 | Jones | Manager | 7839 | 1981-04-02 | 2975 | Null | 20
7654 | Martin | Salesman | 7698 | 1981-09-28 | 1250 | 1400 | 30
7698 | Blake | Manager | 7839 | 1981-05-01 | 2850 | Null | 30
7839 | King | President | Null | 1981-11-17 | 5000 | Null | 10

Inserting data in run time

To insert the first row into table dept you can use the following statement:

INSERT INTO dept (deptno, dname, loc) VALUES (10,'Accounting','New York')

The following code fragment executes the query:

C#csharp Copy Code
OracleConnection conn = new OracleConnection("User Id=scott;Password=tiger;Server=OraServer;");
OracleCommand cmd = new OracleCommand();
cmd.CommandText = "INSERT INTO dept (deptno, dname, loc) VALUES (10,'Accounting','New York')";
cmd.Connection = conn;
conn.Open();
try {
  int aff = cmd.ExecuteNonQuery();
  MessageBox.Show(aff + " rows were affected.");
}
catch {
  MessageBox.Show("Error encountered during INSERT operation.");
}
finally {
  conn.Close();
}
Visual Basic Copy Code
Dim conn As OracleConnection = New OracleConnection("User Id=scott;Password=tiger;Server=OraServer;")
Dim cmd As OracleCommand = New OracleCommand()
cmd.CommandText = "INSERT INTO dept (deptno, dname, loc) VALUES (10,'Accounting','New York')"
cmd.Connection = conn
conn.Open()
Try
  Dim aff As Integer = cmd.ExecuteNonQuery()
  MessageBox.Show(aff & " rows were affected.")
Catch
  MessageBox.Show("Error encountered during INSERT operation.")
Finally
  conn.Close()
End Try

The sample first creates a connection with hardcoded connection string. Then it creates OracleCommand object, assigns the query text and connection to the OracleCommand instance. Connection is opened then. The ExecuteNonQuery() method of OracleCommand runs SQL statement in the CommandText property and returns number of rows affected by the query. This method is not intended to run SELECT statements. We will discuss retrieving data in other tutorials.

If the query is executed successfully you are notified about number of affected rows. If some error occurs you get the error message. The connection is closed anyway. It is recommended that you use try ... finally clauses to make sure the connections are closed properly.

Design time setup

Same operations in design time include following steps:

  1. Place OracleConnection component on a designer.
  2. Setup its properties and open connection by changing the State property to Open
    - or -
    right-click on the component, choose Connect item and use the dialog to connect to server.
  3. Place OracleCommand component on the designer.
  4. In its Connection property select name of the OracleConnection instance on the designer.
  5. In the CommandText property type in the following query:
    INSERT INTO dept VALUES (20,'Sales','Dallas')
  6. Right-click on the OracleCommand and choose Execute from popup menu.
  7. Repeat steps 5 and 6 with the following CommandText:
    INSERT INTO dept VALUES (30,'Sales2','Chicago')

Note that the last two steps might be easier to do in the OracleCommand editor. To invoke it choose CommandText item form OracleCommand popup menu or click on the ellipsis in this property in Properties window.

Using dbForge Fusion for Oracle

Sometimes it is very handy to modify data in design time. This section describes one of the ways to edit data in a grid. These operations are convenient to do in dbForge Fusion for Oracle.

  1. In Database Explorer connect to server and browse to the table Emp (for detailed information on how to do it refer to the tutorial Creating Database Objects).
  2. Right-click on it and choose Retrieve Data from popup menu.
    The editor appears where you can see what data the table contains if any.
  3. Click the Append button (+) or press <insert> key.
  4. Click on the very first cell. Type in value: 7369.
  5. Click on the next cell or hit <Tab>, type in: Smith.
  6. In the following cell, type: Clerk.
  7. Go on filling the row until you reach the last column. Press <Enter> key to apply inserting the row.
  8. Click on the first cell of the second row. Now you have to fill it starting with value 7499. Repeat steps 3-7 to insert all required rows into the table.

Note that dbForge Fusion for Oracle has its own comprehensive documentation with tutorials. See contents of Visual Studio Help Collection for more information on using dbForge Fusion for Oracle.

Additional information

Actually there are lots of ways to insert data into tables. Any tool or component that is capable of running a SQL query, can be used to manage data. Some components are best for performing certain tasks. For example, OracleLoader is the fastest way to insert data, OracleScript is designed for executing series of statements. For more information on these components refer to dotConnect for Oracle reference.

See Also

Getting Started | Using dbForge Fusion for Oracle | OracleCommand Class | OracleLoader | OracleScript Class


Retrieving and Modifying Data

Retrieving and Modifying Data
support@devart.com
  • Introduction
  • Requirements
  • General Information
  • Retrieving and Updating Data using Connected Model
  • Retrieving and Updating Data using Disconnected Model
  • Additional Information

Introduction

This tutorial describes how to use OracleCommand, OracleDataReader, and OracleDataTable components.

Requirements

This walkthrough supposes that you know how to connect to server, how to create the necessary objects on the server, and how to insert the data to the created tables.

Note that if you do not use design-time (specifically, if you do not place on a designer OracleConnection component from toolbox), you have to embed license information manually. This is described in the Licensing topic.

General Information

As we know, an original function of any database application is establishing a connection to a data source and working with data contained in it. The .NET Framework data providers of ADO.NET serve as a bridge between an application and a data source, and allow you to execute commands as well as to retrieve data by using a DataReader or a DataAdapter. Updating data involves using the Command and DataAdapter objects; and it may also involve using transactions.

Let's make some classification to get better understanding of ADO.NET model. There are two approaches to work with data: connected and disconnected models. You can use classes of the connected model for establishing connection and setting transactions, for fetching data and updating datasources. These classes interoperate with database directly: OracleProviderFactory, OracleConnection, OracleTransaction, OracleDataAdapter, OracleCommand, OracleParameter, and OracleDataReader.

The objects, which represent the disconnected model of ADO.NET, don't interoperate with datasource immediately. These classes provide the ability to work off-line against your data storage: DataSet, DataTable, DataColumn, DataRow, Constraints, DataRelation, DataView, and DataRowView.

We will use in our samples the classes from both models.

The goal of this tutorial is to retrieve and update the data from the table dept (the appropriate DDL/DML script is located at \Program Files\Devart\dotConnect\Oracle\Samples\tables.sql - the default path of dotConnect for Oracle installation).

Note Note:
OracleDataAdapter and OracleDataTable components are available for full .NET Framework only. They are not available in dotConnect for Oracle .NET Standard 1.3 compatible assemblies, because there are no base classes for them. Thus, you cannot use disconnected model classes and OracleDataAdapter in projects targeted .NET Core or other .NET platforms except for full .NET Framework.

Retrieving and Updating Data using the Connected Model

In this sample we are using OracleCommand and OracleDataReader to retrieve and manipulate data. For more information, refer to the description of these classes in our documentation.

C#csharp Copy Code
using Devart.Data.Oracle;
...
class Program
{
    void PrintDept(OracleConnection connection)
    {
        OracleCommand command = connection.CreateCommand();
        command.CommandText = "select * from dept";

        // Call the Close method when you are finished using the OracleDataReader
        // to use the associated OracleConnection for any other purpose.
        // Or put the reader in the using block to call Close implicitly.
        using (OracleDataReader reader = command.ExecuteReader())
        {
            // printing the column names
            for (int i = 0; i < reader.FieldCount; i++)
                Console.Write(reader.GetName(i).ToString() + "\t");
            Console.Write(Environment.NewLine);
            // Always call Read before accesing data
            while (reader.Read())
            {
                // printing the table content
                for (int i = 0; i < reader.FieldCount; i++)
                    Console.Write(reader.GetValue(i).ToString() + "\t");
                Console.Write(Environment.NewLine);
            }
        }
    }

    void ModifyDept(OracleConnection connection)
    {
        OracleCommand command = connection.CreateCommand();
        command.CommandText = "UPDATE DEPT SET LOC='VEGAS' WHERE DEPTNO > 20";

        // return value of ExecuteNonQuery (i) is the number of rows affected by the command
        int i = command.ExecuteNonQuery();
        Console.WriteLine(Environment.NewLine + "Rows in DEPT updated: {0}", i + Environment.NewLine);
    }

    static void Main(string[] args)
    {
        using (OracleConnection conn
            = new OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora;"))
        {
            try
            {
                conn.Open();
                Program program = new Program();

                // printing out the Dept table to console
                program.PrintDept(conn);

                // updating records in Dept
                program.ModifyDept(conn);

                // printing out the Dept table to console
                program.PrintDept(conn);
            }
            catch (OracleException ex)
            {
                Console.WriteLine("Exception occurs: {0}", ex.Message);
            }
            finally
            {
                Console.ReadLine();
            }
        }
    }
}
Visual Basic Copy Code
Imports Devart.Data.Oracle
...
Module Module1
    Sub PrintDept(ByVal connection As OracleConnection)
        Dim command As OracleCommand = connection.CreateCommand()
        command.CommandText = "select * from dept"

        ' Call the Close method when you are finished using the OracleDataReader
        ' to use the associated OracleConnection for any other purpose.
        ' Or put the reader in the using block to call Close implicitly.
        Using reader As OracleDataReader = command.ExecuteReader()
            ' printing the column names
            For i As Integer = 0 To reader.FieldCount - 1
                Console.Write(reader.GetName(i).ToString() & VbCrlf)
            Next i
            Console.Write(Environment.NewLine)

            ' Always call Read before accesing data
            While reader.Read()
                ' printing the table content
                For i As Integer = 0 To reader.FieldCount - 1
                    Console.Write(reader.GetValue(i).ToString() & VbCrlf)
                Next
                Console.Write(Environment.NewLine)
            End While
        End Using
    End Sub

    Sub ModifyDept(ByVal connection As OracleConnection)
        Dim command As OracleCommand = connection.CreateCommand()
        command.CommandText = "UPDATE DEPT SET LOC='VEGAS' WHERE DEPTNO > 20"

        ' return value of ExecuteNonQuery (i) is the number of rows affected by the command
        Dim i As Integer = command.ExecuteNonQuery()
        Console.WriteLine(Environment.NewLine & "Rows in DEPT updated: {0}", i & Environment.NewLine)
    End Sub

    Sub Main()
        Using conn _
            As New OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora;")
            Try
                conn.Open()

                ' printing out the Dept table to console
                Module1.PrintDept(conn)

                ' updating records in Dept
                Module1.ModifyDept(conn)

                ' printing out the Dept table to console
                Module1.PrintDept(conn)
            Catch ex As OracleException
                Console.WriteLine("Exception occurs: {0}", ex.Message)
            Finally
                Console.ReadLine()
            End Try
        End Using
    End Sub
End Module

Retrieving and Updating Data using the Disconnected Model

Note Note:
Applicable only for projects targeting full .NET Framework.

A traditional way for working with DataTable and DataSet assumes consecutive creating and initializing Connection, Command, DataAdapter, and CommandBuilder objects. Devart OracleDataTable and OracleDataSet have advanced features that make work with data easier. Even more, with our components you can retrieve and manipulate data in design time. For more information, refer to the descriptions of these classes.

Here is a small sample that demonstrates usage of OracleDataTable.

C#csharp Copy Code
public void UseDataTable()
{
   OracleDataTable myDataTable
    = new OracleDataTable("SELECT * FROM Dept", "User Id=Scott;Password=tiger;Data Source=Ora;");
   try
   {
       // FetchAll=true means to retrieve data from server entirely when DataTable is opened.
       //  By default, FetchAll is set to false - only minimal quantity of rows is requested at once,
       //  which leads to better initial response time and less network traffic.
       myDataTable.FetchAll = true;

       // populating DataTable with data from data source
       myDataTable.Active = true;

       // modifying the third record
       myDataTable.Rows[3]["DName"] = "Researches";

       // Update method executes the appropriate commands (delete, insert, or update) in the data source.
       Console.WriteLine(myDataTable.Update() + " rows updated.");

       // printing the DataTable content
       foreach (DataRow myRow in myDataTable.Rows)
       {
          foreach (DataColumn myCol in myDataTable.Columns)
          {
              Console.Write(myRow[myCol] + "\t");
          }
          Console.WriteLine();
       }
     }
     finally
     {
        //Active=false does not clear the data, but frees the resources allocated on the server, if any.
        myDataTable.Active = false;
     }
}
Visual Basic Copy Code
Public Sub UseDataTable()
    Dim myDataTable As OracleDataTable _
        As New OracleDataTable("SELECT * FROM Dept", "User Id=Scott;Password=tiger;Data Source=Ora;")
    Try
        ' FetchAll=true means to retrieve data from server entirely when DataTable is opened.
        '  By default, FetchAll is set to false - only minimal quantity of rows is requested at once,
        '  which leads to better initial response time and less network traffic.
        myDataTable.FetchAll = True

        ' populating DataTable with data from data source
        myDataTable.Active = True

        ' modifying the third record
        myDataTable.Rows(3)("DName") = "Researches"

        ' Update method executes the appropriate commands (delete, insert, or update) in the data source.
        Console.WriteLine(myDataTable.Update() & " rows updated.")
        Dim myRow As DataRow
        Dim myCol As DataColumn

        ' printing the DataTable content
        For Each myRow In myDataTable.Rows
            For Each myCol In myDataTable.Columns
                Console.Write(myRow(myCol) & VbCrlf)
            Next myCol
            Console.WriteLine()
        Next myRow
    Finally
        ' Active=false does not clear the data, but frees the resources allocated on the server, if any.
        myDataTable.Active = False
    End Try
End Sub

OracleDataSet can be easily created with Devart DataSet Wizard and visually managed with Devart DataSet Manager. Please refer to our Using DataSet Wizard and Using DataSet Manager articles.

Additional Information

This tutorial describes only basic ways of working with data. Besides, you can take advantage of using stored procedures, typed datasets and ORM solutions. dotConnect for Oracle supports the LinqConnect and Entity Framework ORM technologies which are intended for converting data between incompatible type systems in relational databases and object-oriented programming languages. These technologies allow you to decrease the amount of code and maintenance required for data-oriented applications. For more information, please refer to Entity Framework and LinqConnect sections.

See Also

Using DataSet Wizard | Using DataSet Manager | OracleDataTable Advanced Features | ORM Solutions


Working with Oracle Stored Procedures

Working with Oracle Stored Procedures
support@devart.com

This section describes how to create and use Oracle stored procedures and functions with dotConnect for Oracle.

It supposes that you know how to connect to server, how to create the necessary objects on the server, and how to manipulate with the data stored in database tables. The section describes stored procedures using for typed DataSets also supposes that you know how to work with Devart DataSet Wizard.

This section contains the following articles:

  • Stored Procedures - General Information

    Contains general information about stored procedures and functions and describes how to create them.

  • Using Stored Procedures via the OracleCommand Class

    Contains an information about using stored procedures with the help of OracleCommand class.

  • Using Package Procedures

    Describes approaches of the stored procedure usage when they are included into the Oracle packages.

  • Using Stored Procedures in DataSets

    Describes how to generate datasets based on the stored procedures or functions.

  • Using Table-Valued Functions

    Describes how to use Oracle table-valued functions - the functions, returning a collection of rows, that can be queried like usual database tables by calling the function in the FROM clause of SELECT statements.

Besides, you may be interested in using ORM solutions which are used for converting data between incompatible type systems in relational databases and object-oriented programming languages. dotConnect for Oracle supports the LinqConnect and Entity Framework ORM technologies, which allow to decrease the amount of code and maintenance required for data-oriented applications. For more information, please refer to Entity Framework and LinqConnect topics.

See Also

Stored Procedures - General Information | Using Stored Procedures via the OracleCommand class | Using Package Procedures | Using Stored Procedures in DataSets


Stored Procedures - General Information

Stored Procedures - General Information
support@devart.com

This section contains information about general aspects of stored procedures usage.

A stored procedure is a schema object that consists of a set of SQL statements and other PL/SQL constructs, grouped together, stored in the database, and run as a unit to solve a specific problem or perform a set of related tasks. Procedures let you combine the ease and flexibility of SQL with the procedural functionality of a structured programming language. Large or complex processing that might require the execution of several SQL statements is moved into stored procedures, and all applications call the procedures only.

Objects similar to stored procedures are stored functions. Almost everything that is true for procedures, holds for functions as well. The main difference between these objects is that function has a return value, and procedure has not.

A stored procedures and functions may have input, output, and input/output parameters.

Input parameter is a parameter whose value is passed into a stored procedure/function module. The value of an IN parameter is a constant; it can't be changed or reassigned within the module.

For example, the following procedure inserts a row into the Dept table:

CREATE PROCEDURE dept_insert (pDeptno INTEGER, pDname VARCHAR, pLoc VARCHAR) AS
BEGIN
  INSERT INTO dept(deptno, dname, loc) VALUES (pDeptno, pDname, pLoc);
END;

It needs to receive the values to be inserted into the new record, and thus the procedure has three input parameters, corresponding to each field of the table. The procedure may be executed inside a PL/SQL block like follows:

begin
  dept_insert (10, 'Accounting', 'New York');
end;

Output parameter is a parameter whose value is passed out of the stored procedure/function module, back to the calling PL/SQL block. An OUT parameter must be a variable, not a constant. It can be found only on the left-hand side of an assignment in the module. You cannot assign a default value to an OUT parameter outside of the module's body. In other words, an OUT parameter behaves like an uninitialized variable. In the following sample, the stored procedure returns the count of records in table Dept:

CREATE PROCEDURE dept_count (cnt OUT INTEGER)
AS
BEGIN
  SELECT COUNT(*) INTO cnt FROM dept;
END;

An input/output parameter is a parameter that functions as an IN or an OUT parameter or both. The value of the IN/OUT parameter is passed into the stored procedure/function and a new value can be assigned to the parameter and passed out of the module. An IN/OUT parameter must be a variable, not a constant. However, it can be found on both sides of an assignment. In other words, an IN/OUT parameter behaves like an initialized variable.

Besides scalar variables, a stored procedure can return result sets, i.e. the results of a SELECT statement. In Oracle, the cursor variables are used for this case. A cursor may be interpreted as a reference to the result set. The following sample demonstrates how a simplest select statement can be wrapped in a stored procedure:

CREATE PROCEDURE get_all_depts_proc (cur OUT SYS_REFCURSOR) AS
BEGIN
  OPEN cur FOR SELECT * FROM dept;
END;

The same SELECT statement can be used via a stored function as follows:

CREATE OR REPLACE FUNCTION get_all_depts_func RETURN SYS_REFCURSOR
AS
  cur SYS_REFCURSOR;
BEGIN
  OPEN cur FOR SELECT * FROM dept;
  RETURN cur;
END;

Here the cursor is passed as the return value instead of being an output parameter.

See Also

Working with Oracle Stored Procedures | Using Stored Procedures via the OracleCommand class | Using Package Procedures | Using Stored Procedures in DataSets


Using Stored Procedures via the OracleCommand Class

Using Stored Procedures via the OracleCommand Class
support@devart.com

This topic describes how to create and use Oracle stored procedures and functions with dotConnect for Oracle by the help of OracleCommand class.

There are two general ways of executing a stored procedure via OracleCommand.

The first way is to include a procedure invocation into a PL/SQL block and execute this block by putting it into the OracleCommand.CommandText property. In this case, the data returned by the procedure may be at once processed in the same block. If the procedure needs some parameters, they should be added to the OracleCommand.Parameters collection. This method does not differ from the usual command execution, please see Using Parameters article and OracleCommand Class for details.

The second way is to set the OracleCommand.CommandType to System.Data.CommandType.StoredProcedure. In this case, CommandText should be set to the procedure's name. The following sample shows how a DataTable can be filled using the get_all_depts_proc procedure from the previous section:

C#csharp Copy Code
// Open the connection
OracleConnection connection
    = new OracleConnection("Server=Ora; User Id=Scott; Password = tiger;");
connection.Open();

// Create a command
OracleCommand command = new OracleCommand();
command.Connection = connection;

// Set the CommandType property to execute
// stored procedures or functions by this command
command.CommandType = System.Data.CommandType.StoredProcedure;

// Set the name of procedure or function to be executed
command.CommandText = "get_all_depts_proc";

// The ParameterCheck property should be true to automatically
// check the parameters needed for the procedure execution.
command.ParameterCheck = true;

// At this moment, the command is ready for execution.
// As we have an output cursor parameter, we may use the command to fill a data table.
OracleDataTable dt = new OracleDataTable(command, connection);
dt.Fill();
Visual Basic Copy Code
Dim connection _
    As New OracleConnection("Server=Ora; User Id=Scott; Password = tiger;")
connection.Open()

' Create a command.
Dim command = New OracleCommand()
command.Connection = connection

' Set the CommandType property to execute stored procedures or functions by this command.
command.CommandType = System.Data.CommandType.StoredProcedure

' Set the name of procedure or function to be executed.
command.CommandText = "get_all_depts_proc"

' The ParameterCheck property should be true to automatically
' check the parameters needed for the procedure execution.
command.ParameterCheck = True

' At this moment, the command is ready for execution.
' As we have an output cursor parameter, we may use the command to fill a data table.
Dim dt = New OracleDataTable(command, connection)
dt.Fill()

Setting CommandText to "get_all_depts_func", the very same code fills the data table using the stored function instead of the procedure.

Optimization of Stored Procedure Execution

When executing ExecuteReader or ExecuteScalar, and OracleCommand.CommandType is set to System.Data.CommandType.StoredProcedure, by default an additional queries are performed that check whether the procedure is pipelined and, if not, describing the parameters (checking for OUT cursor parameters). This allows you to execute stored procedures after setting just the necessary procedure parameters without bothering to fill the parameters collection completely and correctly, because after getting metadata it will be filled automatically.

However, performing an additional query may be unsuitable, and in some cases may lead to a performance loss. dotConnect for Oracle allows disabling this check with the DescribeStoredProcedure connection string parameter.

If you simply set this connection string parameter to false, OracleCommand executes stored routines without any additional checks. In such case the routine must not be a table-valued function, and all its parameters must be set manually.

If you want to execute a table-valued function without additional checks, you need to set the IsTableValuedFunction property of OracleCommand to true. This allows you to execute table-valued functions without additional checks. Setting this property to true is also the only way to execute non-pipelined table-valued functions. Even if DescribeStoredProcedure is set to true, you must also set IsTableValuedFunction to true to execute a non-pipelined table-valued function.

When you want to disable additional checks just for a single instance of OracleCommand without disabling them for a connection, set both IsTableValuedFunction property (to true or false depending on whether the executed function is table-valued) and ImplicitRefCursors property to false. Setting the IsTableValuedFunction property disables the check whether the the executed function is table-valued, and setting the ImplicitRefCursors property to false disables the check for additional cursor parameters.

See Also

Working with Oracle Stored Procedures | Stored Procedures - General Information | Using Package Procedures | Using Stored Procedures in DataSets | Using Table-Valued Functions


Using Package Procedures

Using Package Procedures
support@devart.com

This topic describes how to create and use Oracle stored procedures and functions within the Oracle packages with dotConnect for Oracle.

In Oracle databases, stored procedures and functions may be grouped into specific sets which are called packages. To call a package procedure, one needs only to add the package name before the procedure's name, like "package.get_all_depts_proc". However, with dotConnect for Oracle using of packages may be even easier due to typed and untyped OraclePackages. The first ones are the classes generated by the Package Wizard, the second ones are instances of the OraclePackage class.

Untyped OraclePackages may be set to represent any package specified by the name, provided that this package is available for the connection used. OraclePackage class has a set of methods intended to execute procedures and retrieve their descriptions.

Typed OraclePackage is a class representing the only specific package. For each procedure or function of this package, instances of corresponding typed OraclePackage have a special method. Such approach allows to invoke stored procedures just like usual object methods. Typed Oracle packages can be created using Typed Oracle Package Wizard. For more information on this see Using Package Wizard for working with PL/SQL Packages.

See Also

Working with Oracle Stored Procedures | Stored Procedures - General Information | Using Stored Procedures via the OracleCommand class | Using Stored Procedures in DataSets


Using Stored Procedures in DataSets

Using Stored Procedures in DataSets
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

This topic describes how to create and use Oracle stored procedures and functions with dotConnect for Oracle in the define typed DataSets.

If a procedure returns a result set, this recordset may be used to generate a data table in the typed data set. To perform this, select either the get_all_depts_proc procedure or the get_all_depts_func function in the DataSet Wizard:

Devart DataSet Wizard - Choose database objects page

Then proceed to the DataSet generation and place the generated data set instance, say, dataSet1, onto the form. After that, the procedure result set can be used just like usual data tables. For example, you can fill a data grid with this table:

C#csharp Copy Code
dataSet1.Fill();
DataTable dt = dataSet1.Tables[0];
dataGridView1.DataSource = dt;
Visual Basic Copy Code
DataSet1.Fill()
Dim dt As DataTable = DataSet1.Tables.Item(0)
DataGridView1.DataSource = dt

Besides generation of data tables, stored procedures may be used to set the update/insert/delete commands in the DataSet Wizard. This can be useful, e.g., if some data validation is made in the procedure.

Perform the following to set the dept_insert stored procedure as the insert command for the typed data set:

  1. Start the DataSet Wizard, select the Dept table and proceed to the next step of wizard
  2. Click the Configure commands button:
    3. Devart DataSet Wizard - Setup individual data tables page
  3. On the Update Commands tab, click the Edit... button:
    4. Table adapter editor
  4. Change the Type list box to StoredProcedure and select the dept_insert procedure in the Object Name list box:
  5. Proceed to the Parameters tab. Click Yes on confirmation window. The parameters that are used for insert command should be regenerated.
  6. For each parameter, select the corresponding column in the Source Column list box
  7. Click OK and proceed to the data set generation

After that the dept_insert procedure will be used as the insert command of the typed Dept data table. For example, the following code, which adds a new row to the Dept table, implicitly calls dept_insert:

C#csharp Copy Code
dataSet1.DEPT.AddDEPTRow(20, "Sales", "NEW YORK");
dataSet1.Update();
Visual Basic Copy Code
DataSet1.DEPT.AddDEPTRow(20, "Sales", "NEW YORK")
DataSet1.Update()

See Also

Working with Oracle Stored Procedures | Stored Procedures - General Information | Using Stored Procedures via the OracleCommand class | Using Package Procedures


Using Table-Valued Functions

Using Table-Valued Functions
support@devart.com

Table-valued functions in Oracle are the functions, returning a collection of rows and can be queried like usual database tables by calling the function in the FROM clause of SELECT statements. Pipelined table-valued functions are the functions that iteratively return rows as soon as they are produced instead of returning all of the rows after the end of the function execution.

In this topic we will show how you can execute such functions with the OracleCommand Class.

We will use the following two functions in our samples:

CREATE OR REPLACE TYPE t_tvf_row AS OBJECT (
  id           NUMBER,
  description  VARCHAR2(50)
);
/
CREATE OR REPLACE TYPE t_tvf_table IS TABLE OF t_tvf_row;
/
CREATE OR REPLACE FUNCTION tvf_table_func (p_rows IN NUMBER)
  RETURN t_tvf_table
AS
  l_tab  t_tvf_table := t_tvf_table();
BEGIN
  FOR i IN 1 .. p_rows LOOP
    l_tab.extend;
    l_tab(l_tab.last) := t_tvf_row(i, 'Description for ' || i);
  END LOOP;

  RETURN l_tab;
END;
/
CREATE OR REPLACE FUNCTION tvf_pipelined_table_func (p_rows IN NUMBER)
  RETURN t_tvf_table PIPELINED
AS
BEGIN
  FOR i IN 1 .. p_rows LOOP
    PIPE ROW(t_tvf_row(i, 'Description for ' || i));
  END LOOP;

  RETURN;
END;
/

The tvf_table_func is a non-pipelined table function, and tvf_pipelined_table_func is a pipelined table function.

The following example executes the non-pipelined tvf_table_func function, however this code can be used for both for pipelined and non-pipelined functions.

C#csharp Copy Code
    private static List<object[]> ExecuteTableValuedFunctionWithoutDescribe() {

      using (OracleConnection conn = new OracleConnection("Data Source=ORA; User Id=scott; Password=tiger; DescribeStoredProcedure=false;")) {
        conn.Open();

        using (OracleCommand cmd = conn.CreateCommand("tvf_table_func", CommandType.StoredProcedure)) {
          cmd.IsTableValuedFunction = true;
          cmd.Parameters.Add("p_rows", 3);

          List<object[]> resultSet = new List<object[]>();
          using (OracleDataReader reader = cmd.ExecuteReader()) {
            while (reader.Read())
              resultSet.Add(reader.GetValues());
            return resultSet;
          }
        }
      }
    }
Visual Basic Copy Code
Private Shared Function ExecuteTableValuedFunctionWithoutDescribe() As List(Of Object())
    Using conn As New OracleConnection("Data Source=ORA; User Id=scott; Password=tiger; DescribeStoredProcedure=false;")
        conn.Open()
        Using cmd As OracleCommand = conn.CreateCommand("tvf_table_func", CommandType.StoredProcedure)
            cmd.IsTableValuedFunction = True
            cmd.Parameters.Add("p_rows", 3)
            Dim resultSet As New List(Of Object())()
            Using reader As OracleDataReader = cmd.ExecuteReader()
                While reader.Read()
                    resultSet.Add(reader.GetValues())
                End While
                Return resultSet
            End Using
        End Using
    End Using
End Function

When performing the ExecuteReader() call, only one call is sent to the database - the stored function call. For this we set the DescribeStoredProcedure connection string parameter to false and the IsTableValuedFunction property of OracleCommand to true. The latter is required for execution of non-pipelined table-valued functions.

The next sample executes the pipelined table-valued function tvf_pipelined_table_func. When performing the ExecuteReader() call, two database calls are performed. The first selects the stored function metadata to determine whether the function is pipelined, and the second executes the procedure. This code cannot be used for executing a non-pipelined table-valued function, such as tvf_table_func.

C#csharp Copy Code
    private List<object[]> ExecuteTableValuedFunctionWithDescribe() {

      using (OracleConnection conn = new OracleConnection("Data Source=ORA; User Id=scott; Password=tiger;")) {
        conn.Open();

        using (OracleCommand cmd = conn.CreateCommand("tvf_pipelined_table_func", CommandType.StoredProcedure)) {
          cmd.Parameters.Add("p_rows", 3);

          List<object[]> resultSet = new List<object[]>();
          using (OracleDataReader reader = cmd.ExecuteReader()) {
            while (reader.Read())
              resultSet.Add(reader.GetValues());
            return resultSet;
          }
        }
      }
    }
Visual Basic Copy Code
Private Function ExecuteTableValuedFunctionWithDescribe() As List(Of Object())
    Using conn As New OracleConnection("Data Source=ORA; User Id=scott; Password=tiger;")
        conn.Open()
        Using cmd As OracleCommand = conn.CreateCommand("tvf_pipelined_table_func", CommandType.StoredProcedure)
            cmd.Parameters.Add("p_rows", 3)
            Dim resultSet As New List(Of Object())()
            Using reader As OracleDataReader = cmd.ExecuteReader()
                While reader.Read()
                    resultSet.Add(reader.GetValues())
                End While
                Return resultSet
            End Using
        End Using
    End Using
End Function

See Also

Working with Oracle Stored Procedures | Stored Procedures - General Information | Using Package Procedures | Using Stored Procedures in DataSets


Using Transactions

Using Transactions
support@devart.com

  • Understanding Transactions
  • Local Transactions
  • Distributed Transactions in the OCI mode
  • Distributed Transactions in the Direct mode

Understanding Transactions

A transaction is one or several operations considered as a single unit of work which is completed entirely or have no effect at all ("all-or-nothing"). If a failure occurs at one point in the transaction, all of the updates can be rolled back to their pre-transaction state. A transaction must conform to the ACID properties - atomicity, consistency, isolation, and durability-in order to guarantee data consistency.

If a transaction involves multiple tables in the same database, then explicit transactions in PL/SQL often perform better. You can use COMMIT and ROLLBACK statements in your SQL to fix and discard respectively the previous commands in your current PL/SQL block. For more information, see Oracle PL/SQL documentation.

Otherwise, a transaction with plain SQL can be implemented via special command classes from library/assemblies designed to work with Oracle database. For example, you can use Devart.Data.Oracle.OracleCommand: start transaction on OracleCommand's connection, execute several SQL statements via this OracleCommand, and commit/rollback all operations when it is necessary. See the sample from the Local Transaction topic.

This article describes the way to manipulate transactions from your .NET code (without envolving PL/SQL transactions) - this is the most common case of working with transactions. Concerning your task, you can choose the type of transaction to implement - local or distributed. A transaction considered to be a local transaction when it is a single-phase transaction and is handled by the database directly. A distributed transaction is a transaction that affects several resources, it is coordinated by a transaction monitor and uses fail-safe mechanisms (such as two-phase commit) for transaction resolution.

Note Note:
Distributed transactions are supported only for projects targeting full .NET Framework.

Note: Be aware, promotable transactions used in SQL Server are not supported by Oracle, and implementation of distributed transactions differs in the OCI and Direct modes. Also take into account that TransactionScope (distributed transactions) is completed only on its disposing.

Local Transactions

dotConnect for Oracle has its OracleTransaction object for performing local transactions. OracleTransaction is used when several operations on one connection object should be performed as one transaction. The application creates a OracleTransaction object by calling BeginTransaction on the OracleConnection object. All subsequent operations associated with the transaction (for example, committing or aborting the transaction), are performed on the OracleTransaction object. The correlation between OracleConnection and OracleTransaction is always 1:1. As a result, only one OracleTransaction can be created for a separate OracleConnection in one moment of time.

Example:

The following example creates an OracleConnection and an OracleTransaction. It also demonstrates how to use the BeginTransaction, Commit, and Rollback methods.

C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  OracleCommand myCommand = new OracleCommand();
  OracleTransaction myTrans;
  // Start a local transaction
  myTrans = myConnection.BeginTransaction(System.Data.IsolationLevel.ReadCommitted);
  // Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans;
  myCommand.Connection = myConnection;
  try
  {
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myTrans.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
Visual Basic Copy Code
Public Sub RunOracleTransaction(ByVal myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  Dim myCommand As New OracleCommand
  Dim myTrans As OracleTransaction
  ' Start a local transaction
  myTrans = myConnection.BeginTransaction(System.Data.IsolationLevel.ReadCommitted)
  ' Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans
  myCommand.Connection = myConnection
  Try
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myTrans.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myTrans.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Distributed Transactions in the OCI mode

If you want to put operations that are executed on several connection objects in the same distributed transaction, it is necessary to enlist them in TransactionScope. It can be done with the Enlist parameter of connection string or with the EnlistTransaction method of OracleConnection class.

The OCI mode has full support of TransactionScope with two-phase commit.

The System.Transactions.TransactionScope class makes a code block transactional by implicitly enlisting connections in a distributed transaction. You must call the Complete method at the end of the code block marked by the TransactionScope. The Dispose method is invoked when program execution leaves a code block, causing the transaction to be discontinued if the Complete method is not called. If an exception has been thrown that causes the code to leave scope, the transaction is considered to be discontinued.

It is recommended that you employ a using block to ensure that the Dispose method is called on the TransactionScope object when the using block is exited. Failure to commit or roll back pending transactions can seriously degrade performance because the default time-out for the TransactionScope is one minute. If you do not use a using statement, you must perform all work in a Try block and explicitly call the Dispose method in the Finally block.

If an exception occurs within the TransactionScope, the transaction is marked as inconsistent and is abandoned. It is rolled back when the TransactionScope is disposed. If no exception occurs, participating transactions commit.

Example:

The following example demonstrates the usage of TransactionScope. It is necessary to add reference to the System.Transactions.dll assembly to use the System.Transactions namespace.

C#csharp Copy Code
using (TransactionScope transScope = new TransactionScope())
{
    using (OracleConnection connection1 = new
       OracleConnection(connectString1))
    {
        // Opening connection1 automatically enlists it in the
        // TransactionScope as a distributed transaction.
        connection1.Open();

        // Do work in the first connection.

        // Assumes conditional logic in place where the second
        // connection will only be opened as needed.
        using (OracleConnection connection2 = new
            OracleConnection(connectString2))
        {
            // Open the second connection, which enlists the
            // second connection to a full distributed transaction.
            connection2.Open();

            // Do work in the second connection.
        }
    }
    //  The Complete method commits the transaction.
    transScope.Complete();
// The result of transaction will be available at the database after
// disposing TransactionScope
}
Visual Basic Copy Code
Using transScope As New TransactionScope()
    Using connection1 As New OracleConnection(connectString1)
        ' Opening connection1 automatically enlists it in the
        ' TransactionScope as a distributed transaction.
        connection1.Open()

        ' Do work in the first connection.

        ' Assumes conditional logic in place where the second
        ' connection will only be opened as needed.
        Using connection2 As New OracleConnection(connectString2)
            ' Open the second connection, which enlists the
            ' second connection and promotes the transaction to
            ' a full distributed transaction.
            connection2.Open()

            ' Do work in the second connection.

        End Using
    End Using

    ' The Complete method commits the transaction.
    transScope.Complete()
' The result of transaction will be available at the database after
' disposing TransactionScope
End Using

Distributed Transactions in the Direct mode

The Direct mode connections also are enlisted in distributed transaction. But there will be only emulation of TransactionScope support in this case, because two-phase commit is not supported in the direct mode. A separate OracleTransaction will be created for every connection in its scope. And these OracleTransaction's work is synchronized not completely:

  • If operations on one of enlisted connections raise exception, you can easily handle this situation with try...catch block. Just place TransactionScope.Complete() to the last line of your try block. So the code execution in the case of any exception will not reach the Complete() line, and distributed transaction will not be commited. On the other side, the following scenario can happen: all operations on two enlisted to TransactionScope connections are successfully executed without exceptions, but if on disposing TransactionScope (when operations are actually committed to the database) the first OracleTransaction fails (e.g., server failure or killing the database session), the second OracleTransaction still is committed anyway, and TransactionScope is "successfully" completed (without its 1-st OracleTransaction).
  • The changes of one OracleTransaction will NOT be visible in other OracleTransactions of current TransactionScope. For example, the 70-th record will be inserted and updated within TransactionScope in the OCI mode, but only inserted (not updated) in the direct mode:
C#csharp Copy Code
using (TransactionScope ts = new TransactionScope()) {
    using (OracleConnection connection = new OracleConnection(connStr)) {
        connection.Open();
        OracleCommand command = connection.CreateCommand();
        command.CommandText = "insert into dept(deptno,dname,loc) values (70,'Development','London')";
        command.ExecuteNonQuery();
    }
    using (OracleConnection connection2 = new OracleConnection(connStr)){
        connection2.Open();
        OracleCommand command2 = connection2.CreateCommand();
        command2.CommandText = "update dept set loc='New York' where deptno=70";
        command2.ExecuteNonQuery();
    }
    ts.Complete();
}
Visual Basic Copy Code
Using ts As New TransactionScope()
    Using connection As New OracleConnection(connStr)
        connection.Open()
        Dim Command As OracleCommand = connection.CreateCommand()
        Command.CommandText = "insert into dept(deptno,dname,loc) values (70,'Development','London')"
        Command.ExecuteNonQuery()
    End Using
    Using connection2 As New OracleConnection(connStr)
        connection2.Open()
        Dim Command2 As OracleCommand = connection2.CreateCommand()
        Command2.CommandText = "update dept set loc='New York' where deptno=70"
        command2.ExecuteNonQuery()
    End Using
    ts.Complete()
End Using

See Also

Entity Framework Support | Entity Framework Tutorial


Licensing

Licensing
support@devart.com

This topic provides technical details on embedding license information into your applications. This is a special resource that must be present in every application that uses dotConnect for Oracle.

Note Note:
License information discussed in this topic is not same thing as license for using dotConnect for Oracle. License purchased on our site allows you, your team, or your company to use dotConnect for Oracle. For information on how to purchase license for using dotConnect for Oracle please refer to topic Ordering.

The article consists of following sections:

  • General Information
  • Adding License Automatically
  • Adding License Manually
  • Class Libraries Support
  • Licensing ASP.NET Applications
  • Licensing Compact Framework Projects
  • DbProviderFactory Notes
  • Compiling License Manually
  • Licensing Mono Projects
  • Troubleshooting

General Information

dotConnect for Oracle uses .NET component licensing. To build an application dotConnect for Oracle requires valid license. If no license is available, dotConnect for Oracle does not work.

License information is a specially formed embedded resource. Usually you do not have to care about embedding license in your application. When you install dotConnect for Oracle, the system is configured so that licensing is done transparently. End-users of your software do not require any additional license.

dotConnect for Oracle includes License Wizard that helps you configure license information. The wizard analyzes the current project, informs you about problems found, and performs some actions needed to fix the problems.

License Information dialog box

To invoke the wizard choose Oracle | License Information from the Visual Studio Tools menu. Then click the Fix buttons in the dialog and follow the wizard's instructions. In most cases this is enough to configure .NET component licensing.

The following table helps get started quickly with dotConnect for Oracle licensing. Find your type of application and follow links to corresponding sections of the article.

Diagram | Explanation
licensing scheme - direct | This is general case of licensed .NET Framework application. Whatever the type of application you develop, read carefully sections Adding License Automatically and Adding License Manually.
licensing scheme - class libraries | These two diagrams show how you can use dotConnect for Oracle through a class library. In addition to Adding License Automatically and Adding License Manually please read section Class Libraries Support.
licensing scheme - class libraries with license
licensing scheme - ASP.NET direct | These are two modes of accessing dotConnect for Oracle within ASP.NET application. In addition to Adding License Automatically and Adding License Manually please read section Licensing ASP.NET Applications.
licensing scheme - ASP.NET with separate file
licensing scheme - provider installed | Some applications that have no licensing information embedded, and use DbProviderFactory to operate dotConnect for Oracle, require the product installed on the computer. Refer to section DbProviderFactory Notes for more information.

Adding License Automatically

License is automatically added to project when you drop a OracleConnection component from Toolbox onto a form designer.

Under .NET Compact Framework, in the moment of compilation license information is automatically added if the dotConnect for Oracle addin for Visual Studio is running.

Adding License Manually

In some cases you have to manually add license. It is necessary for console applications, class libraries, and existing projects initially built with dotConnect for Oracle version that did not use component licensing, that is, 3.00 and older. In this case perform the following steps:

  • Create a file named licenses.licx, if this file does not exist yet.
  • Open the file with a text editor and place this line inside:
    Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle
  • Save the file and add it to your project.
  • Make sure it is embedded as a resource.

If IDE fails to compile the license automatically, you can do it yourself as described in section Compiling License Manually.

Class Libraries Support

In case where it is impossible to put the license information straight to executable file, dotConnect for Oracle allows you to create class libraries that can be used with certain executable files. To do this perform the following steps:

  1. Create and setup file named licenses.licx as described above.
  2. Create a text file named licenses.config and place it next to licenses.licx.
  3. In this file enumerate names of executable files that will work with the library, every file name on separate line, for example:

    MyApplication.exe
    MyAnotherApp.exe
    ExtraTool.exe

You do not have to add the file licenses.config to project.

Licensing a library without specifying the executables that will use it is possible by agreement with Devart. For details on this, please mail to support@devart.com or sales@devart.com.

Licensing Web Projects

There are two types of web projects depending on the type of licensing.

  1. First, Web Application Project (Web Forms, MVC, Web API, etc.) are compiled entirely, so that web server does not perform any compilation on demand. In this case licensing web applications is same as licensing common Class Library applications.
  2. Second, there are Web Site Projects, when source files are uploaded to server, where they are compiled on user request. In this case you should deploy a special assembly App_Licenses.dll to the Bin directory of your site for the Web Site projects. To create this assembly, right-click the licenses.licx file in the Solution Explorer view and then click Build Runtime Licenses. The required assembly will be created automatically. Note that the corresponding shortcut menu command is available when the licenses.licx file is located in the root folder of the site.

Licensing Compact Framework Projects

For .NET Compact Framework the Visual Studio add-in automatically embeds all required information into every assembly that uses Devart.Data.Oracle.dll library. Class libraries are supported automatically.

If the license fails to be added to a project, you can add and compile it manually. Note that there is no license compiler from Microsoft for .NET Compact Framework. You can request the compiler from Devart support team.

There is a known problem with the .NET Compact Framework. A "License not found" exception can be thrown by OracleDataAdapter.Fill method in case when OracleConnection had never been opened. To avoid the problem just open (or open and close) any connection before calling the OracleDataAdapter.Fill method.

DbProviderFactory Notes

Applications that call dotConnect for Oracle through DbProviderFactory require registration in DbProviderFactory. This registration can be performed either by launching installer of dotConnect for Oracle with the Minimal install type (the licenses.licx file is not required in this case), or manually as it is described in the Deployment topic. DbProviderFactory support allows using dotConnect for Oracle in SQL Server 2008/2012 Business Intelligence Solutions.

Compiling License Manually

The license resource cannot be compiled automatically when your project does not have reference to Devart.Data.Oracle.dll or dotConnect for Oracle is not installed on your build server. This section describes how to compile the required resource manually.

Generate licensing resource file using following command line:
"%Compiler Path%\lc.exe" /target:MyApplication.exe /complist:licenses.licx /i:"%Assembly Path%\Devart.Data.Oracle.dll"
Where

  • %Compiler Path% is a path to appropriate lc.exe file (for example, C:\Program Files\Microsoft.NET\SDK\v2.0\Bin);
  • MyApplication.exe is name of your target executable file;
  • licenses.licx is a text file described earlier in this topic;
  • %Assembly Path% is location of Devart.Data.Oracle.dll assembly
Substitute these arguments with actual values. If the license compiler fails with an error, try adding full assembly specification to licenses.licx file, for example:
Devart.Data.Oracle.OracleConnection, Devart.Data.Oracle, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701

License compiler will generate 'MyApplication.exe.licenses' resource file. You should add this file to your project as an embedded resource. Note that you should not add licenses.licx to the project because the *.licenses file already includes all the necessary license information.

If the default namespace of your project is not an empty string, it must be the same as the target assembly name (in this case - 'MyApplication'). IDE adds the default namespace to the resource name when building application, so you have to rename 'MyApplication.exe.licenses' to 'exe.licenses' before adding it to project. If the default namespace of your project is not set (is an empty string) you do not have to rename the resource file before adding it to project.

You can also generate the license resource manually for the class library assembly (*.dll) in the same way. Just place licenses.config in the folder with your licenses.licx (and change /target:MyApplication.exe to /target:YourClassLibraryName.dll).

Licensing Mono Projects

Since automatic license generation and embedding is not possible with Mono you have to add and compile license manually as described above.

Troubleshooting

When something's wrong with license information you get one of the following exceptions on connecting to server:

Exception text Possible reasons and what to do

License not found...

This generally indicates that license information could not be found, or you try to apply it in some way that does not suit the kind of application. For example:

  • File licenses.licx, required for dotConnect for Oracle to function properly, could not be found.
  • File licenses.licx is not added as embedded resource.
  • File App_Licenses.dll not found in ASP.NET 2.0 applications.

To fix the problem determine type of your application and read corresponding section in this topic.

This exception can be thrown by OracleDataAdapter.Fill method under .NET Compact Framework, in case when OracleConnection had never been opened. To avoid the problem just open (or open and close) any connection before calling the OracleDataAdapter.Fill method.

License not valid...

This means that license information was found but it is incorrect. It usually happens in the following cases:

  1. The project was earlier compiled with old or trial version of dotConnect for Oracle.
  2. File licenses.config used by a class library does not refer to launched executable.
  3. The App_Licenses.dll belongs to other application or needs to be recompiled.
  4. Something's wrong with the operating system or installation of dotConnect for Oracle.
  5. You are building your project on a computer with no dotConnect for Oracle installed (for example, it is not installed on your build server), and the compiled license resource is not added to the project.

If you encounter one of these problems, do the following (the numbers of actions correspond to the numbers of the problems in the above list):

  1. Delete all files from the bin and obj folders and rebuild the project.
  2. Specify the executable in the licenses.config file.
  3. Rebuild App_Licenses.dll for the current application.
  4. Perform the following steps:
    1. uninstall dotConnect for Oracle;
    2. remove all Devart.* and policy.*.Devart.* files from the GAC;
    3. clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
    4. re-install dotConnect for Oracle.
  5. There are two ways to solve the problem:
    1. Install dotConnect for Oracle on the computer where you build your project.
    2. Compile the license resource (*.licx file) on a computer, where dotConnect for Oracle is installed, and then add the result file (*.licenses) to your project as an embedded resource. After this you can build your project on a computer with no dotConnect for Oracle installed.

If this does not help, send a small compiled binary with sources to our support address, so we can investigate the problem in more details.

Sorry, your trial period has expired...

This exception indicates that you used trial version of dotConnect for Oracle, and the 30 days trial period is expired. To continue using dotConnect for Oracle register it or uninstall from your machine.

You can also see this message if the application was compiled with registered version of dotConnect for Oracle, but deployed with trial assembly Devart.Data.Oracle.dll. If this is the case, replace old files with latest assemblies.


Deployment

Deployment
support@devart.com

To deploy applications written with dotConnect for Oracle you should register run-time assemblies Devart.Data.Oracle.dll and Devart.Data.dll at Global Assembly Cache (GAC) for appropriate framework or place them in the folder of your application (Bin folder for web projects). These two assemblies should be available in all applications written with dotConnect for Oracle. Make sure that your project contains the license resource as it is described in Licensing.

Another way to install the needed *.dll is to launch the dotConnect for Oracle setup program and choose "Minimal installation". Note that according to End-User License Agreement this is the only install you can do on target machine. You must not distribute any other part of dotConnect for Oracle.

Applications written with dotConnect for Oracle may not contain the license resource when they are deployed on the target machine where dotConnect for Oracle is installed with "Minimal" option.

ASP.NET Applications

When deploying ASP.NET applications, the following additional assemblies may be needed:

  • Devart.Data.Oracle.Web.dll - in case if the OracleDataSource component or ASP.NET providers are used;
  • App_Licenses.dll - if the application is a non-precompiled web site.

When your code uses dotConnect for Oracle via a factory-based class, you should register configuration information in the DbProviderFactories section of the *.config file to inform your environment about the existence of the provider factory. The provider factory is described either in machine.config (globally), in app.config or in web.config (just for your application), but not in both files. This is done as follows:

<system.data>
  <DbProviderFactories>
    <remove invariant="Devart.Data.Oracle" />
    <add name="dotConnect for Oracle" invariant="Devart.Data.Oracle" description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
  </DbProviderFactories>
</system.data>

Replace 8.4.215.0 here with your actual version.

When deploying ASP.NET applications using dotConnect for Oracle SimpleMembership providers, you need to deploy the Devart.Data.Oracle.Web.dll assembly for .NET Framework 4, not the one for .NET Framework 2.0. It is located in the Web\ASP.NET 4 subdirectory of the dotConnect for Oracle installation directory (by default, from Program Files\Devart\dotConnect\Oracle\Web\ASP.NET 4) and has the revision number 4 in its version.

When deploying ASP.NET applications using ADO.NET implementation of ASP.NET Identity via dotConnect for Oracle, you need to deploy the Devart.Data.Oracle.Web.Identity.dll assembly.

When deploying ASP.NET applications using Entity Framework implementation of ASP.NET Identity via dotConnect for Oracle, you need to deploy the Devart.Data.Oracle.Entity.EF6.dll assembly. It is located in the Entity\EF6 subfolder of the dotConnect for Oracle installation folder.

Required Permissions

The following permissions are required by dotConnect for Oracle as partially trusted code (this is actual for web projects):

  • in Direct mode - medium trust plus SocketPermission;
  • in OCI mode - medium trust plus ReflectionPermission, EnvironmentPermission for PATH environment variable, FileIOPermission for Oracle Client.

Since dotConnect for Oracle uses standard Microsoft .NET licensing licensing, it additionally requires RegistryPermission. And though SecurityPermission is granted by default when using medium trust level, the set of flags for the SecurityPermission must be extended. You need to add the following flags: Assertion, SkipVerification, UnmanagedCode, and SerializationFormatter.

For the information on how to do this see Configuring Trust Level for Web Applications.

Entity Framework and LightSwitch Projects

When deploying Entity Framework (or LightSwitch) projects, it is necessary to:

  1. First, you need to check if the Devart.Data.Oracle.Entity.EF<Version>.dll assembly is available for your application. The <Version> here is the version of Entity Framework used in your application. For Entity Framework v1 the assembly is called Devart.Data.Oracle.Entity.EF1.dll, for Entity Framework v4 it is Devart.Data.Oracle.Entity.EF4.dll, for Entity Framework v5 or v6 it is Devart.Data.Oracle.Entity.EF5.dll or Devart.Data.Oracle.Entity.EF6.dll respectively. For Entity Framework Core it is Devart.Data.Oracle.Entity.EFCore.dll. The assembly should reside in the application's folder or in GAC.

  2. If you use Code-First Migrations feature of Entity Framework v4 or Entity Framework v5, you also need to check if the Devart.Data.Oracle.Entity.Migrations.EF<Version>.dll assembly is available for your application. For Entity Framework v6 this assembly is not needed.
  3. If you use Entity Framework Spatials and NetTopologySuite, you also need to check if the Devart.Data.Oracle.Entity.Spatials.EF<Version>.dll assembly is available for your application.
  4. Inform your environment about the provider factory existence (add the entry to the DbProviderFactories section as it is described above).

You can find these assemblies in the Entity folder in the provider installation folder, in the subforder, corresponding to the Entity Framework version necessary.

If you are registering the provider in the machine.config file, please take into account the Entity Framework version. Entity Framework v1 - specific applications require an entry in the .NET Framework 2.0 configuration file, and Entity Framework v4 and later - specific applications should be registered in the .NET Framework 4.0 configuration file. For Entity Framework Core there is no need to register the provider in the machine.config file.

You can also read Microsoft's Deployment Considerations on ADO.NET Entity Framework.

Deploying LightSwitch applications is described here.

LinqConnect Projects

To deploy applications written with LinqConnect support in dotConnect for Oracle, besides deploying the general assemblies you should register run-time LinqConnect assemblies Devart.Data.Oracle.Linq.dll and Devart.Data.Linq.dll at Global Assembly Cache (GAC) or place them in the folder of your application (the Bin folder for web projects).

Workflow Foundation Projects

To deploy applications using Oracle Workflow Instance Store or Oracle Workflow Tracking, in addition to the general assemblies, you also need to deploy the Devart.Data.Oracle.WorkflowFoundation.dll assembly.

Sync Framework Projects

To deploy applications using Sync Framework, in addition to the general assemblies, you also need to deploy the Devart.Data.Synchronization.dll and Devart.Data.Oracle.Synchronization.dll assemblies. Such application also require the Sync Framework itself installed.


Documentation

Documentation
support@devart.com

The dotConnect for Oracle reference documentation contains detailed provider-specific information. Many of the dotConnect for Oracle classes inherit or implement members from other .NET Framework classes or interfaces. The provider documentation includes a summary of all members within each of these classes. For more detailed information about a specific inherited member, see the appropriate topic in the Microsoft .NET Framework SDK. For information about using .NET data providers or an ADO.NET DataSet, see "Accessing Data with ADO.NET" in the .NET Framework SDK documentation.

dotConnect for Oracle documentation is fully integrated into Visual Studio environment and available from Tools | Oracle menu or as dynamic help.

dotConnect for Oracle help system provides information for IntelliSense and supports class members description of Properties window.

You can also download documentation in CHM format from our site on dotConnect for Oracle download page.


Samples

Samples
support@devart.com

This section describes dotConnect for Oracle samples.

  • Samples Overview

    Contains overview of dotConnect for Oracle sample projects.

  • CRM_Demo Description

    Contains description of the dotConnect for Oracle sample database.


Samples Overview - dotConnect for Oracle

Samples Overview
support@devart.com

dotConnect for Oracle samples are divided into 6 categories: General demos, Entity Framework samples, LinqConnect samples, Web demos, Web Service sample, and CRM demo project. You can open all of them from the Start menu group. The General samples demonstrate how to work with components, classes, technologies, and also the usage of individual data access features, Web samples show how to use dotConnect for Oracle in ASP.NET environment, and the CRM demo shows some good design and implementation practices that you can employ with dotConnect for Oracle.

Note: in the Standard, Mobile, and Express editions of dotConnect for Oracle some samples are not available.

General Samples

General samples are demos that demonstrate working with dotConnect for Oracle classes, components, and technologies.

Use the Start menu group to open General samples in the language you prefer. You can also run the compiled binary, which incorporates all General samples and provides quick access to C# source, necessary SQL scripts, and run-time state.

Sample | Description
Alerter | This sample shows how to transfer messages between connections or client applications with the OracleAlerter component. Note: this sample is available only in Professional Edition.
Array | This sample project demonstrates working with data of Oracle VARRAY data type. The sample uses OracleDataReader to get OracleArray object that represents an Oracle collection (VARRAY).
ArrayBind | This sample project demonstrates usage of the array bind feature that allows execution of several SQL statements at once.
Blob | This sample project demonstrates working with Oracle BLOB data type. The sample shows how to get binary data from the table, change BLOB fields using UPDATE statement, and insert a new record by executing a stored procedure with a parameter of BLOB type.
Clob | This sample project demonstrates working with Oracle CLOB data type. The sample shows how to get characters stream from the table, change CLOB fields using UPDATE statement, and insert a new record by executing stored procedure with a parameter of CLOB type.
Crystal | This sample project demonstrates using dotConnect for Oracle for generating reports with Crystal Reports. Be aware that this project requires Crystal Reports, which is no longer included with Visual Studio 2010 and higher. You have to download and install Crystal Reports separately: http://scn.sap.com/docs/DOC-7824 . Then update references to the CrystalDecisions.* assemblies and rebuild the solution.
CursorField | This sample project demonstrates how to work with CURSOR type fields in queries. The sample uses OracleDataAdapter to fill a dataset with data from such queries. The data of CURSOR type fields is represented at dataset as a separate table connected by master-detail relation with the base table.
DataReader | This sample project demonstrates using OracleDataReader class to obtain data from a query. The sample executes SQL statement at the OracleCommand and gets OracleDataReader to retrieve data.
DataSet | This sample project demonstrates using untyped dataset with dotConnect for Oracle to review and update data. The sample uses OracleDataAdapter to fill a dataset and post updated data to Oracle database. OracleDataAdapter uses OracleCommandBuilder class to automatically generate SQL queries for INSERT/UPDATE/DELETE operations.
DbDataTable | This sample project demonstrates data mapping from Oracle tables and paginal access. The sample uses OracleDataTable component to access data from a table and display this data in the DataGrid control. Note: the sample is available only in Professional Edition.
Dependency | The Dependency demo project illustrates how to use the data dependency technique. The sample watches for some tables in the database. As you modify their data, the name of the table being edited is shown in a list. Note: this sample is available in Professional and Standard Edition.
Geometry | This sample project demonstrates using OracleObject class with custom Oracle types.
Loader | This sample project demonstrates working with the OracleLoader component. OracleLoader's work is based on generation of INSERT statements that insert data by several rows for one time. Note: this sample is available only in Professional Edition.
Long | This sample project demonstrates working with Oracle LONG data type. The sample shows how to get character strings from the table, change LONG fields using an UPDATE statement, and insert a new record by executing a stored procedure with a parameter of LONG type.
MasterDetail | This sample project demonstrates setting master-detail relation at the untyped dataset. The sample fills two tables in a dataset using OracleDataAdapter and sets master-detail relation between them.
MetaData | This sample project shows how to retrieve information about databases, tables, columns, users, and so on. The only method used for these tasks is GetSchema.
MultiCursor | This sample project demonstrates filling DataSet with several tables from an OracleCommand that contains a number of parameters of REF CURSOR type.
NestedTable | This sample project demonstrates how to work with nested tables using dotConnect for Oracle. The sample fills a dataset with data from a nested table in a query. The nested table data is represented as a separate table associated with the base table. This is similar to representing a query with CURSOR fields.
Object | This sample project demonstrates using Oracle object types with OracleDataReader component. The sample gets an OracleObject instance from the OracleDataReader, demonstrates working with the attributes and getting attributes values.
ObjectDataSet | This sample project demonstrates how to work in dotConnect for Oracle with untyped dataset to retrieve and update data of Oracle object type. Object attributes are represented at dataset as separate DataTable columns. The sample uses OracleDataAdapter to fill dataset and flush updated data to the server.
ObjectView | This sample demonstrates ability to show OracleObject in a DataGrid component. It illustrates how to show an OracleObject as a field of a table and as a separate object. Note: this sample is available only in Professional Edition.
Pictures | This sample project demonstrates using dotConnect for Oracle for working with BLOB objects as graphics. The sample demonstrates how to retrieve binary data from Oracle database and display it at the monitor, load and save pictures into the file and the database.
Pipe | This sample demonstrates usage of OraclePipe component that allows transferring data between connections or client applications. The OraclePipe component represents Oracle pipes supplied by DBMS_PIPE package. Note: this sample is available only in Professional Edition.
PlSqlTable | This sample project demonstrates working with parameters of PL/SQL Table type, which is similar to arrays in programming languages such as C#.
Queue | This sample illustrates usage of the Oracle Advanced Queuing (AQ) technology. Note: this sample is available only in Professional Edition.
RefCursor | This sample project demonstrates filling a DataSet from the parameter of REF CURSOR type by calling Fill method of an OracleDataAdapter object.
Refs | This sample project demonstrates using REF data type in queries.
StoredProc | This sample project demonstrates how to execute a stored procedure and view modified data.
Table | This sample project demonstrates data mapping from Oracle tables. The sample sets CommandType property of OracleCommand to TableDirect to access data from the table.
Transactions | This sample project demonstrates working with Oracle transactions in dotConnect for Oracle. The sample demonstrates how to get an OracleTransaction object from an OracleConnection object, how to commit or rollback a transaction.
XMLType | This sample demonstrates how to manage XML data in Oracle tables.

Note: before running sample projects from an IDE you need to execute commands from Program Files\Devart\dotConnect\Oracle\Samples\tables.sql to create test data. If C++ projects fail to open, it is possible that you do not have the assemblies Devart.Data.Oracle.dll and Devart.Data.dll in GAC or project's folder.

Web Samples

Run InstallWebTables.sql script by default located in the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET 2\InstallWebTables.sql. Use the Start menu group to open Web samples in the language you prefer.

Sample | Description
AjaxDemo | This sample demonstrates data binding and editing in an asynchronous way. The sample uses OracleDataSource component in conjuction with ASP.NET AJAX Update Panel. Note: this sample is available only in Professional Edition.
CRM | This sample demonstrates how OracleDatasource can be used in the complex software product such as CRM (Customer Relationship Management). The sample illustrates how to perform data retrieving and editing in the complex scenario using OracleDataSource. This sample is based on the CRM_DEMO database. Note: this sample is available only in Professional Edition.
DataSource | This sample shows how to use the OracleDataSource component of dotConnect for Oracle. The sample illustrates using of manual paging, auto paging and master-detail techniques with OracleDataSource component. Note: this sample is available only in Professional Edition.
DataSource_devExpress | This sample demonstrates using OracleDataSource with DevExpress ASPxGridView component. The ASPxGridView component uses OracleDataSource to perform asynchronous data retrieving and paging. Note: this sample is available only in Professional Edition.
LoadOnDemand | This sample demonstrates the load-data-on-demand technique with the dotConnect for Oracle components. The sample shows how to use OracleDataSource and ObjectDataSource to retrieve data from DB asynchronously and only on user demand. Note: this sample is available only in Professional Edition.
LoadOnDemand_Telerik | This sample demonstrates load-data-on-demand technique with OracleDataSource component in conjuction with Telerik RadGrid control. Note: this sample is available only in Professional Edition.
Web | A sample on simple usage of dotConnect for Oracle in an ASP.NET application.
WebProviders | This sample shows how to use dotConnect for Oracle with ASP.NET Providers Model. The sample illustrates using of WebPart, WebEvent, SessionState, Membership, Role, Profile and SiteMap providers. The first part of the WebProviders sample illustrates usage of WebParts, SiteMap, WebEvent, and SessionState Providers, and the second - of Membership, Roles, and Profile Providers. Note: this sample is available only in Professional Edition.

Entity Framework Samples

Use the Start menu group to open Entity framework samples in the language you prefer. To run the samples you should have VisualStudio 2008 Service Pack 1 or later and .NET Framework 3.5 Service Pack 1 or later installed.

Besides, to get more experience you can download the separate Entity Framework Query Samples package from our site.

Note: these samples are available only in Professional Edition.

Sample | Description
LinqQueries | This sample shows the ways of executing LINQ to Entities queries.
MasterDetail | This sample shows how to setup master/detail relationship with the possibility of editing and saving bound entities.
SaveChanges | This sample shows data binding, the possibility of editing table entities collection in DataGridView, and saving the changes to database.

Note: before running sample projects from an IDE you need to execute commands from crm_demo.sql to create test data. Oracle database version 9.2.0.4 or higher should be installed on the server.

LinqConnect Samples

LinqConnect samples are an easy way to get started with LinqConnect applications. They demonstrate usage of Entity classes, Language-Integrated Queries, database operations within LinqConnect. These samples are based on the CRM_DEMO database.

Use the Start menu group to open samples in the language you prefer.

Note: these samples are available only in Professional Edition. You can get more detailed information on the LinqConnect samples in the ReadMe file by the following path - Program Files\Devart\dotConnect\Linq\Samples\Readme.html

Web Service

Sample | Description
Server | This sample illustrates creating a web service with dotConnect for Oracle. In the provided web method dotConnect for Oracle classes are used to fill DataSet and return it to a client.
WebClient | This sample demonstrates using of the web service by the web client. The data recieved from web service is shown in GridView control.
WinClient | This sample demonstrates using of the web service by the WinForms client. The data recieved from web service is shown in the DataGridView control.

CRM Demo

CRM (Customer Relationship Management) is a widespread class of projects in which you can encounter many typical tasks of database applications development. This sample shows how these tasks can be resolved in the scope of approaches that are offered by dotConnect for Oracle data access solution for designing and building WinForms applications. By examining the source code of CRM demo you can see how the advanced features of dotConnect for Oracle help you build a centralized data access and storage solution. Particularly, it solves common problems like implementing flexible data binding, passing instances of data access components, controlling database connections, and so on. For more information on the best practices in the area of data access please refer to the General Concepts in Database Application Development section of dotConnect for Oracle documentation.

To see how it works launch the compiled binary from the Start menu. This sample is based on the CRM_Demo database.

Note: this demo is available only in Professional Edition. Also there is similar demo for ASP.NET; more detailed information on it is provided in the Web samples section.


CRM_Demo Description

CRM_Demo Description
support@devart.com

The CRM_Demo database is used in the substantial part of the dotConnect samples. This topic describes its structure. DDL and DML scripts for this database are available here – \Program Files\Devart\dotConnect\Oracle\Samples\crm_demo.sql.

CRM_Demo is a simple database for managing activities of a book store. Such database should contain information about the products available, the book store customers (which mainly are companies, but may be individuals as well), personal contacts, and orders being processed. This information is stored in six tables:

  • Product Categories
  • Products
  • Company
  • Person Contact
  • Order
  • Order Details

The figure below displays a table structure and scheme of CRM_Demo database:

Product Categories

Products (which are books) are classified by several categories (genres and styles). The categories may contain sub-categories and be embedded into major categories. The Product Categories table contains a field for category name and a field for the reference to the parent category (thus the table is self-referential).

Products

The Products table stores book title, reference to its category, price and quantity of a product in the stock. As it was said, our products are books, or rather literature works. Each work may consist of either one or several volumes. This option is determined by the UnitName field which may be set to either 'unit' (for single volumes) or 'parcel' (for multiple volumes) values, and the UnitScale field which specifies the exact number of volumes in a particular work. The last thing about the products is that they can be discontinued, and the price of discontinued products usually is lower. To handle this case the table includes Discontinued and DiscontinuedPrice fields.

Company

The Company table stores an information about customers and shipping contractors of our book store. Companies related to the book store can be either customers or shipping contractors or both. The Company table contains fields for company name, web site, legal or physical addresses, phones and the PrimaryContact field referencing the person who is preferable company contact.

Person Contact

This table stores an information about representatives of the companies that cooperating with the bookstore. Also, this table contains an information about employees of the shipping companies and individuals that purchase books in the bookstore. The table hence should include general contact information, like names, personal and business phones, full address (which can be either home or business), and, if applicable, the reference to the employer company.

Orders

The general information about orders is stored in the Orders table. Those are: references to customer company and person (when the first is null, the customer is an individual, when it is not, the person is a company contact related to this order), order date, ship date, reference to a shipping company, freight cost, and discount. The information about the products ordered is stored in the Order Details table as each order may consist of several books of different titles.

Order Details

Order Details table contains detailed information on what a single order consists of, each record of this table references to the Product table and contains an information about price and quantity products that are ordered. If an order includes several titles, a single row should be created for each title.

The CRM_Demo database is used in the following samples:

  • The CRM_Demo sample which illustrates how to work with typed DataSets
  • Entity Framework Samples
  • LinqConnect samples

See Also

Getting Started | Samples


General Information

General Information
support@devart.com

This section contains general information about dotConnect for Oracle.

  • Overview
  • Features
  • Requirements
  • Compatibility
  • Components
  • Editions
  • Professional Edition with Source Code
  • Comparing Data Providers for Oracle
  • Ordering
  • Getting Support


Overview

Overview
support@devart.com

dotConnect for Oracle, formerly known as OraDirect .NET, is an enhanced data provider for Oracle that builds on ADO.NET technology to present a complete solution for developing Oracle-based database applications. As part of the Devart database application development framework, dotConnect for Oracle offers both high performance native connectivity to the Oracle database and a number of innovative development tools and technologies. dotConnect for Oracle introduces new approaches for designing application architecture, boosts productivity, and leverages database application implementation.

dotConnect for Oracle is a scalable data access solution developed with wide adaptability in mind. It can be successfully used in WinForms, ASP.NET, two-tier, multi-tier applications; within the ASP.NET Provider Model; in conjunction with the Enterprise Library; under .NET Compact Framework, Mono Framework and so on. Depending on the edition you choose, dotConnect for Oracle can be used as a powerful ADO.NET data provider, or an effective application development framework.

dotConnect for Oracle is actively developed and supported by the Devart. If you have questions about dotConnect for Oracle, email the developers at support@devart.com or visit dotConnect for Oracle online at http://www.devart.com/dotconnect/oracle/.

Advantages of dotConnect for Oracle

Wide Coverage of Oracle Features

By providing access to the most advanced database functionality, dotConnect for Oracle allows developers to harness the full capabilities of the Oracle server and optimize their database applications. dotConnect for Oracle stands out as the set of components with the widest support of Oracle functionality. Get a full list of supported Oracle features in the Features topic.

Flexible Connectivity

dotConnect for Oracle offers two connection modes to the Oracle server: connection through the Oracle Call Interface and direct connection over TCP/IP. Applications written with dotConnect for Oracle are easy to deploy, do not require installation of Oracle Client Software, and tend to be faster than those that use other data connectivity solutions.

Optimized Code

The goal of dotConnect for Oracle is to enable developers to write efficient and flexible database applications. The dotConnect for Oracle assemblies are implemented using optimized code and advanced data access algorithms. Components undergo comprehensive performance tests and are designed to help you write thin and efficient product data access layers.

Comprehensive Support for ADO.NET Technology Features

dotConnect for Oracle supports new ADO.NET features and technologies as soon as they are released. This includes base-class-based provider model, provider factories, connection string builder, metadata schemas, asynchronous commands, pooling enhancements, batch update support, provider-specific types, server enumeration, database change notification support and so on. dotConnect for Oracle will continue supporting the newest standards and innovations of the .NET Framework.

Database Application Development Extensions

dotConnect for Oracle has rich set of design time tools that leverage the development process greatly. Particularly, there are convenient design time component editors, wizards and managers for typed Oracle-specific components, toolset for live data binding and much more. dotConnect for Oracle integrates tightly with Visual Studio 2008 - 2015, Delphi, and SQL Server 2008 - 2016 Business Intelligence Solutions. Last, but not least, there is dbForge Fusion for Oracle to design your database schema and manage table data - all within your favorite IDE.

Oracle Advanced Features Support

dotConnect for Oracle has extra components designed to simplify some tasks and support Oracle-specific technologies. Particularly, OracleScript serves to execute series of SQL statements, OracleLoader serves to load external data into Oracle databases with use of Direct Path API, OracleAlerter and OraclePipe transfer messages and data between connections or client applications, and so on. dotConnect for Oracle includes set of classes designed to work with Oracle Advanced Queuing technology.

ADO.NET Entity Framework Support

ADO.NET Entity Framework is a conceptual approach to database application development with focus on objects instead of relational data. The flexible architecture of Entity Framework is made up of well-thought layers and modules. Entity Framework optimizes the development process with object-relational mapping, SQL-based entity query language, and LINQ.

dotConnect for Oracle fully supports the Entity Framework capabilities, which allows you to base your object-oriented applications on Oracle. dotConnect for Oracle includes a wizard that helps you setup model relations, and a set of demos to use as a starting point. All standard Entity Framework samples can be easily ported to dotConnect for Oracle.

LinqConnect Support

Much like Entity Framework, LinqConnect is an entity-oriented data access technology with focus on objects instead of relational data. LinqConnect is easier to start with, it supports more of server features, and adds less complications to your code. LinqConnect is backed up by Entity Developer to visually design the application entity model and database objects.

Both Connected and Disconnected Models

dotConnect for Oracle combines connected and disconnected data access models in single OracleDataTable component, which allows you to design more flexible application architecture and use full power of data binding.

Development and Support

dotConnect for Oracle is a Oracle connectivity solution that has been actively developed and supported since 2002. dotConnect for Oracle comes with full documentation, demo projects, and fast (usually within one business day) technical support by the dotConnect for Oracle development team. Find out more about how to get help or submit feedback and suggestions in the Getting Support topic.

A description of the dotConnect for Oracle components is provided in the Class and Component List.

Key features

  • Direct access mode (without Oracle client)
  • 100% managed code
  • High performance
  • Easy to deploy
  • Supports the latest versions of Oracle server, including Personal and Express editions
  • All Oracle data types support
  • Full Oracle Objects support
  • Comprehensive REF CURSOR support
  • PL/SQL tables and PL/SQL records support
  • .NET Compact Framework support
  • Entity Framework support
  • LinqConnect support
  • Operates in both connected and disconnected models
  • Powerful OracleDataTable component as all-in-one table data access solution
  • Typed OraclePackage component for wrapping PL/SQL packages
  • Auxiliary components for SQL scripts and bulk data transfer
  • Extra data binding capabilities
  • Cross-form components cooperation
  • Ability of monitoring query execution
  • Licensed royalty-free per developer, per team, or per site

For the detailed list of dotConnect for Oracle features refer to the Features topic.


dotConnect for Oracle Features

dotConnect for Oracle Features
support@devart.com

General usability

  • Direct access to server data. dotConnect for Oracle can be used without Oracle Client Software.
  • Real RAD for database applications
  • Fully compliant with ADO.NET
  • 100% managed code
  • Highly usable design time support
  • Easy to deploy

Network and connectivity

  • In Direct mode does not require Oracle Client Software and works directly through TCP/IP
  • Both connected and disconnected data access models
  • Support for setting connection timeout values for Direct mode
  • Database Resident Connection Pooling support
  • OS authentication
  • DBA privileges to open a session with
  • Proxy Authentication support
  • Unicode connections

Compatibility

  • Full support of the latest versions of Oracle, including Personal and Express editions
  • Support for all versions of Oracle Clients, including Instant Client
  • Full support for x64 architecture
  • .NET Compact Framework support
  • Mono Framework support
  • Microsoft Visual Studio 2008, 2010, 2012, 2013, and 2015 support
  • CodeGear Delphi 2007 support
  • Embarcadero Delphi Prism support
  • SQL Server 2008 Business Intelligence Solutions support
  • Publisher policy files for versions compatibility

Oracle technology support

  • Oracle Advanced Queuing support
  • Oracle package support with powerful OraclePackage component
  • Ability to manage alerts with OracleAlerter class
  • Ability to use pipes with OraclePipe class
  • Support for Direct Path interface with OracleLoader component
  • Ability to perform SQL and PL/SQL tracing with OracleTrace class
  • Support for Oracle Change notifications functionality of Oracle 10g
  • Oracle Transparent Application Failover support
  • Multiple Oracle Homes support
  • DML array operations support
  • Direct LOB access support
  • Temporary LOB management routines
  • Temporary LOBs for updating LOB fields
  • Miscellaneous LOB management modes
  • OCI Connection Pooling
  • Statement Caching
  • ROWID values retrieval
  • Overloaded stored procedures support
  • OracleGlobalization for managing culture settings

Oracle data types support

  • All Oracle data types support
  • TIMESTAMP and INTERVAL data types support
  • PL/SQL table support
  • PL/SQL records support
  • Support for REF CURSORs, including IN, OUT, and IN/OUT
  • Oracle Object (including NOT FINAL objects) types support
  • Nested table support
  • Objects handling in both connected and disconnected modes
  • XMLTYPE data type support

Performance

  • High overall performance
  • Intelligent fetch block size control
  • Advanced connection pooling
  • High performance batch processing

ADO.NET technology support

  • Full support for ADO.NET Entity Framework v1 - v6
  • Entity Framework Core support
  • Server enumeration
  • Batch update support
  • Extended metadata information retrieval
  • Advanced CommandBuilder component with automatic refresh SQL
  • Enhanced pooling control through connection string
  • Connection string builder
  • Provider factory for generating key data access classes
  • Asynchronous command execution
  • Provider-specific types support
  • Password change API
  • Database Change Notification Support
  • OracleCommand execution cancelling support

ADO.NET Entity Framework

  • Conceptual approach to enterprise development
  • High performance
  • Wide support for LINQ to Entities capabilities
  • Wide support for EntitySQL
  • Full CRUD (Create, Retrieve, Update, Delete) support
  • Wide support for server data types
  • Change tracking support
  • Object data caching
  • Inheritance mapping support (TPH, TPT, and TPCT models)
  • Capability to use stored procedures when manipulating data
  • Stored procedure import support
  • Ability to build database-independent applications
  • Visual Studio EDM Wizard support
  • Reverse engineering of database objects to entity model
  • Visual model creation and code generation with Entity Developer
  • Illustrated tutorial to get started with Entity Framework in 5 minutes

LinqConnect (formerly known as LINQ to Oracle)

  • Easy to use
  • High performance
  • Interchangeable with Microsoft LINQ to SQL
  • Plain CLR classes used (no need to use a common base class)
  • Full CRUD (Create, Retrieve, Update, Delete) support
  • Complex type support [New]
  • Support for different configurable algorithms for primary key generation [New]
  • Automatic configurable compiled query caching [New]
  • Change tracking support
  • Object data caching
  • Data binding support
  • Wide support for LINQ capabilities
  • Wide support for server data types
  • Load on demand (lazy load)
  • Database transactions support
  • Inheritance mapping support (table per hierarchy model)
  • Server-independent interface
  • Visual model creation and code generation with Entity Developer
  • Illustrated tutorial to get started with LinqConnect in 5 minutes

Workflow Foundation Support

  • Oracle Workflow Instance Store support
  • OracleTrackingParticipant class to store tracking records in a Oracle database

Extended data access technologies and functionality

  • Powerful OracleDataTable component for manipulating individual tables or query result
  • Structural representation and editing of Oracle objects
  • NonBlocking mode allows fetching data asynchronously in the background
  • Fill DataSet with several REF CURSOR
  • Fill DataSet with object, array and nested table data
  • On-demand data fetch for data-bound controls
  • Paginal access to query result
  • Server side master-detail relation based on queries
  • Ability to refresh individual records in OracleDataTable component
  • Support for Enterprise Library Data Access Application Block (DAAB)
  • Object-oriented building of SELECT statements
  • Extended warning and error information retrieval
  • Extended interface for processing execution exceptions
  • OracleDataAdapter.Fill method with sequential fetch support
  • Ability to defer fetching of some columns in a resultset
  • Custom Oracle Object mapping with ICustomOracleObject interface

WinForms-specific features

  • Flexible data binding with DataLink component
  • InterForm technology for cross-form components cooperation
  • Oracle Object data binding Support
  • Global position synchronization within a data source

ASP.NET-specific features

  • ASP.NET data providers: Membership, Role, Session State, Profile, Personalization, Site Map, Web Event
  • OracleDataSource web component
  • OracleCacheDependency component to control Cache item dependencies in ASP.NET applications

Script execution

  • Advanced script execution features with OracleScript component
  • Support for executing individual statements in scripts
  • Support for executing huge scripts stored in files with dynamic loading
  • Ability to use standard SQL*Plus tool syntax in scripts

SQL execution monitoring

  • Extended SQL tracing capabilities with OracleMonitor component
  • Support for dbMonitor utility for advanced tracing analysis and control
  • Per-component SQL tracing
  • Optional log output to IDE toolwindows

Design-time enhancements

  • Automatic component registration in toolbox
  • Advanced integration with Visual Studio 2008, 2010, 2012, 2013, and 2015, including Server Explorer, Data Source wizard, TableAdapter configuration, Query Builder and configuring web component OracleDataSource
  • DataSet Wizard to create and edit typed Oracle-oriented datasets
  • DataSet Manager to list and bind datasets in the project
  • DataSet Editor to edit dataset contents
  • Oracle Package Wizard that simplifies working with PL/SQL Packages
  • Oracle Object Wizard that simplifies working with Oracle Objects
  • Advanced design-time component and property editors
  • IntelliSense descriptions for dotConnect for Oracle classes
  • Easy migration from MS OracleClient and ODP.NET with Migration Wizard
  • Syntax highlighting and SQL code completion in design-time editors
  • TableMappings editor
  • Convenient instant data preview and management in design time

dbForge Fusion for Oracle main features

  • Integration with dotConnect for Oracle for enhanced component designers and drag-and-drop features
  • PL/SQL debugger
  • SQL code completion and navigation
  • Visual query builder
  • Database Explorer
  • Visual object editors
  • Database search engine
  • Code template library
  • Security Manager
  • Session Manager
  • Export/Import Wizards

Product clarity

  • Complete documentation sets integrated into Visual Studio and CodeGear Delphi
  • Integration with Visual Studio and MSDN help collections
  • A large amount of helpful demos in C# and VB

Licensing and support

  • Included annual dotConnect for Oracle Subscription with Priority Support
  • Licensed royalty-free per developer, per team, or per site


Requirements

Requirements
support@devart.com

Prior to running Setup to install the dotConnect for Oracle, you must already have the .NET Framework 2.0, 3.0, 3.5, 4.0, 4.5 or 4.6 installed on the computer. If the .NET Framework is not installed, the Setup program for the provider will fail.

To use full set of Oracle features you have to have Oracle Client software installed. If you do not want to install it, you can use Direct mode, in which dotConnect for Oracle communicates with Oracle server without intermediate libraries. In order to use the Direct mode, the operating system must have TCP/IP protocol support installed. For more information about using Direct mode, refer to Using Direct Mode article.


Compatibility

Compatibility
support@devart.com

Oracle server and client

dotConnect for Oracle supports Oracle servers 12c, 11g, 10g, 9i, 8i, 8.0 and 7.3, including Personal and Express editions. dotConnect for Oracle supports both x86 and x64 versions of the following Oracle Clients: 12c, 11g, 10g, 9i, 8i and 8.0

Framework Compatibility

The provider works with .NET Frameworks 2.0, 3.0, 3.5, 4.0, 4.5, 4.6, and .NET Compact Framework. dotConnect for Oracle supports Mono version 2.0 and above. The product is compatible with ADO.NET Entity Framework v1 - v6 and Entity Framework Core. (Oracle server 9.2.0.4 or higher is required for Entity Framework).

IDE Compatibility

dotConnect for Oracle can be used with following integrated development environments:

  • Visual Studio 2015
  • Visual Studio 2013
  • Visual Studio 2012
  • Visual Studio 2010
  • Visual Studio 2008
  • Embarcadero Delphi Prism
  • CodeGear RAD Studio 2007

There are some limitations in Express Editions of Visual Studio. The following features are not available: provider add-in, automatic toolbox components registration and Server Explorer integration. As an exclusion, Visual Web Developer 2008 and 2010 supports Server Explorer features.

RAD Studio 2007 is supported in run time only as these environments have no WinForms designers.

Devart Data Providers Compatibility

Since Devart data providers use a common assembly (Devart.Data.dll), it is necessary to make sure that all installed data providers are compatible.

dbForge Fusion for Oracle Compatibility

The current version of dotConnect for Oracle is compatible with dbForge Fusion for Oracle 3.60. dbForge Fusion for Oracle supports Visual Studio 2010, 2012, and 2013.


Class and Component List

Class and Component List
support@devart.com

This topic presents a brief description of the classes and components included in dotConnect for Oracle. Click on the name of each component for more information.

Core ADO.NET Classes

Class | Description
OracleConnection | Establishes a connection to Oracle database and manages transactions.
OracleCommand | Executes SQL statements and stored procedures at Oracle database.
OracleDataReader | Exposes and reads a forward-only stream of data from Oracle database.
OracleDataAdapter | Populates a DataSet and resolves updates with Oracle database.
OracleTransaction | Starts, commits, or rolls back server transactions.
OracleParameter | Represents input, output, and return value parameters for commands.
OracleException | Represents an error encountered at Oracle database. For an error encountered at the client, dotConnect for Oracle throws a .NET Framework exception.

Complementary ADO.NET Classes

Class | Description
OracleCommandBuilder* | A helper object that automatically generates command properties of OracleDataAdapter* and populates the OracleParameter collection of OracleCommand object.
OracleConnectionStringBuilder | Constructs a connection string by assigning values to appropriate properties.
DbDataSourceEnumerator | Retrieves list of available servers in the network.
OracleDataSource | Enables flexible data binding for ASP.NET applications.

dotConnect for Oracle Advanced Classes

Class | Description
OracleDataTable* | Provides all of the functionality needed to retrieve and manipulate data from an Oracle server data source. Combines connected and disconnected data access models.
OracleDataSet* | Represents typed and untyped Oracle-specific datasets. Bases on OracleDataTable objects to build the schema.
DataLink* | Serves to establish flexible cross-form data binding.

dotConnect for Oracle Toolkit Classes

Class | Description
OracleScript | Serves to execute series of SQL statements.
OracleLoader | Serves to load external data into the Oracle database.
OracleAlerter | Transfers messages between connections or client applications.
OraclePackage | Provides access to packages stored in the Oracle database.
OraclePipe | Transfers data between connections or client applications.
OracleTrace | Traces command execution on Oracle server.
OracleQueue* | Represents named data queue in the Oracle database, manages queue items.
OracleQueueTable* | Manages queue tables in the Oracle database.
OracleQueueAdmin* | Creates, drops, starts, stops, and customizes the Oracle queues.
OracleMonitor | Serves to monitor dynamic SQL execution in applications that use dotConnect for Oracle.

* This class is supported only for full .NET Framework. It is not available in the dotConnect for Oracle .NET Standard 1.3 compatible assemblies.


Editions

Editions
support@devart.com

dotConnect for Oracle is available in six editions: Developer, Professional, Standard, Mobile, Source, and Express.

  • The Standard Edition represents a fully-featured ADO.NET data provider with design time support and advanced classes.
  • The Professional Edition adds more classes, tools, technologies, and integration capabilities, including dbForge Fusion for Oracle, an advanced add-in for designing databases and easily manipulating data and schema objects from your IDE.
  • The Developer Edition combines the whole feature set of Professional Edition and also includes dbForge Fusion for Oracle Standard Edition, an advanced add-in for designing databases and easily managing data and schema objects from your IDE.
  • The Mobile Edition is equivalent to the Standard Edition for .NET Compact Framework.
  • The Professional Edition with Source Code has the same features as the Professional Edition and includes the source code for most of the runtime classes and features.
  • The Express Edition is a free data provider with basic connectivity features.

Also Professional and Mobile editions are offered for evaluation. These versions are fully working during 30 days period.

Feature | Developer | Professional | Standard | Mobile | Express
.NET Framework support | + | + | + |  | +
.NET Compact Framework support |  |  |  | + |
ADO.NET core classes | + | + | + | + | +
Native data types classes and structures | + | + | + | + | +
Direct mode to connect without Oracle Client | + | + | + | + |
OracleScript class | + | + | + | + |
OracleMonitor class | + | + | + | + |
OracleDataTable class | + | + |  |  |
OracleDataSet class | + | + |  |  |
OracleLoader class | + | + |  |  |
OraclePackage class | + | + |  |  |
OracleAlerter class | + | + |  |  |
OraclePipe class | + | + |  |  |
OracleTrace class | + | + |  |  |
OracleDependency class | + | + | + |  |
DataLink class | + | + |  |  |
OracleDataSource component for web applications | + | + |  |  |
Design-time features, including component editors and property editors | + | + | + | + |
Oracle Advanced Queue technology support | + | + |  |  |
Entity Framework support | + | + |  |  |
LinqConnect support | + | + |  |  |
Windows Workflow Foundation support | + | + |  |  |
Advanced Visual Studio 2008 - 2015 integration | + | + | + |  |
ASP.NET providers support | + | + |  |  |
SQL Server Business Intelligence Solutions support | + | + |  |  |
Sync Framework support | + | + |  |  |
Enterprise Library support | + | + |  |  |
InterForm technology | + | + |  |  |
DataSet Manager and Editor | + | + |  |  |
DataSet Wizard | + | + |  |  |
Oracle Package Wizard | + | + |  |  |
Oracle Object Wizard | + | + |  |  |
Migration Wizard | + | + | + |  |
dbForge Fusion for Oracle Standard Edition* | + |  |  |  |
DBMonitor support | + | + |  |  |

* List of environments this feature is compatible with you can find in the dedicated article.


Professional Edition with Source Code

Professional Edition with Source Code
support@devart.com

dotConnect for Oracle Professional Edition with Source Code provides the same functionality as the Professional edition. Additionally it includes the source code for most run-time features of dotConnect for Oracle.

When you install dotConnect for Oracle Professional Edition with Source Code, the sources are placed to the Src subfolder of the dotConnect for Oracle installation folder. By default it is "Program Files\Devart\dotConnect\Oracle\Src". The sources are grouped into corresponding folders and solutions according to the features.

To build the runtime assemblies of dotConnect for Oracle from the sources you will need Visual Studio 2010 or higher. Some assemblies require Visual Studio 2012 or higher. The assembly, containing Entity Framework Core provider functionality requires Visual Studio 2015. You must run Visual Studio as administrator.

Features with No Sources Provided

Sources are not provided for the following features:

  • Entity Developer
  • Other design-time features, such as DataSet tools, Migration Wizard, Package and Object wizards, etc.
  • SSIS support
  • Direct mode *

* Source code for the Direct mode is present in an obfuscated form.

PublicKeyToken in Professional Edition with Source Code

Original Devart assemblies are signed with the Devart's private key. We provide a different strong name key file with the source code for signing the assemblies, compiled from the sources, and thus, the public key token is different too. When you need to register the assemblies, compiled from the sources, you need to use the following public key token: "37048f25b06d6560" instead of the Devart's original "09af7300eec23701", which is used in the samples in our documentation.

This concerns registering ADO.NET provider in the DbProviderFactories section, Entity Framework provider in the project config file, registering ASP.NET providers, registering the provider for Enterprise Library data access block, etc.

Source Solutions List

Solution | Location | Description | VS Version
Devart.Data.8.sln | Src\dotConnect\Common\ | The sources of the Devart.Data.dll assembly. Contains base classes of dotConnect for Oracle. | 2010
Devart.Data.Oracle.8.sln | Src\dotConnect\ | Includes the sources of the Devart.Data.dll and Devart.Data.Oracle.dll assemblies. These assemblies contain general ADO.NET provider features of dotConnect for Oracle. | 2010
Devart.Data.Oracle.Entity.EFv1.sln | Src\Entity\ | The sources of the Devart.Data.Oracle.Entity.EF1.dll assembly for Entity Framework v1. This assembly contains Entity Framework functionality. | 2010
Devart.Data.Oracle.Entity.EFv4.sln | Src\Entity\ | The sources of the Devart.Data.Oracle.Entity.EF4.dll and Devart.Data.Oracle.Entity.Migrations.EF4.dll assemblies for Entity Framework v4. These assemblies contain Entity Framework functionality and Entity Framework Code-First Migrations functionality respectively. | 2010
Devart.Data.Oracle.Entity.EFv5.sln | Src\Entity\ | The sources of the Devart.Data.Oracle.Entity.dll and Devart.Data.Oracle.Entity.Migrations.dll assemblies for Entity Framework v4. These assemblies contain Entity Framework functionality, Entity Framework Code-First Migrations functionality, and Entity Framework Spatials support features for Oracle respectively. | 2012
Devart.Data.Oracle.Entity.EFv6.sln | Src\Entity\ | The sources of the Devart.Data.Oracle.Entity.dll and Devart.Data.Oracle.Entity.Spatials.dll assemblies for Entity Framework v6. These assemblies contain Entity Framework functionality and Entity Framework Spatials support features for Oracle respectively. | 2012
Devart.Data.Oracle.Entity.EFCore.sln | Src\Entity\ | The sources of the Devart.Data.Oracle.Entity.EFCore.dll assembly for Entity Framework Core. This assembly contains Entity Framework Core functionality. | 2015
Devart.Data.Oracle.Linq.sln | Src\Linq\ | The sources of the Devart.Data.Linq.dll and Devart.Data.Oracle.Linq.dll assemblies, containing the LinqConnect functionality for Oracle. | 2010
Devart.Data.Oracle.Synchronization.sln | Src\SyncFramework\ | The sources of the Devart.Data.Synchronization.dll and Devart.Data.Oracle.Synchronization.dll assemblies, containing the Sync Framework support functionality. | 2010
Devart.Data.Oracle.Web.sln | Src\Web\ | The sources of the Devart.Data.Oracle.Web.dll assembly, containing the OracleDataSource component for web applications and ASP.NET 2.0 providers functionality. | 2010
Devart.Data.Oracle.Web.Identity.v1.sln | Src\Web\ | The sources of the Devart.Data.Oracle.Web.Identity.dll assembly, containing ASP.NET Identity 1.0 providers functionality. | 2012
Devart.Data.Oracle.Web.Identity.v2.sln | Src\Web\ | The sources of the Devart.Data.Oracle.Web.Identity.dll assembly, containing ASP.NET Identity 2.0 providers functionality. | 2012
Devart.Data.Oracle.Web.net40.sln | Src\Web\ | The sources of the Devart.Data.Oracle.Web.dll assembly, containing ASP.NET 4.0 providers functionality. | 2010
Devart.Data.Oracle.WF.net45.sln | Src\WorkflowFoundation\ | The sources of the Devart.Data.Oracle.WorkflowFoundation.dll assembly, containing the Oracle Workflow Instance Store and Workflow Tracking support features for .NET Framework 4.5. | 2010
Devart.Data.Oracle.WorkflowFoundation.sln | Src\WorkflowFoundation\ | The sources of the Devart.Data.Oracle.WorkflowFoundation.dll assembly, containing the Oracle Workflow Instance Store and Workflow Tracking support features for .NET Framework 3.0, 3.5, or 4.0. | 2012

See Also

Editions


Comparing Data Providers for Oracle

Comparing Data Providers for Oracle
support@devart.com

This article spotlights the differences between dotConnect for Oracle, Oracle Data Provider for .NET (ODP.NET) 11g, and .NET Framework Data Provider for Oracle.

From the interface point of view, the providers look pretty much alike. The question is, what features are supported and how they are supported. This article does not cover performance issues. For information on performance tests please refer to online article at www.devart.com/dotconnect/oracle/performance.html.

This article consists of the following sections:

  • Features table
  • Detailed Information on Features
    • Connectivity
    • Oracle data types
    • Oracle technologies
    • Toolkit components
    • .NET Framework Features
    • IDE, design time
    • ORM solution support
    • Other features

Features Table

The following table enumerates major useful features that assist development of Oracle applications. Each feature in the table is briefly described later in the article.

Feature | dotConnect for Oracle | MS Data Provider for Oracle | Oracle Data Provider for .NET
Connectivity
Direct mode to access database without Oracle Client | Yes | No | No
Wide client and server versions support | Yes | Partial | Partial
OS authentication | Yes | Yes | Yes
Proxy Authentication | Yes | No | Yes
DBA privileges to open a session with | Yes | No | Yes
Oracle data types
All Oracle data types support | Yes | No | Yes
Support for OBJECT, VARRAY, TABLE, REF types | Yes | No | Yes
Support for Oracle XML type | Yes | No | Yes
Support for REF CURSORs | Yes | Partial | Yes
AnyData type support | Yes | No | No
Oracle technologies
Advanced Queuing (AQ) support | Yes | No | Yes
OracleGlobalization class to manipulate the globalization settings of the session, thread, and local computer. | Yes | No | Yes
Array binding feature | Yes | No | Yes
Transparent Application Failover support | Yes | No | Yes
Working with Oracle homes | Yes | No | Yes
OCI Pooling | Yes | No | No
Distributed transactions using TransactionScope in OCI mode support | Yes | Yes | Yes
Toolkit components
OracleAlerter component to transfer messages between connections or client applications. | Yes | No | No
OraclePipe component to transfer data between connections or client applications. | Yes | No | No
OracleTrace component to trace command execution on Oracle server. | Yes | No | No
OracleScript component to execute scripts | Yes | No | No
OracleLoader component for fast data loading | Yes | No | Yes
OraclePackage component for easy working with PL/SQL packages | Yes | No | No
.NET Framework features
100% managed code | Yes | Yes | No
NET Compact Framework support | Yes | No | Yes
Mono Framework support | Yes | Yes | No
All-in-one component to retrieve and manipulate data from Oracle server data source | Yes | No | No
Advanced connection pooling | Yes | Yes | Yes
Asynchronous execution support | Yes | No | No
Paginal access to query result | Yes | No | No
Ability to retrieve metadata information | Yes | Yes | Yes
Ability of monitoring query and stored procedures execution | Yes | No | No
Data source enumeration | Yes | No | Yes
Batch processing support | Yes | Yes | Yes
Database change notification support | Yes | No | Yes
Provider-specific types support | Yes | Partial | Partial
IDE, design time
Advanced integration with Visual Studio 2008 - 2015 | Yes | Yes | Yes
Cross-form components cooperation in WinForms applications | Yes | No | No
Help integrated into Visual Studio | Yes | Yes | Yes
Advanced design-time editors | Yes | Yes | No
Design-time wizards | Yes | Yes | No
ORM solution support
LinqConnect (LINQ to Oracle) | Yes | No | No
Entity Framework | Yes | No | Partial
Other features
Support for Data Access Application Block in Enterprise Library | Yes | No | No
Workflow Foundation support | Yes | No | No
ASP.NET data providers: Membership, Role, Session State, Profile, Personalization, Site Map, Web Event | Yes | No | No
Easy to deploy | Yes | No | No
Free commercial usage | Yes* | Yes | Yes
Free support for registered users during 1 year | Yes | Yes | No

Detailed Information on Features

Of course, all data providers allow you to connect to the server and perform fundamental operations. So, common classes like OracleConnection, OracleCommand, OracleDataReader or OracleDataAdapter were not enumerated. The table shows that major advanced features are supported by the three data providers. dotConnect for Oracle provides extra components to manipulate data, scripts and packages. Additionaly, dotConnect for Oracle has wider compatibility list and can work without Oracle Client Software installed.

Connectivity

  • Direct mode to access database without Oracle client

    dotConnect for Oracle can use Oracle Call Interface (OCI) to connect to Oracle database server. This is usual way to develop Oracle applications with a third-generation language. However, it requires Oracle client software installed on workstation that is the cause of additional expenses for installation and administration. These problems can be eliminated by using Direct mode of connecting to server. In Direct mode dotConnect for Oracle talks to Oracle server in person, without calling any third party libraries. It allows your application to work with Oracle directly through TCP/IP protocol without involving Oracle client software.

  • Wide client and server versions support

    dotConnect for Oracle supports Oracle servers 12c, 11g, 10g, 9i, 8i, 8.0 and 7.3, including Personal and Express editions. The following Oracle clients are supported: 12c, 11g, 10g, 9i, 8i and 8.0. Applications built with ODP.NET or Microsoft provider can work with fewer range of servers and clients. Only dotConnect for Oracle and ODP.NET support x64 versions of Oracle Client Software.

  • OS authentication

    All data providers support the OS authentication feature.

  • Proxy authentication

    In dotConnect for Oracle and ODP.NET you can take advantage of a useful Oracle feature - proxied connections. This helps to optimize application performance.

  • DBA privileges to open a session with

    Allows database administrators to connect to Oracle database with either SYSDBA or SYSOPER privileges. This is done through an attribute of the ConnectionString property. Microsoft Data Provider for Oracle does not allow opening session with DBA privileges.

Oracle data types

  • All Oracle data types support

    Both dotConnect for Oracle and ODP.NET data providers support all existing Oracle types. For types that do not map directly to .NET Framework types there are special classes and structures. Microsoft Data Provider for Oracle has limited types support.

  • Support for OBJECT, VARRAY, TABLE, REF types

    Both dotConnect for Oracle and ODP.NET data providers allow manipulating OBJECT, VARRAY, TABLE and REF types. Microsoft Data Provider for Oracle does not support these types.

  • Support for Oracle XML type

    Both dotConnect for Oracle and ODP.NET provide convenient toolset to work with XML data in Oracle server. Microsoft Data Provider for Oracle does not handle XML data.

  • Support for REF CURSORs

    Both dotConnect for Oracle and ODP.NET allow sophisticated REF CURSOR management. Microsoft Data Provider for Oracle has limited support for REF CURSORs' advanced features.

  • AnyData type support

    dotConnect for Oracle OracleAnyData class can be used as a table column datatype and lets you store heterogeneous values in a single column. The values can be of SQL built-in types as well as user-defined types.

Oracle technologies

  • Advanced Queuing (AQ) support

    dotConnect for Oracle provides convenient client side wrappers for packages and objects used in Oracle Advanced Queuing. ODP.NET also supports Advanced Queuing. In Microsoft Data Provider for Oracle you have to work with pure DBMS packages.

  • OracleGlobalization class

    This class allows you to obtain and set the Oracle globalization settings of the session, thread, and local computer. The class is present in dotConnect for Oracle and ODP.NET.

  • Array binding

    This feature allows you to execute several INSERT SQL statements with different parameters at single query. Server is accessed only once, which increases speed of update a lot. Microsoft Data Provider for Oracle does not implement array binding.

  • Transparent Application Failover support

    Both dotConnect for Oracle and ODP.NET data providers have capability to automatically reconnect to the database if the connection fails. Microsoft Data Provider for Oracle does not have this capability.

  • Working with Oracle homes

    Both dotConnect for Oracle and ODP.NET data providers can switch between Oracle homes if more than one home is installed on the system. Microsoft Data Provider for Oracle does not have this capability.

  • OCI Pooling

    In dotConnect for Oracle you can use OCI Pooling instead of usual connection pooling. This helps to optimize performance in OCI mode.

  • Distributed transactions using TransactionScope in OCI mode support

    TransactionScope is a wrapper class which allows you to include your code into the transaction. It gives an opportunity to use local and distributed transactions. Distributed transactions are supported by all the compared providers.

Toolkit components

  • OracleAlerter component

    This dotConnect for Oracle component enables you to transfer messages between connections or client applications. There is no counterpart in ODP.NET and Microsoft Data Provider for Oracle.

  • OraclePipe component

    This dotConnect for Oracle component enables you to transfer data between connections or client applications. There is no counterpart in ODP.NET and Microsoft Data Provider for Oracle.

  • OracleTrace component

    This dotConnect for Oracle component helps tracing command execution on Oracle server. There is no counterpart in ODP.NET and Microsoft Data Provider for Oracle.

  • OracleScript component

    This dotConnect for Oracle component serves to execute series of SQL statements separated by special symbols, like SQL*Plus scripts. There is no counterpart in ODP.NET and Microsoft Data Provider for Oracle.

  • OracleLoader component

    This dotConnect for Oracle component serves to load external data into the Oracle database. It uses DirectPath OCI API to give highest possible performance. There is no counterpart in Microsoft Data Provider for Oracle. ODP.NET has a similar OracleBulkCopy component.

  • OraclePackage component

    This dotConnect for Oracle component provides access to procedures and variables of packages stored in the Oracle database. There is no counterpart in ODP.NET or Microsoft Data Provider for Oracle.

.NET Framework Features

The table above makes clear that ODP.NET and Microsoft Data Provider for Oracle have partial support for major .NET features. None of the unsupported by .NET features is vital to development process, but some would aid or speed it up greatly.

  • 100% managed code

    dotConnect for Oracle and Microsoft Data Provider for Oracle are written on pure managed code. They do not depend on any unmanaged library. This allows functioning in a restrictive environment (like on web servers), gives automatic optimization for x64 architecture.

  • .NET Compact Framework support

    Both dotConnect for Oracle and ODP.NET allow creating applications for .NET Compact Framework. Microsoft Data Provider for Oracle does not support it.

  • Mono Framework support

    dotConnect for Oracle allows you to create applications for Mono framework (only Direct connection mode is available on Mono). Oracle Data Provider for .NET does not support it.

  • All-in-one component to retrieve and manipulate data

    The OracleDataTable component in dotConnect for Oracle represents a single object that provides all of the functionality needed to retrieve and manipulate data from an Oracle server data source. It supports both connected and disconnected data access models. There is no counterpart in ODP.NET or Microsoft Data Provider for Oracle.

  • Advanced connection pooling

    All data providers utilize sophisticated mechanisms to optimize interaction with Oracle server. This allows you to balance network load and increase performance significantly.

  • Asynchronous execution support

    dotConnect for Oracle supports asynchronous execution of methods that take most of time in database applications, that is, opening a connection, transferring large blocks of data, and other operations alike.

  • Paginal access to query result

    dotConnect for Oracle allows you to request from server a subset of rows that a statement would return in normal way. This helps to save memory and improve performance by stripping off unnecessary data.

  • Ability to retrieve metadata information

    All data providers support OracleConnection.GetSchema() method, which is standard .NET way to obtain information on schema objects.

  • Ability of monitoring query and stored procedures execution

    dotConnect for Oracle provides OracleMonitor component, which allows you to monitor dynamic SQL execution in applications that use dotConnect for Oracle. There is no analogue in ODP.NET and Microsoft Data Provider for Oracle.

  • Data source enumeration

    This feature enables the application to generically obtain a collection of the Oracle data sources that the application can connect to. The capability is supported by dotConnect for Oracle and ODP.NET.

  • Batch processing support

    This feature allows updating specified number of rows in a single round-trip to the database when working with OracleDataAdapter component. The capability is supported by all data providers.

  • Database change notification support

    This feature enables applications to receive notifications when there is a change in a query result set, schema objects, or the state of the database. Using Database Change Notification, an application can easily maintain the validity of the client-side cache. The capability is supported by dotConnect for Oracle and ODP.NET.

  • Provider-specific types support

    Provider-specific types in its native formats can greatly enhance capabilities of client side applications. All data providers can fetch these types. dotConnect for Oracle also can modify the data in provider-specific format.

IDE, design time

This part of the table demonstrates that dotConnect for Oracle is the only product that supports true RAD development and that ODP.NET has only partial design-time support.

  • Advanced integration with Visual Studio 2008 - 2015

    All data providers support all design-time features introduced in Visual Studio 2008 - 2015, known as Data Designer Extensibility. These features allow you to preview data, customize DataSets and many other operations.

  • Cross-form components cooperation in WinForms applications

    dotConnect for Oracle includes the InterForm technology, which allows components in WinForms applications to collaborate even if they are located on different forms of UserControls. This capability is supported in design time, which enables you to setup data access in a declarative way.

  • Help integrated into Visual Studio

    All data providers integrate the documentation into Visual Studio Help Collection.

  • Advanced design-time editors

    dotConnect for Oracle and Microsoft Data Provider for Oracle have components with greatly enhanced design-time tools, which allow you to setup components in a true RAD manner. There is no counterpart in ODP.NET.

  • Design-time wizards

    dotConnect for Oracle and Microsoft Data Provider for Oracle have wizards that leverage client-side application development. ODP.NET does not have such wizards.

ORM solution support

dotConnect for Oracle includes support for LinqConnect (formerly LINQ to Oracle) and Entity Framework ORM solutions. It comes with its own visual model designer - Entity Developer, which allows not just designing models and generating code for them, but executing LINQ and Entity SQL queries against the model and working with database data.

  • LinqConnect (formerly LINQ to Oracle)

    The technology allows you to employ object-oriented database application development with less efforts and in less time. It is compatible with Microsoft LINQ to SQL but provides wider set of features.

  • Entity Framework

    The latest ADO.NET evolution focuses on raising the level of abstraction from the logical (relational) level to the conceptual (entity) level. For this purpose Microsoft introduces the Entity Framework, designed to simplify data - object conversion and embed data access queries into program code. Devart dotConnect for Oracle supports all release versions of Entity Framework. ODP.NET also supports Entity Framework.

Other features

This section of the table contains other aspects of developing applications with Oracle: interaction with other technologies and licensing questions.

  • Support for Data Access Application Block in Enterprise Library

    dotConnect for Oracle makes it easy to employ Microsoft Patterns and Practices in your application.

  • Workflow Foundation support

    dotConnect for Oracle supports Workflow Instance Store and Workflow Tracking.

  • ASP.NET data providers: Membership provider, Role provider, Session State provider, Profile provider

    dotConnect for Oracle can be used as data source in ASP.NET Provider Model, which allows you to develop DBMS-independent web applications.

  • Easy to deploy

    Applications built with dotConnect for Oracle in Direct mode do not require Oracle Client Software installed on the computer, so it is very easy to deploy the applications. Microsoft Data Provider for Oracle is a part of .NET Framework but requires Oracle Client Software. ODP.NET requires specific Oracle Client Software version so it may be necessary to upgrade the client to newer version.

  • Free commercial usage

    Microsoft Data Provider for Oracle and ODP.NET are freely distributed and can be downloaded from web sites of appropriate vendors. dotConnect for Oracle is a commercial product and requires one-time registration fee, but there is a free Express edition of dotConnect for Oracle, which can be used without restrictions.

  • Free support for registered users during 1 year

    dotConnect for Oracle provides free reliable online support (using web forum or e-mail) for registered users.

See Also

Using dbForge Fusion for Oracle | dotConnect for Oracle articles


Ordering

Ordering
support@devart.com

dotConnect for Oracle is licensed, not sold. Please read carefully our end-user license agreement (EULA) before using the product. You can find the EULA in the installation folder, which is by default
\Program Files\Devart\dotConnect\Oracle\License.rtf,
or in the Start menu (Start\Programs\Devart dotConnect for Oracle\License).

Licensing

There are three types of full licenses for dotConnect for Oracle: Single Licenses, Team Licenses, and Site Licenses.

Single Licenses must be purchased for each developer working on a project that uses dotConnect for Oracle.

Purchasing a Team License automatically gives four developers a Single License.

Purchasing a Site License automatically gives all developers in a company a Single License.

For evaluation purposes only, you may also use dotConnect for Oracle Trial Edition under a temporary Evaluation License, which allows you to use dotConnect for Oracle Trial Edition for a period of 30 days, after which you must either remove all files associated with dotConnect for Oracle or purchase a full license.

To purchase a license for dotConnect for Oracle, please visit www.devart.com/dotconnect/oracle/ordering.html.

Editions

Full licenses can be purchased for the following editions of dotConnect for Oracle: Standard Edition, Professional Edition, Developer Edition, Mobile Edition (for .NET Compact Framework).

The Standard Edition represents a fully-featured ADO.NET data provider with design time support and advanced classes. The Professional Edition adds more classes, tools, technologies, and integration capabilities. The Developer Edition combines the whole featureset with Standard Edition of dbForge Fusion, an advanced add-in for designing databases and easily manipulating data and schema objects from your IDE. The Mobile Edition is equivalent to the Standard Edition for .NET Compact Framework. The Trial Edition corresponds to Professional with trial limitation. A comparison chart can be found here.

Subscriptions

The dotConnect for Oracle Subscription program is an annual maintenance and support service for dotConnect for Oracle users.

Users with a valid dotConnect for Oracle Subscription get the following benefits:

  • Access to new versions of dotConnect for Oracle when they are released
  • Access to all dotConnect for Oracle updates and bug fixes
  • Product support through the dotConnect for Oracle Priority Support program
  • Notification of new product versions

If you have any questions regarding licensing or subscriptions, please see the FAQ or contact sales@devart.com.

Trial Limitations

The dotConnect for Oracle Evaluation License lets you try dotConnect for Oracle Trial Edition for a period of 30 days. There are no functionality limitations in dotConnect for Oracle Trial Edition during the trial period.


Getting Support

Getting Support
support@devart.com

This page lists several ways you can find help with using dotConnect for Oracle and describes the dotConnect for Oracle Priority Support program.

Support Options

There are a number of resources for finding help on installing and using dotConnect for Oracle.

  • You can find out more about dotConnect for Oracle installation or ordering by consulting the Ordering and FAQ sections.
  • You can get community assistance and technical support on the dotConnect for Oracle Community Forum.
  • You can get advanced technical assistance by dotConnect for Oracle developers through the dotConnect for Oracle Priority Support program (see below).

If you have a question about ordering dotConnect for Oracle or any other Devart product, please contact sales@devart.com.

dotConnect for Oracle Priority Support

dotConnect for Oracle Priority Support is an advanced product support service for getting expedited individual assistance with dotConnect for Oracle-related questions from the dotConnect for Oracle developers themselves. Priority Support is carried out over email and has a two business day response policy. Priority Support is available for users with an active dotConnect for Oracle Subscription.

To get help through the dotConnect for Oracle Priority Support program, please send an email to support@devart.com describing the problem you are having. Make sure to include the following information in your message:

  • Your dotConnect for Oracle Registration number.
  • Version of Visual Studio or another IDE you are using.
  • Version of dotConnect for Oracle. To get it, in Visual Studio on the Tools menu point to Oracle and then click About.
  • Version of your Oracle server and client you are using.
  • Version of your operating system.
  • A detailed problem description.
  • If possible, a small test project that reproduces the problem. Please include definitions of database objects and avoid using third-party components.


Development Tools and Features

Development Tools and Features
support@devart.com

This section of the documentation contains topics that help you design powerful, flexible applications with use of dotConnect for Oracle advanced features. The section describes how to employ best the components and technologies that constitute dotConnect for Oracle.

  • General Concepts in Database Application Development

    There are many database application development approaches, each with its own advantages and drawbacks. This topic describes some of database application design patterns applicable with dotConnect for Oracle and lists their tradeoffs to help you decide which one best suits your development needs.

  • Migration from OracleClient to dotConnect for Oracle

    dotConnect for Oracle is the most compatible with OracleClient ADO.NET provider, and it provides the easiest migration from OracleClient. Read this topic if you are migrating your project from it.

  • OracleDataTable Advanced Features

    The OracleDataTable component is one of the most effective tools in the dotConnect for Oracle arsenal. It combines connection to server, command object and data storage in single component with really comprehensive capabilities. In addition, it can accomplish data access tasks in both connected and disconnected models. This topic describes how you can use some of the OracleDataTable features.

  • Using Parameters

    dotConnect for Oracle enhances SQL handling capabilities with usage of parameters in SQL queries. You can make execution of a query or stored procedure very flexible using several simple techniques. This article describes some basics you must be acquainted with when working with parameters in dotConnect for Oracle, as well as parameters synchronization and some nuances related to usage of stored procedures.

  • Oracle Specific Features

    dotConnect for Oracle has extra components designed to simplify some tasks and support Oracle specific technologies. Particularly, OracleLoader serves to load external data into Oracle databases with use of Direct Path API, OracleAlerter and OraclePipe transfer messages and data between connections or client applications, and so on. dotConnect for Oracle includes set of classes designed to work with Oracle Advanced Queuing technology.

  • Working with DataSets

    dotConnect for Oracle leverages managing DataSets in your applications with such tools as DataSet Wizard and DataSet Manager. The DataSet Wizard allows you to create and manage typed provider-specific datasets. The DataSet Manager displays the data sources in your project represented by OracleDataSet and OracleDataTable classes and allows you to create a user interface with data-bound controls by dragging items from the window onto forms in the project.

  • WinForms-Specific Features

    Describes dotConnect for Oracle features, specific for WinForms applications.

  • ASP.NET-Specific Features

    Describes dotConnect for Oracle features, specific for ASP.NET applications.

  • Working with Command Editor

    This topic describes how to use command editor for setting SQL commands to the different data access components, like OracleDataTable, OracleDataAdapter, or OracleDataSource.

  • Retrieving Metadata

    dotConnect for Oracle has useful feature - GetSchema method. It allows you to read server schema information without writing queries and parsing the output. All information you may want to obtain is brought to you by single function in easy-to-process format.

  • Asynchronous Query Execution

    dotConnect for Oracle supports asynchronous execution of methods that take most of time in database applications. These are opening a connection, transferring large blocks of data, and other operations alike.

  • Enterprise Library Data Access Block

    dotConnect for Oracle can be used in conjunction with Microsoft Enterprise Library Data Access Application Block. This topic describes what is Enterprise Library, what part of it can be substituted with dotConnect for Oracle, and how to use the bundle in your applications.

  • SQL Server Integration Services

    This section describes SQL Server Integration Services support in dotConnect for Oracle.

  • Sync Framework Tutorial

    This tutorial describes how to use dotConnect for Oracle to synchronize Oracle databases with Microsoft Sync Framework.

  • Windows Workflow Foundation Support

    This section describes dotConnect for Oracle integration with Windows Workflow Foundation.

  • Performance Counters Support

    This section describes dotConnect for Oracle performance counters support.


General Concepts in Database Application Development

General Concepts in Database Application Development
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

There are many database application development approaches, each with its own advantages and drawbacks. This topic describes some of database application design patterns applicable with dotConnect for Oracle and lists their tradeoffs to help you decide which one best suits your development needs.

  • Introduction
  • The Standard Way
  • Typed OracleDataSets
  • Untyped OracleDataSets
  • Individual OracleDataTables
  • Design Time Emphasis
  • Summary

Introduction

One of the key questions in database application development is which set of components to base on. To answer this question it is necessary to clarify the following aspects:

  • How to plan data access architecture and how to create client representation of the schema?
  • How to edit existing database schema?
  • How to implement data binding?
  • How to design forms with data-bound controls?
  • How to pass instances of data access components?
  • How to control database connection used by the components?

Let's see how these questions are handled in standard ADO.NET approach and some advanced ways offered by dotConnect for Oracle.

The Standard Way

The classic ADO.NET solution is to use typed datasets. This way you build your schema with standard DataSet, DataAdapter, and TableAdapter objects. The schema is created and edited with DataSource Wizard, DataSet Designer, and stored in a separate project item. The schema can be also edited with Devart DataSet Wizard in compatibility mode.

To bind the data access components to GUI controls use the standard BindingSource component. Forms with data-bound controls are designed with DataSources Window. In run time instances of connections and datasets should be managed manually (almost no automation). The typed dataset creates individual connection for every DataTable object basing on the connection string stored in the schema or in a configuration file.

To sum it up, the standard way requires much of manual coding, and offers very few design time features. To overcome this problem dotConnect for Oracle provides alternative solutions, which have greater capabilities in design time application development and reduce volumes of necessary coding.

Typed OracleDataSets

The most comprehensive solution is to use typed OracleDataSets. The OracleDataSet components use OracleDataTable components to build a schema with support for Oracle-specific features. The entire schema is stored in separate project item as well. It is created with DataSet Wizard, and edited with DataSet Wizard or standard DataSet Designer.

To bind the data access components to GUI controls use the advanced DataLink component. The multiform data binding is managed with Devart DataSet Manager. In run time all components related to data access can inherit references from design time. Due to the InterForm technology, the components can reference connections and data sources even on other forms. The OracleDataSet can have either individual connections for every OracleDataTable, or single OracleConnection that is used by all tables. The connection can be controlled by the schema or by the OracleConnection component itself.

In general, typed OracleDataSets represent centralized data access and storage solution that provides rich set of design-time tools for working with the schema. However, typed OracleDataSets, as any other typed solution, is not much customizable in run time. Thus if you prefer to control the schema within run time, the untyped OracleDataSets solution might suit you better.

To migrate from a standard typed DataSet, change its Custom Tool property to dcOracleDataSetGenerator, then restart the tool or recompile the project.

Untyped OracleDataSets

Untyped OracleDataSets represent a more flexible alternative to typed OracleDataSets. The schema is built again with the OracleDataTable components encapsulated in a OracleDataSet component. The entire schema is stored in a OracleDataSet component that resides on a project form. It is created simply by dropping the OracleDataSet component from the toolbox, and edited with design-time OracleDataSet Editor or OracleDataTable editor. The solution uses standalone OracleConnection to connect to database.

In other aspects, such as data binding and reference management, the untyped OracleDataSets retain benefits of typed OracleDataSets.

The main difference between typed and untyped OracleDataSets is schema representation. With untyped OracleDataSets it is less convenient to customize the schema in design time, but the run-time schema management is much more powerful.

Individual OracleDataTables

The individual OracleDataTable component can represent just one table or stored procedure, so it is not a direct replacement for typed or untyped OracleDataSets. However, it is a pretty simple and effective solution when you need to manage only small amount of tables.

The OracleDataTable component is created simply by dropping it on a form designer from the toolbox. You can edit it with design-time OracleDataTable editor. It uses standalone OracleConnection to connect to database. In data binding and reference management the OracleDataTable component has same advantages as typed or untyped OracleDataSets.

The advantages and disadvantages of individual OracleDataTable components are immediate consequences of its purposes. This is very simple and yet potential solution for very small schemas.

Design Time Emphasis

The Devart data access approaches allow you to move the development process from run time to design time, which is way more comfortable. The design time development is additionaly supported by the following features.

Live Data

dotConnect for Oracle supports connected data access model, so when you open an OracleDataTable object in design time, you have the actual data immediately. With the data displayed you can customize grid columns, cells format, and the overall appearance of your application without even launching it.

dbForge Fusion for Oracle

dbForge Fusion for Oracle is a powerful add-in designed to leverage, automate, and simplify Oracle database development process. Its design time capabilities provide you the following benefits:

  • Simple creation of database connections, which you can share between your applications
  • Easily explorable database structure and creation of data access components with just a drag'n'drop operation
  • Enhanced SQL text editors with code completion and syntax highlighting
  • Ability to alter tables and stored procedures right from component editors
  • Visual query builder always available when you work with SELECT statements
  • Data preview with convenient cell editors
  • Debugger of Oracle stored procedures and PL/SQL blocks

Summary

dotConnect for Oracle offers solutions that are much more comfortable than the standard way of designing database applications. The solutions allow better control over connection setup, data retrieval and management. With Devart approaches you can employ all the advanced features of OracleDataTable component. Moreover, you can cut down development time even more with usage of dbForge Fusion.

See Also

OracleDataTable Advanced Features | InterForm Technology | DataLink Component Architecture | Developing Database Applications with dotConnect for Oracle | OracleDataSet Reference | OracleDataTable Reference


Migration from OracleClient to dotConnect for Oracle

Migration from OracleClient to dotConnect for Oracle
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

According to this post in the ADO.NET team blog, Microsoft deprecates OracleClient as a part of ADO.NET roadmap. Microsoft strongly recommends customers to use third-party ADO.NET providers for Oracle instead of continuing to use Microsoft’s OracleClient for new application development.

dotConnect for Oracle is fast and reliable ADO.NET provider for the wide range of users. It is the most compatible with OracleClient provider, and it provides the easiest migration from OracleClient. It allows you to migrate easily without effort.

We have researched problems, which users may encounter when migrating from OracleClient to dotConnect for Oracle:

  • Interface differences. Almost all differences in the names of the classes, methods, and fields between OracleClient and dotConnect for Oracle were removed. Migration Wizard will solve the problems with the minor differences that still exist.
  • Behavior differences. We have thoroughly researched the OracleClient provider behavior and compared it with the behavior of our provider. We also have adopted our autotests to the OracleClient and gained their successful execution. All the behavior differences were eliminated, and now you can switch the dotConnect for Oracle to the compatibility mode with OracleUtils.OracleClientCompatible variable.

Migration

Our Migration Wizard makes the migration from the OracleClient to dotConnect for Oracle as easy as the two following steps:

  1. Open the Migration Wizard by choosing Migration Wizard from the Tools -> Oracle menu and in the appeared wizard click the Next button. Then choose the provider to convert from and whether to convert entire solution or the active project only and click Finish.

  2. Set the OracleUtils.OracleClientCompatible to true in your code.

Then you may compile and use your project.

Example

We created an example for such migration from the MSDN code samples.

The sample project can be downloaded here. Then we used the Migration Wizard to migrate this project from OracleClient to dotConnect for Oracle, and inserted OracleUtils.OracleClientCompatible = true into the code. Everything works in the same way as before the migration. Migrated project can be downloaded here.

See Also

Comparing Data Providers for Oracle


OracleDataTable Advanced Features

OracleDataTable Advanced Features
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

The OracleDataTable component is one of the most effective tools in the dotConnect for Oracle arsenal. It combines connection to server, command object and data storage in single component with really comprehensive capabilities. In addition, it can accomplish data access tasks in both connected and disconnected models. This topic describes how you can use some of the OracleDataTable features.

  • Introduction
  • Data Fetch Control Overview
  • Traditional Fetch Mode
  • Sequential Fetch Mode
  • Paginal Fetch Mode
  • Pure Asynchronous Fetch
  • Query-based Master-detail Relationship
  • Deferred Column Data Read
  • Flexible Data Binding

Introduction

The OracleDataTable component can be used both as a standalone data processing unit and in conjunction with GUI controls like grids. The behavior of the OracleDataTable component can be described in a declaratively way with properties, which means that it is very convenient to build and test the application in design time.

The OracleDataTable component supports server-specific data types. It is used by OracleDataSet components to build the schema with server-specific features. However, this does not break compatibility with common data access techniques.

Data Fetch Control Overview

The OracleDataTable component provides rich set of data fetch mechanisms. Besides the traditional mode where selected data is retrieved at once, it supports sequential, paginal, and asynchronous fetch modes. The following OracleDataTable members are involved into the fetch control:

  • Open and Close methods for simply opening and closing whole datasets or its parts
  • Active property to control the dataset state in design time
  • StartRecord, MaxRecords properties to retrive limited resultset
  • FetchAll property to control whether OracleDataTable requests all records at once or just the amount requested by a visual component
  • NonBlocking property, which determines whether data fetch process blocks current thread
  • Fill method to open whole dataset
  • FillPage method to open a part of a dataset
  • BeginFill, EndFill, SuspendFill, CancelFill methods to perform fetch operations asynchronously

This list demonstrates that OracleDataTable has all flavors of data access mechanisms. The component members mentioned in the list can be used in different combinations. The following sections of the topic describe some combinations, their effect and problems that can be solved best with chosen fetch mode.

Traditional Fetch Mode

The usual approach to requesting data is to transfer the whole resultset to client side in single operation. The advantages of this approach are obvious: the entire resultset is available once fetched, the application does not depend on network stability, there are no delays during navigation through large datasets. On the other hand, the disadvantages of this approach are obvious as well: long initial timeout, possibly excessive memory consumption, higher requirements to network connection speed.

To perform traditional fetch with the OracleDataTable component, just invoke the Open method (or set Active property to true). Make sure that the component is configured as follows:

  • FetchAll property is set to true
  • MaxRecords property is set to 0, which indicates that all records should be requested

With these conditions, the Open method will return only when the whole dataset is transferred to client side. However, you can set the NonBlocking property to true, which will make the method return immediately. To capture the end moment of the operation in a non-blocking fetch, watch for the SyncRoot property or handle the FetchFinished event.

Another way is to call the Fill method, which ignores all of the mentioned properties and just fetches the whole resultset.

C#csharp Copy Code
static void UseDataTable(OracleDataTable myDataTable, OracleCommand myCommand)
{
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  myDataTable.FetchAll = true;
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As OracleDataTable, ByVal myCommand As OracleCommand)
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  myDataTable.FetchAll = True
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Sequential Fetch Mode

A more sophisticated approach is to transfer to client only rows that are necessary for rendering or updating. When client needs to fetch more records (for example, user scrolls a grid), another request to server is performed. In contrast to the traditional fetch mode, this way the initial timeout is much shorter, there is no redundant memory consumption, and possibly slow connection would not freeze the application too much. However, sequential mode assumes that you have stable network, so that client does not have to wait every time a new portion of the resultset is requested.

To perform sequential fetch, set the FetchAll property to false, MaxRecords property to 0, and call Open. Note that the NonBlocking property does not affect the sequential fetch, and that the Fill method ignores the FetchAll property as well.

To improve behavior of sequential mode, the OracleDataTable component provides two additional properties, QueryRecordCount and RecordCount. The QueryRecordCount property determines whether to perform additional roundtrip to server to find out how many rows are there in the resultset. If the QueryRecordCount property is set to true, the RecordCount property contains the number of rows, otherwise it contains number of rows currently fetched to the client.

Paginal Fetch Mode

When you know for sure which subset of rows the application actually needs, you can switch to paginal mode that allows selecting rows range explicitly. In this mode it is up to you to determine which and how many rows should be retrieved. The OracleDataTable component has two ways to limit the range:

  • By providing arguments to the FillPage method
  • By setting the StartRecord and MaxRecords properties and calling the Open method

While the first way is self-sufficient and is not affected by any property, the second way still can be modified by the FetchAll and NonBlocking properties (see above for explanation). For example, the following assignments will cause the Open method return before a subrange of rows is entirely fetched:

  • Set MaxRecords to a positive integer
  • Set FetchAll to false
  • Set NonBlocking to true
C#csharp Copy Code
static void UseDataTable(OracleDataTable myDataTable, OracleConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept";
  myDataTable.FetchAll = false;
  myDataTable.NonBlocking = true;
  myDataTable.StartRecord = 10;
  myDataTable.MaxRecords = 5;

  myDataTable.RowFetched += new EventHandler(myDataTable_RowFetched);
  myDataTable.FetchFinished += new EventHandler(myDataTable_FetchFinished);
  myDataTable.Open();
}

static void myDataTable_RowFetched(object sender, EventArgs e) {

  Console.Write(string.Format("{0} rows are fetched", ((OracleDataTable)sender).RecordCount));
}

static void myDataTable_FetchFinished(object sender, EventArgs e) {

  Console.Write("All records are fetched");
}
Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As OracleDataTable, ByVal myConnection As OracleConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept"
  myDataTable.FetchAll = False
  myDataTable.NonBlocking = True
  myDataTable.StartRecord = 10
  myDataTable.MaxRecords = 5
  AddHandler myDataTable.RowFetched, New EventHandler(AddressOf myDataTable_RowFetched)
  AddHandler myDataTable.FetchFinished, New EventHandler(AddressOf myDataTable_FetchFinished)
  myDataTable.Open()
End Sub

Private Shared Sub myDataTable_RowFetched(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write(String.Format("{0} rows are fetched", DirectCast(sender, OracleDataTable).RecordCount))
End Sub

Private Shared Sub myDataTable_FetchFinished(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write("All records are fetched")
End Sub

Pure Asynchronous Fetch

The traditional and paginal fetch modes provide capability of transparent asynchronous fill operations with the NonBlocking property set to true. You can control the asynchronous fetch entirely using the following set of methods:

  • BeginFill initiates data fetch in a background thread. Returns immediately after the server starts to send first pieces of data.
  • EndFill finishes the previously started data fetch. The EndFill method reads out the resultset if it is not fetched entirely yet.
  • SuspendFill pauses the previously started data fetch. You can resume it later with the BeginFill or EndFill methods.
  • CancelFill terminates the previously started data fetch.

For more information about the asynchronous operations in OracleDataTable please refer to topic Asynchronous Execution. The topic describes some useful techniques and provides more examples on the subject.

C#csharp Copy Code
void UseDataTable(OracleDataTable myDataTable, OracleConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept";

  IAsyncResult aRes = myDataTable.BeginFill(null, null);

  Console.Write("Fetch in process");

  Thread.Sleep(100);
  myDataTable.SuspendFill(true);
  Console.Write("Fetch is stopped");

  myDataTable.EndFill(aRes);
  Console.Write("All records are fetched");
}
Visual Basic Copy Code
Private Sub UseDataTable(ByVal myDataTable As OracleDataTable, ByVal myConnection As OracleConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept"
  Dim result1 As IAsyncResult = myDataTable.BeginFill(Nothing, Nothing)
  Console.Write("Fetch in process")
  Thread.Sleep(100)
  myDataTable.SuspendFill(True)
  Console.Write("Fetch is stopped")
  myDataTable.EndFill(result1)
  Console.Write("All records are fetched")
End Sub

Query-based Master-detail Relationship

In addition to classic master-detail relationship, the OracleDataTable component is capable of establishing a relationship where details data is not cached on the client. Every time the current position in the master table is changed, the client OracleDataTable requests an appropriate portion of data from the server. This goal is achieved using the ParentDataRelation class. The query-based master-detail relationship is designed to improve performance of the application and leverage network load.

C#csharp Copy Code
OracleConnection connection = new OracleConnection(connStr);
connection.Open();
OracleDataTable deptTable = new OracleDataTable("SELECT * FROM dept", connection);
OracleDataTable empTable = new OracleDataTable("SELECT * FROM emp", connection);
empTable.ParentRelation.ParentTable = deptTable;
empTable.ParentRelation.ParentColumnNames = new string[] { "deptno" };
empTable.ParentRelation.ChildColumnNames = new string[] { "deptno" };
deptTable.Owner = this;
empTable.Owner = this;
deptTable.Open();
empTable.Open();
deptDataGrid.DataSource = deptTable;
empDataGrid.DataSource = empTable;
Visual Basic Copy Code
Dim connection As New OracleConnection(connStr)
connection.Open()
Dim deptTable As New OracleDataTable("SELECT * FROM dept", connection)
Dim empTable As New OracleDataTable("SELECT * FROM emp", connection)
empTable.ParentRelation.ParentTable = deptTable
empTable.ParentRelation.ParentColumnNames = New String() {"deptno"}
empTable.ParentRelation.ChildColumnNames = New String() {"deptno"}
deptTable.Owner = Me
empTable.Owner = Me
deptTable.Open()
empTable.Open()
deptDataGrid.DataSource = deptTable
empDataGrid.DataSource = empTable

Deferred Column Data Read

The OracleDataTable component is designed to avoid redundant data transfer. One of the tools you can use for this purpose is partial column read. The main point of the technique is having a full dataset schema on client side, but requesting only a subrange of columns. When you decide that a row really needs the rest of the columns, you invoke the ReadComplete method for the chosen row. This can be illustrated with a photo database, where initially you fetch only a short description of a photo, and the image itself is transferred only if the user requests it.

C#csharp Copy Code
static void UseDataTable(OracleDataTable myDataTable, OracleConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT DEPTNO FROM Dept";

  System.Data.DataColumn column_DEPTNO = new System.Data.DataColumn();
  System.Data.DataColumn column_DNAME = new System.Data.DataColumn();
  System.Data.DataColumn column_LOC = new System.Data.DataColumn();
  column_DEPTNO.ColumnName = "DEPTNO";
  column_DEPTNO.DataType = typeof(int);
  column_LOC.ColumnName = "LOC";
  column_LOC.DataType = typeof(string);
  column_DNAME.ColumnName = "DNAME";
  column_DNAME.DataType = typeof(string);
  myDataTable.Columns.AddRange(new System.Data.DataColumn[] {column_DEPTNO, column_DNAME, column_LOC});

  myDataTable.FetchAll = true;
  myDataTable.Open();
  Console.Write("DEPTNO column is loaded");
  myDataTable.ReadComplete(myDataTable.Rows[0]);
  Console.Write("DEPTNO and LOC columns are loaded");
}
Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As OracleDataTable, ByVal myConnection As OracleConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT DEPTNO FROM Dept"
  Dim column_DEPTNO As New DataColumn
  Dim column_DNAME As New DataColumn
  Dim column_LOC As New DataColumn
  column_DEPTNO.ColumnName = "DEPTNO"
  column_DEPTNO.DataType = GetType(Integer)
  column_DNAME.ColumnName = "DNAME"
  column_DNAME.DataType = GetType(String)
  column_LOC.ColumnName = "LOC"
  column_LOC.DataType = GetType(String)
  myDataTable.Columns.AddRange(New DataColumn() {column_DEPTNO, column_DNAME, column_LOC})

  myDataTable.FetchAll = True
  myDataTable.Open()
  Console.Write("DEPTNO column is loaded")
  myDataTable.ReadComplete(myDataTable.Rows.Item(0))
  Console.Write("DEPTNO and LOC columns are loaded")
End Sub

Flexible Data Binding

The OracleDataTable component is designed to provide comprehensive data binding capabilities. It supports the InterForm technology, which means that you can bind controls on another form to the OracleDataTable. The component even allows updating underlying datasets in design time with data binding (when the CachedUpdates property is set to false). In addition, the QueryRecordCount property enables informing GUI controls about real quantity of rows in a resultset. These features make OracleDataTable component the best choice for both design time and run time data processing.

See Also

General Concepts in Database Application Development | Developing Database Applications with dotConnect for Oracle | Asynchronous Execution | InterForm Technology | OracleDataTable Reference | ParentDataRelation Reference


Using Parameters in dotConnect for Oracle

Using Parameters
support@devart.com

dotConnect for Oracle enhances SQL handling capabilities with usage of parameters in SQL queries. You can make execution of a query or stored procedure very flexible using several simple techniques. This article describes some basics you must be acquainted with when working with parameters in dotConnect for Oracle, as well as parameters synchronization and some nuances related to usage of stored procedures.

The article consists of following sections:

  • Parameters basics
  • Using automatic parameters synchronization
  • Using parameters with stored procedures in autosynchronization mode
  • More information
  • Performance issues
  • Examples

Parameters basics

In general, parameter is a placeholder for a variable that contains some value of some type when executing a general-purpose query, or arguments and return values when a stored procedure is executed. Parameter is represented by OracleParameter class. All parameters that take part in query execution constitute a collection that can be accessed through OracleCommand.Parameters property.

Parameters require accordance with names of OracleParameter instances in the collection. Parameters are declared using ':' prefix followed by name of the parameter. You do not have to care about the order in which parameters are created. Parameter can appear more than once in query text, but you have to create only one instance of it in Parameters collection.

For example, a simple Update statement that requires named parameters might look like the following:

    UPDATE dept SET dname = :dname, loc = :loc WHERE deptno = :deptno

To set parameters for this query you can use the next code:

C#csharp Copy Code
OracleCommand myCommand1;
...
myCommand1.CommandText = "UPDATE dept SET dname = :dname, " +
"loc = :loc WHERE deptno = :deptno";
myCommand1.Parameters.Add("deptno", 20);
myCommand1.Parameters.Add("dname", "SALES");
myCommand1.Parameters.Add("loc", "NEW YORK");
Visual Basic Copy Code
Dim myCommand1 as OracleCommand
...
myCommand1.CommandText = "UPDATE dept SET dname = :dname, " & _
"loc = :loc WHERE deptno = :deptno"
myCommand1.Parameters.Add("deptno", 20)
myCommand1.Parameters.Add("dname", "SALES")
myCommand1.Parameters.Add("loc", "NEW YORK")

When you invoke a stored procedure you have to create collection of parameters that corresponds strictly to set of arguments for the stored procedure in names, quantity and types. Parameters that represent arguments to the procedure must have their Direction property set to Input, InputOutput or Output. You retrieve value returned by a stored function through a parameter with Direction property set to ReturnValue.

Using automatic parameters synchronization

The behavior described above assumes that OracleCommand.ParameterCheck is false (by default). By turning it on you enable automatic synchronization of query text and OracleCommand.Parameters collection. In this mode all input parameters are checked for validity, new ones are added if necessary, and redundant parameters are deleted. Thus you do not have to take care about quantity of items in OracleCommand.Parameters collection, you can specify only the ones you really need. The synchronization is done as follows:

  • If parameters are mentioned in the text but are missing in the collection, they are added to collection. OracleParameter.OracleDbType is set to OracleDbType.VarChar. This property is updated to a correct type when a value is assigned to the parameter.
  • If named parameters that exist in the collection are not found in the query text, they are deleted from the collection.
  • Properties of parameters are not altered, except for the ones created during the synchronization process.

For queries that do not represent a stored procedure the synchronization takes place when:

  • OracleCommand.ParameterCheck is set to true
  • OracleCommand.CommandType is set to "Text"
  • OracleCommand.CommandText is altered

For stored procedures synchronization happens when:

  • Query is prepared
  • Query is executed

A separate query is executed against the server to establish the correct types of the parameters when synchronization is performed for stored procedures.

If synchronization is already performed, subsequent calls to these methods do not result in re-synchronization, unless you had modified Parameters collection or one of the properties listed above.

Using parameters with stored procedures in synchronization mode

If parameters are added to the command collection in the order that is different from the function parameters order in database, it is necessary to describe the command by setting OracleCommand.ParameterCheck to true to reoder parameters in a proper way.

When OracleCommand.ParameterCheck is true you can specify only those parameters you really need. Omitted parameters will be created and assigned DBNull value. You can set up required parameters in any order you like. The collection will be filled up and sorted as a result of synchronization.

When working with stored procedures parameter's name must match exactly name of procedure's argument. However the ReturnValue parameter needs not to have any specific name. Moreover, the ReturnValue parameter is assigned name 'RESULT' on query preparation.

In synchronization mode first call to OracleCommand.Prepare or OracleCommand.Execute methods leads to recreation of all argument parameters. If name of a parameter is suitable for the description of stored procedure, parameter is preserved in the collection, otherwise it is lost. If OracleCommand.CommandText property and Parameters collection are unchanged all subsequent invocations of Prepare or Execute methods will not result in recreation of parameters.

For example, consider you had a stored procedure that accepts two arguments, deptno and dname, and then changed OracleCommand.CommandText to reference another stored procedure that accepts deptno and loc arguments. In this case you will have first parameter unchanged, and the second parameter recreated with value assigned to DBNull.

More information

There are two more important issues concerning parameters in dotConnect for Oracle that are available as separate articles. These techniques are not obligatory but using them you can help yourself a deal.

You can use REF CURSOR output parameters to return a result set or several result sets from a procedure or PL/SQL block. The article Working with Cursors covers this matter. You can also find there sample code that shows how to fill a dataset from REF CURSOR output parameters.

Another very useful feature related to usage of parameters is array binding. It allows executing some query many times with different values of parameters. This capability significantly increases query performance and reduces network load. The article Working with Array Binding demonstrates how to use this feature.

For information on how to use parameters with PL/SQL tables please refer to article Working with PL/SQL Tables.

Performance issues

In general, setting OracleCommand.ParameterCheck property to true leads to some performance loss.
When OracleCommand.CommandType is "Text" the synchronization is performed on client, so performance reduces very slightly.
When OracleCommand.CommandType is "StoredProcedure", dotConnect for Oracle sends additional requests to server which are necessary to determine quantity, names, and other information about parameters. Thus performance mostly depends on how fast these additional round trips are performed.

To optimize query multiple execution you can manually call OracleCommand.Prepare method that creates compiled version of the query on server and forces synchronization. After the query is prepared it is not advised to alter OracleCommand.Text property because the OracleCommand becomes unprepared again. The recommended practice is to set up query text and parameters, execute OracleCommand.Prepare method, and afterwards change only parameters' values.

You can greatly speed up multiple execution with array binding. Refer to article Working with Array Binding for information on the issue.

Examples

The first example demonstrates how flexible and convenient usage of parameters can be. In the example two new Sales departments are added to table Dept; then all departments with this name are rendered to console.

First, query text is assigned to OracleCommand object. When OracleCommand.ParameterCheck is set to true dotConnect for Oracle automatically creates collection of parameters you can access to set values. Second, OracleCommand.Prepare method call is issued to achieve the best performance. Two rows are added to table then, each referencing Sales department. Afterwards the query text is changed and again OracleCommand.Parameters collection is rebuilt. This time it has only one item in it. Notice that this parameter was assigned an Int32 value before and now it holds a string. This is possible since you do not assign OracleParameter.OracleDbType explicitly. Once you set a value to OracleDbType or DbType property autodetection of data type ceases to work.

C#csharp Copy Code
static void Main(string[] args)
{
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora");
  myConn.Open();
  OracleCommand myCommand = new OracleCommand(
      "INSERT INTO Dept VALUES (:p1, :p2, :p3)", myConn);
  myCommand.ParameterCheck = true;
  myCommand.Prepare();
  myCommand.Parameters[0].Value = 60;
  myCommand.Parameters[1].Value = "SALES";
  myCommand.Parameters[2].Value = "LA";
  myCommand.ExecuteNonQuery();
  myCommand.Parameters[0].Value = 70;
  myCommand.Parameters[2].Value = "DETROIT";
  myCommand.ExecuteNonQuery();
  myCommand.CommandText = "SELECT * FROM Dept WHERE DName=:p1";
  myCommand.Parameters[0].Value = "SALES";
  OracleDataReader myReader = myCommand.ExecuteReader();
  while (myReader.Read())
  {
    Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(2));
  }
  myReader.Close();
  myConn.Close();
  Console.ReadLine();
}
Visual Basic Copy Code
Sub Main()
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora")
  myConn.Open()
  Dim myCommand As OracleCommand = New OracleCommand( _
      "INSERT INTO Dept VALUES (:p1, :p2, :p3)", myConn)
  myCommand.ParameterCheck = True
  myCommand.Prepare()
  myCommand.Parameters(0).Value = 60
  myCommand.Parameters(1).Value = "SALES"
  myCommand.Parameters(2).Value = "LA"
  myCommand.ExecuteNonQuery()
  myCommand.Parameters(0).Value = 70
  myCommand.Parameters(2).Value = "DETROIT"
  myCommand.ExecuteNonQuery()
  myCommand.CommandText = "SELECT * FROM Dept WHERE DName=:p1"
  myCommand.Parameters(0).Value = "SALES"
  Dim myReader As OracleDataReader = myCommand.ExecuteReader()
  While myReader.Read()
    Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
                    + myReader.GetString(2))
  End While
  myReader.Close()
  myConn.Close()
  Console.ReadLine()
End Sub

The following example shows how to get a stored function to work. We will not use parameters autosynchronisation here.
Consider you have a stored procedure that accepts job name, selects employees with that job from table Emp, gets their total salary and returns it as function result. It may be described as follows:

CREATE FUNCTION GETTOTALSALARY (JobParam IN VARCHAR)
  RETURN NUMBER
AS
  TotalSalary NUMBER;
BEGIN
  SELECT SUM(Sal) INTO TotalSalary FROM Emp WHERE Job=JobParam GROUP BY Job;
  RETURN TotalSalary;
END;

To pass a parameter to the function and obtain a return value you can use the following sample code.

C#csharp Copy Code
static void CallProc()
{
  //Prepare connection and command
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora");
  myConn.Open();
  OracleCommand myCommand = new OracleCommand("GETTOTALSALARY", myConn);
  myCommand.CommandType = System.Data.CommandType.StoredProcedure;
  //Prepare parameters manually
  OracleParameter myInParam = myCommand.Parameters.Add("JobParam", "SALESMAN");
  OracleParameter myReturParam = new OracleParameter();
  myReturParam.Direction = System.Data.ParameterDirection.ReturnValue;
  myCommand.Parameters.Add(myReturParam);
  //Execute the function and render result
  myCommand.ExecuteNonQuery();
  Console.WriteLine(myReturParam.Value);
  myConn.Close();
  Console.ReadLine();
}
Visual Basic Copy Code
Sub CallProc()
  'Prepare(connection And Command())
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora")
  myConn.Open()
  Dim myCommand As OracleCommand = New OracleCommand("GETTOTALSALARY", myConn)
  myCommand.CommandType = System.Data.CommandType.StoredProcedure
  'Prepare parameters manually
  Dim myInParam As OracleParameter = myCommand.Parameters.Add("JobParam", "SALESMAN")
  Dim myReturParam As OracleParameter = New OracleParameter()
  myReturParam.Direction = System.Data.ParameterDirection.ReturnValue
  myCommand.Parameters.Add(myReturParam)
  'Execute the function and render result
  myCommand.ExecuteNonQuery()
  Console.WriteLine(myReturParam.Value)
  myConn.Close()
  Console.ReadLine()
End Sub

The last example demonstrates how to call a stored procedure in autosynchronization mode.
Consider you have a stored procedure that adds a new employee to table Emp. It determines next suitable EmpNo, pastes current date, and checks for input parameters. If they contain a reasonable value, the procedure pastes this value as well; if a parameter contains NULL value, some defaults are used. Here is how source code for this procedure may look:

CREATE PROCEDURE ADDEMP (
  EmpName IN VARCHAR,
  Salary IN NUMBER
)
AS
  e_No NUMBER;
  e_Name VARCHAR(40);
  e_Sal NUMBER;
BEGIN
  e_Name := 'Unnamed';  --Default value
  e_Sal := 1100;        --Default value
  IF EmpName IS NOT NULL THEN e_Name := EmpName; END IF;
  IF Salary  IS NOT NULL THEN e_Sal  := Salary;  END IF;
  SELECT Max(EmpNo) INTO e_No FROM Emp;
  INSERT INTO Emp (EmpNo, EName, Sal, HireDate)
     VALUES (e_No+10, e_Name, e_Sal, SYSDATE);
END;

We will invoke this procedure and pass it single parameter - EmpName. Since ParameterCheck is true, the second parameter will be created in the moment of calling ExecuteNonQuery method. So this code will result in adding of new employee with name Roger and default salary (1100).

Note that in autosynchronisation mode the only thing that matters is name of a parameter. You do not have to take care of creation order and there's no need to create parameters that are intended to have NULL value. Put another words, if we need to add an employee with default name but with specific salary, we can create single argument with ParameterName set to "Salary".

C#csharp Copy Code
static void CallProc()
{
  //Establish connection
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora");
  myConn.Open();
  //Set up myCommand to reference stored procedure 'AddEmp'
  OracleCommand myCommand = new OracleCommand("AddEmp", myConn);
  myCommand.CommandType = System.Data.CommandType.StoredProcedure;
  myCommand.ParameterCheck = true;

  //Create input parameter and assign a value
  OracleParameter myInParam1 = new OracleParameter();
  myInParam1.Value = "Roger";
  myInParam1.ParameterName = "EmpName";
  myCommand.Parameters.Add(myInParam1);
  myInParam1.Direction = System.Data.ParameterDirection.Input;

  //Execute the procedure.
  myCommand.ExecuteNonQuery();
  Console.WriteLine("Done");
  myConn.Close();
}
Visual Basic Copy Code
Sub CallProc()
  'Establish connection
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora")
  myConn.Open()
  'Set up myCommand to reference stored procedure 'AddEmp'
  Dim myCommand As OracleCommand = New OracleCommand("AddEmp", myConn)
  myCommand.CommandType = System.Data.CommandType.StoredProcedure
  myCommand.ParameterCheck = True

  'Create input parameter and assign a value
  Dim myInParam As OracleParameter = New OracleParameter
  myInParam.ParameterName = "EmpName"
  myInParam.Value = "Roger"
  myCommand.Parameters.Add(myInParam)
  myInParam.Direction = System.Data.ParameterDirection.Input

  'Execute the procedure
  myCommand.ExecuteNonQuery()
  Console.WriteLine("Done.")
  myConn.Close()
End Sub

See Also

Working with Array Binding | Working with Cursors | OracleParameter Class | Devart.Data.Oracle Namespace


Oracle Specific Features

Oracle Specific Features
support@devart.com

This section describes dotConnect for Oracle support of Oracle-specific technologies.

  • Using Direct Mode
  • Advanced Queuing Technology
  • Using OracleTrace Component
  • Using OracleAlerter Component
  • Transparent Application Failover Support
  • Working with Data
  • Using Object Wizard for working with Oracle Objects
  • Using Package Wizard for Working with PL/SQL Packages
  • OracleScript Hints for SQL*Plus Users
  • Using OCI Statement Caching
  • Oracle TimesTen Support
  • Connecting to Oracle with Proxy Authentication


Using Direct Mode

Using Direct Mode
support@devart.com

dotConnect for Oracle, like most of applications that work with Oracle, uses Oracle Call Interface (OCI) to connect to Oracle database server. This is usual way to develop Oracle applications with a third-generation language. However, it requires Oracle Client software installed on workstation that is the cause of additional expenses for installation and administration. Moreover, .NET security settings may restrict usage of unmanaged libraries, which makes impossible to use the client software, for example, on ASP.NET servers. Starting with dotConnect for Oracle 3.0, these problems can be eliminated by using the Direct mode of connecting to server.

Please note that the Direct Mode is based on the OCI 8 specification and, therefore, server conceives a client application as an Oracle 8 client.

In the Direct mode dotConnect for Oracle connects to an Oracle server directly, without calling any third party libraries. It allows your application to work with Oracle directly through TCP/IP protocol without involving the Oracle Client software. To run your application built with dotConnect for Oracle you only need to have operating system with TCP/IP protocol support.

Connection String Options in Direct Mode

Connecting to Oracle servers in the Direct mode is as easy as through OCI. You must know the address of computer where Oracle server is, port number to connect, and database global system identifier. The OracleConnection.ConnectionString property must include the following fragments:

Option Name | Description | Example
Direct* | Whether to use Direct mode | Direct=true
Data Source (or Host, or Server) | Oracle server's IP address or DNS name | Data Source=192.168.0.1
Port | Port number to connect to | Port=1521
SID** | System identifier (Global Database Name) | SID=orcl

* When using .NET Standard 1.3 compatible assemblies (for projects targeting .NET Core or other .NET platforms), the Direct mode is the only supported connection mode. Thus, there are no Direct connection string parameter, and it must not be used. Mobile Edition works only in Direct mode, and there are no this parameter for it as well.

** The Service Name connection string parameter can be used instead of SID, but in the Direct Mode you can connect only to one database instance (RAC isn't supported).

The whole connection string may look as follows: "User Id=Scott;Password=tiger;Direct=true;Data Source=192.168.0.1;Port=1521;SID=orcl".

C#csharp Copy Code
using Devart.Data.Oracle;
...
OracleConnectionStringBuilder oraCSB = new OracleConnectionStringBuilder();
oraCSB.Direct = true;
oraCSB.Server = "192.168.0.1";
oraCSB.Port = 1521;
oraCSB.Sid = "orcl";
oraCSB.UserId = "scott";
oraCSB.Password = "tiger";
OracleConnection myConnection = new OracleConnection(oraCSB.ConnectionString);
myConnection.Open();
Visual Basic Copy Code
Imports Devart.Data.Oracle
...
Dim oraCSB As OracleConnectionStringBuilder = New OracleConnectionStringBuilder
oraCSB.Direct = true
oraCSB.Server = "192.168.0.1"
oraCSB.Port = 1521
oraCSB.Sid = "orcl"
oraCSB.UserId = "scott"
oraCSB.Password = "tiger"
Dim myConnection As OracleConnection = New OracleConnection(oraCSB.ConnectionString)
myConnection.Open()

The only option of listed above (except for Direct) that has the default value is Port. Port number defaults to 1521 (most commonly used in Oracle databases). Thus you can omit this option in the connection string.

You can connect to Multi-Threaded Server using the Direct mode. The server must be configured to use the specific port and TTC protocol. This can help you avoid firewall conflicts.

Note that when Direct is false (by default), the Data Source option has another meaning: you must specify either a TNS name or a TNS description. The Port and SID options are not allowed when Direct is false.

How to Switch to Direct Mode

Changing connection strings is the only action required to switch an application to the Direct mode. You do not have to rewrite other parts of your application. You can return to using OCI at any moment later reversing the changes made to connection strings.

Oracle Advanced Security Support in Direct Mode

dotConnect for Oracle supports Oracle Advanced Security data encryption and data integrity in the Direct mode and can connect to Oracle Database as a Service (DBaaS).

In the OCI mode, data encryption and integrity are configured in Oracle Client, and dotConnect for Oracle settings does not affect them. In the Direct mode you can configure the data encryption and integrity by using the corresponding properties of the DirectUtils class.

Data Encryption is an Oracle Advanced Security service that encrypts message data between client and server. dotConnect for Oracle enables data encryption in the Direct mode depending on the DirectUtils.DataEncryptionLevel property.

Data integrity is an Oracle Advanced Security service that ensures that the data, transmitted between client and server, is not modified in between and is not retransmitted multiple times by an attacker. dotConnect for Oracle enables data integrity in the Direct mode depending on the DirectUtils.DataIntegrityLevel property.

For the information on the possible values of these properties, and how they enable or disable encryption, see DirectUtils.SecurityLevel

Default value for both of these properties is DirectUtils.SecurityLevel.Accepted, which corresponds to the default behavior of Oracle Client. Usually, you don't need to modify this value. You can keep default value for connecting to

Direct Mode Compared to OCI Mode

Applications compiled with and without the Direct mode have similar size and performance. Security of using the Direct mode doesn't differ from using OCI.

The advantages of the Direct mode are:

  • installation and administration of Oracle Client software is not required;
  • system requirements are reduced.

The Direct mode has some limitations:

  • Connect using the TCP/IP protocol only.
  • Oracle TimesTen is not supported.
  • Oracle RAC (Real Application Clusters) is not supported.
  • The OracleLoader class uses Array Binding instead of the direct path load interface in the Direct mode, and has limited functionality.
  • Please note that we don't guarantee dotConnect for Oracle compatibility in the Direct mode with all Oracle servers and in every network. We have tested it with all versions of Oracle server for Windows and Linux since 7.3 in local network. Other platforms may cause some incompatibility issues.
  • The Direct mode does not support NLS conversion on client side.
  • Transparent Application Failover not supported
  • Statement caching is not available.
  • OS authentication and proxy authentication features are not available.
  • Implicitly returned resultsets (via DBMS_SQL.RETURN_RESULT introduced in Oracle 12c) are not supported.
  • Oracle Transaction Guard is not supported.
  • Returning the number of rows affected for each array element (ExecuteArray(Int32,Int64[])) when executing a command using array binding is not supported. Array binding with ExecuteArray(Int32) is supported.
  • dotConnect for Oracle does not support using Oracle objects in array binding.
  • The OracleDatabase class is not supported in the Direct mode.
  • The OracleConnection.PurgeStatementCache method works only in OCI mode.
  • The OracleCommand.InitialLobFetchSize property works only in OCI mode.
  • The OracleConnection.HAEvent is supported only in the OCI mode and only for Oracle Client 10g and higher.
  • A number of OracleXml properties and methods are not supported in the Direct mode. See the property descriptions to determine whether they are supported in the Direct mode.

You can return to connecting through OCI at any time if restrictions above become critical for you.


Advanced Queuing Technology

Advanced Queuing Technology
support@devart.com

Advanced Queuing (AQ) is a flexible message exchange mechanism built in Oracle server. With AQ you can send messages from a workstation or server to one or more workstations. dotConnect for Oracle incorporates set of classes that leverage working with this technology.

This feature is available in Professional and Developer Editions only.

This topic provides information and examples that can help you start with AQ. It consists of the following sections:

  • AQ Basics
  • AQ components in dotConnect for Oracle
  • A Simple Example of Point-to-Point Messaging
  • An Extended Example of Point-to-Point Messaging
  • A Simple Example of Point-to-Multipoint Messaging

AQ Basics

Advanced Queuing provides database-integrated message queuing functionality. Advanced Queue messages can be stored persistently, propagated between queues on different machines and databases, and transmitted using Oracle Net Services, HTTP(S), and SMTP. Since Oracle Advanced Queuing is implemented in database tables, all the benefits of high availability, scalability, and reliability are applicable to queue data. This technology is presented by DBMS_AQ and DBMS_AQADM packages. DBMS_AQ manages queue messages, allowing enqueuing and dequeuing. DBMS_AQADM controls a queue lifecycle and its properties.

Standard database features such as recovery, restart, and security are supported in Advanced Queuing, and queue tables can be imported and exported. Advanced Queuing provides the message management functionality and asynchronous communication needed for application integration.

Advanced Queuing is a complicated area, so it is recommended that you read the official documentation for better understanding of AQ aspects and capabilities.

There are two models of AQ functionality: Point-to-Point Model and Publish-Subscribe Model. In the first one, there is an application which puts messages to the queue (this is called enqueuing) and a consumer application which uses enqueued messages, removing them from the queue (this is called dequeuing). There can be more than one consumer applications but any single message can be dequeued just once. Also, consumers may browse the queue without dequeuing messages.

Advanced Queuing diagram 1

In the more sophisticated Publish-Subscribe model we have some applications (publishers) that enqueue messages and some others (subscibers) that dequeue these messages. Publishers propagate messages to queues which are called topics here. These messages can be either addressed for specific applications or they will be received by all destinations. Applications receiving messages are also called agents. We talk about broadcast if the message can be consumed by all applications and about multicast if a subscription is required for consummation.

Advanced Queuing diagram 2

AQ components in dotConnect for Oracle

There are a number of classes used to provide the AQ functionality in dotConnect for Oracle. The main of them are:

  1. OracleQueueMessage
  2. OracleQueue
  3. OracleQueueAdmin

The OracleQueueMessage objects represent queue messages. They are used as arguments when enqueuing messages and are returned by dequeue methods. OracleQueueMessages contain the system-generated message identificator and some message payload, which is of either char or user-defined object type.

The OracleQueue class provides the main queue functionality, such as enqueuing and dequeuing messages. The Enqueue method of OracleQueue take as arguments either OracleQueueMessage objects or any data sufficient for creating the message. In both cases it is possible to enqueue the array of messages via the EnqueueArray method. Dequeuing returns either single OracleQueueMessage (the Dequeue method) or their array (the DequeueArray method). The OracleQueue object can be limited to either enqueuing or dequeuing only. This option may be useful e.g. when one application only generates messages and the other one only consumes them; in this case the first application can use the OracleQueue instance which enqueues messages, while the second application will have the OracleQueue instance limited for dequeuing only.

To administrate the queues itself the OracleQueueAdmin class is used. It allows to create/drop and start/stop message queues as well as to set up their numerous properties. In Publish-Subscribe model, OracleQueueAdmin also manages the queue subscribers.

The queues can consist of either persistent or buffered messages. Persistent messages are stored in the database, buffered messages are not; hence, buffered messages are lost when the application shuts down. Persistent queues need special tables in the database; the functionality needed to create and manage such tables is provided by the OracleQueueTable class.

In Publish-Subscribe model, the consumers and publishers are represented by the OracleQueueAgent class. The specific consumer needs to be subscribed to the queue to get its messages, this can be made using OracleQueueAdmin. The publishers are referred in the properties of every message sent.

There are also special classes representing the property sets of messages, queues etc. These property classes are:

  • OracleQueueOptions representing the queue properties which concern storing and managing messages.
  • OracleQueueEnqueueOptions and OracleQueueDequeueOptions corresponding to the settings of enqueue/dequeue operations. Unless there are some options specified for the particular message, it is enqueued or dequeued according to OracleQueueEnqueueOptions or OracleQueueDequeueOptions.
  • OracleQueueMessageProperties class is used to set the properties of individual messages.
  • OracleQueueTableOptions represents the queue table settings such as compatibility settings, message payload types and message grouping properties.

A Simple Example of Point-to-Point Messaging

The following example demonstrates how to use Advanced Queueing in its simplest form. It represents a point-to-point messaging scheme where messages are deleted from server once they are consumed by the recipient.

First of all, we need to create a connection to the Oracle database. We are going to use object payload for messages, hence the connection must be in OCI mode:

C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
   "User Id=system;Password=manager;Server=ora;Direct=False;");
oracleConnection.Open();
Visual Basic Copy Code
Dim oracleConnection As New OracleConnection( _
"User Id=system;Password=manager;Server=ora;Direct=False;")
oracleConnection.Open()

Sometimes you need messages of some user-defined type (UDT) to contain at least a title or identification number and some content, e.g. message text. In this case, we need to specify which type of messages will be used in our AQ sample. All queue messages will be structured as this UDT. The type itself must be defined in the database.

C#csharp Copy Code
OracleCommand oracleCommand = new OracleCommand(
   "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
       "mestext VARCHAR2(80));", oracleConnection);
oracleCommand.ExecuteNonQuery();
Visual Basic Copy Code
Dim oracleCommand As New OracleCommand(
   "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), & _
         mestext VARCHAR2(80));", oracleConnection)
oracleCommand.ExecuteNonQuery()

Message queues are stored in special tables. The scripts, needed to create and manipulate such tables, are incapsulated in a single OracleQueueTable class. We will create an instance of this class, set the type of messages used in the queue and create the queue table at the database:

C#csharp Copy Code
OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueTable.Options.PayloadTypeName = "message";
oracleQueueTable.CreateQueueTable();
Visual Basic Copy Code
Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueTable.Options.PayloadTypeName = "message"
oracleQueueTable.CreateQueueTable()

The queue lifecycle is managed by OracleQueueAdmin class. The objects of this class create, start, stop and drop queues. Here we will create a new queue administration object and bind it to the "QUEUE_TABLE_MESSAGE" table. Also, we need to specify the name of the currently managed queue ("MESSAGE_QUEUE"):

C#csharp Copy Code
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
    "QUEUE_TABLE_MESSAGE", oracleConnection);
Visual Basic Copy Code
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
"QUEUE_TABLE_MESSAGE", oracleConnection)

Now we are able to create and start the queue itself:

C#csharp Copy Code
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();
Visual Basic Copy Code
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

After initializing the queue we can enqueue and dequeue messages. This operation would be more helpful in the case of several different applications, but we'll confine ourselves with the only one to make the sample more clear.

We will create an object of the OracleQueue class on the "publisher"'s side (which is the only one in our case). The OracleQueue class allows to operate with the messages concerned with the current queue. In particular, it allows the "publisher" putting messages to the queue:

C#csharp Copy Code
OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
Visual Basic Copy Code
Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

The following code creates a message object mes and enqueues the corresponding message:

C#csharp Copy Code
OracleObject mes = new OracleObject("message", oracleConnection);
mes["nickname"] = oracleConnection .UserId;
mes["mestext"] = "Hello, world!";

oracleEnqueueQueue.Enqueue(mes);
Visual Basic Copy Code
Dim mes As New OracleObject("message", oracleConnection)
mes.Item("nickname") = oracleConnection.UserId
mes.Item("mestext") = "Hello, world!"

oracleEnqueueQueue.Enqueue(mes)

Proceed to the "consumer"'s side. Create object oracleDequeueQueue of OracleQueue class.

C#csharp Copy Code
OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
Visual Basic Copy Code
Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Get the message from the queue. By default the Dequeue() method does not return until it successfully receives a message; in PtP model all messages are deleted from the queue after being dequeued. The behavior of the Dequeue method will be explained in details later.

C#csharp Copy Code
OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
if (msg != null && msg.ObjectPayload != null) {
  Console.WriteLine(msg.ObjectPayload["nickname"]);
  Console.WriteLine(msg.ObjectPayload["mestext"]);
}
Visual Basic Copy Code
Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
  Console.WriteLine(msg.ObjectPayload.Item("nickname"))
  Console.WriteLine(msg.ObjectPayload.Item("mestext"))
End If

Stop the queue:

C#csharp Copy Code
oracleQueueAdmin.StopQueue();
Visual Basic Copy Code
oracleQueueAdmin.StopQueue()

Delete the queue from the associated table. The queue will throw an exception on attempt to drop it, if it isn't stopped.

C#csharp Copy Code
oracleQueueAdmin.DropQueue();
Visual Basic Copy Code
oracleQueueAdmin.DropQueue()

Drop the queue table. The queue table needs all its queues to be stopped and deleted to be available for dropping. To automatically stop and delete the queues, use the DropQueueTable(bool force) overload.

C#csharp Copy Code
oracleQueueTable.DropQueueTable();
oracleConnection.Close();
Visual Basic Copy Code
oracleQueueTable.DropQueueTable()
oracleConnection.Close()

There are several ways how the OracleQueue.Dequeue() method behaves. It depends on the value of OracleQueueDequeueOptions.WaitTimeout property. When this value is -1 (by default), the Dequeue() method waits for a message to come, and does not return until the message arrives. When the value is 0, the Dequeue() method checks for a message and returns immediately. If there is no message, an exception is thrown. When the value is a positive integer, it designates a number of seconds to wait for a message. If no message is received during this timeout, an exception is thrown.

In the end of the sample we stop and destroy the queue together with its table. In the real world this may be not necessary, as the queue will continue to work after the application that created it is shut down.

An Extended Example of Point-to-Point Messaging

The next example slightly alters the code from the previous section. First, the payload type is changed to RAW to avoid creation of user-defined types for messaging. Second, a priority is assigned to one of the messages sent through the AQ mechanism. Third, messages are received in a more real-world way, with loops and finite timeouts.

C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
   "User Id=system;Password=manager;Server=ora;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
   "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set sort order by priority for the queue.
// The messages with higher priority will reach the recipient first.
oracleQueueTable.Options.SortOrder = OracleQueueSortOrder.PriorityEnqueueTime;

// Specify type of the messages in the queue.
//This time each message will be represented by just a string object.
//We do so to simplify the unimportant details and concentrate on the advanced features of AQ

oracleQueueTable.Options.PayloadTypeName = "RAW";

// The following operations are same as in the previous example.
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
"QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();
OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

// Create and send the first message.
OracleQueueMessage message1 = new OracleQueueMessage();
message1.StringPayload = "First message.";
message1.MessageProperties.Priority = 7;
oracleEnqueueQueue.Enqueue(message1);

// Create and send the second message. This message is assigned a higher priority value.
// The message will be consumed first, regardless of the fact that it was sent later.
OracleQueueMessage message2 = new OracleQueueMessage();
message2.StringPayload = "Second message with high priority.";
message2.MessageProperties.Priority = 1;
oracleEnqueueQueue.Enqueue(message2);

// Create an object that receives the two messages.
OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
oracleDequeueQueue.DequeueOptions.WaitTimeout = 1;

// Retrieve the messages in a loop. Once there are two messages received, quit.
// (ex.Code == 25228) specifies that the error occured is ORA-25228; it is thrown when the dequeuing timeout expires
// or the end of the queue is reached without dequeuing a message.

int messageCount = 0;
while (messageCount < 2) {
  try {
    OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
    messageCount++;
    if (msg != null && msg.StringPayload != null) {
      Console.WriteLine(msg.StringPayload);
    }
  }
  catch(OracleException ex) {
    if (ex.Code == 25228) {
      continue;
    }
    else
      throw ex;
  }
}

//Stop and destroy the queue and the queue table
oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();
oracleConnection.Close();
Visual Basic Copy Code
Dim oracleConnection As New OracleConnection((
"User Id=system;Password=manager;Server=ora;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set sort order by priority for the queue.
' The messages  with higher priority will reach the recipient first.
oracleQueueTable.Options.SortOrder = OracleQueueSortOrder.PriorityEnqueueTime

' Specify type of the messages in the queue. This time each message will be represented by just a string object.
' We do so to simplify the unimportant

oracleQueueTable.Options.PayloadTypeName = "RAW"

' The following operations are same as in the previous example.
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
   "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()
Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

' Create and send the first message.
Dim message1 As New OracleQueueMessage
message1.StringPayload = "First message."
message1.MessageProperties.Priority = 1
oracleEnqueueQueue.Enqueue(message1)

' Create and send the second message. This message is assigned a higher priority value.
' The message will be consumed first, regardless of the fact that it was sent later.
Dim message2 As New OracleQueueMessage
message2.StringPayload = "Second message with high priority."
message2.MessageProperties.Priority = 7
oracleEnqueueQueue.Enqueue(message2)

' Create an object that receives the two messages.
Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
oracleDequeueQueue.DequeueOptions.WaitTimeout = 1

' Retrieve the messages in a loop. Once there are two messages received, quit.
' (ex.Code == 25228) specifies that the error occured is ORA-25228;
' it is thrown when the dequeuing timeout expires or the end of the queue is reached
' without dequeuing a message.

Dim messageCount As Integer = 0
Do While (messageCount < 2)
  Try
    Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
    messageCount += 1
    if ((Not msg Is Nothing) AndAlso (Not msg.StringPayload Is Nothing)) Then
      Console.WriteLine(msg.StringPayload)
    End If
  Catch ex As OracleException
    If (ex.Code = 25228) Then
      Continue Do
    Else
      Throw ex
    End If
  End Try
Loop

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()
oracleConnection.Close()

A Simple Example of Point-to-Multipoint Messaging

In the point-to-multipoint scheme one publisher generates messages for several subscribers. The publisher may specify who exactly will receive the message. By default messages do not expire, and they are deleted either when dequeued in Remove mode, or when the table is destroyed. You can assign a lifetime to every message when sending it.

The following example illustrates the point-to-multipoint scheme within a single application (though usually consumers are quite different applications). The example demonstrates another dequeue principle: every consumer fires an event when a new message is available.

---------------------------------------
C#csharp Copy Code
void TestAQ() {
  OracleConnection oracleConnection = new OracleConnection(
     "User Id=system;Password=manager;Server=ora;");
  oracleConnection.Open();
  OracleQueueTable oracleQueueTable = new OracleQueueTable(
     "QUEUE_TABLE_MESSAGE", oracleConnection);

  // Set the table to serve multiple consumers.
  oracleQueueTable.Options.MultipleConsumers = true;
  oracleQueueTable.Options.PayloadTypeName = "RAW";
  oracleQueueTable.CreateQueueTable();
  OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
     "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
  oracleQueueAdmin.CreateQueue();
  oracleQueueAdmin.StartQueue();

  // The OracleQueueAgent represents an AQ publisher or subscriber.
  // We register Bob and Scott as known subscribers so that the application is able to send messages to Bob or Scott personally.
  oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));
  oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Scott"));

  OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

  // This message will be delivered to Bob only.
  OracleQueueMessage message1 = new OracleQueueMessage();
  message1.StringPayload = "Message for Bob.";
  message1.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));

  // This message will be delivered to all recipients, as there is
  // no specific member in the recipients list.
  OracleQueueMessage message2 = new OracleQueueMessage();
  message2.StringPayload = "Message for all.";

  // Create an OracleQueue instance that will receive general notifications
  // and notifications for Scott.
  // The Navigation property specifies which message of the queue will be retrieved.
  OracleQueue oracleDequeueScott = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
  oracleDequeueScott.DequeueOptions.Navigation = OracleQueueNavigation.FirstMessage;
  oracleDequeueScott.DequeueOptions.ConsumerName = "Scott";

  // Set up asynchronous notification using events.
  // The event just signals that a new message is available;
  // messages are not dequeued implicitly.
  oracleDequeueScott.AsyncNotification = true;
  oracleDequeueScott.OnMessage += new OracleQueueMessageEventHandler(
        oracleDequeueScott_OnMessage);

  // Create an OracleQueue instance that will receive general
  // notifications and notifications for Bob.
  OracleQueue oracleDequeueBob = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
  oracleDequeueBob.DequeueOptions.Navigation = OracleQueueNavigation.FirstMessage;
  oracleDequeueBob.DequeueOptions.ConsumerName = "Bob";
  oracleDequeueBob.AsyncNotification = true;
  oracleDequeueBob.OnMessage += new OracleQueueMessageEventHandler(
        oracleDequeueBob_OnMessage);

  // Enqueue the messages
  oracleEnqueueQueue.Enqueue(message1);
  oracleEnqueueQueue.Enqueue(message2);

  // Wait a little so the events can fire.
  System.Threading.Thread.Sleep(5000);

  oracleQueueAdmin.StopQueue();
  oracleQueueAdmin.DropQueue();
  oracleQueueTable.DropQueueTable();

  oracleConnection.Close();
}

// A helper function that dequeues messages during an event
  string getMessageData(object sender, OracleQueueMessageEventArgs e) {
  OracleQueue oracleDequeue = sender as OracleQueue;
  OracleQueueDequeueOptions dequeueOptions = oracleDequeue.DequeueOptions;
  dequeueOptions.MessageId = e.MessageId;
  // Messages are not deleted from server once dequeued.
  dequeueOptions.DequeueMode = OracleQueueDequeueMode.Browse;
  OracleQueueMessage msg = oracleDequeue.Dequeue(dequeueOptions);
  return msg.StringPayload;
}

// Simple event handlers that write message text into console
// when a message is received
void oracleDequeueBob_OnMessage(object sender, OracleQueueMessageEventArgs e) {
  string messageData = getMessageData(sender, e);
  Console.WriteLine("Bob receives a message: " + messageData);
}

void oracleDequeueScott_OnMessage(object sender, OracleQueueMessageEventArgs e) {
  string messageData = getMessageData(sender, e);
  Console.WriteLine("Scott receives a message: " + messageData);
}
Visual Basic Copy Code
Private Sub TestAQ()
  Dim oracleConnection As New OracleConnection( _
       "User Id=system;Password=manager;Server=ora;")
  oracleConnection.Open()
  Dim oracleQueueTable As New OracleQueueTable( _
       "QUEUE_TABLE_MESSAGE", oracleConnection)

  ' Set the table to serve multiple consumers.
  oracleQueueTable.Options.MultipleConsumers = True
  oracleQueueTable.Options.PayloadTypeName = "RAW"
  oracleQueueTable.CreateQueueTable()
  Dim oracleQueueAdmin As New OracleQueueAdmin( _
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
  oracleQueueAdmin.CreateQueue()
  oracleQueueAdmin.StartQueue()

  ' The OracleQueueAgent represents an AQ publisher or subscriber.
  ' We register Bob and Scott as known subscribers so that the application is able to send messages to Bob or Scott personall
  oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))
  oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Scott"))

  Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

  ' This message will be delivered to Bob only.
  Dim message1 As New OracleQueueMessage
  message1.StringPayload = "Message for Bob."
  message1.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))

  ' This message will be delivered to all recipients, as there is
  ' no specific member in the recipients list.
  Dim message2 As New OracleQueueMessage
  message2.StringPayload = "Message for all."

  ' Create an OracleQueue instance that will receive general notifications
  ' and notifications for Scott.
  ' The Navigation property specifies which message of the queue will be retrieved.
  Dim oracleDequeueScott As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
  oracleDequeueScott.DequeueOptions.Navigation = OracleQueueNavigation.FirstMessage
  oracleDequeueScott.DequeueOptions.ConsumerName = "Scott"

  ' Set up asynchronous notification using events.
  ' The event just signals that a new message is available;
  oracleDequeueScott.AsyncNotification = True
  AddHandler oracleDequeueScott.OnMessage, _
      New OracleQueueMessageEventHandler(AddressOf oracleDequeueScott_OnMessage)

  ' Create an OracleQueue instance that will receive general
  ' notifications and notifications for Bob.
  Dim oracleDequeueBob As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
  oracleDequeueBob.DequeueOptions.Navigation = OracleQueueNavigation.FirstMessage
  oracleDequeueBob.DequeueOptions.ConsumerName = "Bob"
  oracleDequeueBob.AsyncNotification = True
  AddHandler oracleDequeueBob.OnMessage, _
      New OracleQueueMessageEventHandler(AddressOf oracleDequeueBob_OnMessage)

  ' Enqueue the messages
  oracleEnqueueQueue.Enqueue(message1)
  oracleEnqueueQueue.Enqueue(message2)

  ' Wait a little so the events can fire.
  System.Threading.Thread.Sleep(5000)

  oracleQueueAdmin.StopQueue()
  oracleQueueAdmin.DropQueue()
  oracleQueueTable.DropQueueTable()

  oracleConnection.Close()
End Sub

' A helper function that dequeues messages during an event
Private Function getMessageData(ByVal sender As Object, _
    ByVal e As OracleQueueMessageEventArgs) As String
  Dim oracleDequeue As OracleQueue = TryCast(sender, OracleQueue)
  Dim dequeueOptions As OracleQueueDequeueOptions = oracleDequeue.DequeueOptions
  dequeueOptions.MessageId = e.MessageId
  ' Messages are not deleted from server once dequeued.
  dequeueOptions.DequeueMode = OracleQueueDequeueMode.Browse
  Dim msg As OracleQueueMessage = oracleDequeue.Dequeue(dequeueOptions)
  Return msg.StringPayload
End Function

' Simple event handlers that write message text into console
' when a message is received
Private Sub oracleDequeueBob_OnMessage(ByVal sender As Object, _
    ByVal e As OracleQueueMessageEventArgs)
  Dim messageData As String = getMessageData(sender, e)
  Console.WriteLine(("Bob receives a message: " + messageData))
End Sub

Private Sub oracleDequeueScott_OnMessage(ByVal sender As Object, _
    ByVal e As OracleQueueMessageEventArgs)
  Dim messageData As String = getMessageData(sender, e)
  Console.WriteLine(("Scott receives a message: " + messageData))
End Sub

As seen in the three examples in this article, most administrative tasks can be accomplished by OracleQueueTable and OracleQueueAdmin classes. Note that administering queues often requires a rich set of privileges in the database.

See Also

OracleQueueTable Class | OracleQueueAdmin Class


Using OracleTrace Component

Oracle trace Documentation
Using OracleTrace Component
support@devart.com

The OracleTrace component provides functionality for tracing the SQL and PL/SQL commands execution on the server side. The SQL trace is stored in log files located on the server. The PL/SQL trace is stored in the database tables.

Call the SqlTraceStart() method or set the Enabled property to true for the SQL trace starting. It starts both SQL and PL/SQL traces. The SQL trace automatically chooses a log file where the trace will be written. The full path of this file can be retrieved by the GetTraceFileName() method. Use MaxTraceFileSize property to limit the size of this log file. The SqlTraceMode property specifies which type of statistics should be collected while tracing.

The PL/SQL trace needs the DBMS_TRACE package installed on the server. The PLSQL_TRACE_RUNS and PLSQL_TRACE_EVENTS tables are created to store log. This may be done by executing the tracetab.sql script available in the Oracle database/client installation package. The first table stores information about the trace runs, such as the time when trace started and finished, the trace owner, etc. The second table contains description of events happened while trace was active.

Call the PlSqlTraceStart() method or set the Enabled property to true for the PL/SQL trace starting. It will start the SQL trace as well. You need permissions to execute a DBMS_TRACE package to start PL/SQL tracing. The PL/SQL trace may be paused and resumed by the PlSqlTracePause and PlSqlTraceResume methods. The PlSqlTraceLimit method allows to limit the storage size used for the trace data in the database. The PlSqlTraceMode property specifies the tracing mode, i.e. events of which types should be traced.

C#csharp Copy Code
// Initialize and open the connection to your Oracle server
// Connect as "system" to have the privileges needed to operate with the DBMS_TRACE package
OracleConnection connection = new OracleConnection();
connection.Server = "ORA";
connection.UserId = "system";
connection.Password = "password";
connection.ConnectMode = OracleConnectMode.SysDba;
connection.Open();

// Create the OracleTrace object representing the DBMS_TRACE package functionality.
OracleTrace trace = new OracleTrace(connection);

// Check the full path of the file where the trace log is stored
string path = trace.GetTraceFileName();
Console.WriteLine("The trace file: " + path);

// Create and execute a simple select query
// Observe that nothing was written to the trace file
OracleCommand command = new OracleCommand("select * from scott.dept", connection);
command.ExecuteReader();

// Start tracing the SQL commands execution.
trace.SqlTraceStart();

// Again execute the same command.
// The trace log contains now detailed information on the query performed.
command.ExecuteReader();

// Set the trace to observe the PL/SQL commands execution.
// The PL/SQL trace log is stored in the special database tables.
// By default, the PL/SQL trace mode is not set,
// thus we need to change it, e.g., to tracing all PL/SQL calls.
trace.PlSqlTraceMode = PlSqlTraceMode.AllCalls;
trace.PlSqlTraceStart();

// Now tracing for both SQL and PL/SQL execution is enabled.
// Note that this may be done by setting the Enabled property to true as well.

// Create an PL/SQL command.
string plsqlCode = @"
DECLARE
i INTEGER;
BEGIN
i:= 1;
FOR rec IN (SELECT DeptNo FROM Scott.Dept
   WHERE RowNum <= 4 ORDER BY DeptNo)
LOOP
   UPDATE Scott.Dept
   SET DName = :NameArr(i)
   WHERE DeptNo = Rec.DeptNo;
   i:= i + 1;
END LOOP;
END;
";
string[] nameArray = { "Accounting", "Research", "Sales", "Operations" };
command = new OracleCommand(plsqlCode,connection);
command.Parameters.Add("NameArr", OracleDbType.VarChar);
command.Parameters["NameArr"].ArrayLength = 4;
Visual Basic Copy Code
Dim connection As New OracleConnection
connection.Server = "ORA"
connection.UserId = "system"
connection.Password = "password"
connection.ConnectMode = 2
connection.Open()
Dim trace As New OracleTrace(connection)
Console.WriteLine(("The trace file: " & trace.GetTraceFileName))
Dim command As New OracleCommand("select * from scott.dept", connection)
command.ExecuteReader()
trace.SqlTraceStart()
command.ExecuteReader()
trace.PlSqlTraceMode = 1
trace.PlSqlTraceStart()
Dim plsqlCode As String = VbCrlf &
"DECLARE" & VbCrlf &
"i INTEGER;" & VbCrlf &
"BEGIN" & VbCrlf &
"i:= 1;" & VbCrlf &
"FOR rec IN (SELECT DeptNo FROM Scott.Dept" & VbCrlf &
"   WHERE RowNum <= 4 ORDER BY DeptNo)" & VbCrlf &
"LOOP" & VbCrlf & "   UPDATE Scott.Dept" & VbCrlf &
"   SET DName = :NameArr(i)" & VbCrlf &
"   WHERE DeptNo = Rec.DeptNo;" & VbCrlf &
"   i:= i + 1;" & VbCrlf &
"END LOOP;" & VbCrlf &
"END;" & VbCrlf

Dim nameArray As String() = New String() {"Accounting", "Research", "Sales", "Operations"}
command = New OracleCommand(plsqlCode, connection)
command.Parameters.Add("NameArr", &H1C)
command.Parameters("NameArr").ArrayLength = 4

See Also

Devart.Data.Oracle.OracleTrace class | Using DbMonitor


Using OracleAlerter Component

Using OracleAlerter Component
support@devart.com
OracleAlerter class is an interface for the DBMS_ALERT package. It is available in Professional and Developer Editions only.

The DBMS_ALERT package supports asynchronous notification of database events (alerts). By appropriate use of this package and database triggers, an application can notify any other applications, connected to this database and registered for alerts receiving, about any changes in the database. You can read more about this package here.
This topic provides information and examples that can help you start with Oracle alerts. It consists of the following sections:

  • Oracle Alert basics
  • "Wait alert" mode
  • "Start" mode

Oracle Alert Basics

DBMS_ALERT provides APIs to send alerts, register for alerts, and wait to receive them. The procedures this Solution uses are SIGNAL, REGISTER, and WAITANY:

  • The DBMS_ALERT.SIGNAL procedure signals an alert. The SIGNAL call goes into effect only when the transaction in which it is made commits. If the transaction rolls back, SIGNAL has no effect. All sessions that have registered interest in this alert are notified. (If the application does not require transaction-based alerts, the DBMS_PIPE package may provide a useful alternative).
  • The DBMS_ALERT.REGISTER procedure lets a session register interest in an alert.
  • The DBMS_ALERT.WAITANY procedure waits for any of the alerts for which the current session is registered to occur.

The main principle of OracleAlerter class is shown on the figure below:

The OracleAlerter class supports two modes of work: "WaitAlert" and "Start". The "WaitAlert" mode waits for the nearest alert and returns it to the application. The "Start" launches once and raizes an event each time when alert is received. To stop this mode, call the "Stop" method of the OracleAlerter class instance.

"WaitAlert" mode

The following sample demonstrates the work with OracleAlerter in "WaitAlert" mode.

A simple table and a trigger are created in the database. The trigger generates an Oracle Alert each time when row is added to the table. Then, the OracleAlerter instance is initialized and set up to wait for the alert mentioned. While OracleAlerter is waiting, in another thread a row is inserted to the table, thus triggering the alert. Then the WaitAlert method returns this alert as an OracleAlert object.

C#csharp Copy Code
static OracleConnection con = new OracleConnection();

static void Main(string[] args)
{

  // Initialize and open a connection to the Oracle server.
  // We connect as Sys to have the privilieges to use the DBMS_Alert package.

  con.Server = "ora";
  con.UserId = "sys";
  con.Password = "pwd";
  con.ConnectMode = OracleConnectMode.SysDba;
  con.Open();

  // Execute a script needed to create the database objects used in our sample.
  // These objects are:
  // 1) table "alert_table" with two fields: an integer identification and a char value;
  // 2) trigger "alert_trigger", which initializes the "my_alert" Oracle Alert after each insert to alert_table.

  OracleScript createAll = new OracleScript();
  createAll.Connection = con;
  createAll.ScriptText = @"
  create table scott.alert_table
  (""id"" number(38,0),
   ""value"" varchar2(4000 byte)
  );

  create or replace trigger sys.alert_trigger
    after insert or update on scott.alert_table
    for each row
    begin
      dbms_alert.signal('my_alert', 'A row has been added.');
    end;
  ";

  createAll.Execute();

  // Now we create an instance of the OracleAlerter class, which is used to retrieve alerts.
  // This instance is registered for the "my_alert" Oracle Alert.
  // Timeout stands for the time in seconds during which OracleAlerter will be waiting for alerts.

  OracleAlerter alerter = new OracleAlerter();
  alerter.Connection = con;
  alerter.AlertName = "my_alert";
  alerter.Timeout = 10;

  // When waiting for alerts, OracleAlerter expectedly pauses the current thread.
  // Thus, we need another one to generate the alert while OracleAlerter is listening.
  // In the Insert() function, a row is added to alert_table.
  // As it is shown in the createAll script, this insert triggers the "my_alert" Oracle Alert.

  Thread insertThread = new Thread(new ThreadStart(Insert));
  insertThread.Start();

  // Waits until the "my_alert" alert is received, returns the corresponding OracleAlert object.
  // If it is not during the timeout period, returns null.

  OracleAlert alert = alerter.WaitAlert();

  // Simple output operations to show the alert's content.
  Console.WriteLine("Got an alert: " + ((alert == null) ? "null" : alert.Message));
  Console.Read();

  // Drop table and trigger.
  OracleScript dropAll = new OracleScript();
  dropAll.Connection = con;
  dropAll.ScriptText = @"
  drop trigger sys.alert_trigger;
  drop table scott.alert_table;
  ";
  dropAll.Execute();

  // Close the connection.
  con.Close();
}

// A simple insert command used to trigger the "my_alert" alert.
// We take this command out to use multithreading.

public static void Insert()
{
   OracleCommand insert = new OracleCommand();
   insert.CommandText = "insert into scott.alert_table values ('10', 'Some text')";
   insert.Connection = con;
   insert.ExecuteNonQuery();

   Console.WriteLine("Inserted a row");
}
Visual Basic Copy Code
Private Shared con As New OracleConnection

Shared Sub Main(ByVal args As String())

    ' Initialize and open a connection to the Oracle server.
    ' We connect as Sys to have the privilieges to use the DBMS_Alert package.
    con.Server = "ora"
    con.UserId = "sys"
    con.Password = "pwd"
    con.ConnectMode = OracleConnectMode.SysDba
    con.Open

    ' Execute a script needed to create the database objects used in our sample.
    ' These objects are:
    ' 1) table "alert_table" with two fields: an integer identification and a char value;
    ' 2) trigger "alert_trigger", which initializes the "my_alert" Oracle Alert after each insert to alert_table.

    Dim createAll As New OracleScript
    createAll.Connection = con
    createAll.ScriptText = VbCrlf _
    & "        " _
     & "create table scott.alert_table " & VbCrlf _
     & "        (""id"" number(38,0), " & VbCrlf _
    & "   ""value"" varchar2(4000 byte)" & VbCrlf & _
    "                );" & VbCrlf  & VbCrlf _
    & "                create or replace trigger sys.alert_trigger " & VbCrlf & _
    "                    after insert or update on scott.alert_table " & VbCrlf & _
    "                    for each row " & VbCrlf & _
    "                    begin" & VbCrlf _
    & "                        dbms_alert.signal('my_alert', 'A row has been added.');" _
    & VbCrlf & "                    end;" & VbCrlf & "        "
    createAll.Execute

    ' Now we create an instance of the OracleAlerter class, which is used to retrieve alerts.
    ' This instance is registered for the "my_alert" Oracle Alert.
    ' Timeout stands for the time in seconds during which OracleAlerter will be waiting for alerts.

    Dim alerter As New OracleAlerter
    alerter.Connection = con
    alerter.AlertName = "my_alert"
    alerter.Timeout = 10

    ' When waiting for alerts, OracleAlerter expectedly pauses the current thread.
    ' Thus, we need another one to generate the alert while OracleAlerter is listening.
    ' In the Insert() function, a row is added to alert_table.
    ' As it is shown in the createAll script, this insert triggers the "my_alert" Oracle Alert.
    Dim insertThread As Thread = New Thread(New ThreadStart(insert))
    insertThread.Start()

    ' Waits until the "my_alert" alert is received, returns the corresponding OracleAlert object.
    ' If it is not during the timeout period, returns null.
    Dim alert As OracleAlert = alerter.WaitAlert

    ' Simple output operations to show the alert's content.
    Console.WriteLine(("Got an alert: " & IIf((alert Is Nothing), "null", alert.Message)))
    Console.Read

    ' Drop table and trigger.
    Dim dropAll As New OracleScript
    dropAll.Connection = con
    dropAll.ScriptText = VbCrlf & _
    "        "  & "drop trigger sys.alert_trigger;" & VbCrlf & _
    "        "  & "drop table scott.alert_table;" & VbCrlf
    dropAll.Execute

    ' Close the connection.
    con.Close
End Sub

' A simple insert command used to trigger the "my_alert" alert.
' We take this command out to use multithreading.
Public Shared Sub Insert()
    Dim createAll As New OracleCommand
    createAll.CommandText = "insert into scott.alert_table values ('10', 'Some text')"
    createAll.Connection = con
    createAll.ExecuteNonQuery
    Console.WriteLine("Inserted a row")
End Sub

"Start" mode

In this sample, we use the "Start" mode of alerts retrieving. The OracleAlerter object "alerter" is initialized and set up to listen for the specific alert. Then, another instance of the OracleAlerter class, "alertGenerator", sends alerts with the same name to the server, thus firing the Alert events. After the waiting time expires, the WaitTimeout event is raised and listening starts again. Then the alerter object is stopped to show the Stopped event.

C#csharp Copy Code
static void Main(string[] args)
{
    // Initialize and open a connection to the Oracle server.
    // We connect as Sys to have the privilieges to use the DBMS_Alert package.
    OracleConnection con = new OracleConnection();
    con.Server = "ora";
    con.UserId = "sys";
    con.Password = "pwd";
    con.ConnectMode = OracleConnectMode.SysDba;
    con.Open();

    // Create the OracleAlerter instance and register it for the "my_alert" Oracle Alert.
    // Set Interval to 0 so that there is no delay between two consequent periods of listening.
    OracleAlerter alerter = new OracleAlerter();
    alerter.Connection = con;
    alerter.AlertName = "my_alert";
    alerter.Timeout = 3;
    alerter.Interval = 0;

    // Set the event handlers for all possible OracleAlerter events.
    // The Alert event fires when an alert is received.
    // The Error event fires as any error occurs while receiving alerts.
    // The Stopped event fires when alerter becomes inactive, e.g. after the Stop() method.
    // The WaitTimeout event fires when the Timeout period ends without getting an alert.
    alerter.Alert += new OracleAlerterAlertEventHandler(Alerter_OnAlert);
    alerter.Error += new OracleAlerterErrorEventHandler(Alerter_OnError);
    alerter.Stopped += new OracleAlerterFinishEventHandler(Alerter_OnStop);
    alerter.WaitTimeout += new OracleAlerterFinishEventHandler(Alerter_OnTimeOut);

    // Start the alerter. It will wait for alerts during the Timeout period.
    // After that, it sleeps during Interval and then starts again.
    // As Interval is zero, there will be no sleeping periods.
    // Unlike the WaitAlert method, Start() does not hold the current thread.
    alerter.Start();

    // We need to wait until the alerter begins listening.
    // Otherwise, the alert may fire before OracleAlerter is initialized.
    // In this case, the Alert event won't be triggered and alerter will just wait
    // until Timeout, producing the WaitTimeout event.
    Thread.Sleep(2000);

    // In this sample, we use another instance of OracleAlerter instead of database triggers to generate the alert.
    // alertGenerator uses the same connection and alert name as the alerter object.
    OracleAlerter alertGenerator = new OracleAlerter();
    alertGenerator.Connection = con;
    alertGenerator.AlertName = "my_alert";

    // Send an alert to the server. At this moment alerter should raise the Alert event.
    alertGenerator.Signal("An alert message.");

    // In contrast to WaitAlert(), the Start() method allows to receive alerts continuously.
    // Thus, we can process all alerts that are available on the server.
    alertGenerator.Signal("One more alert");

    // After the alert is received, alerter starts another Timeout period.
    // At its end, the WaitTimeout event will be generated. We pause the thread to get this event.
    // Besides, we need a small pause to let the last alert be sent to the server.
    Thread.Sleep(5000);

    // Disable alerter, raising the Stopped event.
    alerter.Stop();

    Console.Read();

    // Close the connection.
    con.Close();
}

// Simple event handlers for alerter's events.
public static void Alerter_OnAlert(object sender, OracleAlerterAlertEventArgs e)
{
    Console.WriteLine("Got an alert: " + e.AlertMessage);
}
public static void Alerter_OnError(object sender, OracleAlerterErrorEventArgs e)
{
    Console.WriteLine("Error: " + e.AlerterException.Message);
}
public static void Alerter_OnStop(object sender, OracleAlerterFinishEventArgs e)
{
    Console.WriteLine("Stopped: " + e.ToString());
}
public static void Alerter_OnTimeOut(object sender, OracleAlerterFinishEventArgs e)
{
    Console.WriteLine("Time's up: " + e.ToString());
}

Visual Basic Copy Code
Shared Sub Main(ByVal args As String())

    ' Initialize and open a connection to the Oracle server.
    ' We connect as Sys to have the privilieges to use the DBMS_Alert package.
    Dim con As New OracleConnection
    con.Server = "ora"
    con.UserId = "sys"
    con.Password = "pwd"
    con.ConnectMode = OracleConnectMode.SysDba
    con.Open

    ' Create the OracleAlerter instance and register it for the "my_alert" Oracle Alert.
    ' Set Interval to 0 so that there is no delay between two consequent periods of listening.
    Dim alerter As New OracleAlerter
    alerter.Connection = con
    alerter.AlertName = "my_alert"
    alerter.Timeout = 3
    alerter.Interval = 0

    ' Set the event handlers for all possible OracleAlerter events.
    ' The Alert event fires when an alert is received.
    ' The Error event fires as any error occurs while receiving alerts.
    ' The Stopped event fires when alerter becomes inactive, e.g. after the Stop() method.
    ' The WaitTimeout event fires when the Timeout period ends without getting an alert.
    AddHandler alerter.Alert, New OracleAlerterAlertEventHandler(AddressOf Alerter_OnAlert)
    AddHandler alerter.Error, New OracleAlerterErrorEventHandler(AddressOf Alerter_OnError)
    AddHandler alerter.Stopped, New OracleAlerterFinishEventHandler(AddressOf Alerter_OnStop)
    AddHandler alerter.WaitTimeout, New OracleAlerterFinishEventHandler(AddressOf Alerter_OnTimeOut)

    ' Start the alerter. It will wait for alerts during the Timeout period.
    ' After that, it sleeps during Interval and then starts again.
    ' As Interval is zero, there will be no sleeping periods.
    ' Unlike the WaitAlert method, Start() does not hold the current thread.
    alerter.Start

    ' We need to wait until the alerter begins listening.
    ' Otherwise, the alert may fire before OracleAlerter is initialized.
    ' In this case, the Alert event won't be triggered and alerter will just wait
    ' until Timeout, producing the WaitTimeout event.
    Thread.Sleep(2000)

    ' In this sample, we use another instance of OracleAlerter instead of database triggers to generate the alert.
    ' alertGenerator uses the same connection and alert name as the alerter object.
    Dim alertGenerator As New OracleAlerter
    alertGenerator.Connection = con
    alertGenerator.AlertName = "my_alert"

    ' Send an alert to the server. At this moment alerter should raise the Alert event.
    alertGenerator.Signal("An alert message.")

    ' In contrast to WaitAlert(), the Start() method allows to receive alerts continuously.
    ' Thus, we can process all alerts that are available on the server.
    alertGenerator.Signal("One more alert")

    ' After the alert is received, alerter starts another Timeout period.
    ' At its end, the WaitTimeout event will be generated. We pause the thread to get this event.
    ' Besides, we need a small pause to let the last alert be sent to the server.
    Thread.Sleep(5000)

    ' Disable alerter, raising the Stopped event.
    alerter.Stop
    Console.Read

    ' Close the connection.
    con.Close
End Sub

Public Shared Sub Alerter_OnAlert(ByVal sender As Object, ByVal e As OracleAlerterAlertEventArgs)
    Console.WriteLine(("Got an alert: " & e.AlertMessage))
End Sub

Public Shared Sub Alerter_OnError(ByVal sender As Object, ByVal e As OracleAlerterErrorEventArgs)
    Console.WriteLine(("Error: " & e.AlerterException.Message))
End Sub

Public Shared Sub Alerter_OnStop(ByVal sender As Object, ByVal e As OracleAlerterFinishEventArgs)
    Console.WriteLine(("Stopped: " & e.ToString))
End Sub

Public Shared Sub Alerter_OnTimeOut(ByVal sender As Object, ByVal e As OracleAlerterFinishEventArgs)
    Console.WriteLine(("Time's up: " & e.ToString))
End Sub

See Also

Devart.Data.Oracle.OracleAlerter class


Transparent Application Failover Support

Transparent Application Failover Support
support@devart.com

Transparent application failover (TAF) is the ability of applications to automatically reconnect to the database if the connection fails. If the server fails, the connection fails as well. The next time the client tries to use the connection, e.g., to execute a new SQL statement, the operating system displays an error to the client. At this point, the user must log in to the database again. With TAF, however, Oracle automatically obtains a new connection to the database. This allows the user to continue to work using the new connection as if the original connection had never failed. If the client is not involved in a database transaction, then users may not notice the failure of the server. Because this reconnect happens automatically, the client application code may not need changes to use TAF. TAF automatically restores:

  • Client-Server Database Connections;
  • Users' Database Sessions;
  • Executing Commands;
  • Open Cursors Used for Fetching;
  • Active Transactions;
  • Server-Side Program Variables.

Unfortunately, TAF cannot automatically restore some session properties. If the application issued ALTER SESSION commands, then the application must reissue them after TAF processing is complete.

Frequently failure of one instance and failover to another takes time. Because of this delay, you may want to inform users that failover is in progress. Additionally, the session on the initial instance may have received some ALTER SESSION commands. These will not be automatically reissued on the second instance. You may need to reissue these commands on the second instance.

To address such problems, you can use the OracleConnection.Failover event. This event is raised during session recovery process when connection is lost. When connection failure is detected Failover event is raised first time. Then application keeps raising it until connection is restored or user stops failover process.

Transparent Application Failover Restrictions:

  • All PL/SQL package states on the server are lost at failover.
  • ALTER SESSION statements are lost.
  • If failover occurs when a transaction is in process, then each subsequent call causes an error message until the user issues Rollback call. Then a success message is issued. Be sure to check this informational message to see if you must perform any additional operations.
  • Continuing work on failed over cursors may cause an error message.
  • If the first command after failover is not a SELECT statement or fetch operation, an error message results.
  • Failover only takes effect for Oracle 8.0 or higher.
  • At failover time, any queries in progress are reissued and processed again from the beginning. This may result in the next query taking a long time if the original query took a long time.
  • This feature works only for server shutdown. It doesn't help to resolve connection problems caused by network.

Preparing and Running the Sample

To enable TAF on the Oracle server, the corresponding entry in the tnsnames.ora file should be modified. The tnsnames.ora file is located at <Oracle_Home>\network\Admin directory where <Oracle_Home> is the directory where your Oracle database or client is installed. For example, the TNS entry for the server with TAF may look like this:

<DBFAILOVER> =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = SERVER)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SID = ORCL)
      (FAILOVER_MODE = (TYPE = SELECT) (METHOD = BASIC) (RETRIES=100))
    )
  )

For the detailed information on possible subparameters of FAILOVER_MODE, refer to the Oracle documentation

The following sample shows how TAF may be used. First, we create a connection and subscribe a method for the Failover event of this connection:

First register method as Failover event handler.

C#csharp Copy Code
...
OracleConnection conn = new OracleConnection(
   "User Id=scott;Password=tiger;Data Source=DBFAILOVER.US.ORACLE.COM");
conn.Failover += new OracleFailoverEventHandler(conn_Failover);
...
Visual Basic Copy Code
...
Dim conn As OracleConnection = new OracleConnection( _
   "User Id=scott;Password=tiger;Data Source=DBFAILOVER.US.ORACLE.COM")
AddHandler conn.Failover, New OracleFailoverEventHandler(AddressOf conn_Failover)
...

To demonstrate the failover, we break the connection at this moment (see below how to do so). We try to execute a simple query, and the failover process starts:

C#csharp Copy Code
...
OracleCommand cmd = new OracleCommand("SELECT * FROM dept", conn);
cmd.ExecuteReader();
...
Visual Basic Copy Code
...
Dim cmd As New OracleCommand("SELECT * FROM dept", conn)
cmd.ExecuteReader()
...
Here is the implementation of the conn_Failover method:
C#csharp Copy Code
public void conn_Failover(object sender, OracleFailoverEventsArgs eventArgs)
{
  switch(eventArgs.State)
  {
    // The connection was lost and the failover started
    case OracleFailoverState.Begin:
      Console.WriteLine("Failover began");
    break;

    // Failover was aborted
    case OracleFailoverState.Abort:
      Console.WriteLine("Failover aborted");
      break;

    // Failover completed successfully
    case OracleFailoverState.End:
      Console.WriteLine("Failover ended");
      break;

    // An error occurred while reconnecting
    case OracleFailoverState.Error:
      // Retry re-establishing the connection
      eventArgs.Retry = true;
      Console.WriteLine("An error occurred, trying again");
      break;

    // Reautentication is required during failover
    case OracleFailoverState.Reauth:
      Console.WriteLine("Reauthenticating");
      break;

    // Unknown stage, may indicate a failover internal error
    default:
      Console.WriteLine("Unknown failover stage");
      break;
  }
}
Visual Basic Copy Code
Private Sub conn_Failover(ByVal sender As Object, _
   ByVal eventArgs As OracleFailoverEventsArgs)

  Select eventArgs.State

    ' The connection was lost and the failover started
    Case OracleFailoverState.Begin
      Console.WriteLine("Failover began");

    ' Failover was aborted
    Case OracleFailoverState.Abort
      Console.WriteLine("Failover aborted")

    ' Failover completed successfully
    Case OracleFailoverState.End
      Console.WriteLine("Failover End")

    ' An error occurred while reconnecting
    Case OracleFailoverState.Error
      ' Retry re-establishing the connection
      eventArgs.Retry = true
      Console.WriteLine("An error occurred, trying again")

    ' Reautentication is required during failover
    Case OracleFailoverState.Reauth
      Console.WriteLine("Reauthenticating")

    ' Unknown stage, may indicate a failover internal error
    Case Else
      Console.WriteLine("Unknown failover stage")

  End Select
End Sub

When TAF occurs, this method is called. Different values of the State event argument allow to perform appropriate actions on the corresponding stage of the failover process. E.g., it is possible to inform user that the connection failed and is re-establishing, or ask whether it is necessary to reconnect, or ask for credentials if re-authorizing is necessary. Provided that failover succeeds, the query will be executed again with a new connection.

To try TAF, you need to break the connection after it is opened, e.g., by shutting down the Oracle server. This can be done with the SQL*Plus tool. First, it is necessary to login as a user with SYSDBA privileges:

SQL> Connect sys/<password>@<TNSName> as sysdba

Here <password> and <TNSName> should be replaced with the password of the sys user and the TNS name of the server. To shutdown the server, run the command

SQL> shutdown immediate

(the 'immediate' keyword is necessary to tell the server that it should not wait for the pending connection we've opened before). To restart the server, run

SQL> startup

See Also

OracleConnection.Failover event | Devart.Data.Oracle Namespace


Working with Data

Working with Data
support@devart.com

This section describes the features of dotConnect for Oracle that are designed to support Oracle-specific data types and technologies.

  • Array Binding

    Shows how to use array parameters, or DML arrays, to speed up inserting and updating data operations.

  • BLOB and CLOB Data

    Shows how to work with Oracle Large Objects in dotConnect for Oracle. Large Objects, or LOBs, are huge (up to 4 Gbytes) streams of data stored in a database.

  • Cursors

    Shows how to use Oracle cursors, the variables pointing to results sets, with dotConnect for Oracle.

The following topics contain information about support of user-defined types, including PL/SQL collections:

  • PL/SQL Tables

    Describes how to work with PL/SQL tables.

  • UDT Objects

    Shows main concepts of working with Oracle user-defined types.

  • VARRAY Type

    Describes how to work with PL/SQL arrays.


Array Binding

Array Binding
support@devart.com

Using the Oracle array binding feature can greatly speed up execution of the application when inserting or updating big volumes of data. The main advantage is that array binding allows you to execute several INSERT SQL statements with the different parameters for the one time. Note that you access Oracle server only once that increases the speed of update a lot.

In Direct mode you cannot use array binding with Oracle objects.

The following Oracle table definition will be used in our VB and C# samples:

CREATE TABLE dept
(
  deptno NUMBER(2) CONSTRAINT pk_dept PRIMARY KEY,
  dname VARCHAR2(14),
  loc VARCHAR2(13)
);

At first, you should create an object of OracleConnection class and open a connection to Oracle database:

C#csharp Copy Code
...
OracleConnection conn = new OracleConnection(
   "User Id=Scott;Password=tiger;Data Source=Ora");
conn.Open();
...
Visual Basic Copy Code
...
Dim conn As OracleConnection = new OracleConnection( _
   "User Id=Scott;Password=tiger;Data Source=Ora")
conn.Open()
...

Please note that it is only a cut of sample code. The full text will be given at the end of this article.

After that you should create an instance of OracleCommand class associated with the OracleConnection object and specify SQL statement for the execution:

C#csharp Copy Code
...
OracleCommand cmd = conn.CreateCommand();
cmd.CommandText = "INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)";
...
Visual Basic Copy Code
...
Dim cmd As OracleCommand = conn.CreateCommand()
cmd.CommandText = "INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)"
...

Colons at SQL text mean parameters with the values which will be specified later.

Now for each parameter from SQL you should associate an object of OracleParameter class and add this object to the collection of the parameters of OracleCommand objects. Association is accomplished by the names of parameters in following way:

C#csharp Copy Code
...
cmd.Parameters.Add("deptno_p", OracleDbType.Integer);
cmd.Parameters.Add("dname_p", OracleDbType.VarChar, 200);
cmd.Parameters.Add("loc_p", OracleDbType.VarChar, 200);
...
Visual Basic Copy Code
...
cmd.Parameters.Add("deptno_p", OracleDbType.Integer)
cmd.Parameters.Add("dname_p", OracleDbType.VarChar, 200)
cmd.Parameters.Add("loc_p", OracleDbType.VarChar, 200)
...

You should specify the name of each parameter and its type. For VarChar/NVarChar parameters it is also recommended to specify size of the parameter explicitly. This size should be more or equal to the size (in bytes) of the longest string in the array. You may omit specifying the size. In this case it will be determined automatically, however this may cause some performance overhead.

The next important point is assigning values to the parameters. Parameter values should be arrays with the length corresponding to the number of SQL statement executions. And each item of the array must correspond to the single execution of the SQL statement.

C#csharp Copy Code
...
cmd.Parameters["deptno_p"].Value = new int[] { 10, 20, 30, 40 };
cmd.Parameters["dname_p"].Value = new string[] {
   "ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS" };
cmd.Parameters["loc_p"].Value = new string[] {
   "NEW YORK", "DALLAS", "CHICAGO", "BOSTON" };
...
Visual Basic Copy Code
...
Dim deptno(3) As Integer
deptno(0) = 10
deptno(1) = 20
deptno(2) = 30
deptno(3) = 40

Dim dname(3) As String
dname(0) = "ACCOUNTING"
dname(1) = "RESEARCH"
dname(2) = "SALES"
dname(3) = "OPERATIONS"

Dim loc(3) As String
loc(0) = "NEW YORK"
loc(1) = "DALLAS"
loc(2) = "CHICAGO"
loc(3) = "BOSTON"

cmd.Parameters("deptno_p").Value = deptno
cmd.Parameters("dname_p").Value = dname
cmd.Parameters("loc_p").Value = loc
...

After accomplishing previous steps you should call ExecuteArray method that assumes a parameter specifying how many times SQL statement will be executed. Note that the value of this method argument must be equal to the number of elements of parameters value. Now with any Oracle tool (you can use dbForge Studio for Oracle for this purpose) execute SELECT * FROM Dept and you can see four new records appended.

C#csharp Copy Code
...
cmd.ExecuteArray(4);
...
Visual Basic Copy Code
...
cmd.ExecuteArray(4)
...

Following is a sample code that executes several INSERT operations using array binding.

C#csharp Copy Code
public void ArrayBindInsert()
{
  // Create connection object
  OracleConnection conn = new OracleConnection(
     "User Id=Scott;Password=tiger;Data Source=Ora");

  // Open connection
  conn.Open();

  // Create command object with previously opened connection
  OracleCommand cmd = conn.CreateCommand();

  // Set command text property
  cmd.CommandText = "INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)";

  // Add parameters to command parameters collection
  cmd.Parameters.Add("deptno_p", OracleDbType.Integer);
  cmd.Parameters.Add("dname_p", OracleDbType.VarChar);
  cmd.Parameters.Add("loc_p", OracleDbType.VarChar);

  // Set parameters values
  cmd.Parameters["deptno_p"].Value = new int[] { 10, 20, 30, 40 };
  cmd.Parameters["dname_p"].Value = new string[] {
     "ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS" };
  cmd.Parameters["loc_p"].Value = new string[] {
     "NEW YORK", "DALLAS", "CHICAGO", "BOSTON" };

  // Insert four records at one time
  cmd.ExecuteArray(4);

  // Dispose command
  cmd.Dispose();

  // Close connection
  conn.Close();
}
Visual Basic Copy Code

Public Sub ArrayBindInsert()
  ' Create connection object
  Dim conn As OracleConnection = new OracleConnection( _
     "User Id=Scott;Password=tiger;Data Source=Ora")

  ' Open connection
  conn.Open()

  ' Create command object with previously opened connection
  Dim cmd As OracleCommand = conn.CreateCommand()

  ' Set command text property
  cmd.CommandText = "INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)"

  ' Add parameters to command parameters collection
  cmd.Parameters.Add("deptno_p", OracleDbType.Integer)
  cmd.Parameters.Add("dname_p", OracleDbType.VarChar)
  cmd.Parameters.Add("loc_p", OracleDbType.VarChar)

  ' Set parameters values
  Dim deptno(3) As Integer
  deptno(0) = 10
  deptno(1) = 20
  deptno(2) = 30
  deptno(3) = 40

  Dim dname(3) As String
  dname(0) = "ACCOUNTING"
  dname(1) = "RESEARCH"
  dname(2) = "SALES"
  dname(3) = "OPERATIONS"

  Dim loc(3) As String
  loc(0) = "NEW YORK"
  loc(1) = "DALLAS"
  loc(2) = "CHICAGO"
  loc(3) = "BOSTON"

  cmd.Parameters("deptno_p").Value = deptno
  cmd.Parameters("dname_p").Value = dname
  cmd.Parameters("loc_p").Value = loc

  ' Insert four records at one time
  cmd.ExecuteArray(4)

  ' Dispose command
  cmd.Dispose()

  ' Close connection
  conn.Close()
End Sub

So this sample demonstrates how you can insert several records by performing single execute operation. It is important to know that necessary condition of working with array binding feature is assigning array of the items to the parameter value and executing ExecuteArray(int iters) method of the OracleCommand class. The number of times to execute SQL statement within one round trip (iters) should be less than 65535.

Oracle 12c Release 1 (12.1) adds the possibility to get the number of rows affected for each array element. dotConnect for Oracle adds the ExecuteArray method overload, with the second out parameter, for this purpose. This parameter, an array of integers, returns the numbers of rows affected. This overload can be used in only OCI mode and only for Oracle 12c Release 1 (12.1) both server and client.

See Also

OracleCommand Class | Devart.Data.Oracle Namespace


Working with BLOB and CLOB Data

BLOB and CLOB Data
support@devart.com

This article consists of the following sections:

  • LOB basics
  • Working with BLOB data
  • Working with CLOB data
  • Inserting LOBs on Oracle server 8.0.5 and older

LOB basics

LOB stands for Large OBject, a stream of data stored in a database. Maximum capacity of a LOB is 8 TB to 128 TB. In Oracle three kinds of LOB data type exist:

  1. BLOB datatype stores unstructured binary large objects. BLOB objects can be thought of as bitstreams with no character set semantics.
  2. The CLOB datatype stores single-byte and multibyte character data. Both fixed-width and variable-width character sets are supported, and both use the database character set.
  3. The NCLOB datatype stores Unicode data.
dotConnect for Oracle supports all three datatypes.

You can retrieve values of LOB fields using OracleDataReader as well as other types like LONG and LONG RAW. The difference with usage of LOB data type becomes evident when you need to access these fields in DML and PL/SQL statements. For BLOB and CLOB data types only LOB locators (pointers to data) are stored in table columns; actual BLOB and CLOB data is stored in separate tablespace. This is the difference to the way that data of LONG or LONG RAW types is stored in database - tables hold their immediate values.

Another issue you should be aware of is temporary LOBs. This kind of object is not referenced by any table yet. It exists in current transaction only. You have to use temporary LOBs when inserting new data to a table. In dotConnect for Oracle, you can create temorary LOB using OracleLob constructors. Once you create an OracleLob instance corresponding temporary LOB appears on the server, and any data you insert into the object is sent immediately to server. An example of using temporary LOBs you will see later in the article.

Working with BLOB data

Binary data is generally represented as stream of bytes, or buffers. dotConnect for Oracle allows manipulating BLOB data in most convenient ways. You can work with OracleLob.Value property or use OracleLob.Read() and OracleLob.Write() methods to transfer data to and from server. Both ways are presented in the samples below. Note that when OracleLob.LobType property is OracleDbType.Blob the OracleLob.Value is treated as array of bytes (byte[]), whereas OracleDbType.Clob and OracleDbType.NClob represent OracleLob.Value as string.

The next sample routines show how to upload a file from hard disk to server and download it back. To execute these routines you have to create a table that is described as follows:

CREATE TABLE PICTURES (
  ID NUMBER(12),
  PICNAME VARCHAR2(20),
  PICTURE BLOB
)
C#csharp Copy Code
static void UploadBlob(OracleConnection myConnection)
{
  //Open file on disk
  FileStream fs = new FileStream("D:\\Tmp\\test.bmp", FileMode.Open, FileAccess.Read);
  BinaryReader r = new BinaryReader(fs);
  myConnection.Open();
  //Create temporary BLOB
  OracleLob myLob = new OracleLob(myConnection,OracleDbType.Blob);
  int streamLength = (int)fs.Length;
  //Transfer data to server
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength);
  //Perform INSERT
  OracleCommand myCommand = new OracleCommand(
   "INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'pict1',:Pictures)", myConnection);
  OracleParameter myParam = myCommand.Parameters.Add("Pictures", OracleDbType.Blob);
  myParam.OracleValue = myLob;
  try
  {
    Console.WriteLine(myCommand.ExecuteNonQuery() + " rows affected.");
  }
  finally
  {
    myConnection.Close();
    r.Close();
    fs.Close();
  }
}

static void DownloadBlob(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Pictures", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default);
  try
  {
    while (myReader.Read())
    {
      //Obtain OracleLob directly from OracleDataReader
      OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"));
      if (!myLob.IsNull)
      {
        string FN = myReader.GetString(myReader.GetOrdinal("PicName"));
        //Create file on disk
        FileStream fs = new FileStream("D:\\Tmp\\" + FN + ".bmp", FileMode.Create);
        //Use buffer to transfer data
        byte[] b = new byte[myLob.Length];
        //Read data from database
        myLob.Read(b,0,(int)myLob.Length);
        //Write data to file
        fs.Write(b,0,(int)myLob.Length);
        fs.Close();
        Console.WriteLine(FN + " downloaded.");
      }
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
Visual Basic Copy Code
Public Sub UploadBlob(ByVal myConnection As OracleConnection)
  'Open file on disk
  Dim fs As FileStream = New FileStream("D:\Tmp\test.bmp", FileMode.Open, FileAccess.Read)
  Dim r As BinaryReader = New BinaryReader(fs)
  myConnection.Open()
  'Create temporary BLOB
  Dim myLob As OracleLob = New OracleLob(myConnection, OracleDbType.Blob)
  Dim streamLength As Int32 = fs.Length
  'Transfer data to server
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength)
  'Perform INSERT
  Dim myCommand As OracleCommand = New OracleCommand(
    "INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'pict1',:Pictures)", myConnection)
  Dim myParam As OracleParameter = myCommand.Parameters.Add("Pictures", OracleDbType.Blob)
  myParam.OracleValue = myLob
  Try
    Console.WriteLine(myCommand.ExecuteNonQuery() & " rows affected.")
  Finally
    myConnection.Close()
    r.Close()
    fs.Close()
  End Try
End Sub

Public Sub DownloadBlob(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Pictures", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = & _
      myCommand.ExecuteReader(System.Data.CommandBehavior.Default)
  Try
    While myReader.Read()
      Dim myLob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"))
      If Not myLob.IsNull Then
        Dim FN As String = myReader.GetString(myReader.GetOrdinal("PicName"))
        Dim fs As FileStream = New FileStream("D:\Tmp\" + FN + ".bmp", FileMode.Create)
        Dim w As BinaryWriter = New BinaryWriter(fs)
        w.Write(myLob.Value)
        w.Close()
        fs.Close()
        Console.WriteLine(String.Concat(FN, " downloaded."))
      End If
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Working with CLOB data

Working with CLOB data generally is same as working with BLOB data. The difference is in representation of Value property. For CLOB and NCLOB data types when you read from OracleLob.Value property, you get strings. The data is transparently decoded so you do not have to take care about its character set. If you need raw data however you can use streaming capabilities of OracleLob, that is OracleLob.Read and OracleLob.Write methods. Note that since OracleLob.Value is a read-only property, you can write data to LOB only with OracleLob.Write method, and no encoding is performed.

For example consider this table definition.

CREATE TABLE ClobTable (
  Id NUMBER,
  Name VARCHAR2(30),
  Value CLOB
)

If you need to perform simple tasks like fetch record set in most cases you do not need to know about OracleLob. When calling OracleDataReader.GetValue on fetch you get array of bytes for BLOB column and string for CLOB one. In addition you can use OracleDataReader.GetChars, OracleDataReader.GetBytes to get pieces of LOB value.

For example,

C#csharp Copy Code
...
OracleCommand oraCommand = new OracleCommand("SELECT * FROM ClobTable", oraConnection);
OracleDataReader reader = oraCommand.ExecuteReader();
while (reader.Read())
  Console.WriteLine(reader.GetValue(2));
...
Visual Basic Copy Code
...
Dim oraCommand As OracleCommand = new OracleCommand( _
    "SELECT * FROM ClobTable", oraConnection)
Dim reader As OracleDataReader = oraCommand.ExecuteReader()
while (reader.Read())
  Console.WriteLine(reader.GetValue(2))
end while
...

You can do the same thing using OracleLob object directly.

C#csharp Copy Code
...
OracleCommand oraCommand = new OracleCommand("SELECT * FROM ClobTable", oraConnection);
OracleDataReader reader = oraCommand.ExecuteReader();
OracleLob clob;
while (reader.Read()) {
  clob = reader.GetOracleLob(2);
  Console.WriteLine(clob.Value);
}
...
Visual Basic Copy Code
...
Dim oraCommand As OracleCommand = new OracleCommand( _
    "SELECT * FROM ClobTable", oraConnection)
Dim reader As OracleDataReader = oraCommand.ExecuteReader()
Dim clob As OracleLob
while (reader.Read())
  clob = reader.GetOracleLob(2)
  Console.WriteLine(clob.Value)
end while
...

As we see first code cut was shorter. So, usually, you need to access OracleLob directly in more complicated cases (e.g using temporary LOBs, advanced streaming operations).

Inserting LOBs on Oracle server 8.0.5 and older

Temporary LOBs are not supported in Oracle servers version 8.0.5 and older, so you have to create and initialize LOB locator for Value parameter. To initialize LOB locator you must use EMPTY_BLOB or EMPTY_CLOB Oracle function. To return initialized locator in the same statement use RETURNING clause.

For example,

UPDATE ClobTable
SET
  Name = :Name,
  Value = EMPTY_CLOB()
WHERE
  Id = :Id
RETURNING
  Value
INTO
  :Value

Here is the sample code:

C#csharp Copy Code
...
string sql = "UPDATE ClobTable SET Name = :Name, Value = EMPTY_CLOB() +
       WHERE Id = :Id RETURNING Value INTO :Value";
OracleCommand oraCommand = new OracleCommand(sql, oraConnection);
oraCommand.Parameters.Add("Id", 1);
oraCommand.Parameters.Add("Name", "First");
OracleParameter param = oraCommand.Parameters.Add("Value", OracleDbType.Clob);
param.Direction = ParameterDirection.Input;
param.Value = "The CLOB test value.";
oraCommand.ExecuteNonQuery();
...
Visual Basic Copy Code
...
Dim sql As string = "UPDATE ClobTable SET Name = :Name, Value = EMPTY_CLOB() & _
                    WHERE Id = :Id RETURNING Value INTO :Value"
Dim oraCommand As OracleCommand = new OracleCommand(sql, oraConnection)
oraCommand.Parameters.Add("Id", 1)
oraCommand.Parameters.Add("Name", "First")
Dim param As OracleParameter = oraCommand.Parameters.Add("Value", OracleDbType.Clob)
param.Direction = ParameterDirection.Input
param.Value = "The CLOB test value."
oraCommand.ExecuteNonQuery()
...

dotConnect for Oracle writes LOB data to Oracle and then returns initialized Value field in :Value parameter. Stored procedures allow you to automate initialization process of LOB values as follows.

CREATE OR REPLACE
PROCEDURE ClobTableUpdate (p_Id NUMBER, p_Name VARCHAR2,
                           p_Value OUT CLOB)
is
begin
  UPDATE ClobTable
  SET
    Name = p_Name,
    Value = EMPTY_CLOB()
  WHERE
    Id = p_Id
  RETURNING
    Value
  INTO
    p_Value;
end;

Note that p_Value parameter is declared as OUT. At the same time set Direction property for parameter of Lob data type to ParameterDirection.Input and assign it with required data prior to actual call to stored procedure. Having previous procedure declaration we may execute it as this:

C#csharp Copy Code
...
OracleCommand oraCommand = new OracleCommand("ClobTableUpdate", oraConnection);
oraCommand.CommandType = CommandType.StoredProcedure;
OracleCommandBuilder.DeriveParameters(oraCommand);
oraCommand.Parameters["p_Id"].Value = id;
oraCommand.Parameters["p_Name"].Value = name;
oraCommand.Parameters["p_Value"].Direction = ParameterDirection.Input;
oraCommand.Parameters["p_Value"].Value = "The CLOB test value.";
oraCommand.ExecuteNonQuery();
...
Visual Basic Copy Code
...
Dim oraCommand As OracleCommand = new OracleCommand("ClobTableUpdate", oraConnection)
oraCommand.CommandType = CommandType.StoredProcedure
OracleCommandBuilder.DeriveParameters(oraCommand)
oraCommand.Parameters("p_Id").Value = id
oraCommand.Parameters("p_Name").Value = name
oraCommand.Parameters("p_Value").Direction = ParameterDirection.Input
oraCommand.Parameters("p_Value").Value = "The CLOB test value."
oraCommand.ExecuteNonQuery()
...

It is important to use Direction property of OracleParameter in LOB operations. If Direction is ParameterDirection.Input OracleCommand writes data to a server, if Direction is ParameterDirection.Output it reads data.

You can also use OracleDbType.Long and OracleDbType.LongRaw data types with LOB parameters to write ordinary DML statements. In this case Oracle automatically converts LONG and LONG ROW values to CLOB or BLOB data.

See Also

OracleLob Class | Devart.Data.Oracle Namespace


Cursors

Cursors
support@devart.com

A cursor identifies the result set produced by query execution, which consists of all the rows that meet the query search criteria. Oracle server can return a cursor in three ways:

  • by executing an ordinary SELECT statement;
  • by executing a SELECT statement with cursor fields;
  • by returning PL/SQL REF CURSOR as an output parameter.

The following section describes the last two ways of working with cursors.

In our examples we will use the followind database tables:

CREATE TABLE DEPT (
  DEPTNO NUMBER(2) CONSTRAINT PK_DEPT PRIMARY KEY,
  DNAME VARCHAR2(14) ,
  LOC VARCHAR2(13)
);

CREATE TABLE EMP (
  EMPNO NUMBER(4) CONSTRAINT PK_EMP PRIMARY KEY,
  ENAME VARCHAR2(10),
  JOB VARCHAR2(9),
  MGR NUMBER(4),
  HIREDATE DATE,
  SAL NUMBER(7,2),
  COMM NUMBER(7,2),
  DEPTNO NUMBER(2) CONSTRAINT FK_DEPTNO REFERENCES DEPT
);

These tables store information about departments and their employees. For example, we need to get employees for each department. In order to demontrate the use of OracleCursor class, we will do it in the following way:

C#csharp Copy Code
...
string sql = "SELECT Dept.*, CURSOR(SELECT * " +
   "FROM Scott.Emp WHERE Emp.DeptNo = Dept.DeptNo) AS Emp FROM Scott.Dept";
OracleCommand oraCommand = new OracleCommand(sql, oraConnection);
OracleDataAdapter oraDataAdapter = new OracleDataAdapter();
oraDataAdapter.SelectCommand = oraCommand;
oraDataAdapter.Fill(dataSet, "Dept");
masterGrid.DataSource = dataSet1;
detailGrid.DataSource = dataSet1;
masterGrid.DataMember = "Dept";
detailGrid.DataMember = "Dept.DeptEmp";
...
Visual Basic Copy Code
...
Dim sql As string = "SELECT Dept.*, CURSOR(SELECT &_
   * FROM Scott.Emp WHERE Emp.DeptNo = Dept.DeptNo) AS " + _
  "Emp FROM Scott.Dept"
Dim oraCommand OracleCommand = new OracleCommand(sql, oraConnection)
Dim oraDataAdapter OracleDataAdapter = new OracleDataAdapter()
oraDataAdapter.SelectCommand = oraCommand
oraDataAdapter.Fill(dataSet, "Dept")
masterGrid.DataSource = dataSet1
detailGrid.DataSource = dataSet1
masterGrid.DataMember = "Dept"
detailGrid.DataMember = "Dept.DeptEmp"
...

First, note the SQL text. In select list, there is a sub-query with the result set cast to the CURSOR type.

Second, it is important how DataSet is filled. OracleDataAdapter adds one DataTable for the main cursor and one for each column containing cursors. Additional tables are named in the following way: "<main table name>.<main table name><cursor column name>". During fetch OracleDataAdapter fills tables creating relation between "Dept" and "Dept.DeptEmp". This relation works like a foreign key, which allows the DataSet component to filter "Dept.DeptEmp" DataTable when you are navigating the main "Dept" DataTable.

Third, there is a notion concerning update of the DataSet. In the given example you can only update the main DataTable because OracleDataAdapter can update one table at a time. So you need to set up additional OracleDataAdapter to update "Dept.DeptEmp" DataTable.

Another way to get a cursor from an Oracle server is to use the PL/SQL REF CURSOR type. Sometimes you need to perform some additional server-side actions when executing a query. If it is impossible to put them all into a single SELECT statement, a PL/SQL block or stored procedure can be used. But it is still required to get a record set from the server. dotConnect for Oracle allows you to retrieve this record set using OracleCursor parameters.

For example,

C#csharp Copy Code
...
string cmdText = "begin open :cur for select * from dept; end;";
OracleCommand oraCommand = new OracleCommand(cmdText, oraConnection);
oraCommand.Parameters.Add("cur", OracleDbType.Cursor);
oraCommand.Parameters["cur"].Direction = ParameterDirection.Output;
oraCommand.ExecuteNonQuery();
OracleCursor oraCursor = (OracleCursor)oraCommand.Parameters["cur"].Value;
oraDataAdapter.Fill(dataSet, "Table", oraCursor);
...
Visual Basic Copy Code
...
Dim cmdText As string = "begin open :cur for select * from dept; end;"
Dim oraCommand As OracleCommand = new OracleCommand(cmdText, oraConnection)
oraCommand.Parameters.Add("cur", OracleDbType.Cursor)
oraCommand.Parameters("cur").Direction = ParameterDirection.Output
oraCommand.ExecuteNonQuery()
Dim oraCursor As OracleCursor = CType(oraCommand.Parameters("cur").Value, OracleCursor)
oraDataAdapter.Fill(dataSet, "Table", oraCursor)
...

The main feature of the OracleCursor class is that you can get an OracleDataReader object from it. So an OracleCursor object can participate in the fill operation. Note that OracleDataAdapter cannot update DataSet filled in this way automatically using OracleCommandBuilder because it is impossible to get schema table for the cursor. Thus you need to configure OracleDataAdapter manually to be able to update DataSet.

dotConnect for Oracle allows you to work with multiple cursors. It is mostly similar to the above sample, but you can also iterate through result sets using the OracleDataReader.NextResult method. The following code shows how to fill DataSet:

C#csharp Copy Code
...
string cmdText = "begin open :cur1 for select * from dept;" +
    "open :cur2 for select * from emp; end;";
OracleCommand oraCommand = new OracleCommand(cmdText, oraConnection);
oraCommand.Parameters.Add("cur1", OracleDbType.Cursor);
oraCommand.Parameters["cur1"].Direction = ParameterDirection.Output;
oraCommand.Parameters.Add("cur2", OracleDbType.Cursor);
oraCommand.Parameters["cur2"].Direction = ParameterDirection.Output;
oraDataAdapter.SelectCommand = oraCommand;
oraDataAdapter.Fill(dataSet);
...
Visual Basic Copy Code
...
Dim cmdText As string = "begin open :cur1 for select * from dept; &_
    open :cur2 for select * from emp; end;"
Dim oraCommand As OracleCommand = new OracleCommand(cmdText, oraConnection)
oraCommand.Parameters.Add("cur1", OracleDbType.Cursor)
oraCommand.Parameters("cur1").Direction = ParameterDirection.Output
oraCommand.Parameters.Add("cur2", OracleDbType.Cursor)
oraCommand.Parameters("cur2").Direction = ParameterDirection.Output
oraDataAdapter.SelectCommand = oraCommand
oraDataAdapter.Fill(dataSet)
...

As for update, you should manually setup OracleDataAdapter for each record set you'd like to update as it was said earlier.

Additionally dotConnect for Oracle supports returning implicit result sets on Oracle 12c. Implicit result sets are supported only in OCI mode with Oracle Client 12c. If a stored procedure returns both implicit result sets and output cursor parameters, the result sets of output cursor parameters are returned first, and then implicit result sets are returned.

See Also

OracleCursor Class | Devart.Data.Oracle Namespace


PL/SQL Tables

PL/SQL Tables
support@devart.com

dotConnect for Oracle supports PL/SQL arrays known as PL/SQL Tables as parameters of anonymous PL/SQL blocks or as parameters of stored procedures. As general arrays, PL/SQL arrays can be used for common storing similar data types accessible by index.

When binding parameters of PL/SQL Associative Arrays, the following data types of array elements are supported:

  • BINARY_FLOAT
  • CHAR
  • DATE
  • NCHAR
  • NUMBER
  • NVARCHAR2
  • RAW
  • ROWID
  • UROWID
  • VARCHAR2

In our sample we will use our standard Dept table. If you don't have this table in your database see SQL script at Samples\tables.sql folder.

The following sample demonstrates how to update several records from Dept table simultaneously using parameter of PL/SQL Table type.

Here is SQL statement used at our sample:

DECLARE
  i INTEGER;
BEGIN
  i:= 1;
  FOR rec IN (SELECT DeptNo FROM Scott.Dept
    WHERE RowNum <= 10 ORDER BY DeptNo)
  LOOP
    UPDATE Scott.Dept
      SET DName = :NameArr(i)
      WHERE DeptNo = Rec.DeptNo;
    i:= i + 1;
  END LOOP;
END;

At the text of given above SQL there is one parameter with NameArr name of PL/SQL Table type. This SQL updates DName field of Dept table with the values from NameArr array.

At first, you should create an object of OracleConnection class and open a session:

C#csharp Copy Code
...
OracleConnection conn = new OracleConnection(
   "User Id=Scott;Password=tiger;Data Source=Ora");
conn.Open();
...
Visual Basic Copy Code
...
Dim conn As OracleConnection = new OracleConnection( _
   "User Id=Scott;Password=tiger;Data Source=Ora")
conn.Open()
...

Please note that it is only a cut of sample and you shouldn't try to compile it. The full text of the sample will be given at the end of this article.

After that you should create an instance of OracleCommand class associated with the OracleConnection object and specify SQL statement for the execution:

C#csharp Copy Code
...
OracleCommand cmd = conn.CreateCommand();
cmd.CommandText = "DECLARE\n" +
  "  i INTEGER;\n" +
  "BEGIN\n" +
  "  i:= 1;\n" +
  "  FOR rec IN (SELECT DeptNo FROM Scott.Dept\n" +
  "    WHERE RowNum <= 10 ORDER BY DeptNo)\n" +
  "  LOOP\n" +
  "    UPDATE Scott.Dept\n" +
  "      SET DName = :NameArr(i)\n" +
  "      WHERE DeptNo = Rec.DeptNo;\n" +
  "    i:= i + 1;\n" +
  "  END LOOP;\n" +
  "END;";
...
Visual Basic Copy Code
...
Dim cmd As OracleCommand = conn.CreateCommand()
cmd.CommandText = "DECLARE" & VbCrlf & _
        "  i INTEGER;" & VbCrlf & _
        "BEGIN" & VbCrlf & _
        "  i:= 1;" & VbCrlf & _
        "  FOR rec IN (SELECT DeptNo FROM Scott.Dept" & VbCrlf & _
        "    WHERE RowNum <= 10 ORDER BY DeptNo)" & VbCrlf & _
        "  LOOP" & VbCrlf & "    UPDATE Scott.Dept" & VbCrlf & _
        "      SET DName = :NameArr(i)" & VbCrlf & _
        "      WHERE DeptNo = Rec.DeptNo;" & VbCrlf & _
        "    i:= i + 1;" & VbCrlf & _
        "  END LOOP;" & VbCrlf & _
        "END;"
...

Text of SQL has NameArr parameter with the value which should be specified later.

Now for each parameter from SQL you should associate an object of OracleParameter class and add this object to the collection of the parameters of OracleCommand objects. Association is accomplished by the names of parameters in following way:

C#csharp Copy Code
...
cmd.Parameters.Add("NameArr", OracleDbType.VarChar);
...
Visual Basic Copy Code
...
cmd.Parameters.Add("NameArr", OracleDbType.VarChar)
...

Then you need to specify that the parameter with NameArr name has PL/SQL Table type. To do it, you should set ArrayLength property of the parameter to the requested value. If Dept table has four records, the size of the array also must be four.

C#csharp Copy Code
...
cmd.Parameters["NameArr"].ArrayLength = 4;
...
Visual Basic Copy Code
...
cmd.Parameters("NameArr").ArrayLength = 4
...

After that you need to set values for the array items of NameArr parameter. The amount of array items must be the same to the value of ArrayLength property.

C#csharp Copy Code
...
cmd.Parameters["NameArr"].Value = new srting[] {
   "London", "Berlin", "Geneva", "Vienna" };
...
Visual Basic Copy Code
...
Dim valArr(4) As string
valArr(0) = "London"
valArr(1) = "Berlin"
valArr(2) = "Geneva"
valArr(3) = "Vienna"
cmd.Parameters("NameArr").Value = valArr
...

Now you can execute SQL calling ExecuteNonQuery() method of OracleCommand class.

C#csharp Copy Code
...
cmd.ExecuteNonQuery();
...
Visual Basic Copy Code
...
cmd.ExecuteNonQuery()
...

Below full text of the sample.

C#csharp Copy Code
public void UpdateThroughPlSqlTable()
{
  // Create connection object
  OracleConnection conn = new OracleConnection(
     "User Id=Scott;Password=tiger;Data Source=Ora");

  // Open connection
  conn.Open();

  // Create command object with previously opened connection
  OracleCommand cmd = conn.CreateCommand();

  // Set command text property
  cmd.CommandText = "DECLARE\n" +
                    "  i INTEGER;\n" +
                    "BEGIN\n" +
                    "  i:= 1;\n" +
                    "  FOR rec IN (SELECT DeptNo FROM Scott.Dept\n" +
                    "    WHERE RowNum <= 10 ORDER BY DeptNo)\n" +
                    "  LOOP\n" +
                    "    UPDATE Scott.Dept\n" +
                    "      SET DName = :NameArr(i)\n" +
                    "      WHERE DeptNo = Rec.DeptNo;\n" +
                    "    i:= i + 1;\n" +
                    "  END LOOP;\n" +
                    "END;";

  // Add parameters to command parameters collection
  cmd.Parameters.Add("NameArr", OracleDbType.VarChar);

  // Set Pl/SQL table length
  cmd.Parameters["NameArr"].ArrayLength = 4;

  // Set array parameter value
  cmd.Parameters["NameArr"].Value = new string[] {
     "London", "Berlin", "Geneva", "Vienna" };

  // Update table
  cmd.ExecuteNonQuery();

  // Dispose command
  cmd.Dispose();

  // Close connection
  conn.Close();
}
Visual Basic Copy Code
Public Sub UpdateThroughPlSqlTable()

  ' Create connection object
  Dim conn As OracleConnection = new OracleConnection(
     "User Id=Scott;Password=tiger;Data Source=Ora")

  ' Open connection
  conn.Open()

  ' Create command object with previously opened connection
  Dim cmd As OracleCommand = conn.CreateCommand()

  ' Set command text property
cmd.CommandText = "DECLARE" & VbCrlf & _
        "  i INTEGER;" & VbCrlf & _
        "BEGIN" & VbCrlf & _
        "  i:= 1;" & VbCrlf & _
        "  FOR rec IN (SELECT DeptNo FROM Scott.Dept" & VbCrlf & _
        "    WHERE RowNum <= 10 ORDER BY DeptNo)" & VbCrlf & _
        "  LOOP" & VbCrlf & "    UPDATE Scott.Dept" & VbCrlf & _
        "      SET DName = :NameArr(i)" & VbCrlf & _
        "      WHERE DeptNo = Rec.DeptNo;" & VbCrlf & _
        "    i:= i + 1;" & VbCrlf & _
        "  END LOOP;" & VbCrlf & _
        "END;"

  ' Add parameters to command parameters collection
  cmd.Parameters.Add("NameArr", OracleDbType.VarChar)

  ' Set Pl/SQL table length
  cmd.Parameters("NameArr").ArrayLength = 4

  ' Set array parameter value
  Dim valArr(4) As string
  valArr(0) = "London"
  valArr(1) = "Berlin"
  valArr(2) = "Geneva"
  valArr(3) = "Vienna"
  cmd.Parameters("NameArr").Value = valArr

  ' Update table
  cmd.ExecuteNonQuery()

  ' Dispose command
  cmd.Dispose()

  ' Close connection
  conn.Close()
End Sub

If you have any open questions or problems please refer to the sample from Samples\PlSqlTable folder.

See Also

OracleCommand Class | Devart.Data.Oracle Namespace


Objects

Objects
support@devart.com

The Oracle Object usage is considered in this article. We will consider object creation, attribute manipulating, and about object inserting and retrieving in given article.

  • Overview
  • Creating Oracle Objects and Manipulating Attributes
  • Inserting and Retrieving Objects

Overview

dotConnect for Oracle allows you to work with Oracle object types, including array and table types. This includes manipulating object attributes and performing CRUD (create read update delete) operations on rows with object type fields.

Object types can be used with either typed or untyped OracleObjects. Typed OracleObject is a .NET class representing a single user-defined type (UDT); instances of this UDT can be accessed in the same way as usual .NET objects. Such kind of OracleObjects can be generated using the Oracle Object Wizard, see the Using Object Wizard for Working with Oracle Objects topic for more information about this.

This topic describes how to use untyped OracleObjects which are instances of the OracleObject class. Specific information about arrays and tables is contained in the topics VARRAY Type and PL/SQL Tables.

We will work with the following user-defined types and table:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TYPE TPerson AS OBJECT (
  Name VARCHAR2(30),
  Address TAddress,
  Phone VARCHAR2(20),
  BirthDate DATE
);

CREATE TABLE EmpObject (
  Person TPerson,
  Job VARCHAR2(9),
  HireDate DATE,
  Sal NUMBER(7,2)
);

Creating Oracle Objects and Manipulating Attributes

The needed object type should be specified for OracleObject instance creation. Apparently, an opened connection (say, oracleConnection1) is needed at this moment so that it is possible to collect the information about the attributes of this UDT. For example, an instance of the TAddress type can be created as

C#csharp Copy Code
OracleObject address = new OracleObject("TADDRESS", oracleConnection1);
Visual Basic Copy Code
dim address As OracleObject = new OracleObject("TADDRESS", oracleConnection1)

Another way of creating object is to use the OracleType class, which instances represent UDTs themselves:

C#csharp Copy Code
OracleType addressType = OracleType.GetObjectType("TADDRESS", oracleConnection1);
OracleObject address1 = new OracleObject(addressType);
OracleObject address2 = new OracleObject(addressType);
Visual Basic Copy Code
Dim AddressType As OracleType = OracleType.GetObjectType("TADDRESS", oracleConnection1)
Dim address1 As OracleObject = New OracleObject(addressType)
Dim address2 As OracleObject = New OracleObject(addressType)

After OracleObject is created, its fields can be accessed in the following way:

C#csharp Copy Code
address["Country"] = "USA";
address["City"] = "New York, NY";
address["Street"] = "450 Seventh Avenue, Suite 2102";
Visual Basic Copy Code
address("Country") = "USA"
address("City") = "New York, NY"
address("Street") = "450 Seventh Avenue, Suite 2102"

Also you can use the elements of the Attributes collection of the corresponding OracleType instance:

C#csharp Copy Code
OracleAttribute country = addressType.Attributes["Country"];
address[country] = "USA";
Visual Basic Copy Code
Dim country As OracleAttribute = addressType.Attributes("Country")
address(country) = "USA"

The main difference between typed and untyped OracleObjects is the fact that the fields of typed OracleObjects may be accessed through the properties of the corresponding classes generated by the Oracle Objects Wizard.

Inserting and Retrieving Objects

The simplest way of inserting a UDT instance to the table is passing it as a command parameter. Note that the type of the corresponding parameter should be set to OracleDbType.Object:

C#csharp Copy Code
OracleCommand cmd = oracleConnection1.CreateCommand();
cmd.CommandText = "INSERT INTO EmpObject (CODE, PERSON, JOB, HIREDATE, SAL) VALUES (:CODE, :PERSON, :JOB, : HIREDATE, :SAL)";

cmd.Parameters.Add(new OracleParameter("CODE", 10));
cmd.Parameters.Add(new OracleParameter("PERSON", OracleDbType.Object));
cmd.Parameters.Add(new OracleParameter("JOB", "MANAGER"));
cmd.Parameters.Add(new OracleParameter("HIREDATE", new DateTime(1990, 1, 1)));
cmd.Parameters.Add(new OracleParameter("SAL", 1000));

OracleObject address = new OracleObject("TADDRESS", oracleConnection1);
address["CITY"] = "NEW YORK";
address["STREET"] = "450 Seventh Avenue, Suite 2102";
OracleObject person = new OracleObject("TPERSON", oracleConnection1);
person["ADDRESS"] = address;
person["NAME"] = "John Smith";

cmd.Parameters["PERSON"].Value = person;
...

cmd.ExecuteNonQuery();
Visual Basic Copy Code
dim cmd as OracleCommand = oracleConnection1.CreateCommand()
cmd.CommandText = "INSERT INTO EmpObject & _
    (CODE, PERSON, JOB, HIREDATE, SAL) VALUES (:CODE, :PERSON, :JOB, : HIREDATE, :SAL)"

cmd.Parameters.Add(new OracleParameter("CODE", 10))
cmd.Parameters.Add(new OracleParameter("PERSON", OracleDbType.Object))
cmd.Parameters.Add(new OracleParameter("JOB", "MANAGER"))
cmd.Parameters.Add(new OracleParameter("HIREDATE", new DateTime(1990, 1, 1)))
cmd.Parameters.Add(new OracleParameter("SAL", 1000))

dim address As OracleObject = new OracleObject("TADDRESS", oracleConnection1)
address("CITY") = "NEW YORK"
address("STREET") = "450 Seventh Avenue, Suite 2102"
dim person As OracleObject = new OracleObject("TPERSON", oracleConnection1)
person("ADDRESS") = address
person("NAME") = "John Smith"

cmd.Parameters("PERSON").Value = person
...

cmd.ExecuteNonQuery()

OracleObjects can be retrieved from the database in the same way as common data types:

C#csharp Copy Code
OracleCommand cmd = new OracleCommand("select * from EmpObject", oracleConnection1);
OracleDataReader reader = cmd.ExecuteReader();
while (reader.Read())
{
   OracleObject person = (OracleObject)reader["Person"];
   Console.WriteLine(person["NAME"].ToString());
}
Visual Basic Copy Code
Dim Cmd = New OracleCommand("select * from EmpObject", oracleConnection1)
Dim Reader = cmd.ExecuteReader()
While reader.Read
   Dim Person As OracleObject = CType(Reader("Person"), OracleObject)
   Console.WriteLine(Person("NAME").ToString)
End While

You can use the GetOracleObject method instead of explicitly casting reader content:

C#csharp Copy Code
OracleObject person = reader.GetOracleObject(0);
Visual Basic Copy Code
Dim person As OracleObject = reader.GetOracleObject(0)

Besides retrieving UDT as a single object, it can be expanded into several fields of simple data types. To do so, you can use an OracleDataTable object with the SplitObjects property set to true. Notice that SplitObjects is ignored unless the ObjectView property is set to false. In this case, object attributes should be specified in the format [UDT field name].[UDT attribute name]:

C#csharp Copy Code
OracleDataTable table = new OracleDataTable("select * from EmpObject", oracleConnection1);
table.ObjectView = false;
table.SplitObjects = true;
table.Fill();

foreach (DataRow row in table.Rows) {
   Console.WriteLine(row["Person.Name"] + ": " + row["Person.Address.Street"]);
}
Visual Basic Copy Code
Dim table As OracleDataTable = New OracleDataTable("select * from EmpObject", con)
table.ObjectView = False
table.SplitObjects = True
table.Fill()

For Each row As DataRow In table.Rows
   Console.WriteLine(row("Person.Name") + ": " + row("Person.Address.Street"))
Next

See Also

OracleObject Class | Using Object Wizard for Working with Oracle Objects | PL/SQL Tables | VARRAY Type


VARRAY Type

VARRAY Type
support@devart.com

dotConnect for Oracle provides two ways of working with Arrays and Nested tables:

  • fill dataset, in this case array data will be stored at the single table of dataset and a relation set to the table that associates a row from base selection with array rows.
  • get an object of OracleArray type and access its items through indexed property.

If such types are created:

CREATE TYPE TArray1 AS VARRAY (5) OF NUMBER;

CREATE TYPE TArray2 AS VARRAY (4) OF CHAR(10);

CREATE TABLE ArrayTable (
  Code NUMBER,
  Title VARCHAR2(10),
  Arr1 TArray1,
  Arr2 TArray2
);

Filled dataset for the query

SELECT * FROM ArrayTable

will have three tables at dataset: ArrayTable, ArrayTableArr1, ArrayTableArr2. Using this way has a restriction that you are unable to post updated data to the server by DataAdapter.Update method.

The another way to access data from Arrays and Nested tables is to use OracleArray and OracleTable classes. For example, for OracleArray type you can write the next code:

C#csharp Copy Code
OracleArray oraArray = dataReader.GetOracleArray(i);
foreach (object obj in oraArray) {
  lbResult.Items.Add(obj.ToString());
}
Visual Basic Copy Code
dim oraArray as OracleArray = dataReader.GetOracleArray(i);
dim obj as object
for each obj in oraArray
  lbResult.Items.Add(obj.ToString())
next

You can use VARRAY type for parameters of SQL and PL/SQL statements.

For example:

C#csharp Copy Code
OracleCommand cmd = oracleConnection1.CreateCommand();
cmd.CommandText = "INSERT INTO ArrayTable (CODE, ARR1) VALUES (1, :ARR1)";
cmd.Parameters.Add(new OracleParameter("ARR1", OracleDbType.Array));

OracleArray arr1 = new OracleArray("SCOTT.TARRAY1", oracleConnection1);
arr1.Add(10);
arr1.Add(20);
arr1.Add(30);

cmd.Parameters["ARR1"].Value = arr1;
cmd.ExecuteNonQuery();
Visual Basic Copy Code
dim cmd as OracleCommand = OracleConnection1.CreateCommand()
cmd.CommandText = "INSERT INTO ArrayTable (CODE, ARR1) VALUES (1, :ARR1)"
cmd.Parameters.Add(New OracleParameter("ARR1", OracleDbType.Array))

dim arr1 as OracleArray = new OracleArray("SCOTT.TARRAY1", OracleConnection1)
arr1.Add(10)
arr1.Add(20)
arr1.Add(30)

cmd.Parameters("ARR1").Value = arr1
cmd.ExecuteNonQuery()

See Also

OracleArray Class | Devart.Data.Oracle Namespace


Using Package Wizard for Working with PL/SQL Packages

Using Package Wizard for Working with PL/SQL Packages
support@devart.com

This article describes how to work with Oracle Package using dotConnect for Oracle.

  • Introducing
  • Requirements
  • Creating Typed OraclePackages
  • Using Typed OraclePackages

Introducing

Oracle databases allow creating packages, which are unified sets of stored procedures, functions, variables and user-defined types. dotConnect for Oracle leverages working with Oracle packages by implementing typed OraclePackage components. These components allow you to work with a package like with a usual .NET object, invoking stored procedures as object methods. This tutorial describes how to create and use typed OraclePackages.

Requirements

This walkthrough supposes that you know how to establish a connection to server and how to create the database objects.

To follow the tutorial, you also need the package Pack created in your Oracle database. This can be made by executing the following script:

CREATE OR REPLACE PACKAGE Pack AS
  PROCEDURE get_all_depts (cur OUT SYS_REFCURSOR);
  PROCEDURE insert_dept (pDeptno INTEGER, pDname VARCHAR, pLoc VARCHAR);
  FUNCTION dept_count RETURN INTEGER;
END PACK;
/

CREATE OR REPLACE PACKAGE BODY Pack
IS

  PROCEDURE get_all_depts (cur OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN cur FOR SELECT * FROM dept;
  END;

  PROCEDURE insert_dept (pDeptno INTEGER, pDname VARCHAR, pLoc VARCHAR) AS
  BEGIN
    INSERT INTO dept(deptno, dname, loc) VALUES (pDeptno, pDname, pLoc);
  END;

  FUNCTION dept_count RETURN INTEGER
  AS
    cnt INTEGER;
  BEGIN
    SELECT COUNT(*) INTO cnt FROM dept;
    RETURN cnt;
  END;

END PACK;
/

Creating Typed OraclePackages

Typed OraclePackage can be created via Typed Oracle Package Wizard. The wizard can be started either from the Visual Studio main menu (Tools -> Oracle -> Oracle Package Wizard) or from the toolbox (double-click the OraclePackage component or drop it to the form). In the latter case, select the New typed package option in the dialog window and click OK:

Add Oracle package dialog box

After the wizard started, follow these steps:

  1. Set the connection properties to the server where you created a package and click Next to proceed.

    Note that the wizard may operate with both Direct and OCI connections.

    2. dotConnect for Oracle Package Wizard - Setup data connection properties

  2. In this page, you can select whether to show all packages in the database or only those belonging to the specific user. For this purpose, use the radio buttons All and User, and the list box for selecting the user.

    Select the package you want to work with. In this sample, the Pack package is used. Click Next to continue.

    3. dotConnect for Oracle Package Wizard - Choose Oracle package
  3. The next page allows you to set up the name of the generated class, the namespace where it will be placed and the naming rules for members of the package. In this tutorial, the defaults are used, so just click Next.
    4. dotConnect for Oracle Package Wizard - Setup code generation options
  4. Select the Add this OraclePackage to designer check box to place an instance of generated OraclePackage onto the form. Click Finish.
    5. dotConnect for Oracle Package Wizard - Wizard finished successfully

The wizard will generate the Pack class representing the Pack Oracle package and, if you have selected the last check box, will place Pack instance pack1 onto the form. The package class needs an open connection, so if you have created a new connection while running the wizard, OracleConnection instance oracleConnection1 will be placed onto the form too.

Using Typed OraclePackages

The procedures of the Pack package will be available in pack1 just like usual object's methods. In the next sample, we invoke all methods of the Pack package, which are doing the following:

  1. Get count of rows in the Dept table.
  2. Insert a new record into the Dept table.
  3. Retrieve all records of the table.
C#csharp Copy Code
// Open the connection. Until the connection is opened,
// any invocation of package methods will throw an exception.
pack1.Connection.Open();

// 1. Check the number of rows in the dept table via the dept_count function:
int count = (int)pack1.DeptCount();

// 2. Insert a record via the insert_dept procedure:
pack1.InsertDept(100, "Research", "San-Jose");

// 3. Get all records using the get_all_depts procedure, and fill a DataTable with them:
OracleCursor cur;

// The procedure returns an OracleCursor object, which can be used to retrieve a data reader.
pack1.GetAllDepts(out cur);
OracleDataReader r = cur.GetDataReader();

// With the data reader, we can populate the data table.
OracleDataTable dt = new OracleDataTable();
dt.Load(r);
Visual Basic Copy Code
' Open the connection. Until the connection is opened,
' any invocation of package methods will throw an exception.
Pack1.Connection.Open()

' 1. Check the number of rows in the dept table via the dept_count function:
Dim count As Integer = Pack1.DeptCount()

' 2. Insert a record via the insert_dept procedure:
Pack1.InsertDept(100, "Research", "San-Jose")

' 3. Get all records using the get_all_depts procedure, and fill a DataTable with them:
Dim cur As OracleCursor

' The procedure returns an OracleCursor object, which can be used to retrieve a data reader.
Pack1.GetAllDepts(cur)
Dim r As OracleDataReader = cur.GetDataReader()

' With the data reader, we can populate the data table.
Dim dt = New OracleDataTable()
dt.Load(r)

See Also

Logging Onto The Server | Creating Database Objects


Using Object Wizard for Working with Oracle Objects

Using Object Wizard for Working with Oracle Objects
support@devart.com

This article describes how to work with Oracle Objects using dotConnect for Oracle.

  • Introducing
  • Requirements
  • Creating Typed OracleObjects
  • Using Typed OracleObjects

Introducing

dotConnect for Oracle leverages working with user-defined types in Oracle database providing mechanisms for using both typed and untyped OracleObjects.

Untyped OracleObjects are represented by instances of the OracleObject class. This is a flexible way of treating Oracle objects, but it provides almost no possibilities for type validation and is less convenient than using typed OracleObjects. See Objects article for more details about untyped Oracle Object usage.

Typed OracleObject represents the single user-defined type, allowing to work with its instances as with usual .NET objects. This tutorial shows how typed OracleObjects can be created and used.

Typed OracleObjects are available in the OCI mode only. Untyped OracleObjects can be used in both OCI and Direct modes.

Requirements

This walkthrough supposes that you know how to establish a connection to server, how to create the database objects, how to manipulate with the data stored on the server and how to pass parameters to the commands executed.

To follow the tutorial, you also need the user-defined type TAddress and a table EmpObject with a field of the TAddress type created in your Oracle database. This can be made by executing the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);
/

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TADDRESS,
  Job VARCHAR2(9)
);
/

INSERT INTO EmpObject (Code, Person, Address, Job)
            VALUES (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');

INSERT INTO EmpObject (Code, Person, Address, Job)
            VALUES (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');

INSERT INTO EmpObject (Code, Person, Address, Job)
            VALUES (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');

INSERT INTO EmpObject (Code, Person, Address, Job)
            VALUES (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

Creating Typed OracleObjects

To create a typed OracleObject, one may perform the following steps:

  1. Start Typed Oracle Objects Wizard: select Tools -> Oracle -> Oracle Objects Wizard item in main menu of Visual Studio.

  2. Set the connection properties to the server where you created an object type and click Next:

    dotConnect for Oracle Objects Wizard - Setup data connection properties

    Pay attention that the connection can be made in the OCI mode only since Oracle Objects are unavailable in the Direct mode.

  3. Select the type you want to work with and click Next. In this sample, the TAddress type is used:

    dotConnect for Oracle Objects Wizard - Choose Oracle Type

    In this window, you can select to show either all object types in the database or only those belonging to the specific user. For this purpose, use the radio buttons All and User accordingly, and select the user in the corresponding list box.

  4. The next window allows you to set up the name of the generated class, the namespace where it would be placed and the naming rules for attributes of the object. In this tutorial, the defaults are used, so just click Finish.
    dotConnect for Oracle Objects Wizard - Setup code generation options

The wizard will generate the TAddress class representing the TAddress object type.

Using Typed OracleObjects

With the typed OracleObject class generated, attributes of Oracle UDTs can be used just as usual members of .NET objects. The following sample shows how Taddress instances may be used. In the sample, the contents of the EmpObject table are retrieved and printed using instances of the TAddress class:

C#csharp Copy Code
// Create and open a connection. Connection should not be in Direct mode,
// as in this case Oracle Objects would be unavailable.
OracleConnection connection = new OracleConnection
    ("Server = Ora; User Id = Scott; Password = tiger; Direct = false;");

connection.Open();

// Create a command selecting all rows from the table EmpObject
OracleCommand command = new OracleCommand
    ("select * from empobject", connection);

// By default, all Oracle Objects are retrieved by the application as instances
// of the OracleObject class. Thus, to use typed OracleObjects, we need to set
// the mapping from the TADDRESS Oracle UDT to Taddress class used in the application.
OracleType.GetObjectType("TAddress", connection).UdtType = typeof(TAddress);

// Execute the command, retrieve the data reader and print the table content.
OracleDataReader r = command.ExecuteReader();
while (r.Read())
{
    TAddress addr = (Taddress)r["Address"];
    Console.WriteLine
        (r["Person"].ToString() + ": " + addr.Country + ", " +
        addr.City + ", " + addr.Street + " " + addr.Apartment);
}
Visual Basic Copy Code
' Create and open a connection. Connection should not be in Direct mode,
' as in this case Oracle Objects are unavailable.
 Dim connection = New OracleConnection( _
    "Server = Ora; User Id = Scott; Password = tiger; Direct = false;")
connection.Open()

' Create a command selecting all rows from the table EmpObject
Dim command = New OracleCommand
    ("select * from empobject", connection)

' By default, all Oracle Objects are retrieved by the application as instances
' of the OracleObject class. Thus, to use typed OracleObjects, we need to set
' the mapping from the TADDRESS Oracle UDT to Taddress class used in the application.
OracleType.GetObjectType("TAddress", connection).UdtType = GetType(TAddress)

' Execute the command, retrieve the data reader and print the table content.
Dim r As OracleDataReader = command.ExecuteReader()
While (r.Read())
    Dim addr As Taddress = r("Address")
    Console.WriteLine( _
        r("Person").ToString() + ": " + addr.Country + ", " + _
        addr.City + ", " + addr.Street + " " + addr.Apartment.ToString())
End While

In the next sample we update the EmpObject table using the parameter of the Taddress type:

C#csharp Copy Code
// Create an UPDATE command with parameter
OracleCommand command = new OracleCommand
    ("update empobject set address = :pAddress where code = 1", connection);

// Create and set a Taddress object
Taddress addr = new Taddress();
addr.Country = "USA";
addr.City = "New York";
addr.Street = "Street";
addr.Apartment = 418;

// Set up the command parameter.
OracleParameter param = new OracleParameter("pAddress", OracleDbType.Object, "TAddress");
param.Value = addr;
command.Parameters.Add(param);

// Execute the command.
command.ExecuteNonQuery();
Visual Basic Copy Code
' Create an UPDATE command with parameter
Dim command = New OracleCommand( _
    "update empobject set address = :pAddress where code = 1", connection)

' Create and set a Taddress object
Dim addr As Taddress = New Taddress()
addr.Country = "USA"
addr.City = "New York"
addr.Street = "Street"
addr.Apartment = 418

' Set up the command parameter.
Dim param = New OracleParameter("pAddress", OracleDbType.Object, "TAddress")
param.Value = addr
command.Parameters.Add(param)

' Execute the command.
command.ExecuteNonQuery()

See Also

Working with Objects | OracleObject class


Using OCI Statement Caching

Using OCI Statement Caching
support@devart.com

In order to improve performance of SQL statement execution, dotConnect for Oracle supports OCI statements caching. Statement caching eliminates the need for reparsing SQL and PL/SQL statements when executing the same statement that was already executed by reusing the parsing information from the cursor, cached from the previous execution.

In order to achieve the best performance gain, Oracle recommends to use parameters instead of literals, since statement cache information can be reused for other statements that differ from the cached one by parameter values only. It is also recommended to cache only the statements that are executed multiple times. You can disable caching for a specific OracleCommand object by setting its Cached property to false.

You can manage statement cache using Statement Cache Size and Statement Cache Purge connection string parameters.

The Statement Cache Size parameter specifies the maximal number of statements that can be cached. By default it is set to 0, which means that the statement cache is disabled for the connection. Since the cached statement is in fact a cursor for this statement, opened in an Oracle database, this parameter should not be more than MAX_OPEN_CURSORS parameter in the Oracle database.

The Statement Cache Purge parameter determines whether to clear the OCI statement cache (close cache cursors) when closing the connection or putting it to the pool. By default this parameter is set to false, which means that cursors are left open when placing the connection to the pool thus providing best performance when using both connection pooling together with statement caching.

Additionally OracleConnection class has the PurgeStatementCache method, allowing you to clear OCI statement cache at any time.

Note that there is a separate cache for each connection. If you execute a statement, that was executed previously, via another connection, it still needs to be parsed unless the new connection was taken from the pool and is actually the same connection.

See Also

OracleCommand.Cached Property | OracleConnectionStringBuilder.StatementCacheSize | OracleConnectionStringBuilder.StatementCachePurge


OracleScript Hints for SQL*Plus Users

OracleScript Hints for SQL*Plus Users
support@devart.com

OracleScript class allows you to execute several SQL statements one by one. For example, you can use it to execute large scripts from script files. However, if these scripts were written for SQL*Plus, they may contain some commands, unsupported in OracleScript. This article offers some hints on how to execute such scripts with OracleScript.

OracleScript does not support SQL*Plus commands, for example SET or EXECUTE. When it encounters such a command, it throws an exception. Suppose, we have the following script with such commands:

    set define off;
    select * from dept;
    execute stored_procedure('parameter');

Each SQL*Plus command must end with the new line ('\n') character. It allows OracleScript to detect the end of the SQL*Plus command and the beginning of a new statement.

To process such a script, you may use the SqlStatementExecute event of the OracleScript object. Create an OracleScript object with the following code:

C#csharp Copy Code
OracleConnection conn = new OracleConnection("connection string");
static void Main(string[] args)
{
        OracleConnection conn = new OracleConnection("connection string");
        conn.Open();
        OracleScript script = new OracleScript("script text", conn);

        script.SqlStatementExecute += new SqlStatementExecuteEventHandler(script_SqlStatementExecute);
        script.Execute();
        conn.Close();
}
Visual Basic Copy Code
Private conn As New OracleConnection("connection string")
Shared Sub Main(args As String())
        Dim conn As New OracleConnection("connection string")
        conn.Open()
        Dim script As New OracleScript("script text", conn)

        script.SqlStatementExecute += New SqlStatementExecuteEventHandler(script_SqlStatementExecute)
        script.Execute()
        conn.Close()
End Sub

The SqlStatementExecuteEventArgs type has the SqlPlusStatementType property, which determines the type of the SQL*Plus command. So, we can determine and either skip different kinds of SQL*Plus commands or process them manually in the SqlStatementExecute event handler.

In our example we skip the SET commands and enclose EXECUTE commands in PL/SQL blocks.

C#csharp Copy Code
static void script_SqlStatementExecute(object sender, SqlStatementExecuteEventArgs e)
{
   //we skip executing Set commands
   if (e.SqlPlusStatementType == SqlPlusStatementType.Set)
        {
                e.StatementStatus = Devart.Common.SqlStatementStatus.SkipStatement;
                return;
        }

   //we process the execute command - it must be executed inside the PL/SQL block
        if (e.SqlPlusStatementType == SqlPlusStatementType.Execute)
        {
                var script=(OracleScript)sender;
                e.StatementStatus = Devart.Common.SqlStatementStatus.SkipStatement;
                OracleCommand comm = new OracleCommand();
                comm.Connection = script.Connection;
                comm.CommandText = "begin " + e.Text.Remove(0, "execute".Length).Trim() + "; end;";
                comm.ExecuteNonQuery();
                comm.Dispose();
                return;
        }
}

Visual Basic Copy Code
Private Shared Sub script_SqlStatementExecute(sender As Object, e As SqlStatementExecuteEventArgs)
    'we skip executing Set commands
    If e.SqlPlusStatementType = SqlPlusStatementType.[Set] Then
        e.StatementStatus = Devart.Common.SqlStatementStatus.SkipStatement
        Return
    End If

    'we process the execute command - it must be executed inside the PL/SQL block
    If e.SqlPlusStatementType = SqlPlusStatementType.Execute Then
        Dim script = DirectCast(sender, OracleScript)
        e.StatementStatus = Devart.Common.SqlStatementStatus.SkipStatement
        Dim comm As New OracleCommand()
        comm.Connection = script.Connection
        comm.CommandText = "begin " & e.Text.Remove(0, "execute".Length).Trim() & "; end;"
        comm.ExecuteNonQuery()
        comm.Dispose()
        Return
    End If
End Sub

See Also

Devart.Data.Oracle.OracleAlerter class


Oracle TimesTen Support

Oracle TimesTen Support
support@devart.com

TimesTen is an in-memory full-featured relational database management system, sharing many features of Oracle Database, supporting persistence and recoverability.

As an in-memory database, TimesTen provides high performance and very low response times and is widely used in communications, financial services, web applications.

Connecting to Oracle TimesTen Database

dotConnect for Oracle supports Oracle TimesTen in the OCI connection mode. To connect to Oracle TimesTen database you must install TimesTen Data Manager or TimesTen Client on your computer. TimesTen must be installed with the PL/SQL option, and PL/SQL must be enabled.

After this you need to create an ODBC Data Source, connecting to the necessary TimesTen database. Don't forget to set the PLSQL connection attribute to 1.

You may either add the corresponding entry to the Oracle Client tnsnames.ora file, and specify the created tnsname as the Data Source or Server or Host connection string parameter, or use the easy connect naming method to connect to an Oracle TimesTen database.

For easy connect naming method, the Data Source or Server or Host connection string parameter must be specified in the following format: "<host>/<service_name>:<server>", where:

  • <host> is a host with the TimesTen database
  • <service_name> is the name of the corresponding ODBC Data Source.
  • <server> must be "timesten_client" (without quotes) if the corresponding ODBC Data source connects via TimesTen Client or "timesten_direct" (without quotes) if the corresponding ODBC Data source connects via TimesTen Data Manager.

TimesTen Support Limitations

There are the following limitations for TimesTen connections:

  • Connecting to TimesTen is not supported in the Direct mode.
  • Advanced Queuing (AQ) is not supported
  • The OracleLoader class uses Array Binding instead of the direct path load interface, and has limited functionality
  • Transparent Application Failover is not supported
  • User-defined types (UDT) are not supported, and accordingly the OracleObject and NativeOracleObject classes are not supported too
  • The OracleBFile, OracleIntervalYM, and OracleXml classes are not supported
  • The OracleLob class is not supported for Oracle TimesTen 11g Release 1, but is supported for Oracle TimesTen 11g Release 2
  • The OracleDatabase class is not supported
  • The OracleDependency class is not supported
  • The OracleGlobalization class is not supported
  • The OracleTrace class is not supported
  • Views are listed in the Server Explorer without their columns
  • Oracle Package Wizard is not supported
  • Oracle Object Wizard is not supported
  • ASP.NET Web-providers are not supported
  • LinqConnect is not supported
  • Sync Framework is not supported
  • Workflow Foundation is not supported

The following Entity Framework features are not supported for TimesTen databases:

  • Entity Developer
  • Creating autoincrement Identity columns using Code First / Code-First Migrations
  • Adding views to the model when creating a model with EDM Wizard/EDM Designer in Visual Studio 2008 SP1, 2010, 2012, and Entity Framework Tools for Visual Studio 2012/2013/2015 using Database First approach
  • Model First approach

See Also

OracleCommand Class | OracleConnection Class


Connecting to Oracle with Proxy Authentication

dotConnect for Oracle Tutorials Documentation
Connecting to Oracle with Proxy Authentication
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

This topic describes how to connect to Oracle server using proxy authentication.

Proxy authentication allows middle-tier applications to control the security by preserving database user identities and privileges. Oracle allows creating a proxy database user, connecting and authenticating against the database on behalf of database users.

Proxy authentication is not supported in Direct mode.

With dotConnect for Oracle you can connect to Oracle using proxy authentication in two ways: either using two connection instances and the Open method overload, accepting an OracleConnection, and using a single OracleConnection instance with the Proxy User Id and Proxy Password connection string parameters.

Here is an example, using two connections:

C#csharp Copy Code
      using (OracleConnection proxyConnection = new OracleConnection("Data Source=ORA; User Id=my_proxy_user; Password=my_proxy_user_password;")) {
        proxyConnection.Open();

        OracleConnection scottConnection = new OracleConnection("User Id=scott; Pooling=false;");
        scottConnection.Open(proxyConnection);

        OracleCommand cmd = scottConnection.CreateCommand();
        cmd.CommandText = "SELECT SYS_CONTEXT('USERENV', 'PROXY_USER'), SYS_CONTEXT('USERENV', 'SESSION_USER') FROM dual";
        using (OracleDataReader reader = cmd.ExecuteReader(CommandBehavior.SingleRow)) {
          reader.Read();
          Console.WriteLine("PROXY_USER '{0}'", reader.GetString(0));   // 'MY_PROXY_USER'
          Console.WriteLine("SESSION_USER '{0}'", reader.GetString(1)); // 'SCOTT'
        }
      }
Visual Basic Copy Code
Using proxyConnection As New OracleConnection("Data Source=ORA; User Id=my_proxy_user; Password=my_proxy_user_password;")
    proxyConnection.Open()

    Dim scottConnection As New OracleConnection("User Id=scott; Pooling=false;")
    scottConnection.Open(proxyConnection)

    Dim cmd As OracleCommand = scottConnection.CreateCommand()
    cmd.CommandText = "SELECT SYS_CONTEXT('USERENV', 'PROXY_USER'), SYS_CONTEXT('USERENV', 'SESSION_USER') FROM dual"
    Using reader As OracleDataReader = cmd.ExecuteReader(CommandBehavior.SingleRow)
        reader.Read()
        Console.WriteLine("PROXY_USER '{0}'", reader.GetString(0))      ' 'MY_PROXY_USER'
        Console.WriteLine("SESSION_USER '{0}'", reader.GetString(1))    ' 'SCOTT'
    End Using
End Using

And the next example uses the Proxy User Id and Proxy Password connection string parameters:

C#csharp Copy Code
      using (OracleConnection proxyConnection = new OracleConnection("Data Source=ORA; Proxy User Id=my_proxy_user; Proxy Password=my_proxy_user_password; User Id=scott;")) {
        proxyConnection.Open();

        OracleCommand cmd = proxyConnection.CreateCommand();
        cmd.CommandText = "SELECT SYS_CONTEXT('USERENV', 'PROXY_USER'), SYS_CONTEXT('USERENV', 'SESSION_USER') FROM dual";
        using (OracleDataReader reader = cmd.ExecuteReader(CommandBehavior.SingleRow)) {
          reader.Read();
          Console.WriteLine("PROXY_USER '{0}'", reader.GetString(0));   // 'MY_PROXY_USER'
          Console.WriteLine("SESSION_USER '{0}'", reader.GetString(1)); // 'SCOTT'
        }
      }
Visual Basic Copy Code
Using proxyConnection As New OracleConnection("Data Source=ORA; Proxy User Id=my_proxy_user; Proxy Password=my_proxy_user_password; User Id=scott;")
    proxyConnection.Open()

    Dim cmd As OracleCommand = proxyConnection.CreateCommand()
    cmd.CommandText = "SELECT SYS_CONTEXT('USERENV', 'PROXY_USER'), SYS_CONTEXT('USERENV', 'SESSION_USER') FROM dual"
    Using reader As OracleDataReader = cmd.ExecuteReader(CommandBehavior.SingleRow)
        reader.Read()
        Console.WriteLine("PROXY_USER '{0}'", reader.GetString(0))
        ' 'MY_PROXY_USER'
        Console.WriteLine("SESSION_USER '{0}'", reader.GetString(1))
        ' 'SCOTT'
    End Using
End Using

See Also

Getting Started | OracleConnection Class


Working with DataSets

Working with DataSets
support@devart.com

This section describes working with DataSets with such dotConnect tools as DataSet Wizard, DataSet Manager, and DataSet Editor. This section is applicable only for full .NET Framework.

  • Using DataSet Wizard

    The DataSet Wizard is designed to create and manage typed provider-specific datasets. The wizard takes you step by step through the process of creating the typed OracleDataSet object and integrates it with you project. This topic provides information on every screen of DataSet Wizard.

  • Using DataSet Manager

    The DataSet Manager window displays the data sources in your project represented by OracleDataSet and OracleDataTable classes. You can use DataSet Manager to create a user interface with data-bound controls by dragging items from the window onto forms in the project. This article describes how to use DataSet Manager.

  • Using DataSet Editor

    The DataSet Editor is designed to tweak DataSets, set all the necessary parameters for them, create and edit their DataTables, etc. This topic provides information on on how to Edit DataSets with DataSet Editor.


Using DataSet Wizard

Using DataSet Wizard
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

General Information

dotConnect for Oracle leverages managing DataSets in your applications with special wizard that takes you through the process of creation and tuning of client-side data handling. This topic provides information on functions of every screen of dotConnect for Oracle DataSet Wizard and how to use all its features. For detailed information on data access basics please refer to article "Using DataSets in ADO.NET" in MSDN.

There are three ways to invoke the wizard:

  • Click Tools main menu item in IDE, point to Oracle, and click DataSet Wizard item.
  • In DataSet Manager, click Add New DataSet or Configure DataSet with Wizard button.
  • Right-click a OracleDataAdapter component and choose DataSet Wizard item.

The wizard allows you to keep resultsets structure as DataAdapters, TableAdapters or just metadata information. The behavior of Wizard slightly differs depending on whether you had some Windows Forms or Web Forms Designer focused when the DataSet Wizard was invoked. If there was a designer focused, its name is shown in Wizard caption, otherwise the caption contains name of the project, and DataAdapters can't be used as data source for database objects.

This feature is available in Professional and Developer Editions only.

Step 1: Choose DataSet

Devart DataSet Wizard - Choose DataSet to work with

This dialog allows you to choose whether you want to create new DataSet or modify existing one. When you select existing DataSet its tables are shown in the list. The wizard attempts to preserve existing tables and relations whenever possible.

Step 2: Choose Database Objects

Devart DataSet Wizard - Choose database objects

This dialog allows you to select database objects you want to include in the dataset. You can mark tables, views, individual columns, stored procedures and stored functions. Selecting a table automatically selects all its columns. Database relations are not listed in the database hierarchy because you will be able to setup it later.

Note that when you click Next, every selected stored procedure is executed with default parameters' values. Do not select stored procedures that may damage your data.

The buttons to the right of database tree allow you to create, configure, rename and remove connections. The Show all databases check box controls whether you can see all databases on the server or only those specified as default for connections. If a connection has no default database, all databases are visible regardless of this setting.

The Data Source type combo box to the right of the tree allows you to choose how to store all selected database objects. For example, if you choose Data Adapter, new DataAdapter components will be created for all checked tables, views and stored procedures. Similarly, if you choose Command Schema, DataSet will contain structure (metadata) of all selected objects. Every database object can be adjusted on the next step regardless of this setting.

The screenshot above demonstrates that you can select whole tables as well as individual columns.

The Conflict Option combo box allows you to generate update commands with the specified ConflictOption mode.

Step 3: Setup Individual Tables

Devart DataSet Wizard - Setup individual data tables

The DataSet Wizard allows you to configure data source for every individual table. Click on the list at the left part of screen to view its settings. The buttons Configure, Preview Data and Rename perform corresponding actions on underlying data source, while buttons Add and Remove control list of tables.

This page also allows you to map a table name. To do it, select a table from the list and press F2. As presented on the screenshot, tables dept and emp are renamed to departments and employees. These new names will be used on consecutive pages of DataSet Wizard.

The Data source combobox allows you to choose what way every database object will be represented: Table Adapter, Data Adapter or Command schema (this means that only description of data structure is stored in the DataSet). Choose required data source type and then click Configure button to set it up. You can also use existing DataAdapters on the form.

Another combobox, Update method, allows you to enable or disable generating of update commands. It has following options:

  • Do not generate update commands. You typically choose this option when adapter will be used only to read data from a data source, not write it back. Or you wish to fill in the commands yourself after the wizard has finished. This is the only choice available for stored procedures and Command schemas.
  • Generate update commands. When you choose Data Adapter as data source, DataSet Wizard generates SQL statements for the adapter's UpdateCommand, InsertCommand, and DeleteCommand properties. For Table Adapters the Wizard also generates Fill() and GetData() methods.
  • Use CommandBuilder. This option is available for Data Adapters only, if a Form Designer was focused when Wizard started. Wizard will create a CommandBuilder object, setup it and place it on the form.

Step 4: Choose Column Mappings

Devart DataSet Wizard - Cobfigure columns mapping

This step allows you to adjust column name mapping. Click on a table in the left list to reveal its columns. Note that column names must be unique. You can't add or delete columns on this step.

You can map a table name in step 3.

Step 5: Specify Database Relations

Devart DataSet Wizard - Configure DataSet relations

The last step in generating dataset allows you to add, delete or edit database relation. The Wizard automatically imports existing data constraints from database. You can setup a relationship that maintains information about corresponding records in two data tables in a dataset. Creating a relationship also creates a foreign-key constraint that is added to the child table. A foreign-key constraint can implement referential integrity between parent and child tables.

  • Update rule. Specifies how changes are made to child records when a parent record is updated to maintain referential integrity.
  • Delete rule. Specifies how changes are made to child records when a parent record is deleted to maintain referential integrity.
  • Accept/Reject rule. Specifies how changes are made to child records when changes to a parent record are accepted or rejected to maintain referential integrity. For this option the only allowed values are None and Cascade.

The following values are available:

  • None. No action taken on related rows. This is the default value.
  • Cascade. Delete or update related rows.
  • SetDefault. Set values in related rows to some default value.
  • SetNull. Set values in related rows to DBNull.

The screenshot contains example of a relation in single table. According to the layout, if a record is deleted, all MGR fields that once pointed to the record become NULL.

Step 6: Choose DataSet placement

Devart DataSet Wizard - Wizard finished successfully

After dataset is generated you can let Wizard create an instance of generated class. It will be visible in Forms Designer. This option is not available if no designer was focused when wizard started.

Keep in mind that DataSet Wizard creates additional .xse file with some settings. This file is required for the project to build correctly.

See Also

Developing Database Applications with dotConnect for Oracle


Using DataSet Manager

Using DataSet Manager
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

The DataSet Manager window displays the data sources in your project represented by OracleDataSet and OracleDataTable classes. You can use DataSet Manager to create a user interface with data-bound controls by dragging items from the window onto forms in the project. Every item has a drop-down list where you can select the type of control to create when dragging it onto a form. You can customize the control list with additional controls, including controls that you have created.

With DataSet Manager you can:

  • Create forms that display data by dragging items from DataSet Manager onto forms.
  • Connect existing controls to data by dragging items from DataSet Manager onto existing controls.
  • Customize the list of controls available for each data type in DataSet Manager.
  • Choose which control should be created when dragging an item onto a form in your Windows application.
  • Create and add new data sources in your project.
  • Open datasets for editing in the DataSet Editor.

This feature is available in Professional and Developer Editions only.

Opening the DataSet Manager Window

To display the DataSet Manager window, click Tools in the main menu, point to Oracle, and choose DataSet Manager. This menu item is only available when a project is open in Visual Studio.

Populating the DataSet Manager Window

You populate the DataSet Manager window by adding OracleDataSet and OracleDataTable components to your project. One of the easy ways to do it is using the DataSet Wizard.

Note that a data source is available in DataSet Manager only if its form is opened. When you close a form, the OracleDataSet and OracleDataTable components located on it disappear from the DataSet Manager window.

Creating Data-bound Controls

You can drag an item from DataSet Manager onto a form to create a new data-bound control, or you can drag an item from DataSet Manager onto an existing control to set up the data binding between the control and the item dragged onto it. Each node in the DataSet Manager window allows you to choose the type of control that will be created when you drag it onto a form. You must choose between a Grid layout, where all columns or properties are displayed in a DataGridView, or a Details layout, where all columns or properties are displayed in individual controls. You can choose the control to be created prior to dragging by selecting an item in DataSet Manager and choosing the control from the item's drop-down control list.

Data-bound Controls That Display Related Records

DataSet Manager displays related tables in a hierarchical tree view. For example, in a dataset with Dept and Emp tables (where a department can have many employees), the Emp table appears as the last column in the Dept table as an expandable node. To display data from this related table and set up the data binding to display the employees for a selected department, you would drag items from this related tree view (as opposed to items from the individual top-level nodes for Dept and Emp).

Commands Available in DataSet Manager

The following commands are available through the DataSet Manager toolbar or popup menu:

  • Add New DataSet
    Opens the DataSet Wizard, which assists you in creating new data sources in your project.
  • Edit DataSet with Designer
    Opens the selected dataset in the DataSet Designer.
  • Configure DataSet with Wizard
    Opens the DataSet Wizard populated with information from the selected data source.
  • Refresh
    Synchronizes the DataSet Manager window with the data sources in your project. This operation is performed automatically, so actually there is no need to use this option.
  • Preview Data
    Shows the Data Preview form where you can inspect and edit selected table.

Cross-form References

When you drag an item from the DataSet Manager window onto a form that does not have an instance of the DataSet, DataSet Manager creates an additional DataLink component. For more information about cross-form referencing please refer to topic InterForm Technology.

See Also

Using DataSet Wizard | InterForm Technology | DataLink Component Architecture | Developing Database Applications with dotConnect for Oracle


Using DataSet Editor

Using DataSet Editor
support@devart.com
  • General Information
  • Creating typed DataSet
  • Using created DataSet
Note Note:
This topic is applicable only for full .NET Framework.

General Information

dotConnect for Oracle supports working with both strongly typed and untyped DataSets. The DataSet Editor is a tool that allows you to create a strongly typed DataSet visually. This tutorial shows how to set the DataSet schema with the editor manually. For information about typed DataSet generation with the help of wizard, see tutorial Using DataSet Wizard.

This walkthrough supposes that you know how to establish the connection to the Oracle server (see Logging onto the Server) and how to use Devart configuration window for data tables and commands.

Creating typed DataSet

In this tutorial, we will create a strongly typed DataSet from an untyped one. It will include tables Dept and Emp; for their definitions, see the tables.sql script which is located in the dotConnect for Oracle installation directory. The following steps need to be performed:

  1. Create an untyped DataSet OracleDataSet1. To do this, you may either drop an OracleDataSet object to the form or double-click it in the toolbox. Select the Untyped OracleDataSet option and click OK:

    Add OracleDataSet dialog box

    Double-click new DataSet or select the Edit item from the pop-up menu to start DataSet Editor.

  2. Create a data table. Use the Add new table to DataSet button to create a new data table. Rename the table to "Dept" with the corresponding item of the pop-up menu.

  3. Configure data table. Set up DataTable select and update commands. Double-click the table or select the Configure Data Table item from the pop-up menu. DataTable Editor window will appear:

    For detailed information about DataTable Editor using, see the Working with Command Editor topic.

  4. Generate data table schema. Populate the Columns collection of the data table by clicking the Create Columns item from the table item pop-up menu:

    Otherwise, you will be prompted to create table columns during the DataSet schema saving.

  5. Configure additional data tables. Repeat steps 2-4 to add other data tables (the only Emp table in our case):

    Setting up emp table

    Note:To remove redundant data tables from your DataSet, use the Remove table from the DataSet button.

  6. Create associations. Use the Edit DataSet relations button to set up associations between your tables. Add and edit relations in the relation editor:

  7. Save DataSet Schema. Use the Save Schema button to save your DataSet. Set the schema name to NewDataSet. After schema saving the NewDataSet class is generated. It will be available in the toolbox and can be used for other typed DataSets creation with the same schema. OracleDataSet1 object becomes an instance of typed NewDataSet and cannot be changed by the editor anymore:

Using created DataSet

The OracleDataSet1 object can be used as common typed DataSet now. For example, the following code will

  1. fill the OracleDataSet1 object;
  2. insert a new record into the Dept table;
  3. delete the row with Empno = 20 from the Emp table.
C#csharp Copy Code
myDataSet1.Fill();
myDataSet1.Dept.AddDeptRow(50, "IT", "San-Francisco");
myDataSet1.Emp.RemoveEmpRow(myDataSet1.Emp.FindByEMPNO(20));
Visual Basic Copy Code
myDataSet1.Fill()
myDataSet1.Dept.AddDeptRow(50, "IT", "San-Francisco")
myDataSet1.Emp.RemoveEmpRow(myDataSet1.Emp.FindByEMPNO(20))

See Also

Working with Command Editor | Using DataSet Wizard | Logging Onto The Server


WinForms-Specific Features

WinForms-Specific Features
support@devart.com

This section describes dotConnect for Oracle features, specific for WinForms applications.

  • InterForm Technology

    Devart data providers intend to leverage design time aspects of development as much as possible. In this direction dotConnect for Oracle introduces new technology that allows referencing components that reside on different forms of a WinForms application. This article describes the InterForm technology.

  • DataLink Component Architecture

    This article provides information on how to implement advanced data binding with the DataLink component. The article describes advanced features of the component and shows how to use it together with the InterForm technology.


InterForm Technology

InterForm Technology
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

Devart data providers intend to leverage design time aspects of development as much as possible. In this direction dotConnect for Oracle introduces new technology that allows referencing components that reside on different forms of a WinForms application. This article describes how to use the InterForm technology.

  • Introduction
  • InterForm Fundamentals
  • Requirements
  • Limitations
  • Use Cases and Recommendations

Introduction

Modern applications usually implement multiform user interface and centralized data access model. However, Visual Studio provides rather inconvenient tools for design-time development of such applications. For example, it is very uncomfortable to retrieve live data in design time with single database connection and unified data access and storage module. Moreover, you have to write additional code to maintain shared connections and datasets.

The InterForm technology addresses these problems and allows you to circumvent most obstacles on the way to design time development of applications with a good architecture.

InterForm Fundamentals

When you work in design time, it is very easy to establish cross form reference with InterForm. Select the reference property in Properties window, then click the drop down button and navigate through the tree to find the component you want to connect to.

This results in two actions. First, dotConnect for Oracle establishes reference to the selected component, so you can use it right away. Second, dotConnect for Oracle creates a virtual link that describes the referenced component symbolically. This string has three constituents: form name, component name, and, optionally, name of nested component. For example, when a DataLink object references table table1 in OracleDataSet dataSet1 on a MyForm, the virtual link string looks like MyForm.dataSet1.table1. When the referencing component is loaded in run time or design time, dotConnect for Oracle tries to resolve the virtual link. In case when referenced component cannot be found, the reference is set to null in design time, or an exception is thrown in run time. In design time, when you open the form with referenced components, the actual references are updated. When the referenced form is closed, the actual references are set back to null.

The InterForm technology can be used with properties that reference the following types:

  • OracleConnection
  • OracleCommand
  • OracleDataTable
  • OracleDataSet

There's important note about inheritance. Consider you have a form with a component, and this component is referenced from somewhere. Consider you have a descendant of this form. In this case the reference will still point to the ancestor component, not the descendant.

Requirements

There are some requirements for InterForm to function properly. In design time, the form that contains referenced components should be always open, so that virtual links can be resolved. For the same reason, in run time the form that contains referenced components should be created before any form that references it. And there should be only one instance of the form, so that virtual links can be resolved to unique components.

Limitations

The InterForm technology is supported for WinForms applications only (not available for ASP.NET and Compact Framework). The InterForm links are resolved as long as referenced form designer is created, so you have to keep it open. Likewise, if you change the name of a referenced component, and the referencing form is not open, the virtual link is not updated.

Note that in some cases, like inheritance and frame embedding, the IDE compiles ancestor (or original frame) and uses it in design time. In the compiled version the virtual link is not available, so the project may need to be recompiled to reflect most recent changes in references.

As mentioned before, the form that contains referenced components should be created before any form that references it. Hence it is not possible to establish cross-reference links like two forms referencing each other.

Use Cases and Recommendations

If you wish to use advantages of the InterForm technology, we recommend to keep all data access components on a single form, which is created before other forms in run time, and that is kept open in design time. This approach will help to build a centralized application and avoid common problems.

Below we demonstrate some examples of using the InterForm technology to solve some problems that developers encounter frequently.

Shared single connection. It is often required that a complex application with many forms and modules uses single OracleConnection that can be adjusted in single location. Using standard techniques, you would have to pass the connection in run time everywhere, which means no design time operations. But with the InterForm technology you can:

  1. Setup the connection on a standalone form.
  2. Make sure this form is created before other forms in run time.
  3. Point your components to the connection and use all design time features.

Unified data source. Sometimes application architecture requires that some set of components uses same data source. Again, this leads to inconvenient design-time operations for multiform applications. But with the InterForm technology you can:

  1. Setup the data access components on a standalone form.
  2. Create DataLink components to reference the data access components.
  3. Use the DataLink objects as data source.

Now when you resetup the data access components, the changes are propagated to other controls through DataLink objects automatically.

See Also

General Concepts in Database Application Development | DataLink Component Architecture | Developing Database Applications with dotConnect for Oracle


DataLink Component Architecture

DataLink Component Architecture
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

This article provides information on how to implement advanced data binding with the DataLink component. The article describes advanced features of the component and shows how to use it together with the InterForm technology.

  • General Information
  • DataLink Features
  • DataLink Advanced Features
  • Use Case

General Information

With the DataLink component, you can universally bind all Windows Forms controls to data sources.

The DataLink component simplifies the process of binding controls to a data source. The component is the preferred way to bind your Windows Forms controls to data sources because it provides the following advantages over traditional data binding:

  • Design-time data binding
  • Encapsulation of CurrencyManager functionality with CurrencyManager events at design time
  • Simpler creation of a list that supports the IBindingList interface
  • A level of indirection between the data source and the control

The DataLink component is built over the .NET Framework BindingSource class. So, you can use it as an advanced alternative to BindingSource.

DataLink Features

The DataLink component provides several features for binding controls to data. With these features, you can implement most data-binding scenarios with almost no coding on your part. The DataLink component accomplishes this by providing a consistent interface for accessing most usable data sources

The consistent interface provided by the DataLink component greatly simplifies the process of binding data to controls. For data-source types that provide change notification, the DataLink component automatically communicates changes between the control and the data source. For data-source types that do not provide change notification, events are provided that let you raise change notifications. The following list shows the features supported by the DataLink component:

  • Design time support
  • Indirection
  • Currency management
  • Data source as a list
  • DataLink as an IBindingList
  • Custom and transactional item creation
  • IEnumerable support
  • Sorting and filtering with the IBindingListView interface
  • Integration with BindingNavigator

For detailed information on these features please refer to MSDN topic BindingSource Component Architecture.

DataLink Advanced Features

One of the most exciting features about the DataLink component is that it supports the InterForm technology, which means that you can employ cross-form binding in your applications. For example, you can synchronize current positions in two datasets on different forms without writing a line of code. The DataLink component supports both typed and untyped OracleDataSet and OracleDataTable components, as well as relations in the dataset schemas.

The DataLink component has powerful design-time property editor. The editor allows picking data source from any open form in the project.

Use Case

One of the attributes of a good application architecture is unified data source block, in other words, when some set of components uses same data source. The DataLink component allows you to build this scheme and retain convenient design-time setup for multiform applications. To achieve this goal, you should:

  1. Setup the data access components on a standalone form.
  2. Create DataLink components to reference the data access components.
  3. Use the DataLink objects as data source.

Now when you resetup the data access components, the changes are propagated to other controls through DataLink objects automatically.

See Also

General Concepts in Database Application Development | InterForm Technology | Developing Database Applications with dotConnect for Oracle


ASP.NET-Specific Features

ASP.NET-Specific Features
support@devart.com

This section describes dotConnect for Oracle features, specific for ASP.NET applications.

  • ASP.NET Provider Model Support
  • Using ExtendedMembership Provider in ASP.NET MVC 4 Application
  • Using OracleDataSource Component
  • Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle
  • Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle
  • Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle
  • Using Entity Framework Implementation of ASP.NET Identity 2 for Oracle
  • Configuring Trust Level for Web Applications


ASP.NET Provider Model Support

ASP.NET Provider Model Support
support@devart.com

dotConnect for Oracle can be used in the ASP.NET provider model. It allows developers to write better structured applications and easily switch data storage in ASP.NET applications from other media such as Microsoft SQL Server. For detailed information on the basics refer to MSDN whitepaper: ASP.NET 2.0 Provider Model: Introduction to the Provider Model.

dotConnect for Oracle implements the following providers: Membership, Session State, Role, Profile, Site Map, Web Event, and Personalization. This feature is available in Professional and Developer Editions only.

This topic provides information on how to set up ASP.NET application to use dotConnect for Oracle as one of these providers. It consists of the following sections:

  • Installation and setup
  • Membership provider
  • SimpleMembership provider
  • Role provider
  • Profile provider
  • Session State provider
  • Site Map provider
  • Web Event provider
  • Personalization provider
  • Deployment

Installation and setup

All providers are contained in the Devart.Data.Oracle.Web.dll assembly. You should add a reference to this assembly in your project in order to use the ASP.NET provider model. Another condition for the providers to function properly is existence of certain database objects. Before using ASP.NET providers, you have to run the InstallWebTables.sql script against the database you wish to use. The script can be found in the \Program Files\Devart\dotConnect\Oracle\Web\ASP.NET 2 folder.

During the installation process dotConnect for Oracle adds new entries into the machine.config file. They are used by websites when the settings are not overridden with a local Web.config file. You can choose to keep the settings in machine.config, in which case they will be used for all web sites, or in Web.config files, where you can set up specific parameters. Note that the default connection string in the machine.config file is incorrect, so you will want to adjust or override it.

When you redefine an identifier in the Web.config file, you have to add the remove keyword in the appropriate section, as shown below:
  <remove name="OracleServices" />
  <add name="OracleServices" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" />
This example demonstrates how to adjust connection string parameters. By default dotConnect for Oracle creates a stub connection string with the name OracleServices.

You can also configure your website with the standard Control Panel applet "ASP.NET Configuration Settings". To open it, navigate to Control Panel | Administrative Tools | Internet Information Services, then select a site or a virtual directory, open its properties, switch to ASP.NET, and click Edit Configuration. This dialog provides control over various site settings, including the connection string.

Membership provider

The fundamental job of a membership provider is to interface with data sources containing data regarding a site's registered users, and to provide methods for creating users, deleting users, verifying login credentials, changing passwords, and so on. The .NET Framework's System.Web.Security namespace includes the class named MembershipUser that defines the basic attributes of a membership user and that a membership provider uses to represent individual users.

To access this functionality, use the Devart.Data.Oracle.Web.Providers.OracleMembershipProvider class. It behaves as the System.Web.Security.RoleProvider class (you can read its description in MSDN). The following example shows the Web.config file for an ASP.NET application configured to use OracleMembershipProvider.

<configuration>
  <connectionStrings>
    <add name="OracleServices"
         connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" />
  </connectionStrings>
  <system.web>
    ...
    <membership defaultProvider="AspNetOracleMembershipProvider"
      userIsOnlineTimeWindow="15">
      <providers>
        <add
          name="AspNetOracleMembershipProvider"
          type="Devart.Data.Oracle.Web.Providers.OracleMembershipProvider,
                Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                PublicKeyToken=09af7300eec23701"
          connectionStringName="OracleServices"
          enablePasswordRetrieval="false"
          enablePasswordReset="true"
          requiresQuestionAndAnswer="true"
          requiresUniqueEmail="false"
          passwordFormat="Hashed"
          maxInvalidPasswordAttempts="5"
          passwordAttemptWindow="10" />
      </providers>
    </membership>
  </system.web>
</configuration>

Note: replace "8.4.215.0" with the actual provider version.

Role provider

The fundamental job of a role provider is to interface with data sources containing role data mapping users to roles, and to provide methods for creating roles, deleting roles, adding users to roles, and so on. Given a user name, the role manager relies on the role provider to determine what role or roles the user belongs to. The role manager also implements administrative methods such as Roles.CreateRole and Roles.AddUserToRole by calling the underlying methods in the provider.

To access this functionality use the Devart.Data.Oracle.Web.Providers.OracleRoleProvider class. It behaves as the System.Web.Security.RoleProvider class (you can read its description in MSDN). The following example shows the Web.config file for an ASP.NET application configured to use OracleRoleProvider. Note that you can configure OracleRoleProvider to use the same database and user information as OracleMembershipProvider in order to use a single database for authentication and authorization information.

<configuration>
  <connectionStrings>
    <add name="OracleServices"
         connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" />
  </connectionStrings>
  <system.web>
    ...
    <roleManager defaultProvider="AspNetOracleRoleProvider"
      enabled="true"
      cacheRolesInCookie="true"
      cookieName=".ASPROLES"
      cookieTimeout="30"
      cookiePath="/"
      cookieProtection="All" >
      <providers>
        <add
          name="AspNetOracleRoleProvider"
          type="Devart.Data.Oracle.Web.Providers.OracleRoleProvider,
                Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                PublicKeyToken=09af7300eec23701"
          connectionStringName="OracleServices" />
      </providers>
    </roleManager>
  </system.web>
</configuration>

Note: replace "8.4.215.0" with the actual provider version.

SimpleMembership

SimpleMembership is a new Membership API designed to improve and simplify the use of the built in security in ASP.NET. These SimpleMembership API are implemented as SimpleRoleProvider and SimpleMembershipProvider providers. As their predecessors, they are intended to work with data sources containing data regarding a site's registered users and with data sources containing role data mapping users to roles respectively.

To support this functionality, dotConnect for Oracle implements OracleExtendedMembershipProvider and OracleExtendedRoleProvider classes, which behave as the above-mentioned standard provider classes. You can read our Using ExtendedMembership Provider in ASP.NET MVC 4 Application tutorial to see how to use the dotConnect for Oracle SimpleMembership providers' implementation.

Profile provider

The fundamental job of a profile provider is to write profile property values supplied by ASP.NET to persistent profile data sources, and to read the property values back from the data source when requested by ASP.NET.

Unlike Session State provider, Profile provider is a typed structured data storage. It supports both registered and anonymous users. Profile providers also implement methods that allow consumers to manage profile data sources - for example, to delete profiles that haven't been accessed since a specified date.

The user profile is accessed using the Profile property of the current HttpContext object. The following example shows the Web.config file for an ASP.NET application configured to use OracleProfileProvider.

<configuration>
  <connectionStrings>
    <add name="OracleServices"
         connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" />
  </connectionStrings>
  <system.web>
    ...
    <profile defaultProvider="AspNetOracleProfileProvider" >
      <providers>
        <add
          name="AspNetOracleProfileProvider"
          type="Devart.Data.Oracle.Web.Providers.OracleProfileProvider,
                Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                PublicKeyToken=09af7300eec23701"
          connectionStringName="OracleServices" />
      </providers>
      <properties>
        <add name="ZipCode" />
        <add name="CityAndState" />
      </properties>
    </profile>
  </system.web>
</configuration>

Note: replace "8.4.215.0" with the actual provider version.

Here ZipCode and CityAndState are examples of profile elements. For detailed information on how to construct properties section refer to MSDN.

Session State provider

The session-state store provider is called by the SessionStateModule class during the processing of an ASP.NET page to communicate with the data store for the storage and retrieval of session variables and related session information such as the time-out value. Session data within each ASP.NET application is stored separately for each SessionID property. ASP.NET applications do not share session data.

For information on how to employ this functionality refer to ASP.NET Session State topic in MSDN. The following example shows the Web.config file for an ASP.NET application configured to use OracleSessionStateStore.

<configuration>
  <appSettings/>
  <connectionStrings>
    <add name="OracleServices"
         connectionString="User Id=Scott;Password=tiger;Data Source=Ora;"/>
  </connectionStrings>
  <system.web>
    <sessionState
      cookieless="true"
      regenerateExpiredSessionId="true"
      mode="Custom"
      customProvider="OracleSessionProvider">
      <providers>
        <add name="OracleSessionProvider"
          type="Devart.Data.Oracle.Web.Providers.OracleSessionStateStore,
                Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                PublicKeyToken=09af7300eec23701"
          connectionStringName="OracleServices"
          enableExpiredSessionAutoDeletion="true"
          expiredSessionAutoDeletionInterval="1800"
          writeExceptionsToEventLog="false"/>
      </providers>
    </sessionState>
  </system.web>
</configuration>

Note: replace "8.4.215.0" with the actual provider version.

The sessions, created by ASP.NET have a timeout value for each session (by default, 20 minutes). If a session is not accessed within the timeout interval, it is considered expired, and is no longer valid. The date and time when the session expires is stored in the Expires column of the aspnet_sessions table.

By default, expired sessions are not deleted from the table automatically. You can use the enableExpiredSessionAutoDeletion parameter to enable automatic deletion of the expired sessions and the expiredSessionAutoDeletionInterval to specify the interval between automatic deletions of expired sessions, as shown in the example above.

Site Map provider

Site Map provider provides the interface between ASP.NET's data-driven site-navigation features and site map data sources. The fundamental job of OracleSiteMapProvider is to read site map data from a data source and build an upside-down tree of SiteMapNode objects, and to provide methods for retrieving nodes from the site map. Each node in the tree represents one node in the site map. Node properties such as Title, Url, and ChildNodes define the characteristics of each node and allow the tree to be navigated in any direction.

To access this functionality use Devart.Data.Oracle.Web.Providers.OracleSiteMapProvider class. It behaves as described in reference for System.Web.SiteMaProvider class. The following example shows the Web.config file for an ASP.NET application configured to use OracleSiteMaProvider.

<system.web>
  <siteMap defaultProvider="OracleSiteMapProvider">
    <providers>
      <add name="OracleSiteMapProvider"
           type="Devart.Data.Oracle.Web.Providers.OracleSiteMapProvider,
                 Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                 PublicKeyToken=09AF7300EEC23701"
           connectionStringName="ConnectionString"
           securityTrimmingEnabled="true"
           />
    </providers>
  </siteMap>
</system.web>

Note: replace "8.4.215.0" with the actual provider version.

Web Event provider

Web Event provider provides the interface between ASP.NET's health monitoring subsystem and data sources that log or further process the events ("Web events") fired by that subsystem.

To access this functionality use Devart.Data.Oracle.Web.Providers.OracleWebEventProvider class. It behaves as described in reference for System.Web.Management.WebEventProvider class. The following example shows the Web.config file for an ASP.NET application configured to use OracleWebEventProvider. Note that proper use of the provider also requires many other subsections of healthMonitoring to be correctly configured.

<system.web>
  <healthMonitoring enabled="true" heartbeatInterval="0">
    ...
    <providers>
      <clear/>
      <add name="OracleWebEventProvider"
           type="Devart.Data.Oracle.Web.Providers.OracleWebEventProvider,
                 Devart.Data.Oracle.Web, Version=8.4.215.0, Culture=neutral,
                 PublicKeyToken=09AF7300EEC23701"
           connectionStringName="ConnectionString"
           maxEventDetailsLength="1073741823"
           buffer="false"
           bufferMode="Notification" />
    </providers>
    ...
  </healthMonitoring>
<system.web>

Note: replace "8.4.215.0" with the actual provider version.

Personalization provider

The fundamental job of a personalization provider is to provide persistent storage for personalization state regarding the content and layout of web pages.

To access this functionality use Devart.Data.Oracle.Web.Providers.OraclePersonalizationProvider class. It behaves as described in reference for System.Web.UI.WebControls.WebParts.PersonalizationProvider class. The following example shows the Web.config file for an ASP.NET application configured to use OraclePersonalizationProvider.

<system.web>
    <webParts>
      <personalization defaultProvider="WebPartProvider">
        <providers >
          <add name="WebPartProvider"
               connectionStringName="ConnectionString"
               type="Devart.Data.Oracle.Web.Providers.OraclePersonalizationProvider,
                     Devart.Data.Oracle.Web, 8.4.215.0, Culture=neutral,
                     PublicKeyToken=09af7300eec23701" />
        </providers>
      </personalization>
    </webParts>
<system.web>

Note: replace "8.4.215.0" with the actual provider version.

Deployment

To deploy ASP.NET applications written with dotConnect for Oracle you should register run-time assemblies Devart.Data.dll, Devart.Data.Oracle.dll, and Devart.Data.Oracle.Web.dll at Global Assembly Cache (GAC) for appropriate framework or place it in the folder of your application (Bin folder for web projects).

Also place App_Licenses.dll assembly in the Bin folder. For more information about this assembly refer to Licensing topic.

Keep in mind that web application are usually run in a partially trusted environment. Here are the permissions required by dotConnect for Oracle:

  • in Direct mode - medium trust plus SocketPermission;
  • in OCI mode - medium trust plus ReflectionPermission, RegistryPermission, EnvironmentPermission for PATH environment variable, FileIOPermission for Oracle Client.


Using ExtendedMembership Provider in ASP.NET MVC 4 Application

Using ExtendedMembership Provider in ASP.NET MVC 4 Application
support@devart.com

dotConnect for Oracle implements SimpleMembership functionality as OracleExtendedMembershipProvider and OracleExtendedRoleProvider classes. This tutorial describes how to use the new ASP.NET MVC membership provider functionality in ASP.NET MVC 4 application (using the Internet Application template).

To complete this tutorial you need ASP.NET MVC 4 installed. It is preinstalled with Visual Studio 2012 and later. For Visual Studio 2010 you can download it from here.

In order to create an ASP.NET MVC 4 application using our OracleExtendedMembershipProvider, perform the following steps:

  1. Create an ASP.NET MVC 4 Web Application in Visual Studio. To do it, select New -> Project from the File menu, click Web under Installed Templates, and select ASP.NET MVC 4 Web Application in the list of available templates.

    Selecting a project template

    Then select the Internet Application template in the opened New ASP.NET MVC4 Project dialog box.

    Selecting ASP.NET MVC 4 web application template

  2. Add necessary references to our assemblies to the project. You need to add references to the Devart.Data, Devart.Data.Oracle, Devart.Data.Oracle.Web assemblies. Note that you should add the Devart.Data.Oracle.Web assembly by selecting it as a file (not from the extension list) from the NET4 subdirectory of the dotConnect for Oracle installation directory (by default, from Program Files\Devart\dotConnect\Oracle\NET4), not the one from the Extensions list. The Devart.Data.Oracle.Web assembly that is in Extensions list is for .NET Framework 2.0, and we need the one for .NET Framework 4. The required assembly has the revision number 4 in its version.

  3. In the Web.config file replace the DefaultConnection connection string with the actual connection string to the app database. Replace the providerName value with "Devart.Data.Oracle". For example, your connection string may look like the following:

    <connectionStrings>
    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;"
      providerName="Devart.Data.Oracle" />
  </connectionStrings>

  4. In the Web.config file remove the following tag:
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />

  5. Add the following lines to the Web.config file:

      <membership defaultProvider="OracleExtendedMembershipProvider">
    <providers>
      <remove name="OracleExtendedMembershipProvider"/>
      <add name="OracleExtendedMembershipProvider" type="Devart.Data.Oracle.Web.Providers.OracleExtendedMembershipProvider,
        Devart.Data.Oracle.Web, Version=8.4.215.4, Culture=neutral, PublicKeyToken=09af7300eec23701"
        description="dotConnect for Oracle extended membership provider" connectionStringName="DefaultConnection" />
    </providers>
  </membership>
  <roleManager enabled="true" defaultProvider="OracleExtendedRoleProvider">
    <providers>
      <remove name="OracleExtendedRoleProvider"/>
      <add name="OracleExtendedRoleProvider" type="Devart.Data.Oracle.Web.Providers.OracleExtendedRoleProvider,
          Devart.Data.Oracle.Web, Version=8.4.215.4, Culture=neutral, PublicKeyToken=09af7300eec23701"
          description="dotConnect for Oracle extended role provider" connectionStringName="DefaultConnection" />
    </providers>
  </roleManager>

    Note: Replace 8.4.215.4 in the code with your actual version.

  6. In the InitializeSimpleMembershipAttribute.cs or InitializeSimpleMembershipAttribute.vb file (that is located in the Filters project folder), replace the namespace "WebMatrix.WebData" with the "Devart.Common.Web".

  7. Now you can run the application and check whether it works by registering a user.

    Registering a test user

    As you can see, the user is registered and logged in.

    Test user is registered

dotConnect for Oracle ASP.NET Membership Database

dotConnect for Oracle uses the following ASP.NET membership database for its SimpleMembership provider:

ExtendedMemberShip database schema

By default, the application automatically verifies if the tables exist by the specified connection string. The USERPROFILE table is automatically created by Entity Framework runtime if it is not already present in the database. Other tables are created by the WebSecurity.InitializeDatabaseConnection method, defined in the Devart.Common.Web namespace. If these tables are already created, no actions are performed.

However you can create these tables manually. Execute the DDL script %Install_Directory%\Devart\dotConnect\Oracle\NET4\InstallExtendedWebTables.sql (for example C:\Program Files\Devart\dotConnect\Oracle\NET4\InstallExtendedWebTables.sql) against the database server to create the database tables to store the user and role information.

If you are sure that the necessary tables are always present in the specified database and want to disable this automatic verification, you may re-register our provider in your Web.config file with the following settings:

  <membership defaultProvider="OracleExtendedMembershipProvider">
    <providers>
      <remove name="OracleExtendedMembershipProvider"/>
      <add name="OracleExtendedMembershipProvider" type="Devart.Data.Oracle.Web.Providers.OracleExtendedMembershipProvider,
        Devart.Data.Oracle.Web, Version=8.4.215.4, Culture=neutral, PublicKeyToken=09af7300eec23701"
        description="dotConnect for Oracle extended membership provider" connectionStringName="DefaultConnection"
        useridcolumn="UserId" usernamecolumn="UserName" usertablename="UserProfile" />
    </providers>
  </membership>
  <roleManager enabled="true" defaultProvider="OracleExtendedRoleProvider">
    <providers>
      <remove name="OracleExtendedRoleProvider"/>
      <add name="OracleExtendedRoleProvider" type="Devart.Data.Oracle.Web.Providers.OracleExtendedRoleProvider,
        Devart.Data.Oracle.Web, Version=8.4.215.4, Culture=neutral, PublicKeyToken=09af7300eec23701"
        description="dotConnect for Oracle extended role provider" connectionStringName="DefaultConnection"
        useridcolumn="UserId" usernamecolumn="UserName" usertablename="UserProfile" />
    </providers>
  </roleManager>

Note: Replace 8.4.215.4 in the code with your actual version.

Note: In case dotConnect for Oracle is installed on the target computer with the ASP.NET providers option, you may use shortened registration of our provider in the Web.config file as necessary records are added to machine.config. Add the following membership and roleManager elements to the system.web tag of your Web.config file:

<configuration>
  ...
  <system.web>
    ...
    <membership defaultProvider="OracleExtendedMembershipProvider"/>
    <roleManager enabled="true" defaultProvider="OracleExtendedRoleProvider"/>
  </system.web>
  ...
</configuration>


Using OracleDataSource Component

Using OracleDataSource Component
support@devart.com

The OracleDataSource data source control represents data in an Oracle database to data-bound controls. You can use the OracleDataSource control in conjunction with a data-bound control to retrieve data from a database and to display, edit, and sort data on a Web page with little or no code. This topic explains how to use the control in different ways.

  • Usage Basics
  • Load Balancing
  • Data Paging Overview
  • Automatic Data Paging
  • Manual Data Paging
  • Design Time Support
  • Demos

Usage Basics

To connect to a database, you must set the ConnectionString property to a valid connection string. To retrieve data from a database, set the SelectCommand property with a SQL query, you can also set the SelectCommand property to the name of a stored procedure. The SQL query that you specify can also be a parameterized query.

The OracleDataSource control retrieves data whenever the Select method is called. This method provides programmatic access to the method that is specified by SelectMethod property. The Select method is automatically called by controls that are bound to the OracleDataSource when their DataBind method is called. If you set the DataSourceID property of a data-bound control, the control automatically binds to data from the data source, as required. Setting the DataSourceID property is the recommended method for binding an OracleDataSource control to a data-bound control. Alternatively, you can use the DataSource property, but then you must explicitly call the DataBind method of the data-bound control. Some examples of data-bound controls that can use OracleDataSource are DataGrid, DetailsView, DataList, and DropDownList. You can call the Select method programmatically at any time to retrieve data from the underlying database.

You can perform data operations, such as updates, inserts, and deletes. To perform these data operations, set the appropriate command text and any associated parameters for the operation that you want to perform.

Note that OracleDataSource is available in Professional and Developer Editions only.

Load Balancing

If you display data on your page using a OracleDataSource, you can increase the performance of the page by using the data caching capabilities of the data source control. Caching reduces the processing load on the database servers at the expense of memory on the Web server; in most cases, this is a good trade-off. The OracleDataSource automatically caches data when the EnableCaching property is set to true and the CacheDuration property is set to the number of seconds that the cache stores data before the cache entry is discarded. You can also specify a CacheExpirationPolicy and an optional SqlCacheDependency value.

Data Paging Overview

OracleDataSource optimizes data retrieval with advanced data paging. The feature is intented to work with data-bound controls that support paginal data access (for example, DataGrid and DetailsView). In this case the database is queried for only a subset of data. The data is sorted on the database server as well. This allows applications to minimize traffic database server load.

The feature is controlled by the DataPagingMode property, which can have one of the following values:

  • Auto - data paging and sorting is performed automatically.
  • Manual - data paging and sorting is performed in a callback routine.
  • Disabled - no additional data processing is performed.

Automatic Data Paging

When DataPagingMode is set to Auto, OracleDataSource takes the responsibility to determine which subset of rows should be returned. This mode is applicable to CommandType=Text queries only.

The following markup demonstrates how to configure OracleDataSource component to use automatic data paging:

<cc1:OracleDataSource ID="OracleDataSource1" runat="server"
    ConnectionString="User Id=scott;Password=tiger;Server=ORA;Persist Security Info=True;"
      SelectCommand="SELECT * FROM dept" DataPagingMode="Auto">
</cc1:OracleDataSource>

Manual Data Paging

When DataPagingMode is set to Manual, the rows to return are chosen by a handler of the OracleDataSource.OnSelecting event. The event handler should determine the record count and prepare a OracleCommand object to be executed.

Manual data paging is applicable to queries with CommandType Text and StoredProcedure.

The following markup demonstrates how to configure OracleDataSource component to use manual data paging:

<cc1:OracleDataSource ID="OracleDataSource1" runat="server"
    ConnectionString="User Id=scott;Password=tiger;Server=ORA;Persist Security Info=True;"
      SelectCommand="get_dept_paged"
    SelectCommandType="StoredProcedure"
    DataPagingMode="Manual">
    <SelectParameters>
        <asp:Parameter Name="SortExpression" Type="String" />
        <asp:Parameter Name="StartIndex" Type="Int32" />
        <asp:Parameter Name="PageSize" Type="Int32" />
    </SelectParameters>
</cc1:OracleDataSource>

Given that the stored procedure has the following code:

CREATE OR REPLACE PACKAGE TEST.get_dept AS
  TYPE TCursor IS REF CURSOR;
  FUNCTION get_dept_paged(SortExpression IN VARCHAR2,
           StartIndex IN INT, PageSize IN INT) RETURN TCursor;
END;
/

CREATE OR REPLACE PACKAGE BODY TEST.get_dept AS
  FUNCTION get_dept_paged(SortExpression IN VARCHAR2,
       StartIndex IN INT, PageSize IN INT) RETURN TCursor
  AS
    stmt VARCHAR2(2000);
    cur TCursor;
    SortExp VARCHAR2(20);
  BEGIN
    IF SortExpression IS NULL OR SortExpression = '' THEN
      SortExp := 'DEPTNO';
    ELSE
      SortExp := SortExpression;
    END IF;
    stmt := 'select DEPTNO, DNAME, LOC from (SELECT Q1.*, ROWNUM ORADIRECT_QUERY_ROWNUM
                                   FROM  dept Q1 order by ' || SortExp || ') Q
                                   WHERE Q.ORADIRECT_QUERY_ROWNUM > '|| StartIndex ||'
                                   AND Q.ORADIRECT_QUERY_ROWNUM <= ' || (StartIndex + PageSize);

    OPEN cur FOR stmt;
    RETURN cur;
  END;
END;
/

The following event handler demonstrates how to control data paging:

C#csharp Copy Code
protected void OracleDataSource1_Selecting(object sender,
                                            SqlDataSourceSelectingEventArgs e) {
  OracleCommand rowCountCommand = new OracleCommand("SELECT count(*) FROM dept");
  rowCountCommand.Connection = new OracleConnection(OracleDataSource1.ConnectionString);
  rowCountCommand.Connection.Open();
  try {
    e.Arguments.TotalRowCount = (int)(long)rowCountCommand.ExecuteScalar();
  }
  finally {
    rowCountCommand.Connection.Close();
  }
  e.Command.Parameters["SortExpression"].Value = e.Arguments.SortExpression;
  e.Command.Parameters["StartIndex"].Value = e.Arguments.StartRowIndex;
  e.Command.Parameters["PageSize"].Value = e.Arguments.MaximumRows;
}
Visual Basic Copy Code
protected sub OracleDataSource1_Selecting(ByVal sender as object, _
                                           ByVal e as SqlDataSourceSelectingEventArgs)

  Dim rowCountCommand as OracleCommand = new OracleCommand("SELECT count(*) FROM dept")
  rowCountCommand.Connection = new OracleConnection(OracleDataSource1.ConnectionString)
  rowCountCommand.Connection.Open()

  try
    e.Arguments.TotalRowCount = CInt(CLng(rowCountCommand.ExecuteScalar()))
  finally
    rowCountCommand.Connection.Close()
  End Try

  e.Command.Parameters["SortExpression"].Value = e.Arguments.SortExpression
  e.Command.Parameters["StartIndex"].Value = e.Arguments.StartRowIndex
  e.Command.Parameters["PageSize"].Value = e.Arguments.MaximumRows

end sub

Design Time Support

OracleDataSource component exposes its features in design time with convenient editor. In the editor you can set up connection string, adjust SELECT, INSERT, UPDATE, and DELETE statement, modify parameters, and so on. The screenshot demonstrates the Command Generator tab of the component editor, where you control how the data is inserted and updated in the table. The component editor allows you to preview the data you are working with.

Demos

dotConnect for Oracle includes a set of useful demo projects that can be used as a good starting point in ASP.NET development. The demos include:

DataSource Demo

The demo iullustrates the different paging modes described above.

LoadOnDemand Demo

This sample demonstrates the load data on demand technique with dotConnect for Oracle components. Client-side script is used to handle scrolling and to send asynchronous postback to the Web server. Server-side handler uses ObjectDataSource or OracleDataSource to populate more rows. Portion of data is loaded from DB server and displayed in the grid.

Ajax Demo

This sample demonstrates data binding and editing in an asynchronous way. All AJAX asynchronous operations are implemented using standard components only. The demo shows AJAX usage with a single table and with two tables in a master-detail relationship.

3-rd Party Components Demo

These samples demonstrate using OracleDataSource with popular 3-rd party controls such as DevExpress and Telerik grids.

See Also

ASP.NET Provider Model Support


Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle

Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle
support@devart.com

ASP.NET Identity is a new system of user authentication and authorization, that continues the evolution of ASP.NET membership system, and is used in the Visual Studio 2013 or Visual Studio 2013 Update 1 project templates for ASP.NET MVC, Web Forms, Web API and SPA. You can read more on ASP.NET Identity in Microsoft documentation.

dotConnect for Oracle enables you to employ an implementation of ASP.NET Identity for Oracle database using either ADO.NET or Entity Framework functionality in your web applications. This allows you to use such ASP.NET Identity benefits as unit-testable user authentication system, social login support, OWIN integration, etc. This tutorial demonstrates creating an ADO.NET implementation of ASP.NET Identity.

To complete this tutorial you need Visual Studio 2013 or Visual Studio 2013 Update 1 installed. For Visual Studio 2013 Update 2 or higher see Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle.

In order to create an ASP.NET MVC 5 application using dotConnect for Oracle for storing identity information, perform the following steps:

  1. In the Add New Project dialog box expand Visual C# on the left, then Web, and then select ASP.NET Web Application. Name your project, for example, "AspNet_Identity_Application" and then click OK.

    Add New Project dialog box

  2. In the New ASP.NET Project dialog box, select the MVC template with the default options (that includes Individual User Accounts as authentication method) and click OK.

    New ASP.NET Project dialog box

  3. In Solution Explorer, right-click your project and select Manage NuGet Packages from the shortcut menu. In the search text box dialog, type "Identity.EntityFramework". Select this package in the list of results and click Uninstall. You will be prompted to uninstall the dependency package EntityFramework. Click Yes since we will no longer this package on this application.

  4. Add references to the necessary dotConnect for Oracle assemblies:

    • Devart.Data.dll
    • Devart.Data.Oracle.dll
    • Devart.Data.Oracle.Web.Identity.dll

    For ASP.NET Identity 1 you need to add the reference to the Devart.Data.Oracle.Web.Identity.dll, having the revision number 0, and installed to the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET Identity 1 folder

When creating an ASP.NET application, using ASP.NET Identity, you can use the existing ASP.NET Identity functionality as is or customize this functionality. For example, you may add storing some custom information about the user. In our tutorial we will demonstrate both options.

- Using Existing ASP.NET Identity Functionality

First, you need to create a schema that will store information about users. To do it, execute the Install_identity_tables.sql script, which goes with dotConnect for Oracle. By default, this script is in the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET Identity 1 folder. You can also copy this script from the Identity Database Script chapter of this topic. You may use any tool to execute this script, for example SQL*Plus or dbForge Fusion for Oracle. After this perform the following steps:

  1. In Visual Studio remove the IdentityModels.cs (or IdentityModels.vb for Visual Basic) file that is in the Models folder, from the project.

  2. In the Controllers project folder open the AccountController.cs (or AccountController.vb for Visual Basic) file.

    Replace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

    Replace the constructor code:

    C#csharp Copy Code
            public AccountController()
            : this(new UserManager<ApplicationUser>(new UserStore<ApplicationUser>(new ApplicationDbContext())))
        {
        }
    Visual Basic Copy Code
        Public Sub New()
        Me.New(New UserManager(Of ApplicationUser)(New UserStore(Of ApplicationUser)(New ApplicationDbContext())))
    End Sub

    with

    C#csharp Copy Code
        public AccountController()
        : this(new UserManager<ApplicationUser>(new OracleUserStore()))
    {
    }
    Visual Basic Copy Code
        Public Sub New()
        Me.New(New UserManager(Of ApplicationUser)(New OracleUserStore()))
    End Sub

  3. In the web.config file of your project, replace the default connection string with your Oracle one.

    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" providerName="Devart.Data.Oracle" />

+ Extending ASP.NET Identity Functionality

If you want to extend the out-of-the-box ASP.NET Identity functionality, you may inherit from the standard ASP.NET Identity classes. In our tutorial we will create a new user class that stores additional information about users - their emails.

To implement email storing, please perform the following steps:

  1. Open the IdentityModels.cs (or IdentityModels.vb for Visual Basic) file from the Models project folder.

  2. Replace the imported namespace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
  3. Remove the code of the ApplicationDbContext class.

  4. Add the Email property to the ApplicationUser class that is inherited from the IdentityUser class.

    Code before:

    C#csharp Copy Code

    // You can add profile data for the user by adding more properties to your ApplicationUser class, please visit http://go.microsoft.com/fwlink/?LinkID=317594 to learn more.
    public class ApplicationUser : IdentityUser
    {
    }

    public class ApplicationDbContext : IdentityDbContext<ApplicationUser>
    {
        public ApplicationDbContext()
            : base("DefaultConnection")
        {
        }
    }
    Visual Basic Copy Code
        ' You can add profile data for the user by adding more properties to your ApplicationUser class, please visit http://go.microsoft.com/fwlink/?LinkID=317594 to learn more.
    Public Class ApplicationUser
        Inherits IdentityUser
    End Class

    Public Class ApplicationDbContext
        Inherits IdentityDbContext(Of ApplicationUser)
        Public Sub New()
            MyBase.New("DefaultConnection")
        End Sub
    End Class

    Code after:

    C#csharp Copy Code

  public class ApplicationUser : IdentityUser {

    public ApplicationUser() {
    }

    public string Email { get; set; }
  }
    Visual Basic Copy Code

    Public Class ApplicationUser
        Inherits IdentityUser

        Public Sub New()
        End Sub

        Public Property Email() As String
            Get
                Return m_Email
            End Get
            Set
                m_Email = Value
            End Set
        End Property
        Private m_Email As String
    End Class

  5. After this we need to create a database that will store the user information. Modify the Install_identity_tables.sql script, which goes with dotConnect for Oracle. By default, this script is in the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET Identity 1 folder. You can also copy this script from the Identity Database Script chapter of this topic. You may use any tool to execute this script, for example SQL*Plus or dbForge Fusion for Oracle.. Add a column for storing emails to the AspNetUsers table.

    Before adding the column:

      CREATE TABLE "AspNetUsers" (
    "Id" NVARCHAR2(128) NOT NULL,
    "UserName" NVARCHAR2(256) NOT NULL,
    "PasswordHash" NVARCHAR2(256) NULL,
    "SecurityStamp" NVARCHAR2(256) NULL,
    PRIMARY KEY ("Id")
  )

    After adding the column:

      CREATE TABLE "AspNetUsers" (
    "Id" NVARCHAR2(128) NOT NULL,
    "UserName" NVARCHAR2(256) NOT NULL,
    "PasswordHash" NVARCHAR2(256) NULL,
    "SecurityStamp" NVARCHAR2(256) NULL,
    "Email" NVARCHAR2(256) NULL,
    PRIMARY KEY ("Id")
  )

  6. Execute this script. You may use any tool to execute this script, for example SQL*Plus or dbForge Fusion for Oracle.

  7. After this we need to create a UserTable class descendant that will read/write the ApplicationUser objects from/to the database. It can be implemented in two ways. The first way is using SQL to read and update the database.

    C#csharp Copy Code
      public class MyUserTable : UserTable<ApplicationUser> {

    public MyUserTable(DbDataSource dataSource)
      : base(dataSource) {
    }

    public override int Insert(ApplicationUser user) {

      return DataSource.ExecuteNonQuery("INSERT INTO MY_IDENTITY_SCHEMA.\"AspNetUsers\" (\"Id\", \"UserName\", \"PasswordHash\", \"SecurityStamp\", \"Email\") VALUES (:p0, :p1, :p2, :p3, :p4)",
                                        new object[] { user.Id, user.UserName, user.PasswordHash, user.SecurityStamp, user.Email });
    }

    public override int Update(ApplicationUser user) {

      return DataSource.ExecuteNonQuery("UPDATE MY_IDENTITY_SCHEMA.\"AspNetUsers\" SET \"UserName\" = :p0, \"PasswordHash\" = :p1, \"SecurityStamp\" = :p2, \"Email\" = :p3 WHERE \"Id\" = :p4",
                                        new object[] { user.UserName, user.PasswordHash, user.SecurityStamp, user.Email, user.Id });
    }

    protected override ApplicationUser Materialize(DataRecord record) {

      ApplicationUser user = base.Materialize(record);

      if (user != null)
        user.Email = (string)record["Email"];

      return user;
    }

  }
    Visual Basic Copy Code
    Public Class MyUserTable
    Inherits UserTable(Of ApplicationUser)

    Public Sub New(dataSource As DbDataSource)
        MyBase.New(dataSource)
    End Sub

    Public Overrides Function Insert(user As ApplicationUser) As Integer

        Return DataSource.ExecuteNonQuery("INSERT INTO MY_IDENTITY_SCHEMA.""AspNetUsers"" (""Id"", ""UserName"", ""PasswordHash"", ""SecurityStamp"", ""Email"") VALUES (:p0, :p1, :p2, :p3, :p4)", New Object() {user.Id, user.UserName, user.PasswordHash, user.SecurityStamp, user.Email})
    End Function

    Public Overrides Function Update(user As ApplicationUser) As Integer

        Return DataSource.ExecuteNonQuery("UPDATE MY_IDENTITY_SCHEMA.""AspNetUsers"" SET ""UserName"" = :p0, ""PasswordHash"" = :p1, ""SecurityStamp"" = :p2, ""Email"" = :p3 WHERE ""Id"" = :p4", New Object() {user.UserName, user.PasswordHash, user.SecurityStamp, user.Email, user.Id})
    End Function

    Protected Overrides Function Materialize(record As DataRecord) As ApplicationUser

        Dim user As ApplicationUser = MyBase.Materialize(record)

        If user IsNot Nothing Then
            user.Email = DirectCast(record("Email"), String)
        End If

        Return user
    End Function

End Class

    Alternatively we can create a class, which provides the same functionality, but uses the functionality of the UserTable class, inherited from AspNetTable, instead of performing SQL statements.

    C#csharp Copy Code
    public class MyUserTable : UserTable<ApplicationUser> {

    public MyUserTable(DbDataSource dataSource)
      : base(dataSource) {
    }

    protected override List<string> GetInsertColumns() {
        var columns = base.GetInsertColumns();
        columns.Add("Email");
        return columns;
    }
    public override int Insert(ApplicationUser user) {

      return Insert(user.Id, user.UserName, user.PasswordHash, user.SecurityStamp, user.Email);
    }

    public override int Update(ApplicationUser user) {

        return Update(user.UserName, user.PasswordHash, user.SecurityStamp, user.Email, // SET
            user.Id // WHERE
        );
    }

    protected override ApplicationUser Materialize(DataRecord record) {

        ApplicationUser user = base.Materialize(record);

        if (user != null)
            user.Email = (string)record["Email"];

        return user;
    }

}
    Visual Basic Copy Code
    Public Class MyUserTable
    Inherits UserTable(Of ApplicationUser)

    Public Sub New(dataSource As DbDataSource)
        MyBase.New(dataSource)
    End Sub

    Protected Overrides Function GetInsertColumns() As List(Of String)
        Dim columns = MyBase.GetInsertColumns()
        columns.Add("Email")
        Return columns
    End Function
    Public Overrides Function Insert(user As ApplicationUser) As Integer

        Return Insert(user.Id, user.UserName, user.PasswordHash, user.SecurityStamp, user.Email)
    End Function

    Public Overrides Function Update(user As ApplicationUser) As Integer

        Return Update(user.UserName, user.PasswordHash, user.SecurityStamp, user.Email, user.Id)
    End Function

    Protected Overrides Function Materialize(record As DataRecord) As ApplicationUser

        Dim user As ApplicationUser = MyBase.Materialize(record)

        If user IsNot Nothing Then
            user.Email = DirectCast(record("Email"), String)
        End If

        Return user
    End Function

End Class

    In this example we have overridden the GetInsertColumns() method to add the "Email" column to the list of the columns, used for generating the INSERT command. Since we haven't overridden the GetUpdateColumns() method, the same "Email" column will also be present in the column list used for generating the UPDATE command. We pass the parameter values for the commands, generated automatically, in the Insert and Update methods.

  8. After you have created the MyUserTable class in one or another way, create a TableFactory descendant that returns our custom UserTable implementation, that reads and saves ApplicationUser objects from/to database.

    C#csharp Copy Code
      public class MyTableFactory : TableFactory<ApplicationUser, IdentityRole>, ITableFactory<ApplicationUser, IdentityRole> {

    public MyTableFactory(DbDataSource dataSource)
      : base(dataSource) {
    }

    public override UserTable<ApplicationUser> CreateUserTable() {

      return new MyUserTable(DataSource);
    }
  }
    Visual Basic Copy Code
    Public Class MyTableFactory
    Inherits TableFactory(Of ApplicationUser, IdentityRole)
    Implements ITableFactory(Of ApplicationUser, IdentityRole)

    Public Sub New(dataSource As DbDataSource)
        MyBase.New(dataSource)
    End Sub

    Public Overrides Function CreateUserTable() As UserTable(Of ApplicationUser)

        Return New MyUserTable(DataSource)
    End Function
End Class

  9. Create an OracleDataSource descendant, that creates our custom TableFactory.

    C#csharp Copy Code
      public class MyDataSource : OracleDataSource {

    public MyDataSource()
      : base() {
    }

    public override ITableFactory<MyIdentityUser, IdentityRole> CreateTableFactory<MyIdentityUser, IdentityRole>() {

      return (ITableFactory<MyIdentityUser, IdentityRole>)new MyTableFactory(this);
    }
  }
    Visual Basic Copy Code
    Public Class MyDataSource
    Inherits OracleDataSource

    Public Sub New()
        MyBase.New()
    End Sub

    Public Overrides Function CreateTableFactory(Of MyIdentityUser, IdentityRole)() As ITableFactory(Of MyIdentityUser, IdentityRole)

        Return DirectCast(New MyTableFactory(Me), ITableFactory(Of MyIdentityUser, IdentityRole))
    End Function
End Class

    We also can modify the MyDataSource class constructor in order to specify connection string name instead of DefaultConnection in the config file or a custom name of the schema where the identity tables reside. You may need to specify the custom schema name, for example, if the user you connect to is different than the user, in whose schema the identity tables are stored. The MyDataSource class constructor for it can be the following:

    C#csharp Copy Code
        public MyDataSource()
      : base("name=MyConnection", "MY_IDENTITY_SCHEMA") {    }
    Visual Basic Copy Code
    Public Sub New()
    MyBase.New("name=MyConnection", "MY_IDENTITY_SCHEMA")
End Sub

  10. In the web.config file of your project, replace the default connection string with your Oracle one.

    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" providerName="Devart.Data.Oracle" />

    Or, if you are going to use another connection string name, add the new connection string.

  11. Create an OracleUserStore class descendant, that will be used in our application. We will pass it in the AccountController to the UserManager being created.

    C#csharp Copy Code
      public class MyUserStore : OracleUserStore<ApplicationUser, IdentityRole> {

    public MyUserStore()
      : base(new MyDataSource()) {
    }
  }
    Visual Basic Copy Code
    Public Class MyUserStore
    Inherits OracleUserStore(Of ApplicationUser, IdentityRole)

    Public Sub New()
        MyBase.New(New MyDataSource())
    End Sub
End Class

  12. In the Controllers project folder open the AccountController.cs (or AccountController.vb for Visual Basic) file.

  13. Replace the imported namespace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity

  14. Replace the constructor code

    C#csharp Copy Code
            public AccountController()
            : this(new UserManager<ApplicationUser>(new UserStore<ApplicationUser>(new ApplicationDbContext())))
        {
        }
    Visual Basic Copy Code
    Public Sub New()
    Me.New(New UserManager(Of ApplicationUser)(New UserStore(Of ApplicationUser)(New ApplicationDbContext())))
End Sub

    with:

    C#csharp Copy Code
            public AccountController()
            : this(new UserManager<ApplicationUser>(new MyUserStore()))        {
        }
    Visual Basic Copy Code
    Public Sub New()
    Me.New(New UserManager(Of ApplicationUser)(New MyUserStore()))
End Sub

  15. After this we need to update our application and add code for specifying user's email. Open the Models\AccountViewModels.cs (or Models\AccountViewModels.vb for Visual Basic) file and add the email field to the RegisterViewModel class.

    Code before:

    C#csharp Copy Code
        public class RegisterViewModel
    {
        [Required]
        [Display(Name = "User name")]
        public string UserName { get; set; }

        [Required]
        [StringLength(100, ErrorMessage = "The {0} must be at least {2} characters long.", MinimumLength = 6)]
        [DataType(DataType.Password)]
        [Display(Name = "Password")]
        public string Password { get; set; }

        [DataType(DataType.Password)]
        [Display(Name = "Confirm password")]
        [Compare("Password", ErrorMessage = "The password and confirmation password do not match.")]
        public string ConfirmPassword { get; set; }
    }
    Visual Basic Copy Code
        Public Class RegisterViewModel
        <Required> _
        <Display(Name := "User name")> _
        Public Property UserName() As String
            Get
                Return m_UserName
            End Get
            Set
                m_UserName = Value
            End Set
        End Property
        Private m_UserName As String

        <Required> _
        <StringLength(100, ErrorMessage := "The {0} must be at least {2} characters long.", MinimumLength := 6)> _
        <DataType(DataType.Password)> _
        <Display(Name := "Password")> _
        Public Property Password() As String
            Get
                Return m_Password
            End Get
            Set
                m_Password = Value
            End Set
        End Property
        Private m_Password As String

        <DataType(DataType.Password)> _
        <Display(Name := "Confirm password")> _
        <Compare("Password", ErrorMessage := "The password and confirmation password do not match.")> _
        Public Property ConfirmPassword() As String
            Get
                Return m_ConfirmPassword
            End Get
            Set
                m_ConfirmPassword = Value
            End Set
        End Property
        Private m_ConfirmPassword As String
    End Class

    Code after:

    C#csharp Copy Code
        public class RegisterViewModel
    {
        [Required]
        [Display(Name = "User name")]
        public string UserName { get; set; }

        [Required]
        [StringLength(100, ErrorMessage = "The {0} must be at least {2} characters long.", MinimumLength = 6)]
        [DataType(DataType.Password)]
        [Display(Name = "Password")]
        public string Password { get; set; }

        [DataType(DataType.Password)]
        [Display(Name = "Confirm password")]
        [Compare("Password", ErrorMessage = "The password and confirmation password do not match.")]
        public string ConfirmPassword { get; set; }

        [DataType(DataType.EmailAddress)]
        [Display(Name = "E-mail")]
        public string Email { get; set; }
    }
    Visual Basic Copy Code
    Public Class RegisterViewModel
    <Required> _
    <Display(Name := "User name")> _
    Public Property UserName() As String
        Get
            Return m_UserName
        End Get
        Set
            m_UserName = Value
        End Set
    End Property
    Private m_UserName As String

    <Required> _
    <StringLength(100, ErrorMessage := "The {0} must be at least {2} characters long.", MinimumLength := 6)> _
    <DataType(DataType.Password)> _
    <Display(Name := "Password")> _
    Public Property Password() As String
        Get
            Return m_Password
        End Get
        Set
            m_Password = Value
        End Set
    End Property
    Private m_Password As String

    <DataType(DataType.Password)> _
    <Display(Name := "Confirm password")> _
    <Compare("Password", ErrorMessage := "The password and confirmation password do not match.")> _
    Public Property ConfirmPassword() As String
        Get
            Return m_ConfirmPassword
        End Get
        Set
            m_ConfirmPassword = Value
        End Set
    End Property
    Private m_ConfirmPassword As String

    <DataType(DataType.EmailAddress)> _
    <Display(Name := "E-mail")> _
    Public Property Email() As String
        Get
            Return m_Email
        End Get
        Set
            m_Email = Value
        End Set
    End Property
    Private m_Email As String
End Class

  16. Open the Views\Account\Register.cshtml file and edit the Register method. Add a field for email.

        <div class="form-group">
        @Html.LabelFor(m => m.Email, new { @class = "col-md-2 control-label" })
        <div class="col-md-10">
            @Html.TextBoxFor(m => m.Email, new { @class = "form-control" })
        </div>
    </div>

  17. Open the Controllers\AccountController.cs (or Models\AccountController.vb for Visual Basic) file and add code for passing email to the Register method of the AccountController class.

    Code before:

    C#csharp Copy Code
            public async Task<ActionResult> Register(RegisterViewModel model)
        {
            if (ModelState.IsValid)
            {
                var user = new ApplicationUser() { UserName = model.UserName };
                var result = await UserManager.CreateAsync(user, model.Password);
                if (result.Succeeded)
                {
                    await SignInAsync(user, isPersistent: false);
                    return RedirectToAction("Index", "Home");
                }
                else
                {
                    AddErrors(result);
                }
            }

            // If we got this far, something failed, redisplay form
            return View(model);
        }
    Visual Basic Copy Code
            Public Function Register(model As RegisterViewModel) As Task(Of ActionResult)
            If ModelState.IsValid Then
                Dim user = New ApplicationUser() With { _
                    Key .UserName = model.UserName _
                }
                Dim result = Await UserManager.CreateAsync(user, model.Password)
                If result.Succeeded Then
                    Await SignInAsync(user, isPersistent := False)
                    Return RedirectToAction("Index", "Home")
                Else
                    AddErrors(result)
                End If
            End If

            ' If we got this far, something failed, redisplay form
            Return View(model)
        End Function

    Code after:

    C#csharp Copy Code
            public async Task<ActionResult> Register(RegisterViewModel model)
        {
            if (ModelState.IsValid)
            {
                var user = new ApplicationUser() { UserName = model.UserName, Email = model.Email };
                var result = await UserManager.CreateAsync(user, model.Password);
                if (result.Succeeded)
                {
                    await SignInAsync(user, isPersistent: false);
                    return RedirectToAction("Index", "Home");
                }
                else
                {
                    AddErrors(result);
                }
            }

            // If we got this far, something failed, redisplay form
            return View(model);
        }
    Visual Basic Copy Code
            Public Function Register(model As RegisterViewModel) As Task(Of ActionResult)
            If ModelState.IsValid Then
                Dim user = New ApplicationUser() With { _
                    Key .UserName = model.UserName, _
                    Key .Email = model.Email _
                }
                Dim result = Await UserManager.CreateAsync(user, model.Password)
                If result.Succeeded Then
                    Await SignInAsync(user, isPersistent := False)
                    Return RedirectToAction("Index", "Home")
                Else
                    AddErrors(result)
                End If
            End If

            ' If we got this far, something failed, redisplay form
            Return View(model)
        End Function

- Checking Application

Now we can run our application and check if everything works correctly.

  1. Run the application by pressing CTRL+F5.

    Getting started page
  2. Switch to the Register tab on the top of the page.

    Registration page

    For an example with extended ASP.NET Identity functionality the page looks like the following:

    Registration page (with e-mail)
  3. Enter a new user name and password (and email - if you have created an example with extended ASP.NET Identity functionality) to the corresponding boxes and click the Register button.
  4. The new user is now registered and logged in.

    User is registered
  5. After this you may use an appropriate database tool to connect to the database where the user data is stored and verify that the data is stored correctly.

+ Identity Database Script

CREATE TABLE "AspNetRoles" (
  "Id" NVARCHAR2(128) NOT NULL,
  "Name" NVARCHAR2(256) NOT NULL,
  PRIMARY KEY ("Id")
)
/

CREATE TABLE "AspNetUsers" (
  "Id" NVARCHAR2(128) NOT NULL,
  "UserName" NVARCHAR2(256) NOT NULL,
  "PasswordHash" NVARCHAR2(256) NULL,
  "SecurityStamp" NVARCHAR2(256) NULL,
  PRIMARY KEY ("Id")
)
/

CREATE TABLE "AspNetUserClaims" (
  "Id" NUMBER(10) NOT NULL,
  "ClaimType" NVARCHAR2(256) NULL,
  "ClaimValue" NVARCHAR2(256) NULL,
  "UserId" NVARCHAR2(128) NOT NULL,
  PRIMARY KEY ("Id")
)
/

CREATE SEQUENCE "AspNetUserClaims_SEQ"
/

CREATE OR REPLACE TRIGGER "AspNetUserClaims_INS_TRG"
  BEFORE INSERT ON "AspNetUserClaims"
  FOR EACH ROW
BEGIN
  SELECT "AspNetUserClaims_SEQ".NEXTVAL INTO :NEW."Id" FROM DUAL;
END;
/

CREATE TABLE "AspNetUserLogins" (
  "UserId" NVARCHAR2(128) NOT NULL,
  "LoginProvider" NVARCHAR2(128) NOT NULL,
  "ProviderKey" NVARCHAR2(128) NOT NULL,
  PRIMARY KEY ("UserId", "LoginProvider", "ProviderKey")
)
/

CREATE TABLE "AspNetUserRoles" (
  "UserId" NVARCHAR2(128) NOT NULL,
  "RoleId" NVARCHAR2(128) NOT NULL,
  PRIMARY KEY ("UserId", "RoleId")
)
/

CREATE INDEX "IX_AspNetUserClaims_UserId" ON "AspNetUserClaims" ("UserId")
/

CREATE INDEX "IX_AspNetUserLogins_UserId" ON "AspNetUserLogins" ("UserId")
/

CREATE INDEX "IX_AspNetUserRoles_RoleId" ON "AspNetUserRoles" ("RoleId")
/

CREATE INDEX "IX_AspNetUserRoles_UserId" ON "AspNetUserRoles" ("UserId")
/

ALTER TABLE "AspNetUserClaims"
  ADD CONSTRAINT "FK_UserClaims_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserLogins"
  ADD CONSTRAINT "FK_UserLogins_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserRoles"
  ADD CONSTRAINT "FK_UserRoles_Roles" FOREIGN KEY ("RoleId") REFERENCES "AspNetRoles" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserRoles"
  ADD CONSTRAINT "FK_UserRoles_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

See Also

Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle | Using Entity Framework Implementation of ASP.NET Identity 2 for Oracle | Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle


Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle

Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle
support@devart.com

ASP.NET Identity is a new system of user authentication and authorization, that continues the evolution of ASP.NET membership system, and is used in the Visual Studio 2013 Update 2 project templates for ASP.NET MVC, Web Forms, Web API and SPA. You can read more on ASP.NET Identity in Microsoft documentation.

dotConnect for Oracle enables you to employ an implementation of ASP.NET Identity for Oracle database using either ADO.NET or Entity Framework functionality in your web applications. This allows you to use such ASP.NET Identity benefits as unit-testable user authentication system, social login support, OWIN integration, etc. This tutorial demonstrates creating an ADO.NET implementation of ASP.NET Identity.

To complete this tutorial you need Visual Studio 2013 Update 2 or higher. For Visual Studio 2013 or Visual Studio 2013 Update 1 see Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle.

In order to create an ASP.NET MVC 5 application using dotConnect for Oracle for storing identity information, perform the following steps:

  1. In the Add New Project dialog box expand Visual C# on the left, then Web, and then select ASP.NET Web Application. Name your project, for example, "AspNet_Identity_Application" and then click OK.

    Add New Project dialog box

  2. In the New ASP.NET Project dialog box, select the MVC template with the default options (that includes Individual User Accounts as authentication method) and click OK.

    New ASP.NET Project dialog box

  3. In Solution Explorer, right-click your project and select Manage NuGet Packages from the shortcut menu. In the search text box dialog, type "Identity.EntityFramework". Select this package in the list of results and click Uninstall. You will be prompted to uninstall the dependency package EntityFramework. For Visual Studio 2013 Update 2 click Yes. For Visual Studio 2013 Update 3 or higher click No.

  4. Add references to the necessary dotConnect for Oracle assemblies:

    • Devart.Data.dll
    • Devart.Data.Oracle.dll
    • Devart.Data.Oracle.Web.Identity.dll

    For ASP.NET Identity 2 you need to add the reference to the Devart.Data.Oracle.Web.Identity.dll, having the revision number 2, and installed to the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET Identity 2 folder

When creating an ASP.NET application, using ASP.NET Identity, you can use the existing ASP.NET Identity functionality as is or customize this functionality. For example, you may add storing some custom information about the user. In our tutorial we will demonstrate both options.

- Using Existing ASP.NET Identity Functionality

First, you need to create a schema that will store information about users. To do it, execute the Install_identity_tables.sql script, which goes with dotConnect for Oracle. By default, this script is in the Program Files\Devart\dotConnect\Oracle\Web\ASP.NET Identity 2 folder. You can also copy this script from the Identity Database Script chapter of this topic. You may use any tool to execute this script, for example SQL*Plus or dbForge Fusion for Oracle. After this perform the following steps:

  1. In the Models project folder open the IdentityModels.cs (or IdentityModels.vb for Visual Basic) file. that is in the Models folder, from the project.

  2. Replace the file contents with

    C#csharp Copy Code
    using System.Security.Claims;
using System.Threading.Tasks;
using Microsoft.AspNet.Identity;
using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;

namespace AspNet_Identity_Application.Models
{
    public static class ApplicationUserExtensions
    {
        public static async Task<ClaimsIdentity> GenerateUserIdentityAsync(this ApplicationUser user, UserManager<ApplicationUser> manager)
        {
            // Note the authenticationType must match the one defined in CookieAuthenticationOptions.AuthenticationType
            var userIdentity = await manager.CreateIdentityAsync(user, DefaultAuthenticationTypes.ApplicationCookie);
            // Add custom user claims here
            return userIdentity;
        }
    }
}
    Visual Basic Copy Code

Imports System.Security.Claims
Imports System.Threading.Tasks
Imports Microsoft.AspNet.Identity
Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

Public Module ApplicationUserExtensions
    <System.Runtime.CompilerServices.Extension> _
    Public Async Function GenerateUserIdentityAsync(user As ApplicationUser, manager As UserManager(Of ApplicationUser)) As Task(Of ClaimsIdentity)
        ' Note the authenticationType must match the one defined in CookieAuthenticationOptions.AuthenticationType
        Dim userIdentity = Await manager.CreateIdentityAsync(user, DefaultAuthenticationTypes.ApplicationCookie)
        ' Add custom user claims here
        Return userIdentity
    End Function
End Module

    Note that if you have specified the name for the application other than "AspNet_Identity_Application", you must use the corresponding namespace name in the code above instead of "AspNet_Identity_Application".

  3. In the Controllers project folder open the AccountController.cs (or AccountController.vb for Visual Basic) file.

    If you use Visual Studio 2013 Update 2, replace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

    If you use Visual Studio 2013 Update 3 or higher, there is no such line, just add the above code to the beginning of the file.

  4. In the App_Start project folder open the IdentityConfig.cs (or IdentityConfig.vb for Visual Basic) file.

    Replace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

  5. Replace the following line in the Create method:

    C#csharp Copy Code
    var manager = new ApplicationUserManager(new UserStore<ApplicationUser>(context.Get<ApplicationDbContext>()));
    Visual Basic Copy Code
    Private manager As var = New ApplicationUserManager(New UserStore(Of ApplicationUser)(context.[Get](Of ApplicationDbContext)()))

    with:

    C#csharp Copy Code
    var manager = new ApplicationUserManager(new OracleUserStore());
    Visual Basic Copy Code
    Dim manager = New ApplicationUserManager(New OracleUserStore())

  6. In the App_Start project folder open the Startup.Auth.cs (or Startup.Auth.vb for Visual Basic) file.

    If you use Visual Studio 2013 Update 2, replace

    C#csharp Copy Code
    using Microsoft.AspNet.Identity.EntityFramework;
    Visual Basic Copy Code
    Imports Microsoft.AspNet.Identity.EntityFramework

    with:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

    If you use Visual Studio 2013 Update 3 or higher, there is no such line, just add the above code to the beginning of the file.

  7. Delete the following line:

    C#csharp Copy Code
    app.CreatePerOwinContext(ApplicationDbContext.Create);
    Visual Basic Copy Code
    app.CreatePerOwinContext(ApplicationDbContext.Create)

  8. For Visual Studio 2013 Update 3 or higher only - in the Controllers project folder open the ManageController.cs (or ManageController.vb for Visual Basic) file. Add the following code to the beginning of the file:

    C#csharp Copy Code
    using Devart.Common.Web.Identity;
using Devart.Data.Oracle.Web.Identity;
using ApplicationUser = Devart.Common.Web.Identity.IdentityUser;
    Visual Basic Copy Code
    Imports Devart.Common.Web.Identity
Imports Devart.Data.Oracle.Web.Identity
Imports ApplicationUser = Devart.Common.Web.Identity.IdentityUser

  9. In the web.config file of your project, replace the default connection string with your Oracle one.

    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" providerName="Devart.Data.Oracle" />

+ Extending ASP.NET Identity Functionality

The Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle tutorial contains an example with adding a new Email column to the AspNetUsers table. In ASP.NET Identity 2 the AspNetUsers table was significantly extended, and now it includes such Email column. However the approach to extending ASP.NET Identity functionality is the same, and you can take a look at this topic if you need to implement extended ASP.NET Identity 2 functionality.

- Checking Application

Now we can run our application and check if everything works correctly.

  1. Run the application by pressing CTRL+F5.

    Getting started page
  2. Switch to the Register tab on the top of the page.

    Registration page

    For an example with extended ASP.NET Identity functionality the page looks like the following:

    Registration page (with e-mail)
  3. Enter a new user name and password (and email - if you have created an example with extended ASP.NET Identity functionality) to the corresponding boxes and click the Register button.
  4. The new user is now registered and logged in.

    User is registered
  5. After this you may use an appropriate database tool to connect to the database where the user data is stored and verify that the data is stored correctly.

+ Identity Database Script

CREATE TABLE "AspNetRoles" (
  "Id" NVARCHAR2(128) NOT NULL,
  "Name" NVARCHAR2(256) NOT NULL,
  PRIMARY KEY ("Id")
)
/

CREATE TABLE "AspNetUserRoles" (
  "UserId" NVARCHAR2(128) NOT NULL,
  "RoleId" NVARCHAR2(128) NOT NULL,
  PRIMARY KEY ("UserId", "RoleId")
)
/

CREATE TABLE "AspNetUsers" (
  "Id" NVARCHAR2(128) NOT NULL,
  "Email" NVARCHAR2(256) NULL,
  "EmailConfirmed" NUMBER(1) NOT NULL,
  "PasswordHash" NVARCHAR2(256) NULL,
  "SecurityStamp" NVARCHAR2(256) NULL,
  "PhoneNumber" NVARCHAR2(256) NULL,
  "PhoneNumberConfirmed" NUMBER(1) NOT NULL,
  "TwoFactorEnabled" NUMBER(1) NOT NULL,
  "LockoutEndDateUtc" TIMESTAMP(7) NULL,
  "LockoutEnabled" NUMBER(1) NOT NULL,
  "AccessFailedCount" NUMBER(10) NOT NULL,
  "UserName" NVARCHAR2(256) NOT NULL,
  PRIMARY KEY ("Id")
)
/

CREATE TABLE "AspNetUserClaims" (
  "Id" NUMBER(10) NOT NULL,
  "UserId" NVARCHAR2(128) NOT NULL,
  "ClaimType" NVARCHAR2(256) NULL,
  "ClaimValue" NVARCHAR2(256) NULL,
  PRIMARY KEY ("Id")
)
/

CREATE SEQUENCE "AspNetUserClaims_SEQ"
/

CREATE OR REPLACE TRIGGER "AspNetUserClaims_INS_TRG"
  BEFORE INSERT ON "AspNetUserClaims"
  FOR EACH ROW
BEGIN
  SELECT "AspNetUserClaims_SEQ".NEXTVAL INTO :NEW."Id" FROM DUAL;
END;
/

CREATE TABLE "AspNetUserLogins" (
  "LoginProvider" NVARCHAR2(128) NOT NULL,
  "ProviderKey" NVARCHAR2(128) NOT NULL,
  "UserId" NVARCHAR2(128) NOT NULL,
  PRIMARY KEY ("LoginProvider", "ProviderKey", "UserId")
)
/

CREATE UNIQUE INDEX "RoleNameIndex" ON "AspNetRoles" ("Name")
/

CREATE INDEX "IX_AspNetUserRoles_UserId" ON "AspNetUserRoles" ("UserId")
/

CREATE INDEX "IX_AspNetUserRoles_RoleId" ON "AspNetUserRoles" ("RoleId")
/

CREATE UNIQUE INDEX "UserNameIndex" ON "AspNetUsers" ("UserName")
/

CREATE INDEX "IX_AspNetUserClaims_UserId" ON "AspNetUserClaims" ("UserId")
/

CREATE INDEX "IX_AspNetUserLogins_UserId" ON "AspNetUserLogins" ("UserId")
/

ALTER TABLE "AspNetUserRoles"
  ADD CONSTRAINT "FK_UserRoles_Roles" FOREIGN KEY ("RoleId") REFERENCES "AspNetRoles" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserRoles"
  ADD CONSTRAINT "FK_UserRoles_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserClaims"
  ADD CONSTRAINT "FK_UserClaims_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

ALTER TABLE "AspNetUserLogins"
  ADD CONSTRAINT "FK_UserLogins_Users" FOREIGN KEY ("UserId") REFERENCES "AspNetUsers" ("Id")
  ON DELETE CASCADE
/

See Also

Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle | Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle | Using Entity Framework Implementation of ASP.NET Identity 2 for Oracle


Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle

Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle
support@devart.com

ASP.NET Identity is a new system of user authentication and authorization, that continues the evolution of ASP.NET membership system, and is used in the Visual Studio 2013 project templates for ASP.NET MVC, Web Forms, Web API and SPA. You can read more on ASP.NET Identity in Microsoft documentation.

dotConnect for Oracle enables you to employ an implementation of ASP.NET Identity for Oracle database using either ADO.NET or Entity Framework functionality in your web applications. This allows you to use such ASP.NET Identity benefits as unit-testable user authentication system, social login support, OWIN integration, etc. This tutorial demonstrates creating an Entity Framework implementation of ASP.NET Identity.

To complete this tutorial you need Visual Studio 2013 installed.

In order to create an ASP.NET MVC 5 application using dotConnect for Oracle for storing identity information, perform the following steps:

  1. In the Add New Project dialog box expand Visual C# on the left, then Web, and then select ASP.NET Web Application. Name your project, for example, "AspNet_Identity_Application" and then click OK.

    Add New Project dialog box

  2. In the New ASP.NET Project dialog box, select the MVC template with the default options (that includes Individual User Accounts as authentication method) and click OK.

    New ASP.NET Project dialog box

  3. Add references to the necessary dotConnect for Oracle assemblies:

    • Devart.Data.dll
    • Devart.Data.Oracle.dll
    • Devart.Data.Oracle.Entity.EF6.dll

    You need to add the last file from the Entity\EF6 subfolder of the dotConnect for Oracle installation folder. Or you may add it from the GAC.

  4. In the web.config file of your project, replace the default connection string with your Oracle one.

    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" providerName="Devart.Data.Oracle" />

  5. Register the Entity Framework provider in the <providers> section of the web.config file

    Before the registration:

        <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>

    After the registration:

        <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
      <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>

    Note: replace "8.4.215.0" with the actual version.

  6. Open the IdentityModels.cs file from the Models project folder.

  7. Add the following namespaces to the using list:

    C#csharp Copy Code
    using System.Data.Entity;
using System.Data.Entity.Migrations;
    Visual Basic Copy Code
    Imports System.Data.Entity
Imports System.Data.Entity.Migrations

  8. Add the new Configuration class and register the dotConnect for Oracle provider SQL generator for Code-First Migrations.

    C#csharp Copy Code
        internal class Configuration : DbMigrationsConfiguration<ApplicationDbContext>
    {
        public Configuration()
        {
            AutomaticMigrationsEnabled = true;
            SetSqlGenerator("Devart.Data.Oracle", new Devart.Data.Oracle.Entity.Migrations.OracleEntityMigrationSqlGenerator());
        }
    }
    Visual Basic Copy Code
        Friend Class Configuration
        Inherits DbMigrationsConfiguration(Of ApplicationDbContext)
        Public Sub New()
            AutomaticMigrationsEnabled = True
            SetSqlGenerator("Devart.Data.Oracle", New Devart.Data.Oracle.Entity.Migrations.OracleEntityMigrationSqlGenerator())
        End Sub
    End Class

  9. Extend the ApplicationDbContext class code.

    We need to add a static constructor setting the database initializer for the context. Additionally we need to set the TruncateLongDefaultNames option of dotConnect for Oracle Entity Framework provider to true in order for foreign key names to be generated correctly because of Oracle 30 character limitation for foreign key names.

    After this we also need to add the OnModelCreating method, where we change type for character properties that aren't a part of entity key (they are filtered by their names) from the NCLOB data type to NVARCHAR(256) via a lightweight convention.

    The code before editing:

    C#csharp Copy Code
        public class ApplicationDbContext : IdentityDbContext<ApplicationUser>
    {
        public ApplicationDbContext()
            : base("DefaultConnection")
        {
        }
    }
    Visual Basic Copy Code
        Public Class ApplicationDbContext
        Inherits IdentityDbContext(Of ApplicationUser)
        Public Sub New()
            MyBase.New("DefaultConnection")
        End Sub
    End Class

    The code after editing:

    C#csharp Copy Code
        public class ApplicationDbContext : IdentityDbContext<ApplicationUser>
    {
        public ApplicationDbContext()
            : base("DefaultConnection")
        {
        }

        static ApplicationDbContext()
        {
            var config = Devart.Data.Oracle.Entity.Configuration.OracleEntityProviderConfig.Instance;
            config.CodeFirstOptions.TruncateLongDefaultNames = true;

            Database.SetInitializer(new MigrateDatabaseToLatestVersion<ApplicationDbContext, Configuration>());
        }

        protected override void OnModelCreating(DbModelBuilder modelBuilder)
        {

            base.OnModelCreating(modelBuilder);

            modelBuilder
              .Properties()
              .Where(p => p.PropertyType == typeof(string) &&
                          !p.Name.Contains("Id") &&
                          !p.Name.Contains("Provider"))
              .Configure(p => p.HasMaxLength(256));
        }

    }
    Visual Basic Copy Code
        Public Class ApplicationDbContext
        Inherits IdentityDbContext(Of ApplicationUser)
        Public Sub New()
            MyBase.New("DefaultConnection")
        End Sub

        Shared Sub New()
            Dim config = Devart.Data.Oracle.Entity.Configuration.OracleEntityProviderConfig.Instance
            config.CodeFirstOptions.TruncateLongDefaultNames = True

            Database.SetInitializer(New MigrateDatabaseToLatestVersion(Of ApplicationDbContext, Configuration)())
        End Sub

        Protected Overrides Sub OnModelCreating(modelBuilder As DbModelBuilder)

            MyBase.OnModelCreating(modelBuilder)

            modelBuilder.Properties().Where(Function(p) p.PropertyType = GetType(String) AndAlso Not _
                p.Name.Contains("Id") AndAlso Not p.Name.Contains("Provider")).Configure(Function(p) _
                p.HasMaxLength(256))
        End Sub
    End Class

Checking Application

Now we can run our application and check if everything works correctly.

  1. Run the application by pressing CTRL+F5.

    Getting started page
  2. Switch to the Register tab on the top of the page.

    Registration page
  3. Enter a new user name and password to the corresponding boxes and click the Register button.
  4. The new user is now registered and logged in, and the ASP.NET Identity tables are created in the Oracle database.

    User is registered
  5. After this you may use an appropriate database tool to connect to the database where the user data is stored and verify that the data is stored correctly.

See Also

Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle | Using Entity Framework Implementation of ASP.NET Identity 2 for Oracle | Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle


Using Entity Framework Implementation of ASP.NET Identity 2.0 for Oracle

Using Entity Framework Implementation of ASP.NET Identity 2.0 for Oracle
support@devart.com

ASP.NET Identity is a new system of user authentication and authorization, that continues the evolution of ASP.NET membership system, and is used in the Visual Studio 2013 project templates for ASP.NET MVC, Web Forms, Web API and SPA. You can read more on ASP.NET Identity in Microsoft documentation.

dotConnect for Oracle enables you to employ an implementation of ASP.NET Identity for Oracle database using either ADO.NET or Entity Framework functionality in your web applications. This allows you to use such ASP.NET Identity benefits as unit-testable user authentication system, social login support, OWIN integration, etc. This tutorial demonstrates creating an Entity Framework implementation of ASP.NET Identity.

To complete this tutorial you need Visual Studio 2013 Update 2 or higher installed.

In order to create an ASP.NET MVC 5 application using dotConnect for Oracle for storing identity information, perform the following steps:

  1. In the Add New Project dialog box expand Visual C# on the left, then Web, and then select ASP.NET Web Application. Name your project, for example, "AspNet_Identity_Application" and then click OK.

    Add New Project dialog box

  2. In the New ASP.NET Project dialog box, select the MVC template with the default options (that includes Individual User Accounts as authentication method) and click OK.

    New ASP.NET Project dialog box

  3. Add references to the necessary dotConnect for Oracle assemblies:

    • Devart.Data.dll
    • Devart.Data.Oracle.dll
    • Devart.Data.Oracle.Entity.EF6.dll

    You need to add the last file from the Entity\EF6 subfolder of the dotConnect for Oracle installation folder. Or you may add it from the GAC.

  4. In the web.config file of your project, replace the default connection string with your Oracle one.

    <add name="DefaultConnection" connectionString="User Id=Scott;Password=tiger;Data Source=Ora;" providerName="Devart.Data.Oracle" />

  5. Register the Entity Framework provider in the <providers> section of the web.config file

    Before the registration:

        <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>

    After the registration:

        <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
      <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>

    Note: replace "8.4.215.0" with the actual version.

  6. Open the IdentityModels.cs file from the Models project folder.

  7. Add the following namespaces to the using list:

    C#csharp Copy Code
    using System.Data.Entity;
using System.Data.Entity.Migrations;
    Visual Basic Copy Code
    Imports System.Data.Entity
Imports System.Data.Entity.Migrations

  8. Add the new Configuration class and register the dotConnect for Oracle provider SQL generator for Code-First Migrations.

    C#csharp Copy Code
        internal class Configuration : DbMigrationsConfiguration<ApplicationDbContext>
    {
        public Configuration()
        {
            AutomaticMigrationsEnabled = true;
            SetSqlGenerator("Devart.Data.Oracle", new Devart.Data.Oracle.Entity.Migrations.OracleEntityMigrationSqlGenerator());
        }
    }
    Visual Basic Copy Code
        Friend Class Configuration
        Inherits DbMigrationsConfiguration(Of ApplicationDbContext)
        Public Sub New()
            AutomaticMigrationsEnabled = True
            SetSqlGenerator("Devart.Data.Oracle", New Devart.Data.Oracle.Entity.Migrations.OracleEntityMigrationSqlGenerator())
        End Sub
    End Class

  9. Extend the ApplicationDbContext class code.

    We need to add a static constructor setting the database initializer for the context. Additionally we need to set the TruncateLongDefaultNames option of dotConnect for Oracle Entity Framework provider to true in order for foreign key names to be generated correctly because of Oracle 30 character limitation for foreign key names.

    After this we also need to add the OnModelCreating method, where we change type for character properties that aren't a part of entity key (they are filtered by their names) from the NCLOB data type to NVARCHAR(256) via a lightweight convention.

    The code before editing:

    C#csharp Copy Code
    public class ApplicationDbContext : IdentityDbContext<ApplicationUser>
  {
        public ApplicationDbContext()
            : base("DefaultConnection", throwIfV1Schema: false)
      {
        }
        public static ApplicationDbContext Create()
      {
            return new ApplicationDbContext();
        }
    }
    Visual Basic Copy Code
    Public Class ApplicationDbContext
    Inherits IdentityDbContext(Of ApplicationUser)
    Public Sub New()
        MyBase.New("DefaultConnection", throwIfV1Schema:=False)
    End Sub
    Public Shared Function Create() As ApplicationDbContext
        Return New ApplicationDbContext()
    End Function
End Class

    The code after editing:

    C#csharp Copy Code
        public class ApplicationDbContext : IdentityDbContext<ApplicationUser>
        {
        public ApplicationDbContext()
            : base("DefaultConnection", throwIfV1Schema: false)
        {
        }
        static ApplicationDbContext()
      {
            Database.SetInitializer(new MigrateDatabaseToLatestVersion<ApplicationDbContext, Configuration>());
        }
        protected override void OnModelCreating(DbModelBuilder modelBuilder)
        {

            base.OnModelCreating(modelBuilder);

            modelBuilder
              .Properties()
              .Where(p => p.PropertyType == typeof(string) &&
                          !p.Name.Contains("Id") &&
                          !p.Name.Contains("Provider"))
              .Configure(p => p.HasMaxLength(256));
        }

        public static ApplicationDbContext Create()
        {
            return new ApplicationDbContext();
        }
    }
    Visual Basic Copy Code
        Public Class ApplicationDbContext
        Inherits IdentityDbContext(Of ApplicationUser)
        Public Sub New()
            MyBase.New("DefaultConnection", throwIfV1Schema:=False)
        End Sub
        Shared Sub New()
            Database.SetInitializer(New MigrateDatabaseToLatestVersion(Of ApplicationDbContext, Configuration)())
        End Sub
        Protected Overrides Sub OnModelCreating(modelBuilder As DbModelBuilder)

            MyBase.OnModelCreating(modelBuilder)

            modelBuilder.Properties().Where(Function(p) p.PropertyType = GetType(String) AndAlso Not _
                p.Name.Contains("Id") AndAlso Not p.Name.Contains("Provider")).Configure(Function(p) _
                p.HasMaxLength(256))
        End Sub
        Public Shared Function Create() As ApplicationDbContext
            Return New ApplicationDbContext()
        End Function
    End Class

Checking Application

Now we can run our application and check if everything works correctly.

  1. Run the application by pressing CTRL+F5.

    Getting started page
  2. Switch to the Register tab on the top of the page.

    Registration page
  3. Enter a new Email and password to the corresponding boxes and click the Register button.
  4. The new user is now registered and logged in, and the ASP.NET Identity tables are created in the Oracle database.

    User is registered
  5. After this you may use an appropriate database tool to connect to the database where the user data is stored and verify that the data is stored correctly.

See Also

Using Entity Framework Implementation of ASP.NET Identity 1 for Oracle | Using ADO.NET Implementation of ASP.NET Identity 1 for Oracle | Using ADO.NET Implementation of ASP.NET Identity 2 for Oracle


Configuring Trust Level for Web Applications

Configuring Trust Level for Web Applications
support@devart.com

The following permissions are required by dotConnect for Oracle as partially trusted code (this is actual for web projects):

  • in Direct mode - medium trust plus SocketPermission;
  • in OCI mode - medium trust plus ReflectionPermission, EnvironmentPermission for PATH environment variable, FileIOPermission for Oracle Client.

Since dotConnect for Oracle uses standard Microsoft .NET licensing, it additionally requires RegistryPermission. And though SecurityPermission is granted by default when using medium trust level, the set of flags for the SecurityPermission must be extended. You need to add the following flags: Assertion, SkipVerification, UnmanagedCode, and SerializationFormatter.

You can configure the trust level for your application in the following ways:

First, you can modify the .NET Framework configuration file for the medium trust level. Open the web_mediumtrust.config file, that is located in the Windows\Microsoft.NET\Framework\<version>\Config\ folder, where <version> is the version of the target .NET Framework.

Add the following lines to the SecuityClasses tag:

<SecurityClass Name="RegistryPermission" Description="System.Security.Permissions.RegistryPermission, mscorlib, Version=4.0.0.0, Culture=neutral,PublicKeyToken=b77a5c561934e089"/>
<SecurityClass Name="SocketPermission" Description="System.Net.SocketPermission, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

Add the corresponding IPermissions elements to the PermissionSet tag with the Name attribute equal to "ASP.Net":

<PermissionSet class="NamedPermissionSet" version="1" Name="ASP.Net">
    <IPermission
            class="RegistryPermission"
            version="1"
            Unrestricted="true"
    />
    <IPermission
            class="SocketPermission"
            version="1"
            Unrestricted="true"
    />

Replace 4.0.0.0 in this fragment with the necessary version.

Replace the IPermission element, corresponding to SecurityPermission:

                            <IPermission
                                    class="SecurityPermission"
                                    version="1"
                                    Flags="Execution, ControlThread, ControlPrincipal, RemotingConfiguration"
                            />

with

                            <IPermission
                                    class="SecurityPermission"
                                    version="1"
                                    Flags="Assertion, Execution, ControlThread, ControlPrincipal, RemotingConfiguration, SkipVerification, UnmanagedCode, SerializationFormatter"
                            />

However, since the access to this file may be restricted on target computer, you may define your custom trust level. For this, add the following lines to the system.web tag at the beginning of your application web.config file:

<configuration>
    <system.web>
        <securityPolicy>
                  <trustLevel name="Custom" policyFile="web_customtrust.config" />
        </securityPolicy>
        <trust level="Custom" originUrl="" />
This trustLevel tag here introduces the new "Custom" trust level, defined in the web_customtrust.config (that is located in the same directory as the web.config file). The trust tag sets the current trust level to "Custom".

Create the web_customtrust.config file (just copy the content of your web_mediumtrust.config to it and make the changes, described above). You will need to deploy this file with your application.


Working with Command Editor

Working with Command Editor
support@devart.com

This topic describes how to use command editor for setting SQL commands to the different data access components, like OracleDataTable, OracleDataAdapter, OracleCommand or OracleDataSource. To adjust such component, one generally should set up select, insert, update and delete commands, and, if applicable, assign their parameters. The command editor allows doing this in a simple and visual way.

In this topic, we work with an OracleDataTable object. The following steps need to be performed to set up OracleDataTable commands:

  1. Create an object (e.g., add OracleDataTable to the form from the toolbox).

  2. Set up a connection.

    An open connection is required for some operations performed in command editor (for example, generation of update commands). If the connection is not initialized, any of such operations will prompt you setting the connection properties. For detailed information on how to establish a connection, see tutorial Logging Onto The Server.

  3. Specify the select command.

    Select type of a select command from the Type list box. The select command can be one of the following types - Text, StoredProcedure, or TableDirect.

    • Text option means that the specified SQL statement will be used as a command text.

    OracleDataTableEditor - Select Text

    • The StoredProcedure option allows you to select a stored procedure from the procedure list what are available for the current user (i.e., the user specified in the connection).

    • The TableDirect option allows you to bind some table from current user's schema to your data object directly. With the All check box selected you can choose a table from all available schemas.

    You can use the Preview button to see the result set that will be returned by the select command. The Preview Data window will open:

    The Open and Close buttons fill and clear the result set accordingly. If you use the only source table, in the Preview Data window you can also modify data in this table and save the changes with the Update button. Note that update commands are dynamically generated based on the columns mentioned in the select query. Thus if your select command does not include table's primary key, data modification may cause data loss or corruption.

  4. Set the select parameters.

    Let the select query have some parameter(s), like the following one:

                SELECT * FROM dept WHERE deptno = @pDeptNo

    In this case, when moving to this tab you will be prompted for generating parameters for your data object. You may also add and edit them manually.

    OracleDataTableEditor dialog box - Select Parameters

    This tab allows you to set the following parameter options:

    • Common parameter properties. The data type, direction, value and size of parameter can be set in the corresponding controls.
    • Parameter Value Editor is available for setting large string values of parameter or values of complex type parameter. To start the editor use the … button.
    • Null Value. To set the null value of parameter, check the Null Value check box. The Is Null Mapping check box sets the SourceColumnNullMapping property of the parameter.
    • Object and Array types. If the command receives an array parameter, you should set the array length in the appropriate text box. If the parameter is of some user-defined type (Object, Array or Table) the type can be selected from the Object Type Name list box. The All Types check box specifies whether types from other users can be selected.
    • Column Bindings. You may bind some column to parameter's value and use Current, Original, Proposed or Default value of this column (which may be of no use for select commands, but the same options are available for other types of commands). For this purpose, the Source Column text box and the Source Version list box should be used.

  5. Generate commands

    OracleDataTableEditor - Command Generator

    Also, Command Editor allows you to generate insert/update/delete commands for your data access component. You can do it on the Command Generator tab. If you work with several database tables, you should select one for which the update commands will be generated with the corresponding combo box.

    Select the commands which should be generated with the corresponding check boxes. The insert and update commands can be generated in such way that the assigned values will be returned as output parameters. To enable this mode, select the With refresh SQL check boxes. The Quote names check box specifies whether database objects' names will be quoted.

    Click the Get Table Fields button to see the grid with fields for the selected table. In this grid you may check whether particular fields will be Key, Updating and Refreshing.

    • For update and delete statement parameter specifying use the Key fields.
    • For specifying values that can be set by the generated insert and update commands use the Update checkboxes.
    • To select fields that which values will be returned, if the With refresh SQL option is enabled, use Refreshing fields.

  6. Edit update commands

    If you want to edit update commands go to the Update Commands tab.

    OracleDataTableEditor - Update Commands

    You can specify the SQL statement for each command, delete a redundant command using the Remove button, and tune a command with the Edit button. It opens OracleCommandEditor dialog with two pages - CommandText and Parameters.

    OracleCommand editor - parameters

See Also

OracleDataTable Class | OracleDataAdapter Class | OracleCommand Class | Using OracleDataSource Component


Retrieving Metadata

Retrieving Metadata
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

Usually you have to dig through SQL references to find out how to get metadata information for specific DBMS. There are few servers that support same SQL commands. Sometimes the syntax differs slightly, sometimes a server does not support certain statement. Now you can forget about those problems because dotConnect for Oracle retrieves the metadata for you.

You can take advantage of the new useful feature - GetSchema method. It allows you to read server schema information without writing queries and parsing the output. All information you may want to obtain is brought to you by single function in easy-to-process format. You can get information on schemas, views, packages, tables, columns, indexes, users, procedures and functions, their arguments, and reserved words. The method is introduced in System.Data.Common.DbConnection.

This article consists of the following sections:

  • How To Use
  • GetSchema Method Reference
  • Samples

How To Use

GetSchema method is available in three overloads, each of them serves its own purpose. All overloads return System.Data.DataTable object that contains information about server elements.

C#csharp Copy Code
public virtual abstract DataTable GetSchema();
Visual Basic Copy Code
Overloads Public Overridable MustOverride Function GetSchema() As DataTable

If you call the GetSchema method without parameters, or with single parameter "MetaDataCollections" (which is actually the same), the table object returned by the method will contain three columns. The first field of every row is a keyword allowed to be passed to the method (as collectionName argument). The second field is the number of restriction values for this keywords (passed through restrictionValues argument). The third field is not used in dotConnect for Oracle. It is always zero.

C#csharp Copy Code
public virtual abstract DataTable GetSchema(
   string collectionName
);
Visual Basic Copy Code
Overloads Public Overridable MustOverride Function GetSchema( _
   ByVal collectionName As String _
) As DataTable

GetSchema with 1 argument returns general information about the collection queried. For example, GetSchema("Users") returns the list of users on the server.

C#csharp Copy Code
public virtual abstract DataTable GetSchema(
   string collectionName,
   string[] restrictionValues
);
Visual Basic Copy Code
Overloads Public Overridable MustOverride Function GetSchema( _
   ByVal collectionName As String, _
   ByVal restrictionValues() As String _
) As DataTable

In this overload first parameter is name of a collection, and second parameter is the array of restrictions to be applied when querying information. These restrictions specify which subset of the collection will be returned. The restrictions can include, for example, the database name (in this case, only collection elements belonging to this database will be returned) or the mask for the name of collection elements (only the elements satisfying this mask will be returned). The quantity and description of restrictions allowed for each metadata collection are represented in the table here. Their number can also be obtained from the return of the GetSchema() method. If the second parameter is null/Nothing, it is ignored.

Instead of specifying the metadata collection name as a string constant, you may use members of System.Data.DbMetaDataCollectionNames and Devart.Data.Oracle.OracleMetadataCollectionNames as the first GetSchema argument values. The members of these classes are the string fields, each field stores the corresponding metadata collection name. It is recommended to use these fields rather than manually input the collection names manually as the string constants because in case of using these fields, you will find misspellings at compile-time, and intellisense will show you all the available metadata collection names.

GetSchema Method Reference

The following table provides detailed information on metadata collections that can be retrieved using the GetSchema method, and restrictions that can be applied for them. Some collections may be not supported in older server versions. If you try to get metadata for unsupported collection you will get exception with message "Collection not defined".

Collection Name

 Number of restrictions

Remarks
MetaDataCollections 0

Returns this list. Same as using GetSchema() method without parameters.
ReservedWords 0

Lists all reserved words used in the server.
Users 1

Lists all users on the server.

When restricted by username, returns information about specific user.
Tables 2

GetSchema("Tables") returns the list of all tables on the server that you have access to.

  • The first restriction for this collection is name of a schema. If specified, the method returns all tables within the schema.
  • The second restriction is table name. Note that masks are not allowed in dotConnect for Oracle.
Views 2

GetSchema("Views") returns the list of all views on the server that you have access to.

  • The first restriction for this collection is name of a schema. If specified, the method returns all views within the schema.
  • The second restriction is the name of the view.
Columns 3

Returns the list of columns, their type and some extra information.
GetSchema("Columns") returns the list of all columns in all schemas of the table.

  • Restricted by schema name, the method returns all columns in the specified schema.
  • The second restriction is a name of a table that GetSchema method should search in.
  • At last, you can specify column name.
Indexes 4

Returns the list of indexes and their details.

  • The first restriction is name of a schema the indexes belongs to.
  • The second restriction is name of the index.
  • The third restriction is name of a schema the table belongs to.
  • The last restriction is name of a table that uses the index.
IndexColumns 5

Returns information about columns included in indexes. The following restrictions may be specified:

  • The first restriction is name of the schema for indexes;
  • Index name;
  • Name of the schema for tables;
  • Table name;
  • Column name.
Functions 2

Returns the list of functions on the server. The following restrictions may be specified:

  • Schema name;
  • Function name.
Procedures 3

Returns the list of procedures on the server. The following restrictions may be specified:

  • Schema name;
  • Package name;
  • Procedure name.
Arguments 4

Returns the list of procedure and function arguments. The following restrictions may be specified:

  • Schema name;
  • Package name;
  • Procedure name;
  • Argument name.
Synonyms 2

Returns the list of synonyms on the server. The following restrictions may be specified:

  • Schema name;
  • Synonym name.
Sequences 2

Returns the list of sequences on the server. The following restrictions may be specified:

  • Schema name;
  • Sequence name.
Packages 2

Returns the list of packages on the server. The following restrictions may be specified:

  • Schema name;
  • Package name.
PackageBodies 2

Returns the list of package bodies on the server that you have access to. The following restrictions may be specified:

  • Schema name;
  • Package name.
PrimaryKeys 3

Returns the list of primary keys on the server. The following restrictions may be specified:

  • Schema name;
  • Key name;
  • Table name.
PrimaryKeyColumns 3

Returns the list of columns of primary keys on the server. The following restrictions may be specified:

  • Schema name;
  • Key name;
  • Table name;
  • Column name.
ForeignKeys 3

Returns the list of foreign keys on the server. The following restrictions may be specified:

  • Schema name;
  • Key name;
  • Table name.
ForeignKeyColumns 3

Returns the list of columns of foreign key columns on the server. The following restrictions may be specified:

  • Schema name;
  • Key name;
  • Table name.
FullForeignKeyColumns 3

Returns the list of columns of foreign key columns on the server. In comparison to the previous collection, a column with the names of the corresponding referenced columns in the parent table is added to the result DataTable. The following restrictions may be specified:

  • Schema name;
  • Key name;
  • Table name.
Triggers 2

Returns the list of triggers on the server that you have access to. The following restrictions may be specified:

  • Schema name;
  • Trigger name.
Clusters 2

Returns the list of clusters on the server that you have access to. The following restrictions may be specified:

  • Schema name;
  • Cluster name.
QueuePublishers 3

Returns the list of queue publishers on the server. The following restrictions may be specified:

  • Schema name;
  • Queue name;
  • Publisher name.
Queues 5

Returns the list of queues on the server. The following restrictions may be specified:

  • Schema name;
  • Queue name;
  • Queue table name;
  • Queue payload type;
  • Queue payload object type.
QueueTables 4

Returns the list of queue tables on the server. The following restrictions may be specified:

  • Schema name;
  • Queue table name;
  • Queue payload type;
  • Queue payload object type.
QueueSubscribers 4

Returns the list of subscribers to a queue or queues on the server. The following restrictions may be specified:

  • Schema name;
  • Queue name;
  • Queue table name;
  • Subscriber name.

Samples

The following code fragment is an elegant way to detect existence of a table.

C#csharp Copy Code
string tableName = "DEPT";
if (myDbConnection.GetSchema("Tables", new string[] { "SCOTT", tableName }).Rows.Count > 0)
{
Console.WriteLine("Table " + tableName + " found.");
}
Visual Basic Copy Code
Dim tableName As String = "DEPT"
Dim restrictions() As String = {"SCOTT", tableName}
If (myDbConnection.GetSchema("Tables", restrictions).Rows.Count > 0) Then
  Console.WriteLine("Table " + tableName + " found.")
End If

The next sample shows how to retrieve columns information from a table and render it to console.

C#csharp Copy Code
static void GetTableInfo(OracleConnection oraConnection, string tableName)
{
  oraConnection.Open();
  DataTable myDataTable = oraConnection.GetSchema("Columns", new string[] {
            "SCOTT", tableName });
  for (int i = 0; i < myDataTable.Columns.Count; i++)
  {
    Console.Write(myDataTable.Columns[i].Caption + "\t");
  }
  Console.WriteLine();
  foreach (DataRow myRow in myDataTable.Rows)
  {
    foreach (DataColumn myCol in myDataTable.Columns)
    {
      Console.Write(myRow[myCol] + "\t");
    }
    Console.WriteLine();
  }
  oraConnection.Close();
}
Visual Basic Copy Code
Public Sub GetTableInfo(ByVal oraConnection As OracleConnection, ByVal tableName As String)
  oraConnection.Open()
  Dim restrictions() As String = {"SCOTT", tableName}
  Dim myDataTable As DataTable = oraConnection.GetSchema("Columns", restrictions)
  Dim i As Int32
  For i = 0 To myDataTable.Columns.Count - 1
    Console.Write(myDataTable.Columns(i).Caption & Chr(9))
  Next
  Console.WriteLine()
  Dim myRow As DataRow
  Dim myCol As DataColumn
  For Each myRow In myDataTable.Rows
    For Each myCol In myDataTable.Columns
      Console.Write(myRow(myCol) & Chr(9))
    Next
    Console.WriteLine()
  Next
  oraConnection.Close()
End Sub

The following sample demonstrates how to generate SQL CREATE TABLE statement basing on metadata retrieved with GetSchema method. Only column name and type are included in the script.

C#csharp Copy Code
static void GetCreateTable(OracleConnection oraConnection, string tableName)
{
  //Open the connection
  oraConnection.Open();
  //Fill DataTable with columns information
  DataTable myDataTable = oraConnection.GetSchema("Columns", new string[] {
                                                   "SCOTT", tableName });
  string queryText = "CREATE TABLE " + tableName + " (\n";
  string fieldLine;
  DataRow myRow;
  //For every row in the table
  for (int i = 0; i < myDataTable.Rows.Count; i++)
  {
    //Get column name and type
    myRow = myDataTable.Rows[i];
    fieldLine = myRow["Name"] + " " + myRow["DataType"];
    //Add column size if required
    if (Array.IndexOf(new string[] {
       "NUMBER", "VARCHAR", "VARCHAR2", "RAW"
     }, myRow["DataType"]) != -1)
    {
      fieldLine = fieldLine + "(" + myRow["Length"] + ")";
    }
    //Add coma or closing bracket
    if (i < myDataTable.Rows.Count - 1)
    {
      fieldLine = fieldLine + ",\n";
    }
    else
    {
      fieldLine = fieldLine + ")";
    }
    //Add new column to script
    queryText = queryText + fieldLine;
  }
  Console.WriteLine(queryText);
  //Close the connection
  oraConnection.Close();
}
Visual Basic Copy Code
Public Sub GetCreateTable(ByVal oraConnection As OracleConnection, _
  ByVal tableName As String)
  'Open the connection
  oraConnection.Open()
  Dim restrictions() As String = {"SCOTT", tableName}
  'Fill DataTable with columns information
  Dim myDataTable As DataTable = oraConnection.GetSchema("Columns", restrictions)
  Dim queryText As String = "CREATE TABLE " + tableName & _
                            + " (" + System.Environment.NewLine
  Dim fieldLine As String
  Dim myRow As DataRow
  Dim i As Int32
  'For every row in the table
  For i = 0 To myDataTable.Rows.Count - 1
    'Get column name and type
    myRow = myDataTable.Rows(i)
    fieldLine = myRow("Name") & " " & myRow("DataType")
    'Add column size if required
    If (Array.IndexOf(New String() { _
      "VARCHAR", "VARCHAR2", "RAW", "NUMBER"}, myRow("DataType")) <> -1) Then
      fieldLine = fieldLine & "(" & myRow("Length") & ")"
    End If
    'Add coma or closing bracket
    If (i < myDataTable.Rows.Count - 1) Then
      fieldLine = fieldLine + "," + System.Environment.NewLine
    Else
      fieldLine = fieldLine + ")"
    End If
    'Add new column to script
    queryText = queryText + fieldLine
  Next
  Console.WriteLine(queryText)
  'Close the connection
  oraConnection.Close()
End Sub

Also you can get a metadata of query result set using the GetSchemaTable method of OracleDataReader and the ShemaTable property of OracleDataTable classes.

See Also

OracleConnection Class | DbConnectionBase.GetSchema Method | dotConnect for Oracle Articles


Asynchronous Query Execution

Asynchronous Query Execution
support@devart.com

dotConnect for Oracle supports a very useful feature - asynchronous execution of methods that take most of time in database applications. Traditionally, the main thread of the application went blocked during opening a connection, transferring large blocks of data, and other operations alike. Now you can entrust execution of a query to a background thread and concentrate on performing other operations, for example, an update of user interface elements, or on a preparation of another query for execution.

The article consists of following sections:

  • Understanding Asynchronous Methods
  • Completion Signalling
  • Transparent Asynchronous Fetch
  • Halting Execution
  • Samples

Understanding Asynchronous Methods

dotConnect for Oracle provides you with asynchronous methods for most of the time-consuming operations: connecting, data retrieving, and DML statement execution. For every synchronous method two asynchronous methods are implemented, with prefixes "Begin" and "End" respectively. The table below summarizes the new methods in the command object:

Table 1. Asynchronous methods
Class | Synchronous method | Asynchronous methods
 |  | Begin part | End part
OracleConnection | Open | BeginOpen | EndOpen
OracleCommand | ExecuteReader | BeginExecuteReader | EndExecuteReader
OracleCommand | ExecuteNonQuery | BeginExecuteNonQuery | EndExecuteNonQuery
OracleDataTable | Fill | BeginFill | EndFill

A typical usage of asynchronous methods looks like the following code.

C#csharp Copy Code
IAsyncResult myResult = myCommand.BeginExecuteNonQuery(null, null);
...
rowsAffected = myCommand.EndExecuteNonQuery(myResult);
Visual Basic Copy Code
Dim myResult As IAsyncResult = myCommand.BeginExecuteNonQuery(Nothing, Nothing)
...
Dim rowsAffected As Int32 = myCommand.EndExecuteNonQuery(myResult)

First, application calls the "Begin" method and passes it all the parameters needed to accomplish the task. This method returns IAsyncResult object that represents the operation invoked and is used for later processing. After the process has been invoked, application can proceed to do its job.
Later, when the query has finished its execution, application calls the "End" method, passing it IAsyncResult object returned by the "Begin" method that has been invoked earlier.
If something goes wrong with the query, the exception is thrown only when application calls "End" method.

Completion Signalling

The common synchronous method calls do not return until the operation is finished. In the asynchronous cases, the begin call returns immediately, so there is a need to determine when the operation is actually complete. dotConnect for Oracle provides you with three ways to catch the query termination.

All of the methods listed in the table 1 accept at least two parameters. For example, DbCommandBase.BeginExecuteReader method is declared in the following way:

C#csharp Copy Code
public IAsyncResult BeginExecuteReader(
   AsyncCallback callback,
   object stateObject,
   CommandBehavior behavior
);
Visual Basic Copy Code
Public Function BeginExecuteReader( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object, _
   ByVal behavior As CommandBehavior _
) As IAsyncResult

The way you get signalled about query termination depends on what values you pass to the "Begin" method.

  • Callback: pass a delegate as callback parameter, along with (optionally) a user-defined state object stateObject. When this approach is used, dotConnect for Oracle will call that passed-in delegate, and make the state object available through the IAsyncResult object (passed as the second parameter to the delegate). To avoid calling a delegate, pass null (Nothing in Visual Basic) to the callback parameter.
  • Synchronization objects: the IAsyncResult objects returned by the begin methods have a WaitHandle property that contains an event object. The event object can be used in synchronization primitives such as WaitHandle.WaitAny and WaitHandle.WaitAll. This allows the calling code to wait for multiple pending operations, and be notified either when one or all of them finish.
  • Polling: the IAsyncResult object also has an IsCompleted boolean property. This property will change to true when the operation completes, so it can be used by code that needs to perform some continuous activity; that code can periodically check the property and, if it changes, process the results.

In either case you must call corresponding "End" method to continue using the connection that serves the operation. If you try to start another asynchronous operation on connection that already serves a "Begin" method, an exception will be thrown. If you do not call the corresponding "End" method, some system resources may leak. Note that calling the "End" method without waiting for the operation to complete is allowed. In this case the method will block the current thread until the operation finishes.

Every asynchronous method that invokes an operation has stateObject parameter. You can pass it any object you find useful thus providing the callback routine any information it may require. The value of stateObject is accessible through IAsyncResult.AsyncState property.

Transparent Asynchronous Fetch

The OracleDataTable component provides even more features in the area of asynchronous execution. In addition to BeginFill and EndFill methods, it allows you to pause (SuspendFill), continue (BeginFill again), or stop (CancelFetch) the fetch process. Moreover, the component has NonBlocking property, which turns common fill into transparent asynchronous operation. To capture the end moment of the operation in a non-blocking fetch, watch for the SyncRoot property or handle the FetchFinished event.

For more information on the OracleDataTable component refer to topic OracleDataTable Advanced Features.

Halting Execution

dotConnect for Oracle allows you to stop query execution with OracleCommand.Cancel method. The method instructs Oracle server to halt any request from the connection associated with the command. This method returns without errors, while all stopped executions raise exception "ORA-01013: user requested cancel of current operation". Like any other exception, this one is thrown only when you invoke EndExecuteNonQuery or EndExecuteReader methods. Once server halts execution, the completion is signalled: callback delegate invoked, synchronization object triggered, and IsCompleted property is true.

Because OracleCommand.Cancel() method uses server-side technology it is impossible to stop opening connection with BeginOpen()...EndOpen(). This method is available for Oracle server 9 and newer.

Note that unlike all other methods, OracleCommand.Cancel() can be called in the middle of asynchronous execution. Moreover, this is a thread-safe method, so you can stop a common (synchronous) execution. To do this attach an OracleCommand object to connection that is used in operation to halt and invoke Cancel() method in another thread.

Samples

A sample is provided below for each of the signalling methods.

Polling

The following sample starts an asynchronous execution of UPDATE statement, then periodically checks whether the operation is complete, while performing some operations (writes a dot to console). Once query is done, the routine returns and application is ready to close.

C#csharp Copy Code
using System;
using Devart.Data.Oracle;

namespace MyNamespace
{
  class Class1
  {
    static OracleConnection myConnection = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
    static OracleCommand myCommand = new OracleCommand(
      "UPDATE Emp SET Sal = Sal + 500 WHERE Sal < 2000");

    static void PerformAsync()
    {
      myCommand.Connection = myConnection;
      myConnection.Open();
      int rowsAffected;
      try
      {
        IAsyncResult myResult = myCommand.BeginExecuteNonQuery(null, null);
        Console.Write("In progress...");
        while (!myResult.IsCompleted)
        {
          Console.Write(".");
          //Perform here any operation you need
        }
        rowsAffected = myCommand.EndExecuteNonQuery(myResult);
        Console.WriteLine();
        Console.WriteLine("Operation complete. Rows Affected: " + rowsAffected);
      }
      catch
      {
        Console.WriteLine("Error during execution.");
      }
      finally
      {
        myConnection.Close();
      }
    }

    static void Main(string[] args)
    {
      PerformAsync();
      Console.WriteLine("About to exit");
      Console.ReadLine();
    }
  }
}
Visual Basic Copy Code
Imports Devart.Data.Oracle
Imports System

Module Module1

  Dim myConnection As New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myCommand As OracleCommand = New OracleCommand( _
    "UPDATE Emp SET Sal = Sal + 500 WHERE Sal < 2000")

  Public Sub PerformAsync()
    myCommand.Connection = myConnection
    myConnection.Open()
    Dim rowsAffected As Int32
    Try
      Dim myResult As IAsyncResult = myCommand.BeginExecuteNonQuery(Nothing, Nothing)
      Console.Write("In progress...")
      While Not myResult.IsCompleted
        Console.Write(".")
        'Perform here any operation you need
      End While
      rowsAffected = myCommand.EndExecuteNonQuery(myResult)
      Console.WriteLine()
      Console.WriteLine("Operation complete. Rows Affected: " & rowsAffected)
    Catch
      Console.WriteLine("Error during execution.")
    Finally
      myConnection.Close()
    End Try
  End Sub

  Sub Main()
    PerformAsync()
    Console.WriteLine("About to exit.")
    Console.ReadLine()
  End Sub

End Module

Synchronization objects

This method is very effective when several database operations can be executed simultaneously. The sample code opens two connections, then starts two asynchronous executions and waits for either to finish. Once an operation is signaled complete, the code processes results of the operation. Afterwards the application finishes the second operation. Using this method, we reduce query execution time from sum of two operations to the time of the slowest operation.

C#csharp Copy Code
using System;
using Devart.Data.Oracle;

namespace MyNamespace
{

  public class Class1
  {

    static void Main(string[] args)
    {
      //Set up objects required to execute the queries

      OracleConnection[] myConnections = new OracleConnection[2];
      OracleCommand[] myCommands = new OracleCommand[2];
      IAsyncResult[] aResults = new IAsyncResult[2];
      string conStr = "User Id=Scott;Password=tiger;Data Source=Ora;";
      myConnections[0] = new OracleConnection(conStr);
      myCommands[0] = new OracleCommand(
        "UPDATE Dept SET Loc='LA' WHERE DeptNo=10", myConnections[0]);
      myConnections[1] = new OracleConnection(conStr);
      myCommands[1] = new OracleCommand(
        "UPDATE Emp SET Sal = Sal + 500 WHERE Sal < 2000", myConnections[1]);
      try
      {
        //Open the connections
        myConnections[0].Open();
        myConnections[1].Open();
        //Invoke execution of both queries
        aResults[0] = myCommands[0].BeginExecuteNonQuery(null, null);
        aResults[1] = myCommands[1].BeginExecuteNonQuery(null, null);
        Console.WriteLine("Waiting for operations to complete...");
        //Wait for any of the queries to finish
        int ind = System.Threading.WaitHandle.WaitAny(new System.Threading.WaitHandle[] {
                                                             aResults[0].AsyncWaitHandle,
                                                             aResults[1].AsyncWaitHandle });
        //Process results of the query that finished first
        Console.WriteLine("Result #{0}: {1}", ind,
          myCommands[ind].EndExecuteNonQuery(aResults[ind]));
        //Process results of another query
        int anotherIndex = 1 - ind;
        Console.WriteLine("Result #{0}: {1}", (anotherIndex),
          myCommands[anotherIndex].EndExecuteNonQuery(aResults[anotherIndex]));
      }
      catch
      {
        Console.WriteLine("Error during a query.");
      }
      finally
      {
        myConnections[0].Close();
        myConnections[1].Close();
      }
      Console.WriteLine("About to exit");
      Console.ReadLine();
    }
  }
}
Visual Basic Copy Code
Imports System
Imports Devart.Data.Oracle

Module Module1

  Sub Main()
    'Set up objects required to execute the queries
    Dim myConnections(1) As OracleConnection
    Dim myCommands(1) As OracleCommand
    Dim aResults(1) As IAsyncResult
    Dim conStr As String = "User Id=Scott;Password=tiger;Data Source=Ora;"
    myConnections(0) = New OracleConnection(conStr)
    myCommands(0) = New OracleCommand( _
      "UPDATE Dept SET Loc='LA' WHERE DeptNo=10", myConnections(0))
    myConnections(1) = New OracleConnection(conStr)
    myCommands(1) = New OracleCommand( _
      "UPDATE Emp SET Sal = Sal + 500 WHERE Sal < 2000", myConnections(1))
    Try
      'Open the connections
      myConnections(0).Open()
      myConnections(1).Open()
      'Invoke execution of both queries
      aResults(0) = myCommands(0).BeginExecuteNonQuery(Nothing, Nothing)
      aResults(1) = myCommands(1).BeginExecuteNonQuery(Nothing, Nothing)
      Console.WriteLine("Waiting for operations to complete...")
      Dim waitHandles() As System.Threading.WaitHandle = { _
                              aResults(0).AsyncWaitHandle, aResults(1).AsyncWaitHandle}
      'Wait for any of the queries to finish
      Dim ind As Int32 = System.Threading.WaitHandle.WaitAny(waitHandles)
      'Process results of the query that finished first
      Console.WriteLine("Result #{0}: {1}", ind, _
        myCommands(ind).EndExecuteNonQuery(aResults(ind)))
      'Process results of another query
      Dim anotherIndex As Int32 = 1 - ind
      Console.WriteLine("Result #{0}: {1}", (anotherIndex), _
        myCommands(anotherIndex).EndExecuteNonQuery(aResults(anotherIndex)))
    Catch
      Console.WriteLine("Error during a query.")
    Finally
      myConnections(0).Close()
      myConnections(1).Close()
    End Try
    Console.WriteLine("About to exit")
    Console.ReadLine()
  End Sub

End Module

Callback

This method is probably the most effective in many situations. The sample code initiates establishment of two connections with different servers. A connection itself is passed as stateObject parameter. This allows a delegate to know what connection has finished negotiation with servers and to end the asynchronous operation. Using this method, we obtain results of an operation once it is complete, without having to wait for the slower operations that might precede it.

C#csharp Copy Code
using System;
using Devart.Data.Oracle;

namespace MyNamespace
{
  class Class1
  {
    static OracleConnection myConnection1 = new OracleConnection(
        "User Id=Scott;Password=tiger;Data Source=Ora");
    static OracleConnection myConnection2 = new OracleConnection(
        "User Id=Scott;Password=tiger;Data Source=Ora_Another");

    static void OperationComplete(IAsyncResult ar)
    {
      try
      {
        OracleConnection currentConnection = (OracleConnection)ar.AsyncState;
        currentConnection.EndOpen(ar);
        Console.WriteLine("Connection string: "+currentConnection.ConnectionString +
                           ", server version: "+currentConnection.ServerVersion);
      }
      catch
      {
        Console.WriteLine("Error during opening.");
      }
    }

    static void PerformAsync()
    {
      myConnection1.BeginOpen(new AsyncCallback(OperationComplete), myConnection1);
      myConnection2.BeginOpen(new AsyncCallback(OperationComplete), myConnection2);
      Console.WriteLine(
        "Waiting for operations to complete.
        Hit Enter when both connections are established.");
      Console.ReadLine();
      myConnection1.Close();
      myConnection2.Close();
    }

    static void Main(string[] args)
    {
      PerformAsync();
    }
  }
}
Visual Basic Copy Code
Imports System
Imports Devart.Data.Oracle

Module Module1

  Dim myConnection1 As New OracleConnection( _
     "User Id=Scott;Password=tiger;Data Source=Ora")
  Dim myConnection2 As New OracleConnection( _
     "User Id=Scott;Password=tiger;Data Source=Ora_Another")

  Public Sub OperationComplete(ByVal ar As IAsyncResult)
    Try
      Dim currentConnection As OracleConnection = CType(ar.AsyncState, OracleConnection)
      currentConnection.EndOpen(ar)
      Console.WriteLine("Connection string: " & currentConnection.ConnectionString & _
                         ", server version: " & currentConnection.ServerVersion)
    Catch
      Console.WriteLine("Error during opening.")
    End Try
  End Sub

  Public Sub PerformAsync()
    myConnection1.BeginOpen(AddressOf OperationComplete, myConnection1)
    myConnection2.BeginOpen(AddressOf OperationComplete, myConnection2)
    Console.WriteLine( _
      "Waiting for operations to complete. _
        Hit Enter when both connections are established.")
    Console.ReadLine()
    myConnection1.Close()
    myConnection2.Close()
  End Sub

  Sub Main()
    PerformAsync()
  End Sub

End Module

See Also

OracleCommand Class | OracleConnection Class | OracleDataTable Class


Enterprise Library Data Access Block

Enterprise Library Data Access Block
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

dotConnect for Oracle can be used in conjunction with Microsoft Enterprise Library Data Access Application Block, which boosts development productivity in many cases. This topic describes what is Enterprise Library, what part of it can be substituted with dotConnect for Oracle, and how to use the bundle in your applications. The topic consists of following sections:

  • Enterprise Library overview
  • Data Access Application Block
  • When to use the Data Access Application Block
  • Configuring dotConnect for Oracle as Data Access Block
  • Examples
  • Informational Resources

The first three sections contain general information on Enterprise Library and its benefits. You can safely skip it if you are acquainted with the matter. The last section practically demonstrates how to start using dotConnect for Oracle as Data Access Application Block.

This feature is available in Professional and Developer Editions only.

Enterprise Library Overview

Enterprise Library is a set of application blocks - reusable software components designed to help developers with usual enterprise development tasks.

Enterprise Library is designed for:

  • Consistency. All Enterprise Library application blocks feature consistent design patterns and implementation approaches.
  • Extensibility. All application blocks allow developers to customize the behavior by adding own code.
  • Ease of use. Graphical configuration tool, simpler installation procedure, clearer and more complete documentation and samples.
  • Integration. Application blocks are designed to work well together and are tested to make sure that they do.

Application blocks help solve common problems that developers face from one project to another. They have been designed to encapsulate the Microsoft recommended best practices for .NET applications. Application blocks can be added to applications quickly and easily.

Data Access Application Block

The Enterprise Library Data Access Application Block simplifies common data access functionality. Applications can use this application block in a variety of situations, such as reading data for display, passing data through application layers, and submitting changed data back to the database system. The application block supports both stored procedures and in-line SQL. Common maintenance tasks, such as managing connections and creating and caching parameters, are encapsulated in the application block's methods. In other words, the Data Access Application Block provides access to the most often used features of ADO.NET in simple-to-use classes. The Block exposes a model that supports encapsulation of database-specific features, which allows applications to be ported from one database type to another without modifying the client code.

The Data Access Application Block provides the following benefits:

  • It leverages the functionality provided by ADO.NET and allows you to use ADO.NET together with the application block.
  • It reduces the need to write boilerplate code to perform standard tasks.
  • It helps maintain consistent data access practices, both within an application and across the enterprise.
  • It reduces difficulties in changing the database type.

When to Use the Data Access Application Block

The Data Access Application Block includes a small number of methods that simplify the most common methods of accessing a database. Each method encapsulates the logic required to retrieve the data and manage the connection to the database. You should consider using the application block if your application uses standard data access techniques.

The application block supplements the code in ADO.NET that allows you to use the same code with different database types. The GenericDatabase class allows you to use the application block with any configured ADO.NET DbProviderFactory object.

The Data Access Application Block is a complement to ADO.NET; it is not a replacement. The application block provides simplicity and convenience while helping developers use ADO.NET with best practices. If your application needs to retrieve data in specialized way, or if your code needs customization to take advantage of features specific to Oracle, using dotConnect for Oracle might suit you better.

Configuring dotConnect for Oracle as Data Access Block

The rest of the article demonstrates configuring and using Enterprise Library. In this article we will consider parts of the DataAccessQuickStart sample found in Program Files\Devart\dotConnect\Oracle\EnterpriseLibrary\ folder. You can study it in conjunction with this article. The sample represents integral project that demonstrates primary techniques, while the article explains most important points.

The first thing to do in using dotConnect for Oracle as Data Access Block is adjusting application settings. All settings are stored in single file, App.config. No other configuration file is needed. This file (App.config) in your sources should look like the following example:

<configuration>
  <configSections>
    <section
      name="dataConfiguration"
      type="
        Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings,
        Microsoft.Practices.EnterpriseLibrary.Data"/>
  </configSections>
  <connectionStrings>
    <add
      name="DataAccessQuickStart"
      providerName="Devart.Data.Oracle"
      connectionString="server=ORA;
                        User id = scott;
                        password = tiger;" />
  </connectionStrings>
  <system.data>
    <DbProviderFactories>
      <remove invariant="Devart.Data.Oracle" />
      <add name="dotConnect for Oracle" invariant="Devart.Data.Oracle"
            description="Devart dotConnect for Oracle" type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </DbProviderFactories>
  </system.data>
  <dataConfiguration
    defaultDatabase="DataAccessQuickStart">
    <providerMappings>
      <add
      databaseType="Devart.Data.Oracle.EnterpriseLibrary.OracleDatabase,
                    Devart.Data.Oracle.EnterpriseLibrary"
      name="dotConnect for Oracle" />
    </providerMappings>
  </dataConfiguration>
</configuration>

The following assemblies need to be referenced by the solution: Microsoft.Practices.EnterpriseLibrary.Data and Microsoft.Practices.EnterpriseLibrary.Common.

After compilation App.config is renamed to YourAppName.exe.config where YourAppName.exe is name of the executable file, and placed next to the file. Application reads the file when it is loaded. In the fragment presented the XML tree contains some mandatory general information (file types and schemas), and controls whether encryption should be used (disabled in this case).

Note that for web applications and web services metaconfiguration file is web.config in the root directory of your web site or virtual directory.

The most important line in metaconfiguration file is <storageProvider ... path="dataConfiguration.config" />. It points to configuration file that controls Data Access Application Block, which, in turn, should be something like this:

<?xml version="1.0" encoding="utf-8"?>
<dataConfiguration>
  <xmlSerializerSection
    type="
      Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings,
      Microsoft.Practices.EnterpriseLibrary.Data">
    <enterpriseLibrary.databaseSettings
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns="http://www.microsoft.com/practices/enterpriselibrary/08-31-2004/data">
      defaultInstance="DataAccessQuickStart"
      <databaseTypes>
        <databaseType
          name="Oracle"
          type="Devart.Data.Oracle.EnterpriseLibrary.OracleDatabase,
                Devart.Data.Oracle.EnterpriseLibrary" />
      </databaseTypes>
      <instances>
        <instance
          name="DataAccessQuickStart"
          type="Oracle"
          connectionString="LocalQuickStart" />
      </instances>
      <connectionStrings>
        <connectionString name="LocalQuickStart">
          <parameters>
            <parameter name="server" value="localhost" isSensitive="false" />
            <parameter name="user id" value="scott" isSensitive="false" />
            <parameter name="password" value="tiger" isSensitive="false" />          </parameters>
        </connectionString>
      </connectionStrings>
    </enterpriseLibrary.databaseSettings>
  </xmlSerializerSection>
</dataConfiguration>

The latter XML is of much more interest to database developer because it actually contains data used to connect to database. In Enterprise Library you handle databases with Microsoft.Practices.EnterpriseLibrary.Data.Database class, which is initialized according to this configuration file. The file describes possible database instances that can be created in application.

In Data Access Application Block obtaining handle to database is as simple as following statement:
Database db = DatabaseFactory.CreateDatabase();
If an argument was not supplied to the method it searches configuration XML for defaultInstance attribute of enterpriseLibrary.databaseSettings node. Its value is name of the instance to use. This instance must be described in instances node. Type of the instance determines what provider to use (enumerated in databaseTypes) and name of connection string. The connection string itself is defined in connectionStrings node. Its arguments are self-explanatory.

This is how Data Access Application Block initializes database connections. Single configuration file can describe multiple data providers, connection strings and databases. You can refer to certain database in your code directly:
Database db = DatabaseFactory.CreateDatabase("myInstanceName");

Microsoft provides a GUI tool to create and configure visually the files App.config and dataConfiguration.config. You can find in Start menu shortcut Enterprise Library Configuration to the file EntLibConfig.exe. This tool also allows you to setup encryption for the configuration file.

Note that unlike App.config, dataConfiguration.config file is not copied automatically to output directory. You can do it manually, or run appropriate command line in a Post-build event of your project. Another way to make sure that configuration is up to date is to hardcode full path in App.config file.

The following assemblies need to be referenced by the solution: Microsoft.Practices.EnterpriseLibrary.Data, Microsoft.Practices.EnterpriseLibrary.Common and Microsoft.Practices.EnterpriseLibrary.Configuration. They are typically located in bin folder of Enterprise Library like \Program Files\Microsoft Enterprise Library\bin\. Add namespace Microsoft.Practices.EnterpriseLibrary.Data to using (Imports in Visual Basic) clause of your sources to have important classes visible (for example, Database and DBCommandWrapper).

To use dotConnect for Oracle as Data Access Application Block you have to add reference to Devart.Data.Oracle.EnterpriseLibrary.dll assembly. dotConnect for Oracle is shipped with sources of this assembly, so if you need to alter it or add custom functionality, add Devart.Data.Oracle.EnterpriseLibrary project to your solution.

Examples

The following routine returns list of customers from corresponding table. It returns the list as string object where individual customers are separated with line breaks.

public string GetCustomerList() {

  // Create the Database object, using the default
  // database service as described above.
  Database db = DatabaseFactory.CreateDatabase();
  // Define SQL query to retrieve the data.
  string sqlCommand = "Select Name From Customers";
  // Create ADO.NET DbCommand object
  DbCommand dbCommand = db.GetSqlStringCommand(sqlCommand);
  // Create intermediate data holder
  StringBuilder readerData = new StringBuilder();
  // DataReader that will hold the returned results
  // The ExecuteReader call will request the connection to be closed upon
  // the closing of the DataReader. The DataReader will be closed
  // automatically when it is disposed.
  using (IDataReader dataReader = db.ExecuteReader(dbCommand)) {
    // Iterate through DataReader
    while (dataReader.Read()) {
      // Get the value of the 'Name' column in the DataReader
      readerData.Append(dataReader["Name"]);
      readerData.Append(Environment.NewLine);
    }
  }
  return readerData.ToString();
}

The next example demonstrates usage of parameters. The routine returns DataSet that contains all products within given category.

public DataSet GetProductsInCategory(int Category) {

  Database db = DatabaseFactory.CreateDatabase();
  string sqlCommand = "Select * From Products Where CategoryID = :CategoryID";
  DbCommand dbCommand = db.GetSqlStringCommand(sqlCommand);
  // Create and add integer input parameter
  db.AddInParameter(dbCommand, "CategoryID", DbType.Int32, Category);
  // DataSet that will hold the returned results
  DataSet productsDataSet = null;
  // Open connection, execute the query and close connection
  productsDataSet = db.ExecuteDataSet(dbCommand);
  return productsDataSet;
}

The next example shows how to modify a DataSet. The routine retrieves data, inserts new row into table and updates changes. You can alter or delete existing rows in same way.

public int UpdateProducts() {

  Database db = DatabaseFactory.CreateDatabase();
  // Create DataSet that receives initial data
  DataSet productsDataSet = new DataSet();
  string sqlCommand = "Select ProductID, ProductName, CategoryID,
                       UnitPrice, LastUpdate From Products";
  DbCommand dbCommand = db.GetSqlStringCommand(sqlCommand);
  // Declare table name to refer later
  string productsTable = "Products";
  // Retrieve the initial data
  db.LoadDataSet(dbCommand, productsDataSet, productsTable);
  // Get the table that will be modified
  DataTable table = productsDataSet.Tables[productsTable];
  // Add a new product to existing DataSet
  DataRow addedRow = table.Rows.Add(new object[] {
                       DBNull.Value, "New product", 11, 25 });
  // Setup Insert command
  DbCommand insertCommand = db.GetSqlStringCommand("Insert Into Products " +
    "(ProductName, CategoryID, UnitPrice) Values (:ProductName,
                                             :CategoryID,:UnitPrice)");
  db.AddInParameter(insertCommand, "ProductName", DbType.String,
                                   "ProductName", DataRowVersion.Current);
  db.AddInParameter(insertCommand, "CategoryID", DbType.Int32,
                                   "CategoryID", DataRowVersion.Current);
  db.AddInParameter(insertCommand, "UnitPrice", DbType.Decimal,
                                   "UnitPrice", DataRowVersion.Current);
  // Update the DataSet, capturing the number of rows that were affected
  int rowsAffected = db.UpdateDataSet(productsDataSet, "Products",
                                      insertCommand, null,
                                      null, UpdateBehavior.Standard);
  return rowsAffected;
}

More examples can be found in DataAccessQuickStart demo project. You can open it in your IDE and explore other features of Enterprise Library.

Informational Resources

  • The homepage to start from is http://msdn2.microsoft.com/en-us/library/aa480453.aspx. It contains download information and links to other useful locations.
  • If you are going to use Enterprise Library, take a look through corresponding page published in January, 2006: http://msdn.microsoft.com/en-us/library/cc467893.aspx.
  • Finally, after you install the library, refer to Visual Studio Integrated Help Collection for detailed information on every aspect of the product.
  • If you encounter problems using it, make sure you are acquainted with FAQ: http://channel9.msdn.com/wiki/default.aspx/Channel9.EnterpriseLibraryFAQ.


SQL Server Integration Services

SQL Server Integration Services
support@devart.com

This section describes SQL Server Integration Services support in dotConnect for Oracle (dotConnect for Oracle SSIS Data Flow components).

General Information on SSIS Support
This section provides an introduction to Devart dotConnect for Oracle SSIS Data Flow components.

Creating a Oracle Connection
This topic describes creating a connection to Oracle in Integration Services package.

Devart Oracle Source
This topic describes the Devart Oracle Source component.

Devart Oracle Destination
This topic describes the Devart Oracle Destination component.

SSIS Tutorials
This section contains tutorials on using dotConnect for Oracle in Integration Services packages.


General Information on SSIS Support

General Information on SSIS Support
support@devart.com

This section provides an introduction to Devart dotConnect for Oracle SSIS Data Flow components.

SSIS Support Overview
This topic provides an overview of SQL Server Integration Services and Devart dotConnect for Oracle as its component.

Requirements for SSIS Data Flow Components
This topic describes requirements that should be met prior to installation.

SSIS Data Flow Components Installation
This topic describes how to install Devart dotConnect for Oracle SSIS Data Flow components in BIDS 2008.


SSIS Support Overview

SSIS Support Overview
support@devart.com

SQL Server Integration Services (SSIS) is a component of the Microsoft SQL Server database software designed to perform a variety of tasks for data migration. SSIS is a platform intended for data integration and workflow applications. It is a powerful data warehousing tool created for the purposes of data extraction, transformation, and loading (ETL).

SSIS allows you to create packages that migrate data from a data source to a destination, applying transformations at the same time, if necessary. With its rich set of built-in tasks and transformations combined with a visual development tool based on Microsoft Visual Studio, that is called the SQL Server Business Intelligence Development Studio (BIDS), you can easily manage data flow tasks. Besides, you can keep track of the package execution through the color-coded, real-time monitoring feature of this tool.

Devart dotConnect for Oracle SSIS embeds into SQL Server Integration Services and thus enables data migration to and from Oracle.

See Also

Installation Requirements | Installation


Requirements for SSIS Data Flow Components

Requirements for SSIS Data Flow Components
support@devart.com

Prior to installing Devart dotConnect for Oracle SSIS, make sure that the following requirements are met.

  • SQL Server Integration Services 2008, 2012, 2014, or 2016 (SSIS component) is installed.
  • BIDS 2008 (Business Intelligence Development Studio) or Microsoft SQL Server Integration Services Designer is installed.
  • Internet connection is available.

SQL Server 2008

To check that Business Intelligence Development Studio is installed, click Start -> All Programs, click the Microsoft SQL Server 2008 folder. Business Intelligence Development Studio should be present in this folder.

To verify that SQL Server Integration Services component is installed, run Business Intelligence Development Studio, then click the File menu -> New -> Project. This will display the New Project window; locate the Project Types area and make sure that it contains the Business Intelligence Projects item.

SQL Server 2012 - 2016

To verify that SQL Server Integration Services component and Microsoft SQL Server Integration Services Designer are installed, run SQL Server Data Tools (on the Start menu, point to All Programs, click Microsoft SQL Server, and then click SQL Server Data Tools). Then on the File menu point to New and click Project. This will display the New Project window; locate the Installed templates area and make sure that it contains the Business Intelligence -> Integration Services item.

See Also

SSIS Overview | Installation


SSIS Data Flow Components Installation

SSIS Data Flow Components Installation
support@devart.com

In BIDS 2008 (installed with SQL Server 2008), Devart dotConnect for Oracle SSIS Data Flow components are not added to the Toolbox by default. To install our Data Flow components to the Toolbox, perform the following steps:

  1. Create an Integration Services Project (for details refer to SQL Server Integration Services Tutorials).
  2. Right-click in the Toolbox floating window to call its context menu and select Choose Items. .Net Framework Components tab of the Choose Toolbox Items dialog box is displayed; switch to its SSIS Data Flow Items tab.
  3. Locate and select the Devart Oracle Source and Devart Oracle Destination items, and click OK. Now these components are added to the toolbox.
  4. Drag them to the corresponding toolbox sections for further convenience.

In Microsoft SQL Server Integration Services Designer (installed with SQL Server 2012, 2014, or 2016), our components are added to the toolbox automatically when you install dotConnect for Oracle. They are added to the Common tab of the Toolbox.

See Also

SSIS Overview | Installation Requirements


Creating Oracle Connection

Creating Oracle Connection
support@devart.com

To create a connection to Oracle, do the following:

  1. Right-click in the Connection Managers pane and select New Connection from the context menu. The Add SSIS Connection Manager dialog box is displayed:

  2. In the Connection manager type list select DevartOracle and click Add. The General tab of the Oracle Connection Manager Editor dialog box is displayed:

  3. Specify the connection parameters.

    1. If you connect through OCI, in the Server property type TNS alias of the server.
    2. If you use Direct mode, perform the following assignments:
      • set Direct to true
      • in the Server property type DNS name or IP address of the computer where Oracle server resides
      • in the Sid property type service name
      • In the Port property specify the port that the server listens to (usually this is 1521).

    In our tutorial we create a Direct mode connection that does not require Oracle Client.


Devart Oracle Source

Devart Oracle Source
support@devart.com

Devart Oracle Source is a data flow component that makes data from Oracle available to other data flow components. It provides a convenient editor dialog box, which allows you to easily define which data to load.

To call the Devart Oracle Source Editor, double-click the Devart Oracle Source data flow object.

This dialog box has the following components:

  • The Tables area allows you to view the existing Oracle tables, expand their nodes to view columns, and drag them from this area to the Query area.

    • The Show all schemas Show all schemas button enables displaying all the objects of the selected connection; otherwise, only the objects of the default schema for the connection are displayed.
    • The Refresh Objects Refresh Objects button updates the list of Oracle tables.
  • The Variables area allows you to view the system and user variables grouped in the corresponding nodes, and if necessary, drag them to the Query area.

  • The Query area is intended for creating a query to be executed against the Oracle database. You can drag the required Oracle tables and variables to this area, or write the query yourself.

    • The Preview Data Refresh Objects button calls the Preview Data window that displays the query execution result.
  • The Properties area displays properties of the currently selected Oracle table, column or variable.
  • The Oracle Connection drop-down list is intended for selecting the corresponding Devart Oracle Connection Manager.


Devart Oracle Destination

Devart Oracle Destination
support@devart.com

Devart Oracle Destination is designed for loading data into Oracle tables.

With OCI connections, Devart Oracle Destination uses direct path load interface to speed up loading. With Direct mode it uses array binding feature.

The Oracle table you want to migrate data to can be selected in the Table Name combo box on the Component Properties tab of the Devart Oracle Destination data flow object.

The action that should be performed with data during migration is defined by the Action parameter of Devart Oracle Destination object, that provides the following options: Insert, Update, Delete, and BulkInsert. As all of the actions have certain peculiarities:

  • Insert - as this case is the most common, we decided to cover it in a detailed tutorial. It uses simple INSERT statements to load data to Oracle.
  • BulkInsert - uses Oracle-specific technique to quickly load data to Oracle. With OCI connections, Devart Oracle Destination uses direct path load interface to speed up loading. With Direct mode it uses array binding feature.
  • Update - Devart Oracle Destination component in the Update mode enables updating data in a Oracle table.
    Note Note:

    Peculiarity of this action consists in the fact, that performing it requires using primary key values of the Oracle table. Thus, when performing an update, you must know and specify the primary key values of the Oracle table to update a record.
  • Delete - Devart Oracle Destination component enables deleting data from a Oracle table.
    Note Note:

    As is the case with the Update action, the ID column from the local data source corresponding to the Primary key values column in the Oracle table, must be used.

The amount of data that can be migrated at a time is limited by the BufferSize property.

BufferSize defines the maximum size of the local buffer, its default value is 262144.

Devart Oracle Data Flow components support error outputs, which allow you to manage how the component treats row-level errors in both incoming and outgoing data.

The error output includes the column set taking part in the data flow and additional columns, they are ErrorCode that identifies the error, ErrorColumn that contains the lineage identifier of the error column and ErrorDescription that provides a detailed description of the error.

The ErrorCode column can accept the following values:

ErrorCode | Description
-1 | Means that the record is valid.
>0 | Means that the record causes an error.

Additionally, when the primary key values are automatically generated for the target table, Devart Oracle Destination retrieves the generated values and adds them to its output columns.

See Also

Loading Data to Oracle


SSIS Tutorials

SSIS Tutorials
support@devart.com

This section provides tutorials for the Devart Oracle data flow components.

Loading Data from Oracle
This tutorial describes how to load data from the Oracle database via the Devart Oracle Source component.

Loading Data to Oracle
This tutorial describes how to load data to the Oracle database via the Devart Oracle Destination component.

SQL Server Import and Export Wizard Tutorial
This tutorial describes how to import a table from an Oracle server to SQL Server using SQL Server Import and Export Wizard.


Loading Data from Oracle

Loading Data from Oracle
support@devart.com

This tutorial requires SQL Server 2012 and Microsoft SQL Server Integration Services Designer. A similar Integration Services package can be created with SQL Server 2008 and BIDS 2008; however, there may be some differences, mostly in using the Toolbox. In BIDS 2008, dotConnect for Oracle SSIS Data Flow components are not added to the Toolbox by default. You need to add them yourself as described in SSIS Data Flow Components Installation in BIDS 2008. The names of the Toolbox tabs are also different in BIDS 2008 and Microsoft SQL Server Integration Services Designer.

For the purpose of this tutorial, we create a Devart Oracle Source and an OLE DB Destination.

In the Control Flow tab, from the Control Flow Items tab in the Toolbox, drag Data Flow Task to the design area. The Data Flow Task is created.

Switch to the Data Flow tab. From the Other Destinations tab of the Toolbox drag the OLE DB Destination to the design area.

From the Common tab of the Toolbox drag Devart Oracle Source to the design area. (By default dotConnect for Oracle SSIS Data Flow components are added to the Common tab when installing dotConnect for Oracle.)

Connect the two data flow objects with a Data Flow path.

For this example we need two connections - one for the OLE DB Destination, the other one for the Devart Oracle Source. To create a connection to Oracle, do the following:

  1. Right-click in the Connection Managers pane and select New Connection from the context menu. The Add SSIS Connection Manager dialog box is displayed:

  2. In the Connection manager type list select DevartOracle and click Add. The General tab of the Oracle Connection Manager Editor dialog box is displayed:

  3. Specify the connection parameters.

    1. If you connect through OCI, in the Server property type TNS alias of the server.
    2. If you use Direct mode, perform the following assignments:
      • set Direct to true
      • in the Server property type DNS name or IP address of the computer where Oracle server resides
      • in the Sid property type service name
      • In the Port property specify the port that the server listens to (usually this is 1521).

    In our tutorial we create a Direct mode connection that does not require Oracle Client.

The connection is now created.

To create a connection for the OLE DB Source we do the following:

  1. Right-click in the Connection Managers pane and then click New OLE DB Connection. The Configure OLE DB Connection Manager dialog box is displayed.
  2. Click New. The Connection Manager dialog box is displayed; fill in the connection settings as required, e.g. as follows:

    Click OK.

  3. Click OK in the Configure OLE DB Connection Manager dialog box.

The connection for the OLE DB source is now created.

Note Note:

If you create an Integration Services package in BIDS 2008, you will need to do additional actions to open the Configure OLE DB Connection Manager dialog box instead of simply selecting New OLE DB Connection from the shortcut menu. To be more specific, you will need to right-click in the Connection Managers pane and then click New Connection instead of New OLE DB Connection, as the latter is not present in BIDS 2008. After this, the Add SSIS Connection Manager dialog box is displayed. In the Connection manager type list select OLEDB and click Add. Then the Configure OLE DB Connection Manager dialog box is displayed, and after this you need to perform the steps above.

After the two required connections are created, we can proceed to customizing the data flow items.

For the sake of this example, we will also create a variable, for this:

  1. Right-click the design surface and in the context menu select the Variables item.

    The Variables tool window is displayed.

  2. Click the Add Variable button in the toolbar of the Variables tool window.
  3. A new variable is created and displayed in the tool window. Rename it as required, then go to the Properties tool window and set the variable properties.

    In this example we call the variable 'myvar' and set the following properties:

    • ValueType = Int32
    • Value = 7007

    other properties are left set to their default values.

Now we proceed to customizing the Devart Oracle Source.

Double-click the Devart Oracle Source data flow object.

The Devart Oracle Source Editor dialog box is displayed.

Drag the required table (in our example we use the Products table from the dotConnect for Oracle sample crm_demo database) from the Oracle Objects area to the Query area:

Then we add a WHERE clause and drag the variable we have previously created from the User node of the Variables area to the Query area, thus we get the following query:

Click the Preview Data button to view the result of the query execution. The Preview Data window is displayed:

Click Close to return to the Devart Oracle Source Editor dialog box.

In the editor dialog box click OK.

If all options are set correctly, the red marker on the data flow object disappears.

Drag the OLE DB Destination data flow object to the design area.

Connect the two data flow objects with a Data Flow path.

Proceed to customizing the OLE DB Destination.

Right-click the OLE DB Destination data flow object. The Connection Manager tab of the OLE DB Destination Editor dialog box is displayed.

Specify the following settings in this tab:

  • Select the required connection in the OLE DB connection manager drop-down list;
  • Select Table or View in the Data access mode drop-down list;
  • Select the required database object name in the Name of the table or the view drop-down list.

Switch to the Mappings tab.

This tab displays mapping defined automatically by SSIS on the basis of the column name correspondence. If necessary, specify mapping between the source and destination columns either using the Input Columns drop-down lists, or just by drawing lines between the corresponding columns:

Switch to the Error Output tab.

This tab allows you to specify in what way component failure should be treated; the following options are available: Fail component, Redirect row, Ignore failure.

After all options are set, click OK.

Make sure that the red marker is absent on the OLE DB Destination data flow object.

Right-click the design area and select Execute Task in the context menu. The green color of the data flow objects indicates that the data flow process is completed successfully:

See Also

Source Overview


Loading Data to Oracle

Loading Data to Oracle
support@devart.com

This tutorial requires SQL Server 2012 and Microsoft SQL Server Integration Services Designer. A similar Integration Services package can be created with SQL Server 2008 and BIDS 2008; however, there may be some differences, mostly in using the Toolbox. In BIDS 2008, dotConnect for Oracle SSIS Data Flow components are not added to the Toolbox by default. You need to add them yourself as described in SSIS Data Flow Components Installation in BIDS 2008. The names of the Toolbox tabs are also different in BIDS 2008 and Microsoft SQL Server Integration Services Designer.

For the purpose of this tutorial, we create an OLE DB Source and a Devart Oracle Destination.

In the Control Flow tab, from the Control Flow Items tab in the Toolbox, drag Data Flow Task to the design area. The Data Flow Task is created.

Switch to the Data Flow tab. From the Other Sources tab of the Toolbox drag the OLE DB Source to the design area.

From the Common tab of the Toolbox drag Devart Oracle Destination to the design area. (By default dotConnect for Oracle SSIS Data Flow components are added to the Common tab when installing dotConnect for Oracle.)

Connect the two data flow objects with a Data Flow path.

For this example we need two connections - one for the OLE DB Source, the other one for the Devart Oracle Destination. To create a connection to Oracle, do the following:

  1. Right-click in the Connection Managers pane and select New Connection from the context menu. The Add SSIS Connection Manager dialog box is displayed:

  2. In the Connection manager type list select DevartOracle and click Add. The General tab of the Oracle Connection Manager Editor dialog box is displayed:

  3. Specify the connection parameters.

    1. If you connect through OCI, in the Server property type TNS alias of the server.
    2. If you use Direct mode, perform the following assignments:
      • set Direct to true
      • in the Server property type DNS name or IP address of the computer where Oracle server resides
      • in the Sid property type service name
      • In the Port property specify the port that the server listens to (usually this is 1521).

    In our tutorial we create a Direct mode connection that does not require Oracle Client.

The connection is now created.

To create a connection for the OLE DB Source we do the following:

  1. Right-click in the Connection Managers pane and then click New OLE DB Connection. The Configure OLE DB Connection Manager dialog box is displayed.
  2. Click New. The Connection Manager dialog box is displayed; fill in the connection settings as required, e.g. as follows:

    Click OK.

  3. Click OK in the Configure OLE DB Connection Manager dialog box.

The connection for the OLE DB source is now created.

Note Note:

If you create an Integration Services package in BIDS 2008, you will need to do additional actions to open the Configure OLE DB Connection Manager dialog box instead of simply selecting New OLE DB Connection from the shortcut menu. To be more specific, you will need to right-click in the Connection Managers pane and then click New Connection instead of New OLE DB Connection, as the latter is not present in BIDS 2008. After this, the Add SSIS Connection Manager dialog box is displayed. In the Connection manager type list select OLEDB and click Add. Then the Configure OLE DB Connection Manager dialog box is displayed, and after this you need to perform the steps above.

After the two required connections are created, we can proceed to customizing the data flow items.

In the Data Flow design area, double-click the OLE DB Source data flow item.

The Connection Manager tab of the OLE DB Source Editor dialog box is displayed.

Specify the following settings in this tab:

  • Select the required connection in the OLE DB connection manager drop-down list;
  • Select the Data access mode, e.g. SQL command;
  • Enter the required query in the SQL command text field.

Switch to the Columns tab.

Configure the properties used by the data flow to obtain data from the OLE DB typer:

  • Select the required columns in the Available External Columns box;
  • Configure Output Column names, if necessary.

Switch to the Error Output tab.

This tab allows you to specify in what way component failure should be treated; the following options are available: Fail component, Redirect row, Ignore failure.

After all options are set, click OK.

If all options are set correctly, the red marker on the data flow object disappears.

Proceed to customizing the Devart Oracle Destination data flow object.

Double-click the Devart Oracle Destination in the design area. The Connection Managers tab of the Advanced Editor for Devart Oracle Destination dialog box is displayed.

Select the Devart Oracle Connection Manager in the Connection Manager drop-down list and go to the Component Properties tab.

Here you can customize the data flow component properties. Pay attention to Custom properties. In addition to the Insert operation, Devart Oracle Destination supports Update, Delete, and high-performance BulkInsert operation.

Go to the Column Mappings tab.

This tab displays mapping defined automatically by SSIS on the basis of the column name correspondence. If necessary, the default mapping can be changed in this tab according to your needs. For this, use the Input Column drop-down lists, or just draw connecting lines between the required column names.

After mapping is defined, switch to the following Input and Output Properties tab.

In this tab you can review input and output properties of the data flow component. Click OK.

Make sure that the red marker is absent on the Devart Oracle Destination data flow object.

Right-click the design area and select Execute Task in the context menu. The green color of the data flow objects indicates that the data flow process is completed successfully:

See Also

Destination Overview | Loading Data from Oracle


SQL Server Import and Export Wizard Tutorial

SQL Server Import and Export Wizard Tutorial
support@devart.com

This tutorial describes how to create a simple Integration Services package that imports a table from an Oracle server to SQL Server using SQL Server Import and Export Wizard for further operations such as analysis or reporting.

For dotConnect for Oracle this tutorial is considered outdated. dotConnect for Oracle offers its own Source and Destination components with advanced features, and we recommend using these components instead.

SQL Server Integration Services - diagram

In this walkthrough:

  • Requirements
  • Creating the Integration Services Project
  • Running the Wizard to Create the Basic Package
  • Creating a Oracle Connection in the IDE
  • Fine-tuning Type Mapping
  • Additional Information

Requirements

The tutorial requires SQL Server 2008 or 2012 installed on the computer. In order to connect to Oracle server you need the server itself running, dotConnect for Oracle installed and Business Intelligence Development Studio running. Note that Business Intelligence Solutions support is only available in Professional and Developer Editions of dotConnect for Oracle.

Creating the Integration Services Project

  1. On the Start menu, point to All Programs, point to Microsoft SQL Server, and click SQL Server Business Intelligence Development Studio.

  2. On the File menu, point to New, and click Project to create a new Integration Services project.

  3. In the New Project dialog box, select Integration Services Project in the Templates pane.

  4. Click OK.

    New Project dialog box

Running the Wizard to Create the Basic Package

  1. In Project menu, click the SSIS Export and Import Wizard item.

  2. On the Welcome page of the SQL Server Import and Export Wizard, click Next.

  3. On the Choose a Data Source page, select Devart dotConnect for Oracle as Data source and provide connection settings for your server, click Next. If the connection settings are incorrect, the wizard shows a warning and does not advance to the next step.

    SQL Server Import and Export Wizard - Choose a Data Source

  4. On the Choose Destination page, provide connection settings for your SQL Server instance:

    SQL Server Import and Export Wizard - Choose a Destination

  5. On the Specify Table Copy or Query page, click Write a query to specify the data to transfer. The other option, Copy data from one or more tables or views, allows you to transfer several database objects at once, but for the purpose of this tutorial we will demonstrate flexibility of queries used in the wizard. Click Next.

    SQL Server Import and Export Wizard - Specify Table Copy or Query

  6. On the Provide a Source Query page, in the SQL statement box, type or copy the following SQL statement:

    SELECT
  "CompanyName",
  "FirstName",
  "LastName",
  "MobilePhone"
FROM
  "Company", "Person Contact"
WHERE
  "Person Contact"."CompanyID" = "Company"."CompanyID"

    This query is based on tables from the CRM Demo sample project shipped with dotConnect for Oracle. You can use any query you find suitable.

    Click Next.

  7. On the Select Source Tables and Views page, click [dbo].[Query], and then change the table name, Query, to Companies. Optionally, you can edit column metadata and table options. To do it, click Edit Mappings.

  8. On the the next page the wizard informs you about type conversion status and possible problems. You can safely ignore warnings about missing files, if any. Click Next.

  9. On the final screen, view the actions that the wizard performs. When finished, the Status column for each action should display "Success".

    SQL Server Import and Export Wizard - The execution was successful

  10. Click Close.

This creates a new package named Package.dtsx. Now you can save it and run to test the functionality of the package. Once executed in Business Intelligence Development Studio, the package should look as follows:

Pacjkage designer - Data Flow

The wizard can be launched as a standalone tool from the Start menu: Microsoft SQL Server 2008 | Import and Export Data (or Microsoft SQL Server 2012 | Import and Export Data). In this case the wizard includes additional steps that allow you to run the package immediately or save it.

Creating a Oracle Connection in the IDE

You can also create an Oracle connection in the Connection Managers pane of Business Intelligence Development Studio. This allows you to use Oracle connectivity in the packages when editing them. To create a new Oracle connection follow these steps:

  1. Right-click in the Connection Managers pane, choose New ADO.NET Connection.

  2. In the Configure ADO.NET Connection Manager dialog, click New....

    Configure ADO.NET Connection Manager dialog box

  3. Click on the Provider list, choose dotConnect for Oracle, click OK.

  4. In the Connection Parameters group, provide the connection settings. If you need some advanced settings of dotConnect for Oracle, click the All button to the left.

    Connection Manager dialog box

  5. Click OK.

  6. Make sure that the line with your User Id is selected in the Data connections list and click OK.

  7. Notice the new item in the Connection Managers pane.

Fine-Tuning Type Mapping

dotConnect for Oracle is seamlessly integrated with SQL Server 2008/2012 Business Intelligence Solutions, and most of the connectivity options are available in design time. One issue that might require attention is type mapping between Oracle, SQL Server, and Integration Services. dotConnect for Oracle initially configures type mapping with reasonable defaults, so in most cases no adjustments are required. Should you need to change the default type mapping, you can do it in the following files:

  • OracleToMSSql10.xml
  • OracleToSSIS10.xml
  • MSSQLToOracle.xml
  • SSISToOracle.xml

The default location of these files is
\Program Files\Microsoft SQL Server\100\DTS\MappingFiles\

Additional Information

SQL Server Business Intelligence Solutions is a platform well documented by Microsoft, so you might find some useful information in MSDN:

  • SQL Server Integration Services
  • Integration Services Videos (SQL Server 2008)


Sync Framework Tutorial

Sync Framework Tutorial
support@devart.com
Note Note:
This topic is applicable only for full .NET Framework.

Microsoft Sync Framework is a data synchronization platform, allowing data synchronization between any applications, services or devices regardless of the network used and data source type. To allow data source agnostic synchronization, Sync Framework uses synchronization providers for connecting to each of the data sources. Sync Framework database synchronization providers, similar to ADO.NET providers, allow other Sync Framework components to work without the need to concern on the underlying database implementation.

Note that Sync Framework is supported only in the Professional and Developer Editions of dotConnect for Oracle.

  • Sync Framework Support Overview
  • Sample Application
  • Database Provisioning
    • Creating Synchronization Scope without Filter
    • Creating Synchronization Scope with Filter
    • Creating Synchronization Scope with Filter Based on Template
  • Synchronization
    • Provisioning Production Database
    • Synchronization
  • Database Deprovisioning
    • Deprovisioning Synchronization Scope
    • Deprovisioning Template
    • Deprovisioning Storage

Sync Framework Support Overview

Sync Framework architecture allows clients both to synchronize data via the central server or to exchange data directly. The following main classes are used for data synchronization:

  • SyncOrchestrator - creates and manages synchronization sessions. This class is provided by Sync Framework.
  • DbSyncProvider - implements the synchronization service for interaction with a database and shields SyncOrchestrator from the specific implementation of the database. dotConnect for Oracle provides its own OracleSyncProvider class implementation for Oracle database.
  • DbSyncAdapter - maintains the interaction between the DbSyncProvider and the database. This class is provided by Sync Framework.

To include database data to synchronization, first you need to provision the database. Provisioning means the creation of Sync Framework auxiliary tables, stored procedures, functions, and triggers for tracking data changes in the specified synchronization scope - a table or a group of tables to synchronize data from. Both databases being synchronized must be provisioned in order to synchronise data.

OracleSyncScopeProvisioning is the key class for performing database provisioning. It allows provisioning a synchronization scope. We will describe the provisioning and synchronization scopes in more details in our tutorial below.

After the provisioning, the databases can be synchronised. When synchronizing databases, you may retrieve synchronization operation statistics. It includes the time synchronization took, the number of processed changes and failed changes.

In case there is no need to synchronise a database or any specific scope any more, the database (or scope) can be deprovisioned. This means deleting of the unneeded Sync Framework database objects and/or data. User tables and data are retained. dotConnect for Oracle offers the OracleSyncScopeDeprovisioning class for scope deprovisioning.

The parent class of the OracleSyncProvider class is the descendant of the standard Sync Framework DbSyncProvider class. Other synchronization classes of dotConnect for Oracle are not inherited from the standard Sync Framework classes, but provide the same interface.

Sample Application

For this tutorial you need Visual Studio 2008 or higher, and Sync Framework 2.1.

In our tutorial we will synchronize two databases with identical structure. Let's call them the development database and the production database. We will use a simple database of one table "Product" for our tutorial. Here is its script:

CREATE table "Products"
  (
  "Id" INT NOT NULL PRIMARY KEY,
  "Name" VARCHAR2(100),
  "CategoryId" INT,
  "IsAvailable" NUMBER(1)
  );

INSERT ALL
  INTO "Products"  VALUES (1, 'HP 2000-2b19WM ', 1, 1)
  INTO "Products"  VALUES (2, 'Dell Adamo XPS', 1, 0)
  INTO "Products"  VALUES (3, 'DELL LAPTOP I14Z', 1, 1)
  INTO "Products"  VALUES (4, 'HP DC5750 Desktop Computer Dual Core/ ', 2, 1)
  INTO "Products"  VALUES (5, 'Apple iMac All In One', 2, 0)
  INTO "Products"  VALUES (6, 'Sharp - AQUOS - ', 3, 1)
  INTO "Products"  VALUES (7, 'Samsung ST76', 4, 1)
  INTO "Products"  VALUES (8, 'Canon PowerShot', 4, 1)
  INTO "Products"  VALUES (9, 'Olympus OM-D E-M5', 4, 1)
  SELECT * FROM dual;

If you want to configure data synchronization for a new database, and its tables are not created yet, they can be automatically generated during the provisioning. However, in our tutorial we will create them manually.

Create a new console application in Visual Studio. It could be any other project type as well, but for simplicity's sake we'll use console project throughout the tutorial.

Add the references to the following assemblies to your project:

  • Devart.Data.Synchronization
  • Devart.Data.Oracle.Synchronization
  • Microsoft.Synchronization Version 2.1
  • Microsoft.Synchronization.Data Version 3.1
  • Devart.Data.Oracle

Database Provisioning

The first step of the synchronization is database provisioning. We will start from the development database and demonstrate different provisioning scenarios. Provisioning includes defining the synchronization scope and creating the necessary database objects.

The synchronization scope is one or more tables (with the specified columns to synchronize) that will be synchronized as a whole. The synchronization scope can include all columns in a table or just a subset of them. It can include all rows or only the rows that match some filter condition. You also can create a template for filters (a condition including a variable), and then create multiple synchronization scopes using filters based on this template.

When creating a synchronization scope, you must create descriptions for the tables of this scope. The synchronization scope tables can either already exist in the database, or they be created during the database provisioning based on their descriptions.

Creating Synchronization Scope without Filter

You can create table descriptions in two ways. The first way is to create the description manually, and the second is to use the OracleSyncDescriptionBuilder class to generate the description based on an existing database table. Since the tables are already created, we will use the second option.

Add the following code to the Main method:

C#csharp Copy Code

      // Specify the connection to development database. Replace the sample connection string with your one.
      OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      // Define the scope, named ProductsScope
      DbSyncScopeDescription scopeDesc = new DbSyncScopeDescription("ProductsScope");

      // Retrive the description for the Products table from the database
      DbSyncTableDescription tableDesc = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection);

      // Add the table description to the scope definition
      scopeDesc.Tables.Add(tableDesc);

      // Create the scope
      OracleSyncScopeProvisioning devProvision = new OracleSyncScopeProvisioning(devConnection, scopeDesc);

      // Start the provision
      devProvision.Apply();
Visual Basic Copy Code
      ' Specify the connection to development database. Replace the sample connection string with your one.
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      ' Define the scope, named ProductsScope
      Dim scopeDesc As New DbSyncScopeDescription("ProductsScope")

      ' Retrive the description for the Products table from the database
      Dim tableDesc As DbSyncTableDescription = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection)

      ' Add the table description to the scope definition
      scopeDesc.Tables.Add(tableDesc)

      ' Create the scope
      Dim devProvision As New OracleSyncScopeProvisioning(devConnection, scopeDesc)

      ' Start the provision
      devProvision.Apply()

After executing this code, Sync Framework creates the following database objects in the database:

  • schema_version table - contains the information on the version of Sync Framework that provisioned the database.
  • scope_info table - contains the list of all the provisioned scopes.
  • scope_config table - contains scope configuration information.
  • products_tracking the table with metadata of the provisioned table "products".
  • Stored procedures and functions for selecting/inserting the updated strings and metadata updates.
  • Insert/update/delete triggers for tracking changes in the provisioned table.

Creating Synchronization Scope with Filter

Now we will demonstrate creating synchronization scope with a filter. The filter is just a SQL WHERE condition that allows synchronizing not all the data of a table, but only the rows that meets certain condition. This filter condition is added to the selectchanges procedure that gets the changed data.

The following code creates the synchronization scope with the filter.

C#csharp Copy Code

      //Specify connection to dev database
      OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      DbSyncScopeDescription devScope = new DbSyncScopeDescription("DevCategoryScope");
      DbSyncTableDescription tableDesc = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection);
      devScope.Tables.Add(tableDesc);

      SyncScopeProvisioning devProvision = new OracleSyncScopeProvisioning(devConnection, devScope);

      //Specify filter clause
      devProvision.Tables["Products"].AddFilterColumn("CategoryId");

      devProvision.Tables["Products"].FilterClause = "t.CategoryId = 1";

      //Skip create Sync Framework objects because we have already created them on the previous step
      devProvision.SetCreateTableDefault(DbSyncCreationOption.Skip);
      //Create new selectchanges procedure for our scope
      devProvision.SetCreateProceduresForAdditionalScopeDefault(DbSyncCreationOption.Create);

      devProvision.Apply();
Visual Basic Copy Code
      'Specify connection to dev database
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      Dim devScope As New DbSyncScopeDescription("DevCategoryScope")
      Dim tableDesc As DbSyncTableDescription = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection)
      devScope.Tables.Add(tableDesc)

      Dim devProvision As SyncScopeProvisioning = New OracleSyncScopeProvisioning(devConnection, devScope)

      'Specify filter clause
      devProvision.Tables("Products").AddFilterColumn("CategoryId")

      devProvision.Tables("Products").FilterClause = "t.CategoryId = 1"

      'Skip create Sync Framework objects because we have already created them on the previous step
      devProvision.SetCreateTableDefault(DbSyncCreationOption.Skip)
      'Create new selectchanges procedure for our scope
      devProvision.SetCreateProceduresForAdditionalScopeDefault(DbSyncCreationOption.Create)

      devProvision.Apply()

The AddFilterColumn call specifies the column from the provisioned table, that will be used in the filter and must be added to the tracking table. FilterClause specifies the condition. Note that we use the alias t when specifying the condition. This alias refers to the tracking table.

After this code is executed, the specified filter column is added to the products_tracking tracking table. An updated products_insert trigger will set values to this column. Sync Framework also creates the stored procedure for selecting changes with the specified filter applied.

Creating Synchronization Scope with Filter Based on Template

Creating a filter template is similar to creating a synchronization scope with a filter. The difference is that the filter condition uses a parameter instead of value. You can then create multiple synchronization scopes based on this template by supplying a value that will substitute this parameter in the filter condition. The template itself cannot be used for synchronization.

For example, in our tutorial we will create an IsAvailableTemplate template with the condition "t.Available = f_Available" where f_Available is a parameter of a boolean type. We will create two synchronization scopes by providing values for this parameter. They will be the AvailableScope scope with f_Available = true and NotAvailableScope with f_Available = false.

Here is the code for creating the template:

C#csharp Copy Code
      OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      // Create a template named "IsAvaibleTemplate"
      DbSyncScopeDescription scopeDesc = new DbSyncScopeDescription("IsAvaibleTemplate");

      // Definition for tables.
      DbSyncTableDescription productsDescription =
          OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection);
      scopeDesc.Tables.Add(productsDescription);

      SyncScopeProvisioning templateProvisioning = new OracleSyncScopeProvisioning(devConnection, scopeDesc, SyncScopeProvisioningType.Template);

      templateProvisioning.Tables[0].AddFilterColumn("IsAvailable");
      templateProvisioning.Tables[0].FilterClause = "t.\"IsAvailable\" = f_available";
      templateProvisioning.Tables[0].FilterParameters.Add(new OracleParameter("f_available", OracleDbType.Number, 1));

      templateProvisioning.SetCreateProceduresForAdditionalScopeDefault(DbSyncCreationOption.Create);

      templateProvisioning.Apply();
Visual Basic Copy Code
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      ' Create a template named "IsAvaibleTemplate"
      Dim scopeDesc As New DbSyncScopeDescription("IsAvaibleTemplate")

      ' Definition for tables.
      Dim productsDescription As DbSyncTableDescription = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", devConnection)
      scopeDesc.Tables.Add(productsDescription)

      Dim templateProvisioning As SyncScopeProvisioning = New OracleSyncScopeProvisioning(devConnection, scopeDesc, SyncScopeProvisioningType.Template)

      templateProvisioning.Tables(0).AddFilterColumn("IsAvailable")
      templateProvisioning.Tables(0).FilterClause = "t.""IsAvailable"" = f_available"
      templateProvisioning.Tables(0).FilterParameters.Add(New OracleParameter("f_available", OracleDbType.Number, 1))

      templateProvisioning.SetCreateProceduresForAdditionalScopeDefault(DbSyncCreationOption.Create)

      templateProvisioning.Apply()

After executing this code, the new selectchanges procedure will contain the parameter in the filtering condition.

And now let's create synchronization scopes based on the template. To create such scope, you need to call the PopulateFromTemplate method and pass the new scope name, the name of the template, and the value of the filter parameter to it.

C#csharp Copy Code
       OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      // Create a synchronization scope
       OracleSyncScopeProvisioning devProvAvailable = new  OracleSyncScopeProvisioning(devConnection);

      // Populate the scope description from template
      devProvAvailable.PopulateFromTemplate("AvaibleScope", "IsAvaibleTemplate");

      // Set value to the parameter
      devProvAvailable.Tables["Products"].FilterParameters["f_available"].Value = true;

      // Set description for template.
      devProvAvailable.UserComment = "Scope for available products";

      devProvAvailable.Apply();
Visual Basic Copy Code
      Dim devConnection As New  OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      ' Create a synchronization scope
      Dim devProvAvailable As New  OracleSyncScopeProvisioning(devConnection)

      ' Populate the scope description from template
      devProvAvailable.PopulateFromTemplate("AvaibleScope", "IsAvaibleTemplate")

      ' Set value to the parameter
      devProvAvailable.Tables("Products").FilterParameters("f_available").Value = True

      ' Set description for template.
      devProvAvailable.UserComment = "Scope for available products"

      devProvAvailable.Apply()

The code for creating the NotAvaibleScope is almost the same, just change the scope name and the filter parameter value.

Creating Synchronization Scope with Subset of Columns of Existing Table

Here is an example of creating synchronization scope for synchronizing data in only a subset of table columns.

C#csharp Copy Code
      OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      // Define scope with name ProductsScope"
      DbSyncScopeDescription scopeDesc = new DbSyncScopeDescription("ProductsScopeWithColumnSpec");

      // Specify the list of columns of the Products Table to include
      Collection<string> columnsToInclude = new Collection<string>();
      columnsToInclude.Add("Id");
      columnsToInclude.Add("Name");
      columnsToInclude.Add("CategoryId");
      columnsToInclude.Add("Available");

      // Retrive description for Products with specified columns from database
      DbSyncTableDescription tableDesc =
          OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", columnsToInclude, devConnection);

      // add the table description to the sync scope definition
      scopeDesc.Tables.Add(tableDesc);

      // create a development scope provisioning object based on the OrdersScope
      OracleSyncScopeProvisioning devProvision = new OracleSyncScopeProvisioning(devConnection, scopeDesc);

      // start the provision
      devProvision.Apply();
Visual Basic Copy Code
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      ' Define scope with name ProductsScope"
      Dim scopeDesc As New DbSyncScopeDescription("ProductsScopeWithColumnSpec")

      ' Specify the list of columns of the Products table to include
      Dim columnsToInclude As New Collection(Of String)()
      columnsToInclude.Add("Id")
      columnsToInclude.Add("Name")
      columnsToInclude.Add("CategoryId")
      columnsToInclude.Add("Available")

      ' Retrive description for Products with specified columns from database
      Dim tableDesc As DbSyncTableDescription = OracleSyncDescriptionBuilder.GetDescriptionForTable("Products", columnsToInclude, devConnection)

      ' add the table description to the sync scope definition
      scopeDesc.Tables.Add(tableDesc)

      ' create a development scope provisioning object based on the OrdersScope
      Dim devProvision As New OracleSyncScopeProvisioning(devConnection, scopeDesc)

      ' start the provision
      devProvision.Apply()

Synchronization

To synchronize databases you need first to provision the Production database, and then to actually synchronize the databases.

Provisioning Production Database

When provisioning the production database, the DbSyncScopeDescription class is used to specify the synchronization scope name and tables to synchronize. The latter can be either specified explicitly or retrieved from the already provisioned development database.

C#csharp Copy Code
     OracleConnection productionConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraProd");
     OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

     //Get definition for ProductsScope from dev
     DbSyncScopeDescription scopeDescription = OracleSyncDescriptionBuilder.GetDescriptionForScope("DevCategoryScope", devConnection);

     //Provise production using this definition
     SyncScopeProvisioning productionProvisioning = new OracleSyncScopeProvisioning(productionConnection, scopeDescription);

      productionProvisioning.Apply();
Visual Basic Copy Code
     Dim productionConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraProd")
     Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

     'Get definition for ProductsScope from dev
     Dim scopeDescription As DbSyncScopeDescription = OracleSyncDescriptionBuilder.GetDescriptionForScope("DevCategoryScope", devConnection)

     'Provise production using this definition
     Dim productionProvisioning As SyncScopeProvisioning = New OracleSyncScopeProvisioning(productionConnection, scopeDescription)

     productionProvisioning.Apply()

Synchronization

Synchronization is performed via the SyncOrchestrator class. You need to assign the synchronization provider instances to its RemoteProvider and LocalProvider properties and then run its Synchronize method.

C#csharp Copy Code
      OracleConnection productionConnection = new  OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraProd");
      OracleConnection devConnection = new  OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      SyncOrchestrator syncOrchestrator = new SyncOrchestrator();

      //Specify source database
      syncOrchestrator.RemoteProvider = new OracleSyncProvider("DevCategoryScope", devConnection, null, null);

      //Specify production database
      syncOrchestrator.LocalProvider = new OracleSyncProvider("DevCategoryScope", productionConnection, null, null);

      syncOrchestrator.Synchronize();
Visual Basic Copy Code
      Dim productionConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraProd")
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      Dim syncOrchestrator As New SyncOrchestrator()

      'Specify source database
      syncOrchestrator.RemoteProvider = New OracleSyncProvider("DevCategoryScope", devConnection, Nothing, Nothing)

      'Specify production database
      syncOrchestrator.LocalProvider = New OracleSyncProvider("DevCategoryScope", productionConnection, Nothing, Nothing)

      syncOrchestrator.Synchronize()

Database Deprovisioning

When deprovisioning the database, the objects, created by Sync Framework, that are not used any more are deleted. If there is at least one scope that still uses these objects, they will not be deleted. User database objects are not deleted at all. You can deprovision a provisioned scope, a template with all scopes built on it, or the whole database.

Deprovisioning Synchronization Scope

To deprovision a single synchronization scope you need to create a OracleSyncScopeDeprovisioning object and execute its DeprovisionScope method, which accepts the scope name as its parameter.

Deprovisioning Template

Template deprovisioning deletes the template and all the synchronization scopes, based on this template. The DeprovisionTemplate method of OracleSyncScopeDeprovisioning is used to deprovision a template.

C#csharp Copy Code
      OracleConnection devConnection = new OracleConnection(@"User Id=Scott;Password=tiger;Data Source=OraDev");

      // Remove the "IsAvaibleTemplate" template from the dev database.
      OracleSyncScopeDeprovisioning templateDeprovision = new OracleSyncScopeDeprovisioning(devConnection);

      // Remove the scope.
      templateDeprovision.DeprovisionTemplate("IsAvaibleTemplate");
Visual Basic Copy Code
      Dim devConnection As New OracleConnection("User Id=Scott;Password=tiger;Data Source=OraDev")

      ' Remove the "IsAvaibleTemplate" template from the dev database.
      Dim templateDeprovision As New OracleSyncScopeDeprovisioning(devConnection)

      ' Remove the scope.
      templateDeprovision.DeprovisionTemplate("IsAvaibleTemplate")

Deprovisioning Storage

Storage deprovisioning removes all the templates, synchronization scopes, and all the Sync Framework database objects in the connection schema. The DeprovisionStore method is used for storage deprovisioning.

See Also

Entity Framework section | Entity Framework Support Overview


Workflow Foundation Support

Workflow Foundation Support
support@devart.com

This section describes dotConnect for Oracle integration with Windows Workflow Foundation.

  • Oracle Workflow Instance Store

    This topic describes how to configure the Oracle Workflow Instance Store to enable persistence for your workflows.

  • Workflow Tracking Support

    This topic describes how to use our OracleTrackingParticipant class that stores workflow TrackingRecord objects in the Oracle database.

See Also

Development Tools and Features | Devart.Data.Oracle Namespace


Oracle Workflow Instance Store

Oracle Workflow Instance Store
support@devart.com

As of version 6.30, dotConnect for Oracle implements Oracle Workflow Instance Store. To use Oracle Workflow Instance Store you need Oracle server 9 or higher.

Before using Oracle Workflow Instance Store, you need to create a database that is used to persist workflow instances. dotConnect for Oracle provides the scripts for creating this database. They are placed to the WF Services subfolder of the dotConnect for Oracle installation folder. By default it is %ProgramFiles%\Devart\dotConnect\Oracle\WF Services\. Note that there are two versions of scripts - for .NET Framework 4.5, and for previous versions of .NET Framework.

If you target .NET Framework 4.5, execute the OracleInstanceStoreSchema45.sql script first and then execute OracleInstanceStoreLogic45.sql. If you target .NET Framework 3.0, 3.5, or 4.0, execute the OracleInstanceStoreSchema.sql script first and then execute OracleInstanceStoreLogic.sql. You may use these scripts to clean up the persistence database to have a fresh database in the same way, just execute them in the same order.

Configuring InstanceStore for Self-Hosted Workflows that use WorkflowApplication

To enable persistence for self-hosted workflows that use WorkflowApplication, perform the following steps:

  1. Add the reference to Devart.Data.Oracle.WorkflowFoundation.dll in your project.

  2. Specify the using directive:

    C#csharp Copy Code
    using Devart.Data.Oracle.DurableInstancing;
    Visual Basic Copy Code
    Imports Devart.Data.Oracle.DurableInstancing

  3. Create OracleInstanceStore and assign the following code to the InstanceStore property of WorkflowApplication:

    C#csharp Copy Code
    OracleInstanceStore store = new OracleInstanceStore(your_connection_string);
WorkflowApplication wfApp = new WorkflowApplication(new Workflow1());
wfApp.InstanceStore = store;
    Visual Basic Copy Code
    Dim store As New OracleInstanceStore(your_connection_string)
Dim wfApp As New WorkflowApplication(New Workflow1())
wfApp.InstanceStore = store
  4. Call the Persist() method on the WorkflowApplication to persist a workflow.

Configuring InstanceStore with OracleInstanceStoreBehavior Class

To enable persistence using the OracleInstanceStoreBehavior class, perform the following steps:

  1. Add a reference to the Devart.Data.Oracle.Activities.Description.dll

  2. Add the following statement at the top of the source file after the existing "using" statements.

    C#csharp Copy Code
    using Devart.Data.Oracle.Activities.Description;
    Visual Basic Copy Code
    Imports Devart.Data.Oracle.Activities.Description

  3. Create an instance of the WorkflowServiceHost and add endpoints for the workflow service.

    C#csharp Copy Code
    WorkflowServiceHost host = new WorkflowServiceHost(new CountingWorkflow(), new Uri(hostBaseAddress));
host.AddServiceEndpoint("ICountingWorkflow", new BasicHttpBinding(), "");
    Visual Basic Copy Code
    Dim host As New WorkflowServiceHost(New CountingWorkflow(), New Uri(hostBaseAddress))
host.AddServiceEndpoint("ICountingWorkflow", New BasicHttpBinding(), "")

  4. Construct an OracleInstanceStoreBehavior object and to set properties of the behavior object.

    C#csharp Copy Code
    OracleInstanceStoreBehavior instanceStoreBehavior = new OracleInstanceStoreBehavior(connectionString);
instanceStoreBehavior.HostLockRenewalPeriod = new TimeSpan(0, 0, 5);
instanceStoreBehavior.InstanceCompletionAction = InstanceCompletionAction.DeleteAll;
instanceStoreBehavior.InstanceLockedExceptionAction = InstanceLockedExceptionAction.AggressiveRetry;
instanceStoreBehavior.InstanceEncodingOption = InstanceEncodingOption.GZip;
instanceStoreBehavior.RunnableInstancesDetectionPeriod = new TimeSpan("00:00:02");
host.Description.Behaviors.Add(instanceStoreBehavior);
    Visual Basic Copy Code
    Dim instanceStoreBehavior As New OracleInstanceStoreBehavior(connectionString)
instanceStoreBehavior.HostLockRenewalPeriod = New TimeSpan(0, 0, 5)
instanceStoreBehavior.InstanceCompletionAction = InstanceCompletionAction.DeleteAll
instanceStoreBehavior.InstanceLockedExceptionAction = InstanceLockedExceptionAction.AggressiveRetry
instanceStoreBehavior.InstanceEncodingOption = InstanceEncodingOption.GZip
instanceStoreBehavior.RunnableInstancesDetectionPeriod = New TimeSpan("00:00:02")
host.Description.Behaviors.Add(instanceStoreBehavior)

  5. Open the workflow service host.

    C#csharp Copy Code
    host.Open();
    Visual Basic Copy Code
    host.Open()

Configuring InstanceStore with Config File

To configure Oracle Instance Store by using the oracleInstanceStore behavior element in a configuration file, perform the following steps:

  1. Add the following behavior extension element to the Machine.config file so that you can use the <oracleInstanceStore> service behavior element in the configuration files of your applications to configure persistence for your services:

    <configuration>
    <system.serviceModel>
        <extensions>
            <behaviorExtensions>
                <add name="oracleInstanceStore" type="Devart.Data.Oracle.Activities.Configuration.OracleInstanceStoreElement, Devart.Data.Oracle.WorkflowFoundation, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
            </behaviorExtensions>
        </extensions>
    </system.serviceModel>
</configuration>

    Note: Replace 8.4.215.0 in the code with your actual version.

  2. Configure Oracle Instance Store by using the oracleInstanceStore behavior element in a configuration file of your application:

    <configuration>
    <system.serviceModel>
      <behaviors>
        <serviceBehaviors>
            <behavior name="">
                <oracleInstanceStore
                    connectionString="User Id=Scott;Password=tiger;Data Source=Ora;"
                    instanceEncodingOption="GZip | None"
                    instanceCompletionAction="DeleteAll | DeleteNothing"
                    instanceLockedExceptionAction="NoRetry | BasicRetry |AggressiveRetry"
                    hostLockRenewalPeriod="00:00:30"
                    runnableInstancesDetectionPeriod="00:00:05" />
            </behavior>
        </serviceBehaviors>
      </behaviors>
    </system.serviceModel>
</configuration>

See Also

Workflow Tracking Support | Development Tools and Features


Workflow Tracking Support

Workflow Tracking Support
support@devart.com

dotConnect for Oracle provides OracleTrackingParticipant class that stores TrackingRecord objects in the Oracle database. Tracking participants are the objects that allow tracking the execution of a workflow instances by subscribing for tracking records that are emitted by the workflow runtime. The tracking participants contain the logic to process the tracking records.

To store tracking records to an Oracle database, first you need to create the schema for storing tracking records. dotConnect for Oracle provides the scripts for creating this database. They are placed to the WF Services subfolder of the dotConnect for Oracle installation folder. By default it is %ProgramFiles%\Devart\dotConnect\Oracle\WF Services\. Execute the OracleTrackingSchema.sql script first and then execute OracleTrackingLogic.sql. You may use these scripts to clean up the persistence database to have a fresh database in the same way, just execute them in the same order.

Configuring InstanceStore with OracleTrackingParticipant class

To use OracleTrackingParticipant class, perform the following steps:

  1. Add the Devart.Data.Oracle.WorkflowFoundation assembly to References of your solution.
  2. Add the following line to your code: "using Devart.Data.Oracle.ActivitiesTracking".
  3. Create a TrackingProfile instance.
  4. Add tracking queries to the profile.
  5. Create an OracleTrackingParticipant instance, passing a connection string as the parameter to its constructor
  6. Assign the tracking profile to the TrackingProfile property of your OracleTrackingParticipant object.
  7. Add the tracking participant to Extensions of your WorkflowApplication.
C#csharp Copy Code
TrackingProfile profile = new TrackingProfile {
  Name = "SampleTrackingProfile",
  ActivityDefinitionId = "*",
};
profile.Queries.Add(new WorkflowInstanceQuery { States = { "*" } });
profile.Queries.Add(new ActivityStateQuery { States = { "*" } });
profile.Queries.Add(new ActivityScheduledQuery());
profile.Queries.Add(new BookmarkResumptionQuery() { Name = "*" });

OracleTrackingParticipant trackingParticipant = new OracleTrackingParticipant("User Id=Scott;Password=tiger;Data Source=Ora;");
trackingParticipant.TrackingProfile = profile;

WorkflowApplication wfApp = new WorkflowApplication(new Workflow1());
wfApp.Extensions.Add(trackingParticipant);

wfApp.Run();
Visual Basic Copy Code
Dim profile As New TrackingProfile() With { _
    Key .Name = "SampleTrackingProfile", _
    Key .ActivityDefinitionId = "*" _
}
profile.Queries.Add(New WorkflowInstanceQuery() With { _
    Key .States = {"*"} _
})
profile.Queries.Add(New ActivityStateQuery() With { _
    Key .States = {"*"} _
})
profile.Queries.Add(New ActivityScheduledQuery())
profile.Queries.Add(New BookmarkResumptionQuery() With { _
    Key .Name = "*" _
})

Dim trackingParticipant As New OracleTrackingParticipant("User Id=Scott;Password=tiger;Data Source=Ora;")
trackingParticipant.TrackingProfile = profile

Dim wfApp As New WorkflowApplication(New Workflow1())
wfApp.Extensions.Add(trackingParticipant)

wfApp.Run()

Configuring Workflow Tracking with Config File

To configure Oracle Tracking by using the oracleTracking behavior element in a configuration file, perform the following steps:

  1. Add the following behavior extension element to the Machine.config file so that you can use the <oracleTracking> service behavior element in the configuration files of your applications to configure persistence for your services:

    <configuration>
    <system.serviceModel>
        <extensions>
            <behaviorExtensions>
                <add name="oracleTracking" type="Devart.Data.Oracle.Activities.Configuration.OracleTrackingElement, Devart.Data.Oracle.WorkflowFoundation, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
            </behaviorExtensions>
        </extensions>
    </system.serviceModel>
</configuration>

    Note: Replace 8.4.215.0 in the code with your actual version.

  2. Configure Oracle Tracking by using the oracleTracking behavior element in a configuration file of your application:

    <configuration>
    <system.serviceModel>
     <tracking>
        <profiles>
              <trackingProfile name="Sample Tracking Profile">
                <workflow activityDefinitionId="*">
                  <workflowInstanceQueries>
                        <workflowInstanceQuery>
                          <states>
                            <state name="Started"/>
                            <state name="Completed"/>
                          </states>
                        </workflowInstanceQuery>
                  </workflowInstanceQueries>
                </workflow>
              </trackingProfile>
            </profiles>
      </tracking>
    <behaviors>
        <serviceBehaviors>
                <behavior name="">
              <oracleTracking
                        connectionString="User Id=Scott;Password=tiger;Data Source=Ora;"
                        profileName="Sample Tracking Profile" />
                </behavior>
        </serviceBehaviors>
    </behaviors>
  </system.serviceModel>
</configuration>

Configuring Workflow Tracking with OracleTrackingBehavior Class

To enable tracking using the OracleTrackingBehavior class, perform the following steps:

  1. Add a reference to the Devart.Data.Oracle.WorkflowFoundation.dll.

  2. Add the following statement at the top of the source file after the existing "using" statements.

    C#csharp Copy Code
    using Devart.Data.Oracle.Activities.Description;
    Visual Basic Copy Code
    Imports Devart.Data.Oracle.Activities.Description

  3. Create an instance of the WorkflowServiceHost and add endpoints for the workflow service.

    C#csharp Copy Code
    WorkflowServiceHost host = new WorkflowServiceHost(new CountingWorkflow(), new Uri(hostBaseAddress));
host.AddServiceEndpoint("ICountingWorkflow", new BasicHttpBinding(), "");
    Visual Basic Copy Code
    Dim host As New WorkflowServiceHost(New CountingWorkflow(), New Uri(hostBaseAddress))
host.AddServiceEndpoint("ICountingWorkflow", New BasicHttpBinding(), "")

  4. Construct an OracleTrackingBehavior object and to set properties of the behavior object.

    C#csharp Copy Code
    ServiceHost svcHost = new ServiceHost(typeof(WorkflowService), new
                               Uri("http://localhost:8001/Sample"));
OracleTrackingBehavior trackingBehavior = new OracleTrackingBehavior(connectionString){
     ProfileName = "Sample Tracking Profile"
};
svcHost.Description.Behaviors.Add(trackingBehavior);
    Visual Basic Copy Code
    Dim svcHost As New ServiceHost(GetType(WorkflowService), New Uri("http://localhost:8001/Sample"))
Dim trackingBehavior As New OracleTrackingBehavior(connectionString) With { _
    Key .ProfileName = "Sample Tracking Profile" _
}
svcHost.Description.Behaviors.Add(trackingBehavior)

  5. Open the workflow service host.

    C#csharp Copy Code
    svcHost.Open();
    Visual Basic Copy Code
    svcHost.Open()

Workflow Tracking Information

The OracleTrackingParticipant class stores the workflow tracking information in the created schema. Its tables are described below:

  • wf_tracking_record - contains all tracking records.
  • wf_record_type - maps numeric record type values in wf_tracking_record table to the corresponding type names.
  • wf_annotation - contains annotations for tracking records.
  • wf_instance_record - contains additional information for records of WorkflowInstanceRecord and derived types. This table should be joined with wf_tracking_record table to get all the WorkflowInstanceRecord data.
  • wf_activity_info - contains values from ActivityInfo objects that are used in many record types.
  • wf_unhandled_exception_record - contains additional information for records of WorkflowInstanceUnhandledExceptionRecord type. This table should be joined with wf_tracking_record and wf_instance_record tables.
  • wf_value_collection - contains key/value collections used in tracking record (arguments and variables).
  • wf_value - contains keys and values for each collection in wf_value_collection table.
  • wf_activity_state_record - contains additional information for records of ActivityStateRecord type. This table should be joined with wf_tracking_record table.
  • wf_activity_scheduled_record - contains additional information for records of ActivityScheduledRecord type. This table should be joined with wf_tracking_record table.
  • wf_fault_propagation_record - contains additional information for records of FaultPropagationRecord type. This table should be joined with wf_tracking_record table.
  • wf_cancel_requested_record - contains additional information for records of CancelRequestedRecord type. This table should be joined with wf_tracking_record table.
  • wf_bookmark_resumption_record - contains additional information for records of BookmarkResumptionRecord type. This table should be joined with wf_tracking_record table.
  • wf_custom_tracking_record - contains additional information for records of CustomTrackingRecord type. This table should be joined with wf_tracking_record table

Here is the diagram of this schema:

To retrieve the workflow tracking information, execute queries to these tables. For example, to retrieve all the ActivityStateRecord data for today, use the following query.

SELECT * FROM wf_tracking_record TR
  INNER JOIN wf_activity_state_record SR ON TR.RECORD_ID = SR.RECORD_ID
WHERE TR.event_time >= TRUNC(SYSDATE)

See Also

Oracle Workflow Instance Store | Development Tools and Features


Performance Counters Support

Performance Counters Support
support@devart.com

When developing a data access layer, performance is almost always a crucial factor. In order to provide a wider set tools for analysing performance, dotConnect for Oracle offers support for performance counters that allow you to conveniently measure the frequency of connecting/disconnecting to the data source, the number of active connections, pooled connections, etc.

You can use these performance counters to monitor the connection resources your application uses. They can be monitored in Windows Performance Monitor or accessed programmatically using the PerformanceCounter class.

Activating Performance Counters

Please note that dotConnect for Oracle performance counters are disabled by default in order to not hamper performance. To enable them, set the Use Performance Monitor connection string parameter to true for all your dotConnect for Oracle connections you want to monitor. Only connections with this connection string parameter will be counted.

Available Performance Counters

Currently dotConnect for Oracle offers 12 different performance counters.

Performance counter | Description
HardConnectsPerSecond | The number of dotConnect for Oracle connections per second that are being made to Oracle.
HardDisconnectsPerSecond | The number of dotConnect for Oracle disconnects from Oracle per second.
NumberOfActiveConnectionPools | The total number of dotConnect for Oracle connection pools.
NumberOfActiveConnections | The number of active dotConnect for Oracle connections that currently are in use.
NumberOfFreeConnections | The number of free dotConnect for Oracle connections available for use in the connection pools.
NumberOfInactiveConnectionPools | The number of inactive dotConnect for Oracle connection pools that have not had any recent activity and are waiting to be disposed.
NumberOfNonPooledConnections | The number of active dotConnect for Oracle connections that are not pooled.
NumberOfPooledConnections | The total number of active dotConnect for Oracle connections in connection pools.
NumberOfReclaimedConnections | The number of dotConnect for Oracle connections that have been reclaimed through garbage collection where Close or Dispose was not called by the application. Not explicitly closing or disposing connections hurts performance.
NumberOfStasisConnections | The number of dotConnect for Oracle connections currently awaiting completion of an action and which are therefore unavailable for use by the application.
SoftConnectsPerSecond | The number of active dotConnect for Oracle connections being pulled from the connection pool per second.
SoftDisconnectsPerSecond | The number of active dotConnect for Oracle connections that are being returned to the connection pool per second.

A typical usage of asynchronous methods looks like the following code.

C#csharp Copy Code
IAsyncResult myResult = myCommand.BeginExecuteNonQuery(null, null);
...
rowsAffected = myCommand.EndExecuteNonQuery(myResult);
Visual Basic Copy Code
Dim myResult As IAsyncResult = myCommand.BeginExecuteNonQuery(Nothing, Nothing)
...
Dim rowsAffected As Int32 = myCommand.EndExecuteNonQuery(myResult)

First, application calls the "Begin" method and passes it all the parameters needed to accomplish the task. This method returns IAsyncResult object that represents the operation invoked and is used for later processing. After the process has been invoked, application can proceed to do its job.
Later, when the query has finished its execution, application calls the "End" method, passing it IAsyncResult object returned by the "Begin" method that has been invoked earlier.
If something goes wrong with the query, the exception is thrown only when application calls "End" method.

Completion Signalling

The common synchronous method calls do not return until the operation is finished. In the asynchronous cases, the begin call returns immediately, so there is a need to determine when the operation is actually complete. dotConnect for Oracle provides you with three ways to catch the query termination.

All of the methods listed in the table 1 accept at least two parameters. For example, DbCommandBase.BeginExecuteReader method is declared in the following way:

C#csharp Copy Code
public IAsyncResult BeginExecuteReader(
   AsyncCallback callback,
   object stateObject,
   CommandBehavior behavior
);
Visual Basic Copy Code
Public Function BeginExecuteReader( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object, _
   ByVal behavior As CommandBehavior _
) As IAsyncResult

Samples

C#csharp Copy Code
using Devart.Data.Oracle;
using System;
using System.Diagnostics;
using System.Runtime.InteropServices;

class Program
{
    PerformanceCounter[] PerfCounters = new PerformanceCounter[12];
    OracleConnection connection = new OracleConnection();

    static void Main()
    {
        Program prog = new Program();
        // Open a connection and create the performance counters.
        prog.connection.ConnectionString = GetConnectionString1();
        prog.SetUpPerformanceCounters();
        Console.WriteLine("Available Performance Counters:");

        // Create the connections and display the results.
        prog.CreateConnections();
        Console.WriteLine("Press Enter to finish.");
        Console.ReadLine();
    }

    private void CreateConnections()
    {
        // List the Performance counters.
        WritePerformanceCounters();

        // Create 4 connections and display counter information.
        OracleConnection connection1 = new OracleConnection(
              GetConnectionString1());
        connection1.Open();
        Console.WriteLine("Opened the 1st Connection:");
        WritePerformanceCounters();

        OracleConnection connection2 = new OracleConnection(
              GetConnectionString3());
        connection2.Open();
        Console.WriteLine("Opened the 2nd Connection:");
        WritePerformanceCounters();

        OracleConnection connection3 = new OracleConnection(
              GetConnectionString2());
        connection3.Open();
        Console.WriteLine("Opened the 3rd Connection:");
        WritePerformanceCounters();

        OracleConnection connection4 = new OracleConnection(
              GetConnectionString2());
        connection4.Open();
        Console.WriteLine("Opened the 4th Connection:");
        WritePerformanceCounters();

        connection1.Close();
        Console.WriteLine("Closed the 1st Connection:");
        WritePerformanceCounters();

        connection2.Close();
        Console.WriteLine("Closed the 2nd Connection:");
        WritePerformanceCounters();

        connection3.Close();
        Console.WriteLine("Closed the 3rd Connection:");
        WritePerformanceCounters();

        connection4.Close();
        Console.WriteLine("Closed the 4th Connection:");
        WritePerformanceCounters();
    }

    private enum DC_Ora_Performance_Counters
    {
        NumberOfActiveConnectionPools,
        NumberOfReclaimedConnections,
        HardConnectsPerSecond,
        HardDisconnectsPerSecond,
        NumberOfInactiveConnectionPools,
        NumberOfNonPooledConnections,
        NumberOfPooledConnections,
        NumberOfStasisConnections
        SoftConnectsPerSecond
        SoftDisconnectsPerSecond
        NumberOfActiveConnections
        NumberOfFreeConnections
    }

    private void SetUpPerformanceCounters()
    {
        connection.Close();
        this.PerfCounters = new PerformanceCounter[10];
        string instanceName = GetInstanceName();
        Type apc = typeof(ADO_Net_Performance_Counters);
        int i = 0;
        foreach (string s in Enum.GetNames(apc))
        {
            this.PerfCounters[i] = new PerformanceCounter();
            this.PerfCounters[i].CategoryName = "Devart dotConnect for Oracle";
            this.PerfCounters[i].CounterName = s;
            this.PerfCounters[i].InstanceName = instanceName;
            i++;
        }
    }

    [DllImport("kernel32.dll", SetLastError = true)]
    static extern int GetCurrentProcessId();

    private string GetInstanceName()
    {
        //This works for Winforms apps.
        string instanceName =
            System.Reflection.Assembly.GetEntryAssembly().GetName().Name;

        // Must replace special characters like (, ), #, /, \\
        string instanceName2 =
            AppDomain.CurrentDomain.FriendlyName.ToString().Replace('(', '[')
            .Replace(')', ']').Replace('#', '_').Replace('/', '_').Replace('\\', '_');

        // For ASP.NET applications your instanceName will be your CurrentDomain's
        // FriendlyName. Replace the line above that sets the instanceName with this:
        // instanceName = AppDomain.CurrentDomain.FriendlyName.ToString().Replace('(','[')
        // .Replace(')',']').Replace('#','_').Replace('/','_').Replace('\\','_');

        string pid = GetCurrentProcessId().ToString();
        instanceName = instanceName + "[" + pid + "]";
        Console.WriteLine("Instance Name: {0}", instanceName);
        Console.WriteLine("---------------------------");
        return instanceName;
    }

    private void WritePerformanceCounters()
    {
        Console.WriteLine("---------------------------");
        foreach (PerformanceCounter p in this.PerfCounters)
        {
            Console.WriteLine("{0} = {1}", p.CounterName, p.NextValue());
        }
        Console.WriteLine("---------------------------");
    }

    private static string GetConnectionString1()
    {
        // To avoid storing the connection string in your code,
        // you can retrieve it from a configuration file.
        return @""User Id=Scott;Password=tiger;Data Source=Ora;"" +
          "Use Performance Monitor=True;";
    }
    private static string GetConnectionString2()
    {
        // To avoid storing the connection string in your code,
        // you can retrieve it from a configuration file.
        return @"User Id=Scott;Password=tiger;Server=DBORACLE;Direct=True;Service Name=orcl1110" +
          "Use Performance Monitor=True;";
    }

    private static string GetConnectionString3()
    {
        // To avoid storing the connection string in your code,
        // you can retrieve it from a configuration file.
        return @"User Id=Demobase;Password=test;Data Source=Ora;" +
          "Use Performance Monitor=True;";
    }
}
Visual Basic Copy Code
Option Explicit On
Option Strict On

Imports Devart.Data.Oracle
Imports System.Diagnostics
Imports System.Runtime.InteropServices

Class Program

    Private PerfCounters(9) As PerformanceCounter
    Private connection As OracleConnection = New OracleConnection

    Public Shared Sub Main()
        Dim prog As Program = New Program
        ' Open a connection and create the performance counters.
        prog.connection.ConnectionString = _
           GetConnectionString1()
        prog.SetUpPerformanceCounters()
        Console.WriteLine("Available Performance Counters:")

        ' Create the connections and display the results.
        prog.CreateConnections()
        Console.WriteLine("Press Enter to finish.")
        Console.ReadLine()
    End Sub

    Private Sub CreateConnections()
        ' List the Performance counters.
        WritePerformanceCounters()

        ' Create 4 connections and display counter information.
        Dim connection1 As OracleConnection = New OracleConnection( _
           GetConnectionString1)
        connection1.Open()
        Console.WriteLine("Opened the 1st Connection:")
        WritePerformanceCounters()

        Dim connection2 As OracleConnection = New OracleConnection( _
           GetConnectionString3)
        connection2.Open()
        Console.WriteLine("Opened the 2nd Connection:")
        WritePerformanceCounters()

        Console.WriteLine("Opened the 3rd Connection:")
        Dim connection3 As OracleConnection = New OracleConnection( _
           GetConnectionString)
        connection3.Open()
        WritePerformanceCounters()

        Dim connection4 As OracleConnection = New OracleConnection( _
           GetConnectionString)
        connection4.Open()
        Console.WriteLine("Opened the 4th Connection:")
        WritePerformanceCounters()

        connection1.Close()
        Console.WriteLine("Closed the 1st Connection:")
        WritePerformanceCounters()

        connection2.Close()
        Console.WriteLine("Closed the 2nd Connection:")
        WritePerformanceCounters()

        connection3.Close()
        Console.WriteLine("Closed the 3rd Connection:")
        WritePerformanceCounters()

        connection4.Close()
        Console.WriteLine("Closed the 4th Connection:")
        WritePerformanceCounters()
    End Sub

    Private Enum ADO_Net_Performance_Counters
        NumberOfActiveConnectionPools
        NumberOfReclaimedConnections
        HardConnectsPerSecond
        HardDisconnectsPerSecond
        NumberOfInactiveConnectionPools
        NumberOfNonPooledConnections
        NumberOfPooledConnections
        NumberOfStasisConnections
        SoftConnectsPerSecond
        SoftDisconnectsPerSecond
        NumberOfActiveConnections
        NumberOfFreeConnections
    End Enum

    Private Sub SetUpPerformanceCounters()
        connection.Close()
        Me.PerfCounters(9) = New PerformanceCounter()

        Dim instanceName As String = GetInstanceName()
        Dim apc As Type = GetType(ADO_Net_Performance_Counters)
        Dim i As Integer = 0
        Dim s As String = ""
        For Each s In [Enum].GetNames(apc)
            Me.PerfCounters(i) = New PerformanceCounter()
            Me.PerfCounters(i).CategoryName = "Devart dotConnect for Oracle"
            Me.PerfCounters(i).CounterName = s
            Me.PerfCounters(i).InstanceName = instanceName
            i = (i + 1)
        Next
    End Sub

    Private Declare Function GetCurrentProcessId Lib "kernel32.dll" () As Integer

    Private Function GetInstanceName() As String
        'This works for Winforms apps.
        Dim instanceName As String = _
           System.Reflection.Assembly.GetEntryAssembly.GetName.Name

        ' Must replace special characters like (, ), #, /, \\
        Dim instanceName2 As String = _
           AppDomain.CurrentDomain.FriendlyName.ToString.Replace("(", "[") _
           .Replace(")", "]").Replace("#", "_").Replace("/", "_").Replace("\\", "_")

        'For ASP.NET applications your instanceName will be your CurrentDomain's
        'FriendlyName. Replace the line above that sets the instanceName with this:
        'instanceName = AppDomain.CurrentDomain.FriendlyName.ToString.Replace("(", "[") _
        '    .Replace(")", "]").Replace("#", "_").Replace("/", "_").Replace("\\", "_")

        Dim pid As String = GetCurrentProcessId.ToString
        instanceName = (instanceName + ("[" & (pid & "]")))
        Console.WriteLine("Instance Name: {0}", instanceName)
        Console.WriteLine("---------------------------")
        Return instanceName
    End Function

    Private Sub WritePerformanceCounters()
        Console.WriteLine("---------------------------")
        For Each p As PerformanceCounter In Me.PerfCounters
            Console.WriteLine("{0} = {1}", p.CounterName, p.NextValue)
        Next
        Console.WriteLine("---------------------------")
    End Sub

    Private Shared Function GetConnectionString1() As String
        ' To avoid storing the connection string in your code,
        ' you can retrieve it from a configuration file.
        Return ("User Id=Scott;Password=tiger;Data Source=Ora;" & _
          "Use Performance Monitor=True;")
    End Function

    Private Shared Function GetConnectionString2() As String
        ' To avoid storing the connection string in your code,
        ' you can retrieve it from a configuration file.
        Return ("User Id=Scott;Password=tiger;Server=DBORACLE;Direct=True;Service Name=orcl1110" & _
          "Use Performance Monitor=True;")
    End Function

    Private Shared Function GetConnectionString3() As String
        ' To avoid storing the connection string in your code,
        ' you can retrieve it from a configuration file.
        Return ("User Id=Demobase;Password=test;Data Source=Ora;" & _
          "Use Performance Monitor=True;")
    End Function
End Class

See Also

OracleCommand Class | OracleConnection Class | OracleDataTable Class


ORM Solutions

ORM Solutions
support@devart.com

This section describes support for ORM solutions in dotConnect for Oracle.

  • Entity Framework
  • LinqConnect
  • Entity Developer Overview


Entity Framework

Entity Framework
support@devart.com

This section describes Entity Framework support in dotConnect for Oracle.

  • Entity Framework Support
  • Entity Framework Data Type Mapping
  • Using CHAR(1) mapped to System.Boolean in Entity Framework
  • Entity Framework Tutorial
  • Entity Framework Core Code-First Tutorial
  • Entity Framework Core Database-First Tutorial
  • Entity Framework Canonical Functions
  • Using Entity Data Model Wizard
  • Working with Transactions in Entity Framework
  • Working with Oracle Cursors and Stored Procedures in Entity Framework
  • Generating Database from Model
  • Entity Framework Spatials
  • JSON Support in Entity Framework
  • Entity Framework Provider Configuration


Entity Framework Support

Entity Framework Support
support@devart.com

The latest ADO.NET evolution focuses on raising the level of abstraction from the logical (relational) level to the conceptual (entity) level. For this purpose Microsoft introduces the Entity Framework, designed to simplify data - object conversion and embed data access queries into program code.

The Devart dotConnect product line supports the ADO.NET Entity Framework for the following databases: Oracle, MySQL, PostgreSQL, SQLite, DB2, and the following cloud applications: Salesforce, Dynamics CRM, SugarCRM, Zoho CRM, MailChimp, ExactTarget, Bigcommerce, Magento, QuickBooks, and FreshBooks.

The article consists of the following sections:

  • What is ADO.NET Entity Framework?
  • Entity Framework Support Key Features
  • Using the Entity Data Provider
  • Using the Entity Data Provider with Entity Framework v6
  • Using the Entity Data Provider with Entity Framework Core
  • Deploying an Entity Framework Project
  • Visual Model Creation
  • Limitations
  • Compatibility and Requirements
  • Migration between ADO.NET Entity Data Model (*.edmx) and Devart Entity Model (*.edml)

What is ADO.NET Entity Framework?

The Entity Framework is a set of technologies in ADO.NET that support development of data-oriented software applications. The Entity Framework is designed to enable developers to create data access applications by programming against a conceptual application model instead of programming directly against a relational storage schema. The goal is to decrease the amount of code and maintenance required for data-oriented applications. Entity Framework applications provide the following benefits:

  • Applications can work in terms of a more application-centric conceptual model, including types with inheritance, complex members, and relationships.
  • Applications are freed from hard-coded dependencies on a particular data engine or storage schema.
  • Mappings between the conceptual model and the storage-specific schema can change without changing the application code.
  • Developers can work with a consistent application object model that can be mapped to various storage schemas, possibly implemented in different data sources.
  • Multiple conceptual models can be mapped to a single storage schema.
  • Language-integrated query support provides compile-time syntax validation for queries against a conceptual model.

Entity Framework Support Key Features

  • Conceptual approach to enterprise development
  • High performance
  • Wide support for LINQ to Entities
  • Wide support for EntitySQL
  • Full CRUD (Create, Retrieve, Update, Delete) support
  • Wide support for server data types
  • Capability to use stored procedures when manipulating data
  • Stored procedure import support
  • Visual Studio EDM Wizard support (reverse engineering of database objects to entity model)
  • Visual Studio LightSwitch support
  • Generate Database Wizard (Model-First) support
  • Configurable Code-First CreateDatabase/DatabaseExists/DropDatabase functionality support
  • Support for Code-First Migrations with database-specific features
  • Entity Framework Spatials support
  • Support for database-specific system functions in LINQ to Entities and Entity SQL
  • Full-text search support
  • Batch updates
  • Entity Framework provider configuration

Using the Entity Data Provider

Use of dotConnect for Oracle in the Entity Framework is similar to use of standard SqlClient. Generally it conforms to the following scheme:

  1. Open your project.
  2. Add new item ADO.NET Entity Data Model to your project and specify its name.
  3. Choose Generate from database.
  4. Choose the dotConnect you use as data provider and specify the connection string.
  5. Select tables that are actually used in your project and click Generate to finish the process. If the selected tables contain foreign keys, they will be reflected in the generated models as well.
  6. Specify a name for the model namespace. Note that this name should be different from the database (schema) name.

For your convenience there is a brief Entity Framework Tutorial that you can use to get acquainted with the technology. You can also take a look at Entity Framework samples available with the product, or download separate Entity Framework Query Samples package. The latter is a standard Microsoft demo with added Oracle connectivity.

Using the Entity Data Provider with Entity Framework v6

Since there are no global Entity Framework provider registration for Entity Framework v6, you should register our provider manually in the config file of your project. For this you should add the following line:

<provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices,
Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

to the entityFramework -> providers section.

<entityFramework>
    <providers>
      <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices,
      Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>
</entityFramework>

Note: replace 8.4.215.0 with the actual assembly version.

If it suits for your project, you may omit the exact assembly version:

<entityFramework>
    <providers>
        <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity.EF6" />
    </providers>
</entityFramework>

This section appears in the project config file only after you add the NuGet EntityFramework package either explicitly, by executing the "install-package EntityFramework" command, or implicitly, by adding an Entity Framework v6 model for SQL Server via EDM Wizard.

Using the Entity Data Provider with Entity Framework Core

dotConnect for Oracle currently supports Entity Framework Core. Entity Framework Core is supported only for the Full .NET Framework platform of version 4.5.1 and higher. Dynamic database object creation (tables/FK/PK/indexes/triggers/sequences) based on an Entity Framework model is supported. Database-First via Package Manager Console is not supported.

Please note that only a part of Entity Framework provider configuration settings is supported for Entity Framework Core. Also, not all Entity Framework v6 features are supported because Entity Framework Core does not support a lot of Entity Framework v6 features itself.

In order to use Entity Framework Core you need Visual Studio 2013 or higher.

In order to register an Entity Framework provider and set a connection string, you need to override the OnConfiguring method of your DbContext class descendant.

C#csharp Copy Code
protected override void OnConfiguring(DbContextOptionsBuilder optionsBuilder) {

  optionsBuilder.UseOracle(@"User Id=Scott;Password=tiger;Data Source=Ora;");
}
Visual Basic Copy Code
Protected Overrides Sub OnConfiguring(optionsBuilder As DbContextOptionsBuilder)

    optionsBuilder.UseOracle("User Id=Scott;Password=tiger;Data Source=Ora;")
End Sub

The mapping supported by Entity Framework Core is described in details in the corresponding section of Entity Framework documentation. If you plan to support several data sources for one base Entity Framework model, that is mapped to tables and columns named differently in different data sources, you can use special provider-specific extension methods in fluent mapping in order to support specific mapping for each data source simultaneously. dotConnect for Oracle provides the following extension methods:

  • ForOracleToTable() - specifies the table name.
  • ForOracleHasColumnName() - specifies the column name.
  • ForOracleHasColumnType() - specifies the column type.
  • ForOracleHasName() - specifies the the name of the index and primary key.
  • ForOracleHasConstraintName() - specifies the foreign key.
  • ForOracleHasDefaultValueSql() - specifies the column default value.

Deploying an Entity Framework Project

When deploying Entity Framework projects, it is necessary to:

  1. Check if the required assemblies Devat.Data.dll, Devart.Data.Oracle.dll, and Devart.Data.Oracle.Entity.EF<Version>.dll are available for your application. The <Version> here is the version of Entity Framework used in your application. For Entity Framework v1 the assembly is called Devart.Data.Oracle.Entity.EF1.dll "1", for Entity Framework v4 it is Devart.Data.Oracle.Entity.EF4.dll, for Entity Framework v5 and v6 it is Devart.Data.Oracle.Entity.EF5.dll or Devart.Data.Oracle.Entity.EF6.dll respectively. For Entity Framework Core it is Devart.Data.Oracle.Entity.EFCore.dll. The assembly should reside in the application's folder or in GAC.

  2. If you use Code-First Migrations feature of Entity Framework v4 or Entity Framework v5, you also need to check if the Devart.Data.Oracle.Entity.Migrations.EF<Version>.dll assembly is available for your application. For Entity Framework v6 this assembly is not needed.
  3. If you use Entity Framework Spatials and NetTopologySuite, you also need to check if the Devart.Data.Oracle.Entity.Spatials.EF<Version>.dll assembly is available for your application.
  4. For Entity Framework v1 - v6, you need to inform your environment about the provider factory existence (add the entry to the DbProviderFactories section as it is described above).
<system.data>
  <DbProviderFactories>
    <remove invariant="Devart.Data.Oracle" />
    <add name="dotConnect for Oracle" invariant="Devart.Data.Oracle"
     description="Devart dotConnect for Oracle"
     type="Devart.Data.Oracle.OracleProviderFactory, Devart.Data.Oracle,
       Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
  </DbProviderFactories>
</system.data>

Replace 8.4.215.0 here with your actual version.

You can find the necessary assemblies in the Entity folder in the provider installation folder, in the subfolder, corresponding to the Entity Framework version necessary.

If you are registering the provider in the machine.config file, please take into account the Entity Framework version. Entity Framework v1 - specific applications require an entry in the .NET Framework 2.0 configuration file, and Entity Framework v4 and later - specific applications should be registered in the .NET Framework 4.0 configuration file. For Entity Framework Core there is no need to register the provider in the machine.config file.

You can also read Micrsoft's Deployment Considerations on ADO.NET Entity Framework.

Visual Model Creation

dotConnect for Oracle is tightly integrated with Visual Studio Entity Data Model Wizard for generating model definitions. dotConnect for Oracle also includes several demo projects that show how to use the product in conceptual programming against data.

Moreover, dotConnect providers have a bundled visual ORM model designer - Entity Developer. Entity Developer provides far more advanced model editing functionality than standard Visual Studio EDM Designer. It provides better support for Model-First and Database-First development wider mapping support, and powerful template-based code generation. Visit this webpage for more information on Entity Developer benefits.

dotConnect for Oracle also supports Visual Studio LightSwitch, so you can develop LightSwitch applications with our providers. You can find a tutorial on creating a simple LightSwitch application using dotConnect for Oracle here: Tutorial: How to Connect Visual Studio LightSwitch to Oracle with dotConnect for Oracle Data Provider.

Limitations

We have applied our efforts to support the Entity Framework functionality (and particularly LINQ to Entities) as much as possible for the Oracle Server. And we have successfully implemented most features, but there are some limitations which cannot be overcome:

  • Oracle doesn't have its equivalents for the SQL Server OUTER APPLY and CROSS APPLY constructions (this issue is described at http://msdn.microsoft.com/en-us/library/bb896273.aspx). Microsoft decided not to change the current behaviour. So, users who encounter the mentioned obstacles should re-construct their LINQ-queries.
  • User-defined types, including Oracle objects, array types and nested tables are not supported.

You can get more information at our website.

All the provider documentation: www.devart.com/dotconnect/oracle/docs
The Entity Framework section: www.devart.com/dotconnect/oracle/docs/?EFSupport.html
The blog articles dedicated to Entity Framework: http://blog.devart.com/tag/entity-framework

Compatibility and Requirements

dotConnects for Oracle, MySQL, PostgreSQL, SQLite, and DB2 are compatible with the latest version of ADO.NET Entity Framework and Visual Studio. The following server versions are required for Entity Framework to function properly:

  • Oracle: 9.2.0.4 or higher
  • MySQL: 5.0 or higher
  • PostgreSQL: 8.0 or higher
  • SQLite: any supported version
  • DB2: 9 and higher

Migration between ADO.NET Entity Data Model (*.edmx) and Devart Entity Model (*.edml)

To migrate your ADO.NET Entity Data Model to Devart Entity Model, change the extension of the model file to edml (edmx -> edml), set the Build Action property of your model to "DevartEntityDeploy", and Custom Tool to "DevartEfGenerator". After that the model can be edited with the Devart Entity Developer.

To migrate your Devart Entity Model to ADO.NET Entity Data Model, change the model file extension (edml ->edmx), set the Build Action property of your model to "EntityDeploy", and Custom Tool to "EntityModelCodeGenerator". After that the model can be edited with Entity Designer.

Both *.edml and *.edmx can be opened and edited manually using XML Editor.

See Also

Entity Framework Tutorial | Devart LinqConnect | http://blog.devart.com/tag/entity-framework


Entity Framework Data Type Mapping

Entity Framework Data Type Mapping
support@devart.com

Oracle to .NET type mapping

Type mapping rules from this table are used by default when generating a model from a database with Entity Data Model Wizard in Visual Studio 2008 - 2015 and Create Model Wizard in Entity Developer.

You may override the default mapping for numeric types in Entity Data Model Wizard using the OracleConnection.NumberMappings property.

Oracle data types | SSDL 1 | CSDL 1 | .NET
NUMBER(1) | bool | Boolean | System.Boolean
NUMBER(2)..NUMBER(9)2 | int | Int32 | System.Int32
NUMBER(10)..NUMBER(18)2 | int64 | Int64 | System.Int64
NUMBER (p, s), where 0 < s < p < 162 | double | Double | System.Double
other NUMBERs | decimal | Decimal | System.Decimal
FLOAT, REAL, BINARY_FLOAT3, BINARY_DOUBLE3 | the same3 | Decimal | System.Decimal
DATE, TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME ZONE | the same4 | DateTime | System.DateTime
INTERVAL DAY TO SECOND | the same4 | Time | System.TimeSpan
CHAR, NCHAR, VARCHAR2, NVARCHAR2, CLOB, NCLOB, ROWID, UROWID, XMLTYPE, INTERVAL YEAR TO MONTH, LONG5 | the same4 | String | System.String
BLOB, RAW6, LONG RAW5 | the same4 | Binary | System.Byte[]
PL/SQL BOOLEAN | the same4 | Boolean | System.Boolean
RAW(16) | guid | Guid | System.Guid
PL/SQL BOOLEAN | the same4 | Boolean | System.Boolean
SDO_GEOMETRY7 | sdo_geometry4 | Geometry, GeometryCollection, GeometryLineString, GeometryMultiLineString, GeometryMultiPoint, GeometryMultiPolygon, GeometryPoint, GeometryPolygon | DbGeometry
SDO_GEOMETRY7 | sdo_geography4 | Geography, GeographyCollection, GeographyLineString, GeographyMultiLineString, GeographyMultiPoint, GeographyMultiPolygon, GeographyPoint, GeographyPolygon | DbGeography

1 Applicable only to Entity Framework v1 - v6. Not applicable to Entity Framework Core, because Entity Framework Core does not support XML mapping.

2 The negative scale cases are taken into account.

3 BINARY_DOUBLE and BINARY_FLOAT data types appeared in Oracle 10g.

4 These SSDL types completely identical to the corresponding Oracle data types.

5 According to official Oracle recomendations, using of LONG and LONG RAW data types is not recommended.

6 All RAW types, except RAW(16).

7 Supported in Entity Framework v5 and v6.

.NET to Oracle default type mapping

.NET | CSDL 1 | SSDL 1 | Oracle data types
System.Boolean | Boolean | bool | NUMBER(1)
System.Byte | Byte | byte | NUMBER(3)2
System.Byte[] | Binary | BLOB | BLOB
DbGeometry3 | Geometry | sdo_geometry | SDO_GEOMETRY
DbGeography3 | Geography | sdo_geography | SDO_GEOMETRY
System.DateTime | DateTime | TIMESTAMP | TIMESTAMP
System.DateTimeOffset | DateTimeOffset | datetimeoffset | TIMESTAMP WITH TIME ZONE
System.Decimal | Decimal | decimal | NUMBER4
System.Double | Double | double | NUMBER
System.Guid | Guid | guid | RAW(16)
System.Int16 | Int16 | int16 | NUMBER(5)2
System.Int32 | Int32 | int | NUMBER(10)2
System.Int64 | Int64 | int64 | NUMBER(19)2
System.SByte | SByte | sbyte | NUMBER(3)2
System.Single | Single | single | NUMBER(15,5)2
System.String | String | VARCHAR2 | VARCHAR2
System.TimeSpan | Time | INTERVAL DAY TO SECOND | INTERVAL DAY TO SECOND

1 Applicable only to Entity Framework v1 - v6. Not applicable to Entity Framework Core, because Entity Framework Core does not support XML mapping.

2 Note that when mapping corresponding database data type, you will need the .NET type with larger precision. That is because, for example, any Int32 value can be stored in the NUMBER(10) column, but largest NUMBER(10) column value cannot be stored in the Int32 field, it requires Int64 field.

3 Supported in Entity Framework v5 and v6.

4 Mapping of this type depends on the DecimalPropertyConvention. If this convention is enabled (it is enabled by default), System.Decimal is mapped to NUMBER(18,2). Otherwise, it is mapped to NUMBER.


Using CHAR(1) mapped to System.Boolean in Entity Framework

Using CHAR(1) mapped to System.Boolean in Entity Framework
support@devart.com

Oracle does not provide a dedicated type for storing boolean values in tables. There are different workarounds for this problem. The most common workarounds are using NUMBER(1) or CHAR(1) columns for storing boolean values and setting them to 0 or 1 for NUMBER(1) fields or to 'Y' or 'N' for CHAR(1) fields.

dotConnect for Oracle Entity Framework provider supports both mapping NUMBER(1) and CHAR(1) to System.Boolean. To support mapping System.Boolean to CHAR(1), a new data type "yes no char as boolean" is introduced. This type does not have a direct counterpart in Oracle. It can be used in SSDL model part for columns of storage entities and as a column data types for Code First mapping. By default, mapping NUMBER(1) to System.Boolean is used. You can read about mapping CHAR(1) to System.Boolean for different development approaches below.

Database First

EDM Wizard / EDM Designer

After creating an Entity Framework model, you need to edit it in the following way:

  • Replace the String type of the required properties in the conceptual model with the Boolean type.
  • Replace the char type of the corresponding storage model columns with the "yes no char as boolean". It cannot be done in the EDM Designer, and needs manual model editing with a text editor, for example, Visual Studio XML Editor.

Entity Developer

If you need to map all the CHAR(1) columns to System.Boolean, add the new type mapping rule (on the Server Options -> Oracle page of Entity Developer Options dialog box) and then create the model. See the Creating and Editing Type Mapping Rules topic in the Entity Developer documentation.

If you need only some of the CHAR(1) columns to be mapped to System.Boolean, you need to manually edit the necessary properties and change their type from String to Boolean. You also need to change the type of the corresponding storage model columns from "CHAR" to "yes no char as boolean". Entity Developer allows doing it quite easily because it supports full-featured visual editing of both conceptual and storage parts of the model and quick navigation between conceptual model entity property and storage model entity column in two ways:

  • You can open the editor for a storage model column from the editor of the corresponding conceptual model property (see the "Property Editor" topic in the Entity Developer documentation).
  • You can right-click the conceptual model property on a diagram and select Select Storage from the shortcut menu to navigate to the corresponding storage model column.

Code First

Defining Type Explicitly

The following example demonstrates mapping System.Boolean to both NUMBER(1) (the NumberBasedBoolean property) and CHAR(1) (the CharBasedBoolean property).

We will use the Column data annotation attribute to specify the type "yes no char as boolean":

C#csharp Copy Code
  public class BoolTable {

    public int Id { get; set; }

    public bool NumberBasedBoolean { get; set; }

    [Column(TypeName = "yes no char as boolean")]
    public bool CharBasedBoolean { get; set; }

  }

  public class MyContext: DbContext {

    public DbSet<BoolTable> BoolTable { get; set; }

    // ...
  }
Visual Basic Copy Code
    Public Class BoolTable

    Public Property Id() As Integer
        Get
            Return m_Id
        End Get
        Set
            m_Id = Value
        End Set
    End Property
    Private m_Id As Integer

    Public Property NumberBasedBoolean() As Boolean
        Get
            Return m_NumberBasedBoolean
        End Get
        Set
            m_NumberBasedBoolean = Value
        End Set
    End Property
    Private m_NumberBasedBoolean As Boolean

    <Column(TypeName := "yes no char as boolean")> _
    Public Property CharBasedBoolean() As Boolean
        Get
            Return m_CharBasedBoolean
        End Get
        Set
            m_CharBasedBoolean = Value
        End Set
    End Property
    Private m_CharBasedBoolean As Boolean

End Class

Public Class MyContext
    Inherits DbContext

    Public Property BoolTable() As DbSet(Of BoolTable)
        Get
            Return m_BoolTable
        End Get
        Set
            m_BoolTable = Value
        End Set
    End Property
    Private m_BoolTable As DbSet(Of BoolTable)

    ' ...
End Class

The following DDL will be generated for such a class:

CREATE TABLE "BoolTables" (
  "Id" NUMBER(10)  NOT NULL,
  "NumberBasedBoolean" NUMBER(1) NOT NULL,
  "CharBasedBoolean" CHAR(1) NOT NULL,
  PRIMARY KEY ("Id")
)

Specifying Type via Convention

Entity Framework 6 allows using conventions for mapping.

Conventions are convenient when, for example, all the System.Boolean properties in all model classes must be mapped to CHAR(1) columns. In such a case you may write a lightweight convention instead of specifying data type for each boolean property with ColumnAttribute.

C#csharp Copy Code
  public class MyContext : DbContext {

    protected override void OnModelCreating(DbModelBuilder modelBuilder) {

      modelBuilder
        .Properties()
        .Where(p => p.PropertyType == typeof(Boolean))
        .Configure(p => p.HasColumnType("yes no char as boolean"));
    }

    // ...
  }
Visual Basic Copy Code
Public Class MyContext
    Inherits DbContext

    Protected Overrides Sub OnModelCreating(modelBuilder As DbModelBuilder)

        modelBuilder.Properties().Where(Function(p) p.PropertyType = GetType([Boolean])).Configure(Function(p) p.HasColumnType("yes no char as boolean"))
    End Sub

    ' ...
End Class
End Sub

See Also

Entity Framework | Entity Framework Data Type Mapping


Using Entity Data Model Wizard

Using Entity Data Model Wizard
support@devart.com

dotConnect for Oracle fully supports ADO.NET Entity Framework and can be used with standard Visual Studio Entity Data Model Wizard. The wizard, however, is tuned for SQL Server and exposes some problems when used against other data sources. This topic provides information on overcoming the issues of Entity Data Model Wizard. This topic is also applicable to LightSwitch Attach Data Source Wizard.

Please note that Entity Data Model Wizard and LightSwitch Attach Data Source Wizard are not supported by Entity Framework Core. They are supported for previous Entity Framework versions only.

To invoke the wizard, add new item to the project and select ADO.NET Entity Data Model. When supplied with valid connection parameters, the wizard shows a tree of objects that you can include in the model. There are three types of objects: tables, views, and stored procedures. The objects are grouped by schema name and sorted by object name.

You may encounter the following problems during the process of creating the model with Entity Data Model Wizard:

  • Some database objects are not available in the tree.
  • Some database objects are not included in the model though you have selected them.
  • Tables or views have some columns missing.
  • The wizard or EDM Designer work very slowly.

For Entity Framework v6 you also need to register our Entity Framework provider in the config file of your project.

Database Objects Not Available in the Tree

The wizard includes all objects that the database user has access to. The visibility scope is determined by SELECT and EXECUTE grants, system privileges SELECT ANY TABLE and EXECUTE ANY PROCEDURE for both user and his roles. If you have any objects missing, make sure you are granted proper privileges.

Database Objects Are Not Included in the Model

ADO.NET Entity Framework can't work with user-defined types and PL/SQL types that cannot be used in tables. Therefore, database objects that can be included in the model are subject to the following restrictions:

  • Object tables must be based upon primitive types only.
  • Stored procedures must have only parameters of supported types. If any parameter has unsupported type, the stored procedure is excluded from the model.
  • Tables and views must have inferable entity key.

Entity Framework requires every entity to have at least one column in the entity key. Usually entity key is inferred basing on the table's primary key. If a table has no primary key, the entity key includes all NOT NULL columns. If a table has neither primary key nor NOT NULL columns, it is excluded from the model. The same applies to views: if a view has no NOT NULL columns, it is excluded from the model.

Entity Framework also exposes the following requirements to primary keys: it should be constrained NOT NULL and should not contain binary columns. If a primary key fails in these conditions, the entity is excluded from the model.

Tables Or Views Have Some Columns Missing

Columns of unsupported types are not included in the model. The tables and views that contain such columns are included, but without corresponding property.

After the generation of the model you can inspect the list of excluded objects in Visual Studio Error List window.

The Wizard Or EDM Designer Work Very Slowly

The way Microsoft EDM Wizard retrieves metadata from data source is not the best way for Oracle. The wizard's performance significantly decreases when there are many database objects available. EDM Designer can be extremely slow for models with more than 100 entities.

If you experience performance problems, you can try the following workarounds:

  • Do not connect as DBA.
  • For the current user or role remove the privileges SELECT ANY TABLE and EXECUTE ANY PROCEDURE. Also you can remove grants SELECT and EXECUTE for particular objects.
  • Create a new user with access only to objects that are intended for the model.
  • Move the database schema to a clean installation of Oracle server and generate the model with that server.
  • Decrease the amount of model entities.

Instead of Microsoft EDM Wizard, you can use our Entity Developer - our advanced model designer for Entity Framework and LinqConnect. It is much more compatible with Oracle and does not have the mentioned problems.

Using the Entity Data Provider with Entity Framework v6

Since there are no global Entity Framework provider registration for Entity Framework v6, you should register our provider manually in the config file of your project. For this you should add the following line:

<provider invariantName="Devart.Data.Oracle"
type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity.EF6, Version=8.1.26.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

To the entityFramework -> providers section.

<entityFramework>
    <providers>
      <provider invariantName="Devart.Data.Oracle"
      type="Devart.Data.Oracle.Entity.OracleEntityProviderServices, Devart.Data.Oracle.Entity.EF6, Version=8.1.26.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>
</entityFramework>

Note: replace 8.1.26.0 with the actual assembly version.

This section appears in the project config file only after you add the NuGet EntityFramework package either explicitly, by executing the "install-package EntityFramework" command, or implicitly, by adding an Entity Framework v6 model for SQL Server via EDM Wizard.

See Also

Entity Framework Support


Entity Framework Tutorial

Entity Framework Tutorial
support@devart.com

This tutorial guides you through the process of creating a simple application powered by ADO.NET Entity Framework. In less than 5 minutes you will have a ready-to-use data access layer for your business objects.

Please note that this tutorial is not applicable for Entity Framework Core. It is intended for previous Entity Framework versions.

In this walkthrough:

  • Introducing the ADO.NET Entity Framework
  • Requirements
  • Entity Framework v6
  • Generating Model from Database
  • Querying Data
  • Inserting New Data
  • Updating Data
  • Deleting Data
  • Additional Information

Introducing the ADO.NET Entity Framework

ADO.NET Entity Framework is an object-relational mapping (ORM) framework for the .NET Framework. It is designed to enable developers to create data access applications by programming against a conceptual application model instead of programming directly against a relational storage schema. The goal is to decrease the amount of code and maintenance required for data-oriented applications.

Requirements

In order to connect to Oracle server you need the server itself running, dotConnect for Oracle installed and IDE running. ADO.NET Entity Framework requires .NET Framework 3.5 Service Pack 1 or higher, Visual Studio 2008 Service Pack 1 or higher, and Oracle server 9.2.0.4 or higher. Note that Entity Framework support is available only in Professional and Developer Editions of dotConnect for Oracle.

For Entity Framework 6, you will also need a NuGet Visual Studio extension installed since it is used for adding EntityFramework NuGet package. Alternatively you may create model for Entity Framework v1 or v4, which don't require NuGet, in this tutorial.

In this tutorial it is assumed that you already have the database objects created. You have to execute a script from the following file if you have not done so yet:
\Program Files\Devart\dotConnect\Oracle\Samples\crm_demo.sql

In this sample we will create a simple console application. It could be any other project type as well, but for simplicity's sake we'll use console project throughout the tutorial. Start Visual Studio and create a new console application.

Entity Framework v6

The following actions are required if you want to create an Entity Framework v6 model.

Open the Package Manager Console window and execute the following command in it.

install-package EntityFramework

After this add the following line:

<provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices,
Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />

to the entityFramework -> providers section.

<entityFramework>
    <providers>
      <provider invariantName="Devart.Data.Oracle" type="Devart.Data.Oracle.Entity.OracleEntityProviderServices,
      Devart.Data.Oracle.Entity.EF6, Version=8.4.215.0, Culture=neutral, PublicKeyToken=09af7300eec23701" />
    </providers>
</entityFramework>

Note: replace 8.4.215.0 with the actual assembly version.

After this you need to rebuild the project before running the EDM wizard.

Generating Model from Database

  1. In the Solution Explorer right-click on the project and choose Add | New Item.
  2. In the dialog select ADO.NET Entity Data Model, click Add. This launches Entity Data Model Wizard.
  3. In the wizard select Generate from database, click Next.
  4. Pick an existing dotConnect for Oracle connection string or create a new one. When creating a new connection select Oracle Database in the Data Source list, then dotConnect for Oracle in the Data provider list. See the screenshot below.
    EDM wizard - connection
  5. Agree to include the sensitive data in the connection string.
  6. In the Save entity connection settings... box type CrmDemoEntities. This will be the name of the main data access class. Click Next.
  7. Select database objects that will be used in the model. These are all objects from the crm_demo script, including auxiliary tables.
    EDM wizard - selecting objects
  8. Click Finish. The model will be generated and opened in EDM Designer.
    Entity data model

The model you've just generated is ready to use. Its name is Model1.edmx, unless you changed it in the step 2. You can inspect it visually in the designer or take a look behind the scenes with XML Editor.

The wizard creates classes for all selected tables that represent entities. It also creates a descendant of System.Data.Objects.ObjectContext class, which controls the connection to the database, and the whole data flow. This class includes properties and methods named after your database objects. You will use these members to retrieve and modify data in the context. The code is contained in an autogenerated file Model1.Designer.cs (Model1.Designer.vb).

Note that if you have an association between two properties of non-coinciding numeric types, you can manually change both conceptual and storage types to the type that will be wide enough to include data for each property.

Querying Data

All Entity Framework operations are executed through the ObjectContext descendant, which is named CrmDemoEntities in this tutorial. To retrieve data you have to first create an instance of the context, then prepare a query with LINQ to Entities or EntitySQL or their mix, and then access the object returned by the query, which may be a collection of objects or a single object.

Let's read all the data from the table Company, sort it by CompanyID, and output some columns. Add the following block of code to the method Main:

C#csharp Copy Code
CrmDemoEntities context = new CrmDemoEntities();
var query = from it in context.Company
            orderby it.CompanyID
            select it;

foreach (Company comp in query)
  Console.WriteLine("{0} | {1} | {2}", comp.CompanyID, comp.CompanyName, comp.Country);

Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoEntities = New CrmDemoEntities
Dim query = From it In context.Company _
    Order By it.CompanyID _
    Select it

Dim comp As Company
For Each comp In query
  Console.WriteLine("{0} | {1} | {2}", comp.CompanyID, comp.CompanyName, comp.Country)
Next

Console.ReadLine()

As simple as that. You prepare a query and then iterate through it as you would do with a usual collection of objects. The database interaction is performed by Entity Framework in the background. Now let's see who is who in this code sample.

  • CrmDemoEntities is the name of the class that knows all about your model and does everything to handle it. You named it in the step 6. All Entity Framework operations are performed within this class's properties and methods. It is recommended that you keep a single instance of the class throughout your application because it consumes lots of resources.
  • query, it - these are arbitrary variable names in the LINQ to Entities statement. The former is used as the collection of data objects, the latter is not used outside the statement.
  • context.Company refers to a public property of CrmDemoEntities class. This property represents the collection of all companies in the context.
  • Company (in the foreach statement) is the name of an autogenerated class. This class maps to the Company table in the database and is named after it.

Here is the project's output in the console:

Note that the LINQ to Entities query code just describes the query. It does not execute it. This approach is known as deferred execution.

Now let's query data from two tables united with a foreign key. Replace the old code with this:

C#csharp Copy Code
CrmDemoEntities context = new CrmDemoEntities();

var query = from it in context.Products.Include("Product_Categories")
            orderby it.Product_Categories.CategoryName, it.ProductName
            select it;

foreach (Products product in query)
  Console.WriteLine("{0} | {1} | {2}",
    product.Product_Categories.CategoryName, product.ProductName, product.Price);

Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoEntities = New CrmDemoEntities
Dim query = From it In context.Products.Include("Product_Categories") _
Order By it.Product_Categories.CategoryName, it.ProductName _
Select it

Dim product As Products
For Each product In query
  Console.WriteLine("{0} | {1} | {2}", _
    product.Product_Categories.CategoryName, product.ProductName, product.Price)
Next
Console.ReadLine()

This sample is much like the previous one, with exception that it adds the Include method that instructs the query to retrieve data from one more table.

Inserting New Data

What earlier was adding rows to tables, now is just adding new objects to context collections. When you are ready to send the changes to the database, call the SaveChanges() method of the context. Before doing this, you must first set all properties that do not support null (Nothing) values. The SaveChanges() method generates and executes commands that perform the equivalent INSERT, UPDATE, or DELETE statements against the data source.

Let's add a new product and a new category to the database. Replace the old code with this:

C#csharp Copy Code
CrmDemoEntities context = new CrmDemoEntities();

// Create a new category
Product_Categories newCategory = new Product_Categories();
newCategory.CategoryID = 1000;
newCategory.CategoryName = "New category";
context.AddToProduct_Categories(newCategory);

// Create a new product
Products newProduct = new Products();
newProduct.ProductID = 2000;
newProduct.ProductName = "New product";
newProduct.Price = 20;
// Associate the new product with the new category
newProduct.Product_Categories = newCategory;
context.AddToProducts(newProduct);

// Send the changes to the database.
// Until you do it, the changes are cached on the client side.
context.SaveChanges();

// Request the new product from the database
var query = from it in context.Products.Include("Product_Categories")
            where it.ProductID == 2000
            select it;

// Since we query for a single object instead of a collection, we can use the method First()
Products product = query.First();
Console.WriteLine("{0} | {1} | {2}",
  product.Product_Categories.CategoryName, product.ProductName, product.Price);
Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoEntities = New CrmDemoEntities

' Create a new category
Dim newCategory As Product_Categories = New Product_Categories()
newCategory.CategoryID = 1000
newCategory.CategoryName = "New category"
context.AddToProduct_Categories(newCategory)

' Create a new product
Dim newProduct As Products = New Products()
newProduct.ProductID = 2000
newProduct.ProductName = "New product"
newProduct.Price = 20
' Associate the new product with the new category
newProduct.Product_Categories = newCategory
context.AddToProducts(newProduct)

' Send the changes to the database.
' Until you do it, the changes are cached on the client side.
context.SaveChanges()

' Request the new product from the database
Dim query = From it in context.Products.Include("Product_Categories") _
            Where it.ProductID = 2000 _
            Select it

' Since we query for a single object instead of a collection, we can use the method First()
Dim product As Products = query.First()
Console.WriteLine("{0} | {1} | {2}", _
  product.Product_Categories.CategoryName, product.ProductName, product.Price)
Console.ReadLine()

The methods AddToProduct_Categories, AddToProducts, and others are automatically generated in the context. Such methods exist for every class in your model.

Note that after you have added the new product and category by submitting the changes, you cannot execute this solution again as is. To execute the solution again, change the names and IDs of the objects to be added.

Updating Data

Entity instances are modified as usual. The only thing to remember is that you have to invoke the SaveChanges() method to send the data to the database.

Append the following block to the existing code and launch the project:

C#csharp Copy Code
product.ProductName = "Edited product";
product.Price = 15;
context.SaveChanges();
Visual Basic Copy Code
product.ProductName = "Edited product"
product.Price = 15
context.SaveChanges()

Deleting Data

To extract an instance from a context use the DeleteObject method of the context. The object is removed from the collection of its type, but not destroyed. To delete the object's data from the database invoke the SaveChanges() method.

You can do this with a block of code like the following:

C#csharp Copy Code
context.DeleteObject(newCategory);
context.DeleteObject(newProduct);
context.SaveChanges();
Visual Basic Copy Code
context.DeleteObject(newCategory)
context.DeleteObject(newProduct)
context.SaveChanges()

Additional Information

Now that you can perform the basic data manipulation with Entity Framework, you can move on to some advanced topics. Here are some useful links to MSDN:

  • ADO.NET Entity Framework
  • LINQ to Entities
  • Entity SQL Language

For hands-on experience download the separate Entity Framework Query Samples package or use samples shipped with dotConnect for Oracle. You can access the samples from the Start menu.

To understand deeper the works of Entity Framework engine you can watch the generated SQL statements in dbMonitor.

See Also

Entity Framework section | Entity Framework Support Overview


Entity Framework Core Code-First Tutorial

Entity Framework Core Code-First Tutorial
support@devart.com

This tutorial guides you through the process of creating a simple application powered by Entity Framework Core. This application will create tables in the database based on the model in run-time, fill them with sample data, and execute queries.

Requirements

In order to connect to Oracle server you need dotConnect for Oracle installed and IDE running. ADO.NET Entity Framework requires .NET Framework 4.5.1 or higher and Visual Studio 2013 or higher. Additionally an Oracle server 9.2.0.4 or higher is required. Note that Entity Framework support is available only in Professional and Developer Editions of dotConnect for Oracle.

Creating Application

To create the sample application, let's perform the following steps:
  1. Create a new console application.
  2. Ensure you are targeting .NET Framework 4.5.1 or later.
  3. Install the Entity Framework Core NuGet package by executing the following command in the Package Manager Console:
    Install-Package Microsoft.EntityFrameworkCore.Relational

  4. Additionally you need to add references to the following assemblies to your project:

    • Devart.Data.dll
    • Devart.Data.Oracle.dll
    • Devart.Data.Oracle.Entity.EFCore.dll
  5. Create a DbContext descendant.
    C#csharp Copy Code
    using Microsoft.EntityFrameworkCore;
using System;
using System.Collections.Generic;
using System.ComponentModel.DataAnnotations;
using System.ComponentModel.DataAnnotations.Schema;
using System.Data;
using System.IO;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

public class MyDbContext : DbContext {

}
    Visual Basic Copy Code
    Imports Microsoft.EntityFrameworkCore
Imports System.Collections.Generic
Imports System.ComponentModel.DataAnnotations
Imports System.ComponentModel.DataAnnotations.Schema
Imports System.Data
Imports System.IO
Imports System.Linq
Imports System.Text
Imports System.Threading.Tasks

Public Class MyDbContext
    Inherits DbContext

End Class
  6. Register Entity Framework Core provider for using with our DbContext and specify the connection string. For this override the OnConfiguring method.
    C#csharp Copy Code
    public class MyDbContext : DbContext {

  protected override void OnConfiguring(DbContextOptionsBuilder optionsBuilder) {

     optionsBuilder.UseOracle(@"User Id=Scott;Password=tiger;Data Source=Ora;");
  }
}
    Visual Basic Copy Code
    Public Class MyDbContext
    Inherits DbContext

    Protected Overrides Sub OnConfiguring(optionsBuilder As DbContextOptionsBuilder)

        optionsBuilder.UseOracle("User Id=Scott;Password=tiger;Data Source=Ora;")
    End Sub
End Class

  7. Create entity classes, used in the model. If necessary, set DataAnnotation attributes for the classes and properties.

    + Show/Hide code

    C#csharp Copy Code
      [Table("Product")]
  public class Product {

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long ProductID { get; set; }

    [Required]
    [MaxLength(50)]
    public string ProductName { get; set; }

    public string UnitName { get; set; }
    public int UnitScale { get; set; }
    public long InStock { get; set; }
    public double Price { get; set; }
    public double DiscontinuedPrice { get; set; }

    public virtual ProductCategory Category { get; set; }
    public virtual ICollection<OrderDetail> OrderDetails { get; set; }
  }

  [Table("ProductCategory")]
  public class ProductCategory {

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long CategoryID { get; set; }

    [Required]
    [MaxLength(20)]
    public string CategoryName { get; set; }

    public virtual ProductCategory ParentCategory { get; set; }
    public virtual ICollection<ProductCategory> ChildCategories { get; set; }
    public virtual ICollection<Product> Products { get; set; }
  }

  [Table("Order Details")]
  public class OrderDetail {

    [Column(Order = 1)]
    public long OrderID { get; set; }

    [Column(Order = 2)]
    public long ProductID { get; set; }

    public double Price { get; set; }
    public double Quantity { get; set; }

    public virtual Product Product { get; set; }
    public virtual Order Order { get; set; }
  }

  [Table("Orders")]
  public class Order {

    public Order() {

      OrderDate = DateTime.Now;
    }

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long OrderID { get; set; }

    [Required]
    public DateTime OrderDate { get; set; }

    public double Freight { get; set; }
    public DateTime? ShipDate { get; set; }
    public Double Discount { get; set; }

    public virtual ICollection<OrderDetail> OrderDetails { get; set; }

    [InverseProperty("Orders")]
    public virtual PersonContact PersonContact { get; set; }

    public virtual Company Company { get; set; }

    public virtual Company ShipCompany { get; set; }
  }

  [Table("Company")]
  public class Company {

    public Company() {
    }

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long CompanyID { get; set; }

    [Required]
    [MaxLength(40)]
    public string CompanyName { get; set; }

    [MaxLength(100)]
    public string Web { get; set; }

    [MaxLength(50)]
    public string Email { get; set; }

    public virtual AddressType Address { get; set; }

    [InverseProperty(nameof(Order.Company))]
    public virtual ICollection<Order> Orders { get; set; }

    [InverseProperty(nameof(Order.ShipCompany))]
    public virtual ICollection<Order> ShippedOrders { get; set; }

    [InverseProperty(nameof(PersonContact.Companies))]
    public virtual PersonContact PrimaryContact { get; set; }

    [InverseProperty(nameof(PersonContact.Company))]
    public virtual ICollection<PersonContact> Contacts { get; set; }

  }

  [Table("Person Contact")]
  public class PersonContact {

    public PersonContact() {
    }

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long ContactID { get; set; }

    [MaxLength(8)]
    public string Title { get; set; }

    [MaxLength(50)]
    public string FirstName { get; set; }

    [MaxLength(50)]
    public string MiddleName { get; set; }

    [MaxLength(50)]
    public string LastName { get; set; }

    [MaxLength(25)]
    public string HomePhone { get; set; }

    [MaxLength(25)]
    public string MobilePhone { get; set; }

    public virtual AddressType Address { get; set; }

    public virtual ICollection<Order> Orders { get; set; }
    public virtual Company Company { get; set; }
    public virtual ICollection<Company> Companies { get; set; }
  }

  [Table("AddressType")]
  public class AddressType {

    [Key]
    [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
    public long Id { get; set; }

    [MaxLength(120)]
    public string AddressTitle { get; set; }

    [MaxLength(60)]
    public string Address { get; set; }

    [MaxLength(30)]
    public string City { get; set; }

    [MaxLength(20)]
    public string Region { get; set; }

    [MaxLength(15)]
    public string PostalCode { get; set; }

    [MaxLength(20)]
    public string Country { get; set; }

    [MaxLength(25)]
    public string Phone { get; set; }

    [MaxLength(25)]
    public string Fax { get; set; }
  }

    [Visual Basic]

    <Table("Product")> _
Public Class Product

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property ProductID() As Long
        Get
            Return m_ProductID
        End Get
        Set
            m_ProductID = Value
        End Set
    End Property
    Private m_ProductID As Long

    <Required> _
    <MaxLength(50)> _
    Public Property ProductName() As String
        Get
            Return m_ProductName
        End Get
        Set
            m_ProductName = Value
        End Set
    End Property
    Private m_ProductName As String

    Public Property UnitName() As String
        Get
            Return m_UnitName
        End Get
        Set
            m_UnitName = Value
        End Set
    End Property
    Private m_UnitName As String
    Public Property UnitScale() As Integer
        Get
            Return m_UnitScale
        End Get
        Set
            m_UnitScale = Value
        End Set
    End Property
    Private m_UnitScale As Integer
    Public Property InStock() As Long
        Get
            Return m_InStock
        End Get
        Set
            m_InStock = Value
        End Set
    End Property
    Private m_InStock As Long
    Public Property Price() As Double
        Get
            Return m_Price
        End Get
        Set
            m_Price = Value
        End Set
    End Property
    Private m_Price As Double
    Public Property DiscontinuedPrice() As Double
        Get
            Return m_DiscontinuedPrice
        End Get
        Set
            m_DiscontinuedPrice = Value
        End Set
    End Property
    Private m_DiscontinuedPrice As Double

    Public Overridable Property Category() As ProductCategory
        Get
            Return m_Category
        End Get
        Set
            m_Category = Value
        End Set
    End Property
    Private Overridable m_Category As ProductCategory
    Public Overridable Property OrderDetails() As ICollection(Of OrderDetail)
        Get
            Return m_OrderDetails
        End Get
        Set
            m_OrderDetails = Value
        End Set
    End Property
    Private Overridable m_OrderDetails As ICollection(Of OrderDetail)
End Class

<Table("ProductCategory")> _
Public Class ProductCategory

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property CategoryID() As Long
        Get
            Return m_CategoryID
        End Get
        Set
            m_CategoryID = Value
        End Set
    End Property
    Private m_CategoryID As Long

    <Required> _
    <MaxLength(20)> _
    Public Property CategoryName() As String
        Get
            Return m_CategoryName
        End Get
        Set
            m_CategoryName = Value
        End Set
    End Property
    Private m_CategoryName As String

    Public Overridable Property ParentCategory() As ProductCategory
        Get
            Return m_ParentCategory
        End Get
        Set
            m_ParentCategory = Value
        End Set
    End Property
    Private Overridable m_ParentCategory As ProductCategory
    Public Overridable Property ChildCategories() As ICollection(Of ProductCategory)
        Get
            Return m_ChildCategories
        End Get
        Set
            m_ChildCategories = Value
        End Set
    End Property
    Private Overridable m_ChildCategories As ICollection(Of ProductCategory)
    Public Overridable Property Products() As ICollection(Of Product)
        Get
            Return m_Products
        End Get
        Set
            m_Products = Value
        End Set
    End Property
    Private Overridable m_Products As ICollection(Of Product)
End Class

<Table("Order Details")> _
Public Class OrderDetail

    <Column(Order := 1)> _
    Public Property OrderID() As Long
        Get
            Return m_OrderID
        End Get
        Set
            m_OrderID = Value
        End Set
    End Property
    Private m_OrderID As Long

    <Column(Order := 2)> _
    Public Property ProductID() As Long
        Get
            Return m_ProductID
        End Get
        Set
            m_ProductID = Value
        End Set
    End Property
    Private m_ProductID As Long

    Public Property Price() As Double
        Get
            Return m_Price
        End Get
        Set
            m_Price = Value
        End Set
    End Property
    Private m_Price As Double
    Public Property Quantity() As Double
        Get
            Return m_Quantity
        End Get
        Set
            m_Quantity = Value
        End Set
    End Property
    Private m_Quantity As Double

    Public Overridable Property Product() As Product
        Get
            Return m_Product
        End Get
        Set
            m_Product = Value
        End Set
    End Property
    Private Overridable m_Product As Product
    Public Overridable Property Order() As Order
        Get
            Return m_Order
        End Get
        Set
            m_Order = Value
        End Set
    End Property
    Private Overridable m_Order As Order
End Class

<Table("Orders")> _
Public Class Order

    Public Sub New()

        OrderDate = DateTime.Now
    End Sub

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property OrderID() As Long
        Get
            Return m_OrderID
        End Get
        Set
            m_OrderID = Value
        End Set
    End Property
    Private m_OrderID As Long

    <Required> _
    Public Property OrderDate() As DateTime
        Get
            Return m_OrderDate
        End Get
        Set
            m_OrderDate = Value
        End Set
    End Property
    Private m_OrderDate As DateTime

    Public Property Freight() As Double
        Get
            Return m_Freight
        End Get
        Set
            m_Freight = Value
        End Set
    End Property
    Private m_Freight As Double
    Public Property ShipDate() As System.Nullable(Of DateTime)
        Get
            Return m_ShipDate
        End Get
        Set
            m_ShipDate = Value
        End Set
    End Property
    Private m_ShipDate As System.Nullable(Of DateTime)
    Public Property Discount() As [Double]
        Get
            Return m_Discount
        End Get
        Set
            m_Discount = Value
        End Set
    End Property
    Private m_Discount As [Double]

    Public Overridable Property OrderDetails() As ICollection(Of OrderDetail)
        Get
            Return m_OrderDetails
        End Get
        Set
            m_OrderDetails = Value
        End Set
    End Property
    Private Overridable m_OrderDetails As ICollection(Of OrderDetail)

    <InverseProperty("Orders")> _
    Public Overridable Property PersonContact() As PersonContact
        Get
            Return m_PersonContact
        End Get
        Set
            m_PersonContact = Value
        End Set
    End Property
    Private Overridable m_PersonContact As PersonContact

    Public Overridable Property Company() As Company
        Get
            Return m_Company
        End Get
        Set
            m_Company = Value
        End Set
    End Property
    Private Overridable m_Company As Company

    Public Overridable Property ShipCompany() As Company
        Get
            Return m_ShipCompany
        End Get
        Set
            m_ShipCompany = Value
        End Set
    End Property
    Private Overridable m_ShipCompany As Company
End Class

<Table("Company")> _
Public Class Company

    Public Sub New()
    End Sub

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property CompanyID() As Long
        Get
            Return m_CompanyID
        End Get
        Set
            m_CompanyID = Value
        End Set
    End Property
    Private m_CompanyID As Long

    <Required> _
    <MaxLength(40)> _
    Public Property CompanyName() As String
        Get
            Return m_CompanyName
        End Get
        Set
            m_CompanyName = Value
        End Set
    End Property
    Private m_CompanyName As String

    <MaxLength(100)> _
    Public Property Web() As String
        Get
            Return m_Web
        End Get
        Set
            m_Web = Value
        End Set
    End Property
    Private m_Web As String

    <MaxLength(50)> _
    Public Property Email() As String
        Get
            Return m_Email
        End Get
        Set
            m_Email = Value
        End Set
    End Property
    Private m_Email As String

    Public Overridable Property Address() As AddressType
        Get
            Return m_Address
        End Get
        Set
            m_Address = Value
        End Set
    End Property
    Private Overridable m_Address As AddressType

    <InverseProperty(nameof(Order.Company))> _
    Public Overridable Property Orders() As ICollection(Of Order)
        Get
            Return m_Orders
        End Get
        Set
            m_Orders = Value
        End Set
    End Property
    Private Overridable m_Orders As ICollection(Of Order)

    <InverseProperty(nameof(Order.ShipCompany))> _
    Public Overridable Property ShippedOrders() As ICollection(Of Order)
        Get
            Return m_ShippedOrders
        End Get
        Set
            m_ShippedOrders = Value
        End Set
    End Property
    Private Overridable m_ShippedOrders As ICollection(Of Order)

    <InverseProperty(nameof(PersonContact.Companies))> _
    Public Overridable Property PrimaryContact() As PersonContact
        Get
            Return m_PrimaryContact
        End Get
        Set
            m_PrimaryContact = Value
        End Set
    End Property
    Private Overridable m_PrimaryContact As PersonContact

    <InverseProperty(nameof(PersonContact.Company))> _
    Public Overridable Property Contacts() As ICollection(Of PersonContact)
        Get
            Return m_Contacts
        End Get
        Set
            m_Contacts = Value
        End Set
    End Property
    Private Overridable m_Contacts As ICollection(Of PersonContact)

End Class

<Table("Person Contact")> _
Public Class PersonContact

    Public Sub New()
    End Sub

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property ContactID() As Long
        Get
            Return m_ContactID
        End Get
        Set
            m_ContactID = Value
        End Set
    End Property
    Private m_ContactID As Long

    <MaxLength(8)> _
    Public Property Title() As String
        Get
            Return m_Title
        End Get
        Set
            m_Title = Value
        End Set
    End Property
    Private m_Title As String

    <MaxLength(50)> _
    Public Property FirstName() As String
        Get
            Return m_FirstName
        End Get
        Set
            m_FirstName = Value
        End Set
    End Property
    Private m_FirstName As String

    <MaxLength(50)> _
    Public Property MiddleName() As String
        Get
            Return m_MiddleName
        End Get
        Set
            m_MiddleName = Value
        End Set
    End Property
    Private m_MiddleName As String

    <MaxLength(50)> _
    Public Property LastName() As String
        Get
            Return m_LastName
        End Get
        Set
            m_LastName = Value
        End Set
    End Property
    Private m_LastName As String

    <MaxLength(25)> _
    Public Property HomePhone() As String
        Get
            Return m_HomePhone
        End Get
        Set
            m_HomePhone = Value
        End Set
    End Property
    Private m_HomePhone As String

    <MaxLength(25)> _
    Public Property MobilePhone() As String
        Get
            Return m_MobilePhone
        End Get
        Set
            m_MobilePhone = Value
        End Set
    End Property
    Private m_MobilePhone As String

    Public Overridable Property Address() As ddressType
        Get
            Return m_Address
        End Get
        Set
            m_Address = Value
        End Set
    End Property
    Private Overridable m_Address As ddressType

    Public Overridable Property Orders() As ICollection(Of Order)
        Get
            Return m_Orders
        End Get
        Set
            m_Orders = Value
        End Set
    End Property
    Private Overridable m_Orders As ICollection(Of Order)
    Public Overridable Property Company() As Company
        Get
            Return m_Company
        End Get
        Set
            m_Company = Value
        End Set
    End Property
    Private Overridable m_Company As Company
    Public Overridable Property Companies() As ICollection(Of Company)
        Get
            Return m_Companies
        End Get
        Set
            m_Companies = Value
        End Set
    End Property
    Private Overridable m_Companies As ICollection(Of Company)
End Class

<Table("AddressType")> _
Public Class AddressType

    <Key> _
    <DatabaseGenerated(DatabaseGeneratedOption.Identity)> _
    Public Property Id() As Long
        Get
            Return m_Id
        End Get
        Set
            m_Id = Value
        End Set
    End Property
    Private m_Id As Long

    <MaxLength(120)> _
    Public Property AddressTitle() As String
        Get
            Return m_AddressTitle
        End Get
        Set
            m_AddressTitle = Value
        End Set
    End Property
    Private m_AddressTitle As String

    <MaxLength(60)> _
    Public Property Address() As String
        Get
            Return m_Address
        End Get
        Set
            m_Address = Value
        End Set
    End Property
    Private m_Address As String

    <MaxLength(30)> _
    Public Property City() As String
        Get
            Return m_City
        End Get
        Set
            m_City = Value
        End Set
    End Property
    Private m_City As String

    <MaxLength(20)> _
    Public Property Region() As String
        Get
            Return m_Region
        End Get
        Set
            m_Region = Value
        End Set
    End Property
    Private m_Region As String

    <MaxLength(15)> _
    Public Property PostalCode() As String
        Get
            Return m_PostalCode
        End Get
        Set
            m_PostalCode = Value
        End Set
    End Property
    Private m_PostalCode As String

    <MaxLength(20)> _
    Public Property Country() As String
        Get
            Return m_Country
        End Get
        Set
            m_Country = Value
        End Set
    End Property
    Private m_Country As String

    <MaxLength(25)> _
    Public Property Phone() As String
        Get
            Return m_Phone
        End Get
        Set
            m_Phone = Value
        End Set
    End Property
    Private m_Phone As String

    <MaxLength(25)> _
    Public Property Fax() As String
        Get
            Return m_Fax
        End Get
        Set
            m_Fax = Value
        End Set
    End Property
    Private m_Fax As String
End Class

  8. Add our classes to the DbContext descendant as DbSet properties. If necessary, you can also write fluent mapping, by overriding the OnModelCreating method.
    C#csharp Copy Code
    public class MyDbContext : DbContext {

  protected override void OnConfiguring(DbContextOptionsBuilder optionsBuilder) {

    optionsBuilder.UseOracle(@"User Id=Scott;Password=tiger;Data Source=Ora;");
  }

  protected override void OnModelCreating(ModelBuilder modelBuilder) {

    modelBuilder.Entity<OrderDetail>()
      .HasKey(p => new { p.OrderID, p.ProductID });
  }

  public DbSet<Product> Products { get; set; }
  public DbSet<ProductCategory> ProductCategories { get; set; }
  public DbSet<OrderDetail> OrderDetails { get; set; }
  public DbSet<Order> Orders { get; set; }
  public DbSet<Company> Companies { get; set; }
  public DbSet<PersonContact> PersonContacts { get; set; }
}
    Visual Basic Copy Code
    Public Class MyDbContext
    Inherits DbContext

    Protected Overrides Sub OnConfiguring(optionsBuilder As DbContextOptionsBuilder)

        optionsBuilder.UseOracle("User Id=Scott;Password=tiger;Data Source=Ora;")
    End Sub

    Protected Overrides Sub OnModelCreating(modelBuilder As ModelBuilder)

        modelBuilder.Entity(Of OrderDetail)().HasKey(Function(p) New From { _
            p.OrderID, _
            p.ProductID _
        })
    End Sub

    Public Property Products() As DbSet(Of Product)
        Get
            Return m_Products
        End Get
        Set
            m_Products = Value
        End Set
    End Property
    Private m_Products As DbSet(Of Product)
    Public Property ProductCategories() As DbSet(Of ProductCategory)
        Get
            Return m_ProductCategories
        End Get
        Set
            m_ProductCategories = Value
        End Set
    End Property
    Private m_ProductCategories As DbSet(Of ProductCategory)
    Public Property OrderDetails() As DbSet(Of OrderDetail)
        Get
            Return m_OrderDetails
        End Get
        Set
            m_OrderDetails = Value
        End Set
    End Property
    Private m_OrderDetails As DbSet(Of OrderDetail)
    Public Property Orders() As DbSet(Of Order)
        Get
            Return m_Orders
        End Get
        Set
            m_Orders = Value
        End Set
    End Property
    Private m_Orders As DbSet(Of Order)
    Public Property Companies() As DbSet(Of Company)
        Get
            Return m_Companies
        End Get
        Set
            m_Companies = Value
        End Set
    End Property
    Private m_Companies As DbSet(Of Company)
    Public Property PersonContacts() As DbSet(Of PersonContact)
        Get
            Return m_PersonContacts
        End Get
        Set
            m_PersonContacts = Value
        End Set
    End Property
    Private m_PersonContacts As DbSet(Of PersonContact)
End Class

  9. Now let's choose how to create the database. We can generate Code-First Migrations. Or, for test purposes, we can implement the analogue of Entity Framework 6 initialization strategy DropCreateDatabaseAlways.

    + Show/Hide code

    C#csharp Copy Code
      public static class MyDbContextSeeder {

    public static void Seed(MyDbContext context) {

      context.Database.EnsureDeleted();
      context.Database.EnsureCreated();

      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "prose"
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "novel"
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "poetry",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "novel")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "detective story"
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "fantasy",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "novel")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "pop art",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "fantasy")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "textbook"
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "research book",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "textbook")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "poem",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "novel")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "collection",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "textbook")
      });
      context.ProductCategories.Add(new ProductCategory() {
        CategoryName = "dictionary",
        ParentCategory = context.ProductCategories.Local.Single(p => p.CategoryName == "collection")
      });

      context.Products.Add(new Product() {
        ProductName = "Shakespeare W. Shakespeare's dramatische Werke",
        Price = 78,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "prose")
      });
      context.Products.Add(new Product() {
        ProductName = "King Stephen. 'Salem's Lot",
        Price = 67,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "poetry")
      });
      context.Products.Add(new Product() {
        ProductName = "Plutarchus. Plutarch's moralia",
        Price = 89,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "prose")
      });
      context.Products.Add(new Product() {
        ProductName = "Twain Mark. Ventures of Huckleberry Finn",
        Price = 34,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "novel")
      });
      context.Products.Add(new Product() {
        ProductName = "Harrison G. B. England in Shakespeare's day",
        Price = 540,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "novel")
      });
      context.Products.Add(new Product() {
        ProductName = "Corkett Anne. The salamander's laughter",
        Price = 5,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "poem")
      });
      context.Products.Add(new Product() {
        ProductName = "Lightman Alan. Einstein''s dreams",
        Price = 5,
        Category = context.ProductCategories.Local.Single(p => p.CategoryName == "poem")
      });

      context.Companies.Add(new Company() {
        CompanyName = "Borland UK CodeGear Division",
        Web = "support.codegear.com/"
      });
      context.Companies.Add(new Company() {
        CompanyName = "Alfa-Bank",
        Web = "www.alfabank.com"
      });
      context.Companies.Add(new Company() {
        CompanyName = "Pioneer Pole Buildings, Inc.",
        Web = "www.pioneerpolebuildings.com"
      });
      context.Companies.Add(new Company() {
        CompanyName = "Orion Telecoms (Pty) Ltd.",
        Web = "www.oriontele.com"
      });
      context.Companies.Add(new Company() {
        CompanyName = "Orderbase Consulting GmbH",
        Web = "orderbase.de"
      });

      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2007, 4, 11),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Borland UK CodeGear Division")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2006, 3, 11),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Borland UK CodeGear Division")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2006, 8, 6),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Alfa-Bank")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2004, 7, 6),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Alfa-Bank")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2006, 8, 8),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Alfa-Bank")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2003, 3, 1),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Pioneer Pole Buildings, Inc.")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2005, 8, 6),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Orion Telecoms (Pty) Ltd.")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2006, 8, 1),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Orion Telecoms (Pty) Ltd.")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2007, 7, 1),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Orion Telecoms (Pty) Ltd.")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2007, 2, 6),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Orderbase Consulting GmbH")
      });
      context.Orders.Add(new Order() {
        OrderDate = new DateTime(2007, 8, 1),
        Company = context.Companies.Local.Single(c => c.CompanyName == "Orderbase Consulting GmbH")
      });

      context.SaveChanges();
    }
  }
    Visual Basic Copy Code
    Public NotInheritable Class MyDbContextSeeder
    Private Sub New()
    End Sub

    Public Shared Sub Seed(context As MyDbContext)

        context.Database.EnsureDeleted()
        context.Database.EnsureCreated()

        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "prose" _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "novel" _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "poetry", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "novel") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "detective story" _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "fantasy", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "novel") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "pop art", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "fantasy") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "textbook" _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "research book", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "textbook") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "poem", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "novel") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "collection", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "textbook") _
        })
        context.ProductCategories.Add(New ProductCategory() With { _
            Key .CategoryName = "dictionary", _
            Key .ParentCategory = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "collection") _
        })

        context.Products.Add(New Product() With { _
            Key .ProductName = "Shakespeare W. Shakespeare's dramatische Werke", _
            Key .Price = 78, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "prose") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "King Stephen. 'Salem's Lot", _
            Key .Price = 67, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "poetry") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "Plutarchus. Plutarch's moralia", _
            Key .Price = 89, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "prose") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "Twain Mark. Ventures of Huckleberry Finn", _
            Key .Price = 34, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "novel") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "Harrison G. B. England in Shakespeare's day", _
            Key .Price = 540, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "novel") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "Corkett Anne. The salamander's laughter", _
            Key .Price = 5, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "poem") _
        })
        context.Products.Add(New Product() With { _
            Key .ProductName = "Lightman Alan. Einstein''s dreams", _
            Key .Price = 5, _
            Key .Category = context.ProductCategories.Local.[Single](Function(p) p.CategoryName = "poem") _
        })

        context.Companies.Add(New Company() With { _
            Key .CompanyName = "Borland UK CodeGear Division", _
            Key .Web = "support.codegear.com/" _
        })
        context.Companies.Add(New Company() With { _
            Key .CompanyName = "Alfa-Bank", _
            Key .Web = "www.alfabank.com" _
        })
        context.Companies.Add(New Company() With { _
            Key .CompanyName = "Pioneer Pole Buildings, Inc.", _
            Key .Web = "www.pioneerpolebuildings.com" _
        })
        context.Companies.Add(New Company() With { _
            Key .CompanyName = "Orion Telecoms (Pty) Ltd.", _
            Key .Web = "www.oriontele.com" _
        })
        context.Companies.Add(New Company() With { _
            Key .CompanyName = "Orderbase Consulting GmbH", _
            Key .Web = "orderbase.de" _
        })

        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2007, 4, 11), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Borland UK CodeGear Division") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2006, 3, 11), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Borland UK CodeGear Division") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2006, 8, 6), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Alfa-Bank") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2004, 7, 6), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Alfa-Bank") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2006, 8, 8), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Alfa-Bank") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2003, 3, 1), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Pioneer Pole Buildings, Inc.") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2005, 8, 6), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Orion Telecoms (Pty) Ltd.") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2006, 8, 1), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Orion Telecoms (Pty) Ltd.") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2007, 7, 1), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Orion Telecoms (Pty) Ltd.") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2007, 2, 6), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Orderbase Consulting GmbH") _
        })
        context.Orders.Add(New Order() With { _
            Key .OrderDate = New DateTime(2007, 8, 1), _
            Key .Company = context.Companies.Local.[Single](Function(c) c.CompanyName = "Orderbase Consulting GmbH") _
        })

        context.SaveChanges()
    End Sub
End Class

  10. Now let's add code that creates the context, re-creates the database, fills it with the test data, and executes LINQ to Entities queries. Before compiling the following code add the Microsoft.EntityFrameworkCore namespace to the using list (for C#) or to the Imports list (for VB).
    C#csharp Copy Code
      class Program {

    static void Main(string[] args) {

      var context = new MyDbContext ();

      Console.WriteLine("Entity Framework Core (EF7) Code-First sample");
      Console.WriteLine();

      MyDbContextSeeder.Seed(context);

      Console.WriteLine("Products with categories");
      Console.WriteLine();

      var query = context.Products.Include(p => p.Category)
          .Where(p => p.Price > 20.0)
          .ToList();

      Console.WriteLine("{0,-10} | {1,-50} | {2}", "ProductID", "ProductName", "CategoryName");
      Console.WriteLine();
      foreach (var product in query )
        Console.WriteLine("{0,-10} | {1,-50} | {2}", product.ProductID, product.ProductName, product.Category.CategoryName);

      Console.ReadKey();
    }
  }
    Visual Basic Copy Code
    Class Program

    Private Shared Sub Main(args As String())

        Dim context = New MyDbContext()

        Console.WriteLine("Entity Framework Core (EF7) Code-First sample")
        Console.WriteLine()

        MyDbContextSeeder.Seed(context)

        Console.WriteLine("Products with categories")
        Console.WriteLine()

        Dim query = context.Products.Include(Function(p) p.Category).Where(Function(p) p.Price > 20.0).ToList()

        Console.WriteLine("{0,-10} | {1,-50} | {2}", "ProductID", "ProductName", "CategoryName")
        Console.WriteLine()
        For Each product As var In query
            Console.WriteLine("{0,-10} | {1,-50} | {2}", product.ProductID, product.ProductName, product.Category.CategoryName)
        Next

        Console.ReadKey()
    End Sub
End Class

  11. Now we can run the application. It will create tables in the database, fill them with data, execute a query and output its results to the console:
    Entity Framework Core (EF7) Code-First sample

Products with categories

ProductID  | ProductName                                        | CategoryName

1          | Harrison G. B. England in Shakespeare's day        | novel
2          | Twain Mark. Ventures of Huckleberry Finn           | novel
3          | Plutarchus. Plutarch's moralia                     | prose
4          | Shakespeare W. Shakespeare's dramatische Werke     | prose
5          | King Stephen. 'Salem's Lot                         | poetry

See Also

Entity Framework section | Entity Framework Support Overview


Entity Framework Core Database-First Tutorial

Entity Framework Core Database-First Tutorial
support@devart.com

Entity Framework Core supports Database-First approach via the Scaffold-DbContext command of Package Manager Console. This command scaffolds a DbContext and entity type classes for a specified database.

This tutorial shows how to create a simple console application, powered by Entity Framework Core and using Database-First approach. In less than 10 minutes you will have a ready-to-use data access layer for your business objects.

Requirements

This tutorial requires the following:

  • Visual Studio 2015 Update 3
  • Latest version of NuGet Package Manager
  • Latest version of Windows PowerShell

We will use the tables, we have created in the Creating Database Objects and Inserting Data Into Tables tutorials. In this tutorial it is assumed that you already have the database objects created. If you haven't created them yet, please do it before starting this tutorial.

Creating New Project

  1. Open Visual Studio 2015
  2. On the File menu point to New and then click Project. The New Project dialog box will open.
  3. On the left side of the dialog box select Templates -> Visual C# -> Windows.
  4. On the left side of the dialog box select Console Application and click Create.
  5. Ensure you are targeting .NET Framework 4.5.1 or later
  6. Enter the project name and location if necessary.
  7. Click OK. A new project will be created.

Installing NuGet Packages

After we created a new project, we need to add the necessary NuGet packages to it.

Now let's install the necessary packages:

  1. On the Tools menu point to NuGet Package Manager and then click Package Manager Console.
  2. Run the following command in the Package Manager Console:
    Install-Package Microsoft.EntityFrameworkCore.Tools -Pre

Adding References to dotConnect for Oracle Assemblies

Additionally you need to add references to the following assemblies to your project:

  • Devart.Data.dll
  • Devart.Data.Oracle.dll
  • Devart.Data.Oracle.Entity.EFCore.dll
  • Devart.Data.Oracle.Entity.EFCore.Design.dll

Creating a Model From the Database

For Entity Framework Core, creating a model from the database is as easy as entering the Scaffold-DbContext command with a connection string and a provider as parameters. For example, you can run the following command in the Package Manager Console:

Scaffold-DbContext "User Id=Scott;Password=tiger;Data Source=Ora;" Devart.Data.Oracle.Entity.EFCore

If you have other tables in your database, you may use additional parameters - -Schemas and -Tables - to filter the list of schemas and/or tables that are added to the model. For example, you can use the following command:

Scaffold-DbContext "User Id=Scott;Password=tiger;Data Source=Ora;" Devart.Data.Oracle.Entity.EFCore -Tables DEPT,EMP

As the result, a context class and entity classes are generated, based on the Dept and Emp tables.

C#csharp Copy Code
using System;
using System.Collections.Generic;

namespace ConsoleApplication1
{
   public partial class Dept
   {
       public Dept()
       {
           Emp = new HashSet<Emp>();
       }

       public int Deptno { get; set; }
       public string Dname { get; set; }
       public string Loc { get; set; }

       public virtual ICollection<Emp> Emp { get; set; }
   }
}
C#csharp Copy Code
using System;
using System.Collections.Generic;

namespace ConsoleApplication1
{
   public partial class Emp
   {
       public int Empno { get; set; }
       public string Ename { get; set; }
       public string Job { get; set; }
       public int Mgr { get; set; }
       public DateTime Hiredate { get; set; }
       public double Sal { get; set; }
       public double Comm { get; set; }
       public int Deptno { get; set; }

       public virtual Dept DeptnoNavigation { get; set; }
   }
}

Entity classes are just simple classes, representing the data, stored in the database. The context represents a session with the database and allows you to query and save instances of the entity classes.

C#csharp Copy Code
using System;
using Microsoft.EntityFrameworkCore;
using Microsoft.EntityFrameworkCore.Metadata;

namespace ConsoleApplication1
{
    public partial class ModelContext : DbContext
    {
        public virtual DbSet Dept { get; set; }
        public virtual DbSet Emp { get; set; }

        protected override void OnConfiguring(DbContextOptionsBuilder optionsBuilder)
        {
            #warning To protect potentially sensitive information in your connection string, you should move it out of source code. See http://go.microsoft.com/fwlink/?LinkId=723263 for guidance on storing connection strings.
            optionsBuilder.UseOracle(@"User Id=Scott;Password=tiger;Data Source=Ora;");
        }

        protected override void OnModelCreating(ModelBuilder modelBuilder)
        {
            modelBuilder.Entity<Dept>(entity =>
            {
                entity.HasKey(e => e.Deptno)
                    .HasName("SYS_C00220618");

                entity.ToTable("DEPT", "SCOTT");

                entity.Property(e => e.Deptno).HasColumnName("DEPTNO");

                entity.Property(e => e.Dname)
                    .HasColumnName("DNAME")
                    .HasColumnType("varchar2")
                    .HasMaxLength(14);

                entity.Property(e => e.Loc)
                    .HasColumnName("LOC")
                    .HasColumnType("varchar2")
                    .HasMaxLength(13);
            });

            modelBuilder.Entity<Emp>(entity =>
            {
                entity.HasKey(e => e.Empno)
                    .HasName("SYS_C00220619");

                entity.ToTable("EMP", "SCOTT");

                entity.Property(e => e.Empno).HasColumnName("EMPNO");

               entity.Property(e => e.Comm)
                   .HasColumnName("COMM")
                   .HasColumnType("float");

                entity.Property(e => e.Deptno).HasColumnName("DEPTNO");

                entity.Property(e => e.Ename)
                    .HasColumnName("ENAME")
                    .HasColumnType("varchar2")
                    .HasMaxLength(10);

                entity.Property(e => e.Hiredate)
                    .HasColumnName("HIREDATE")
                    .HasColumnType("date");

                entity.Property(e => e.Job)
                    .HasColumnName("JOB")
                    .HasColumnType("varchar2")
                    .HasMaxLength(9);

                entity.Property(e => e.Mgr).HasColumnName("MGR");

               entity.Property(e => e.Sal)
                   .HasColumnName("SAL")
                   .HasColumnType("float");

                entity.HasOne(d => d.DeptnoNavigation)
                    .WithMany(p => p.Emp)
                    .HasForeignKey(d => d.Deptno)
                    .HasConstraintName("SYS_C00220620");
            });
        }
    }
}

Here we may comment or delete the warning about the connection string. After this we can start using our model to retrieve and modify data.

Using Model

Open your Program.cs file and paste the following code instead of the Main function:

C#csharp Copy Code
        static void Main(string[] args)
        {
            using (var db = new ModelContext())
            {
                // Creating a new department and saving it to the database
                var newDept = new Dept();
                newDept.Deptno = 60;
                newDept.Dname = "Development";
                newDept.Loc = "Houston";
                db.Dept.Add(newDept);
                var count=db.SaveChanges();
                Console.WriteLine("{0} records saved to database", count);

                // Retrieving and displaying data
                Console.WriteLine();
                Console.WriteLine("All departments in the database:");
                foreach (var dept in db.Dept)
                {
                    Console.WriteLine("{0} | {1}", dept.Dname, dept.Loc);
                }
            }
        }

After this, on the Debug menu, click Run without debugging.

Entity Framework Core - Database-First Console application

See Also

Compatibility | Direct Mode


Entity Framework Canonical Functions

Entity Framework Canonical Functions
support@devart.com

This article can be useful for programmers who want to develop a cross-database applications and use the canonical functions. I

Entity Framework Canonical Functions are a set of functions, which are supported by all Entity Framework providers. These canonical functions will be translated to the corresponding data source functionality for the provider.

The tables below contain information about these functions supported by the Devart products. Functions supported by the following DBMS: MySQL, PostgreSQL, Oracle, SQLite, DB2, SQL Server 2005, and SQL Server 2008 are marked with green.

Please note, that the "EF version" column contains a number of Entity Framework version in which this function was defined. Additionally note that Entity Framework Canonical Functions are not supported in Entity Framework Core. This topic is applicable only to previous Entity Framework versions.

Aggregate Canonical Functions

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
Avg | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
BigCount* | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Count | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Max | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Min | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
StDev | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
StDevP | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Sum | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Var | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
VarP | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
You can read more about Aggregate Canonical functions in MSDN.

* Only SQL Server has an aggregate function COUNT_BIG(expr). This function is compiled to the ordinary COUNT(expr) in other databases.

Math Canonical Functions

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
Abs | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Ceiling | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Floor | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Power | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Round(value) | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Round(value, digits) | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Truncate | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
You can read more about Math Canonical functions in MSDN.

String Canonical Functions

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
Concat | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Contains | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
EndsWith | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
IndexOf | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Left | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Length | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
LTrim | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Replace | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Reverse | v1 | Yes | Yes | Yes / No * | Yes | No | Yes | Yes
Right | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
RTrim | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Substring | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
StartsWith | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
ToLower | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
ToUpper | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Trim | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes

* The Reverse function is supported with PostgreSQL 9.1 and higher.

You can read more about String Canonical functions in MSDN.

Date and Time Canonical Function

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
AddNanoseconds* | v4 | Yes | No | Yes | Yes | No | Yes | Yes
AddMicroseconds | v4 | Yes | No | Yes | Yes | Yes | Yes | Yes
AddMilliseconds | v4 | Yes | No | Yes | Yes | Yes | Yes | Yes
AddSeconds | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
AddMinutes | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
AddHours | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
AddDays | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
AddMonths | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
AddYears | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CreateDateTime | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CreateDateTimeOffset | v4 | Yes | No | Yes | Yes | No | No | Yes
CreateTime | v4 | Yes | Yes | Yes | Yes | Yes | No | Yes
CurrentDateTime | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CurrentDateTimeOffset | v4 | Yes | No | Yes | Yes | No | No | Yes
CurrentUtcDateTime | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Day | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
DayOfYear | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
DiffNanoseconds | v4 | No | No | No | No | No | Yes | Yes
DiffMilliseconds | v4 | No | No | No | No | Yes | Yes | Yes
DiffMicroseconds | v4 | No | No | No | No | Yes | Yes | Yes
DiffSeconds | v4 | No | No | No | No | Yes | Yes | Yes
DiffMinutes | v4 | No | No | No | No | Yes | Yes | Yes
DiffHours | v4 | No | No | No | No | Yes | Yes | Yes
DiffDays | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
DiffMonths | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
DiffYears | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
GetTotalOffsetMinutes | v1 | Yes | No | No | Yes | No | No | Yes
Hour | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Millisecond | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Minute | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Month | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Second | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Truncate | v4 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Year | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
You can read more about Date and Time Canonical functions in MSDN.

* Some DBMS can store nanoseconds into the dates, but .NET type DateTime doesn't allow nanoseconds storage. It can recognize only 100-nanoseconds intervals. The AddNanoseconds in dotConnect for SQLite realization can add only integer value of the 100-nanoseconds intervals. So, if you call AddNanoseconds(224), in the database to the value will be added only 200 nanoseconds.

Bitwise Canonical Functions

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
BitWiseAnd | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
BitWiseNot | v1 | No | Yes | Yes | Yes | Yes | Yes | Yes
BitWiseOr | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
BitWiseXor | v1 | Yes | Yes | Yes | Yes | Yes | Yes | Yes
You can read more about Bitwise Canonical functions in MSDN.

Other Canonical Functions

Canonical Function Name | EF version | Oracle | MySQL | PostgreSQL | SQLite | DB2 | MS SQL Server 2005 | MS SQL Server 2008/2012
NewGuid | v1 | Yes | No | Yes | Yes | Yes | Yes | Yes
You can read more about this group of functions in MSDN.

In conclusion, please note that the functionality of the different DBMS varies. It is reason why not all the functions can be implemented by standard routines and SQL statements. Sometimes similar functions can return different values because of different accuracy. Especially it concerns mathematic and aggregate functions.

See Also

Entity Framework Support | Entity Framework Tutorial


Working with Oracle Cursors and Stored Procedures in Entity Framework

Working with Oracle Cursors and Stored Procedures in Entity Framework
support@devart.com

This article describes how to create Entity Framework model with stored procedures in Entity Developer and EDM Designer. It tells how to create methods, based on Oracle stored procedures and functions, returning REF CURSOR parameters, and how to use the stored procedures for mapping insert, delete, and update operations.

Requirements

In order to complete this walkthrough, you will need access to the Oracle database server 9.2.0.4 or higher. You also need dotConnect for Oracle Professional Edition 5.25 or higher. Microsoft Visual Studio 2008 SP1 or higher is also required. You need to create EntityClass Dept based on Dept table in the Northwind database. You can read more about this activity in the Entity Framework tutorial.

The topics in this section are applicable to Entity Framework v1 - v6. They are not applicable to Entity Framework Core, which does not support stored routines.

Contents

  • Stored Routines in Entity Framework Model
  • Creating Database and Model
  • Stored Procedure Returning Result Set using REF CURSOR Out Parameter
  • Stored Function Returning REF CURSOR
  • Mapping CUD Operations to Stored Routines
  • Mapping CUD Operations to Command Texts
  • Working with Oracle Pipelined Functions

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard


Stored Routines in Entity Framework Model

Stored Routines in Entity Framework Model
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which supports neither stored routines nor EDM Wizard and EDM Designer.

Stored Routines Support in Entity Framework

Entity Framework has limited support for stored routines. Stored routines can be used for mapping insert, delete, and update operations and for creating methods returning collections of entities or scalar objects by using Function Import. Stored functions that were added to the storage model can be invoked with Entity SQL, but cannot be invoked directly in the LINQ to Entities.

Stored routine parameter types have the same constraint as the table and view columns - they should be primitive non-object types. REF CURSOR out parameters and stored functions, returning cursors are also supported. Stored procedures, having more than one REF CURSOR out parameters cannot be supported completely and return only one result set.

Microsoft EDM Wizard and EDM Designer

Microsoft implementation of run-time and design-time tools for Entity Framework is targeted to the users of MS SQL Server. Current functionality doesn't provide full support for specific features of Oracle stored routines.

Main disadvantages:
  • ADO.NET Entity Data Model Designer does not allow storage model editing which may cause its editing in the XML Editor. It also does not support drag-n-drop from the Server Explorer and you may need to update model with Update Wizard, which discards all manual changes made to the storage model.
  • Visual Studio 2008 SP1 code generation supports Function Import only for methods that return a collection of entities. If the method should return nothing or a collection of scalars, code generation will not work.
  • Stored functions are not supported by Function Import and cannot be used for mapping entity insert, delete, and update operations.

Devart Entity Developer

Entity Developer is designed for creating Entity Framework model visually, saving the user from editing XML manually. It provides you with completely editable storage model, including the dialog box for creating and editing command text. Drag-n-drop support from the Database Explorer eases model updating. Oracle specific features, such as returning result set using REF CURSORs and stored procedures from packages are considered. Flexible and customizable code generation supports all types of methods, created with Function Import.

Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Creating Database and Model | Stored Procedure Returning Result Set using REF CURSOR Out Parameter | Stored Function Returning REF CURSOR | Mapping CUD Operations to Stored Routines


Creating Database and Model

Creating Database and Model
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

In this chapter we consider a database and model creation and their usage with ORM tools.

  • Database objects creation
  • Devart Entity Developer
  • Microsoft EDM Wizard and EDM Designer

Database objects creation

In order to complete this walkthrough, you need to create the DEPT table and a set of stored routines after this we will create the Entity Framework model using Entity Developer or Microsoft EDM Wizard with this table in the model. See the script for the table and the routines below. In this walkthrough we will use the SCOTT schema for our database objects.

CREATE TABLE DEPT (
  DEPTNO NUMBER(9),
  DNAME VARCHAR2(20),
  LOC VARCHAR2(20),
  CONSTRAINT PK_DEPT PRIMARY KEY (DEPTNO)
);
/

CREATE SEQUENCE DEPT_SEQ;
/

CREATE TRIGGER FOR_DEPT
  BEFORE INSERT ON DEPT FOR EACH ROW
BEGIN
  SELECT DEPT_SEQ.NEXTVAL INTO :NEW.DEPTNO FROM DUAL;
END;
/

CREATE PROCEDURE GET_DEPT_PROC(curParam OUT SYS_REFCURSOR)
IS
BEGIN
  OPEN curParam FOR
    SELECT *
      FROM DEPT
    ORDER BY DEPTNO;
END;
/

CREATE FUNCTION GET_DEPT_FUNC RETURN SYS_REFCURSOR
AS
 cur SYS_REFCURSOR;
BEGIN
  OPEN cur FOR
    SELECT *
      FROM DEPT
    ORDER BY DEPTNO;
  RETURN cur;
END;
/

CREATE PROCEDURE DEPT_UPDATE(pDEPTNO INT, pDNAME VARCHAR, pLOC VARCHAR) IS
BEGIN
  UPDATE DEPT
     SET DNAME = pDNAME,
         LOC = pLOC
   WHERE DEPTNO = pDEPTNO;
END;
/

CREATE PROCEDURE DEPT_DELETE(pDEPTNO INT) IS
BEGIN
  DELETE FROM DEPT
   WHERE DEPTNO = pDEPTNO;
END;
/

CREATE PROCEDURE DEPT_INSERT(pDNAME VARCHAR, pLOC VARCHAR, curParam OUT
SYS_REFCURSOR)
IS
  OUT_DEPTNO NUMBER;
BEGIN
  INSERT INTO DEPT (DNAME, LOC) VALUES(pDNAME, pLOC) RETURNING DEPTNO INTO
OUT_DEPTNO;
  OPEN curParam FOR SELECT OUT_DEPTNO AS "OUT_DEPTNO" FROM DUAL;
END dept_insert;
/

INSERT INTO DEPT (DNAME, LOC) VALUES ('ACCOUNTING', 'NEW YORK');
INSERT INTO DEPT (DNAME, LOC) VALUES ('RESEARCH', 'DALLAS');
INSERT INTO DEPT (DNAME, LOC) VALUES ('SALES', 'CHICAGO');
INSERT INTO DEPT (DNAME, LOC) VALUES ('OPERATIONS', 'BOSTON');

Devart Entity Developer

After you have created these database objects, perform the following steps:
  1. Choose Create From Database from the File menu.
  2. The Database Reverse Engineering Wizard will appear. Click Entity Framework and then click the Next button.
  3. Choose dotConnect for Oracle in the Provider box and set the connection parameters to connect to the database with the created objects. You can use Test Connection button to verify the entered parameters. Click the Next button.

  4. Expand the database node in the Choose source tree and then the Tables node. Select the DEPT table node check box and click Next.

  5. Set naming options for classes and properties. Click Next.
  6. Specify the namespace for the generated classes, enter name for Entity Container, and click the Next button.

  7. Clear the Run generator for model check box if it is selected and click the Finish button.

Microsoft EDM Wizard and EDM Designer

Perform the following steps to create such model in Visual Studio:
  1. Create your project in the Visual Studio.
  2. Right-click it in the Solution Explorer and choose Add -> New Item from the popup menu.
  3. Click ADO.NET Entity Data Model in the Templates box, specify the name for the model, and click Add.

  4. Click Generate from database and then click Next.

  5. Click the New Connection button.
  6. In the appeared Choose Data Source Dialog Box click Oracle Database in the Data source list and select dotConnect for Oracle in the Data provider drop-down list, then click OK.

  7. Specify the connection parameters and click OK.
  8. Specify whether to include the sensitive data in the connection string and click Next.

  9. Select the check boxes for the DEPT table and GET_DEPT_PROC, GET_DEPT_FUNC, DEPT_UPDATE, DEPT_DELETE, DEPT_INSERT stored procedures.

    Note:

    For Entity Developer we did not select the stored routines because in Entity Developer it is very easy to add them later. In Microsoft EDM Designer you may use the Update Wizard to add a stored procedure into an existing model, but remember that Update Wizard overwrites the storage model and may discard your manual changes. So, it is better to add everything we need when creating model.

  10. Specify the Model Namespace and click Finish.

Previous chapter | Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Stored Routines in Entity Framework Model | Stored Procedure Returning Result Set using REF CURSOR Out Parameter | Stored Function Returning REF CURSOR | Mapping CUD Operations to Stored Routines


Stored Procedure Returning Result Set using REF CURSOR Out Parameter

Stored Procedure Returning Result Set using REF CURSOR Out Parameter
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

In this chapter we consider an usage of stored procedures with ORM tools.

  • Procedure creation
  • Devart Entity Developer
  • Microsoft EDM Wizard and EDM Designer
  • Using the Method

Procedure creation

Code of the procedure:

CREATE PROCEDURE GET_DEPT_PROC(curParam OUT SYS_REFCURSOR)
IS
BEGIN
 OPEN curParam FOR
 SELECT *
  FROM DEPT
  ORDER BY DEPTNO;
END;

Devart Entity Developer

Expand the connection node in the Database Explorer, then your schema node and then the Stored Procedures node. Drag the GET_DEPT_PROC to the diagram sheet. The function will be created in the storage model, its REF CURSOR parameter is hidden and its ResultSetParameterName attribute is automatically set to the needed parameter. Corresponding method will be automatically created in the conceptual model. However, you need to set the return type for it manually. To do this perform the following actions:

  1. Double-click the method in the Model Explorer.
  2. Select DEPT from the Value Types drop-down list.

  3. Click OK.

You also may drag the procedure from Database Explorer to the storage model node in the Model Explorer. In such case only the storage model is updated, the corresponding method is not created. To create corresponding method, drag the procedure from the Model Explorer to the diagram sheet or right-click it in the Model Explorer and select Create Method from the popup menu.

Microsoft EDM Wizard and EDM Designer

After we have added GET_DEPT_PROC procedure to the model, the following XML was generated for it.

<Function Name="GET_DEPT_PROC" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT">
            <Parameter Name="CURPARAM" Type="REF CURSOR" Mode="Out" />
        </Function>
We need to perform some XML code changes manually to use this procedure in our model.
  1. Right-click the model and select Open With from the popup menu.

  2. Click XML Editor in the Choose the program you want to use to open this file box and then click OK.
  3. If the model was already opened in the model designer, Visual Studio will ask you whether to close the designer. Click Yes.
  4. Add the following attribute to the Schema tag, which is in the Storage Model:
    xmlns:devart="http://devart.com/schemas/edml/StorageSchemaExtensions/1.0"
  5. Add the devart:ResultSetParameterName attribute with the "CURPARAM" value to the FUNCTION tag of the GET_DEPT_PROC function, and remove its CURRPARAM Parameter tag. The result XML for the function should look like this:
    <Function Name="GET_DEPT_PROC" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT"
devart:ResultSetParameterName="CURPARAM">
        </Function>
  6. Save the file and close it.
  7. Reopen it in the ADO.NET EDM Designer.
  8. Locate the GET_DEPT_PROC in the Model Browser. Right-click it and select Create Function Import from the popup menu.
  9. In the Add Function Import dialog box click Entities and then select DEPT from the Entities drop-down list. You also may change the Function Import Name.

  10. Click OK.

Using the Method

This example illustrates call of the method, retrieving the collection of entities, and entity output to console. Object context name and case of the Depts class and its fields may differ in your case.

C#csharp Copy Code
    using (SCOTTEntities context = new SCOTTEntities()) {
       var depts = context.GetDeptProc();
       foreach (Dept item in depts)
           Console.WriteLine("Dept {0}: '{1}', '{2}'", item.Deptno, item.Dname, item.Loc);
    }

Visual Basic Copy Code
        Using context = New SCOTTEntities
            Dim depts = context.GETDEPTPROC()
            For Each dept As DEPT In depts
                Console.WriteLine("Dept {0}: '{1}', '{2}'", dept.DEPTNO, dept.DNAME, dept.LOC)
            Next
        End Using

Previous chapter | Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Stored Routines in Entity Framework Model | Creating Database and Model | Stored Function Returning REF CURSOR | Mapping CUD Operations to Stored Routines


Stored Function Returning REF CURSOR

Stored Function Returning REF CURSOR
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

In this chapter we consider an usage of stored functions with ORM tools.

  • Function creation
  • Devart Entity Developer
  • Microsoft EDM Wizard and EDM Designer
  • Using the Method

Function creation

Code of the function:

CREATE FUNCTION GET_DEPT_FUNC RETURN SYS_REFCURSOR
AS
cur SYS_REFCURSOR;
BEGIN
  OPEN cur FOR
  SELECT *
    FROM DEPT
    ORDER BY DEPTNO;
  RETURN cur;
END;

Devart Entity Developer

Expand the connection node in the Database Explorer, then your schema node and then the Functions node. Drag the GET_DEPT_FUNC to the diagram sheet. The function will be created in the storage model, and its following attributes will be set:

  • IsComposable="false" - This attribute indicates if the function returns some value.
  • IsConcealedFunction="true" - This attribute indicates that the function returns value, but the value is invisible for the Entity Framework.

Corresponding method will be automatically created in the conceptual model. However, you need to set the return type for it manually. To do this perform the following actions:

  1. Double-click the method in the Model Explorer.
  2. Click Entities and then select DEPT from the Entities drop-down list.

  3. Click OK.

You also may drag the function from Database Explorer to the storage model node in the Model Explorer. In such case only the storage model is updated, the corresponding method is not created. To create corresponding method, drag the function from the Model Explorer to the diagram sheet or right-click it in the Model Explorer and select Create Method from the popup menu.

Microsoft EDM Wizard and EDM Designer

After we have added GET_DEPT_FUNC function to the model, the following XML was generated for it.
<Function Name="GET_DEPT_FUNC" ReturnType="REF CURSOR" Aggregate="false"
BuiltIn="false" NiladicFunction="false" IsComposable="true"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT" />
We need to perform some XML code changes manually to use this function in our model.
  1. Right-click the model and select Open With from the popup menu.
  2. Click XML Editor in the Choose the program you want to use to open this file box and then click OK.
  3. If the model was already opened in the model designer, Visual Studio will ask you whether to close the designer. Click Yes.
  4. Add the devart:IsConcealedFunction="true" attribute to the FUNCTION tag of the GET_DEPT_FUNC function.
  5. Replace the ReturnType="REF CURSOR" attribute with the devart:ReturnType="REF CURSOR"
  6. Change value of the IsComposable attribute from "true" to "false". The result XML for the function should look like this:

    <Function Name="GET_DEPT_FUNC" devart:IsConcealedFunction="true"
devart:ReturnType="REF CURSOR" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT" />
  7. Save the file and close it.
  8. Reopen it in the ADO.NET EDM Designer.
  9. Locate the GET_DEPT_FUNC in the Model Browser. Right-click it and select Create Function Import from the popup menu.
  10. In the Add Function Import dialog box click Entities and then select DEPT from the Entities drop-down list. You also may change the Function Import Name.

  11. Click OK.

Using the Method

This example illustrates call of the method, retrieving the first element of the collection of entities, and output to console. Object context name and case of the Depts class and its fields may differ in your case.

C#csharp Copy Code
      using (SCOTTEntities context = new SCOTTEntities()) {
         Dept dept = context.GetDeptFunc().First();
         Console.WriteLine("Dept {0}: '{1}', '{2}'", dept.Deptno, dept.Dname, dept.Loc);
      }

Visual Basic Copy Code

    Using context = New SCOTTEntities
        Dim dept As Dept =  context.GetDeptFunc().First()
        Console.WriteLine("Dept {0}: '{1}', '{2}'", dept.Deptno, dept.Dname, dept.Loc)
    End Using

Previous chapter | Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Stored Routines in Entity Framework Model | Creating Database and Model | Stored Procedure Returning Result Set using REF CURSOR Out Parameter | Mapping CUD Operations to Stored Routines


Mapping CUD Operations to Stored Routines

Mapping CUD Operations to Stored Routines
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

In this chapter we consider use of stored routines for insert/update/delete operations

  • Database objects creation
  • Devart Entity Developer
  • Microsoft EDM Wizard and EDM Designer
  • Creating New Entity Instance

Database objects creation

Using stored routines for insert/update/delete operations is a widely met task in developing applications, working with databases. And it is often necessary that insert operation should return primary key column values. Let's see, how it is done with Entity Framework.

Code of the stored routines:

CREATE PROCEDURE DEPT_UPDATE(pDEPTNO INT, pDNAME VARCHAR, pLOC VARCHAR) IS
BEGIN
  UPDATE DEPT
    SET DNAME = pDNAME,
    LOC = pLOC
    WHERE DEPTNO = pDEPTNO;
END;
/

CREATE PROCEDURE DEPT_DELETE(pDEPTNO INT) IS
BEGIN
  DELETE FROM DEPT
    WHERE DEPTNO = pDEPTNO;
END;
/

CREATE PROCEDURE DEPT_INSERT(pDNAME VARCHAR, pLOC VARCHAR, curParam OUT
SYS_REFCURSOR)
IS
  OUT_DEPTNO NUMBER;
BEGIN
  INSERT INTO DEPT(DNAME, LOC) VALUES(pDNAME, pLOC) RETURNING DEPTNO INTO
    OUT_DEPTNO;
  OPEN curParam FOR SELECT OUT_DEPTNO AS "OUT_DEPTNO" FROM DUAL;
END dept_insert;
/

Devart Entity Developer

  1. Expand the connection node in the Database Explorer, then your schema node and then the Stored Procedures node.
  2. Drag the DEPT_UPDATE, DEPT_DELETE, and DEPT_INSERT procedures to the storage model node in the Model Explorer to avoid automatic method creating.
  3. Right-click the Dept class and then click Stored Procedure Mapping.
  4. In the Commands list click Insert.
  5. In the Stored Procedure list select the DEPT_INSERT stored procedure.
  6. Click <Add Result Binding> in the Result Column Bindings grid and type OUT_DEPTNO.
  7. Click the corresponding Property column cell of the Result Column Bindings grid, and select Deptno in the drop-down list.

    Stored Procedure Mapping - Insert

  8. The corresponding Dept properties are automatically mapped to the parameters in the grid below the Stored Procedure drop-down list because they have the same names. If the parameter names were different, you would need to map them by selecting the corresponding property from the drop-down list in the Property column.
  9. In the Commands list click Update.
  10. In the Stored Procedure list select the DEPT_UPDATE stored procedure.
  11. The corresponding Dept properties are automatically mapped to the parameters in the grid below the Stored Procedure drop-down list because they have the same names. If the parameter names were different, you would need to map them by selecting the corresponding property from the drop-down list in the Property column.

    Stored Procedure Mapping - Update

  12. In the Commands list click Delete.
  13. In the Stored Procedure list select the DEPT_DELETE stored procedure.
  14. The corresponding DeptNo Property is automatically mapped to the corresponding parameter in the grid below the Stored Procedure drop-down list.

    Stored Procedure Mapping - Delete
  15. Click OK.

Microsoft EDM Wizard and EDM Designer

After we have added DEPT_UPDATE, DEPT_DELETE, and DEPT_INSERT procedures to the model, the following XML was generated for them.
        <Function Name="DEPT_DELETE" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT">
            <Parameter Name="PDEPTNO" Type="decimal" Mode="In" />
        </Function>
        <Function Name="DEPT_INSERT" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT">
            <Parameter Name="PDNAME" Type="VARCHAR2" Mode="In" />
            <Parameter Name="PLOC" Type="VARCHAR2" Mode="In" />
            <Parameter Name="CURPARAM" Type="REF CURSOR" Mode="Out" />
        </Function>
        <Function Name="DEPT_UPDATE" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT">
            <Parameter Name="PDEPTNO" Type="decimal" Mode="In" />
            <Parameter Name="PDNAME" Type="VARCHAR2" Mode="In" />
            <Parameter Name="PLOC" Type="VARCHAR2" Mode="In" />
        </Function>
We need to perform some XML code changes manually to use this procedure in our model.
  1. Right-click the model and select Open With from the popup menu.
  2. Click XML Editor in the Choose the program you want to use to open this file box and then click OK.
  3. If the model was already opened in the model designer, Visual Studio will ask you whether to close the designer. Click Yes.
  4. Add the devart:ResultSetParameterName attribute with the "curParam" value to the FUNCTION tag of DEPT_INSERT function, and remove its curParam Parameter tag. The result XML for the function should look like this:
            <Function Name="DEPT_INSERT" Aggregate="false" BuiltIn="false"
NiladicFunction="false" IsComposable="false"
ParameterTypeSemantics="AllowImplicitConversion" Schema="SCOTT"
devart:ResultSetParameterName="CURPARAM">
            <Parameter Name="PDNAME" Type="VARCHAR2" Mode="In" />
            <Parameter Name="PLOC" Type="VARCHAR2" Mode="In" />
        </Function>
  5. Save the file and close it.
  6. Reopen it in the ADO.NET EDM Designer.
  7. Right-click the DEPT entity in the Model Browser window and choose Stored Procedure Mapping in the popup menu.
  8. Click <Select Insert Function> and select DEPT_INSERT from the drop-down list.
  9. Assign the corresponding Dept properties to the parameters in the grid below by selecting the corresponding property from the drop-down list in the Property column.
  10. Click <Add Result Binding> in the Result Column Bindings node and type OUT_DEPTNO.
  11. Choose Deptno in the drop-down list in the Property column of the Result Column Bindings node.
  12. Click <Select Update Function> and select DEPT_UPDATE from the drop-down list.
  13. Assign the corresponding Dept properties to the parameters in the grid below by selecting the corresponding property from the drop-down list in the Property column.
  14. Click <Select Delete Function> and select DEPT_DELETE from the drop-down list.

  15. Assign the Deptno property to the only parameter in the grid below by selecting the corresponding property from the drop-down list in the Property column.

Creating New Entity Instance

This example shows how to create a new entity instance and save it to database. When the entity is saved to the database, its Deptno field is updated. This new value is output to the console.

C#csharp Copy Code
        using (SCOTTEntities context = new SCOTTEntities()) {
        Dept newDept = new Dept() { Dname = "New DNAME", Loc = "New LOC" };
        context.AddToDepts(newDept);
        context.SaveChanges();
        Console.WriteLine("DEPTNO: {0}", newDept.Deptno);
      }

Visual Basic Copy Code

Dim context As SCOTTEntities
Using context = New SCOTTEntities
   Dim newDept As New Dept
   newDept.Dname = "New DNAME"
   newDept.Loc = "New LOC"
   context.AddToDepts(newDept)
   context.SaveChanges()
   Console.WriteLine("DEPTNO: {0}", newDept.Deptno)
End Using

Previous chapter | Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Stored Routines in Entity Framework Model | Creating Database and Model | Stored Procedure Returning Result Set using REF CURSOR Out Parameter | Stored Function Returning REF CURSOR | Mapping CUD Operations to Command Texts | Working with Oracle Pipelined Functions


Mapping CUD Operations to Command Texts

Mapping CUD Operations to Command Texts
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

In the previous chapter we have considered mapping CUD operations to stored routines, which is very useful when you need the insert operation to return primary key values or other column values and in other cases. However, sometimes there are no such stored routines in the database, and adding ones is not allowed or is undesirable. In this case you may emulate the routines with PL/SQL blocks in the SSDL part of your model instead of creating actual stored routines.

  • Devart Entity Developer
  • Microsoft EDM Wizard and EDM Designer
  • Creating New Entity Instance

Devart Entity Developer

  1. Expand the storage node (<ModelName>.Store)
  2. Right-click the Stored Procedures node, then point to Add and click New Command Text.

  3. Paste the following code to the SQL Script box:

    DECLARE
  a ROWID;
BEGIN
  INSERT INTO dept (deptno, dname)
  VALUES (:p0, :p1)
  RETURNING ROWID INTO a;

  OPEN :curparam FOR SELECT loc FROM dept WHERE ROWID=a;
END;
  4. Click the Parameters tab.
  5. You will be asked whether to regenerate the parameters collection. Click Yes.
  6. Click the p0 parameter in the Parameter Name list and select Int in the Data Type list.
  7. Click the curparam parameter in the Parameter Name list and then click Remove.
  8. Click OK.
  9. Right-click the Dept class and then click Stored Procedure Mapping.
  10. In the Commands list click Insert.
  11. In the Stored Procedure list select the Procedure1 command text.
  12. Click the corresponding Property column cell in the p0 row of tthe grid under Storage Procedure and select Deptno in the drop-down list.
  13. Click the corresponding Property column cell in the p1 row of the grid under Storage Procedure and select DName in the drop-down list.
  14. Click <Add Result Binding> in the Result Column Bindings grid and type LOC.
  15. Click the corresponding Property column cell in the Result Column Bindings grid and select LOC in the drop-down list.

    Mapping Insert operation to Command text in Entity Developer
  16. Click OK.

Microsoft EDM Wizard and EDM Designer

We need to perform some XML code changes manually to use this procedure in our model. We will add our command text function to it.

  1. Right-click the model and select Open With from the popup menu.
  2. Click XML Editor in the Choose the program you want to use to open this file box and then click OK.
  3. If the model was already opened in the model designer, Visual Studio will ask you whether to close the designer. Click Yes.
  4. Add the following Function element to the Schema element of the edmx:StorageModels tag.
            <Function Name="Procedure1" devart:ResultSetParameterName="curparam" IsComposable="false" BuiltIn="false" Aggregate="false" NiladicFunction="false" ParameterTypeSemantics="AllowImplicitConversion">
          <CommandText>declare
  a rowid;
begin
  INSERT INTO dept (deptno, dname)
  VALUES (:p0, :p1)
  RETURNING rowid INTO a;

  open :curparam for select loc from dept where rowid=a;
end;</CommandText>
          <Parameter Name="p0" Type="int" Mode="In" />
          <Parameter Name="p1" Type="NVARCHAR2" Mode="In" />
        </Function>

    Note that the following attribute must be added to the Schema element of the edmx:StorageModels tag, as we did in the Stored Procedure Returning Result Set using REF CURSOR Out Parameter chapter:

    xmlns:devart="http://devart.com/schemas/edml/StorageSchemaExtensions/1.0"
  5. Save the file and close it.
  6. Reopen it in the ADO.NET EDM Designer.
  7. Right-click the DEPT entity in the Model Browser window and choose Stored Procedure Mapping in the popup menu.
  8. Click <Select Insert Function> and type in the name of the created command text - Procedure1.
  9. Assign the corresponding Dept properties to the parameters in the grid below by selecting the corresponding property from the drop-down list in the Property column.
  10. Click <Add Result Binding> in the Result Column Bindings node and type LOC.
  11. Choose LOC in the drop-down list in the Property column of the Result Column Bindings node.

    12. Mapping CUD Operations to Command Text in EDM Designer

Creating New Entity Instance

This example shows how to create a new entity instance and save it to database. When the entity is saved to the database, its Deptno field is updated. This new value is output to the console.

C#csharp Copy Code
        using (SCOTTEntities context = new SCOTTEntities()) {
        Dept newDept = new Dept() { Dname = "New DNAME", Deptno = 2020 };
        context.AddToDepts(newDept);
        context.SaveChanges();
        Console.WriteLine("LOC: {0}", newDept.Loc);
      }

Visual Basic Copy Code

Dim context As SCOTTEntities
Using context = New SCOTTEntities
   Dim newDept As New Dept
   newDept.Dname = "New DNAME"
   newDept.Deptno = 2020
   context.AddToDepts(newDept)
   context.SaveChanges()
   Console.WriteLine("LOC: {0}", newDept.Loc)
End Using

Previous chapter | Content | Next chapter

See Also

Entity Framework Tutorial | Using Entity Data Model Wizard | Stored Routines in Entity Framework Model | Creating Database and Model | Stored Procedure Returning Result Set using REF CURSOR Out Parameter | Stored Function Returning REF CURSOR | Mapping CUD Operations to Stored Routines | Working with Oracle Pipelined Functions


Working with Oracle Pipelined Functions

Working with Oracle Pipelined Functions
support@devart.com

This topic is applicable to Entity Framework v1 - v6. It is not applicable to Entity Framework Core, which does not support stored routines.

Oracle pipelined functions are stored functions that return a collection type result iteratively by elements. There are two ways to run Oracle pipelined function via Entity Framework - creating an entity based on such function or reting a Function Import. They will be demonstrated using the following sample pipelined function:

CREATE TYPE ARRAY AS TABLE OF NUMBER;

CREATE FUNCTION gen_numbers(n IN NUMBER DEFAULT NULL)
RETURN ARRAY
PIPELINED
AS
BEGIN
  FOR i IN 1 .. nvl(n,999999999)
  LOOP
    PIPE ROW(i);
  END LOOP;
  RETURN;
END;

Creating Entity Based on Oracle Pipelined Function

  1. Right-click the Tables/Views node in Model Explorer and select Defining Query from the Add submenu of the shortcut menu.

    Adding defining query

  2. Type SELECT * FROM TABLE(GEN_NUMBERS(100)) in Defining Query Editor. Replace 100 here with your own value. Be aware that this value will be obfuscated.

    Defining Query Editor
  3. Click Execute and make sure that correct data are returned (a grid will be displayed).
  4. Switch to the Columns tab to generate the collection of columns.
  5. Close Defining Query Editor by clicking OK - Entity1 will be created.
  6. Drag Entity1 from the storage model in Model Explorer to the diagram surface - this creates the corresponding entity in the conceptual part of the model.
  7. Save the model to generate code.

Now you can use this pipelined function as a usual entity.

C#csharp Copy Code
using (PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities context =
    new PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities())
{
    var query1 = context.Entity1s
        .Select(e1 => e1.COLUMNVALUE)
        .ToList();

    var query2 = context.Entity1s
        .Where(e2 => e2.COLUMNVALUE > 5)
        .Take(10)
        .OrderByDescending(e2 => e2.COLUMNVALUE)
        .Select(e2 => e2.COLUMNVALUE)
        .ToList();
}
Visual Basic Copy Code
Using context As New PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities()
      Dim query1 = context.Entity1s.[Select](Function(e1) e1.COLUMNVALUE).ToList()

      Dim query2 = context.Entity1s.Where( _
        Function(e2) e2.COLUMNVALUE > 5 _
    ) _
        .Take(10) _
        .OrderByDescending(Function(e2) e2.COLUMNVALUE)
        .[Select](Function(e2) e2.COLUMNVALUE).ToList()
End Using

Advantages:

  • You can work with this function like with a usual entity - apply conditions, use ".Where", join it with other entities, order data, etc., and all of this is performed on the server side.

Disadvantages:

  • You cannot specify different parameter values for a function. The only way to do it is to create other entities with a different defining query.
  • Applying Where condition is not as effective as in case of selecting data from a table. Thought everything is performed on the server side, the function still produces all the data, though the part of it that does not match to the condition is not sent to the client.
  • If a result set, returned by a pipelined function, does not contain a set of columns that can uniquely identify each row, this method is not applicable.

Creating Function Import Based on Oracle Pipelined Function

  1. Drag the stored function to the Stored Procedures node in Model Explorer. The model will become not valid.
  2. Set the Concealed property of this function to true.
  3. Drag this function from the Model Explorer to the diagram surface to create the corresponding method in conceptual model (Function Import). Click Yes when dialog asks you to obtain metadata of procedure result set to generate complex type automatically

    Metadata retrieval warning
  4. Save the model to generate code.

Now you can use this pipelined function in the following way.

C#csharp Copy Code
using (PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities context =
    new PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities()) {
var results = context.GENNUMBER(14).Select(e => e.MyProperty).ToList();
}
Visual Basic Copy Code
Using context As New PipelinedFunctionDemoModel.PipelinedFunctionDemoEntities()
    Dim results = context.GENNUMBER(14).[Select](Function(e) e.MyProperty).ToList()
End Using

Advantages:

  • It is possible to use different parameter values.

Disadvantages:

  • You cannot work with this function as with entity - use where conditions, etc.
Previous chapter | Content


Working with Transactions in Entity Framework

Working with Transactions in Entity Framework
support@devart.com

In this article we consider a short description of the Entity Framework transactional models. There are also some simple code listings illustrating different aspects of the transactional model.

A transaction is a series of operations performed as a single unit of work. Entity Framework transactions are a part of its internal architecture. The SaveChanges method operates within a transaction and saves results of the work. It is designed to ensure data integrity. The common reason of integrity problems is a Concurrency violation, which can be raised during the saving process. Concurrency violation occurs an OptimisticConcurrencyException in this case. To resolve this conflict call the Refresh method with the StoreWins or ClientWins value, and after that call SaveChanges again. But be aware, that the Refresh with the ClientWins option can be a source of problem too. It rewrites all changes made to the data after context query execution.

Imagine we want the SaveChanges to be only a part of more complicated update process. For example, we want to execute several SaveChanges as one operation in a single ObjectContext or DbContext.

The possible solution is to use the database connection. The connection is accessed differently for ObjectContext and DbContext. An example for ObjectContext:

C#csharp Copy Code
    var connection = context.Connection;
Visual Basic Copy Code
    Dim connection = context.Connection

For DbContext you should open the connection of internal ObjectContext which is within DbContext.

C#csharp Copy Code
    var connection = ((IObjectContextAdapter)dbContext).ObjectContext.Connection;
Visual Basic Copy Code
    Dim connection = DirectCast(dbContext, IObjectContextAdapter).ObjectContext.Connection

The rest of the sample is the same for ObjectContext and DbContext:

C#csharp Copy Code
       //Opening connection
        connection.Open();
        DEPT department = context.DEPT.Where(d => d.DEPTNO == 10).First();
        department.LOC = "TEST";
        //Opening transaction
        using (System.Data.Common.DbTransaction transaction = context.Connection.BeginTransaction())
        {
           //This call participates in the transaction
           context.SaveChanges();
           department.DNAME = "TEST";
           //This call also participates in the transaction
           context.SaveChanges();
           //Replace the flag condition with the one you need
           //or remove it and leave only commit part
           if(flag)
           {
              //transaction completed successfully, both calls succeeded
              transaction.Commit();
           }
           else
           {
              //something is wrong, both calls are rolled back
              transaction.Rollback();
           }
        }
Visual Basic Copy Code
        'Opening connection
        connection.Open()
    Dim department As Dept = context.Depts.Where(Function(ByVal d As Dept) d.Deptno = 10).First()
    department.LOC = "TEST"
        'Opening transaction
        Using transaction As System.Data.Common.DbTransaction = Context.Connection.BeginTransaction()
        {
           'This call participates in the transaction
            Context.SaveChanges()
        department.DNAME = "TEST"
           'This call also participates in the transaction
           context.SaveChanges();
           'Replace the flag condition with the one you need
           'or remove it and leave only commit part
           if(flag)
           {
              'transaction completed successfully, both calls succeeded
              transaction.Commit()
           }
           else
           {
              'something is wrong, both calls are rolled back
              transaction.Rollback()
           }
        }

The transaction is opened on database connection, and SaveChanges are added to this transaction.

You can use TransactionScope as another approach (our solutions have implementation of the TransactionScope for Oracle, MySQL and PostgreSQL database servers). It can be used both as a local transaction replacement and as a wrapping transaction for the local SaveChanges.

The TransactionScope ensures that changes to objects in the object context are coordinated with a message queue. Object Services use this transaction when it saves changes to the database. When an UpdateException occurs, the operation is retried up to two times. The changes in the object context are accepted when the operation succeeds. See Managing Transactions in Object Services for more information.

A TransactionScope object has three options:

  1. Join the ambient transaction, or create a new one if one does not exist (Required).
  2. Be a new root scope, that is, start a new transaction and have that transaction be the new ambient transaction inside its own scope (RequiresNew).
  3. Not take part in a transaction at all. There is no ambient transaction as a result (Suppress).

The following code displays the RequiresNew usage.

C#csharp Copy Code

        DEPT department = context.DEPT.Where(d => d.DEPTNO == 25).First();
        department.DNAME = "xxx";
        using (TransactionScope tscope = new TransactionScope(TransactionScopeOption.RequiresNew))
        {
           //a new transaction will be created for this call
           context.SaveChanges();
           tscope.Complete();
        }
Visual Basic Copy Code
        Dim department As Dept = Context.Depts.Where(Function(ByVal d As Dept) d.DEPTNO = 25).First()
    department.Dname = "xxx"
    Using TScope As New TransactionScope(TransactionScopeOption.RequiresNew)
       'a new transaction will be created for this call
        Context.SaveChanges()
            TScope.Complete()
    End Using

You can find more information about Transactions in MSDN.


Generating Database from Model

Generating Database from Model
support@devart.com

Entity Framework v4, v5, and v6 allow you to use Model First feature to generate database, and the SSDL, and MSL. In this article we consider how to use this functionality.

Note that this functionality is not supported in Entity Framework Core.

This feature provides a possibility to start from a conceptual model and then to generate the other parts of the EDM (Entity Data Model) and the database. Create Database from Model wizard can be used for database generation from an Entity Data Model in Visual Studio 2010 - 2015.

Entity Framework workflow for DDL generating from CSDL includes two actions. The first one generates SSDL and MSL from CSDL. It is common for all providers and cannot be customized independently. The second action is specific to Entity Framework provider and can be modified for specific DBMS.

Devart offers additional templates for database script generation.

The following steps will guide you through database generation wizard:

  1. Create an EF model. The given example shows a CRM_DEMO schema.
    Entity Framework model
  2. Select a corresponding template in the model properties window. Then right-click on the diagram and run the Create Database from Model wizard by choosing Generate Database from Model from the popup menu.
    generating database from model
    3. Note Note:
    The default schema name for Microsoft SQL Server database is "dbo". Don't forget to change it to the necessary one before the code generation.
  3. Here is a DDL script generated for the current model.
    Generate Database Wizard - Summary and Settings

As a result of these steps you will obtain a valid database-specific DDL script. You can run this script against your database to create a valid database schema.

Note Note:

Microsoft does not take into account the Oracle 30 symbol limitation on the length of database object names. That may result in problems in case your conceptual model contains objects with very long names. We are generating SQL using the storage model (SSDL). The SSDL generation in its turn is performed by EDM Designer. The procedure of generation is described here:

\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\DBGen\TablePerTypeStrategy.xaml.

Our generation is performed using the .tt templates:

\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\DBGen\Devart SSDLToOracle.tt

\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\Templates\Includes\Devart SSDLToOracle.ttinclude

\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\Templates\Includes\Devart SSDLToSQL.ttinclude

\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\DBGen\Devart SSDLToSQLite.tt

10.0 here is the Visual Studio version for Visual Studio 2010. For other Visual Studio versions, you need to place the following versions instead of 10.0:

  • Visual Studio 2012 - 11.0
  • Visual Studio 2013 - 12.0
  • Visual Studio 2015 - 14.0

One can change these templates to modify the generated DDL. There is a limitation in Devart SSDLToOracle.ttinclude: IdentifierMaxLength = 30; If it is removed, it is changed to a greater value, DDL will be successfully generated, but there will be an Oracle exception while executing the script.

The names of generated primary keys, foreign keys, triggers, sequences are cut to fit 30 symbols. We don't cut the names of tables and columns - this allow creating a valid DDL, but this will cause runtime errors because these names will still be full in the model.

So, there can be two solutions for the problem:

  1. Shorten the names of classes and fields to 30 symbols or less.
  2. After SSDL is generated, open the model in XML Editor and shorten the names of long identifiers in the SSDL and MSL parts of the model, and generate DDL (without SSDL regeneration).

Please also note that dotConnect for Oracle goes with its own ORM designer - Entity Developer. It provides advanced Model First support and a number of other features, not available in Visual Studio EDM designer.

See Also

Entity Framework | Entity Framework Tutorial


Entity Framework Spatials

Entity Framework Spatials
support@devart.com

This section is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

This section describes support for Entity Framework spatials in dotConnect for Oracle.

  • Spatials Overview
  • Choosing Spatial Service
  • Spatial Options
  • DbGeometry/DbGeography Support in Spatial Services


Spatials Overview

Spatials Overview
support@devart.com

This topic is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

In Oracle, the MDSYS.SDO_GEOMETRY object type is used to represent spatials. Entity Framework 5 uses DbGeometry and DbGeography types from the System.Data.Entity.dll assembly for this purpose (.NET Framework 4.5). Entity Framework 6 uses DbGeometry and DbGeography types from the EntityFramework.dll (.NET Framework 4.0 and .NET Framework 4.5).

When using XML mapping spatial types are mapped in the following way in edmx/edml files:

Oracle data types | SSDL | CSDL | .NET
MDSYS.SDO_GEOMETRY | sdo_geometry | Geometry, GeometryCollection, GeometryLineString, GeometryMultiLineString, GeometryMultiPoint, GeometryMultiPolygon, GeometryPoint, GeometryPolygon | DbGeometry
MDSYS.SDO_GEOMETRY | sdo_geography | Geography, GeographyCollection, GeographyLineString, GeographyMultiLineString, GeographyMultiPoint, GeographyMultiPolygon, GeographyPoint, GeographyPolygon | DbGeography

When creating Entity Framework model in Entity Data Model Wizard or LightSwitch Attach Data Source Wizard using Database First approach, all spatial columns are mapped to DbGeometry, and it is impossible to change this behaviour currently. If you need to map properties to DbGeography, open the Entity Framework model with XML editor and replace data type for the required columns: "sdo__geometry" with "sdo__geography" in SSDL and "Geometry" with "Geography" in CSDL. When creating an Entity Framework model in Devart Entity Developer using Database First approach, you can define corresponding data type mapping rules.

See Also

Choosing Spatial Service


Choosing Spatial Service

Choosing Spatial Service
support@devart.com

This topic is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

A spatial service is used for reading spatial objects from the database, saving objects to database, working with static and instance methods and properties of the DbGeometry and DbGeography classes.

Spatial Services, Provided by dotConnect for Oracle

NetTopologySuite

The NetTopologySuiteSpatialService class is used. It uses NetTopologySuite library.

Provider value is a NetTopologySuite object, which can be used with third-party libraries that support NetTopologySuite (like SharpMap v1 and higher).

This service requires NetTopologySuite.dll, GeoAPI.dll, and PowerCollections.dll assemblies from the NetTopologySuite project website.

SharpMap

This spatial service is considered deprecated. It is not recommended to use in new projects. We recommend using NetTopologySuite spatial service instead.

OracleSharpMapSpatialService class is used. It uses SharpMap v0.9 library.

Provider value is a SharpMap object, which can be used with third-party libraries that support SharpMap 0.9.

This service requires Devart.Data.Oracle.Entity.Spatials.EF5.dll or Devart.Data.Oracle.Entity.Spatials.EF6.dll assembly (for Entity Framework v5 or v6 respectively), which is supplied with dotConnect for Oracle, and SharpMap.dll and ProjNET.dll assemblies from the SharpMap project website.

Note that since SharpMap.dll is unsigned, Devart.Data.Oracle.Entity.Spatials.EF5.dll and Devart.Data.Oracle.Entity.Spatials.EF6.dll assemblies are unsigned too, because it uses SharpMap.dll.

Well-Known Text (WKT)

OracleWktSpatialService class is used. Provider value is a WKT representation (string), which can be used with third-party libraries that support WKT.

Extended Well-Known Text (EWKT)

OracleExtendedWktSpatialService class is used. Provider value is a EWKT (WKT with SRID specified) representation (string), which can be used with third-party libraries that support EWKT.

Well-Known Binary (WKB)

OracleWkbSpatialService class is used. Provider value is a WKB representation (byte[]), which can be used with third-party libraries that support WKB.

WKB data is compact, so it generates less traffic than WKT or EWKT.

OracleObject

OracleObjectSpatialService class is used. Provider value is a Devart.Data.Oracle.OracleObject class, which can be used with third-party libraries that support OracleObject class.

When using OracleObject service, there is no need to convert data when reading/writing it to database.

Spatial Service Comparison

Spatial service | DbGeometry and DbGeography | SRID | WellKnownValue support1 | Oracle |  | Stored procedures and functions
 |  |  |  | 9.2/10g R1/XE | 10g R2/11g R1/11g R2 | In params and function return value | Out / InOut params
NetTopologySuite | Yes 2 | Yes | Yes | No | Yes | Yes | No
SharpMap | Yes 2 | Yes | Yes | No | Yes | Yes | No
Well-Known Text (WKT) | No 3 | No 4 | Yes | No | Yes | Yes | No
Extended Well-Known Text (EWKT) | No 3 | Yes | Yes | No | Yes | Yes | No
Well-Known Binary (WKB) | No 3 | No 4 | Yes | No | Yes | Yes | No
OracleObject | No 3 | Yes | No | Yes | Yes | Yes | Yes

1 DbGeometryWellKnownValue and DbGeographyWellKnownValue data types support (data contract serializable representation of a DbGeometry/DbGeography values).

2 Most features are supported, but not all of them.

3 Minimal feature set is supported. See details in the DbGeometry/DbGeography Support in Spatial Services topic.

4 When persisting data to the database, default SRID values from the GeometryDefaultSrid and GeographyDefaultSrid settings are used. When retrieving SDO_GEOMETRY data from the database, its WKT/WKB representation is retrieved, and SRID is ignored.

See the Spatial Service Type topic to get more information on specifying which spatial service to use.

See Also

Default SRID | Spatial Service Type | Tolerance | Area and Distance Units | Spatials Comparison | Oracle Spatial Engine | Spatial Type Name Representation


Spatial Options

Spatial Options
support@devart.com

This section is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

This section describes Entity Framework provider settings for Entity Framework spatials in dotConnect for Oracle.

  • Spatial Service Type
  • Default SRID
  • Tolerance
  • Area and Distance Units
  • Spatials Comparison
  • Oracle Spatial Engine
  • Spatial Type Name Representation


Spatial Service Type

Spatial Service Type
support@devart.com

This topic is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

The spatial service used is specified in the SpatialServiceType property.

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.SpatialServiceType = SpatialServiceType.NetTopologySuite;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.SpatialServiceType = SpatialServiceType.NetTopologySuite

Setting this property is enough to use spatials. You can omit setting other options related to spatials.

Alternatively, you may specify the spatial service to use in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions SpatialServiceType="NetTopologySuite" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

See Also

Default SRID | Choosing Spatial Service | Tolerance | Area and Distance Units | Spatials Comparison | Oracle Spatial Engine | Spatial Type Name Representation | DbGeometry/DbGeography Support in Spatial Services


Default SRID

Default SRID
support@devart.com

This topic is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

When creating DbGeometry / DbGeography using such static methods as FromText(String), FromBinary(Byte[]), FromGml(String), the default SRID values are used.

User can set these default values with the GeometryDefaultSrid and GeographyDefaultSrid settings.

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.GeometryDefaultSrid = 0; // this is the default value
config.SpatialOptions.GeographyDefaultSrid = 4326; // this is the default value
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.GeometryDefaultSrid = 0
' this is the default value
config.SpatialOptions.GeographyDefaultSrid = 4326
' this is the default value

Alternatively, you may specify the default SRID values in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions GeometryDefaultSrid="0" GeographyDefaultSrid="4326" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

dotConnect for Oracle also provides the following additional settings that control the use of default SRID values:

  • config.SpatialOptions.AlwaysUseGeometryDefaultSrid - forces the provider to always use the config.SpatialOptions.GeometryDefaultSrid value instead of reading the actual SRID for the DbGeometry spatial from the database. Default value is false.
  • config.SpatialOptions.AlwaysUseGeographyDefaultSrid - forces the provider to always use the config.SpatialOptions.GeographyDefaultSrid value instead of reading the actual SRID for the DbGeometry spatial from the database. Default value is false.

Enabling these options may be useful for EWKT, NetTopologySuite, and SharpMap spatial services in case all the database objects have the same SRID value as it may increase performance of working with spatial data. It also reduces traffic a bit for all databases, which is useful when materializing a large number of spatial objects.

See Also

Choosing Spatial Service | Tolerance | Area and Distance Units | Spatials Comparison | Oracle Spatial Engine | Spatial Type Name Representation


Tolerance

Tolerance
support@devart.com

Some Oracle functions has an additional mandatory argument "tolerance" (See Oracle documentation about tolerance). When generating SQL, the tolerance value should be set.

User can set the values, used for generating SQL, with GeometryTolerance and GeographyTolerance settings. The default values of these settings are 0.005.

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.GeometryTolerance = 0.02;
config.SpatialOptions.GeographyTolerance = 0.001;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.GeometryTolerance = 0.02
config.SpatialOptions.GeographyTolerance = 0.001

Alternatively, you may specify tolerance in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions GeometryTolerance="0.02" GeographyTolerance="0.001" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

See Also

Choosing Spatial Service | Default SRID | Area and Distance Units | Spatials Comparison | Oracle Spatial Engine | Spatial Type Name Representation


Area and Distance Units

Area and Distance Units
support@devart.com

Some Oracle functions accept an additional argument "unit", that allows setting measurement unit for function result. Particularly this applies to the functions, returning the length of an object, distances between objects, and area of objects.

DbGeometry/DbGeography classes have their own methods to get these values (Length, Area, and Distance), however they cannot use this Oracle-specific feature of selecting measurement units directly.

User can specify the necessary measurement units with GeometryDistanceUnit / GeographyDistanceUnit and GeometryAreaUnit / GeographyAreaUnit settings. The default values of these settings are DistanceMeasurementUnit.Default and AreaMeasurementUnit.Default.

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.GeometryDistanceUnit = DistanceMeasurementUnit.Meter;
config.SpatialOptions.GeographyDistanceUnit = DistanceMeasurementUnit.Mile;
config.SpatialOptions.GeometryAreaUnit = AreaMeasurementUnit.SquareKilometer;
config.SpatialOptions.GeographyAreaUnit = AreaMeasurementUnit.Acre;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.GeometryDistanceUnit = DistanceMeasurementUnit.Meter
config.SpatialOptions.GeographyDistanceUnit = DistanceMeasurementUnit.Mile
config.SpatialOptions.GeometryAreaUnit = AreaMeasurementUnit.SquareKilometer
config.SpatialOptions.GeographyAreaUnit = AreaMeasurementUnit.Acre

Alternatively, you may specify measurement units in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions
    GeometryDistanceUnit="Meter"
    GeographyDistanceUnit="Mile"
    GeometryAreaUnit="SquareKilometer"
    GeographyAreaUnit="Acre" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

The following measurement units are available:

DistanceMeasurementUnit:

  • Default
  • Meter
  • Kilometer
  • Centimeter
  • Millimeter
  • Mile
  • NauticalMile
  • Yard
  • Foot
  • Inch

AreaMeasurementUnit:

  • Default
  • SquareMeter
  • SquareKilometer
  • SquareCentimeter
  • SquareMillimeter
  • SquareMile
  • SquareYard
  • SquareFoot
  • SquareInch
  • Acre
  • Hectare

See Also

Choosing Spatial Service | Default SRID | Tolerance | Spatials Comparison | Oracle Spatial Engine | Spatial Type Name Representation


Spatials Comparison

Spatials Comparison
support@devart.com

MDSYS.SDO_GEOMETRY is an Oracle object type and it cannot be compared with the '=' operator, like:
(GeometryColumn=AnotherGeometryColumn OR GeometryColumn=:pGeometryParameter)

Oracle offers different ways to compare spatial data, however, not all of them are available in different versions of Oracle Spatial and Oracle Locator. You can see more details in SDO_GEOM Package (Geometry) and Spatial Operators topics of Oracle documentation.

Here is an example, demonstrating setting the comparison method:

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.ComparisonMethod = SpatialComparisonMethod.SdoRelate;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.ComparisonMethod = SpatialComparisonMethod.SdoRelate

Alternatively, you may specify the comparison method in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions ComparisonMethod="SdoRelate" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

Let's describe the available SpatialComparisonMethod values:

Default

This is the default value. The comparison behaviour depends on the OracleSpatialEngine setting.

OracleSpatialEngine | Actually used SpatialComparisonMethod
Default | WellKnownValue
Oracle Spatial (any version) | SdoGeomRelate
Oracle Locator (Oracle 10g Release 1 and 9i) | SdoRelate
Oracle Locator (Oracle 10g Release 2 and higher) | WellKnownValue

SdoRelate

SDO_RELATE spatial operator is used when possible. If the first spatial expression is a table column, SDO_RELATE spatial operator is used. Otherwise, WellKnownValue comparison is used (see below).

Pros:

  • SDO_RELATE spatial operator can be used with all Oracle Spatial/Oracle Locator versions.

Cons:

  • SDO_RELATE spatial operator requires the first spatial expression to be a table column with a spatial index. If there is no spatial index for this column, the comparison will produce an error.

WellKnownValue or DatabaseWellKnownValue

Values are compared as WKT or WKB. In case of WellKnownValue, server-side value reconvertion is performed. In case of DatabaseWellKnownValue, WKT and WKB values are compared as is, without reconvertion.

It's better to use DatabaseWellKnownValue when working with WKB/WKT spatial services, when spatial values are the same on the server and client sides. In such case there is no need for reconvertion, and performance is better.

Pros:

  • Can be used with all versions of Oracle Spatial/Oracle Locator since Oracle 10g Release 2.
  • Can be used with both columns and parameters or spatial function results in any combinations.

Cons:

  • Oracle 9i and Oracle 10g Release 1 are not supported.
  • SRID values of the compared SDO_GEOMETRY objects are not compared. Only their WKT / WKB representations are compared.
  • Current implementation of convertion between WKT / WKB and SDO_GEOMETRY does not support 3D coords.

SdoGeomRelate

SDO_GEOM.RELATE package function is used.

Pros:

  • Can be used with all Oracle Spatial versions.
  • Can be used with both columns and parameters or spatial function results in any combinations.
  • SDO_GEOM.RELATE package function allows setting tolerance value, which can be configured with GeometryTolerance and GeographyTolerance settings.

Cons:

  • SDO_GEOM.RELATE package function cannot be used with Oracle Locator (any version).

See Also

Choosing Spatial Service | Default SRID | Tolerance | Area and Distance Units | Oracle Spatial Engine | Spatial Type Name Representation


Oracle Spatial Engine

Oracle Spatial Engine
support@devart.com

dotConnect for Oracle allows you to explicitly specify the minimal Oracle spatial engine for Oracle Database server the application connects to. The engine to use is specified with the OracleSpatialEngine setting.

This setting affects SQL generation as the functionality of Oracle Spatial and Oracle Locator is different, and it depends on their version. Some functions should be implemented differently for different engines and different engine versions.

The specified engine also affects the list of unsupported features. If OracleSpatialEngine is set to other value than OracleSpatialEngine.Default, and some non-supported feature is used, NotSupportedException is thrown. It is thrown immediately when parsing a LINQ to Entities expression.

Here is an example, demonstrating specifying Oracle spatial engine:

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.OracleSpatialEngine = OracleSpatialEngine.OracleSpatial11g;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.OracleSpatialEngine = OracleSpatialEngine.OracleSpatial11g

Alternatively, you may specify the minimal Oracle spatial engine to use in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions OracleSpatialEngine="OracleSpatial11g" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

The following OracleSpatialEngine values are available:

  • Default
  • OracleLocator9i
  • OracleLocator10g
  • OracleLocator10gR2
  • OracleLocator11g
  • OracleSpatial9i
  • OracleSpatial10g
  • OracleSpatial10gR2
  • OracleSpatial11g

See Also

Choosing Spatial Service | Default SRID | Tolerance | Area and Distance Units | Spatials Comparison | Spatial Type Name Representation


Spatial Type Name Representation

Spatial Type Name Representation
support@devart.com

DbGeometry and DbGeography classes have the SpatialTypeName property. As Oracle does not offer any standard way to get the type name, we offer several ways to determine SpatialTypeName. You can specify the way with SpatialTypeNameRepresentation setting. The default value is OpenGisCompatibleName.

C#csharp Copy Code
var config = OracleEntityProviderConfig.Instance;
config.SpatialOptions.SpatialTypeNameRepresentation = SpatialTypeNameRepresentation.OracleNumeric;
Visual Basic Copy Code
Dim config = OracleEntityProviderConfig.Instance
config.SpatialOptions.SpatialTypeNameRepresentation = SpatialTypeNameRepresentation.OracleNumeric

Alternatively, you may specify the method, determining SpatialTypeName, in the project config file. For this, you need to update or add the configSections element like it is described in the Entity Framework Provider Configuration section and then add the following Devart.Data.Oracle.Entity tag to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
  <SpatialOptions SpatialTypeNameRepresentation="OracleNumeric" />
 </Devart.Data.Oracle.Entity>

Note: If you need to set multiple Entity Framework provider options for dotConnect for Oracle, don't add multiple Devart.Data.Oracle.Entity tags. Specify all settings in one Devart.Data.Oracle.Entity tag.

The following SpatialTypeNameRepresentation values are available:

  • OracleNumeric - unmodified textual representation of SDO_GEOMETRY.GTYPE
  • OracleTypeName - the name from the Oracle documentation, corresponding to SDO_GEOMETRY.GTYPE, is returned
  • OpenGisCompatibleName - the name used in OpenGIS compatible solutions, corresponding to SDO_GEOMETRY.GTYPE, is returned

See Also

Choosing Spatial Service | Default SRID | Tolerance | Area and Distance Units | Spatials Comparison | Oracle Spatial Engine


DbGeometry/DbGeography Support in Spatial Services

DbGeometry/DbGeography Support in Spatial Services
support@devart.com

This topic is applicable to Entity Framework v5 and v6. It is not applicable to Entity Framework Core, which does not support spatials.

The following table demonstrates which properties and methods of DbGeometry and DbGeography are supported by available spatial services:

Method/Property |  |  | Spatial service
Name | DbGeometry | DbGeography | NetTopologySuite1 | SharpMap1 | WKT | EWKT | WKB | OracleObject
Instance Properties
Area | √ | √ | Yes | Yes | No | No | No | No
Boundary | √ | – | Yes | Yes | No | No | No | No
Centroid | √ | – | Yes | Yes | No | No | No | No
ConvexHull | √ | – | Yes | Yes | No | No | No | No
CoordinateSystemId | √ | √ | Yes | Yes | Yes 2 | Yes | Yes 2 | Yes
Dimension | √ | √ | Yes | Yes | No | No | No | Yes
ElementCount | √ | √ | Yes | Yes | No | No | No | No
Elevation | √ | √ | Yes | Yes | No | No | No | No
EndPoint | √ | √ | Yes | Yes | No | No | No | No
Envelope | √ | – | Yes | Yes | No | No | No | No
ExteriorRing | √ | – | Yes | Yes | No | No | No | No
InteriorRingCount | √ | – | Yes | Yes | No | No | No | No
IsClosed | √ | √ | Yes | Yes | No | No | No | No
IsEmpty | √ | √ | Yes | Yes | No | No | No | No
IsRing | √ | – | Yes | Yes | No | No | No | No
IsSimple | √ | – | Yes | Yes | No | No | No | No
IsValid | √ | – | Yes | No | No | No | No | No
Latitude | – | √ | Yes | Yes | No | No | No | No
Length | √ | √ | Yes | Yes | No | No | No | No
Longitude | – | √ | Yes | Yes | No | No | No | No
Measure | √ | √ | Yes | No | No | No | No | No
PointCount | √ | √ | Yes | Yes | No | No | No | No
PointOnSurface | √ | – | Yes | Yes | No | No | No | No
ProviderValue | √ | √ | Yes | Yes | Yes | Yes | Yes | Yes
SpatialTypeName | √ | √ | Yes | Yes | No | No | No | Yes 3
StartPoint | √ | √ | Yes | Yes | No | No | No | No
WellKnownValue | √ | √ | Yes | Yes | Yes | Yes | Yes | No
XCoordinate | √ | – | Yes | Yes | No | No | No | No
YCoordinate | √ | – | Yes | Yes | No | No | No | No
Instance Methods
AsBinary | √ | √ | Yes | Yes | No | No | Yes | No
AsGml | √ | √ | Yes | No | No | No | No | No
StartPoint | √ | √ | Yes | Yes | No | No | No | No
AsText | √ | √ | Yes | Yes | Yes | Yes | No | No
Buffer | √ | √ | Yes | Yes | No | No | No | No
Contains | √ | – | Yes | Yes | No | No | No | No
Crosses | √ | – | Yes | Yes | No | No | No | No
Difference | √ | √ | Yes | Yes | No | No | No | No
Disjoint | √ | √ | Yes | Yes | No | No | No | No
Distance | √ | √ | Yes | Yes | No | No | No | No
ElementAt | √ | √ | Yes | Yes | No | No | No | No
InteriorRingAt | √ | – | Yes | Yes | No | No | No | No
Intersection | √ | √ | Yes | Yes | No | No | No | No
Intersects | √ | √ | Yes | Yes | No | No | No | No
Overlaps | √ | – | Yes | Yes | No | No | No | No
PointAt | √ | √ | Yes | Yes | No | No | No | No
Relate | √ | – | Yes | Yes | No | No | No | No
SpatialEquals | √ | √ | Yes | Yes | No | No | No | No
SymmetricDifference | √ | √ | Yes | Yes | No | No | No | No
Touches | √ | – | Yes | Yes | No | No | No | No
Union | √ | √ | Yes | Yes | No | No | No | No
Within | √ | – | Yes | Yes | No | No | No | No
Static Methods
FromBinary(Byte[]) | √ | √ | Yes | Yes | No | No | Yes | No
FromBinary(Byte[], Int32) | √ | √ | Yes | Yes | No | No | No | No
FromGml(String) | √ | √ | Yes | No | No | No | No | No
FromGml(String, Int32) | √ | √ | Yes | No | No | No | No | No
FromText(String) | √ | √ | Yes | Yes | Yes | Yes | No | No
FromText(String, Int32) | √ | √ | Yes | Yes | No | No | No | No
GeometryCollectionFromBinary | √ | √ | Yes | Yes | No | No | No | No
GeometryCollectionFromText | √ | √ | Yes | Yes | No | No | No | No
LineFromBinary | √ | √ | Yes | Yes | No | No | No | No
LineFromText | √ | √ | Yes | Yes | No | No | No | No
MultiLineFromBinary | √ | √ | Yes | Yes | No | No | No | No
MultiLineFromText | √ | √ | Yes | Yes | No | No | No | No
MultiPointFromBinary | √ | √ | Yes | Yes | No | No | No | No
MultiPointFromText | √ | √ | Yes | Yes | No | No | No | No
MultiPolygonFromBinary | √ | √ | Yes | Yes | No | No | No | No
MultiPolygonFromText | √ | √ | Yes | Yes | No | No | No | No
PointFromBinary | √ | √ | Yes | Yes | No | No | No | No
PointFromText | √ | √ | Yes | Yes | No | No | No | No
PolygonFromBinary | √ | √ | Yes | Yes | No | No | No | No
PolygonFromText | √ | √ | Yes | Yes | No | No | No | No

1 The Yes mark in the SharpMap or NetTopologySuite column does not mean the feature is completely supported. It means that SharpMap or NetTopologySuite declares support for it, and it is used by our SharpMap or NetTopologySuite spatial service. However, this feature may not be implemented for some types and cases in the corresponding SharpMap or NetTopologySuite library.

2 WKT and WKB spatial services always return config.SpatialOptions.GeometryDefaultSrid for DbGeometry and config.SpatialOptions.GeographyDefaultSrid for DbGeography as CoordinateSystemId.

3 The returned SpatialTypeName value depends on config.SpatialOptions.SpatialTypeNameRepresentation value for OracleObject spatial service.

See Also

Choosing Spatial Service


%%ItemTitle%%

JSON Support in Entity Framework
support@devart.com

Glossary Item Box

dotConnect for Oracle provides support for JSON functionality in Oracle 12c. It allows using Oracle JSON functions in LINQ to Entities queries via the OracleJsonFunctions class. They are supported in Entity Framework v4, v5, and v6.

Model

Here is a code that maps an entity to a simple table with a JSON column. The column is mapped to a property of the System.String type. In Oracle, JSON data is stored in usual CLOB and NCLOB columns.

C# Copy Code
public class MyContext: DbContext {

  public DbSet<JsonTable> JsonTables { get; set; }

}

public class JsonTable {

  [Key]
  [DatabaseGenerated(DatabaseGeneratedOption.Identity)]
  public int Id { get; set; }

  // The JSON column
  [Column(TypeName = "nclob")]
  public string JObject { get; set; }

  public string Text { get; set; }

}

Database Table Creation

To create the corresponding table in the database, use the following code:

C# Copy Code
var ctx = new MyContext();
ctx.Database.Create();

This code will create the following table:

CREATE TABLE "JsonTable" (
  "Id" NUMBER(10) GENERATED BY DEFAULT ON NULL AS IDENTITY NOT NULL,
  "JObject" NCLOB NULL,
  "Text" NCLOB NULL,
  CONSTRAINT "PK_JsonTable" PRIMARY KEY ("Id")
)

JSON Features in LINQ to Entities

The OracleJsonFunctions class contains the following methods:

OracleJsonFunctions methods | Corresponding Oracle Functions and Operators | Description
IsJson | IS JSON | Checks whether some data is well-formed JSON data.
Exists | JSON_EXISTS | Checks whether a particular value exists within some JSON data.
TextContains | JSON_TEXTCONTAINS | Checks whether a specified string exists in JSON property values.
Value | JSON_VALUE | Select a scalar value from JSON data as an SQL value.

Query Example

For example, the following query retrieves rows where the specified JSON value (named "a") exists in a stored JSON object and selects this value.

C# Copy Code
var query = context.JsonTables
  .Where(t => OracleJsonFunctions.Exists(t.JObject, "$.a"))
  .Select(t => new
  {
    Id = t.Id,
    Json = t.JObject,
    Value = OracleJsonFunctions.Value(t.JObject, "$.a")
  });

The following SQL query will be generated for this LINQ query:

SELECT
"Extent1"."Id",
"Extent1"."JObject",
JSON_VALUE("Extent1"."JObject", '$.a') AS C1
FROM "JsonTable" "Extent1"
WHERE JSON_EXISTS("Extent1"."JObject", '$.a')


Entity Framework Provider Configuration

Entity Framework Provider Configuration
support@devart.com

Entity Framework support features can be configured either in code using Devart.Data.Oracle.Entity.Configuration.OracleEntityProviderConfig class or in the project .config file. The OracleEntityProviderConfig class is available in the Devart.Data.Oracle.Entity.dll assembly. For example, this code is used to enable batch updates feature:

C#csharp Copy Code
OracleEntityProviderConfig config = OracleEntityProviderConfig.Instance;
config.DmlOptions.BatchUpdates.Enabled = true;
Visual Basic Copy Code
Dim Config As OracleEntityProviderConfig
Config = OracleEntityProviderConfig.Instance
Config.DmlOptions.BatchUpdates.Enabled = True

To configure Entity Framework provider with a config file, you need to add the following section to the configSections tag:

<configSections>
  <section name="Devart.Data.Oracle.Entity"
  type="Devart.Data.Oracle.Entity.Configuration.OracleEntityProviderConfigurationSection,
  Devart.Data.Oracle.Entity.EF[Version], Version=8.4.215.0, Culture=neutral,
  PublicKeyToken=09af7300eec23701" />
</configSections>

Where [Version] is the version of the Entity Framework used. For Entity Framework v1 it is "1", for Entity Framework v4 it is "4", for Entity Framework v5 and v6 it is "5" or "6" respectively. For Entity Framework Core it is "Core".

If there is no configSections element in your config file, add it. It must be the first element. If it's not the first element, your application will throw an error when starting.

Then add the following element to the configuration tag:

 <Devart.Data.Oracle.Entity xmlns="http://devart.com/schemas/Devart.Data.Oracle.Entity/1.0">
 </Devart.Data.Oracle.Entity>

And use the following elements of the Devart.Data.Oracle.Entity tag to configure Entity Framework provider.

  • DmlOptions
  • QueryOptions
  • SqlFormatting
  • CodeFirstOptions
  • Workarounds
  • DatabaseScript
  • SpatialOptions

For more details on using OracleEntityProviderConfig class or configuring Entity Framework provider with a config file see the following topics:

  • DML Options
  • Batch Updates
  • Query Options
  • SQL Formatting
  • Code First Options
  • Additional Options
  • Database Script Generation Settings
  • Spatial Options


DML Options

DML Options
support@devart.com

To increase a configurability of dotConnect for Oracle as Entity Framework provider and provide more flexibility in behavior, we have added a number of DML options that influence the INSERT/UPDATE/DELETE commands and stored procedure calls.

Currently this feature is not yet supported for Entity Framework Core. It is supported only for Entity Framework v1 - v6.

Except for the batch updates settings, which are described in the Batch Updates topic, the list of DML options includes:

  • ReuseParameters - enables reusing existing parameters instead of creating new ones. For example, if the batch contains 30 INSERT statements, inserting the number 1024, one :p1 parameter will be used instead of creating 30 :p1 - :p30 parameters. Set this property to true only if a large number of the same values is sent to the database. Otherwise, it may even cause performance loss, if there are many parameters in a batch.
  • ParametersAsLiterals - determines if parameter values are inserted into SQL statements as literals instead of parameters. This behaviour is implemented in Connector .NET and can improve performance a bit in some rare cases.

  • InsertNullBehaviour. NULL values can be inserted in different ways. This configuration property allows the developer to determine the behaviour suitable for his particular application. Here is the list of possible alternatives:

    • InsertNull. In this case NULLs are inserted explicitly (for each column that do not have a non-NULL value specified) like in the following example:

      INSERT INTO "Company"
  ("CompanyID","CompanyName","Web","Email","Address_AddressTitle","Address_Address",
  "Address_City","Address_Region","Address_PostalCode","Address_Country",
  "Address_Phone","Address_Fax","PrimaryContact_ContactID","PersonContact_ContactID")
VALUES
  (:p0,:p1,:p2,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL)

    • Omit. In this case provider simply omits all columns that do not have non-NULL values like in the following example:

      INSERT INTO "Company"("CompanyID","CompanyName","Web")VALUES(:p0,:p1,:p2)
    • InsertDefaultOrNull. In this case provider determines if there is a default value specified in the SSDL part of the model, and if it is available, this value is persisted to the database. If there is no default value specified, the behaviour is identical to the InsertNull one.
    • InsertDefaultOrOmit. In this case provider determines if there is a default value specified in the SSDL part of the model as well. However, if there is no default value specified for a column, it is omitted from the INSERT command completely.
  • EmptyUpdates. When set to false, the provider turns off the generation of fake updates for parent entities. The default value is true.
  • UseReturningClause. Determines the provider behaviour when generating INSERT/UPDATE commands when the database-generated values must be returned. When set to true, the RETURNING clause is generated and the ROWID of the added/updated record is used. When set to false, primary key column values are used instead of the RETURNING clause and ROWID. The default value is true.

Please note that the last two options work with both common DefaultValue SSDL attribute and the new custom devart:DefaultValue SSDL attribute. The latter attribute does not trigger the type consistency check, so you can use a wider range of default values, like CURRENT_TIMESTAMP or my_sequence.nextval.

Here is a simple example:

<Property Name="ProductID" Type="int" Nullable="false"
devart:DefaultValue="my_sequence.nextval" StoreGeneratedPattern="Identity" />

The generated SQL command looks like the following:

INSERT INTO "Product"
  ("ProductID","ProductName","UnitScale","InStock","Price","DiscontinuedPrice")
  VALUES(my_sequence.nextval,:p0,:p1,:p2,:p3,:p4)

These options can be set either in code as the properties of the EntityProviderConfig.DmlOptions object or in the project config file as the attributes of the DmlOptions element of the Devart.Data.Oracle.Entity tag.

The example code that enables the ReuseParameters option:

C#csharp Copy Code
OracleEntityProviderConfig config = OracleEntityProviderConfig.Instance;
config.DmlOptions.ReuseParameters = true;
Visual Basic Copy Code
Dim Config As OracleEntityProviderConfig
Config = OracleEntityProviderConfig.Instance
Config.DmlOptions.ReuseParameters = True

If the InsertNullBehaviour is set to InsertNullBehaviour.InsertDefaultOrNull or InsertNullBehaviour.InsertDefaultOrOmit, and the column has DefaultValue, then the following rules are applied when executing INSERT:

  • For Primary Key columns, DefaultValue is always inserted.
  • For a column with StoreGeneratedPattern, DefaultValue is always inserted too.
  • For a nullable column without StoreGeneratedPattern, if the value is not NULL, then this value is inserted, otherwise, the DefaultValue is inserted.
  • For a not null column without StoreGeneratedPattern of .NET reference type (string, byte[]), if the value is not NULL, then this value is inserted, otherwise, the DefaultValue is inserted.
  • For a not null column of value type (Int32, DateTime, etc) without StoreGeneratedPattern, the value cannot be NULL, so this value is inserted.


Batch Updates

Batch Updates
support@devart.com

By default Entity Framework updates data one statement at a time. dotConnect for Oracle allows grouping several INSERT/UPDATE/DELETE statements into one SQL block and merging their parameters. Now, instead of sending each DML statement separately, SaveChanges generates and executes statement batches. It increases SaveChanges performance substantially because of reducing number of server calls. This feature is called Batch Updates.

Currently this feature is not yet supported for Entity Framework Core. It is supported only for Entity Framework v1 - v6.

Note that in situations when other applications significantly load the database server, you will get even more performance gain with batch updates, because they reduce the number of database server calls.

Batch Updates Settings

Batch Updates are configured with a number of parameters either in code with the OracleEntityProviderConfig class or in the project config file as the attributes of the BatchUpdates element of the DmlOptions tag.

  • Enabled - enables batch updates. If set to false (the default value), other Batch Updates settings are ignored.
  • BatchSize - specifies the maximal number of commands in a batch. Optimal batch size is different for each specific case and DBMS, however, the default value 30 provides good enough results in most cases. If this property is set to 0, all commands will be encapsulated in one batch. In this case, the performance goes down, and DBMS will probably fail with an error because of the too large command size.

  • AsynchronousBatch - determines whether batches are executed asynchronously (false by default), or a new batch will be created and executed only after the successful execution of the previous batch. It is recommended to enable asynchronous batch execution when the batch size is large. If the batch size is small, the performance gain is compensated by synchronization costs. However, if the batch size is too large, the performance gain will not be significant. To conclude: BatchSize should be large enough to take some time to execute, and small enough not to make the main thread wait for the background thread for too long.

    Activating asynchronous batch execution makes sense only if your application will be run on multiple-core processors. On single-core processors asynchronous batch execution provides even less performance than synchronous one.

  • ConcurrencyCheck - enables concurrency check. By default, concurrency check is disabled when using batch updates. Then the concurrency is checked by comparing the number of affected rows to the batch size. Note that enabling concurrency check database may cause some performance loss because of the additional parameter and calculations. It should be remembered that concurrency check in this case is performed for batches, not for individual rows. One command can influence 0 entries, and another can influence 2 entries, this situation will not be treated as an exception if these commands are in one batch. Of course, such situations are very uncommon.

    When concurrency check is enabled, the StateEntries property of the generated OptimisticConcurrencyException, if any, is not initialized because batch updates are managed by provider at ADO.NET level, and the provider does not have the Entity Framework level information about states of entities in the context's collection.

For example, this code is used to enable batch updates:

C#csharp Copy Code
OracleEntityProviderConfig config = OracleEntityProviderConfig.Instance;
config.DmlOptions.BatchUpdates.Enabled = true;
Visual Basic Copy Code
Dim Config As OracleEntityProviderConfig
Config = OracleEntityProviderConfig.Instance
Config.DmlOptions.BatchUpdates.Enabled = True

Batch Updates Limitations

TransactionScope cannot be used with batch updates. When using batch updates, concurrency check is not performed. However, you may still enable concurrency check as it is described above.

Some statements cannot be united into batches. When such a statement is encountered, the batch with previously added commands is executed immediately, then this statement is executed separately.

The following statements cannot be united into batches:

  • Statements with the RETURNING clause, for example, statements that update or insert entities with columns having the StoreGeneratedPattern attribute value set to Identity or Computed.
  • Calls of stored procedures or functions that have non-empty CommandText.


Query Options

Query Options
support@devart.com

dotConnect for Oracle has some options that customize translating LINQ to Entities to SQL statements. The list of these options includes:

  • NoEscapeLike - allows disabling ESCAPE in LIKE expression. The default value is false.
  • CaseInsensitiveLike - allows using case insensitive comparison mode, when translating LINQ to Entities extension methods .Contains(), .EndsWith(), .StartsWith(). The default value is false.
  • CaseInsensitiveComparison - allows using case insensitive comparison mode, when translating LINQ to Entities extension method .Equals(). The default value is false.

  • OrderByNullBehavior. Determines how NULL values will participate in sorting (whether to add NULLS FIRST or NULLS LAST to the ORDER BY clause of generated SQL queries). This option can have the following values:

    • Default. In this case neither NULLS FIRST nor NULLS LAST is added to the generated ORDER BY clauses.

    • NullsFirst . In this case NULLS FIRST is added to the generated ORDER BY clauses.

    • NullsLast. In this case NULLS LAST is added to the generated ORDER BY clauses.
  • AdvancedMetadataQuery - Allows you to turn on the advanced metadata query mode. When set to true, the provider behaves similarly to the Visual Studio Entity Data Model Wizard when querying metadata. This mode should be used when the functionality of System.Data.Entity.Design.dll is used for metadata retrieving in the project. The default value is false.

  • TrueValueNumber - Allows you to specify which number values are accepted as a true boolean value:

    • One. Only value of 1 is accepted as as a true boolean value.

    • NotZero . Any non-zero number is accepted as a true boolean value. This is the default value.

  • UseCSharpNullComparisonBehavior - allows performing NULL checks when comparing a property (column) with a value (parameter) in LINQ to Entities. The default value is false.

Please note that the last two options work with both common DefaultValue SSDL attribute and the new custom devart:DefaultValue SSDL attribute. The latter attribute does not trigger the type consistency check, so you can use a wider range of default values, like CURRENT_TIMESTAMP or my_sequence.nextval.

Here is a simple example:

<Property Name="ProductID" Type="int" Nullable="false"
devart:DefaultValue="my_sequence.NEXTVAL" StoreGeneratedPattern="Identity" />

The generated SQL command looks like the following:

INSERT INTO "Product"
  ("ProductID","ProductName","UnitScale","InStock","Price","DiscontinuedPrice")
  VALUES(my_sequence.NEXTVAL,:p0,:p1,:p2,:p3,:p4)

These options can be set either in code as the properties of the EntityProviderConfig.QueryOptions object or in the project config file as the attributes of the QueryOptions element of the Devart.Data.Oracle.Entity tag.


SQL Formatting

SQL Formatting
support@devart.com

dotConnect for Oracle includes settings for disabling code formatting. This reduces the size of generated SQL statements a bit. The formatting can be completely enabled or disabled using the OracleEntityProviderConfig.SqlFormatting.Enable() or OracleEntityProviderConfig.SqlFormatting.Disable() methods respectively. More specific settings are available as well:

  • ColumnListStacking - disables inserting new lines in the SELECT list. If set to true, the list looks like the following:

    SELECT
"Extent1"."CompanyID",
"Extent1"."CompanyName",
"Extent1"."Web",
"Extent1"."Email",
"Extent1"."Address_AddressTitle",
"Extent1"."Address_Address",
"Extent1"."Address_City",
...

    instead of

    SELECT "Extent1"."CompanyID", "Extent1"."CompanyName", "Extent1"."Web", "Extent1"."Email", "Extent1"."Address_AddressTitle", "Extent1"."Address_Address", "Extent1"."Address_City", ...
  • ExtraSpaces - determines whether to insert spaces between operators and operands and after commas.
  • Indenting - determines whether to indent keywords in multi-line queries.
  • MultilineStatements - determines whether to split statements to several lines.

These options can be set either in code as the properties of the EntityProviderConfig.SqlFormatting object or in the project config file as the attributes of the SqlFormatting element of the Devart.Data.Oracle.Entity tag.


Code First Options

Code First Options
support@devart.com

dotConnect for Oracle includes settings for configuring DDL generation in Entity Framework Code First. The following settings are available.

  • RemoveSchemaFromDefaultConstraintName - When set to true, the schema (database) name prefix is removed from default constraint names (primary keys, foreign keys) generated by Code-First Migrations. Default value is true.

  • AddTableNameInDefaultIndexName - When set to true, the table name is added to default index name generated by Code-First Migrations (like 'IX_TableName_ColumnName'). When set to false, then default index names will be like 'IX_ColumnName'. Default value is true.
  • TruncateLongDefaultNames - When set to true, long default names of triggers, sequences, indexes, primary keys, and foreign keys generated by Code-First Migrations will be truncated to 30 symbols. When set to false, an exception will be raised for long default names. Be careful when setting the property to true, because checks for uniqueness of names are not performed. Default value is false.

  • UseNonUnicodeStrings - When set to true, string properties without explicitly specified server data type will be treated as non-unicode. Default value is false.

    By default, Entity Framework considers all the string properties as Unicode and maps them to NCHAR, NVARCHAR, and NCLOB columns depending on other property parameters when creating/updating database structure. If you want to use CHAR, VARCHAR2, and CLOB columns for string properties by default, set this option to true.

  • UseNonLobStrings - When set to true, string properties without explicitly specified server data type will be treated as non-LOBs. Default value is false.

  • ColumnTypeCasingConventionCompatibility - This option allows you to avoid explicitly turning off the ColumnTypeCasingConvention for each DbContext when working with Devart dotConnect for Oracle. By default it is set to false. When using XML mapping (Entity Framework v1 and v4) - a edmx/edml file and ObjectContext or DbContext in the XML mapping mode - this option must be FALSE. When using Entity Framework Code First (Entity Framework v1 and v4), this option can be true or false, but if it is set to false, you must turn off ColumnTypeCasingConvention explicitly for each DbContext. This option must be True for EF Code-First Migrations (EF v4.3.x and v5.x) to work correctly.
  • UseDateTimeAsDate - When set to true, DateTime properties without as explicitly specified server data type will be treated as DATE. Default value is false.

These options can be set either in code as the properties of the EntityProviderConfig.CodeFirstOptions object or in the project config file as the attributes of the CodeFirstOptions element of the Devart.Data.Oracle.Entity tag.


Additonal Options

Additonal Options
support@devart.com

One of the most sophisticated issues with supporting Entity Framework is to accommodate the peculiarities of different DBMS, because Entity Framework is the easiest to use with Microsoft SQL Server. Some of the conflicts may be resolved with the following options, which can be set as the properties from the Workarounds class or in the config file as the attributes of the Workarounds element of the Devart.Data.Oracle.Entity tag.:

IgnoreSchemaName

Default value is false. When set to true, this property makes provider remove the schema (database) name from all commands and queries, no matter whether Schema is specified in the model or not. A command will use the schema from the connection.

This workaround is very useful in EF 4.1 Code First, since the "dbo" schema is set by default (like in SQL Server), and writing either attribute-based or fluent mapping is rather a time-consuming task. This functionality is useful in case of the Model or Database First approach as well. If the production and testing schemas have identical structure, it is enough to use this workaround, and no manual Schema replacing or removing is necessary in this case.

IgnoreDboSchemaName

Default value is true for Entity Framework 4.3 Code-First Migrations. When set to true, this property makes provider remove the "dbo" schema (database) name from all commands and queries. A command will use the schema from the connectio n.

Unlike the previous option, it allowsyou to explicitly specify a schema name other than "dbo" for tables.

DisableQuoting

Default value is false. This property allows the user to disable quoting all identifiers in all queries and commands.

The example code that disables quoting:

C#csharp Copy Code
OracleEntityProviderConfig config = OracleEntityProviderConfig.Instance;
config.Workarounds.DisableQuoting = true;
Visual Basic Copy Code
Dim Config As OracleEntityProviderConfig
Config = OracleEntityProviderConfig.Instance
Config.Workarounds.DisableQuoting = True


Database Script Generation Settings

Database Script Generation Settings
support@devart.com

dotConnect for Oracle allows configuring creating and deleting database objects in the CreateDatabase() and DeleteDatabase() methods. These customizations are rather useful for the Code First approach. You can tweak the behaviour of the methods using the OracleEntityProviderConfig.DatabaseScript.Schema, OracleEntityProviderConfig.DatabaseScript.Table, OracleEntityProviderConfig.DatabaseScript.Column, OracleEntityProviderConfig.DatabaseScript.Index, and OracleEntityProviderConfig.DatabaseScript.ForeignKey classes.

OracleEntityProviderConfig.DatabaseScript.Schema Settings

  • DeleteDatabaseBehaviour. This enumeration determines the behavior of the DeleteDatabase() function.

    • ModelObjectsOnly - this is the default value. Only the tables and sequences that model objects are mapped to are created/deleted.
    • AllSchemaObjects - all tables (and corresponding sequences used for auto-increment columns in Oracle prior to Oracle 12c) will be created/deleted from schemas or databases that model objects were mapped to. In Oracle 12c, the sequences will be created/deleted only if config.DatabaseScript.Column.NumericIdentityBehavior = ExplicitTriggerAndSequence.

    • Schema - entire schema, containing model objects, is created/deleted. If the model contains objects from other schemas, these schemas will be created/deleted as well.

      Note: There is no possibility to delete the user that is currently connected in Oracle. Thus, to call the DeleteDatabase() method, the user must have grants to delete users and must not have any database objects that model objects are mapped to.

  • DefaultTablespace - set the name of default tablespace for the created schema.
  • Grants - pass the list of grants for the CREATE USER statement.
  • Profile - set the existing profile to the created user.
  • TemporaryTablespace - set the name of temporary tablespace for the created schema.

OracleEntityProviderConfig.DatabaseScript.ForeignKey Settings

  • Enabled. Turns on/off generation of foreign constraints. The default value is true.
  • IndexCreation. When set to true, an index is created for the columns being parts of the foreign key. The default value is true.

OracleEntityProviderConfig.DatabaseScript.Table Settings

  • Tablespace - sets the name of the tablespace for the created tables.

OracleEntityProviderConfig.DatabaseScript.Column Settings

  • NumericIdentityBehavior. This property manages generation of columns with StoreGenerationPattern="Identity". This property can have the following values:

    • Default - for Oracle12c a column GENERATED ALWAYS AS IDENTITY is created. For earlier Oracle server versions, a sequence and a trigger are created. This is the default value.
    • ImplicitSequence - a column GENERATED ALWAYS AS IDENTITY is created.
    • ExplicitTriggerAndSequence - a sequence and a trigger are created.
    • None - nothing is generated.

OracleEntityProviderConfig.DatabaseScript.Index Settings

  • Tablespace - sets the name of the tablespace for the created indexes.


LinqConnect

LinqConnect
support@devart.com

This section describes LinqConnect, formerly known as LINQ to Oracle, in dotConnect for Oracle.

  • Devart LinqConnect
  • LinqConnect Tutorial
  • LinqConnect Data Type Mapping
  • Working with Transactions in LinqConnect


Devart LinqConnect

Devart LinqConnect
support@devart.com

LinqConnect is the fast and lightweight ORM solution, which is closely compatible to Microsoft LINQ to SQL and contains its own advanced features, such as complex type support, advanced data fetching options, configurable compiled query caching, and others. LinqConnect is integrated into dotConnect for Oracle, dotConnect for MySQL, dotConnect for PostgreSQL, and dotConnect for SQLite.

LinqConnect includes run time assemblies to be used directly by your code, and a visual tool - Entity Developer, which helps you build object-relational model from scratch or by reverse-engineering your database.

The article consists of the following sections:

  • What is LINQ?
  • Why Use LinqConnect?
  • Key Features
  • Visual Model Creation
  • Feature Information

What is LINQ?

LINQ stands for Language-Integrated Query, which means that data retrieval is no longer a separate language. The LINQ engine allows .NET applications to connect to databases without bothering much about columns and rows. The data you receive is automatically formed as objects ready to use by your business logic.

LINQ to Relational Data may be thought of as an object-relational mapping (ORM) tool. The type-safe LINQ queries get compiled into MSIL on the fly, and the query clauses are translated into SQL and sent to Oracle server for execution. This makes your data access layer safer, faster, and greatly more convenient to design.

Why Use LinqConnect?

Let's briefly enumerate just four main reasons to use LinqConnect in your applications:

  • Development time: it is really faster, having stripped off better part of the mundane work.
  • Maintenance time and effort: greatly designed application does not need as much maintenance as a poorly written one.
  • Performance: high enough without lots of efforts on optimizing your code. Even higher if you bother to do so.
  • Security: LINQ to SQL enforces good application architecture, which leaves less room for design vulnerabilities.

Key Features

  • Interchangeable with Microsoft LINQ to SQL
  • Wide support for LINQ capabilities
  • Wide database support
  • High performance
  • Visual schema modelling with Entity Developer
  • Visual Studio integration
  • POCO classes used (no need to use a common base class)
  • Full CRUD (Create, Retrieve, Update, Delete) support
  • Batch updates
  • PLINQ support
  • ASP.NET Dynamic Data support
  • Change tracking support
  • Inheritance mapping (Table per hierarchy, Table per type)
  • Metadata mapping
  • Well-thought predefined templates for class generation
  • Custom templates for generated classes
  • Visual Studio debugger visualizer for DataQuery objects
  • Query logging
  • dbMonitor support

Visual Model Creation

LinqConnect includes a powerful visual tool for creating entity model that describes your business objects and their mapping to the database. You can design the model from scratch or reverse-engineer an existing database, in which case you will have the classes and the relations with just several clicks.

Screenshot Entity Developer

Entity Developer generates the classes in C# or Visual Basic. These classes (the model) is used by your application code.

Feature Information

Requirements

LinqConnect requires .NET Framework 3.5 or later installed on the computer.

Documentation And Samples

LinqConnect includes documentation that covers LinqConnect usage and run time reference.

For a quick start with the technology you can use LinqConnect Tutorial.

There are three demo projects in C# and Visual Basic that can help you start using LinqConnect. Use Start menu to open them.

Discussion Forum

LinqConnect has a dedicated forum where you can get help on using the technology within Devart dotConnects.

See Also

dotConnect LINQ to SQL Documentation | LINQ to Oracle Tutorial | ADO.NET Entity Framework Support


LinqConnect Tutorial

LinqConnect Tutorial
support@devart.com

This tutorial guides you through the process of creating a simple application powered by LinqConnect (formerly LINQ to Oracle) technology. In less than 5 minutes you will have a ready-to-use data access layer for your business objects.

In this walkthrough:

  • Introducing the LinqConnect Technology
  • Requirements
  • Preparing the Project
  • Generating Model from Database
  • Querying Data
  • Inserting New Data
  • Updating Data
  • Deleting Data
  • Additional Information

Introducing the LinqConnect Technology

LinqConnect is the fast and lightweight ORM solution, which is closely compatible to Microsoft LINQ to SQL and contains its own advanced features, such as complex type support, advanced data fetching options, configurable compiled query caching, and others.

LINQ stands for Language-Integrated Query, which means that data retrieval is no longer a separate language. The LINQ engine allows .NET applications to connect to databases without bothering much about columns and rows. The data you receive is automatically formed as objects ready to use by your business logic.

LINQ to Relational Data may be thought of as an object-relational mapping (ORM) tool. The type-safe LINQ queries get compiled into MSIL on the fly, and the query clauses are translated into SQL and sent to Oracle server for execution. This makes your data access layer safer, faster, and greatly more convenient to design.

Requirements

In order to connect to Oracle server you need the server itself running, dotConnect for Oracle installed and IDE running. LinqConnect requires .NET Framework 3.5, Visual Studio 2008, and Oracle server 9.2.0.4 or higher. Note that LinqConnect feature is only available in Professional and Developer Editions of dotConnect for Oracle.

In this tutorial it is assumed that you already have the database objects created. You have to execute a script from the following file installed by default to
\Program Files\Devart\dotConnect\Oracle\Samples\crm_demo.sql

Preparing the Project

Create a new console application in Visual Studio. It could be any other project type as well, but for simplicity's sake we'll use console project throughout the tutorial. The rest of the tutorial assumes that the name of the project is ConsoleApplication1. If you project is named otherwise, you will have to substitute this name with the actual one in Solution Explorer.

Generating Model from Database

  1. Add Devart LinqConnect Model to the project. To do this, right-click on the project node in Solution Explorer, point to Add, click New Item.... In the Add New Item dialog select Data category, choose Devart LinqConnect Model template, and click Add. This automatically launches Create New Model wizard, which creates a new empty model or generates it from database.
    Add item dialog box
  2. Click Next on the welcome screen.
  3. Fill in connection settings and click Next.
    Entity Developer Create Model Wizard - Setup data connection properties
  4. Choose database objects that will be used in the model. These are all objects from the crm_demo script, including auxiliary tables. Click Next.
    Entity Developer Create Model Wizard - Choose database object
  5. On the next screen you can adjust naming rules for entities and their members. For the CRM Demo database no rules are required, so just click Next.
    Entity Developer Create Model Wizard - Setup naming rules
  6. Input CrmDemoContext as namespace, and CrmDemoDataContext as the name of DataContext descendant. This will be the name of the main data access class. Click Next.
    Entity Developer Create Model Wizard - Model properties
  7. Press Finish. The model will be generated and opened in Entity Developer add-in.
  8. In the main menu, click File | Save. This updates the generated CrmDemoDataContext model code in Visual Studio.

The model you've just generated is ready to use.

Entity Developer diagram

Entity Developer creates classes for all selected tables that represent entities. It also creates a descendant of Devart.Data.Linq.DataContext class, which controls the connection to the database, and the whole data flow. This class includes properties and methods named after your database objects. You will use these members to retrieve and modify data in the context. The generated code is contained in the file DataContext.Designer.cs (DataContext.Designer.vb). You may write your own partial classes and methods for it in the file DataContext.cs (DataContext.vb).

Querying Data

All LINQ to Oracle operations are executed through the DataContext descendant, which is named CrmDemoDataContext in this tutorial. To retrieve data you have to first create an instance of the context, then prepare a query with LinqConnect, and then access the object returned by the query, which may be a collection of objects or a single object.

Let's read all the data from the table Company, sort it by CompanyID, and output some columns. Add the following block of code to the method Main:

C#csharp Copy Code
CrmDemoDataContext context = new CrmDemoDataContext();
var query = from it in context.Companies
            orderby it.CompanyID
            select it;

foreach (Company comp in query)
  Console.WriteLine("{0} | {1} | {2}", comp.CompanyID, comp.CompanyName, comp.Country);

Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoDataContext = New CrmDemoDataContext
Dim query = From it In context.companies _
    Order By it.CompanyID _
    Select it

Dim comp As company
For Each comp In query
    Console.WriteLine("{0} | {1} | {2}", comp.CompanyID, comp.CompanyName, comp.Country)
Next

Console.ReadLine()

As simple as that. You prepare a query and then iterate through it as you would do with a usual collection of objects. The database interaction is performed by LinqConnect in the background. Now let's see who is who in this code sample.

  • CrmDemoDataContext is the name of the class that knows all about your model and does everything to handle it. All LinqConnect operations are performed within this class's properties and methods. It is recommended that you keep a single instance of the class throughout your application because it consumes lots of resources, and entities are not allowed to be shared through different data contexts.
  • query, it are arbitrary variable names in the LINQ to SQL statement. The former is used as the collection of data objects, the latter is not used outside the statement.
  • context.Companies refers to a public property of CrmDemoDataContext class. This property represents the collection of all companies in the context.
  • Company (in the foreach statement) is the name of an autogenerated class. This class maps to the Company table in the database and is named after it.

Here is the project's output in the console:

Note that the LINQ query code just describes the query. It does not execute it. This approach is known as deferred execution.

Now let's query data from two tables united with a foreign key. Replace the old code with this:

C#csharp Copy Code
CrmDemoDataContext context = new CrmDemoDataContext();
var query = from it in context.Companies
            orderby it.CompanyID
            select it;

foreach (Company comp in query) {
  if (comp.PersonContacts.Count > 0) {
    Console.WriteLine("{0} | {1} | {2}",
      comp.CompanyName, comp.PersonContacts[0].FirstName,
      comp.PersonContacts[0].LastName);
  }
}

Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoDataContext = New CrmDemoDataContext
Dim query = From it In context.companies _
    Order By it.CompanyID _
    Select it

Dim comp As company
For Each comp In query
    If comp.personcontacts.Count > 0 Then
        Console.WriteLine("{0} | {1} | {2}", _
              comp.CompanyName, comp.personcontacts(0).FirstName, _
              comp.personcontacts(0).LastName)
    End If
Next

Console.ReadLine()

As you can see, the LINQ query statement was not changed at all. The data about the contact persons was retrieved from the database automatically when you accessed the corresponding property of the company object. This is one of the great things about LINQ: you do not have to worry about dependencies when writing queries.

Inserting New Data

What earlier was adding rows to tables, now is just adding new objects to context collections. When you are ready to send the changes to the database, call SubmitChanges() method of the context. Before doing this, you must first set all properties that do not support null (Nothing) values. The SubmitChanges() method generates and executes commands that perform the equivalent INSERT, UPDATE, or DELETE statements against the data source.

Let's add a new product and a new category to the database. Replace the old code with this:

C#csharp Copy Code
CrmDemoDataContext context = new CrmDemoDataContext();

// Create a new category
ProductCategory newCategory = new ProductCategory();
newCategory.CategoryID = 1000;
newCategory.CategoryName = "New category";

// Create a new product
Product newProduct = new Product();
newProduct.ProductID = 2000;
newProduct.ProductName = "New product";
newProduct.Price = 20;

// Associate the new product with the new category
newProduct.ProductCategory = newCategory;
context.Products.InsertOnSubmit(newProduct);

// Send the changes to the database.
// Until you do it, the changes are cached on the client side.
context.SubmitChanges();

// Request the new product from the database
var query = from it in context.Products
            where it.ProductID == 2000
            select it;

// Since we query for a single object instead of a collection, we can use the method First()
Product product = query.First();
Console.WriteLine("{0} | {1} | {2}",
  product.ProductCategory.CategoryName, product.ProductName, product.Price);
Console.ReadLine();
Visual Basic Copy Code
Dim context As CrmDemoDataContext = New CrmDemoDataContext
' Create a new category
Dim newCategory As productcategory = New productcategory()
newCategory.CategoryID = 1000
newCategory.CategoryName = "New category"

' Create a new product
Dim newProduct As product = New product()
newProduct.ProductID = 2000
newProduct.ProductName = "New product"
newProduct.Price = 20
' Associate the new product with the new category
newProduct.productcategory = newCategory
context.products.InsertOnSubmit(newProduct)

' Send the changes to the database.
' Until you do it, the changes are cached on the client side.
context.SubmitChanges()

' Request the new product from the database
Dim query = From it In context.products _
            Where it.ProductID = 2000 _
            Select it

' Since we query for a single object instead of a collection, we can use the method First()
Dim product As product = query.First()
Console.WriteLine("{0} | {1} | {2}", _
  product.productcategory.CategoryName, product.ProductName, product.Price)
Console.ReadLine()

The InsertOnSubmit() method is created for every collection in the context. This method stores in the database information about all linked objects. As shown in the example, it is only necessary to call InsertOnSubmit() once to submit both product and category objects.

Note that after you have added the new product and category by submitting the changes, you cannot execute this solution again as is. To execute the solution again, change the IDs of the objects to be added.

Updating Data

Entity instances are modified as usual. The only thing to remember is that you have to invoke the SubmitChanges() method to send the data to the database.

Append the following block to the existing code and launch the project:

C#csharp Copy Code
product.ProductName = "Edited product";
product.Price = 15;
context.SubmitChanges();
Visual Basic Copy Code
product.ProductName = "Edited product"
product.Price = 15
context.SubmitChanges()

Deleting Data

To extract an instance from a context use the DeleteOnSubmit method of the corresponding collection. The object is removed from the collection of its type, but not destroyed. To delete the object's data from the database invoke the SubmitChanges() method.

You can do this with a block of code like the following:

C#csharp Copy Code
context.products.DeleteOnSubmit(newProduct);
context.productcategories.DeleteOnSubmit(newCategory);
context.SubmitChanges();
Visual Basic Copy Code
context.products.DeleteOnSubmit(newProduct)
context.productcategories.DeleteOnSubmit(newCategory)
context.SubmitChanges()

Deletion of objects is affected by attributes in the model. When DeleteRule parameter is Cascade, dependent objects are deleted automatically. When this parameter is SetNull, dependent objects are not deleted, but the relation is nullified. When no rule is specified, the order of deletion sequence is important.

Additional Information

Now that you can perform the basic data manipulation with LinqConnect, you can move on to some advanced topics. dotConnect for Oracle includes a help section dedicated to the LinqConnect technology. You can access it online at http://www.devart.com/linqconnect/docs/ or locally in Visual Studio help collections.

LinqConnect is developed closely to the Microsoft's implementation of LINQ to SQL, so you might find some useful information in MSDN:

  • LINQ to SQL
  • LINQ to SQL: .NET Language-Integrated Query for Relational Data

For hands-on experience use samples shipped with dotConnect for Oracle. You can access the samples from the Start menu.

To understand deeper the works of LinqConnect engine you can watch the generated SQL statements in dbMonitor or using the DataContext.Log property.

See Also

LinqConnect section | Devart LinqConnect


LinqConnect Data Type Mapping

LinqConnect Data Type Mapping
support@devart.com

Type mapping rules from this table are used when Oracle table columns are mapped to the entity properties of LinqConnect model.

Oracle data type | CLR data type
INTERVAL YEAR TO MONTH, INTERVAL YEAR, NUMBER(1) - NUMBER(9) | System.Int32
NUMBER(10) - NUMBER(22), BINARY_DOUBLE, | System.Double
FLOAT(1) - FLOAT(10), BINARY_FLOAT | System.Single
NUMBER, FLOAT(11) - FLOAT(...) | System.Decimal
DATE, TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME ZONE | System.DateTime
INTERVAL DAY TO SECOND | System.TimeSpan
VARCHAR2, NVARCHAR2, CHAR, NCHAR, URITYPE, LONG, ROWID, UROWID, CLOB, NCLOB, XMLTYPE | System.String
RAW(16) | System.Guid
RAW, BLOB, BFILE, LONG RAW | System.Byte[]

Note Note:

Please note, that the mapping rules of NUMBER and FLOAT data types can change in dependence of the field size. For example, NUMBER(1)-NUMBER(9) will be mapped to the System.Int32, but NUMBER(10) - NUMBER(22) will be mapped to the double. NUMBER field without size definition will be mapped to the decimal. If you have a NUMBER(x, y) where y <> 0 or x > 15 then this value should be mapped to decimal.


Working with Transactions in LinqConnect

Working with Transactions in LinqConnect
support@devart.com

In this article we consider a short description of the LinqConnect transactional models. There are also some simple code listings illustrating different aspects of the transactional model.

LinqConnect has transactions as a part of its architecture.

Implicit Local Transaction. LinqConnect starts a local DbTransaction and uses it to execute generated SQL commands, if there is no open transaction into the LinqConnect connection instance. When all SQL commands have been successfully completed, LinqConnect commits the transaction and returns.

Explicit Local and Distributed Transaction. LinqConnect performs a check whether this call was executed in the scope of the Transaction started by user (local or distributed), when SubmitChanges is called. It is executed in the context of the same transaction, if the DataContext.Transaction property is set to a DbTransaction instance. Please note, that you should either commit or rollback the transaction (LinqConnect does not perform it for you).

C#csharp Copy Code
        //Opening connection
        context.Connection.Open();
        DEPT department = context.DEPT.Where(d => d.DEPTNO == 10).First();
        department.LOC = "TEST";
        //Opening transaction.
        //Transaction property
        context.Transaction = context.Connection.BeginTransaction();
        //This call participates in the transaction
        context.SubmitChanges();
        department.DNAME = "TEST";
        //This call also participates in the transaction
        context.SubmitChanges();
        //Replace the flag condition with the one you need
        //or remove it and leave only commit part
        if(flag)
        {
          //transaction completed successfully, both calls succeeded
          context.Transaction.Commit();
        }
        else
        {
          //something is wrong, both calls are rolled back
          context.Transaction.Rollback();
        }
Visual Basic Copy Code
        'Opening connection
    Context.Connection.Open()
    Dim department As Dept = context.Depts.Where(Function(ByVal d As Dept) d.Deptno = 10).First()
    department.LOC = "TEST"
    'Opening transaction
    'Transaction property
    Context.Transaction = Context.Connection.BeginTransaction()
    'This call participates in the transaction
    Context.SubmitChanges()
    department.DNAME = "TEST"
    'This call also participates in the transaction
    context.SubmitChanges()
    'Replace the flag condition with the one you need
    'or remove it and leave only commit part
    If(flag)
         'transaction completed successfully, both calls succeeded
          Context.Transaction.Commit()
    Else
         'something is wrong, both calls are rolled back
          Context.Transaction.Rollback()
        End If

Here is an example for DataContext.Transaction usage. In LinqConnect we have a context-level Transaction property.

In Microsoft LINQ to SQL the connection corresponding to the transaction must match the connection used for constructing the DataContext. An exception is thrown, if a different connection is used.

Devart LinqConnect implements this situation a bit differently - we use a new connection for every querying operation for performance reasons. There is a way to obtain the planned behaviour, however. To achieve this, you can use Devart.Data.DataContext.MaxUsedConnections property:

C#csharp Copy Code
Devart.Data.DataContext.MaxUsedConnections = 1;
Visual Basic Copy Code
Devart.Data.DataContext.MaxUsedConnections = 1

Then all queries will be executed using the single instance of the connection. In case of submitting the changes the DataContext.Connection persists.

Distributed Transactions and TransactionScope. Here is a code sample about usage Suppress option of TransactionScope:

C#csharp Copy Code
        DEPT department = context.DEPT.Where(d => d.DEPTNO == 25).First();
        department.DNAME = "xxx";
        using (TransactionScope tscope = new TransactionScope(TransactionScopeOption.Suppress))
        {
        //a new transaction will be created for this call
            context.SubmitChanges();
            tscope.Complete();
         }
Visual Basic Copy Code
        Dim department As Dept = Context.Depts.Where(Function(ByVal d As Dept) d.DEPTNO = 25).First()
    department.Dname = "xxx"
    Using TScope As New TransactionScope(TransactionScopeOption.Suppress)
        'a new transaction will be created for this call
        Context.SubmitChanges()
        TScope.Complete()
    End Using

You can find more information about Transactions in MSDN.


Entity Developer Overview

Entity Developer Overview
support@devart.com

Entity Developer is a powerful modeling and code generation tool for LinqConnect and ADO.NET Entity Framework. You can design an entity model from scratch or reverse-engineer an existing database, in which case you will have the classes and the relations with just several clicks. All model editing operations are performed in GUI, eliminating the need of manual XML code editing. Code for different programming languages can be generated for the model with predefined or custom T4-like templates.

Entity Developer Key Features

  • Support for ADO.NET Entity Framework v1 - v6
  • LinqConnect support
  • Visual schema modelling
  • Customizable and intuitive user interface
  • Reverse engineering model from database
  • Execution of LINQ to SQL, LINQ to Entities, and Entity SQL queries
  • Well-thought predefined templates for class generation and flexible T4-like template language for custom templates
  • TPC, TPT, TPH inheritances support
  • Customizable naming rules for database objects
  • Data viewing and editing
  • State-of-the-art diagram with diagram overview and printing
  • Entity Framework Storage Schema editing
  • Undo/Redo support
  • Comprehensive help system
  • Two ways of work: in integration with Visual Studio or standalone

Using Entity Developer

Entity Developer can be used as a separate application or as an add-in to Visual Studio 2008, Visual Studio 2010, Visual Studio 2012, Visual Studio 2013, or Visual Studio 2015. If the Visual Studio is installed on the PC, Entity Developer will be integrated with it during its installation, retaining the capability to be used as a separate application.

To start working with Entity Developer as a Visual Studio add-in, choose Add New Item... from the Project menu, then choose Devart LinqConnect Model or Devart Entity Framework Model, and click OK. The model will be added to your project and it will be opened as Entity Developer diagram. After this you may design the model manually or generate model entities from database by clicking the Create From Database button on the Entity Developer Model toolbar or by choosing Create From Database from the Tools -> Entity Developer menu. After you have finished editing model, just save it, and the code for it will be generated automatically.

Entity Framework model in Entity Developer VS addin

If you want to use Entity Developer as a separate application, you may launch it from the Devart dotConnect for Oracle program group in the Start Menu. Then create and design your model or generate the new one from database. After the model is finished, generate code for it and add the generated code files to your Visual Studio project.

See Entity Developer documentation for more information about using it. To open the documentation, choose Entity Developer Documentation from the dotConnect for Oracle program group in the Start Menu or press F1 when Entity Developer window or dialog is active.

Note: Entity Developer is available with dotConnect for Oracle Professional and Developer Editions only.

See Also

Devart LinqConnect | Entity Framework Support


Integration

Integration
support@devart.com

This section describes how dotConnect for Oracle integrates with other development software.

  • Visual Studio 2008 - 2015 Advanced Integration
  • Using dbMonitor
  • Using dbForge Fusion for Oracle


Visual Studio 2008 - 2015 Advanced Integration

Visual Studio 2008 - 2015 Advanced Integration
support@devart.com

dotConnect for Oracle integrates tightly with design-time features of Visual Studio 2008, 2010, 2012, 2013, and 2015 such as Server Explorer. This is also mentioned as Data Designer Extensibility features, or DDEX. The integration helps to design applications in more convenient and fast way. For example, you can take advantage of DataSet Designer, Data Source wizard, Query Builder, TableAdapter configuration, use Preview Data capability and configure web SqlDataSource component.

This topic provides information on what new features are available and how to use them.

Note that Server Explorer integration is not available for Compact Framework projects and in Visual Studio Express editions except Microsoft Web Developer Express 2008 and 2010.

This article consists of the following sections:

  • Integrating with Server Explorer
  • Design-time integration with project data
  • Getting more help and information

Integrating with Server Explorer

Server Explorer is the server management console for Visual Studio. Use this window to open data connections and to log on to servers and explore their databases. With Server Explorer you can view and retrieve information from all of the databases you are connected to. Use Server Explorer to list database tables, views, stored procedures, functions, and expand individual nodes to list their columns or arguments. Connections created with Server Explorer are later available in other parts of Visual Studio such as Data Designers.

To access Server Explorer, choose Server Explorer on the View menu.

Add/Modify Connection Dialog Box

Add Connection dialog box

This dialog box allows you to create and modify database connections. There are three ways to access this dialog box:

  • From the Tools menu select Connect to Database.
  • Right-click the Data Connections node in Server Explorer and click Add Connection.
  • Right-click the data connection you want to modify in Server Explorer and click Modify Connection.

The dialog consists of several controls where you supply information needed to connect to server. The following list describes the most important controls.

Host
The name or IP address of host of Oracle database to which to connect.
User Id
The Oracle login account.
Password
The password for the Oracle login account.
Allow saving password
If set to true password is stored among the other connection parameters.

After you fill the controls with data click Test connection button to verify it or click OK button to apply changes and close the dialog.

Advanced Properties dialog box

The Advanced Properties dialog box allows you to specify all properties for the dotConnect for Oracle connection. Invoke this dialog when you need to set specific and rarely used connection parameters.

Design-time integration with project data

Data source wizard

The Data Source Configuration Wizard creates and edits data sources in your application. These data sources can be made from databases, Web services, or objects, and can be bound to controls that display data on forms. After you run the wizard, the data source is available in the Data Sources window for dragging onto forms in Windows applications. For example, the wizard can generate and add DataSet to your project, which can be later customized with TableAdapter Configuration Wizard.

You can run the Data Source Configuration Wizard in any of the following ways:

  • Selecting Add New Data Source from the Data menu.
  • Selecting Add New Data Source from the Data Sources Window.
  • Selecting Add New Data Source from the DataSource property of bindable Windows Forms controls.
Data Source Configuration Wizard

When wizard starts, choose Database as data source type, and click Next. Then choose Dataset, and on the next page click the New Connection button. Change data source to Oracle Server, provide logon information and click OK. After that you will have to choose whether to save sensitive information together with other parts of connection string in application configuration file. On the last page of the wizard you select database objects to include in dataset.

On wizard completion you can switch to Solution Explorer to manipulate generated datasets.

TableAdapter configuration

The TableAdapter Configuration Wizard creates and edits TableAdapters. The wizard creates TableAdapters based on SQL statements you enter or on existing stored procedures in the database. The wizard can also create new stored procedures in the database based on SQL statements you enter into the wizard.

A TableAdapter connects to a database, executes queries or stored procedures against a database, and fills a DataTable with the data returned by the query or stored procedure. In addition to filling existing data tables with data, TableAdapters can return new data tables filled with data.

Using parametrized TableAdapter queries

A parametrized query returns data that meets the conditions of a WHERE clause within the query. For example, you can parametrize a customer list to display only customers in a certain city by adding WHERE City = ? to the end of the SQL statement that returns a list of customers. You create parametrized TableAdapter queries in the DataSet Designer, or during creation of data-bound forms in a Windows application with the Parametrize Data Source command on the Data menu. The Parametrize Data Source command also creates controls on your form to input the parameter values and execute the query.

Web SQL data source wizard

This wizard is similar to common Data Source Configuration Wizard. To open it from an ASP.NET Web server control perform the following:

  • In Visual Web Developer, create or open an existing .aspx page and then switch to Design view.
  • From the Toolbox, drag one of the server controls that support data binding onto the page. For example, from the Standard group of the Toolbox, drag a GridView control onto the page.
  • Right-click the control and then click Show Smart Tag.
  • In the tasks window, from the Choose Data Source drop-down list, select New data source. (If there is no drop-down list available in the tasks window, click Choose Data Source.)

Getting more help and information

If you experience problems with using Visual Studio windows related to tasks described above just press F1 to open Visual Studio documentation.

If you wish to study more detailed the capabilities of Visual Studio integration you can pay attention to Creating Client Data Applications section in Visual Studio Help. dotConnect for Oracle provides integration capabilities similar to standard data providers.

See Also

dbForge Fusion for Oracle | DataSet Wizard


Using dbMonitor

Using dbMonitor
support@devart.com

To extend monitoring capabilities of dotConnect for Oracle applications there is an additional tool called dbMonitor. It is easy-to-use tool to provide visual monitoring of your database applications. dbMonitor can be used for any kind of applications - desktop, ASP.NET and windows services.

dbMonitor performs per-component tracing of database events such as commit, rollback, SQL statement execution, preparing, etc.

dbMonitor has the following features:

ID

Name

Description

1

Events grid

Events grid displays you all the traced database events. It provides brief description, timestamp, duration, and event status. Below the grid four windows are docked in the group: SQL, Parameters, Error, and Call Stack. They display information about the event, currently selected in the Events window. You may click the header of the events grid columns to sort the events by the clicked column.

2

Event details

This group of four windows includes:

  • The SQL window displays the SQL statements for the database event, selected in the Events window, if the event is an execution of SQL code.
  • The Parameters window displays the SQL statement parameters for the database event, selected in the Events window, if this event is an execution of SQL statement, containing parameters.
  • The Error window displays information resulted in error.
  • The Call stack window displays call stack of the function, that started the event.
You can view main details of the selected event, switching between following windows. The screen above shows window for SQL-statement of the event (this event is an execution of SQL code).
To open a window that you need, select corresponding item from the View menu.

3

Processes window

This window displays list of monitored processes and their status. It allows you to choose what process to trace. Events grid displays events only for the selected process. After process application is closed, it has Terminated status, but its event log is not cleared, you can still view their information or save it to file. To remove terminated process from the list, either right-click it and select Delete Inactive from the popup menu, or click it and then click the Delete Terminated Process button on the toolbar.

4

Object tree window

This window below the Processes window displays monitored objects. Objects are combined in a tree with top level All Objects node, second level connection object nodes, and third level object nodes. Object Tree also contains 'Pools' node to group connection pools. It allows you to view events for all process objects, for specific connection, or for specific object. Just click the node to trace events for this node and its descendants.

5

Call tree window

It contains merged call stacks of the database events for the process. You can use it to filter events by functions, that started them. Just click the function in call stack tree, and Events window will display only events, called from that function or its descendants.

Remote debugging

To use remote debugging for your applications, you should set the following properties:

  • OracleMonitor.Host - to the name or IP address of the computer, where dbMonitor will be used.
  • OracleMonitor.Port - to the port, that will be used for communicating between dbMonitor and your application.
Then in dbMonitor options you should set the same port value on the General tab of the Options Dialog Box. After this you may run your application and monitor database calls.

Unicode support

You can monitor applications using international databases by help of the Unicode support.

During monitoring you can easy switch between client processes and view hierarchy of objects being traced.

dbMonitor is intended to hamper application being monitored as less as possible.

Monitoring is accessible at design-time as well.

To trace your application with dbMonitor you should follow these steps:

  • Create an instance of OracleMonitor component in your application. You can do it by dropping OracleMonitor on form from toolbox or by creating it manually in code. Only one instance of OracleMonitor is needed in the application.
  • Set OracleMonitor.IsActive property to true to enable monitoring.
  • Start dbMonitor application before running your program. If dbMonitor is installed you can start it from OracleMonitor component designer by clicking "Run dbMonitor" verb or from Oracle submenu of the Tools menu.

Optional. To trace your application remotely with dbMonitor you should follow these steps:

  • Perform the steps defined above.
  • Set OracleMonitor.Host property to the name of the station where dbMonitor is running.
  • Set OracleMonitor.Port property to port number of the dbMonitor application (1000 by default).
  • Run dbMonitor application and start tracing.

Note: dbMonitor utility is available with dotConnect for Oracle Professional and Developer Editions only.

See Also

OracleMonitor Class | Devart.Data.Oracle Namespace


Using dbForge Fusion for Oracle

Using dbForge Fusion for Oracle
support@devart.com

This article provides basic information about dbForge Fusion for Oracle. The article explains what dbForge Fusion is, where it can be downloaded, and how to install and start using it. For detailed information on dbForge Fusion, please, refer to its own documentation.

This article consists of the following sections:

  • Introduction
  • Versions and Compatibility
  • Downloading and Installing
  • Basic Usage Instructions
  • Complete Documentation

Introduction

dbForge Fusion is a powerful tool designed to automate and simplify Oracle database development process. It integrates into Visual Studio making all database development and administration tasks available from your favorite IDE. Using dbForge Fusion, you can:

  • Automate debugging by means of step-by-step code execution, breakpoints, watches, call stack, and a variables evaluation mechanism
  • Work with databases offline
  • Use extended code formatting and completion capabilities that enable code navigation, quick object information, and syntax check
  • Optimize multi-second queries by detecting problems and bottlenecks in them
  • Build complex queries in several clicks using a visual diagram and expression editor
  • Create and modify table structures and indexes visually using a table editor
  • Create, edit, analyze, reverse-engineer your Oracle databases visually with a database diagram
  • Compare and analyze changes in your database data and schema, generate comparison reports
  • Export and import data to/from more than 10 popular formats to fill your databases with new data
  • Customize the process and use templates to adjust the process

Screenshot of dbForge Fusion for Oracle

Versions and Compatibility

  • dbForge Fusion for Oracle supports Oracle server versions from 8i to 12c.
  • dbForge Fusion for Oracle is compatible with .NET Framework 3.5, 4.0, 4.5.
  • dbForge Fusion for Oracle can be used with Microsoft Visual Studio 2010, 2012, 2013, and 2015.
  • dbForge Fusion for Oracle can be used with dotConnect for Oracle version 7.6 or higher.

Devart issues dbForge Fusion for Oracle for integrating into different versions of Microsoft Visual Studio (2010, 2012, 2013). There are also versions that do not require an IDE (dbForge Studio for Oracle) and that are designed for Oracle server (dbForge Studio for Oracle product line). You can find the full list of Devart database tools on the web site.

All registered customers of dotConnect for Oracle Developer Edition are granted right to download and use dbForge Fusion.

This version of dotConnect for Oracle is compatible with dbForge Fusion 3.50 and higher.

Downloading and Installing

Before installing dbForge Fusion make sure that there is no earlier version of the software installed for the target IDE.

Download an appropriate dbForge Fusion version from the dedicated webpage: http://www.devart.com/dbforge/oracle/fusion/download.html. After you download the file, close all open IDE instances, launch the downloaded installer and follow the instructions of the wizard.

Basic Usage Instructions

Creating, modifying and deleting database connections

Database Explorer displays database connections at the top level of the tree hierarchy. After a connection is established, you can open it to retrieve and manipulate the data provided.

To add a database connection:

  1. On the Database Explorer window toolbar, press the New Connection button or select the corresponding item from the shortcut menu.
  2. On the Data Source tab of the Database Connection Properties dialog box, choose the required database server from the list.
  3. On the Connection tab of the Database Connection Properties dialog box, provide the main logon information required to connect to the server.
  4. On the Parameters tab of the Database Connection Properties dialog box, provide all specific connection properties you need.
  5. You can optionally perform a connection test by clicking the Test Connection button.
  6. Click OK to establish a database connection.

Then the Database Connection Properties dialog box is closed, and the new database connection is displayed at the top level of the tree and the database can now be accessed.

You can modify database connection properties in the Database Connection Properties dialog box. To open it, select Modify Connection from the shortcut menu of the root node. After you apply changes to the existing connection by pressing the OK button, the database connection is closed and reopened.

To drop a database connection, choose Delete from the shortcut menu of the node.

Displaying server specific database schema information in a tree view

After the database connection is created and opened, you can explore the database schema hierarchy by expanding the tree nodes. Database Explorer allows you to view, edit, create and drop database objects. To see the actions available for a specific node, right-click it to display its shortcut menu.

As other users modify the database, you can refresh the list of the database objects displayed in the Database Explorer and their properties by clicking the Refresh button.

Designing Databases

dbForge Fusion provides two ways of database design:

  • Offline database design with database projects, allowing you to build your database project to the deployment script.
  • Online database design with Visual Database Designer, Database Explorer, and database object editors.

Database projects have significantly improved database development, giving developers a number of great opportunities.

A database project is an offline representation of a database schema with extended opportunities for offline schema development. It is a collection of logically organized SQL scripts and query files, which are used both to create a new database and update the existing one.

Database development is clear and logical within a database project. It allows you to do the following:

  1. Create a database project with the help of the wizard, either empty or with database objects imported from the required database.
  2. Manage SQL scripts and query files in the project and edit their contents.
  3. Build the ready project to create a script that will deploy all the project changes to the database on the server.
  4. Deploy either the entire project or only certain changes to the server.

Visit the Database Projects - Modern Approach in Database Development article on our website to learn more about using Database Projects.

Database Designer is a powerful visual design tool for database development that allows you to build a clear and effective database structure visually and to see the complete picture representing all the tables, foreign key relations between them, views, and stored routines of your database on a database diagram. It allows you to view and edit your database in a convenient visual way.

To create a database diagram, click the Create New Database Diagram button on the main application toolbar, then drag the existing database objects to the diagram. After this you can use the dbForge toolbar buttons or diagram shortcut menu to align objects and create new ones.

Most of database objects displayed in the Database Explorer tree can be modified. There are two kinds of object editors: a popup dialog box and a tool window based editor. When you launch a popup dialog editor from the tree view, changes are applied to the database right after you click the OK button. Unlike the dialog box, the editor based on a tool window can post or discard changes several times without closing the editor. In addition, dbForge Fusion allows you to open more than one tool window based editor simultaneously.

For every object that has some properties a special window is available where you can see all the properties of a given element such as tables, indexes, connections and so on.

To drop a database object, navigate to it, right-click, and choose Delete in the shortcut menu.

Debugging stored routines and SQL scripts

dbForge Fusion has a professional tool for debugging stored routines and SQL scripts with Oracle. The full-featured Debugger automates all time consuming tasks connected with debugging and provides full code control. It enables you to do the following:

  • perform step-by-step execution of procedures, functions, triggers, and SQL scripts
  • view the currently active stack of stored routine calls
  • set breakpoints to stop execution on any code line
  • evaluate variables and parameters declared in routines

To debug a stored routine you must compile it with debug information. To do this, right-click the required routine in the Database Explorer and select Compile for Debugging from the Debug submenu of the shortcut menu. To start stored routine debugging, right-click the stored routine in the Database Explorer or a stored routine source window and use the Step Into command from the Debug submenu of the shortcut menu. Then you can step through the debugger execution using the Step Into, Step Over and Step Out debugger commands from the debugger toolbar or the Debug menu.

To debug SQL Script, open the required script in the SQL editor and choose Start from the Debug menu. The breakpoints can be set at SQL statements. If some statement is invalid, the error message appears in the error list. Though debugging process continues. The debugging of SQL script can be suspended by the Pause command. You can also use the Step commands of the Debug menu to trace the SQL script.

Comparing and synchronizing database schema and data

dbForge Fusion for Oracle gives you a perfect opportunity to compare schema and data between different databases with many useful features. New Schema Comparison and New Data Comparison wizards provide easy ways to set comparison parameters. Click Tools, to open these wizards. Then select dbForge Fusion for Oracle, and click Database. Then choose the objects to be synchronized, and click the Show Synchronization Wizard button on the Comparison toolbar to start synchronization.

Creating and executing SQL statements with SQL editor

dbForge Fusion allows you to execute all kinds of queries. Click the Create New SQL button on the toolbar to create a new SQL document. Type your query in it and click the Execute button to run it. Results of the query as well as error messages are redirected to the common Output window. You can view the dataset returned from the SELECT query in the Data tab (on the View menu, click Data if it is not visible yet).

Designing queries visually using Query Builder

You can switch to the Design mode to construct a query using Query Builder. In this mode you can create SELECT statements easily and quickly. To open Query Builder, click the corresponding menu item on the View menu. Note that if you have had a correct SELECT statement in the SQL editor, it is automatically inserted into Query Builder. Now you can drag and drop tables from the Database Explorer. Use a special tabbed editor to easily setup JOIN options as well as WHERE, GROUP BY, HAVING and ORDER BY clauses.

Viewing and editing data using a grid based editor

Database objects representing tables and views allow you to view and edit their data using a special data editor. It is accessible from the object shortcut menu. When you open the editor, it is automatically filled with data from a table. To apply inserting of a new row in a table, press ENTER; to cancel changes, press ESC. To refresh data from a table, click Refresh in the shortcut menu.

Creating new components by dragging items from the Database Explorer

You can drag connections, tables and stored procedures from the Database Explorer and drop them onto Visual Studio designers, the integrated development environment (IDE) automatically creates new components that reference the resources selected. For example, if you drag a table from Database Explorer onto a Visual Studio designer, the IDE automatically creates new instances of OracleConnection and OracleDataAdapter components preconfigured to reference that particular table.

Taking advantage of component designers' extended capabilities

dbForge Fusion extends the functionality of component designers by adding new commands to provide easy access to useful operations. Click a command to open the corresponding wizard and setup the component. This feature makes common operations far more handy. For example, the Oracle Connection designer has a new "Open in Database Explorer" command; an Oracle Command has capabilities of editing SQL statements using "SQL Editor..." and "Query Builder..." as well as editing a target object using "Object Editor..." command; the Oracle Data Adapter and Oracle Data Table designers have a handy "Query Builder..." command that calls Query Builder. You can quickly setup a connection string for Oracle Connection by clicking the "Connection String..." command and choosing an existing connection to inherit its parameters.

Complete Documentation

dbForge Fusion has its own comprehensive documentation that describes every aspect of using the software, contains walkthroughs and reference information. There are several ways to open the documentation:

  • Use an appropriate shortcut in the Start menu, for instance, Start - Programs - Devart dbForge Fusion - Documentation.
  • Use a command in the IDE: Tools - Devart dbForge Fusion - Help.
  • Focus on any dbForge Fusion element (for example, on the Database Explorer), and press F1.


Frequently Asked Questions

Frequently Asked Questions
support@devart.com

This page contains frequently asked questions about dotConnect for Oracle. When you have a question first of all please browse through this list. If this page does not contain the answer, refer to support page.

  1. What is the difference between the Standard and Professional editions?
    The Standard Edition represents a fully-featured ADO.NET data provider with design time support and advanced classes. The Professional Edition adds more classes, tools, technologies, and integration capabilities. The following list briefly enumerates main advantages of Professional Edition.
    • Entity Framework support allows you to employ the latest conceptual technology from Microsoft.
    • LinqConnect support allows you to focus on objects instead of relational data in database application development.
    • The OracleLoader class serves to load external data into the Oracle database extremely fast.
    • The OraclePackage class and Package Wizard provide access to packages stored in the Oracle database.
    • The DataLink class serves for universal cross-form data binding.
    • The OracleAlerter and OraclePipe classes serve for advanced messaging between client and server.
    • The OracleTrace class designed to controls server side SQL and PL/SQL tracing.
    • The powerful OracleDataTable component as all-in-one table data access solution.
    • The OracleDataSet class allows using typed and untyped provider-specific datasets.
    • DataSet Wizard greatly simplifies process of generating datasets in your application.
    • DataSet Manager and DataSet Editor help managing the datasets.
    • Advanced Queue technology support enables you to rich a new level of flexibility in your applications.
    • Support for dbMonitor that performs per-component tracing of database events such as SQL statement execution, commit, rollback, etc.
    • Enterprise Library support allows you to take advantage of Data Access Application Block functionality.
    • ASP.NET 2.0 providers support allows using dotConnect for Oracle in ASP.NET 2.0 provider model.
    • Windows Workflow Foundation support includes Oracle Workflow Instance Store and Workflow Tracking
    • Sync Framework support allows using dotConnect for Oracle for synchronizing Oracle data with other data sources.
    To test this functionality use the Trial Edition, which incorporates all aforementioned features.
  2. What is the difference between the Professional and Developer editions?
    The Developer Edition includes everything from the Professional Edition plus Standard Edition of dbForge Fusion for Oracle, an advanced add-in for designing databases and easily manipulating data and schema objects from your IDE. dbForge Fusion for Oracle greatly speeds up the development process every time you interact with your database.
  3. What is the difference between the Express and Standard editions?

    Express Edition is a free data provider with basic connectivity features. Standard Edition represents a fully-featured ADO.NET data provider with design time support and advanced classes.

    The following list briefly enumerates main advantages of Standard Edition.

    • The Direct mode to connect without Oracle Client
    • The OracleScript class serves to execute series of SQL statements separated by special symbols
    • The OracleMonitor class monitors dynamic SQL execution in applications that use dotConnect for Oracle
    • The OracleDependency class tracks changes on the server
    • The OracleSelectStatement class represents Oracle SELECT statement
    • Design-time features allow you to move the development process from run time to design time, which is way more comfortable
    • Migration Wizard helps to migrate project from Microsoft OracleClient and Oracle ODP.NET data providers to dotConnect for Oracle.
Installation and deployment
  1. I installed dotConnect for Oracle trial, then I have bought and installed purchased version, but something went wrong.
    Make sure you had uninstalled the trial version correctly. There should be no old (trial) assemblies present in your system. Uninstall dotConnect for Oracle and check your Global Assembly Cache and local folders for Devart.* assemblies. Remove all Devart.* files and reinstall dotConnect for Oracle.
  2. How do I upgrade to a newer version of dotConnect for Oracle?
    Close all running IDEs and help collections, then run the installation package of the newer version. You will be prompted to uninstall the previous version; agree and then proceed to installing the newer build.
  3. You say, there are sample projects, but I can't find any.
    Probably you installed dotConnect for Oracle not in full mode. Please choose full when installing the product. All samples are installed by default in \Program Files\dotConnect\Oracle\Samples folder.
  4. Are there any restrictions for Visual Studio Express editions?
    Yes, there are some. First, the provider add-in (and hence menu item) is not available. Second, components are not registered in toolbox automatically (though you can do it manually). Finally, advanced Visual Studio integration (DDEX) is not available, except Microsoft Web Developer Express 2008 and 2010.
  5. How do I deploy my application?

    To deploy an application written with dotConnect for Oracle, you need to:

    • deploy the Devart runtime assemblies used by your application;
    • include the technical license resource;
    • in case your application uses provider factories, you also need to expose dotConnect for Oracle to the system.

    For the detailed description of each of these steps, please refer to the Deployment and Licensing topics in dotConnect for Oracle help.

  6. How to install dotConnect for Oracle on machine that does not have Visual Studio or Delphi installed?
    Choose "Minimal" type when asked by the installer.
  7. How do I upgrade my projects from dotConnect for Oracle 4.xx?

    In the 5.0 release there were some important name changes in the product. Particularly, assemblies, namespaces, invariant name, and some types were changed as follows:
    "CoreLab.Data" became "Devart.Data";
    "CoreLab.Oracle" became "Devart.Data.Oracle";
    "OracleDirectFactory" became "OracleProviderFactory";
    Invariant name became "Devart.Data.Oracle";

    Your projects must be updated to be compatible with dotConnect for Oracle 5.0. Here is the list of files you should update:
    *.csproj, *.vbproj - references to assemblies
    *.cs, *.vb - namespaces
    *.licx - namespaces and assembly names
    Web.config - assembly names and web provider types

    This is done automatically when you invoke the Upgrade wizard from Visual Studio menu: Tools | Oracle | Upgrade Wizard.

  8. I have received a message that Devart.Data is incompatible...

    Devart data providers use a common assembly (Devart.Data.dll), so it is necessary to install compatible providers versions. We release our ADO.NET data providers in a single pack, thus releases from the same date should be compatible. Also, Devart data providers should warn you before installation if an incompatible version of Devart.Data.dll was detected.
  9. I have received the following message - "error 0175: The specified store provider cannot be found in the configuration, or is not valid..". What does it mean and what should I do?

    You should put the Devart.Data, Devart.Data.Oracle, and Devart.Data.Oracle.Entity.EF<Version> assemblies in the Bin folder of your application (or place these assemblies in Global Assembly Cache). The <Version> here is the version of Entity Framework used in your application. For Entity Framework v1 the assembly is called Devart.Data.Oracle.Entity.EF1.dll, for Entity Framework v4 it is Devart.Data.Oracle.Entity.EF4.dll, for Entity Framework v5 or v6 it is Devart.Data.Oracle.Entity.EF5.dll or Devart.Data.Oracle.Entity.EF6.dll respectively. For Entity Framework Core it is Devart.Data.Oracle.Entity.EFCore.dll. Make sure that your application is licensed correctly (take a look at the Licensing article for more information).

    Information about provider registering is available in the Deployment article.
Subscriptions and Upgrades
  1. I have a registered version of dotConnect for Oracle. Will I need to pay to upgrade to future versions?

    Since dotConnect for Oracle 4.00, all upgrades to future versions are free for users with an active dotConnect for Oracle Subscription.

    Users that have a registration for versions of dotConnect for Oracle prior to OraDirect .NET 4.00 can upgrade to dotConnect for Oracle 5.00 to jump in on the Subscription Program.
  2. What are the benefits of the dotConnect for Oracle Subscription Program?

    The dotConnect for Oracle Subscription Program is an annual maintenance and support service for dotConnect for Oracle users.

    Users with a valid dotConnect for Oracle Subscription get the following benefits:

    • Access to new versions of dotConnect for Oracle when they are released
    • Access to all dotConnect for Oracle updates and bug fixes
    • Product support through the dotConnect for Oracle Priority Support program
    • Notification of new product versions

    Priority Support is an advanced product support program which offers you expedited individual assistance with dotConnect for Oracle-related questions from the dotConnect for Oracle developers themselves. Priority Support is carried out over email and has a two business day response policy.

    The dotConnect for Oracle Subscription Program is available for registered users of dotConnect for Oracle 4.00 and higher.
  3. Can I use my version of dotConnect for Oracle after my Subscription expires?

    Yes, you can. dotConnect for Oracle version licenses are perpetual.
  4. Do I need a new subscription to use dotConnect for Oracle 8?
    No, you don't. Provided that you have an active subscription, you will be able to download dotConnect for Oracle 8 from Registered Users' Area.
Technical Licensing
  1. What is the licensing you use?
    dotConnect for Oracle uses .NET component licensing. To build operational application dotConnect for Oracle requires valid license. If no license is available, dotConnect for Oracle does not work.
  2. How to embed license into my application?
    Usually you do not have to care about embedding license in your application. When you install dotConnect for Oracle the system is configured so that licensing is done transparently. License is automatically added to project when you place a OracleConnection component onto a form.
    In some cases you have to manually add license. It is necessary for console applications, class libraries, some ASP.NET applications and existing projects initially built with dotConnect for Oracle version that did not use component licensing, that is, 3.20 and older. For instructions on how to add license manually refer to Licensing topic in dotConnect for Oracle help.
  3. On opening connection I get an exception saying "License not found...". What should I do?

    This generally indicates that license information could not be found, or you try to apply it in some way that does not suit the kind of application. For example:

    • File licenses.licx, required for dotConnect for Oracle to function properly, could not be found.
    • File licenses.licx is not added as embedded resource.
    • File App_Licenses.dll not found in ASP.NET applications.

    To fix the problem determine type of your application and read corresponding section of "Licensing topic.
  4. On opening connection I get an exception saying "License not valid...". What should I do?

    This means that license information was found but it is incorrect. It usually happens in the following cases:

    1. The project was earlier compiled with old or trial version of dotConnect for Oracle.
    2. File licenses.config used by a class library does not refer to launched executable.
    3. The App_Licenses.dll belongs to other application or needs to be recompiled.
    4. Something's wrong with the operating system or installation of dotConnect for Oracle.

    If you encounter one of these problems, do the following (the numbers of actions correspond to the numbers of the problems in the above list):

    1. Delete all files from the bin and obj folders and rebuild the project.
    2. Specify the executable in the licenses.config file.
    3. Rebuild App_Licenses.dll for the current application.
    4. Perform the following steps:
      1. uninstall dotConnect for Oracle;
      2. remove all Devart.* and policy.*.Devart.* files from the GAC;
      3. clear the Program Files\Devart\dotConnect and Program Files\Common Files\Devart\dotConnect folders;
      4. re-install dotConnect for Oracle.

    If this does not help, send a small compiled binary with sources to our support address, so we can investigate the problem in more details.
  5. Deployed application worked fine some time, but in some moment it started to say "Sorry, your trial period has expired". But I do not use trial version any more.
    Probably you compiled the application with Trial edition of dotConnect for Oracle, and deployed it with assemblies from non-trial version. In this case time limit is actual as well. To eliminate the problem just recompile the project.
  6. How to license ASP.NET applications?

    To support server-side compilation you ought to have special assembly App_Licenses.dll in the Bin directory of your site. To create this assembly execute Build Runtime Licenses command in the licenses.licx file context menu in the Solution Explorer view. Required assembly will be created automatically.

    Note that this is not necessary for precompiled ASP.NET applications (if nothing is compiled on server by user request). Precompiled applications are licensed as usual applications.
  7. How to make dotConnect for Oracle work with SQL Server 2008 Business Intelligence Solutions?

    To do this install dotConnect for Oracle on same computer where SQL Server 2008 resides.
  8. I am having problems with the licensing in my project... What am I to do?

    If any problems with licensing occurred in your project, you should use the License Information dialog to resolve them. You can access it from the Visual Studio menu: Tools | Oracle | License Information.
  9. Do end-users need a license?
    No, end-users of your application do not require any license.
Connection pooling
  1. I call OracleConnection.Open(), then Close(). Physical connection is still visible by server. Isn't it a bug?
    No, it is not. This is Connection Pooling feature. Actual connection is not closed in order to be used later by your application. This boosts performance greatly.
  2. I get exception "Timeout expired. The timeout period elapsed..." What to do?
    The full text of the exception is "Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached." It clearly states that you have run out of connections available. To solve the problem increase Max Pool Size connection string parameter value. The default value is 100. Another way to get extra connections is to clear one or all of the pools. Or you can turn connection pooling off using Pooling connection string parameter.
  3. How to prevent possible pooling problems?
    You can clear the pool explicitly. Generally pool is cleared automatically when connections are idle or closed by server. To force the operation call ClearPool or ClearAllPools methods. Another solution is to disable the pool at all (set Pooling=false in connection string). If this does not help, the problem is not caused by pooling.
Documentation problems
  1. How to open documentation on dotConnect for Oracle?
    There are several ways to open dotConnect for Oracle documentation:
    • Use appropriate shortcut in start menu, for instance, Start - Programs - Devart dotConnect for Oracle - Documentation.
    • Use command in the IDE: Tools - Oracle - dotConnect for Oracle Help.
    • Position cursor on some class from Devart.Data.Oracle and press F1.
    There is also same documentation in chm format. You can download it from our site at the following address: www.devart.com/dotconnect/oracle/dcoracle.chm
  2. I can't see the documentation in Visual Studio Help Collection.
    Correctly installed documentation appears as separate node in combined collection of Visual Studio and Delphi. If you can't find dotConnect for Oracle node there it is because you enabled topics filtering. To reveal the node set filter to "Devart Documentation", or "(unfiltered)", or "Visual C#" etc.
    Another possible reason is that you installed some IDE after installation of dotConnect for Oracle. In this case use aforementioned methods to reach documentation.
  3. All topics in CHM file are blank.
    This can happen due to some patches from Microsoft installed on your system. Please read this page to find possible solutions for the problem. In most cases it is enough to right-click on the CHM file, select Properties, click on the "Unblock" button and click "Apply" to show the contents.
ORM solutions
  1. Are LINQ to SQL and Entity Framework supported?
    The Professional Edition of dotConnect for Oracle supports both LinqConnect (formerly called LINQ to Oracle) and the latest version of ADO.NET Entity Framework.
  2. Where do I start with Entity Framework or LinqConnect?
    For your convenience there are brief tutorials that you can use to get acquainted with the technologies:
    • Entity Framework Tutorial
    • LinqConnect Tutorial
  3. Are there any demo projects to play with?
    Yes, dotConnect for Oracle includes several Entity Framework and LinqConnect samples in C# and Visual Basic. The samples demonstrate how to use several entities and a relationship between them. You can also download separate Entity Framework Query Samples package, which is a standard Microsoft demo with added Oracle connectivity.
Miscellaneous
  1. How to obtain ROWID value after INSERT or UPDATE operation?
    Use OracleCommand.GetRowId method.
  2. I get concurrency error when modifying records using OracleDataAdapter or OracleDataTable. What can be wrong?
    This can happen when OracleCommandBuilder generates a query without primary key field. To avoid it use custom update command instead of generated by OracleCommandBuilder. This problem should not take place if primary key field participates in SELECT statement.
  3. No components can be found in the toolbox.
    This can happen if the installation encountered some problems. You can add the components to toolbox manually. This procedure is described in the Installation article in the documentation. Note that Microsoft Web Developer 2008 Express edition does not allow working with toolbox at all.
  4. dotConnect for Oracle components in Visual Studio 2008 are grey...
    Make sure you're in Component Designer view. Do not confuse with Designer view. To switch between views use context menu of .aspx file in Solution Explorer. This relates to Web projects only.
  5. SQL Server Integration Service (SSIS) can't get the list of tables in my Oracle server.
    This is an architecture limitation from Microsoft, SSIS understands metadata of SQL Server only. To circumvent this you have to write queries manually.
  6. Can I use dotConnect for Oracle assemblies in the x64 process?
    dotConnect for Oracle assemblies are built with the /platform:anycpu option. So, you can use provider's assemblies on any platform (x86 or x64). For more information, refer to http://msdn.microsoft.com/en-us/library/zekwfyz4.aspx. The mode of your own assemblies depends on capacity of Oracle Client you are using, and doesn't depend on capacity of your Oracle Server.
  7. I get an exception "Can not obtain Oracle client information from registry. Make sure that Oracle Client Software is installed, or use Direct mode of connecting to server."
    This exception means that your application uses an OCI connection, and either there is no Oracle Client installed on the computer your application is running on or that the Oracle Client and your application have different bitness (x86 or x64). To solve the issue:
    1. Make sure that Oracle Client is installed on your computer.
    2. Make sute that Oracle Client has the same bitness as your application. For 32bit application, you must have 32bit Oracle Client installed, and for 64bit application you must have 64bit Oracle Client installed.
    3. Make sure that the user account, on behalf of which the application is running, has enough privileges to access registry.
General issues related to Oracle server
  1. Cannot connect to server on %server name%...
    This is actual for mobile edition. Use IP of the server instead of DNS name. It is recommended to use internal IP address. For information on how to address target machine refer to network administrator.
  2. What about performance?
    We regularly carry out performance tests on different databases with miscellaneous environments. The tests show that dotConnect for Oracle is much better than ODBC, OLEDB, and ODP.NET. Besides that dotConnect for Oracle has much more features than any data provider, including ODP.NET.
  3. Non-latin characters in my data are not retrieved correctly.
    Use UTF-8 encoding. To enable it, set Connection.Unicode property to true or include Unicode=true; in connection string. Keep in mind, however, that this affects performance. So it is better to synchronize default client encoding and database objects encoding if possible.
  4. I successfully run illegal SQL script that issues CREATE OR REPLACE PACKAGE... Where is my error?
    Errors in CREATE OR REPLACE PACKAGE are considered as warnings in Oracle because PACKAGE can be created with errors. You can get information about warnings using OracleConnection.InfoMessage event.
  5. I work with dates and get different results in Direct and OCI modes.
    Direct mode does not consider Oracle client settings. The results would be identical if you set NLS_LANG='AMERICAN....' in HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEn (change AMERICA to you real location) or execute statement like this in Direct mode: ALTER SESSION SET NLS_TERRITORY ='AMERICA'
  6. I can't get or pass data through Array type parameter.
    Probably you use wrong type of parameter. Consider the following declarations:
    TYPE PLSQLTableType IS TABLE OF VARCHAR2(20) INDEX BY BINARY_INTEGER;
    TYPE NESTEDTABLEType1 IS TABLE OF VARCHAR2(20);
    TYPE NESTEDTABLEType2 IS TABLE OF OBJECTTYPE;
    TYPE VARRAYTYPE AS VARRAY(3) OF VARCHAR2(20);

    Use PLSQLTableType with OracleDbType.VarChar and int[] types.
    Use NESTEDTABLEType1 and NESTEDTABLEType2 with OracleDbType.Table and OracleTable types.
    Use VARRAYTYPE with OracleDbType.Array and OracleArray types.
  7. I have a stored procedure that returns a "cursor" parameter. What do I need to do on client side to retrieve this parameter?
    You can use OracleCommand with stored procedure call in conjunction with OracleDataAdapter component and fill any DataSet as usual. You can receive OracleCursor value from executed OracleCommand and receive OracleDataReader as described below:
    OracleParameter p;
    ...
    OracleDataReader r = ((OracleCursor)p.OracleValue).GetDataReader();
    You can fill DataSet from any OracleCursor object as follows:
    DataSet ds = new DataSet();
    cmd.ExecuteNonQuery();
    oracleDataAdapter1.Fill(ds, ((OracleCursor)cmd.Parameters["pcur"].OracleValue));
  8. How to connect using dotconnect for Oracle through Oracle instant client?
    You have to include path to oci.dll to the first place in environment PATH variable. Put tnsnames.ora to directory where your application is located.
  9. I have an Oracle query with nested subqueries. When a column from the outer query is used in the subquery of level 2 and deeper, I get an error "ORA-00904 - Invalid identifier". However, the same SQL works perfectly on my Oracle 10.2.0.1 instance. What's going on?

    This is a known Oracle feature. It does not recognize the fields from the outer query in the subquery. For example, the following query leads to this error:

    SELECT "Extent1".DEPTNO AS ID
FROM DEPT "Extent1"
  WHERE EXISTS (
    SELECT
    1 AS C1
    FROM ( SELECT
      "Extent2".EMPNO AS ID
      FROM EMP "Extent2"
      WHERE "Extent1".DEPTNO = "Extent2".DEPTNO
    ) "Project1")

    This behavior was changed in Oracle 10.2.0.1, and these changes were rolled back in the further Oracle versions.
Mobile edition
  1. I'm getting "A socket operation encountered a dead network" when trying to connect with Mobile Edition in run time.
    Make sure that you have synchronized your device with a workstation because some synchronization tool (e.g., Microsoft ActiveSync or Windows Mobile Device Center) should be used when you work with mobile device or emulator. Before deployment make Connect and Cradle to the emulator you want to use via Device Emulator Manager (the Tools menu in Visual Studio). After cradle the ActiveSync icon in the tray should become green (indication that synchronization is successful). In the case of Windows Mobile Device Center, its Sync Center should return the "Connected" and "Sync completed" statuses.
  2. When deploying application compiled with a trial version to mobile device, I'm getting the "trial period expired" exception. What's wrong?
    The possible reason may be that the system date/time of the device is not synchronised with the date/time on your workstation; hence, the problem can be resolved by setting the date/time identical to the one on the workstation.


Reference

Reference
support@devart.com

Assemblies

Assembly | Description
Devart.Data | This assembly is shared with other Devart data providers.
Devart.Data.Oracle | This assembly contains the dotConnect for Oracle specific functionality.
Devart.Data.Synchronization | This assembly is shared with other Devart data providers and contains base classes for synchronizing databases with Microsoft Sync Framework.
Devart.Data.Oracle.Synchronization | This assembly contains the dotConnect for Oracle specific classes for synchronizing databases with Microsoft Sync Framework.


Devart.Data Assembly
See Also support@devart.com

Namespaces

Namespace | Description
Devart.Common |
Devart.Data |


%%ItemTitle%%

Devart.Common Namespace (Devart.Data)
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbCommandBase | Represents a SQL statement or stored procedure to execute against a data source.
Class | DbCommandBuilder | Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.
Class | DbCommandBuilderBase | Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.
Class | DbConnectionStringBuilder | Generates automatically connection strings used to connect to a data source.
Class | DbDataAdapter | Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update a data source.
Class | DbDataReaderBase | Allows to read a forward-only stream of rows from a data source.
Class | DbDataSet | Represents an in-memory cache of data with connected model support.
Class | DbDataSourceEnumerator | Retrieves list of available servers in the network.
Class | DbDataTable | The DbDataTable class represents a single object that provides all of the functionality needed to retrieve and manipulate data from a data source. The DbDataTable class is built using existing ADO.NET components.
Class | DbDump | Serves to store a database or its parts as a script and also to restore database from the received script.
Class | DbLoader | Serves to load external data into the data source.
Class | DbLoaderColumn | Represents the attributes for column loading.
Class | DbLoaderColumnCollection | Represents a collection of columns relevant to a DbLoader.
Class | DbMonitor | Allows to monitor dynamic SQL execution in applications that use .NET data providers.
Class | DbParameterBase | Represents a parameter to a DbCommandBase, and optionally, its mapping to System.Data.DataSet columns.
Class | DbParameterBaseCollection | Collects all parameters relevant to a DbCommandBase as well as their respective mappings to System.Data.DataSet columns.
Class | DbProviderException | The base class for all exceptions thrown on data provider side. This does not include data source exceptions.
Class | DbScript | Serves to execute series of SQL statements separated by special symbols.
Class | DbTransactionBase | Base class for the dotConnect for Oracle transaction class Devart.Data.Oracle.OracleTransaction
Class | MonitorEventArgs | Provides data for the DbMonitor.TraceEvent event of the DbMonitor class.
Class | ParentDataRelation | Establishes query-based master-detail relation.
Class | QueryRecordCountException | Describes an error that is raised during record count request process.
Class | ScriptErrorEventArgs | Provides data for the DbScript.Error event of the DbScript class.
Class | ScriptProgressEventArgs | Provides data for the DbScript.Progress event of the DbScript class.
Class | SqlStatement | Represents a single statement in a script.
Class | SqlStatementCollection | Represents collection of statements that constitute Oracle script.
Class | TransactionStateChangedEventArgs | Provides data for the DbTransactionBase.StateChanged event of the DbTransactionBase class.
Class | TransactionStateChangeEventArgs | Base class for TransactionStateChangedEventArgs and TransactionStateChangingEventArgs classes.
Class | TransactionStateChangingEventArgs | Provides data for the DbTransactionBase.StateChanging event of the DbTransactionBase class.

Delegates

 | Delegate | Description
Delegate | MonitorEventHandler | Represents the method that will handle the DbMonitor.TraceEvent event of the DbMonitor class.
Delegate | ScriptErrorEventHandler | Represents the method that will handle the DbScript.Error event of the DbScript.
Delegate | ScriptProgressEventHandler | Represents the method that will handle the DbScript.Progress event of the DbScript.
Delegate | TransactionStateChangedEventHandler | Represents the method that will handle the DbTransactionBase.StateChanged event of DbTransactionBase descendants.
Delegate | TransactionStateChangingEventHandler | Represents the method that will handle the DbTransactionBase.StateChanging event of DbTransactionBase descendants.

Enumerations

 | Enumeration | Description
Enumeration | DumpMode | Specifies what kind of information should be exported by T:Devart.Data.Oracle.OracleDump.
Enumeration | MonitorEventType | Describes type of the current DbMonitor event.
Enumeration | MonitorTracePoint | Determines when DbMonitor.TraceEvent event occurs.
Enumeration | RefreshRowMode | Describes autorefresh actions that can be taken by DbCommandBuilder and DbDataTable.
Enumeration | SqlStatementType | Describes type of a statement in a script.
Enumeration | TransactionAction | Indicates the operation, that is being performed or has been performed in the transaction in the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging events.

See Also

Reference

Devart.Data Assembly


%%ItemTitle%% - Classes

Devart.Common Namespace (Devart.Data) - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbCommandBase | Represents a SQL statement or stored procedure to execute against a data source.
Class | DbCommandBuilder | Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.
Class | DbCommandBuilderBase | Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.
Class | DbConnectionStringBuilder | Generates automatically connection strings used to connect to a data source.
Class | DbDataAdapter | Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update a data source.
Class | DbDataReaderBase | Allows to read a forward-only stream of rows from a data source.
Class | DbDataSet | Represents an in-memory cache of data with connected model support.
Class | DbDataSourceEnumerator | Retrieves list of available servers in the network.
Class | DbDataTable | The DbDataTable class represents a single object that provides all of the functionality needed to retrieve and manipulate data from a data source. The DbDataTable class is built using existing ADO.NET components.
Class | DbDump | Serves to store a database or its parts as a script and also to restore database from the received script.
Class | DbLoader | Serves to load external data into the data source.
Class | DbLoaderColumn | Represents the attributes for column loading.
Class | DbLoaderColumnCollection | Represents a collection of columns relevant to a DbLoader.
Class | DbMonitor | Allows to monitor dynamic SQL execution in applications that use .NET data providers.
Class | DbParameterBase | Represents a parameter to a DbCommandBase, and optionally, its mapping to System.Data.DataSet columns.
Class | DbParameterBaseCollection | Collects all parameters relevant to a DbCommandBase as well as their respective mappings to System.Data.DataSet columns.
Class | DbProviderException | The base class for all exceptions thrown on data provider side. This does not include data source exceptions.
Class | DbScript | Serves to execute series of SQL statements separated by special symbols.
Class | DbTransactionBase | Base class for the dotConnect for Oracle transaction class Devart.Data.Oracle.OracleTransaction
Class | MonitorEventArgs | Provides data for the DbMonitor.TraceEvent event of the DbMonitor class.
Class | ParentDataRelation | Establishes query-based master-detail relation.
Class | QueryRecordCountException | Describes an error that is raised during record count request process.
Class | ScriptErrorEventArgs | Provides data for the DbScript.Error event of the DbScript class.
Class | ScriptProgressEventArgs | Provides data for the DbScript.Progress event of the DbScript class.
Class | SqlStatement | Represents a single statement in a script.
Class | SqlStatementCollection | Represents collection of statements that constitute Oracle script.
Class | TransactionStateChangedEventArgs | Provides data for the DbTransactionBase.StateChanged event of the DbTransactionBase class.
Class | TransactionStateChangeEventArgs | Base class for TransactionStateChangedEventArgs and TransactionStateChangingEventArgs classes.
Class | TransactionStateChangingEventArgs | Provides data for the DbTransactionBase.StateChanging event of the DbTransactionBase class.

See Also

Reference

Devart.Data Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbCommandBase Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbCommandBase Class

Represents a SQL statement or stored procedure to execute against a data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbCommand
Devart.Common.DbCommandBase
Devart.Data.Oracle.OracleCommand

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbCommandBase
   Inherits System.Data.Common.DbCommand
   Implements IComponent, IDbCommand, IDisposable
C#
public abstract class DbCommandBase : System.Data.Common.DbCommand, IComponent, IDbCommand, IDisposable

Remarks

Abstract DbCommandBase class implements some of DbCommandBase functionality that is data source-independent.

Example

The following sample demonstrates how using base classes helps to create data source-independent code.
C#csharp Copy Code
public void PrintDept(DbConnectionBase myConnection) {
        DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
        myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
        myConnection.Open();
        DbDataReader myReader = myCommand.ExecuteReader();
        try {
                while (myReader.Read()) {
                        Console.WriteLine(myReader.GetInt32(0).ToString() + " " +
                                myReader.GetString(1) + " " + myReader.GetString(2));
                }
        }
        finally {
                myReader.Close();
                myConnection.Close();
        }
}
C#Visual Basic Copy Code
Public Sub PrintDept(ByVal myConnection As DbConnectionBase)
        Dim myCommand As DbCommandBase = myConnection.CreateCommand()
        myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
        myConnection.Open()
        Dim myReader As DbDataReader = myCommand.ExecuteReader()
        Try
                While myReader.Read()
                        Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", _
                                myReader.GetString(1), " ", myReader.GetString(2)))
                End While
        Finally
                myReader.Close()
                myConnection.Close()
        End Try
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbCommandBase Members
Devart.Common Namespace
DbCommandBase Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbCommandBase Class Members
See Also Fields Properties Methods Events support@devart.com
Devart.Common Namespace : DbCommandBase Class

The following tables list the members exposed by DbCommandBase.

Public Fields

 | Name | Description
public Field | DefaultCommandTimeout | Gets or sets the default timeout for all commands.
Top

Public Properties

 | Name | Description
public Property | CommandText | Overridden. Gets or sets the SQL statement to execute against a data source.
public Property | CommandTimeout | Overridden. Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.
public Property | CommandType | Overridden. Gets or sets a value indicating how the CommandText property is to be interpreted.
public Property | Connection | Gets or sets the System.Data.Common.DbConnection used by this System.Data.Common.DbCommand. (Inherited from System.Data.Common.DbCommand)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Owner | Gets or sets a form or other container that the DbCommandBase instance belongs to.
public Property | ParameterCheck | Gets or sets a value indicating whether the command object regenerates parameter objects if text of the command is changed.
public Property | Parameters | Gets the collection of System.Data.Common.DbParameter objects. For more information on parameters, see Configuring Parameters and Parameter Data Types. (Inherited from System.Data.Common.DbCommand)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Transaction | Gets or sets the System.Data.Common.DbTransaction within which this System.Data.Common.DbCommand object executes. (Inherited from System.Data.Common.DbCommand)
public Property | UpdatedRowSource | Overridden. Gets or sets how command results are applied to the System.Data.DataRow when used by the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method of the System.Data.Common.DbDataAdapter.
Top

Public Methods

 | Name | Description
public Method | BeginExecuteNonQuery | Overloaded. Starts an asynchronous invocation of an ExecuteNonQuery method.
public Method | BeginExecuteReader | Overloaded. Starts an asynchronous invocation of an ExecuteReader method.
public Method | Cancel | Overridden. Attempts to cancel the execution of a query currently running.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateParameter | Creates a new instance of a System.Data.Common.DbParameter object. (Inherited from System.Data.Common.DbCommand)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndExecuteNonQuery | Ends an asynchronous invocation of the ExecuteNonQuery method.
public Method | EndExecuteReader | Ends an asynchronous invocation of the System.Data.Common.DbCommandBase.ExecuteReader method.
public Method | ExecuteNonQuery | Overridden. Executes SQL statement against the Connection and returns the number of rows affected.
public Method | ExecutePageReader | Returns a specific subset of rows when paging through the results of a query.
public Method | ExecuteReader | Overloaded. Executes the System.Data.Common.DbCommand.CommandText against the System.Data.Common.DbCommand.Connection, and returns an System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DbCommand)
public Method | ExecuteScalar | Overridden. Executes the query, and returns the first column of the first row in the result set returned by the query. Extra columns or rows are ignored.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRecordCount | Returns count of records in the resultset.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Prepare | Overridden. Creates a prepared (or compiled) version of the command on the server.
public Method | ResetCommandTimeout | Resets CommandTimeout to its default value, which is taken from DefaultCommandTimeout.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbCommandBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbCommandBase Class

For a list of all members of this type, see DbCommandBase members.

Public Methods

 | Name | Description
public Method | BeginExecuteNonQuery | Overloaded. Starts an asynchronous invocation of an ExecuteNonQuery method.
public Method | BeginExecuteReader | Overloaded. Starts an asynchronous invocation of an ExecuteReader method.
public Method | Cancel | Overridden. Attempts to cancel the execution of a query currently running.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateParameter | Creates a new instance of a System.Data.Common.DbParameter object. (Inherited from System.Data.Common.DbCommand)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndExecuteNonQuery | Ends an asynchronous invocation of the ExecuteNonQuery method.
public Method | EndExecuteReader | Ends an asynchronous invocation of the System.Data.Common.DbCommandBase.ExecuteReader method.
public Method | ExecuteNonQuery | Overridden. Executes SQL statement against the Connection and returns the number of rows affected.
public Method | ExecutePageReader | Returns a specific subset of rows when paging through the results of a query.
public Method | ExecuteReader | Overloaded. Executes the System.Data.Common.DbCommand.CommandText against the System.Data.Common.DbCommand.Connection, and returns an System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DbCommand)
public Method | ExecuteScalar | Overridden. Executes the query, and returns the first column of the first row in the result set returned by the query. Extra columns or rows are ignored.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRecordCount | Returns count of records in the resultset.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Prepare | Overridden. Creates a prepared (or compiled) version of the command on the server.
public Method | ResetCommandTimeout | Resets CommandTimeout to its default value, which is taken from DefaultCommandTimeout.
Top

See Also

Reference

DbCommandBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteNonQuery Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : BeginExecuteNonQuery Method

Starts an asynchronous invocation of an ExecuteNonQuery method.

Overload List

Overload | Description
BeginExecuteNonQuery() | Starts an asynchronous invocation of an ExecuteNonQuery method.
BeginExecuteNonQuery(AsyncCallback,Object) | Starts an asynchronous invocation of an ExecuteNonQuery method with information for callback function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteNonQuery() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteNonQuery Method : BeginExecuteNonQuery() Method

Starts an asynchronous invocation of an ExecuteNonQuery method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteNonQuery() As IAsyncResult
C#
public IAsyncResult BeginExecuteNonQuery()

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

This method is a simplified overload of the BeginExecuteNonQuery(AsyncCallback,Object) method.

Refer to "Asynchronous Query Execution" article for detailed information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteNonQuery(AsyncCallback,Object) Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteNonQuery Method : BeginExecuteNonQuery(AsyncCallback,Object) Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of an ExecuteNonQuery method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteNonQuery( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginExecuteNonQuery(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginExecuteNonQuery method enables you to execute a query on a server without having current thread blocked. In other words, your program can continue execution while the query runs on Oracle so you do not have to wait for it.

To start running a query, you have to call BeginExecuteNonQuery method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to System.IAsyncResult object. After executing this method program flow continues.

When you are ready to accept query results, call EndExecuteNonQuery. If at the moment you call this function the query execution has not yet been finished, application stops and waits till the function returns number of rows affected by the query.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

In the example below an easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a query execution is started. The operation state (done or in progress) is checked and a report is written to the console. At last query result is rendered.
C#csharp Copy Code
static void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')";
  Console.WriteLine("Starting asynchronous query execution...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteNonQuery(null, null);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  try
  {
    int RowsAffected = myCommand.EndExecuteNonQuery(cres);
    Console.WriteLine("Done. Rows affected: " + RowsAffected.ToString());
  }
  catch (Exception e)
  {
    Console.WriteLine("An exception has occurred: " + e.Message);
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')"
  Console.WriteLine("Starting asynchronous query execution...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteNonQuery(Nothing, Nothing)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Try
    Dim RowsAffected As Integer = myCommand.EndExecuteNonQuery(cres)
    Console.WriteLine(String.Concat("Rows affected: ", RowsAffected.ToString()))
  Catch e As Exception
    Console.WriteLine(String.Concat("An exception has occurred: ", e.Message))
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteReader Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : BeginExecuteReader Method

Starts an asynchronous invocation of an ExecuteReader method.

Overload List

Overload | Description
BeginExecuteReader() | Starts an asynchronous invocation of an ExecuteReader method.
BeginExecuteReader(CommandBehavior) | Starts an asynchronous invocation of an ExecuteReader method.
BeginExecuteReader(AsyncCallback,Object) | Starts an asynchronous invocation of an ExecuteReader method with information for callback function.
BeginExecuteReader(AsyncCallback,Object,CommandBehavior) | Starts an asynchronous invocation of an ExecuteReader method with information for callback function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteReader() Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteReader Method : BeginExecuteReader() Method

Starts an asynchronous invocation of an ExecuteReader method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteReader() As IAsyncResult
C#
public IAsyncResult BeginExecuteReader()

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginExecuteReader method enables you to execute a query on a server without having current thread blocked. In other words, your program can continue execution while the query runs on Oracle so you do not have to wait for it.

Refer to "Asynchronous Query Execution" article for detailed information.

To start running a query, you have to call BeginExecuteReader method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to accept query results, call EndExecuteReader. If at the moment you call this function the query execution has not yet been finished, application stops and waits till the function returns. Then you can treat a DbDataReaderBase in a common way.

Example

In the example below the easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to DbDataReaderBase and rendered to the console.
C#csharp Copy Code
public void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader();
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  DbDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader()
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As DbDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteReader(CommandBehavior) Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteReader Method : BeginExecuteReader(CommandBehavior) Method

behavior
One of the System.Data.CommandBehavior values.
Starts an asynchronous invocation of an ExecuteReader method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteReader( _
   ByVal behavior As CommandBehavior _
) As IAsyncResult
C#
public IAsyncResult BeginExecuteReader(
   CommandBehavior behavior
)

Parameters

behavior
One of the System.Data.CommandBehavior values.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginExecuteReader method enables you to execute a query on a server without having current thread blocked. In other words, your program can continue execution while the query runs on Oracle so you do not have to wait for it.

Refer to "Asynchronous Query Execution" article for detailed information.

To start running a query, you have to call BeginExecuteReader method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to accept query results, call EndExecuteReader. If at the moment you call this function the query execution has not yet been finished, application stops and waits till the function returns. Then you can treat a DbDataReaderBase in a common way.

Example

In the example below the easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to DbDataReaderBase and rendered to the console.
C#csharp Copy Code
public void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader(CommandBehavior.Default);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  DbDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader(CommandBehavior.Default)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As DbDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteReader(AsyncCallback,Object) Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteReader Method : BeginExecuteReader(AsyncCallback,Object) Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of an ExecuteReader method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteReader( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginExecuteReader(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginExecuteReader method enables you to execute a query on a server without having current thread blocked. In other words, your program can continue execution while the query runs on Oracle so you do not have to wait for it.

Refer to "Asynchronous Query Execution" article for detailed information.

To start running a query, you have to call BeginExecuteReader method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to accept query results, call EndExecuteReader. If at the moment you call this function the query execution has not yet been finished, application stops and waits till the function returns. Then you can treat a DbDataReaderBase in a common way.

Example

In the example below the easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to DbDataReaderBase and rendered to the console.
C#csharp Copy Code
public void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader(null, null);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  DbDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader(Nothing, Nothing)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As DbDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginExecuteReader(AsyncCallback,Object,CommandBehavior) Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class > BeginExecuteReader Method : BeginExecuteReader(AsyncCallback,Object,CommandBehavior) Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
behavior
One of the System.Data.CommandBehavior values.
Starts an asynchronous invocation of an ExecuteReader method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginExecuteReader( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object, _
   ByVal behavior As CommandBehavior _
) As IAsyncResult
C#
public IAsyncResult BeginExecuteReader(
   AsyncCallback callback,
   object stateObject,
   CommandBehavior behavior
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
behavior
One of the System.Data.CommandBehavior values.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginExecuteReader method enables you to execute a query on a server without having current thread blocked. In other words, your program can continue execution while the query runs on Oracle so you do not have to wait for it.

Refer to "Asynchronous Query Execution" article for detailed information.

To start running a query, you have to call BeginExecuteReader method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to accept query results, call EndExecuteReader. If at the moment you call this function the query execution has not yet been finished, application stops and waits till the function returns. Then you can treat a DbDataReaderBase in a common way.

Example

In the example below the easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to DbDataReaderBase and rendered to the console.
C#csharp Copy Code
public void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader(null, null, CommandBehavior.Default);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  DbDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader(Nothing, Nothing, CommandBehavior.Default)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As DbDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cancel Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : Cancel Method

Attempts to cancel the execution of a query currently running.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Cancel()
C#
public override void Cancel()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndExecuteNonQuery Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class : EndExecuteNonQuery Method

result
The System.IAsyncResult returned by BeginExecuteNonQuery.
Ends an asynchronous invocation of the ExecuteNonQuery method.

Syntax

Visual Basic (Declaration)
Public Function EndExecuteNonQuery( _
   ByVal result As IAsyncResult _
) As Integer
C#
public int EndExecuteNonQuery(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned by BeginExecuteNonQuery.

Return Value

For UPDATE, INSERT, and DELETE statements, the return value is the number of rows affected by the command. For all other types of statements, the return value is -1.

Remarks

The function ends an asynchronous execution of a query that is started with BeginExecuteNonQuery. A pair of asynchronous functions (BeginExecuteNonQuery and EndExecuteNonQuery) can be used instead of the synchronous function ExecuteNonQuery to gain more performance and flexibility in your application.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

In the example below an easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a query execution is started. The operation state (done or in progress) is checked and a report is written to the console. At last query result is rendered.
C#csharp Copy Code
static void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')";
  Console.WriteLine("Starting asynchronous query execution...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteNonQuery(null, null);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  try
  {
    int RowsAffected = myCommand.EndExecuteNonQuery(cres);
    Console.WriteLine("Done. Rows affected: " + RowsAffected.ToString());
  }
  catch (Exception e)
  {
    Console.WriteLine("An exception has occurred: " + e.Message);
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')"
  Console.WriteLine("Starting asynchronous query execution...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteNonQuery(Nothing, Nothing)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Try
    Dim RowsAffected As Integer = myCommand.EndExecuteNonQuery(cres)
    Console.WriteLine(String.Concat("Rows affected: ", RowsAffected.ToString()))
  Catch e As Exception
    Console.WriteLine(String.Concat("An exception has occurred: ", e.Message))
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndExecuteReader Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class : EndExecuteReader Method

result
The System.IAsyncResult returned by BeginExecuteReader.
Ends an asynchronous invocation of the System.Data.Common.DbCommandBase.ExecuteReader method.

Syntax

Visual Basic (Declaration)
Public Function EndExecuteReader( _
   ByVal result As IAsyncResult _
) As DbDataReader
C#
public DbDataReader EndExecuteReader(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned by BeginExecuteReader.

Return Value

A DbDataReaderBase object.

Remarks

The function ends an asynchronous execution of a query that is started with BeginExecuteReader. A pair of asynchronous functions (BeginExecuteReader and EndExecuteReader) can be used instead of the synchronous function ExecuteReader to gain more performance and flexibility in your application.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

In the example below an easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to DbDataReaderBase and rendered to the console.
C#csharp Copy Code
public void Async_Exec(DbConnectionBase myConnection)
{
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader(null, null, CommandBehavior.Default);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  DbDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As DbConnectionBase)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader(Nothing, Nothing, CommandBehavior.Default)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As DbDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNonQuery Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : ExecuteNonQuery Method

Executes SQL statement against the Connection and returns the number of rows affected.

Syntax

Visual Basic (Declaration)
Public Overrides Function ExecuteNonQuery() As Integer
C#
public override int ExecuteNonQuery()

Return Value

For UPDATE, INSERT, and DELETE statements, the return value is the number of rows affected by the command. For all other types of statements, the return value is -1.

Remarks

You can use ExecuteNonQuery method to perform catalog operations (for example, querying the structure of a database or creating database objects such as tables); or to change the data in a data source, without using a DataSet, by executing UPDATE, INSERT, or DELETE statements.

Although ExecuteNonQuery does not return any rows, any output parameters or return values mapped to parameters are populated with data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecutePageReader Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class : ExecutePageReader Method

behavior
One of the System.Data.CommandBehavior values.
startRecord
Zero-based ordinal of row that result set starts with.
maxRecords
Quantity of rows in result set.
Returns a specific subset of rows when paging through the results of a query.

Syntax

Visual Basic (Declaration)
Public Function ExecutePageReader( _
   ByVal behavior As CommandBehavior, _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer _
) As DbDataReader
C#
public DbDataReader ExecutePageReader(
   CommandBehavior behavior,
   int startRecord,
   int maxRecords
)

Parameters

behavior
One of the System.Data.CommandBehavior values.
startRecord
Zero-based ordinal of row that result set starts with.
maxRecords
Quantity of rows in result set.

Return Value

A DbDataReaderBase object.

Remarks

Use method ExecutePageReader when you want to retrieve not the whole dataset but some part of it that begins with given row number and has certain quantity of rows. This is especially useful when working with large amounts of data.

If you want to retrieve all data in a dataset, use ExecuteReader() instead.

Example

The example below shows how to retrieve a part of a table. If this function is called with parameters startRecord=2 and maxRecords=3, it returns 3 rows: second, third, and fourth.
C#csharp Copy Code
public void ExecutePaged(OracleConnection myConnection, int StartRow, int PageLength)
{
  OracleCommand myCommand = new OracleCommand("SELECT DeptNo, DName, Loc FROM Test.Dept", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecutePageReader(System.Data.CommandBehavior.Default,StartRow,PageLength);
  try
  {
    while (myReader.Read())
    {
        Console.WriteLine(myReader.GetInt32(0).ToString() + ", " + myReader.GetString(1) + ", " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub ExecutePaged(ByVal myConnection As OracleConnection, ByVal StartRow As Integer, ByVal PageLength As Integer)
  Dim myCommand As New OracleCommand("SELECT DeptNo, DName, Loc FROM Test.Dept", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecutePageReader(System.Data.CommandBehavior.Default, StartRow, PageLength)
  Try
    While myReader.Read()
      Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
      + myReader.GetString(1) + ", " _
      + myReader.GetString(2))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteScalar Method
See Also Example support@devart.com
Devart.Common Namespace > DbCommandBase Class : ExecuteScalar Method

Executes the query, and returns the first column of the first row in the result set returned by the query. Extra columns or rows are ignored.

Syntax

Visual Basic (Declaration)
Public Overrides Function ExecuteScalar() As Object
C#
public override object ExecuteScalar()

Return Value

The first column of the first row in the result set.

Remarks

Use the ExecuteScalar method to retrieve a single value (for example, an aggregate value) from a data source. This requires less code than using the ExecuteReader method, and then performing the operations necessary to generate the single value from the data returned by a DbDataReaderBase.

Example

This example shows typical usage of ExecuteScalar method
C#csharp Copy Code
using(OracleConnection conn = new OracleConnection(connectionString)) {
  conn.Open();
  OracleCommand cmd = conn.CreateCommand();
  cmd.CommandText = "SELECT count(*) as NumberOfRegions FROM regions";
  Int64 count = Convert.ToInt64(cmd.ExecuteScalar());
}
C#Visual Basic Copy Code
Dim conn As New OracleConnection(connectionString)
conn.Open()
Dim cmd As OracleCommand = conn.CreateCommand()
cmd.CommandText = "SELECT count(*) as NumberOfRegions FROM regions"
Dim count As Int64 = Convert.ToInt64(cmd.ExecuteScalar());
conn.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRecordCount Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : GetRecordCount Method

Returns count of records in the resultset.

Syntax

Visual Basic (Declaration)
Public Function GetRecordCount() As Integer
C#
public int GetRecordCount()

Return Value

The count of records.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Prepare Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : Prepare Method

Creates a prepared (or compiled) version of the command on the server.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Prepare()
C#
public override void Prepare()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ResetCommandTimeout Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : ResetCommandTimeout Method

Resets CommandTimeout to its default value, which is taken from DefaultCommandTimeout.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetCommandTimeout()
C#
public virtual void ResetCommandTimeout()

Remarks

Available in Direct mode only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbCommandBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbCommandBase Class

For a list of all members of this type, see DbCommandBase members.

Public Properties

 | Name | Description
public Property | CommandText | Overridden. Gets or sets the SQL statement to execute against a data source.
public Property | CommandTimeout | Overridden. Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.
public Property | CommandType | Overridden. Gets or sets a value indicating how the CommandText property is to be interpreted.
public Property | Connection | Gets or sets the System.Data.Common.DbConnection used by this System.Data.Common.DbCommand. (Inherited from System.Data.Common.DbCommand)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Owner | Gets or sets a form or other container that the DbCommandBase instance belongs to.
public Property | ParameterCheck | Gets or sets a value indicating whether the command object regenerates parameter objects if text of the command is changed.
public Property | Parameters | Gets the collection of System.Data.Common.DbParameter objects. For more information on parameters, see Configuring Parameters and Parameter Data Types. (Inherited from System.Data.Common.DbCommand)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Transaction | Gets or sets the System.Data.Common.DbTransaction within which this System.Data.Common.DbCommand object executes. (Inherited from System.Data.Common.DbCommand)
public Property | UpdatedRowSource | Overridden. Gets or sets how command results are applied to the System.Data.DataRow when used by the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method of the System.Data.Common.DbDataAdapter.
Top

See Also

Reference

DbCommandBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandText Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : CommandText Property

Gets or sets the SQL statement to execute against a data source.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandText As String
C#
public override string CommandText {get; set;}

Property Value

The SQL statement or stored procedure to execute. The default value is an empty string ("").

Remarks

Sense of CommandText property depends on value of CommandType property.

When CommandType value is System.Data.CommandType.Text, property CommandText should contain text of a query that must be run on the server.

When the value is System.Data.CommandType.StoredProcedure, property CommandText must be a name of a procedure to execute.

When the value is set to System.Data.CommandType.TableDirect, CommandText must be name of a table you want to get all data from. All rows and columns are retrieved.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandTimeout Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : CommandTimeout Property

Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandTimeout As Integer
C#
public override int CommandTimeout {get; set;}

Property Value

The time (in seconds) to wait for the command to execute. The default value is 30 seconds.

Remarks

A value of zero (0) specifies no limit to the wait time, rather than no wait time, and therefore should be avoided.

The value of the CommandTimeout property is used in Direct mode. The OCI mode doesn't take into account the cmd.CommandTimeout, and the duration of command timeout is determined by Oracle client settings.

Available in Direct mode only. Not available under .NET Compact Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandType Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : CommandType Property

Gets or sets a value indicating how the CommandText property is to be interpreted.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandType As CommandType
C#
public override CommandType CommandType {get; set;}

Property Value

One of the System.Data.CommandType values. The default value is System.Data.CommandType.Text.

Remarks

CommandType can be one of the following values: Text, StoredProcedure, TableDirect.

When the value is System.Data.CommandType.Text, property CommandText should contain text of a query that must be run on the server.

When the value is System.Data.CommandType.StoredProcedure, CommandText property must be a name of a procedure to execute.

When the value is set to System.Data.CommandType.TableDirect, CommandText must be name of a table you want to get all data from. All rows and columns are retrieved.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : Owner Property

Gets or sets a form or other container that the DbCommandBase instance belongs to.

Syntax

Visual Basic (Declaration)
Public Property Owner As Object
C#
public object Owner {get; set;}

Property Value

A form or other container that the object belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParameterCheck Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : ParameterCheck Property

Gets or sets a value indicating whether the command object regenerates parameter objects if text of the command is changed.

Syntax

Visual Basic (Declaration)
Public Property ParameterCheck As Boolean
C#
public bool ParameterCheck {get; set;}

Property Value

Value indicating whether the command object regenerates parameter objects if text of the command is changed. The default value is false.

Remarks

If true, the Parameters collection is automatically regenerated to reflect all parameters contained in command text. In other words, quantity of parameters in the collection always equals to quantity of parameters in the query string. If due to text changes the quantity of parameters is increased, then old parameters will retain their values while all new parameters will be empty. For detailed explanation on behavior of ParameterCheck property please read article Using Parameters in dotConnect.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatedRowSource Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : UpdatedRowSource Property

Gets or sets how command results are applied to the System.Data.DataRow when used by the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method of the System.Data.Common.DbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overrides Property UpdatedRowSource As UpdateRowSource
C#
public override UpdateRowSource UpdatedRowSource {get; set;}

Property Value

One of the System.Data.UpdateRowSource values.

Remarks

The default System.Data.UpdateRowSource value is Both unless the command is automatically generated (i.e. by DbCommandBuilder), in which case the default is None.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
DbCommandBase Class Fields
See Also support@devart.com
Devart.Common Namespace : DbCommandBase Class

For a list of all members of this type, see DbCommandBase members.

Public Fields

 | Name | Description
public Field | DefaultCommandTimeout | Gets or sets the default timeout for all commands.
Top

See Also

Reference

DbCommandBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DefaultCommandTimeout Field
See Also support@devart.com
Devart.Common Namespace > DbCommandBase Class : DefaultCommandTimeout Field

Gets or sets the default timeout for all commands.

Syntax

Visual Basic (Declaration)
Public Const DefaultCommandTimeout As Integer
C#
public const int DefaultCommandTimeout

Field Value

The default timeout for all commands.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBase Class
DbCommandBase Members
CommandTimeout Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbCommandBuilder Class
Members See Also support@devart.com
Devart.Common Namespace : DbCommandBuilder Class

Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbCommandBuilder
Devart.Common.DbCommandBuilderBase
Devart.Common.DbCommandBuilder
Devart.Data.Oracle.OracleCommandBuilder

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbCommandBuilder
   Inherits DbCommandBuilderBase
   Implements IComponent, IDisposable
C#
public abstract class DbCommandBuilder : DbCommandBuilderBase, IComponent, IDisposable

Remarks

This is an abstract class implemented by Devart data providers.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbCommandBuilder Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilder Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbCommandBuilder Class

The following tables list the members exposed by DbCommandBuilder.

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | CatalogSeparator | Sets or gets a string used as the catalog separator for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a System.Data.Common.DbDataAdapter object for which Transact-SQL statements are automatically generated. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbCommandBuilderBase should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | SchemaSeparator | Gets or sets the character to be used for the separator between the schema identifier and any other identifiers. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingFields | Gets or sets the list of the fields, separated with ';' (semicolon), that should be updated with the update commands in the DbCommandBuilder. If the field is not included in the list, it will not be updated.
public Property | UpdatingTable | Gets or sets table name to generate update statements for. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated SQL statement required to perform deletions.
public Method | GetInsertCommand | Overloaded. Gets the automatically generated SQL statement required to perform inserts.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated SQL statement required to perform updates on the data source.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Overridden. Returns the string passed as the parameter enclosed in quotes.
public Method | RefreshSchema | Clears the commands associated with this System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | UnquoteIdentifier | Given a quoted identifier, returns the correct unquoted form of that identifier, including properly un-escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBuilder Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilder Class Methods
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilder Class

For a list of all members of this type, see DbCommandBuilder members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated SQL statement required to perform deletions.
public Method | GetInsertCommand | Overloaded. Gets the automatically generated SQL statement required to perform inserts.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated SQL statement required to perform updates on the data source.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Overridden. Returns the string passed as the parameter enclosed in quotes.
public Method | RefreshSchema | Clears the commands associated with this System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | UnquoteIdentifier | Given a quoted identifier, returns the correct unquoted form of that identifier, including properly un-escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
Top

See Also

Reference

DbCommandBuilder Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : GetDeleteCommand Method

Gets the automatically generated SQL statement required to perform deletions.

Overload List

Overload | Description
GetDeleteCommand() | Gets the automatically generated SQL statement required to perform deletions when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.
GetDeleteCommand(Boolean) | Gets the automatically generated SQL statement required to perform deletions when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetDeleteCommand Method : GetDeleteCommand() Method

Gets the automatically generated SQL statement required to perform deletions when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetDeleteCommand() As DbCommand
C#
public new DbCommand GetDeleteCommand()

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetDeleteCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetDeleteCommand() as the basis of a modified command. For example, you might call GetDeleteCommand() and modify the CommandTimeout value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetDeleteCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetDeleteCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand(Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetDeleteCommand Method : GetDeleteCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to perform deletions when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetDeleteCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public new DbCommand GetDeleteCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetDeleteCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetDeleteCommand() as the basis of a modified command. For example, you might call GetDeleteCommand() and modify the CommandTimeout value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetDeleteCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetDeleteCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : GetInsertCommand Method

Gets the automatically generated SQL statement required to perform inserts.

Overload List

Overload | Description
GetInsertCommand() | Gets the automatically generated SQL statement required to perform inserts when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.
GetInsertCommand(Boolean) | Gets the automatically generated SQL statement required to perform inserts when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.
GetInsertCommand(String[],Boolean) | Gets the automatically generated SQL statement required to perform inserts for the specified fields when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetInsertCommand Method : GetInsertCommand() Method

Gets the automatically generated SQL statement required to perform inserts when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetInsertCommand() As DbCommand
C#
public new DbCommand GetInsertCommand()

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetInsertCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetInsertCommand() as the basis of a modified command. For example, you might call GetInsertCommand() and modify the CommandTimeout value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetInsertCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand(Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetInsertCommand Method : GetInsertCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to perform inserts when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetInsertCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public new DbCommand GetInsertCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetInsertCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetInsertCommand() as the basis of a modified command. For example, you might call GetInsertCommand() and modify the CommandTimeout value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetInsertCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetInsertCommand Method : GetInsertCommand(String[],Boolean) Method

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to perform inserts for the specified fields when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInsertCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public DbCommand GetInsertCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

This overload of the method allows you to restrict list of columns that are included in the generated statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : GetRefreshCommand Method

Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.

Overload List

Overload | Description
GetRefreshCommand() | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(String[],Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand() Method

Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand() As DbCommand
C#
public new DbCommand GetRefreshCommand()

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public new DbCommand GetRefreshCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand(String[],Boolean) Method

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public new DbCommand GetRefreshCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : GetUpdateCommand Method

Gets the automatically generated SQL statement required to perform updates on the data source.

Overload List

Overload | Description
GetUpdateCommand() | Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.
GetUpdateCommand(Boolean) | Gets the automatically generated SQL statement required to perform updates when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.
GetUpdateCommand(String[],Boolean) | Gets the automatically generated SQL statement required to perform updates for the specified fields when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand() Method

Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetUpdateCommand() As DbCommand
C#
public new DbCommand GetUpdateCommand()

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetUpdateCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetUpdateCommand() as the basis of a modified command. For example, you might call GetUpdateCommand() and modify the CommandText value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetUpdateCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand(Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to perform updates when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetUpdateCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public new DbCommand GetUpdateCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

You can use the GetUpdateCommand() method for informational or troubleshooting purposes because it returns the DbCommandBase object to be executed.

You can also use GetUpdateCommand() as the basis of a modified command. For example, you might call GetUpdateCommand() and modify the CommandText value, and then explicitly set that on the DbDataAdapter.

After the SQL statement is first generated, you must explicitly call DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetUpdateCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand(String[],Boolean) Method

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to perform updates for the specified fields when an application calls System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) on the System.Data.IDbDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetUpdateCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As DbCommand
C#
public DbCommand GetUpdateCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Remarks

This overload of the method allows to restrict list of columns that are included in the generated statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QuoteIdentifier Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : QuoteIdentifier Method

unquotedIdentifier
Identifier to be placed inside the quotes.
Returns the string passed as the parameter enclosed in quotes.

Syntax

Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier( _
   ByVal unquotedIdentifier As String _
) As String
C#
public override string QuoteIdentifier(
   string unquotedIdentifier
)

Parameters

unquotedIdentifier
Identifier to be placed inside the quotes.

Return Value

The identifier enclosed in quotes.

Remarks

This method constructs a quoted identifier by concatenating QuotePrefix, unquotedIdentifier, and QuoteSuffix.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilder Class Properties
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilder Class

For a list of all members of this type, see DbCommandBuilder members.

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | CatalogSeparator | Sets or gets a string used as the catalog separator for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a System.Data.Common.DbDataAdapter object for which Transact-SQL statements are automatically generated. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbCommandBuilderBase should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | SchemaSeparator | Gets or sets the character to be used for the separator between the schema identifier and any other identifiers. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingFields | Gets or sets the list of the fields, separated with ';' (semicolon), that should be updated with the update commands in the DbCommandBuilder. If the field is not included in the list, it will not be updated.
public Property | UpdatingTable | Gets or sets table name to generate update statements for. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
Top

See Also

Reference

DbCommandBuilder Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingFields Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilder Class : UpdatingFields Property

Gets or sets the list of the fields, separated with ';' (semicolon), that should be updated with the update commands in the DbCommandBuilder. If the field is not included in the list, it will not be updated.

Syntax

Visual Basic (Declaration)
Public MustOverride Property UpdatingFields As String
C#
public abstract string UpdatingFields {get; set;}

Property Value

The list of the fields, separated with ';' (semicolon), that should be updated with the update commands in the DbCommandBuilder.

Remarks

If the property contains an empty string, all fields will be updated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilder Class
DbCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbCommandBuilderBase Class
Members See Also support@devart.com
Devart.Common Namespace : DbCommandBuilderBase Class

Allows to automatically generate single-table commands used to reconcile changes made to a System.Data.DataSet with the associated data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbCommandBuilder
Devart.Common.DbCommandBuilderBase
Devart.Common.DbCommandBuilder

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbCommandBuilderBase
   Inherits System.Data.Common.DbCommandBuilder
   Implements IComponent, IDisposable
C#
public abstract class DbCommandBuilderBase : System.Data.Common.DbCommandBuilder, IComponent, IDisposable

Remarks

This is an abstract class implemented by Devart data providers.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbCommandBuilderBase Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilderBase Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbCommandBuilderBase Class

The following tables list the members exposed by DbCommandBuilderBase.

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | CatalogSeparator | Sets or gets a string used as the catalog separator for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a System.Data.Common.DbDataAdapter object for which Transact-SQL statements are automatically generated. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects.
public Property | QuotePrefix | Gets or sets the beginning character or characters to use when specifying database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | QuoteSuffix | Gets or sets the ending character or characters to use when specifying database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbCommandBuilderBase should retrieve field values adjusted by server after an update.
public Property | SchemaSeparator | Gets or sets the character to be used for the separator between the schema identifier and any other identifiers. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names.
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform deletions at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | GetInsertCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform insertions at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform updates at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Given an unquoted identifier in the correct catalog case, returns the correct quoted form of that identifier, including properly escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | RefreshSchema | Overridden. Refreshes the data source schema information used to generate INSERT, UPDATE, or DELETE statements.
public Method | UnquoteIdentifier | Given a quoted identifier, returns the correct unquoted form of that identifier, including properly un-escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBuilderBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilderBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilderBase Class

For a list of all members of this type, see DbCommandBuilderBase members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform deletions at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | GetInsertCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform insertions at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated System.Data.Common.DbCommand object required to perform updates at the data source. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Given an unquoted identifier in the correct catalog case, returns the correct quoted form of that identifier, including properly escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | RefreshSchema | Overridden. Refreshes the data source schema information used to generate INSERT, UPDATE, or DELETE statements.
public Method | UnquoteIdentifier | Given a quoted identifier, returns the correct unquoted form of that identifier, including properly un-escaping any embedded quotes in the identifier. (Inherited from System.Data.Common.DbCommandBuilder)
Top

See Also

Reference

DbCommandBuilderBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : GetRefreshCommand Method

Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.

Overload List

Overload | Description
GetRefreshCommand() | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(String[],Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand() Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class > GetRefreshCommand Method : GetRefreshCommand() Method

Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRefreshCommand() As IDbCommand
C#
public IDbCommand GetRefreshCommand()

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class > GetRefreshCommand Method : GetRefreshCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRefreshCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As IDbCommand
C#
public IDbCommand GetRefreshCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class > GetRefreshCommand Method : GetRefreshCommand(String[],Boolean) Method

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRefreshCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As IDbCommand
C#
public IDbCommand GetRefreshCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A DbCommandBase with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshSchema Method
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : RefreshSchema Method

Refreshes the data source schema information used to generate INSERT, UPDATE, or DELETE statements.

Syntax

Visual Basic (Declaration)
Public Overrides Sub RefreshSchema()
C#
public override void RefreshSchema()

Remarks

You can call this method to ensure that changes made to the schema are up-to-date.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members
RefreshMode Property


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilderBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilderBase Class

For a list of all members of this type, see DbCommandBuilderBase members.

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | CatalogSeparator | Sets or gets a string used as the catalog separator for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a System.Data.Common.DbDataAdapter object for which Transact-SQL statements are automatically generated. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects.
public Property | QuotePrefix | Gets or sets the beginning character or characters to use when specifying database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | QuoteSuffix | Gets or sets the ending character or characters to use when specifying database objects (for example, tables or columns) whose names contain characters such as spaces or reserved tokens. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbCommandBuilderBase should retrieve field values adjusted by server after an update.
public Property | SchemaSeparator | Gets or sets the character to be used for the separator between the schema identifier and any other identifiers. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names.
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names.
Top

See Also

Reference

DbCommandBuilderBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
KeyFields Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : KeyFields Property

Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Property KeyFields As String
C#
public string KeyFields {get; set;}

Property Value

The string containing list of key field names separated by semicolon.

Remarks

This property is used when the ConflictOption property is set to OverwriteChanges, otherwise all columns will be used in the WHERE clause.

If KeyFields is nonempty, its value is used as list of columns for the WHERE clause. If KeyFields is empty, the primary key columns are used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Quoted Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : Quoted Property

Gets or sets whether the command builder quotes all the names of data source objects.

Syntax

Visual Basic (Declaration)
Public Overridable Property Quoted As Boolean
C#
public virtual bool Quoted {get; set;}

Property Value

true if the command builder will quote all the names of data source objects; otherwise, false. The default value is false.

Remarks

Names of data source objects can contain any characters, including spaces, commas, national or lowercase characters. To accommodate this, use the Quoted property that allows enclosing of all objects names by quotation mark in generated SQL statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshingFields Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : RefreshingFields Property

Gets or sets list of fields whose values should be retrieved after a DML statement execution.

Syntax

Visual Basic (Declaration)
Public Overridable Property RefreshingFields As String
C#
public virtual string RefreshingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Remarks

This property is used in conjunction with Devart.Common.DbCommandBuilderBase.RefreshMode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshMode Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : RefreshMode Property

Gets or sets a value that indicates whether and how the DbCommandBuilderBase should retrieve field values adjusted by server after an update.

Syntax

Visual Basic (Declaration)
Public Property RefreshMode As RefreshRowMode
C#
public RefreshRowMode RefreshMode {get; set;}

Property Value

One of the RefreshRowMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members
RefreshingFields Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingTable Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : UpdatingTable Property

Gets or sets table name to generate update statements for.

Syntax

Visual Basic (Declaration)
Public Property UpdatingTable As String
C#
public string UpdatingTable {get; set;}

Property Value

The name of the table.

Remarks

Use the UpdatingTable property to generate SQL statements for specific table in a complicated query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UseCatalog Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : UseCatalog Property

Specifies whether the catalog identifier is included in data source object names.

Syntax

Visual Basic (Declaration)
Public Overridable Property UseCatalog As Boolean
C#
public virtual bool UseCatalog {get; set;}

Property Value

true if the catalog identifier is included in data source object names; otherwise, false. The default value is true.

Remarks

If true, data source object names in the generated CUD statements will contain the catalog identifier.

Catalog is a second-level data container. This property is only reasonable for the databases that support more than one level of containerization with UseSchema being true.

For example, if this property is true, the generated INSERT statement will look like the following:

INSERT INTO mycatalog.myschema.mytable ...

And if this property is false, the generated INSERT statement will look like the following:

INSERT INTO myschema.mytable ...

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UseSchema Property
See Also support@devart.com
Devart.Common Namespace > DbCommandBuilderBase Class : UseSchema Property

Specifies whether the schema identifier is included in data source object names.

Syntax

Visual Basic (Declaration)
Public Overridable Property UseSchema As Boolean
C#
public virtual bool UseSchema {get; set;}

Property Value

true if the schema identifier is included in data source object names; otherwise, false. The default value is true.

Remarks

If true, data source object names in the generated CUD statements will contain the schema identifier.

For example, if this property is true, the generated INSERT statement will look like the following:

INSERT INTO myschema.mytable ...

And if this property is false, the generated INSERT statement will look like the following:

INSERT INTO mytable ...

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbCommandBuilderBase Class
DbCommandBuilderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbConnectionStringBuilder Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbConnectionStringBuilder Class

Generates automatically connection strings used to connect to a data source.

Inheritance Hierarchy

System.Object
System.Data.Common.DbConnectionStringBuilder
Devart.Common.DbConnectionStringBuilder
Devart.Data.Oracle.OracleConnectionStringBuilder

Syntax

Visual Basic (Declaration)
Public Class DbConnectionStringBuilder
   Inherits System.Data.Common.DbConnectionStringBuilder
   Implements ICollection, IDictionary, IEnumerable, ICustomTypeDescriptor
C#
public class DbConnectionStringBuilder : System.Data.Common.DbConnectionStringBuilder, ICollection, IDictionary, IEnumerable, ICustomTypeDescriptor

Remarks

The DbConnectionStringBuilder class provides the base class from which the strongly typed connection string builders (Devart.Data.Oracle.OracleConnectionStringBuilder) are derived. The connection string builders let developers programmatically create syntactically correct connection strings, and parse and rebuild existing connection strings. The DbConnectionStringBuilder has been defined in a data source-agnostic manner. Because of the addition of the Devart.Common namespace, developers require a base class against which they can program in order to build connection strings that can work against an arbitrary database. But it is possible using this class to create invalid connection strings. It is recommended to use the strongly typed connection string builders (Devart.Data.Oracle.OracleConnectionStringBuilder and so on) because they support only key/value pairs that are supported by particular data source; trying to add invalid pairs will throw an exception. For more information, refer to the description of the System.Data.Common.DbConnectionStringBuilder class in MSDN.

Example

C#csharp Copy Code
Devart.Common.DbConnectionStringBuilder csb = new Devart.Common.DbConnectionStringBuilder();
csb["Direct"] = true;
csb["Server"] = "192.168.0.1";
csb["Port"] = 1521;
csb["Sid"] = "OracleSid";
csb["User Id"] = "scott";
csb["Password"] = "tiger";
csb["Max Pool Size"] = 150;
csb["Connection Timeout"] = 30;
Devart.Data.Oracle.OracleConnection myConnection = new Devart.Data.Oracle.OracleConnection(csb.ConnectionString);
C#Visual Basic Copy Code
Dim csb As Devart.Common.DbConnectionStringBuilder = New Devart.Common.DbConnectionStringBuilder
csb("Direct") = true
csb("Server") = "192.168.0.1"
csb("Port") = 1521
csb("Sid") = "OracleSid"
csb("User Id") = "scott"
csb("Password") = "tiger"
csb("Max Pool Size") = 150
csb("Connection Timeout") = 30
Dim myConnection As Devart.Data.Oracle.OracleConnection = New Devart.Data.Oracle.OracleConnection(csb.ConnectionString)

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbConnectionStringBuilder Members
Devart.Common Namespace
OracleConnectionStringBuilder Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbConnectionStringBuilder Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbConnectionStringBuilder Class

The following tables list the members exposed by DbConnectionStringBuilder.

Public Constructors

 | Name | Description
public Constructor | DbConnectionStringBuilder Constructor | Initializes a new instance of the DbConnectionStringBuilder class.
Top

Public Properties

 | Name | Description
public Property | ConnectionString | Gets or sets the connection string associated with the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Count | Gets the current number of keys that are contained within the System.Data.Common.DbConnectionStringBuilder.ConnectionString property. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | InitializationCommand | Specifies a data source-specific command that should be executed immediately after establishing the connection.
public Property | IsFixedSize | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder has a fixed size. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | IsReadOnly | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder is read-only. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Item | Overridden. Gets or sets the value associated with the specified key.
public Property | Keys | Gets an System.Collections.ICollection that contains the keys in the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | RunOnceCommand | Specifies a data source-specific command that should be executed immediately after first establishing the connection. Unlike InitializationCommand, this command is not executed when a connection is taken from the pool.
public Property | Values | Gets an System.Collections.ICollection that contains the values in the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
Top

Public Methods

 | Name | Description
public Method | Add | Adds an entry with the specified key and value into the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | Clear | Clears the contents of the System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | ContainsKey | Determines whether the System.Data.Common.DbConnectionStringBuilder contains a specific key. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | EquivalentTo | Overloaded. Compares the specified connection information in this DbConnectionStringBuilder object with the specified connection information in the supplied DbConnectionStringBuilder object.
public Method | Remove | Removes the entry with the specified key from the System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | ShouldSerialize | Indicates whether the specified key exists in this System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | TryGetValue | Retrieves a value corresponding to the supplied key from this System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
Top

See Also

Reference

DbConnectionStringBuilder Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbConnectionStringBuilder Constructor
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class : DbConnectionStringBuilder Constructor

Initializes a new instance of the DbConnectionStringBuilder class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DbConnectionStringBuilder()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbConnectionStringBuilder Class Methods
See Also support@devart.com
Devart.Common Namespace : DbConnectionStringBuilder Class

For a list of all members of this type, see DbConnectionStringBuilder members.

Public Methods

 | Name | Description
public Method | Add | Adds an entry with the specified key and value into the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | Clear | Clears the contents of the System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | ContainsKey | Determines whether the System.Data.Common.DbConnectionStringBuilder contains a specific key. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | EquivalentTo | Overloaded. Compares the specified connection information in this DbConnectionStringBuilder object with the specified connection information in the supplied DbConnectionStringBuilder object.
public Method | Remove | Removes the entry with the specified key from the System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | ShouldSerialize | Indicates whether the specified key exists in this System.Data.Common.DbConnectionStringBuilder instance. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | TryGetValue | Retrieves a value corresponding to the supplied key from this System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
Top

See Also

Reference

DbConnectionStringBuilder Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EquivalentTo Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class : EquivalentTo Method

Compares the specified connection information in this DbConnectionStringBuilder object with the specified connection information in the supplied DbConnectionStringBuilder object.

Overload List

Overload | Description
EquivalentTo(DbConnectionStringBuilder,Boolean) | Compares the specified connection information in this DbConnectionStringBuilder object with the specified connection information in the supplied DbConnectionStringBuilder object.
EquivalentTo(DbConnectionStringBuilder) | Compares the connection information in this System.Data.Common.DbConnectionStringBuilder object with the connection information in the supplied object. (Inherited from System.Data.Common.DbConnectionStringBuilder)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EquivalentTo(DbConnectionStringBuilder,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class > EquivalentTo Method : EquivalentTo(DbConnectionStringBuilder,Boolean) Method

connectionStringBuilder
The DbConnectionStringBuilder to be compared with this DbConnectionStringBuilder object.
loginOnly

If this parameter is true, only the following DbConnectionStringBuilder properties are compared:

For Devart.Data.Oracle.OracleConnection.Direct connection:

  • Devart.Data.Oracle.OracleConnectionStringBuilder.UserId
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Server
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Port
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Sid

For client connection:

  • Devart.Data.Oracle.OracleConnectionStringBuilder.UserId
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Server
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Home
If this parameter is false, all the DbConnectionStringBuilder properties are compared.
Compares the specified connection information in this DbConnectionStringBuilder object with the specified connection information in the supplied DbConnectionStringBuilder object.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function EquivalentTo( _
   ByVal connectionStringBuilder As DbConnectionStringBuilder, _
   ByVal loginOnly As Boolean _
) As Boolean
C#
public virtual bool EquivalentTo(
   DbConnectionStringBuilder connectionStringBuilder,
   bool loginOnly
)

Parameters

connectionStringBuilder
The DbConnectionStringBuilder to be compared with this DbConnectionStringBuilder object.
loginOnly

If this parameter is true, only the following DbConnectionStringBuilder properties are compared:

For Devart.Data.Oracle.OracleConnection.Direct connection:

  • Devart.Data.Oracle.OracleConnectionStringBuilder.UserId
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Server
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Port
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Sid

For client connection:

  • Devart.Data.Oracle.OracleConnectionStringBuilder.UserId
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Server
  • Devart.Data.Oracle.OracleConnectionStringBuilder.Home
If this parameter is false, all the DbConnectionStringBuilder properties are compared.

Return Value

trueif the specified connection information in both of the DbConnectionStringBuilder objects is equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbConnectionStringBuilder Class Properties
See Also support@devart.com
Devart.Common Namespace : DbConnectionStringBuilder Class

For a list of all members of this type, see DbConnectionStringBuilder members.

Public Properties

 | Name | Description
public Property | ConnectionString | Gets or sets the connection string associated with the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Count | Gets the current number of keys that are contained within the System.Data.Common.DbConnectionStringBuilder.ConnectionString property. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | InitializationCommand | Specifies a data source-specific command that should be executed immediately after establishing the connection.
public Property | IsFixedSize | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder has a fixed size. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | IsReadOnly | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder is read-only. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Item | Overridden. Gets or sets the value associated with the specified key.
public Property | Keys | Gets an System.Collections.ICollection that contains the keys in the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | RunOnceCommand | Specifies a data source-specific command that should be executed immediately after first establishing the connection. Unlike InitializationCommand, this command is not executed when a connection is taken from the pool.
public Property | Values | Gets an System.Collections.ICollection that contains the values in the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
Top

See Also

Reference

DbConnectionStringBuilder Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InitializationCommand Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class : InitializationCommand Property

Specifies a data source-specific command that should be executed immediately after establishing the connection.

Syntax

Visual Basic (Declaration)
Public Property InitializationCommand As String
C#
public string InitializationCommand {get; set;}

Property Value

A data source-specific command that should be executed immediately after establishing the connection.

Remarks

If this command fails, the connection is not established. Devart.Data.Oracle.OracleConnection throws an exception with the error returned by Oracle. You can specify a sequense of several commands in this parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class : Item Property

keyword
The key of the item to get or set.
Gets or sets the value associated with the specified key.

Syntax

Visual Basic (Declaration)
Public Overrides Default Property Item( _
   ByVal keyword As String _
) As Object
C#
public override object this(
   string keyword
) {get; set;}

Parameters

keyword
The key of the item to get or set.

Property Value

Value associated with the specified key.

Remarks

If the specified key is not found, trying to get it returns null, and trying to set it creates a new element using the specified key. Assigning a null value removes the key/value pair.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RunOnceCommand Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionStringBuilder Class : RunOnceCommand Property

Specifies a data source-specific command that should be executed immediately after first establishing the connection. Unlike InitializationCommand, this command is not executed when a connection is taken from the pool.

Syntax

Visual Basic (Declaration)
Public Property RunOnceCommand As String
C#
public string RunOnceCommand {get; set;}

Property Value

A data source-specific command that should be executed immediately after establishing the connection.

Remarks

If this command fails, the connection is not established. Devart.Data.Oracle.OracleConnection throws an exception with the error returned by Oracle. You can specify a sequense of several commands in this parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionStringBuilder Class
DbConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDataAdapter Class
Members See Also support@devart.com
Devart.Common Namespace : DbDataAdapter Class

Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update a data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DataAdapter
System.Data.Common.DbDataAdapter
Devart.Common.DbDataAdapter
Devart.Data.Oracle.OracleDataAdapter

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDataAdapter
   Inherits System.Data.Common.DbDataAdapter
   Implements IComponent, IDataAdapter, IDbDataAdapter, ICloneable, IDisposable
C#
public abstract class DbDataAdapter : System.Data.Common.DbDataAdapter, IComponent, IDataAdapter, IDbDataAdapter, ICloneable, IDisposable

Remarks

This is an abstract class implemented by Devart data providers.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDataAdapter Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDataAdapter Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbDataAdapter Class

The following tables list the members exposed by DbDataAdapter.

Public Properties

 | Name | Description
public Property | AcceptChangesDuringFill | Gets or sets a value indicating whether System.Data.DataRow.AcceptChanges is called on a System.Data.DataRow after it is added to the System.Data.DataTable during any of the Fill operations. (Inherited from System.Data.Common.DataAdapter)
public Property | AcceptChangesDuringUpdate | Gets or sets whether System.Data.DataRow.AcceptChanges is called during a System.Data.Common.DataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.DataAdapter)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | ContinueUpdateOnError | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update. (Inherited from System.Data.Common.DataAdapter)
public Property | DeleteCommand | Gets or sets a command for deleting records from the data set. (Inherited from System.Data.Common.DbDataAdapter)
public Property | FillLoadOption | Gets or sets the System.Data.LoadOption that determines how the adapter fills the System.Data.DataTable from the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DataAdapter)
public Property | InsertCommand | Gets or sets a command used to insert new records into the data source. (Inherited from System.Data.Common.DbDataAdapter)
public Property | MissingMappingAction | Determines the action to take when incoming data does not have a matching table or column. (Inherited from System.Data.Common.DataAdapter)
public Property | MissingSchemaAction | Determines the action to take when existing System.Data.DataSet schema does not match incoming data. (Inherited from System.Data.Common.DataAdapter)
public Property | ReturnProviderSpecificTypes | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values. (Inherited from System.Data.Common.DataAdapter)
public Property | SelectCommand | Gets or sets a command used to select records in the data source. (Inherited from System.Data.Common.DbDataAdapter)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableMappings | Gets a collection that provides the master mapping between a source table and a System.Data.DataTable. (Inherited from System.Data.Common.DataAdapter)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch. (Inherited from System.Data.Common.DbDataAdapter)
public Property | UpdateCommand | Gets or sets a command used to update records in the data source. (Inherited from System.Data.Common.DbDataAdapter)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Fill | Overloaded. Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the System.Data.DataSet and System.Data.DataTable names. (Inherited from System.Data.Common.DbDataAdapter)
public Method | FillPage | Fills associated DataSet with specified range of rows.
public Method | FillSchema | Overloaded. Overridden. Configures the schema of the specified System.Data.DataTable based on the specified System.Data.SchemaType.
public Method | GetFillParameters | Gets the parameters set by the user when executing an SQL SELECT statement. (Inherited from System.Data.Common.DataAdapter)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Update | Overloaded. Calls the respective INSERT, UPDATE, or DELETE statements for each inserted, updated, or deleted row in the specified System.Data.DataSet from a System.Data.DataTable named "Table." (Inherited from System.Data.Common.DataAdapter)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | FillError | Returned when an error occurs during a fill operation. (Inherited from System.Data.Common.DataAdapter)
Top

See Also

Reference

DbDataAdapter Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDataAdapter Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDataAdapter Class

For a list of all members of this type, see DbDataAdapter members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Fill | Overloaded. Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the System.Data.DataSet and System.Data.DataTable names. (Inherited from System.Data.Common.DbDataAdapter)
public Method | FillPage | Fills associated DataSet with specified range of rows.
public Method | FillSchema | Overloaded. Overridden. Configures the schema of the specified System.Data.DataTable based on the specified System.Data.SchemaType.
public Method | GetFillParameters | Gets the parameters set by the user when executing an SQL SELECT statement. (Inherited from System.Data.Common.DataAdapter)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Update | Overloaded. Calls the respective INSERT, UPDATE, or DELETE statements for each inserted, updated, or deleted row in the specified System.Data.DataSet from a System.Data.DataTable named "Table." (Inherited from System.Data.Common.DataAdapter)
Top

See Also

Reference

DbDataAdapter Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillPage Method
See Also support@devart.com
Devart.Common Namespace > DbDataAdapter Class : FillPage Method

dataTable
A DataTable to fill.
startRecord
Ordinal of row that result set starts with.
maxRecords
Quantity of rows to fill.
Fills associated DataSet with specified range of rows.

Syntax

Visual Basic (Declaration)
Public Function FillPage( _
   ByVal dataTable As DataTable, _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer _
) As Integer
C#
public int FillPage(
   DataTable dataTable,
   int startRecord,
   int maxRecords
)

Parameters

dataTable
A DataTable to fill.
startRecord
Ordinal of row that result set starts with.
maxRecords
Quantity of rows to fill.

Return Value

Number of rows filled.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataAdapter Class
DbDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDataReaderBase Class
Members See Also support@devart.com
Devart.Common Namespace : DbDataReaderBase Class

Allows to read a forward-only stream of rows from a data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbDataReader
Devart.Common.DbDataReaderBase
Devart.Data.Oracle.OracleDataReader

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDataReaderBase
   Inherits System.Data.Common.DbDataReader
   Implements IEnumerable, IDataReader, IDataRecord, IDisposable
C#
public abstract class DbDataReaderBase : System.Data.Common.DbDataReader, IEnumerable, IDataReader, IDataRecord, IDisposable

Remarks

Abstract DbDataReaderBase class implements some of DbDataReaderBase functionality that is DBMS-independent.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDataReaderBase Members
Devart.Common Namespace
DbDataReaderBase Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDataReaderBase Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbDataReaderBase Class

The following tables list the members exposed by DbDataReaderBase.

Public Properties

 | Name | Description
public Property | Depth | Overridden. Gets a value indicating the depth of nesting for the current row.
public Property | EndOfData | Indicates whether the DbDataReaderBase has been read completely.
public Property | FieldCount | Overridden. Gets the number of columns in the current row.
public Property | HasRows | Overridden. Gets a value indicating whether the DbDataReaderBase contains one or more rows.
public Property | IsClosed | Overridden. Gets a value indicating whether the data reader is closed.
public Property | Item | Overridden. Gets the value of the specified column in its native format given the column name.
public Property | RecordsAffected | Overridden. Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
public Property | VisibleFieldCount | Gets the number of fields in the System.Data.Common.DbDataReader that are not hidden. (Inherited from System.Data.Common.DbDataReader)
Top

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes the DbDataReaderBase object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | Overloaded. Gets the value of the specified column as a Boolean.
public Method | GetByte | Overloaded. Gets the value of the specified column as a byte.
public Method | GetBytes | Overloaded. Overridden. Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetChar | Overloaded. Gets the value of the specified column as a single character.
public Method | GetChars | Overloaded. Overridden. Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetDataTypeName | Overloaded. Overridden. Gets the name of the source data type.
public Method | GetDateTime | Overloaded. Gets the value of the specified column as a DateTime object.
public Method | GetDateTimeOffset | Overloaded. Gets the value of the specified column as a DateTimeOffset object.
public Method | GetDecimal | Overloaded. Gets the value of the specified column as a DateTime object.
public Method | GetDouble | Overloaded. Gets the value of the specified column as a double-precision floating point number.
public Method | GetEnumerator | Overridden. Fills System.Collection.IEnumerator object with data from DbDataReaderBase.
public Method | GetFieldType | Overloaded. Overridden. Gets the System.Type that is the data type of the object.
public Method | GetFloat | Overloaded. Gets the value of the specified column as a single-precision floating point number.
public Method | GetGuid | Overloaded. Gets the value of the specified column as a globally-unique identifier (GUID).
public Method | GetInt16 | Overloaded. Gets the value of the specified column as a 16-bit signed integer.
public Method | GetInt32 | Overloaded. Gets the value of the specified column as a 32-bit signed integer.
public Method | GetInt64 | Overloaded. Gets the value of the specified column as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | Overridden. Gets the name of the specified column.
public Method | GetOrdinal | Overridden. Gets the column ordinal, given the name of the column.
public Method | GetProviderSpecificFieldType | Returns the provider-specific field type of the specified column.
public Method | GetProviderSpecificValue | Gets the value of the specified column as an instance of System.Object
public Method | GetSchemaTable | Overridden. Returns a System.Data.DataTable that describes the column metadata of the DbDataReaderBase.
public Method | GetString | Overloaded. Gets the value of the specified column as an instance of System.String
public Method | GetValue | Overloaded. Overridden. Gets the value of the specified column in its native format.
public Method | GetValues | Overridden. Gets all attribute columns in the collection for the current row.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | Overloaded. Gets a value indicating whether the column contains non-existent or missing values.
public Method | NextResult | Overridden. Advances the data reader to the next result, when reading the results of batch SQL statements.
public Method | Read | Overridden. Advances the DbDataReaderBase to the next record.
Top

See Also

Reference

DbDataReaderBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDataReaderBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDataReaderBase Class

For a list of all members of this type, see DbDataReaderBase members.

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes the DbDataReaderBase object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | Overloaded. Gets the value of the specified column as a Boolean.
public Method | GetByte | Overloaded. Gets the value of the specified column as a byte.
public Method | GetBytes | Overloaded. Overridden. Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetChar | Overloaded. Gets the value of the specified column as a single character.
public Method | GetChars | Overloaded. Overridden. Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetDataTypeName | Overloaded. Overridden. Gets the name of the source data type.
public Method | GetDateTime | Overloaded. Gets the value of the specified column as a DateTime object.
public Method | GetDateTimeOffset | Overloaded. Gets the value of the specified column as a DateTimeOffset object.
public Method | GetDecimal | Overloaded. Gets the value of the specified column as a DateTime object.
public Method | GetDouble | Overloaded. Gets the value of the specified column as a double-precision floating point number.
public Method | GetEnumerator | Overridden. Fills System.Collection.IEnumerator object with data from DbDataReaderBase.
public Method | GetFieldType | Overloaded. Overridden. Gets the System.Type that is the data type of the object.
public Method | GetFloat | Overloaded. Gets the value of the specified column as a single-precision floating point number.
public Method | GetGuid | Overloaded. Gets the value of the specified column as a globally-unique identifier (GUID).
public Method | GetInt16 | Overloaded. Gets the value of the specified column as a 16-bit signed integer.
public Method | GetInt32 | Overloaded. Gets the value of the specified column as a 32-bit signed integer.
public Method | GetInt64 | Overloaded. Gets the value of the specified column as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | Overridden. Gets the name of the specified column.
public Method | GetOrdinal | Overridden. Gets the column ordinal, given the name of the column.
public Method | GetProviderSpecificFieldType | Returns the provider-specific field type of the specified column.
public Method | GetProviderSpecificValue | Gets the value of the specified column as an instance of System.Object
public Method | GetSchemaTable | Overridden. Returns a System.Data.DataTable that describes the column metadata of the DbDataReaderBase.
public Method | GetString | Overloaded. Gets the value of the specified column as an instance of System.String
public Method | GetValue | Overloaded. Overridden. Gets the value of the specified column in its native format.
public Method | GetValues | Overridden. Gets all attribute columns in the collection for the current row.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | Overloaded. Gets a value indicating whether the column contains non-existent or missing values.
public Method | NextResult | Overridden. Advances the data reader to the next result, when reading the results of batch SQL statements.
public Method | Read | Overridden. Advances the DbDataReaderBase to the next record.
Top

See Also

Reference

DbDataReaderBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : Close Method

Closes the DbDataReaderBase object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

You must explicitly call the Close method when you are finished using the DbDataReaderBase to use the associated DbConnectionBase for any other purpose.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBoolean Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetBoolean Method

Gets the value of the specified column as a Boolean.

Overload List

Overload | Description
GetBoolean(String) | Gets the value of the specified column as a Boolean.
GetBoolean(Int32) | Gets the value of the specified column as a Boolean. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBoolean(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetBoolean Method : GetBoolean(String) Method

name
The name of the column.
Gets the value of the specified column as a Boolean.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetBoolean( _
   ByVal name As String _
) As Boolean
C#
public bool GetBoolean(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetByte Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetByte Method

Gets the value of the specified column as a byte.

Overload List

Overload | Description
GetByte(String) | Gets the value of the specified column as a byte.
GetByte(Int32) | Gets the value of the specified column as a byte. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetByte(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetByte Method : GetByte(String) Method

name
The name of the column.
Gets the value of the specified column as a byte.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetByte( _
   ByVal name As String _
) As Byte
C#
public byte GetByte(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetBytes Method

Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Overload List

Overload | Description
GetBytes(Int32,Int64,Byte[],Int32,Int32) | Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
GetBytes(String,Int64,Byte[],Int32,Int32) | Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes(Int32,Int64,Byte[],Int32,Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetBytes Method : GetBytes(Int32,Int64,Byte[],Int32,Int32) Method

ordinal
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum length to copy into the buffer.
Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetBytes( _
   ByVal ordinal As Integer, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Byte, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public override long GetBytes(
   int ordinal,
   long fieldOffset,
   byte[] buffer,
   int bufferOffset,
   int length
)

Parameters

ordinal
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum length to copy into the buffer.

Return Value

The actual number of bytes read.

Remarks

GetBytes returns the number of available bytes in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetBytes has already been used to obtain bytes from the field. This may be the case, for example, if the DbDataReaderBase is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value, GetBytes returns the length of the field in bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes(String,Int64,Byte[],Int32,Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetBytes Method : GetBytes(String,Int64,Byte[],Int32,Int32) Method

name
The name of the column.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum length to copy into the buffer.
Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetBytes( _
   ByVal name As String, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Byte, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public long GetBytes(
   string name,
   long fieldOffset,
   byte[] buffer,
   int bufferOffset,
   int length
)

Parameters

name
The name of the column.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum length to copy into the buffer.

Return Value

The actual number of bytes read.

Remarks

GetBytes returns the number of available bytes in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetBytes has already been used to obtain bytes from the field. This may be the case, for example, if the DbDataReaderBase is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value, GetBytes returns the length of the field in bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChar Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetChar Method

Gets the value of the specified column as a single character.

Overload List

Overload | Description
GetChar(String) | Gets the value of the specified column as a single character.
GetChar(Int32) | Gets the value of the specified column as a single character. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChar(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetChar Method : GetChar(String) Method

name
The name of the column.
Gets the value of the specified column as a single character.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChar( _
   ByVal name As String _
) As Char
C#
public char GetChar(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetChars Method

Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Overload List

Overload | Description
GetChars(Int32,Int64,Char[],Int32,Int32) | Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
GetChars(String,Int64,Char[],Int32,Int32) | Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars(Int32,Int64,Char[],Int32,Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetChars Method : GetChars(Int32,Int64,Char[],Int32,Int32) Method

ordinal
The zero-based column ordinal.
fieldOffset
The index within the row where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum number of characters to read.
Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetChars( _
   ByVal ordinal As Integer, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Char, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public override long GetChars(
   int ordinal,
   long fieldOffset,
   char[] buffer,
   int bufferOffset,
   int length
)

Parameters

ordinal
The zero-based column ordinal.
fieldOffset
The index within the row where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum number of characters to read.

Return Value

The actual number of characters read.

Remarks

GetChars returns the number of available characters in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetChars has already been used to obtain characters from the field. This may be the case, for example, if the DbDataReaderBase is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value. GetChars returns the length of the field in characters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars(String,Int64,Char[],Int32,Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetChars Method : GetChars(String,Int64,Char[],Int32,Int32) Method

name
The name of the column.
fieldOffset
The index within the row where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum number of characters to read.
Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChars( _
   ByVal name As String, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Char, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public long GetChars(
   string name,
   long fieldOffset,
   char[] buffer,
   int bufferOffset,
   int length
)

Parameters

name
The name of the column.
fieldOffset
The index within the row where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index where buffer is to begin the write operation.
length
The maximum number of characters to read.

Return Value

The actual number of characters read.

Remarks

GetChars returns the number of available characters in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetChars has already been used to obtain characters from the field. This may be the case, for example, if the DbDataReaderBase is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value. GetChars returns the length of the field in characters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetDataTypeName Method

Gets the name of the source data type.

Overload List

Overload | Description
GetDataTypeName(Int32) | Gets the name of the source data type.
GetDataTypeName(String) | Gets the name of the source data type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDataTypeName Method : GetDataTypeName(Int32) Method

ordinal
The zero-based column ordinal.
Gets the name of the source data type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDataTypeName( _
   ByVal ordinal As Integer _
) As String
C#
public override string GetDataTypeName(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

The name of the back-end data type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDataTypeName Method : GetDataTypeName(String) Method

name
The name of the column.
Gets the name of the source data type.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDataTypeName( _
   ByVal name As String _
) As String
C#
public string GetDataTypeName(
   string name
)

Parameters

name
The name of the column.

Return Value

The name of the back-end data type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTime Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetDateTime Method

Gets the value of the specified column as a DateTime object.

Overload List

Overload | Description
GetDateTime(String) | Gets the value of the specified column as a DateTime object.
GetDateTime(Int32) | Gets the value of the specified column as a System.DateTime object. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTime(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDateTime Method : GetDateTime(String) Method

name
The name of the column.
Gets the value of the specified column as a DateTime object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDateTime( _
   ByVal name As String _
) As Date
C#
public DateTime GetDateTime(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTimeOffset Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetDateTimeOffset Method

Gets the value of the specified column as a DateTimeOffset object.

Overload List

Overload | Description
GetDateTimeOffset(String) | Gets the value of the specified column as a DateTimeOffset object.
GetDateTimeOffset(Int32) | Gets the value of the specified column as a System.DateTimeOffset object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTimeOffset(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDateTimeOffset Method : GetDateTimeOffset(String) Method

name
The name of the column.
Gets the value of the specified column as a DateTimeOffset object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDateTimeOffset( _
   ByVal name As String _
) As DateTimeOffset
C#
public DateTimeOffset GetDateTimeOffset(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTimeOffset(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDateTimeOffset Method : GetDateTimeOffset(Int32) Method

ordinal
The zero-based column ordinal.
Gets the value of the specified column as a System.DateTimeOffset object.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetDateTimeOffset( _
   ByVal ordinal As Integer _
) As DateTimeOffset
C#
public virtual DateTimeOffset GetDateTimeOffset(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDecimal Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetDecimal Method

Gets the value of the specified column as a DateTime object.

Overload List

Overload | Description
GetDecimal(String) | Gets the value of the specified column as a DateTime object.
GetDecimal(Int32) | Gets the value of the specified column as a System.Decimal object. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDecimal(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDecimal Method : GetDecimal(String) Method

name
The name of the column.
Gets the value of the specified column as a DateTime object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDecimal( _
   ByVal name As String _
) As Decimal
C#
public decimal GetDecimal(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDouble Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetDouble Method

Gets the value of the specified column as a double-precision floating point number.

Overload List

Overload | Description
GetDouble(String) | Gets the value of the specified column as a double-precision floating point number.
GetDouble(Int32) | Gets the value of the specified column as a double-precision floating point number. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDouble(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetDouble Method : GetDouble(String) Method

name
The name of the column.
Gets the value of the specified column as a double-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDouble( _
   ByVal name As String _
) As Double
C#
public double GetDouble(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetEnumerator Method

Fills System.Collection.IEnumerator object with data from DbDataReaderBase.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator() As IEnumerator
C#
public override IEnumerator GetEnumerator()

Return Value

System.Collection.IEnumerator object to be populated with data.

Example

C#csharp Copy Code
static void UseEnumerator(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT comm FROM Test.emp");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    IEnumerator enumerator = reader.GetEnumerator();

    while (enumerator.MoveNext()) {
      if (((IDataRecord)enumerator.Current).IsDBNull(0)) {
        Console.WriteLine("Null value found");
      }
    }
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub UseEnumerator(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT comm FROM Test.emp")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    Dim enumerator As IEnumerator = reader.GetEnumerator
    Do While enumerator.MoveNext
      If DirectCast(enumerator.Current, IDataRecord).IsDBNull(0) Then
        Console.WriteLine("Null value found")
      End If
    Loop
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetFieldType Method

Gets the System.Type that is the data type of the object.

Overload List

Overload | Description
GetFieldType(Int32) | Gets the System.Type that is the data type of the object.
GetFieldType(String) | Gets the System.Type that is the data type of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetFieldType Method : GetFieldType(Int32) Method

ordinal
The zero-based column ordinal.
Gets the System.Type that is the data type of the object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetFieldType( _
   ByVal ordinal As Integer _
) As Type
C#
public override Type GetFieldType(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

The System.Type that is the data type of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetFieldType Method : GetFieldType(String) Method

name
The name of the column.
Gets the System.Type that is the data type of the object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFieldType( _
   ByVal name As String _
) As Type
C#
public Type GetFieldType(
   string name
)

Parameters

name
The name of the column.

Return Value

The System.Type that is the data type of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFloat Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetFloat Method

Gets the value of the specified column as a single-precision floating point number.

Overload List

Overload | Description
GetFloat(String) | Gets the value of the specified column as a single-precision floating point number.
GetFloat(Int32) | Gets the value of the specified column as a single-precision floating point number. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFloat(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetFloat Method : GetFloat(String) Method

name
The name of the column.
Gets the value of the specified column as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFloat( _
   ByVal name As String _
) As Single
C#
public float GetFloat(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetGuid Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetGuid Method

Gets the value of the specified column as a globally-unique identifier (GUID).

Overload List

Overload | Description
GetGuid(String) | Gets the value of the specified column as a globally-unique identifier (GUID).
GetGuid(Int32) | Gets the value of the specified column as a globally-unique identifier (GUID). (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetGuid(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetGuid Method : GetGuid(String) Method

name
The name of the column.
Gets the value of the specified column as a globally-unique identifier (GUID).

Syntax

Visual Basic (Declaration)
Public Overloads Function GetGuid( _
   ByVal name As String _
) As Guid
C#
public Guid GetGuid(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt16 Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetInt16 Method

Gets the value of the specified column as a 16-bit signed integer.

Overload List

Overload | Description
GetInt16(String) | Gets the value of the specified column as a 16-bit signed integer.
GetInt16(Int32) | Gets the value of the specified column as a 16-bit signed integer. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt16(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetInt16 Method : GetInt16(String) Method

name
The name of the column.
Gets the value of the specified column as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInt16( _
   ByVal name As String _
) As Short
C#
public short GetInt16(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt32 Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetInt32 Method

Gets the value of the specified column as a 32-bit signed integer.

Overload List

Overload | Description
GetInt32(String) | Gets the value of the specified column as a 32-bit signed integer.
GetInt32(Int32) | Gets the value of the specified column as a 32-bit signed integer. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt32(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetInt32 Method : GetInt32(String) Method

name
The name of the column.
Gets the value of the specified column as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInt32( _
   ByVal name As String _
) As Integer
C#
public int GetInt32(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt64 Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetInt64 Method

Gets the value of the specified column as a 64-bit signed integer.

Overload List

Overload | Description
GetInt64(String) | Gets the value of the specified column as a 64-bit signed integer.
GetInt64(Int32) | Gets the value of the specified column as a 64-bit signed integer. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt64(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetInt64 Method : GetInt64(String) Method

name
The name of the column.
Gets the value of the specified column as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInt64( _
   ByVal name As String _
) As Long
C#
public long GetInt64(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetName Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetName Method

ordinal
The zero-based column ordinal.

Gets the name of the specified column.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetName( _
   ByVal ordinal As Integer _
) As String
C#
public override string GetName(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

A string that is the name of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOrdinal Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetOrdinal Method

name
The name of the column.
Gets the column ordinal, given the name of the column.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetOrdinal( _
   ByVal name As String _
) As Integer
C#
public override int GetOrdinal(
   string name
)

Parameters

name
The name of the column.

Return Value

The zero-based column ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificFieldType(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetProviderSpecificFieldType Method : GetProviderSpecificFieldType(String) Method

name
The name of the column.
Returns the provider-specific field type of the specified column.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProviderSpecificFieldType( _
   ByVal name As String _
) As Type
C#
public Type GetProviderSpecificFieldType(
   string name
)

Parameters

name
The name of the column.

Return Value

The provider-specific field type of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValue(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetProviderSpecificValue Method : GetProviderSpecificValue(String) Method

name
The name of the column.
Gets the value of the specified column as an instance of System.Object

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProviderSpecificValue( _
   ByVal name As String _
) As Object
C#
public object GetProviderSpecificValue(
   string name
)

Parameters

name
The name of the column.

Return Value

The provider-specific field type of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchemaTable Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetSchemaTable Method

Returns a System.Data.DataTable that describes the column metadata of the DbDataReaderBase.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSchemaTable() As DataTable
C#
public override DataTable GetSchemaTable()

Return Value

A System.Data.DataTable that describes the column metadata.

Remarks

The GetSchemaTable method returns metadata about each column in the following order:

DataReader Column | Description
ColumnName | The name of the column; this might not be unique. If the column name cannot be determined, a null value is returned. This name always reflects the most recent naming of the column in the current view or command text.
ColumnOrdinal | The ordinal of the column. This is zero for the bookmark column of the row, if any. Other columns are numbered starting with 1. This column cannot contain a null value.
ColumnSize | The maximum possible length of a value in the column. For columns that use a fixed-length data type, this is the size of the data type.
NumericPrecision | If System.Data.DbType is a numeric data type, this is the maximum precision of the column. The precision depends on the definition of the column. If System.Data.DbType is not a numeric data type, this is a null value.
NumericScale | If System.Data.DbType is Decimal, the number of digits to the right of the decimal point. Otherwise, this is a null value.
DataType | Maps to the .Net Framework type of the column.
ProviderType | The indicator of the column's data type.
IsLong | true if the column contains a BLOB that contains very long data.
AllowDBNull | true if the consumer can set the column to a null value. Otherwise, false. A column may contain null values, even if it cannot be set to a null value.
IsReadOnly | true if the column can not be modified; otherwise, false.
IsRowVersion | Set if the column contains a persistent row identifier that cannot be written to, and has no meaningful value except to identity the row.
IsUnique | true: No two rows in the base table-the table returned in BaseTableName-can have the same value in this column. IsUnique is guaranteed to be true if the column constitutes a key by itself or if there is a constraint of type UNIQUE that applies only to this column. false: The column can contain duplicate values in the base table.The default for this column is false.
IsKey true: The column is one of a set of columns in the rowset that, taken together, uniquely identify the row. The set of columns with IsKey set to true must uniquely identify a row in the rowset. There is no requirement that this set of columns is a minimal set of columns. This set of columns may be generated from a base table primary key, a unique constraint or a unique index. false: The column is not required to uniquely identify the row.
To get the primary key information, including whether a field is part of a primary key and whether it is an AutoIncrement field, you should set the CommandBehavior.KeyInfo parameter of the OracleCommand.ExecuteReader() method when getting your data reader.
IsAutoIncrement | true if the column assigns values to new rows in fixed increments; otherwise, false. The default value for this column is false.
BaseSchemaName | The name of the schema in the database that contains the column. NULL if the base catalog name cannot be determined. The default for this column is a null value.
BaseCatalogName | The name of the catalog in the data store that contains the column. NULL if the base catalog name cannot be determined. The default value for this column is a null value.
BaseTableName | The name of the table or view in the data store that contains the column. A null value if the base table name cannot be determined. The default value of this column is a null value.
BaseColumnName | The name of the column in the data store. This might be different than the column name returned in the ColumnName column if an alias was used. A null value if the base column name cannot be determined or if the rowset column is derived, but not identical to, a column in the data store. The default value for this column is a null value.
IsAliased | true if the column name is an alias; otherwise, false.
IsExpression | true if the column is an expression; otherwise, false.
IdentityType

This column can have the following values:

OracleIdentityType.None - the column is not an Oracle Identity column.

OracleIdentityType.GeneratedByDefault - the column is an Oracle Identity column, and its value is generated by the data source when no value is explicitly provided for this column.

OracleIdentityType.GeneratedByDefaultOnNull - the column is an Oracle Identity column, and its value is generated by the data source when no value is explicitly provided for this column or a NULL value is provided.

OracleIdentityType.GeneratedAlways - the column is an Oracle Identity column, and its value is always generated for every INSERT or UPDATE. No updates or inserts are allowed for this column.

For Oracle with version lower than 12c this column always contains OracleIdentityType.None. It also always contains OracleIdentityType.None in OracleConnection.Direct mode.

Note: if you want metadata columns to return the correct information, you must call the Command.ExecuteReader(CommandBehavior) method with the behavior parameter set to KeyInfo. Otherwise, some of the schema table columns may return null, default, or incorrect data.

Note: This method is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

C#csharp Copy Code
static void GetSchemaFromReader(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.emp, Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader(CommandBehavior.KeyInfo);

    DataTable dt = reader.GetSchemaTable();
    //...

    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetSchemaFromReader(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.emp, Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader(CommandBehavior.KeyInfo)
    Dim dt As DataTable = reader.GetSchemaTable
    '...

    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetString Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetString Method

Gets the value of the specified column as an instance of System.String

Overload List

Overload | Description
GetString(String) | Gets the value of the specified column as an instance of System.String
GetString(Int32) | Gets the value of the specified column as an instance of System.String. (Inherited from System.Data.Common.DbDataReader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetString(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetString Method : GetString(String) Method

name
The name of the column.
Gets the value of the specified column as an instance of System.String

Syntax

Visual Basic (Declaration)
Public Overloads Function GetString( _
   ByVal name As String _
) As String
C#
public string GetString(
   string name
)

Parameters

name
The name of the column.

Return Value

The value of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetValue Method

Gets the value of the specified column in its native format.

Overload List

Overload | Description
GetValue(Int32) | Gets the value of the specified column in its native format.
GetValue(String) | Gets the value of the specified column in its native format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetValue Method : GetValue(Int32) Method

ordinal
The zero-based column ordinal.
Gets the value of the specified column in its native format.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetValue( _
   ByVal ordinal As Integer _
) As Object
C#
public override object GetValue(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

The value to return.

Remarks

This method returns System.DBNull for null columns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > GetValue Method : GetValue(String) Method

name
The value of the specified column.
Gets the value of the specified column in its native format.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetValue( _
   ByVal name As String _
) As Object
C#
public object GetValue(
   string name
)

Parameters

name
The value of the specified column.

Return Value

The value to return.

Remarks

This method returns System.DBNull for null columns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValues Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetValues Method

values
An array of System.Object into which to copy the attribute columns.
Gets all attribute columns in the collection for the current row.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetValues( _
   ByVal values() As Object _
) As Integer
C#
public override int GetValues(
   object[] values
)

Parameters

values
An array of System.Object into which to copy the attribute columns.

Return Value

The number of instances of System.Object in the array.

Remarks

For most applications, the GetValues method provides an efficient means for retrieving all columns, rather than retrieving each column individually.

You can pass an System.Object array that contains fewer than the number of columns contained in the resulting row. Only the amount of data the System.Object array holds is copied to the array. You can also pass an System.Object array whose length is more than the number of columns contained in the resulting row.

This method returns System.DBNull for null columns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : IsDBNull Method

Gets a value indicating whether the column contains non-existent or missing values.

Overload List

Overload | Description
IsDBNull(String) | Gets a value indicating whether the column contains non-existent or missing values.
IsDBNull(Int32) | Gets a value indicating whether the column contains non-existent or missing values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > IsDBNull Method : IsDBNull(String) Method

name
The value of the specified column.
Gets a value indicating whether the column contains non-existent or missing values.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsDBNull( _
   ByVal name As String _
) As Boolean
C#
public bool IsDBNull(
   string name
)

Parameters

name
The value of the specified column.

Return Value

true if the specified column value is equivalent to System.DBNull; otherwise, false.

Remarks

To avoid raising an error, call this method to check for null column values before calling the typed Get methods (for example, GetBytes, GetChars, and so on).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class > IsDBNull Method : IsDBNull(Int32) Method

ordinal
The zero-based column ordinal.
Gets a value indicating whether the column contains non-existent or missing values.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IsDBNull( _
   ByVal ordinal As Integer _
) As Boolean
C#
public override bool IsDBNull(
   int ordinal
)

Parameters

ordinal
The zero-based column ordinal.

Return Value

true if the specified column value is equivalent to System.DBNull; otherwise, false.

Remarks

To avoid raising an error, call this method to check for null column values before calling the typed Get methods (for example, GetBytes, GetChars, and so on).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NextResult Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : NextResult Method

Advances the data reader to the next result, when reading the results of batch SQL statements.

Syntax

Visual Basic (Declaration)
Public Overrides Function NextResult() As Boolean
C#
public override bool NextResult()

Return Value

true if there are more result sets; otherwise, false.

Remarks

Used to process multiple results, which can be generated by executing batch SQL statements.

By default, the DbDataReaderBase is positioned on the first result.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : Read Method

Advances the DbDataReaderBase to the next record.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read() As Boolean
C#
public override bool Read()

Return Value

true if there are more rows; otherwise, false.

Remarks

The default position of the DbDataReaderBase is prior to the first record. Therefore, you must call Read to begin accessing any data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbDataReaderBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbDataReaderBase Class

For a list of all members of this type, see DbDataReaderBase members.

Public Properties

 | Name | Description
public Property | Depth | Overridden. Gets a value indicating the depth of nesting for the current row.
public Property | EndOfData | Indicates whether the DbDataReaderBase has been read completely.
public Property | FieldCount | Overridden. Gets the number of columns in the current row.
public Property | HasRows | Overridden. Gets a value indicating whether the DbDataReaderBase contains one or more rows.
public Property | IsClosed | Overridden. Gets a value indicating whether the data reader is closed.
public Property | Item | Overridden. Gets the value of the specified column in its native format given the column name.
public Property | RecordsAffected | Overridden. Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
public Property | VisibleFieldCount | Gets the number of fields in the System.Data.Common.DbDataReader that are not hidden. (Inherited from System.Data.Common.DbDataReader)
Top

See Also

Reference

DbDataReaderBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Depth Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : Depth Property

Gets a value indicating the depth of nesting for the current row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Depth As Integer
C#
public override int Depth {get;}

Property Value

The depth of nesting for the current row.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndOfData Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : EndOfData Property

Indicates whether the DbDataReaderBase has been read completely.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property EndOfData As Boolean
C#
public abstract bool EndOfData {get;}

Property Value

true if there is no more data in DbDataReaderBase. This property is false if there is more data to read, or there were no data at all.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FieldCount Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : FieldCount Property

Gets the number of columns in the current row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FieldCount As Integer
C#
public override int FieldCount {get;}

Property Value

When not positioned in a valid record set, 0; otherwise the number of columns in the current record. The default value is -1.

Remarks

After executing a query that does not return rows, FieldCount returns 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
HasRows Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : HasRows Property

Gets a value indicating whether the DbDataReaderBase contains one or more rows.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HasRows As Boolean
C#
public override bool HasRows {get;}

Property Value

true if the DbDataReaderBase contains one or more rows; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsClosed Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : IsClosed Property

Gets a value indicating whether the data reader is closed.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsClosed As Boolean
C#
public override bool IsClosed {get;}

Property Value

true if the DbDataReaderBase is closed; otherwise, false.

Remarks

IsClosed and RecordsAffected are the only properties that you can call after the DbDataReaderBase is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : Item Property

name
The column name.
Gets the value of the specified column in its native format given the column name.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Default Property Item( _
   ByVal name As String _
) As Object
C#
public override object this(
   string name
) {get;}

Parameters

name
The column name.

Property Value

The value of the specified column in its native format.

Remarks

You can omit the property name.

Example

C#csharp Copy Code
static void GetHireDate(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.emp");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
        DateTime recievedTime = (DateTime)reader["hiredate"];
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetHireDate(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.emp")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedTime As DateTime = CDate(reader("hiredate"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecordsAffected Property
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : RecordsAffected Property

Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property RecordsAffected As Integer
C#
public override int RecordsAffected {get;}

Property Value

The number of rows changed, inserted, or deleted. -1 for SELECT statements; 0 if no rows were affected, or the statement failed.

Remarks

The value of this property is not cumulative. For example, if two records are inserted in the first statement in batch mode, and the second statement affected 3 records, the value of RecordsAffected will be 3.

IsClosed and RecordsAffected are the only properties that you can call after the DbDataReaderBase is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDataSet Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbDataSet Class

Represents an in-memory cache of data with connected model support.

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Data.DataSet
Devart.Common.DbDataSet
Devart.Data.Oracle.OracleDataSet

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDataSet
   Inherits System.Data.DataSet
   Implements IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable
C#
public abstract class DbDataSet : System.Data.DataSet, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable

Remarks

Base class for provider-specific DataSet components.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

This sample shows how to use DbDataSet. The routine accepts DbDataSet-compatible object and connection string. After Devart.Data.Oracle.OracleDataTables were created and populated, they were added to DataTableCollection of DbDataSet, and DataRelation was created to link tables.
C#csharp Copy Code
pubic void FillDataSet(DbDataSet dataSet, string connStr) {
        // retrieving data from DEPT table
        OracleDataTable dept = new OracleDataTable("select * from dept", connStr);
        dept.FetchAll = true;
        dept.Active = true;

        // retrieving data from EMP table
        OracleDataTable emp = new OracleDataTable("select * from emp", connStr);
        emp.FetchAll = true;
        emp.Active = true;

        // adding data tables to OracleDataSet
        dataSet.Tables.Add(dept);
        dataSet.Tables.Add(emp);

        // linking tables to allow navigation from parent table rows
        // to corresponding child table rows
        DataColumn parentColumn = dataSet.Tables["DEPT"].Columns["DEPTNO"];
        DataColumn childColumn = dataSet.Tables["EMP"].Columns["DEPTNO"];
        DataRelation relation =        new System.Data.DataRelation("DeptsEmps",
                parentColumn, childColumn);
        dataSet.Relations.Add(relation);
}
C#Visual Basic Copy Code
Public Sub FillDataSet(ByRef dataSet As DbDataSet, ByVal connStr As String)
        ' retrieving data from DEPT table
        Dim dept As New OracleDataTable("select * from dept", connStr)
        dept.FetchAll = True
        dept.Active = True

        ' retrieving data from EMP table
        Dim emp As New OracleDataTable("select * from emp", connStr)
        emp.FetchAll = True
        emp.Active = True

        ' adding data tables to OracleDataSet
        dataSet.Tables.Add(dept)
        dataSet.Tables.Add(emp)

        ' linking tables to allow navigation from parent table rows
        ' to corresponding child table rows
        Dim parentColumn As DataColumn = dataSet.Tables("DEPT").Columns("DEPTNO")
        Dim childColumn As DataColumn = dataSet.Tables("EMP").Columns("DEPTNO")
        Dim relation As New System.Data.DataRelation("DeptsEmps", parentColumn, childColumn)
        dataSet.Relations.Add(relation)
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDataSet Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDataSet Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbDataSet Class

The following tables list the members exposed by DbDataSet.

Public Properties

 | Name | Description
public Property | CaseSensitive | Gets or sets a value indicating whether string comparisons within System.Data.DataTable objects are case-sensitive. (Inherited from System.Data.DataSet)
public Property | Connection | Gets or sets DbConnectionBase used by the DbDataSet.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSetName | Gets or sets the name of the current System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | DefaultViewManager | Gets a custom view of the data contained in the System.Data.DataSet to allow filtering, searching, and navigating using a custom System.Data.DataViewManager. (Inherited from System.Data.DataSet)
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from System.Data.DataSet)
public Property | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from System.Data.DataSet)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the System.Data.DataTable objects within this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataSet)
public Property | Name | Gets or sets name of the DbDataSet.
public Property | Namespace | Gets or sets the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Owner | Gets or sets a form or other container that the DbDataSet instance belongs to.
public Property | Prefix | Gets or sets an XML prefix that aliases the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Relations | Get the collection of relations that link tables and allow navigation from parent tables to child tables. (Inherited from System.Data.DataSet)
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the DbDataSet used during remoting.
public Property | SchemaSerializationMode | Gets or sets a System.Data.SchemaSerializationMode for a System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | Tables | Gets the collection of tables contained in the System.Data.DataSet. (Inherited from System.Data.DataSet)
Top

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this System.Data.DataSet since it was loaded or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | BeginInit | Begins the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Clear | Clears the DbDataSet of any data by removing all rows in all tables.
public Method | Clone | Overridden. Copies the structure of the DbDataSet, including all DbDataTable schemas, relations, and constraints. Does not copy any data.
public Method | Copy | Copies both the structure and data for this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | CreateDataReader | Overloaded. Returns a System.Data.DataTableReader with one result set per System.Data.DataTable, in the same sequence as the tables appear in the System.Data.DataSet.Tables collection. (Inherited from System.Data.DataSet)
public Method | CreateDataTable | Creates new table in the DbDataSet.
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndInit | Ends the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Fill | Fills the System.Data.DataTable.Rows collection of the DbDataSet with rows from the data source.
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataSet that contains all changes made to it since it was loaded or since System.Data.DataSet.AcceptChanges was last called. (Inherited from System.Data.DataSet)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | GetXml | Returns the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetXmlSchema | Returns the XML Schema for the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | HasChanges | Overloaded. Gets a value indicating whether the System.Data.DataSet has changes, including new, deleted, or modified rows. (Inherited from System.Data.DataSet)
public Method | InferXmlSchema | Overloaded. Applies the XML schema from the specified System.Xml.XmlReader to the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | Load | Overloaded. Fills a System.Data.DataSet with values from a data source using the supplied System.Data.IDataReader, using an array of System.Data.DataTable instances to supply the schema and namespace information. (Inherited from System.Data.DataSet)
public Method | Merge | Overloaded. Merges a specified System.Data.DataSet and its schema into the current DataSet. (Inherited from System.Data.DataSet)
public Method | ReadXml | Overloaded. Reads XML schema and data into the DbDataSet.
public Method | ReadXmlSchema | Overloaded. Reads the XML schema from the specified System.Xml.XmlReader into the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | RejectChanges | Rolls back all the changes made to the System.Data.DataSet since it was created, or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | Reset | Clears all tables and removes all relations, foreign constraints, and tables from the System.Data.DataSet. Subclasses should override System.Data.DataSet.Reset to restore a System.Data.DataSet to its original state. (Inherited from System.Data.DataSet)
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | WriteXml | Overloaded. Writes the current data for the System.Data.DataSet using the specified System.IO.Stream. (Inherited from System.Data.DataSet)
public Method | WriteXmlSchema | Overloaded. Writes the System.Data.DataSet structure as an XML schema to the specified System.IO.Stream object. (Inherited from System.Data.DataSet)
Top

Public Events

 | Name | Description
public Event | Disposed | Adds an event handler to listen to the System.ComponentModel.MarshalByValueComponent.Disposed event on the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Event | Initialized | Occurs after the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Event | MergeFailed | Occurs when a target and source System.Data.DataRow have the same primary key value, and System.Data.DataSet.EnforceConstraints is set to true. (Inherited from System.Data.DataSet)
Top

See Also

Reference

DbDataSet Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDataSet Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDataSet Class

For a list of all members of this type, see DbDataSet members.

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this System.Data.DataSet since it was loaded or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | BeginInit | Begins the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Clear | Clears the DbDataSet of any data by removing all rows in all tables.
public Method | Clone | Overridden. Copies the structure of the DbDataSet, including all DbDataTable schemas, relations, and constraints. Does not copy any data.
public Method | Copy | Copies both the structure and data for this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | CreateDataReader | Overloaded. Returns a System.Data.DataTableReader with one result set per System.Data.DataTable, in the same sequence as the tables appear in the System.Data.DataSet.Tables collection. (Inherited from System.Data.DataSet)
public Method | CreateDataTable | Creates new table in the DbDataSet.
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndInit | Ends the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Fill | Fills the System.Data.DataTable.Rows collection of the DbDataSet with rows from the data source.
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataSet that contains all changes made to it since it was loaded or since System.Data.DataSet.AcceptChanges was last called. (Inherited from System.Data.DataSet)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | GetXml | Returns the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetXmlSchema | Returns the XML Schema for the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | HasChanges | Overloaded. Gets a value indicating whether the System.Data.DataSet has changes, including new, deleted, or modified rows. (Inherited from System.Data.DataSet)
public Method | InferXmlSchema | Overloaded. Applies the XML schema from the specified System.Xml.XmlReader to the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | Load | Overloaded. Fills a System.Data.DataSet with values from a data source using the supplied System.Data.IDataReader, using an array of System.Data.DataTable instances to supply the schema and namespace information. (Inherited from System.Data.DataSet)
public Method | Merge | Overloaded. Merges a specified System.Data.DataSet and its schema into the current DataSet. (Inherited from System.Data.DataSet)
public Method | ReadXml | Overloaded. Reads XML schema and data into the DbDataSet.
public Method | ReadXmlSchema | Overloaded. Reads the XML schema from the specified System.Xml.XmlReader into the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | RejectChanges | Rolls back all the changes made to the System.Data.DataSet since it was created, or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | Reset | Clears all tables and removes all relations, foreign constraints, and tables from the System.Data.DataSet. Subclasses should override System.Data.DataSet.Reset to restore a System.Data.DataSet to its original state. (Inherited from System.Data.DataSet)
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | WriteXml | Overloaded. Writes the current data for the System.Data.DataSet using the specified System.IO.Stream. (Inherited from System.Data.DataSet)
public Method | WriteXmlSchema | Overloaded. Writes the System.Data.DataSet structure as an XML schema to the specified System.IO.Stream object. (Inherited from System.Data.DataSet)
Top

See Also

Reference

DbDataSet Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Clear Method

Clears the DbDataSet of any data by removing all rows in all tables. Clears the DbDataSet of any data by removing all rows in all tables.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Clone Method

Copies the structure of the DbDataSet, including all DbDataTable schemas, relations, and constraints. Does not copy any data.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As DataSet
C#
public override DataSet Clone()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateDataTable Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : CreateDataTable Method

Creates new table in the DbDataSet.

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateDataTable() As DbDataTable
C#
public virtual DbDataTable CreateDataTable()

Return Value

A new table object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Fill Method

Fills the System.Data.DataTable.Rows collection of the DbDataSet with rows from the data source.

Syntax

Visual Basic (Declaration)
Public Sub Fill()
C#
public void Fill()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : ReadXml Method

Reads XML schema and data into the DbDataSet.

Overload List

Overload | Description
ReadXml(Stream) | Reads XML schema and data into the DbDataSet using the specified System.IO.Stream.
ReadXml(String) | Reads XML schema and data into the DbDataSet using the specified file.
ReadXml(TextReader) | Reads XML schema and data into the DbDataSet using the specified System.IO.TextReader.
ReadXml(XmlReader) | Reads XML schema and data into the DbDataSet using the specified System.Xml.XmlReader.
ReadXml(Stream,XmlReadMode) | Reads XML schema and data into the DbDataSet using the specified System.IO.Stream.
ReadXml(String,XmlReadMode) | Reads XML schema and data into the DbDataSet using the specified file and System.Data.XmlReadMode.
ReadXml(TextReader,XmlReadMode) | Reads XML schema and data into the DbDataSet using the specified System.IO.TextReader.
ReadXml(XmlReader,XmlReadMode) | Reads XML schema and data into the DbDataSet using the specified System.Xml.XmlReader.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(Stream) Method

stream
An object that derives from System.IO.Stream.
Reads XML schema and data into the DbDataSet using the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal stream As Stream _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   Stream stream
)

Parameters

stream
An object that derives from System.IO.Stream.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(String) Method

fileName
The filename (including the path) from which to read.
Reads XML schema and data into the DbDataSet using the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal fileName As String _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   string fileName
)

Parameters

fileName
The filename (including the path) from which to read.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(TextReader) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(TextReader) Method

reader
The System.IO.TextReader from which to read the schema and data.
Reads XML schema and data into the DbDataSet using the specified System.IO.TextReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal reader As TextReader _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   TextReader reader
)

Parameters

reader
The System.IO.TextReader from which to read the schema and data.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(XmlReader) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(XmlReader) Method

reader
The System.Xml.XmlReader from which to read the schema and data.
Reads XML schema and data into the DbDataSet using the specified System.Xml.XmlReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal reader As XmlReader _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   XmlReader reader
)

Parameters

reader
The System.Xml.XmlReader from which to read the schema and data.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(Stream,XmlReadMode) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(Stream,XmlReadMode) Method

stream
An object that derives from System.IO.Stream.
mode
One of the System.Data.XmlReadMode values.
Reads XML schema and data into the DbDataSet using the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal stream As Stream, _
   ByVal mode As XmlReadMode _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   Stream stream,
   XmlReadMode mode
)

Parameters

stream
An object that derives from System.IO.Stream.
mode
One of the System.Data.XmlReadMode values.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(String,XmlReadMode) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(String,XmlReadMode) Method

fileName
The filename (including the path) from which to read.
mode
One of the System.Data.XmlReadMode values.
Reads XML schema and data into the DbDataSet using the specified file and System.Data.XmlReadMode.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal fileName As String, _
   ByVal mode As XmlReadMode _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   string fileName,
   XmlReadMode mode
)

Parameters

fileName
The filename (including the path) from which to read.
mode
One of the System.Data.XmlReadMode values.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(TextReader,XmlReadMode) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(TextReader,XmlReadMode) Method

reader
The System.IO.TextReader from which to read the schema and data.
mode
One of the System.Data.XmlReadMode values.
Reads XML schema and data into the DbDataSet using the specified System.IO.TextReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal reader As TextReader, _
   ByVal mode As XmlReadMode _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   TextReader reader,
   XmlReadMode mode
)

Parameters

reader
The System.IO.TextReader from which to read the schema and data.
mode
One of the System.Data.XmlReadMode values.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadXml(XmlReader,XmlReadMode) Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class > ReadXml Method : ReadXml(XmlReader,XmlReadMode) Method

reader
The System.Xml.XmlReader from which to read the schema and data.
mode
One of the System.Data.XmlReadMode values.
Reads XML schema and data into the DbDataSet using the specified System.Xml.XmlReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ReadXml( _
   ByVal reader As XmlReader, _
   ByVal mode As XmlReadMode _
) As XmlReadMode
C#
public new XmlReadMode ReadXml(
   XmlReader reader,
   XmlReadMode mode
)

Parameters

reader
The System.Xml.XmlReader from which to read the schema and data.
mode
One of the System.Data.XmlReadMode values.

Return Value

The System.Data.XmlReadMode used to read the data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Update Method
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Update Method

Executes the appropriate commands to delete, insert, or update rows in the data source.

Syntax

Visual Basic (Declaration)
Public Sub Update()
C#
public void Update()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbDataSet Class Properties
See Also support@devart.com
Devart.Common Namespace : DbDataSet Class

For a list of all members of this type, see DbDataSet members.

Public Properties

 | Name | Description
public Property | CaseSensitive | Gets or sets a value indicating whether string comparisons within System.Data.DataTable objects are case-sensitive. (Inherited from System.Data.DataSet)
public Property | Connection | Gets or sets DbConnectionBase used by the DbDataSet.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSetName | Gets or sets the name of the current System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | DefaultViewManager | Gets a custom view of the data contained in the System.Data.DataSet to allow filtering, searching, and navigating using a custom System.Data.DataViewManager. (Inherited from System.Data.DataSet)
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from System.Data.DataSet)
public Property | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from System.Data.DataSet)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the System.Data.DataTable objects within this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataSet)
public Property | Name | Gets or sets name of the DbDataSet.
public Property | Namespace | Gets or sets the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Owner | Gets or sets a form or other container that the DbDataSet instance belongs to.
public Property | Prefix | Gets or sets an XML prefix that aliases the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Relations | Get the collection of relations that link tables and allow navigation from parent tables to child tables. (Inherited from System.Data.DataSet)
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the DbDataSet used during remoting.
public Property | SchemaSerializationMode | Gets or sets a System.Data.SchemaSerializationMode for a System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | Tables | Gets the collection of tables contained in the System.Data.DataSet. (Inherited from System.Data.DataSet)
Top

See Also

Reference

DbDataSet Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Connection Property

Gets or sets DbConnectionBase used by the DbDataSet.

Syntax

Visual Basic (Declaration)
Public Property Connection As DbConnection
C#
public DbConnection Connection {get; set;}

Property Value

A DbDataSet object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Name Property

Gets or sets name of the DbDataSet.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the DbDataSet.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : Owner Property

Gets or sets a form or other container that the DbDataSet instance belongs to.

Syntax

Visual Basic (Declaration)
Public Property Owner As Object
C#
public object Owner {get; set;}

Property Value

A form or other container that the object belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemotingFormat Property
See Also support@devart.com
Devart.Common Namespace > DbDataSet Class : RemotingFormat Property

Gets or sets a System.Data.SerializationFormat for the DbDataSet used during remoting.

Syntax

Visual Basic (Declaration)
Public Shadows Property RemotingFormat As SerializationFormat
C#
public new SerializationFormat RemotingFormat {get; set;}

Property Value

A System.Data.SerializationFormat object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSet Class
DbDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDataSourceEnumerator Class
Members See Also support@devart.com
Devart.Common Namespace : DbDataSourceEnumerator Class

Retrieves list of available servers in the network.

Inheritance Hierarchy

System.Object
System.Data.Common.DbDataSourceEnumerator
Devart.Common.DbDataSourceEnumerator

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDataSourceEnumerator
   Inherits System.Data.Common.DbDataSourceEnumerator
C#
public abstract class DbDataSourceEnumerator : System.Data.Common.DbDataSourceEnumerator

Remarks

This function is similar to the Devart.Data.Oracle.OracleHome.GetServerList method. The function is not available in Direct mode.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDataSourceEnumerator Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDataSourceEnumerator Class Members
See Also Methods support@devart.com
Devart.Common Namespace : DbDataSourceEnumerator Class

The following tables list the members exposed by DbDataSourceEnumerator.

Public Methods

 | Name | Description
public Method | GetDataSources | Overridden. Retrieves a DataTable containing information about all visible instances of the server.
Top

See Also

Reference

DbDataSourceEnumerator Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDataSourceEnumerator Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDataSourceEnumerator Class

For a list of all members of this type, see DbDataSourceEnumerator members.

Public Methods

 | Name | Description
public Method | GetDataSources | Overridden. Retrieves a DataTable containing information about all visible instances of the server.
Top

See Also

Reference

DbDataSourceEnumerator Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataSources Method
See Also support@devart.com
Devart.Common Namespace > DbDataSourceEnumerator Class : GetDataSources Method

Retrieves a DataTable containing information about all visible instances of the server.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetDataSources() As DataTable
C#
public override DataTable GetDataSources()

Return Value

A DataTable containing information about the visible instances of the associated data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataSourceEnumerator Class
DbDataSourceEnumerator Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDataTable Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbDataTable Class

The DbDataTable class represents a single object that provides all of the functionality needed to retrieve and manipulate data from a data source. The DbDataTable class is built using existing ADO.NET components.

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Data.DataTable
Devart.Common.DbDataTable
Devart.Data.Oracle.OracleDataTable

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDataTable
   Inherits System.Data.DataTable
   Implements IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable
C#
public abstract class DbDataTable : System.Data.DataTable, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable

Remarks

The DbDataTable class extends the System.Data.DataTable class to provide a single object that can be used to access and update data from a data source. When a DbDataTable is created, the default values of its constituent parts are set to reasonable defaults, meaning that the programmer can create a single object and immediately use it to retrieve and manipulate data from a data source. It allows to cut down the size of the written code.

The DbDataTable class is designed to employ both connected and disconnected data access models. It also provides functionality for asynchronous fill operations.

The DbDataTable class can be fully adjusted at design-time. You may retrieve data at design-time from a data source if you set Active property to true.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

For more information on advanced features of DbDataTable please refer to topic DataTable Advanced Features.

Example

This sample shows how to use DbDataTable. The routine accepts DbTable-compatible object and IDbConnection implementor object as parameters. After SQL query text has been set, the data is retrieved from the table.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";
  try
  {
    myDataTable.Fill();
    myDataTable.Rows[1].Delete();
    myDataTable.Update();
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol] + "\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Try
    myDataTable.Fill()
    myDataTable.Rows(1).Delete()
    myDataTable.Update()
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Clear()
  End Try
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDataTable Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDataTable Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbDataTable Class

The following tables list the members exposed by DbDataTable.

Public Properties

 | Name | Description
public Property | Active | Gets or sets whether a DbDataTable is filled with data from a data source.
public Property | CachedUpdates | Enables or disables cached updates mode.
public Property | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from System.Data.DataTable)
public Property | ChildRelations | Gets the collection of child relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Columns | Gets the collection of columns that belong to this table.
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the DbDataTable.
public Property | Connection | Gets or sets the System.Data.IDbConnection used to connect to the data source.
public Property | Constraints | Gets the collection of constraints maintained by this table.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSet | Gets the System.Data.DataSet to which this table belongs. (Inherited from System.Data.DataTable)
public Property | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from System.Data.DataTable)
public Property | DeleteCommand | Gets or sets a SQL statement to delete records from the data set.
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
static (Shared in Visual Basic) | DisableListChangedEvents | Disables some of the events, which occurs when DbDataTable content is changed.
public Property | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from System.Data.DataTable)
public Property | ExtendedProperties | Gets the collection of customized user information. (Inherited from System.Data.DataTable)
public Property | FetchAll | Determines whether data is requested from server entirely or partially.
public Property | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the System.Data.DataSet to which the table belongs. (Inherited from System.Data.DataTable)
public Property | InsertCommand | Gets or sets a SQL statement to insert new records into the data source.
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataTable)
public Property | MaxRecords | Gets or sets max number of records to fetch starting from StartRecord.
public Property | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from System.Data.DataTable)
public Property | MissingSchemaAction | Determines the action to take when existing DataSet schema does not match incoming data.
public Property | Name | Gets or sets name of the component.
public Property | Namespace | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | NonBlocking | Gets or sets data request mode.
public Property | Owner | Gets or sets form that the component resides on.
public Property | ParentRelation | Gets or sets a ParentDataRelation object that is used for server side master-detail relation.
public Property | ParentRelations | Gets the collection of parent relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Prefix | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table.
public Property | QueryRecordCount | Determines whether DbDataTable should perfrom additional request to determine quantity of records in the result set.
public Property | Quoted | Gets or sets whether the DbDataTable quotes all the names of data source objects.
public Property | RecordCount | Gets number of rows in the result set.
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbDataTable should retrieve field values adjusted by server after an update.
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the DbDataTable used during remoting.
public Property | ReturnProviderSpecificTypes | Determines whether to use provider-specific types whenever possible.
public Property | Rows | Gets the collection of rows that belong to this table. (Inherited from System.Data.DataTable)
public Property | SchemaTable | Gets the schema table corresponding to the SelectCommand query.
public Property | SelectCommand | Gets or sets a SQL statement used to select records in the data source.
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | StartRecord | Gets or sets record number to start.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the Rows collection.
public Property | TableMapping | Gets a System.Data.Common.DataTableMapping that provides the master mapping between a source table and a DbDataTable.
public Property | TableName | Gets or sets the name of the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.
public Property | UpdateCommand | Gets or sets a SQL statement used to update records in the data source.
public Property | UpdatingFields | Gets or sets string containing list of field names used to generate update commands.
public Property | UpdatingKeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
Top

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this table since the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | BeginFill | Starts an asynchronous invocation of the Fill() method.
public Method | BeginInit | Begins the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | BeginLoadData | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from System.Data.DataTable)
public Method | CancelFetch | Stops asynchronous fill operation.
public Method | Clear | Clears DbDataTable and stops Fill operation.
public Method | Clone | Overridden. Clones the structure of the DbDataTable, including all System.Data.DataTable schemes and constraints.
public Method | Close | Disconnects DbDataTable from the data source and frees server resources allocated for the query.
public Method | Compute | Computes the given expression on the current rows that pass the filter criteria. (Inherited from System.Data.DataTable)
public Method | Copy | Copies both the structure and data for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | CreateDataReader | Returns a System.Data.DataTableReader corresponding to the data within this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndFill | Ends an asynchronous invocation of the Fill() method.
public Method | EndInit | Overridden. Ends the initialization of a DbDataTable that is used on a form or used by another component. The initialization occurs at run time.
public Method | EndLoadData | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from System.Data.DataTable)
public Method | Fill | Overloaded. Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source.
public Method | FillPage | Overloaded. Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.
public Method | FillSchema | Configures the schema to match that in the data source.
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataTable that contains all changes made to it since it was loaded or System.Data.DataTable.AcceptChanges was last called. (Inherited from System.Data.DataTable)
public Method | GetErrors | Gets an array of System.Data.DataRow objects that contain errors. (Inherited from System.Data.DataTable)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | ImportRow | Copies a System.Data.DataRow into a System.Data.DataTable, preserving any property settings, as well as original and current values. (Inherited from System.Data.DataTable)
public Method | Load | Overloaded. Fills a System.Data.DataTable with values from a data source using the supplied System.Data.IDataReader. If the System.Data.DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from System.Data.DataTable)
public Method | LoadDataRow | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from System.Data.DataTable)
public Method | Merge | Overloaded. Merge the specified System.Data.DataTable with the current System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | NewRow | Creates a new System.Data.DataRow with the same schema as the table. (Inherited from System.Data.DataTable)
public Method | Open | Fetches data and sets the Active property to true.
public Method | Read | Reads the next data row when DbDataTable operates in connected model.
public Method | ReadComplete | Fills a row with data not fetched in the initial fill operation.
public Method | ReadXml | Overloaded. Reads XML schema and data into the System.Data.DataTable using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | ReadXmlSchema | Overloaded. Reads an XML schema into the System.Data.DataTable using the specified stream. (Inherited from System.Data.DataTable)
public Method | RefreshRow | Refreshes the specified row with values from server.
public Method | RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | Reset | Resets the System.Data.DataTable to its original state. Reset removes all data, indexes, relations, and columns of the table. If a DataSet includes a DataTable, the table will still be part of the DataSet after the table is reset. (Inherited from System.Data.DataTable)
public Method | Select | Overloaded. Gets an array of DataRow objects.
public Method | SuspendFill | Overloaded. Suspends asynchronous fill operation.
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | UpdateRows | Executes the appropriate commands to delete, insert, or update the specified rows in the data source.
public Method | WriteXml | Overloaded. Writes the current contents of the System.Data.DataTable as XML using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | WriteXmlSchema | Overloaded. Writes the current data structure of the System.Data.DataTable as an XML schema to the specified stream. (Inherited from System.Data.DataTable)
Top

Public Events

 | Name | Description
public Event | ColumnChanged | Occurs after a value has been changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | ColumnChanging | Occurs when a value is being changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
public Event | FetchFinished | Occurs when a result set is completely fetched.
public Event | FillError | Occurs when an error is raised during a fill operation.
public Event | Initialized | Occurs after the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Event | RowChanged | Occurs after a System.Data.DataRow has been changed successfully. (Inherited from System.Data.DataTable)
public Event | RowChanging | Occurs when a System.Data.DataRow is changing. (Inherited from System.Data.DataTable)
public Event | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from System.Data.DataTable)
public Event | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from System.Data.DataTable)
public Event | RowFetched | Occurs when another row is completely fetched.
public Event | TableCleared | Occurs after a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableClearing | Occurs when a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableNewRow | Occurs when a new System.Data.DataRow is inserted. (Inherited from System.Data.DataTable)
Top

See Also

Reference

DbDataTable Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDataTable Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDataTable Class

For a list of all members of this type, see DbDataTable members.

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this table since the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | BeginFill | Starts an asynchronous invocation of the Fill() method.
public Method | BeginInit | Begins the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | BeginLoadData | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from System.Data.DataTable)
public Method | CancelFetch | Stops asynchronous fill operation.
public Method | Clear | Clears DbDataTable and stops Fill operation.
public Method | Clone | Overridden. Clones the structure of the DbDataTable, including all System.Data.DataTable schemes and constraints.
public Method | Close | Disconnects DbDataTable from the data source and frees server resources allocated for the query.
public Method | Compute | Computes the given expression on the current rows that pass the filter criteria. (Inherited from System.Data.DataTable)
public Method | Copy | Copies both the structure and data for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | CreateDataReader | Returns a System.Data.DataTableReader corresponding to the data within this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndFill | Ends an asynchronous invocation of the Fill() method.
public Method | EndInit | Overridden. Ends the initialization of a DbDataTable that is used on a form or used by another component. The initialization occurs at run time.
public Method | EndLoadData | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from System.Data.DataTable)
public Method | Fill | Overloaded. Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source.
public Method | FillPage | Overloaded. Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.
public Method | FillSchema | Configures the schema to match that in the data source.
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataTable that contains all changes made to it since it was loaded or System.Data.DataTable.AcceptChanges was last called. (Inherited from System.Data.DataTable)
public Method | GetErrors | Gets an array of System.Data.DataRow objects that contain errors. (Inherited from System.Data.DataTable)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | ImportRow | Copies a System.Data.DataRow into a System.Data.DataTable, preserving any property settings, as well as original and current values. (Inherited from System.Data.DataTable)
public Method | Load | Overloaded. Fills a System.Data.DataTable with values from a data source using the supplied System.Data.IDataReader. If the System.Data.DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from System.Data.DataTable)
public Method | LoadDataRow | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from System.Data.DataTable)
public Method | Merge | Overloaded. Merge the specified System.Data.DataTable with the current System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | NewRow | Creates a new System.Data.DataRow with the same schema as the table. (Inherited from System.Data.DataTable)
public Method | Open | Fetches data and sets the Active property to true.
public Method | Read | Reads the next data row when DbDataTable operates in connected model.
public Method | ReadComplete | Fills a row with data not fetched in the initial fill operation.
public Method | ReadXml | Overloaded. Reads XML schema and data into the System.Data.DataTable using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | ReadXmlSchema | Overloaded. Reads an XML schema into the System.Data.DataTable using the specified stream. (Inherited from System.Data.DataTable)
public Method | RefreshRow | Refreshes the specified row with values from server.
public Method | RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | Reset | Resets the System.Data.DataTable to its original state. Reset removes all data, indexes, relations, and columns of the table. If a DataSet includes a DataTable, the table will still be part of the DataSet after the table is reset. (Inherited from System.Data.DataTable)
public Method | Select | Overloaded. Gets an array of DataRow objects.
public Method | SuspendFill | Overloaded. Suspends asynchronous fill operation.
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | UpdateRows | Executes the appropriate commands to delete, insert, or update the specified rows in the data source.
public Method | WriteXml | Overloaded. Writes the current contents of the System.Data.DataTable as XML using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | WriteXmlSchema | Overloaded. Writes the current data structure of the System.Data.DataTable as an XML schema to the specified stream. (Inherited from System.Data.DataTable)
Top

See Also

Reference

DbDataTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginFill Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : BeginFill Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of the Fill() method.

Syntax

Visual Basic (Declaration)
Public Function BeginFill( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginFill(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

Refer to "Asynchronous Query Execution" topic for detailed information.

If the suspended fetch is stopped with EndFill method, the BeginFill method will start the fetch from the point where the fetch was stopped. To make BeginFill starting the query from the beginning, use the CancelFetch method.

Example

The following example demonstrates how to use the BeginFill method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  IAsyncResult aRes = myDataTable.BeginFill(null, null);

  Console.Write("Fetch in process");

  Thread.Sleep(100);
  myDataTable.SuspendFill(true);
  Console.Write("Fetch is stopped");

  myDataTable.EndFill(aRes);
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable3(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Dim result1 As IAsyncResult = myDataTable.BeginFill(Nothing, Nothing)
  Console.Write("Fetch in process")
  Thread.Sleep(100)
  myDataTable.SuspendFill(True)
  Console.Write("Fetch is stopped")
  myDataTable.EndFill(result1)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
EndFill Method
SuspendFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CancelFetch Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : CancelFetch Method

Stops asynchronous fill operation.

Syntax

Visual Basic (Declaration)
Public Sub CancelFetch()
C#
public void CancelFetch()

Remarks

This method cancels an asynchronous fill operation. Unlike Devart.Common.DbDataTable.SuspendFill, after you call this method there will be no way to read out the dataset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
BeginFill Method
SuspendFill Method
EndFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear() Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Clear() Method

Clears DbDataTable and stops Fill operation. Clears DbDataTable and stops Fill operation.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
C#
public new void Clear()

Remarks

This method clears all information except table schema and sets Active property to false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone() Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Clone() Method

Clones the structure of the DbDataTable, including all System.Data.DataTable schemes and constraints.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As DataTable
C#
public override DataTable Clone()

Return Value

A new DbDataTable with the same schema as the current DbDataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close() Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : Close() Method

Disconnects DbDataTable from the data source and frees server resources allocated for the query.

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()

Remarks

This method does not clear the data. To close the DbDataTable and free resources use the Clear method.

Example

The following example demonstrates how to use the Close() method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbCommand myCommand)
{
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  try
  {
    myDataTable.Open();
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Close();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myCommand As DbCommand)
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  Try
    myDataTable.Open()
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Active Property
Open Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndFill Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : EndFill Method

result
The System.IAsyncResult returned from BeginFill.
Ends an asynchronous invocation of the Fill() method.

Syntax

Visual Basic (Declaration)
Public Sub EndFill( _
   ByVal result As IAsyncResult _
)
C#
public void EndFill(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned from BeginFill.

Remarks

This method returns when the asynchronous fill operation is complete.

Refer to "Asynchronous Query Execution" topic for detailed information.

If the fetch is suspended by the Devart.Common.DbDataTable.SuspendFill method and then stopped by the EndFill method, the BeginFill method will start the fetch from the point where the fetch was stopped. To make BeginFill starting the query from the beginning, use the CancelFetch method.

Example

The following example demonstrates how to use the EndFill method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  IAsyncResult aRes = myDataTable.BeginFill(null, null);

  Console.Write("Fetch in process");

  Thread.Sleep(100);
  myDataTable.SuspendFill(true);
  Console.Write("Fetch is stopped");

  myDataTable.EndFill(aRes);
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable3(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Dim result1 As IAsyncResult = myDataTable.BeginFill(Nothing, Nothing)
  Console.Write("Fetch in process")
  Thread.Sleep(100)
  myDataTable.SuspendFill(True)
  Console.Write("Fetch is stopped")
  myDataTable.EndFill(result1)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
BeginFill Method
SuspendFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndInit Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : EndInit Method

Ends the initialization of a DbDataTable that is used on a form or used by another component. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Overrides Sub EndInit()
C#
public override void EndInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Fill Method

Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source.

Overload List

Overload | Description
Fill(Object[]) | Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source using the parameter values passed in parameterValues.
Fill() | Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill(Object[]) Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > Fill Method : Fill(Object[]) Method

parameterValues
Used to fill the Devart.Data.Oracle.OracleCommand.Parameters collection of the SelectCommand property.
Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source using the parameter values passed in parameterValues.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill( _
   ByVal parameterValues() As Object _
) As Integer
C#
public int Fill(
   object[] parameterValues
)

Parameters

parameterValues
Used to fill the Devart.Data.Oracle.OracleCommand.Parameters collection of the SelectCommand property.

Return Value

The number of rows successfully added to or refreshed in the DbDataTable. This does not include rows affected by statements that do not return rows.

Example

The following sample shows how to get data from a data source using Fill method with condition parameter value passed.
C#csharp Copy Code
public void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection, IDbDataParameter myParameter)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp WHERE DeptNo=:DeptNo";
  myParameter.ParameterName = "DeptNo";
  myDataTable.SelectCommand.Parameters.Add(myParameter);
  object[] myParamValue = new object[1];
  myParamValue[0] = 10;
  try
  {
    myDataTable.Fill(myParamValue);
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection, ByVal myParameter As IDbDataParameter)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp WHERE DeptNo=:DeptNo"
  myParameter.ParameterName = "DeptNo"
  myDataTable.SelectCommand.Parameters.Add(myParameter)
  Dim myParamValue() As Object = {10}
  Try
    myDataTable.Fill(myParamValue)
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill() Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > Fill Method : Fill() Method

Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill() As Integer
C#
public int Fill()

Return Value

The number of rows successfully added to or refreshed in the DbDataTable. This does not include rows affected by statements that do not return rows.

Example

The following sample shows how to get data from a data source using Fill method.
C#csharp Copy Code
static void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";
  try
  {
    myDataTable.Fill();
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear;
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Try
    myDataTable.Fill()
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Clear()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillPage Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : FillPage Method

Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.

Overload List

Overload | Description
FillPage(Int32,Int32) | Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.
FillPage(Int32,Int32,Object[]) | Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords using the parameter values passed in parameterValues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillPage(Int32,Int32) Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > FillPage Method : FillPage(Int32,Int32) Method

startRecord
The number of the first row to retrieve. Value 0 means the first row, 1 means the second, and so on.
maxRecords
The maximum number of records to retrieve.
Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.

Syntax

Visual Basic (Declaration)
Public Overloads Function FillPage( _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer _
) As Integer
C#
public int FillPage(
   int startRecord,
   int maxRecords
)

Parameters

startRecord
The number of the first row to retrieve. Value 0 means the first row, 1 means the second, and so on.
maxRecords
The maximum number of records to retrieve.

Return Value

The number of rows successfully added to or refreshed in the DbDataTable. This does not include rows affected by statements that do not return rows.

Remarks

This method clears any exisiting rows in the DbDataTable.

Example

This sample shows how to use paged access to data. It attempts to read rows 11 through 20 from the table and to display them. However, if quantity of records in the table is less than 20, only available rows will be filled into DbDataTable. Number of rows actually added is rendered to console.
C#csharp Copy Code
public void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp";
  try
  {
    Console.WriteLine(myDataTable.FillPage(10,10) + " rows filled.");
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp"
  Try
    Console.WriteLine(myDataTable.FillPage(10, 10) & " rows filled.")
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Clear()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillPage(Int32,Int32,Object[]) Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > FillPage Method : FillPage(Int32,Int32,Object[]) Method

startRecord
The number of the first row to retrieve. Value 0 means the first row, 1 means the second, and so on.
maxRecords
The maximum number of records to retrieve.
parameterValues
Used to fill the System.Data.IDbCommand.Parameters collection of the SelectCommand property.
Fills the System.Data.DataTable.Rows collection of the DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords using the parameter values passed in parameterValues.

Syntax

Visual Basic (Declaration)
Public Overloads Function FillPage( _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer, _
   ByVal parameterValues() As Object _
) As Integer
C#
public int FillPage(
   int startRecord,
   int maxRecords,
   object[] parameterValues
)

Parameters

startRecord
The number of the first row to retrieve. Value 0 means the first row, 1 means the second, and so on.
maxRecords
The maximum number of records to retrieve.
parameterValues
Used to fill the System.Data.IDbCommand.Parameters collection of the SelectCommand property.

Return Value

The number of rows successfully added to or refreshed in the DbDataTable. This does not include rows affected by statements that do not return rows.

Remarks

This method clears any exisiting rows in the DbDataTable.

Example

This sample shows how to use paged access to data. It attempts to read rows 3 through 12 from the table and to display them. However, if quantity of records that match condition in the table is less than 12, only available rows will be filled into DbDataTable. Number of rows actually added is rendered to console.
C#csharp Copy Code
public void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection, IDbDataParameter myParameter)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp WHERE DeptNo=:DeptNo";
  myParameter.ParameterName = "DeptNo";
  myDataTable.SelectCommand.Parameters.Add(myParameter);
  object[] myParamValue = new object[1];
  myParamValue[0] = 10;
  try
  {
    myDataTable.FillPage(2,10,myParamValue);
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection, ByVal myParameter As IDbDataParameter)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp WHERE DeptNo=:DeptNo"
  myParameter.ParameterName = "DeptNo"
  myDataTable.SelectCommand.Parameters.Add(myParameter)
  Dim myParamValue() As Object = {10}
  Try
    myDataTable.FillPage(2, 10, myParamValue)
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillSchema Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : FillSchema Method

Configures the schema to match that in the data source.

Syntax

Visual Basic (Declaration)
Public Sub FillSchema()
C#
public void FillSchema()

Remarks

Use this method when you need to retrieve structure of a table only, not the data.

The FillSchema method retrieves the schema from the data source using the SelectCommand. The connection object associated with the SelectCommand must be valid, but it does not need to be open. If the connection is closed before FillSchema is called, it is opened to retrieve data, then closed. If the connection is open before FillSchema is called, it remains open.

A FillSchema operation adds columns to the Columns collection of the DbDataTable, and configures DataColumn properties if they exist at the data source. FillSchema also configures the Constraints property.

FillSchema does not return any rows. Use the Fill, FillPage, or Open methods to add rows to a DbDataTable.

For more detailed information, refer to topic System.Data.Common.DataAdapter.FillSchema.

Example

The following example demonstrates how to use the FillSchema property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  myDataTable.FillSchema();
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.FillSchema()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Fill Method
Open Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open() Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : Open() Method

Fetches data and sets the Active property to true.

Syntax

Visual Basic (Declaration)
Public Sub Open()
C#
public void Open()

Remarks

The Open method executes the SelectCommand, creates columns and fills rows with data. Depending on values of miscellaneous properties, DbDataTable fetches either all data or some subset. For example, when DbDataTable is connected to a grid, it requests only data required for rendering (Devart.Common.DbDataTable.FetchAll=false mode), or the whole recordset (Devart.Common.DbDataTable.FetchAll=true mode).

For more information about DbDataTable fill capabilities please refer to descriptions of the following properties: Devart.Common.DbDataTable.FetchAll, MaxRecords, NonBlocking, DbDataTable.QueryRecordCount, ReturnProviderSpecificTypes, StartRecord. The following methods also provide additional features: BeginFill, FillPage, FillSchema.

Example

The following example demonstrates how to use the Open() method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbCommand myCommand)
{
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  try
  {
        myDataTable.FetchAll=true;
    myDataTable.Open();
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Close();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myCommand As DbCommand)
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  Try
        myDataTable.FetchAll=True
    myDataTable.Open()
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Active Property
Fill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Read Method

Reads the next data row when DbDataTable operates in connected model.

Syntax

Visual Basic (Declaration)
Public Function Read() As Boolean
C#
public bool Read()

Return Value

true if there are more rows; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
FetchAll Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadComplete Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : ReadComplete Method

row
Row to read out.
Fills a row with data not fetched in the initial fill operation.

Syntax

Visual Basic (Declaration)
Public Sub ReadComplete( _
   ByVal row As DataRow _
)
C#
public void ReadComplete(
   DataRow row
)

Parameters

row
Row to read out.

Remarks

This method is designed to optimize working with LOBs and other big-size server types. It allows you to execute initial fill with only a subset of fields (e.g. all except LOBs). Then you can can create missing columns manually and call ReadComplete for the row you want to get data for.

Example

The following example demonstrates how to use the ReadComplete property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT DEPTNO FROM Test.Dept";

  System.Data.DataColumn column_DEPTNO = new System.Data.DataColumn();
  System.Data.DataColumn column_DNAME = new System.Data.DataColumn();
  System.Data.DataColumn column_LOC = new System.Data.DataColumn();
  column_DEPTNO.ColumnName = "DEPTNO";
  column_DEPTNO.DataType = typeof(int);
  column_LOC.ColumnName = "LOC";
  column_DEPTNO.DataType = typeof(string);
  myDataTable.Columns.AddRange(new System.Data.DataColumn[] {column_DEPTNO, column_DNAME, column_LOC});

  myDataTable.FetchAll = true;
  myDataTable.Open();

  Console.Write("DEPTNO column is loaded");

  myDataTable.ReadComplete(myDataTable.Rows[0]);

  Console.Write("DEPTNO and LOC columns are loaded");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT DEPTNO FROM Test.Dept"
  Dim column1 As New DataColumn
  Dim column2 As New DataColumn
  Dim column3 As New DataColumn
  column1.ColumnName = "DEPTNO"
  column1.DataType = GetType(Integer)
  column3.ColumnName = "LOC"
  column1.DataType = GetType(String)
  myDataTable.Columns.AddRange(New DataColumn() {column1, column2, column3})
  myDataTable.FetchAll = True
  myDataTable.Open()
  Console.Write("DEPTNO column is loaded")
  myDataTable.ReadComplete(myDataTable.Rows.Item(0))
  Console.Write("DEPTNO and LOC columns are loaded")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshRow(DataRow) Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : RefreshRow(DataRow) Method

row
The row to refresh.
Refreshes the specified row with values from server.

Syntax

Visual Basic (Declaration)
Public Sub RefreshRow( _
   ByVal row As DataRow _
)
C#
public void RefreshRow(
   DataRow row
)

Parameters

row
The row to refresh.

Remarks

DbDataTable uses primary key fields to find the row on the server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
PrimaryKey Property
RefreshMode Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Select Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Select Method

Gets an array of DataRow objects.

Overload List

Overload | Description
Select() | Gets an array of all DataRow objects.
Select(String) | Gets an array of all DataRow objects that match the filter criteria.
Select(String,String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
Select(String,String,DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Select() Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class > Select Method : Select() Method

Gets an array of all DataRow objects.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function Select() As DataRow()
C#
public new DataRow[] Select()

Return Value

An array of DataRow objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Select(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class > Select Method : Select(String) Method

filterExpression
The criteria to use to filter the rows.
Gets an array of all DataRow objects that match the filter criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function Select( _
   ByVal filterExpression As String _
) As DataRow()
C#
public new DataRow[] Select(
   string filterExpression
)

Parameters

filterExpression
The criteria to use to filter the rows.

Return Value

An array of DataRow objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Select(String,String) Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class > Select Method : Select(String,String) Method

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.
Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function Select( _
   ByVal filterExpression As String, _
   ByVal sort As String _
) As DataRow()
C#
public new DataRow[] Select(
   string filterExpression,
   string sort
)

Parameters

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.

Return Value

An array of DataRow objects matching the filter expression.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Select(String,String,DataViewRowState) Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class > Select Method : Select(String,String,DataViewRowState) Method

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.
recordStates
One of the DataViewRowState values.
Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function Select( _
   ByVal filterExpression As String, _
   ByVal sort As String, _
   ByVal recordStates As DataViewRowState _
) As DataRow()
C#
public new DataRow[] Select(
   string filterExpression,
   string sort,
   DataViewRowState recordStates
)

Parameters

filterExpression
The criteria to use to filter the rows.
sort
A string specifying the column and sort direction.
recordStates
One of the DataViewRowState values.

Return Value

An array of DataRow objects matching the filter expression.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SuspendFill Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : SuspendFill Method

Suspends asynchronous fill operation.

Overload List

Overload | Description
SuspendFill() | Suspends asynchronous fill operation.
SuspendFill(Boolean) | Suspends asynchronous fill operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SuspendFill() Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > SuspendFill Method : SuspendFill() Method

Suspends asynchronous fill operation.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SuspendFill()
C#
public void SuspendFill()

Remarks

The fill operation can be resumed later with BeginFill and EndFill methods.

Example

The following example demonstrates how to use the SuspendFill() method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  IAsyncResult aRes = myDataTable.BeginFill(null, null);

  Console.Write("Fetch in process");

  Thread.Sleep(100);
  myDataTable.SuspendFill(true);
  Console.Write("Fetch is stopped");

  myDataTable.EndFill(aRes);
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable3(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Dim result1 As IAsyncResult = myDataTable.BeginFill(Nothing, Nothing)
  Console.Write("Fetch in process")
  Thread.Sleep(100)
  myDataTable.SuspendFill(True)
  Console.Write("Fetch is stopped")
  myDataTable.EndFill(result1)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List
BeginFill Method
EndFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SuspendFill(Boolean) Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class > SuspendFill Method : SuspendFill(Boolean) Method

wait
Determines whether to wait for break operation. If false, the method returns before the fill operation is actually suspended.
Suspends asynchronous fill operation.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SuspendFill( _
   ByVal wait As Boolean _
)
C#
public void SuspendFill(
   bool wait
)

Parameters

wait
Determines whether to wait for break operation. If false, the method returns before the fill operation is actually suspended.

Remarks

The fill operation can be resumed later with BeginFill and EndFill methods.

Example

The following example demonstrates how to use the SuspendFill(Boolean) method.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  IAsyncResult aRes = myDataTable.BeginFill(null, null);

  Console.Write("Fetch in process");

  Thread.Sleep(100);
  myDataTable.SuspendFill(true);
  Console.Write("Fetch is stopped");

  myDataTable.EndFill(aRes);
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable3(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  Dim result1 As IAsyncResult = myDataTable.BeginFill(Nothing, Nothing)
  Console.Write("Fetch in process")
  Thread.Sleep(100)
  myDataTable.SuspendFill(True)
  Console.Write("Fetch is stopped")
  myDataTable.EndFill(result1)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Overload List
BeginFill Method
EndFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Update() Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Update() Method

Executes the appropriate commands to delete, insert, or update rows in the data source.

Syntax

Visual Basic (Declaration)
Public Overridable Function Update() As Integer
C#
public virtual int Update()

Return Value

The number of rows successfully updated from the DbDataTable.

Remarks

If the CachedUpdates property is true, this method applies all updates made to the DbDataTable. If the CachedUpdates property is false, the method does nothing, because changes are applied instantly.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
UpdateRows Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateRows Method
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdateRows Method

datarows
An array of System.Data.DataRow objects containing the rows to be updated.
Executes the appropriate commands to delete, insert, or update the specified rows in the data source.

Syntax

Visual Basic (Declaration)
Public Function UpdateRows( _
   ByVal datarows() As DataRow _
) As Integer
C#
public int UpdateRows(
   DataRow[] datarows
)

Parameters

datarows
An array of System.Data.DataRow objects containing the rows to be updated.

Return Value

The number of rows successfully updated from the DbDataTable.

Remarks

Using this method may result in performance gains, for example, on very big tables. If the CachedUpdates property is false, the method does nothing, because changes are applied instantly.

Example

The following code adds two records to a table and updates them. The table is rendered then to console.
C#csharp Copy Code
static void UpdateATable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp";
  try
  {
    myDataTable.Active = true;
    DataRow[] newRows = new DataRow[2];
    newRows[0] = myDataTable.Rows.Add(new object[] {20000,"Jefferson"});
    newRows[1] = myDataTable.Rows.Add(new object[] {20001,"Jameson"});
    myDataTable.UpdateRows(newRows);

    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UpdateATable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand()
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp"
  Try
    myDataTable.Active = True
    Dim newVal1() As Object = {20000, "Jefferson"}
    Dim newVal2() As Object = {20001, "Jameson"}
    Dim newRows(1) As DataRow
    newRows(0) = myDataTable.Rows.Add(newVal1)
    newRows(1) = myDataTable.Rows.Add(newVal2)
    myDataTable.UpdateRows(newRows)

    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
Update Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbDataTable Class Properties
See Also support@devart.com
Devart.Common Namespace : DbDataTable Class

For a list of all members of this type, see DbDataTable members.

Public Properties

 | Name | Description
public Property | Active | Gets or sets whether a DbDataTable is filled with data from a data source.
public Property | CachedUpdates | Enables or disables cached updates mode.
public Property | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from System.Data.DataTable)
public Property | ChildRelations | Gets the collection of child relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Columns | Gets the collection of columns that belong to this table.
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the DbDataTable.
public Property | Connection | Gets or sets the System.Data.IDbConnection used to connect to the data source.
public Property | Constraints | Gets the collection of constraints maintained by this table.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSet | Gets the System.Data.DataSet to which this table belongs. (Inherited from System.Data.DataTable)
public Property | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from System.Data.DataTable)
public Property | DeleteCommand | Gets or sets a SQL statement to delete records from the data set.
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
static (Shared in Visual Basic) | DisableListChangedEvents | Disables some of the events, which occurs when DbDataTable content is changed.
public Property | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from System.Data.DataTable)
public Property | ExtendedProperties | Gets the collection of customized user information. (Inherited from System.Data.DataTable)
public Property | FetchAll | Determines whether data is requested from server entirely or partially.
public Property | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the System.Data.DataSet to which the table belongs. (Inherited from System.Data.DataTable)
public Property | InsertCommand | Gets or sets a SQL statement to insert new records into the data source.
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataTable)
public Property | MaxRecords | Gets or sets max number of records to fetch starting from StartRecord.
public Property | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from System.Data.DataTable)
public Property | MissingSchemaAction | Determines the action to take when existing DataSet schema does not match incoming data.
public Property | Name | Gets or sets name of the component.
public Property | Namespace | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | NonBlocking | Gets or sets data request mode.
public Property | Owner | Gets or sets form that the component resides on.
public Property | ParentRelation | Gets or sets a ParentDataRelation object that is used for server side master-detail relation.
public Property | ParentRelations | Gets the collection of parent relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Prefix | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table.
public Property | QueryRecordCount | Determines whether DbDataTable should perfrom additional request to determine quantity of records in the result set.
public Property | Quoted | Gets or sets whether the DbDataTable quotes all the names of data source objects.
public Property | RecordCount | Gets number of rows in the result set.
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the DbDataTable should retrieve field values adjusted by server after an update.
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the DbDataTable used during remoting.
public Property | ReturnProviderSpecificTypes | Determines whether to use provider-specific types whenever possible.
public Property | Rows | Gets the collection of rows that belong to this table. (Inherited from System.Data.DataTable)
public Property | SchemaTable | Gets the schema table corresponding to the SelectCommand query.
public Property | SelectCommand | Gets or sets a SQL statement used to select records in the data source.
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | StartRecord | Gets or sets record number to start.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the Rows collection.
public Property | TableMapping | Gets a System.Data.Common.DataTableMapping that provides the master mapping between a source table and a DbDataTable.
public Property | TableName | Gets or sets the name of the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.
public Property | UpdateCommand | Gets or sets a SQL statement used to update records in the data source.
public Property | UpdatingFields | Gets or sets string containing list of field names used to generate update commands.
public Property | UpdatingKeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
Top

See Also

Reference

DbDataTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Active Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : Active Property

Gets or sets whether a DbDataTable is filled with data from a data source.

Syntax

Visual Basic (Declaration)
Public Property Active As Boolean
C#
public bool Active {get; set;}

Property Value

true if a DbDataTable is populated with data from a data source; otherwise, false. The default value is false.

Remarks

Set Active property to true to populate the DbDataTable with the data returned from executing SelectCommand. Setting the property to false clears the data and frees the resources allocated on the server, if any.

Example

This sample shows how to use DbDataTable. The routine accepts DbTable-compatible object and IDbCommand implementor object as parameters. After SQL query text has been set the data is retrieved from the table.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbCommand myCommand)
{
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  try
  {
        myDataTable.FetchAll = true;
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myCommand As DbCommand)
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  Try
        myDataTable.FetchAll = True
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
SelectCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CachedUpdates Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : CachedUpdates Property

Enables or disables cached updates mode.

Syntax

Visual Basic (Declaration)
Public Property CachedUpdates As Boolean
C#
public bool CachedUpdates {get; set;}

Property Value

If true, the changes made to DbDataTable are not sent to server until the Update() method is invoked. If false, the Update() method is automatically called once a row finishes editing in a visual component.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Columns Property

Gets the collection of columns that belong to this table.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Columns As DataColumnCollection
C#
public new DataColumnCollection Columns {get;}

Property Value

A System.Data.DataColumnCollection that contains the collection of System.Data.DataColumn objects for the table; otherwise, a null value if no System.Data.DataColumn objects exist.

This property is read-only.

Remarks

The System.Data.DataColumnCollection determines the schema of a table by defining the data type of each column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConflictOption Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : ConflictOption Property

Specifies which System.Data.ConflictOption is to be used by the DbDataTable.

Syntax

Visual Basic (Declaration)
Public Overridable Property ConflictOption As ConflictOption
C#
public virtual ConflictOption ConflictOption {get; set;}

Property Value

One of the System.Data.ConflictOption values describing the behavior of this DbDataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : Connection Property

Gets or sets the System.Data.IDbConnection used to connect to the data source.

Syntax

Visual Basic (Declaration)
Public Property Connection As DbConnection
C#
public DbConnection Connection {get; set;}

Property Value

An System.Data.IDbConnection object which provides a connection to the data source.

Remarks

This property is used by DeleteCommand, InsertCommand, SelectCommand, and UpdateCommand, in case when these properties do not have own created connection.

Example

This sample shows how to use DbDataTable. The routine accepts DbTable-compatible object, IDbCommand implementor object, and IDbConnection implementor object as parameters. After SQL query text has been set the data is retrieved from the table.
C#csharp Copy Code
public void UseDataTable(DbDataTable myDataTable, DbCommand myCommand, DbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myCommand As DbCommand, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Constraints Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Constraints Property

Gets the collection of constraints maintained by this table.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Constraints As ConstraintCollection
C#
public new ConstraintCollection Constraints {get;}

Property Value

A System.Data.ConstraintCollection that contains the collection of System.Data.Constraint objects for the table; otherwise, a null value if no System.Data.Constraint objects exist.

This property is read-only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteCommand Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : DeleteCommand Property

Gets or sets a SQL statement to delete records from the data set.

Syntax

Visual Basic (Declaration)
Public Property DeleteCommand As DbCommand
C#
public DbCommand DeleteCommand {get; set;}

Property Value

An System.Data.IDbCommand used during an update operation to delete records in the data source that correspond to deleted rows in the System.Data.DataSet.

Remarks

DeleteCommand uses its own Connection if it is created. Otherwise DeleteCommand uses Connection property.

If the DeleteCommand property is not set, DbDataTable generates necessary SQL statements automatically.

Example

Refer to help on types that derive from DbDataTable for samples on usage of this property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
InsertCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DisableListChangedEvents Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : DisableListChangedEvents Property

Disables some of the events, which occurs when DbDataTable content is changed.

Syntax

Visual Basic (Declaration)
Public Shared Property DisableListChangedEvents As Boolean
C#
public static bool DisableListChangedEvents {get; set;}

Remarks

It is not recommended to set this property to true when using DbDataTable with System.Windows.Forms.DataGridView control, but it can improve data fetching performance for some third-party components, such as DevExpress grid control.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FetchAll Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : FetchAll Property

Determines whether data is requested from server entirely or partially.

Syntax

Visual Basic (Declaration)
Public Overridable Property FetchAll As Boolean
C#
public virtual bool FetchAll {get; set;}

Property Value

If true, the data is requested when the DbDataTable is opened, otherwise records are fetched only when necessary. The default value is false.

Remarks

The Devart.Common.DbDataTable.FetchAll property allows you to optimize application behavior depending on circumstances. For example, consider a situation when user requests large amount of data to be displayed in a grid. When Devart.Common.DbDataTable.FetchAll is true, the whole dataset is retrieved from server at once, and while navigating through the dataset no server roundtrips are necessary. Thus application less depends on network speed and stability. When Devart.Common.DbDataTable.FetchAll is false, only minimal quantity of rows is requested at once, which leads to better initial response time and less network traffic.

Note that when Devart.Common.DbDataTable.FetchAll is true, fill operations can be asynchronous. Refer to NonBlocking property for more information.

When Devart.Common.DbDataTable.FetchAll is false, it could be useful to determine rows quantity with the DbDataTable.QueryRecordCount property.

Example

The following example demonstrates how to use the Devart.Common.DbDataTable.FetchAll property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection, DataGrid dataGrid) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.FetchAll = true;
  myDataTable.CachedUpdates = false;
  myDataTable.Active = true;
  dataGrid.DataSource = myDataTable;
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection, ByVal dataGrid As DataGrid)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.FetchAll = True
  myDataTable.CachedUpdates = False
  myDataTable.Active = True
  dataGrid.DataSource = myDataTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
NonBlocking Property
QueryRecordCount Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertCommand Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : InsertCommand Property

Gets or sets a SQL statement to insert new records into the data source.

Syntax

Visual Basic (Declaration)
Public Property InsertCommand As DbCommand
C#
public DbCommand InsertCommand {get; set;}

Property Value

An System.Data.IDbCommand used during an update operation to insert records in the data source that correspond to new rows in the System.Data.DataTable.

Remarks

InsertCommand uses its own Connection if it is created. Otherwise InsertCommand uses Connection property.

If the InsertCommand property is not set, DbDataTable generates necessary SQL statements automatically.

Example

Refer to help on types that derive from DbDataTable for samples on usage of this property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
DeleteCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxRecords Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : MaxRecords Property

Gets or sets max number of records to fetch starting from StartRecord.

Syntax

Visual Basic (Declaration)
Public Property MaxRecords As Integer
C#
public int MaxRecords {get; set;}

Property Value

Max number of records to fetch starting from StartRecord.

Remarks

StartRecord and MaxRecords take effect only when DbDataTable is opened using the Active property or the Open method.

Another way to access only a subset of rows is to use FillPage method.

Assigning a value to this property invokes the fill operation.

Example

This sample shows how to access only a part of dataset returned by a query.
C#csharp Copy Code
static void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp";
  myDataTable.StartRecord = 0;
  myDataTable.MaxRecords = 10;
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  Try
    myDataTable.Connection = myConnection
    myDataTable.SelectCommand = myConnection.CreateCommand()
    myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp"
    myDataTable.StartRecord = 0
    myDataTable.MaxRecords = 10
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Clear()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
StartRecord Property
Active Property
FillPage Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MissingSchemaAction Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : MissingSchemaAction Property

Determines the action to take when existing DataSet schema does not match incoming data.

Syntax

Visual Basic (Declaration)
Public Property MissingSchemaAction As MissingSchemaAction
C#
public MissingSchemaAction MissingSchemaAction {get; set;}

Property Value

One of the System.Data.MissingSchemaAction values.

Remarks

The default value is AddWithKey.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Name Property

Gets or sets name of the component.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

Name of the component

Remarks

This name is used for cross-form referencing the component.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NonBlocking Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : NonBlocking Property

Gets or sets data request mode.

Syntax

Visual Basic (Declaration)
Public Property NonBlocking As Boolean
C#
public bool NonBlocking {get; set;}

Property Value

If this property is true, true, and the Devart.Common.DbDataTable.FetchAll property is true also, the data is requested asynchronously.

Remarks

When Devart.Common.DbDataTable.FetchAll property is false, the NonBlocking property is ignored. When both Devart.Common.DbDataTable.FetchAll and NonBlocking properties are true, the fill operation is performed asynchronously, and you can use Devart.Common.DbDataTable.SuspendFill, EndFill, and other asynchronous methods.

Example

The following example demonstrates how to use the NonBlocking property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.NonBlocking = true;
  myDataTable.Active = true;

  while ( true ) {
    Thread.Sleep(100);
    bool isFetching = !System.Threading.Monitor.TryEnter(myDataTable.SyncRoot, 0);
    if (!isFetching)
      System.Threading.Monitor.Exit(myDataTable.SyncRoot);
    else
      break;
    Console.Write("Fetch in process");
  }
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.NonBlocking = True
  myDataTable.Active = True
  Do While True
    Thread.Sleep(100)
    If Not Monitor.TryEnter(myDataTable.SyncRoot, 0) Then
      Console.Write("All records are fetched")
      Return
    End If
    Monitor.Exit(myDataTable.SyncRoot)
    Console.Write("Fetch in process")
  Loop
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
FetchAll Property
SuspendFill Method
EndFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Owner Property

Gets or sets form that the component resides on.

Syntax

Visual Basic (Declaration)
Public Property Owner As Object
C#
public object Owner {get; set;}

Property Value

The form that the component resides on.

Remarks

This property is used for cross-form referencing and server side master-detail relationship.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentRelation Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : ParentRelation Property

Gets or sets a ParentDataRelation object that is used for server side master-detail relation.

Syntax

Visual Basic (Declaration)
Public Property ParentRelation As ParentDataRelation
C#
public ParentDataRelation ParentRelation {get; set;}

Property Value

A ParentDataRelation object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PrimaryKey Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : PrimaryKey Property

Gets or sets an array of columns that function as primary keys for the data table.

Syntax

Visual Basic (Declaration)
Public Shadows Property PrimaryKey As DataColumn()
C#
public new DataColumn[] PrimaryKey {get; set;}

Property Value

An array of System.Data.DataColumn objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueryRecordCount Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : QueryRecordCount Property

Determines whether DbDataTable should perfrom additional request to determine quantity of records in the result set.

Syntax

Visual Basic (Declaration)
Public Property QueryRecordCount As Boolean
C#
public bool QueryRecordCount {get; set;}

Property Value

If true, an additional request to server is executed, and the RecordCount is updated.

Remarks

The SQL statement for obtaining the record count is generated basing on the SelectCommand object. This property can be used when Devart.Common.DbDataTable.FetchAll is false, otherwise it is useless.

Example

The following example demonstrates how to use the DbDataTable.QueryRecordCount property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  myDataTable.QueryRecordCount = false;
  myDataTable.Active = true;
  int count = myDataTable.RecordCount; //the number of currently fetched rows
  myDataTable.Active = false;

  myDataTable.QueryRecordCount = true;
  myDataTable.Active = true;
  count = myDataTable.RecordCount; //the real number of rows in the table
  myDataTable.Active = false;
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable5(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.QueryRecordCount = False

  myDataTable.Active = True
  Dim num1 As Integer = myDataTable.RecordCount 'the number of currently fetched rows

  myDataTable.Active = False
  myDataTable.QueryRecordCount = True

  myDataTable.Active = True
  num1 = myDataTable.RecordCount 'the real number of rows in the table

  myDataTable.Active = False
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
RecordCount Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Quoted Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : Quoted Property

Gets or sets whether the DbDataTable quotes all the names of data source objects.

Syntax

Visual Basic (Declaration)
Public Property Quoted As Boolean
C#
public bool Quoted {get; set;}

Property Value

true if the DbDataTable will quote all the names of data source objects; otherwise, false. The default value is false.

Remarks

Names of data source objects can contain any characters, including spaces, commas, national or lowercase characters. To accommodate this, use the Quoted property that allows enclosing of all objects names by quotation mark in generated SQL statements.

Example

The following example demonstrates how to use the Quoted property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM \"DeptMixedCase\"";
  myDataTable.Quoted = true;
  myDataTable.FetchAll = true;
  myDataTable.CachedUpdates = false;
  myDataTable.Open();
  DataRow row = myDataTable.Rows[0];
  row[myDataTable.Columns["DNAME"]] = "Departament1";
  myDataTable.Update();
  myDataTable.Close();
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM ""DeptMixedCase"""
  myDataTable.Quoted = True
  myDataTable.FetchAll = True
  myDataTable.CachedUpdates = False
  myDataTable.Open()
  Dim row1 As DataRow = myDataTable.Rows.Item(0)
  row1.Item(myDataTable.Columns.Item("DNAME")) = "Departament1"
  myDataTable.Update()
  myDataTable.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecordCount Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : RecordCount Property

Gets number of rows in the result set.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordCount As Integer
C#
public int RecordCount {get;}

Property Value

Number of rows in the result set. Meaning of this value depends on the DbDataTable.QueryRecordCount property.

Remarks

If the DbDataTable.QueryRecordCount property is true, the RecordCount property represents number of rows in the current result set. If the DbDataTable.QueryRecordCount property is false, it is number of fetched rows.

Example

The following example demonstrates how to use the RecordCount property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  myDataTable.QueryRecordCount = false;
  myDataTable.Active = true;
  int count = myDataTable.RecordCount; //the number of currently fetched rows
  myDataTable.Active = false;

  myDataTable.QueryRecordCount = true;
  myDataTable.Active = true;
  count = myDataTable.RecordCount; //the real number of rows in the table
  myDataTable.Active = false;
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable5(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.QueryRecordCount = False

  myDataTable.Active = True
  Dim num1 As Integer = myDataTable.RecordCount 'the number of currently fetched rows

  myDataTable.Active = False
  myDataTable.QueryRecordCount = True

  myDataTable.Active = True
  num1 = myDataTable.RecordCount 'the real number of rows in the table

  myDataTable.Active = False
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
QueryRecordCount Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshingFields Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : RefreshingFields Property

Gets or sets list of fields whose values should be retrieved after a DML statement execution.

Syntax

Visual Basic (Declaration)
Public Property RefreshingFields As String
C#
public string RefreshingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Remarks

This property is used in conjunction with Devart.Common.DbDataTable.RefreshMode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
RefreshRow(DataRow) Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshMode Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : RefreshMode Property

Gets or sets a value that indicates whether and how the DbDataTable should retrieve field values adjusted by server after an update.

Syntax

Visual Basic (Declaration)
Public Property RefreshMode As RefreshRowMode
C#
public RefreshRowMode RefreshMode {get; set;}

Property Value

One of the RefreshRowMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
RefreshingFields Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemotingFormat Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : RemotingFormat Property

Gets or sets a System.Data.SerializationFormat for the DbDataTable used during remoting.

Syntax

Visual Basic (Declaration)
Public Shadows Property RemotingFormat As SerializationFormat
C#
public new SerializationFormat RemotingFormat {get; set;}

Property Value

A System.Data.SerializationFormat object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReturnProviderSpecificTypes Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : ReturnProviderSpecificTypes Property

Determines whether to use provider-specific types whenever possible.

Syntax

Visual Basic (Declaration)
Public Property ReturnProviderSpecificTypes As Boolean
C#
public bool ReturnProviderSpecificTypes {get; set;}

Property Value

If true, DbDataTable uses the DbDataReaderBase.GetProviderSpecificFieldType and DbDataReaderBase.GetProviderSpecificValue methods to retrieve data from server.

Remarks

The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchemaTable Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : SchemaTable Property

Gets the schema table corresponding to the SelectCommand query.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaTable As DataTable
C#
public DataTable SchemaTable {get;}

Property Value

The schema table corresponding to the SelectCommand query.

Remarks

This property is available after executing Open, Fill, or FillPage.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectCommand Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : SelectCommand Property

Gets or sets a SQL statement used to select records in the data source.

Syntax

Visual Basic (Declaration)
Public Property SelectCommand As DbCommand
C#
public DbCommand SelectCommand {get; set;}

Property Value

An System.Data.IDbCommand that is used during a fill operation to select records from the data source for placement in the DbDataTable.

Remarks

SelectCommand uses its own Connection if it is created. Otherwise SelectCommand uses Connection property.

If the SelectCommand property is not set, DbDataTable generates necessary SQL statements automatically.

Example

This sample shows how to use DbDataTable. The routine accepts DbDataTable-compatible object, IDbCommand implementor object, and IDbConnection implementor object as parameters. After SQL query text has been set the data is retrieved from the table.
C#csharp Copy Code
public void UseDataTable(DbDataTable myDataTable, DbCommand myCommand, DbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myCommand.CommandText = "SELECT * FROM Test.Dept";
  myDataTable.SelectCommand = myCommand;
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myCommand As DbCommand, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myCommand.CommandText = "SELECT * FROM Test.Dept"
  myDataTable.SelectCommand = myCommand
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
DeleteCommand Property
InsertCommand Property
UpdateCommand Property
QueryRecordCount Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartRecord Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : StartRecord Property

Gets or sets record number to start.

Syntax

Visual Basic (Declaration)
Public Property StartRecord As Integer
C#
public int StartRecord {get; set;}

Property Value

Record number to start. Value 0 means the first row, 1 means the second, and so on.

Remarks

StartRecord and MaxRecords take effect only when DbDataTable is opened using the Active property or the Open method.

Another way to access only a subset of rows is to use FillPage method.

Assigning a value to this property invokes the fill operation.

Example

This sample shows how to access only a part of dataset returned by a query.
C#csharp Copy Code
static void FillDataTable(DbDataTable myDataTable, IDbConnection myConnection)
{
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp";
  myDataTable.StartRecord = 0;
  myDataTable.MaxRecords = 10;
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Clear();
  }
}
C#Visual Basic Copy Code
Public Sub FillDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As IDbConnection)
  Try
    myDataTable.Connection = myConnection
    myDataTable.SelectCommand = myConnection.CreateCommand()
    myDataTable.SelectCommand.CommandText = "SELECT EmpNo, EName FROM Test.Emp"
    myDataTable.StartRecord = 0
    myDataTable.MaxRecords = 10
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Clear()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
MaxRecords Property
Active Property
FillPage Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncRoot Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : SyncRoot Property

Gets an object that can be used to synchronize access to the Rows collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

A synchronization object.

Remarks

DbDataTable uses the SyncRoot object during some fill operations. You can use this object to check if the operation is still in progress.

Example

The following example demonstrates how to use the SyncRoot property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept";
  myDataTable.NonBlocking = true;
  myDataTable.Active = true;

  while ( true ) {
    Thread.Sleep(100);
    bool isFetching = !System.Threading.Monitor.TryEnter(myDataTable.SyncRoot, 0);
    if (!isFetching)
      System.Threading.Monitor.Exit(myDataTable.SyncRoot);
    else
      break;
    Console.Write("Fetch in process");
  }
  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Dept"
  myDataTable.NonBlocking = True
  myDataTable.Active = True
  Do While True
    Thread.Sleep(100)
    If Not Monitor.TryEnter(myDataTable.SyncRoot, 0) Then
      Console.Write("All records are fetched")
      Return
    End If
    Monitor.Exit(myDataTable.SyncRoot)
    Console.Write("Fetch in process")
  Loop
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableMapping Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : TableMapping Property

Gets a System.Data.Common.DataTableMapping that provides the master mapping between a source table and a DbDataTable.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableMapping As DataTableMapping
C#
public DataTableMapping TableMapping {get;}

Property Value

A System.Data.Common.DataTableMapping that provides the master mapping between a source table and a DbDataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateBatchSize Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdateBatchSize Property

Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.

Syntax

Visual Basic (Declaration)
Public Property UpdateBatchSize As Integer
C#
public int UpdateBatchSize {get; set;}

Property Value

The number of rows to process per batch. If 0, there is no limit on the batch size. If 1, batch updating is disabled. If more than 1, determines the amount of operations sent at once.

Remarks

Use the UpdateBatchSize property to update a data source with changes from a DbDataSet. This can increase application performance by reducing the number of round-trips to the server. However, executing an extremely large batch could decrease performance. You should test for the optimum batch size setting before implementing your application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateCommand Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdateCommand Property

Gets or sets a SQL statement used to update records in the data source.

Syntax

Visual Basic (Declaration)
Public Property UpdateCommand As DbCommand
C#
public DbCommand UpdateCommand {get; set;}

Property Value

An System.Data.IDbCommand used during an update operation to update records in the data source that correspond to modified rows in the DbDataTable.

Remarks

UpdateCommand uses its own Connection if it is created. Otherwise UpdateCommand uses Connection property.

If the UpdateCommand property is not set, DbDataTable generates necessary SQL statements automatically.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
DeleteCommand Property
InsertCommand Property
SelectCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingFields Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdatingFields Property

Gets or sets string containing list of field names used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Property UpdatingFields As String
C#
public string UpdatingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Example

The following example demonstrates how to use the UpdatingFields property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT e.EMPNO, e.ENAME, e.JOB, d.DNAME
        FROM Test.Dept d, Test.Emp e
        where d.Deptno = e.Deptno";

  myDataTable.FetchAll = true;
  myDataTable.CachedUpdates = false;
  myDataTable.UpdatingTable = "Test.Emp";
  myDataTable.UpdatingKeyFields = "EMPNO";
  myDataTable.UpdatingFields = "EMPNO;ENAME;JOB";

  myDataTable.Open();

  DataRow row = myDataTable.Rows[0];
  row[myDataTable.Columns["ENAME"]] = "John Smith";

  myDataTable.Update();
  myDataTable.Close();
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT e.EMPNO, e.ENAME, e.JOB, d.DNAME" + _
        "FROM Test.Dept d, Test.Emp e " + _
        "where d.Deptno = e.Deptno"
  myDataTable.FetchAll = True
  myDataTable.CachedUpdates = False
  myDataTable.UpdatingTable = "Test.Emp"
  myDataTable.UpdatingKeyFields = "EMPNO"
  myDataTable.UpdatingFields = "EMPNO;ENAME;JOB"
  myDataTable.Open()
  Dim row1 As DataRow = myDataTable.Rows.Item(0)
  row1.Item(myDataTable.Columns.Item("ENAME")) = "John Smith"
  myDataTable.Update()
  myDataTable.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
UpdatingTable Property
UpdatingKeyFields Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingKeyFields Property
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdatingKeyFields Property

Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Property UpdatingKeyFields As String
C#
public string UpdatingKeyFields {get; set;}

Property Value

The string containing list of key field names separated by semicolon.

Example

The following example demonstrates how to use the Devart.Common.DbDataTable.UpdatingKeyFields property.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT e.EMPNO, e.ENAME, e.JOB, d.DNAME FROM Test.Dept d, Test.Emp e where d.Deptno = e.Deptno";

  myDataTable.FetchAll = true;
  myDataTable.CachedUpdates = false;
  myDataTable.UpdatingTable = "Test.Emp";
  myDataTable.UpdatingKeyFields = "EMPNO";
  myDataTable.UpdatingFields = "EMPNO;ENAME;JOB";

  myDataTable.Open();

  DataRow row = myDataTable.Rows[0];
  row[myDataTable.Columns["ENAME"]] = "John Smith";

  myDataTable.Update();
  myDataTable.Close();
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT e.EMPNO, e.ENAME, e.JOB, d.DNAME FROM Test.Dept d, Test.Emp e where d.Deptno = e.Deptno"
  myDataTable.FetchAll = True
  myDataTable.CachedUpdates = False
  myDataTable.UpdatingTable = "Test.Emp"
  myDataTable.UpdatingKeyFields = "EMPNO"
  myDataTable.UpdatingFields = "EMPNO;ENAME;JOB"
  myDataTable.Open()
  Dim row1 As DataRow = myDataTable.Rows.Item(0)
  row1.Item(myDataTable.Columns.Item("ENAME")) = "John Smith"
  myDataTable.Update()
  myDataTable.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
UpdatingTable Property
UpdatingFields Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingTable Property
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : UpdatingTable Property

Gets or sets table name to generate update statements for.

Syntax

Visual Basic (Declaration)
Public Property UpdatingTable As String
C#
public string UpdatingTable {get; set;}

Property Value

The name of the table.

Remarks

Use the Devart.Common.DbDataTable.UpdatingTable property to generate SQL statements for specific table in a complicated query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
UpdatingFields Property
UpdatingKeyFields Property


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbDataTable Class Events
See Also support@devart.com
Devart.Common Namespace : DbDataTable Class

For a list of all members of this type, see DbDataTable members.

Public Events

 | Name | Description
public Event | ColumnChanged | Occurs after a value has been changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | ColumnChanging | Occurs when a value is being changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
public Event | FetchFinished | Occurs when a result set is completely fetched.
public Event | FillError | Occurs when an error is raised during a fill operation.
public Event | Initialized | Occurs after the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Event | RowChanged | Occurs after a System.Data.DataRow has been changed successfully. (Inherited from System.Data.DataTable)
public Event | RowChanging | Occurs when a System.Data.DataRow is changing. (Inherited from System.Data.DataTable)
public Event | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from System.Data.DataTable)
public Event | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from System.Data.DataTable)
public Event | RowFetched | Occurs when another row is completely fetched.
public Event | TableCleared | Occurs after a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableClearing | Occurs when a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableNewRow | Occurs when a new System.Data.DataRow is inserted. (Inherited from System.Data.DataTable)
Top

See Also

Reference

DbDataTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Disposed Event
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Disposed Event

Adds an event handler to listen to the Disposed event on the component.

Syntax

Visual Basic (Declaration)
Public Shadows Event Disposed As EventHandler
C#
public new event EventHandler Disposed

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FetchFinished Event
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : FetchFinished Event

Occurs when a result set is completely fetched.

Syntax

Visual Basic (Declaration)
Public Event FetchFinished As EventHandler
C#
public event EventHandler FetchFinished

Remarks

This event is fired every time a fill operation is finished, regardless of the property or method that invoked the fetch process.

Example

The following example demonstrates how to use the FetchFinished event.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  myDataTable.RowFetched += new EventHandler(myDataTable_RowFetched);
  myDataTable.FetchFinished += new EventHandler(myDataTable_FetchFinished);
  myDataTable.Open();
}

static void myDataTable_RowFetched(object sender, EventArgs e) {

  Console.Write(string.Format("{0} rows are fetched", ((DbDataTable)sender).RecordCount));
}

static void myDataTable_FetchFinished(object sender, EventArgs e) {

  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  AddHandler myDataTable.RowFetched, New EventHandler(AddressOf Form1.myDataTable_RowFetched)
  AddHandler myDataTable.FetchFinished, New EventHandler(AddressOf Form1.myDataTable_FetchFinished)
  myDataTable.Open()
End Sub

Private Shared Sub myDataTable_RowFetched(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write(String.Format("{0} rows are fetched", DirectCast(sender, DbDataTable).RecordCount))
End Sub

Private Shared Sub myDataTable_FetchFinished(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members
EndFill Method
Fill Method
FillPage Method
Active Property
Open Method
MaxRecords Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FillError Event
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : FillError Event

Occurs when an error is raised during a fill operation.

Syntax

Visual Basic (Declaration)
Public Event FillError As FillErrorEventHandler
C#
public event FillErrorEventHandler FillError

Event Data

The event handler receives an argument of type FillErrorEventArgs containing data related to this event. The following FillErrorEventArgs properties provide information specific to this event.

Property | Description
Continue | Gets or sets a value indicating whether to continue the fill operation despite the error.
DataTable | Gets the System.Data.DataTable being updated when the error occurred.
Errors | Gets the errors being handled.
Values | Gets the values for the row being updated when the error occurred.

Remarks

A System.Data.FillErrorEventArgs object is passed to delegate, so you can determine what DbDataTable object has raised an error, what errors are being handled, what are the values for the row being updated when the error occurred, and whether to continue the execution. For more information refer to MSDN topic System.Data.FillErrorEventArgs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowFetched Event
See Also Example support@devart.com
Devart.Common Namespace > DbDataTable Class : RowFetched Event

Occurs when another row is completely fetched.

Syntax

Visual Basic (Declaration)
Public Event RowFetched As EventHandler
C#
public event EventHandler RowFetched

Example

The following example demonstrates how to use the RowFetched event.
C#csharp Copy Code
static void UseDataTable(DbDataTable myDataTable, DbConnection myConnection) {

  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = myConnection.CreateCommand();
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept";

  myDataTable.RowFetched += new EventHandler(myDataTable_RowFetched);
  myDataTable.FetchFinished += new EventHandler(myDataTable_FetchFinished);
  myDataTable.Open();
}

static void myDataTable_RowFetched(object sender, EventArgs e) {

  Console.Write(string.Format("{0} rows are fetched", ((DbDataTable)sender).RecordCount));
}

static void myDataTable_FetchFinished(object sender, EventArgs e) {

  Console.Write("All records are fetched");
}
C#Visual Basic Copy Code
Private Shared Sub UseDataTable(ByVal myDataTable As DbDataTable, ByVal myConnection As DbConnection)
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = myConnection.CreateCommand
  myDataTable.SelectCommand.CommandText = "SELECT * FROM Test.Dept"
  AddHandler myDataTable.RowFetched, New EventHandler(AddressOf Form1.myDataTable_RowFetched)
  AddHandler myDataTable.FetchFinished, New EventHandler(AddressOf Form1.myDataTable_FetchFinished)
  myDataTable.Open()
End Sub

Private Shared Sub myDataTable_RowFetched(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write(String.Format("{0} rows are fetched", DirectCast(sender, DbDataTable).RecordCount))
End Sub

Private Shared Sub myDataTable_FetchFinished(ByVal sender As Object, ByVal e As EventArgs)
  Console.Write("All records are fetched")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbDump Class
Members See Also support@devart.com
Devart.Common Namespace : DbDump Class

Serves to store a database or its parts as a script and also to restore database from the received script.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbDump

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbDump
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public abstract class DbDump : System.ComponentModel.Component, IComponent, IDisposable

Remarks

Abstract DbDump class implements some of DbDump functionality that is DBMS-independent.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbDump Members
Devart.Common Namespace
T:Devart.Data.Oracle.OracleDump


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbDump Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbDump Class

The following tables list the members exposed by DbDump.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the System.Data.Common.DbConnectionBase used by this instance of the DbDump.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DumpText | Gets as a result of Backup() execution, or sets data needed to execute Restore() method.
public Property | GenerateHeader | Gets or sets a value that determines whether to add some extra information in the script header.
public Property | IncludeDrop | Determines whether to recreate database objects.
public Property | Mode | Determines whether to include data from tables into the dump text, script to create database objects or both.
public Property | QuoteIdentifier | Determines whether to quote all identifiers present in the database.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Tables | Gets or sets a list of the tables which will be used in the script. Table names are separated by semicolon.
Top

Public Methods

 | Name | Description
public Method | Backup | Overloaded. Generates a script for further restoring with the Restore method.
public Method | BackupQuery | Overloaded. Generates a script with a backup of the data, returned by the specified query, for further restoring with the Restore method.
public Method | BeginBackup | Overloaded. Starts an asynchronous invocation of a Backup method.
public Method | BeginBackupQuery | Overloaded. Starts an asynchronous invocation of a BackupQuery method.
public Method | BeginRestore | Overloaded. Starts an asynchronous invocation of a Restore method.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndBackup | Ends an asynchronous invocation of the Backup method.
public Method | EndBackupQuery | Ends an asynchronous invocation of the BackupQuery method.
public Method | EndRestore | Ends an asynchronous invocation of the Restore method.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Restore | Overloaded. Executes the previously dumped script.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbDump Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbDump Class Methods
See Also support@devart.com
Devart.Common Namespace : DbDump Class

For a list of all members of this type, see DbDump members.

Public Methods

 | Name | Description
public Method | Backup | Overloaded. Generates a script for further restoring with the Restore method.
public Method | BackupQuery | Overloaded. Generates a script with a backup of the data, returned by the specified query, for further restoring with the Restore method.
public Method | BeginBackup | Overloaded. Starts an asynchronous invocation of a Backup method.
public Method | BeginBackupQuery | Overloaded. Starts an asynchronous invocation of a BackupQuery method.
public Method | BeginRestore | Overloaded. Starts an asynchronous invocation of a Restore method.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndBackup | Ends an asynchronous invocation of the Backup method.
public Method | EndBackupQuery | Ends an asynchronous invocation of the BackupQuery method.
public Method | EndRestore | Ends an asynchronous invocation of the Restore method.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Restore | Overloaded. Executes the previously dumped script.
Top

See Also

Reference

DbDump Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Backup Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : Backup Method

Generates a script for further restoring with the Restore method.

Overload List

Overload | Description
Backup() | Generates a script and writes it to the DumpText property.
Backup(String) | Generates a script and writes it to the specified file.
Backup(Stream) | Generates a script and writes it to the specified System.IO.Stream.
Backup(TextWriter) | Generates a script and writes it to the specified System.IO.TextWriter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Backup() Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Backup Method : Backup() Method

Generates a script and writes it to the DumpText property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Backup()
C#
public void Backup()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Backup(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Backup Method : Backup(String) Method

fileName
The name of the file to write the script to.
Generates a script and writes it to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Backup( _
   ByVal fileName As String _
)
C#
public void Backup(
   string fileName
)

Parameters

fileName
The name of the file to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Backup(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Backup Method : Backup(Stream) Method

stream
The System.IO.Stream to write the script to.
Generates a script and writes it to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Backup( _
   ByVal stream As Stream _
)
C#
public void Backup(
   Stream stream
)

Parameters

stream
The System.IO.Stream to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Backup(TextWriter) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Backup Method : Backup(TextWriter) Method

writer
The System.IO.TextWriter to write the script to.
Generates a script and writes it to the specified System.IO.TextWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Backup( _
   ByVal writer As TextWriter _
)
C#
public void Backup(
   TextWriter writer
)

Parameters

writer
The System.IO.TextWriter to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BackupQuery Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : BackupQuery Method

Generates a script with a backup of the data, returned by the specified query, for further restoring with the Restore method.

Overload List

Overload | Description
BackupQuery(String) | Generates a script with a backup of the data, returned by the specified query, and writes it to the DumpText property.
BackupQuery(String,String) | Generates a script with a backup of the data, returned by the specified query, and writes it to the specified file.
BackupQuery(String,Stream) | Generates a script with a backup of the data, returned by the specified query, and writes it to the specified System.IO.Stream.
BackupQuery(String,TextWriter) | Generates a script with a backup of the data, returned by the specified query, and writes it to the specified System.IO.TextWriter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BackupQuery(String) Method
See Also Example support@devart.com
Devart.Common Namespace > DbDump Class > BackupQuery Method : BackupQuery(String) Method

query
The query, returning data for backup.
Generates a script with a backup of the data, returned by the specified query, and writes it to the DumpText property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BackupQuery( _
   ByVal query As String _
)
C#
public void BackupQuery(
   string query
)

Parameters

query
The query, returning data for backup.

Example

The following example dumps the query data to the DumpText property.
C#csharp Copy Code
dump.BackupQuery("SELECT * FROM DEPT WHERE Deptno > 50");
C#Visual Basic Copy Code
dump.BackupQuery('SELECT * FROM DEPT WHERE Deptno > 50')

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BackupQuery(String,String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BackupQuery Method : BackupQuery(String,String) Method

query
The query, returning data for backup.
fileName
Name of the file to write the script to.
Generates a script with a backup of the data, returned by the specified query, and writes it to the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BackupQuery( _
   ByVal query As String, _
   ByVal fileName As String _
)
C#
public void BackupQuery(
   string query,
   string fileName
)

Parameters

query
The query, returning data for backup.
fileName
Name of the file to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BackupQuery(String,Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BackupQuery Method : BackupQuery(String,Stream) Method

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.
Generates a script with a backup of the data, returned by the specified query, and writes it to the specified System.IO.Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BackupQuery( _
   ByVal query As String, _
   ByVal stream As Stream _
)
C#
public void BackupQuery(
   string query,
   Stream stream
)

Parameters

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BackupQuery(String,TextWriter) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BackupQuery Method : BackupQuery(String,TextWriter) Method

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.
Generates a script with a backup of the data, returned by the specified query, and writes it to the specified System.IO.TextWriter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BackupQuery( _
   ByVal query As String, _
   ByVal writer As TextWriter _
)
C#
public void BackupQuery(
   string query,
   TextWriter writer
)

Parameters

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : BeginBackup Method

Starts an asynchronous invocation of a Backup method.

Overload List

Overload | Description
BeginBackup() | Starts an asynchronous invocation of a Backup method.
BeginBackup(AsyncCallback,Object) | Starts an asynchronous invocation of a Backup method with information for callback function.
BeginBackup(String) | Starts an asynchronous invocation of a Backup(String) method.
BeginBackup(String,AsyncCallback,Object) | Starts an asynchronous invocation of a Backup(String) method with information for callback function.
BeginBackup(Stream) | Starts an asynchronous invocation of a Backup(Stream) method.
BeginBackup(Stream,AsyncCallback,Object) | Starts an asynchronous invocation of a Backup(Stream) method with information for callback function.
BeginBackup(TextWriter) | Starts an asynchronous invocation of a Backup(TextWriter) method.
BeginBackup(TextWriter,AsyncCallback,Object) | Starts an asynchronous invocation of a Backup(TextWriter) method with information for callback function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup() Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup() Method

Starts an asynchronous invocation of a Backup method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup() As IAsyncResult
C#
public IAsyncResult BeginBackup()

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(AsyncCallback,Object) Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Backup method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(AsyncCallback,Object) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(String) Method

fileName
The name of the file to write the script to.
Starts an asynchronous invocation of a Backup(String) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal fileName As String _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   string fileName
)

Parameters

fileName
The name of the file to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(String) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(String) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(String,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(String,AsyncCallback,Object) Method

fileName
The name of the file to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Backup(String) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal fileName As String, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   string fileName,
   AsyncCallback callback,
   object stateObject
)

Parameters

fileName
The name of the file to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(String,AsyncCallback,Object) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(String,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(Stream) Method

stream
The System.IO.Stream to write the script to.
Starts an asynchronous invocation of a Backup(Stream) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal stream As Stream _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   Stream stream
)

Parameters

stream
The System.IO.Stream to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(Stream) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(Stream) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(Stream,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(Stream,AsyncCallback,Object) Method

stream
The System.IO.Stream to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Backup(Stream) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal stream As Stream, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   Stream stream,
   AsyncCallback callback,
   object stateObject
)

Parameters

stream
The System.IO.Stream to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(Stream,AsyncCallback,Object) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(Stream,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(TextWriter) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(TextWriter) Method

writer
The System.IO.TextWriter to write the script to.
Starts an asynchronous invocation of a Backup(TextWriter) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal writer As TextWriter _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   TextWriter writer
)

Parameters

writer
The System.IO.TextWriter to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(TextWriter) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(TextWriter) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackup(TextWriter,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackup Method : BeginBackup(TextWriter,AsyncCallback,Object) Method

writer
The System.IO.TextWriter to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Backup(TextWriter) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackup( _
   ByVal writer As TextWriter, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackup(
   TextWriter writer,
   AsyncCallback callback,
   object stateObject
)

Parameters

writer
The System.IO.TextWriter to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackup(TextWriter,AsyncCallback,Object) method enables you to perform a backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the backup operation, you have to call BeginBackup(TextWriter,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndBackup. If at the moment you call this function the backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : BeginBackupQuery Method

Starts an asynchronous invocation of a BackupQuery method.

Overload List

Overload | Description
BeginBackupQuery(String) | Starts an asynchronous invocation of a BackupQuery(String) method.
BeginBackupQuery(String,AsyncCallback,Object) | Starts an asynchronous invocation of a BackupQuery(String) method with information for callback function.
BeginBackupQuery(String,String) | Starts an asynchronous invocation of a BackupQuery(String,String) method.
BeginBackupQuery(String,String,AsyncCallback,Object) | Starts an asynchronous invocation of a BackupQuery(String,String) method with information for callback function.
BeginBackupQuery(String,Stream) | Starts an asynchronous invocation of a BackupQuery(String,Stream) method.
BeginBackupQuery(String,Stream,AsyncCallback,Object) | Starts an asynchronous invocation of a BackupQuery(String,Stream) method with information for callback function.
BeginBackupQuery(String,TextWriter) | Starts an asynchronous invocation of a BackupQuery(String,TextWriter) method.
BeginBackupQuery(String,TextWriter,AsyncCallback,Object) | Starts an asynchronous invocation of a BackupQuery(String,TextWriter) method with information for callback function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String) Method

query
The query, returning data for backup.
Starts an asynchronous invocation of a BackupQuery(String) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query
)

Parameters

query
The query, returning data for backup.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,AsyncCallback,Object) Method

query
The query, returning data for backup.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a BackupQuery(String) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   AsyncCallback callback,
   object stateObject
)

Parameters

query
The query, returning data for backup.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,AsyncCallback,Object) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,String) Method

query
The query, returning data for backup.
fileName
The name of the file to write the script to.
Starts an asynchronous invocation of a BackupQuery(String,String) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal fileName As String _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   string fileName
)

Parameters

query
The query, returning data for backup.
fileName
The name of the file to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,String) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,String) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,String,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,String,AsyncCallback,Object) Method

query
The query, returning data for backup.
fileName
The name of the file to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a BackupQuery(String,String) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal fileName As String, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   string fileName,
   AsyncCallback callback,
   object stateObject
)

Parameters

query
The query, returning data for backup.
fileName
The name of the file to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,String,AsyncCallback,Object) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,String,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,Stream) Method

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.
Starts an asynchronous invocation of a BackupQuery(String,Stream) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal stream As Stream _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   Stream stream
)

Parameters

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,Stream) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,Stream) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,Stream,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,Stream,AsyncCallback,Object) Method

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a BackupQuery(String,Stream) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal stream As Stream, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   Stream stream,
   AsyncCallback callback,
   object stateObject
)

Parameters

query
The query, returning data for backup.
stream
The System.IO.Stream to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,Stream,AsyncCallback,Object) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,Stream,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,TextWriter) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,TextWriter) Method

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.
Starts an asynchronous invocation of a BackupQuery(String,TextWriter) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal writer As TextWriter _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   TextWriter writer
)

Parameters

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,TextWriter) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,TextWriter) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBackupQuery(String,TextWriter,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginBackupQuery Method : BeginBackupQuery(String,TextWriter,AsyncCallback,Object) Method

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a BackupQuery(String,TextWriter) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginBackupQuery( _
   ByVal query As String, _
   ByVal writer As TextWriter, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginBackupQuery(
   string query,
   TextWriter writer,
   AsyncCallback callback,
   object stateObject
)

Parameters

query
The query, returning data for backup.
writer
The System.IO.TextWriter to write the script to.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginBackupQuery(String,TextWriter,AsyncCallback,Object) method enables you to perform a query backup operation without having current thread blocked. In other words, your program can continue execution while the backup runs in background so you do not have to wait for it.

To start the query backup operation, you have to call BeginBackupQuery(String,TextWriter,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the query backup operation, call EndBackupQuery. If at the moment you call this function the query backup has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : BeginRestore Method

Starts an asynchronous invocation of a Restore method.

Overload List

Overload | Description
BeginRestore() | Starts an asynchronous invocation of a Restore method.
BeginRestore(AsyncCallback,Object) | Starts an asynchronous invocation of a Restore method with information for callback function.
BeginRestore(String) | Starts an asynchronous invocation of a Restore(String) method.
BeginRestore(String,AsyncCallback,Object) | Starts an asynchronous invocation of a Restore(String) method with information for callback function.
BeginRestore(Stream) | Starts an asynchronous invocation of a Restore(Stream) method.
BeginRestore(Stream,AsyncCallback,Object) | Starts an asynchronous invocation of a Restore(Stream) method with information for callback function.
BeginRestore(TextReader) | Starts an asynchronous invocation of a Restore(TextReader) method.
BeginRestore(TextReader,AsyncCallback,Object) | Starts an asynchronous invocation of a Restore(TextReader) method with information for callback function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore() Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore() Method

Starts an asynchronous invocation of a Restore method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore() As IAsyncResult
C#
public IAsyncResult BeginRestore()

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(AsyncCallback,Object) Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Restore method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(AsyncCallback,Object) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(String) Method

fileName
The name of the file to load the script from.
Starts an asynchronous invocation of a Restore(String) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal fileName As String _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   string fileName
)

Parameters

fileName
The name of the file to load the script from.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(String) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(String) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(String,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(String,AsyncCallback,Object) Method

fileName
The name of the file to load the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Restore(String) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal fileName As String, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   string fileName,
   AsyncCallback callback,
   object stateObject
)

Parameters

fileName
The name of the file to load the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(String,AsyncCallback,Object) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(String,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(Stream) Method

stream
The System.IO.Stream object to read the script from.
Starts an asynchronous invocation of a Restore(Stream) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal stream As Stream _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   Stream stream
)

Parameters

stream
The System.IO.Stream object to read the script from.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(Stream) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(Stream) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(Stream,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(Stream,AsyncCallback,Object) Method

stream
The System.IO.Stream object to read the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Restore(Stream) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal stream As Stream, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   Stream stream,
   AsyncCallback callback,
   object stateObject
)

Parameters

stream
The System.IO.Stream object to read the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(Stream,AsyncCallback,Object) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(Stream,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(TextReader) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(TextReader) Method

reader
The System.IO.TextReader object to read the script from.
Starts an asynchronous invocation of a Restore(TextReader) method.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal reader As TextReader _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   TextReader reader
)

Parameters

reader
The System.IO.TextReader object to read the script from.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(TextReader) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(TextReader) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginRestore(TextReader,AsyncCallback,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > BeginRestore Method : BeginRestore(TextReader,AsyncCallback,Object) Method

reader
The System.IO.TextReader object to read the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of a Restore(TextReader) method with information for callback function.

Syntax

Visual Basic (Declaration)
Public Overloads Function BeginRestore( _
   ByVal reader As TextReader, _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginRestore(
   TextReader reader,
   AsyncCallback callback,
   object stateObject
)

Parameters

reader
The System.IO.TextReader object to read the script from.
callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginRestore(TextReader,AsyncCallback,Object) method enables you to perform a restore operation without having current thread blocked. In other words, your program can continue execution while the restore operation runs in background so you do not have to wait for it.

To start the restore operation, you have to call BeginRestore(TextReader,AsyncCallback,Object) method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to an System.IAsyncResult object. After executing this method, the program flow continues.

When you are ready to finish the backup operation, call EndRestore. If at the moment you call this function the restore operation has not yet been finished, application stops and waits till the function returns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndBackup Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : EndBackup Method

result
The System.IAsyncResult returned by BeginBackup.
Ends an asynchronous invocation of the Backup method.

Syntax

Visual Basic (Declaration)
Public Sub EndBackup( _
   ByVal result As IAsyncResult _
)
C#
public void EndBackup(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned by BeginBackup.

Remarks

The function ends an asynchronous backup that is started with BeginBackup. A pair of asynchronous functions (BeginBackup and EndBackup) can be used instead of the synchronous function Backup to gain more performance and flexibility in your application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndBackupQuery Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : EndBackupQuery Method

result
The System.IAsyncResult returned by BeginBackupQuery.
Ends an asynchronous invocation of the BackupQuery method.

Syntax

Visual Basic (Declaration)
Public Sub EndBackupQuery( _
   ByVal result As IAsyncResult _
)
C#
public void EndBackupQuery(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned by BeginBackupQuery.

Remarks

The function ends an asynchronous query backup that is started with BeginBackupQuery. A pair of asynchronous functions (BeginBackupQuery and EndBackupQuery) can be used instead of the synchronous function BackupQuery to gain more performance and flexibility in your application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndRestore Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : EndRestore Method

result
The System.IAsyncResult returned by BeginRestore.
Ends an asynchronous invocation of the Restore method.

Syntax

Visual Basic (Declaration)
Public Sub EndRestore( _
   ByVal result As IAsyncResult _
)
C#
public void EndRestore(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned by BeginRestore.

Remarks

The function ends an asynchronous backup that is started with BeginRestore. A pair of asynchronous functions (BeginRestore and EndRestore) can be used instead of the synchronous function Restore to gain more performance and flexibility in your application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restore Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class : Restore Method

Executes the previously dumped script.

Overload List

Overload | Description
Restore() | Executes script specified in the DbDump descendant property.
Restore(String) | Executes script from the specified file.
Restore(Stream) | Executes script from the specified System.IO.Stream object.
Restore(TextReader) | Executes script from the specified System.IO.TextReader object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restore() Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Restore Method : Restore() Method

Executes script specified in the DbDump descendant property.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Restore()
C#
public void Restore()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restore(String) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Restore Method : Restore(String) Method

fileName
The name of the file to load the script from.
Executes script from the specified file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Restore( _
   ByVal fileName As String _
)
C#
public void Restore(
   string fileName
)

Parameters

fileName
The name of the file to load the script from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restore(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Restore Method : Restore(Stream) Method

stream
The System.IO.Stream object to read the script from.
Executes script from the specified System.IO.Stream object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Restore( _
   ByVal stream As Stream _
)
C#
public void Restore(
   Stream stream
)

Parameters

stream
The System.IO.Stream object to read the script from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restore(TextReader) Method
See Also support@devart.com
Devart.Common Namespace > DbDump Class > Restore Method : Restore(TextReader) Method

reader
The System.IO.TextReader object to read the script from.
Executes script from the specified System.IO.TextReader object.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Restore( _
   ByVal reader As TextReader _
)
C#
public void Restore(
   TextReader reader
)

Parameters

reader
The System.IO.TextReader object to read the script from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbDump Class Properties
See Also support@devart.com
Devart.Common Namespace : DbDump Class

For a list of all members of this type, see DbDump members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the System.Data.Common.DbConnectionBase used by this instance of the DbDump.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DumpText | Gets as a result of Backup() execution, or sets data needed to execute Restore() method.
public Property | GenerateHeader | Gets or sets a value that determines whether to add some extra information in the script header.
public Property | IncludeDrop | Determines whether to recreate database objects.
public Property | Mode | Determines whether to include data from tables into the dump text, script to create database objects or both.
public Property | QuoteIdentifier | Determines whether to quote all identifiers present in the database.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Tables | Gets or sets a list of the tables which will be used in the script. Table names are separated by semicolon.
Top

See Also

Reference

DbDump Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : Connection Property

Gets or sets the System.Data.Common.DbConnectionBase used by this instance of the DbDump.

Syntax

Visual Basic (Declaration)
Public Property Connection As DbConnection
C#
public DbConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DumpText Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : DumpText Property

Gets as a result of Backup() execution, or sets data needed to execute Restore() method.

Syntax

Visual Basic (Declaration)
Public Overridable Property DumpText As String
C#
public virtual string DumpText {get; set;}

Property Value

SQL commands separated by ';' symbols.

Remarks

Use DumpText property to store generated by Backup() script. Also use this property as a source on execution Restore() operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members
Backup Method
Restore Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GenerateHeader Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : GenerateHeader Property

Gets or sets a value that determines whether to add some extra information in the script header.

Syntax

Visual Basic (Declaration)
Public Property GenerateHeader As Boolean
C#
public bool GenerateHeader {get; set;}

Property Value

If true, T:Devart.Data.Oracle.OracleDump adds comments with information about server version, script generation date, and so on.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IncludeDrop Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : IncludeDrop Property

Determines whether to recreate database objects.

Syntax

Visual Basic (Declaration)
Public Property IncludeDrop As Boolean
C#
public bool IncludeDrop {get; set;}

Property Value

true, if database objects must be recreated; otherwise, false. The default value is false.

Remarks

For example, before "CREATE TABLE" "DROP TABLE" will be added, if IncludeDrop property is set to true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Mode Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : Mode Property

Determines whether to include data from tables into the dump text, script to create database objects or both.

Syntax

Visual Basic (Declaration)
Public Property Mode As DumpMode
C#
public DumpMode Mode {get; set;}

Property Value

One of DumpMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QuoteIdentifier Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : QuoteIdentifier Property

Determines whether to quote all identifiers present in the database.

Syntax

Visual Basic (Declaration)
Public Property QuoteIdentifier As Boolean
C#
public bool QuoteIdentifier {get; set;}

Property Value

true, if database identifiers must be quoted; otherwise, false. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tables Property
See Also support@devart.com
Devart.Common Namespace > DbDump Class : Tables Property

Gets or sets a list of the tables which will be used in the script. Table names are separated by semicolon.

Syntax

Visual Basic (Declaration)
Public Overridable Property Tables As String
C#
public virtual string Tables {get; set;}

Property Value

System.String containing a list of the tables separated by semicolon.

Remarks

If an empty value, all the tables present in the database will be processed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDump Class
DbDump Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoader Class
Members See Also support@devart.com
Devart.Common Namespace : DbLoader Class

Serves to load external data into the data source.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbLoader
Devart.Data.Oracle.OracleLoader

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbLoader
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public abstract class DbLoader : System.ComponentModel.Component, IComponent, IDisposable

Remarks

Abstract DbLoader class implements some of DbLoader functionality that is DBMS-independent.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbLoader Members
Devart.Common Namespace
DbLoaderColumn Class
DbLoaderColumnCollection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbLoader Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbLoader Class

The following tables list the members exposed by DbLoader.

Public Properties

 | Name | Description
public Property | BufferSize | Gets or sets a size of data packet loaded to the server.
public Property | Columns | Gets the Devart.Common.DbLoaderColumnCollection collection.
public Property | Connection | Gets or sets the DbConnectionBase used by this instance of the DbLoader.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Item | Overloaded. Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableName | Gets or sets table name that will be loaded.
Top

Public Methods

 | Name | Description
public Method | Close | Closes loading session and flushes remaining rows to the table.
public Method | CreateColumns | Retrieves table columns information from the table specified in the TableName property and populates columns collection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | LoadTable | Overloaded. Loads data into the table from the specified DataTable.
public Method | NextRow | Advances DbLoader to the next row.
public Method | Open | Prepares DbLoader for the loading.
public Method | SetNull | Overloaded. Sets the value of the column with the specified name or ordinal to NULL.
public Method | SetValue | Overloaded. Sets the value of the column with the specified name or ordinal.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbLoader Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbLoader Class Methods
See Also support@devart.com
Devart.Common Namespace : DbLoader Class

For a list of all members of this type, see DbLoader members.

Public Methods

 | Name | Description
public Method | Close | Closes loading session and flushes remaining rows to the table.
public Method | CreateColumns | Retrieves table columns information from the table specified in the TableName property and populates columns collection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | LoadTable | Overloaded. Loads data into the table from the specified DataTable.
public Method | NextRow | Advances DbLoader to the next row.
public Method | Open | Prepares DbLoader for the loading.
public Method | SetNull | Overloaded. Sets the value of the column with the specified name or ordinal to NULL.
public Method | SetValue | Overloaded. Sets the value of the column with the specified name or ordinal.
Top

See Also

Reference

DbLoader Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : Close Method

Closes loading session and flushes remaining rows to the table.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Close()
C#
public abstract void Close()

Remarks

You must call Close method after finishing of loading session. If rows exist in the loader internal buffer, they will be flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateColumns Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : CreateColumns Method

Retrieves table columns information from the table specified in the TableName property and populates columns collection.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateColumns()
C#
public abstract void CreateColumns()

Remarks

If DbLoader.Columns property consists of some columns they will be deleted before calling CreateColumns method. TableName property must be set before calling this method.

CreateColumns retrieves all columns from the table. It means that when inserting the data, SQL INSERT statement is generated for all of the columns, regardless of how many you have assigned with SetValue method. The columns you have omitted are considered to be of NULL value. If you want to generate the statements for chosen columns only, you have to manually edit the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : LoadTable Method

Loads data into the table from the specified DataTable.

Overload List

Overload | Description
LoadTable(DataTable) | Loads data into the table from the specified DataTable.
LoadTable(DataTable,DataRowState) | Loads rows that match to the specified row state from the specified DataTable into the table.
LoadTable(DataTable,IColumnMappingCollection) | Loads data into the table from the specified DataTable.
LoadTable(DataRow[]) | Loads data into the table from the specified array of data rows.
LoadTable(IDataReader) | Loads data into the table from the specified IDataReader.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable(DataTable) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > LoadTable Method : LoadTable(DataTable) Method

table
The DataTable object to obtain data from.
Loads data into the table from the specified DataTable.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTable( _
   ByVal table As DataTable _
)
C#
public void LoadTable(
   DataTable table
)

Parameters

table
The DataTable object to obtain data from.

Remarks

Loader can be in either opened or closed state. This method closes the loading session, so all rows are flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable(DataTable,DataRowState) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > LoadTable Method : LoadTable(DataTable,DataRowState) Method

table
The DataTable object to obtain data from.
rowState
The specified row state. Only rows that match it will be copied to the target table.
Loads rows that match to the specified row state from the specified DataTable into the table.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTable( _
   ByVal table As DataTable, _
   ByVal rowState As DataRowState _
)
C#
public void LoadTable(
   DataTable table,
   DataRowState rowState
)

Parameters

table
The DataTable object to obtain data from.
rowState
The specified row state. Only rows that match it will be copied to the target table.

Remarks

Loader can be in either opened or closed state. This method closes the loading session, so all rows are flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable(DataTable,IColumnMappingCollection) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > LoadTable Method : LoadTable(DataTable,IColumnMappingCollection) Method

table
The DataTable object to obtain data from.
columnMappings
Column mappings used to match table columns to data source table columns. If this argument is null, the DataTable columns names are used.
Loads data into the table from the specified DataTable.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTable( _
   ByVal table As DataTable, _
   ByVal columnMappings As IColumnMappingCollection _
)
C#
public void LoadTable(
   DataTable table,
   IColumnMappingCollection columnMappings
)

Parameters

table
The DataTable object to obtain data from.
columnMappings
Column mappings used to match table columns to data source table columns. If this argument is null, the DataTable columns names are used.

Remarks

Loader can be in either opened or closed state. This method closes the loading session, so all rows are flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable(DataRow[]) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > LoadTable Method : LoadTable(DataRow[]) Method

rows
The array of data rows to load into target table.
Loads data into the table from the specified array of data rows.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTable( _
   ByVal rows() As DataRow _
)
C#
public void LoadTable(
   DataRow[] rows
)

Parameters

rows
The array of data rows to load into target table.

Remarks

Loader can be in either opened or closed state. This method closes the loading session, so all rows are flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LoadTable(IDataReader) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > LoadTable Method : LoadTable(IDataReader) Method

reader
The IDataReader object to obtain data from.
Loads data into the table from the specified IDataReader.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadTable( _
   ByVal reader As IDataReader _
)
C#
public void LoadTable(
   IDataReader reader
)

Parameters

reader
The IDataReader object to obtain data from.

Remarks

Loader can be in either opened or closed state. This method closes the loading session, so all rows are flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NextRow Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : NextRow Method

Advances DbLoader to the next row.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub NextRow()
C#
public abstract void NextRow()

Remarks

Call this method after you put the row to the DbLoader internal buffer. If DbLoader rows buffer is full NextRow method flushes rows buffer to the loading table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : Open Method

Prepares DbLoader for the loading.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Open()
C#
public abstract void Open()

Remarks

Use Open method to prepare internal DbLoader structures for loading. If you do not call this method explicitly it will be called automatically.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNull Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : SetNull Method

Sets the value of the column with the specified name or ordinal to NULL.

Overload List

Overload | Description
SetNull(Int32) | Sets the value of the column with the specified index to NULL.
SetNull(String) | Sets the value of the column with the specified name to NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNull(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > SetNull Method : SetNull(Int32) Method

i
Zero-based index of the column.
Sets the value of the column with the specified index to NULL.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetNull( _
   ByVal i As Integer _
)
C#
public void SetNull(
   int i
)

Parameters

i
Zero-based index of the column.

Remarks

Use SetNull(Int32) method to set column with specific index in the current row to a NULL value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List
SetValue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNull(String) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > SetNull Method : SetNull(String) Method

name
The name of the column.
Sets the value of the column with the specified name to NULL.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetNull( _
   ByVal name As String _
)
C#
public void SetNull(
   string name
)

Parameters

name
The name of the column.

Remarks

Use SetNull(String) method to set column with specific name in the current row to a NULL value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List
SetValue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetValue Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : SetValue Method

Sets the value of the column with the specified name or ordinal.

Overload List

Overload | Description
SetValue(String,Object) | Sets the value of the column with the specified name.
SetValue(Int32,Object) | Sets the value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetValue(String,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > SetValue Method : SetValue(String,Object) Method

name
The name of the column.
value
Column value.
Sets the value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetValue( _
   ByVal name As String, _
   ByVal value As Object _
)
C#
public void SetValue(
   string name,
   object value
)

Parameters

name
The name of the column.
value
Column value.

Remarks

Use SetValue(String,Object) method to set column with specific name in the current row to the value. To assign a column NULL value use SetNull(String) method instead.

The columns that you did not explicitly assign a value are considered to be NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List
SetNull(String) Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetValue(Int32,Object) Method
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > SetValue Method : SetValue(Int32,Object) Method

i
Zero-based index of the column.
value
Column value.
Sets the value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads MustOverride Sub SetValue( _
   ByVal i As Integer, _
   ByVal value As Object _
)
C#
public abstract void SetValue(
   int i,
   object value
)

Parameters

i
Zero-based index of the column.
value
Column value.

Remarks

Use SetValue(Int32,Object) method to set column with specific index in the current row to the value. To assign a column NULL value use SetNull(Int32) method instead.

The columns that you did not explicitly assign a value are considered to be NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List
SetNull(Int32) Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbLoader Class Properties
See Also support@devart.com
Devart.Common Namespace : DbLoader Class

For a list of all members of this type, see DbLoader members.

Public Properties

 | Name | Description
public Property | BufferSize | Gets or sets a size of data packet loaded to the server.
public Property | Columns | Gets the Devart.Common.DbLoaderColumnCollection collection.
public Property | Connection | Gets or sets the DbConnectionBase used by this instance of the DbLoader.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Item | Overloaded. Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableName | Gets or sets table name that will be loaded.
Top

See Also

Reference

DbLoader Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BufferSize Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : BufferSize Property

Gets or sets a size of data packet loaded to the server.

Syntax

Visual Basic (Declaration)
Public Property BufferSize As Integer
C#
public int BufferSize {get; set;}

Property Value

Size of the data packet in bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : Columns Property

Gets the Devart.Common.DbLoaderColumnCollection collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As DbLoaderColumnCollection
C#
public DbLoaderColumnCollection Columns {get;}

Property Value

Columns which loaded table consist of.

Remarks

You may manually add columns to the Devart.Common.DbLoaderColumnCollection or call CreateColumns method to populate columns collection from the table description.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : Connection Property

Gets or sets the DbConnectionBase used by this instance of the DbLoader.

Syntax

Visual Basic (Declaration)
Public Property Connection As DbConnection
C#
public DbConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Remarks

DbLoader instance uses DbConnectionBase during loading and for populating columns collection when CreateColumns method is called. For these operations DbLoader requires open connection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : Item Property

Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection.

Overload List

Overload | Description
Item(String) | Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection.
Item(Int32) | Sets the value of the column at the specified index for Devart.Common.DbLoaderColumnCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > Item Property : Item(String) Property

columnName
The name of the column.
Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection.

Syntax

Visual Basic (Declaration)
Public Overloads WriteOnly Property Item( _
   ByVal columnName As String _
) As Object
C#
public object Item(
   string columnName
) {set;}

Parameters

columnName
The name of the column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class > Item Property : Item(Int32) Property

columnIndex
The zero-based index.
Sets the value of the column at the specified index for Devart.Common.DbLoaderColumnCollection.

Syntax

Visual Basic (Declaration)
Public Overloads WriteOnly Property Item( _
   ByVal columnIndex As Integer _
) As Object
C#
public object Item(
   int columnIndex
) {set;}

Parameters

columnIndex
The zero-based index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableName Property
See Also support@devart.com
Devart.Common Namespace > DbLoader Class : TableName Property

Gets or sets table name that will be loaded.

Syntax

Visual Basic (Declaration)
Public Overridable Property TableName As String
C#
public virtual string TableName {get; set;}

Property Value

Name of the table that will be loaded.

Remarks

TableName property must be specified before beginning of loading data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoader Class
DbLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Class
Members See Also support@devart.com
Devart.Common Namespace : DbLoaderColumn Class

Represents the attributes for column loading.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Common.DbLoaderColumn
Devart.Data.Oracle.OracleLoaderColumn

Syntax

Visual Basic (Declaration)
Public Class DbLoaderColumn
   Inherits System.MarshalByRefObject
C#
public class DbLoaderColumn : System.MarshalByRefObject

Remarks

Each DbLoader uses DbLoader.Columns to maintain a collection of Devart.Common.DbLoaderColumn objects. The Devart.Common.DbLoaderColumn object represents the attributes for column loading. Every Devart.Common.DbLoaderColumn object corresponds to one of the table fields with the same name as its Name property.

You can manually make changes to the DbLoader.Columns collection to exclude some columns from INSERT statement generated by DbLoader object.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbLoaderColumn Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbLoaderColumn Class

The following tables list the members exposed by DbLoaderColumn.

Public Constructors

 | Name | Description
public Constructor | DbLoaderColumn Constructor | Overloaded. Initializes a new instance of the Devart.Common.DbLoaderColumn class.
Top

Public Properties

 | Name | Description
public Property | Name | Gets or sets the name of the Devart.Common.DbLoaderColumn.
public Property | Precision | Gets or sets the maximum number of digits used to represent the column value.
public Property | Scale | Gets or sets the number of decimal places to which column value is resolved.
public Property | Size | Gets or sets the maximum size, in bytes, of the data within the column.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ToString | Returns the name of the Devart.Common.DbLoaderColumn.
Top

See Also

Reference

DbLoaderColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Constructor
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : DbLoaderColumn Constructor

Initializes a new instance of the Devart.Common.DbLoaderColumn class.

Overload List

Overload | Description
DbLoaderColumn Constructor() | Initializes a new instance of the Devart.Common.DbLoaderColumn class.
DbLoaderColumn Constructor(String,Int32,Int32,Int32) | Initializes a new instance of the Devart.Common.DbLoaderColumn class with the column name, size, precision and scale.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Constructor()
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumn Class > DbLoaderColumn Constructor : DbLoaderColumn Constructor()

Initializes a new instance of the Devart.Common.DbLoaderColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DbLoaderColumn()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Constructor(String,Int32,Int32,Int32)
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumn Class > DbLoaderColumn Constructor : DbLoaderColumn Constructor(String,Int32,Int32,Int32)

name
The name of the column.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.
Initializes a new instance of the Devart.Common.DbLoaderColumn class with the column name, size, precision and scale.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal size As Integer, _
   ByVal precision As Integer, _
   ByVal scale As Integer _
)
C#
public DbLoaderColumn(
   string name,
   int size,
   int precision,
   int scale
)

Parameters

name
The name of the column.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.

Remarks

Use this constructor to create a Devart.Common.DbLoaderColumn instance with custom column name, data size, precision and scale.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Class Methods
See Also support@devart.com
Devart.Common Namespace : DbLoaderColumn Class

For a list of all members of this type, see DbLoaderColumn members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ToString | Returns the name of the Devart.Common.DbLoaderColumn.
Top

See Also

Reference

DbLoaderColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : ToString Method

Returns the name of the Devart.Common.DbLoaderColumn.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The name of the Devart.Common.DbLoaderColumn.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumn Class Properties
See Also support@devart.com
Devart.Common Namespace : DbLoaderColumn Class

For a list of all members of this type, see DbLoaderColumn members.

Public Properties

 | Name | Description
public Property | Name | Gets or sets the name of the Devart.Common.DbLoaderColumn.
public Property | Precision | Gets or sets the maximum number of digits used to represent the column value.
public Property | Scale | Gets or sets the number of decimal places to which column value is resolved.
public Property | Size | Gets or sets the maximum size, in bytes, of the data within the column.
Top

See Also

Reference

DbLoaderColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : Name Property

Gets or sets the name of the Devart.Common.DbLoaderColumn.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the Devart.Common.DbLoaderColumn. The default value is an empty string ("").

Remarks

Every Devart.Common.DbLoaderColumn object corresponds to one of the table fields with the same name as its Name property.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Precision Property
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : Precision Property

Gets or sets the maximum number of digits used to represent the column value.

Syntax

Visual Basic (Declaration)
Public Overridable Property Precision As Integer
C#
public virtual int Precision {get; set;}

Property Value

The maximum number of digits used to represent the column value. The default value is 0.

Remarks

Use Precision property to set the precision of number columns.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetDataColumns(ByVal myConnection As OracleConnection)
  myConnection.Open()
  Dim loader As OracleLoader
  loader = New OracleLoader
  loader.Connection = myConnection
  loader.TableName = "load_table"
  Dim myColumn As OracleLoaderColumn
  Try
    loader.CreateColumns()
    Dim i As Integer
    For i = 0 To loader.Columns.Count - 1
      myColumn = loader.Columns(i)
      Console.WriteLine(myColumn.Name)
      Console.WriteLine(myColumn.OracleDbType.ToString())
      Console.WriteLine(myColumn.Size)
      Console.WriteLine(myColumn.Scale)
      Console.WriteLine(myColumn.Precision)
      Console.WriteLine()
    Next i
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Scale Property
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : Scale Property

Gets or sets the number of decimal places to which column value is resolved.

Syntax

Visual Basic (Declaration)
Public Property Scale As Integer
C#
public int Scale {get; set;}

Property Value

The number of decimal places to which column value is resolved. The default value is 0.

Remarks

Use Scale property to set the scale of number columns.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Size Property
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumn Class : Size Property

Gets or sets the maximum size, in bytes, of the data within the column.

Syntax

Visual Basic (Declaration)
Public Overridable Property Size As Integer
C#
public virtual int Size {get; set;}

Property Value

The maximum size, in bytes, of the data within the column.

Remarks

Use Size property to set maximum size in bytes of data for the column. Size is used only for string columns.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
public void GetDataColumns(OracleConnection myConnection)
{

  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumn Class
DbLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumnCollection Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbLoaderColumnCollection Class

Represents a collection of columns relevant to a DbLoader.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.DbLoaderColumnCollection
Devart.Data.Oracle.OracleLoaderColumnCollection

Syntax

Visual Basic (Declaration)
Public Class DbLoaderColumnCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public class DbLoaderColumnCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

Use Devart.Common.DbLoaderColumnCollection class to add or remove columns that will be loaded. Order and number of columns in the collection must be equal to the order and number of columns in the loaded table.

Example

Following example displays all loader columns.
C#csharp Copy Code
public void DisplayColumns(string tableName, OracleConnection conn) {

  // Create loader instance
  OracleLoader loader = new OracleLoader();

  // Set up working connection
  // Connection must be opened
  loader.Connection = conn;

  // Set up table name for loading
  loader.TableName = tableName;

  // Create column collection for loading table
  loader.CreateColumns();

  // Iterate through column collection
  foreach (OracleLoaderColumn column in loader.Columns)
    Console.WriteLine(column.Name);
}
C#Visual Basic Copy Code
Public Sub DisplayColumns(tableName as string, conn as OracleConnection)

  ' Create loader instance
  Dim loader as OracleLoader = new OracleLoader()

  ' Set up working connection
  ' Connection must be opened
  loader.Connection = conn

  ' Set up table name for loading
  loader.TableName = tableName

  ' Create column collection for loading table
  loader.CreateColumns()

  ' Iterate through column collection
  Dim column as OracleLoaderColumn
  For Each column in loader.Columns
    Console.WriteLine(column.Name)
  Next
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbLoaderColumnCollection Members
Devart.Common Namespace
DbLoader Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumnCollection Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbLoaderColumnCollection Class

The following tables list the members exposed by DbLoaderColumnCollection.

Public Constructors

 | Name | Description
public Constructor | DbLoaderColumnCollection Constructor | Initializes a new instance of the Devart.Common.DbLoaderColumnCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets or sets the Devart.Common.DbLoaderColumn at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Adds the specified Devart.Common.DbLoaderColumn to the Devart.Common.DbLoaderColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection.
public Method | CopyTo | Copies Devart.Common.DbLoaderColumn objects from the Devart.Common.DbLoaderColumnCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location in the collection of the Devart.Common.DbLoaderColumn object.
public Method | Insert | Inserts a Devart.Common.DbLoaderColumn into the collection at the specified index.
public Method | Remove | Removes the specified Devart.Common.DbLoaderColumn object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

DbLoaderColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbLoaderColumnCollection Constructor
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : DbLoaderColumnCollection Constructor

Initializes a new instance of the Devart.Common.DbLoaderColumnCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DbLoaderColumnCollection()

Remarks

The base constructor initializes all fields to their default values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumnCollection Class Methods
See Also support@devart.com
Devart.Common Namespace : DbLoaderColumnCollection Class

For a list of all members of this type, see DbLoaderColumnCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds the specified Devart.Common.DbLoaderColumn to the Devart.Common.DbLoaderColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection.
public Method | CopyTo | Copies Devart.Common.DbLoaderColumn objects from the Devart.Common.DbLoaderColumnCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location in the collection of the Devart.Common.DbLoaderColumn object.
public Method | Insert | Inserts a Devart.Common.DbLoaderColumn into the collection at the specified index.
public Method | Remove | Removes the specified Devart.Common.DbLoaderColumn object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

DbLoaderColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : Add Method

value
The Devart.Common.DbLoaderColumn to add to the collection.
Adds the specified Devart.Common.DbLoaderColumn to the Devart.Common.DbLoaderColumnCollection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As DbLoaderColumn _
) As Integer
C#
public int Add(
   DbLoaderColumn value
)

Parameters

value
The Devart.Common.DbLoaderColumn to add to the collection.

Return Value

Index of the new Devart.Common.DbLoaderColumn object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
DbLoaderColumn Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : Contains Method

Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection.

Overload List

Overload | Description
Contains(DbLoaderColumn) | Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection.
Contains(String) | Gets a value indicating whether a Devart.Common.DbLoaderColumn object with the specified name exists in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(DbLoaderColumn) Method
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > Contains Method : Contains(DbLoaderColumn) Method

value
The value of the Devart.Common.DbLoaderColumn object to find.
Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As DbLoaderColumn _
) As Boolean
C#
public bool Contains(
   DbLoaderColumn value
)

Parameters

value
The value of the Devart.Common.DbLoaderColumn object to find.

Return Value

true if the collection contains the Devart.Common.DbLoaderColumn; otherwise, false.

Example

The following example searches for a Devart.Common.DbLoaderColumn within a Devart.Common.DbLoaderColumnCollection. If the column exists, the example displays the index of the column. If the column does not exist, the example displays an error. This example assumes that a Devart.Common.DbLoaderColumnCollection has already been created.
C#csharp Copy Code
public void SearchMyColumns() {
  // ...
  // create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  // ...
  if (!myColumns.Contains((Object) myNewColumn))
    MessageBox.Show("ERROR: no such column in the collection");
  else
    MessageBox.Show("match on column #" +
      myColumns.IndexOf((Object) myNewColumn).ToString());
}
C#Visual Basic Copy Code
Public Sub SearchMyColumns()
  ' ...
  ' create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  ' ...
  If Not myColumns.Contains(CType(myNewColumn, Object)) Then
    MessageBox.Show("ERROR: no such column in the collection")
  Else
    MessageBox.Show("match on column #" & myColumns.IndexOf(CType(myNewColumn, Object)).ToString())
  End If
End Sub 'SearchMyColumns

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(String) Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > Contains Method : Contains(String) Method

name
The name of the column to find.
Gets a value indicating whether a Devart.Common.DbLoaderColumn object with the specified name exists in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal name As String _
) As Boolean
C#
public bool Contains(
   string name
)

Parameters

name
The name of the column to find.

Return Value

true if the collection contains the Devart.Common.DbLoaderColumn; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : CopyTo Method

array
The array into which to copy the Devart.Common.DbLoaderColumn objects.
index
The zero-based index of the array.
Copies Devart.Common.DbLoaderColumn objects from the Devart.Common.DbLoaderColumnCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As DbLoaderColumn, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   DbLoaderColumn[] array,
   int index
)

Parameters

array
The array into which to copy the Devart.Common.DbLoaderColumn objects.
index
The zero-based index of the array.

Example

The following example exports the Devart.Common.DbLoaderColumnCollection to an array of Devart.Data.Oracle.OracleLoaderColumn objects, doubles the size of the array by using CopyTo and returns the collection. It then clears the collection, and returns true if the columns are no longer persisting. This example assumes that a Devart.Common.DbLoaderColumnCollection has already been created.
C#csharp Copy Code
public bool DoubleYourColumns() {
  // ...
  // create OracleLoaderColumnCollection myColumns
  // ...
  OracleLoaderColumn[] myColumnArray = new OracleLoaderColumn[(2*myColumns.Count) - 1];
  myColumns.CopyTo(myColumnArray, 0);
  myColumns.CopyTo(myColumnArray, myColumns.Count);
  myColumns.Clear();
  return true;
}
C#Visual Basic Copy Code
Public Function DoubleYourColumns() As Boolean
  ' ...
  ' create OracleLoaderColumnCollection myColumns
  ' ...
  Dim myColumnArray(2 * myColumns.Count - 1) As OracleLoaderColumn
  myColumns.CopyTo(myColumnArray, 0)
  myColumns.CopyTo(myColumnArray, myColumns.Count)
  myColumns.Clear()
  Return True
End Function 'DoubleYourColumns

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : IndexOf Method

Gets the location in the collection of the Devart.Common.DbLoaderColumn object.

Overload List

Overload | Description
IndexOf(DbLoaderColumn) | Gets the location in the collection of the Devart.Common.DbLoaderColumn object.
IndexOf(String) | Gets the location in the collection of the Devart.Common.DbLoaderColumn object by the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf(DbLoaderColumn) Method
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > IndexOf Method : IndexOf(DbLoaderColumn) Method

value
The Devart.Common.DbLoaderColumn object to find.
Gets the location in the collection of the Devart.Common.DbLoaderColumn object.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As DbLoaderColumn _
) As Integer
C#
public int IndexOf(
   DbLoaderColumn value
)

Parameters

value
The Devart.Common.DbLoaderColumn object to find.

Return Value

The zero-based location of the Devart.Common.DbLoaderColumn in the collection.

Example

The following example searches for a Devart.Common.DbLoaderColumn within a Devart.Common.DbLoaderColumnCollection. If the column exists, the example displays the index of the column. If the column does not exist, the example displays an error. This example assumes that a Devart.Common.DbLoaderColumnCollection has already been created.
C#csharp Copy Code
public void SearchMyColumns() {
  // ...
  // create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  // ...
  if (!myColumns.Contains((Object) myNewColumn))
    MessageBox.Show("ERROR: no such column in the collection");
  else
    MessageBox.Show("match on column #" +
      myColumns.IndexOf((Object) myNewColumn).ToString());
}
C#Visual Basic Copy Code
Public Sub SearchMyColumns()
  ' ...
  ' create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  ' ...
  If Not myColumns.Contains(CType(myNewColumn, Object)) Then
    MessageBox.Show("ERROR: no such column in the collection")
  Else
    MessageBox.Show("match on column #" & myColumns.IndexOf(CType(myNewColumn, Object)).ToString())
  End If
End Sub 'SearchMyColumns

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List
Contains Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf(String) Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > IndexOf Method : IndexOf(String) Method

name
The name of the column to find.
Gets the location in the collection of the Devart.Common.DbLoaderColumn object by the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal name As String _
) As Integer
C#
public int IndexOf(
   string name
)

Parameters

name
The name of the column to find.

Return Value

The zero-based location of the Devart.Common.DbLoaderColumn in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List
Contains Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : Insert Method

index
The zero-based index where the column is to be inserted within the collection.
value
The Devart.Common.DbLoaderColumn to add to the collection.
Inserts a Devart.Common.DbLoaderColumn into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As DbLoaderColumn _
)
C#
public void Insert(
   int index,
   DbLoaderColumn value
)

Parameters

index
The zero-based index where the column is to be inserted within the collection.
value
The Devart.Common.DbLoaderColumn to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also Example support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : Remove Method

value
The Devart.Common.DbLoaderColumn object to remove from the collection.
Removes the specified Devart.Common.DbLoaderColumn object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As DbLoaderColumn _
)
C#
public void Remove(
   DbLoaderColumn value
)

Parameters

value
The Devart.Common.DbLoaderColumn object to remove from the collection.

Example

The following example searches for a Devart.Data.Oracle.OracleLoaderColumn object in a Devart.Data.Oracle.OracleLoaderColumnCollection. If the column exists, it is removed. This example assumes that a Devart.Data.Oracle.OracleLoaderColumnCollection has already been created.
C#csharp Copy Code
public void SearchMyColumns() {
  // ...
  // create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  // ...
  if (myColumns.Contains((Object) myNewColumn))
    myColumns.Remove(((Object) myNewColumn).ToString());
}
C#Visual Basic Copy Code
Public Sub SearchMyColumns()
  ' ...
  ' create OracleLoaderColumnCollection myColumns and OracleLoaderColumn myNewColumn
  ' ...
  If myColumns.Contains(CType(myNewColumn, Object)) Then
    myColumns.Remove(CType(myNewColumn, Object).ToString())
  End If
End Sub 'SearchMyColumns

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbLoaderColumnCollection Class Properties
See Also support@devart.com
Devart.Common Namespace : DbLoaderColumnCollection Class

For a list of all members of this type, see DbLoaderColumnCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets or sets the Devart.Common.DbLoaderColumn at the specified index.
Top

See Also

Reference

DbLoaderColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class : Item Property

Gets or sets the Devart.Common.DbLoaderColumn at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the Devart.Common.DbLoaderColumn at the specified index.
Item(String) | Gets or sets the Devart.Common.DbLoaderColumn with the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the column.
Gets or sets the Devart.Common.DbLoaderColumn at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As DbLoaderColumn
C#
public DbLoaderColumn Item(
   int index
) {get; set;}

Parameters

index
The zero-based index of the column.

Property Value

The Devart.Common.DbLoaderColumn at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Common Namespace > DbLoaderColumnCollection Class > Item Property : Item(String) Property

name
The name of the column.
Gets or sets the Devart.Common.DbLoaderColumn with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal name As String _
) As DbLoaderColumn
C#
public DbLoaderColumn Item(
   string name
) {get; set;}

Parameters

name
The name of the column.

Property Value

The Devart.Common.DbLoaderColumn with the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbLoaderColumnCollection Class
DbLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbMonitor Class
Members See Also support@devart.com
Devart.Common Namespace : DbMonitor Class

Allows to monitor dynamic SQL execution in applications that use .NET data providers.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbMonitor
Devart.Common.DbMonitorHelper

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbMonitor
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public abstract class DbMonitor : System.ComponentModel.Component, IComponent, IDisposable

Remarks

You can survey what happens in data provider components in two ways. First, you can handle DbMonitor.TraceEvent and perform necessary actions in the event handler. Second, if dbMonitor application is running and your edition of provider supports it, you will see execution logs in dbMonitor.

To enable monitoring just drop DbMonitor component to the form and set IsActive property to true. If dbMonitor application has already been started you can see messages and SQL statements that your application executes. For monitoring you need only one DbMonitor component on any of the forms your application consists of.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbMonitor Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbMonitor Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbMonitor Class

The following tables list the members exposed by DbMonitor.

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application.
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default.
public Property | IsActive | Enables or disables monitoring applications.
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application.
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when DbMonitor object signals about some database activity.
Top

See Also

Reference

DbMonitor Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbMonitor Class Properties
See Also support@devart.com
Devart.Common Namespace : DbMonitor Class

For a list of all members of this type, see DbMonitor members.

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application.
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default.
public Property | IsActive | Enables or disables monitoring applications.
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application.
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window.
Top

See Also

Reference

DbMonitor Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EventQueueLimit Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : EventQueueLimit Property

Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application.

Syntax

Visual Basic (Declaration)
Public Property EventQueueLimit As Integer
C#
public int EventQueueLimit {get; set;}

Property Value

The maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application.

Remarks

Default value is 1000. Zero means no limit for queue size. If the number of unprocessed events exceeds EventQueueLimit, extra events are discarded.

This property is designed for monitoring applications that generate events at a high rate: if no queue limit is set, storing all unprocessed events may cause memory leaks for such applications.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Host Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : Host Property

Gets or sets the host where the dbMonitor application is running, 'localhost' by default.

Syntax

Visual Basic (Declaration)
Public Property Host As String
C#
public string Host {get; set;}

Property Value

The host where the dbMonitor application is running, 'localhost' by default.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsActive Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : IsActive Property

Enables or disables monitoring applications.

Syntax

Visual Basic (Declaration)
Public MustOverride Property IsActive As Boolean
C#
public abstract bool IsActive {get; set;}

Property Value

true if monitoring the application is enabled; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Port Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : Port Property

Gets or sets the port of the dbMonitor application to which to connect, 1000 by default.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Property Value

Port of the dbMonitor application to which to connect, 1000 by default.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UseApp Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : UseApp Property

Disables or enables sending database interaction events to dbMonitor application.

Syntax

Visual Basic (Declaration)
Public Property UseApp As Boolean
C#
public bool UseApp {get; set;}

Property Value

true if sending database interaction events to dbMonitor application is enabled; otherwise, false.

Remarks

If you don't use dbMonitor application, set this property to false to avoid spending resources to send database interaction events.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UseIdeOutput Property
See Also support@devart.com
Devart.Common Namespace > DbMonitor Class : UseIdeOutput Property

Enables or disables writing log messages to the IDE output window.

Syntax

Visual Basic (Declaration)
Public Property UseIdeOutput As Boolean
C#
public bool UseIdeOutput {get; set;}

Property Value

If true, the DbMonitor object writes its information to the Output window (Visual Studio) or Messages window (Delphi).

Remarks

This property is applicable when you debug your projects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbMonitor Class Events
See Also support@devart.com
Devart.Common Namespace : DbMonitor Class

For a list of all members of this type, see DbMonitor members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when DbMonitor object signals about some database activity.
Top

See Also

Reference

DbMonitor Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TraceEvent Event
See Also Example support@devart.com
Devart.Common Namespace > DbMonitor Class : TraceEvent Event

Occurs when DbMonitor object signals about some database activity.

Syntax

Visual Basic (Declaration)
Public Event TraceEvent As MonitorEventHandler
C#
public event MonitorEventHandler TraceEvent

Event Data

The event handler receives an argument of type MonitorEventArgs containing data related to this event. The following MonitorEventArgs properties provide information specific to this event.

Property | Description
CallStack | Gets the call stack of the monitor event.
Description | Gets the description of a DbMonitor event.
Duration | The time between the start and the end of the event.
EventType | Gets DbMonitor event type.
ExtraInfo | Gets the additional information for a DbMonitor event.
TracePoint | Determines whether DbMonitor.TraceEvent event occurs before or after the operation takes place.

Example

The following sample shows how to enable and disable monitoring of database activity in your application.
C#csharp Copy Code
static void OnEvent(object sender, MonitorEventArgs e)
{
  if (e.TracePoint==MonitorTracePoint.BeforeEvent)
  {
    Console.WriteLine("Description: " + e.Description);
    Console.WriteLine(" Extra info: " + e.ExtraInfo);
  }
}

[MTAThread]
static void Main(string[] args)
{
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  OracleMonitor myMonitor = new OracleMonitor();
  myMonitor.TraceEvent += new MonitorEventHandler(OnEvent);
  myMonitor.IsActive = true;
  OracleCommand myCommand = new OracleCommand("select count(*) from Dept",myConn);
  myConn.Open();
  Console.WriteLine(myCommand.ExecuteScalar());
  myConn.Close();
  myMonitor.TraceEvent -= new MonitorEventHandler(OnEvent);
  Console.ReadLine();
}
C#Visual Basic Copy Code
Sub OnEvent(ByVal sender As Object, ByVal e As MonitorEventArgs)
  If e.TracePoint = MonitorTracePoint.BeforeEvent Then
    Console.WriteLine("Description: " & e.Description)
    Console.WriteLine(" Extra info: " & e.ExtraInfo)
  End If
End Sub

<MTAThread()> _
Sub Main()
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myMonitor As OracleMonitor = New OracleMonitor
  AddHandler myMonitor.TraceEvent, AddressOf OnEvent
  myMonitor.IsActive = True
  Dim myCommand As OracleCommand = New OracleCommand("select count(*) from Dept", myConn)
  myConn.Open()
  Console.WriteLine(myCommand.ExecuteScalar())
  myConn.Close()
  RemoveHandler myMonitor.TraceEvent, AddressOf OnEvent
  Console.ReadLine()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbMonitor Class
DbMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbParameterBase Class
Members See Also support@devart.com
Devart.Common Namespace : DbParameterBase Class

Represents a parameter to a DbCommandBase, and optionally, its mapping to System.Data.DataSet columns.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbParameter
Devart.Common.DbParameterBase
Devart.Data.Oracle.OracleParameter

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbParameterBase
   Inherits System.Data.Common.DbParameter
   Implements IDataParameter, IDbDataParameter
C#
public abstract class DbParameterBase : System.Data.Common.DbParameter, IDataParameter, IDbDataParameter

Remarks

Abstract DbParameterBase class implements some of Devart.Data.Oracle.OracleParameter functionality that is data source-independent.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbParameterBase Members
Devart.Common Namespace
OracleParameter Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbParameterBase Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbParameterBase Class

The following tables list the members exposed by DbParameterBase.

Public Properties

 | Name | Description
public Property | DbType | Gets or sets the System.Data.DbType of the parameter. (Inherited from System.Data.Common.DbParameter)
public Property | Direction | Overridden. Gets or sets a value indicating whether the parameter is input-only, output-only, or bidirectional parameter.
public Property | IsNullable | Overridden. Gets or sets a value indicating whether the parameter accepts null values.
public Property | ParameterName | Overridden. Gets or sets the name of the DbParameterBase.
public Property | Size | Overridden. Gets or sets the maximum size, in bytes, of the data within the column.
public Property | SourceColumn | Overridden. Gets or sets the name of the source column mapped to the System.Data.DataSet and used for loading or returning the Value. For internal use.
public Property | SourceColumnNullMapping | Overridden. Sets or gets a value which indicates whether the source column is nullable.
public Property | SourceVersion | Overridden. Gets or sets the System.Data.DataRowVersion to use when loading Value.
public Property | Value | Overridden. Gets or sets the value of the parameter.
Top

Public Methods

 | Name | Description
public Method | CopyTo | Copies all properties of a DbParameterBase object to another DbParameterBase object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ResetDbType | Resets the DbType property to its original settings. (Inherited from System.Data.Common.DbParameter)
public Method | ToString | Gets the name of the DbParameterBase.
Top

See Also

Reference

DbParameterBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbParameterBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbParameterBase Class

For a list of all members of this type, see DbParameterBase members.

Public Methods

 | Name | Description
public Method | CopyTo | Copies all properties of a DbParameterBase object to another DbParameterBase object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ResetDbType | Resets the DbType property to its original settings. (Inherited from System.Data.Common.DbParameter)
public Method | ToString | Gets the name of the DbParameterBase.
Top

See Also

Reference

DbParameterBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : CopyTo Method

destination
The System.Data.DbParameterBase object to copy properties to.
Copies all properties of a DbParameterBase object to another DbParameterBase object.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal destination As DbParameter _
)
C#
public void CopyTo(
   DbParameter destination
)

Parameters

destination
The System.Data.DbParameterBase object to copy properties to.

Remarks

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : ToString Method

Gets the name of the DbParameterBase.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The name of the DbParameterBase.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbParameterBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbParameterBase Class

For a list of all members of this type, see DbParameterBase members.

Public Properties

 | Name | Description
public Property | DbType | Gets or sets the System.Data.DbType of the parameter. (Inherited from System.Data.Common.DbParameter)
public Property | Direction | Overridden. Gets or sets a value indicating whether the parameter is input-only, output-only, or bidirectional parameter.
public Property | IsNullable | Overridden. Gets or sets a value indicating whether the parameter accepts null values.
public Property | ParameterName | Overridden. Gets or sets the name of the DbParameterBase.
public Property | Size | Overridden. Gets or sets the maximum size, in bytes, of the data within the column.
public Property | SourceColumn | Overridden. Gets or sets the name of the source column mapped to the System.Data.DataSet and used for loading or returning the Value. For internal use.
public Property | SourceColumnNullMapping | Overridden. Sets or gets a value which indicates whether the source column is nullable.
public Property | SourceVersion | Overridden. Gets or sets the System.Data.DataRowVersion to use when loading Value.
public Property | Value | Overridden. Gets or sets the value of the parameter.
Top

See Also

Reference

DbParameterBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Direction Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : Direction Property

Gets or sets a value indicating whether the parameter is input-only, output-only, or bidirectional parameter.

Syntax

Visual Basic (Declaration)
Public Overrides Property Direction As ParameterDirection
C#
public override ParameterDirection Direction {get; set;}

Property Value

One of the System.Data.ParameterDirection values. The default value is Input.

Remarks

If the System.Data.ParameterDirection is Output, and execution of the associated DbCommandBase does not return a value, the DbParameterBase will contain a null value. Null values are handled using the System.DBNull class.

After the last row from the last result set is read, the Output, InputOut, and ReturnValue parameters are updated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNullable Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : IsNullable Property

Gets or sets a value indicating whether the parameter accepts null values.

Syntax

Visual Basic (Declaration)
Public Overrides Property IsNullable As Boolean
C#
public override bool IsNullable {get; set;}

Property Value

true if null values are accepted; otherwise, false. The default value is false.

Remarks

Null values are handled using the System.DBNull class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParameterName Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : ParameterName Property

Gets or sets the name of the DbParameterBase.

Syntax

Visual Basic (Declaration)
Public Overrides Property ParameterName As String
C#
public override string ParameterName {get; set;}

Property Value

The name of the DbParameterBase. The default value is an empty string ("").

Remarks

You must set ParameterName before executing a DbCommandBase that relies on parameters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Size Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : Size Property

Gets or sets the maximum size, in bytes, of the data within the column.

Syntax

Visual Basic (Declaration)
Public Overrides Property Size As Integer
C#
public override int Size {get; set;}

Property Value

The maximum size, in bytes, of the data within the column. The default value is inferred from the parameter value.

Remarks

The Size property is used for binary and string types.

For variable-length data types, the Size property describes the maximum amount of data to transmit to the server. For example, for a string value, the Size property could be used to limit the amount of data sent to the server to the first one hundred bytes.

For nonstring data types and ANSI string data, the Size property refers to the number of bytes. For Unicode string data, the Size property refers to the number of characters. The count for strings does not include the terminating character.

If not explicitly set, the value of Size is inferred from the actual size of the specified parameter value.

For fixed-width data types, the value of Size is ignored. It can be retrieved for informational purposes, and returns the maximum amount of bytes the provider uses when transmitting the value of the parameter to the server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SourceColumn Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : SourceColumn Property

Gets or sets the name of the source column mapped to the System.Data.DataSet and used for loading or returning the Value. For internal use.

Syntax

Visual Basic (Declaration)
Public Overrides Property SourceColumn As String
C#
public override string SourceColumn {get; set;}

Property Value

The name of the source column that will be used to set the value of this parameter. The default value is an empty string ("").

Remarks

When SourceColumn property is set to anything other than an empty string, the value of the parameter is retrieved from the column with the SourceColumn name. If Direction is set to Input, the value is taken from the System.Data.DataSet. If Direction is set to Output, the value is taken from the data source. A Direction of InputOutput is a combination of both.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SourceColumnNullMapping Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : SourceColumnNullMapping Property

Sets or gets a value which indicates whether the source column is nullable.

Syntax

Visual Basic (Declaration)
Public Overrides Property SourceColumnNullMapping As Boolean
C#
public override bool SourceColumnNullMapping {get; set;}

Property Value

true if source column is nullable; otherwise, false. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SourceVersion Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : SourceVersion Property

Gets or sets the System.Data.DataRowVersion to use when loading Value.

Syntax

Visual Basic (Declaration)
Public Overrides Property SourceVersion As DataRowVersion
C#
public override DataRowVersion SourceVersion {get; set;}

Property Value

One of the System.Data.DataRowVersion values. The default value is Current.

Remarks

The SourceVersion is used by DbDataAdapter.UpdateCommand during an System.Data.Common.DbDataAdapter.Update() operation to determine whether the parameter value is set to Current or Original. This allows primary keys to be updated. This property is ignored by DbDataAdapter.InsertCommand and DbDataAdapter.DeleteCommand.

This property is set to the version of the System.Data.DataRow used by either the System.Data.DataRow.Item property (System.Data.DataRow indexer), or the System.Data.DataRow.GetChildRows() method of the System.Data.DataRow object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBase Class : Value Property

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Public Overrides Property Value As Object
C#
public override object Value {get; set;}

Property Value

An System.Object that is the value of the parameter. The default value is null.

Remarks

For input parameters, the value is bound to the DbCommandBase that is sent to the server. For output and return-value parameters, the value is set on completion of the DbCommandBase and after the DbDataReaderBase is closed.

When sending a null parameter value to the server, the user must specify System.DBNull, not null. A null value in the system is an empty object that has no value. System.DBNull is used to represent null values.

If the application specifies the data type, the bound value is converted to that type when the provider sends the data to the server. The provider attempts to convert any type of value if it supports the IConvertible interface. Conversion errors may result if the specified type is not compatible with the value.

The DbType property can be inferred by setting Value. If applicable, the size, precision, and scale will also be inferred from Value.

The Value property is overwritten by the System.Data.Common.DbDataAdapter.Update() method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBase Class
DbParameterBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbParameterBaseCollection Class
Members See Also support@devart.com
Devart.Common Namespace : DbParameterBaseCollection Class

Collects all parameters relevant to a DbCommandBase as well as their respective mappings to System.Data.DataSet columns.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbParameterCollection
Devart.Common.DbParameterBaseCollection
Devart.Data.Oracle.OracleParameterCollection

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbParameterBaseCollection
   Inherits System.Data.Common.DbParameterCollection
   Implements ICollection, IEnumerable, IList, IDataParameterCollection
C#
public abstract class DbParameterBaseCollection : System.Data.Common.DbParameterCollection, ICollection, IEnumerable, IList, IDataParameterCollection

Remarks

Abstract DbParameterBaseCollection class implements some of Devart.Data.Oracle.OracleParameterCollection functionality that is DBMS-independent.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbParameterBaseCollection Members
Devart.Common Namespace
OracleParameterCollection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbParameterBaseCollection Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbParameterBaseCollection Class

The following tables list the members exposed by DbParameterBaseCollection.

Public Properties

 | Name | Description
public Property | Count | Overridden. Gets the number of DbParameterBase objects in the collection.
public Property | IsFixedSize | Overridden. Indicating whether the collection has a fixed size.
public Property | IsReadOnly | Overridden. Indicates whether the collection is read-only.
public Property | IsSynchronized | Overridden. Indicates whether access to the collection is synchronized (thread-safe).
public Property | Item | Overloaded. Gets and sets the System.Data.Common.DbParameter at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Property | SyncRoot | Overridden. Gets an object that can be used to synchronize access to the DbParameterBaseCollection.
Top

Public Methods

 | Name | Description
public Method | AddRange | Overridden. Adds the specified array of DbParameterBase objects to the DbParameterBaseCollection.
public Method | Clear | Overridden. Removes all items from the collection.
public Method | Contains | Overloaded. Overridden. Gets a value indicating whether a DbParameterBase object exists in the collection.
public Method | CopyTo | Overridden. Copies a DbParameterBase objects from the DbParameterBaseCollection to the specified array.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetEnumerator | Overridden. Returns an enumerator for the DbParameterBaseCollection.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IndexOf | Overloaded. Overridden. Gets the location in the collection of the DbParameterBase objects.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Overridden. Inserts a DbParameterBase into the collection at the specified index.
public Method | Remove | Overridden. Removes the specified DbParameterBase from the collection.
public Method | RemoveAt | Overloaded. Overridden. Removes the specified DbParameterBase from the collection.
Top

See Also

Reference

DbParameterBaseCollection Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbParameterBaseCollection Class Methods
See Also support@devart.com
Devart.Common Namespace : DbParameterBaseCollection Class

For a list of all members of this type, see DbParameterBaseCollection members.

Public Methods

 | Name | Description
public Method | AddRange | Overridden. Adds the specified array of DbParameterBase objects to the DbParameterBaseCollection.
public Method | Clear | Overridden. Removes all items from the collection.
public Method | Contains | Overloaded. Overridden. Gets a value indicating whether a DbParameterBase object exists in the collection.
public Method | CopyTo | Overridden. Copies a DbParameterBase objects from the DbParameterBaseCollection to the specified array.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetEnumerator | Overridden. Returns an enumerator for the DbParameterBaseCollection.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IndexOf | Overloaded. Overridden. Gets the location in the collection of the DbParameterBase objects.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Overridden. Inserts a DbParameterBase into the collection at the specified index.
public Method | Remove | Overridden. Removes the specified DbParameterBase from the collection.
public Method | RemoveAt | Overloaded. Overridden. Removes the specified DbParameterBase from the collection.
Top

See Also

Reference

DbParameterBaseCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddRange Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : AddRange Method

values
Array of DbParameterBase objects to be added to the DbParameterBaseCollection.
Adds the specified array of DbParameterBase objects to the DbParameterBaseCollection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddRange( _
   ByVal values As Array _
)
C#
public override void AddRange(
   Array values
)

Parameters

values
Array of DbParameterBase objects to be added to the DbParameterBaseCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : Clear Method

Removes all items from the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : Contains Method

Gets a value indicating whether a DbParameterBase object exists in the collection.

Overload List

Overload | Description
Contains(Object) | Gets a value indicating whether a DbParameterBase object exists in the collection.
Contains(String) | Gets a value indicating whether a DbParameterBase object with the specified parameter name exists in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(Object) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > Contains Method : Contains(Object) Method

value
The value of the DbParameterBase object to find.
Gets a value indicating whether a DbParameterBase object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public override bool Contains(
   object value
)

Parameters

value
The value of the DbParameterBase object to find.

Return Value

true if the collection contains the DbParameterBase; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(String) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > Contains Method : Contains(String) Method

value
The name of the DbParameterBase object to find.
Gets a value indicating whether a DbParameterBase object with the specified parameter name exists in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Contains( _
   ByVal value As String _
) As Boolean
C#
public override bool Contains(
   string value
)

Parameters

value
The name of the DbParameterBase object to find.

Return Value

true if the collection contains the DbParameterBase; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : CopyTo Method

array
The array into which to copy the DbParameterBase objects.
index
The zero-based index of the array.
Copies a DbParameterBase objects from the DbParameterBaseCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public override void CopyTo(
   Array array,
   int index
)

Parameters

array
The array into which to copy the DbParameterBase objects.
index
The zero-based index of the array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : GetEnumerator Method

Returns an enumerator for the DbParameterBaseCollection.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator() As IEnumerator
C#
public override IEnumerator GetEnumerator()

Return Value

An enumerator for the DbParameterBaseCollection.

Remarks

Enumerators allow only reading the data in the collection and cannot be used to modify it.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : IndexOf Method

Gets the location in the collection of the DbParameterBase objects.

Overload List

Overload | Description
IndexOf(Object) | Gets the location in the collection of the DbParameterBase objects.
IndexOf(String) | Gets the location in the collection of the DbParameterBase object with a specific parameter name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf(Object) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > IndexOf Method : IndexOf(Object) Method

value
The DbParameterBase object to find.
Gets the location in the collection of the DbParameterBase objects.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public override int IndexOf(
   object value
)

Parameters

value
The DbParameterBase object to find.

Return Value

The zero-based location of the DbParameterBase in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf(String) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > IndexOf Method : IndexOf(String) Method

parameterName
The name of the parameter to retrieve.
Gets the location in the collection of the DbParameterBase object with a specific parameter name.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IndexOf( _
   ByVal parameterName As String _
) As Integer
C#
public override int IndexOf(
   string parameterName
)

Parameters

parameterName
The name of the parameter to retrieve.

Return Value

The zero-based location of the DbParameterBase in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : Insert Method

index
The zero-based index where the parameter is to be inserted within the collection.
value
The DbParameterBase object to add to the collection.
Inserts a DbParameterBase into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public override void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index where the parameter is to be inserted within the collection.
value
The DbParameterBase object to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : Remove Method

value
The DbParameterBase object to remove from the collection.
Removes the specified DbParameterBase from the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal value As Object _
)
C#
public override void Remove(
   object value
)

Parameters

value
The DbParameterBase object to remove from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : RemoveAt Method

Removes the specified DbParameterBase from the collection.

Overload List

Overload | Description
RemoveAt(Int32) | Removes the DbParameterBase at the specified index from the collection.
RemoveAt(String) | Removes the DbParameterBase with the specified name from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt(Int32) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > RemoveAt Method : RemoveAt(Int32) Method

index
The zero-based index of the parameter to remove.
Removes the DbParameterBase at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public override void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the parameter to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt(String) Method
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class > RemoveAt Method : RemoveAt(String) Method

parameterName
The name of the parameter to remove.
Removes the DbParameterBase with the specified name from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub RemoveAt( _
   ByVal parameterName As String _
)
C#
public override void RemoveAt(
   string parameterName
)

Parameters

parameterName
The name of the parameter to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbParameterBaseCollection Class Properties
See Also support@devart.com
Devart.Common Namespace : DbParameterBaseCollection Class

For a list of all members of this type, see DbParameterBaseCollection members.

Public Properties

 | Name | Description
public Property | Count | Overridden. Gets the number of DbParameterBase objects in the collection.
public Property | IsFixedSize | Overridden. Indicating whether the collection has a fixed size.
public Property | IsReadOnly | Overridden. Indicates whether the collection is read-only.
public Property | IsSynchronized | Overridden. Indicates whether access to the collection is synchronized (thread-safe).
public Property | Item | Overloaded. Gets and sets the System.Data.Common.DbParameter at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Property | SyncRoot | Overridden. Gets an object that can be used to synchronize access to the DbParameterBaseCollection.
Top

See Also

Reference

DbParameterBaseCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : Count Property

Gets the number of DbParameterBase objects in the collection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Count As Integer
C#
public override int Count {get;}

Property Value

The number of DbParameterBase objects in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsFixedSize Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : IsFixedSize Property

Indicating whether the collection has a fixed size.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsFixedSize As Boolean
C#
public override bool IsFixedSize {get;}

Property Value

true if the collection has a fixed size; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsReadOnly Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : IsReadOnly Property

Indicates whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
C#
public override bool IsReadOnly {get;}

Property Value

true if the collection is read-only; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsSynchronized Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : IsSynchronized Property

Indicates whether access to the collection is synchronized (thread-safe).

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsSynchronized As Boolean
C#
public override bool IsSynchronized {get;}

Property Value

true if access to the collection is synchronized (thread-safe); otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncRoot Property
See Also support@devart.com
Devart.Common Namespace > DbParameterBaseCollection Class : SyncRoot Property

Gets an object that can be used to synchronize access to the DbParameterBaseCollection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SyncRoot As Object
C#
public override object SyncRoot {get;}

Property Value

An object that can be used to synchronize access to the DbParameterBaseCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbParameterBaseCollection Class
DbParameterBaseCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbProviderException Class
Members See Also support@devart.com
Devart.Common Namespace : DbProviderException Class

The base class for all exceptions thrown on data provider side. This does not include data source exceptions.

Inheritance Hierarchy

System.Object
System.Exception
Devart.Common.DbProviderException
Devart.Data.Oracle.OracleProviderException

Syntax

Visual Basic (Declaration)
Public Class DbProviderException
   Inherits System.Exception
   Implements _Exception, ISerializable
C#
public class DbProviderException : System.Exception, _Exception, ISerializable

Remarks

The DbProviderException class is also used as the base class for provider-specific exception class implementations.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbProviderException Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbProviderException Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : DbProviderException Class

The following tables list the members exposed by DbProviderException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
public Method | ToString | Gets the exception text.
Top

See Also

Reference

DbProviderException Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbProviderException Class Methods
See Also support@devart.com
Devart.Common Namespace : DbProviderException Class

For a list of all members of this type, see DbProviderException members.

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
public Method | ToString | Gets the exception text.
Top

See Also

Reference

DbProviderException Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Common Namespace > DbProviderException Class : ToString Method

Gets the exception text.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The exception text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbProviderException Class
DbProviderException Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbScript Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbScript Class

Serves to execute series of SQL statements separated by special symbols.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbScript
Devart.Data.Oracle.OracleScript

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbScript
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public abstract class DbScript : System.ComponentModel.Component, IComponent, IDisposable

Remarks

Use DbScript to consecutively execute several SQL statements stored in ScriptText property. DbScript allows to execute them all at once or one by one. You can use DbScript.Progress event to monitor execution flow and DbScript.Error to catch errors.

There are three ways to execute a script:

- using Execute method;

- using ExecuteNext method;

- using SqlStatement.SqlStatement.Execute method.

For more information refer to corresponding method.

Example

This sample demonstrates how to execute script and retrieve information about execution flow using DbScript.Progress and DbScript.Error events.
C#csharp Copy Code
[STAThread]
static void Main(string[] args)
{
string script =
"DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
        ");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
      OracleConnection myConn = new OracleConnection(
          "User Id=Scott;Password=tiger;Data Source=Ora;");
      OracleScript myScript = new OracleScript(script,myConn);
      myScript.Progress += new Devart.Common.ScriptProgressEventHandler(OnProgress);
      myScript.Error += new Devart.Common.ScriptErrorEventHandler(OnError);
      myConn.Open();
      myScript.Execute();
      myConn.Close();
    }

static void OnProgress(object sender, Devart.Common.ScriptProgressEventArgs e)
{
  Console.WriteLine(e.Text);
  Console.WriteLine("  Successfully executed.");
}

static void OnError(object sender, Devart.Common.ScriptErrorEventArgs e)
{
  e.Ignore = true;
  Console.WriteLine(e.Text);
  Console.WriteLine("  Failed.");
}
C#Visual Basic Copy Code
Module Module1

  Friend WithEvents myScript As Devart.Data.Oracle.OracleScript

  Sub Main()
    Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
  "SELECT * FROM DEPT"
    Dim myConn As OracleConnection = New OracleConnection( _
        "User Id=Scott;Password=tiger;Data Source=Ora;")
    myScript = New OracleScript(script, myConn)
    myConn.Open()
    myScript.Execute()
    myConn.Close()
    Console.ReadLine()
  End Sub

  Sub OnProgress(ByVal sender As Object, ByVal e As Devart.Common.ScriptProgressEventArgs) Handles myScript.Progress
    Console.WriteLine(e.Text)
    Console.WriteLine("  Successfully executed.")
  End Sub

  Sub OnError(ByVal sender As Object, ByVal e As Devart.Common.ScriptErrorEventArgs) Handles myScript.Error
    e.Ignore = True
    Console.WriteLine(e.Text)
    Console.WriteLine("  Failed.")
  End Sub

End Module

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbScript Members
Devart.Common Namespace
SqlStatement Class
SqlStatementCollection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbScript Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbScript Class

The following tables list the members exposed by DbScript.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time before terminating an attempt to execute a script and generating an error.
public Property | Connection | Gets or sets the System.Data.IDbConnection used by this instance of the DbScript.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets the name of component that will be displayed in dbMonitor application.
public Property | ScriptText | Gets or sets script text.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Statements | Gets the collection of statements that make up the script.
Top

Public Methods

 | Name | Description
public Method | Cancel | Tries to cancel the execution of a DbScript descendant.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes the script specified in ScriptText property.
public Method | ExecuteNext | Executes the next statement from the script.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Prepares a stream to be executed as SQL script.
public Method | Reset | Positions ExecuteNext method on the first statement in the script.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when a SQL statement within script has produced an error.
public Event | Progress | Occurs when a SQL statement within script has successfully executed.
Top

See Also

Reference

DbScript Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbScript Class Methods
See Also support@devart.com
Devart.Common Namespace : DbScript Class

For a list of all members of this type, see DbScript members.

Public Methods

 | Name | Description
public Method | Cancel | Tries to cancel the execution of a DbScript descendant.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes the script specified in ScriptText property.
public Method | ExecuteNext | Executes the next statement from the script.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Prepares a stream to be executed as SQL script.
public Method | Reset | Positions ExecuteNext method on the first statement in the script.
Top

See Also

Reference

DbScript Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cancel Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class : Cancel Method

Tries to cancel the execution of a DbScript descendant.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Cancel()
C#
public virtual void Cancel()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Execute Method
See Also Example support@devart.com
Devart.Common Namespace > DbScript Class : Execute Method

Executes the script specified in ScriptText property.

Syntax

Visual Basic (Declaration)
Public Sub Execute()
C#
public void Execute()

Remarks

Use Execute method to execute the script. Text of the script should be specified by ScriptText property.

After execution of each individual statement the DbScript.Progress event fires. If the statement has produced an error, event DbScript.Error fires.

Example

This sample demonstrates how to execute script and retrieve information about execution flow using DbScript.Progress and DbScript.Error events.
C#csharp Copy Code
[STAThread]
static void Main(string[] args)
{
string script =
"DROP TABLE DEPT;"+
"CREATE TABLE DEPT ("+
"  DEPTNO NUMBER(38) NOT NULL,"+
"  DNAME VARCHAR2(14),"+
"  LOC VARCHAR2(13)"+
");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
      OracleConnection myConn = new OracleConnection(
          "User Id=Scott;Password=tiger;Data Source=Ora;");
      OracleScript myScript = new OracleScript(script,myConn);
      myScript.Progress += new Devart.Common.ScriptProgressEventHandler(OnProgress);
      myScript.Error += new Devart.Common.ScriptErrorEventHandler(OnError);
      myConn.Open();
      myScript.Execute();
      myConn.Close();
    }

static void OnProgress(object sender, Devart.Common.ScriptProgressEventArgs e)
{
  Console.WriteLine(e.Text);
  Console.WriteLine("  Successfully executed.");
}

static void OnError(object sender, Devart.Common.ScriptErrorEventArgs e)
{
  e.Ignore = true;
  Console.WriteLine(e.Text);
  Console.WriteLine("  Failed.");
}
C#Visual Basic Copy Code
Module Module1

  Friend WithEvents myScript As Devart.Data.Oracle.OracleScript

  Sub Main()
    Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _"INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
  "SELECT * FROM DEPT"
    Dim myConn As OracleConnection = New OracleConnection( _
        "User Id=Scott;Password=tiger;Data Source=Ora;")
    myScript = New OracleScript(script, myConn)
    myConn.Open()
    myScript.Execute()
    myConn.Close()
    Console.ReadLine()
  End Sub

  Sub OnProgress(ByVal sender As Object, ByVal e As Devart.Common.ScriptProgressEventArgs) Handles myScript.Progress
    Console.WriteLine(e.Text)
    Console.WriteLine("  Successfully executed.")
  End Sub

  Sub OnError(ByVal sender As Object, ByVal e As Devart.Common.ScriptErrorEventArgs) Handles myScript.Error
    e.Ignore = True
    Console.WriteLine(e.Text)
    Console.WriteLine("  Failed.")
  End Sub

End Module

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
ScriptText Property
ExecuteNext Method
Progress Event
Error Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNext(IDataReader) Method
See Also Example support@devart.com
Devart.Common Namespace > DbScript Class : ExecuteNext(IDataReader) Method

reader
DbDataReaderBase to store result set.
Executes the next statement from the script.

Syntax

Visual Basic (Declaration)
Public Function ExecuteNext( _
   ByRef reader As IDataReader _
) As Boolean
C#
public bool ExecuteNext(
   out IDataReader reader
)

Parameters

reader
DbDataReaderBase to store result set.

Return Value

true if there are more statements to execute; otherwise, false.

Remarks

Use ExecuteNext method to execute the statements from the script one by one. Text of the script should be specified by ScriptText property.

After the method has executed the DbScript.Progress event fires where you can obtain statement text and process query results. If the statement has produced an error, event DbScript.Error fires.

To restart execution from the beginning of the script call Reset method. When ScriptText property is modified DbScript automatically positions on the first statement.

Example

This sample demonstrates how to execute script and retrieve information about how many records were affected by a statement. For statements that return a result set the first column is written to console.
C#csharp Copy Code
string script =
"DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
OracleScript myScript = new OracleScript(script,myConn);
IDataReader myReader;
myConn.Open();
while (myScript.ExecuteNext(out myReader))
{
  Console.WriteLine("Records affected " + myReader.RecordsAffected);
  while (myReader.Read())
  {
    Console.WriteLine(myReader.GetString(0));
  }
  myReader.Close();
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
  "SELECT * FROM DEPT"
Dim myConn As OracleConnection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
Dim myScript As OracleScript = New OracleScript(script, myConn)
Dim myReader As IDataReader
myConn.Open()
While (myScript.ExecuteNext(myReader))
  Console.WriteLine("Records affected " & myReader.RecordsAffected)
  While myReader.Read()
    Console.WriteLine(myReader.GetString(0))
  End While
  myReader.Close()
End While
myConn.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
ScriptText Property
Execute Method
Progress Event
Error Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class : Open Method

Prepares a stream to be executed as SQL script.

Overload List

Overload | Description
Open(Stream) | Prepares a stream to be executed as SQL script.
Open(String) | Prepares a file stream to be executed as SQL script.
Open(TextReader) | Prepares a StreamReader to be executed as SQL script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open(Stream) Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class > Open Method : Open(Stream) Method

stream
Stream to read SQL statements from.
Prepares a stream to be executed as SQL script.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal stream As Stream _
)
C#
public void Open(
   Stream stream
)

Parameters

stream
Stream to read SQL statements from.

Remarks

Call to this method makes consequent invocation of Execute read SQL script from specified stream.

This Open(String) method, as well as its overloads, does not load the text into memory or populate the DbScript.Statements collection. So it is much more efficient to use Open(String) methods from performance and memory consumption points of view.

Open(Stream) does not change current position in the stream.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open(String) Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class > Open Method : Open(String) Method

fileName
Name of file to open.
Prepares a file stream to be executed as SQL script.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal fileName As String _
)
C#
public void Open(
   string fileName
)

Parameters

fileName
Name of file to open.

Remarks

Call to this method makes consequent invocation of Execute read SQL script from specified file.

This Open(String) method, as well as its overloads, does not load the text into memory or populate the DbScript.Statements collection. So it is much more efficient to use Open(String) methods from performance and memory consumption points of view.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open(TextReader) Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class > Open Method : Open(TextReader) Method

reader
TextReader to read SQL statements from.
Prepares a StreamReader to be executed as SQL script.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal reader As TextReader _
)
C#
public void Open(
   TextReader reader
)

Parameters

reader
TextReader to read SQL statements from.

Remarks

Call to this method makes consequent invocation of Execute read SQL script from specified TextReader.

This Open(String) method, as well as its overloads, does not load the text into memory or populate the DbScript.Statements collection. So it is much more efficient to use Open(String) methods from performance and memory consumption points of view.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Reset Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class : Reset Method

Positions ExecuteNext method on the first statement in the script.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
C#
public virtual void Reset()

Remarks

Use this method to restart execution of a script. This also happens when ScriptText property is modified.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbScript Class Properties
See Also support@devart.com
Devart.Common Namespace : DbScript Class

For a list of all members of this type, see DbScript members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time before terminating an attempt to execute a script and generating an error.
public Property | Connection | Gets or sets the System.Data.IDbConnection used by this instance of the DbScript.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets the name of component that will be displayed in dbMonitor application.
public Property | ScriptText | Gets or sets script text.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Statements | Gets the collection of statements that make up the script.
Top

See Also

Reference

DbScript Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandTimeout Property
See Also support@devart.com
Devart.Common Namespace > DbScript Class : CommandTimeout Property

Gets or sets the wait time before terminating an attempt to execute a script and generating an error.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Property Value

The time to wait while server responds when executing the command. The default value is 30 seconds.

Remarks

This property does not set the timeout for command execution, only the period of time for which to wait for response. I.e., if intervals between server responses are less than CommandTimeout, there is no time limit for command execution.

Zero value specifies that the wait time is unlimited.

The value of the CommandTimeout property is used in Direct mode. The OCI mode doesn't take into account the cmd.CommandTimeout, and the duration of command timeout is determined by Oracle client settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Common Namespace > DbScript Class : Connection Property

Gets or sets the System.Data.IDbConnection used by this instance of the DbScript.

Syntax

Visual Basic (Declaration)
Public Property Connection As IDbConnection
C#
public IDbConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > DbScript Class : Name Property

Gets or sets the name of component that will be displayed in dbMonitor application.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the component.

Remarks

This property value assigned automatically with the name of the component at design-time. If the component was created at run-time and property value was not set then the component will be displayed in dbMonitor application with object type name followed by unique number in parentheses.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptText Property
See Also support@devart.com
Devart.Common Namespace > DbScript Class : ScriptText Property

Gets or sets script text.

Syntax

Visual Basic (Declaration)
Public Overridable Property ScriptText As String
C#
public virtual string ScriptText {get; set;}

Property Value

The text of the script. The default value is an empty string ("").

Remarks

When you assign value to ScriptText the following actions take place. First, if DbScript.Statements property had been used before to obtain a Devart.Common.SqlStatementCollection object, this collection gets cleared and no SqlStatement objects associated with obsolete script can be used. Second, DbScript positions itself on the first statement in the script, thus next invocation of ExecuteNext method will execute the first SQL statement regardless of whether it had been called before.

Note that large scripts a better handled with Open method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Statements Property
See Also Example support@devart.com
Devart.Common Namespace > DbScript Class : Statements Property

Gets the collection of statements that make up the script.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statements As SqlStatementCollection
C#
public SqlStatementCollection Statements {get;}

Property Value

Collection of statements.

Remarks

Use DbScript.Statements to obtain Devart.Common.SqlStatementCollection which allows to access individual statements of the script and execute them manually. The collection is read-only so you can not modify it in any way. It is also bound to originating DbScript object, which means that if you have altered ScriptText, previously obtained collection will be cleared.

Example

This sample shows how to retrieve collection of statements that make up the script and execute them one by one.
C#csharp Copy Code
string script =
  "DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
  ");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
OracleScript myScript = new OracleScript(script,myConn);
SqlStatementCollection myColl = myScript.Statements;
IDataReader myReader;
myConn.Open();
foreach (SqlStatement myStatement in myColl)
{
  Console.WriteLine(myStatement.Text);
  try
  {
    myReader = myStatement.Execute();
    Console.WriteLine("  Records affected " + myReader.RecordsAffected);
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetString(0));
    }
    myReader.Close();
    Console.WriteLine();
  }
  catch
  {
    Console.WriteLine("  Failed");
  }
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
  "DROP TABLE DEPT;" + _
  "CREATE TABLE DEPT (" + _
  "  DEPTNO NUMBER(38) NOT NULL," + _
  "  DNAME VARCHAR2(14)," + _
  "  LOC VARCHAR2(13)" + _
  ");" + _
    "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" + _
    "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" + _
    "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" + _
    "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" + _
    "SELECT * FROM DEPT"
Dim myConn As OracleConnection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
Dim myScript As OracleScript = New OracleScript(script, myConn)
Dim myColl As SqlStatementCollection = myScript.Statements
Dim myReader As IDataReader
myConn.Open()
For Each myStatement As SqlStatement In myColl
  Console.WriteLine(myStatement.Text)
  Try
    myReader = myStatement.Execute()
    Console.WriteLine("  Records affected " & myReader.RecordsAffected)
    While myReader.Read()
      Console.WriteLine(myReader.GetString(0))
    End While
    myReader.Close()
    Console.WriteLine()
  Catch ex As Exception
    Console.WriteLine("  Failed")
  End Try
Next myStatement
myConn.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
SqlStatementCollection Class
ScriptText Property


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbScript Class Events
See Also support@devart.com
Devart.Common Namespace : DbScript Class

For a list of all members of this type, see DbScript members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when a SQL statement within script has produced an error.
public Event | Progress | Occurs when a SQL statement within script has successfully executed.
Top

See Also

Reference

DbScript Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Error Event
See Also Example support@devart.com
Devart.Common Namespace > DbScript Class : Error Event

Occurs when a SQL statement within script has produced an error.

Syntax

Visual Basic (Declaration)
Public Event Error As ScriptErrorEventHandler
C#
public event ScriptErrorEventHandler Error

Event Data

The event handler receives an argument of type ScriptErrorEventArgs containing data related to this event. The following ScriptErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the System.Exception instance that DbScript throws.
Ignore | Gets or sets whether the current error will be ignored or not.
Length | Gets length of statement where an error occurred.
LineNumber | Gets number of the line where an error occurred.
LinePosition | Gets position in the line where an error occurred.
Offset | Gets offset of statement where an error occurred.
StatementType | Gets type of the statement that caused an error.
Text | Gets SQL statement where an error occurred.

Remarks

This event can be generated by Execute and ExecuteNext methods when an error happens.

By default, Execute method stops and returns immediately after event handler finishes. If you want to ignore the error and continue execution of the script, set ScriptErrorEventArgs.Ignore property to true.

Example

This sample demonstrates how to execute script and retrieve information about execution flow using DbScript.Progress and DbScript.Error events.
C#csharp Copy Code
[STAThread]
static void Main(string[] args)
{
string script =
  "DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
  ");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
      OracleConnection myConn = new OracleConnection(
          "User Id=Scott;Password=tiger;Data Source=Ora;");
      OracleScript myScript = new OracleScript(script,myConn);
      myScript.Progress += new Devart.Common.ScriptProgressEventHandler(OnProgress);
      myScript.Error += new Devart.Common.ScriptErrorEventHandler(OnError);
      myConn.Open();
      myScript.Execute();
      myConn.Close();
    }

static void OnProgress(object sender, Devart.Common.ScriptProgressEventArgs e)
{
  Console.WriteLine(e.Text);
  Console.WriteLine("  Successfully executed.");
}

static void OnError(object sender, Devart.Common.ScriptErrorEventArgs e)
{
  e.Ignore = true;
  Console.WriteLine(e.Text);
  Console.WriteLine("  Failed.");
}
C#Visual Basic Copy Code
Module Module1

  Friend WithEvents myScript As Devart.Data.Oracle.OracleScript

  Sub Main()
    Dim script As String = _
  "DROP TABLE DEPT;" + _
  "CREATE TABLE DEPT (" + _
  "  DEPTNO NUMBER(38) NOT NULL," + _
  "  DNAME VARCHAR2(14)," + _
  "  LOC VARCHAR2(13)" + _
  ");" + _
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" + _
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" + _
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" + _
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" + _
  "SELECT * FROM DEPT"
    Dim myConn As OracleConnection = New OracleConnection( _
        "User Id=Scott;Password=tiger;Data Source=Ora;")
    myScript = New OracleScript(script, myConn)
    myConn.Open()
    myScript.Execute()
    myConn.Close()
    Console.ReadLine()
  End Sub

  Sub OnProgress(ByVal sender As Object, ByVal e As Devart.Common.ScriptProgressEventArgs) Handles myScript.Progress
    Console.WriteLine(e.Text)
    Console.WriteLine("  Successfully executed.")
  End Sub

  Sub OnError(ByVal sender As Object, ByVal e As Devart.Common.ScriptErrorEventArgs) Handles myScript.Error
    e.Ignore = True
    Console.WriteLine(e.Text)
    Console.WriteLine("  Failed.")
  End Sub

End Module

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
Progress Event
Execute Method
ExecuteNext Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Progress Event
See Also Example support@devart.com
Devart.Common Namespace > DbScript Class : Progress Event

Occurs when a SQL statement within script has successfully executed.

Syntax

Visual Basic (Declaration)
Public Event Progress As ScriptProgressEventHandler
C#
public event ScriptProgressEventHandler Progress

Event Data

The event handler receives an argument of type ScriptProgressEventArgs containing data related to this event. The following ScriptProgressEventArgs properties provide information specific to this event.

Property | Description
Length | Gets length of the statement in symbols.
LineNumber | Gets number of line in the whole script where the statement can be located.
LinePosition | Gets position of the statement in its line.
Offset | Gets offset of the statement in the whole script text.
StatementType | Gets type of the statement that is executed.
Text | Gets SQL statement that has been executed.

Remarks

This event can be generated by Execute and ExecuteNext methods in case of successfull execution of a statement in a script.

If you want to stop script execution from the event handler, you can raise an exception.

Example

This sample demonstrates how to execute script and retrieve information about execution flow using DbScript.Progress and DbScript.Error events.
C#csharp Copy Code
[STAThread]
static void Main(string[] args)
{
string script =
  "DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
  ");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
      OracleConnection myConn = new OracleConnection(
          "User Id=Scott;Password=tiger;Data Source=Ora;");
      OracleScript myScript = new OracleScript(script,myConn);
      myScript.Progress += new Devart.Common.ScriptProgressEventHandler(OnProgress);
      myScript.Error += new Devart.Common.ScriptErrorEventHandler(OnError);
      myConn.Open();
      myScript.Execute();
      myConn.Close();
    }

static void OnProgress(object sender, Devart.Common.ScriptProgressEventArgs e)
{
  Console.WriteLine(e.Text);
  Console.WriteLine("  Successfully executed.");
}

static void OnError(object sender, Devart.Common.ScriptErrorEventArgs e)
{
  e.Ignore = true;
  Console.WriteLine(e.Text);
  Console.WriteLine("  Failed.");
}
C#Visual Basic Copy Code
Module Module1

  Friend WithEvents myScript As Devart.Data.Oracle.OracleScript

  Sub Main()
    Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
  "SELECT * FROM DEPT"
    Dim myConn As OracleConnection = New OracleConnection( _
        "User Id=Scott;Password=tiger;Data Source=Ora;")
    myScript = New OracleScript(script, myConn)
    myConn.Open()
    myScript.Execute()
    myConn.Close()
    Console.ReadLine()
  End Sub

  Sub OnProgress(ByVal sender As Object, ByVal e As Devart.Common.ScriptProgressEventArgs) Handles myScript.Progress
    Console.WriteLine(e.Text)
    Console.WriteLine("  Successfully executed.")
  End Sub

  Sub OnError(ByVal sender As Object, ByVal e As Devart.Common.ScriptErrorEventArgs) Handles myScript.Error
    e.Ignore = True
    Console.WriteLine(e.Text)
    Console.WriteLine("  Failed.")
  End Sub

End Module

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members
Error Event
Execute Method
ExecuteNext Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbTransactionBase Class
Members See Also support@devart.com
Devart.Common Namespace : DbTransactionBase Class

Base class for the dotConnect for Oracle transaction class Devart.Data.Oracle.OracleTransaction

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbTransaction
Devart.Common.DbTransactionBase
Devart.Data.Oracle.OracleTransaction

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbTransactionBase
   Inherits System.Data.Common.DbTransaction
   Implements IDbTransaction, IDisposable
C#
public abstract class DbTransactionBase : System.Data.Common.DbTransaction, IDbTransaction, IDisposable

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbTransactionBase Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbTransactionBase Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbTransactionBase Class

The following tables list the members exposed by DbTransactionBase.

Public Properties

 | Name | Description
public Property | Connection | Specifies the System.Data.Common.DbConnection object associated with the transaction. (Inherited from System.Data.Common.DbTransaction)
public Property | IsolationLevel | Overridden. Specifies the System.Data.IsolationLevel for the transaction.
Top

Public Methods

 | Name | Description
public Method | Commit | Commits the database transaction. (Inherited from System.Data.Common.DbTransaction)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases the unmanaged resources used by the System.Data.Common.DbTransaction. (Inherited from System.Data.Common.DbTransaction)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Rollback | Rolls back a transaction from a pending state. (Inherited from System.Data.Common.DbTransaction)
Top

Public Events

 | Name | Description
public Event | StateChanged | Occurs when the state of the transaction is changed.
public Event | StateChanging | Occurs when the state of the transaction is changing.
Top

See Also

Reference

DbTransactionBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbTransactionBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbTransactionBase Class

For a list of all members of this type, see DbTransactionBase members.

Public Properties

 | Name | Description
public Property | Connection | Specifies the System.Data.Common.DbConnection object associated with the transaction. (Inherited from System.Data.Common.DbTransaction)
public Property | IsolationLevel | Overridden. Specifies the System.Data.IsolationLevel for the transaction.
Top

See Also

Reference

DbTransactionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsolationLevel Property
See Also support@devart.com
Devart.Common Namespace > DbTransactionBase Class : IsolationLevel Property

Specifies the System.Data.IsolationLevel for the transaction.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsolationLevel As IsolationLevel
C#
public override IsolationLevel IsolationLevel {get;}

Property Value

The System.Data.IsolationLevel for the transaction.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbTransactionBase Class
DbTransactionBase Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbTransactionBase Class Events
See Also support@devart.com
Devart.Common Namespace : DbTransactionBase Class

For a list of all members of this type, see DbTransactionBase members.

Public Events

 | Name | Description
public Event | StateChanged | Occurs when the state of the transaction is changed.
public Event | StateChanging | Occurs when the state of the transaction is changing.
Top

See Also

Reference

DbTransactionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StateChanged Event
See Also support@devart.com
Devart.Common Namespace > DbTransactionBase Class : StateChanged Event

Occurs when the state of the transaction is changed.

Syntax

Visual Basic (Declaration)
Public Event StateChanged As TransactionStateChangedEventHandler
C#
public event TransactionStateChangedEventHandler StateChanged

Event Data

The event handler receives an argument of type TransactionStateChangedEventArgs containing data related to this event. The following TransactionStateChangedEventArgs properties provide information specific to this event.

Property | Description
Action (Inherited from Devart.Common.TransactionStateChangeEventArgs) | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbTransactionBase Class
DbTransactionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StateChanging Event
See Also support@devart.com
Devart.Common Namespace > DbTransactionBase Class : StateChanging Event

Occurs when the state of the transaction is changing.

Syntax

Visual Basic (Declaration)
Public Event StateChanging As TransactionStateChangingEventHandler
C#
public event TransactionStateChangingEventHandler StateChanging

Event Data

The event handler receives an argument of type TransactionStateChangingEventArgs containing data related to this event. The following TransactionStateChangingEventArgs properties provide information specific to this event.

Property | Description
Action (Inherited from Devart.Common.TransactionStateChangeEventArgs) | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbTransactionBase Class
DbTransactionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MonitorEventArgs Class
Members Example See Also support@devart.com
Devart.Common Namespace : MonitorEventArgs Class

Provides data for the DbMonitor.TraceEvent event of the DbMonitor class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.MonitorEventArgs

Syntax

Visual Basic (Declaration)
Public Class MonitorEventArgs
   Inherits System.EventArgs
C#
public class MonitorEventArgs : System.EventArgs

Remarks

The DbMonitor.TraceEvent event occurs when DbMonitor object is active and the monitoring application performs any SQL activity.

Example

The following sample shows how to enable and disable monitoring of database activity in your application.
C#csharp Copy Code
static void OnEvent(object sender, MonitorEventArgs e)
{
  if (e.TracePoint==MonitorTracePoint.BeforeEvent)
  {
    Console.WriteLine("Description: " + e.Description);
    Console.WriteLine(" Extra info: " + e.ExtraInfo);
  }
}

[MTAThread]
static void Main(string[] args)
{
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  OracleMonitor myMonitor = new OracleMonitor();
  myMonitor.TraceEvent += new MonitorEventHandler(OnEvent);
  myMonitor.IsActive = true;
  OracleCommand myCommand = new OracleCommand("select count(*) from Dept",myConn);
  myConn.Open();
  Console.WriteLine(myCommand.ExecuteScalar());
  myConn.Close();
  myMonitor.TraceEvent -= new MonitorEventHandler(OnEvent);
  Console.ReadLine();
}
C#Visual Basic Copy Code
Sub OnEvent(ByVal sender As Object, ByVal e As MonitorEventArgs)
  If e.TracePoint = MonitorTracePoint.BeforeEvent Then
    Console.WriteLine("Description: " & e.Description)
    Console.WriteLine(" Extra info: " & e.ExtraInfo)
  End If
End Sub

<MTAThread()> _
Sub Main()
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myMonitor As OracleMonitor = New OracleMonitor
  AddHandler myMonitor.TraceEvent, AddressOf OnEvent
  myMonitor.IsActive = True
  Dim myCommand As OracleCommand = New OracleCommand("select count(*) from Dept", myConn)
  myConn.Open()
  Console.WriteLine(myCommand.ExecuteScalar())
  myConn.Close()
  RemoveHandler myMonitor.TraceEvent, AddressOf OnEvent
  Console.ReadLine()
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

MonitorEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
MonitorEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : MonitorEventArgs Class

The following tables list the members exposed by MonitorEventArgs.

Public Properties

 | Name | Description
public Property | CallStack | Gets the call stack of the monitor event.
public Property | Description | Gets the description of a DbMonitor event.
public Property | Duration | The time between the start and the end of the event.
public Property | EventType | Gets DbMonitor event type.
public Property | ExtraInfo | Gets the additional information for a DbMonitor event.
public Property | TracePoint | Determines whether DbMonitor.TraceEvent event occurs before or after the operation takes place.
Top

See Also

Reference

MonitorEventArgs Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
MonitorEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : MonitorEventArgs Class

For a list of all members of this type, see MonitorEventArgs members.

Public Properties

 | Name | Description
public Property | CallStack | Gets the call stack of the monitor event.
public Property | Description | Gets the description of a DbMonitor event.
public Property | Duration | The time between the start and the end of the event.
public Property | EventType | Gets DbMonitor event type.
public Property | ExtraInfo | Gets the additional information for a DbMonitor event.
public Property | TracePoint | Determines whether DbMonitor.TraceEvent event occurs before or after the operation takes place.
Top

See Also

Reference

MonitorEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CallStack Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : CallStack Property

Gets the call stack of the monitor event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CallStack As String()
C#
public string[] CallStack {get;}

Property Value

The call stack of the monitor event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Description Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : Description Property

Gets the description of a DbMonitor event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Description As String
C#
public string Description {get;}

Property Value

The text description of a DbMonitor event.

Remarks

This property contains such information as text of SQL statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Duration Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : Duration Property

The time between the start and the end of the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Duration As Double
C#
public double Duration {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EventType Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : EventType Property

Gets DbMonitor event type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EventType As MonitorEventType
C#
public MonitorEventType EventType {get;}

Property Value

The DbMonitor event type that depends on SQL activity of the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExtraInfo Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : ExtraInfo Property

Gets the additional information for a DbMonitor event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraInfo As String
C#
public string ExtraInfo {get;}

Property Value

The string representation of the connection string, error text, or SQL parameters.

Remarks

This property contains such information as connection string or quantity of rows affected by a query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TracePoint Property
See Also support@devart.com
Devart.Common Namespace > MonitorEventArgs Class : TracePoint Property

Determines whether DbMonitor.TraceEvent event occurs before or after the operation takes place.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TracePoint As MonitorTracePoint
C#
public MonitorTracePoint TracePoint {get;}

Property Value

One of MonitorTracePoint values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

MonitorEventArgs Class
MonitorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentDataRelation Class
Members Example See Also support@devart.com
Devart.Common Namespace : ParentDataRelation Class

Establishes query-based master-detail relation.

Inheritance Hierarchy

System.Object
Devart.Common.ParentDataRelation

Syntax

Visual Basic (Declaration)
Public Class ParentDataRelation
C#
public class ParentDataRelation

Remarks

The ParentDataRelation class is designed to establish a master-detail relationship where details data is not cached on the client. Every time the current position in the master table is changed, the client DbDataTable requests the appropriate portion of data from the server.

Use property ParentTable to specify master DbDataTable, and the properties ParentColumnNames and ChildColumnNames to describe the relationiship.

Note that this feature can be used only for two instances of DbDataTable class that have same DbDataTable.Owner. In other words, the DbDataTable objects must reside on the same forms.

Example

The following example shows how to render related data in two grids.
C#csharp Copy Code
OracleConnection connection = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
connection.Open();
OracleDataTable deptTable = new OracleDataTable("SELECT * FROM dept", connection);
OracleDataTable empTable = new OracleDataTable("SELECT * FROM emp", connection);
empTable.ParentRelation.ParentTable = deptTable;
empTable.ParentRelation.ParentColumnNames = new string[] { "deptno" };
empTable.ParentRelation.ChildColumnNames = new string[] { "deptno" };
deptTable.Owner = this;
empTable.Owner = this;
deptTable.FetchAll = true;
empTable.FetchAll = true;
deptTable.Open();
empTable.Open();
deptDataGrid.DataSource = deptTable;
empDataGrid.DataSource = empTable;
C#Visual Basic Copy Code
Dim connection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
connection.Open()
Dim deptTable As New OracleDataTable("SELECT * FROM dept", connection)
Dim empTable As New OracleDataTable("SELECT * FROM emp", connection)
empTable.ParentRelation.ParentTable = deptTable
empTable.ParentRelation.ParentColumnNames = New String() {"deptno"}
empTable.ParentRelation.ChildColumnNames = New String() {"deptno"}
deptTable.Owner = Me
empTable.Owner = Me
deptTable.FetchAll = True
empTable.FetchAll = True
deptTable.Open()
empTable.Open()
deptDataGrid.DataSource = deptTable
empDataGrid.DataSource = empTable

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ParentDataRelation Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
ParentDataRelation Class Members
See Also Properties support@devart.com
Devart.Common Namespace : ParentDataRelation Class

The following tables list the members exposed by ParentDataRelation.

Public Constructors

 | Name | Description
public Constructor | ParentDataRelation Constructor | Initializes a new instance of the ParentDataRelation class using the specified parent DbDataTable and matched arrays of parent and child column names.
Top

Public Properties

 | Name | Description
public Property | ChildColumnNames | Gets or sets list of child columns used to establish the relation.
public Property | ParentColumnNames | Gets or sets list of child columns used to establish the relation.
public Property | ParentTable | Gets or sets the DbDataTable that is used as master dataset.
Top

See Also

Reference

ParentDataRelation Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentDataRelation Constructor
See Also support@devart.com
Devart.Common Namespace > ParentDataRelation Class : ParentDataRelation Constructor

parentTable
A DbDataTable that is used as master dataset.
parentColumnNames
List of master columns used to establish the relation.
childColumnNames
List of child columns used to establish the relation.
Initializes a new instance of the ParentDataRelation class using the specified parent DbDataTable and matched arrays of parent and child column names.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentTable As IListSource, _
   ByVal parentColumnNames() As String, _
   ByVal childColumnNames() As String _
)
C#
public ParentDataRelation(
   IListSource parentTable,
   string[] parentColumnNames,
   string[] childColumnNames
)

Parameters

parentTable
A DbDataTable that is used as master dataset.
parentColumnNames
List of master columns used to establish the relation.
childColumnNames
List of child columns used to establish the relation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ParentDataRelation Class
ParentDataRelation Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
ParentDataRelation Class Properties
See Also support@devart.com
Devart.Common Namespace : ParentDataRelation Class

For a list of all members of this type, see ParentDataRelation members.

Public Properties

 | Name | Description
public Property | ChildColumnNames | Gets or sets list of child columns used to establish the relation.
public Property | ParentColumnNames | Gets or sets list of child columns used to establish the relation.
public Property | ParentTable | Gets or sets the DbDataTable that is used as master dataset.
Top

See Also

Reference

ParentDataRelation Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ChildColumnNames Property
See Also support@devart.com
Devart.Common Namespace > ParentDataRelation Class : ChildColumnNames Property

Gets or sets list of child columns used to establish the relation.

Syntax

Visual Basic (Declaration)
Public Property ChildColumnNames As String()
C#
public string[] ChildColumnNames {get; set;}

Property Value

List of child columns used to establish the relation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ParentDataRelation Class
ParentDataRelation Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentColumnNames Property
See Also support@devart.com
Devart.Common Namespace > ParentDataRelation Class : ParentColumnNames Property

Gets or sets list of child columns used to establish the relation.

Syntax

Visual Basic (Declaration)
Public Property ParentColumnNames As String()
C#
public string[] ParentColumnNames {get; set;}

Property Value

List of parent columns used to establish the relation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ParentDataRelation Class
ParentDataRelation Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentTable Property
See Also support@devart.com
Devart.Common Namespace > ParentDataRelation Class : ParentTable Property

Gets or sets the DbDataTable that is used as master dataset.

Syntax

Visual Basic (Declaration)
Public Property ParentTable As DbDataTable
C#
public DbDataTable ParentTable {get; set;}

Property Value

A DbDataTable that is used as master dataset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ParentDataRelation Class
ParentDataRelation Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueryRecordCountException Class
Members Example See Also support@devart.com
Devart.Common Namespace : QueryRecordCountException Class

Describes an error that is raised during record count request process.

Inheritance Hierarchy

System.Object
System.Exception
Devart.Common.QueryRecordCountException

Syntax

Visual Basic (Declaration)
Public Class QueryRecordCountException
   Inherits System.Exception
   Implements _Exception, ISerializable
C#
public class QueryRecordCountException : System.Exception, _Exception, ISerializable

Remarks

This class is used to differentiate exceptions from DbDataTable.QueryRecordCount and other fetch exceptions. The actual error message can be accessed via the InnerException property.

Example

The sample shows a catch block that is defined to catch a QueryRecordCountException exception.
C#csharp Copy Code
// Create a command selecting all records from the Dept table.
Devart.Data.Oracle.OracleCommand command = new Devart.Data.Oracle.OracleCommand("select * from Dept");
try
{
    // Execution of the command will fail as no connection is set to it.
    command.GetRecordCount();
}
catch (QueryRecordCountException ex)
{
    // Use the InnerException property to determine the actual error occurred.
    Console.WriteLine("An error occurred while counting records in the result set: "
        + ex.InnerException.Message);
}
C#Visual Basic Copy Code
' Create a command selecting all records from the Dept table.
Dim command = New Devart.Data.Oracle.OracleCommand("select * from Dept")
Try
    ' Execution of the command will fail as no connection is set to it.
    command.GetRecordCount()
Catch ex As QueryRecordCountException
    ' Use the InnerException property to determine the actual error occurred.
    Console.WriteLine("An error occurred while counting records in the result set: " _
        + ex.InnerException.Message)
End Try

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

QueryRecordCountException Members
Devart.Common Namespace
QueryRecordCount Property


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
QueryRecordCountException Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : QueryRecordCountException Class

The following tables list the members exposed by QueryRecordCountException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

QueryRecordCountException Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptErrorEventArgs Class
Members See Also support@devart.com
Devart.Common Namespace : ScriptErrorEventArgs Class

Provides data for the DbScript.Error event of the DbScript class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.ScriptErrorEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptErrorEventArgs
   Inherits System.EventArgs
C#
public sealed class ScriptErrorEventArgs : System.EventArgs

Remarks

The DbScript.Error event contains all information about an error and allows to choose whether to ignore the error or stop script execution.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ScriptErrorEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
ScriptErrorEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : ScriptErrorEventArgs Class

The following tables list the members exposed by ScriptErrorEventArgs.

Public Constructors

 | Name | Description
public Constructor | ScriptErrorEventArgs Constructor | Initialize a new instance of ScriptErrorEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Exception | Gets the System.Exception instance that DbScript throws.
public Property | Ignore | Gets or sets whether the current error will be ignored or not.
public Property | Length | Gets length of statement where an error occurred.
public Property | LineNumber | Gets number of the line where an error occurred.
public Property | LinePosition | Gets position in the line where an error occurred.
public Property | Offset | Gets offset of statement where an error occurred.
public Property | StatementType | Gets type of the statement that caused an error.
public Property | Text | Gets SQL statement where an error occurred.
Top

See Also

Reference

ScriptErrorEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptErrorEventArgs Constructor
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : ScriptErrorEventArgs Constructor

e
The System.Exception instance that contains information specific to DbScript error.
text
SQL statement text where an error occurred.
offset
Offset of statement where an error occurs.
length
Length of statement where an error occurs.
lineNumber
Number of the line where an error occurs.
linePosition
Position in the line where an error occurs.
statementType
Type of the statement.
Initialize a new instance of ScriptErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal e As Exception, _
   ByVal text As String, _
   ByVal offset As Integer, _
   ByVal length As Integer, _
   ByVal lineNumber As Integer, _
   ByVal linePosition As Integer, _
   ByVal statementType As SqlStatementType _
)
C#
public ScriptErrorEventArgs(
   Exception e,
   string text,
   int offset,
   int length,
   int lineNumber,
   int linePosition,
   SqlStatementType statementType
)

Parameters

e
The System.Exception instance that contains information specific to DbScript error.
text
SQL statement text where an error occurred.
offset
Offset of statement where an error occurs.
length
Length of statement where an error occurs.
lineNumber
Number of the line where an error occurs.
linePosition
Position in the line where an error occurs.
statementType
Type of the statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
ScriptErrorEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : ScriptErrorEventArgs Class

For a list of all members of this type, see ScriptErrorEventArgs members.

Public Properties

 | Name | Description
public Property | Exception | Gets the System.Exception instance that DbScript throws.
public Property | Ignore | Gets or sets whether the current error will be ignored or not.
public Property | Length | Gets length of statement where an error occurred.
public Property | LineNumber | Gets number of the line where an error occurred.
public Property | LinePosition | Gets position in the line where an error occurred.
public Property | Offset | Gets offset of statement where an error occurred.
public Property | StatementType | Gets type of the statement that caused an error.
public Property | Text | Gets SQL statement where an error occurred.
Top

See Also

Reference

ScriptErrorEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Exception Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : Exception Property

Gets the System.Exception instance that DbScript throws.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Property Value

An System.Exception instance that contains information specific to DbScript error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Ignore Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : Ignore Property

Gets or sets whether the current error will be ignored or not.

Syntax

Visual Basic (Declaration)
Public Property Ignore As Boolean
C#
public bool Ignore {get; set;}

Property Value

true if the current error will be ignored; otherwise false.

Remarks

If false (by default), Execute method stops and returns immediately after event handler finishes. If you want to ignore the error and continue execution of the script, set this property to true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : Length Property

Gets length of statement where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

Length of statement where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LineNumber Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : LineNumber Property

Gets number of the line where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber {get;}

Property Value

Number of the line where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LinePosition Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : LinePosition Property

Gets position in the line where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinePosition As Integer
C#
public int LinePosition {get;}

Property Value

Position in the line where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Offset Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : Offset Property

Gets offset of statement where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
C#
public int Offset {get;}

Property Value

Offset of statement where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementType Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : StatementType Property

Gets type of the statement that caused an error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StatementType As SqlStatementType
C#
public SqlStatementType StatementType {get;}

Property Value

One of the SqlStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Text Property
See Also support@devart.com
Devart.Common Namespace > ScriptErrorEventArgs Class : Text Property

Gets SQL statement where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Property Value

SQL statement text where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptErrorEventArgs Class
ScriptErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptProgressEventArgs Class
Members See Also support@devart.com
Devart.Common Namespace : ScriptProgressEventArgs Class

Provides data for the DbScript.Progress event of the DbScript class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.ScriptProgressEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ScriptProgressEventArgs
   Inherits System.EventArgs
C#
public sealed class ScriptProgressEventArgs : System.EventArgs

Remarks

The DbScript.Progress event contains all information about the statement that has just executed.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ScriptProgressEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
ScriptProgressEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : ScriptProgressEventArgs Class

The following tables list the members exposed by ScriptProgressEventArgs.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols.
public Property | LineNumber | Gets number of line in the whole script where the statement can be located.
public Property | LinePosition | Gets position of the statement in its line.
public Property | Offset | Gets offset of the statement in the whole script text.
public Property | StatementType | Gets type of the statement that is executed.
public Property | Text | Gets SQL statement that has been executed.
Top

See Also

Reference

ScriptProgressEventArgs Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
ScriptProgressEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : ScriptProgressEventArgs Class

For a list of all members of this type, see ScriptProgressEventArgs members.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols.
public Property | LineNumber | Gets number of line in the whole script where the statement can be located.
public Property | LinePosition | Gets position of the statement in its line.
public Property | Offset | Gets offset of the statement in the whole script text.
public Property | StatementType | Gets type of the statement that is executed.
public Property | Text | Gets SQL statement that has been executed.
Top

See Also

Reference

ScriptProgressEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : Length Property

Gets length of the statement in symbols.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

Length of the statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LineNumber Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : LineNumber Property

Gets number of line in the whole script where the statement can be located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber {get;}

Property Value

Number of line in the whole script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LinePosition Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : LinePosition Property

Gets position of the statement in its line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinePosition As Integer
C#
public int LinePosition {get;}

Property Value

Position of the statement.

Remarks

Read the property to get offset of the statement from the beginning of the line where it can be located.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Offset Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : Offset Property

Gets offset of the statement in the whole script text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
C#
public int Offset {get;}

Property Value

Offset of the statement in the script text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementType Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : StatementType Property

Gets type of the statement that is executed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StatementType As SqlStatementType
C#
public SqlStatementType StatementType {get;}

Property Value

One of the SqlStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Text Property
See Also support@devart.com
Devart.Common Namespace > ScriptProgressEventArgs Class : Text Property

Gets SQL statement that has been executed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Property Value

SQL statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ScriptProgressEventArgs Class
ScriptProgressEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatement Class
Members Example See Also support@devart.com
Devart.Common Namespace : SqlStatement Class

Represents a single statement in a script.

Inheritance Hierarchy

System.Object
Devart.Common.SqlStatement
Devart.Data.Oracle.OracleSqlStatement

Syntax

Visual Basic (Declaration)
Public Class SqlStatement
C#
public class SqlStatement

Remarks

Use SqlStatement to execute individual statements in a script. Each SqlStatement object contains SQL text and information about location of statement in the whole script.

SqlStatement object can be obtained through DbScript.Statements collection. After originating ScriptText has been modified any obsolete SqlStatement objects can no longer be used.

Example

This sample shows how to retrieve collection of statements that make up the script and execute them one by one.
C#csharp Copy Code
string script =
"DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
OracleScript myScript = new OracleScript(script,myConn);
SqlStatementCollection myColl = myScript.Statements;
IDataReader myReader;
myConn.Open();
foreach (SqlStatement myStatement in myColl)
{
  Console.WriteLine(myStatement.Text);
  try
  {
    myReader = myStatement.Execute();
    Console.WriteLine("  Records affected " + myReader.RecordsAffected);
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetString(0));
    }
    myReader.Close();
    Console.WriteLine();
  }
  catch
  {
    Console.WriteLine("  Failed");
  }
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _
    "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
    "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
    "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
    "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
    "SELECT * FROM DEPT"
Dim myConn As OracleConnection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
Dim myScript As OracleScript = New OracleScript(script, myConn)
Dim myColl As SqlStatementCollection = myScript.Statements
Dim myReader As IDataReader
myConn.Open()
For Each myStatement As SqlStatement In myColl
  Console.WriteLine(myStatement.Text)
  Try
    myReader = myStatement.Execute()
    Console.WriteLine("  Records affected " & myReader.RecordsAffected)
    While myReader.Read()
      Console.WriteLine(myReader.GetString(0))
    End While
    myReader.Close()
    Console.WriteLine()
  Catch ex As Exception
    Console.WriteLine("  Failed")
  End Try
Next myStatement
myConn.Close()

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SqlStatement Members
Devart.Common Namespace
SqlStatementCollection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SqlStatement Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SqlStatement Class

The following tables list the members exposed by SqlStatement.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols.
public Property | LineNumber | Gets number of line in the whole script where the statement can be located.
public Property | LinePosition | Gets position of the statement in its line.
public Property | Offset | Gets offset of the statement in the whole script text.
public Property | StatementType | Gets type of the statement.
public Property | Text | Gets SQL statement to be executed.
Top

Public Methods

 | Name | Description
public Method | Execute | Executes the statement and returns result set.
public Method | ExecuteNonQuery | Executes the statement.
Top

See Also

Reference

SqlStatement Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SqlStatement Class Methods
See Also support@devart.com
Devart.Common Namespace : SqlStatement Class

For a list of all members of this type, see SqlStatement members.

Public Methods

 | Name | Description
public Method | Execute | Executes the statement and returns result set.
public Method | ExecuteNonQuery | Executes the statement.
Top

See Also

Reference

SqlStatement Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Execute Method
See Also Example support@devart.com
Devart.Common Namespace > SqlStatement Class : Execute Method

Executes the statement and returns result set.

Syntax

Visual Basic (Declaration)
Public Function Execute() As IDataReader
C#
public IDataReader Execute()

Return Value

Result set returned by the statement execution.

Remarks

This method is an alternative to Execute and ExecuteNext methods. It allows you to execute statements individually in any order. Note that SqlStatement.Execute of SqlStatement does not generate DbScript.Error or DbScript.Progress event.

Example

This sample shows how to retrieve collection of statements that make up the script and execute them one by one.
C#csharp Copy Code
string script =
"DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
OracleScript myScript = new OracleScript(script,myConn);
SqlStatementCollection myColl = myScript.Statements;
IDataReader myReader;
myConn.Open();
foreach (SqlStatement myStatement in myColl)
{
  Console.WriteLine(myStatement.Text);
  try
  {
    myReader = myStatement.Execute();
    Console.WriteLine("  Records affected " + myReader.RecordsAffected);
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetString(0));
    }
    myReader.Close();
    Console.WriteLine();
  }
  catch
  {
    Console.WriteLine("  Failed");
  }
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
  "DROP TABLE DEPT;" + _
  "CREATE TABLE DEPT (" + _
  "  DEPTNO NUMBER(38) NOT NULL," + _
  "  DNAME VARCHAR2(14)," + _
  "  LOC VARCHAR2(13)" + _
  ");" + _
    "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" + _
    "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" + _
    "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" + _
    "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" + _
    "SELECT * FROM DEPT"
Dim myConn As OracleConnection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
Dim myScript As OracleScript = New OracleScript(script, myConn)
Dim myColl As SqlStatementCollection = myScript.Statements
Dim myReader As IDataReader
myConn.Open()
For Each myStatement As SqlStatement In myColl
  Console.WriteLine(myStatement.Text)
  Try
    myReader = myStatement.Execute()
    Console.WriteLine("  Records affected " & myReader.RecordsAffected)
    While myReader.Read()
      Console.WriteLine(myReader.GetString(0))
    End While
    myReader.Close()
    Console.WriteLine()
  Catch ex As Exception
    Console.WriteLine("  Failed")
  End Try
Next myStatement
myConn.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
Text Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNonQuery Method
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : ExecuteNonQuery Method

Executes the statement.

Syntax

Visual Basic (Declaration)
Public Sub ExecuteNonQuery()
C#
public void ExecuteNonQuery()

Remarks

This method is an alternative to Execute and ExecuteNext methods. It allows you to execute statements individually in any order. Note that SqlStatement.Execute of SqlStatement does not generate DbScript.Error or DbScript.Progress event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
Text Property


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SqlStatement Class Properties
See Also support@devart.com
Devart.Common Namespace : SqlStatement Class

For a list of all members of this type, see SqlStatement members.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols.
public Property | LineNumber | Gets number of line in the whole script where the statement can be located.
public Property | LinePosition | Gets position of the statement in its line.
public Property | Offset | Gets offset of the statement in the whole script text.
public Property | StatementType | Gets type of the statement.
public Property | Text | Gets SQL statement to be executed.
Top

See Also

Reference

SqlStatement Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : Length Property

Gets length of the statement in symbols.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

Length of the statement in symbols.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
Text Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LineNumber Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : LineNumber Property

Gets number of line in the whole script where the statement can be located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber {get;}

Property Value

Number of line in the whole script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
LinePosition Property
Offset Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LinePosition Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : LinePosition Property

Gets position of the statement in its line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinePosition As Integer
C#
public int LinePosition {get;}

Property Value

Position of the statement.

Remarks

Read the property to get offset of the statement from the beginning of the line where it can be located.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
LineNumber Property
Offset Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Offset Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : Offset Property

Gets offset of the statement in the whole script text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
C#
public int Offset {get;}

Property Value

Offset of the statement in the script text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
LineNumber Property
Offset Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementType Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : StatementType Property

Gets type of the statement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StatementType As SqlStatementType
C#
public SqlStatementType StatementType {get;}

Property Value

One of the SqlStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Text Property
See Also support@devart.com
Devart.Common Namespace > SqlStatement Class : Text Property

Gets SQL statement to be executed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Property Value

SQL statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatement Class
SqlStatement Members
Length Property
Execute Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementCollection Class
Members Example See Also support@devart.com
Devart.Common Namespace : SqlStatementCollection Class

Represents collection of statements that constitute Oracle script.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.SqlStatementCollection
Devart.Data.Oracle.OracleSqlStatementCollection

Syntax

Visual Basic (Declaration)
Public Class SqlStatementCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public class SqlStatementCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

The collection is read-only. You can not add your own SqlStatement objects or remove them.

Devart.Common.SqlStatementCollection is used to execute statements in a script one by one. To populate the collection with data use DbScript.Statements property.

Example

This sample shows how to retrieve collection of statements that make up the script and execute them one by one.
C#csharp Copy Code
string script =
"DROP TABLE DEPT;"+
  "CREATE TABLE DEPT ("+
  "  DEPTNO NUMBER(38) NOT NULL,"+
  "  DNAME VARCHAR2(14),"+
  "  LOC VARCHAR2(13)"+
");"+
  "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');"+
  "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');"+
  "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');"+
  "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');"+
  "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
OracleScript myScript = new OracleScript(script,myConn);
SqlStatementCollection myColl = myScript.Statements;
IDataReader myReader;
myConn.Open();
foreach (SqlStatement myStatement in myColl)
{
  Console.WriteLine(myStatement.Text);
  try
  {
    myReader = myStatement.Execute();
    Console.WriteLine("  Records affected " + myReader.RecordsAffected);
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetString(0));
    }
    myReader.Close();
    Console.WriteLine();
  }
  catch
  {
    Console.WriteLine("  Failed");
  }
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
  "DROP TABLE DEPT;" & _
  "CREATE TABLE DEPT (" & _
  "  DEPTNO NUMBER(38) NOT NULL," & _
  "  DNAME VARCHAR2(14)," & _
  "  LOC VARCHAR2(13)" & _
  ");" & _
    "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
    "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
    "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
    "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
    "SELECT * FROM DEPT"
Dim myConn As OracleConnection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
Dim myScript As OracleScript = New OracleScript(script, myConn)
Dim myColl As SqlStatementCollection = myScript.Statements
Dim myReader As IDataReader
myConn.Open()
For Each myStatement As SqlStatement In myColl
  Console.WriteLine(myStatement.Text)
  Try
    myReader = myStatement.Execute()
    Console.WriteLine("  Records affected " & myReader.RecordsAffected)
    While myReader.Read()
      Console.WriteLine(myReader.GetString(0))
    End While
    myReader.Close()
    Console.WriteLine()
  Catch ex As Exception
    Console.WriteLine("  Failed")
  End Try
Next myStatement
myConn.Close()

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SqlStatementCollection Members
Devart.Common Namespace
Statements Property


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SqlStatementCollection Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SqlStatementCollection Class

The following tables list the members exposed by SqlStatementCollection.

Public Constructors

 | Name | Description
public Constructor | SqlStatementCollection Constructor | Initializes a new instance of the Devart.Common.SqlStatementCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets the SqlStatement at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Not used in Devart.Common.SqlStatementCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SqlStatement object exists in the collection.
public Method | CopyTo | Copies SqlStatement objects from the Devart.Common.SqlStatementCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SqlStatement object.
public Method | Insert | Not used in Devart.Common.SqlStatementCollection.
public Method | Remove | Not used in Devart.Common.SqlStatementCollection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SqlStatementCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementCollection Constructor
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : SqlStatementCollection Constructor

Initializes a new instance of the Devart.Common.SqlStatementCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SqlStatementCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SqlStatementCollection Class Methods
See Also support@devart.com
Devart.Common Namespace : SqlStatementCollection Class

For a list of all members of this type, see SqlStatementCollection members.

Public Methods

 | Name | Description
public Method | Add | Not used in Devart.Common.SqlStatementCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SqlStatement object exists in the collection.
public Method | CopyTo | Copies SqlStatement objects from the Devart.Common.SqlStatementCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SqlStatement object.
public Method | Insert | Not used in Devart.Common.SqlStatementCollection.
public Method | Remove | Not used in Devart.Common.SqlStatementCollection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SqlStatementCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : Add Method

value
Not used in Devart.Common.SqlStatementCollection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As SqlStatement _
) As Integer
C#
public int Add(
   SqlStatement value
)

Parameters

value

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : Contains Method

value
The value of the SqlStatement object to find.
Gets a value indicating whether a SqlStatement object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As SqlStatement _
) As Boolean
C#
public bool Contains(
   SqlStatement value
)

Parameters

value
The value of the SqlStatement object to find.

Return Value

true if the collection contains the SqlStatement; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : CopyTo Method

array
The array into which to copy the SqlStatement objects.
index
The zero-based index of the object to copy.
Copies SqlStatement objects from the Devart.Common.SqlStatementCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As SqlStatement, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   SqlStatement[] array,
   int index
)

Parameters

array
The array into which to copy the SqlStatement objects.
index
The zero-based index of the object to copy.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : IndexOf Method

value
The SqlStatement object to find.
Gets the location in the collection of the SqlStatement object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As SqlStatement _
) As Integer
C#
public int IndexOf(
   SqlStatement value
)

Parameters

value
The SqlStatement object to find.

Return Value

The zero-based location of the SqlStatement in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : Insert Method

index
value
Not used in Devart.Common.SqlStatementCollection.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As SqlStatement _
)
C#
public void Insert(
   int index,
   SqlStatement value
)

Parameters

index
value

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : Remove Method

value
Not used in Devart.Common.SqlStatementCollection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As SqlStatement _
)
C#
public void Remove(
   SqlStatement value
)

Parameters

value

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SqlStatementCollection Class Properties
See Also support@devart.com
Devart.Common Namespace : SqlStatementCollection Class

For a list of all members of this type, see SqlStatementCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets the SqlStatement at the specified index.
Top

See Also

Reference

SqlStatementCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > SqlStatementCollection Class : Item Property

index
The zero-based index of the statement.
Gets the SqlStatement at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SqlStatement
C#
public SqlStatement this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the statement.

Property Value

The SqlStatement at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementCollection Class
SqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangedEventArgs Class
Members See Also support@devart.com
Devart.Common Namespace : TransactionStateChangedEventArgs Class

Provides data for the DbTransactionBase.StateChanged event of the DbTransactionBase class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.TransactionStateChangeEventArgs
Devart.Common.TransactionStateChangedEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TransactionStateChangedEventArgs
   Inherits TransactionStateChangeEventArgs
C#
public sealed class TransactionStateChangedEventArgs : TransactionStateChangeEventArgs

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

TransactionStateChangedEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangedEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : TransactionStateChangedEventArgs Class

The following tables list the members exposed by TransactionStateChangedEventArgs.

Public Constructors

 | Name | Description
public Constructor | TransactionStateChangedEventArgs Constructor | Initializes an instance of the TransactionStateChangedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs. (Inherited from Devart.Common.TransactionStateChangeEventArgs)
Top

See Also

Reference

TransactionStateChangedEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangedEventArgs Constructor
See Also support@devart.com
Devart.Common Namespace > TransactionStateChangedEventArgs Class : TransactionStateChangedEventArgs Constructor

action
The operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged event occurs.
Initializes an instance of the TransactionStateChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As TransactionAction _
)
C#
public TransactionStateChangedEventArgs(
   TransactionAction action
)

Parameters

action
The operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged event occurs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

TransactionStateChangedEventArgs Class
TransactionStateChangedEventArgs Members
TransactionAction Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangeEventArgs Class
Members Example See Also support@devart.com
Devart.Common Namespace : TransactionStateChangeEventArgs Class

Base class for TransactionStateChangedEventArgs and TransactionStateChangingEventArgs classes.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.TransactionStateChangeEventArgs
Devart.Common.TransactionStateChangedEventArgs
Devart.Common.TransactionStateChangingEventArgs

Syntax

Visual Basic (Declaration)
Public MustInherit Class TransactionStateChangeEventArgs
   Inherits System.EventArgs
C#
public abstract class TransactionStateChangeEventArgs : System.EventArgs

Example

This sample demonstrates how the common base TransactionStateChangeEventArgs class for TransactionStateChanged and TransactionStateChanging envent arguments allows using more general code.
C#csharp Copy Code
OracleConnection connection = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
   connection.TransactionStateChanged += new TransactionStateChangedEventHandler(connection_TransactionStateChange);
   connection.TransactionStateChanging += new TransactionStateChangingEventHandler(connection_TransactionStateChange);
   connection.Open();
   // ...
OracleTransaction transaction = connection.BeginTransaction();
   // ...
   transaction.Commit();
   // ...

void connection_TransactionStateChange(object sender, TransactionStateChangeEventArgs e) {

        // common actions that must be done before and after the transaction state change
        // ...

        if (e is TransactionStateChangingEventArgs) {
                // actions before the transaction state change
                // ...
        }
        else { // e is TransactionStateChangedEventArgs
                // actions after the transaction state change
                // ...
        }
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
AddHandler connection.TransactionStateChanged, New TransactionStateChangedEventHandler(AddressOf &_ Me.connection_TransactionStateChange)
        AddHandler connection.TransactionStateChanging, New TransactionStateChangingEventHandler(AddressOf &_ Me.connection_TransactionStateChange)
        connection.Open()
        ' ...
        Dim Transaction As OracleTransaction
        Transaction = connection.BeginTransaction()
        ' ...
        Transaction.Commit()
        ' ...

        Private Sub connection_TransactionStateChange(ByVal sender As Object, ByVal e As TransactionStateChangeEventArgs)
        ' common actions that must be done before and after the transaction state change
        '...
        If TypeOf e Is TransactionStateChangingEventArgs Then
                ' actions before the transaction state change
                ' ...
        Else ' e is TransactionStateChangedEventArgs
                ' actions after the transaction state change
                ' ...
        End If
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

TransactionStateChangeEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangeEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : TransactionStateChangeEventArgs Class

The following tables list the members exposed by TransactionStateChangeEventArgs.

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.
Top

See Also

Reference

TransactionStateChangeEventArgs Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangeEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : TransactionStateChangeEventArgs Class

For a list of all members of this type, see TransactionStateChangeEventArgs members.

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.
Top

See Also

Reference

TransactionStateChangeEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Action Property
See Also support@devart.com
Devart.Common Namespace > TransactionStateChangeEventArgs Class : Action Property

Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As TransactionAction
C#
public TransactionAction Action {get;}

Property Value

One of the Devart.Common.TransactionAction values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

TransactionStateChangeEventArgs Class
TransactionStateChangeEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangingEventArgs Class
Members See Also support@devart.com
Devart.Common Namespace : TransactionStateChangingEventArgs Class

Provides data for the DbTransactionBase.StateChanging event of the DbTransactionBase class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Common.TransactionStateChangeEventArgs
Devart.Common.TransactionStateChangingEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TransactionStateChangingEventArgs
   Inherits TransactionStateChangeEventArgs
C#
public sealed class TransactionStateChangingEventArgs : TransactionStateChangeEventArgs

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

TransactionStateChangingEventArgs Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangingEventArgs Class Members
See Also Properties support@devart.com
Devart.Common Namespace : TransactionStateChangingEventArgs Class

The following tables list the members exposed by TransactionStateChangingEventArgs.

Public Constructors

 | Name | Description
public Constructor | TransactionStateChangingEventArgs Constructor | Initializes a new instance of the TransactionStateChangingEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs. (Inherited from Devart.Common.TransactionStateChangeEventArgs)
Top

See Also

Reference

TransactionStateChangingEventArgs Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangingEventArgs Constructor
See Also support@devart.com
Devart.Common Namespace > TransactionStateChangingEventArgs Class : TransactionStateChangingEventArgs Constructor

action
The operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanging event occurs.
Initializes a new instance of the TransactionStateChangingEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As TransactionAction _
)
C#
public TransactionStateChangingEventArgs(
   TransactionAction action
)

Parameters

action
The operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanging event occurs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

TransactionStateChangingEventArgs Class
TransactionStateChangingEventArgs Members
TransactionAction Enumeration


%%ItemTitle%% - Enumerations

Devart.Common Namespace (Devart.Data) - Enumerations
See Also Inheritance Hierarchy support@devart.com

Enumerations

 | Enumeration | Description
Enumeration | DumpMode | Specifies what kind of information should be exported by T:Devart.Data.Oracle.OracleDump.
Enumeration | MonitorEventType | Describes type of the current DbMonitor event.
Enumeration | MonitorTracePoint | Determines when DbMonitor.TraceEvent event occurs.
Enumeration | RefreshRowMode | Describes autorefresh actions that can be taken by DbCommandBuilder and DbDataTable.
Enumeration | SqlStatementType | Describes type of a statement in a script.
Enumeration | TransactionAction | Indicates the operation, that is being performed or has been performed in the transaction in the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging events.

See Also

Reference

Devart.Data Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DumpMode Enumeration
See Also support@devart.com
Devart.Common Namespace : DumpMode Enumeration

Specifies what kind of information should be exported by T:Devart.Data.Oracle.OracleDump.

Syntax

Visual Basic (Declaration)
Public Enum DumpMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum DumpMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
All | Export both data and metadata. The dump contains DDL and DML statements.
Data | Export only data contained in tables. The dump text contains DML statements only.
Schema | Export metadata information only. The dump contains DDL statements only. Information about users is included as well.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.DumpMode

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MonitorEventType Enumeration
See Also support@devart.com
Devart.Common Namespace : MonitorEventType Enumeration

Describes type of the current DbMonitor event.

Syntax

Visual Basic (Declaration)
Public Enum MonitorEventType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum MonitorEventType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
ActivateInPool | Application takes a connection from the pool.
BeginTransaction | Application begins a transaction (local or distributed) against a data source.
Commit | Application executes COMMIT statement against a data source.
Connect | Application opens connection to a data source.
Custom | Application executes any user defined statement against a data source.
Disconnect | Application closes connection to a data source.
Error | Data source returns an error message.
Execute | Application executes a statement against a data source.
Prepare | Application prepares an execute statement.
ReturnToPool | Application returns a connection to the pool.
Rollback | Application executes ROLLBACK statement against a data source.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.MonitorEventType

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MonitorTracePoint Enumeration
See Also support@devart.com
Devart.Common Namespace : MonitorTracePoint Enumeration

Determines when DbMonitor.TraceEvent event occurs.

Syntax

Visual Basic (Declaration)
Public Enum MonitorTracePoint
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum MonitorTracePoint : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
AfterEvent | Occurs in DbMonitor after some operation is complete.
BeforeEvent | Occurs in DbMonitor before some operation has started.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.MonitorTracePoint

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshRowMode Enumeration
See Also support@devart.com
Devart.Common Namespace : RefreshRowMode Enumeration

Describes autorefresh actions that can be taken by DbCommandBuilder and DbDataTable.

Syntax

Visual Basic (Declaration)
Public Enum RefreshRowMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum RefreshRowMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
AfterInsert | Retrieve field values from the server after an INSERT statement execution.
AfterUpdate | Retrieve field values from the server after an UPDATE statement execution.
Both | Retrieve field values from the server after an execution of either INSERT or UPDATE statements.
None | Never refresh field values from the server.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.RefreshRowMode

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementType Enumeration
See Also support@devart.com
Devart.Common Namespace : SqlStatementType Enumeration

Describes type of a statement in a script.

Syntax

Visual Basic (Declaration)
Public Enum SqlStatementType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum SqlStatementType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Alter | An ALTER statement.
Batch | A complex construction like script or statement block.
Commit | A COMMIT statement.
Create | A CREATE statement.
Delete | A DELETE statement.
Drop | A DROP statement.
Execute | An EXECUTE statement.
Extended | A construction that does not represent usual SQL statements.
Insert | An INSERT statement.
Rollback | A ROLLBACK statement.
Select | A SELECT statement.
Truncate | A TRUNCATE statement.
Unknown | Unknown statement type.
Update | An UPDATE statement.
With | A WITH statement.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.SqlStatementType

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionAction Enumeration
See Also support@devart.com
Devart.Common Namespace : TransactionAction Enumeration

Indicates the operation, that is being performed or has been performed in the transaction in the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging events.

Syntax

Visual Basic (Declaration)
Public Enum TransactionAction
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum TransactionAction : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
BeginTransaction | Transaction is being started or has been started.
Commit | Transaction is being committed or has been committed.
ReleaseSavepoint | Savepoint is being released or has been released.
Rollback | Transaction is being rolled back or has been rolled back.
RollbackToSavepoint | Transaction is being rolled back to savepoint or has been rolled back to savepoint.
Savepoint | The savepoint is being created or has been created.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Common.TransactionAction

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Common Namespace


%%ItemTitle%% - Delegates

Devart.Common Namespace (Devart.Data) - Delegates
See Also Inheritance Hierarchy support@devart.com

Delegates

 | Delegate | Description
Delegate | MonitorEventHandler | Represents the method that will handle the DbMonitor.TraceEvent event of the DbMonitor class.
Delegate | ScriptErrorEventHandler | Represents the method that will handle the DbScript.Error event of the DbScript.
Delegate | ScriptProgressEventHandler | Represents the method that will handle the DbScript.Progress event of the DbScript.
Delegate | TransactionStateChangedEventHandler | Represents the method that will handle the DbTransactionBase.StateChanged event of DbTransactionBase descendants.
Delegate | TransactionStateChangingEventHandler | Represents the method that will handle the DbTransactionBase.StateChanging event of DbTransactionBase descendants.

See Also

Reference

Devart.Data Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MonitorEventHandler Delegate
See Also Example support@devart.com
Devart.Common Namespace : MonitorEventHandler Delegate

sender
The source of the event.
e
The MonitorEventArgs object that contains the event data.
Represents the method that will handle the DbMonitor.TraceEvent event of the DbMonitor class.

Syntax

Visual Basic (Declaration)
Public Delegate Sub MonitorEventHandler( _
   ByVal sender As Object, _
   ByVal e As MonitorEventArgs _
)
C#
public delegate void MonitorEventHandler(
   object sender,
   MonitorEventArgs e
)

Parameters

sender
The source of the event.
e
The MonitorEventArgs object that contains the event data.

Remarks

When you create a MonitorEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Example

The following sample shows how to enable and disable monitoring of database activity in your application.
C#csharp Copy Code
static void OnEvent(object sender, MonitorEventArgs e)
{
  if (e.TracePoint==MonitorTracePoint.BeforeEvent)
  {
    Console.WriteLine("Description: " + e.Description);
    Console.WriteLine(" Extra info: " + e.ExtraInfo);
  }
}

[MTAThread]
static void Main(string[] args)
{
  OracleConnection myConn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  OracleMonitor myMonitor = new OracleMonitor();
  myMonitor.TraceEvent += new MonitorEventHandler(OnEvent);
  myMonitor.IsActive = true;
  OracleCommand myCommand = new OracleCommand("select count(*) from Test.Dept",myConn);
  myConn.Open();
  Console.WriteLine(myCommand.ExecuteScalar());
  myConn.Close();
  myMonitor.TraceEvent -= new MonitorEventHandler(OnEvent);
  Console.ReadLine();
}
C#Visual Basic Copy Code
Sub OnEvent(ByVal sender As Object, ByVal e As MonitorEventArgs)
  If e.TracePoint = MonitorTracePoint.BeforeEvent Then
    Console.WriteLine("Description: " & e.Description)
    Console.WriteLine(" Extra info: " & e.ExtraInfo)
  End If
End Sub

<MTAThread()> _
Sub Main()
  Dim myConn As OracleConnection = New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myMonitor As OracleMonitor = New OracleMonitor
  AddHandler myMonitor.TraceEvent, AddressOf OnEvent
  myMonitor.IsActive = True
  Dim myCommand As OracleCommand = New OracleCommand("select count(*) from Test.Dept", myConn)
  myConn.Open()
  Console.WriteLine(myCommand.ExecuteScalar())
  myConn.Close()
  RemoveHandler myMonitor.TraceEvent, AddressOf OnEvent
  Console.ReadLine()
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

MonitorEventHandler Members
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptErrorEventHandler Delegate
See Also support@devart.com
Devart.Common Namespace : ScriptErrorEventHandler Delegate

sender
The source of the event.
e
The ScriptErrorEventArgs object that contains the event data.
Represents the method that will handle the DbScript.Error event of the DbScript.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ScriptErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScriptErrorEventArgs _
)
C#
public delegate void ScriptErrorEventHandler(
   object sender,
   ScriptErrorEventArgs e
)

Parameters

sender
The source of the event.
e
The ScriptErrorEventArgs object that contains the event data.

Remarks

When you create a ScriptErrorEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ScriptErrorEventHandler Members
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptProgressEventHandler Delegate
See Also support@devart.com
Devart.Common Namespace : ScriptProgressEventHandler Delegate

sender
The source of the event.
e
The ScriptErrorEventArgs object that contains the event data.
Represents the method that will handle the DbScript.Progress event of the DbScript.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ScriptProgressEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScriptProgressEventArgs _
)
C#
public delegate void ScriptProgressEventHandler(
   object sender,
   ScriptProgressEventArgs e
)

Parameters

sender
The source of the event.
e
The ScriptErrorEventArgs object that contains the event data.

Remarks

When you create a ScriptErrorEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ScriptProgressEventHandler Members
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangedEventHandler Delegate
See Also support@devart.com
Devart.Common Namespace : TransactionStateChangedEventHandler Delegate

sender
The source of the event.
e
The TransactionStateChangedEventArgs object that contains the event data.
Represents the method that will handle the DbTransactionBase.StateChanged event of DbTransactionBase descendants.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TransactionStateChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As TransactionStateChangedEventArgs _
)
C#
public delegate void TransactionStateChangedEventHandler(
   object sender,
   TransactionStateChangedEventArgs e
)

Parameters

sender
The source of the event.
e
The TransactionStateChangedEventArgs object that contains the event data.

Remarks

When you create a TransactionStateChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

TransactionStateChangedEventHandler Members
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChangingEventHandler Delegate
See Also support@devart.com
Devart.Common Namespace : TransactionStateChangingEventHandler Delegate

sender
The source of the event.
e
The TransactionStateChangingEventArgs object that contains the event data.
Represents the method that will handle the DbTransactionBase.StateChanging event of DbTransactionBase descendants.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TransactionStateChangingEventHandler( _
   ByVal sender As Object, _
   ByVal e As TransactionStateChangingEventArgs _
)
C#
public delegate void TransactionStateChangingEventHandler(
   object sender,
   TransactionStateChangingEventArgs e
)

Parameters

sender
The source of the event.
e
The TransactionStateChangingEventArgs object that contains the event data.

Remarks

When you create a TransactionStateChangingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

TransactionStateChangingEventHandler Members
Devart.Common Namespace


%%ItemTitle%%

Devart.Data Namespace
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DataLink | Allows establishing flexible cross-form data binding.

See Also

Reference

Devart.Data Assembly


%%ItemTitle%% - Classes

Devart.Data Namespace - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DataLink | Allows establishing flexible cross-form data binding.

See Also

Reference

Devart.Data Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataLink Class
Members Example See Also support@devart.com
Devart.Data Namespace : DataLink Class

Allows establishing flexible cross-form data binding.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.BindingSource
Devart.Data.DataLink

Syntax

Visual Basic (Declaration)
Public Class DataLink
   Inherits System.Windows.Forms.BindingSource
   Implements ICollection, IEnumerable, IList, IBindingList, IBindingListView, ICancelAddNew, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, ITypedList, IDisposable, ICurrencyManagerProvider
C#
public class DataLink : System.Windows.Forms.BindingSource, ICollection, IEnumerable, IList, IBindingList, IBindingListView, ICancelAddNew, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, ITypedList, IDisposable, ICurrencyManagerProvider

Remarks

For information on features of DataLink please refer to topic DataLink Component Architecture. See also description of InterForm Technology.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

It is recommended to work with this component in design time. For example, if you create the OracleDataTable object (“myDataTable1”) on Form1, you can access Form1's myDataTable1 via the DataSource property of Form2's DataLink object (“dataLink1”). In this case, you will find the following entry in Form2.InitializeComponent():
C#csharp Copy Code
private void InitializeComponent() {
        ...
        this.dataLink1.DataSource = ((object)(Devart.Common.GlobalComponentsCache.GetObjectByName("Form1.myDataTable1")));
        ...
}
C#Visual Basic Copy Code
Private Sub InitializeComponent()
        ...
        Me.DataLink1.DataSource = CType(Devart.Common.GlobalComponentsCache.GetObjectByName("Form1.myDataTable1"), Object)
        ...
End Sub

Requirements

Namespace: Devart.Data

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DataLink Members
Devart.Data Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DataLink Class Members
See Also Properties Methods Events support@devart.com
Devart.Data Namespace : DataLink Class

The following tables list the members exposed by DataLink.

Public Constructors

 | Name | Description
public Constructor | DataLink Constructor | Creates a new instance of the DataLink class.
Top

Public Properties

 | Name | Description
public Property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from System.Windows.Forms.BindingSource)
public Property | AllowNew | Gets or sets a value indicating whether the System.Windows.Forms.BindingSource.AddNew method can be used to add items to the list. (Inherited from System.Windows.Forms.BindingSource)
public Property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from System.Windows.Forms.BindingSource)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Count | Gets the total number of items in the underlying list, taking the current System.Windows.Forms.BindingSource.Filter value into consideration. (Inherited from System.Windows.Forms.BindingSource)
public Property | CurrencyManager | Gets the currency manager associated with this System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Property | Current | Gets the current item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Property | CurrentRow | Gets the current data row, which can be changed by user by changing position in the data grid or data controls.
public Property | DataMember | Gets or sets the specific data member in a multimember data source to bind to a data listing control.
public Property | DataSource | Gets or sets the source containing a list of values used to populate the items within the control.
public Property | Filter | Gets or sets the expression used to filter which rows are viewed. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsBindingSuspended | Gets a value indicating whether the list binding is suspended. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsSorted | Gets a value indicating whether the items in the underlying list are sorted. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from System.Windows.Forms.BindingSource)
public Property | Item | Gets or sets the list element at the specified index. (Inherited from System.Windows.Forms.BindingSource)
public Property | List | Gets the list that the connector is bound to.
public Property | Owner | Gets or sets a form or other container that the DataLink instance belongs to.
public Property | Position | Gets or sets the index of the current item in the underlying list.
public Property | RaiseListChangedEvents | Gets or sets a value indicating whether System.Windows.Forms.BindingSource.ListChanged events should be raised. (Inherited from System.Windows.Forms.BindingSource)
public Property | SeparateEditing | Puts separate filters over the DataView object that was created.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsFiltering | Gets a value indicating whether the data source supports filtering. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsSearching | Gets a value indicating whether the data source supports searching with the System.Windows.Forms.BindingSource.Find(System.ComponentModel.PropertyDescriptor,System.Object) method. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsSorting | Gets a value indicating whether the data source supports sorting. (Inherited from System.Windows.Forms.BindingSource)
public Property | Synchronized | Gets or sets a value indicating whether to synchronize current position with other DataLink instances that reference the same data source.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from System.Windows.Forms.BindingSource)
Top

Public Methods

 | Name | Description
public Method | Add | Adds an existing item to the internal list. (Inherited from System.Windows.Forms.BindingSource)
public Method | AddNew | Overridden. Adds a new item to the underlying list.
public Method | CancelEdit | Cancels the current edit operation. (Inherited from System.Windows.Forms.BindingSource)
public Method | Clear | Removes all elements from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | Contains | Determines whether an object is an item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | CopyTo | Copies the contents of the System.Windows.Forms.BindingSource.List to the specified array, starting at the specified index value. (Inherited from System.Windows.Forms.BindingSource)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndEdit | Applies pending changes to the underlying data source. (Inherited from System.Windows.Forms.BindingSource)
public Method | Find | Overloaded. Returns the index of the item in the list with the specified property name and value.
public Method | GetEnumerator | Retrieves an enumerator for the System.Windows.Forms.BindingSource.List. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetItemProperties | Retrieves an array of System.ComponentModel.PropertyDescriptor objects representing the bindable properties of the data source list type. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetListName | Gets the name of the list supplying data for the binding. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetRelatedCurrencyManager | Gets the related currency manager for the specified data member. (Inherited from System.Windows.Forms.BindingSource)
public Method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from System.Windows.Forms.BindingSource)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an item into the list at the specified index. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveFirst | Moves to the first item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveLast | Moves to the last item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveNext | Moves to the next item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MovePrevious | Moves to the previous item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | Remove | Removes the specified item from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveAt | Removes the item at the specified index in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveCurrent | Removes the current item from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveFilter | Removes the filter associated with the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveSort | Removes the sort associated with the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetAllowNew | Reinitializes the System.Windows.Forms.BindingSource.AllowNew property. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetBindings | Causes a control bound to the System.Windows.Forms.BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetCurrentItem | Causes a control bound to the System.Windows.Forms.BindingSource to reread the currently selected item and refresh its displayed value. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetItem | Causes a control bound to the System.Windows.Forms.BindingSource to reread the item at the specified index, and refresh its displayed value. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResumeBinding | Resumes data binding. (Inherited from System.Windows.Forms.BindingSource)
public Method | SuspendBinding | Suspends data binding to prevent changes from updating the bound data source. (Inherited from System.Windows.Forms.BindingSource)
Top

Public Events

 | Name | Description
public Event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from System.Windows.Forms.BindingSource)
public Event | BindingComplete | Occurs when all the clients have been bound to this System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from System.Windows.Forms.BindingSource)
public Event | CurrentItemChanged | Occurs when a property value of the System.Windows.Forms.BindingSource.Current property has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataError | Occurs when a currency-related exception is silently handled by the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataMemberChanged | Occurs when the System.Windows.Forms.BindingSource.DataMember property value has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataSourceChanged | Occurs when the System.Windows.Forms.BindingSource.DataSource property value has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from System.Windows.Forms.BindingSource)
public Event | PositionChanged | Occurs after the value of the System.Windows.Forms.BindingSource.Position property has changed. (Inherited from System.Windows.Forms.BindingSource)
Top

See Also

Reference

DataLink Class
Devart.Data Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataLink Constructor
See Also support@devart.com
Devart.Data Namespace > DataLink Class : DataLink Constructor

Creates a new instance of the DataLink class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public DataLink()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DataLink Class Methods
See Also support@devart.com
Devart.Data Namespace : DataLink Class

For a list of all members of this type, see DataLink members.

Public Methods

 | Name | Description
public Method | Add | Adds an existing item to the internal list. (Inherited from System.Windows.Forms.BindingSource)
public Method | AddNew | Overridden. Adds a new item to the underlying list.
public Method | CancelEdit | Cancels the current edit operation. (Inherited from System.Windows.Forms.BindingSource)
public Method | Clear | Removes all elements from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | Contains | Determines whether an object is an item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | CopyTo | Copies the contents of the System.Windows.Forms.BindingSource.List to the specified array, starting at the specified index value. (Inherited from System.Windows.Forms.BindingSource)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndEdit | Applies pending changes to the underlying data source. (Inherited from System.Windows.Forms.BindingSource)
public Method | Find | Overloaded. Returns the index of the item in the list with the specified property name and value.
public Method | GetEnumerator | Retrieves an enumerator for the System.Windows.Forms.BindingSource.List. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetItemProperties | Retrieves an array of System.ComponentModel.PropertyDescriptor objects representing the bindable properties of the data source list type. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetListName | Gets the name of the list supplying data for the binding. (Inherited from System.Windows.Forms.BindingSource)
public Method | GetRelatedCurrencyManager | Gets the related currency manager for the specified data member. (Inherited from System.Windows.Forms.BindingSource)
public Method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from System.Windows.Forms.BindingSource)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an item into the list at the specified index. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveFirst | Moves to the first item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveLast | Moves to the last item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MoveNext | Moves to the next item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | MovePrevious | Moves to the previous item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | Remove | Removes the specified item from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveAt | Removes the item at the specified index in the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveCurrent | Removes the current item from the list. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveFilter | Removes the filter associated with the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Method | RemoveSort | Removes the sort associated with the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetAllowNew | Reinitializes the System.Windows.Forms.BindingSource.AllowNew property. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetBindings | Causes a control bound to the System.Windows.Forms.BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetCurrentItem | Causes a control bound to the System.Windows.Forms.BindingSource to reread the currently selected item and refresh its displayed value. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResetItem | Causes a control bound to the System.Windows.Forms.BindingSource to reread the item at the specified index, and refresh its displayed value. (Inherited from System.Windows.Forms.BindingSource)
public Method | ResumeBinding | Resumes data binding. (Inherited from System.Windows.Forms.BindingSource)
public Method | SuspendBinding | Suspends data binding to prevent changes from updating the bound data source. (Inherited from System.Windows.Forms.BindingSource)
Top

See Also

Reference

DataLink Class
Devart.Data Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddNew Method
See Also support@devart.com
Devart.Data Namespace > DataLink Class : AddNew Method

Adds a new item to the underlying list.

Syntax

Visual Basic (Declaration)
Public Overrides Function AddNew() As Object
C#
public override object AddNew()

Return Value

The System.Object that was created and added to the list.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Find Method
See Also support@devart.com
Devart.Data Namespace > DataLink Class : Find Method

Returns the index of the item in the list with the specified property name and value.

Overload List

Overload | Description
Find(String,Object) | Returns the index of the item in the list with the specified property name and value.
Find(PropertyDescriptor,Object) | Searches for the index of the item that has the given property descriptor. (Inherited from System.Windows.Forms.BindingSource)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Find(String,Object) Method
See Also support@devart.com
Devart.Data Namespace > DataLink Class > Find Method : Find(String,Object) Method

propertyName
The name of the property to search for.
key
The value of the item with the specified name to find.
Returns the index of the item in the list with the specified property name and value.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function Find( _
   ByVal propertyName As String, _
   ByVal key As Object _
) As Integer
C#
public new int Find(
   string propertyName,
   object key
)

Parameters

propertyName
The name of the property to search for.
key
The value of the item with the specified name to find.

Return Value

The zero-based index of the item, having the specified property name and value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DataLink Class Properties
See Also support@devart.com
Devart.Data Namespace : DataLink Class

For a list of all members of this type, see DataLink members.

Public Properties

 | Name | Description
public Property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from System.Windows.Forms.BindingSource)
public Property | AllowNew | Gets or sets a value indicating whether the System.Windows.Forms.BindingSource.AddNew method can be used to add items to the list. (Inherited from System.Windows.Forms.BindingSource)
public Property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from System.Windows.Forms.BindingSource)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Count | Gets the total number of items in the underlying list, taking the current System.Windows.Forms.BindingSource.Filter value into consideration. (Inherited from System.Windows.Forms.BindingSource)
public Property | CurrencyManager | Gets the currency manager associated with this System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Property | Current | Gets the current item in the list. (Inherited from System.Windows.Forms.BindingSource)
public Property | CurrentRow | Gets the current data row, which can be changed by user by changing position in the data grid or data controls.
public Property | DataMember | Gets or sets the specific data member in a multimember data source to bind to a data listing control.
public Property | DataSource | Gets or sets the source containing a list of values used to populate the items within the control.
public Property | Filter | Gets or sets the expression used to filter which rows are viewed. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsBindingSuspended | Gets a value indicating whether the list binding is suspended. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsSorted | Gets a value indicating whether the items in the underlying list are sorted. (Inherited from System.Windows.Forms.BindingSource)
public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from System.Windows.Forms.BindingSource)
public Property | Item | Gets or sets the list element at the specified index. (Inherited from System.Windows.Forms.BindingSource)
public Property | List | Gets the list that the connector is bound to.
public Property | Owner | Gets or sets a form or other container that the DataLink instance belongs to.
public Property | Position | Gets or sets the index of the current item in the underlying list.
public Property | RaiseListChangedEvents | Gets or sets a value indicating whether System.Windows.Forms.BindingSource.ListChanged events should be raised. (Inherited from System.Windows.Forms.BindingSource)
public Property | SeparateEditing | Puts separate filters over the DataView object that was created.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsFiltering | Gets a value indicating whether the data source supports filtering. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsSearching | Gets a value indicating whether the data source supports searching with the System.Windows.Forms.BindingSource.Find(System.ComponentModel.PropertyDescriptor,System.Object) method. (Inherited from System.Windows.Forms.BindingSource)
public Property | SupportsSorting | Gets a value indicating whether the data source supports sorting. (Inherited from System.Windows.Forms.BindingSource)
public Property | Synchronized | Gets or sets a value indicating whether to synchronize current position with other DataLink instances that reference the same data source.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from System.Windows.Forms.BindingSource)
Top

See Also

Reference

DataLink Class
Devart.Data Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CurrentRow Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : CurrentRow Property

Gets the current data row, which can be changed by user by changing position in the data grid or data controls.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentRow As DbDataRowView
C#
public DbDataRowView CurrentRow {get;}

Property Value

The current data row, which can be changed by user by changing position in the data grid or data controls.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataMember Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : DataMember Property

Gets or sets the specific data member in a multimember data source to bind to a data listing control.

Syntax

Visual Basic (Declaration)
Public Shadows Property DataMember As String
C#
public new string DataMember {get; set;}

Property Value

A data member from a multimember data source. The default value is an empty string.

Remarks

Use the DataMember property to specify a member from a multimember data source to bind to the list control. For example, if you have a data source with more than one table specified in the DataSource property, use the DataMember property to specify which table to bind to a data listing control.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members
DataSource Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataSource Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : DataSource Property

Gets or sets the source containing a list of values used to populate the items within the control.

Syntax

Visual Basic (Declaration)
Public Shadows Property DataSource As Object
C#
public new object DataSource {get; set;}

Property Value

An IEnumerable or IListSource that contains a collection of values used to supply data to this control. The default value is a null reference.

Remarks

Use the DataSource property to specify the source of values to bind to a data listing control. A data source must be an object that implements either the System.Collections.IEnumerable interface (such as System.Data.DataView, System.Collections.ArrayList, or System.Collections.Hashtable) or the IListSource interface to bind to a control derived from the BaseDataList class. When you set the DataSource property, you must manually write the code to perform data binding.

If the data source specified by the DataSource property contains multiple sources of data, use the DataMember property to specify the specific source to bind to the control. For example, if you have a System.Data.DataSet object with multiple tables, you must specify which table to bind to the control.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members
DataMember Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
List Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : List Property

Gets the list that the connector is bound to.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property List As IList
C#
public new IList List {get;}

Property Value

The list that the connector is bound to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : Owner Property

Gets or sets a form or other container that the DataLink instance belongs to.

Syntax

Visual Basic (Declaration)
Public Property Owner As Object
C#
public object Owner {get; set;}

Property Value

A form or other container that the object belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Position Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : Position Property

Gets or sets the index of the current item in the underlying list.

Syntax

Visual Basic (Declaration)
Public Shadows Property Position As Integer
C#
public new int Position {get; set;}

Property Value

The zero-based index of the current item in the underlying list.

Remarks

When setting the Position property, out-of-range values are treated in the following manner:

  • Negative values are treated as 0.
  • Values greater than or equal to Count are treated as Count minus 1.

Changing the Position property will correspondingly change the CurrentRow property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SeparateEditing Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : SeparateEditing Property

Puts separate filters over the DataView object that was created.

Syntax

Visual Basic (Declaration)
Public Property SeparateEditing As Boolean
C#
public bool SeparateEditing {get; set;}

Remarks

By default DataLink uses the same DataView object as the data source it references to does. This influences sorting and filtering data to DataLink.

When the SeparateEditing property is set to true, DataLink creates its own DataView object, over which filters are put separately.

See Creating and Using DataViews for more information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Synchronized Property
See Also support@devart.com
Devart.Data Namespace > DataLink Class : Synchronized Property

Gets or sets a value indicating whether to synchronize current position with other DataLink instances that reference the same data source.

Syntax

Visual Basic (Declaration)
Public Property Synchronized As Boolean
C#
public bool Synchronized {get; set;}

Property Value

If %%, navigation in this instance of DataLink will affect other instances. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DataLink Class
DataLink Members


Devart.Data.Oracle Assembly
See Also support@devart.com

Namespaces

Namespace | Description
Devart.Common |
Devart.Data.Oracle |


%%ItemTitle%%

Devart.Common Namespace (Devart.Data.Oracle)
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbConnectionBase | Represents an open connection to a server.
Class | DbMonitorHelper | Allows to monitor dynamic SQL execution in applications that use .NET data providers.
Class | SelectColumn | Represents a column or an expression in SELECT, GROUP BY and ORDER BY clauses of a SQL statement.
Class | SelectColumnCollection | Represents a collection of columns and expressions in a SelectStatement object.
Class | SelectStatement | Composes, modifies and parses SELECT statements.
Class | SelectStatementNode | An abstract SQL element.
Class | SelectTable | Represents a table or a subquery in the FROM clause of a SELECT statement.
Class | SelectTableCollection | Represents a collection of tables and subqueries in a SelectStatement object.

See Also

Reference

Devart.Data.Oracle Assembly


%%ItemTitle%% - Classes

Devart.Common Namespace (Devart.Data.Oracle) - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbConnectionBase | Represents an open connection to a server.
Class | DbMonitorHelper | Allows to monitor dynamic SQL execution in applications that use .NET data providers.
Class | SelectColumn | Represents a column or an expression in SELECT, GROUP BY and ORDER BY clauses of a SQL statement.
Class | SelectColumnCollection | Represents a collection of columns and expressions in a SelectStatement object.
Class | SelectStatement | Composes, modifies and parses SELECT statements.
Class | SelectStatementNode | An abstract SQL element.
Class | SelectTable | Represents a table or a subquery in the FROM clause of a SELECT statement.
Class | SelectTableCollection | Represents a collection of tables and subqueries in a SelectStatement object.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbConnectionBase Class
Members Example See Also support@devart.com
Devart.Common Namespace : DbConnectionBase Class

Represents an open connection to a server.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbConnection
Devart.Common.DbConnectionBase
Devart.Data.Oracle.OracleConnection

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbConnectionBase
   Inherits System.Data.Common.DbConnection
   Implements IComponent, IDbConnection, IDisposable
C#
public abstract class DbConnectionBase : System.Data.Common.DbConnection, IComponent, IDbConnection, IDisposable

Remarks

The abstract DbConnectionBase class implements some of DbConnectionBase functionality that is DBMS-independent.

Example

The following sample demonstrates how using base classes helps to create database-independent code.
C#csharp Copy Code
public void PrintDept(DbConnectionBase myConnection) {
        DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
        myCommand.CommandText = "SELECT * FROM Test.Dept";
        myConnection.Open();
        DbDataReader myReader = myCommand.ExecuteReader();
        try {
                while (myReader.Read()) {
                        Console.WriteLine(myReader.GetInt32(0) + " " +
                                myReader.GetString(1) + " " + myReader.GetString(2));
                }
        }
        finally {
                myReader.Close();
                myConnection.Close();
        }
}
C#Visual Basic Copy Code
Public Sub PrintDept(ByVal myConnection As DbConnectionBase)
        Dim myCommand As DbCommandBase = myConnection.CreateCommand()
        myCommand.CommandText = "SELECT * FROM Test.Dept"
        myConnection.Open()
        Dim myReader As DbDataReader = myCommand.ExecuteReader()
        Try
                While myReader.Read()
                        Console.WriteLine(String.Concat(myReader.GetInt32(0), " ", _
                                myReader.GetString(1), " ", myReader.GetString(2)))
                End While
        Finally
                myReader.Close()
                myConnection.Close()
        End Try
End Sub

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbConnectionBase Members
Devart.Common Namespace
DbConnectionBase Class
OracleConnection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbConnectionBase Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbConnectionBase Class

The following tables list the members exposed by DbConnectionBase.

Public Properties

 | Name | Description
public Property | ConnectionString | Overridden. Gets or sets the string used to open a server connection.
public Property | ConnectionTimeout | Overridden. Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Database | Overridden. Gets or sets the name of the current database or the database to be used once a connection is open.
public Property | DataSource | Overridden. Gets or sets name of the server to which to connect.
public Property | InDistributedTransaction | Indicates whether the connection is enlisted in a distributed transaction.
public Property | Name | Gets or sets name of the component.
public Property | Owner | Gets or sets a form or other container that the DbConnectionBase instance belongs to.
public Property | ServerVersion | Overridden. Gets a string containing the version of the instance of the server to which the client is connected.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | State | Overridden. Gets the current state of the connection.
Top

Public Methods

 | Name | Description
public Method | BeginOpen | Starts an asynchronous invocation of an Open method.
public Method | BeginTransaction | Overloaded. Starts a database transaction. (Inherited from System.Data.Common.DbConnection)
public Method | ChangeDatabase | Overridden. Changes the current schema associated with an open DbConnectionBase.
public Method | Close | Overridden. Closes the connection to the database. This is the preferred method of closing any open connection.
public Method | CreateCommand | Creates and returns a System.Data.Common.DbCommand object associated with the current connection. (Inherited from System.Data.Common.DbConnection)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndOpen | Ends an asynchronous invocation of the Open method.
public Method | EnlistTransaction | Overridden. Enlists in the specified transaction.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSchema | Overloaded. Overridden. Provides information about server schema objects.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overridden. Opens a data source connection with the property settings specified by the ConnectionString.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | StateChange | Occurs when the state of the connection changes.
public Event | TransactionStateChanged | Occurs when the state of the transaction is changed.
public Event | TransactionStateChanging | Occurs when the state of the transaction is changing.
Top

See Also

Reference

DbConnectionBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbConnectionBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbConnectionBase Class

For a list of all members of this type, see DbConnectionBase members.

Public Methods

 | Name | Description
public Method | BeginOpen | Starts an asynchronous invocation of an Open method.
public Method | BeginTransaction | Overloaded. Starts a database transaction. (Inherited from System.Data.Common.DbConnection)
public Method | ChangeDatabase | Overridden. Changes the current schema associated with an open DbConnectionBase.
public Method | Close | Overridden. Closes the connection to the database. This is the preferred method of closing any open connection.
public Method | CreateCommand | Creates and returns a System.Data.Common.DbCommand object associated with the current connection. (Inherited from System.Data.Common.DbConnection)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndOpen | Ends an asynchronous invocation of the Open method.
public Method | EnlistTransaction | Overridden. Enlists in the specified transaction.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSchema | Overloaded. Overridden. Provides information about server schema objects.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overridden. Opens a data source connection with the property settings specified by the ConnectionString.
Top

See Also

Reference

DbConnectionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginOpen Method
See Also Example support@devart.com
Devart.Common Namespace > DbConnectionBase Class : BeginOpen Method

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.
Starts an asynchronous invocation of an Open method.

Syntax

Visual Basic (Declaration)
Public Function BeginOpen( _
   ByVal callback As AsyncCallback, _
   ByVal stateObject As Object _
) As IAsyncResult
C#
public IAsyncResult BeginOpen(
   AsyncCallback callback,
   object stateObject
)

Parameters

callback
The delegate to call when the asynchronous invoke is complete. If callback is a null reference (Nothing in Visual Basic), the delegate is not called.
stateObject
State information that is passed on to the delegate.

Return Value

An System.IAsyncResult interface that represents the asynchronous operation started by calling this method.

Remarks

BeginOpen method enables you to open a connection to server without having current thread blocked. In other words, your program can continue execution while the connection is establishing so you do not have to wait for it.

To start opening a connection, you have to call BeginOpen method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to System.IAsyncResult object. After executing this method program flow continues.

When you are ready to use the connection, call EndOpen. If at the moment you call this method the negotiation process has not yet been finished, application stops and waits till the function returns which means that the connection is open.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

This sample shows how to implement asynchronous opening of a connection.
C#csharp Copy Code
public void AsyncOpen(DbConnectionBase myConnection)
{
  IAsyncResult myAsyncResult = myConnection.BeginOpen(null, null);
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values('100', 'DEVELOPMENT')";
  //some operations here
  myConnection.EndOpen(myAsyncResult);
  try
  {
    myCommand.ExecuteNonQuery();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub AsyncOpen(ByVal myConnection As DbConnectionBase)
  Dim myAsyncResult As IAsyncResult = myConnection.BeginOpen(Nothing, Nothing)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values('110', 'QA')"
  ' some operations here
  myConnection.EndOpen(myAsyncResult)
  Try
    myCommand.ExecuteNonQuery()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ChangeDatabase Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : ChangeDatabase Method

value
The schema name.
Changes the current schema associated with an open DbConnectionBase.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ChangeDatabase( _
   ByVal value As String _
)
C#
public override void ChangeDatabase(
   string value
)

Parameters

value
The schema name.

Remarks

This method does not close physical connection to the server, it only changes the current schema associated with an open DbConnectionBase.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : Close Method

Closes the connection to the database. This is the preferred method of closing any open connection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

The Close method rolls back any pending transactions. It then releases the connection to the connection pool, or closes the connection if connection pooling is disabled.

Note that you must manually close all connections opened by the application. If a DbConnectionBase goes out of scope, it is not closed automatically till the application shuts down.

An application can call Close more than one time without generating an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndOpen Method
See Also Example support@devart.com
Devart.Common Namespace > DbConnectionBase Class : EndOpen Method

result
The System.IAsyncResult returned from BeginOpen.
Ends an asynchronous invocation of the Open method.

Syntax

Visual Basic (Declaration)
Public Sub EndOpen( _
   ByVal result As IAsyncResult _
)
C#
public void EndOpen(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned from BeginOpen.

Remarks

BeginOpen method enables you to open a connection to server without having current thread blocked. In other words, your program can continue execution while the connection is establishing so you do not have to wait for it.

To start opening a connection, you have to call BeginOpen method, which in turn invokes appropriate actions in another thread. Return value of this method must be assigned to System.IAsyncResult object. After executing this method program flow continues.

When you are ready to use the connection, call EndOpen. If at the moment you call this method the negotiation process has not yet been finished, application stops and waits till the function returns which means that the connection is open.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

This sample shows how to implement asynchronous opening of a connection.
C#csharp Copy Code
public void AsyncOpen(DbConnectionBase myConnection)
{
  IAsyncResult myAsyncResult = myConnection.BeginOpen(null, null);
  DbCommandBase myCommand = (DbCommandBase)myConnection.CreateCommand();
  myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values('100', 'DEVELOPMENT')";
  //some operations here
  myConnection.EndOpen(myAsyncResult);
  try
  {
    myCommand.ExecuteNonQuery();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub AsyncOpen(ByVal myConnection As DbConnectionBase)
  Dim myAsyncResult As IAsyncResult = myConnection.BeginOpen(Nothing, Nothing)
  Dim myCommand As DbCommandBase = myConnection.CreateCommand()
  myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values('110', 'QA')"
  ' some operations here
  myConnection.EndOpen(myAsyncResult)
  Try
    myCommand.ExecuteNonQuery()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnlistTransaction Method
See Also Example support@devart.com
Devart.Common Namespace > DbConnectionBase Class : EnlistTransaction Method

transaction
A reference to an existing System.Transactions.Transaction in which to enlist.
Enlists in the specified transaction.

Syntax

Visual Basic (Declaration)
Public Overrides Sub EnlistTransaction( _
   ByVal transaction As Transaction _
)
C#
public override void EnlistTransaction(
   Transaction transaction
)

Parameters

transaction
A reference to an existing System.Transactions.Transaction in which to enlist.

Remarks

Once a connection is explicitly enlisted in a distributed transaction, it cannot be unenlisted or enlisted in another transaction until the first transaction finishes.

This feature is not available in Direct mode.

Example

These samples demonstrate usage of Devart.Data.Oracle.OracleConnection.EnlistTransaction.
C#csharp Copy Code
OracleCommand1.Connection=OracleConnection1;
using (TransactionScope transScope = new TransactionScope()) {
 OracleConnection1.Open();
 OracleCommand1.ExecuteNonQuery();
 transScope.Complete();
}
OracleConnection1.Close();

- or -

OracleCommand1.Connection=OracleConnection1;
OracleConnection1.Open();
using (TransactionScope transScope = new TransactionScope()) {
 OracleConnection1.EnlistTransaction(Transaction.Current);
 OracleCommand1.ExecuteNonQuery();
 transScope.Complete();
}
OracleConnection1.Close();

- or -

CommittableTransaction cmtTx = new CommittableTransaction();
OracleConnection1.Open();
OracleConnection1.EnlistTransaction(cmtTx);
OracleCommand1.ExecuteNonQuery();
OracleConnection1.Close();
C#Visual Basic Copy Code
Me.OracleCommand1.Connection = Me.OracleConnection1
Using transScope = New Transactions.TransactionScope
  Me.OracleConnection1.Open()
  Me.OracleCommand1.ExecuteNonQuery()
  transScope.Complete()
End Using
Me.OracleConnection1.Close()

- or -

Me.OracleCommand1.Connection = Me.OracleConnection1
Me.OracleConnection1.Open()
Using transScope = New Transactions.TransactionScope
  Me.OracleConnection1.EnlistTransaction(Transactions.Transaction.Current)
  Me.OracleCommand1.ExecuteNonQuery()
  transScope.Complete()
End Using
Me.OracleConnection1.Close()

- or -

Dim cmtTx As New Transactions.CommittableTransaction
Me.OracleConnection1.Open()
Me.OracleConnection1.EnlistTransaction(cmtTx)
Me.OracleCommand1.ExecuteNonQuery()
Me.OracleConnection1.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchema Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : GetSchema Method

Provides information about server schema objects.

Overload List

Overload | Description
GetSchema() | Returns list of metadata collections and number of restrictions for a collection.
GetSchema(String) | Provides information about server schema objects.
GetSchema(String,String[]) | Returns detailed information about a server schema object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchema() Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class > GetSchema Method : GetSchema() Method

Returns list of metadata collections and number of restrictions for a collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetSchema() As DataTable
C#
public override DataTable GetSchema()

Return Value

A System.Data.DataTable object.

Remarks

Calling this method is actually same as calling GetSchema(String) method with parameter "MetaDataCollections". It allows to obtain information about names of the server schema elements.

Refer to "Retrieving Metadata" article for detailed information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchema(String) Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class > GetSchema Method : GetSchema(String) Method

collectionName
Name of the collection to get information about.
Provides information about server schema objects.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetSchema( _
   ByVal collectionName As String _
) As DataTable
C#
public override DataTable GetSchema(
   string collectionName
)

Parameters

collectionName
Name of the collection to get information about.

Return Value

A System.Data.DataTable object.

Remarks

GetSchema with 1 argument returns general information about the collection queried. For example, GetSchema("Users") returns list of the users on the server. To get the list of collections, call the GetSchema method without parameters, or with single parameter "MetaDataCollections" (which is actually the same). The table object returned by the method will contain three columns. The first field of every row is a keyword allowed to pass to the method (as collectionName argument). The second field is number of restriction values for this keywords (passed through restrictionValues argument).

Refer to "Retrieving Metadata" article for detailed information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchema(String,String[]) Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class > GetSchema Method : GetSchema(String,String[]) Method

collectionName
Name of the collection to get information about.
restrictionValues
Array of strings representing collection restrictions. In some cases last array members may be omitted.
Returns detailed information about a server schema object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetSchema( _
   ByVal collectionName As String, _
   ByVal restrictionValues() As String _
) As DataTable
C#
public override DataTable GetSchema(
   string collectionName,
   string[] restrictionValues
)

Parameters

collectionName
Name of the collection to get information about.
restrictionValues
Array of strings representing collection restrictions. In some cases last array members may be omitted.

Return Value

A System.Data.DataTable object.

Remarks

GetSchema with 2 arguments returns detailed information about the collection or collection members. You can use wildcards in some cases to obtain information about several collection members.

Refer to "Retrieving Metadata" article for detailed information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : Open Method

Opens a data source connection with the property settings specified by the ConnectionString.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Open()
C#
public override void Open()

Remarks

The DbConnectionBase draws an open connection from the connection pool if one is available. Otherwise, it establishes a new connection to the data source.

Note: If the DbConnectionBase goes out of scope, the connection it represents does not close automatically. Therefore, you must explicitly close the connection by calling Close.

Opening an open connection does nothing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbConnectionBase Class Properties
See Also support@devart.com
Devart.Common Namespace : DbConnectionBase Class

For a list of all members of this type, see DbConnectionBase members.

Public Properties

 | Name | Description
public Property | ConnectionString | Overridden. Gets or sets the string used to open a server connection.
public Property | ConnectionTimeout | Overridden. Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Database | Overridden. Gets or sets the name of the current database or the database to be used once a connection is open.
public Property | DataSource | Overridden. Gets or sets name of the server to which to connect.
public Property | InDistributedTransaction | Indicates whether the connection is enlisted in a distributed transaction.
public Property | Name | Gets or sets name of the component.
public Property | Owner | Gets or sets a form or other container that the DbConnectionBase instance belongs to.
public Property | ServerVersion | Overridden. Gets a string containing the version of the instance of the server to which the client is connected.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | State | Overridden. Gets the current state of the connection.
Top

See Also

Reference

DbConnectionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionString Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : ConnectionString Property

Gets or sets the string used to open a server connection.

Syntax

Visual Basic (Declaration)
Public Overrides Property ConnectionString As String
C#
public override string ConnectionString {get; set;}

Property Value

The connection string that includes parameters needed to establish the initial connection. The default value is an empty string ("").

Remarks

When ConnectionString property is assigned a value, connection closes. The connection string is parsed immediately after being set. If errors in syntax are found when parsing, a runtime exception, such as System.ArgumentException, is generated. Other errors can be found only when an attempt is made to Open the connection.

The ConnectionString is similar to an OLE DB connection string. Values may be delimited by single or double quotes, (for example, name='value' or name="value"). Either single or double quotes may be used within a connection string by using the other delimiter, for example, name="value's" or name= 'value"s', but not name= 'value's' or name= ""value"". All blank characters, except those placed within a value or within quotes, are ignored. Keyword value pairs must be separated by a semicolon (;). If a semicolon is part of a value, it also must be delimited by quotes. No escape sequences are supported. The value type is irrelevant. Names are not case sensitive.

If a given name occurs more than once in the connection string, the value associated with the last occurrence is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionTimeout Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : ConnectionTimeout Property

Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ConnectionTimeout As Integer
C#
public override int ConnectionTimeout {get;}

Property Value

The time (in seconds) to wait for a connection to open. The default value is 15 seconds.

Remarks

A value of 0 indicates no limit, and should be avoided in a ConnectionString because an attempt to connect will wait indefinitely.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Database Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : Database Property

Gets or sets the name of the current database or the database to be used once a connection is open.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Database As String
C#
public override string Database {get;}

Property Value

The name of the current database or the name of the database to be used once a connection is open. The default value is an empty string ("").

Remarks

This property is not used in dotConnect for Oracle.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataSource Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : DataSource Property

Gets or sets name of the server to which to connect.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DataSource As String
C#
public override string DataSource {get;}

Property Value

Gets or sets name of the server to which to connect. The default value is an empty string ("").

Remarks

When a value is assigned to this property, the DbConnectionBase is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InDistributedTransaction Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : InDistributedTransaction Property

Indicates whether the connection is enlisted in a distributed transaction.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InDistributedTransaction As Boolean
C#
public bool InDistributedTransaction {get;}

Property Value

true if the connection is enlisted in a distributed transaction; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : Name Property

Gets or sets name of the component.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : Owner Property

Gets or sets a form or other container that the DbConnectionBase instance belongs to.

Syntax

Visual Basic (Declaration)
Public Property Owner As Object
C#
public object Owner {get; set;}

Property Value

A form or other container that the object belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServerVersion Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : ServerVersion Property

Gets a string containing the version of the instance of the server to which the client is connected.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ServerVersion As String
C#
public override string ServerVersion {get;}

Property Value

The version of the server instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
State Property
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : State Property

Gets the current state of the connection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property State As ConnectionState
C#
public override ConnectionState State {get;}

Property Value

A bitwise combination of the System.Data.ConnectionState values. The default value is Closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbConnectionBase Class Events
See Also support@devart.com
Devart.Common Namespace : DbConnectionBase Class

For a list of all members of this type, see DbConnectionBase members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | StateChange | Occurs when the state of the connection changes.
public Event | TransactionStateChanged | Occurs when the state of the transaction is changed.
public Event | TransactionStateChanging | Occurs when the state of the transaction is changing.
Top

See Also

Reference

DbConnectionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StateChange Event
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : StateChange Event

Occurs when the state of the connection changes.

Syntax

Visual Basic (Declaration)
Public Shadows Event StateChange As StateChangeEventHandler
C#
public new event StateChangeEventHandler StateChange

Event Data

The event handler receives an argument of type StateChangeEventArgs containing data related to this event. The following StateChangeEventArgs properties provide information specific to this event.

Property | Description
CurrentState | Gets the new state of the connection. The connection object will be in the new state already when the event is fired.
OriginalState | Gets the original state of the connection.

Remarks

The event handler receives an argument of type System.Data.StateChangeEventArgs containing data related to this event. The following System.Data.StateChangeEventArgs properties provide information specific to this event.
Property | Description
CurrentState | Gets the new state of the connection. The connection object will be in the new state already when the event is fired.
OriginalState | Gets the original state of the connection.

The StateChange event is raised immediately after the State changes from Closed to Opened, or from Opened to Closed.

If an event handler throws an exception from within the StateChange event, the exception propagates to the caller of the Open or Close method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChanged Event
See Also Example support@devart.com
Devart.Common Namespace > DbConnectionBase Class : TransactionStateChanged Event

Occurs when the state of the transaction is changed.

Syntax

Visual Basic (Declaration)
Public Event TransactionStateChanged As TransactionStateChangedEventHandler
C#
public event TransactionStateChangedEventHandler TransactionStateChanged

Event Data

The event handler receives an argument of type TransactionStateChangedEventArgs containing data related to this event. The following TransactionStateChangedEventArgs properties provide information specific to this event.

Property | Description
Action (Inherited from Devart.Common.TransactionStateChangeEventArgs) | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.

Example

This sample demonstrates how to use the TransactionStateChanged and TransactionStateChanging events.
C#csharp Copy Code
OracleConnection connection = new OracleConnection(
     "User Id=Scott;Password=tiger;Data Source=Ora;");
     connection.TransactionStateChanged += new TransactionStateChangedEventHandler(connection_TransactionStateChanged);
     connection.TransactionStateChanging += new TransactionStateChangingEventHandler(connection_TransactionStateChanging);
     connection.Open();

     // ...
OracleTransaction tr = connection.BeginTransaction();
     // ...
     tr.Commit();
     // ...

void connection_TransactionStateChanging(object sender, TransactionStateChangingEventArgs e) {

        if (e.Action == TransactionAction.Commit) {
                // do somthing...
        }
}

void connection_TransactionStateChanged(object sender, TransactionStateChangedEventArgs e) {

        if (e.Action == TransactionAction.Commit) {
                // do somthing...
        }
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
AddHandler connection.TransactionStateChanged, New TransactionStateChangedEventHandler(AddressOf &_ Me.connection_TransactionStateChanged)
        AddHandler connection.TransactionStateChanging, New TransactionStateChangingEventHandler(AddressOf &_ Me.connection_TransactionStateChanging)
        connection.Open()
        '...
        Dim Transaction As OracleTransaction
        Transaction = connection.BeginTransaction()
        '...
        Transaction.Commit()
        '...

        Private Sub connection_TransactionStateChanged(ByVal sender As Object, ByVal e As TransactionStateChangedEventArgs)
        If (e.Action = TransactionAction.Commit) Then
                '...
        End If
End Sub

Private Sub connection_TransactionStateChanging(ByVal sender As Object, ByVal e As TransactionStateChangingEventArgs)
        If (e.Action = TransactionAction.Commit) Then
                '...
        End If
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionStateChanging Event
See Also support@devart.com
Devart.Common Namespace > DbConnectionBase Class : TransactionStateChanging Event

Occurs when the state of the transaction is changing.

Syntax

Visual Basic (Declaration)
Public Event TransactionStateChanging As TransactionStateChangingEventHandler
C#
public event TransactionStateChangingEventHandler TransactionStateChanging

Event Data

The event handler receives an argument of type TransactionStateChangingEventArgs containing data related to this event. The following TransactionStateChangingEventArgs properties provide information specific to this event.

Property | Description
Action (Inherited from Devart.Common.TransactionStateChangeEventArgs) | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs.

Example

This sample demonstrates how to use the TransactionStateChanged and TransactionStateChanging events.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbConnectionBase Class
DbConnectionBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbMonitorHelper Class
Members See Also support@devart.com
Devart.Common Namespace : DbMonitorHelper Class

Allows to monitor dynamic SQL execution in applications that use .NET data providers.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbMonitor
Devart.Common.DbMonitorHelper
Devart.Data.Oracle.OracleMonitor

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbMonitorHelper
   Inherits DbMonitor
   Implements IComponent, IDisposable
C#
public abstract class DbMonitorHelper : DbMonitor, IComponent, IDisposable

Remarks

Abstract DbMonitorHelper class implements some of Devart.Data.Oracle.OracleMonitor functionality.

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbMonitorHelper Members
Devart.Common Namespace
OracleMonitor Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbMonitorHelper Class Members
See Also Properties Methods Events support@devart.com
Devart.Common Namespace : DbMonitorHelper Class

The following tables list the members exposed by DbMonitorHelper.

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default. (Inherited from Devart.Common.DbMonitor)
public Property | IsActive | Enables or disables monitoring applications. (Inherited from Devart.Common.DbMonitor)
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default. (Inherited from Devart.Common.DbMonitor)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window. (Inherited from Devart.Common.DbMonitor)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when DbMonitor object signals about some database activity. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

DbMonitorHelper Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumn Class
Members Example See Also support@devart.com
Devart.Common Namespace : SelectColumn Class

Represents a column or an expression in SELECT, GROUP BY and ORDER BY clauses of a SQL statement.

Inheritance Hierarchy

System.Object
Devart.Common.SelectStatementNode
Devart.Common.SelectColumn

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SelectColumn
   Inherits SelectStatementNode
C#
public sealed class SelectColumn : SelectStatementNode

Example

This example shows how SelectColumns can be used to create a SelectStatement object representing the following query:

SELECT test.dept.dname Department, test.dept.loc Location
    FROM test.dept
C#csharp Copy Code
OracleSelectStatement statement = new OracleSelectStatement();

// Create columns. Specify their schema, tables to which they belong, their names and aliases.
SelectColumn cName = new SelectColumn("test", "dept", "dname", "Department");
SelectColumn cLoc = new SelectColumn("test", "dept", "loc", "Location");

statement.Columns.Add(cName);
statement.Columns.Add(cLoc);

statement.Tables.Add(new SelectTable("test", "dept", ""));
C#Visual Basic Copy Code
Dim statement As OracleSelectStatement = New OracleSelectStatement()

' Create columns. Specify their schema, tables to which they belong, their names and aliases.
Dim cName = New SelectColumn("test", "dept", "dname", "Department")
Dim cLoc = New SelectColumn("test", "dept", "loc", "Location")

statement.Columns.Add(cName)
statement.Columns.Add(cLoc)

statement.Tables.Add(New SelectTable("test", "dept", ""))

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectColumn Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectColumn Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SelectColumn Class

The following tables list the members exposed by SelectColumn.

Public Constructors

 | Name | Description
public Constructor | SelectColumn Constructor | Overloaded. Creates and initializes new instance of SelectColumn.
Top

Public Properties

 | Name | Description
public Property | Alias | Gets or sets column alias.
public Property | Database | Gets or sets database that the column belongs to.
public Property | Expression | Gets or sets the SQL expression that the column represents.
public Property | Name | Gets or sets name of the column.
public Property | Schema | Gets or sets schema that the column belongs to.
public Property | Table | Gets or sets table or view that the column belongs to.
Top

Public Methods

 | Name | Description
public Method | Equals | Determines whether two SelectColumn objects are identical.
public Method | GetHashCode | Returns hash code of the current instance.
public Method | ToString | Returns the current SelectColumn object in the text form.
Top

See Also

Reference

SelectColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumn Constructor
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : SelectColumn Constructor

Creates and initializes new instance of SelectColumn.

Overload List

Overload | Description
SelectColumn Constructor(String) | Creates and initializes new instance of SelectColumn with the specified column name (expression text).
SelectColumn Constructor(String,String,String,String) | Creates and initializes new instance of SelectColumn with the specified schema name, table name, column name (expression text) and an alias.
SelectColumn Constructor(String,String,String,String,String) | Creates and initializes new instance of SelectColumn with the specified schema name, table name, column name (expression text) and an alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumn Constructor(String)
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class > SelectColumn Constructor : SelectColumn Constructor(String)

name
Creates and initializes new instance of SelectColumn with the specified column name (expression text).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public SelectColumn(
   string name
)

Parameters

name

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumn Constructor(String,String,String,String)
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class > SelectColumn Constructor : SelectColumn Constructor(String,String,String,String)

schema
The schema that the column belongs to.
table
The table or view that the column belongs to.
name
The name of the column or expression text.
alias
The column alias.
Creates and initializes new instance of SelectColumn with the specified schema name, table name, column name (expression text) and an alias.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String _
)
C#
public SelectColumn(
   string schema,
   string table,
   string name,
   string alias
)

Parameters

schema
The schema that the column belongs to.
table
The table or view that the column belongs to.
name
The name of the column or expression text.
alias
The column alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumn Constructor(String,String,String,String,String)
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class > SelectColumn Constructor : SelectColumn Constructor(String,String,String,String,String)

database
The database that the column belongs to.
schema
The schema that the column belongs to.
table
The table or view that the column belongs to.
name
The name of the column or expression text.
alias
The column alias.
Creates and initializes new instance of SelectColumn with the specified schema name, table name, column name (expression text) and an alias.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String _
)
C#
public SelectColumn(
   string database,
   string schema,
   string table,
   string name,
   string alias
)

Parameters

database
The database that the column belongs to.
schema
The schema that the column belongs to.
table
The table or view that the column belongs to.
name
The name of the column or expression text.
alias
The column alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SelectColumn Class Methods
See Also support@devart.com
Devart.Common Namespace : SelectColumn Class

For a list of all members of this type, see SelectColumn members.

Public Methods

 | Name | Description
public Method | Equals | Determines whether two SelectColumn objects are identical.
public Method | GetHashCode | Returns hash code of the current instance.
public Method | ToString | Returns the current SelectColumn object in the text form.
Top

See Also

Reference

SelectColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Equals Method

obj
A SelectColumn object to compare with.
Determines whether two SelectColumn objects are identical.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
A SelectColumn object to compare with.

Return Value

true, if the given obj object equals to the current SelectColumn instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : GetHashCode Method

Returns hash code of the current instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Remarks

Do not use the GetHashCode method. It is for internal purposes only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString() Method
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : ToString() Method

Returns the current SelectColumn object in the text form.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Text representation of the current SelectColumn object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SelectColumn Class Properties
See Also support@devart.com
Devart.Common Namespace : SelectColumn Class

For a list of all members of this type, see SelectColumn members.

Public Properties

 | Name | Description
public Property | Alias | Gets or sets column alias.
public Property | Database | Gets or sets database that the column belongs to.
public Property | Expression | Gets or sets the SQL expression that the column represents.
public Property | Name | Gets or sets name of the column.
public Property | Schema | Gets or sets schema that the column belongs to.
public Property | Table | Gets or sets table or view that the column belongs to.
Top

See Also

Reference

SelectColumn Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Alias Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Alias Property

Gets or sets column alias.

Syntax

Visual Basic (Declaration)
Public Property Alias As String
C#
public string Alias {get; set;}

Property Value

Column alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Database Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Database Property

Gets or sets database that the column belongs to.

Syntax

Visual Basic (Declaration)
Public Property Database As String
C#
public string Database {get; set;}

Property Value

A database that the column belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Expression Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Expression Property

Gets or sets the SQL expression that the column represents.

Syntax

Visual Basic (Declaration)
Public Property Expression As String
C#
public string Expression {get; set;}

Property Value

The SQL expression.

Remarks

If the Expression property is non-empty, the Name property is ignored.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Name Property

Gets or sets name of the column.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Schema Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Schema Property

Gets or sets schema that the column belongs to.

Syntax

Visual Basic (Declaration)
Public Property Schema As String
C#
public string Schema {get; set;}

Property Value

A schema that the column belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Table Property
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : Table Property

Gets or sets table or view that the column belongs to.

Syntax

Visual Basic (Declaration)
Public Property Table As String
C#
public string Table {get; set;}

Property Value

A table or view that the column belongs to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectColumnCollection Class
Members Example See Also support@devart.com
Devart.Common Namespace : SelectColumnCollection Class

Represents a collection of columns and expressions in a SelectStatement object.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.SelectColumnCollection

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SelectColumnCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public sealed class SelectColumnCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

Use SelectColumnCollection class to manage columns used in a query. To access the collection use the SelectStatement.Columns, SelectStatement.GroupBy and SelectStatement.OrderBy properties.

Example

In the following sample we retrieve a collection of SelectColumns from an OracleSelectStatement object and print them. For example, if statement represents the command:

SELECT test.dept.dname Department, test.dept.loc Location
    FROM test.dept

the output of the sample would be the following:

test.dept.dname Department
test.dept.loc Location
C#csharp Copy Code
SelectColumnCollection collection = statement.Columns;

foreach (SelectColumn column in collection)
        Console.WriteLine(column.ToString());
C#Visual Basic Copy Code
Dim collection As SelectColumnCollection = statement.Columns
For Each column In collection
        Console.WriteLine(column.ToString())
Next

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectColumnCollection Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectColumnCollection Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SelectColumnCollection Class

The following tables list the members exposed by SelectColumnCollection.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the SelectColumn at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified SelectColumn to the SelectColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SelectColumn object exists in the collection.
public Method | CopyTo | Copies SelectColumn objects from the SelectColumnCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SelectColumn object.
public Method | Insert | Inserts a SelectColumn into the collection at the specified index.
public Method | Remove | Removes the specified SelectColumn object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SelectColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SelectColumnCollection Class Methods
See Also support@devart.com
Devart.Common Namespace : SelectColumnCollection Class

For a list of all members of this type, see SelectColumnCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified SelectColumn to the SelectColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SelectColumn object exists in the collection.
public Method | CopyTo | Copies SelectColumn objects from the SelectColumnCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SelectColumn object.
public Method | Insert | Inserts a SelectColumn into the collection at the specified index.
public Method | Remove | Removes the specified SelectColumn object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SelectColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : Add Method

Adds the specified SelectColumn to the SelectColumnCollection.

Overload List

Overload | Description
Add(String) | Creates a new SelectColumn object with the name specified and adds it to the collection.
Add(String,Boolean) | Creates a new SelectColumn object with the name specified and adds it to the collection.
Add(String,String,String,String) | Adds a newly created SelectColumn object with the specified schema, table, name, and alias to the collection.
Add(String,String,String,String,Boolean) | Adds a newly created SelectColumn object with the specified schema, table, name, and alias to the collection.
Add(String,String,String,String,String) | Adds a newly created SelectColumn object with the specified database, schema, table, name, and alias to the collection.
Add(String,String,String,String,String,Boolean) | Adds a newly created SelectColumn object with the specified database, schema, table, name, and alias to the collection.
Add(SelectColumn) | Adds the specified SelectColumn to the SelectColumnCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String) Method

name
The name of the column which the SelectColumn object should represent.
Creates a new SelectColumn object with the name specified and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As SelectColumn
C#
public SelectColumn Add(
   string name
)

Parameters

name
The name of the column which the SelectColumn object should represent.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String,Boolean) Method

name
The name of the column that the SelectColumn object should represent.
quote
Specifies whether the column name should be quoted.
Creates a new SelectColumn object with the name specified and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal quote As Boolean _
) As SelectColumn
C#
public SelectColumn Add(
   string name,
   bool quote
)

Parameters

name
The name of the column that the SelectColumn object should represent.
quote
Specifies whether the column name should be quoted.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String,String,String,String) Method

schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.
Adds a newly created SelectColumn object with the specified schema, table, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String _
) As SelectColumn
C#
public SelectColumn Add(
   string schema,
   string table,
   string name,
   string alias
)

Parameters

schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String,String,String,String,Boolean) Method

schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.
quote
Specifies if the column parameters should be quoted.
Adds a newly created SelectColumn object with the specified schema, table, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String, _
   ByVal quote As Boolean _
) As SelectColumn
C#
public SelectColumn Add(
   string schema,
   string table,
   string name,
   string alias,
   bool quote
)

Parameters

schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.
quote
Specifies if the column parameters should be quoted.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String,String) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String,String,String,String,String) Method

database
The database which the table containing this column belongs to.
schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.
Adds a newly created SelectColumn object with the specified database, schema, table, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String _
) As SelectColumn
C#
public SelectColumn Add(
   string database,
   string schema,
   string table,
   string name,
   string alias
)

Parameters

database
The database which the table containing this column belongs to.
schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column that the SelectColumn object should represent.
alias
The alias of the column.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String,String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(String,String,String,String,String,Boolean) Method

database
The database which the table containing this column belongs to.
schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column which the SelectColumn object should represent.
alias
The alias of the column.
quote
Specifies if the column parameters should be quoted.
Adds a newly created SelectColumn object with the specified database, schema, table, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal table As String, _
   ByVal name As String, _
   ByVal alias As String, _
   ByVal quote As Boolean _
) As SelectColumn
C#
public SelectColumn Add(
   string database,
   string schema,
   string table,
   string name,
   string alias,
   bool quote
)

Parameters

database
The database which the table containing this column belongs to.
schema
The schema which the table containing this column belongs to.
table
The name of the table containing the column.
name
The name of the column which the SelectColumn object should represent.
alias
The alias of the column.
quote
Specifies if the column parameters should be quoted.

Return Value

The SelectColumn object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(SelectColumn) Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class > Add Method : Add(SelectColumn) Method

value
The SelectColumn to add to the collection.
Adds the specified SelectColumn to the SelectColumnCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As SelectColumn _
) As Integer
C#
public int Add(
   SelectColumn value
)

Parameters

value
The SelectColumn to add to the collection.

Return Value

Index of the new SelectColumn object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : Contains Method

value
The value of the SelectColumn object to find.
Gets a value indicating whether a SelectColumn object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As SelectColumn _
) As Boolean
C#
public bool Contains(
   SelectColumn value
)

Parameters

value
The value of the SelectColumn object to find.

Return Value

true if the collection contains the SelectColumn; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : CopyTo Method

array
The array into which to copy the SelectColumn objects.
index
The zero-based index of the array.
Copies SelectColumn objects from the SelectColumnCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As SelectColumn, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   SelectColumn[] array,
   int index
)

Parameters

array
The array into which to copy the SelectColumn objects.
index
The zero-based index of the array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : IndexOf Method

value
The SelectColumn object to find.
Gets the location in the collection of the SelectColumn object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As SelectColumn _
) As Integer
C#
public int IndexOf(
   SelectColumn value
)

Parameters

value
The SelectColumn object to find.

Return Value

The zero-based location of the SelectColumn in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : Insert Method

index
The zero-based index where the table is to be inserted within the collection.
value
The SelectColumn to add to the collection.
Inserts a SelectColumn into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As SelectColumn _
)
C#
public void Insert(
   int index,
   SelectColumn value
)

Parameters

index
The zero-based index where the table is to be inserted within the collection.
value
The SelectColumn to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : Remove Method

value
The SelectColumn object to remove from the collection.
Removes the specified SelectColumn object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As SelectColumn _
)
C#
public void Remove(
   SelectColumn value
)

Parameters

value
The SelectColumn object to remove from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SelectColumnCollection Class Properties
See Also support@devart.com
Devart.Common Namespace : SelectColumnCollection Class

For a list of all members of this type, see SelectColumnCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the SelectColumn at the specified index.
Top

See Also

Reference

SelectColumnCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > SelectColumnCollection Class : Item Property

index
The zero-based index of the table.
Gets or sets the SelectColumn at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SelectColumn
C#
public SelectColumn this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the table.

Property Value

The SelectColumn at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumnCollection Class
SelectColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectStatement Class
Members Example See Also support@devart.com
Devart.Common Namespace : SelectStatement Class

Composes, modifies and parses SELECT statements.

Inheritance Hierarchy

System.Object
Devart.Common.SelectStatement
Devart.Data.Oracle.OracleSelectStatement

Syntax

Visual Basic (Declaration)
Public Class SelectStatement
C#
public class SelectStatement

Remarks

The SelectStatement class is designed for easy manipulation of SQL SELECT statements. It allows you to perform the following tasks:

  • Construct SELECT statements in run time;
  • Modify the statements with object-oriented interface;
  • Parse the statements from strings.
The SelectStatement class exposes SELECT, ORDER BY and GROUP BY clauses as collections of SelectColumn objects (SelectColumnCollection), and FROM clause as collection of SelectTable objects (SelectTableCollection). The WHERE and HAVING clauses are represented as string expressions.

To obtain the statement text use the ToString method.

Instances of this class cannot be created directly. To use its functionality, one needs to create an object of a descendant class, like Devart.Data.Oracle.OracleSelectStatement.

Example

This example illustrates how to construct in run time a SelectStatement object the represents the following query:

SELECT Test.td.dname AS Department,td.loc AS Location,te.ename AS Name
FROM Test.dept AS td,emp AS te
GROUP BY te.empno
ORDER BY te.ename
C#csharp Copy Code
SelectStatement stmt = (SelectStatement) new OracleSelectStatement();

stmt.Columns.Add(new SelectColumn("test", "td", "dname", "Department"));
stmt.Columns.Add(new SelectColumn("", "td", "loc", "Location"));
stmt.Columns.Add(new SelectColumn("", "te", "ename", "Name"));

stmt.Tables.Add(new SelectTable("test", "dept", "td"));
stmt.Tables.Add(new SelectTable("", "emp", "te"));

stmt.GroupBy.Add(new SelectColumn("", "te", "empno", ""));

stmt.OrderBy.Add(new SelectColumn("", "te", "ename", ""));
C#Visual Basic Copy Code
Dim stmt As SelectStatement = New OracleSelectStatement()

stmt.Columns.Add(New SelectColumn("test", "td", "dname", "Department"))
stmt.Columns.Add(New SelectColumn("", "td", "loc", "Location"))
stmt.Columns.Add(New SelectColumn("", "te", "ename", "Name"))

stmt.Tables.Add(New SelectTable("test", "dept", "td"))
stmt.Tables.Add(New SelectTable("", "emp", "te"))

stmt.GroupBy.Add(New SelectColumn("", "te", "empno", ""))

stmt.OrderBy.Add(New SelectColumn("", "te", "ename", ""))

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectStatement Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectStatement Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SelectStatement Class

The following tables list the members exposed by SelectStatement.

Public Properties

 | Name | Description
public Property | All | Gets or sets the value, indicating if the all records are selected or only the unique ones.
public Property | Columns | Contains list of columns and expressions used in the select-list of the current SelectStatement object.
public Property | Distinct | Gets or sets whether statement should request unique rows only.
public Property | GroupBy | Contains list of columns used in the GROUP BY clause of the current SelectStatement object.
public Property | Having | Gets or sets HAVING clause of the statement.
public Property | OrderBy | Contains list of columns used in the ORDER BY clause of the current SelectStatement object.
public Property | Tables | Contains list of tables and subqueries used in the FROM clause of the current SelectStatement object.
public Property | Where | Gets or sets WHERE clause of the statement.
Top

Public Methods

 | Name | Description
public Method | AddHavingCondition | Adds new condition to HAVING clause of the statement, represented by the Having property.
public Method | AddWhereCondition | Adds new condition to WHERE clause of the statement, represented by the Where property.
public Method | Clear | Clears all parts of the SelectStatement.
public Method | ToString | Returns SQL statement in the text form.
Top

See Also

Reference

SelectStatement Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SelectStatement Class Methods
See Also support@devart.com
Devart.Common Namespace : SelectStatement Class

For a list of all members of this type, see SelectStatement members.

Public Methods

 | Name | Description
public Method | AddHavingCondition | Adds new condition to HAVING clause of the statement, represented by the Having property.
public Method | AddWhereCondition | Adds new condition to WHERE clause of the statement, represented by the Where property.
public Method | Clear | Clears all parts of the SelectStatement.
public Method | ToString | Returns SQL statement in the text form.
Top

See Also

Reference

SelectStatement Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddHavingCondition Method
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : AddHavingCondition Method

condition
A new condition to add.
Adds new condition to HAVING clause of the statement, represented by the Having property.

Syntax

Visual Basic (Declaration)
Public Sub AddHavingCondition( _
   ByVal condition As String _
)
C#
public void AddHavingCondition(
   string condition
)

Parameters

condition
A new condition to add.

Remarks

If the Having property is not empty, the new condition is concatenated using AND keyword.

Example

The following example demonstrates how to use the AddHavingCondition method.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("EMP"));
stmt.Columns.Add(new SelectColumn("SAL"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.AddHavingCondition("SAL > 1000");

//select JOB,SAL from emp having SAL > 1000
OracleCommand command = new OracleCommand(stmt.ToString());
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("EMP"))
stmt.Columns.Add(New SelectColumn("SAL"))
stmt.Tables.Add(New SelectTable("emp"))
stmt.AddHavingCondition("SAL > 1000")

'select JOB,SAL from emp having SAL > 1000
Dim command As New OracleCommand(stmt.ToString)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddWhereCondition Method
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : AddWhereCondition Method

condition
A new condition to add.
Adds new condition to WHERE clause of the statement, represented by the Where property.

Syntax

Visual Basic (Declaration)
Public Sub AddWhereCondition( _
   ByVal condition As String _
)
C#
public void AddWhereCondition(
   string condition
)

Parameters

condition
A new condition to add.

Remarks

If the Where property is not empty, the new condition is concatenated using AND keyword.

Example

The following example demonstrates how to use the AddWhereCondition method.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("ENAME"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.Where = "1000 < SAL";
stmt.AddWhereCondition("SAL < 1500");
stmt.AddWhereCondition("JOB = 'SALESMAN'");

//select ENAME from emp where ((1000 < SAL) AND SAL < 1500 ) AND JOB = 'SALESMAN'
OracleCommand command = new OracleCommand(stmt.ToString());
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("ENAME"))
stmt.Tables.Add(New SelectTable("emp"))

stmt.Where = "1000 < SAL"
stmt.AddWhereCondition("SAL < 1500")
stmt.AddWhereCondition("JOB = 'SALESMAN'")

'select ENAME from emp where ((1000 < SAL) AND SAL < 1500 ) AND JOB = 'SALESMAN'
Dim command As New OracleCommand(stmt.ToString)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Clear Method

Clears all parts of the SelectStatement.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
C#
public virtual void Clear()

Remarks

Call Clear to empty all properties of the SelectStatement object.

Example

The following example demonstrates how to use the Clear method.
C#csharp Copy Code
private void RefreshStatement(OracleSelectStatement stmt)
{
  stmt.Clear();
  stmt.Columns.Add(new SelectColumn("ENAME"));
  stmt.Columns.Add(new SelectColumn("", "emp", "JOB", "j"));
  stmt.Columns.Add(new SelectColumn("test", "", "emp", "HIREDATE", "hd"));

  stmt.Tables.Add(new SelectTable("emp"));

  //select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  string queryText = stmt.ToString();
}
C#Visual Basic Copy Code
Private Sub RefreshStatement(ByVal stmt As OracleSelectStatement)
  stmt.Clear()
  stmt.Columns.Add(New SelectColumn("ENAME"))
  stmt.Columns.Add(New SelectColumn("", "emp", "JOB", "j"))
  stmt.Columns.Add(New SelectColumn("test", "", "emp", "HIREDATE", "hd"))
  stmt.Tables.Add(New SelectTable("emp"))
  'select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  Dim queryText As String = stmt.ToString
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : ToString Method

Returns SQL statement in the text form.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The text of SQL statement that is equivalent to current state of the SelectStatement object.

Example

The following example demonstrates how to use the ToString method.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("JOB"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.Distinct = true;

//select distinct JOB from emp
string queryText = stmt.ToString();
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("JOB"))
stmt.Tables.Add(New SelectTable("emp"))
stmt.Distinct = True

'select distinct JOB from emp
Dim queryText As String = stmt.ToString

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SelectStatement Class Properties
See Also support@devart.com
Devart.Common Namespace : SelectStatement Class

For a list of all members of this type, see SelectStatement members.

Public Properties

 | Name | Description
public Property | All | Gets or sets the value, indicating if the all records are selected or only the unique ones.
public Property | Columns | Contains list of columns and expressions used in the select-list of the current SelectStatement object.
public Property | Distinct | Gets or sets whether statement should request unique rows only.
public Property | GroupBy | Contains list of columns used in the GROUP BY clause of the current SelectStatement object.
public Property | Having | Gets or sets HAVING clause of the statement.
public Property | OrderBy | Contains list of columns used in the ORDER BY clause of the current SelectStatement object.
public Property | Tables | Contains list of tables and subqueries used in the FROM clause of the current SelectStatement object.
public Property | Where | Gets or sets WHERE clause of the statement.
Top

See Also

Reference

SelectStatement Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
All Property
See Also support@devart.com
Devart.Common Namespace > SelectStatement Class : All Property

Gets or sets the value, indicating if the all records are selected or only the unique ones.

Syntax

Visual Basic (Declaration)
Public Property All As Boolean
C#
public bool All {get; set;}

Property Value

true, if the result set should contain all the rows; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Columns Property

Contains list of columns and expressions used in the select-list of the current SelectStatement object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As SelectColumnCollection
C#
public SelectColumnCollection Columns {get;}

Property Value

A SelectColumnCollection that represents list of columns and expressions used in the SELECT clause.

Example

The following example demonstrates how to use the SelectStatement.Columns property.
C#csharp Copy Code
private void RefreshStatement(OracleSelectStatement stmt)
{
  stmt.Clear();
  stmt.Columns.Add(new SelectColumn("ENAME"));
  stmt.Columns.Add(new SelectColumn("", "emp", "JOB", "j"));
  stmt.Columns.Add(new SelectColumn("test", "", "emp", "HIREDATE", "hd"));

  stmt.Tables.Add(new SelectTable("emp"));

  //select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  string queryText = stmt.ToString();
}
C#Visual Basic Copy Code
Private Sub RefreshStatement(ByVal stmt As OracleSelectStatement)
  stmt.Clear()
  stmt.Columns.Add(New SelectColumn("ENAME"))
  stmt.Columns.Add(New SelectColumn("", "emp", "JOB", "j"))
  stmt.Columns.Add(New SelectColumn("test", "", "emp", "HIREDATE", "hd"))
  stmt.Tables.Add(New SelectTable("emp"))
  'select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  Dim queryText As String = stmt.ToString
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Distinct Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Distinct Property

Gets or sets whether statement should request unique rows only.

Syntax

Visual Basic (Declaration)
Public Property Distinct As Boolean
C#
public bool Distinct {get; set;}

Property Value

true, if the result set should contain unique rows only; otherwise, false.

Example

The following example demonstrates how to use the Distinct property.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("JOB"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.Distinct = true;

//select distinct JOB from emp
string queryText = stmt.ToString();
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("JOB"))
stmt.Tables.Add(New SelectTable("emp"))
stmt.Distinct = True

'select distinct JOB from emp
Dim queryText As String = stmt.ToString

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GroupBy Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : GroupBy Property

Contains list of columns used in the GROUP BY clause of the current SelectStatement object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupBy As SelectColumnCollection
C#
public SelectColumnCollection GroupBy {get;}

Property Value

A SelectColumnCollection that represents list of columns used in the GROUP BY clause.

Example

The following example demonstrates how to use the SelectStatement.GroupBy property.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
SelectColumn jobName = new SelectColumn("JOB");
stmt.Columns.Add(jobName);
stmt.Columns.Add(new SelectColumn("AVG(SAL)"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.GroupBy.Add(jobName);
stmt.Having = "AVG(SAL) > 1000";

//select JOB,AVG(SAL) from emp group by JOB having AVG(SAL) > 1000
OracleCommand command = new OracleCommand(stmt.ToString());

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Having Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Having Property

Gets or sets HAVING clause of the statement.

Syntax

Visual Basic (Declaration)
Public Overridable Property Having As String
C#
public virtual string Having {get; set;}

Property Value

The HAVING clause of the statement.

Remarks

To quickly add new condition to the clause use the AddHavingCondition method.

Example

The following example demonstrates how to use the Having property.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
SelectColumn jobName = new SelectColumn("JOB");
stmt.Columns.Add(jobName);
stmt.Columns.Add(new SelectColumn("AVG(SAL)"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.GroupBy.Add(jobName);
stmt.Having = "AVG(SAL) > 1000";

//select JOB,AVG(SAL) from emp group by JOB having AVG(SAL) > 1000
OracleCommand command = new OracleCommand(stmt.ToString());
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
Dim jobName As New SelectColumn("JOB")
stmt.Columns.Add(jobName)
stmt.Columns.Add(New SelectColumn("AVG(SAL)"))
stmt.Tables.Add(New SelectTable("emp"))

stmt.GroupBy.Add(jobName)
stmt.Having = "AVG(SAL) > 1000"

'select JOB,AVG(SAL) from emp group by JOB having AVG(SAL) > 1000
Dim command As New OracleCommand(stmt.ToString)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OrderBy Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : OrderBy Property

Contains list of columns used in the ORDER BY clause of the current SelectStatement object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OrderBy As SelectColumnCollection
C#
public SelectColumnCollection OrderBy {get;}

Property Value

A SelectColumnCollection that represents list of columns used in the ORDER BY clause.

Example

The following example demonstrates how to use the SelectStatement.OrderBy property.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
SelectColumn empName = new SelectColumn("ENAME");
stmt.Columns.Add(empName);
stmt.Tables.Add(new SelectTable("emp"));

stmt.OrderBy.Add(empName);

//select ENAME from emp order by ENAME
OracleCommand command = new OracleCommand(stmt.ToString());
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
Dim empName As New SelectColumn("ENAME")
stmt.Columns.Add(empName)
stmt.Tables.Add(New SelectTable("emp"))

stmt.OrderBy.Add(empName)

'select ENAME from emp order by ENAME
Dim command5 As New OracleCommand(stmt.ToString)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tables Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Tables Property

Contains list of tables and subqueries used in the FROM clause of the current SelectStatement object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As SelectTableCollection
C#
public SelectTableCollection Tables {get;}

Property Value

A SelectTableCollection that represents list of tables and subqueries used in the FROM clause.

Example

The following example demonstrates how to use the SelectStatement.Tables property.
C#csharp Copy Code
private void RefreshStatement(OracleSelectStatement stmt)
{
  stmt.Clear();
  stmt.Columns.Add(new SelectColumn("ENAME"));
  stmt.Columns.Add(new SelectColumn("", "emp", "JOB", "j"));
  stmt.Columns.Add(new SelectColumn("test", "", "emp", "HIREDATE", "hd"));

  stmt.Tables.Add(new SelectTable("emp"));

  //select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  string queryText = stmt.ToString();
}
C#Visual Basic Copy Code
Private Sub RefreshStatement(ByVal stmt As OracleSelectStatement)
  stmt.Clear()
  stmt.Columns.Add(New SelectColumn("ENAME"))
  stmt.Columns.Add(New SelectColumn("", "emp", "JOB", "j"))
  stmt.Columns.Add(New SelectColumn("test", "", "emp", "HIREDATE", "hd"))
  stmt.Tables.Add(New SelectTable("emp"))
  'select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  Dim queryText As String = stmt.ToString
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Where Property
See Also Example support@devart.com
Devart.Common Namespace > SelectStatement Class : Where Property

Gets or sets WHERE clause of the statement.

Syntax

Visual Basic (Declaration)
Public Overridable Property Where As String
C#
public virtual string Where {get; set;}

Property Value

The WHERE clause of the statement.

Remarks

To quickly add new condition to the clause use the AddWhereCondition method.

Example

The following example demonstrates how to use the Where property.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("ENAME"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.Where = "1000 < SAL AND SAL < 1500 OR JOB = 'SALESMAN'";

OracleCommand command = new OracleCommand(stmt.ToString());
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("ENAME"))
stmt.Tables.Add(New SelectTable("emp"))

stmt.Where = "1000 < SAL AND SAL < 1500 OR JOB = 'SALESMAN'"

Dim command As New OracleCommand(stmt.ToString)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatement Class
SelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectStatementNode Class
Members See Also support@devart.com
Devart.Common Namespace : SelectStatementNode Class

An abstract SQL element.

Inheritance Hierarchy

System.Object
Devart.Common.SelectStatementNode
Devart.Common.SelectColumn
Devart.Common.SelectTable

Syntax

Visual Basic (Declaration)
Public Class SelectStatementNode
C#
public class SelectStatementNode

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectStatementNode Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectStatementNode Class Members
See Also support@devart.com
Devart.Common Namespace : SelectStatementNode Class

The following tables list the members exposed by SelectStatementNode.

Public Constructors

 | Name | Description
public Constructor | SelectStatementNode Constructor | Creates and initializes new instance of SelectStatementNode.
Top

See Also

Reference

SelectStatementNode Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectStatementNode Constructor
See Also support@devart.com
Devart.Common Namespace > SelectStatementNode Class : SelectStatementNode Constructor

Creates and initializes new instance of SelectStatementNode.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SelectStatementNode()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectStatementNode Class
SelectStatementNode Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTable Class
Members Example See Also support@devart.com
Devart.Common Namespace : SelectTable Class

Represents a table or a subquery in the FROM clause of a SELECT statement.

Inheritance Hierarchy

System.Object
Devart.Common.SelectStatementNode
Devart.Common.SelectTable

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SelectTable
   Inherits SelectStatementNode
C#
public sealed class SelectTable : SelectStatementNode

Example

This example shows how SelectTables can be used to create a SelectStatement object representing the following query:

SELECT * FROM test.dept tDept, test.emp tEmp
C#csharp Copy Code
OracleSelectStatement statement = new OracleSelectStatement();

statement.Columns.Add("*");

// Create SelectTables, specify their schemas, names and aliases.
SelectTable dept = new SelectTable("test", "dept", "tDept");
SelectTable emp = new SelectTable("test", "emp", "tEmp");

statement.Tables.Add(dept);
statement.Tables.Add(emp);
C#Visual Basic Copy Code
Dim statement = New OracleSelectStatement()

statement.Columns.Add("*")

' Create SelectTables, specify their schemas, names and aliases.
Dim dept = New SelectTable("test", "dept", "tDept")
Dim emp = New SelectTable("test", "emp", "tEmp")

statement.Tables.Add(dept)
statement.Tables.Add(emp)

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectTable Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectTable Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SelectTable Class

The following tables list the members exposed by SelectTable.

Public Constructors

 | Name | Description
public Constructor | SelectTable Constructor | Overloaded. Creates and initializes new instance of SelectTable.
Top

Public Properties

 | Name | Description
public Property | Alias | Gets or sets table alias.
public Property | Database | Gets or sets the name of the table database.
public Property | JoinClause | Gets or sets a JOIN clause for the SelectTable.
public Property | JoinCondition | Gets or sets a JOIN ON clause for the SelectTable.
public Property | Name | Gets or sets name of the table or subquery text.
public Property | Schema | Gets or sets the name of the table schema.
public Property | SubQuery | Gets the subquery text that the SelectTable represents.
Top

Public Methods

 | Name | Description
public Method | Equals | Determines whether two SelectTable objects are identical.
public Method | GetHashCode | Returns hash code of the current instance.
public Method | ToString | Returns the current SelectTable object in the text form.
Top

See Also

Reference

SelectTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTable Constructor
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : SelectTable Constructor

Creates and initializes new instance of SelectTable.

Overload List

Overload | Description
SelectTable Constructor(String) | Creates and initializes new instance of SelectTable with the specified table name (subquery text).
SelectTable Constructor(String,String,String) | Creates and initializes new instance of SelectTable with the specified schema, table name (subquery text) and alias.
SelectTable Constructor(String,String,String,String) | Creates and initializes new instance of SelectTable with the specified schema, table name (subquery text) and alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTable Constructor(String)
See Also support@devart.com
Devart.Common Namespace > SelectTable Class > SelectTable Constructor : SelectTable Constructor(String)

name
The name of the table or subquery text.
Creates and initializes new instance of SelectTable with the specified table name (subquery text).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public SelectTable(
   string name
)

Parameters

name
The name of the table or subquery text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTable Constructor(String,String,String)
See Also support@devart.com
Devart.Common Namespace > SelectTable Class > SelectTable Constructor : SelectTable Constructor(String,String,String)

schema
The name of the table schema.
name
The name of the table or subquery text.
alias
The alias for the table or expression.
Creates and initializes new instance of SelectTable with the specified schema, table name (subquery text) and alias.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String _
)
C#
public SelectTable(
   string schema,
   string name,
   string alias
)

Parameters

schema
The name of the table schema.
name
The name of the table or subquery text.
alias
The alias for the table or expression.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTable Constructor(String,String,String,String)
See Also support@devart.com
Devart.Common Namespace > SelectTable Class > SelectTable Constructor : SelectTable Constructor(String,String,String,String)

database
The name of the table database.
schema
The name of the table schema.
name
The name of the table or subquery text.
alias
The alias for the table or expression.
Creates and initializes new instance of SelectTable with the specified schema, table name (subquery text) and alias.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String _
)
C#
public SelectTable(
   string database,
   string schema,
   string name,
   string alias
)

Parameters

database
The name of the table database.
schema
The name of the table schema.
name
The name of the table or subquery text.
alias
The alias for the table or expression.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SelectTable Class Methods
See Also support@devart.com
Devart.Common Namespace : SelectTable Class

For a list of all members of this type, see SelectTable members.

Public Methods

 | Name | Description
public Method | Equals | Determines whether two SelectTable objects are identical.
public Method | GetHashCode | Returns hash code of the current instance.
public Method | ToString | Returns the current SelectTable object in the text form.
Top

See Also

Reference

SelectTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : Equals Method

obj
A SelectColumn object to compare with.
Determines whether two SelectTable objects are identical.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
A SelectColumn object to compare with.

Return Value

true, if the given obj object equals to the current SelectTable instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : GetHashCode Method

Returns hash code of the current instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Remarks

Do not use the GetHashCode method. It is for internal purposes only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString() Method
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : ToString() Method

Returns the current SelectTable object in the text form.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Text representation of the current SelectTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SelectTable Class Properties
See Also support@devart.com
Devart.Common Namespace : SelectTable Class

For a list of all members of this type, see SelectTable members.

Public Properties

 | Name | Description
public Property | Alias | Gets or sets table alias.
public Property | Database | Gets or sets the name of the table database.
public Property | JoinClause | Gets or sets a JOIN clause for the SelectTable.
public Property | JoinCondition | Gets or sets a JOIN ON clause for the SelectTable.
public Property | Name | Gets or sets name of the table or subquery text.
public Property | Schema | Gets or sets the name of the table schema.
public Property | SubQuery | Gets the subquery text that the SelectTable represents.
Top

See Also

Reference

SelectTable Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Alias Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : Alias Property

Gets or sets table alias.

Syntax

Visual Basic (Declaration)
Public Property Alias As String
C#
public string Alias {get; set;}

Property Value

Table alias.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Database Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : Database Property

Gets or sets the name of the table database.

Syntax

Visual Basic (Declaration)
Public Property Database As String
C#
public string Database {get; set;}

Property Value

The name of the table database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
JoinClause Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : JoinClause Property

Gets or sets a JOIN clause for the SelectTable.

Syntax

Visual Basic (Declaration)
Public Property JoinClause As String
C#
public string JoinClause {get; set;}

Property Value

The JOIN clause.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
JoinCondition Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : JoinCondition Property

Gets or sets a JOIN ON clause for the SelectTable.

Syntax

Visual Basic (Declaration)
Public Property JoinCondition As String
C#
public string JoinCondition {get; set;}

Property Value

The JOIN ON clause.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : Name Property

Gets or sets name of the table or subquery text.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the table or subquery text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Schema Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : Schema Property

Gets or sets the name of the table schema.

Syntax

Visual Basic (Declaration)
Public Property Schema As String
C#
public string Schema {get; set;}

Property Value

The name of the table schema.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SubQuery Property
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : SubQuery Property

Gets the subquery text that the SelectTable represents.

Syntax

Visual Basic (Declaration)
Public Property SubQuery As String
C#
public string SubQuery {get; set;}

Property Value

The subquery text.

Remarks

If the SubQuery property is non-empty, the Name property is ignored.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectTableCollection Class
Members Example See Also support@devart.com
Devart.Common Namespace : SelectTableCollection Class

Represents a collection of tables and subqueries in a SelectStatement object.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.SelectTableCollection

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SelectTableCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public sealed class SelectTableCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

Use SelectTableCollection class to manage tables used in a query. To access the collection use the SelectStatement.Tables property.

Example

In the following sample we retrieve a collection of SelectTables from an OracleSelectStatement object 'statement' and print them. For example, if statement represents the command

SELECT * FROM test.dept tDept,test.emp tEmp

the output of the sample would be the following:

test.dept tDept
test.emp tEmp
C#csharp Copy Code
SelectTableCollection collection = statement.Tables;
foreach (SelectTable table in collection)
        Console.WriteLine(table.ToString());
C#Visual Basic Copy Code
Dim collection As SelectTableCollection = statement.Tables
For Each table In collection
        Console.WriteLine(table.ToString())
Next

Requirements

Namespace: Devart.Common

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SelectTableCollection Members
Devart.Common Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SelectTableCollection Class Members
See Also Properties Methods support@devart.com
Devart.Common Namespace : SelectTableCollection Class

The following tables list the members exposed by SelectTableCollection.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the SelectTable at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified SelectTable to the SelectTableCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SelectTable object exists in the collection.
public Method | CopyTo | Copies SelectTable objects from the SelectTableCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SelectTable object.
public Method | Insert | Inserts a SelectTable into the collection at the specified index.
public Method | Remove | Removes the specified SelectTable object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SelectTableCollection Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SelectTableCollection Class Methods
See Also support@devart.com
Devart.Common Namespace : SelectTableCollection Class

For a list of all members of this type, see SelectTableCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified SelectTable to the SelectTableCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a SelectTable object exists in the collection.
public Method | CopyTo | Copies SelectTable objects from the SelectTableCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the SelectTable object.
public Method | Insert | Inserts a SelectTable into the collection at the specified index.
public Method | Remove | Removes the specified SelectTable object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

SelectTableCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : Add Method

Adds the specified SelectTable to the SelectTableCollection.

Overload List

Overload | Description
Add(String) | Creates a new SelectTable object with the name specified and adds it to the collection.
Add(String,Boolean) | Creates a new SelectTable object with the name specified and adds it to the collection.
Add(String,String,String) | Adds a newly created SelectTable object with the specified schema, name, and alias to the collection.
Add(String,String,String,Boolean) | Adds a newly created SelectTable object with the specified schema, name, and alias to the collection.
Add(String,String,String,String) | Adds a newly created SelectTable object with the specified database, schema, name, and alias to the collection.
Add(String,String,String,String,Boolean) | Adds a newly created SelectTable object with the specified database, schema, name, and alias to the collection.
Add(SelectTable) | Adds the specified SelectTable to the SelectTableCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String) Method

name
The name of the table that the SelectTable object should represent.
Creates a new SelectTable object with the name specified and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As SelectTable
C#
public SelectTable Add(
   string name
)

Parameters

name
The name of the table that the SelectTable object should represent.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String,Boolean) Method

name
The name of the table that the SelectTable object should represent.
quoted
Specifies whether the table name should be quoted.
Creates a new SelectTable object with the name specified and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal quoted As Boolean _
) As SelectTable
C#
public SelectTable Add(
   string name,
   bool quoted
)

Parameters

name
The name of the table that the SelectTable object should represent.
quoted
Specifies whether the table name should be quoted.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String,String,String) Method

schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
Adds a newly created SelectTable object with the specified schema, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String _
) As SelectTable
C#
public SelectTable Add(
   string schema,
   string name,
   string alias
)

Parameters

schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String,String,String,Boolean) Method

schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
quote
Specifies if the table parameters should be quoted.
Adds a newly created SelectTable object with the specified schema, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String, _
   ByVal quote As Boolean _
) As SelectTable
C#
public SelectTable Add(
   string schema,
   string name,
   string alias,
   bool quote
)

Parameters

schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
quote
Specifies if the table parameters should be quoted.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String,String,String,String) Method

database
The database, which the table belongs to.
schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
Adds a newly created SelectTable object with the specified database, schema, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String _
) As SelectTable
C#
public SelectTable Add(
   string database,
   string schema,
   string name,
   string alias
)

Parameters

database
The database, which the table belongs to.
schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String,String,String,Boolean) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(String,String,String,String,Boolean) Method

database
The database, which the table belongs to.
schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
quote
Specifies if the table parameters should be quoted.
Adds a newly created SelectTable object with the specified database, schema, name, and alias to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal database As String, _
   ByVal schema As String, _
   ByVal name As String, _
   ByVal alias As String, _
   ByVal quote As Boolean _
) As SelectTable
C#
public SelectTable Add(
   string database,
   string schema,
   string name,
   string alias,
   bool quote
)

Parameters

database
The database, which the table belongs to.
schema
The schema, which the table belongs to.
name
The name of the table that the SelectTable object should represent.
alias
The alias of the table.
quote
Specifies if the table parameters should be quoted.

Return Value

The SelectTable object created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(SelectTable) Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class > Add Method : Add(SelectTable) Method

value
The SelectTable to add to the collection.
Adds the specified SelectTable to the SelectTableCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As SelectTable _
) As Integer
C#
public int Add(
   SelectTable value
)

Parameters

value
The SelectTable to add to the collection.

Return Value

Index of the new SelectTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : Contains Method

value
The value of the SelectTable object to find.
Gets a value indicating whether a SelectTable object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As SelectTable _
) As Boolean
C#
public bool Contains(
   SelectTable value
)

Parameters

value
The value of the SelectTable object to find.

Return Value

true if the collection contains the SelectTable; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : CopyTo Method

array
The array into which to copy the SelectTable objects.
index
The zero-based index of the array.
Copies SelectTable objects from the SelectTableCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As SelectTable, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   SelectTable[] array,
   int index
)

Parameters

array
The array into which to copy the SelectTable objects.
index
The zero-based index of the array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : IndexOf Method

value
The SelectTable object to find.
Gets the location in the collection of the SelectTable object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As SelectTable _
) As Integer
C#
public int IndexOf(
   SelectTable value
)

Parameters

value
The SelectTable object to find.

Return Value

The zero-based location of the SelectTable in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : Insert Method

index
The zero-based index where the table is to be inserted within the collection.
value
The SelectTable to add to the collection.
Inserts a SelectTable into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As SelectTable _
)
C#
public void Insert(
   int index,
   SelectTable value
)

Parameters

index
The zero-based index where the table is to be inserted within the collection.
value
The SelectTable to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : Remove Method

value
The SelectTable object to remove from the collection.
Removes the specified SelectTable object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As SelectTable _
)
C#
public void Remove(
   SelectTable value
)

Parameters

value
The SelectTable object to remove from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SelectTableCollection Class Properties
See Also support@devart.com
Devart.Common Namespace : SelectTableCollection Class

For a list of all members of this type, see SelectTableCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the SelectTable at the specified index.
Top

See Also

Reference

SelectTableCollection Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Common Namespace > SelectTableCollection Class : Item Property

index
The zero-based index of the table.
Gets or sets the SelectTable at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As SelectTable
C#
public SelectTable this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the table.

Property Value

The SelectTable at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTableCollection Class
SelectTableCollection Members


%%ItemTitle%%

Devart.Data.Oracle Namespace
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DirectUtils | Use this class to configure the packet size in the Devart.Data.Oracle.OracleConnection.Direct mode.
Class | NativeOracleArray | Represents an Oracle collection (VARRAY).
Class | NativeOracleObject | Represents a Oracle object of type defined by user.
Class | NativeOracleObjectBase | Represents an object of any Oracle object type defined by the user (Object, VARRAY or Nested table).
Class | NativeOracleTable | Represents Oracle Nested table type.
Class | OracleAlert | Represents Oracle alert message.
Class | OracleAlerter | Manages Oracle alerts.
Class | OracleAlerterAlertEventArgs | Provides data for the OracleAlerter.Alert event of the OracleAlerter class.
Class | OracleAlerterErrorEventArgs | Provides data for the OracleAlerter.Error event of the OracleAlerter class.
Class | OracleAlerterFinishEventArgs | Provides data for the OracleAlerter.Stopped event of the OracleAlerter class.
Class | OracleAnyData | Represents Oracle SYS.ANYDATA type.
Class | OracleArray | Represents a client-side cached Oracle collection (VARRAY).
Class | OracleArrayDataReader | Allows to read a forward-only stream of rows from an OracleArray or OracleTable.
Class | OracleAttribute | Represents an attribute of the OracleObject type.
Class | OracleAttributeCollection | Represents attributes of Oracle object type.
Class | OracleBFile | Represents a managed OracleBFile object to work with the Oracle BFILE data type.
Class | OracleClientFactory | Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.
Class | OracleCommand | Represents a SQL statement, PL/SQL statement, or stored procedure to execute against Oracle.
Class | OracleCommandBuilder | Automatically generates single-table commands used to reconcile changes made to a System.Data.DataSet with the Oracle.
Class | OracleConnection | Represents an open connection to Oracle.
Class | OracleConnectionErrorEventArgs | Provides data for the OracleConnection.Error event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleConnectionStringBuilder | Generates automatically connection strings used to connect to Oracle.
Class | OracleCursor | Represents an Oracle REF CURSOR and value of cursor field.
Class | OracleDataAdapter | Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update an Oracle data.
Class | OracleDatabase | This class represents an Oracle Database instance and allows you to start and stop it.
Class | OracleDataReader | Reads a forward-only stream of rows from Oracle.
Class | OracleDataSet | Represents an in-memory cache of data with support for Oracle-specific features.
Class | OracleDataSourceEnumerator | Provides a mechanism for enumerating all known Oracle servers (TNS aliases).
Class | OracleDataTable | Represents a single object that provides all of the functionality needed to retrieve and manipulate data from an Oracle data source.
Class | OracleDependency | Represents a dependency between an application and an Oracle database.
Class | OracleError | Represents an Oracle error returned by the server.
Class | OracleErrorCollection | Collects errors of an exception generated by dotConnect for Oracle. This class cannot be inherited.
Class | OracleException | The exception that is generated when Oracle returns an error.
Class | OracleFailoverEventsArgs | Provides data for the OracleConnection.Failover event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleGlobalization | Manages the Oracle globalization settings of the application, and local computer. Oracle globalization settings of the local computer are read-only.
Class | OracleHAEventArgs | Provides data for the OracleConnection.HAEvent event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleHome | Represents an Oracle home.
Class | OracleHomeCollection | Represents a list of available Oracle homes.
Class | OracleInfoMessageEventArgs | Provides data for the OracleConnection.InfoMessage event.
Class | OracleLoader | Serves to load external data into the Oracle database.
Class | OracleLoaderColumn | Represents the attributes for column loading.
Class | OracleLoaderColumnCollection | Represents a collection of columns relevant to a OracleLoader.
Class | OracleLoaderErrorEventArgs | Provides data for the OracleLoader.Error event of the OracleLoader class.
Class | OracleLoaderRowsCopiedEventArgs | Provides data for the OracleLoader.Error event of the OracleLoader class.
Class | OracleLob | Represents LOB data type stored on an Oracle server.
Class | OracleLogicalTransaction | This class allows you to find out whether the transaction, running during the last database outage, was successfully committed and completed and determine whether your application should commit, complete, or rollback the transaction in order to avoid logical corruption because of committing duplicate transactions.
Class | OracleLogicalTransactionStatus | Indicates the logical status of the transaction.
Class | OracleMetaDataCollectionNames | Enumerates collection names you can use for metadata retrieval purposes.
Class | OracleMonitor | Monitors dynamic SQL execution in applications that use dotConnect for Oracle.
Class | OracleNotificationEventArgs | Provides data for the OracleDependency.OnChange event.
Class | OracleNotificationRequest | Represents a notification request to be subscribed in the database.
Class | OracleNumberMapping | Represents a mapping between .NET and Oracle number types.
Class | OracleNumberMappingCollection | Represents a collection of OracleNumberMapping objects.
Class | OracleObject | Represents a client-side cached Oracle object of type defined by user.
Class | OraclePackage | Provides access to packages stored in the Oracle database.
Class | OracleParameter | Represents a parameter to a OracleCommand, and optionally, its mapping to System.Data.DataSet columns.
Class | OracleParameterCollection | Collects all parameters relevant to a OracleCommand as well as their respective mappings to System.Data.DataSet columns.
Class | OraclePermission | Enables dotConnect for Oracle to ensure that a user has an adequate security level to access an Oracle database. This class cannot be inherited.
Class | OraclePermissionAttribute | Associates a security action with a custom security attribute.
Class | OraclePipe | Represents Oracle pipe.
Class | OraclePipeMessage | Represents elementary piece of data to transfer through Oracle pipe.
Class | OraclePipeMessageCollection | Represents data transferred through Oracle pipe.
Class | OracleProviderException | The exception that is thrown when dotConnect for Oracle returns a provider (non-database) error.
Class | OracleProviderFactory | Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.
Class | OracleQueue | Represents Oracle Streams Advanced Queuing (AQ).
Class | OracleQueueAdmin | Manages Oracle Streams Advanced Queuing (AQ) configuration and administration information.
Class | OracleQueueAgent | Identifies a producer or a consumer of a message.
Class | OracleQueueAgentCollection | Represents a collection of OracleQueueAgent objects.
Class | OracleQueueDequeueOptions | Represents the options available for the dequeue operation.
Class | OracleQueueEnqueueOptions | Represents the options available for the enqueue operation.
Class | OracleQueueMessage | Represents queue messages.
Class | OracleQueueMessageEventArgs | Provides data for the OracleQueue.OnMessage event of the OracleQueue class.
Class | OracleQueueMessageProperties | Describes the information that AQ uses to manage individual messages.
Class | OracleQueueOptions | Queue options that are used upon creation.
Class | OracleQueueTable | Represent queue table for messages of a predefined type.
Class | OracleQueueTableOptions | Queue table properties, that are used for its creation.
Class | OracleRef | Represents a reference to the object (REF).
Class | OracleRowUpdatedEventArgs | Provides data for the OracleDataAdapter.RowUpdated event.
Class | OracleRowUpdatingEventArgs | Provides data for the OracleDataAdapter.RowUpdating event. This class cannot be inherited.
Class | OracleScript | Serves to execute series of SQL statements separated by special symbols, like SQL*Plus scripts.
Class | OracleSelectStatement | Represents a SELECT statement.
Class | OracleSqlStatement | Represents a SQL statement.
Class | OracleSqlStatementCollection | Represents a list of OracleSqlStatement objects.
Class | OracleTable | Represents a client-side cached Oracle Nested table type.
Class | OracleTrace | Controls server side SQL and PL/SQL tracing.
Class | OracleTransaction | Represents a SQL transaction to be made in the Oracle database.
Class | OracleType | Represents any Oracle object type defined by the user such as OracleObject, OracleArray or OracleTable.
Class | OracleXml | Represents an Oracle XMLType instance.
Class | SqlStatementExecuteEventArgs | Provides data for the OracleScript.SqlStatementExecute event of the OracleScript class.

Interfaces

 | Interface | Description
Interface | ICustomOracleArray | Represents an Oracle ARRAY.
Interface | ICustomOracleObject | Represents an Oracle OBJECT.

Structures

 | Structure | Description
Structure | OracleBinary | Represents a variable-length binary data to be stored in or retrieved from a database.
Structure | OracleDate | Represents the Oracle DATE data type.
Structure | OracleIntervalDS | Represents the Oracle INTERVAL DAY TO SECOND data type. Each object of the OracleIntervalDS class stores a period of time in term of days, hours, minutes, seconds, and fractional seconds.
Structure | OracleIntervalYM | Represents the Oracle INTERVAL YEAR TO MONTH data type. Each object of the OracleIntervalYM class stores a period of time in years and months.
Structure | OracleNumber | Represents the Oracle NUMBER or any numeric type.
Structure | OracleQueueMessageId | Represents the system-generated identification of the message.
Structure | OracleString | Represents a variable-length stream of characters to be stored in or retrieved from the database.
Structure | OracleTimeStamp | Represents the Oracle TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME ZONE data types.

Delegates

 | Delegate | Description
Delegate | OnChangeEventHandler | Represents the method that will handle the OracleDependency.OnChange event of an OracleDependency.
Delegate | OracleAlerterAlertEventHandler | Represents the method that will handle the OracleAlerter.Alert event of an OracleAlerter.
Delegate | OracleAlerterErrorEventHandler | Represents the method that will handle the OracleAlerter.Error event of an OracleAlerter.
Delegate | OracleAlerterFinishEventHandler | Represents the method that will handle the OracleAlerter.Stopped event of an OracleAlerter.
Delegate | OracleConnectionErrorEventHandler | Represents the method that will handle the OracleConnection.Error event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleFailoverEventHandler | Represents the method that will handle the OracleConnection.Failover event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleHAEventHandler | Represents the method that will handle the OracleConnection.HAEvent event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleInfoMessageEventHandler | Represents the method that will handle the OracleConnection.InfoMessage event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleLoaderErrorEventHandler | Represents the method that will handle the OracleLoader.Error event of an OracleLoader.
Delegate | OracleLoaderRowsCopiedEventHandler | Represents the method that will handle the OracleLoader.RowsCopied event of an OracleLoader.
Delegate | OracleQueueMessageEventHandler | Represents the method that will handle the OracleQueue.OnMessage event of an OracleQueue.
Delegate | OracleRowUpdatedEventHandler | Represents the method that will handle the OracleDataAdapter.RowUpdated event of an OracleDataAdapter.
Delegate | OracleRowUpdatingEventHandler | Represents the method that will handle the OracleDataAdapter.RowUpdating event of an OracleDataAdapter.
Delegate | SqlStatementExecuteEventHandler | Represents the method that will handle the OracleScript.SqlStatementExecute event of an OracleScript.

Enumerations

 | Enumeration | Description
Enumeration | DirectUtils.SecurityLevel | Determines the configuration of Oracle Advanced Security data encryption and data integrity for the Direct mode.
Enumeration | OracleConnectMode | Holds fields which allow to open a session with specified privileges.
Enumeration | OracleDbType | Specifies the data type of a field, property, Devart.Data.Oracle.OracleParameter or OracleAttribute.
Enumeration | OracleFailoverState | Represents Transparent Application Failover state.
Enumeration | OracleFailoverType | Represents Transparent Application Failover type.
Enumeration | OracleHAEventSource | Indicates the source of a HA event.
Enumeration | OracleHAEventStatus | Indicates the status of the HA event source.
Enumeration | OracleIdentityType | Specifies how Oracle identity column values are generated.
Enumeration | OracleLoaderOptions | Allows configuring behavior of the OracleLoader class.
Enumeration | OracleLobOpenMode | Specifies whether an OracleLob should be opened in read-only or read/write mode.
Enumeration | OracleNotificationInfo | Specifies the operation, for which a notification is received from Oracle server.
Enumeration | OracleNotificationType | Specifies the type of notification received from Oracle server.
Enumeration | OracleNumberType | Enumerates main Oracle number types.
Enumeration | OracleObjectType | Describes Oracle object type for the OracleError class. Object type is a logical structure of data stored in a database. A brief definitions of corresponding Oracle structures are given below.
Enumeration | OraclePdbOpenMode | Specifies the open mode for starting a PDB Oracle instance with the OracleDatabase.Startup method of the OracleDatabase class (for Oracle 12c and higher).
Enumeration | OracleQueryBasedNotificationMode | Specifies the mode for query-based notifications.
Enumeration | OracleQueueCompatible | Specifies the lowest database version with which the queue is compatible.
Enumeration | OracleQueueDeliveryMode | Specifies whether the message is persistent or buffered. If buffered, it will be lost after the application's shutdown. Persistent messages are stored in the database table.
Enumeration | OracleQueueDequeueMode | Specifies how the messages will be dequeued.
Enumeration | OracleQueueMessageGrouping | Specifies the message grouping behaviour.
Enumeration | OracleQueueMessageState | Specifies the state of the message.
Enumeration | OracleQueueNavigation | Specifies which message will be dequeued next.
Enumeration | OracleQueuePrivilege | The privilege to enqueue or dequeue messages on the queue.
Enumeration | OracleQueueSequenceDeviation | Specifies whether the message being enqueued should be dequeued before other messages already in the queue.
Enumeration | OracleQueueSortOrder | Specifies which parameters are used to order messages in the queue. The order is ascending.
Enumeration | OracleQueueSystemPrivilege | The AQ administration privilige granted to or revoked from a user or role.
Enumeration | OracleQueueType | Specifies whether the queue is normal, service or nonpersistent with RAW message payload.
Enumeration | OracleQueueVisibility | Specifies the visibility options for an enqueue operation.
Enumeration | OracleServerType | Specifies whether the connection is established to an Oracle database or to TimesTen database.
Enumeration | OracleShutdownMode | Specifies the shutdown mode for the OracleDatabase.Shutdown method that shuts down an Oracle Database instance.
Enumeration | OracleStartupMode | Specifies the database startup mode.
Enumeration | PlSqlTraceMode | Defines the level of PL/SQL trace for the OracleTrace component.
Enumeration | ReadLobMode | Determines how LOB data is fetched and represented.
Enumeration | SqlPlusStatementType | Describes type of SQL*Plus command. Unless the corresponding SQL*Plus command name is explicitly specified, it coincides with the enumeration member's title. The functionality of corresponding commands in SQL*Plus is given below.
Enumeration | SqlTraceMode | Defines the level of SQL trace for the OracleTrace component.
Enumeration | TraceState | Specifies type of the trace mode in the OracleTrace component.

See Also

Reference

Devart.Data.Oracle Assembly


%%ItemTitle%% - Classes

Devart.Data.Oracle Namespace - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DirectUtils | Use this class to configure the packet size in the Devart.Data.Oracle.OracleConnection.Direct mode.
Class | NativeOracleArray | Represents an Oracle collection (VARRAY).
Class | NativeOracleObject | Represents a Oracle object of type defined by user.
Class | NativeOracleObjectBase | Represents an object of any Oracle object type defined by the user (Object, VARRAY or Nested table).
Class | NativeOracleTable | Represents Oracle Nested table type.
Class | OracleAlert | Represents Oracle alert message.
Class | OracleAlerter | Manages Oracle alerts.
Class | OracleAlerterAlertEventArgs | Provides data for the OracleAlerter.Alert event of the OracleAlerter class.
Class | OracleAlerterErrorEventArgs | Provides data for the OracleAlerter.Error event of the OracleAlerter class.
Class | OracleAlerterFinishEventArgs | Provides data for the OracleAlerter.Stopped event of the OracleAlerter class.
Class | OracleAnyData | Represents Oracle SYS.ANYDATA type.
Class | OracleArray | Represents a client-side cached Oracle collection (VARRAY).
Class | OracleArrayDataReader | Allows to read a forward-only stream of rows from an OracleArray or OracleTable.
Class | OracleAttribute | Represents an attribute of the OracleObject type.
Class | OracleAttributeCollection | Represents attributes of Oracle object type.
Class | OracleBFile | Represents a managed OracleBFile object to work with the Oracle BFILE data type.
Class | OracleClientFactory | Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.
Class | OracleCommand | Represents a SQL statement, PL/SQL statement, or stored procedure to execute against Oracle.
Class | OracleCommandBuilder | Automatically generates single-table commands used to reconcile changes made to a System.Data.DataSet with the Oracle.
Class | OracleConnection | Represents an open connection to Oracle.
Class | OracleConnectionErrorEventArgs | Provides data for the OracleConnection.Error event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleConnectionStringBuilder | Generates automatically connection strings used to connect to Oracle.
Class | OracleCursor | Represents an Oracle REF CURSOR and value of cursor field.
Class | OracleDataAdapter | Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update an Oracle data.
Class | OracleDatabase | This class represents an Oracle Database instance and allows you to start and stop it.
Class | OracleDataReader | Reads a forward-only stream of rows from Oracle.
Class | OracleDataSet | Represents an in-memory cache of data with support for Oracle-specific features.
Class | OracleDataSourceEnumerator | Provides a mechanism for enumerating all known Oracle servers (TNS aliases).
Class | OracleDataTable | Represents a single object that provides all of the functionality needed to retrieve and manipulate data from an Oracle data source.
Class | OracleDependency | Represents a dependency between an application and an Oracle database.
Class | OracleError | Represents an Oracle error returned by the server.
Class | OracleErrorCollection | Collects errors of an exception generated by dotConnect for Oracle. This class cannot be inherited.
Class | OracleException | The exception that is generated when Oracle returns an error.
Class | OracleFailoverEventsArgs | Provides data for the OracleConnection.Failover event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleGlobalization | Manages the Oracle globalization settings of the application, and local computer. Oracle globalization settings of the local computer are read-only.
Class | OracleHAEventArgs | Provides data for the OracleConnection.HAEvent event of the Devart.Data.Oracle.OracleConnection class.
Class | OracleHome | Represents an Oracle home.
Class | OracleHomeCollection | Represents a list of available Oracle homes.
Class | OracleInfoMessageEventArgs | Provides data for the OracleConnection.InfoMessage event.
Class | OracleLoader | Serves to load external data into the Oracle database.
Class | OracleLoaderColumn | Represents the attributes for column loading.
Class | OracleLoaderColumnCollection | Represents a collection of columns relevant to a OracleLoader.
Class | OracleLoaderErrorEventArgs | Provides data for the OracleLoader.Error event of the OracleLoader class.
Class | OracleLoaderRowsCopiedEventArgs | Provides data for the OracleLoader.Error event of the OracleLoader class.
Class | OracleLob | Represents LOB data type stored on an Oracle server.
Class | OracleLogicalTransaction | This class allows you to find out whether the transaction, running during the last database outage, was successfully committed and completed and determine whether your application should commit, complete, or rollback the transaction in order to avoid logical corruption because of committing duplicate transactions.
Class | OracleLogicalTransactionStatus | Indicates the logical status of the transaction.
Class | OracleMetaDataCollectionNames | Enumerates collection names you can use for metadata retrieval purposes.
Class | OracleMonitor | Monitors dynamic SQL execution in applications that use dotConnect for Oracle.
Class | OracleNotificationEventArgs | Provides data for the OracleDependency.OnChange event.
Class | OracleNotificationRequest | Represents a notification request to be subscribed in the database.
Class | OracleNumberMapping | Represents a mapping between .NET and Oracle number types.
Class | OracleNumberMappingCollection | Represents a collection of OracleNumberMapping objects.
Class | OracleObject | Represents a client-side cached Oracle object of type defined by user.
Class | OraclePackage | Provides access to packages stored in the Oracle database.
Class | OracleParameter | Represents a parameter to a OracleCommand, and optionally, its mapping to System.Data.DataSet columns.
Class | OracleParameterCollection | Collects all parameters relevant to a OracleCommand as well as their respective mappings to System.Data.DataSet columns.
Class | OraclePermission | Enables dotConnect for Oracle to ensure that a user has an adequate security level to access an Oracle database. This class cannot be inherited.
Class | OraclePermissionAttribute | Associates a security action with a custom security attribute.
Class | OraclePipe | Represents Oracle pipe.
Class | OraclePipeMessage | Represents elementary piece of data to transfer through Oracle pipe.
Class | OraclePipeMessageCollection | Represents data transferred through Oracle pipe.
Class | OracleProviderException | The exception that is thrown when dotConnect for Oracle returns a provider (non-database) error.
Class | OracleProviderFactory | Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.
Class | OracleQueue | Represents Oracle Streams Advanced Queuing (AQ).
Class | OracleQueueAdmin | Manages Oracle Streams Advanced Queuing (AQ) configuration and administration information.
Class | OracleQueueAgent | Identifies a producer or a consumer of a message.
Class | OracleQueueAgentCollection | Represents a collection of OracleQueueAgent objects.
Class | OracleQueueDequeueOptions | Represents the options available for the dequeue operation.
Class | OracleQueueEnqueueOptions | Represents the options available for the enqueue operation.
Class | OracleQueueMessage | Represents queue messages.
Class | OracleQueueMessageEventArgs | Provides data for the OracleQueue.OnMessage event of the OracleQueue class.
Class | OracleQueueMessageProperties | Describes the information that AQ uses to manage individual messages.
Class | OracleQueueOptions | Queue options that are used upon creation.
Class | OracleQueueTable | Represent queue table for messages of a predefined type.
Class | OracleQueueTableOptions | Queue table properties, that are used for its creation.
Class | OracleRef | Represents a reference to the object (REF).
Class | OracleRowUpdatedEventArgs | Provides data for the OracleDataAdapter.RowUpdated event.
Class | OracleRowUpdatingEventArgs | Provides data for the OracleDataAdapter.RowUpdating event. This class cannot be inherited.
Class | OracleScript | Serves to execute series of SQL statements separated by special symbols, like SQL*Plus scripts.
Class | OracleSelectStatement | Represents a SELECT statement.
Class | OracleSqlStatement | Represents a SQL statement.
Class | OracleSqlStatementCollection | Represents a list of OracleSqlStatement objects.
Class | OracleTable | Represents a client-side cached Oracle Nested table type.
Class | OracleTrace | Controls server side SQL and PL/SQL tracing.
Class | OracleTransaction | Represents a SQL transaction to be made in the Oracle database.
Class | OracleType | Represents any Oracle object type defined by the user such as OracleObject, OracleArray or OracleTable.
Class | OracleXml | Represents an Oracle XMLType instance.
Class | SqlStatementExecuteEventArgs | Provides data for the OracleScript.SqlStatementExecute event of the OracleScript class.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DirectUtils Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : DirectUtils Class

Use this class to configure the packet size in the Devart.Data.Oracle.OracleConnection.Direct mode.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.DirectUtils

Syntax

Visual Basic (Declaration)
Public MustInherit NotInheritable Class DirectUtils
C#
public static class DirectUtils

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DirectUtils Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DirectUtils Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : DirectUtils Class

The following tables list the members exposed by DirectUtils.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AdvancedSecurity |
static (Shared in Visual Basic) | DataIntegrityLevel | Determines whether to use Oracle Advanced Security data integrity in the Devart.Data.Oracle.OracleConnection.Direct mode.
static (Shared in Visual Basic) | EncryptionLevel | Determines whether to use Oracle Advanced Security data encryption in the Devart.Data.Oracle.OracleConnection.Direct mode.
static (Shared in Visual Basic) | OldAuthMode | Allows switching the algorithm for password encryption.
static (Shared in Visual Basic) | PacketSize | Allows controlling the packet size only in the Direct mode.
Top

See Also

Reference

DirectUtils Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DirectUtils Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : DirectUtils Class

For a list of all members of this type, see DirectUtils members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AdvancedSecurity |
static (Shared in Visual Basic) | DataIntegrityLevel | Determines whether to use Oracle Advanced Security data integrity in the Devart.Data.Oracle.OracleConnection.Direct mode.
static (Shared in Visual Basic) | EncryptionLevel | Determines whether to use Oracle Advanced Security data encryption in the Devart.Data.Oracle.OracleConnection.Direct mode.
static (Shared in Visual Basic) | OldAuthMode | Allows switching the algorithm for password encryption.
static (Shared in Visual Basic) | PacketSize | Allows controlling the packet size only in the Direct mode.
Top

See Also

Reference

DirectUtils Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AdvancedSecurity Property
See Also support@devart.com
Devart.Data.Oracle Namespace > DirectUtils Class : AdvancedSecurity Property

Syntax

Visual Basic (Declaration)
Public Shared Property AdvancedSecurity As Boolean
C#
public static bool AdvancedSecurity {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DirectUtils Class
DirectUtils Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataIntegrityLevel Property
See Also support@devart.com
Devart.Data.Oracle Namespace > DirectUtils Class : DataIntegrityLevel Property

Determines whether to use Oracle Advanced Security data integrity in the OracleConnection.Direct mode.

Syntax

Visual Basic (Declaration)
Public Shared Property DataIntegrityLevel As DirectUtils.SecurityLevel
C#
public static DirectUtils.SecurityLevel DataIntegrityLevel {get; set;}

Property Value

One of the DirectUtils.SecurityLevel values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DirectUtils Class
DirectUtils Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EncryptionLevel Property
See Also support@devart.com
Devart.Data.Oracle Namespace > DirectUtils Class : EncryptionLevel Property

Determines whether to use Oracle Advanced Security data encryption in the OracleConnection.Direct mode.

Syntax

Visual Basic (Declaration)
Public Shared Property EncryptionLevel As DirectUtils.SecurityLevel
C#
public static DirectUtils.SecurityLevel EncryptionLevel {get; set;}

Property Value

One of the DirectUtils.SecurityLevel values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DirectUtils Class
DirectUtils Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OldAuthMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > DirectUtils Class : OldAuthMode Property

Allows switching the algorithm for password encryption.

Syntax

Visual Basic (Declaration)
Public Shared Property OldAuthMode As Boolean
C#
public static bool OldAuthMode {get; set;}

Property Value

true if the algorithm of Oracle 7 and 8 is used for password encryption; false if the algorithm corresponds to the actual server version is used for password encryption.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DirectUtils Class
DirectUtils Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PacketSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > DirectUtils Class : PacketSize Property

Allows controlling the packet size only in the Direct mode.

Syntax

Visual Basic (Declaration)
Public Shared Property PacketSize As Integer
C#
public static int PacketSize {get; set;}

Property Value

The size of packets in OracleConnection.Direct mode in bytes.

Remarks

The range of acceptable values is 800 - 32768.

We cannot guarantee that the packet size will be exactly the same as it was set in the OCI mode, because data transfer is controlled by Oracle Client in this case.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DirectUtils Class
DirectUtils Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleArray Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleArray Class

Represents an Oracle collection (VARRAY).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.NativeOracleObjectBase
Devart.Data.Oracle.NativeOracleArray
Devart.Data.Oracle.NativeOracleTable

Syntax

Visual Basic (Declaration)
Public Class NativeOracleArray
   Inherits NativeOracleObjectBase
   Implements ICollection, IEnumerable, IList, IDisposable
C#
public class NativeOracleArray : NativeOracleObjectBase, ICollection, IEnumerable, IList, IDisposable

Remarks

The NativeOracleArray class provides methods to access elements of the collection. Items values are accessible by Item indexed property.

This class represents OCI arrays, and is intended for use in connected data access model.

The array elements can be added to the collection dynamically by calling Add, Insert methods or removed by calling Remove or RemoveAt but the maximum number of the elements cannot exceed P:Devart.Data.Oracle.NativeOracleArray.Capacity specified at Oracle declaration of the VARRAY.

Indexes in this collection are zero-based.

Note that NativeOracleArray can be used in data binding with DataGrid as it implements IListSource interface.

This class is not available in Devart.Data.Oracle.OracleConnection.Direct mode.

Example

This example demonstrates how to retrieve a NativeOracleArray object from the server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE OR REPLACE TYPE TEmployees AS
  VARYING ARRAY(10000) OF VARCHAR2(40);

CREATE TABLE CompanyEmpObject (
  Code NUMBER PRIMARY KEY,
  Company VARCHAR2(40),
  Employees TEmployees
);
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (1, 'Microsoft', TEmployees('PROGRAMMER', 'MANAGER', 'ELECTRICIAN', 'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (2, 'Borland', TEmployees('PROGRAMMER', 'ELECTRICIAN', 'COURIER'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (3, 'MC Donalds', TEmployees('SHOP ASSISTANT', 'CLERK',  'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (4, 'Ford', TEmployees('MECHANICIAN', 'MANAGER'));
C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM CompanyEmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
        int index = dataReader.GetOrdinal("Employees");
        while (dataReader.Read()) {
                NativeOracleArray oraArray = dataReader.GetNativeOracleArray(index);
                if (!oraArray.IsNull) {
                        string[] employees = new string[oraArray.Count];
                        for (int i = 0; i < oraArray.Count; i++)
                                employees[i] = (string)oraArray[i];

                        Console.WriteLine("Company: " + dataReader.GetString(1));
                        foreach (string str in employees)
                                Console.WriteLine("\t"+str);
                }
                else{
                        Console.WriteLine("Company: " + dataReader.GetString(1));
                        Console.WriteLine("No vacancies");
                }
        }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM CompanyEmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
        Dim index As Integer = dataReader.GetOrdinal("Employees")
          While dataReader.Read()
                Dim oraArray As NativeOracleArray = dataReader.GetNativeOracleArray(index)
            If Not oraArray.IsNull Then
                        Dim employees(oraArray.Count) As String
                        Dim I As Integer
                        For I = 0 To oraArray.Count - 1
                                employees(I) = oraArray(I)
                      Next I
                      Console.WriteLine("Company: " & dataReader.GetString(1))
                        For Each str As String In employees
                        Console.WriteLine(Chr(9) & str)
                      Next
            Else
                      Console.WriteLine("Company: " & dataReader.GetString(1))
                      Console.WriteLine("No vacancies")
            End If
          End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

NativeOracleArray Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
NativeOracleArray Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : NativeOracleArray Class

The following tables list the members exposed by NativeOracleArray.

Public Constructors

 | Name | Description
public Constructor | NativeOracleArray Constructor | Overloaded. Initializes a new instance of the NativeOracleArray class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Count | Gets the number of elements contained in the NativeOracleArray.
public Property | IsFixedSize | Gets a value indicating whether the NativeOracleArray has a fixed size.
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsReadOnly | Gets a value indicating whether the NativeOracleArray is read-only.
public Property | IsSynchronized | Gets a value indicating whether access to the NativeOracleArray is synchronized (thread-safe).
public Property | Item | Gets or sets the element at the specified index.
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the NativeOracleArray.
public Property | Value | Gets the value of the NativeOracleArray as .NET Framework array of the elements of the same type.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the NativeOracleArray.
public Method | Clear | Removes all elements from the NativeOracleArray.
public Method | Contains | Determines whether an element is in the NativeOracleArray.
public Method | CopyTo | Copies the entire NativeOracleArray to a compatible System.Array starting at the specified index.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetEnumerator | Returns an enumerator for the NativeOracleArray.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format.
public Method | IndexOf | Gets the location in the collection of the NativeOracleArray object.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an NativeOracleArray into the collection at the specified index.
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Remove | Removes the specified element from the NativeOracleArray.
public Method | RemoveAt | Removes the element at the specified index from the NativeOracleArray.
Top

See Also

Reference

NativeOracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleArray Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : NativeOracleArray Constructor

Initializes a new instance of the NativeOracleArray class.

Overload List

Overload | Description
NativeOracleArray Constructor(String,OracleConnection) | Initializes a new instance of the NativeOracleArray class of the specified type with the specified OracleConnection.
NativeOracleArray Constructor(OracleType,OracleConnection) | Initializes a new instance of the NativeOracleArray class of the specified type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleArray Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class > NativeOracleArray Constructor : NativeOracleArray Constructor(String,OracleConnection)

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.
Initializes a new instance of the NativeOracleArray class of the specified type with the specified OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleArray(
   string typeName,
   OracleConnection connection
)

Parameters

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.

Remarks

Use this constructor to create an NativeOracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleArray Constructor(OracleType,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class > NativeOracleArray Constructor : NativeOracleArray Constructor(OracleType,OracleConnection)

objectType
connection
An OracleConnection used to describe object type at the Oracle server.
Initializes a new instance of the NativeOracleArray class of the specified type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectType As OracleType, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleArray(
   OracleType objectType,
   OracleConnection connection
)

Parameters

objectType
connection
An OracleConnection used to describe object type at the Oracle server.

Remarks

Use this constructor to create an NativeOracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
NativeOracleArray Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleArray Class

For a list of all members of this type, see NativeOracleArray members.

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the NativeOracleArray.
public Method | Clear | Removes all elements from the NativeOracleArray.
public Method | Contains | Determines whether an element is in the NativeOracleArray.
public Method | CopyTo | Copies the entire NativeOracleArray to a compatible System.Array starting at the specified index.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetEnumerator | Returns an enumerator for the NativeOracleArray.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format.
public Method | IndexOf | Gets the location in the collection of the NativeOracleArray object.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an NativeOracleArray into the collection at the specified index.
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Remove | Removes the specified element from the NativeOracleArray.
public Method | RemoveAt | Removes the element at the specified index from the NativeOracleArray.
Top

See Also

Reference

NativeOracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Add Method

value
The System.Object to be added to the end of the NativeOracleArray.
Adds an object of specified OracleType.ItemDbType type to the end of the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Object _
) As Integer
C#
public int Add(
   object value
)

Parameters

value
The System.Object to be added to the end of the NativeOracleArray.

Return Value

The NativeOracleArray index at which the value has been added.

Remarks

If value of Count property equals to P:Devart.Data.Oracle.NativeOracleArray.Capacity the Add method raises an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Clear Method

Removes all elements from the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Contains Method

value
An System.Object to locate in the NativeOracleArray.
Determines whether an element is in the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
An System.Object to locate in the NativeOracleArray.

Return Value

true if an item is found in the NativeOracleArray; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : CopyTo Method

array
The System.Array where to copy elements from NativeOracleArray.
index
The zero-based starting index.
Copies the entire NativeOracleArray to a compatible System.Array starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The System.Array where to copy elements from NativeOracleArray.
index
The zero-based starting index.

Remarks

The specified array must be of a compatible type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : GetEnumerator Method

Returns an enumerator for the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
C#
public IEnumerator GetEnumerator()

Return Value

An enumerator for the NativeOracleArray.

Remarks

Enumerators allow only reading the data in the collection and cannot be used to modify it.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : GetOracleValue Method

i
The zero-based element ordinal.
Gets the value of the array element at the specified ordinal in its Oracle format.

Syntax

Visual Basic (Declaration)
Public Function GetOracleValue( _
   ByVal i As Integer _
) As Object
C#
public object GetOracleValue(
   int i
)

Parameters

i
The zero-based element ordinal.

Return Value

The value of the array element.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : IndexOf Method

value
The NativeOracleArray object to find.
Gets the location in the collection of the NativeOracleArray object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value
The NativeOracleArray object to find.

Return Value

The zero-based location of the NativeOracleArray in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Insert Method

index
The zero-based index where the NativeOracleArray is to be inserted within the collection.
value
The NativeOracleArray object to add to the collection.
Inserts an NativeOracleArray into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index where the NativeOracleArray is to be inserted within the collection.
value
The NativeOracleArray object to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Remove Method

value
The System.Object to remove from the NativeOracleArray.
Removes the specified element from the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
C#
public void Remove(
   object value
)

Parameters

value
The System.Object to remove from the NativeOracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : RemoveAt Method

index
Removes the element at the specified index from the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
NativeOracleArray Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleArray Class

For a list of all members of this type, see NativeOracleArray members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Count | Gets the number of elements contained in the NativeOracleArray.
public Property | IsFixedSize | Gets a value indicating whether the NativeOracleArray has a fixed size.
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsReadOnly | Gets a value indicating whether the NativeOracleArray is read-only.
public Property | IsSynchronized | Gets a value indicating whether access to the NativeOracleArray is synchronized (thread-safe).
public Property | Item | Gets or sets the element at the specified index.
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the NativeOracleArray.
public Property | Value | Gets the value of the NativeOracleArray as .NET Framework array of the elements of the same type.
Top

See Also

Reference

NativeOracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Count Property

Gets the number of elements contained in the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the NativeOracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsFixedSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : IsFixedSize Property

Gets a value indicating whether the NativeOracleArray has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

true if the NativeOracleArray has a fixed size; otherwise, false.

Remarks

A collection with a fixed size does not allow to add or remove elements after the collection is created, but it allows to modify already existing elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsReadOnly Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : IsReadOnly Property

Gets a value indicating whether the NativeOracleArray is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if the NativeOracleArray is read-only; otherwise, false.

Remarks

A collection that is read-only does not allow the add, remove, or modify elements after the collection is created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsSynchronized Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : IsSynchronized Property

Gets a value indicating whether access to the NativeOracleArray is synchronized (thread-safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

true if access to the NativeOracleArray is synchronized (thread-safe); otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Item Property

index
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Shadows Default Property Item( _
   ByVal index As Integer _
) As Object
C#
public new object this(
   int index
) {get; set;}

Parameters

index

Property Value

The element at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncRoot Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : SyncRoot Property

Gets an object that can be used to synchronize access to the NativeOracleArray.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

An System.Object that can be used to synchronize access to the NativeOracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleArray Class : Value Property

Gets the value of the NativeOracleArray as .NET Framework array of the elements of the same type.

Syntax

Visual Basic (Declaration)
Public Property Value As Array
C#
public Array Value {get; set;}

Property Value

An System.Array with NativeOracleArray data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleArray Class
NativeOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleObject Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObject Class

Represents a Oracle object of type defined by user.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.NativeOracleObjectBase
Devart.Data.Oracle.NativeOracleObject

Syntax

Visual Basic (Declaration)
Public Class NativeOracleObject
   Inherits NativeOracleObjectBase
   Implements IDisposable
C#
public class NativeOracleObject : NativeOracleObjectBase, IDisposable

Remarks

This class is a wrapper around OCI objects, and is intended for use in connected data access model. To retrieve values of object attributes the NativeOracleObject class uses Item indexed property.

You can create an instance of NativeOracleObject by one of the following ways:

- execute a query that returns an object as one of the fields calling OracleDataReader.GetNativeOracleObject method;

- return an NativeOracleObject instance as a parameter value of OracleDbType.Object type;

- get object reference (OracleRef), call OracleRef.Pin method and get NativeOracleObject by calling OracleRef.GetObject method;

- get the NativeOracleObject as a value of owned NativeOracleObject attribute.

Also you can create an instance of NativeOracleObject manually.

You can use NativeOracleObject to pass object as a parameter value and post updated data to the server using NativeOracleObjectBase.Flush method for the pinned object received by OracleRef.

Note that NativeOracleObject can be used in data binding with DataGrid as it implements IListSource interface.

This class is not available in Devart.Data.Oracle.OracleConnection.Direct mode.

Example

This example demonstrates how to retrieve a NativeOracleObject instance from the server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');
C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
        int index = dataReader.GetOrdinal("Address");
        while (dataReader.Read()) {
                NativeOracleObject oraObj = dataReader.GetNativeOracleObject(index);
                if (!oraObj.IsNull) {
                        string country = (string)oraObj["Country"];
                        string city = (string)oraObj["City"];
                        string street = (string)oraObj["Street"];
                        decimal Apartment = (decimal)oraObj["Apartment"];
                        Console.WriteLine(dataReader.GetString(0) + "   " + dataReader.GetString(1) + "   " + "Adress: " + country + ", " + city + ", " + street + ", "+ Apartment.ToString() + "   " + dataReader.GetString(3));
                }
        }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
        Dim index As Integer = dataReader.GetOrdinal("Address")
          While dataReader.Read()
                Dim oraObj As NativeOracleObject = dataReader.GetNativeOracleObject(index)
            If Not oraObj.IsNull Then
                        Dim country As String = oraObj("Country")
                        Dim city As String = oraObj("City")
                        Dim street As String = oraObj("Street")
                        Dim Apartment As Decimal = oraObj("Apartment")
                      Console.WriteLine(dataReader.GetString(0) & " " & dataReader.GetString(1) & " " & "Adress: " & country & ", " & city & ", " & street & ", " & Apartment.ToString() & " " & dataReader.GetString(3))
            End If
          End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

NativeOracleObject Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
NativeOracleObject Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObject Class

The following tables list the members exposed by NativeOracleObject.

Public Constructors

 | Name | Description
public Constructor | NativeOracleObject Constructor | Overloaded. Initializes a new instance of the NativeOracleObject class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Item | Gets or sets the value of the specified attribute.
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Overloaded. Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | SetAttributeNotNull | For internal use.
Top

See Also

Reference

NativeOracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleObject Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class : NativeOracleObject Constructor

Initializes a new instance of the NativeOracleObject class.

Overload List

Overload | Description
NativeOracleObject Constructor(String,OracleConnection) | Initializes a new instance of the NativeOracleObject class.
NativeOracleObject Constructor(OracleType,OracleConnection) | Initializes a new instance of the NativeOracleObject class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleObject Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class > NativeOracleObject Constructor : NativeOracleObject Constructor(String,OracleConnection)

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.
Initializes a new instance of the NativeOracleObject class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleObject(
   string typeName,
   OracleConnection connection
)

Parameters

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.

Remarks

Use this constructor to create an NativeOracleObject and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of OracleParameter initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleObject Constructor(OracleType,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class > NativeOracleObject Constructor : NativeOracleObject Constructor(OracleType,OracleConnection)

objectType
connection
An OracleConnection used to describe object type at the Oracle server.
Initializes a new instance of the NativeOracleObject class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectType As OracleType, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleObject(
   OracleType objectType,
   OracleConnection connection
)

Parameters

objectType
connection
An OracleConnection used to describe object type at the Oracle server.

Remarks

Use this constructor to create an NativeOracleObject and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of OracleParameter initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
NativeOracleObject Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObject Class

For a list of all members of this type, see NativeOracleObject members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Overloaded. Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | SetAttributeNotNull | For internal use.
Top

See Also

Reference

NativeOracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class : GetOracleValue Method

Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Overload List

Overload | Description
GetOracleValue(OracleAttribute) | Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
GetOracleValue(String) | Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(OracleAttribute) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class > GetOracleValue Method : GetOracleValue(OracleAttribute) Method

attribute
An OracleAttribute object.
Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal attribute As OracleAttribute _
) As Object
C#
public object GetOracleValue(
   OracleAttribute attribute
)

Parameters

attribute
An OracleAttribute object.

Return Value

The value of the attribute as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue(OracleAttribute) returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class > GetOracleValue Method : GetOracleValue(String) Method

attributeName
String that represents a full path to the attribute or the element of the array.
Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal attributeName As String _
) As Object
C#
public object GetOracleValue(
   string attributeName
)

Parameters

attributeName
String that represents a full path to the attribute or the element of the array.

Return Value

The value of the attribute as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue(String) returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetAttributeNotNull Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class : SetAttributeNotNull Method

attribute
For internal use.

Syntax

Visual Basic (Declaration)
Public Sub SetAttributeNotNull( _
   ByVal attribute As OracleAttribute _
)
C#
public void SetAttributeNotNull(
   OracleAttribute attribute
)

Parameters

attribute

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
NativeOracleObject Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObject Class

For a list of all members of this type, see NativeOracleObject members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Item | Gets or sets the value of the specified attribute.
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
Top

See Also

Reference

NativeOracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObject Class : Item Property

attribute
An OracleAttribute object.
Gets or sets the value of the specified attribute.

Syntax

Visual Basic (Declaration)
Public Shadows Default Property Item( _
   ByVal attribute As OracleAttribute _
) As Object
C#
public new object this(
   OracleAttribute attribute
) {get; set;}

Parameters

attribute
An OracleAttribute object.

Property Value

The value of the specified attribute.

Remarks

The Item property allows retrieving values of the attributes of the NativeOracleObject.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObject Class
NativeOracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleObjectBase Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObjectBase Class

Represents an object of any Oracle object type defined by the user (Object, VARRAY or Nested table).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.NativeOracleObjectBase
Devart.Data.Oracle.NativeOracleArray
Devart.Data.Oracle.NativeOracleObject

Syntax

Visual Basic (Declaration)
Public MustInherit Class NativeOracleObjectBase
   Inherits System.MarshalByRefObject
   Implements IDisposable
C#
public abstract class NativeOracleObjectBase : System.MarshalByRefObject, IDisposable

Remarks

The NativeOracleObjectBase class represents common interface to access attributes of the object and elements of the array by Item indexed property.

This class is not available in Devart.Data.Oracle.OracleConnection.Direct mode.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

NativeOracleObjectBase Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
NativeOracleObjectBase Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObjectBase Class

The following tables list the members exposed by NativeOracleObjectBase.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant.
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value.
public Property | Item | Gets or sets the OracleAttribute or OracleArray element by the specified path.
public Property | ObjectType | Gets an OracleType of the specified object.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object.
public Method | Flush | Flushes updated data to the server.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Refresh | Refreshes object data from the server.
Top

See Also

Reference

NativeOracleObjectBase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
NativeOracleObjectBase Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObjectBase Class

For a list of all members of this type, see NativeOracleObjectBase members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object.
public Method | Flush | Flushes updated data to the server.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Refresh | Refreshes object data from the server.
Top

See Also

Reference

NativeOracleObjectBase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : Dispose Method

Disposes the resources allocated by the NativeOracleObjectBase object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

After closing NativeOracleObjectBase object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Flush Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : Flush Method

Flushes updated data to the server.

Syntax

Visual Basic (Declaration)
Public Sub Flush()
C#
public void Flush()

Remarks

Use the NativeOracleObjectBase.Flush method to update data at the server for the object received by OracleRef. When the object is written to the server, triggers may be fired. Objects can be modified by the triggers at the server. To keep the objects in the object cache being coherent with the database, the clients can free or refresh the objects in the cache.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Refresh Method
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : Refresh Method

Refreshes object data from the server.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
C#
public void Refresh()

Remarks

The Refresh method is executable for the objects received by OracleRef.

In case if the NativeOracleObjectBase contains triggers which modify values of the object attributes it is necessary to update data after calling the NativeOracleObjectBase.Flush method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
NativeOracleObjectBase Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleObjectBase Class

For a list of all members of this type, see NativeOracleObjectBase members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant.
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value.
public Property | Item | Gets or sets the OracleAttribute or OracleArray element by the specified path.
public Property | ObjectType | Gets an OracleType of the specified object.
Top

See Also

Reference

NativeOracleObjectBase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : Connection Property

Gets or sets OracleConnection used by NativeOracleObjectBase descendant.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connection As OracleConnection
C#
public OracleConnection Connection {get;}

Property Value

An OracleConnection instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : IsNull Property

Indicates whether or not the NativeOracleObject represents a null value.

Syntax

Visual Basic (Declaration)
Public Property IsNull As Boolean
C#
public bool IsNull {get; set;}

Property Value

true if the NativeOracleObject represents a null value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : Item Property

Name
String that represents a full path to the attribute or the element of the array. Note that it is case-sensitive.
Gets or sets the OracleAttribute or OracleArray element by the specified path.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal Name As String _
) As Object
C#
public object this(
   string Name
) {get; set;}

Parameters

Name
String that represents a full path to the attribute or the element of the array. Note that it is case-sensitive.

Property Value

An OracleAttribute or OracleArray element by the specified path.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleObjectBase Class : ObjectType Property

Gets an OracleType of the specified object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As OracleType
C#
public OracleType ObjectType {get;}

Property Value

An OracleType of the specified object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleObjectBase Class
NativeOracleObjectBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleTable Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleTable Class

Represents Oracle Nested table type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.NativeOracleObjectBase
Devart.Data.Oracle.NativeOracleArray
Devart.Data.Oracle.NativeOracleTable

Syntax

Visual Basic (Declaration)
Public Class NativeOracleTable
   Inherits NativeOracleArray
   Implements ICollection, IEnumerable, IList, IDisposable
C#
public class NativeOracleTable : NativeOracleArray, ICollection, IEnumerable, IList, IDisposable

Remarks

The behavior of the NativeOracleTable is similar to NativeOracleArray class. The main difference is that NativeOracleTable can contain unlimited number of the elements.

This class represents OCI nested tables, and is intended for use in connected data access model.

Note that NativeOracleTable can be used in data binding with DataGrid as it implements IListSource interface.

This class is not available in Devart.Data.Oracle.OracleConnection.Direct mode.

Example

This example demonstrates how to retrieve a NativeOracleTable object from the server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE OR REPLACE TYPE TEmployees AS
  TABLE OF VARCHAR2(40);

CREATE TABLE CompanyEmpObject (
  Code NUMBER PRIMARY KEY,
  Company VARCHAR2(40),
  Employees TEmployees
)NESTED TABLE Employees STORE AS N_TAB;

INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (1, 'Microsoft', TEmployees('PROGRAMMER', 'MANAGER', 'ELECTRICIAN', 'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (2, 'Borland', TEmployees('PROGRAMMER', 'ELECTRICIAN', 'COURIER'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (3, 'MC Donalds', TEmployees('SHOP ASSISTANT', 'CLERK',  'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (4, 'Ford', TEmployees('MECHANICIAN', 'MANAGER'));
C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM CompanyEmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
    int index = dataReader.GetOrdinal("Employees");
    while (dataReader.Read()) {
            NativeOracleTable oraTable = dataReader.GetNativeOracleTable(index);
             if (!oraTable.IsNull) {
                        string[] employees = new string[oraTable.Count];
                        for (int i = 0; i < oraTable.Count; i++)
                                employees[i] = (string)oraTable[i];

                        Console.WriteLine("Company: " + dataReader.GetString(1));
                        foreach (string str in employees)
                                Console.WriteLine("\t" + str);
                }
                else{
                        Console.WriteLine("Company: " + dataReader.GetString(1));
                        Console.WriteLine("No vacancies");
                }
        }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
Console.ReadLine();
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM CompanyEmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
        Dim index As Integer = dataReader.GetOrdinal("Employees")
          While dataReader.Read()
                Dim oraTable As NativeOracleTable = dataReader.GetNativeOracleTable(index)
            If Not oraTable.IsNull Then
                        Dim employees(oraTable.Count) As String
                        Dim I As Integer
                        For I = 0 To oraTable.Count - 1
                                employees(I) = oraTable(I)
                Next I
                      Console.WriteLine("Company: " & dataReader.GetString(1))
                        For Each str As String In employees
                        Console.WriteLine(Chr(9) & str)
                      Next
            Else
                      Console.WriteLine("Company: " & dataReader.GetString(1))
                      Console.WriteLine("No vacancies")
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

NativeOracleTable Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
NativeOracleTable Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : NativeOracleTable Class

The following tables list the members exposed by NativeOracleTable.

Public Constructors

 | Name | Description
public Constructor | NativeOracleTable Constructor | Overloaded. Initializes a new instance of the NativeOracleTable class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Count | Gets the number of elements contained in the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsFixedSize | Gets a value indicating whether the NativeOracleArray has a fixed size. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsReadOnly | Gets a value indicating whether the NativeOracleArray is read-only. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsSynchronized | Gets a value indicating whether access to the NativeOracleArray is synchronized (thread-safe). (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | Item | Overloaded. Gets or sets the element at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | Value | Gets the value of the NativeOracleArray as .NET Framework array of the elements of the same type. (Inherited from Devart.Data.Oracle.NativeOracleArray)
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Clear | Removes all elements from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Contains | Determines whether an element is in the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | CopyTo | Copies the entire NativeOracleArray to a compatible System.Array starting at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetEnumerator | Returns an enumerator for the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | IndexOf | Gets the location in the collection of the NativeOracleArray object. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an NativeOracleArray into the collection at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Remove | Removes the specified element from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | RemoveAt | Removes the element at the specified index from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
Top

See Also

Reference

NativeOracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleTable Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleTable Class : NativeOracleTable Constructor

Initializes a new instance of the NativeOracleTable class.

Overload List

Overload | Description
NativeOracleTable Constructor(String,OracleConnection) | Initializes a new instance of the NativeOracleTable class.
NativeOracleTable Constructor(OracleType,OracleConnection) | Initializes a new instance of the NativeOracleTable class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleTable Class
NativeOracleTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleTable Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleTable Class > NativeOracleTable Constructor : NativeOracleTable Constructor(String,OracleConnection)

typeName
The name of the type on the server.
connection
An OracleConnection to use.
Initializes a new instance of the NativeOracleTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleTable(
   string typeName,
   OracleConnection connection
)

Parameters

typeName
The name of the type on the server.
connection
An OracleConnection to use.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleTable Class
NativeOracleTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NativeOracleTable Constructor(OracleType,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > NativeOracleTable Class > NativeOracleTable Constructor : NativeOracleTable Constructor(OracleType,OracleConnection)

objectType
connection
An OracleConnection to use.
Initializes a new instance of the NativeOracleTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectType As OracleType, _
   ByVal connection As OracleConnection _
)
C#
public NativeOracleTable(
   OracleType objectType,
   OracleConnection connection
)

Parameters

objectType
connection
An OracleConnection to use.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

NativeOracleTable Class
NativeOracleTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlert Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlert Class

Represents Oracle alert message.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleAlert

Syntax

Visual Basic (Declaration)
Public Class OracleAlert
C#
public class OracleAlert

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlert Members
Devart.Data.Oracle Namespace
WaitAlert Method


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAlert Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleAlert Class

The following tables list the members exposed by OracleAlert.

Public Constructors

 | Name | Description
public Constructor | OracleAlert Constructor | Initializes a new instance of the OracleAlert class.
Top

Public Properties

 | Name | Description
public Property | Message | Gets the message contents.
public Property | Name | Gets the name of the alert.
Top

Public Methods

 | Name | Description
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OracleAlert Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlert Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlert Class : OracleAlert Constructor

name
The name of the alert.
message
The message contents.
Initializes a new instance of the OracleAlert class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal message As String _
)
C#
public OracleAlert(
   string name,
   string message
)

Parameters

name
The name of the alert.
message
The message contents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlert Class
OracleAlert Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleAlert Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlert Class

For a list of all members of this type, see OracleAlert members.

Public Methods

 | Name | Description
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OracleAlert Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlert Class : ToString Method

Returns string representation of the object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The string representation of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlert Class
OracleAlert Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAlert Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlert Class

For a list of all members of this type, see OracleAlert members.

Public Properties

 | Name | Description
public Property | Message | Gets the message contents.
public Property | Name | Gets the name of the alert.
Top

See Also

Reference

OracleAlert Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Message Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlert Class : Message Property

Gets the message contents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

A string that represents message contents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlert Class
OracleAlert Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlert Class : Name Property

Gets the name of the alert.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

A string that represents message name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlert Class
OracleAlert Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerter Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

Manages Oracle alerts.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OracleAlerter

Syntax

Visual Basic (Declaration)
Public Class OracleAlerter
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public class OracleAlerter : System.ComponentModel.Component, IComponent, IDisposable

Remarks

This class is designed to subscribe to alert messages, and transfer them between client and Oracle server.

On server side, package DBMS_ALERT lets you use database triggers to alert an application when specific database values change. The alerts are transaction based and asynchronous.

On client side, use Start and Stop methods to listen to alert events, and Signal method to send message to Oracle server. You can also use the Devart.Data.Oracle.OracleAlerter.WaitAlert method to wait for single alerts.

There are two principal schemes for receiving alerts from server. First, you can use the Devart.Data.Oracle.OracleAlerter.WaitAlert method to wait for alerts during a Timeout. After an alert is received or the timeout expires the OracleAlerter does not continue to monitor the alerts. If you need to listen to the alerts continuously, use the Start method. The method monitors the alerts through cloned connection during Timeout, then pauses during Interval, then again monitors during Timeout, and so on.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following sample shows how an alert can be received in the Start/Stop mode of OracleAlerter. We send an alert message by one instance of OracleAlerter and receive this message asynchronously using another OracleAlerter.
C#csharp Copy Code
static void Main(string[] args) {
        // Open a connection to the Oracle server.
        OracleConnection con = new OracleConnection("Server = ora; User Id = sys; Password = pwd; Mode = SysDba");
        con.Open();

        // Create the OracleAlerter instance and register it for the "my_alert" Oracle Alert.
        OracleAlerter alerter = new OracleAlerter();
        alerter.Connection = con;
        alerter.AlertName = "my_alert";
        alerter.Timeout = 5;
        alerter.Interval = 0;

        // Set the event handler for receiving an alert.
        alerter.Alert += new OracleAlerterAlertEventHandler(Alerter_OnAlert);

        // Start the alerter. It will wait for alerts and fire the OnAlert event when any is received.
        alerter.Start();

        // Pause the thread to wait until the alerter begins listening.
        Thread.Sleep(2000);

        // Another instance of OracleAlerter is used to generate the alert.
        // alertGenerator uses the same connection and alert name as the alerter object.
        OracleAlerter alertGenerator = new OracleAlerter();
        alertGenerator.Connection = con;
        alertGenerator.AlertName = "my_alert";

        // Send an alert to the server. At this moment alerter should raise the Alert event.
        alertGenerator.Signal("An alert message.");

        // Make a pause to wait until the alert is created and processed.
        Thread.Sleep(2000);

        // Stop listening to alerts.
        alerter.Stop();

        Console.Read();
        con.Close();
}

    // Simple event handler for the OnAlert event.
public static void Alerter_OnAlert(object sender, OracleAlerterAlertEventArgs e) {
        Console.WriteLine("Got an alert: " + e.AlertMessage);
}
C#Visual Basic Copy Code
Sub Main(ByVal args As String())

        ' Open a connection to the Oracle server.
        Dim con As New OracleConnection("Server = ora; User Id = sys; Password = pwd; Mode = SysDba")
        con.Open()

        ' Create the OracleAlerter instance and register it for the "my_alert" Oracle Alert.
        Dim alerter As New OracleAlerter
        alerter.Connection = con
        alerter.AlertName = "my_alert"
        alerter.Timeout = 5
        alerter.Interval = 0

        ' Set the event handler for receiving an alert.
        AddHandler alerter.Alert, New OracleAlerterAlertEventHandler(AddressOf Alerter_OnAlert)

        ' Start the alerter. It will wait for alerts and fire the OnAlert event when any is received.
        alerter.Start()

        ' Pause the thread to wait until the alerter begins listening.
        Thread.Sleep(2000)

        ' Another instance of OracleAlerter is used to generate the alert.
        ' alertGenerator uses the same connection and alert name as the alerter object.
        Dim alertGenerator As New OracleAlerter
        alertGenerator.Connection = con
        alertGenerator.AlertName = "my_alert"

        ' Send an alert to the server. At this moment alerter should raise the Alert event.
        alertGenerator.Signal("An alert message.")

        'Make a pause to wait until the alert is created and processed.
        Thread.Sleep(2000)

        ' Stop listening to alerts.
        alerter.Stop()

        Console.Read()
        con.Close()
End Sub

    ' Simple event handler for the OnAlert event.
Public Sub Alerter_OnAlert(ByVal sender As Object, ByVal e As OracleAlerterAlertEventArgs)
        Console.WriteLine(("Got an alert: " & e.AlertMessage))
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerter Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAlerter Class Members
See Also Fields Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

The following tables list the members exposed by OracleAlerter.

Public Constructors

 | Name | Description
public Constructor | OracleAlerter Constructor | Overloaded. Initializes a new instance of the OracleAlerter class.Initializes a new instance of the OracleAlerter class.
Top

Public Fields

 | Name | Description
public Field | MaxWaitTimeout | Returns the max allowed value for the Timeout property.
Top

Public Properties

 | Name | Description
public Property | Active | Gets or sets a value indicating whether dotConnect for Oracle listens to alerts on a server.
public Property | AlertName | Gets or sets name of the alerts on the server.
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by OracleAlerter.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Interval | Gets or sets alert poll period.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Timeout | Gets or sets maximum time in seconds to wait for message to be received.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Signal | Sends a message to Oracle server.
public Method | Start | Enables listening to Oracle server.
public Method | Stop | Disables listening to Oracle server.
public Method | WaitAlert | Waits specified Timeout for alert to be receieved from server.
Top

Public Events

 | Name | Description
public Event | Alert | Occurs when an alert is received.
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when an error is trapped during message send or receive.
public Event | Stopped | Occurs when listening to server gets disabled.
public Event | WaitTimeout | Occurs when no message was received from server during Timeout interval.
Top

See Also

Reference

OracleAlerter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerter Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : OracleAlerter Constructor

Initializes a new instance of the OracleAlerter class.Initializes a new instance of the OracleAlerter class.

Overload List

Overload | Description
OracleAlerter Constructor() | Initializes a new instance of the OracleAlerter class.
OracleAlerter Constructor(OracleConnection,String) | Initializes a new instance of the OracleAlerter class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerter Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class > OracleAlerter Constructor : OracleAlerter Constructor()

Initializes a new instance of the OracleAlerter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleAlerter()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerter Constructor(OracleConnection,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class > OracleAlerter Constructor : OracleAlerter Constructor(OracleConnection,String)

connection
An OracleConnection to use.
alertName
Name of the alert on the server.
Initializes a new instance of the OracleAlerter class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal alertName As String _
)
C#
public OracleAlerter(
   OracleConnection connection,
   string alertName
)

Parameters

connection
An OracleConnection to use.
alertName
Name of the alert on the server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleAlerter Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

For a list of all members of this type, see OracleAlerter members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Signal | Sends a message to Oracle server.
public Method | Start | Enables listening to Oracle server.
public Method | Stop | Disables listening to Oracle server.
public Method | WaitAlert | Waits specified Timeout for alert to be receieved from server.
Top

See Also

Reference

OracleAlerter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Signal Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Signal Method

alertMessage
Message contents.
Sends a message to Oracle server.

Syntax

Visual Basic (Declaration)
Public Sub Signal( _
   ByVal alertMessage As String _
)
C#
public void Signal(
   string alertMessage
)

Parameters

alertMessage
Message contents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Start Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Start Method

Enables listening to Oracle server.

Syntax

Visual Basic (Declaration)
Public Sub Start()
C#
public void Start()

Remarks

This method sets Active property to true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Stop Method
WaitAlert Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Stop Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Stop Method

Disables listening to Oracle server.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
C#
public void Stop()

Remarks

This method sets Active property to false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Start Method
Stopped Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
WaitAlert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : WaitAlert Method

Waits specified Timeout for alert to be receieved from server.

Syntax

Visual Basic (Declaration)
Public Function WaitAlert() As OracleAlert
C#
public OracleAlert WaitAlert()

Return Value

An OracleAlert object. If no alert happened during the Timeout, the value returned is null.

Remarks

The Devart.Data.Oracle.OracleAlerter.WaitAlert method initiates the listening for alerts during the Timeout period.

Unlike Devart.Data.Oracle.OracleAlerter.WaitAlert, this method reserves the Connection to perform listening.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Alert Event
OracleAlert Class
Start Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAlerter Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

For a list of all members of this type, see OracleAlerter members.

Public Properties

 | Name | Description
public Property | Active | Gets or sets a value indicating whether dotConnect for Oracle listens to alerts on a server.
public Property | AlertName | Gets or sets name of the alerts on the server.
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by OracleAlerter.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Interval | Gets or sets alert poll period.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Timeout | Gets or sets maximum time in seconds to wait for message to be received.
Top

See Also

Reference

OracleAlerter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Active Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Active Property

Gets or sets a value indicating whether dotConnect for Oracle listens to alerts on a server.

Syntax

Visual Basic (Declaration)
Public Property Active As Boolean
C#
public bool Active {get; set;}

Property Value

true if alerts are monitored; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlertName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : AlertName Property

Gets or sets name of the alerts on the server.

Syntax

Visual Basic (Declaration)
Public Property AlertName As String
C#
public string AlertName {get; set;}

Property Value

The name of the alerts to watch for. This name is also used for sending alerts.

Remarks

You cannot change this property while OracleAlerter is active (started or waiting).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Connection Property

Gets or sets OracleConnection used by OracleAlerter.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

An OracleConnection instance.

Remarks

This connection is cloned and used for listening to alerts when you invoke Start for the first time. On the contrary, the Devart.Data.Oracle.OracleAlerter.WaitAlert method does not clone the connection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Interval Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Interval Property

Gets or sets alert poll period.

Syntax

Visual Basic (Declaration)
Public Property Interval As Integer
C#
public int Interval {get; set;}

Property Value

A number in seconds that represents interval between two consequent monitoring periods.

Remarks

The value of this property affects behavior of the OracleAlerter when the Start method is used. If the Interval is -1, OracleAlerter waits for alerts during the Timeout period and then automatically stops. If the Interval is 0, OracleAlerter monitors the alerts infinitely. If the Interval property is set to a positive integer value, this value represents pauses between two consequent monitoring periods.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Timeout Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Timeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Timeout Property

Gets or sets maximum time in seconds to wait for message to be received.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Property Value

An integer value that represents time to monitor alerts in seconds.

Remarks

The range of acceptable values is from 1 to 86400000. Setting the timeout to -1 is the same as setting it to 86400000. If the timeout is set to 0, WaitAlert returns null immediately if there is no pending alert. If the value exceeds 86400000 or is less than -1, the ArgumentOutOfRange exception is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
Interval Property
WaitAlert Method
Start Method


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleAlerter Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

For a list of all members of this type, see OracleAlerter members.

Public Fields

 | Name | Description
public Field | MaxWaitTimeout | Returns the max allowed value for the Timeout property.
Top

See Also

Reference

OracleAlerter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxWaitTimeout Field
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : MaxWaitTimeout Field

Returns the max allowed value for the Timeout property.

Syntax

Visual Basic (Declaration)
Public Const MaxWaitTimeout As Integer
C#
public const int MaxWaitTimeout

Field Value

The max allowed value for the Timeout property.

Example

This field can be used, for example, in the following way:
C#csharp Copy Code
OracleAlerter alerter = new OracleAlerter();
alerter.Timeout = OracleAlerter.MaxWaitTimeout;
C#Visual Basic Copy Code
Dim alerter As New OracleAlerter()
alerter.Timeout = OracleAlerter.MaxWaitTimeout

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleAlerter Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerter Class

For a list of all members of this type, see OracleAlerter members.

Public Events

 | Name | Description
public Event | Alert | Occurs when an alert is received.
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when an error is trapped during message send or receive.
public Event | Stopped | Occurs when listening to server gets disabled.
public Event | WaitTimeout | Occurs when no message was received from server during Timeout interval.
Top

See Also

Reference

OracleAlerter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Alert Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Alert Event

Occurs when an alert is received.

Syntax

Visual Basic (Declaration)
Public Event Alert As OracleAlerterAlertEventHandler
C#
public event OracleAlerterAlertEventHandler Alert

Event Data

The event handler receives an argument of type OracleAlerterAlertEventArgs containing data related to this event. The following OracleAlerterAlertEventArgs properties provide information specific to this event.

Property | Description
AlertMessage | Gets the alert contents.
AlertName | Gets the alert name.

Remarks

This event is invoked when the OracleAlerter is started with the Start method. The Devart.Data.Oracle.OracleAlerter.WaitAlert method does not trigger the Devart.Data.Oracle.OracleAlerter.Alert event.

The event handler receives an argument of OracleAlerterAlertEventArgs type containing data related to this event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
WaitAlert Method
OracleAlerterAlertEventArgs Class
OracleAlerterAlertEventHandler Delegate


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Error Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Error Event

Occurs when an error is trapped during message send or receive.

Syntax

Visual Basic (Declaration)
Public Event Error As OracleAlerterErrorEventHandler
C#
public event OracleAlerterErrorEventHandler Error

Event Data

The event handler receives an argument of type OracleAlerterErrorEventArgs containing data related to this event. The following OracleAlerterErrorEventArgs properties provide information specific to this event.

Property | Description
AlerterException | Gets the exception that represents the error.

Remarks

The event handler receives an argument of OracleAlerterErrorEventArgs type containing data related to this event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Stopped Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : Stopped Event

Occurs when listening to server gets disabled.

Syntax

Visual Basic (Declaration)
Public Event Stopped As OracleAlerterFinishEventHandler
C#
public event OracleAlerterFinishEventHandler Stopped

Remarks

The event handler receives an argument of OracleAlerterFinishEventArgs type containing data related to this event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members
OracleAlerterFinishEventArgs Class
OracleAlerterFinishEventHandler Delegate
Stop Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
WaitTimeout Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerter Class : WaitTimeout Event

Occurs when no message was received from server during Timeout interval.

Syntax

Visual Basic (Declaration)
Public Event WaitTimeout As OracleAlerterFinishEventHandler
C#
public event OracleAlerterFinishEventHandler WaitTimeout

Remarks

This event is invoked when the OracleAlerter is started with the Start method. The Devart.Data.Oracle.OracleAlerter.WaitAlert method does not trigger the Devart.Data.Oracle.OracleAlerter.Alert event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerter Class
OracleAlerter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterAlertEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterAlertEventArgs Class

Provides data for the OracleAlerter.Alert event of the OracleAlerter class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleAlerterAlertEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleAlerterAlertEventArgs
   Inherits System.EventArgs
C#
public class OracleAlerterAlertEventArgs : System.EventArgs

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterAlertEventArgs Members
Devart.Data.Oracle Namespace
Alert Event


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAlerterAlertEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterAlertEventArgs Class

The following tables list the members exposed by OracleAlerterAlertEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleAlerterAlertEventArgs Constructor | Initializes a new instance of the OracleAlerterAlertEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AlertMessage | Gets the alert contents.
public Property | AlertName | Gets the alert name.
Top

See Also

Reference

OracleAlerterAlertEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterAlertEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterAlertEventArgs Class : OracleAlerterAlertEventArgs Constructor

alertName
The name of the alert.
alertMessage
The contents of the alert.
Initializes a new instance of the OracleAlerterAlertEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal alertName As String, _
   ByVal alertMessage As String _
)
C#
public OracleAlerterAlertEventArgs(
   string alertName,
   string alertMessage
)

Parameters

alertName
The name of the alert.
alertMessage
The contents of the alert.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterAlertEventArgs Class
OracleAlerterAlertEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAlerterAlertEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterAlertEventArgs Class

For a list of all members of this type, see OracleAlerterAlertEventArgs members.

Public Properties

 | Name | Description
public Property | AlertMessage | Gets the alert contents.
public Property | AlertName | Gets the alert name.
Top

See Also

Reference

OracleAlerterAlertEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlertMessage Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterAlertEventArgs Class : AlertMessage Property

Gets the alert contents.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AlertMessage As String
C#
public string AlertMessage {get;}

Property Value

A string that represents the message contents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterAlertEventArgs Class
OracleAlerterAlertEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlertName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterAlertEventArgs Class : AlertName Property

Gets the alert name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AlertName As String
C#
public string AlertName {get;}

Property Value

A string that represents the message name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterAlertEventArgs Class
OracleAlerterAlertEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterErrorEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterErrorEventArgs Class

Provides data for the OracleAlerter.Error event of the OracleAlerter class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleAlerterErrorEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleAlerterErrorEventArgs
   Inherits System.EventArgs
C#
public class OracleAlerterErrorEventArgs : System.EventArgs

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterErrorEventArgs Members
Devart.Data.Oracle Namespace
Error Event


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAlerterErrorEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterErrorEventArgs Class

The following tables list the members exposed by OracleAlerterErrorEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleAlerterErrorEventArgs Constructor | Initializes a new instance of the OracleAlerterAlertEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AlerterException | Gets the exception that represents the error.
Top

See Also

Reference

OracleAlerterErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterErrorEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterErrorEventArgs Class : OracleAlerterErrorEventArgs Constructor

exception
The exception that represents the error.
Initializes a new instance of the OracleAlerterAlertEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
C#
public OracleAlerterErrorEventArgs(
   Exception exception
)

Parameters

exception
The exception that represents the error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterErrorEventArgs Class
OracleAlerterErrorEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAlerterErrorEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterErrorEventArgs Class

For a list of all members of this type, see OracleAlerterErrorEventArgs members.

Public Properties

 | Name | Description
public Property | AlerterException | Gets the exception that represents the error.
Top

See Also

Reference

OracleAlerterErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlerterException Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterErrorEventArgs Class : AlerterException Property

Gets the exception that represents the error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AlerterException As Exception
C#
public Exception AlerterException {get;}

Property Value

The exception that represents the error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterErrorEventArgs Class
OracleAlerterErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterFinishEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterFinishEventArgs Class

Provides data for the OracleAlerter.Stopped event of the OracleAlerter class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleAlerterFinishEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleAlerterFinishEventArgs
   Inherits System.EventArgs
C#
public class OracleAlerterFinishEventArgs : System.EventArgs

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterFinishEventArgs Members
Devart.Data.Oracle Namespace
Stopped Event


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAlerterFinishEventArgs Class Members
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterFinishEventArgs Class

The following tables list the members exposed by OracleAlerterFinishEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleAlerterFinishEventArgs Constructor | Initializes a new instance of the OracleAlerterFinishEventArgs class.
Top

See Also

Reference

OracleAlerterFinishEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterFinishEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAlerterFinishEventArgs Class : OracleAlerterFinishEventArgs Constructor

Initializes a new instance of the OracleAlerterFinishEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleAlerterFinishEventArgs()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAlerterFinishEventArgs Class
OracleAlerterFinishEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAnyData Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAnyData Class

Represents Oracle SYS.ANYDATA type.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleAnyData

Syntax

Visual Basic (Declaration)
Public Class OracleAnyData
   Implements INullable, IDisposable
C#
public class OracleAnyData : INullable, IDisposable

Remarks

This type contains an instance of a given type, with data, plus a description of the type. OracleAnyData can be used as a table column datatype and lets you store heterogeneous values in a single column. The values can be of SQL built-in types as well as user-defined types.

This type is supported starting with Oracle 9i.

OracleAnyData can be used with one of these types:

  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Array
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Char
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Date
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Double (Oracle 10 and above)
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Float (Oracle 10 and above)
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.IntervalDS
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.IntervalYM
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.NChar
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Number
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.NVarChar
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Object
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Raw
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Ref
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.Table
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.TimeStamp
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.TimeStampLTZ
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.TimeStampTZ
  • F:Devart.Data.Oracle.OracleDbType.OracleDbType.VarChar

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAnyData Members
Devart.Data.Oracle Namespace
GetOracleAnyData(Int32) Method


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAnyData Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleAnyData Class

The following tables list the members exposed by OracleAnyData.

Public Constructors

 | Name | Description
public Constructor | OracleAnyData Constructor | Initializes a new instance of the OracleAnyData class.
Top

Public Properties

 | Name | Description
public Property | IsNull | Indicates whether or not the OracleAnyData represents a null value.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleAnyData structure.
public Property | OracleDbType | Gets the type of the OracleAnyData.
public Property | OracleValue | Gets the value of the OracleAnyData.
public Property | Value | Gets the value of the OracleAnyData converted to a .NET type.
Top

Public Methods

 | Name | Description
public Method | Dispose | Disposes the resources allocated by the OracleAnyData object.
Top

See Also

Reference

OracleAnyData Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAnyData Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : OracleAnyData Constructor

oracleDbType
One of the OracleDbType values.
oracleValue
The value of the OracleAnyData instance.
Initializes a new instance of the OracleAnyData class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oracleDbType As OracleDbType, _
   ByVal oracleValue As Object _
)
C#
public OracleAnyData(
   OracleDbType oracleDbType,
   object oracleValue
)

Parameters

oracleDbType
One of the OracleDbType values.
oracleValue
The value of the OracleAnyData instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleAnyData Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAnyData Class

For a list of all members of this type, see OracleAnyData members.

Public Methods

 | Name | Description
public Method | Dispose | Disposes the resources allocated by the OracleAnyData object.
Top

See Also

Reference

OracleAnyData Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : Dispose Method

Disposes the resources allocated by the OracleAnyData object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

After disposing OracleAnyData object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAnyData Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAnyData Class

For a list of all members of this type, see OracleAnyData members.

Public Properties

 | Name | Description
public Property | IsNull | Indicates whether or not the OracleAnyData represents a null value.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleAnyData structure.
public Property | OracleDbType | Gets the type of the OracleAnyData.
public Property | OracleValue | Gets the value of the OracleAnyData.
public Property | Value | Gets the value of the OracleAnyData converted to a .NET type.
Top

See Also

Reference

OracleAnyData Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : IsNull Property

Indicates whether or not the OracleAnyData represents a null value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the OracleAnyData represents a null value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : Null Property

Represents a null value that can be assigned to the Value property of an OracleAnyData structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Null As OracleAnyData
C#
public static OracleAnyData Null {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDbType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : OracleDbType Property

Gets the type of the OracleAnyData.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OracleDbType As OracleDbType
C#
public OracleDbType OracleDbType {get;}

Property Value

One of the OracleDbType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleValue Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : OracleValue Property

Gets the value of the OracleAnyData.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OracleValue As Object
C#
public object OracleValue {get;}

Property Value

The value of the OracleAnyData.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members
Value Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : Value Property

Gets the value of the OracleAnyData converted to a .NET type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

The value of the OracleAnyData converted to a .NET type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members
OracleValue Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArray Class

Represents a client-side cached Oracle collection (VARRAY).

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleArray
Devart.Data.Oracle.OracleTable

Syntax

Visual Basic (Declaration)
Public Class OracleArray
   Implements ICustomOracleArray, ICollection, IEnumerable, IList, IListSource, INullable, ICloneable
C#
public class OracleArray : ICustomOracleArray, ICollection, IEnumerable, IList, IListSource, INullable, ICloneable

Remarks

The OracleArray class provides methods to access elements of the collection. Items values are accessible by Item indexed property.

The array elements can be added to the collection dynamically by calling Add, Insert methods or removed by calling Remove or RemoveAt but the maximum number of the elements cannot exceed Capacity specified at Oracle declaration of the VARRAY.

Indexes in this collection are zero-based.

Note that OracleArray can be used in data binding with DataGrid as it implements IListSource interface.

Example

This example demonstrates how to retrieve OracleArray object from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE OR REPLACE TYPE TEmployees AS
  VARYING ARRAY(10000) OF VARCHAR2(40);

CREATE TABLE CompanyEmpObject (
  Code NUMBER PRIMARY KEY,
  Company VARCHAR2(40),
  Employees TEmployees
);
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (1, 'Microsoft', TEmployees('PROGRAMMER', 'MANAGER', 'ELECTRICIAN', 'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (2, 'Borland', TEmployees('PROGRAMMER', 'ELECTRICIAN', 'COURIER'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (3, 'MC Donalds', TEmployees('SHOP ASSISTANT', 'CLERK',  'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (4, 'Ford', TEmployees('MECHANICIAN', 'MANAGER'));

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM CompanyEmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Employees");
  while (dataReader.Read()) {
    OracleArray oraArray = dataReader.GetOracleArray(index);
    if (!oraArray.IsNull) {
      string[] employees = new string[oraArray.Count];
      for (int i = 0; i < oraArray.Count; i++)
        employees[i] = (string)oraArray[i];

      Console.WriteLine("Company: " + dataReader.GetString(1));
      foreach (string str in employees)
        Console.WriteLine("\t"+str);
    }
    else{
      Console.WriteLine("Company: " + dataReader.GetString(1));
      Console.WriteLine("No vacancies");
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM CompanyEmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Employees")
  While dataReader.Read()
    Dim oraArray As OracleArray = dataReader.GetOracleArray(index)
    If Not oraArray.IsNull Then
      Dim employees(oraArray.Count) As String
      Dim I As Integer
      For I = 0 To oraArray.Count - 1
        employees(I) = oraArray(I)
      Next I
      Console.WriteLine("Company: " & dataReader.GetString(1))
      For Each str As String In employees
        Console.WriteLine(Chr(9) & str)
      Next
    Else
      Console.WriteLine("Company: " & dataReader.GetString(1))
      Console.WriteLine("No vacancies")
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleArray Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleArray Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleArray Class

The following tables list the members exposed by OracleArray.

Public Constructors

 | Name | Description
public Constructor | OracleArray Constructor | Overloaded. Initializes a new instance of the OracleArray class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets the number of elements that the OracleArray can contain.
public Property | Count | Gets the number of elements contained in the OracleArray.
public Property | IsFixedSize | Gets a value indicating whether the OracleArray has a fixed size.
public Property | IsNull | Indicates whether or not the OracleArray represents a null value.
public Property | IsReadOnly | Gets a value indicating whether the OracleArray is read-only.
public Property | IsSynchronized | Gets a value indicating whether access to the OracleArray is synchronized (thread-safe).
public Property | Item | Gets or sets the element at the specified index.
static (Shared in Visual Basic) | Null | Represents a null value of an OracleArray object.
public Property | ObjectType | Gets type of the objects in the array.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the OracleArray.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the OracleArray.
public Method | Clear | Removes all elements from the OracleArray.
public Method | Clone | Creates a copy of an OracleArray object.
public Method | Contains | Determines whether an element is in the OracleArray.
public Method | CopyTo | Copies the entire OracleArray to a compatible System.Array starting at the specified index.
public Method | GetEnumerator | Returns an enumerator for the OracleArray.
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format.
public Method | IndexOf | Gets the location in the collection of the OracleArray object.
public Method | Insert | Inserts an OracleArray into the collection at the specified index.
public Method | Remove | Removes the specified element from the OracleArray.
public Method | RemoveAt | Removes the element at the specified index from the OracleArray.
Top

See Also

Reference

OracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : OracleArray Constructor

Initializes a new instance of the OracleArray class.

Overload List

Overload | Description
OracleArray Constructor(String,OracleConnection) | Initializes a new instance of the OracleArray class of the specified type with the specified OracleConnection.
OracleArray Constructor(OracleType) | Initializes a new instance of the OracleArray class of the specified type.
OracleArray Constructor(String,OracleConnection,IEnumerable) | Initializes a new instance of the OracleArray class of the specified type with the specified OracleConnection.
OracleArray Constructor(OracleType,IEnumerable) | Initializes a new instance of the OracleArray class of the specified type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class > OracleArray Constructor : OracleArray Constructor(String,OracleConnection)

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server. This should be the array type, not the type of objects of which the array consists.
Initializes a new instance of the OracleArray class of the specified type with the specified OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleArray(
   string typeName,
   OracleConnection connection
)

Parameters

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server. This should be the array type, not the type of objects of which the array consists.

Remarks

Use this constructor to create an OracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Constructor(OracleType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class > OracleArray Constructor : OracleArray Constructor(OracleType)

oraType
An OracleType to create a new instance of the OracleArray. This should be the array type, not the type of objects of which the array consists.
Initializes a new instance of the OracleArray class of the specified type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oraType As OracleType _
)
C#
public OracleArray(
   OracleType oraType
)

Parameters

oraType
An OracleType to create a new instance of the OracleArray. This should be the array type, not the type of objects of which the array consists.

Remarks

Use this constructor to create an OracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Constructor(String,OracleConnection,IEnumerable)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class > OracleArray Constructor : OracleArray Constructor(String,OracleConnection,IEnumerable)

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server. This should be the array type, not the type of objects of which the array consists.
source
A set of array item values.
Initializes a new instance of the OracleArray class of the specified type with the specified OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection, _
   ByVal source As IEnumerable _
)
C#
public OracleArray(
   string typeName,
   OracleConnection connection,
   IEnumerable source
)

Parameters

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server. This should be the array type, not the type of objects of which the array consists.
source
A set of array item values.

Remarks

Use this constructor to create an OracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArray Constructor(OracleType,IEnumerable)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class > OracleArray Constructor : OracleArray Constructor(OracleType,IEnumerable)

oraType
An OracleType to create a new instance of the OracleArray. This should be the array type, not the type of objects of which the array consists.
source
A set of array item values.
Initializes a new instance of the OracleArray class of the specified type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oraType As OracleType, _
   ByVal source As IEnumerable _
)
C#
public OracleArray(
   OracleType oraType,
   IEnumerable source
)

Parameters

oraType
An OracleType to create a new instance of the OracleArray. This should be the array type, not the type of objects of which the array consists.
source
A set of array item values.

Remarks

Use this constructor to create an OracleArray and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleArray Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArray Class

For a list of all members of this type, see OracleArray members.

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the OracleArray.
public Method | Clear | Removes all elements from the OracleArray.
public Method | Clone | Creates a copy of an OracleArray object.
public Method | Contains | Determines whether an element is in the OracleArray.
public Method | CopyTo | Copies the entire OracleArray to a compatible System.Array starting at the specified index.
public Method | GetEnumerator | Returns an enumerator for the OracleArray.
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format.
public Method | IndexOf | Gets the location in the collection of the OracleArray object.
public Method | Insert | Inserts an OracleArray into the collection at the specified index.
public Method | Remove | Removes the specified element from the OracleArray.
public Method | RemoveAt | Removes the element at the specified index from the OracleArray.
Top

See Also

Reference

OracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Add Method

value
The System.Object to be added to the end of the OracleArray.
Adds an object of specified OracleType.ItemDbType type to the end of the OracleArray.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As Object _
) As Integer
C#
public int Add(
   object value
)

Parameters

value
The System.Object to be added to the end of the OracleArray.

Return Value

The OracleArray index at which the value has been added.

Remarks

If value of Count property equals to Capacity the Add method raises an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Clear Method

Removes all elements from the OracleArray.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Clone Method

Creates a copy of an OracleArray object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

An OracleArray object.

Remarks

The cloned object has the same property values as that of the object being cloned.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Contains Method

value
An System.Object to locate in the OracleArray.
Determines whether an element is in the OracleArray.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
C#
public bool Contains(
   object value
)

Parameters

value
An System.Object to locate in the OracleArray.

Return Value

true if an item is found in the OracleArray; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : CopyTo Method

array
The System.Array where to copy elements from OracleArray.
index
The zero-based starting index.
Copies the entire OracleArray to a compatible System.Array starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The System.Array where to copy elements from OracleArray.
index
The zero-based starting index.

Remarks

The specified array must be of a compatible type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : GetEnumerator Method

Returns an enumerator for the OracleArray.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
C#
public IEnumerator GetEnumerator()

Return Value

An enumerator for the OracleArray.

Remarks

Enumerators allow only reading the data in the collection and cannot be used to modify it.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : GetOracleValue Method

i
The zero-based element ordinal.
Gets the value of the array element at the specified ordinal in its Oracle format.

Syntax

Visual Basic (Declaration)
Public Function GetOracleValue( _
   ByVal i As Integer _
) As Object
C#
public object GetOracleValue(
   int i
)

Parameters

i
The zero-based element ordinal.

Return Value

The value of the array element.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : IndexOf Method

value
The OracleArray object to find.
Gets the location in the collection of the OracleArray object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
C#
public int IndexOf(
   object value
)

Parameters

value
The OracleArray object to find.

Return Value

The zero-based location of the OracleArray in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Insert Method

index
The zero-based index where the OracleArray is to be inserted within the collection.
value
The OracleArray object to add to the collection.
Inserts an OracleArray into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
C#
public void Insert(
   int index,
   object value
)

Parameters

index
The zero-based index where the OracleArray is to be inserted within the collection.
value
The OracleArray object to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Remove Method

value
The System.Object to remove from the OracleArray.
Removes the specified element from the OracleArray.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
C#
public void Remove(
   object value
)

Parameters

value
The System.Object to remove from the OracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : RemoveAt Method

i
The zero-based index of the element to remove.
Removes the element at the specified index from the OracleArray.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal i As Integer _
)
C#
public void RemoveAt(
   int i
)

Parameters

i
The zero-based index of the element to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleArray Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArray Class

For a list of all members of this type, see OracleArray members.

Public Properties

 | Name | Description
public Property | Capacity | Gets the number of elements that the OracleArray can contain.
public Property | Count | Gets the number of elements contained in the OracleArray.
public Property | IsFixedSize | Gets a value indicating whether the OracleArray has a fixed size.
public Property | IsNull | Indicates whether or not the OracleArray represents a null value.
public Property | IsReadOnly | Gets a value indicating whether the OracleArray is read-only.
public Property | IsSynchronized | Gets a value indicating whether access to the OracleArray is synchronized (thread-safe).
public Property | Item | Gets or sets the element at the specified index.
static (Shared in Visual Basic) | Null | Represents a null value of an OracleArray object.
public Property | ObjectType | Gets type of the objects in the array.
public Property | SyncRoot | Gets an object that can be used to synchronize access to the OracleArray.
Top

See Also

Reference

OracleArray Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Capacity Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Capacity Property

Gets the number of elements that the OracleArray can contain.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity As Integer
C#
public int Capacity {get;}

Property Value

The number of elements that the OracleArray can contain.

Remarks

The number of elements that the OracleArray can contain is specified on creating VARRAY type at the Oracle server. For example, the value of Capacity property for type 'VARRAY(5) OF NUMBER' is 5.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Count Property

Gets the number of elements contained in the OracleArray.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the OracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsFixedSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : IsFixedSize Property

Gets a value indicating whether the OracleArray has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize {get;}

Property Value

true if the OracleArray has a fixed size; otherwise, false.

Remarks

A collection with a fixed size does not allow to add or remove elements after the collection is created, but it allows to modify already existing elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : IsNull Property

Indicates whether or not the OracleArray represents a null value.

Syntax

Visual Basic (Declaration)
Public Property IsNull As Boolean
C#
public bool IsNull {get; set;}

Property Value

true if the OracleArray represents a null value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsReadOnly Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : IsReadOnly Property

Gets a value indicating whether the OracleArray is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly {get;}

Property Value

true if the OracleArray is read-only; otherwise, false.

Remarks

A collection that is read-only does not allow the add, remove, or modify elements after the collection is created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsSynchronized Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : IsSynchronized Property

Gets a value indicating whether access to the OracleArray is synchronized (thread-safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized {get;}

Property Value

true if access to the OracleArray is synchronized (thread-safe); otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Item Property

i
The zero-based index of the element to retrieve.
Gets or sets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal i As Integer _
) As Object
C#
public object this(
   int i
) {get; set;}

Parameters

i
The zero-based index of the element to retrieve.

Property Value

The element at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : Null Property

Represents a null value of an OracleArray object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Null As OracleArray
C#
public static OracleArray Null {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : ObjectType Property

Gets type of the objects in the array.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As OracleType
C#
public OracleType ObjectType {get;}

Property Value

An OracleType that describes the objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncRoot Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArray Class : SyncRoot Property

Gets an object that can be used to synchronize access to the OracleArray.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public object SyncRoot {get;}

Property Value

An System.Object that can be used to synchronize access to the OracleArray.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArray Class
OracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleArrayDataReader Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArrayDataReader Class

Allows to read a forward-only stream of rows from an OracleArray or OracleTable.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleArrayDataReader

Syntax

Visual Basic (Declaration)
Public Class OracleArrayDataReader
   Inherits System.MarshalByRefObject
   Implements IEnumerable, IDataReader, IDataRecord, IDisposable
C#
public class OracleArrayDataReader : System.MarshalByRefObject, IEnumerable, IDataReader, IDataRecord, IDisposable

Remarks

As OracleArray and OracleTable have structure similar to usual database tables, it is natural to work with them in a similar way. For this purpose, OracleArrayDataReader implements the functionality of OracleDataReader for OracleArray and OracleTable.

To create a new instance of OracleArrayDataReader, the OracleDataReader.GetValue method of the OracleDataReader object should be used instead of calling a constructor directly.

This class is not available in Devart.Data.Oracle.OracleConnection.Direct mode.

Example

The sample demonstrates how OracleArrayDataReader may be retrieved and used. To create required objects and fill the table with data the following script should be executed:

CREATE OR REPLACE TYPE TEmployees AS
  TABLE OF VARCHAR2(40);

CREATE TABLE CompanyEmpObject (
  Code NUMBER PRIMARY KEY,
  Company VARCHAR2(40),
  Employees TEmployees
)NESTED TABLE Employees STORE AS N_TAB;

INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (1, 'Microsoft', TEmployees('PROGRAMMER', 'MANAGER', 'ELECTRICIAN', 'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (2, 'Borland', TEmployees('PROGRAMMER', 'ELECTRICIAN', 'COURIER'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (3, 'MC Donalds', TEmployees('SHOP ASSISTANT', 'CLERK',  'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (4, 'Ford', TEmployees('MECHANICIAN', 'MANAGER'));
C#csharp Copy Code
// Open a connection
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora1110");
connection.Open();

// Execute a simple command reading all records from CompanyEmpObject
OracleCommand command = new OracleCommand("SELECT * FROM CompanyEmpObject", connection);
OracleDataReader dataReader = command.ExecuteReader();

try
{
        // Get index of the Employees column
    int index = dataReader.GetOrdinal("Employees");
    while (dataReader.Read())
    {
        Console.WriteLine(dataReader["Company"] + ":");

        // The GetValue method returns OracleArrayDataReader, which
        // allows to read records inside the Employees nested table.
        OracleArrayDataReader oraTableReader = (OracleArrayDataReader)dataReader.GetValue(index);
        // The OracleArrayDataReader may be used in the same way as usual data reader:
        while (oraTableReader.Read())
            Console.Write(oraTableReader.GetString(0) + "|");

        Console.WriteLine("\n" + new string('*', 79));
        }
}
catch (OracleException ex)
{
        Console.WriteLine(ex.Message);
}
finally
{
        dataReader.Close();
        connection.Close();
}
Console.ReadLine();
C#Visual Basic Copy Code
'Open a connection
Dim connection = New OracleConnection("User Id=scott;Password=tiger;Data Source=ora1110")
connection.Open()

' Execute a simple command reading all records from CompanyEmpObject
Dim command = New OracleCommand("SELECT * FROM CompanyEmpObject", connection)
Dim dataReader As OracleDataReader = command.ExecuteReader()

Try
        ' Get index of the Employees column
Dim index As Integer = dataReader.GetOrdinal("Employees")

        While dataReader.Read()
                Console.WriteLine(dataReader.Item("Company") + ":")
                ' The GetValue method returns OracleArrayDataReader, which
                ' allows to read records inside the Employees nested table.
        Dim oraTableReader As OracleArrayDataReader = dataReader.GetValue(index)
                ' The OracleArrayDataReader may be used in the same way as usual data reader:
                While (oraTableReader.Read())
                        Console.Write(oraTableReader.GetString(0) + "|")
                End While
                Console.WriteLine(vbCrLf + New String("*", 79))
        End While
Catch ex As OracleException
        Console.WriteLine(ex.Message)
Finally
        dataReader.Close()
        connection.Close()
End Try
Console.ReadLine()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleArrayDataReader Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleArrayDataReader Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleArrayDataReader Class

The following tables list the members exposed by OracleArrayDataReader.

Public Properties

 | Name | Description
public Property | Depth | Do not use.
public Property | FieldCount | If the array consists of OBJECT TYPE elements, gets number of array element properties.
public Property | IsClosed | Indicates whether the OracleArrayDataReader was closed.
public Property | Item | Overloaded. If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Property | RecordsAffected | Do not use.
Top

Public Methods

 | Name | Description
public Method | Close | Closes the OracleArrayDataReader object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Method | GetByte | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Byte, otherwise, gets the value of the current array element as a Boolean.
public Method | GetBytes | If the array consists of OBJECT TYPE elements, reads a stream of bytes from the specified property of the current array element, otherwise, reads a stream of bytes from the current array element.
public Method | GetChar | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single character, otherwise, gets the value of the current array element as a single character.
public Method | GetChars | If the array consists of OBJECT TYPE elements, reads a stream of characters from the specified property of the current array element, otherwise, reads a stream of characters from the current array element.
public Method | GetData | If the array consists of OBJECT TYPE elements, gets nested DataReader for the specified property of the current current array element, otherwise, gets the name of the source data type.
public Method | GetDataTypeName | If the array consists of OBJECT TYPE elements, gets the name of the source data type of the current array element, otherwise, gets the name of the source data type.
public Method | GetDateTime | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.DateTime object, otherwise, gets the value of the current array element as a System.DateTime object.
public Method | GetDecimal | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.Decimal object, otherwise, gets the value of the current array element as a System.Decimal object.
public Method | GetDouble | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a double-precision floating point number, otherwise, gets the value of the current array element as a double-precision floating point number.
public Method | GetEnumerator | Gets the enumerator for the ORACLE ARRAY elements.
public Method | GetFieldType | If the array consists of OBJECT TYPE elements, gets the System.Type that is the data type of the specified property of the current array element, otherwise, the System.Type that is the data type of the current array element.
public Method | GetFloat | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single-precision floating point number, otherwise, gets the value of the current array element as a single-precision floating point number.
public Method | GetGuid | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a globally-unique identifier (GUID), otherwise, gets the value of the current array element as a globally-unique identifier.
public Method | GetInt16 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 16-bit signed integer, otherwise, gets the value of the current array element as a 16-bit signed integer.
public Method | GetInt32 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 32-bit signed integer, otherwise, gets the value of the current array element as a 32-bit signed integer.
public Method | GetInt64 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 64-bit signed integer, otherwise, gets the value of the current array element as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | If the array consists of OBJECT TYPE elements, gets the name of the specified property of the current array element.
public Method | GetOracleArray | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleArray object, otherwise, gets the value of the current array element as an OracleArray object.
public Method | GetOracleBFile | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBFile object, otherwise, gets the value of the current array element as an OracleBFile object.
public Method | GetOracleBinary | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBinary object, otherwise, gets the value of the current array element as an OracleBinary object.
public Method | GetOracleCursor | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleCursor object, otherwise, gets the value of the current array element as an OracleCursor object.
public Method | GetOracleDate | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleDate object, otherwise, gets the value of the current array element as an OracleDate object.
public Method | GetOracleIntervalDS | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalDS object, otherwise, gets the value of the current array element as an OracleIntervalDS object.
public Method | GetOracleIntervalYM | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalYM object, otherwise, gets the value of the current array element as an OracleIntervalYM object.
public Method | GetOracleLob | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleLob object, otherwise, gets the value of the current array element as an OracleLob object.
public Method | GetOracleMonthSpan | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleMonthSpan object, otherwise, gets the value of the current array element as an OracleMonthSpan object.
public Method | GetOracleNumber | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleNumber object, otherwise, gets the value of the current array element as an OracleNumber object.
public Method | GetOracleObject | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleObject object, otherwise, gets the value of the current array element as an OracleObject object.
public Method | GetOracleRef | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleRef object, otherwise, gets the value of the current array element as an OracleRef object.
public Method | GetOracleString | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleString object, otherwise, gets the value of the current array element as an OracleString object.
public Method | GetOracleTable | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTable object, otherwise, gets the value of the current array element as an OracleTable object.
public Method | GetOracleTimeSpan | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTimeSpan object, otherwise, gets the value of the current array element as an OracleTimeSpan object.
public Method | GetOracleValue | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element in its Oracle format wrapped by dotConnect for Oracle, otherwise, gets the value of the current array element in its Oracle format wrapped by dotConnect for Oracle.
public Method | GetOrdinal | Gets the ordinal of the specified OBJECT TYPE property.
public Method | GetSchemaTable | Gets array metadata. If array consists of OBJECT TYPE elements, object type properties correspond to table columns. Otherwise, System.Data.DataTable has only one column with the same datatype as array elements.
public Method | GetString | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a string, otherwise, gets the value of the current array element as a string.
public Method | GetValue | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Method | GetValues | Gets OBJECT TYPE properties of the current array element, if the array consists of the OBJECT TYPE elements. Otherwise, gets current array element as a single value.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | If the array consists of OBJECT TYPE elements, indicates whether the specified property of the current array element is null, otherwise, indicates wether the current array element is null.
public Method | NextResult | Advances the data reader to the next result, when reading the results of batch SQL statements.
public Method | Read | Advances the T:DevartData.Oracle.OracleArrayDataReader to the next array element.
Top

See Also

Reference

OracleArrayDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleArrayDataReader Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArrayDataReader Class

For a list of all members of this type, see OracleArrayDataReader members.

Public Methods

 | Name | Description
public Method | Close | Closes the OracleArrayDataReader object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Method | GetByte | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Byte, otherwise, gets the value of the current array element as a Boolean.
public Method | GetBytes | If the array consists of OBJECT TYPE elements, reads a stream of bytes from the specified property of the current array element, otherwise, reads a stream of bytes from the current array element.
public Method | GetChar | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single character, otherwise, gets the value of the current array element as a single character.
public Method | GetChars | If the array consists of OBJECT TYPE elements, reads a stream of characters from the specified property of the current array element, otherwise, reads a stream of characters from the current array element.
public Method | GetData | If the array consists of OBJECT TYPE elements, gets nested DataReader for the specified property of the current current array element, otherwise, gets the name of the source data type.
public Method | GetDataTypeName | If the array consists of OBJECT TYPE elements, gets the name of the source data type of the current array element, otherwise, gets the name of the source data type.
public Method | GetDateTime | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.DateTime object, otherwise, gets the value of the current array element as a System.DateTime object.
public Method | GetDecimal | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.Decimal object, otherwise, gets the value of the current array element as a System.Decimal object.
public Method | GetDouble | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a double-precision floating point number, otherwise, gets the value of the current array element as a double-precision floating point number.
public Method | GetEnumerator | Gets the enumerator for the ORACLE ARRAY elements.
public Method | GetFieldType | If the array consists of OBJECT TYPE elements, gets the System.Type that is the data type of the specified property of the current array element, otherwise, the System.Type that is the data type of the current array element.
public Method | GetFloat | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single-precision floating point number, otherwise, gets the value of the current array element as a single-precision floating point number.
public Method | GetGuid | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a globally-unique identifier (GUID), otherwise, gets the value of the current array element as a globally-unique identifier.
public Method | GetInt16 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 16-bit signed integer, otherwise, gets the value of the current array element as a 16-bit signed integer.
public Method | GetInt32 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 32-bit signed integer, otherwise, gets the value of the current array element as a 32-bit signed integer.
public Method | GetInt64 | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 64-bit signed integer, otherwise, gets the value of the current array element as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | If the array consists of OBJECT TYPE elements, gets the name of the specified property of the current array element.
public Method | GetOracleArray | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleArray object, otherwise, gets the value of the current array element as an OracleArray object.
public Method | GetOracleBFile | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBFile object, otherwise, gets the value of the current array element as an OracleBFile object.
public Method | GetOracleBinary | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBinary object, otherwise, gets the value of the current array element as an OracleBinary object.
public Method | GetOracleCursor | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleCursor object, otherwise, gets the value of the current array element as an OracleCursor object.
public Method | GetOracleDate | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleDate object, otherwise, gets the value of the current array element as an OracleDate object.
public Method | GetOracleIntervalDS | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalDS object, otherwise, gets the value of the current array element as an OracleIntervalDS object.
public Method | GetOracleIntervalYM | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalYM object, otherwise, gets the value of the current array element as an OracleIntervalYM object.
public Method | GetOracleLob | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleLob object, otherwise, gets the value of the current array element as an OracleLob object.
public Method | GetOracleMonthSpan | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleMonthSpan object, otherwise, gets the value of the current array element as an OracleMonthSpan object.
public Method | GetOracleNumber | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleNumber object, otherwise, gets the value of the current array element as an OracleNumber object.
public Method | GetOracleObject | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleObject object, otherwise, gets the value of the current array element as an OracleObject object.
public Method | GetOracleRef | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleRef object, otherwise, gets the value of the current array element as an OracleRef object.
public Method | GetOracleString | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleString object, otherwise, gets the value of the current array element as an OracleString object.
public Method | GetOracleTable | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTable object, otherwise, gets the value of the current array element as an OracleTable object.
public Method | GetOracleTimeSpan | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTimeSpan object, otherwise, gets the value of the current array element as an OracleTimeSpan object.
public Method | GetOracleValue | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element in its Oracle format wrapped by dotConnect for Oracle, otherwise, gets the value of the current array element in its Oracle format wrapped by dotConnect for Oracle.
public Method | GetOrdinal | Gets the ordinal of the specified OBJECT TYPE property.
public Method | GetSchemaTable | Gets array metadata. If array consists of OBJECT TYPE elements, object type properties correspond to table columns. Otherwise, System.Data.DataTable has only one column with the same datatype as array elements.
public Method | GetString | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a string, otherwise, gets the value of the current array element as a string.
public Method | GetValue | If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Method | GetValues | Gets OBJECT TYPE properties of the current array element, if the array consists of the OBJECT TYPE elements. Otherwise, gets current array element as a single value.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | If the array consists of OBJECT TYPE elements, indicates whether the specified property of the current array element is null, otherwise, indicates wether the current array element is null.
public Method | NextResult | Advances the data reader to the next result, when reading the results of batch SQL statements.
public Method | Read | Advances the T:DevartData.Oracle.OracleArrayDataReader to the next array element.
Top

See Also

Reference

OracleArrayDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : Close Method

Closes the OracleArrayDataReader object.

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()

Remarks

You must explicitly call the Close method when you are finished using the OracleArrayDataReader to use the associated OracleConnection for any other purpose.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members
OracleConnection Class
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBoolean Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetBoolean Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Syntax

Visual Basic (Declaration)
Public Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
C#
public bool GetBoolean(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a Boolean. Otherwise, the value of the current array element as a Boolean.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetByte Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetByte Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Byte, otherwise, gets the value of the current array element as a Boolean.

Syntax

Visual Basic (Declaration)
Public Function GetByte( _
   ByVal i As Integer _
) As Byte
C#
public byte GetByte(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a Byte. Otherwise, the value of the current array element as a Byte.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetBytes Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferoffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.
If the array consists of OBJECT TYPE elements, reads a stream of bytes from the specified property of the current array element, otherwise, reads a stream of bytes from the current array element.

Syntax

Visual Basic (Declaration)
Public Function GetBytes( _
   ByVal i As Integer, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Byte, _
   ByVal bufferoffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public long GetBytes(
   int i,
   long fieldOffset,
   byte[] buffer,
   int bufferoffset,
   int length
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferoffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.

Return Value

The actual number of bytes read.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChar Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetChar Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single character, otherwise, gets the value of the current array element as a single character.

Syntax

Visual Basic (Declaration)
Public Function GetChar( _
   ByVal i As Integer _
) As Char
C#
public char GetChar(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a single character. Otherwise, the value of the current array element as a single character.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetChars Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
fieldoffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferoffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.
If the array consists of OBJECT TYPE elements, reads a stream of characters from the specified property of the current array element, otherwise, reads a stream of characters from the current array element.

Syntax

Visual Basic (Declaration)
Public Function GetChars( _
   ByVal i As Integer, _
   ByVal fieldoffset As Long, _
   ByVal buffer() As Char, _
   ByVal bufferoffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public long GetChars(
   int i,
   long fieldoffset,
   char[] buffer,
   int bufferoffset,
   int length
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
fieldoffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferoffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.

Return Value

The actual number of bytes read.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetData Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetData Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets nested DataReader for the specified property of the current current array element, otherwise, gets the name of the source data type.

Syntax

Visual Basic (Declaration)
Public Function GetData( _
   ByVal i As Integer _
) As IDataReader
C#
public IDataReader GetData(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The name of the source data type of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements. Otherwise, the name of the source data type of the current array element.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetDataTypeName Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the name of the source data type of the current array element, otherwise, gets the name of the source data type.

Syntax

Visual Basic (Declaration)
Public Function GetDataTypeName( _
   ByVal i As Integer _
) As String
C#
public string GetDataTypeName(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The name of the source data type of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements. Otherwise, the name of the source data type of the current array element.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTime Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetDateTime Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.DateTime object, otherwise, gets the value of the current array element as a System.DateTime object.

Syntax

Visual Basic (Declaration)
Public Function GetDateTime( _
   ByVal i As Integer _
) As Date
C#
public DateTime GetDateTime(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a System.DateTime object. Otherwise, the value of the current array element as a System.DateTime object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDecimal Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetDecimal Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a System.Decimal object, otherwise, gets the value of the current array element as a System.Decimal object.

Syntax

Visual Basic (Declaration)
Public Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
C#
public decimal GetDecimal(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a System.Decimal object. Otherwise, the value of the current array element as a System.Decimal object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDouble Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetDouble Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a double-precision floating point number, otherwise, gets the value of the current array element as a double-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Function GetDouble( _
   ByVal i As Integer _
) As Double
C#
public double GetDouble(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a double-precision floating point number. Otherwise, the value of the current array element as a double-precision floating point number.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetEnumerator Method

Gets the enumerator for the ORACLE ARRAY elements.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
C#
public IEnumerator GetEnumerator()

Return Value

The enumerator for the ORACLE ARRAY elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetFieldType Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the System.Type that is the data type of the specified property of the current array element, otherwise, the System.Type that is the data type of the current array element.

Syntax

Visual Basic (Declaration)
Public Function GetFieldType( _
   ByVal i As Integer _
) As Type
C#
public Type GetFieldType(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The System.Type that is the data type of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a single character. Otherwise, the System.Type that is the data type of the current array element as a single character.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFloat Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetFloat Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a single-precision floating point number, otherwise, gets the value of the current array element as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Function GetFloat( _
   ByVal i As Integer _
) As Single
C#
public float GetFloat(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a single-precision floating point number. Otherwise, the value of the current array element as a single-precision floating point number.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetGuid Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetGuid Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a globally-unique identifier (GUID), otherwise, gets the value of the current array element as a globally-unique identifier.

Syntax

Visual Basic (Declaration)
Public Function GetGuid( _
   ByVal i As Integer _
) As Guid
C#
public Guid GetGuid(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a globally-unique identifier (GUID). Otherwise, the value of the current array element as a globally-unique identifier.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt16 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetInt16 Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 16-bit signed integer, otherwise, gets the value of the current array element as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function GetInt16( _
   ByVal i As Integer _
) As Short
C#
public short GetInt16(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a 16-bit signed integer. Otherwise, the value of the current array element as a 16-bit signed integer.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt32 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetInt32 Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 32-bit signed integer, otherwise, gets the value of the current array element as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function GetInt32( _
   ByVal i As Integer _
) As Integer
C#
public int GetInt32(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a 32-bit signed integer. Otherwise, the value of the current array element as a 32-bit signed integer.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt64 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetInt64 Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a 64-bit signed integer, otherwise, gets the value of the current array element as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Function GetInt64( _
   ByVal i As Integer _
) As Long
C#
public long GetInt64(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a 64-bit signed integer. Otherwise, the value of the current array element as a 64-bit signed integer.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetName Method

i
Zero-based ordinal of the OBJECT TYPE property.
If the array consists of OBJECT TYPE elements, gets the name of the specified property of the current array element.

Syntax

Visual Basic (Declaration)
Public Function GetName( _
   ByVal i As Integer _
) As String
C#
public string GetName(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property.

Return Value

The name of the specified property of the current array element, if the array consists of OBJECT TYPE elements as a Boolean. Otherwise, the result of the method is undefined.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleArray Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleArray object, otherwise, gets the value of the current array element as an OracleArray object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleArray( _
   ByVal i As Integer _
) As OracleArray
C#
public OracleArray GetOracleArray(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleArray object. Otherwise, the value of the current array element as an OracleArray object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBFile Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleBFile Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBFile object, otherwise, gets the value of the current array element as an OracleBFile object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleBFile( _
   ByVal i As Integer _
) As OracleBFile
C#
public OracleBFile GetOracleBFile(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleBFile object. Otherwise, the value of the current array element as an OracleBFile object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBinary Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleBinary Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleBinary object, otherwise, gets the value of the current array element as an OracleBinary object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleBinary( _
   ByVal i As Integer _
) As OracleBinary
C#
public OracleBinary GetOracleBinary(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleBinary object. Otherwise, the value of the current array element as an OracleBinary object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleCursor Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleCursor Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleCursor object, otherwise, gets the value of the current array element as an OracleCursor object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleCursor( _
   ByVal i As Integer _
) As OracleCursor
C#
public OracleCursor GetOracleCursor(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleCursor object. Otherwise, the value of the current array element as an OracleCursor object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleDate Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleDate object, otherwise, gets the value of the current array element as an OracleDate object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleDate( _
   ByVal i As Integer _
) As OracleDate
C#
public OracleDate GetOracleDate(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleDate object. Otherwise, the value of the current array element as an OracleDate object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalDS Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleIntervalDS Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalDS object, otherwise, gets the value of the current array element as an OracleIntervalDS object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleIntervalDS( _
   ByVal i As Integer _
) As OracleIntervalDS
C#
public OracleIntervalDS GetOracleIntervalDS(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleIntervalDS object. Otherwise, the value of the current array element as an OracleIntervalDS object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalYM Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleIntervalYM Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleIntervalYM object, otherwise, gets the value of the current array element as an OracleIntervalYM object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleIntervalYM( _
   ByVal i As Integer _
) As OracleIntervalYM
C#
public OracleIntervalYM GetOracleIntervalYM(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleIntervalYM object. Otherwise, the value of the current array element as an OracleIntervalYM object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleLob Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleLob Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleLob object, otherwise, gets the value of the current array element as an OracleLob object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleLob( _
   ByVal i As Integer _
) As OracleLob
C#
public OracleLob GetOracleLob(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleLob object. Otherwise, the value of the current array element as an OracleLob object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleMonthSpan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleMonthSpan Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleMonthSpan object, otherwise, gets the value of the current array element as an OracleMonthSpan object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleMonthSpan( _
   ByVal i As Integer _
) As OracleMonthSpan
C#
public OracleMonthSpan GetOracleMonthSpan(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleMonthSpan object. Otherwise, the value of the current array element as an OracleMonthSpan object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleNumber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleNumber Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleNumber object, otherwise, gets the value of the current array element as an OracleNumber object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleNumber( _
   ByVal i As Integer _
) As OracleNumber
C#
public OracleNumber GetOracleNumber(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleNumber object. Otherwise, the value of the current array element as an OracleNumber object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleObject Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleObject object, otherwise, gets the value of the current array element as an OracleObject object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleObject( _
   ByVal i As Integer _
) As OracleObject
C#
public OracleObject GetOracleObject(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleObject object. Otherwise, the value of the current array element as an OracleObject object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleRef Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleRef Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleRef object, otherwise, gets the value of the current array element as an OracleRef object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleRef( _
   ByVal i As Integer _
) As OracleRef
C#
public OracleRef GetOracleRef(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleRef object. Otherwise, the value of the current array element as an OracleRef object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleString Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleString object, otherwise, gets the value of the current array element as an OracleString object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleString( _
   ByVal i As Integer _
) As OracleString
C#
public OracleString GetOracleString(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleString object. Otherwise, the value of the current array element as an OracleString object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleTable Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTable object, otherwise, gets the value of the current array element as an OracleTable object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleTable( _
   ByVal i As Integer _
) As OracleTable
C#
public OracleTable GetOracleTable(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleTable object. Otherwise, the value of the current array element as an OracleTable object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTimeSpan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleTimeSpan Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as an OracleTimeSpan object, otherwise, gets the value of the current array element as an OracleTimeSpan object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleTimeSpan( _
   ByVal i As Integer _
) As OracleTimeSpan
C#
public OracleTimeSpan GetOracleTimeSpan(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as an OracleTimeSpan object. Otherwise, the value of the current array element as an OracleTimeSpan object.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOracleValue Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element in its Oracle format wrapped by dotConnect for Oracle, otherwise, gets the value of the current array element in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Function GetOracleValue( _
   ByVal i As Integer _
) As Object
C#
public object GetOracleValue(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements, in its Oracle format wrapped by dotConnect for Oracle. Otherwise, the value of the current array element in its Oracle format wrapped by dotConnect for Oraclein its Oracle format wrapped by dotConnect for Oraclein its Oracle format wrapped by dotConnect for Oracle.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOrdinal Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetOrdinal Method

name
Name of the property to get the ordinal of.
Gets the ordinal of the specified OBJECT TYPE property.

Syntax

Visual Basic (Declaration)
Public Function GetOrdinal( _
   ByVal name As String _
) As Integer
C#
public int GetOrdinal(
   string name
)

Parameters

name
Name of the property to get the ordinal of.

Return Value

Ordinal of the specified OBJECT TYPE property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSchemaTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetSchemaTable Method

Gets array metadata. If array consists of OBJECT TYPE elements, object type properties correspond to table columns. Otherwise, System.Data.DataTable has only one column with the same datatype as array elements.

Syntax

Visual Basic (Declaration)
Public Function GetSchemaTable() As DataTable
C#
public DataTable GetSchemaTable()

Return Value

Array metadata as a System.Data.DataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetString Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a string, otherwise, gets the value of the current array element as a string.

Syntax

Visual Basic (Declaration)
Public Function GetString( _
   ByVal i As Integer _
) As String
C#
public string GetString(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a string. Otherwise, the value of the current array element as a string.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetValue Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Syntax

Visual Basic (Declaration)
Public Function GetValue( _
   ByVal i As Integer _
) As Object
C#
public object GetValue(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a Boolean. Otherwise, the value of the current array element as a Boolean.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValues Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : GetValues Method

values
An array of System.Object into which to copy the current array element properties.
Gets OBJECT TYPE properties of the current array element, if the array consists of the OBJECT TYPE elements. Otherwise, gets current array element as a single value.

Syntax

Visual Basic (Declaration)
Public Function GetValues( _
   ByVal values() As Object _
) As Integer
C#
public int GetValues(
   object[] values
)

Parameters

values
An array of System.Object into which to copy the current array element properties.

Return Value

The number of returned instances of System.Object in the array.

Remarks

For most applications, the M:OracleArrayDataReader.GetValues method provides an efficient way for retrieving all properties, rather than retrieving each property individually.

You can pass an System.Object array that contains fewer than the number of columns contained in the resulting row. Only the amount of data the System.Object array holds is copied to the array. You can also pass an System.Object array whose length is more than the number of columns contained in the resulting row.

This method returns System.DBNull for null database columns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : IsDBNull Method

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, indicates whether the specified property of the current array element is null, otherwise, indicates wether the current array element is null.

Syntax

Visual Basic (Declaration)
Public Function IsDBNull( _
   ByVal i As Integer _
) As Boolean
C#
public bool IsDBNull(
   int i
)

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when array consists of elements with type other than OBJECT TYPE.

Return Value

True if the current array element property, having the specified index, is null, or if the array consists of elements other than OBJECT TYPE and the current array element is null. Otherwise, false.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NextResult Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : NextResult Method

Advances the data reader to the next result, when reading the results of batch SQL statements.

Syntax

Visual Basic (Declaration)
Public Function NextResult() As Boolean
C#
public bool NextResult()

Return Value

true if there are more result sets; otherwise, false.

Remarks

Used to process multiple results, which can be generated by executing batch SQL statements.

By default, the T:DevartData.Oracle.OracleArrayDataReader is positioned on the first result.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : Read Method

Advances the T:DevartData.Oracle.OracleArrayDataReader to the next array element.

Syntax

Visual Basic (Declaration)
Public Function Read() As Boolean
C#
public bool Read()

Return Value

true if there are more rows; otherwise, false.

Remarks

The default position of the T:DevartData.Oracle.OracleArrayDataReader is prior to the first record. Therefore, you must call the Read method to begin accessing any data.

While the T:DevartData.Oracle.OracleArrayDataReader is in use, the associated T:DevartData.Oracle.OracleConnection is busy serving it until you call M:DevartData.Oracle.OracleArrayDataReader.Close.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleArrayDataReader Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleArrayDataReader Class

For a list of all members of this type, see OracleArrayDataReader members.

Public Properties

 | Name | Description
public Property | Depth | Do not use.
public Property | FieldCount | If the array consists of OBJECT TYPE elements, gets number of array element properties.
public Property | IsClosed | Indicates whether the OracleArrayDataReader was closed.
public Property | Item | Overloaded. If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
public Property | RecordsAffected | Do not use.
Top

See Also

Reference

OracleArrayDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Depth Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : Depth Property

Do not use.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Depth As Integer
C#
public int Depth {get;}

Property Value

Always 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FieldCount Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : FieldCount Property

If the array consists of OBJECT TYPE elements, gets number of array element properties.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FieldCount As Integer
C#
public int FieldCount {get;}

Property Value

Number of array element properties if the array consists of OBJECT TYPE elements, otherwise 1.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsClosed Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : IsClosed Property

Indicates whether the OracleArrayDataReader was closed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
C#
public bool IsClosed {get;}

Property Value

True if the T:DevartData.Oracle.OracleArrayDataReader was closed (Close method was called); otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : Item Property

If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Overload List

Overload | Description
Item(String) | If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.
Item(Int32) | If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class > Item Property : Item(String) Property

name
Name of the OBJECT TYPE property. If the array consists of elements with type other than OBJECT TYPE, and this parameter is used, System.IndexOutOfRangeException is thrown.
If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Object
C#
public object Item(
   string name
) {get;}

Parameters

name
Name of the OBJECT TYPE property. If the array consists of elements with type other than OBJECT TYPE, and this parameter is used, System.IndexOutOfRangeException is thrown.

Property Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a Boolean. Otherwise, the value of the current array element as a Boolean.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class > Item Property : Item(Int32) Property

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when the array consists of elements with type other than OBJECT TYPE.
If the array consists of OBJECT TYPE elements, gets or sets the value of the specified property of the current array element, as a Boolean, otherwise, gets the value of the current array element as a Boolean.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal i As Integer _
) As Object
C#
public object Item(
   int i
) {get;}

Parameters

i
Zero-based ordinal of the OBJECT TYPE property. Ignored when the array consists of elements with type other than OBJECT TYPE.

Property Value

The value of the current array element property, having the specified index, if the array consists of OBJECT TYPE elements as a Boolean. Otherwise, the value of the current array element as a Boolean.

Remarks

If the array consists of OBJECT TYPE elements and i is equal or more than FieldCount, or it is less than zero, System.ArgumentOutOfRangeException is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecordsAffected Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleArrayDataReader Class : RecordsAffected Property

Do not use.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecordsAffected As Integer
C#
public int RecordsAffected {get;}

Property Value

Always 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleArrayDataReader Class
OracleArrayDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAttribute Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttribute Class

Represents an attribute of the OracleObject type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleAttribute

Syntax

Visual Basic (Declaration)
Public Class OracleAttribute
   Inherits System.MarshalByRefObject
C#
public class OracleAttribute : System.MarshalByRefObject

Remarks

Describes an attribute of the object type. The OracleAttribute object provides only metadata of the type attribute, not the attribute value for the particular object. To get the attribute value, the OracleObject.Item property should be used; note that one of its overloads takes an OracleAttribute object as a parameter.

The full collection of type's attributes may be received from the OracleType.Attributes property of the OracleType object.

Example

This example demonstrates how to retrieve OracleType object from server and display its attributes. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Address");
  while (dataReader.Read()) {
    OracleObject oraObj = dataReader.GetOracleObject(index);
    OracleType oraType = dataReader.GetObjectType(index);
    if (!oraObj.IsNull && oraType != null) {
      Console.WriteLine(dataReader.GetString(1) +" - " + dataReader.GetString(3));
      Console.WriteLine("Adress:");
      for (int i = 0; i < oraType.Attributes.Count; i++)
        Console.WriteLine( "\t" + oraObj[oraType.Attributes[i]]);
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Address")
  While dataReader.Read()
    Dim oraObj As OracleObject = dataReader.GetOracleObject(index)
    Dim oraType As OracleType = dataReader.GetObjectType(index)
    If Not oraObj.IsNull And Not oraType Is Nothing Then
      Console.WriteLine(dataReader.GetString(1) & " - " & dataReader.GetString(3))
      Console.WriteLine("Adress:")
      Dim I As Integer
      For I = 0 To oraType.Attributes.Count - 1
        Console.WriteLine(Chr(9) & oraObj(oraType.Attributes(I)))
      Next I
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAttribute Members
Devart.Data.Oracle Namespace
OracleAttributeCollection Class
Item(OracleAttribute) Property


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAttribute Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleAttribute Class

The following tables list the members exposed by OracleAttribute.

Public Properties

 | Name | Description
public Property | DbType | Gets the OracleDbType of the specified attribute.
public Property | Name | Gets the name of the OracleAttribute.
public Property | ObjectType | Gets an OracleType of the specified attribute.
public Property | Precision | Gets the maximum number of digits used to represent the attribute value.
public Property | Scale | Gets the number of decimal places to which attribute value is resolved.
public Property | TypeName | Gets a name for the Oracle object type.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAttribute Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttribute Class

For a list of all members of this type, see OracleAttribute members.

Public Properties

 | Name | Description
public Property | DbType | Gets the OracleDbType of the specified attribute.
public Property | Name | Gets the name of the OracleAttribute.
public Property | ObjectType | Gets an OracleType of the specified attribute.
public Property | Precision | Gets the maximum number of digits used to represent the attribute value.
public Property | Scale | Gets the number of decimal places to which attribute value is resolved.
public Property | TypeName | Gets a name for the Oracle object type.
Top

See Also

Reference

OracleAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : DbType Property

Gets the OracleDbType of the specified attribute.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbType As OracleDbType
C#
public OracleDbType DbType {get;}

Property Value

One of the OracleDbType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : Name Property

Gets the name of the OracleAttribute.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of the OracleAttribute.

Remarks

Use name of the attribute to get OracleAttribute description and its values by Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : ObjectType Property

Gets an OracleType of the specified attribute.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As OracleType
C#
public OracleType ObjectType {get;}

Property Value

An OracleType of the specified attribute if its type is Oracle object type; otherwise, null.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Precision Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : Precision Property

Gets the maximum number of digits used to represent the attribute value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Precision As Integer
C#
public int Precision {get;}

Property Value

The maximum number of digits used to represent the attribute value.

Remarks

The Precision property is only used for numeric attributes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Scale Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : Scale Property

Gets the number of decimal places to which attribute value is resolved.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Scale As Integer
C#
public int Scale {get;}

Property Value

The number of decimal places to which attribute value is resolved.

Remarks

The Scale property is only used for numeric attributes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttribute Class : TypeName Property

Gets a name for the Oracle object type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName {get;}

Property Value

System.String representing a name for the Oracle object type.

Remarks

You can describe attribute of OracleObject type using this property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttribute Class
OracleAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAttributeCollection Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttributeCollection Class

Represents attributes of Oracle object type.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Data.Oracle.OracleAttributeCollection

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleAttributeCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public sealed class OracleAttributeCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

An Devart.Data.Oracle.OracleAttributeCollection represents describe information for object type. Collection can be used only for reading.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAttributeCollection Members
Devart.Data.Oracle Namespace
OracleAttribute Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleAttributeCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleAttributeCollection Class

The following tables list the members exposed by OracleAttributeCollection.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets the OracleAttribute with the specified name.
Top

Public Methods

 | Name | Description
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleAttributeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleAttributeCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttributeCollection Class

For a list of all members of this type, see OracleAttributeCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets the OracleAttribute with the specified name.
Top

See Also

Reference

OracleAttributeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttributeCollection Class : Item Property

Gets the OracleAttribute with the specified name.

Overload List

Overload | Description
Item(String) | Gets the OracleAttribute with the specified name.
Item(Int32) | Gets the OracleAttribute at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttributeCollection Class
OracleAttributeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttributeCollection Class > Item Property : Item(String) Property

name
The name of the attribute to retrieve. Note that it is case-sensitive.
Gets the OracleAttribute with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As OracleAttribute
C#
public OracleAttribute Item(
   string name
) {get;}

Parameters

name
The name of the attribute to retrieve. Note that it is case-sensitive.

Property Value

The OracleAttribute with the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttributeCollection Class
OracleAttributeCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAttributeCollection Class > Item Property : Item(Int32) Property

i
The zero-based index of the parameter to retrieve.
Gets the OracleAttribute at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal i As Integer _
) As OracleAttribute
C#
public OracleAttribute Item(
   int i
) {get;}

Parameters

i
The zero-based index of the parameter to retrieve.

Property Value

The OracleAttribute at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAttributeCollection Class
OracleAttributeCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBFile Class

Represents a managed OracleBFile object to work with the Oracle BFILE data type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Devart.Data.Oracle.OracleLob
Devart.Data.Oracle.OracleBFile

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleBFile
   Inherits OracleLob
   Implements INullable, ICloneable, IComparable, IDisposable
C#
public sealed class OracleBFile : OracleLob, INullable, ICloneable, IComparable, IDisposable

Remarks

The Oracle BFILE data type represents a reference to the physical file in the operating system where Oracle is installed. Maximum size of the file is 4 gigabytes. The OracleDbType.BFile data type cannot be modified and provides read-only access to data. So write-oriented methods of OracleBFile class are not supported.

To read data use Read and OracleLob.Seek methods.

Example

The following sample shows how the OracleBFile class can be used. We insert a BFile object to the database and then print the content of the corresponding file on the physical drive. To run the sample, you need to create the BFileTable table first:

CREATE TABLE BFileTable (
  id NUMBER,
  bf BFILE)
C#csharp Copy Code
// Open a connection
OracleConnection con = new OracleConnection("Server = Ora; User Id = Scott; Password = tiger;");
con.Open();

OracleCommand com = new OracleCommand();
com.Connection = con;

// Create an Oracle directory corresponding to the folder containing the file.
com.CommandText = "CREATE OR REPLACE DIRECTORY Images as 'D:\\images\\'";
com.ExecuteNonQuery();

// Create an OracleBFile object.
// Note that the directory name should be in upper case.
// Otherwise, it will be case-sensitive and may cause errors.
OracleBFile bFile = new OracleBFile(con, "IMAGES", "image001.jpg");

// Insert the OracleBFile object to the database.
com.CommandText = "INSERT INTO BFileTable VALUES (1, :bfile)";
com.Parameters.Add(new OracleParameter("bfile", bFile));
com.ExecuteNonQuery();

// Retrieve data from the table.
com.Parameters.Clear();
com.CommandText = "SELECT * FROM BFileTable";
OracleDataReader reader = com.ExecuteReader();

while (reader.Read()) {

        // Get BFiles from the reader and print a part of their content.
        bFile = reader.GetOracleBFile(1);
        bFile.OpenFile();

        byte[] buffer = new byte[100];
        bFile.Read(buffer, 0, 100);
        foreach(byte bt in buffer)
                   Console.Write(bt + " ");

         Console.WriteLine();

        bFile.Close();
}
C#Visual Basic Copy Code
' Open a connection
Dim con = New OracleConnection("Server = Ora; User Id = Scott; Password = tiger;")
con.Open()

Dim com = New OracleCommand()
com.Connection = con

' Create an Oracle directory corresponding to the folder containing the file.
com.CommandText = "CREATE OR REPLACE DIRECTORY Images as 'D:\\Images\\'"
com.ExecuteNonQuery()

' Create an OracleBFile object.
' Note that the directory name should be in upper case.
' Otherwise, it will be case-sensitive and may cause errors.
Dim bFile As OracleBFile = New OracleBFile(con, "IMAGES", "image001.jpg")

' Insert the OracleBFile object to the database.
com.CommandText = "INSERT INTO BFileTable VALUES (1, :bfile)"
com.Parameters.Add(New OracleParameter("bfile", bFile))
com.ExecuteNonQuery()

' Retrieve data from the table.
com.Parameters.Clear()
com.CommandText = "SELECT * FROM BFileTable"
Dim reader = com.ExecuteReader()

While reader.Read()

    ' Get BFiles from the reader and print a part of their content.
    bFile = reader.GetOracleBFile(1)
    bFile.OpenFile()

    Dim buffer As Byte() = New Byte(100) {}
    bFile.Read(buffer, 0, 100)
    For Each bt As Byte In buffer
        Console.Write(bt & " ")
    Next

    Console.WriteLine()

    bFile.Close()

End While

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleBFile Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleBFile Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleBFile Class

The following tables list the members exposed by OracleBFile.

Public Constructors

 | Name | Description
public Constructor | OracleBFile Constructor | Overloaded. Initializes a new instance of the OracleBFile class.Initializes a new instance of the OracleBFile class.Initializes a new instance of the OracleBFile class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null OracleBFile object not associated with any physical file at the server.
Top

Public Properties

 | Name | Description
public Property | Cached | Specifies whether the OracleLob is cached. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Inherited from System.IO.Stream)
public Property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Inherited from System.IO.Stream)
public Property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always false because OracleBFile is read-only.
public Property | ChunkSize | Gets a value indicating the minimum number of bytes used during read/write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used by this instance of the OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | DirectoryName | Gets the name of the directory with which an OracleBFile object is associated.
public Property | FileExists | Gets a value indicating whether a physical file specified by the DirectoryName and FileName exists.
public Property | FileName | Gets the name of a physical file with which an OracleBFile object is associated.
public Property | IsBatched | Gets a value indicating whether the application called the OracleLob.BeginBatch method. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsEmpty | Gets a value indicating whether the OracleLob is empty or not. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsNull | Gets a value indicating whether the OracleLob is a OracleLob.Null stream. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsOpen | Determines whether the physical file has been opened by calling OpenFile method.
public Property | IsTemporary | Gets a value indicating whether the OracleLob is a temporary LOB. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Inherited from System.IO.Stream)
public Property | LobType | Gets the LOB data type. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Inherited from System.IO.Stream)
public Property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from System.IO.Stream)
public Property | Value | Gets the value of the OracleLob object. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | Append | Overloaded. Appends the supplied data to the current OracleLob instance. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | BeginBatch | Overloaded. Prevents server-side triggers from firing while performing multiple write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | BeginRead | Begins an asynchronous read operation. (Inherited from System.IO.Stream)
public Method | BeginWrite | Begins an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Clone | Overridden. Creates a copy of the current OracleBFile object associated with the same physical file as the original.
public Method | Close | Overridden. Closes the current stream and releases any resources associated with it.
public Method | CloseFile | Closes the physical file associated with the OracleBFile object opened before by OpenFile method.
public Method | CopyTo | Overloaded. Copies data from the OracleBFile to a destination OracleLob.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleLob object. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | EndBatch | Allows server-side triggers to resume firing after performing multiple write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from System.IO.Stream)
public Method | EndWrite | Ends an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Erase | Overloaded. Erases data from the specified OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from System.IO.Stream)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleLob object is equal to the current OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | OpenFile | Opens the file with which an OracleBFile object is associated.
public Method | Read | Overloaded. Overridden. Reads a sequence of bytes from the current OracleBFile stream and advances the position within the stream by the number of bytes read.
public Method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from System.IO.Stream)
public Method | Seek | When overridden in a derived class, sets the position within the current stream. (Inherited from System.IO.Stream)
public Method | SetFileName | Binds the OracleBFile object to a different file in the operating system.
public Method | SetLength | When overridden in a derived class, sets the length of the current stream. (Inherited from System.IO.Stream)
public Method | Write | Overloaded. When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from System.IO.Stream)
public Method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from System.IO.Stream)
Top

See Also

Reference

OracleBFile Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : OracleBFile Constructor

Initializes a new instance of the OracleBFile class.Initializes a new instance of the OracleBFile class.Initializes a new instance of the OracleBFile class.

Overload List

Overload | Description
OracleBFile Constructor() | Initializes a new instance of the OracleBFile class.
OracleBFile Constructor(String,String) | Initializes a new instance of the OracleBFile class with the specified name of the file and directory.
OracleBFile Constructor(OracleConnection) | Initializes a new instance of the OracleBFile class with the specified OracleConnection.
OracleBFile Constructor(OracleConnection,String,String) | Initializes a new instance of the OracleBFile class with the specified OracleConnection, name of the file and directory.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > OracleBFile Constructor : OracleBFile Constructor()

Initializes a new instance of the OracleBFile class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleBFile()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Constructor(String,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > OracleBFile Constructor : OracleBFile Constructor(String,String)

directory
Name of the directory with which an OracleBFile object is associated.
fileName
The name of a physical file with which an OracleBFile object is associated.
Initializes a new instance of the OracleBFile class with the specified name of the file and directory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal directory As String, _
   ByVal fileName As String _
)
C#
public OracleBFile(
   string directory,
   string fileName
)

Parameters

directory
Name of the directory with which an OracleBFile object is associated.
fileName
The name of a physical file with which an OracleBFile object is associated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Constructor(OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > OracleBFile Constructor : OracleBFile Constructor(OracleConnection)

connection
OracleConnection to use.
Initializes a new instance of the OracleBFile class with the specified OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection _
)
C#
public OracleBFile(
   OracleConnection connection
)

Parameters

connection
OracleConnection to use.

Remarks

The connection must be opened explicitly by the application. OracleBFile object does not open the connection implicitly.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBFile Constructor(OracleConnection,String,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > OracleBFile Constructor : OracleBFile Constructor(OracleConnection,String,String)

connection
OracleConnection to use.
directory
Name of the directory with which an OracleBFile object is associated.
fileName
The name of a physical file with which an OracleBFile object is associated.
Initializes a new instance of the OracleBFile class with the specified OracleConnection, name of the file and directory.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal directory As String, _
   ByVal fileName As String _
)
C#
public OracleBFile(
   OracleConnection connection,
   string directory,
   string fileName
)

Parameters

connection
OracleConnection to use.
directory
Name of the directory with which an OracleBFile object is associated.
fileName
The name of a physical file with which an OracleBFile object is associated.

Remarks

The connection must be opened explicitly by the application. OracleBFile object does not open the connection implicitly.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleBFile Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBFile Class

For a list of all members of this type, see OracleBFile members.

Public Methods

 | Name | Description
public Method | Append | Overloaded. Appends the supplied data to the current OracleLob instance. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | BeginBatch | Overloaded. Prevents server-side triggers from firing while performing multiple write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | BeginRead | Begins an asynchronous read operation. (Inherited from System.IO.Stream)
public Method | BeginWrite | Begins an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Clone | Overridden. Creates a copy of the current OracleBFile object associated with the same physical file as the original.
public Method | Close | Overridden. Closes the current stream and releases any resources associated with it.
public Method | CloseFile | Closes the physical file associated with the OracleBFile object opened before by OpenFile method.
public Method | CopyTo | Overloaded. Copies data from the OracleBFile to a destination OracleLob.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleLob object. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | EndBatch | Allows server-side triggers to resume firing after performing multiple write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from System.IO.Stream)
public Method | EndWrite | Ends an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Erase | Overloaded. Erases data from the specified OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from System.IO.Stream)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleLob object is equal to the current OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Method | OpenFile | Opens the file with which an OracleBFile object is associated.
public Method | Read | Overloaded. Overridden. Reads a sequence of bytes from the current OracleBFile stream and advances the position within the stream by the number of bytes read.
public Method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from System.IO.Stream)
public Method | Seek | When overridden in a derived class, sets the position within the current stream. (Inherited from System.IO.Stream)
public Method | SetFileName | Binds the OracleBFile object to a different file in the operating system.
public Method | SetLength | When overridden in a derived class, sets the length of the current stream. (Inherited from System.IO.Stream)
public Method | Write | Overloaded. When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from System.IO.Stream)
public Method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from System.IO.Stream)
Top

See Also

Reference

OracleBFile Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : Clone Method

Creates a copy of the current OracleBFile object associated with the same physical file as the original.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Clone() As Object
C#
public override object Clone()

Return Value

A new OracleBFile object associated with the same physical file as the original.

Remarks

Creates a new OracleBFile object with the properties that have the same values as those of the original object. However, changing properties of the new object has no influence on the values of the same properties of the original object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : Close Method

Closes the current stream and releases any resources associated with it.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
C#
public override void Close()

Remarks

After closing OracleBFile object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CloseFile Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : CloseFile Method

Closes the physical file associated with the OracleBFile object opened before by OpenFile method.

Syntax

Visual Basic (Declaration)
Public Sub CloseFile()
C#
public void CloseFile()

Remarks

Use CloseFile method to close the physical file associated with the OracleBFile object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : CopyTo Method

Copies data from the OracleBFile to a destination OracleLob.

Overload List

Overload | Description
CopyTo(OracleLob) | Copies data from the OracleBFile to an OracleLob.
CopyTo(OracleLob,Int64) | Copies data from the OracleBFile to an OracleLob with the specified destination offset.
CopyTo(Int64,OracleLob,Int64,Int64) | Copies data from the OracleBFile to an OracleLob with the specified amount of data, source offset and destination offset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(OracleLob) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > CopyTo Method : CopyTo(OracleLob) Method

dest
The OracleLob object to which the data is copied.
Copies data from the OracleBFile to an OracleLob.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function CopyTo( _
   ByVal dest As OracleLob _
) As Long
C#
public new long CopyTo(
   OracleLob dest
)

Parameters

dest
The OracleLob object to which the data is copied.

Return Value

The number of bytes copied.

Remarks

An OracleLob object to which the data is copied must have OracleDbType.Blob type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List
OracleLob Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(OracleLob,Int64) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > CopyTo Method : CopyTo(OracleLob,Int64) Method

dest
The OracleLob object to which the data is copied.
destOffset
The offset to which to copy.
Copies data from the OracleBFile to an OracleLob with the specified destination offset.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function CopyTo( _
   ByVal dest As OracleLob, _
   ByVal destOffset As Long _
) As Long
C#
public new long CopyTo(
   OracleLob dest,
   long destOffset
)

Parameters

dest
The OracleLob object to which the data is copied.
destOffset
The offset to which to copy.

Return Value

The number of bytes copied.

Remarks

An OracleLob object to which the data is copied must have OracleDbType.Blob type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List
OracleLob Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(Int64,OracleLob,Int64,Int64) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > CopyTo Method : CopyTo(Int64,OracleLob,Int64,Int64) Method

srcOffset
The offset from which to copy.
dest
The OracleLob object to which the data is copied.
destOffset
The offset to which to copy.
amount
The quantity of data, in bytes, to copy.
Copies data from the OracleBFile to an OracleLob with the specified amount of data, source offset and destination offset.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function CopyTo( _
   ByVal srcOffset As Long, _
   ByVal dest As OracleLob, _
   ByVal destOffset As Long, _
   ByVal amount As Long _
) As Long
C#
public new long CopyTo(
   long srcOffset,
   OracleLob dest,
   long destOffset,
   long amount
)

Parameters

srcOffset
The offset from which to copy.
dest
The OracleLob object to which the data is copied.
destOffset
The offset to which to copy.
amount
The quantity of data, in bytes, to copy.

Return Value

The number of bytes copied.

Remarks

An OracleLob object to which the data is copied must have OracleDbType.Blob type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List
OracleLob Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OpenFile Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : OpenFile Method

Opens the file with which an OracleBFile object is associated.

Syntax

Visual Basic (Declaration)
Public Sub OpenFile()
C#
public void OpenFile()

Remarks

Some operations on the OracleBFile object, such as Read, CopyTo require that the file be opened using OpenFile before the operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : Read Method

Reads a sequence of bytes from the current OracleBFile stream and advances the position within the stream by the number of bytes read.

Overload List

Overload | Description
Read(Byte[],Int32,Int32) | Reads a sequence of bytes from the current OracleBFile stream and advances the position within the stream by the number of bytes read.
Read(Char[],Int32,Int32) | Reads a sequence of characters from the current OracleLob stream and advances the position within the stream by the number of bytes read. (Inherited from Devart.Data.Oracle.OracleLob)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read(Byte[],Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The byte array buffer to be populated.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to read.
Reads a sequence of bytes from the current OracleBFile stream and advances the position within the stream by the number of bytes read.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)

Parameters

buffer
The byte array buffer to be populated.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to read.

Return Value

The total number of bytes read into the buffer.

Remarks

The Read method reads a maximum of count bytes from the current stream and stores them in buffer beginning at offset position. The current position within the stream is advanced by the number of bytes read. The Read method returns 0 if the position is at the end of the stream.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetFileName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : SetFileName Method

directory
The name of the directory that contains a physical file.
fileName
The name of the file in the operating system.
Binds the OracleBFile object to a different file in the operating system.

Syntax

Visual Basic (Declaration)
Public Sub SetFileName( _
   ByVal directory As String, _
   ByVal fileName As String _
)
C#
public void SetFileName(
   string directory,
   string fileName
)

Parameters

directory
The name of the directory that contains a physical file.
fileName
The name of the file in the operating system.

Remarks

To change name of the file or directory specified OracleBFile object must be within a transaction and must not be opened by OpenFile method.

If you change the name of the file or directory the current position resets to zero.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleBFile Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBFile Class

For a list of all members of this type, see OracleBFile members.

Public Properties

 | Name | Description
public Property | Cached | Specifies whether the OracleLob is cached. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Inherited from System.IO.Stream)
public Property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Inherited from System.IO.Stream)
public Property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always false because OracleBFile is read-only.
public Property | ChunkSize | Gets a value indicating the minimum number of bytes used during read/write operations. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used by this instance of the OracleLob. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | DirectoryName | Gets the name of the directory with which an OracleBFile object is associated.
public Property | FileExists | Gets a value indicating whether a physical file specified by the DirectoryName and FileName exists.
public Property | FileName | Gets the name of a physical file with which an OracleBFile object is associated.
public Property | IsBatched | Gets a value indicating whether the application called the OracleLob.BeginBatch method. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsEmpty | Gets a value indicating whether the OracleLob is empty or not. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsNull | Gets a value indicating whether the OracleLob is a OracleLob.Null stream. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | IsOpen | Determines whether the physical file has been opened by calling OpenFile method.
public Property | IsTemporary | Gets a value indicating whether the OracleLob is a temporary LOB. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Inherited from System.IO.Stream)
public Property | LobType | Gets the LOB data type. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Inherited from System.IO.Stream)
public Property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from System.IO.Stream)
public Property | Value | Gets the value of the OracleLob object. (Inherited from Devart.Data.Oracle.OracleLob)
public Property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from System.IO.Stream)
Top

See Also

Reference

OracleBFile Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CanWrite Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : CanWrite Property

Always false because OracleBFile is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
C#
public override bool CanWrite {get;}

Property Value

Always false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DirectoryName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : DirectoryName Property

Gets the name of the directory with which an OracleBFile object is associated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DirectoryName As String
C#
public string DirectoryName {get;}

Property Value

The name of the directory.

Remarks

The maximum length of a DirectoryName is 30 bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FileExists Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : FileExists Property

Gets a value indicating whether a physical file specified by the DirectoryName and FileName exists.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileExists As Boolean
C#
public bool FileExists {get;}

Property Value

true if a physical file containing OracleDbType.BFile data exists; otherwise false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FileName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : FileName Property

Gets the name of a physical file with which an OracleBFile object is associated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FileName As String
C#
public string FileName {get;}

Property Value

The name of the BFILE without the path.

Remarks

For Null, an empty string is returned.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsOpen Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : IsOpen Property

Determines whether the physical file has been opened by calling OpenFile method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsOpen As Boolean
C#
public bool IsOpen {get;}

Property Value

true if the OracleBFile is open; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleBFile Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBFile Class

For a list of all members of this type, see OracleBFile members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null OracleBFile object not associated with any physical file at the server.
Top

See Also

Reference

OracleBFile Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBFile Class : Null Field

Represents a null OracleBFile object not associated with any physical file at the server.

Syntax

Visual Basic (Declaration)
Public Shadows Shared ReadOnly Null As OracleBFile
C#
public new static readonly OracleBFile Null

Remarks

The Null field can be useful to check whether an OracleBFile object is associated with any physical file at the server.

Any attempt to perform a read operation on a Null object succeeds, but does not return any data. Any attempt to perform a write operation on a Null object generates an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBFile Class
OracleBFile Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleClientFactory Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleClientFactory Class

Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.

Inheritance Hierarchy

System.Object
System.Data.Common.DbProviderFactory
Devart.Data.Oracle.OracleProviderFactory
Devart.Data.Oracle.OracleClientFactory

Syntax

Visual Basic (Declaration)
Public Class OracleClientFactory
   Inherits OracleProviderFactory
   Implements IServiceProvider
C#
public class OracleClientFactory : OracleProviderFactory, IServiceProvider

Remarks

Implemented for compatibility with Oracle Client provider.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleClientFactory Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleClientFactory Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleClientFactory Class

The following tables list the members exposed by OracleClientFactory.

Public Constructors

 | Name | Description
public Constructor | OracleClientFactory Constructor | Creates an instance of OracleClientFactory.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleClientFactory.
Top

Public Properties

 | Name | Description
public Property | CanCreateDataSourceEnumerator | Specifies whether the specific System.Data.Common.DbProviderFactory supports the System.Data.Common.DbDataSourceEnumerator class. (Inherited from System.Data.Common.DbProviderFactory)
Top

Public Methods

 | Name | Description
public Method | CreateCommand | Returns a new instance of the provider's class that implements the System.Data.Common.DbCommand class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateCommandBuilder | Returns a new instance of the provider's class that implements the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateConnection | Returns a new instance of the provider's class that implements the System.Data.Common.DbConnection class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateConnectionStringBuilder | Returns a new instance of the provider's class that implements the System.Data.Common.DbConnectionStringBuilder class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateDataAdapter | Returns a new instance of the provider's class that implements the System.Data.Common.DbDataAdapter class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateDataSourceEnumerator | Returns a new instance of the provider's class that implements the System.Data.Common.DbDataSourceEnumerator class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateParameter | Returns a new instance of the provider's class that implements the System.Data.Common.DbParameter class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreatePermission | Returns a new instance of the provider's class that implements the provider's version of the System.Security.CodeAccessPermission class. (Inherited from System.Data.Common.DbProviderFactory)
Top

See Also

Reference

OracleClientFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleClientFactory Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleClientFactory Class : OracleClientFactory Constructor

Creates an instance of OracleClientFactory.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleClientFactory()

Remarks

Only one instance of OracleClientFactory can exist in the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleClientFactory Class
OracleClientFactory Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleClientFactory Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleClientFactory Class

For a list of all members of this type, see OracleClientFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleClientFactory.
Top

See Also

Reference

OracleClientFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Instance Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleClientFactory Class : Instance Field

Returns the instance of OracleClientFactory.

Syntax

Visual Basic (Declaration)
Public Shadows Shared Instance As OracleProviderFactory
C#
public new static OracleProviderFactory Instance

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleClientFactory Class
OracleClientFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommand Class

Represents a SQL statement, PL/SQL statement, or stored procedure to execute against Oracle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbCommand
Devart.Common.DbCommandBase
Devart.Data.Oracle.OracleCommand

Syntax

Visual Basic (Declaration)
Public Class OracleCommand
   Inherits Devart.Common.DbCommandBase
   Implements IComponent, IDbCommand, ICloneable, IDisposable
C#
public class OracleCommand : Devart.Common.DbCommandBase, IComponent, IDbCommand, ICloneable, IDisposable

Remarks

The OracleCommand class provides the following methods for executing commands against the Oracle database:
Item | Description
ExecuteReader | Executes commands that return rows.
ExecutePageReader | Returns a specific subset of rows when paging through the results of a query.
Devart.Common.DbCommandBase.ExecuteNonQuery | Executes SQL commands such as INSERT, DELETE, UPDATE or PL/SQL block.
ExecuteScalar | Retrieves a single value (for example, an aggregate value) from a data source.
ExecuteArray | Executes SQL statement specified number of times.

If execution of the command results in a fatal OracleException, the Devart.Data.Oracle.OracleConnection may close. However, the user can reopen the connection and continue.

This class supports cross-form data binding with the InterForm Technology.

Example

The following example uses the ExecuteReader method of OracleCommand, along with OracleDataReader and Devart.Data.Oracle.OracleConnection, to select rows from a table.
C#csharp Copy Code
public void ReadMyData(string myConnString)
{
  string mySelectQuery = "SELECT DeptNo, DName FROM Test.Dept";
  OracleConnection myConnection = new OracleConnection(myConnString);
  OracleCommand myCommand = new OracleCommand(mySelectQuery,myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader();
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0).ToString() + ", " + myReader.GetString(1));
    }
  }
  finally
  {
  // always call Close when done reading.
  myReader.Close();
  // always call Close when done reading.
  myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub ReadMyData(myConnString As String)
  Dim mySelectQuery As String = "SELECT DeptNo, DName FROM Test.Dept"
  Dim myConnection As New OracleConnection(myConnString)
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader()
  Try
    While myReader.Read()
      Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
        + myReader.GetString(1))
    End While
  Finally
      ' always call Close when done reading.
      myReader.Close()
      ' always call Close when done with connection.
      myConnection.Close()
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleCommand Members
Devart.Data.Oracle Namespace
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleCommand Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleCommand Class

The following tables list the members exposed by OracleCommand.

Public Constructors

 | Name | Description
public Constructor | OracleCommand Constructor | Overloaded. Initializes a new instance of the OracleCommand class.
Top

Public Properties

 | Name | Description
public Property | Cached | Gets or sets a value indicating whether Oracle resources assosiated with the current statement will be cached inside a session.
public Property | CommandText | Overridden. Gets or sets the SQL or PL/SQL statement or stored procedure to execute against the Oracle database.
public Property | CommandTimeout | Overridden. Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.
public Property | CommandType | Overridden. Gets or sets a value indicating how the CommandText property is to be interpreted.
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used by this instance of the OracleCommand.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | FetchSize | Gets or sets the number of rows that will be transferred across the network at a time.
public Property | ImplicitRefCursors | Determines whether to send an additional query to check whether there are implicit REF CURSOR parameters if CommandType is CommandType.StoredProcedure and OracleConnectionStringBuilder.DescribeStoredProcedure is true when executing the command.
public Property | InitialLobFetchSize | Gets or sets the number of bytes of LOB data to prefetch and cache when querying data containing LOB columns. Default value is 0, which means no data is prefetched.
public Property | IsTableValuedFunction | Determines whether a command is a table-valued stored function call.
public Property | Notification | Gets OracleNotificationRequest assigned by OracleDependency.
public Property | Owner | Gets or sets a form or other container that the Devart.Common.DbCommandBase instance belongs to. (Inherited from Devart.Common.DbCommandBase)
public Property | ParameterCheck | Gets or sets a value indicating whether the command object regenerates parameter objects if text of the command is changed. (Inherited from Devart.Common.DbCommandBase)
public Property | Parameters | Gets or sets the Devart.Data.Oracle.OracleParameterCollection.
public Property | PassParametersByName | Gets or sets a value indicating whether stored procedure parameters are passed anonimously or with the names specified.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Transaction | Gets the OracleTransaction in which the OracleCommand executes.
public Property | UpdatedRowSource | Gets or sets how command results are applied to the System.Data.DataRow when used by the Update method of a System.Data.Common.DbDataAdapter. (Inherited from System.Data.Common.DbCommand)
Top

Public Methods

 | Name | Description
public Method | BeginExecuteNonQuery | Overloaded. Starts an asynchronous invocation of an Devart.Common.DbCommandBase.ExecuteNonQuery method. (Inherited from Devart.Common.DbCommandBase)
public Method | BeginExecuteReader | Overloaded. Starts an asynchronous invocation of an Devart.Common.DbCommandBase.ExecuteReader method. (Inherited from Devart.Common.DbCommandBase)
public Method | Cancel | Overridden. Stops execution of OracleCommand methods.
public Method | Clone | Creates a new object that is a copy of the current OracleCommand instance.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateParameter | Creates a new instance of a Devart.Data.Oracle.OracleParameter object.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndExecuteNonQuery | Ends an asynchronous invocation of the Devart.Common.DbCommandBase.ExecuteNonQuery method. (Inherited from Devart.Common.DbCommandBase)
public Method | EndExecuteReader | Ends an asynchronous invocation of the ExecuteReader method.
public Method | ExecuteArray | Overloaded. Executes SQL statement specified number of times.
public Method | ExecuteCursor | Executes the CommandText and returns an OracleCursor object.
public Method | ExecuteNonQuery | Overridden. Executes SQL statement against the Devart.Data.Oracle.OracleConnection and returns the number of rows affected.
public Method | ExecutePageReader | Returns a specific subset of rows when paging through the results of a query.
public Method | ExecuteReader | Overloaded. Sends the CommandText to the Connection and builds a OracleDataReader.
public Method | ExecuteScalar | Executes the query and returns the first column of the first row in the result set returned by the query. All other columns and rows are ignored. (Inherited from System.Data.Common.DbCommand)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRecordCount | Returns count of records in the resultset. (Inherited from Devart.Common.DbCommandBase)
public Method | GetRowId | Returns Oracle ROWID string that represents physical location of the row inside the table.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Prepare | Creates a prepared (or compiled) version of the command on the data source. (Inherited from System.Data.Common.DbCommand)
public Method | ResetCommandTimeout | Overridden. Resets CommandTimeout to its default value.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleCommand Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : OracleCommand Constructor

Initializes a new instance of the Devart.Data.Oracle.OracleCommand class.

Overload List

Overload | Description
OracleCommand Constructor() | Initializes a new instance of the Devart.Data.Oracle.OracleCommand class.
OracleCommand Constructor(String) | Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query.
OracleCommand Constructor(String,CommandType) | Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query and the command type.
OracleCommand Constructor(String,OracleConnection) | Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query and a object, and the OracleTransaction.
OracleCommand Constructor(String,OracleTransaction) | Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query, and the OracleTransaction object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor()

Initializes a new instance of the Devart.Data.Oracle.OracleCommand class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleCommand()

Remarks

The base constructor initializes all fields to their default values. The following table shows initial property values for an instance of Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | empty string ("")
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | System.Data.CommandType.Text
Connection | null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor(String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor(String)

commandText
The text of the query.
Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandText As String _
)
C#
public OracleCommand(
   string commandText
)

Parameters

commandText
The text of the query.

Remarks

The following table shows initial property values for an instance of Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | commandText
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | System.Data.CommandType.Text
Connection | null

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateOracleCommand()
{
  string mySelectQuery = "SELECT * FROM Test.Dept";
  OracleCommand myCommand = new OracleCommand(mySelectQuery);
  myCommand.FetchSize = 100;
}
C#Visual Basic Copy Code
Public Sub CreateOracleCommand()
  Dim mySelectQuery As String = "SELECT * FROM Test.Dept"
  Dim myCommand As New OracleCommand(mySelectQuery)
  myCommand.FetchSize = 100
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor(String,CommandType)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor(String,CommandType)

commandText
The text of the query.
commandType
The command type.
Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query and the command type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandText As String, _
   ByVal commandType As CommandType _
)
C#
public OracleCommand(
   string commandText,
   CommandType commandType
)

Parameters

commandText
The text of the query.
commandType
The command type.

Remarks

The following table shows initial property values for an instance of Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | commandText
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | commandType
Connection | null

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
OracleCommand myCommand = new OracleCommand("SCOTT.GetDepts", CommandType.StoredProcedure);
C#Visual Basic Copy Code
OracleCommand myCommand = new OracleCommand("SCOTT.GetDepts", CommandType.StoredProcedure);

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor(String,OracleConnection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor(String,OracleConnection)

commandText
The text of the query.
connection
A OracleConnection object that represents the connection to Oracle.
Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query and a scrap:condition=communityenabled,name=_COMMUNITY_SECTION,contenttype=summary%%

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandText As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleCommand(
   string commandText,
   OracleConnection connection
)

Parameters

commandText
The text of the query.
connection
A OracleConnection object that represents the connection to Oracle.

Remarks

The following table shows initial property values for an instance of Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | commandText
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | System.Data.CommandType.Text
Connection | connection

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateCommand()
{
  OracleConnection myConnection = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  string mySelectQuery = "SELECT * FROM Test.Dept";
  OracleCommand myCommand = new OracleCommand(mySelectQuery, myConnection);
  myCommand.FetchSize = 100;
}
C#Visual Basic Copy Code
Public Sub CreateCommand()
  Dim myConnection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim mySelectQuery As String = _
    "SELECT * FROM Test.Dept"
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myCommand.FetchSize = 100
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor(String,OracleConnection,OracleTransaction)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor(String,OracleConnection,OracleTransaction)

commandText
The text of the query.
connection
A OracleConnection object that represents the connection to Oracle.
transaction
OracleTransaction object used to perform transactions with this Devart.Data.Oracle.OracleCommand object.
Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query, a scrap:condition=communityenabled,name=_COMMUNITY_SECTION,contenttype=summary%%

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandText As String, _
   ByVal connection As OracleConnection, _
   ByVal transaction As OracleTransaction _
)
C#
public OracleCommand(
   string commandText,
   OracleConnection connection,
   OracleTransaction transaction
)

Parameters

commandText
The text of the query.
connection
A OracleConnection object that represents the connection to Oracle.
transaction
OracleTransaction object used to perform transactions with this Devart.Data.Oracle.OracleCommand object.

Remarks

The following table shows initial property values for an instance of this implementation of the Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | commandText
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | System.Data.CommandType.Text
Connection | connection

You can change the value for any of these parameters by setting the related property.

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateCommand()
{
  OracleConnection myConnection = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  myConnection.Open();
  OracleTransaction myTrans = myConnection.BeginTransaction();
  string mySelectQuery = "SELECT * FROM Test.Dept";
  OracleCommand myCommand = new OracleCommand(mySelectQuery, myConnection,myTrans);
  myCommand.FetchSize = 100
}
C#Visual Basic Copy Code
Public Sub CreateCommand()
  Dim myConnection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
  myConnection.Open()
  Dim myTrans As OracleTransaction = myConnection.BeginTransaction()
  Dim mySelectQuery As String = _
    "SELECT * FROM Test.Dept"
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection, myTrans)
  myCommand.FetchSize = 100
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class
OracleTransaction Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommand Constructor(String,OracleTransaction)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > OracleCommand Constructor : OracleCommand Constructor(String,OracleTransaction)

commandText
The text of the query.
transaction
OracleTransaction object used to perform transactions with this Devart.Data.Oracle.OracleCommand object.
Initializes a new instance of the Devart.Data.Oracle.OracleCommand class with the text of the query, and the OracleTransaction object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal commandText As String, _
   ByVal transaction As OracleTransaction _
)
C#
public OracleCommand(
   string commandText,
   OracleTransaction transaction
)

Parameters

commandText
The text of the query.
transaction
OracleTransaction object used to perform transactions with this Devart.Data.Oracle.OracleCommand object.

Remarks

The following table shows initial property values for an instance of Devart.Data.Oracle.OracleCommand.
Properties | Initial value
CommandText | commandText
Devart.Common.DbCommandBase.CommandTimeout | 30
CommandType | System.Data.CommandType.Text
Connection | null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleCommand Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommand Class

For a list of all members of this type, see OracleCommand members.

Public Methods

 | Name | Description
public Method | BeginExecuteNonQuery | Overloaded. Starts an asynchronous invocation of an Devart.Common.DbCommandBase.ExecuteNonQuery method. (Inherited from Devart.Common.DbCommandBase)
public Method | BeginExecuteReader | Overloaded. Starts an asynchronous invocation of an Devart.Common.DbCommandBase.ExecuteReader method. (Inherited from Devart.Common.DbCommandBase)
public Method | Cancel | Overridden. Stops execution of OracleCommand methods.
public Method | Clone | Creates a new object that is a copy of the current OracleCommand instance.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateParameter | Creates a new instance of a Devart.Data.Oracle.OracleParameter object.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndExecuteNonQuery | Ends an asynchronous invocation of the Devart.Common.DbCommandBase.ExecuteNonQuery method. (Inherited from Devart.Common.DbCommandBase)
public Method | EndExecuteReader | Ends an asynchronous invocation of the ExecuteReader method.
public Method | ExecuteArray | Overloaded. Executes SQL statement specified number of times.
public Method | ExecuteCursor | Executes the CommandText and returns an OracleCursor object.
public Method | ExecuteNonQuery | Overridden. Executes SQL statement against the Devart.Data.Oracle.OracleConnection and returns the number of rows affected.
public Method | ExecutePageReader | Returns a specific subset of rows when paging through the results of a query.
public Method | ExecuteReader | Overloaded. Sends the CommandText to the Connection and builds a OracleDataReader.
public Method | ExecuteScalar | Executes the query and returns the first column of the first row in the result set returned by the query. All other columns and rows are ignored. (Inherited from System.Data.Common.DbCommand)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRecordCount | Returns count of records in the resultset. (Inherited from Devart.Common.DbCommandBase)
public Method | GetRowId | Returns Oracle ROWID string that represents physical location of the row inside the table.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Prepare | Creates a prepared (or compiled) version of the command on the data source. (Inherited from System.Data.Common.DbCommand)
public Method | ResetCommandTimeout | Overridden. Resets CommandTimeout to its default value.
Top

See Also

Reference

OracleCommand Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cancel Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Cancel Method

Stops execution of Devart.Data.Oracle.OracleCommand methods.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Cancel()
C#
public override void Cancel()

Remarks

This thread-safe method allows you to stop query execution. To do this attach an OracleCommand object to connection that is used in operation to halt and invoke Cancel() method in another thread. This method returns without errors, while all stopped executions raise exception "ORA-01013: user requested cancel of current operation".

For detailed information on how to stop asynchronous execution refer to article Asynchronous Execution.

This method is available for Oracle server 9 and newer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Clone Method

Creates a new object that is a copy of the current Devart.Data.Oracle.OracleCommand instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleCommand
C#
public OracleCommand Clone()

Return Value

A new Devart.Data.Oracle.OracleCommand object in which all property values are the same as the original.

Remarks

Use this method when you need to create a new Devart.Data.Oracle.OracleCommand object that is absolutely like existing one.

Example

This example shows how to clone a Devart.Data.Oracle.OracleCommand . To make sure all the properties are inherited, one of them (CommandText) is written to the console.
C#csharp Copy Code
public void CloneACommand()
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept");
        OracleCommand myCommand2 = myCommand.Clone();
  Console.WriteLine(myCommand2.CommandText);
}
C#Visual Basic Copy Code
Public Sub CloneACommand()
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Dept")
  Dim myCommand2 As OracleCommand = myCommand.Clone()
  Console.WriteLine(myCommand2.CommandText)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateParameter Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : CreateParameter Method

Creates a new instance of a OracleParameter object. Creates a new instance of a OracleParameter object.

Syntax

Visual Basic (Declaration)
Public Shadows Function CreateParameter() As OracleParameter
C#
public new OracleParameter CreateParameter()

Return Value

A OracleParameter object.

Remarks

This method is a strongly-typed version of System.Data.IDbCommand.CreateParameter. See OracleParameter to find out more ways to create a parameter.

Example

This sample shows how to create a parameter using CreateParameter function.
C#csharp Copy Code
Public void CreateParam(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo=:Deptno",myConnection);
  OracleParameter myParam = myCommand.CreateParameter();
  myParam.OracleDbType = Devart.Data.Oracle.OracleDbType.Integer;
  myParam.Value = 10;
  myParam.ParameterName = "Deptno";
  myCommand.Parameters.Add(myParam);
  myConnection.Open();
  OracleDataReader myReader = null;
  try
  {
    myReader = myCommand.ExecuteReader();
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(1) + ", " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub CreateParam(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo=:Deptno", myConnection)
  Dim myParam As OracleParameter = myCommand.CreateParameter()
  myParam.OracleDbType = Devart.Data.Oracle.OracleDbType.Integer
  myParam.Value = 10
  myParam.ParameterName = "Deptno"
  myCommand.Parameters.Add(myParam)
  myConnection.Open()
  Dim myReader As OracleDataReader = Nothing
  Try
    myReader = myCommand.ExecuteReader()
    While myReader.Read()
      Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
        + myReader.GetString(1) + ", " _
        + myReader.GetString(2))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Parameters Property
OracleParameter Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndExecuteReader Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : EndExecuteReader Method

result
The System.IAsyncResult returned from Devart.Common.DbCommandBase.BeginExecuteReader.
Ends an asynchronous invocation of the ExecuteReader method. Ends an asynchronous invocation of the ExecuteReader method.

Syntax

Visual Basic (Declaration)
Public Shadows Function EndExecuteReader( _
   ByVal result As IAsyncResult _
) As OracleDataReader
C#
public new OracleDataReader EndExecuteReader(
   IAsyncResult result
)

Parameters

result
The System.IAsyncResult returned from Devart.Common.DbCommandBase.BeginExecuteReader.

Return Value

A OracleDataReader object.

Remarks

The function ends an asynchronous execution of a query that is started with Devart.Common.DbCommandBase.BeginExecuteReader. A pair of asynchronous functions (Devart.Common.DbCommandBase.BeginExecuteReader and EndExecuteReader) can be used instead of the synchronous function ExecuteReader to gain more performance and flexibility in your application.

Refer to "Asynchronous Query Execution" article for detailed information.

Example

In the example below an easiest way of executing an asynchronous operation is shown. First, all components are set up and a connection is opened. Second, a data retrieval operation is started. The operation state (done or in progress) is checked and a report is written to the console. At last query results are sent to OracleDataReader and rendered to the console.
C#csharp Copy Code
Public void Async_Exec(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept",myConnection);
  Console.WriteLine("Starting asynchronous retrieval of data...");
  myConnection.Open();
  IAsyncResult cres = myCommand.BeginExecuteReader(null,null,CommandBehavior.Default);
  if (cres.IsCompleted)
    Console.WriteLine("Completed.");
  else
    Console.WriteLine("Have to wait for operation to complete...");
  OracleDataReader myReader = myCommand.EndExecuteReader(cres);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0) + " " + myReader.GetString(1) + " " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub Async_Exec(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Dept", myConnection)
  Console.WriteLine("Starting asynchronous retrieval of data...")
  myConnection.Open()
  Dim cres As IAsyncResult = myCommand.BeginExecuteReader(Nothing, Nothing, CommandBehavior.Default)
  If cres.IsCompleted Then
    Console.WriteLine("Completed.")
  Else
    Console.WriteLine("Have to wait for operation to complete...")
  End If
  Dim myReader As OracleDataReader = myCommand.EndExecuteReader(cres)
  Try
    While myReader.Read()
      Console.WriteLine(String.Concat(myReader.GetInt32(0), " ", myReader.GetString(1), " ", myReader.GetString(2)))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
BeginExecuteReader Method
ExecuteReader Method
EndExecuteNonQuery Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ExecuteArray Method

Executes SQL statement specified number of times.

Overload List

Overload | Description
ExecuteArray(Int32) | Executes SQL statement specified number of times.
ExecuteArray(Int32,Int64[]) | Executes SQL statement specified number of times. Returns the numbers of rows affected for each array element in its out parameter. Supported only for Oracle 12c Release 1 (12.1) - both server and client. Not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteArray(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > ExecuteArray Method : ExecuteArray(Int32) Method

iters
Number of times to execute SQL statement.
Executes SQL statement specified number of times.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteArray( _
   ByVal iters As Integer _
) As Integer
C#
public int ExecuteArray(
   int iters
)

Parameters

iters
Number of times to execute SQL statement.

Return Value

The return value is the number of rows affected by the statement.

Remarks

The ExecuteArray method allows to execute several SQL statements for the one time. The main advantage of using this method is that only one round trip to the server is used to execute several queries, which speeds up queries execution compared to consecutive invocation.

All parameters of the query must have System.Array type and an elements of the array must have type corresponding to the type of the parameter. The value of the iters parameter must be equal to the number of elements of the array.

Refer to "Working with Array Binding" article for detailed information and example.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteArray(Int32,Int64[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > ExecuteArray Method : ExecuteArray(Int32,Int64[]) Method

iters
Number of times to execute SQL statement.
rowsAffected
Returns the numbers of rows affected for each array element.
Executes SQL statement specified number of times. Returns the numbers of rows affected for each array element in its out parameter. Supported only for Oracle 12c Release 1 (12.1) - both server and client. Not supported in the OracleConnection.Direct mode.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteArray( _
   ByVal iters As Integer, _
   ByRef rowsAffected As Long() _
) As Integer
C#
public int ExecuteArray(
   int iters,
   out long[] rowsAffected
)

Parameters

iters
Number of times to execute SQL statement.
rowsAffected
Returns the numbers of rows affected for each array element.

Return Value

The return value is the number of rows affected by the statement.

Remarks

The ExecuteArray method allows to execute several SQL statements for the one time. The main advantage of using this method is that only one round trip to the server is used to execute several queries, which speeds up queries execution compared to consecutive invocation.

All parameters of the query must have System.Array type and an elements of the array must have type corresponding to the type of the parameter. The value of the iters parameter must be equal to the number of elements of the array.

Refer to "Working with Array Binding" article for detailed information and example.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteCursor Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ExecuteCursor Method

Executes the CommandText and returns an OracleCursor object.

Syntax

Visual Basic (Declaration)
Public Function ExecuteCursor() As OracleCursor
C#
public OracleCursor ExecuteCursor()

Return Value

An OracleCursor object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNonQuery Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ExecuteNonQuery Method

Executes SQL statement against the OracleConnection and returns the number of rows affected.

Syntax

Visual Basic (Declaration)
Public Overrides Function ExecuteNonQuery() As Integer
C#
public override int ExecuteNonQuery()

Return Value

For UPDATE, INSERT, and DELETE statements, the return value is the number of rows affected by the command. For all other types of statements, the return value is -1.

Remarks

You can use ExecuteNonQuery method to perform catalog operations (for example, querying the structure of a database or creating database objects such as tables); or to change the data in a database, without using a DataSet, by executing UPDATE, INSERT, or DELETE statements.

Although ExecuteNonQuery does not return any rows, any output parameters or return values mapped to parameters are populated with data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecutePageReader Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ExecutePageReader Method

behavior
One of the System.Data.CommandBehavior values.
startRecord
maxRecords
Returns a specific subset of rows when paging through the results of a query. Returns a specific subset of rows when paging through the results of a query.

Syntax

Visual Basic (Declaration)
Public Shadows Function ExecutePageReader( _
   ByVal behavior As CommandBehavior, _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer _
) As OracleDataReader
C#
public new OracleDataReader ExecutePageReader(
   CommandBehavior behavior,
   int startRecord,
   int maxRecords
)

Parameters

behavior
One of the System.Data.CommandBehavior values.
startRecord
maxRecords

Return Value

A OracleDataReader object.

Remarks

Use method ExecutePageReader when you want to retrieve not the whole dataset but some part of it that begins with given row number and has certain quantity of rows. This is especially useful when working with large amounts of data.

If you want to retrieve all data in a dataset, use ExecuteReader() instead.

Note: This method is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

ExecutePageReader method puts on following restrictions on the executable statement:

- you cannot execute stored procedures and PL/SQL blocks;

- you may specify only SQL statement that can be placed into the subquery.

To use ExecutePageReader method it is recommended to optimize a query for retrieving a first row, otherwise using this method is ineffective.

Example

The example below shows how to retrieve a part of a table. If this function is called with parameters startRecord=2 and maxRecords=3, it returns 3 rows: second, third, and fourth.
C#csharp Copy Code
public void ExecutePaged(OracleConnection myConnection, int StartRow, int PageLength)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecutePageReader(System.Data.CommandBehavior.Default,StartRow,PageLength);
  try
  {
    while (myReader.Read())
    {
      Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(1) + ", " + myReader.GetString(2));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub ExecutePaged(ByVal myConnection As OracleConnection, ByVal StartRow As Integer, ByVal PageLength As Integer)
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Dept", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecutePageReader(System.Data.CommandBehavior.Default, StartRow, PageLength)
  Try
    While myReader.Read()
      Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
      + myReader.GetString(1) + ", " _
      + myReader.GetString(2))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
ExecuteReader() Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteReader Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ExecuteReader Method

Sends the CommandText to the Connection and builds a OracleDataReader.

Overload List

Overload | Description
ExecuteReader() | Sends the CommandText to the Connection and builds a OracleDataReader.
ExecuteReader(CommandBehavior) | Sends the CommandText to the Connection, and builds a OracleDataReader using one of the System.Data.CommandBehavior values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteReader() Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > ExecuteReader Method : ExecuteReader() Method

Sends the CommandText to the Connection and builds a OracleDataReader.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ExecuteReader() As OracleDataReader
C#
public new OracleDataReader ExecuteReader()

Return Value

A OracleDataReader object.

Example

The following example creates a Devart.Data.Oracle.OracleCommand, then executes it by passing a string that is SQL SELECT statement, and a string to use to connect to the data source.
C#csharp Copy Code
public void CreateOracleDataReader(string mySelectQuery,string myConnectionString)
{
  OracleConnection myConnection = new OracleConnection(myConnectionString);
  OracleCommand myCommand = new OracleCommand(mySelectQuery, myConnection);
  myCommand.Connection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader();
  try
  {
    while(myReader.Read())
    {
      Console.WriteLine(myReader.GetString(0));
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub CreateOracleDataReader(mySelectQuery As String, _
myConnectionString As String)
  Dim myConnection As New OracleConnection(myConnectionString)
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myCommand.Connection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader()
  Try
    While myReader.Read()
      Console.WriteLine(myReader.GetString(0))
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteReader(CommandBehavior) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class > ExecuteReader Method : ExecuteReader(CommandBehavior) Method

behavior
One of the System.Data.CommandBehavior values.
Sends the CommandText to the Connection, and builds a OracleDataReader using one of the System.Data.CommandBehavior values.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function ExecuteReader( _
   ByVal behavior As CommandBehavior _
) As OracleDataReader
C#
public new OracleDataReader ExecuteReader(
   CommandBehavior behavior
)

Parameters

behavior
One of the System.Data.CommandBehavior values.

Return Value

A OracleDataReader object.

Remarks

The OracleDataReader supports a special mode that enables large binary values to be read efficiently. For more information, see the SequentialAccess setting for System.Data.CommandBehavior.

Example

The following example creates a Devart.Data.Oracle.OracleCommand, then executes it by passing a string that is SQL SELECT statement, and a string to use to connect to the data source. The System.Data.CommandBehavior is then set to CloseConnection.
C#csharp Copy Code
public void CreateOracleDataReader(string mySelectQuery,string myConnectionString)
{
  OracleConnection myConnection = new OracleConnection(myConnectionString);
  OracleCommand myCommand = new OracleCommand(mySelectQuery, myConnection);
  myCommand.Connection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(CommandBehavior.CloseConnection);
  while(myReader.Read())
  {
    Console.WriteLine(myReader.GetString(0));
  }
  myReader.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleDataReader(mySelectQuery As String, _
myConnectionString As String)
  Dim myConnection As New OracleConnection(myConnectionString)
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myCommand.Connection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader(CommandBehavior.CloseConnection)
  While myReader.Read()
    Console.WriteLine(myReader.GetString(0))
  End While
  myReader.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Overload List
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRowId Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : GetRowId Method

Returns Oracle ROWID string that represents physical location of the row inside the table.

Syntax

Visual Basic (Declaration)
Public Function GetRowId() As String
C#
public string GetRowId()

Return Value

ROWID string in Base64 format string.

Remarks

You can use this method to obtain ROWID and use it within UPDATE SQL statement or other SQL constructions. It is available only if you have issued M:Devart.Common.DbCommand.Prepare method before calling one of Execute methods.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ResetCommandTimeout Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ResetCommandTimeout Method

Resets CommandTimeout to its default value.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ResetCommandTimeout()
C#
public override void ResetCommandTimeout()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleCommand Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommand Class

For a list of all members of this type, see OracleCommand members.

Public Properties

 | Name | Description
public Property | Cached | Gets or sets a value indicating whether Oracle resources assosiated with the current statement will be cached inside a session.
public Property | CommandText | Overridden. Gets or sets the SQL or PL/SQL statement or stored procedure to execute against the Oracle database.
public Property | CommandTimeout | Overridden. Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.
public Property | CommandType | Overridden. Gets or sets a value indicating how the CommandText property is to be interpreted.
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used by this instance of the OracleCommand.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | FetchSize | Gets or sets the number of rows that will be transferred across the network at a time.
public Property | ImplicitRefCursors | Determines whether to send an additional query to check whether there are implicit REF CURSOR parameters if CommandType is CommandType.StoredProcedure and OracleConnectionStringBuilder.DescribeStoredProcedure is true when executing the command.
public Property | InitialLobFetchSize | Gets or sets the number of bytes of LOB data to prefetch and cache when querying data containing LOB columns. Default value is 0, which means no data is prefetched.
public Property | IsTableValuedFunction | Determines whether a command is a table-valued stored function call.
public Property | Notification | Gets OracleNotificationRequest assigned by OracleDependency.
public Property | Owner | Gets or sets a form or other container that the Devart.Common.DbCommandBase instance belongs to. (Inherited from Devart.Common.DbCommandBase)
public Property | ParameterCheck | Gets or sets a value indicating whether the command object regenerates parameter objects if text of the command is changed. (Inherited from Devart.Common.DbCommandBase)
public Property | Parameters | Gets or sets the Devart.Data.Oracle.OracleParameterCollection.
public Property | PassParametersByName | Gets or sets a value indicating whether stored procedure parameters are passed anonimously or with the names specified.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Transaction | Gets the OracleTransaction in which the OracleCommand executes.
public Property | UpdatedRowSource | Gets or sets how command results are applied to the System.Data.DataRow when used by the Update method of a System.Data.Common.DbDataAdapter. (Inherited from System.Data.Common.DbCommand)
Top

See Also

Reference

OracleCommand Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cached Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Cached Property

Gets or sets a value indicating whether Oracle resources assosiated with the current statement will be cached inside a session.

Syntax

Visual Basic (Declaration)
Public Property Cached As Boolean
C#
public bool Cached {get; set;}

Property Value

true if the statement is cached; otherwise, false. Default value is true.

Remarks

OCI statement cache is enabled when you set Statement Cache Size in Connection String to a positive value. Set Statement Cache Size to 0 (default) if you don't want the statements to be cached.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandText Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : CommandText Property

Gets or sets the SQL or PL/SQL statement or stored procedure to execute against the Oracle database.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandText As String
C#
public override string CommandText {get; set;}

Property Value

The SQL statement or stored procedure to execute. The default value is an empty string ("").

When working with overloaded stored procedures, use following syntax for executing specific overloaded routine: "StoredProcName:1" or "StoredProcName:5". First example executes first overloaded stored procedure, while second example executes fifth overloaded procedure. This notation affects only describing procedures in Devart.Common.DbCommandBase.ParameterCheck is true.

Remarks

Sense of CommandText property depends on value of CommandType property.

When CommandType value is System.Data.CommandType.Text, property CommandText should contain text of a query that must be run on the server.

When the value is System.Data.CommandType.StoredProcedure, property CommandText must be a name of a procedure to execute.

When the value is set to System.Data.CommandType.TableDirect, CommandText must be name of a table you want to get all data from. All rows and columns are retrieved.

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateCommand()
{
  OracleCommand myCommand = new OracleCommand();
  myCommand.CommandText = "SELECT * FROM Test.Dept ORDER BY DeptNo";
}
C#Visual Basic Copy Code
Public Sub CreateCommand()
  Dim myCommand As New OracleCommand()
  myCommand.CommandText = "SELECT * FROM Test.Dept ORDER BY DeptNo"
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
Connection Property
CommandType Property
Parameters Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : CommandTimeout Property

Gets or sets the wait time before terminating an attempt to execute a command and generating an error. Note that it is the time to wait for any server reply since the command was sent to a server, and it doesn't include the time necessary to fetch data if the command selects some data.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandTimeout As Integer
C#
public override int CommandTimeout {get; set;}

Property Value

The time (in seconds) to wait for the command to execute. The default value is 0. Not available under .NET Compact Framework.

Remarks

Zero value specifies that the wait time is unlimited.

The value of the CommandTimeout property is used in Direct mode. The OCI mode doesn't take into account the cmd.CommandTimeout, and the duration of command timeout is determined by Oracle client settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandType Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : CommandType Property

Gets or sets a value indicating how the CommandText property is to be interpreted.

Syntax

Visual Basic (Declaration)
Public Overrides Property CommandType As CommandType
C#
public override CommandType CommandType {get; set;}

Property Value

One of the System.Data.CommandType values. The default value is System.Data.CommandType.Text.

Remarks

CommandType can be one of the following values: Text, StoredProcedure, TableDirect.

When the value is CommandType.Text, the property CommandText should contain text of a query that must be run on the server.

When the value is CommandType.StoredProcedure, CommandText property must be a name of a procedure to execute.

When the value is set to TableDirect, CommandText must be name of a table you want to get all data from. All rows and columns are retrieved.

Example

The following example creates an instance of a derived class Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateCommand()
{
  OracleCommand myCommand = new OracleCommand();
  myCommand.CommandText = "SELECT * FROM Test.Dept ORDER BY DeptNo";
  myCommand.CommandType = CommandType.Text;
}
C#Visual Basic Copy Code
Public Sub CreateCommand()
  Dim myCommand As New OracleCommand()
  myCommand.CommandText = "SELECT * FROM Test.Dept ORDER BY DeptNo"
  myCommand.CommandType = CommandType.Text
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
CommandText Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Connection Property

Gets or sets the OracleConnection used by this instance of the Devart.Data.Oracle.OracleCommand.

Syntax

Visual Basic (Declaration)
Public Shadows Property Connection As OracleConnection
C#
public new OracleConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Remarks

OracleConnection specified in this property will carry out all operations executed with this Devart.Data.Oracle.OracleCommand.

This property supports the InterForm technology.

Example

The following example creates a Devart.Data.Oracle.OracleCommand and sets some of its properties.
C#csharp Copy Code
public void CreateCommand()
{
  string mySelectQuery = "SELECT * FROM Test.Dept ORDER BY DeptNo";
  OracleCommand myCommand = new OracleCommand(mySelectQuery);
  myCommand.Connection = new OracleConnection(
    "User Id=Scott;Password=tiger;Data Source=Ora;");
  myCommand.CommandType = System.Data.CommandType.Text;
}
C#Visual Basic Copy Code
Public Sub CreateCommand()
  Dim mySelectQuery As String = _
    "SELECT * FROM Test.Dept ORDER BY DeptNo"
  Dim myCommand As New OracleCommand(mySelectQuery)
  myCommand.Connection = New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
  myCommand.CommandType = System.Data.CommandType.Text
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
CommandText Property
CommandType Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FetchSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : FetchSize Property

Gets or sets the number of rows that will be transferred across the network at a time.

Syntax

Visual Basic (Declaration)
Public Property FetchSize As Integer
C#
public int FetchSize {get; set;}

Property Value

The number of rows that will be transferred across the network at the same time. The default value is 0.

Remarks

If 0 value is assigned, a value of this parameter will be determined automatically and it will be changed dynamically when executing read operations. If you do not want to have a specific number of rows be fetched at a time, it is better to keep this default value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ImplicitRefCursors Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : ImplicitRefCursors Property

Determines whether to send an additional query to check whether there are implicit REF CURSOR parameters if CommandType is CommandType.StoredProcedure and OracleConnectionStringBuilder.DescribeStoredProcedure is true when executing the command.

Syntax

Visual Basic (Declaration)
Public Property ImplicitRefCursors As Boolean
C#
public bool ImplicitRefCursors {get; set;}

Property Value

true if the check must be performed; otherwise, false. Default value is true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InitialLobFetchSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : InitialLobFetchSize Property

Gets or sets the number of bytes of LOB data to prefetch and cache when querying data containing LOB columns. Default value is 0, which means no data is prefetched.

Syntax

Visual Basic (Declaration)
Public Property InitialLobFetchSize As Integer
C#
public int InitialLobFetchSize {get; set;}

Property Value

The number of bytes of LOB data to prefetch and cache when querying data containing LOB columns.

Remarks

Setting this property allows improving performance of getting data when the data contains small LOB values.

This property works only when the version of both Client and server is 11 or higher or in the Direct mode with the server 11 or higher.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsTableValuedFunction Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : IsTableValuedFunction Property

Determines whether a command is a table-valued stored function call.

Syntax

Visual Basic (Declaration)
Public Property IsTableValuedFunction As Nullable(Of Boolean)
C#
public Nullable<bool> IsTableValuedFunction {get; set;}

Property Value

true if the command is a table-valued stored function call; otherwise, false.

Remarks

When a command is a non-pipelined table-valued function call, this property must be set to true. If this property is not set and OracleConnectionStringBuilder.DescribeStoredProcedure is true, an additional query is sent to the server to check whether the stored function is pipelined if CommandType is CommandType.StoredProcedure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Notification Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Notification Property

Gets OracleNotificationRequest assigned by OracleDependency.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Notification As OracleNotificationRequest
C#
public OracleNotificationRequest Notification {get;}

Property Value

An OracleNotificationRequest object.

Remarks

You can modify the properties of associated OracleNotificationRequest object after the command has been attached but before the listener is started, as all OracleNotificationRequest objects bound to same OracleDependency use same property values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
OracleDependency Class
OracleNotificationRequest Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parameters Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Parameters Property

Gets or sets the OracleParameterCollection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Parameters As OracleParameterCollection
C#
public new OracleParameterCollection Parameters {get;}

Property Value

The parameters of a SQL statement or a stored procedure. The default value is an empty collection.

Remarks

By default, you have to construct this collection and provide values for it manually. However, if you choose to use autosynchronization mode by setting Devart.Common.DbCommandBase.ParameterCheck property to true you can have the collecton adjusted automatically. Please refer to article Using Parameters in dotConnect for Oracle for detailed information on using this mode.

Example

The following example creates a OracleConnection, Devart.Data.Oracle.OracleCommand, fills its parameters and displays them. An UPDATE statement with the parameters involved is executed then.
C#csharp Copy Code
static void CreateCommand(OracleConnection myConnection, string mySelectQuery, OracleParameter[] myParamArray)
{
  OracleCommand myCommand = new OracleCommand(mySelectQuery, myConnection);
  string myMessage = "";
  for (int i = 0; i < myParamArray.Length; i++)
  {
    myCommand.Parameters.Add(myParamArray[i]);
    myMessage += myCommand.Parameters[i].ToString() + "\n";
  }
  Console.Write(myMessage);
  try
  {
    myConnection.Open();
    myCommand.ExecuteNonQuery();
  }
  finally
  {
    myConnection.Close();
  }
}

static void Main(string[] args)
{
  OracleParameter[] myParams = new OracleParameter[]
    {
      new OracleParameter("DeptNo", 10),
      new OracleParameter("DName", "COUNTING")
    };
  OracleConnection myConnection1 = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  CreateCommand(myConnection1,"UPDATE Test.Dept SET DName = :DName WHERE DeptNo = :DeptNo",myParams);
}
C#Visual Basic Copy Code
Public Sub CreateCommand(ByVal myConnection As Devart.Data.Oracle.OracleConnection, _
 ByVal mySelectQuery As String, ByVal myParamArray() As Devart.Data.Oracle.OracleParameter)
  Dim myCommand As New Devart.Data.Oracle.OracleCommand(mySelectQuery, myConnection)
  Dim myMessage As String = ""
  Dim i As Integer
  For i = 0 To (myParamArray.Length - 1)
    myCommand.Parameters.Add(myParamArray(i))
    myMessage = String.Concat(myMessage, " ", myCommand.Parameters(i).ToString())
  Next
  Console.WriteLine(myMessage)
  Try
    myConnection.Open()
    myCommand.ExecuteNonQuery()
  Finally
    myConnection.Close()
  End Try
End Sub

Sub Main()
  Dim myP1 As New Devart.Data.Oracle.OracleParameter
  myP1.ParameterName = "DeptNo"
  myP1.Value = 10
  Dim myP2 As New Devart.Data.Oracle.OracleParameter
  myP2.ParameterName = "DName"
  myP2.Value = "ACCOUNTING"
  Dim myParams(1) As Devart.Data.Oracle.OracleParameter
  myParams(0) = myP1
  myParams(1) = myP2
  Dim myConnection1 As New Devart.Data.Oracle.OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  CreateCommand(myConnection1, "UPDATE Test.Dept SET DName = :DName WHERE DeptNo = :DeptNo", myParams)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members
OracleParameter Class
CommandText Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PassParametersByName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : PassParametersByName Property

Gets or sets a value indicating whether stored procedure parameters are passed anonimously or with the names specified.

Syntax

Visual Basic (Declaration)
Public Property PassParametersByName As Boolean
C#
public bool PassParametersByName {get; set;}

Property Value

true if parameter names are specified in the procedure invocation; otherwise, false.

Remarks

With this property set to false, a procedure will be called like "Proc(:param1, :param2)" or "Proc(:param2, :param1)" subject to parameters order. If true, the statement will be like "Proc(param2 => :param2, param1 => :param1)", thus result will be the same regardless of parameters order.

This property can be used with any value of the ParameterCheck property. Ignored if CommandType is other than CommandType.StoredProcedure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transaction Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommand Class : Transaction Property

Gets the OracleTransaction in which the Devart.Data.Oracle.OracleCommand executes.

Syntax

Visual Basic (Declaration)
Public Shadows Property Transaction As OracleTransaction
C#
public new OracleTransaction Transaction {get; set;}

Property Value

An OracleTransaction. The default value is a null reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommand Class
OracleCommand Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommandBuilder Class

Automatically generates single-table commands used to reconcile changes made to a System.Data.DataSet with the Oracle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbCommandBuilder
Devart.Common.DbCommandBuilderBase
Devart.Common.DbCommandBuilder
Devart.Data.Oracle.OracleCommandBuilder

Syntax

Visual Basic (Declaration)
Public Class OracleCommandBuilder
   Inherits Devart.Common.DbCommandBuilder
   Implements IComponent, IDisposable
C#
public class OracleCommandBuilder : Devart.Common.DbCommandBuilder, IComponent, IDisposable

Remarks

The OracleDataAdapter does not automatically generate the SQL statements required to reconcile changes made to a System.Data.DataSet associated with Oracle. However, you can create a OracleCommandBuilder object that generates SQL statements for single-table updates. After assigning the OracleDataAdapter to the OracleCommandBuilder, it begins to generate any additional SQL statements that you do not set.

The relationship between a OracleDataAdapter and its corresponding OracleCommandBuilder is always one-to-one. To create this correspondence, you set the DataAdapter property of the OracleCommandBuilder object. This causes the OracleCommandBuilder to register itself as a listener, which produces the output of OracleDataAdapter.RowUpdating events that affect the System.Data.DataSet.

To generate INSERT, UPDATE, or DELETE statements, the OracleCommandBuilder uses the OracleDataAdapter.SelectCommand property to retrieve a required set of metadata. If you change the value of OracleDataAdapter.SelectCommand after the metadata has been retrieved (for example, after the first update), you then should call the Devart.Common.DbCommandBuilderBase.RefreshSchema method to update the metadata.

The OracleCommandBuilder also uses the Connection, Devart.Common.DbCommandBase.CommandTimeout, and Devart.Common.DbCommandBase.Transaction properties referenced by the OracleDataAdapter.SelectCommand. The user should call Devart.Common.DbCommandBuilderBase.RefreshSchema if any of these properties are modified, or value of the OracleDataAdapter.SelectCommand property itself is changed. Otherwise the OracleDataAdapter.InsertCommand, OracleDataAdapter.UpdateCommand, and OracleDataAdapter.DeleteCommand properties retain their previous values.

If you assign null to corresponding property of OracleDataAdapter, the OracleCommandBuilder will be disassociated from the OracleDataAdapter, and the generated commands will no longer be used.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

The following example uses OracleCommand, along with OracleDataAdapter and Devart.Data.Oracle.OracleConnection, to select rows from Oracle. The example is passed an initialized System.Data.DataSet, a connection string, a query string that is SQL SELECT statement, and a string that is the name of the Oracle table. The example then creates a OracleCommandBuilder.
C#csharp Copy Code
public DataSet SelectOracleSrvRows(DataSet myDataSet,string myConnection,string mySelectQuery,string myTableName)
{
  OracleConnection myConn = new OracleConnection(myConnection);
  OracleDataAdapter myDataAdapter = new OracleDataAdapter();
  myDataAdapter.SelectCommand = new OracleCommand(mySelectQuery, myConn);
  OracleCommandBuilder myCommandBuilder = new OracleCommandBuilder(myDataAdapter);

  myConn.Open();

  DataSet myDataSet = new DataSet();
  myDataAdapter.Fill(myDataSet, "Departments");

  //code to modify data in dataset here

  //Without the OracleCommandBuilder this line would fail
  myDataAdapter.Update(myDataSet, "Departments");

  myConn.Close();

  return myDataSet;
}
C#Visual Basic Copy Code
Public Function SelectOracleSrvRows(myDataSet As DataSet, myConnection As String, mySelectQuery As String, myTableName As String) As DataSet
  Dim myConn As New OracleConnection(myConnection)
  Dim myDataAdapter As New OracleDataAdapter()
  myDataAdapter.SelectCommand = New OracleCommand(mySelectQuery, myConn)
  Dim myCommandBuilder As OracleCommandBuilder = New OracleCommandBuilder(myDataAdapter)

  myConn.Open()

  Dim myDataSet As DataSet = New DataSet
  myDataAdapter.Fill(myDataSet, "Departments")

  ' Code to modify data in DataSet here

  ' Without the OracleCommandBuilder this line would fail.
  myDataAdapter.Update(myDataSet, "Departments")

  myConn.Close()

  SelectOracleSrvRows = myDataSet
End Function

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleCommandBuilder Members
Devart.Data.Oracle Namespace
OracleDataAdapter Class
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleCommandBuilder Class

The following tables list the members exposed by OracleCommandBuilder.

Public Constructors

 | Name | Description
public Constructor | OracleCommandBuilder Constructor | Overloaded. Initializes a new instance of the OracleCommandBuilder class.
Top

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a OracleDataAdapter object for which this OracleCommandBuilder object will generate SQL statements.
public Property | IdentityInsert | Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.
public Property | IdentityUpdate | Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshingFields | Overridden. Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the Devart.Common.DbCommandBuilderBase should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingFields | Overridden. Gets or sets list of fields to modify.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | DeriveParameters | Populates the specified OracleCommand object's Devart.Data.Oracle.OracleCommand.Parameters collection with parameter information for the SQL statement specified in the CommandText.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated SQL statement required to perform deletions on the data source.
public Method | GetInsertCommand | Overloaded. Gets the automatically generated SQL statement required to perform inserts on the data source.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated SQL statement required to perform updates on the data source.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Overridden. Returns the string passed as the parameter enclosed in quotes.
public Method | RefreshSchema | Clears the commands associated with this System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | UnquoteIdentifier | Overridden. Removes quote strings from identifier.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleCommandBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : OracleCommandBuilder Constructor

Initializes a new instance of the OracleCommandBuilder class.

Overload List

Overload | Description
OracleCommandBuilder Constructor() | Initializes a new instance of the OracleCommandBuilder class.
OracleCommandBuilder Constructor(OracleDataAdapter) | Initializes a new instance of the OracleCommandBuilder class with the associated OracleDataAdapter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > OracleCommandBuilder Constructor : OracleCommandBuilder Constructor()

Initializes a new instance of the OracleCommandBuilder class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleCommandBuilder()

Remarks

The base constructor initializes all fields to their default values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Constructor(OracleDataAdapter)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > OracleCommandBuilder Constructor : OracleCommandBuilder Constructor(OracleDataAdapter)

adapter
Initializes a new instance of the OracleCommandBuilder class with the associated OracleDataAdapter object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal adapter As OracleDataAdapter _
)
C#
public OracleCommandBuilder(
   OracleDataAdapter adapter
)

Parameters

adapter

Remarks

The OracleCommandBuilder registers itself as a listener for OracleDataAdapter.RowUpdating events that are generated by the OracleDataAdapter specified in this property.

When you create a new instance of OracleCommandBuilder, any existing OracleCommandBuilder associated with this OracleDataAdapter is released.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommandBuilder Class

For a list of all members of this type, see OracleCommandBuilder members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | DeriveParameters | Populates the specified OracleCommand object's Devart.Data.Oracle.OracleCommand.Parameters collection with parameter information for the SQL statement specified in the CommandText.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetDeleteCommand | Overloaded. Gets the automatically generated SQL statement required to perform deletions on the data source.
public Method | GetInsertCommand | Overloaded. Gets the automatically generated SQL statement required to perform inserts on the data source.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetRefreshCommand | Overloaded. Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.
public Method | GetUpdateCommand | Overloaded. Gets the automatically generated SQL statement required to perform updates on the data source.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | QuoteIdentifier | Overridden. Returns the string passed as the parameter enclosed in quotes.
public Method | RefreshSchema | Clears the commands associated with this System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Method | UnquoteIdentifier | Overridden. Removes quote strings from identifier.
Top

See Also

Reference

OracleCommandBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeriveParameters Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : DeriveParameters Method

command
The Devart.Data.Oracle.OracleCommand referencing the SQL statement for which the parameter information is to be derived. The derived parameters will be populated into the Devart.Data.Oracle.OracleCommand.Parameters collection of this command.
Populates the specified Devart.Data.Oracle.OracleCommand object's Devart.Data.Oracle.OracleCommand.Parameters collection with parameter information for the SQL statement specified in the CommandText.

Syntax

Visual Basic (Declaration)
Public Shared Sub DeriveParameters( _
   ByVal command As OracleCommand _
)
C#
public static void DeriveParameters(
   OracleCommand command
)

Parameters

command
The Devart.Data.Oracle.OracleCommand referencing the SQL statement for which the parameter information is to be derived. The derived parameters will be populated into the Devart.Data.Oracle.OracleCommand.Parameters collection of this command.

Remarks

DeriveParameters overwrites any existing parameter information for the Devart.Data.Oracle.OracleCommand.

DeriveParameters requires an extra call to the data server to obtain the information. If the parameter information is known in advance, it is more efficient to populate the parameters collection by setting the information explicitly.

For more information, see "Using Stored Procedures with a Command" in the Microsoft .NET Framework SDK documentation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : GetDeleteCommand Method

Gets the automatically generated SQL statement required to perform deletions on the data source.

Overload List

Overload | Description
GetDeleteCommand() | Gets the automatically generated SQL statement required to perform deletions on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.
GetDeleteCommand(Boolean) | Gets the automatically generated SQL statement required to perform deletions on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetDeleteCommand Method : GetDeleteCommand() Method

Gets the automatically generated SQL statement required to perform deletions on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetDeleteCommand() As OracleCommand
C#
public new OracleCommand GetDeleteCommand()

Return Value

The text of the SQL statement to be executed.

Remarks

You can use the GetDeleteCommand method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetDeleteCommand as the basis of a modified command. For example, you might call GetDeleteCommand and modify the Devart.Common.DbCommandBase.CommandTimeout value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetDeleteCommand still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetDeleteCommand.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDeleteCommand(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetDeleteCommand Method : GetDeleteCommand(Boolean) Method

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.
Gets the automatically generated SQL statement required to perform deletions on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetDeleteCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetDeleteCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.

Return Value

The text of the SQL statement to be executed.

Remarks

You can use the GetDeleteCommand method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetDeleteCommand as the basis of a modified command. For example, you might call GetDeleteCommand and modify the Devart.Common.DbCommandBase.CommandTimeout value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetDeleteCommand still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) or GetDeleteCommand.

useColumnsForParameterNames argument determines whether names of parameters in command text will be like ":p1", ":p2" (if false), or names of columns will be used (if true), like ":mycolumn1", ":myothercolumn".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : GetInsertCommand Method

Gets the automatically generated SQL statement required to perform inserts on the data source.

Overload List

Overload | Description
GetInsertCommand() | Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.
GetInsertCommand(Boolean) | Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.
GetInsertCommand(String[],Boolean) | Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetInsertCommand Method : GetInsertCommand() Method

Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetInsertCommand() As OracleCommand
C#
public new OracleCommand GetInsertCommand()

Return Value

The text of the SQL statement to be executed.

Remarks

You can use the GetInsertCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetInsertCommand() as the basis of a modified command. For example, you might call GetInsertCommand() and modify the Devart.Common.DbCommandBase.CommandTimeout value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetInsertCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetInsertCommand Method : GetInsertCommand(Boolean) Method

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.
Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetInsertCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetInsertCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.

Return Value

The text of the SQL statement to be executed.

Remarks

You can use the GetInsertCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetInsertCommand() as the basis of a modified command. For example, you might call GetInsertCommand() and modify the Devart.Common.DbCommandBase.CommandTimeout value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetInsertCommand().

useColumnsForParameterNames argument determines whether names of paramerters in command text will be like ":p1", ":p2" (if false), or names of columns will be used (if true), like ":mycolumn1", ":myothercolumn".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInsertCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetInsertCommand Method : GetInsertCommand(String[],Boolean) Method

fields
Defines list of columns that are allowed to update.
useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.
Gets the automatically generated SQL statement required to perform inserts on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetInsertCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetInsertCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
Defines list of columns that are allowed to update.
useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.

Return Value

The text of the SQL statement to be executed.

Remarks

You can use the GetInsertCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetInsertCommand() as the basis of a modified command. For example, you might call GetInsertCommand() and modify the Devart.Common.DbCommandBase.CommandTimeout value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetInsertCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetInsertCommand().

useColumnsForParameterNames argument determines whether names of paramerters in command text will be like ":p1", ":p2" (if false), or names of columns will be used (if true), like ":mycolumn1", ":myothercolumn".

fields argument defines list of columns that are allowed to update. Columns not included into the list will not be updated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : GetRefreshCommand Method

Gets the automatically generated SQL statement required to refresh values from the data source. Gets the automatically generated SQL statement required to refresh values from the data source.

Overload List

Overload | Description
GetRefreshCommand() | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.
GetRefreshCommand(String[],Boolean) | Gets the automatically generated SQL statement required to refresh values from the data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand() Method

Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand() As OracleCommand
C#
public new OracleCommand GetRefreshCommand()

Return Value

A T:Devart.Common.DbCommand with Devart.Common.DbCommandBase.CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand(Boolean) Method

useColumnsForParameterNames
Determines whether dotConnect for Oracle uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetRefreshCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether dotConnect for Oracle uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A Devart.Data.Oracle.OracleCommand with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetRefreshCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetRefreshCommand Method : GetRefreshCommand(String[],Boolean) Method

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect for Oracle uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.
Gets the automatically generated SQL statement required to refresh values from the data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetRefreshCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetRefreshCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
The array of string containing list of the field names.
useColumnsForParameterNames
Determines whether dotConnect for Oracle uses columns metadata to make up parameters' names. If true, the names are composed using colon and name of appropriate column; otherwise the names look like :p1, :p2 etc.

Return Value

A Devart.Data.Oracle.OracleCommand with CommandText containing SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : GetUpdateCommand Method

Gets the automatically generated SQL statement required to perform updates on the data source.

Overload List

Overload | Description
GetUpdateCommand() | Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.
GetUpdateCommand(Boolean) | Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.
GetUpdateCommand(String[],Boolean) | Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand() Method

Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetUpdateCommand() As OracleCommand
C#
public new OracleCommand GetUpdateCommand()

Return Value

The Devart.Data.Oracle.OracleCommand object to be executed.

Remarks

You can use the GetUpdateCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetUpdateCommand() as the basis of a modified command. For example, you might call GetUpdateCommand() and modify the CommandText value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetUpdateCommand().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand(Boolean) Method

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.
Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetUpdateCommand( _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetUpdateCommand(
   bool useColumnsForParameterNames
)

Parameters

useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.

Return Value

The Devart.Data.Oracle.OracleCommand object to be executed.

Remarks

You can use the GetUpdateCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetUpdateCommand() as the basis of a modified command. For example, you might call GetUpdateCommand() and modify the CommandText value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetUpdateCommand().

useColumnsForParameterNames argument determines whether names of paramerters in command text will be like ":p1", ":p2" (if false), or names of columns will be used (if true), like ":mycolumn1", ":myothercolumn".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUpdateCommand(String[],Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class > GetUpdateCommand Method : GetUpdateCommand(String[],Boolean) Method

fields
Defines list of columns that are allowed to update.
useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.
Gets the automatically generated SQL statement required to perform updates on the data source when an application calls System.Data.Common.DbDataAdapter.Update() on the OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function GetUpdateCommand( _
   ByVal fields() As String, _
   ByVal useColumnsForParameterNames As Boolean _
) As OracleCommand
C#
public new OracleCommand GetUpdateCommand(
   string[] fields,
   bool useColumnsForParameterNames
)

Parameters

fields
Defines list of columns that are allowed to update.
useColumnsForParameterNames
Determines whether names of parameters in command text will be based on columns' names.

Return Value

The Devart.Data.Oracle.OracleCommand object to be executed.

Remarks

You can use the GetUpdateCommand() method for informational or troubleshooting purposes because it returns the Devart.Data.Oracle.OracleCommand object to be executed.

You can also use GetUpdateCommand() as the basis of a modified command. For example, you might call GetUpdateCommand() and modify the CommandText value, and then explicitly set that on the OracleDataAdapter.

After the SQL statement is first generated, you must explicitly call Devart.Common.DbCommandBuilderBase.RefreshSchema if it changes the statement in any way. Otherwise, the GetUpdateCommand() still will be using information from the previous statement, which might not be correct. The SQL statements are first generated when the application calls either System.Data.Common.DbDataAdapter.Update() or GetUpdateCommand().

useColumnsForParameterNames argument determines whether names of paramerters in command text will be like ":p1", ":p2" (if false), or names of columns will be used (if true), like ":mycolumn1", ":myothercolumn".

fields argument defines list of columns that are allowed to update. Columns not included into the list will not be updated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QuoteIdentifier Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : QuoteIdentifier Method

unquotedIdentifier
Identifier to be placed inside the quotes.
Returns the string passed as the parameter enclosed in quotes.

Syntax

Visual Basic (Declaration)
Public Overrides Function QuoteIdentifier( _
   ByVal unquotedIdentifier As String _
) As String
C#
public override string QuoteIdentifier(
   string unquotedIdentifier
)

Parameters

unquotedIdentifier
Identifier to be placed inside the quotes.

Return Value

The identifier enclosed in quotes.

Remarks

This method constructs a quoted identifier by concatenating Devart.Common.DbCommandBuilderBase.QuotePrefix, unquotedIdentifier, and Devart.Common.DbCommandBuilderBase.QuoteSuffix.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnquoteIdentifier Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : UnquoteIdentifier Method

quotedIdentifier
String containing Devart.Common.DbCommandBuilderBase.QuotePrefix, identifier itself, and Devart.Common.DbCommandBuilderBase.QuoteSuffix parts.
Removes quote strings from identifier.

Syntax

Visual Basic (Declaration)
Public Overrides Function UnquoteIdentifier( _
   ByVal quotedIdentifier As String _
) As String
C#
public override string UnquoteIdentifier(
   string quotedIdentifier
)

Parameters

quotedIdentifier
String containing Devart.Common.DbCommandBuilderBase.QuotePrefix, identifier itself, and Devart.Common.DbCommandBuilderBase.QuoteSuffix parts.

Return Value

Unquoted identifier.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommandBuilder Class

For a list of all members of this type, see OracleCommandBuilder members.

Public Properties

 | Name | Description
public Property | CatalogLocation | Sets or gets the System.Data.Common.CatalogLocation for an instance of the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the System.Data.Common.DbCommandBuilder. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataAdapter | Gets or sets a OracleDataAdapter object for which this OracleCommandBuilder object will generate SQL statements.
public Property | IdentityInsert | Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.
public Property | IdentityUpdate | Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.
public Property | KeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | Quoted | Gets or sets whether the command builder quotes all the names of data source objects. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | RefreshingFields | Overridden. Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the Devart.Common.DbCommandBuilderBase should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | SetAllValues | Specifies whether all column values in an update statement are included or only changed ones. (Inherited from System.Data.Common.DbCommandBuilder)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UpdatingFields | Overridden. Gets or sets list of fields to modify.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
public Property | UseCatalog | Specifies whether the catalog identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
public Property | UseSchema | Specifies whether the schema identifier is included in data source object names. (Inherited from Devart.Common.DbCommandBuilderBase)
Top

See Also

Reference

OracleCommandBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataAdapter Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : DataAdapter Property

Gets or sets a OracleDataAdapter object for which this OracleCommandBuilder object will generate SQL statements.

Syntax

Visual Basic (Declaration)
Public Shadows Property DataAdapter As OracleDataAdapter
C#
public new OracleDataAdapter DataAdapter {get; set;}

Property Value

A OracleDataAdapter object that is associated with this OracleCommandBuilder.

Remarks

The OracleCommandBuilder registers itself as a listener for OracleDataAdapter.RowUpdating events that are generated by the OracleDataAdapter specified in this property.

When you create a new instance of OracleCommandBuilder, any existing OracleCommandBuilder associated with this OracleDataAdapter is released.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IdentityInsert Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : IdentityInsert Property

Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.

Syntax

Visual Basic (Declaration)
Public Property IdentityInsert As Boolean
C#
public bool IdentityInsert {get; set;}

Property Value

If true, identity column values are inserted into the database for columns with OracleIdentityType equal to GeneratedByDefault or GeneratedByDefaultOnNull; otherwise they are not inserted. Default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IdentityUpdate Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : IdentityUpdate Property

Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.

Syntax

Visual Basic (Declaration)
Public Property IdentityUpdate As Boolean
C#
public bool IdentityUpdate {get; set;}

Property Value

If true, identity column values are inserted into the database for columns with OracleIdentityType equal to GeneratedByDefault or GeneratedByDefaultOnNull; otherwise they are not inserted. Default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
KeyFields Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : KeyFields Property

Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Shadows Property KeyFields As String
C#
public new string KeyFields {get; set;}

Property Value

The string containing list of key field names separated by semicolon.

Remarks

This property is used when the ConflictOption property is set to OverwriteChanges, otherwise all columns will be used in the WHERE clause.

If KeyFields is nonempty, its value is used as the list of columns for the WHERE clause. If KeyFields is empty, the primary key columns are used.

Example

The following example demonstrates how UPDATE and DELETE statements are generated.
C#csharp Copy Code
public void UseKeyFields(string connectionString) {

        OracleConnection conn = new OracleConnection(connectionString);
        conn.Open();

        OracleDataAdapter adapter = new OracleDataAdapter("SELECT * FROM Test.Dept", conn);
        OracleCommandBuilder commBuilder = new OracleCommandBuilder(adapter);

        commBuilder.ConflictOption = ConflictOption.OverwriteChanges;

        commBuilder.KeyFields = "DeptNo, DName";

        string updateComm = commBuilder.GetUpdateCommand().CommandText;
        string deleteComm = commBuilder.GetDeleteCommand().CommandText;

        Console.WriteLine(updateComm);
        Console.WriteLine(deleteComm);
        conn.Close();
}
C#Visual Basic Copy Code
Public Sub UseKeyFields(ByVal connectionString As String)
        Dim conn As OracleConnection = New OracleConnection(connectionString)
        conn.Open()

        Dim adapter As OracleDataAdapter = New OracleDataAdapter("SELECT * FROM Test.Dept", conn)
        Dim commBuilder As OracleCommandBuilder = New OracleCommandBuilder(adapter)

        commBuilder.ConflictOption = ConflictOption.OverwriteChanges

        commBuilder.KeyFields = "DeptNo, DName"

        Dim updateComm As String = commBuilder.GetUpdateCommand().CommandText
        Dim deleteComm As String = commBuilder.GetDeleteCommand().CommandText

        Console.WriteLine(updateComm)
        Console.WriteLine(deleteComm)
        conn.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshingFields Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : RefreshingFields Property

Gets or sets list of fields whose values should be retrieved after a DML statement execution.

Syntax

Visual Basic (Declaration)
Public Overrides Property RefreshingFields As String
C#
public override string RefreshingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Remarks

This property is used in conjunction with Devart.Common.DbCommandBuilderBase.RefreshMode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members
GetRefreshCommand Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingFields Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : UpdatingFields Property

Gets or sets list of fields to modify.

Syntax

Visual Basic (Declaration)
Public Overrides Property UpdatingFields As String
C#
public override string UpdatingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Remarks

UpdatingFields is used by GetInsertCommand and GetUpdateCommand overloads that do not have fields argument. If the UpdatingFields property is empty, full set of columns is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingTable Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCommandBuilder Class : UpdatingTable Property

Gets or sets table name to generate update statements for.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdatingTable As String
C#
public new string UpdatingTable {get; set;}

Property Value

The name of the table.

Remarks

Use the UpdatingTable property to generate SQL statements for specific table in a complicated query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCommandBuilder Class
OracleCommandBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnection Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnection Class

Represents an open connection to Oracle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DbConnection
Devart.Common.DbConnectionBase
Devart.Data.Oracle.OracleConnection

Syntax

Visual Basic (Declaration)
Public Class OracleConnection
   Inherits Devart.Common.DbConnectionBase
   Implements IComponent, IDbConnection, ICloneable, IDisposable
C#
public class OracleConnection : Devart.Common.DbConnectionBase, IComponent, IDbConnection, ICloneable, IDisposable

Remarks

A Devart.Data.Oracle.OracleConnection object represents a unique connection to Oracle. Use it in conjunction with OracleCommand, OracleDataReader, OracleDataAdapter or other components for convenient interoperation with Oracle.

When you create an instance of Devart.Data.Oracle.OracleConnection, all properties are set to their initial values. For a list of these values, see the OracleConnection Constructor constructor.

If the Devart.Data.Oracle.OracleConnection goes out of scope, it is not closed. Therefore, you must explicitly close the connection by calling Close.

Note that Devart.Data.Oracle.OracleConnection instance is not guaranteed to be thread safe. You should avoid using the same Devart.Data.Oracle.OracleConnection in several threads at the same time. It is recommended to open a new connection per thread and to close it when the work is done. Actually, connections will not be created/disposed every time with the Pooling=true; connection string option - connections will be stored at connection pool. This boosts performance greatly.

A single Devart.Data.Oracle.OracleConnection can be used by many OracleCommand objects on the assumption that all operations will be done consecutively. In other words, you can not execute a SQL statement while an asynchronous operation is in progress.

This class supports cross-form data binding with the InterForm Technology.

Example

The following example creates a OracleCommand and a Devart.Data.Oracle.OracleConnection. The Devart.Data.Oracle.OracleConnection is opened and set as the Connection property. The example then calls Devart.Common.DbCommandBase.ExecuteNonQuery method, and closes the connection. To accomplish this, the Devart.Common.DbCommandBase.ExecuteNonQuery is passed a connection string and a query string that is SQL INSERT statement.
C#csharp Copy Code
public void InsertRow(string myConnectionString)
{
  // If the connection string is empty, use default.
  if(myConnectionString == "")
  {
    myConnectionString =
        "User Id=Scott;Password=tiger;Data Source=Ora;";
  }
  OracleConnection myConn = new OracleConnection(myConnectionString);
  string myInsertQuery = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')";
  OracleCommand myCommand = new OracleCommand(myInsertQuery);
  myCommand.Connection = myConn;
  myConn.Open();
  try
  {
    myCommand.ExecuteNonQuery();
  }
  finally
  {
    myConn.Close();
  }
}
C#Visual Basic Copy Code
Public Sub InsertRow(myConnectionString As String)
  ' If the connection string is empty, use default.
  If myConnectionString = "" Then
    myConnectionString = _
        "User Id=Scott;Password=tiger;Data Source=Ora;"
  End If
  Dim myConn As New OracleConnection(myConnectionString)
  Dim myInsertQuery As String = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')"
  Dim myCommand As New OracleCommand(myInsertQuery)
  myCommand.Connection = myConn
  myConn.Open()
  Try
    myCommand.ExecuteNonQuery()
  Finally
    myConn.Close()
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleConnection Members
Devart.Data.Oracle Namespace
OracleDataAdapter Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleConnection Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleConnection Class

The following tables list the members exposed by OracleConnection.

Public Constructors

 | Name | Description
public Constructor | OracleConnection Constructor | Overloaded. Initializes a new instance of the Devart.Data.Oracle.OracleConnection class.Initializes a new instance of the Devart.Data.Oracle.OracleConnection class.
Top

Public Properties

 | Name | Description
public Property | ActionName | Gets or sets the action name for the connection.
public Property | AutoCommit | Determines whether modifications will be committed automatically at the server or not.
public Property | ClientId | This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.
public Property | ClientInfo | Gets or sets the client information for the connection.
public Property | ClientVersion | Returns version of Oracle client used for this connection.
public Property | ConnectionString | Gets or sets the string used to open an Oracle server database.
public Property | ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | ConnectMode | Opens a session with administrative privileges SYSDBA or SYSOPER.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataSource | Gets the name of the database server to which to connect. (Inherited from System.Data.Common.DbConnection)
public Property | Direct | Indicates whether Direct mode of communicating with server should be used.
public Property | Home | Gets or sets Oracle Home to be used.
static (Shared in Visual Basic) | Homes | Gets the list of all available Oracle homes.
public Property | InDistributedTransaction | Indicates whether the connection is enlisted in a distributed transaction. (Inherited from Devart.Common.DbConnectionBase)
public Property | LogicalTransactionId | Gets the logical transaction ID (LTXID) of the last executed translation. Can be used for determining the outcome of the last transaction, opened by this connection, following an outage. Requires Oracle 12c and works only in OCI mode.
public Property | ModuleName | Gets or sets the module name for the connection.
public Property | Name | Gets or sets name of the component.
public Property | NumberMappings | Gets or sets the collection of number mappings used for this connection.
public Property | OracleLogicalTransaction | Gets an OracleLogicalTransaction object, which allows you to determine whether the running transaction during the last database outage was successfully committed and completed.
public Property | Owner | Gets or sets a form or other container that the OracleConnection instance belongs to.
public Property | PassParametersByName | Determines whether parameters will be passed by name to the stored procedure calls.
public Property | Password | Gets or sets the user's password to connect.
public Property | Port | Gets or sets number of a port to communicate with listener on the server.
public Property | Server | Gets or sets the name of TNS alias of the Oracle database to which to connect.
public Property | ServerType | Indicates whether the connected database is an Oracle database or a TimesTen database.
public Property | ServerVersion | Gets a string containing the version of the instance of Oracle to which the client is connected.
public Property | ServiceName | Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.
public Property | ShortServerVersion | Gets the version of the instance of Oracle Database, the Devart.Data.Oracle.OracleConnection object is connected to, as a System.Version object.
public Property | Sid | Gets or sets a unique name for an Oracle database instance.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | State | Gets the current state of the connection.
public Property | TrimFixedChar | Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).
public Property | Unicode | Gets or sets a value indicating whether the UTF16 charset will be used.
public Property | UserId | Gets or sets the name of the user to connect.
Top

Public Methods

 | Name | Description
public Method | BeginOpen | Starts an asynchronous invocation of an Open method. (Inherited from Devart.Common.DbConnectionBase)
public Method | BeginTransaction | Overloaded. Begins a transaction at the database.
public Method | ChangeDatabase | Changes the current database for an open connection. (Inherited from System.Data.Common.DbConnection)
public Method | ChangePassword | Changes the password for the specified user.
static (Shared in Visual Basic) | ClearAllPools | Overloaded. Clears all pools associated with the connection.
static (Shared in Visual Basic) | ClearPool | Clears the pool matching ConnectionString of provided Devart.Data.Oracle.OracleConnection object.
public Method | Clone | Creates a new object that is a copy of the current instance.
public Method | Close | Overridden. Closes the connection to the database. This is the preferred method of closing any open connection.
public Method | Commit | Commits the database transaction.
public Method | CreateCommand | Overloaded. Creates and returns a OracleCommand object associated with the Devart.Data.Oracle.OracleConnection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndOpen | Ends an asynchronous invocation of the Open method. (Inherited from Devart.Common.DbConnectionBase)
public Method | EnlistTransaction | Enlists in the specified transaction. (Inherited from System.Data.Common.DbConnection)
public Method | GetDatabaseInfo | Overloaded. Gets OracleGlobalization settings for the current database.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetLogicalTransactionStatus | Returns the status of the specified transaction. Requires Oracle 12c and works only in OCI mode.
public Method | GetNativeHandle | Gets a native handle for the Devart.Data.Oracle.OracleConnection.
public Method | GetSchema | Overloaded. Returns schema information for the data source of this System.Data.Common.DbConnection. (Inherited from System.Data.Common.DbConnection)
static (Shared in Visual Basic) | GetServerList | Overloaded. Returns an array of available TNS aliases.
public Method | GetSessionInfo | Overloaded. Populates an OracleGlobalization object with client side information.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Opens connection with Proxy Authentication mechanism.
public Method | Ping | Determines whether connection to Oracle server is valid.
public Method | PurgeStatementCache | Clears OCI statement cache for the connection.
public Method | Rollback | Rolls back a transaction from a pending state.
public Method | SetDbmsApplicationInfo | This method uses the DBMS_APPLICATION_INFO package to record the names of the module and action performed and the client information to Oracle database in order to ease tracking of the application actions, performance, and resource usage.
public Method | SetSessionInfo | Sets Oracle globalization settings for the current connection.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when Oracle returns an error message.
public Event | Failover | Occurs when Oracle Failover mechanism takes place.
public Event | HAEvent | Occurs when a HA event happens.
public Event | InfoMessage | Occurs when Oracle returns a warning or informational message.
public Event | StateChange | Occurs when the state of the connection changes. (Inherited from Devart.Common.DbConnectionBase)
public Event | TransactionStateChanged | Occurs when the state of the transaction is changed. (Inherited from Devart.Common.DbConnectionBase)
public Event | TransactionStateChanging | Occurs when the state of the transaction is changing. (Inherited from Devart.Common.DbConnectionBase)
Top

See Also

Reference

OracleConnection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : OracleConnection Constructor

Initializes a new instance of the OracleConnection class.Initializes a new instance of the OracleConnection class.

Overload List

Overload | Description
OracleConnection Constructor() | Initializes a new instance of the OracleConnection class.
OracleConnection Constructor(String) | Initializes a new instance of the OracleConnection class when given a string containing the connection string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnection Constructor()
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > OracleConnection Constructor : OracleConnection Constructor()

Initializes a new instance of the OracleConnection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleConnection()

Remarks

When a new instance of OracleConnection is created, the read/write properties are set to the following initial values unless they are specifically set using their associated keywords in the ConnectionString property.
Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Password | empty string ("")
UserId | empty string ("")

Example

The following example creates and opens a OracleConnection.
C#csharp Copy Code
public void CreateOracleConnection()
{
  OracleConnection myConnection = new OracleConnection();
  myConnection.ConnectionString =
      "User Id=Scott;Password=tiger;Data Source=Ora;";
  myConnection.Open();
  //Do something
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection()
  Dim myConnection As New OracleConnection()
  myConnection.ConnectionString = _
      "User Id=Scott;Password=tiger;Data Source=Ora;"
  myConnection.Open()
  'Do something
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnection Constructor(String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > OracleConnection Constructor : OracleConnection Constructor(String)

connectionString
The connection used to connect to Oracle.
Initializes a new instance of the OracleConnection class when given a string containing the connection string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String _
)
C#
public OracleConnection(
   string connectionString
)

Parameters

connectionString
The connection used to connect to Oracle.

Remarks

When a new instance of OracleConnection is created, the read/write properties are set to the following initial values unless they are specifically set using their associated keywords in the ConnectionString property.
Properties | Initial Value
ConnectionString | connectionString
ConnectionTimeout | 15
Password | empty string ("")
UserId | empty string ("")

Example

The following example creates and opens a OracleConnection.
C#csharp Copy Code
public void CreateOracleConnection()
{
  string myConnString =
      "User Id=Scott;Password=tiger;Data Source=Ora;";
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  //Do something
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection()
  Dim myConnString As String = _
      "User Id=Scott;Password=tiger;Data Source=Ora;"
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  'Do something
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
ConnectionString Property


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleConnection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnection Class

For a list of all members of this type, see OracleConnection members.

Public Methods

 | Name | Description
public Method | BeginOpen | Starts an asynchronous invocation of an Open method. (Inherited from Devart.Common.DbConnectionBase)
public Method | BeginTransaction | Overloaded. Begins a transaction at the database.
public Method | ChangeDatabase | Changes the current database for an open connection. (Inherited from System.Data.Common.DbConnection)
public Method | ChangePassword | Changes the password for the specified user.
static (Shared in Visual Basic) | ClearAllPools | Overloaded. Clears all pools associated with the connection.
static (Shared in Visual Basic) | ClearPool | Clears the pool matching ConnectionString of provided Devart.Data.Oracle.OracleConnection object.
public Method | Clone | Creates a new object that is a copy of the current instance.
public Method | Close | Overridden. Closes the connection to the database. This is the preferred method of closing any open connection.
public Method | Commit | Commits the database transaction.
public Method | CreateCommand | Overloaded. Creates and returns a OracleCommand object associated with the Devart.Data.Oracle.OracleConnection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndOpen | Ends an asynchronous invocation of the Open method. (Inherited from Devart.Common.DbConnectionBase)
public Method | EnlistTransaction | Enlists in the specified transaction. (Inherited from System.Data.Common.DbConnection)
public Method | GetDatabaseInfo | Overloaded. Gets OracleGlobalization settings for the current database.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetLogicalTransactionStatus | Returns the status of the specified transaction. Requires Oracle 12c and works only in OCI mode.
public Method | GetNativeHandle | Gets a native handle for the Devart.Data.Oracle.OracleConnection.
public Method | GetSchema | Overloaded. Returns schema information for the data source of this System.Data.Common.DbConnection. (Inherited from System.Data.Common.DbConnection)
static (Shared in Visual Basic) | GetServerList | Overloaded. Returns an array of available TNS aliases.
public Method | GetSessionInfo | Overloaded. Populates an OracleGlobalization object with client side information.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Opens connection with Proxy Authentication mechanism.
public Method | Ping | Determines whether connection to Oracle server is valid.
public Method | PurgeStatementCache | Clears OCI statement cache for the connection.
public Method | Rollback | Rolls back a transaction from a pending state.
public Method | SetDbmsApplicationInfo | This method uses the DBMS_APPLICATION_INFO package to record the names of the module and action performed and the client information to Oracle database in order to ease tracking of the application actions, performance, and resource usage.
public Method | SetSessionInfo | Sets Oracle globalization settings for the current connection.
Top

See Also

Reference

OracleConnection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginTransaction Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : BeginTransaction Method

Begins a transaction at the database.

Overload List

Overload | Description
BeginTransaction() | Begins a database transaction.
BeginTransaction(IsolationLevel) | Begins a database transaction with the specified isolation level.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginTransaction() Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > BeginTransaction Method : BeginTransaction() Method

Begins a database transaction.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function BeginTransaction() As OracleTransaction
C#
public new OracleTransaction BeginTransaction()

Return Value

An object representing the new transaction.

Remarks

To commit or roll back the transaction, you must explicitly use the Commit or Rollback methods.

Example

The following example creates a OracleConnection and a OracleTransaction. It also demonstrates how to use the BeginTransaction(), Devart.Data.Oracle.OracleConnection.Commit, and Devart.Data.Oracle.OracleConnection.Rollback methods.
C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();

  OracleCommand myCommand = new OracleCommand();
  myCommand.Connection = myConnection;
  OracleTransaction myTrans;

  // Start a local transaction
  myTrans = myConnection.BeginTransaction();
  // Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans;

  try
  {
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myTrans.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub RunOracleTransaction(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()

  Dim myCommand As New OracleCommand()
  myCommand.Connection = myConnection
  Dim myTrans As OracleTransaction

  ' Start a local transaction
  myTrans = myConnection.BeginTransaction()
  ' Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans

  Try
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myTrans.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myTrans.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
OracleCommand Class
OracleTransaction Class
Commit Method
Rollback Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginTransaction(IsolationLevel) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > BeginTransaction Method : BeginTransaction(IsolationLevel) Method

il
Begins a database transaction with the specified isolation level.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function BeginTransaction( _
   ByVal il As IsolationLevel _
) As OracleTransaction
C#
public new OracleTransaction BeginTransaction(
   IsolationLevel il
)

Parameters

il

Return Value

An object representing the new transaction.

Remarks

To commit or roll back the transaction, you must explicitly use the Commit or Rollback methods.

Example

The following example creates a OracleConnection and a OracleTransaction. It also demonstrates how to use the BeginTransaction(), Devart.Data.Oracle.OracleConnection.Commit, and Devart.Data.Oracle.OracleConnection.Rollback methods.
C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();

  OracleCommand myCommand = new OracleCommand();
  myCommand.Connection = myConnection;
  OracleTransaction myTrans;

  // Start a local transaction
  myTrans = myConnection.BeginTransaction(IsolationLevel.ReadCommitted);
  // Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans;

  try
  {
    myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myTrans.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub RunOracleTransaction(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()

  Dim myCommand As New OracleCommand()
  myCommand.Connection = myConnection
  Dim myTrans As OracleTransaction

  ' Start a local transaction
  myTrans = myConnection.BeginTransaction(IsolationLevel.ReadCommitted)
  ' Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans

  Try
    myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myTrans.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myTrans.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
OracleCommand Class
OracleTransaction Class
Commit Method
Rollback Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ChangePassword Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ChangePassword Method

newPassword
The new password.
Changes the password for the specified user.

Syntax

Visual Basic (Declaration)
Public Sub ChangePassword( _
   ByVal newPassword As String _
)
C#
public void ChangePassword(
   string newPassword
)

Parameters

newPassword
The new password.

Remarks

Use the ChangePassword method to change user's password if the current password is obsolete. If a session is not opened the ChangePassword method opens the session automatically with username and password specified at UserId and Password properties.

For OCI mode connections, the Oracle Client version must be the same as the Oracle server version.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClearAllPools Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ClearAllPools Method

Clears all pools associated with the connection.

Overload List

Overload | Description
ClearAllPools() | Clears all pools associated with the connection.
ClearAllPools(Boolean) | Clears all pools associated with the connection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClearAllPools() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > ClearAllPools Method : ClearAllPools() Method

Clears all pools associated with the connection.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ClearAllPools()
C#
public static void ClearAllPools()

Remarks

Pools are automatically cleared if a connection is idle for some time or closed by the server. Call ClearAllPools to force explicit pools clearance.

ClearAllPools method does not immediately clear the pools. The operation is started in approximately 30 seconds. The main thread of the application is not blocked.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClearAllPools(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > ClearAllPools Method : ClearAllPools(Boolean) Method

forced
Determines whether to start the operation immediately, or after the timeout.
Clears all pools associated with the connection.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ClearAllPools( _
   ByVal forced As Boolean _
)
C#
public static void ClearAllPools(
   bool forced
)

Parameters

forced
Determines whether to start the operation immediately, or after the timeout.

Remarks

Pools are automatically cleared if a connection is idle for some time or closed by the server. Call the ClearAllPools method to force explicit pools clearance.

Note: if forced=false, this function is equivalent to ClearAllPools.

If there are many opened connections, immediate pool clearing can cause high server load, so it is recommended to use forced = false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClearPool Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ClearPool Method

connection
A connection that holds ConnectionString that identifies pool to clear.
Clears the pool matching ConnectionString of provided OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Shared Sub ClearPool( _
   ByVal connection As OracleConnection _
)
C#
public static void ClearPool(
   OracleConnection connection
)

Parameters

connection
A connection that holds ConnectionString that identifies pool to clear.

Remarks

Pool is automatically cleared if a connection is idle for some time or closed by the server. Call ClearPool to force explicit pool clearance.

ClearPool does not immediately clear the pool. The operation is started in approximately 30 seconds. The main thread of the application is not blocked.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Clone Method

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleConnection
C#
public OracleConnection Clone()

Return Value

A new OracleConnection object.

Remarks

Creates a new OracleConnection object with the properties that have the same values as those of the original object. However, changing properties of the new object has no influence on the values of the same properties of the original object.

Note that state of the new instance is always Closed, regardless of the state of original instance.

Example

This example shows how to clone a OracleConnection. To make sure all the properties are inherited, one of them (UserId) is written to the console.
C#csharp Copy Code
public void CloneAConnection()
{
  OracleConnection myConnection = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  OracleConnection myConnection2 = myConnection.Clone();
  Console.WriteLine(myConnection2.UserId);
}
C#Visual Basic Copy Code
Public Sub CloneAConnection()
  Dim myConnection As New OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myConnection2 As OracleConnection = myConnection.Clone()
  Console.WriteLine(myConnection2.UserId)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Close Method

Closes the connection to the database. This is the preferred method of closing any open connection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

The M:Devart.Common.DbConnection.Close() method rolls back any pending transactions. It then releases the connection to the connection pool, or closes the connection if connection pooling is disabled.

Note that you must manually close all connections opened by the application. If a T:Devart.Common.DbConnection goes out of scope, it is not closed automatically till the application shuts down.

An application can call M:Devart.Common.DbConnection.Close() more than one time without generating an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Commit Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Commit Method

Commits the database transaction.

Syntax

Visual Basic (Declaration)
Public Sub Commit()
C#
public void Commit()

Example

The following example demonstrates how to use Commit and Rollback methods.
C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  OracleCommand myCommand = new OracleCommand();
  myCommand.Connection = myConnection;
  myConnection.BeginTransaction();
  try
  {
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myConnection.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myConnection.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub RunOracleTransaction(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  Dim myCommand As New OracleCommand()
  myCommand.Connection = myConnection
  myConnection.BeginTransaction()
  Try
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myConnection.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myConnection.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Rollback Method
BeginTransaction Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : CreateCommand Method

Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection.

Overload List

Overload | Description
CreateCommand() | Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection.
CreateCommand(String) | Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection, and having the specified command text.
CreateCommand(String,CommandType) | Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection, and having the specified command text and command type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommand() Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > CreateCommand Method : CreateCommand() Method

Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Function CreateCommand() As OracleCommand
C#
public new OracleCommand CreateCommand()

Return Value

A Devart.Data.Oracle.OracleCommand object.

Remarks

You can use this method as an alternative to common Devart.Data.Oracle.OracleCommand constructors.

Example

In this sample Devart.Data.Oracle.OracleCommand object is created. It is automatically associated with OracleConnection that created it.
C#csharp Copy Code
public void CreateOracleCommand(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  OracleCommand myCommand = myConnection.CreateCommand();
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')";
  myConnection.Open();
  try
  {
    myCommand.ExecuteNonQuery();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub CreateOracleCommand(ByVal myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  Dim myCommand As OracleCommand = myConnection.CreateCommand()
  myCommand.CommandText = "INSERT INTO DEPT VALUES (50,'Development','Philadelphia')"
  myConnection.Open()
  Try
    myCommand.ExecuteNonQuery()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommand(String) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > CreateCommand Method : CreateCommand(String) Method

commandText
The command text to assign to the command object.
Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection, and having the specified command text.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateCommand( _
   ByVal commandText As String _
) As OracleCommand
C#
public OracleCommand CreateCommand(
   string commandText
)

Parameters

commandText
The command text to assign to the command object.

Return Value

A Devart.Data.Oracle.OracleCommand object.

Remarks

You can use this method as an alternative to common Devart.Data.Oracle.OracleCommand constructors.

Example

In this sample Devart.Data.Oracle.OracleCommand object is created. It is automatically associated with OracleConnection that created it.
C#csharp Copy Code
public void CreateOracleCommand(string myConnString)
{
        OracleConnection myConnection = new OracleConnection(myConnString);
        OracleCommand myCommand = myConnection.CreateCommand("INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')");
        myConnection.Open();
        try
        {
                myCommand.ExecuteNonQuery();
        }
        finally
        {
                myConnection.Close();
        }
}
C#Visual Basic Copy Code
Public Sub CreateOracleCommand(ByVal myConnString As String)
        Dim myConnection As New OracleConnection(myConnString)
        Dim myCommand As OracleCommand = myConnection.CreateCommand("INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')")
        myConnection.Open()
        Try
                myCommand.ExecuteNonQuery()
        Finally
                myConnection.Close()
        End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommand(String,CommandType) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > CreateCommand Method : CreateCommand(String,CommandType) Method

commandText
The command text to assign to the command object.
commandType
One of the System.Data.CommandType values.
Creates and returns a Devart.Data.Oracle.OracleCommand object associated with the OracleConnection, and having the specified command text and command type.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateCommand( _
   ByVal commandText As String, _
   ByVal commandType As CommandType _
) As OracleCommand
C#
public OracleCommand CreateCommand(
   string commandText,
   CommandType commandType
)

Parameters

commandText
The command text to assign to the command object.
commandType
One of the System.Data.CommandType values.

Return Value

A Devart.Data.Oracle.OracleCommand object.

Remarks

You can use this method as an alternative to common Devart.Data.Oracle.OracleCommand constructors.

Example

In this sample Devart.Data.Oracle.OracleCommand object is created. It is automatically associated with OracleConnection that created it.
C#csharp Copy Code
public void CreateOracleCommand(string myConnString)
{
        OracleConnection myConnection = new OracleConnection(myConnString);
        OracleCommand myCommand = myConnection.CreateCommand("INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')", CommandType.Text);
        myConnection.Open();
        try
        {
                myCommand.ExecuteNonQuery();
        }
        finally
        {
                myConnection.Close();
        }
}
C#Visual Basic Copy Code
Public Sub CreateOracleCommand(ByVal myConnString As String)
        Dim myConnection As New OracleConnection(myConnString)
        Dim myCommand As OracleCommand = myConnection.CreateCommand("INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')", CommandType.Text)
        myConnection.Open()
        Try
                myCommand.ExecuteNonQuery()
        Finally
                myConnection.Close()
        End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDatabaseInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : GetDatabaseInfo Method

Gets OracleGlobalization settings for the current database.

Overload List

Overload | Description
GetDatabaseInfo() | Gets OracleGlobalization settings for the current database.
GetDatabaseInfo(OracleGlobalization) | Gets OracleGlobalization settings for the current database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDatabaseInfo() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetDatabaseInfo Method : GetDatabaseInfo() Method

Gets OracleGlobalization settings for the current database.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDatabaseInfo() As OracleGlobalization
C#
public OracleGlobalization GetDatabaseInfo()

Return Value

An OracleGlobalization object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDatabaseInfo(OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetDatabaseInfo Method : GetDatabaseInfo(OracleGlobalization) Method

oraGlob
An OracleGlobalization object.
Gets OracleGlobalization settings for the current database.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetDatabaseInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public void GetDatabaseInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetLogicalTransactionStatus Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : GetLogicalTransactionStatus Method

ltxid
The logical transaction ID (LTXID).
Returns the status of the specified transaction. Requires Oracle 12c and works only in OCI mode.

Syntax

Visual Basic (Declaration)
Public Function GetLogicalTransactionStatus( _
   ByVal ltxid() As Byte _
) As OracleLogicalTransactionStatus
C#
public OracleLogicalTransactionStatus GetLogicalTransactionStatus(
   byte[] ltxid
)

Parameters

ltxid
The logical transaction ID (LTXID).

Return Value

The status of the specified transaction.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
IsRecoverable Property
LogicalTransactionId Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeHandle Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : GetNativeHandle Method

Gets a native handle for the OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function GetNativeHandle() As HandleRef
C#
public HandleRef GetNativeHandle()

Return Value

A System.Runtime.InteropServices.HandleRef.

Remarks

Note: This method is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetServerList Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : GetServerList Method

Returns an array of available TNS aliases.

Overload List

Overload | Description
GetServerList() | Returns an array of available TNS aliases.
GetServerList(String) | Returns an array of available TNS aliases.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetServerList() Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetServerList Method : GetServerList() Method

Returns an array of available TNS aliases.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetServerList() As String()
C#
public static string[] GetServerList()

Return Value

An array of available TNS aliases.

Remarks

Use GetServerList() function to read TNS aliases from TNSNAMES.ORA configuration file found in Oracle default home directory.

Example

The following example obtains and then prints list of the servers.
C#csharp Copy Code
public void DisplayServerList()
{
  string[] serverList = OracleConnection.GetServerList();
  foreach (string server in serverList)
  Console.WriteLine(server);
}
C#Visual Basic Copy Code
Public Sub DisplayServerList()
  Dim serverList As String() = OracleConnection.GetServerList()
  Dim server As String
  For Each server In  serverList
    Console.WriteLine(server)
  Next server
End Sub 'DisplayServerList

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetServerList(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetServerList Method : GetServerList(String) Method

homeName
Name of the Oracle home to read TNS aliases from.
Returns an array of available TNS aliases.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetServerList( _
   ByVal homeName As String _
) As String()
C#
public static string[] GetServerList(
   string homeName
)

Parameters

homeName
Name of the Oracle home to read TNS aliases from.

Return Value

An array of available TNS aliases.

Remarks

Use GetServerList(String) function to read TNS aliases from TNSNAMES.ORA configuration file found in specified Oracle home directory.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSessionInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : GetSessionInfo Method

Populates an OracleGlobalization object with client side information.

Overload List

Overload | Description
GetSessionInfo() | Populates an OracleGlobalization object with client side information.
GetSessionInfo(OracleGlobalization) | Populates an OracleGlobalization object with client side information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSessionInfo() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetSessionInfo Method : GetSessionInfo() Method

Populates an OracleGlobalization object with client side information.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetSessionInfo() As OracleGlobalization
C#
public OracleGlobalization GetSessionInfo()

Return Value

A new OracleGlobalization object with the Oracle globalization settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSessionInfo(OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > GetSessionInfo Method : GetSessionInfo(OracleGlobalization) Method

oraGlob
An OracleGlobalization object to be populated with the Oracle globalization settings.
Populates an OracleGlobalization object with client side information.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetSessionInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public void GetSessionInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization object to be populated with the Oracle globalization settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Open Method

Opens connection with Proxy Authentication mechanism.

Overload List

Overload | Description
Open(OracleConnection) | Opens connection with Proxy Authentication mechanism.
Open() | Opens a Oracle connection with the property settings specified by the ConnectionString.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open(OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > Open Method : Open(OracleConnection) Method

proxy
The established proxy connection to use.
Opens connection with Proxy Authentication mechanism.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal proxy As OracleConnection _
)
C#
public void Open(
   OracleConnection proxy
)

Parameters

proxy
The established proxy connection to use.

Remarks

When you open a proxied connection, you do not need to specify username and password.

Do not mix this method of opening proxied connections with specifying proxy credentials in OCI Pool connection string.

Proxy authentication is not supported in Direct mode.

For more information on using Proxy Authentication see Connecting to Oracle with Proxy Authentication.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
ProxyUserId Property
ProxyPassword Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open() Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class > Open Method : Open() Method

Opens a Oracle connection with the property settings specified by the ConnectionString.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Open()
C#
public override void Open()

Remarks

The OracleConnection draws an open connection from the connection pool if one is available. Otherwise, it establishes a new connection to the data source.

Note: If the OracleConnection goes out of scope, the connection it represents does not close automatically. Therefore, you must explicitly close the connection by calling Devart.Common.DbConnectionBase.Close.

Opening an open connection does nothing.

Example

The following example creates a OracleConnection, opens it, displays some of its properties, and then closes the connection.
C#csharp Copy Code
public void CreateOracleConnection(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  MessageBox.Show("ServerVersion: " + myConnection.ServerVersion
    + "\nState: " + myConnection.State.ToString());
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  MessageBox.Show("ServerVersion: " + myConnection.ServerVersion _
    + ControlChars.Cr + "State: " + myConnection.State.ToString())
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Overload List
Close Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Ping Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Ping Method

Determines whether connection to Oracle server is valid.

Syntax

Visual Basic (Declaration)
Public Function Ping() As Boolean
C#
public bool Ping()

Return Value

true, if the connection is valid; otherwise, false.

Remarks

If the application has an open connection for a long time, it is recommended to check whether the connection is still valid, before using it. Call of Ping method has single round trip on Oracle server.

It is not a good idea to keep a connection open for long time. Connection pool automatically pings all connections within, thus closing old connections and opening new ones is encouraged.

If the connection being pinged is not initialized or has the state other than ConnectionState.Open, the method throws an exception.

Example

This code sample shows how to check for server availability before issuing a query.
C#csharp Copy Code
public void ExecuteSafely(OracleConnection connection)
{
        OracleCommand command = new OracleCommand("INSERT INTO Dept(DeptNo, DName) Values('50', 'DEVELOPMENT')");
        command.Connection = connection;
        try
        {
                if (connection.Ping())
                {
                        command.ExecuteNonQuery();
                        Console.WriteLine("Successfully executed");
                }
                else
                {
                        connection.Close();
                        Console.WriteLine("Unable to ping the server");
                }
        }
        catch
        {
                connection.Close();
                Console.WriteLine("Error during query execution");
        }
}
C#Visual Basic Copy Code
Public Sub ExecuteSafely(ByVal connection As OracleConnection)
        Dim command As New OracleCommand("INSERT INTO Dept(DeptNo, DName) Values('50', 'DEVELOPMENT')")
        command.Connection = connection
        Try
                If (connection.Ping()) Then
                        command.ExecuteNonQuery()
                        Console.WriteLine("Successfully executed")
                Else
                        connection.Close()
                        Console.WriteLine("Unable to ping the server")
                End If
        Catch
                connection.Close()
                Console.WriteLine("Error during query execution")
        End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeStatementCache Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : PurgeStatementCache Method

Clears OCI statement cache for the connection.

Syntax

Visual Basic (Declaration)
Public Sub PurgeStatementCache()
C#
public void PurgeStatementCache()

Remarks

This method works in OCI mode only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Rollback Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Rollback Method

Rolls back a transaction from a pending state.

Syntax

Visual Basic (Declaration)
Public Sub Rollback()
C#
public void Rollback()

Example

The following example demonstrates how to use Commit and Rollback methods.
C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();

  OracleCommand myCommand = new OracleCommand();
  myConnection.BeginTransaction();
  try
  {
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myConnection.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myConnection.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub RunOracleTransaction(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()

  Dim myCommand As New OracleCommand()
  myConnection.BeginTransaction()
  Try
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myConnection.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myConnection.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Commit Method
BeginTransaction Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDbmsApplicationInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : SetDbmsApplicationInfo Method

moduleName
The module name to record.
actionName
The action name to record.
clientInfo
The client information to record.
This method uses the DBMS_APPLICATION_INFO package to record the names of the module and action performed and the client information to Oracle database in order to ease tracking of the application actions, performance, and resource usage.

Syntax

Visual Basic (Declaration)
Public Sub SetDbmsApplicationInfo( _
   ByVal moduleName As String, _
   ByVal actionName As String, _
   ByVal clientInfo As String _
)
C#
public void SetDbmsApplicationInfo(
   string moduleName,
   string actionName,
   string clientInfo
)

Parameters

moduleName
The module name to record.
actionName
The action name to record.
clientInfo
The client information to record.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetSessionInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : SetSessionInfo Method

oraGlob
An OracleGlobalization object.
Sets Oracle globalization settings for the current connection.

Syntax

Visual Basic (Declaration)
Public Sub SetSessionInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public void SetSessionInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleConnection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnection Class

For a list of all members of this type, see OracleConnection members.

Public Properties

 | Name | Description
public Property | ActionName | Gets or sets the action name for the connection.
public Property | AutoCommit | Determines whether modifications will be committed automatically at the server or not.
public Property | ClientId | This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.
public Property | ClientInfo | Gets or sets the client information for the connection.
public Property | ClientVersion | Returns version of Oracle client used for this connection.
public Property | ConnectionString | Gets or sets the string used to open an Oracle server database.
public Property | ConnectionTimeout | Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | ConnectMode | Opens a session with administrative privileges SYSDBA or SYSOPER.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DataSource | Gets the name of the database server to which to connect. (Inherited from System.Data.Common.DbConnection)
public Property | Direct | Indicates whether Direct mode of communicating with server should be used.
public Property | Home | Gets or sets Oracle Home to be used.
static (Shared in Visual Basic) | Homes | Gets the list of all available Oracle homes.
public Property | InDistributedTransaction | Indicates whether the connection is enlisted in a distributed transaction. (Inherited from Devart.Common.DbConnectionBase)
public Property | LogicalTransactionId | Gets the logical transaction ID (LTXID) of the last executed translation. Can be used for determining the outcome of the last transaction, opened by this connection, following an outage. Requires Oracle 12c and works only in OCI mode.
public Property | ModuleName | Gets or sets the module name for the connection.
public Property | Name | Gets or sets name of the component.
public Property | NumberMappings | Gets or sets the collection of number mappings used for this connection.
public Property | OracleLogicalTransaction | Gets an OracleLogicalTransaction object, which allows you to determine whether the running transaction during the last database outage was successfully committed and completed.
public Property | Owner | Gets or sets a form or other container that the OracleConnection instance belongs to.
public Property | PassParametersByName | Determines whether parameters will be passed by name to the stored procedure calls.
public Property | Password | Gets or sets the user's password to connect.
public Property | Port | Gets or sets number of a port to communicate with listener on the server.
public Property | Server | Gets or sets the name of TNS alias of the Oracle database to which to connect.
public Property | ServerType | Indicates whether the connected database is an Oracle database or a TimesTen database.
public Property | ServerVersion | Gets a string containing the version of the instance of Oracle to which the client is connected.
public Property | ServiceName | Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.
public Property | ShortServerVersion | Gets the version of the instance of Oracle Database, the Devart.Data.Oracle.OracleConnection object is connected to, as a System.Version object.
public Property | Sid | Gets or sets a unique name for an Oracle database instance.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | State | Gets the current state of the connection.
public Property | TrimFixedChar | Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).
public Property | Unicode | Gets or sets a value indicating whether the UTF16 charset will be used.
public Property | UserId | Gets or sets the name of the user to connect.
Top

See Also

Reference

OracleConnection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ActionName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ActionName Property

Gets or sets the action name for the connection.

Syntax

Visual Basic (Declaration)
Public Property ActionName As String
C#
public string ActionName {get; set;}

Property Value

The string, representing the action name for the connection.

Remarks

When you set this property, the SET_ACTION procedure from the DBMS_APPLICATION_INFO package is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AutoCommit Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : AutoCommit Property

Determines whether modifications will be committed automatically at the server or not.

Syntax

Visual Basic (Declaration)
Public Property AutoCommit As Boolean
C#
public bool AutoCommit {get; set;}

Property Value

true if Commit is called for the current transaction after the execution of each SQL statement; otherwise, false. The default value is true.

Remarks

By default, dotConnect for Oracle provider is in AutoCommit mode that commits a current transaction automatically after the execution of each SQL statement. If a transaction was started explicitly by calling OracleConnection.BeginTransaction method the value of AutoCommit property is ignored.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ClientId Property

This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.

Syntax

Visual Basic (Declaration)
Public Property ClientId As String
C#
public string ClientId {get; set;}

Property Value

The string to be used as the client identifier.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientInfo Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ClientInfo Property

Gets or sets the client information for the connection.

Syntax

Visual Basic (Declaration)
Public Property ClientInfo As String
C#
public string ClientInfo {get; set;}

Property Value

The string, representing the client information for the connection.

Remarks

When you set this property, the SET_CLIENT_INFO procedure from the DBMS_APPLICATION_INFO package is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ClientVersion Property

Returns version of Oracle client used for this connection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientVersion As String
C#
public string ClientVersion {get;}

Property Value

A string containing the Oracle client version. In OracleConnection.Direct Mode, returns "9.2.0.0".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionString Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ConnectionString Property

Gets or sets the string used to open an Oracle server database.

Syntax

Visual Basic (Declaration)
Public Shadows Property ConnectionString As String
C#
public new string ConnectionString {get; set;}

Property Value

The connection string that includes the source database name, and other parameters needed to establish the initial connection. The default value is an empty string ("").

Remarks

The ConnectionString property can be set only when the connection is closed; setting ConnectionString of an opened connection closes this connection. Many of the connection string values have corresponding properties. When the connection string is set, all of these properties are updated, except when an error is detected. In this case, none of the properties are updated. OracleConnection properties return only those settings contained in the ConnectionString.

Resetting the ConnectionString on a closed connection resets all connection string values (and related properties) including the password. For example, if you set a connection string that includes "Home = OraClient11g_Home1", and then reset the connection string to "Data Source=ora; User ID = Scott; Password = tiger", the Home property is no longer set to 'OraClient11g_Home1'.

The connection string is parsed immediately after being set. If errors in syntax are found when parsing, a runtime exception, such as System.ArgumentException, is generated. Other errors can be found only when an attempt is made to open the connection.

The ConnectionString property format is the same as for common ADO.NET connection strings. Connection string consists of pairs of parameter name and parameter value connected by the equal sign (=). Each pair should be separated from the previous one by a semicolon. Parameter values may be specified inside single or double qotes, (for example, name='value' or name="value"). Either single or double quotes may be used in a value if it is set using another type of quotes, for example, name="value's" or name= 'value"s', but not name= 'value's' or name= ""value"". If a semicolon is a part of a value, the value must be quoted. All blank characters, except those placed within a value or within quotes, are ignored. No escape sequences are supported. The value type is irrelevant. Parameter names are case insensitive. Arguments names may occur only once in the connection string.

The following table lists the valid names for values within the ConnectionString.

Name | Description
ClientId | Specifies the client identifier for the connection.
Connect Mode | Allows to open a session with administrative privileges SYSDBA or SYSOPER.
Connection Class | Connection class for Oracle's Database Resident Connection Pooling (DRCP). You need to set also OCI Session Pooling = true for using DRCP. DRCP is supported starting with Oracle 11g.
Connection Lifetime | When a connection is returned to the pool, its creation time is compared with the current time, and the connection is destroyed if that time span (in seconds) exceeds the value specified by Connection Lifetime. The default value is 0.
Connection Timeout | Time (in seconds) to wait while trying to establish a connection before terminating the attempt and generating an error. A value of 0 indicates no limit. The default value is 15 seconds.
Data Source -or- Server -or- Host | The name of TNS alias of Oracle database to which to connect. For more information refer to Server property.
Default Command Timeout | The time in seconds to wait while trying to execute a command before terminating the attempt and generating an error. 0 indicates no limit.
DescribeStoredProcedure -or- Describe Stored Procedure | Enables or disables additional check queries, performed when executing an Devart.Data.Oracle.OracleCommand with CommandType equal to CommandType.StoredProcedure. See more details in OracleConnectionStringBuilder.DescribeStoredProcedure.
Direct | If true, dotConnect for Oracle can operate without an Oracle client installed. The default value is false. See Using Direct Mode for more information.
Enlist | Determines whether the connection is automatically enlisted in the current distributed transaction. The default value is true. This parameter is not available in Mobile Edition.
HA Events | Allows dotConnect for Oracle to proactively remove connections to cooresponding Oracle database service, service member, instance, or node from the pool when this service, service member, instance, or node goes down.
Home | The Oracle Home that will be used.
Initialization Command | Specifies a database-specific command that should be executed immediately after establishing the connection. You can specify a sequence of several commands in this parameter.
Lob Block Size | Specifies the size of a block (in megabytes) to read/write CLOB or NCLOB data from/to database. This option is supported in OCI mode only. Applicable only for Unicode Oracle servers. Default value is 0, which means that the whole value is sent in one block. If you get errors when reading/writing huge LOB values, try setting this property to 8, it is the safest value.
Max Pool Size | The maximum number of connections allowed in the pool. Setting the Max Pool Size value of the ConnectionString can affect performance. The default value is 100.
Min Pool Size | The minimum number of connections allowed in the pool. The default value is 0.
Number Mappings

Sets the number mappings used for this connection. Each mapping is set as (OracleNumberType, FromPrecision, ToPrecision, SystemType), where:

- OracleNumberType is one of the values from OracleNumberType enumeration;
FromPrecision and ToPrecision set the minimal and maximal precisions of the Oracle number type to map with this mapping;
SystemType is a .NET type to which Oracle number type should be mapped.

Several mappings should be separated by commas and covered by a common parentheses. For example, this property may be set as:
Number Mappings = (Integer, 1, 1, System.Boolean)
or
Number Mappings = ((Integer, 1, 5, System.Int16), (FLOAT,12,15,System.Decimal), (NUMBER,7,9,System.Single))
Oci Session Pooling | If true, enables the OCI Session Pooling feature. In this mode the dotConnect for Oracle pool is disabled.
Oci Session Pool Allow Waiting | If true, new connections wait for an existing one to close if Max Size is reached; otherwise an exception is thrown.
Oci Session Pool Connection Lifetime | This attribute specifies the lifetime of the connection in seconds. Before the Connection is placed back into the pool, the lifetime of the connection is checked. If the lifetime of the connection exceeds this property value, the connection is closed and disposed. If this property value is 0, the connection lifetime is never checked.
Oci Session Pool Increment | Allows applications to set the next increment for sessions to be started if the current number of sessions is less than Max Size. The valid values are 1 and above.
Oci Session Pool Max Size | Specifies the maximum number of sessions that can be opened in the session pool. Once this value is reached, no more sessions are opened. The valid values are 1 and above.
Oci Session Pool Min Size | Specifies the minimum number of sessions in the session pool. This number of sessions are started initially. After this, sessions are opened only when necessary.
Oci Session Pool Password | If set, defines password for proxy user.
Oci Session Pool User Id | If set, defines user name for proxy user. Available only when OCI Session Pooling is enabled. If you want to have proxy connections without OCI Session Pooling, use the Open(OracleConnection) overload that accepts another OracleConnection as argument.
OraMts | If set to true, Oracle Services for Microsoft Transaction Server (OraMTS) is used for distributed transactions; otherwise OraMTS is not used.
Pass Parameters By Name | Pass parameters by name to the stored procedure calls. If set to true, parameters will be passed by name regardless of individual OracleCommand.PassParametersByName values. Default value is false.
Password | The password for the Oracle login account. Leave blank if you want to use Integrated Security connections (OS authentication)
Pooling | If true, by default, the OracleConnection object is drawn from the appropriate pool or is created and added to the appropriate pool.
Port | Number of a port to communicate with listener on the server to use in OracleConnection.Direct mode. The default value is 1521.
Run Once Command | Specifies a database-specific command that should be executed immediately after establishing the connection. Unlike Initialization Command, it is not executed when a connection is taken from the pool.
Service Name | Alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode. The default value is empty string. When Service Name is specified and implies several database instances, dotConnect for Oracle connects to the first instance provided by Oracle listener. Note that RAC is not supported in the Direct mode, and provider works only with this one database instance.
SID | Unique name for an Oracle database instance to use in the OracleConnection.Direct mode. The default value is empty string.
Statement Cache Purge | Determines whether to clear the OCI statement cache when closing the connection or putting it to the pool. The default value is false.
Statement Cache Size | This attribute enables or disables statement caching. Its value specifies the maximum number of statements that can be cached for a connection. By default this attribute is set to 0 (disabled). Statement caching starts if this parameter is set to a value more than 0. It should not be more than MAX_OPEN_CURSORS parameter in an Oracle database.
Transaction Scope Local | If there are several connections with the same connection string (which includes "Transaction Scope Local=true;") within a scope of TransactionScope, our provider will use only one connection internally. The default value is false. Not available in Mobile Edition.
Trim Fixed Char | Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR). It affects all command objects of this connection. Behaviour of data reader depends on Trim Fixed Char value at the moment of opening data reader. The default value is true.
Unicode | Specifies whether dotConnect for Oracle uses UTF16 mode API calls. The default value is false.
Use Performance Monitor | Enables dotConnect for Oracle performance counters that allow you to conveniently measure the frequency of connecting/disconnecting to the data source, the number of active connections, pooled connections, etc. via Windows Performance Monitor or programmatically. See Performance Counters Support for more information.
User ID -or- User | The Oracle login account. Leave blank if you want to use Integrated Security connections (OS authentication).
Validate Connection | Specifies whether to validate connections that are being got from the pool.

Example

The following example creates an OracleConnection and sets some of its properties in the connection string.
C#csharp Copy Code
public void CreateOraConnection()
{
        string oracleConnectionString1 = "User ID=Scott; Password=tiger; Data Source=ORA";
        OracleConnection oracleConnection1 = new OracleConnection(oracleConnectionString1);
        oracleConnection1.Open();

        string oracleConnectionString2 =
                "User ID=Scott; Password=tiger; Direct = true; Host=ORA; Service Name=SID; Port=1521;";
        OracleConnection oracleConnection2 = new OracleConnection(oracleConnectionString2);
        oracleConnection2.Open();
}
C#Visual Basic Copy Code
Public Sub CreateOraConnection()
        Dim OracleConnectionString1 As String = "User ID=Scott; Password=tiger; Data Source=ORA"
        Dim OracleConnection1 As New OracleConnection(OracleConnectionString1)
        OracleConnection1.Open()

        Dim OracleConnectionString2 As String = _
                "User ID=Scott; Password=tiger; Direct = true; Host=ORA; Service Name=SID; Port=1521;"
        Dim OracleConnection2 As New OracleConnection(OracleConnectionString2)
        OracleConnection2.Open()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Open Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ConnectionTimeout Property

Gets the time to wait while trying to establish a connection before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property ConnectionTimeout As Integer
C#
public new int ConnectionTimeout {get;}

Property Value

The time (in seconds) to wait for a connection to open. The default value is 15 seconds.

Remarks

A value of 0 indicates no limit, and should be avoided in a ConnectionString because an attempt to connect will wait indefinitely. Use connection string to overwrite this value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ConnectMode Property

Opens a session with administrative privileges SYSDBA or SYSOPER.

Syntax

Visual Basic (Declaration)
Public Property ConnectMode As OracleConnectMode
C#
public OracleConnectMode ConnectMode {get; set;}

Property Value

An OracleConnectModevalue to determine user privileges.

Remarks

To open a session with SYSDBA or SYSOPER privileges the user must have appropriate privileges.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Direct Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Direct Property

Indicates whether Direct mode of communicating with server should be used.

Syntax

Visual Basic (Declaration)
Public Property Direct As Boolean
C#
public bool Direct {get; set;}

Property Value

true, if dotConnect for Oracle should interact with Oracle server directly; otherwise, false. The default value is false.

Remarks

When OracleConnection.Direct property is true, dotConnect for Oracle does not require Oracle client libraries installed. When a value is assigned to this property, the OracleConnection is closed. Refer to "Using Direct Mode" article for detailed information.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework. OracleConnection from the .NET Standard 1.3 compatible assembly always uses the Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Home Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Home Property

Gets or sets Oracle Home to be used.

Syntax

Visual Basic (Declaration)
Public Property Home As String
C#
public string Home {get; set;}

Property Value

An Oracle Home to be used.

Remarks

Set Home property to select what Oracle client will be used in your application. Use this property if there are some Oracle clients installed at the machine. If Home property is empty dotConnect for Oracle uses default Home. You can change a value of the default home by Oracle Home Selector.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Homes Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Homes Property

Gets the list of all available Oracle homes.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Homes As OracleHomeCollection
C#
public static OracleHomeCollection Homes {get;}

Property Value

The list of all available Oracle homes.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LogicalTransactionId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : LogicalTransactionId Property

Gets the logical transaction ID (LTXID) of the last executed translation. Can be used for determining the outcome of the last transaction, opened by this connection, following an outage. Requires Oracle 12c and works only in OCI mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LogicalTransactionId As Byte()
C#
public byte[] LogicalTransactionId {get;}

Property Value

The logical transaction ID (LTXID) of the last executed translation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
GetLogicalTransactionStatus Method
IsRecoverable Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ModuleName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ModuleName Property

Gets or sets the module name for the connection.

Syntax

Visual Basic (Declaration)
Public Property ModuleName As String
C#
public string ModuleName {get; set;}

Property Value

The string, representing the module name for the connection.

Remarks

When you set this property, the SET_MODULE procedure from the DBMS_APPLICATION_INFO package is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Name Property

Gets or sets name of the component.

Syntax

Visual Basic (Declaration)
Public Shadows Property Name As String
C#
public new string Name {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NumberMappings Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : NumberMappings Property

Gets or sets the collection of number mappings used for this connection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NumberMappings As OracleNumberMappingCollection
C#
public OracleNumberMappingCollection NumberMappings {get;}

Property Value

A Devart.Data.Oracle.OracleNumberMappingCollection object representing the number mappings.

Remarks

Allows you to override default number mapping rules for the connection. Default value is an empty collection, which means to use default rules.

Example

This sample demonstrates how to override default number mapping rules.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection();

// Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, typeof(Int64));

// Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, typeof(bool));
C#Visual Basic Copy Code
Dim oracleConnection as New OracleConnection

' Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, GetType(Int64))

' Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, GetType(Boolean))

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
OracleNumberMappingCollection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLogicalTransaction Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : OracleLogicalTransaction Property

Gets an OracleLogicalTransaction object, which allows you to determine whether the running transaction during the last database outage was successfully committed and completed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OracleLogicalTransaction As OracleLogicalTransaction
C#
public OracleLogicalTransaction OracleLogicalTransaction {get;}

Property Value

A OracleLogicalTransaction object for OCI mode connection to Oracle 12c and higher. Null for OracleConnection.Direct mode connection or connection to Oracle with version lower than 12c.

Example

The following example demonstrates how to use the OracleLogicalTransaction class and its members in order to correctly process database outages and resubmit or rollback the last running transaction depending on its status.
C#csharp Copy Code
using System;
using Devart.Data.Oracle;

class Test
{
        static void Main()
        {
                string constr = "User Id=Scott;Password=tiger;Data Source=Ora;";
                OracleConnection connection = new OracleConnection(constr);
                OracleTransaction transaction = null;
                OracleCommand command = null;

                try
                {
                        connection.Open();
                        transaction = connection.BeginTransaction();
                        command = new OracleCommand(connection, "update emp set dept=10 where empno=4321");
                        command.ExecuteNonQuery();
                }
                catch(Exception e)
                {
                        Console.WriteLine(e.ToString());
                        return;
                }

                try
                {
                        transaction.Commit();
                }
                catch(Exception e)
                {
                        if (e.IsRecoverable)
                        {
                                OracleLogicalTransaction logicalTransaction = connection.OracleLogicalTransaction;
                                logicalTransaction.GetOutcome(); // or logicalTransaction.GetOutcome("scott", "tiger", "inst1");

                                if (!logicalTransaction.Committed && !logicalTransaction.UserCallCompleted)
                                {
                                // any chosen processing here if a retry is desired.
                        }
                                else
                                {
                                // transaction committed, but was not full completed
                                }
                                }
                        else
                        {
                                // Not recoverable transaction. Rollback (and re-execute).
                        }
                }
        }
}
C#Visual Basic Copy Code
Imports Devart.Data.Oracle

Class Test
        Private Shared Sub Main()
                Dim constr As String = "User Id=Scott;Password=tiger;Data Source=Ora;"
                Dim connection As New OracleConnection(constr)
                Dim transaction As OracleTransaction = Nothing
                Dim command As OracleCommand = Nothing

                Try
                        connection.Open()
                        transaction = connection.BeginTransaction()
                        command = New OracleCommand(connection, "update emp set dept=10 where empno=4321")
                        command.ExecuteNonQuery()
                Catch e As Exception
                        Console.WriteLine(e.ToString())
                        Return
                End Try

                Try
                        transaction.Commit()
                Catch e As Exception
                        If e.IsRecoverable Then
                                Dim logicalTransaction As OracleLogicalTransaction = connection.OracleLogicalTransaction
                                logicalTransaction.GetOutcome()
                                ' or logicalTransaction.GetOutcome("scott", "tiger", "inst1");
                                ' any chosen processing here if a retry is desired.
                                If Not logicalTransaction.Committed AndAlso Not logicalTransaction.UserCallCompleted Then
                                        ' transaction committed, but was not full completed
                                Else
                                End If
                                ' Not recoverable transaction. Rollback (and re-execute).
                        Else
                        End If
                End Try
        End Sub
End Class

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
OracleLogicalTransaction Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Owner Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Owner Property

Gets or sets a form or other container that the OracleConnection instance belongs to.

Syntax

Visual Basic (Declaration)
Public Shadows Property Owner As Object
C#
public new object Owner {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PassParametersByName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : PassParametersByName Property

Determines whether parameters will be passed by name to the stored procedure calls.

Syntax

Visual Basic (Declaration)
Public Property PassParametersByName As Boolean
C#
public bool PassParametersByName {get; set;}

Property Value

true if parameters should be passed by name; otherwise, false. The default value is false.

Remarks

If set to true, parameters will be passed by name regardless of individual OracleCommand.PassParametersByName values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Password Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Password Property

Gets or sets the user's password to connect.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Property Value

The user's password to connect.

Remarks

When a value is assigned to this property, the OracleConnection is closed.

Leave this property blank if you want to use Integrated Security connections (OS authentication). The UserId property must be empty as well.

Example

The following example creates a OracleConnection and displays the password.
C#csharp Copy Code
public void CreateOracleConnection()
{
  string myConnString =
      "User Id=Scott;Password=tiger;Data Source=Ora;";
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  MessageBox.Show("Password: " + myConnection.Password.ToString());
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection()
  Dim myConnString As String = _
    "User Id=Scott;Password=tiger;Data Source=Ora;"
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  MessageBox.Show("Password: " + myConnection.Password.ToString())
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
UserId Property
ConnectionString Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Port Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Port Property

Gets or sets number of a port to communicate with listener on the server.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Property Value

Number of a port to communicate with listener on the server. The default value is 1521.

Remarks

This Port property is used only in OracleConnection.Direct mode. When a value is assigned to this property, the OracleConnection is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Server Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Server Property

Gets or sets the name of TNS alias of the Oracle database to which to connect.

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server {get; set;}

Property Value

The name of TNS alias of the Oracle database to which to connect. The default value is an empty string ("").

Remarks

In this property you can choose a Home to work with. Homes are enumerated in file named tnsnames.ora. You can use Server property to specify the server detailed instead of alias:
(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = SERVER)(PORT = 1521))) (CONNECT_DATA = (SID = ORCL)))
This is particularly useful for Instant Client, which can be used with Server property set this way. dotConnect for Oracle searches for Instant Client in directories specified by PATH environment variable.

In OracleConnection.Direct mode this property represents host name or IP address of the database server.

Example

The following example creates an OracleConnection and displays the server name.
C#csharp Copy Code
public void CreateOraConnection()
{
  string myConnString = "User ID=scott; Password=tiger; Data Source=ora";
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  MessageBox.Show("Server: " + myConnection.Server);
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOraConnection()
  Dim myConnString As String = _
    "User ID=scott; Password=tiger; Data Source=ora"
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  MessageBox.Show("Server: " + myConnection.Server)
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Database Property
ConnectionString Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServerType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ServerType Property

Indicates whether the connected database is an Oracle database or a TimesTen database.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerType As OracleServerType
C#
public OracleServerType ServerType {get;}

Property Value

One of the OracleServerType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServerVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ServerVersion Property

Gets a string containing the version of the instance of Oracle to which the client is connected.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property ServerVersion As String
C#
public new string ServerVersion {get;}

Property Value

The version of the instance of Oracle.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServiceName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ServiceName Property

Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.

Syntax

Visual Basic (Declaration)
Public Property ServiceName As String
C#
public string ServiceName {get; set;}

Property Value

Alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode. The default value is empty string.

Remarks

This property is used only in OracleConnection.Direct mode. When a value is assigned to this property, the OracleConnection is closed.

When Service Name is specified and implies several database instances, dotConnect for Oracle connects to the first instance provided by Oracle listener. Note that RAC is not supported in the Direct mode, and provider works only with this one database instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ShortServerVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : ShortServerVersion Property

Gets the version of the instance of Oracle Database, the OracleConnection object is connected to, as a System.Version object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortServerVersion As Version
C#
public Version ShortServerVersion {get;}

Property Value

The System.Version object, representing the version of the instance of Oracle Database, the OracleConnection object is connected to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sid Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Sid Property

Gets or sets a unique name for an Oracle database instance.

Syntax

Visual Basic (Declaration)
Public Property Sid As String
C#
public string Sid {get; set;}

Property Value

Unique name for an Oracle database instance to use in the OracleConnection.Direct mode. The default value is empty string.

Remarks

This Sid property is used only in OracleConnection.Direct mode. When a value is assigned to this property, the OracleConnection is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
State Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : State Property

Gets the current state of the connection.

Syntax

Visual Basic (Declaration)
Public Shadows Property State As ConnectionState
C#
public new ConnectionState State {get; set;}

Property Value

A bitwise combination of the System.Data.ConnectionState values. The default value is Closed.

Remarks

The allowed state changes are:
  • From Closed to Open, using the Open() method of the OracleConnection object.
  • From Open to Closed, using either the Devart.Common.DbConnectionBase.Close method or the Dispose() method of the OracleConnection object.

Example

The following example creates an instance of a derived class, OracleConnection, sets its ConnectionString, and displays its State.
C#csharp Copy Code
public void CreateOracleConnection()
{
  OracleConnection myConnection = new OracleConnection();
  myConnection.ConnectionString =
      "User Id=Scott;Password=tiger;Data Source=Ora;";
  myConnection.Open();
  MessageBox.Show("Connection State: " + myConnection.State.ToString());
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection()
  Dim myConnection As New OracleConnection()
  myConnection.ConnectionString = _
      "User Id=Scott;Password=tiger;Data Source=Ora;"
  myConnection.Open()
  MessageBox.Show("Connection State: " + myConnection.State.ToString())
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
ConnectionString Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TrimFixedChar Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : TrimFixedChar Property

Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).

Syntax

Visual Basic (Declaration)
Public Property TrimFixedChar As Boolean
C#
public bool TrimFixedChar {get; set;}

Property Value

true, if fixed-length string data type (CHAR, NCHAR) values should be trimmed; otherwise, false. The default value is true.

Remarks

Affects all command objects of this connection. Behaviour of data reader depends on TrimFixedChar value at the moment of opening data reader.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unicode Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Unicode Property

Gets or sets a value indicating whether the UTF16 charset will be used.

Syntax

Visual Basic (Declaration)
Public Property Unicode As Boolean
C#
public bool Unicode {get; set;}

Property Value

true, if client charset UTF16 is used; false, if default client charset is used. The default value is false.

Example

The following two functions demonstrate how to use Unicode property to implement charset-safe string transfer.
C#csharp Copy Code
public void UploadString(OracleConnection myConnection)
{
  myConnection.Unicode = true;
  OracleCommand myCommand = new OracleCommand("INSERT INTO Test.TextBlocks (BlockID, BlockName, BlockContent) VALUES(1,'First',:BlockText)", myConnection);
  myCommand.Parameters.Add("BlockText",OracleDbType.VarChar,50).Value = "Place here some text that requires Unicode support.";
  myConnection.Open();
  try
  {
    Console.WriteLine(myCommand.ExecuteNonQuery()+" rows affected.");
  }
  finally
  {
    myConnection.Close();
  }
}

public void DownloadString(OracleConnection myConnection)
{
  myConnection.Unicode = true;
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.TextBlocks", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(CommandBehavior.Default);
  try
  {
    while (myReader.Read())
    {
      string myString = (string)myReader["BlockContent"];
      Console.WriteLine(myString);
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub UploadString(ByVal myConnection As OracleConnection)
  myConnection.Unicode = True
  Dim myCommand As New OracleCommand("INSERT INTO Test.TextBlocks (BlockID, BlockName, BlockContent) VALUES(1,'First',:BlockText)", myConnection)
  myCommand.Parameters.Add("BlockText", OracleDbType.VarChar, 50).Value = "Place here some text that requires Unicode support."
  myConnection.Open()
  Try
    Console.WriteLine(String.Concat(myCommand.ExecuteNonQuery(), " rows affected."))
  Finally
    myConnection.Close()
  End Try
End Sub

Public Sub DownloadString(ByVal myConnection As OracleConnection)

  myConnection.Unicode = True
  Dim myCommand As New OracleCommand("SELECT * FROM Test.TextBlocks", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader(CommandBehavior.Default)
  Try
    While myReader.Read()
      Dim myString As String = CType(myReader("BlockContent"), String)
      Console.WriteLine(myString)
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
ConnectionString Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserId Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : UserId Property

Gets or sets the name of the user to connect.

Syntax

Visual Basic (Declaration)
Public Property UserId As String
C#
public string UserId {get; set;}

Property Value

The name of the user to connect.

Remarks

When a value is assigned to this property, the OracleConnection is closed.

Leave this property blank if you want to use Integrated Security connections (OS authentication). The Password property must be empty as well.

Example

The following example creates a OracleConnection and displays the user name.
C#csharp Copy Code
public void CreateOracleConnection()
{
  string myConnString =
      "User Id=Scott;Password=tiger;Data Source=Ora;";
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();
  MessageBox.Show("User: " + myConnection.UserId);
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub CreateOracleConnection()
  Dim myConnString As String = _
      "User Id=Scott;Password=tiger;Data Source=Ora;"
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()
  MessageBox.Show("User: " + myConnection.UserId)
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
Password Property
ConnectionString Property


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleConnection Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnection Class

For a list of all members of this type, see OracleConnection members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when Oracle returns an error message.
public Event | Failover | Occurs when Oracle Failover mechanism takes place.
public Event | HAEvent | Occurs when a HA event happens.
public Event | InfoMessage | Occurs when Oracle returns a warning or informational message.
public Event | StateChange | Occurs when the state of the connection changes. (Inherited from Devart.Common.DbConnectionBase)
public Event | TransactionStateChanged | Occurs when the state of the transaction is changed. (Inherited from Devart.Common.DbConnectionBase)
public Event | TransactionStateChanging | Occurs when the state of the transaction is changing. (Inherited from Devart.Common.DbConnectionBase)
Top

See Also

Reference

OracleConnection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Error Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Error Event

Occurs when Oracle returns an error message.

Syntax

Visual Basic (Declaration)
Public Event Error As OracleConnectionErrorEventHandler
C#
public event OracleConnectionErrorEventHandler Error

Event Data

The event handler receives an argument of type OracleConnectionErrorEventArgs containing data related to this event. The following OracleConnectionErrorEventArgs properties provide information specific to this event.

Property | Description
Code | Gets the Oracle specific error code.
Message | Gets the full text of the error sent from the Oracle database.

Remarks

Clients that want to process errors raised by the server should create an OracleConnectionErrorEventHandler delegate to listen to this event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Failover Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : Failover Event

Occurs when Oracle Failover mechanism takes place.

Syntax

Visual Basic (Declaration)
Public Event Failover As OracleFailoverEventHandler
C#
public event OracleFailoverEventHandler Failover

Remarks

Use this event to transparently reconnect to another Oracle server when the current server crashes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
HAEvent Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : HAEvent Event

Occurs when a HA event happens.

Syntax

Visual Basic (Declaration)
Public Event HAEvent As OracleHAEventHandler
C#
public event OracleHAEventHandler HAEvent

Remarks

Oracle HA (High Availability) events allow quickly informing client applications that an Oracle Real Application Clusters (RAC) service, service member, instance, or node goes down because of a failure or other reason. Note that you need to set the OracleConnectionStringBuilder.HAEvents connection string parameter to true in order to receive HA events.

Please note that this event is not supported in the OracleConnection.Direct mode. It is supported for Oracle Client 10g and higher. For Oracle Client 10g this event can be received only when you have at least one active connection to the Oracle database service, service member, instance, or node that goes down. For Oracle Client 11 and higher this event is received regardless of a presence of active connections to the event source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members
OracleHAEventArgs Class
OracleHAEventHandler Delegate


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InfoMessage Event
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnection Class : InfoMessage Event

Occurs when Oracle returns a warning or informational message.

Syntax

Visual Basic (Declaration)
Public Event InfoMessage As OracleInfoMessageEventHandler
C#
public event OracleInfoMessageEventHandler InfoMessage

Event Data

The event handler receives an argument of type OracleInfoMessageEventArgs containing data related to this event. The following OracleInfoMessageEventArgs properties provide information specific to this event.

Property | Description
Code | Gets the Oracle specific message code.
Errors | Returns collection of errors generated by Devart.Data.Oracle.OracleCommand.
Message | Gets the full text of the message sent from the Oracle database.
Source | Gets the name of the application or the object that threw the event.

Remarks

Clients that want to process warnings or informational messages sent by the server should create an OracleInfoMessageEventHandler delegate to listen to this event.

The InfoMessage event receives an InfoMessageEventArgs object containing, in its Errors property, a collection of the messages from the data source. You can query the Error objects in this collection for the error number and message text, as well as the source of the error. There are also details about the database, stored procedure, and line number that the message came from.

Example

The following example demostrates registering InfoMessage event handler that prints out the warning info.
C#csharp Copy Code
class OracleInfoMessage {
        public static void WarningPrinter(object src,
                OracleInfoMessageEventArgs args)
        {
                Console.WriteLine("Source object is: " + src.GetType().Name);
                Console.WriteLine("InfoMessageArgs.Message is " + args.Message);
                Console.WriteLine("InfoMessageArgs.Source is " + args.Source);
        }
        static void Main()
        {
                OracleConnection con = new OracleConnection("User Id=scott;" +
                        "Password=tiger;Data Source=ora1110;");

                con.Open();

                OracleCommand cmd = con.CreateCommand();

                // Register to the InfoMessageHandler
                cmd.Connection.InfoMessage +=
                        new OracleInfoMessageEventHandler(WarningPrinter);

                cmd.CommandText = "CREATE OR REPLACE PACKAGE BODY PACKAGEWITHNOSPECIFICATION AS" +
                        "PROCEDURE GET_ALL_DEPTS (cur OUT SYS_REFCURSOR) AS" +
                        "BEGIN" +
                        " OPEN cur FOR SELECT * FROM DEPT;" +
                        "END;" +
                        "END PACKAGEWITHNOSPECIFICATION;";

                // Execute the statement that produces a warning
                cmd.ExecuteNonQuery();

                // Clean up
                cmd.Dispose();
                con.Dispose();
        }
}
C#Visual Basic Copy Code
Module Module1
        Public Sub WarningPrinter(ByVal src As Object, ByVal args As OracleInfoMessageEventArgs)
                Console.WriteLine("Source object is: " + src.GetType().Name)
                Console.WriteLine("InfoMessageArgs.Message is " + args.Message)
                Console.WriteLine("InfoMessageArgs.Source is " + args.Source)
        End Sub 'WarningPrinter
        Sub Main()
                Dim con As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora1110;")
                con.Open()
                Dim cmd As OracleCommand = con.CreateCommand()
                ' Register to the InfoMessageHandler
                AddHandler cmd.Connection.InfoMessage, _
                New OracleInfoMessageEventHandler(AddressOf WarningPrinter)
                'command.Connection.InfoMessage += New OracleInfoMessageEventHandler(WarningPrinter)
                cmd.CommandText = "CREATE OR REPLACE PACKAGE BODY PACKAGEWITHNOSPECIFICATION AS" & _
                        "PROCEDURE GET_ALL_DEPTS (cur OUT SYS_REFCURSOR) AS" & _
                        "BEGIN" & _
                        " OPEN cur FOR SELECT * FROM DEPT;" & _
                        "END;" & _
                        "END PACKAGEWITHNOSPECIFICATION;"
                ' Execute the statement that produces a warning
                cmd.ExecuteNonQuery()

                ' Clean up
                cmd.Dispose()
                con.Dispose()
        End Sub
End Module

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnection Class
OracleConnection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionErrorEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionErrorEventArgs Class

Provides data for the OracleConnection.Error event of the Devart.Data.Oracle.OracleConnection class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleConnectionErrorEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleConnectionErrorEventArgs
   Inherits System.EventArgs
C#
public sealed class OracleConnectionErrorEventArgs : System.EventArgs

Remarks

The OracleConnection.Error event contains Code and Message properties sent from the data source.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleConnectionErrorEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleConnectionErrorEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionErrorEventArgs Class

The following tables list the members exposed by OracleConnectionErrorEventArgs.

Public Properties

 | Name | Description
public Property | Code | Gets the Oracle specific error code.
public Property | Message | Gets the full text of the error sent from the Oracle database.
Top

See Also

Reference

OracleConnectionErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleConnectionErrorEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionErrorEventArgs Class

For a list of all members of this type, see OracleConnectionErrorEventArgs members.

Public Properties

 | Name | Description
public Property | Code | Gets the Oracle specific error code.
public Property | Message | Gets the full text of the error sent from the Oracle database.
Top

See Also

Reference

OracleConnectionErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Code Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionErrorEventArgs Class : Code Property

Gets the Oracle specific error code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As Integer
C#
public int Code {get;}

Property Value

Oracle specific error code.

Remarks

You may use this property to obtain the Oracle error code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionErrorEventArgs Class
OracleConnectionErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Message Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionErrorEventArgs Class : Message Property

Gets the full text of the error sent from the Oracle database.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

Message that Oracle returns with the error.

Remarks

You can use this property to obtain the Oracle error message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionErrorEventArgs Class
OracleConnectionErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionStringBuilder Class

Generates automatically connection strings used to connect to Oracle.

Inheritance Hierarchy

System.Object
System.Data.Common.DbConnectionStringBuilder
Devart.Common.DbConnectionStringBuilder
Devart.Data.Oracle.OracleConnectionStringBuilder

Syntax

Visual Basic (Declaration)
Public Class OracleConnectionStringBuilder
   Inherits Devart.Common.DbConnectionStringBuilder
   Implements ICollection, IDictionary, IEnumerable, ICustomTypeDescriptor
C#
public class OracleConnectionStringBuilder : Devart.Common.DbConnectionStringBuilder, ICollection, IDictionary, IEnumerable, ICustomTypeDescriptor

Remarks

The OracleConnectionStringBuilder allows you to construct a connection string by assigning values to corresponding properties. After you have initialized all connection properties you need, use ConnectionString property or ToString method to obtain the connection string built.

Example

This sample shows how to construct a connection string and pass it to Devart.Data.Oracle.OracleConnection object.
C#csharp Copy Code
public void UseConnectionStringBuilder()
{
        OracleConnectionStringBuilder myCSB = new OracleConnectionStringBuilder();
        oraCSB.Direct = true;
        oraCSB.Server = "192.168.0.1";
        oraCSB.Port = 1521;
        oraCSB.Sid = "OracleSid";
        oraCSB.UserId = "scott";
        oraCSB.Password = "tiger";
        oraCSB.MaxPoolSize = 150;
        oraCSB.ConnectionTimeout = 30;
        OracleConnection myConnection = new OracleConnection(myCSB.ConnectionString);
        myConnection.Open();
        Console.WriteLine(myConnection.ServerVersion);
        myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub UseConnectionStringBuilder()
        Dim myCSB As OracleConnectionStringBuilder = New OracleConnectionStringBuilder
        oraCSB.Direct = true
        oraCSB.Server = "192.168.0.1"
        oraCSB.Port = 1521
        oraCSB.Sid = "OracleSid"
        oraCSB.UserId = "scott"
        oraCSB.Password = "tiger"
        oraCSB.MaxPoolSize = 150
        oraCSB.ConnectionTimeout = 30
        Dim myConnection As OracleConnection = New OracleConnection(myCSB.ConnectionString)
                myConnection.Open()
        Console.WriteLine(myConnection.ServerVersion)
        myConnection.Close()
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleConnectionStringBuilder Members
Devart.Data.Oracle Namespace
ConnectionString Property


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionStringBuilder Class

The following tables list the members exposed by OracleConnectionStringBuilder.

Public Constructors

 | Name | Description
public Constructor | OracleConnectionStringBuilder Constructor | Overloaded. Initializes a new instance of the OracleConnectionStringBuilder class.
Top

Public Properties

 | Name | Description
public Property | ClientId | This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.
public Property | ConnectionClass | Gets or sets the connection class used for database resident connection pooling.
public Property | ConnectionLifetime | Gets or sets time span in seconds for connection to live.
public Property | ConnectionString | Gets or sets the connection string associated with the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | ConnectionTimeout | Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | ConnectMode | Gets or sets whether to open a session with default or administrative privileges.
public Property | Count | Gets the current number of keys that are contained within the System.Data.Common.DbConnectionStringBuilder.ConnectionString property. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | DefaultCommandTimeout | Gets or sets the time in seconds to wait while trying to execute a command before terminating the attempt and generating an error.
public Property | DescribeStoredProcedure | Enables or disables additional check queries, performed when executing an OracleCommand with CommandType equal to CommandType.StoredProcedure.
public Property | Direct | Indicates whether Direct mode of communicating with server should be used.
public Property | Enlist | Gets or sets a Boolean value that indicates whether the connection is automatically enlisted in the current transaction context.
public Property | HAEvents | Allows dotConnect for Oracle to proactively remove connections to cooresponding Oracle Real Application Clusters (RAC) database service, service member, instance, or node from the pool when this service, service member, instance, or node goes down.
public Property | Home | Gets or sets which Oracle Home to use.
public Property | InitializationCommand | Specifies a data source-specific command that should be executed immediately after establishing the connection. (Inherited from Devart.Common.DbConnectionStringBuilder)
public Property | IsFixedSize | Overridden. Returns true.
public Property | IsReadOnly | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder is read-only. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Item | Overridden. Returns the value of given key.
public Property | Keys | Overridden. Collection of keys in the OracleConnectionStringBuilder.
public Property | LobBlockSize | Specifies the size of a block (in megabytes) to read/write CLOB or NCLOB data from/to database. This option is supported in OCI mode only. Applicable only for Unicode Oracle servers.
public Property | MaxPoolSize | The maximum number of connections allowed in the pool.
public Property | MinPoolSize | The minimum number of connections allowed in the pool.
public Property | NumberMappings | Gets or sets the collection of number mappings used for this connection.
public Property | OciSessionPoolAllowWaiting | Enables or disables waiting for a connection to close when there is no free connection.
public Property | OciSessionPoolConnectionLifetime | Gets or sets the connection lifetime in the OCI pool.
public Property | OciSessionPoolIncrement | Specifies the number of sessions that are added at once.
public Property | OciSessionPooling | Enables or disables the OCI Session Pooling feature.
public Property | OciSessionPoolMaxSize | Specifies the maximum number of sessions that can be opened in the session pool.
public Property | OciSessionPoolMinSize | Specifies the minimum number of sessions in the session pool.
public Property | OciSessionPoolPassword | Gets or sets password for proxy connections.
public Property | OciSessionPoolUserId | Gets or sets User Id for proxy connections.
public Property | OraMts | Determines whether to use Oracle Services for Microsoft Transaction Server (OraMTS) for distributed transactions.
public Property | PassParametersByName | Determines whether parameters will be passed by name to the stored procedure calls.
public Property | Password | Gets or sets the user's password to connect.
public Property | PersistSecurityInfo | Gets or sets a value indicating whether password is stored in connection string after connection is opened.
public Property | Pooling | Gets or sets pooling mode.
public Property | Port | Gets or sets number of a port to communicate with listener on the server.
public Property | ProxyPassword | Gets or sets the password for Oracle proxy authentication.
public Property | ProxyUserId | Gets or sets the proxy user id for Oracle proxy authentication.
public Property | RunOnceCommand | Specifies a data source-specific command that should be executed immediately after first establishing the connection. Unlike Devart.Common.DbConnectionStringBuilder.InitializationCommand, this command is not executed when a connection is taken from the pool. (Inherited from Devart.Common.DbConnectionStringBuilder)
public Property | Server | Gets or sets the name of TNS alias of the Oracle database to which to connect.
public Property | ServiceName | Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.
public Property | Sid | Gets or sets a unique name for an Oracle database instance.
public Property | StatementCachePurge | Determines whether to clear the OCI statement cache when closing the connection or putting it to the pool.
public Property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached for a connection.
public Property | TransactionScopeLocal | Enables support for non-distributed transactions in the TransactionScope implementation.
public Property | TrimFixedChar | Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).
public Property | Unicode | Gets or sets a value indicating whether the UTF16 charset will be used.
public Property | UsePerformanceMonitor | Enables dotConnect for Oracle performance counters that allow you to conveniently measure the frequency of connecting/disconnecting to the data source, the number of active connections, pooled connections, etc. via Windows Performance Monitor or programmatically. See Performance Counters Support for more information.
public Property | UserId | Gets or sets the name of the user to connect.
public Property | ValidateConnection | Indicates whether to validate connections that are being taken from the pool.
public Property | Values | Overridden. Collection of values in the OracleConnectionStringBuilder.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an entry with the specified key and value into the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | Clear | Overridden. Sets all OracleConnectionStringBuilder properties to default values.
public Method | ContainsKey | Overridden. Indicates whether specified key is set in the OracleConnectionStringBuilder object.
public Method | EquivalentTo | Overloaded. Overridden. Returns a value indicating whether this OracleConnectionStringBuilder has same parameters as given DbConnectionStringBuilder.
public Method | Remove | Overridden. Sets value of the specified key to default.
public Method | ShouldSerialize | Overridden. Determines whether the key will be serialized if required.
public Method | ToString | Returns the current connection string for the OracleConnectionStringBuilder.
public Method | TryGetValue | Overridden. Attempts to get a key value.
Top

See Also

Reference

OracleConnectionStringBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OracleConnectionStringBuilder Constructor

Initializes a new instance of the OracleConnectionStringBuilder class.

Overload List

Overload | Description
OracleConnectionStringBuilder Constructor() | Initializes a new instance of the OracleConnectionStringBuilder class.
OracleConnectionStringBuilder Constructor(String) | Initializes a new instance of the OracleConnectionStringBuilder class and assigns custom initial values to some properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class > OracleConnectionStringBuilder Constructor : OracleConnectionStringBuilder Constructor()

Initializes a new instance of the OracleConnectionStringBuilder class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleConnectionStringBuilder()

Remarks

When a new instance of OracleConnectionStringBuilder is created, its properties are set to the following initial values:
Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Password | empty string ("")
UserId | empty string ("")

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class > OracleConnectionStringBuilder Constructor : OracleConnectionStringBuilder Constructor(String)

connectionString
Initial connection setup string.
Initializes a new instance of the OracleConnectionStringBuilder class and assigns custom initial values to some properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String _
)
C#
public OracleConnectionStringBuilder(
   string connectionString
)

Parameters

connectionString
Initial connection setup string.

Remarks

When a new instance of OracleConnectionStringBuilder is created, its properties are set to the following initial values unless they are specifically set using their associated keywords in the connectionString parameter.
Properties | Initial Value
ConnectionString | empty string ("")
ConnectionTimeout | 15
Password | empty string ("")
UserId | empty string ("")
If the connectionString parameter can not be parsed, an exception is thrown and the object is not created.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionStringBuilder Class

For a list of all members of this type, see OracleConnectionStringBuilder members.

Public Methods

 | Name | Description
public Method | Add | Adds an entry with the specified key and value into the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Method | Clear | Overridden. Sets all OracleConnectionStringBuilder properties to default values.
public Method | ContainsKey | Overridden. Indicates whether specified key is set in the OracleConnectionStringBuilder object.
public Method | EquivalentTo | Overloaded. Overridden. Returns a value indicating whether this OracleConnectionStringBuilder has same parameters as given DbConnectionStringBuilder.
public Method | Remove | Overridden. Sets value of the specified key to default.
public Method | ShouldSerialize | Overridden. Determines whether the key will be serialized if required.
public Method | ToString | Returns the current connection string for the OracleConnectionStringBuilder.
public Method | TryGetValue | Overridden. Attempts to get a key value.
Top

See Also

Reference

OracleConnectionStringBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Clear Method

Sets all OracleConnectionStringBuilder properties to default values.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
C#
public override void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ContainsKey Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ContainsKey Method

keyword
Key to search for.
Indicates whether specified key is set in the OracleConnectionStringBuilder object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ContainsKey( _
   ByVal keyword As String _
) As Boolean
C#
public override bool ContainsKey(
   string keyword
)

Parameters

keyword
Key to search for.

Return Value

true, if the value of the specified key differs from default; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EquivalentTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : EquivalentTo Method

Returns a value indicating whether this OracleConnectionStringBuilder has same parameters as given DbConnectionStringBuilder.

Overload List

Overload | Description
EquivalentTo(DbConnectionStringBuilder,Boolean) | Returns a value indicating whether this OracleConnectionStringBuilder object has same parameters as given DbConnectionStringBuilder object.
EquivalentTo(DbConnectionStringBuilder) | Compares the connection information in this System.Data.Common.DbConnectionStringBuilder object with the connection information in the supplied object. (Inherited from System.Data.Common.DbConnectionStringBuilder)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EquivalentTo(DbConnectionStringBuilder,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class > EquivalentTo Method : EquivalentTo(DbConnectionStringBuilder,Boolean) Method

connectionStringBuilder
A DbConnectionStringBuilder object to compare with.
loginOnly
If true,only the following properties are compared: UserId, Password, and Server.
Returns a value indicating whether this OracleConnectionStringBuilder object has same parameters as given DbConnectionStringBuilder object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EquivalentTo( _
   ByVal connectionStringBuilder As DbConnectionStringBuilder, _
   ByVal loginOnly As Boolean _
) As Boolean
C#
public override bool EquivalentTo(
   DbConnectionStringBuilder connectionStringBuilder,
   bool loginOnly
)

Parameters

connectionStringBuilder
A DbConnectionStringBuilder object to compare with.
loginOnly
If true,only the following properties are compared: UserId, Password, and Server.

Return Value

true, if the two objects have same parameters; otherwise, false.

Remarks

Use EquivalentTo to quickly compare two DbConnectionStringBuilder objects. If you need to check only the main connection properties, ensuring that you login to the same place with the same user, set loginOnly to true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Remove Method

keyword
The key to clear.
Sets value of the specified key to default.

Syntax

Visual Basic (Declaration)
Public Overrides Function Remove( _
   ByVal keyword As String _
) As Boolean
C#
public override bool Remove(
   string keyword
)

Parameters

keyword
The key to clear.

Return Value

true, if operation is successful; false otherwise.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ShouldSerialize Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ShouldSerialize Method

keyword
Key name to inquiry.
Determines whether the key will be serialized if required.

Syntax

Visual Basic (Declaration)
Public Overrides Function ShouldSerialize( _
   ByVal keyword As String _
) As Boolean
C#
public override bool ShouldSerialize(
   string keyword
)

Parameters

keyword
Key name to inquiry.

Return Value

true, if the key will be serialized; false otherwise.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ToString Method

Returns the current connection string for the OracleConnectionStringBuilder.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The current connection string for the OracleConnectionStringBuilder.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryGetValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : TryGetValue Method

keyword
Key name to obtain the value.
value
Value of the key. If operation fails, the value is null.
Attempts to get a key value.

Syntax

Visual Basic (Declaration)
Public Overrides Function TryGetValue( _
   ByVal keyword As String, _
   ByRef value As Object _
) As Boolean
C#
public override bool TryGetValue(
   string keyword,
   out object value
)

Parameters

keyword
Key name to obtain the value.
value
Value of the key. If operation fails, the value is null.

Return Value

true if the operation is successful; false otherwise.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleConnectionStringBuilder Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionStringBuilder Class

For a list of all members of this type, see OracleConnectionStringBuilder members.

Public Properties

 | Name | Description
public Property | ClientId | This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.
public Property | ConnectionClass | Gets or sets the connection class used for database resident connection pooling.
public Property | ConnectionLifetime | Gets or sets time span in seconds for connection to live.
public Property | ConnectionString | Gets or sets the connection string associated with the System.Data.Common.DbConnectionStringBuilder. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | ConnectionTimeout | Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.
public Property | ConnectMode | Gets or sets whether to open a session with default or administrative privileges.
public Property | Count | Gets the current number of keys that are contained within the System.Data.Common.DbConnectionStringBuilder.ConnectionString property. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | DefaultCommandTimeout | Gets or sets the time in seconds to wait while trying to execute a command before terminating the attempt and generating an error.
public Property | DescribeStoredProcedure | Enables or disables additional check queries, performed when executing an OracleCommand with CommandType equal to CommandType.StoredProcedure.
public Property | Direct | Indicates whether Direct mode of communicating with server should be used.
public Property | Enlist | Gets or sets a Boolean value that indicates whether the connection is automatically enlisted in the current transaction context.
public Property | HAEvents | Allows dotConnect for Oracle to proactively remove connections to cooresponding Oracle Real Application Clusters (RAC) database service, service member, instance, or node from the pool when this service, service member, instance, or node goes down.
public Property | Home | Gets or sets which Oracle Home to use.
public Property | InitializationCommand | Specifies a data source-specific command that should be executed immediately after establishing the connection. (Inherited from Devart.Common.DbConnectionStringBuilder)
public Property | IsFixedSize | Overridden. Returns true.
public Property | IsReadOnly | Gets a value that indicates whether the System.Data.Common.DbConnectionStringBuilder is read-only. (Inherited from System.Data.Common.DbConnectionStringBuilder)
public Property | Item | Overridden. Returns the value of given key.
public Property | Keys | Overridden. Collection of keys in the OracleConnectionStringBuilder.
public Property | LobBlockSize | Specifies the size of a block (in megabytes) to read/write CLOB or NCLOB data from/to database. This option is supported in OCI mode only. Applicable only for Unicode Oracle servers.
public Property | MaxPoolSize | The maximum number of connections allowed in the pool.
public Property | MinPoolSize | The minimum number of connections allowed in the pool.
public Property | NumberMappings | Gets or sets the collection of number mappings used for this connection.
public Property | OciSessionPoolAllowWaiting | Enables or disables waiting for a connection to close when there is no free connection.
public Property | OciSessionPoolConnectionLifetime | Gets or sets the connection lifetime in the OCI pool.
public Property | OciSessionPoolIncrement | Specifies the number of sessions that are added at once.
public Property | OciSessionPooling | Enables or disables the OCI Session Pooling feature.
public Property | OciSessionPoolMaxSize | Specifies the maximum number of sessions that can be opened in the session pool.
public Property | OciSessionPoolMinSize | Specifies the minimum number of sessions in the session pool.
public Property | OciSessionPoolPassword | Gets or sets password for proxy connections.
public Property | OciSessionPoolUserId | Gets or sets User Id for proxy connections.
public Property | OraMts | Determines whether to use Oracle Services for Microsoft Transaction Server (OraMTS) for distributed transactions.
public Property | PassParametersByName | Determines whether parameters will be passed by name to the stored procedure calls.
public Property | Password | Gets or sets the user's password to connect.
public Property | PersistSecurityInfo | Gets or sets a value indicating whether password is stored in connection string after connection is opened.
public Property | Pooling | Gets or sets pooling mode.
public Property | Port | Gets or sets number of a port to communicate with listener on the server.
public Property | ProxyPassword | Gets or sets the password for Oracle proxy authentication.
public Property | ProxyUserId | Gets or sets the proxy user id for Oracle proxy authentication.
public Property | RunOnceCommand | Specifies a data source-specific command that should be executed immediately after first establishing the connection. Unlike Devart.Common.DbConnectionStringBuilder.InitializationCommand, this command is not executed when a connection is taken from the pool. (Inherited from Devart.Common.DbConnectionStringBuilder)
public Property | Server | Gets or sets the name of TNS alias of the Oracle database to which to connect.
public Property | ServiceName | Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.
public Property | Sid | Gets or sets a unique name for an Oracle database instance.
public Property | StatementCachePurge | Determines whether to clear the OCI statement cache when closing the connection or putting it to the pool.
public Property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached for a connection.
public Property | TransactionScopeLocal | Enables support for non-distributed transactions in the TransactionScope implementation.
public Property | TrimFixedChar | Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).
public Property | Unicode | Gets or sets a value indicating whether the UTF16 charset will be used.
public Property | UsePerformanceMonitor | Enables dotConnect for Oracle performance counters that allow you to conveniently measure the frequency of connecting/disconnecting to the data source, the number of active connections, pooled connections, etc. via Windows Performance Monitor or programmatically. See Performance Counters Support for more information.
public Property | UserId | Gets or sets the name of the user to connect.
public Property | ValidateConnection | Indicates whether to validate connections that are being taken from the pool.
public Property | Values | Overridden. Collection of values in the OracleConnectionStringBuilder.
Top

See Also

Reference

OracleConnectionStringBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ClientId Property

This property specifies the client identifier for the connection. It helps to make audition of the client connections and gives an opportunity to distinguish between the applications connecting to.

Syntax

Visual Basic (Declaration)
Public Property ClientId As String
C#
public string ClientId {get; set;}

Property Value

The string to be used as the client identifier.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionClass Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ConnectionClass Property

Gets or sets the connection class used for database resident connection pooling.

Syntax

Visual Basic (Declaration)
Public Property ConnectionClass As String
C#
public string ConnectionClass {get; set;}

Property Value

The connection class used for database resident connection pooling.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionLifetime Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ConnectionLifetime Property

Gets or sets time span in seconds for connection to live.

Syntax

Visual Basic (Declaration)
Public Property ConnectionLifetime As Integer
C#
public int ConnectionLifetime {get; set;}

Property Value

Number of seconds for connection to live.

Remarks

When a connection is returned to the pool, its creation time is compared with the current time, and the connection is destroyed if that time span (in seconds) exceeds the value specified by Connection Lifetime. The default value is 0 (connection always returns to pool).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectionTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ConnectionTimeout Property

Gets or sets the time to wait while trying to establish a connection before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Property ConnectionTimeout As Integer
C#
public int ConnectionTimeout {get; set;}

Property Value

The time (in seconds) to wait for a connection to open. The default value is 15 seconds.

Remarks

A value of 0 indicates no limit, and should be avoided, because an attempt to connect will wait indefinitely.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConnectMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ConnectMode Property

Gets or sets whether to open a session with default or administrative privileges.

Syntax

Visual Basic (Declaration)
Public Property ConnectMode As OracleConnectMode
C#
public OracleConnectMode ConnectMode {get; set;}

Property Value

One of OracleConnectMode values

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DefaultCommandTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : DefaultCommandTimeout Property

Gets or sets the time in seconds to wait while trying to execute a command before terminating the attempt and generating an error.

Syntax

Visual Basic (Declaration)
Public Property DefaultCommandTimeout As Integer
C#
public int DefaultCommandTimeout {get; set;}

Property Value

The time in seconds to wait while trying to execute a command before terminating the attempt and generating an error.

Remarks

A value of 0 indicates no limit. The default value is 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DescribeStoredProcedure Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : DescribeStoredProcedure Property

Enables or disables additional check queries, performed when executing an Devart.Data.Oracle.OracleCommand with CommandType equal to CommandType.StoredProcedure.

Syntax

Visual Basic (Declaration)
Public Property DescribeStoredProcedure As Boolean
C#
public bool DescribeStoredProcedure {get; set;}

Property Value

true if additional queries for stored routine metadata must be performed; otherwise, false. Default value is true.

Remarks

When this parameter is set to true (the default behavior), the following additional checks are performed for Devart.Data.Oracle.OracleCommand with CommandType equal to CommandType.StoredProcedure:

  • First, a query is sent to determine whether the command is a call to a pipelined table-valued function.
  • If this is not the call to a pipelined table-valued function, the second query describes procedure parameters.

To disable these checks for a single Devart.Data.Oracle.OracleCommand instance set the OracleCommand.IsTableValuedFunction property (depending on whether this command is a table-valued function call), and set OracleCommand.ImplicitRefCursors to false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Direct Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Direct Property

Indicates whether Direct mode of communicating with server should be used.

Syntax

Visual Basic (Declaration)
Public Property Direct As Boolean
C#
public bool Direct {get; set;}

Property Value

true, if dotConnect for Oracle should interact with Oracle server directly; otherwise, false. The default value is false.

Remarks

When OracleConnection.Direct property is true, dotConnect for Oracle does not require Oracle client libraries installed.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework. OracleConnection from the .NET Standard 1.3 compatible assembly always uses the Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enlist Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Enlist Property

Gets or sets a Boolean value that indicates whether the connection is automatically enlisted in the current transaction context.

Syntax

Visual Basic (Declaration)
Public Property Enlist As Boolean
C#
public bool Enlist {get; set;}

Property Value

true, if the connection is automatically enlisted in the current transaction context; false otherwise.

Remarks

This property corresponds to the "Enlist" key within the connection string. The default value is true. This property is not available in Mobile Edition.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
HAEvents Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : HAEvents Property

Allows dotConnect for Oracle to proactively remove connections to cooresponding Oracle Real Application Clusters (RAC) database service, service member, instance, or node from the pool when this service, service member, instance, or node goes down.

Syntax

Visual Basic (Declaration)
Public Property HAEvents As Boolean
C#
public bool HAEvents {get; set;}

Property Value

If true, the connections to Oracle Real Application Clusters (RAC) database services, service members, instances, or nodes that went down will be proactively removed from the pool. The default value is false.

Remarks

Please note that HA events are not supported in the OracleConnection.Direct mode. They are supported for Oracle Client 10g and higher. For Oracle Client 10g this event can be received only when you have at least one active connection to the Oracle database service, service member, instance, or node that goes down. For Oracle Client 11 and higher this event is received regardless of a presence of active connections to the event source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Home Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Home Property

Gets or sets which Oracle Home to use.

Syntax

Visual Basic (Declaration)
Public Property Home As String
C#
public string Home {get; set;}

Property Value

An Oracle Home to be used.

Remarks

Set Home property to select what Oracle client will be used in your application. Use this property if there are some Oracle clients installed at the machine. If Home property is empty dotConnect for Oracle uses default Home. You can change a value of the default home by Oracle Home Selector.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsFixedSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : IsFixedSize Property

Returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsFixedSize As Boolean
C#
public override bool IsFixedSize {get;}

Property Value

Always true.

Remarks

The value of this property is always true because connection string can consist of fixed number of keys.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Item Property

keyword
The key name.
Returns the value of given key.

Syntax

Visual Basic (Declaration)
Public Overrides Default Property Item( _
   ByVal keyword As String _
) As Object
C#
public override object this(
   string keyword
) {get; set;}

Parameters

keyword
The key name.

Property Value

Value of given key.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Keys Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Keys Property

Collection of keys in the OracleConnectionStringBuilder.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Keys As ICollection
C#
public override ICollection Keys {get;}

Property Value

Collection of keys.

Remarks

OracleConnectionStringBuilder contains two collections: Keys and Values. Collection items with the same index contain key-value pairs. Use these collections to get indexed access to properties and values of OracleConnectionStringBuilder.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
Values Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LobBlockSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : LobBlockSize Property

Specifies the size of a block (in megabytes) to read/write CLOB or NCLOB data from/to database. This option is supported in OCI mode only. Applicable only for Unicode Oracle servers.

Syntax

Visual Basic (Declaration)
Public Property LobBlockSize As Integer
C#
public int LobBlockSize {get; set;}

Property Value

The size of a block (in megabytes) to read/write CLOB or NCLOB data from/to database.

Remarks

Default value is 0, which means that the whole value is sent in one block. If you get errors when reading/writing huge LOB values, try setting this property to 8, it is the safest value.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxPoolSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : MaxPoolSize Property

The maximum number of connections allowed in the pool.

Syntax

Visual Basic (Declaration)
Public Property MaxPoolSize As Integer
C#
public int MaxPoolSize {get; set;}

Property Value

Number of connections allowed in the pool. The default value is 100.

Remarks

Setting the Max Pool Size value of the ConnectionString can affect performance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinPoolSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : MinPoolSize Property

The minimum number of connections allowed in the pool.

Syntax

Visual Basic (Declaration)
Public Property MinPoolSize As Integer
C#
public int MinPoolSize {get; set;}

Property Value

Number of connections allowed in the pool. The default value is 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NumberMappings Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : NumberMappings Property

Gets or sets the collection of number mappings used for this connection.

Syntax

Visual Basic (Declaration)
Public Property NumberMappings As OracleNumberMappingCollection
C#
public OracleNumberMappingCollection NumberMappings {get; set;}

Property Value

A Devart.Data.Oracle.OracleNumberMappingCollection object representing the number mappings.

Remarks

Allows yu to override default number mapping rules for the connection. Default value is an empty collection, which means to use default rules.

Example

This sample demonstrates how to override default number mapping rules.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection();

// Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, typeof(Int64));

// Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, typeof(bool));
C#Visual Basic Copy Code
Dim oracleConnection as New OracleConnection

' Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, GetType(Int64))

' Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, GetType(Boolean))

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
OracleNumberMappingCollection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolAllowWaiting Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolAllowWaiting Property

Enables or disables waiting for a connection to close when there is no free connection.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolAllowWaiting As Boolean
C#
public bool OciSessionPoolAllowWaiting {get; set;}

Property Value

If true, new connections wait for an existing one to close if Max Size is reached; otherwise an exception is thrown.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolConnectionLifetime Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolConnectionLifetime Property

Gets or sets the connection lifetime in the OCI pool.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolConnectionLifetime As Integer
C#
public int OciSessionPoolConnectionLifetime {get; set;}

Property Value

The connection lifetime.

Remarks

This attribute specifies the lifetime of the connection in seconds. Before the Connection is placed back into the pool, the lifetime of the connection is checked. If the lifetime of the connection exceeds this property value, the connection is closed and disposed. If this property value is 0, the connection lifetime is never checked.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolIncrement Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolIncrement Property

Specifies the number of sessions that are added at once.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolIncrement As Integer
C#
public int OciSessionPoolIncrement {get; set;}

Property Value

The next increment for sessions to be started if the current number of sessions is less than OciSessionPoolMaxSize. The valid values are 1 and above.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPooling Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPooling Property

Enables or disables the OCI Session Pooling feature.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPooling As Boolean
C#
public bool OciSessionPooling {get; set;}

Property Value

If true, enables the OCI Session Pooling feature. In this mode the dotConnect for Oracle pool is disabled. The default value is false.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolMaxSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolMaxSize Property

Specifies the maximum number of sessions that can be opened in the session pool.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolMaxSize As Integer
C#
public int OciSessionPoolMaxSize {get; set;}

Property Value

The maximum number of sessions. Once this value is reached, no more sessions are opened. The valid values are 1 and above.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolMinSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolMinSize Property

Specifies the minimum number of sessions in the session pool.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolMinSize As Integer
C#
public int OciSessionPoolMinSize {get; set;}

Property Value

The minimum number of sessions. This number of sessions are started initially. After this, sessions are opened only when necessary.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolPassword Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolPassword Property

Gets or sets password for proxy connections.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolPassword As String
C#
public string OciSessionPoolPassword {get; set;}

Property Value

If set, defines password for proxy user.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OciSessionPoolUserId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OciSessionPoolUserId Property

Gets or sets User Id for proxy connections.

Syntax

Visual Basic (Declaration)
Public Property OciSessionPoolUserId As String
C#
public string OciSessionPoolUserId {get; set;}

Property Value

If set, defines user name for proxy user.

Remarks

This property is available only when OCI Session Pooling is enabled. If you want to have proxy connections without OCI Session Pooling, use the Open(OracleConnection) overload that accepts another OracleConnection as argument.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraMts Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : OraMts Property

Determines whether to use Oracle Services for Microsoft Transaction Server (OraMTS) for distributed transactions.

Syntax

Visual Basic (Declaration)
Public Property OraMts As Boolean
C#
public bool OraMts {get; set;}

Property Value

true, if Oracle Services for Microsoft Transaction Server (OraMTS) should be used for distributed transactions; otherwise false.

Remarks

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PassParametersByName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : PassParametersByName Property

Determines whether parameters will be passed by name to the stored procedure calls.

Syntax

Visual Basic (Declaration)
Public Property PassParametersByName As Boolean
C#
public bool PassParametersByName {get; set;}

Property Value

true if parameters should be passed by name; otherwise, false. The default value is false.

Remarks

If set to true, parameters will be passed by name regardless of individual OracleCommand.PassParametersByName values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Password Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Password Property

Gets or sets the user's password to connect.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Property Value

The user's password to connect.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PersistSecurityInfo Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : PersistSecurityInfo Property

Gets or sets a value indicating whether password is stored in connection string after connection is opened.

Syntax

Visual Basic (Declaration)
Public Property PersistSecurityInfo As Boolean
C#
public bool PersistSecurityInfo {get; set;}

Property Value

If true, ConnectionString remains unaltered after opening connection; otherwise, password is removed. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pooling Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Pooling Property

Gets or sets pooling mode.

Syntax

Visual Basic (Declaration)
Public Property Pooling As Boolean
C#
public bool Pooling {get; set;}

Property Value

If true (the default value), when a OracleConnection is closed, the internal connection object is not actually closed, and is placed object is drawn from the appropriate pool or is created and added to the appropriate pool.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Port Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Port Property

Gets or sets number of a port to communicate with listener on the server.

Syntax

Visual Basic (Declaration)
Public Property Port As Integer
C#
public int Port {get; set;}

Property Value

Number of a port to communicate with listener on the server. The default value is 1521.

Remarks

This Port property is used only in OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ProxyPassword Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ProxyPassword Property

Gets or sets the password for Oracle proxy authentication.

Syntax

Visual Basic (Declaration)
Public Property ProxyPassword As String
C#
public string ProxyPassword {get; set;}

Property Value

The password for Oracle proxy authentication.

Remarks

In case of using Oracle proxy authentication, the Password connection string parameter is optional unless you perform distributed transactions.

For more information on using Proxy Authentication see Connecting to Oracle with Proxy Authentication.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ProxyUserId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ProxyUserId Property

Gets or sets the proxy user id for Oracle proxy authentication.

Syntax

Visual Basic (Declaration)
Public Property ProxyUserId As String
C#
public string ProxyUserId {get; set;}

Property Value

The proxy user id for Oracle proxy authentication.

Remarks

For more information on using Proxy Authentication see Connecting to Oracle with Proxy Authentication.

Note: This property is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Server Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Server Property

Gets or sets the name of TNS alias of the Oracle database to which to connect.

Syntax

Visual Basic (Declaration)
Public Property Server As String
C#
public string Server {get; set;}

Property Value

The name of TNS alias of the Oracle database to which to connect. The default value is an empty string ("").

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServiceName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ServiceName Property

Gets or sets an alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode.

Syntax

Visual Basic (Declaration)
Public Property ServiceName As String
C#
public string ServiceName {get; set;}

Property Value

Alias to an Oracle database instance (or many instances) to use in the OracleConnection.Direct mode. The default value is empty string.

Remarks

This property is used only in OracleConnection.Direct mode. When a value is assigned to this property, the OracleConnection is closed.

When Service Name is specified and implies several database instances, dotConnect for Oracle connects to the first instance provided by Oracle listener. Note that RAC is not supported in the Direct mode, and provider works only with this one database instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sid Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Sid Property

Gets or sets a unique name for an Oracle database instance.

Syntax

Visual Basic (Declaration)
Public Property Sid As String
C#
public string Sid {get; set;}

Property Value

Unique name for an Oracle database instance to use in the OracleConnection.Direct mode. The default value is empty string.

Remarks

This Sid property is used only in OracleConnection.Direct mode. When a value is assigned to this property, the OracleConnection is closed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementCachePurge Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : StatementCachePurge Property

Determines whether to clear the OCI statement cache when closing the connection or putting it to the pool.

Syntax

Visual Basic (Declaration)
Public Property StatementCachePurge As Boolean
C#
public bool StatementCachePurge {get; set;}

Property Value

If true, the OCI statement cache is cleared when closing the connection or putting it to the pool. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementCacheSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : StatementCacheSize Property

Gets or sets the maximum number of statements that can be cached for a connection.

Syntax

Visual Basic (Declaration)
Public Property StatementCacheSize As Integer
C#
public int StatementCacheSize {get; set;}

Property Value

The maximum number of statements that can be cached for a connection. Default value is 0 (statement caching is disabled).

Remarks

Statement caching starts if this parameter is set to a value more than 0. It should not be more than MAX_OPEN_CURSORS parameter in an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionScopeLocal Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : TransactionScopeLocal Property

Enables support for non-distributed transactions in the TransactionScope implementation.

Syntax

Visual Basic (Declaration)
Public Property TransactionScopeLocal As Boolean
C#
public bool TransactionScopeLocal {get; set;}

Property Value

true, if one-phase commit is used within TransactionScope; false otherwise.

Remarks

This feature means that if there are several connections with the same connection string (which includes "Transaction Scope Local=true;") within a scope of TransactionScope, our provider will use only one connection internally. The default value is false. This property is not available in Mobile Edition.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TrimFixedChar Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : TrimFixedChar Property

Specifies whether to trim trailing spaces when reading data from fixed-length string data types (CHAR, NCHAR).

Syntax

Visual Basic (Declaration)
Public Property TrimFixedChar As Boolean
C#
public bool TrimFixedChar {get; set;}

Property Value

true, if fixed-length string data type (CHAR, NCHAR) values should be trimmed; otherwise, false. The default value is true.

Remarks

Affects all command objects of this connection. Behaviour of data reader depends on TrimFixedChar value at the moment of opening data reader.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unicode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Unicode Property

Gets or sets a value indicating whether the UTF16 charset will be used.

Syntax

Visual Basic (Declaration)
Public Property Unicode As Boolean
C#
public bool Unicode {get; set;}

Property Value

true, if client charset UTF16 is used; false, if default client charset is used. The default value is false.

Remarks

Sets Oracle server client charset to UTF16 and converts client data according to this charset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UsePerformanceMonitor Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : UsePerformanceMonitor Property

Enables dotConnect for Oracle performance counters that allow you to conveniently measure the frequency of connecting/disconnecting to the data source, the number of active connections, pooled connections, etc. via Windows Performance Monitor or programmatically. See Performance Counters Support for more information.

Syntax

Visual Basic (Declaration)
Public Property UsePerformanceMonitor As Boolean
C#
public bool UsePerformanceMonitor {get; set;}

Property Value

If true, the dotConnect for Oracle performance counters will be enabled and available in Windows Performance Monitor when an application, using such connections is running. The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : UserId Property

Gets or sets the name of the user to connect.

Syntax

Visual Basic (Declaration)
Public Property UserId As String
C#
public string UserId {get; set;}

Property Value

The name of the user to connect.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ValidateConnection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : ValidateConnection Property

Indicates whether to validate connections that are being taken from the pool.

Syntax

Visual Basic (Declaration)
Public Property ValidateConnection As Boolean
C#
public bool ValidateConnection {get; set;}

Property Value

true, if the connection should be validated when it is taken from the pool; false otherwise.

Remarks

If true, each time when a connection is taken from the pool, it is checked for validity. If the connection is not valid, it is destroyed and a new one is created.

If this parameter is true, the connection pool manager background validation is disabled in this case as it is not needed. In such case we always have a valid connection, however the performance is not optimal.

This behaviour may be useful when the physical connection is unstable and connection can be lost in a short period of time. Pool manager validates pool connections every 30 seconds, so it is possible that connection will become invalid during this interval and the application will take it from the pool before the validation. If the physical connection is stable, pool manager validation is enough to ensure that the connection is valid, so it is better not to use this property. Use this property only if necessary because it causes a round-trip to the database to validate each connection immediately before it is provided to the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Values Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleConnectionStringBuilder Class : Values Property

Collection of values in the OracleConnectionStringBuilder.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Values As ICollection
C#
public override ICollection Values {get;}

Property Value

Collection of values.

Remarks

OracleConnectionStringBuilder contains two collections: Keys and Values. Collection items with the same index contain key-value pairs. Use these collections to get indexed access to properties and values of OracleConnectionStringBuilder.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleConnectionStringBuilder Class
OracleConnectionStringBuilder Members
Keys Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleCursor Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCursor Class

Represents an Oracle REF CURSOR and value of cursor field.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleCursor

Syntax

Visual Basic (Declaration)
Public Class OracleCursor
   Inherits System.MarshalByRefObject
   Implements IDataReader, IDataRecord, INullable, IDisposable
C#
public class OracleCursor : System.MarshalByRefObject, IDataReader, IDataRecord, INullable, IDisposable

Remarks

You can get cursor as a parameter value by Value property or by calling OracleDataReader.GetOracleCursor method of the OracleDataReader object.

You can use cursor to obtain OracleDataReader object and read data from it. The OracleDataReader can be retrieved only once.

Example

The following example uses OracleCursor class as the type of output parameter. It demonstrates how to retrieve Oracle REF CURSOR from server, obtain OracleDataReader object and read data from it. To create required stored procedure, table and fill it with data you can use the following script:

DROP TABLE DEPT;

CREATE TABLE DEPT (
  DEPTNO NUMBER(4) CONSTRAINT PK_DEPT PRIMARY KEY,
  DNAME VARCHAR2(14) ,
  LOC VARCHAR2(13)
);

INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');
INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');
INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');
INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');

CREATE OR REPLACE PROCEDURE GET_DEPT(CUR OUT SYS_REFCURSOR)
IS
BEGIN
  OPEN CUR FOR SELECT * FROM DEPT;
END;
C#csharp Copy Code
public void GettingCursor(string connStr) {
        OracleConnection conn = new OracleConnection(connStr);
        conn.Open();
        try {
                OracleCommand command = conn.CreateCommand();
                command.CommandType = System.Data.CommandType.StoredProcedure;
                command.CommandText = "GET_DEPT";
                command.Parameters.Add("cursor", OracleDbType.Cursor);
                command.Parameters["cursor"].Direction = System.Data.ParameterDirection.Output;
                command.ExecuteNonQuery();
                OracleDataReader reader = ((OracleCursor)command.Parameters["cursor"].Value).GetDataReader();
                while (reader.Read()) {
                        Console.WriteLine(reader.GetInt32(0) + ", " + reader.GetString(reader.GetOrdinal("DName")));
                }
        }
        catch (OracleException ex) {
                Console.WriteLine(ex.Message);
        }
        finally {
                conn.Close();
        }
}
C#Visual Basic Copy Code
Public Sub GettingCursor(ByVal connStr As String)
        Dim conn As New OracleConnection(connStr)
        conn.Open()
        Try
                Dim command As OracleCommand = conn.CreateCommand()
                command.CommandType = System.Data.CommandType.StoredProcedure
                command.CommandText = "GET_DEPT"
                command.Parameters.Add("cursor", OracleDbType.Cursor)
                command.Parameters("cursor").Direction = System.Data.ParameterDirection.Output
                command.ExecuteNonQuery()
                Dim reader As OracleDataReader = (CType(command.Parameters("cursor").Value, OracleCursor)).GetDataReader()
                While reader.Read()
                        Console.WriteLine(reader.GetInt32(0).ToString() + ", " + reader.GetString(reader.GetOrdinal("DName")))
                End While
        Catch ex As OracleException
                Console.WriteLine(ex.Message)
        Finally
                conn.Close()
        End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleCursor Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleCursor Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleCursor Class

The following tables list the members exposed by OracleCursor.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null OracleCursor object not associated with any cursor at the server.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets the Devart.Data.Oracle.OracleConnection used by the OracleCursor.
public Property | FetchSize | Gets or sets the required size of the OracleDataReader internal cache to store result set data. The default value is 131072.
public Property | IsClosed | Gets a value indicating whether the OracleCursor object is closed or not.
public Property | IsNull | Gets a value indicating whether the OracleCursor object represents Null.
Top

Public Methods

 | Name | Description
public Method | Close | Closes server cursor.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleCursor object.
public Method | GetDataReader | Gets an OracleDataReader for the specified cursor.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleCursor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleCursor Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCursor Class

For a list of all members of this type, see OracleCursor members.

Public Methods

 | Name | Description
public Method | Close | Closes server cursor.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleCursor object.
public Method | GetDataReader | Gets an OracleDataReader for the specified cursor.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleCursor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : Close Method

Closes server cursor.

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : Dispose() Method

Disposes the resources allocated by the OracleCursor object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

After disposing OracleCursor object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataReader Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : GetDataReader Method

Gets an OracleDataReader for the specified cursor.

Syntax

Visual Basic (Declaration)
Public Function GetDataReader() As OracleDataReader
C#
public OracleDataReader GetDataReader()

Return Value

The OracleDataReader for the cursor.

Remarks

An OracleDataReader allows you to read data from the cursor at the server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleCursor Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCursor Class

For a list of all members of this type, see OracleCursor members.

Public Properties

 | Name | Description
public Property | Connection | Gets the Devart.Data.Oracle.OracleConnection used by the OracleCursor.
public Property | FetchSize | Gets or sets the required size of the OracleDataReader internal cache to store result set data. The default value is 131072.
public Property | IsClosed | Gets a value indicating whether the OracleCursor object is closed or not.
public Property | IsNull | Gets a value indicating whether the OracleCursor object represents Null.
Top

See Also

Reference

OracleCursor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : Connection Property

Gets the OracleConnection used by the OracleCursor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Connection As OracleConnection
C#
public OracleConnection Connection {get;}

Property Value

An OracleConnection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FetchSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : FetchSize Property

Gets or sets the required size of the OracleDataReader internal cache to store result set data. The default value is 131072.

Syntax

Visual Basic (Declaration)
Public Property FetchSize As Integer
C#
public int FetchSize {get; set;}

Property Value

The required size of the OracleDataReader internal cache to store result set data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsClosed Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : IsClosed Property

Gets a value indicating whether the OracleCursor object is closed or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsClosed As Boolean
C#
public bool IsClosed {get;}

Property Value

true if the OracleCursor is closed; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : IsNull Property

Gets a value indicating whether the OracleCursor object represents Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the OracleCursor object represents Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleCursor Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCursor Class

For a list of all members of this type, see OracleCursor members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null OracleCursor object not associated with any cursor at the server.
Top

See Also

Reference

OracleCursor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : Null Field

Represents a null OracleCursor object not associated with any cursor at the server.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleCursor
C#
public static readonly OracleCursor Null

Remarks

Use Null field to compare with values returned from server through OracleParameter.OracleValue and some methods of OracleDataReader. You can pass value of this field to the server as well through OracleParameter.OracleValue or OracleParameter.Value properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataAdapter Class

Represents a set of data commands and a data source connection that are used to fill the System.Data.DataSet and update an Oracle data.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Data.Common.DataAdapter
System.Data.Common.DbDataAdapter
Devart.Common.DbDataAdapter
Devart.Data.Oracle.OracleDataAdapter

Syntax

Visual Basic (Declaration)
Public Class OracleDataAdapter
   Inherits Devart.Common.DbDataAdapter
   Implements IComponent, IDataAdapter, IDbDataAdapter, ICloneable, IDisposable
C#
public class OracleDataAdapter : Devart.Common.DbDataAdapter, IComponent, IDataAdapter, IDbDataAdapter, ICloneable, IDisposable

Remarks

The OracleDataAdapter serves as a bridge between a System.Data.DataSet and a data source for retrieving and saving data. The OracleDataAdapter provides this bridge by using System.Data.Common.DbDataAdapter.Fill to load data from the data source into the System.Data.DataSet, and using System.Data.DataSet.Update() to send changes made in the System.Data.DataSet back to the data source.

OracleDataAdapter is used in conjunction with Devart.Data.Oracle.OracleConnection and OracleCommand to increase performance when connecting to Oracle.

The OracleDataAdapter also includes the OracleDataAdapter.SelectCommand, OracleDataAdapter.InsertCommand, OracleDataAdapter.DeleteCommand, OracleDataAdapter.UpdateCommand, and TableMappings properties to facilitate loading and updating of data.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

The following example demonstrates how to retrieve and manipulate data using OracleDataAdapter.
C#csharp Copy Code
public void UseDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Departments");
  object[] rowVals = new object[2];
  rowVals[0] = 40;
  rowVals[1] = "Operations";
  myDataSet.Tables["Departments"].Rows.Add(rowVals);
  myAdapter.InsertCommand = new OracleCommand("INSERT INTO Test.Dept (DeptNo, DName) " +
    "VALUES (:DeptNo, :DName)", myConnection);
  myAdapter.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo");
  myAdapter.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName");
  myAdapter.Update(myDataSet,"Departments");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Departments")
  Dim rowVals(1) As Object
  rowVals(0) = "40"
  rowVals(1) = "Operations"
  myDataSet.Tables("Departments").Rows.Add(rowVals)
  myAdapter.InsertCommand = New OracleCommand("INSERT INTO Test.Dept (DeptNo, DName) " & _
      "VALUES (:DeptNo, :DName)", myConnection)
  myAdapter.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo")
  myAdapter.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName")
  myAdapter.Update(myDataSet, "Departments")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDataAdapter Members
Devart.Data.Oracle Namespace
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleDataAdapter Class

The following tables list the members exposed by OracleDataAdapter.

Public Constructors

 | Name | Description
public Constructor | OracleDataAdapter Constructor | Overloaded. Initializes a new instance of the OracleDataAdapter class.
Top

Public Properties

 | Name | Description
public Property | AcceptChangesDuringFill | Gets or sets a value indicating whether System.Data.DataRow.AcceptChanges is called on a System.Data.DataRow after it is added to the System.Data.DataTable during any of the Fill operations. (Inherited from System.Data.Common.DataAdapter)
public Property | AcceptChangesDuringUpdate | Gets or sets whether System.Data.DataRow.AcceptChanges is called during a System.Data.Common.DataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.DataAdapter)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | ContinueUpdateOnError | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update. (Inherited from System.Data.Common.DataAdapter)
public Property | DeleteCommand | Gets or sets an Oracle statement to delete records from the data set.
public Property | FillLoadOption | Gets or sets the System.Data.LoadOption that determines how the adapter fills the System.Data.DataTable from the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DataAdapter)
public Property | InsertCommand | Gets or sets an Oracle statement to insert new records into the data source.
public Property | MissingMappingAction | Determines the action to take when incoming data does not have a matching table or column. (Inherited from System.Data.Common.DataAdapter)
public Property | MissingSchemaAction | Determines the action to take when existing System.Data.DataSet schema does not match incoming data. (Inherited from System.Data.Common.DataAdapter)
public Property | ReturnProviderSpecificTypes | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values. (Inherited from System.Data.Common.DataAdapter)
public Property | SelectCommand | Gets or sets an Oracle statement used to select records in the data source.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableMappings | Gets a collection that provides the master mapping between a source table and a OracleDataTable.
public Property | UpdateBatchSize | Overridden. Gets or sets the number of rows that are processed in each round-trip to the server.
public Property | UpdateCommand | Gets or sets an Oracle statement used to update records in the data source.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Fill | Overloaded. Adds or refreshes rows in a System.Data.DataTable to match those in the data source using the specified System.Data.DataTable and OracleCursor.
public Method | FillPage | Fills associated DataSet with specified range of rows. (Inherited from Devart.Common.DbDataAdapter)
public Method | FillSchema | Overloaded. Adds a System.Data.DataTable to the specified System.Data.DataSet. (Inherited from System.Data.Common.DataAdapter)
public Method | GetFillParameters | Gets the parameters set by the user when executing an SQL SELECT statement. (Inherited from System.Data.Common.DataAdapter)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeSequentialFill | Prepares the OracleDataAdapter to operate in sequential mode.
public Method | TerminateSequentialFill | Frees the resources required for the sequential mode.
public Method | Update | Overloaded. Calls the respective INSERT, UPDATE, or DELETE statements for each inserted, updated, or deleted row in the specified System.Data.DataSet from a System.Data.DataTable named "Table." (Inherited from System.Data.Common.DataAdapter)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | FillError | Returned when an error occurs during a fill operation. (Inherited from System.Data.Common.DataAdapter)
public Event | RowUpdated | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | RowUpdating | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.
Top

See Also

Reference

OracleDataAdapter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : OracleDataAdapter Constructor

Initializes a new instance of the OracleDataAdapter class.

Overload List

Overload | Description
OracleDataAdapter Constructor() | Initializes a new instance of the OracleDataAdapter class.
OracleDataAdapter Constructor(OracleCommand) | Initializes a new instance of the OracleDataAdapter class with the specified Devart.Data.Oracle.OracleCommand as the %% property.
OracleDataAdapter Constructor(String,String) | Initializes a new instance of the OracleDataAdapter class with a OracleDataAdapter.SelectCommand and a connection string.
OracleDataAdapter Constructor(String,OracleConnection) | Initializes a new instance of the OracleDataAdapter class with a OracleDataAdapter.SelectCommand and a OracleConnection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Constructor()
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > OracleDataAdapter Constructor : OracleDataAdapter Constructor()

Initializes a new instance of the OracleDataAdapter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleDataAdapter()

Remarks

When you create an instance of OracleDataAdapter, the following read/write properties are set to their default values, as shown in the table.
Properties | Default Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example

The following example creates a OracleDataAdapter, sets some of its properties, retrieves data from a table, and displays it.
C#csharp Copy Code
public void CreateDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter();
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.SelectCommand = new OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.Fill(myDataSet,"Dept");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub CreateDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.SelectCommand = New OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.Fill(myDataSet, "Dept")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Constructor(OracleCommand)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > OracleDataAdapter Constructor : OracleDataAdapter Constructor(OracleCommand)

selectCommand
A Devart.Data.Oracle.OracleCommand that contains SQL SELECT statement, and is set as the OracleDataAdapter.SelectCommand property of the OracleDataAdapter.
Initializes a new instance of the OracleDataAdapter class with the specified Devart.Data.Oracle.OracleCommand as the scrap:condition=communityenabled,name=_COMMUNITY_SECTION,contenttype=summary%%

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommand As OracleCommand _
)
C#
public OracleDataAdapter(
   OracleCommand selectCommand
)

Parameters

selectCommand
A Devart.Data.Oracle.OracleCommand that contains SQL SELECT statement, and is set as the OracleDataAdapter.SelectCommand property of the OracleDataAdapter.

Remarks

This implementation of the OracleDataAdapter constructor sets the OracleDataAdapter.SelectCommand property to the value specified in the selectCommand parameter.

When you create an instance of OracleDataAdapter, the following read/write properties are set to their default values, as shown in the table.

Properties | Default Value
MissingMappingAction | MissingMappingAction.Passthrough
MissingSchemaAction | MissingSchemaAction.Add

You can change the value of any of these properties through a separate call to the property.

Example

The following example creates a OracleDataAdapter, sets some of its properties, retrieves data from a table, and displays it.
C#csharp Copy Code
public void CreateDataAdapter(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  OracleDataAdapter myAdapter = new OracleDataAdapter(myCommand);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Dept");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub CreateDataAdapter(ByVal myConnection As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter(myCommand)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Dept")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleConnection Class
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Constructor(String,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > OracleDataAdapter Constructor : OracleDataAdapter Constructor(String,String)

selectCommandText
A System.String that is a SELECT statement to be used as the CommandText of the OracleDataAdapter.SelectCommand property of the OracleDataAdapter .
selectConnectionString
The connection string.
Initializes a new instance of the OracleDataAdapter class with a OracleDataAdapter.SelectCommand and a connection string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommandText As String, _
   ByVal selectConnectionString As String _
)
C#
public OracleDataAdapter(
   string selectCommandText,
   string selectConnectionString
)

Parameters

selectCommandText
A System.String that is a SELECT statement to be used as the CommandText of the OracleDataAdapter.SelectCommand property of the OracleDataAdapter .
selectConnectionString
The connection string.

Example

The following example creates a OracleDataAdapter, sets some of its properties, retrieves data from a table, and displays it.
C#csharp Copy Code
public void CreateDataAdapter()
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept",
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Departments");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub CreateDataAdapter()
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Departments")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleConnection Class
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Constructor(String,OracleConnection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > OracleDataAdapter Constructor : OracleDataAdapter Constructor(String,OracleConnection)

selectCommandText
A System.String that contains a SQL SELECT statement to be used as the CommandText of the OracleDataAdapter.SelectCommand property of the OracleDataAdapter.
selectConnection
A OracleConnection that represents the connection.
Initializes a new instance of the OracleDataAdapter class with a OracleDataAdapter.SelectCommand and a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommandText As String, _
   ByVal selectConnection As OracleConnection _
)
C#
public OracleDataAdapter(
   string selectCommandText,
   OracleConnection selectConnection
)

Parameters

selectCommandText
A System.String that contains a SQL SELECT statement to be used as the CommandText of the OracleDataAdapter.SelectCommand property of the OracleDataAdapter.
selectConnection
A OracleConnection that represents the connection.

Remarks

This implementation of the OracleDataAdapter can be useful in an application that must call the Fill method for two or more OracleDataAdapter objects.

Example

The following example creates a OracleDataAdapter, sets some of its properties, retrieves data from a table, and displays it.
C#csharp Copy Code
public void CreateDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Dept");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub CreateDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Dept")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataAdapter Class

For a list of all members of this type, see OracleDataAdapter members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Fill | Overloaded. Adds or refreshes rows in a System.Data.DataTable to match those in the data source using the specified System.Data.DataTable and OracleCursor.
public Method | FillPage | Fills associated DataSet with specified range of rows. (Inherited from Devart.Common.DbDataAdapter)
public Method | FillSchema | Overloaded. Adds a System.Data.DataTable to the specified System.Data.DataSet. (Inherited from System.Data.Common.DataAdapter)
public Method | GetFillParameters | Gets the parameters set by the user when executing an SQL SELECT statement. (Inherited from System.Data.Common.DataAdapter)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeSequentialFill | Prepares the OracleDataAdapter to operate in sequential mode.
public Method | TerminateSequentialFill | Frees the resources required for the sequential mode.
public Method | Update | Overloaded. Calls the respective INSERT, UPDATE, or DELETE statements for each inserted, updated, or deleted row in the specified System.Data.DataSet from a System.Data.DataTable named "Table." (Inherited from System.Data.Common.DataAdapter)
Top

See Also

Reference

OracleDataAdapter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : Fill Method

Adds or refreshes rows in a System.Data.DataTable to match those in the data source using the specified System.Data.DataTable and OracleCursor.

Overload List

Overload | Description
Fill(DataTable,OracleCursor) | Adds or refreshes rows in a System.Data.DataTable to match those in the data source using the specified System.Data.DataTable and OracleCursor.
Fill(DataSet,OracleCursor) | Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the specified System.Data.DataSet and the OracleCursor.
Fill(DataSet,String,OracleCursor) | Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the specified System.Data.DataSet and OracleCursor.
Fill(DataSet,Int32,Int32,String,OracleCursor) | Adds or refreshes rows in a specified range in the System.Data.DataSet to match those in the data source using the System.Data.DataSet, System.Data.DataTable, and OracleCursor.
Fill(DataSet,String) | Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the System.Data.DataSet and System.Data.DataTable names. (Inherited from System.Data.Common.DbDataAdapter)
Fill(DataSet,Int32,Int32,String) | Adds or refreshes rows in a specified range in the System.Data.DataSet to match those in the data source using the System.Data.DataSet and System.Data.DataTable names. (Inherited from System.Data.Common.DbDataAdapter)
Fill(DataTable) | Adds or refreshes rows in a specified range in the System.Data.DataSet to match those in the data source using the System.Data.DataTable name. (Inherited from System.Data.Common.DbDataAdapter)
Fill(Int32,Int32,DataTable[]) | Adds or refreshes rows in a System.Data.DataTable to match those in the data source starting at the specified record and retrieving up to the specified maximum number of records. (Inherited from System.Data.Common.DbDataAdapter)
Fill(DataSet) | Adds or refreshes rows in the System.Data.DataSet to match those in the data source. (Inherited from System.Data.Common.DataAdapter)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill(DataTable,OracleCursor) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > Fill Method : Fill(DataTable,OracleCursor) Method

dataTable
A System.Data.DataTable to fill with records.
cursor
An OracleCursor used to retrieve data using OracleDataReader.
Adds or refreshes rows in a System.Data.DataTable to match those in the data source using the specified System.Data.DataTable and OracleCursor.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill( _
   ByVal dataTable As DataTable, _
   ByVal cursor As OracleCursor _
) As Integer
C#
public int Fill(
   DataTable dataTable,
   OracleCursor cursor
)

Parameters

dataTable
A System.Data.DataTable to fill with records.
cursor
An OracleCursor used to retrieve data using OracleDataReader.

Return Value

The number of rows successfully added to or refreshed in the System.Data.DataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleCursor Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill(DataSet,OracleCursor) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > Fill Method : Fill(DataSet,OracleCursor) Method

dataSet
A System.Data.DataSet to fill with records.
cursor
An OracleCursor used to retrieve data using OracleDataReader.
Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the specified System.Data.DataSet and the OracleCursor.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill( _
   ByVal dataSet As DataSet, _
   ByVal cursor As OracleCursor _
) As Integer
C#
public int Fill(
   DataSet dataSet,
   OracleCursor cursor
)

Parameters

dataSet
A System.Data.DataSet to fill with records.
cursor
An OracleCursor used to retrieve data using OracleDataReader.

Return Value

The number of rows successfully added to or refreshed in the System.Data.DataSet.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleCursor Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill(DataSet,String,OracleCursor) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > Fill Method : Fill(DataSet,String,OracleCursor) Method

dataSet
A System.Data.DataSet to fill with records.
srcTable
The name of the System.Data.DataTable to use for table mapping.
cursor
An OracleCursor used to retrieve data using OracleDataReader.
Adds or refreshes rows in the System.Data.DataSet to match those in the data source using the specified System.Data.DataSet and OracleCursor.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill( _
   ByVal dataSet As DataSet, _
   ByVal srcTable As String, _
   ByVal cursor As OracleCursor _
) As Integer
C#
public int Fill(
   DataSet dataSet,
   string srcTable,
   OracleCursor cursor
)

Parameters

dataSet
A System.Data.DataSet to fill with records.
srcTable
The name of the System.Data.DataTable to use for table mapping.
cursor
An OracleCursor used to retrieve data using OracleDataReader.

Return Value

The number of rows successfully added to or refreshed in the System.Data.DataSet.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleCursor Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Fill(DataSet,Int32,Int32,String,OracleCursor) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class > Fill Method : Fill(DataSet,Int32,Int32,String,OracleCursor) Method

dataSet
A System.Data.DataSet to fill with records.
startRecord
The zero-based record number to start with.
maxRecords
The maximum number of records to retrieve.
srcTable
The name of the System.Data.DataTable to use for table mapping.
cursor
An OracleCursor used to retrieve data using OracleDataReader.
Adds or refreshes rows in a specified range in the System.Data.DataSet to match those in the data source using the System.Data.DataSet, System.Data.DataTable, and OracleCursor.

Syntax

Visual Basic (Declaration)
Public Overloads Function Fill( _
   ByVal dataSet As DataSet, _
   ByVal startRecord As Integer, _
   ByVal maxRecords As Integer, _
   ByVal srcTable As String, _
   ByVal cursor As OracleCursor _
) As Integer
C#
public int Fill(
   DataSet dataSet,
   int startRecord,
   int maxRecords,
   string srcTable,
   OracleCursor cursor
)

Parameters

dataSet
A System.Data.DataSet to fill with records.
startRecord
The zero-based record number to start with.
maxRecords
The maximum number of records to retrieve.
srcTable
The name of the System.Data.DataTable to use for table mapping.
cursor
An OracleCursor used to retrieve data using OracleDataReader.

Return Value

The number of rows successfully added to or refreshed in the System.Data.DataSet.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
Overload List
OracleCursor Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InitializeSequentialFill Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : InitializeSequentialFill Method

Prepares the OracleDataAdapter to operate in sequential mode.

Syntax

Visual Basic (Declaration)
Public Sub InitializeSequentialFill()
C#
public void InitializeSequentialFill()

Remarks

The sequential mode provides significant performance boost when the OracleDataAdapter requests adjacent blocks of data one after another.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
TerminateSequentialFill Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TerminateSequentialFill Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : TerminateSequentialFill Method

Frees the resources required for the sequential mode.

Syntax

Visual Basic (Declaration)
Public Sub TerminateSequentialFill()
C#
public void TerminateSequentialFill()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
InitializeSequentialFill Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataAdapter Class

For a list of all members of this type, see OracleDataAdapter members.

Public Properties

 | Name | Description
public Property | AcceptChangesDuringFill | Gets or sets a value indicating whether System.Data.DataRow.AcceptChanges is called on a System.Data.DataRow after it is added to the System.Data.DataTable during any of the Fill operations. (Inherited from System.Data.Common.DataAdapter)
public Property | AcceptChangesDuringUpdate | Gets or sets whether System.Data.DataRow.AcceptChanges is called during a System.Data.Common.DataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.DataAdapter)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | ContinueUpdateOnError | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update. (Inherited from System.Data.Common.DataAdapter)
public Property | DeleteCommand | Gets or sets an Oracle statement to delete records from the data set.
public Property | FillLoadOption | Gets or sets the System.Data.LoadOption that determines how the adapter fills the System.Data.DataTable from the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DataAdapter)
public Property | InsertCommand | Gets or sets an Oracle statement to insert new records into the data source.
public Property | MissingMappingAction | Determines the action to take when incoming data does not have a matching table or column. (Inherited from System.Data.Common.DataAdapter)
public Property | MissingSchemaAction | Determines the action to take when existing System.Data.DataSet schema does not match incoming data. (Inherited from System.Data.Common.DataAdapter)
public Property | ReturnProviderSpecificTypes | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values. (Inherited from System.Data.Common.DataAdapter)
public Property | SelectCommand | Gets or sets an Oracle statement used to select records in the data source.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableMappings | Gets a collection that provides the master mapping between a source table and a OracleDataTable.
public Property | UpdateBatchSize | Overridden. Gets or sets the number of rows that are processed in each round-trip to the server.
public Property | UpdateCommand | Gets or sets an Oracle statement used to update records in the data source.
Top

See Also

Reference

OracleDataAdapter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : DeleteCommand Property

Gets or sets an Oracle statement to delete records from the data set.

Syntax

Visual Basic (Declaration)
Public Shadows Property DeleteCommand As OracleCommand
C#
public new OracleCommand DeleteCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to delete records in Oracle that correspond to deleted rows in the System.Data.DataSet.

Remarks

During an update operation, if OracleDataAdapter.DeleteCommand is not set and primary key information is present in the System.Data.DataSet, you can use the OracleCommandBuilder class to automatically generate the OracleDataAdapter.DeleteCommand, and additional commands needed to reconcile the System.Data.DataSet to the data source. To do this, set the OracleDataAdapter.SelectCommand property of the OracleDataAdapter. For more information see "Automatically Generated Commands" in the Microsoft .NET Framework SDK documentation.

Example

The following example demonstrates how to retrieve and manipulate data using OracleDataAdapter.
C#csharp Copy Code
public void UseDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Departments");
  myDataSet.Tables["Departments"].Rows[3].Delete();
  myAdapter.DeleteCommand = new OracleCommand("DELETE FROM Test.Dept WHERE DeptNo = :DeptNo", myConnection);
  myAdapter.DeleteCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original;
  myAdapter.Update(myDataSet,"Departments");

  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Departments")
  myDataSet.Tables("Departments").Rows(3).Delete()
  myAdapter.DeleteCommand = New OracleCommand("DELETE FROM Test.Dept WHERE DeptNo = :DeptNo", myConnection)
  myAdapter.DeleteCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original
  myAdapter.Update(myDataSet, "Departments")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
InsertCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : InsertCommand Property

Gets or sets an Oracle statement to insert new records into the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property InsertCommand As OracleCommand
C#
public new OracleCommand InsertCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to insert records in the data source that correspond to new rows in the System.Data.DataSet.

Remarks

During an update operation, if OracleDataAdapter.InsertCommand is not set and primary key information is present in the System.Data.DataSet, you can use the OracleCommandBuilder class to automatically generate OracleDataAdapter.InsertCommand, and additional commands needed to reconcile the System.Data.DataSet to the data source. To do this, set the OracleDataAdapter.SelectCommand property of the OracleDataAdapter. For more information see "Automatically Generated Commands" in the Microsoft .NET Framework SDK documentation.

Note: If execution of this command returns rows, these rows may be added to the System.Data.DataSet depending upon how you set the Devart.Common.DbCommandBase.UpdatedRowSource property of the Devart.Data.Oracle.OracleCommand object.

Example

The following example demonstrates how to retrieve and manipulate data using OracleDataAdapter.
C#csharp Copy Code
public void UseDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Departments");
  object[] rowVals = new object[2];
  rowVals[0] = 40;
  rowVals[1] = "Operations";
  myDataSet.Tables["Departments"].Rows.Add(rowVals);
  myAdapter.InsertCommand = new OracleCommand("INSERT INTO Test.Dept (DeptNo, DName) " +
    "VALUES (:DeptNo, :DName)", myConnection);
        myAdapter.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo");
  myAdapter.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName");
  myAdapter.Update(myDataSet,"Departments");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Departments")
  Dim rowVals(1) As Object
  rowVals(0) = "40"
  rowVals(1) = "Operations"
  myDataSet.Tables("Departments").Rows.Add(rowVals)
  myAdapter.InsertCommand = New OracleCommand("INSERT INTO Test.Dept (DeptNo, DName) " & _
      "VALUES (:DeptNo, :DName)", myConnection)
  myAdapter.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo")
  myAdapter.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName")
  myAdapter.Update(myDataSet, "Departments")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
DeleteCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : SelectCommand Property

Gets or sets an Oracle statement used to select records in the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property SelectCommand As OracleCommand
C#
public new OracleCommand SelectCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand that is used during a fill operation to select records from the data source for placement in the System.Data.DataSet.

Remarks

When OracleDataAdapter.SelectCommand is assigned to a previously created Devart.Data.Oracle.OracleCommand, the Devart.Data.Oracle.OracleCommand is not cloned. Instead, the OracleDataAdapter.SelectCommand maintains a reference to the previously created Devart.Data.Oracle.OracleCommand object.

If OracleDataAdapter.SelectCommand does not return any rows, no tables are added to the System.Data.DataSet, and no exception is raised.

This property supports the InterForm technology.

Example

The following example creates a OracleDataAdapter, sets some of its properties, retrieves data from a table, and displays it.
C#csharp Copy Code
public void CreateDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter();
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.SelectCommand = new OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.Fill(myDataSet,"Dept");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub CreateDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.SelectCommand = New OracleCommand("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.Fill(myDataSet, "Dept")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
DeleteCommand Property
InsertCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableMappings Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : TableMappings Property

Gets a collection that provides the master mapping between a source table and a OracleDataTable.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property TableMappings As DataTableMappingCollection
C#
public new DataTableMappingCollection TableMappings {get;}

Property Value

A collection that provides the master mapping between the returned records and the System.Data.DataSet. The default value is an empty collection.

Remarks

When reconciling changes, the OracleDataAdapter uses the System.Data.Common.DataTableMappingCollection collection to associate the column names used by the data source with the column names used by the System.Data.DataSet.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateBatchSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : UpdateBatchSize Property

Gets or sets the number of rows that are processed in each round-trip to the server.

Syntax

Visual Basic (Declaration)
Public Overrides Property UpdateBatchSize As Integer
C#
public override int UpdateBatchSize {get; set;}

Property Value

The number of rows to process per batch.

Value is | Effect
0 | There is no limit on the batch size.
1 | Disables batch updating.
more than 1 | Changes are sent using batches of UpdateBatchSize operations at a time.

When setting this to a value other than 1, all the commands associated with the OracleDataAdapter should have their Devart.Common.DbCommandBase.UpdatedRowSource property set to None or OutputParameters. An exception is thrown otherwise.

Remarks

Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch.

Use the UpdateBatchSize property to update a data source with changes from a OracleDataSet. This can increase application performance by reducing the number of round-trips to the server.

Executing an extremely large batch could decrease performance. Therefore, you should test for the optimum batch size setting before implementing your application.

An System.ArgumentOutOfRangeException is thrown if the value is set to a number less than zero.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : UpdateCommand Property

Gets or sets an Oracle statement used to update records in the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdateCommand As OracleCommand
C#
public new OracleCommand UpdateCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to update records in the data source that correspond to modified rows in the System.Data.DataSet.

Remarks

During an update operation, if OracleDataAdapter.UpdateCommand is not set and primary key information is present in the System.Data.DataSet, you can use the OracleCommandBuilder class to automatically generate OracleDataAdapter.UpdateCommand, and additional commands needed to reconcile the System.Data.DataSet to the data source. To do this, set the OracleDataAdapter.SelectCommand property of the OracleDataAdapter. For more information see "Automatically Generated Commands" in the Microsoft .NET Framework SDK documentation.

Note: If execution of this command returns rows, these rows may be merged with the System.Data.DataSet depending upon how you set the Devart.Common.DbCommandBase.UpdatedRowSource property of the Devart.Data.Oracle.OracleCommand object.

Example

The following example demonstrates how to retrieve and manipulate data using OracleDataAdapter.
C#csharp Copy Code
public void UseDataAdapter(OracleConnection myConnection)
{
  OracleDataAdapter myAdapter = new OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection);
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey;
  DataSet myDataSet = new DataSet();
  myAdapter.Fill(myDataSet,"Departments");
  myDataSet.Tables["Departments"].Rows[3]["DName"] = "Researches";
  myAdapter.UpdateCommand = new OracleCommand("UPDATE Test.Dept SET DeptNo = :DeptNo, DName = :DName " +
      "WHERE DeptNo = :oldDeptNo", myConnection);
  myAdapter.UpdateCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo");
  myAdapter.UpdateCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName");
  myAdapter.UpdateCommand.Parameters.Add("oldDeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original;
  myAdapter.Update(myDataSet,"Departments");
  //Get all data from all tables within the dataset
  foreach(DataTable myTable in myDataSet.Tables)
  {
    foreach(DataRow myRow in myTable.Rows)
    {
      foreach (DataColumn myColumn in myTable.Columns)
      {
        Console.Write(myRow[myColumn]+"\t");
      }
      Console.WriteLine();
    }
    Console.WriteLine();
  }
}
C#Visual Basic Copy Code
Public Sub UseDataAdapter(ByVal myConnection As OracleConnection)
  Dim myAdapter As OracleDataAdapter = New OracleDataAdapter("SELECT DeptNo, DName FROM Test.Dept", myConnection)
  myAdapter.MissingSchemaAction = MissingSchemaAction.AddWithKey
  Dim myDataSet As DataSet = New DataSet
  myAdapter.Fill(myDataSet, "Departments")
  myDataSet.Tables("Departments").Rows(3)("DName") = "Researches"
  myAdapter.UpdateCommand = New OracleCommand("UPDATE Test.Dept SET DeptNo = :DeptNo, DName = :DName " & _
        "WHERE DeptNo = :oldDeptNo", myConnection)
  myAdapter.UpdateCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo")
  myAdapter.UpdateCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName")
  myAdapter.UpdateCommand.Parameters.Add("oldDeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original
  myAdapter.Update(myDataSet, "Departments")
  Dim myTable As DataTable
  Dim myRow As DataRow
  Dim myColumn As DataColumn
  ' Get all data from all tables within the dataset
  For Each myTable In myDataSet.Tables
    For Each myRow In myTable.Rows
      For Each myColumn In myTable.Columns
        Console.Write(myRow(myColumn) & Chr(9))
      Next myColumn
      Console.WriteLine()
    Next myRow
    Console.WriteLine()
  Next myTable
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members
DeleteCommand Property
InsertCommand Property
SelectCommand Property


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleDataAdapter Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataAdapter Class

For a list of all members of this type, see OracleDataAdapter members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | FillError | Returned when an error occurs during a fill operation. (Inherited from System.Data.Common.DataAdapter)
public Event | RowUpdated | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | RowUpdating | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.
Top

See Also

Reference

OracleDataAdapter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowUpdated Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : RowUpdated Event

Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.

Syntax

Visual Basic (Declaration)
Public Event RowUpdated As OracleRowUpdatedEventHandler
C#
public event OracleRowUpdatedEventHandler RowUpdated

Event Data

The event handler receives an argument of type OracleRowUpdatedEventArgs containing data related to this event. The following OracleRowUpdatedEventArgs properties provide information specific to this event.

Property | Description
Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
Errors (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command was executed.
RecordsAffected (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
RowCount (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows processed in a batch of updated records.
StatementType (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property.
TableMapping (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.Common.DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

Remarks

The event handler receives an argument of type OracleRowUpdatedEventArgs containing data related to this event. The following OracleRowUpdatedEventArgs properties provide information specific to this event.
Property | Description
OracleRowUpdatedEventArgs.Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) is called.
Errors (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets any errors generated by the .NET data provider when the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet) was executed.
RecordsAffected (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
StatementType (System.Data.Common.RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the UpdateStatus of the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet).
TableMapping (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

When using the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method, there are two events that occur per data row updated. The order of execution is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowUpdating Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataAdapter Class : RowUpdating Event

Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.

Syntax

Visual Basic (Declaration)
Public Event RowUpdating As OracleRowUpdatingEventHandler
C#
public event OracleRowUpdatingEventHandler RowUpdating

Event Data

The event handler receives an argument of type OracleRowUpdatingEventArgs containing data related to this event. The following OracleRowUpdatingEventArgs properties provide information specific to this event.

Property | Description
Command | Gets or sets the Devart.Data.Oracle.OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.
Errors (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command executes.
Row (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.DataRow that will be sent to the server as part of an insert, update, or delete operation.
StatementType (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets or sets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property.
TableMapping (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.Common.DataTableMapping to send through the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

Remarks

The event handler receives an argument of type OracleRowUpdatingEventArgs containing data related to this event. The following OracleRowUpdatingEventArgs properties provide information specific to this event.
Property | Description
OracleRowUpdatedEventArgs.Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) is called.
Errors (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets any errors generated by the .NET data provider when the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet) was executed.
Row (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.DataRow to sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
StatementType (System.Data.Common.RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the UpdateStatus of the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet).
TableMapping (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the DataTableMapping to sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

When using the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method, there are two events that occur per data row updated. The order of execution is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataAdapter Class
OracleDataAdapter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDatabase Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDatabase Class

This class represents an Oracle Database instance and allows you to start and stop it.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleDatabase

Syntax

Visual Basic (Declaration)
Public Class OracleDatabase
   Implements IDisposable
C#
public class OracleDatabase : IDisposable

Remarks

Note that if you connect to an Oracle 12c (or later) container (root) database - CDB, you can shutdown it with the OracleDatabase class, however after this OracleDatabase class cannot start it again. You need to have either physical or remote access to the server to start it, for example, by restarting the Oracle instance. So, it's not recommended to use the OracleDatabase class with a CDB

This class is not supported in the Devart.Data.Oracle.OracleConnection.Direct mode.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

This sample creates and opens an Devart.Data.Oracle.OracleConnection instance, and if the target Oracle Database exists but is stopped, the sample attempts to start it.
C#csharp Copy Code
private OracleConnection OpenConnection() {

        string connectionString = "Data Source=ora; User Id=sys; Password=manager; Connect Mode=sysdba;";

        try {
                OracleConnection connection = new OracleConnection(connectionString);
                connection.Open();
                return connection;
        }
        catch (OracleException ex) {
                if (ex.Code == 1034) { // ORA-01034: ORACLE not available
                        using (OracleDatabase database = new OracleDatabase(connectionString)) {
                                database.Startup();
                        }
                        OracleConnection connection = new OracleConnection(connectionString);
                        connection.Open();
                        return connection;
                }
                else
                        throw;
        }
}
C#Visual Basic Copy Code
Private Function OpenConnection() As OracleConnection

        Dim connectionString As String = "Data Source=ora; User Id=sys; Password=manager; Connect Mode=sysdba;"

        Try
                Dim connection As New OracleConnection(connectionString)
                connection.Open()
                Return connection
        Catch ex As OracleException
                If ex.Code = 1034 Then
                        ' ORA-01034: ORACLE not available
                        Using database As New OracleDatabase(connectionString)
                                database.Startup()
                        End Using
                        Dim connection As New OracleConnection(connectionString)
                        connection.Open()
                        Return connection
                Else
                        Throw
                End If
        End Try
End Function

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDatabase Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDatabase Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleDatabase Class

The following tables list the members exposed by OracleDatabase.

Public Constructors

 | Name | Description
public Constructor | OracleDatabase Constructor | Creates an instance of OracleDatabase using the supplied connection string.
Top

Public Properties

 | Name | Description
public Property | IsPluggableDatabase | Indicates whether the current Oracle Database instance is an Oracle pluggable database (PDB).
public Property | ServerVersion | Gets a string containing the version of the instance of Oracle Database, the OracleDatabase object is connected to.
public Property | ShortServerVersion | Gets the version of the instance of Oracle Database, the OracleDatabase object is connected to, as a System.Version object.
Top

Public Methods

 | Name | Description
public Method | Dispose | Releases all resources allocated by this object.
public Method | ExecuteNonQuery | Executes SQL statement against this Oracle Database instance.
public Method | Shutdown | Overloaded. Shuts down a database instance.
public Method | Startup | Overloaded. Starts a database instance. You need database administrator privileges to start a database instance.
Top

See Also

Reference

OracleDatabase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDatabase Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : OracleDatabase Constructor

connectionString
The connection string used for connecting to the Oracle Database instance.
Creates an instance of OracleDatabase using the supplied connection string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connectionString As String _
)
C#
public OracleDatabase(
   string connectionString
)

Parameters

connectionString
The connection string used for connecting to the Oracle Database instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDatabase Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDatabase Class

For a list of all members of this type, see OracleDatabase members.

Public Methods

 | Name | Description
public Method | Dispose | Releases all resources allocated by this object.
public Method | ExecuteNonQuery | Executes SQL statement against this Oracle Database instance.
public Method | Shutdown | Overloaded. Shuts down a database instance.
public Method | Startup | Overloaded. Starts a database instance. You need database administrator privileges to start a database instance.
Top

See Also

Reference

OracleDatabase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : Dispose() Method

Releases all resources allocated by this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNonQuery(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : ExecuteNonQuery(String) Method

sql
The SQL statement to execute.
Executes SQL statement against this Oracle Database instance.

Syntax

Visual Basic (Declaration)
Public Sub ExecuteNonQuery( _
   ByVal sql As String _
)
C#
public void ExecuteNonQuery(
   string sql
)

Parameters

sql
The SQL statement to execute.

Remarks

You can use ExecuteNonQuery(String) method to perform DDL statements, for example, ALTER DATABASE.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Shutdown Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : Shutdown Method

Shuts down a database instance.

Overload List

Overload | Description
Shutdown() | Shuts down a database instance.
Shutdown(OracleShutdownMode) | Shuts down a database instance using the specified mode.
Shutdown(OracleShutdownMode,Boolean) | Shuts down a database instance using the specified mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Shutdown() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Shutdown Method : Shutdown() Method

Shuts down a database instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Shutdown()
C#
public void Shutdown()

Remarks

This overload uses OracleShutdownMode.Default mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Shutdown(OracleShutdownMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Shutdown Method : Shutdown(OracleShutdownMode) Method

shutdownMode
One of the OracleShutdownMode values.
Shuts down a database instance using the specified mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Shutdown( _
   ByVal shutdownMode As OracleShutdownMode _
)
C#
public void Shutdown(
   OracleShutdownMode shutdownMode
)

Parameters

shutdownMode
One of the OracleShutdownMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Shutdown(OracleShutdownMode,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Shutdown Method : Shutdown(OracleShutdownMode,Boolean) Method

shutdownMode
One of the OracleShutdownMode values.
closeDismountAndFinalize
Specifies whether the database should be closed, dismounted, and finalized. Ignored if T:Devart.Data.Oracle.OracleShutdownModel.Final is used.
Shuts down a database instance using the specified mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Shutdown( _
   ByVal shutdownMode As OracleShutdownMode, _
   ByVal closeDismountAndFinalize As Boolean _
)
C#
public void Shutdown(
   OracleShutdownMode shutdownMode,
   bool closeDismountAndFinalize
)

Parameters

shutdownMode
One of the OracleShutdownMode values.
closeDismountAndFinalize
Specifies whether the database should be closed, dismounted, and finalized. Ignored if T:Devart.Data.Oracle.OracleShutdownModel.Final is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Startup Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : Startup Method

Starts a database instance. You need database administrator privileges to start a database instance.

Overload List

Overload | Description
Startup() | Starts a database instance using the server-side parameter file.
Startup(OracleStartupMode) | Starts a database instance using the server-side parameter file and the specified startup mode.
Startup(OracleStartupMode,OraclePdbOpenMode) | Starts a database instance using the server-side parameter file and the specified startup mode and the specified PDB opening mode. This method can be used only for Oracle 12c and higher.
Startup(OracleStartupMode,String,Boolean) | Starts a database instance using the client-side parameter file.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Startup() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Startup Method : Startup() Method

Starts a database instance using the server-side parameter file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Startup()
C#
public void Startup()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Startup(OracleStartupMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Startup Method : Startup(OracleStartupMode) Method

startupMode
One of the OracleStartupMode values.
Starts a database instance using the server-side parameter file and the specified startup mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Startup( _
   ByVal startupMode As OracleStartupMode _
)
C#
public void Startup(
   OracleStartupMode startupMode
)

Parameters

startupMode
One of the OracleStartupMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Startup(OracleStartupMode,OraclePdbOpenMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Startup Method : Startup(OracleStartupMode,OraclePdbOpenMode) Method

startupMode
One of the OracleStartupMode values.
pdbOpenMode
One of the OraclePdbOpenMode values.
Starts a database instance using the server-side parameter file and the specified startup mode and the specified PDB opening mode. This method can be used only for Oracle 12c and higher.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Startup( _
   ByVal startupMode As OracleStartupMode, _
   ByVal pdbOpenMode As OraclePdbOpenMode _
)
C#
public void Startup(
   OracleStartupMode startupMode,
   OraclePdbOpenMode pdbOpenMode
)

Parameters

startupMode
One of the OracleStartupMode values.
pdbOpenMode
One of the OraclePdbOpenMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Startup(OracleStartupMode,String,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class > Startup Method : Startup(OracleStartupMode,String,Boolean) Method

startupMode
One of the OracleStartupMode values.
pfile
The full name of the client-side parameter file.
mountAndOpen
Specifies whether the database should be mounted and opened. If this parameter is false, the database must be mounted and opened explicitly by the application.
Starts a database instance using the client-side parameter file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Startup( _
   ByVal startupMode As OracleStartupMode, _
   ByVal pfile As String, _
   ByVal mountAndOpen As Boolean _
)
C#
public void Startup(
   OracleStartupMode startupMode,
   string pfile,
   bool mountAndOpen
)

Parameters

startupMode
One of the OracleStartupMode values.
pfile
The full name of the client-side parameter file.
mountAndOpen
Specifies whether the database should be mounted and opened. If this parameter is false, the database must be mounted and opened explicitly by the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDatabase Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDatabase Class

For a list of all members of this type, see OracleDatabase members.

Public Properties

 | Name | Description
public Property | IsPluggableDatabase | Indicates whether the current Oracle Database instance is an Oracle pluggable database (PDB).
public Property | ServerVersion | Gets a string containing the version of the instance of Oracle Database, the OracleDatabase object is connected to.
public Property | ShortServerVersion | Gets the version of the instance of Oracle Database, the OracleDatabase object is connected to, as a System.Version object.
Top

See Also

Reference

OracleDatabase Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsPluggableDatabase Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : IsPluggableDatabase Property

Indicates whether the current Oracle Database instance is an Oracle pluggable database (PDB).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPluggableDatabase As Boolean
C#
public bool IsPluggableDatabase {get;}

Property Value

true if the current Oracle Database instance is an Oracle pluggable database (PDB); otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServerVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : ServerVersion Property

Gets a string containing the version of the instance of Oracle Database, the OracleDatabase object is connected to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerVersion As String
C#
public string ServerVersion {get;}

Property Value

The version of the instance of Oracle Database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ShortServerVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : ShortServerVersion Property

Gets the version of the instance of Oracle Database, the OracleDatabase object is connected to, as a System.Version object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShortServerVersion As Version
C#
public Version ShortServerVersion {get;}

Property Value

The System.Version object, representing the version of the instance of Oracle Database, the OracleDatabase object is connected to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataReader Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataReader Class

Reads a forward-only stream of rows from Oracle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbDataReader
Devart.Common.DbDataReaderBase
Devart.Data.Oracle.OracleDataReader

Syntax

Visual Basic (Declaration)
Public Class OracleDataReader
   Inherits Devart.Common.DbDataReaderBase
   Implements IEnumerable, IDataReader, IDataRecord, IDisposable
C#
public class OracleDataReader : Devart.Common.DbDataReaderBase, IEnumerable, IDataReader, IDataRecord, IDisposable

Remarks

To create a OracleDataReader, you must call the ExecuteReader method of the OracleCommand object, rather than directly using a constructor.

IsClosed and RecordsAffected are the only properties that you can call after the OracleDataReader is closed. In some cases, you must call Close before you can call RecordsAffected.

Example

The following example creates a Devart.Data.Oracle.OracleConnection, a OracleCommand, and a OracleDataReader. The example reads through the data, writing it out to the console. Finally, the example closes the OracleDataReader, then the Devart.Data.Oracle.OracleConnection.
C#csharp Copy Code
public void ReadMyData(string myConnString)  {
        OracleConnection myConnection = new OracleConnection(myConnString);
        OracleCommand myCommand = (OracleCommand)myConnection.CreateCommand();
        myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept";
        myConnection.Open();
        OracleDataReader myReader = myCommand.ExecuteReader();
        try {
                // Always call Read before accessing data.
                while (myReader.Read()) {
                Console.WriteLine(myReader.GetInt32(0).ToString() + " " +
                myReader.GetString(1) + " " + myReader.GetString(2));
        }
        }
        finally {
                // always call Close when done reading.
                myReader.Close();

                // Close the connection when done with it.
                myConnection.Close();
        }
}
C#Visual Basic Copy Code
Public Sub ReadMyData(ByVal myConnString As String)
        Dim myConnection As New OracleConnection(myConnString)
        Dim myCommand As OracleCommand = myConnection.CreateCommand()
                myCommand.CommandText = "SELECT DeptNo, DName, Loc FROM Test.Dept"
        myConnection.Open()
        Dim myReader As OracleDataReader = myCommand.ExecuteReader()
        Try
                ' Always call Read before accessing data.
                While myReader.Read()
                        Console.WriteLine(String.Concat(myReader.GetInt32(0).ToString(), " ", _
                        myReader.GetString(1), " ", myReader.GetString(2)))
                End While
        Finally
                ' always call Close when done reading.
                myReader.Close()

                        ' Close the connection when done with it.
                        myConnection.Close()
        End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDataReader Members
Devart.Data.Oracle Namespace
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDataReader Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleDataReader Class

The following tables list the members exposed by OracleDataReader.

Public Properties

 | Name | Description
public Property | Depth | Overridden. Gets a value indicating the depth of nesting for the current row.
public Property | EndOfData | Overridden. Indicates whether the OracleDataReader has been read completely.
public Property | FieldCount | Overridden. Gets the number of columns in the current row.
public Property | HasRows | Overridden. Gets a value indicating whether the OracleDataReader contains one or more rows.
public Property | IsClosed | Gets a value indicating whether the System.Data.Common.DbDataReader is closed. (Inherited from System.Data.Common.DbDataReader)
public Property | Item | Overloaded. Gets the value of the specified column as an instance of System.Object. (Inherited from System.Data.Common.DbDataReader)
public Property | RecordsAffected | Overridden. Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
public Property | VisibleFieldCount | Gets the number of fields in the System.Data.Common.DbDataReader that are not hidden. (Inherited from System.Data.Common.DbDataReader)
Top

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes the OracleDataReader object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | Overloaded. Overridden. Gets the value of the specified column as a Boolean.
public Method | GetByte | Overloaded. Overridden. Gets the value of the specified column as a byte.
public Method | GetBytes | Overloaded. Overridden. Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetChar | Overloaded. Overridden. Gets the value of the specified column as a single character.
public Method | GetChars | Overloaded. Overridden. Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetDataTypeName | Overloaded. Overridden. Gets the name of the source data type.
public Method | GetDateTime | Overloaded. Overridden. Gets the value of the specified column as a System.DateTime object.
public Method | GetDateTimeOffset | Overloaded. Overridden. Gets the value of the specified column as an DateTimeOffset object.
public Method | GetDecimal | Overloaded. Overridden. Gets the value of the specified column as a System.Decimal object.
public Method | GetDouble | Overloaded. Overridden. Gets the value of the specified column as a double-precision floating point number.
public Method | GetEnumerator | Returns an System.Collections.IEnumerator that can be used to iterate through the rows in the data reader. (Inherited from System.Data.Common.DbDataReader)
public Method | GetFieldType | Overloaded. Overridden. Gets the System.Type that is the data type of the object.
public Method | GetFloat | Overloaded. Overridden. Gets the value of the specified column as a single-precision floating point number.
public Method | GetGuid | Overloaded. Overridden. Gets the value of the specified column as a globally-unique identifier (GUID).
public Method | GetInt16 | Overloaded. Overridden. Gets the value of the specified column as a 16-bit signed integer.
public Method | GetInt32 | Overloaded. Overridden. Gets the value of the specified column as a 32-bit signed integer.
public Method | GetInt64 | Overloaded. Overridden. Gets the value of the specified column as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | Overridden. Gets the name of the specified column.
public Method | GetNativeOracleArray | Overloaded. Gets the value of the specified column as an NativeOracleArray object.
public Method | GetNativeOracleObject | Overloaded. Gets the value of the specified column as an NativeOracleObject object.
public Method | GetNativeOracleTable | Overloaded. Gets the value of the specified column as an NativeOracleTable object.
public Method | GetObjectType | Overloaded. Gets the value of the specified column as an OracleType object.
public Method | GetOracleAnyData | Overloaded. Gets the value of the specified column as an OracleAnyData object.
public Method | GetOracleArray | Overloaded. Gets the value of the specified column as an OracleArray object.
public Method | GetOracleBFile | Overloaded. Gets the value of the specified column as an OracleBFile object.
public Method | GetOracleBinary | Overloaded. Gets the value of the specified column as an OracleBinary object.
public Method | GetOracleCursor | Overloaded. Gets the value of the specified column as an OracleCursor object.
public Method | GetOracleDate | Overloaded. Gets the value of the specified column as an OracleDate object.
public Method | GetOracleDateTime | Gets the value of the specified column as an OracleDateTime object.
public Method | GetOracleIntervalDS | Overloaded. Gets the value of the specified column as an OracleIntervalDS object.
public Method | GetOracleIntervalYM | Overloaded. Gets the value of the specified column as an OracleIntervalYM object.
public Method | GetOracleLob | Overloaded. Gets the value of the specified column as a OracleLob object.
public Method | GetOracleMonthSpan | Gets the value of the specified column as an OracleMonthSpan object.
public Method | GetOracleNumber | Overloaded. Gets the value of the specified column as an OracleNumber object.
public Method | GetOracleObject | Overloaded. Gets the value of the specified column as an OracleObject object.
public Method | GetOracleRef | Overloaded. Gets the value of the specified column as an OracleRef object.
public Method | GetOracleString | Overloaded. Gets the value of the specified column as an OracleString object.
public Method | GetOracleTable | Overloaded. Gets the value of the specified column as an OracleTable object.
public Method | GetOracleTimeSpan | Gets the value of the specified column as an OracleTimeSpan object.
public Method | GetOracleTimeStamp | Overloaded. Gets the value of the specified column as an OracleTimeStamp object.
public Method | GetOracleValue | Overloaded. Gets the value of the column at the specified ordinal in its Oracle format wrapped by dotConnect for Oracle.
public Method | GetOracleValues | Overloaded. Gets all the column values as the dotConnect for Oracle wrapped types.
public Method | GetOracleXml | Overloaded. Gets the value of the specified column as an OracleXml object.
public Method | GetOrdinal | Gets the column ordinal given the name of the column. (Inherited from System.Data.Common.DbDataReader)
public Method | GetProviderSpecificFieldType | Overloaded. Overridden. Gets the System.Type that is the provider-specific data type of the object.
public Method | GetProviderSpecificValue | Overloaded. Overridden. Gets the value of the specified column. If possible, a provider-specific type is used.
public Method | GetProviderSpecificValues | Overloaded. Overridden. Gets all column values in the collection for the current row. If possible, a provider-specific type is used.
public Method | GetSchemaTable | Returns a System.Data.DataTable that describes the column metadata of the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DbDataReader)
public Method | GetString | Overloaded. Overridden. Gets the value of the specified column as a string.
public Method | GetTimeSpan | Overloaded. Gets the value of the specified column as a System.TimeSpan.
public Method | GetValue | Overloaded. Overridden. Gets the value of the specified column in its native format.
public Method | GetValues | Overloaded. Overridden. Gets all column values for the current row.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | Overloaded. Overridden. Gets a value indicating whether the column contains non-existent or missing values.
public Method | NextResult | Overridden. Advances the data reader to the next result, when reading the results of multiple REF CURSORs in PL/SQL statement.
public Method | Read | Overridden. Advances the OracleDataReader to the next record.
Top

See Also

Reference

OracleDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDataReader Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataReader Class

For a list of all members of this type, see OracleDataReader members.

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes the OracleDataReader object.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetBoolean | Overloaded. Overridden. Gets the value of the specified column as a Boolean.
public Method | GetByte | Overloaded. Overridden. Gets the value of the specified column as a byte.
public Method | GetBytes | Overloaded. Overridden. Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetChar | Overloaded. Overridden. Gets the value of the specified column as a single character.
public Method | GetChars | Overloaded. Overridden. Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
public Method | GetDataTypeName | Overloaded. Overridden. Gets the name of the source data type.
public Method | GetDateTime | Overloaded. Overridden. Gets the value of the specified column as a System.DateTime object.
public Method | GetDateTimeOffset | Overloaded. Overridden. Gets the value of the specified column as an DateTimeOffset object.
public Method | GetDecimal | Overloaded. Overridden. Gets the value of the specified column as a System.Decimal object.
public Method | GetDouble | Overloaded. Overridden. Gets the value of the specified column as a double-precision floating point number.
public Method | GetEnumerator | Returns an System.Collections.IEnumerator that can be used to iterate through the rows in the data reader. (Inherited from System.Data.Common.DbDataReader)
public Method | GetFieldType | Overloaded. Overridden. Gets the System.Type that is the data type of the object.
public Method | GetFloat | Overloaded. Overridden. Gets the value of the specified column as a single-precision floating point number.
public Method | GetGuid | Overloaded. Overridden. Gets the value of the specified column as a globally-unique identifier (GUID).
public Method | GetInt16 | Overloaded. Overridden. Gets the value of the specified column as a 16-bit signed integer.
public Method | GetInt32 | Overloaded. Overridden. Gets the value of the specified column as a 32-bit signed integer.
public Method | GetInt64 | Overloaded. Overridden. Gets the value of the specified column as a 64-bit signed integer.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetName | Overridden. Gets the name of the specified column.
public Method | GetNativeOracleArray | Overloaded. Gets the value of the specified column as an NativeOracleArray object.
public Method | GetNativeOracleObject | Overloaded. Gets the value of the specified column as an NativeOracleObject object.
public Method | GetNativeOracleTable | Overloaded. Gets the value of the specified column as an NativeOracleTable object.
public Method | GetObjectType | Overloaded. Gets the value of the specified column as an OracleType object.
public Method | GetOracleAnyData | Overloaded. Gets the value of the specified column as an OracleAnyData object.
public Method | GetOracleArray | Overloaded. Gets the value of the specified column as an OracleArray object.
public Method | GetOracleBFile | Overloaded. Gets the value of the specified column as an OracleBFile object.
public Method | GetOracleBinary | Overloaded. Gets the value of the specified column as an OracleBinary object.
public Method | GetOracleCursor | Overloaded. Gets the value of the specified column as an OracleCursor object.
public Method | GetOracleDate | Overloaded. Gets the value of the specified column as an OracleDate object.
public Method | GetOracleDateTime | Gets the value of the specified column as an OracleDateTime object.
public Method | GetOracleIntervalDS | Overloaded. Gets the value of the specified column as an OracleIntervalDS object.
public Method | GetOracleIntervalYM | Overloaded. Gets the value of the specified column as an OracleIntervalYM object.
public Method | GetOracleLob | Overloaded. Gets the value of the specified column as a OracleLob object.
public Method | GetOracleMonthSpan | Gets the value of the specified column as an OracleMonthSpan object.
public Method | GetOracleNumber | Overloaded. Gets the value of the specified column as an OracleNumber object.
public Method | GetOracleObject | Overloaded. Gets the value of the specified column as an OracleObject object.
public Method | GetOracleRef | Overloaded. Gets the value of the specified column as an OracleRef object.
public Method | GetOracleString | Overloaded. Gets the value of the specified column as an OracleString object.
public Method | GetOracleTable | Overloaded. Gets the value of the specified column as an OracleTable object.
public Method | GetOracleTimeSpan | Gets the value of the specified column as an OracleTimeSpan object.
public Method | GetOracleTimeStamp | Overloaded. Gets the value of the specified column as an OracleTimeStamp object.
public Method | GetOracleValue | Overloaded. Gets the value of the column at the specified ordinal in its Oracle format wrapped by dotConnect for Oracle.
public Method | GetOracleValues | Overloaded. Gets all the column values as the dotConnect for Oracle wrapped types.
public Method | GetOracleXml | Overloaded. Gets the value of the specified column as an OracleXml object.
public Method | GetOrdinal | Gets the column ordinal given the name of the column. (Inherited from System.Data.Common.DbDataReader)
public Method | GetProviderSpecificFieldType | Overloaded. Overridden. Gets the System.Type that is the provider-specific data type of the object.
public Method | GetProviderSpecificValue | Overloaded. Overridden. Gets the value of the specified column. If possible, a provider-specific type is used.
public Method | GetProviderSpecificValues | Overloaded. Overridden. Gets all column values in the collection for the current row. If possible, a provider-specific type is used.
public Method | GetSchemaTable | Returns a System.Data.DataTable that describes the column metadata of the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DbDataReader)
public Method | GetString | Overloaded. Overridden. Gets the value of the specified column as a string.
public Method | GetTimeSpan | Overloaded. Gets the value of the specified column as a System.TimeSpan.
public Method | GetValue | Overloaded. Overridden. Gets the value of the specified column in its native format.
public Method | GetValues | Overloaded. Overridden. Gets all column values for the current row.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsDBNull | Overloaded. Overridden. Gets a value indicating whether the column contains non-existent or missing values.
public Method | NextResult | Overridden. Advances the data reader to the next result, when reading the results of multiple REF CURSORs in PL/SQL statement.
public Method | Read | Overridden. Advances the OracleDataReader to the next record.
Top

See Also

Reference

OracleDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : Close Method

Closes the OracleDataReader object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

You must explicitly call the Close method after you have finished working with the OracleDataReader in order to use the associated OracleConnection for any other purpose.

Example

The following example creates a OracleConnection, a Devart.Data.Oracle.OracleCommand, and a OracleDataReader. The example reads through the data, writing it out to the console. Finally, the example closes the OracleDataReader, then the OracleConnection.
C#csharp Copy Code
public void ReadMyData(string myConnString)
{
  string mySelectQuery = "SELECT DeptNo, DName FROM Test.Dept";
  OracleConnection myConnection = new OracleConnection(myConnString);
  OracleCommand myCommand = new OracleCommand(mySelectQuery,myConnection);
  myConnection.Open();
  OracleDataReader myReader;
  myReader = myCommand.ExecuteReader();
  // Always call Read before accessing data.
  while (myReader.Read()) {
    Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(1));
  }
  // always call Close when done reading.
  myReader.Close();
  // Close the connection when done with it.
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub ReadMyData(myConnString As String)
  Dim mySelectQuery As String = "SELECT DeptNo, DName FROM Test.Dept"
  Dim myConnection As New OracleConnection(myConnString)
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader
  myReader = myCommand.ExecuteReader()
  ' Always call Read before accessing data.
  While myReader.Read()
    Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
      + myReader.GetString(1))
  End While
  ' always call Close when done reading.
  myReader.Close()
  ' Close the connection when done with it.
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
OracleConnection Class
OracleCommand Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBoolean Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetBoolean Method

Gets the value of the specified column as a Boolean.

Overload List

Overload | Description
GetBoolean(Int32) | Gets the value of the specified column as a Boolean.
GetBoolean(String) | Gets the value of the specified column as a Boolean. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBoolean(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetBoolean Method : GetBoolean(Int32) Method

i
Gets the value of the specified column as a Boolean.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetBoolean( _
   ByVal i As Integer _
) As Boolean
C#
public override bool GetBoolean(
   int i
)

Parameters

i

Return Value

The value of the column.

Example

C#csharp Copy Code
static void GetMyBoolean(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    bool recievedBool = reader.GetBoolean(reader.GetOrdinal("BoolCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyBoolean(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedBool As Boolean = reader.GetBoolean(reader.GetOrdinal("BoolCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetByte Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetByte Method

Gets the value of the specified column as a byte.

Overload List

Overload | Description
GetByte(Int32) | Gets the value of the specified column as a byte.
GetByte(String) | Gets the value of the specified column as a byte. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetByte(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetByte Method : GetByte(Int32) Method

i
Gets the value of the specified column as a byte.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetByte( _
   ByVal i As Integer _
) As Byte
C#
public override byte GetByte(
   int i
)

Parameters

i

Return Value

The value of the specified column as a byte.

Example

C#csharp Copy Code
static void GetMyByte(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    byte recievedByte = reader.GetByte(reader.GetOrdinal("ByteCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyByte(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedByte As Byte = reader.GetByte(reader.GetOrdinal("ByteCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetBytes Method

Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Overload List

Overload | Description
GetBytes(Int32,Int64,Byte[],Int32,Int32) | Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.
GetBytes(String,Int64,Byte[],Int32,Int32) | Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetBytes(Int32,Int64,Byte[],Int32,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetBytes Method : GetBytes(Int32,Int64,Byte[],Int32,Int32) Method

i
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.
Reads a stream of bytes from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetBytes( _
   ByVal i As Integer, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Byte, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public override long GetBytes(
   int i,
   long fieldOffset,
   byte[] buffer,
   int bufferOffset,
   int length
)

Parameters

i
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to read the stream of bytes.
bufferOffset
The index within the buffer where the write operation is to begin.
length
The maximum length to copy into the buffer.

Return Value

The actual number of bytes read.

Remarks

GetBytes returns the number of available bytes in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetBytes has already been used to obtain bytes from the field. This may be the case, for example, if the OracleDataReader is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value, GetBytes returns the length of the field in bytes.

Example

This sample shows how to obtain array of bytes from a table and save it to a file.
C#csharp Copy Code
static void GetThatBytes(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    byte[] myBytes = new byte[50];
    long bytesRead = reader.GetBytes(reader.GetOrdinal("DName"),0,myBytes,0,50);
    FileStream fs = new FileStream("D:\\Tmp\\1.txt", FileMode.Create);
    fs.Write(myBytes,0,(int)bytesRead);
    fs.Close();
    Console.WriteLine(bytesRead+ " bytes downloaded from table to file.");
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetThatBytes(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim myBytes(50) As Byte
    Dim bytesRead As Long = reader.GetBytes(reader.GetOrdinal("DName"), 0, myBytes, 0, 50)
    Dim fs As FileStream = New FileStream("D:\Tmp\1.txt", FileMode.Create)
    fs.Write(myBytes, 0, Convert.ToInt32(bytesRead))
    fs.Close()
    Console.WriteLine(bytesRead & " bytes downloaded from table to file.")
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChar Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetChar Method

Gets the value of the specified column as a single character.

Overload List

Overload | Description
GetChar(Int32) | Gets the value of the specified column as a single character.
GetChar(String) | Gets the value of the specified column as a single character. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChar(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetChar Method : GetChar(Int32) Method

i
Gets the value of the specified column as a single character.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetChar( _
   ByVal i As Integer _
) As Char
C#
public override char GetChar(
   int i
)

Parameters

i

Return Value

The value of the specified column as a character.

Example

C#csharp Copy Code
static void GetMyChar(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    char recievedChar = reader.GetChar(reader.GetOrdinal("CharCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyChar(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedChar As Char = reader.GetChar(reader.GetOrdinal("CharCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetChars Method

Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Overload List

Overload | Description
GetChars(Int32,Int64,Char[],Int32,Int32) | Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.
GetChars(String,Int64,Char[],Int32,Int32) | Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetChars(Int32,Int64,Char[],Int32,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetChars Method : GetChars(Int32,Int64,Char[],Int32,Int32) Method

i
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index within the buffer where the write operation is to begin.
length
The maximum number of characters to read.
Reads a stream of characters from the specified column offset into the buffer as an array starting at the given buffer offset.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetChars( _
   ByVal i As Integer, _
   ByVal fieldOffset As Long, _
   ByVal buffer() As Char, _
   ByVal bufferOffset As Integer, _
   ByVal length As Integer _
) As Long
C#
public override long GetChars(
   int i,
   long fieldOffset,
   char[] buffer,
   int bufferOffset,
   int length
)

Parameters

i
The zero-based column ordinal.
fieldOffset
The index within the field where the read operation is to begin.
buffer
The buffer into which to copy data.
bufferOffset
The index within the buffer where the write operation is to begin.
length
The maximum number of characters to read.

Return Value

The actual number of characters read.

Remarks

GetChars returns the number of available characters in the field. In most cases this is the exact length of the field. However, the number returned may be less than the true length of the field if GetChars has already been used to obtain characters from the field. This may be the case, for example, if the OracleDataReader is reading a large data structure into a buffer. For more information, see the SequentialAccess setting of System.Data.CommandBehavior in the Microsoft .NET Framework SDK documentation.

If you pass a buffer that is a null value. GetChars returns the length of the field in characters.

Example

This sample shows how to read data from a field into array of chars.
C#csharp Copy Code
static void GetThatChars(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    char[] myChars = new char[50];
    long bytesRead = reader.GetChars(reader.GetOrdinal("DName"),0,myChars,0,50);
    Console.WriteLine(bytesRead+ " bytes read from the table.");
    Console.WriteLine(myChars);
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetThatChars(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim myChars(50) As Char
    Dim bytesRead As Long = reader.GetChars(reader.GetOrdinal("DName"), 0, myChars, 0, 50)
    Console.WriteLine(bytesRead & " bytes read from the table.")
    Console.WriteLine(myChars)
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetDataTypeName Method

Gets the name of the source data type.

Overload List

Overload | Description
GetDataTypeName(Int32) | Gets the name of the source data type.
GetDataTypeName(String) | Gets the name of the source data type. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataTypeName(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetDataTypeName Method : GetDataTypeName(Int32) Method

i
Gets the name of the source data type.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDataTypeName( _
   ByVal i As Integer _
) As String
C#
public override string GetDataTypeName(
   int i
)

Parameters

i

Return Value

The name of the back-end data type.

Example

This sample shows how to retrieve names and types of all columns in a table.
C#csharp Copy Code
public void GetFields(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    for (int i=0;i < reader.FieldCount;i++)
    {
      string fieldType = reader.GetDataTypeName(i);
      string fieldName = reader.GetName(i);
      string fieldType2 = reader.GetFieldType(i).FullName;
      Console.WriteLine(fieldName+"\t"+ fieldType+"\t"+ fieldType2);
    }
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetFields(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim i As Integer
    For i = 0 To reader.FieldCount - 1
      Dim fieldType As String = reader.GetDataTypeName(i)
      Dim fieldName As String = reader.GetName(i)
      Dim fieldType2 As String = reader.GetFieldType(i).FullName
      Console.WriteLine(fieldName & Chr(9) & fieldType & Chr(9) & fieldType2)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
GetFieldType Method
GetName Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTime Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetDateTime Method

Gets the value of the specified column as a System.DateTime object.

Overload List

Overload | Description
GetDateTime(Int32) | Gets the value of the specified column as a System.DateTime object.
GetDateTime(String) | Gets the value of the specified column as a DateTime object. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTime(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetDateTime Method : GetDateTime(Int32) Method

i
Gets the value of the specified column as a System.DateTime object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDateTime( _
   ByVal i As Integer _
) As Date
C#
public override DateTime GetDateTime(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call Devart.Common.DbDataReaderBase.IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyDateTime(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    DateTime recievedDate = reader.GetDateTime(reader.GetOrdinal("DateCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyDateTime(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedDate As DateTime = reader.GetDateTime(reader.GetOrdinal("DateCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTimeOffset Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetDateTimeOffset Method

Gets the value of the specified column as an DateTimeOffset object.

Overload List

Overload | Description
GetDateTimeOffset(Int32) | Gets the value of the specified column as an DateTimeOffset object.
GetDateTimeOffset(String) | Gets the value of the specified column as a DateTimeOffset object. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDateTimeOffset(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetDateTimeOffset Method : GetDateTimeOffset(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an DateTimeOffset object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDateTimeOffset( _
   ByVal i As Integer _
) As DateTimeOffset
C#
public override DateTimeOffset GetDateTimeOffset(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an DateTimeOffset object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDecimal Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetDecimal Method

Gets the value of the specified column as a System.Decimal object.

Overload List

Overload | Description
GetDecimal(Int32) | Gets the value of the specified column as a System.Decimal object.
GetDecimal(String) | Gets the value of the specified column as a DateTime object. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDecimal(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetDecimal Method : GetDecimal(Int32) Method

i
Gets the value of the specified column as a System.Decimal object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDecimal( _
   ByVal i As Integer _
) As Decimal
C#
public override decimal GetDecimal(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Example

C#csharp Copy Code
static void GetMyDecimal(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    decimal recievedDecimal = reader.GetDecimal(reader.GetOrdinal("DecimalCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyDecimal(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedDecimal As Decimal = reader.GetDecimal(reader.GetOrdinal("DecimalCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDouble Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetDouble Method

Gets the value of the specified column as a double-precision floating point number.

Overload List

Overload | Description
GetDouble(Int32) | Gets the value of the specified column as a double-precision floating point number.
GetDouble(String) | Gets the value of the specified column as a double-precision floating point number. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDouble(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetDouble Method : GetDouble(Int32) Method

i
Gets the value of the specified column as a double-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetDouble( _
   ByVal i As Integer _
) As Double
C#
public override double GetDouble(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyDouble(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    double recievedDouble = reader.GetDouble(reader.GetOrdinal("DoubleCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyDouble(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedDouble As Double = reader.GetDouble(reader.GetOrdinal("DoubleCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetFieldType Method

Gets the System.Type that is the data type of the object.

Overload List

Overload | Description
GetFieldType(Int32) | Gets the System.Type that is the data type of the object.
GetFieldType(String) | Gets the System.Type that is the data type of the object. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFieldType(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetFieldType Method : GetFieldType(Int32) Method

i
Gets the System.Type that is the data type of the object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetFieldType( _
   ByVal i As Integer _
) As Type
C#
public override Type GetFieldType(
   int i
)

Parameters

i

Return Value

The System.Type that is the data type of the object.

Example

This sample shows how to retrieve names and types of all columns in a table.
C#csharp Copy Code
public void GetFields(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    for (int i=0;i < reader.FieldCount;i++)
    {
      string fieldType = reader.GetDataTypeName(i);
      string fieldName = reader.GetName(i);
      string fieldType2 = reader.GetFieldType(i).FullName;
      Console.WriteLine(fieldName+"\t"+ fieldType+"\t"+ fieldType2);
    }
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetFields(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim i As Integer
    For i = 0 To reader.FieldCount - 1
      Dim fieldType As String = reader.GetDataTypeName(i)
      Dim fieldName As String = reader.GetName(i)
      Dim fieldType2 As String = reader.GetFieldType(i).FullName
      Console.WriteLine(fieldName & Chr(9) & fieldType & Chr(9) & fieldType2)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
GetName Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFloat Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetFloat Method

Gets the value of the specified column as a single-precision floating point number.

Overload List

Overload | Description
GetFloat(Int32) | Gets the value of the specified column as a single-precision floating point number.
GetFloat(String) | Gets the value of the specified column as a single-precision floating point number. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetFloat(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetFloat Method : GetFloat(Int32) Method

i
Gets the value of the specified column as a single-precision floating point number.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetFloat( _
   ByVal i As Integer _
) As Single
C#
public override float GetFloat(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyFloat(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    float recievedFloat = reader.GetFloat(reader.GetOrdinal("FloatCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyFloat(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedFloat As Single = reader.GetFloat(reader.GetOrdinal("FloatCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetGuid Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetGuid Method

Gets the value of the specified column as a globally-unique identifier (GUID).

Overload List

Overload | Description
GetGuid(Int32) | Gets the value of the specified column as a globally-unique identifier (GUID).
GetGuid(String) | Gets the value of the specified column as a globally-unique identifier (GUID). (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetGuid(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetGuid Method : GetGuid(Int32) Method

i
Gets the value of the specified column as a globally-unique identifier (GUID).

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetGuid( _
   ByVal i As Integer _
) As Guid
C#
public override Guid GetGuid(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Example

C#csharp Copy Code
static void GetMyGuid(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    Guid recievedGuid = reader.GetGuid(reader.GetOrdinal("GuidCol"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyGuid(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedGuid As Guid = reader.GetGuid(reader.GetOrdinal("GuidCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt16 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetInt16 Method

Gets the value of the specified column as a 16-bit signed integer.

Overload List

Overload | Description
GetInt16(Int32) | Gets the value of the specified column as a 16-bit signed integer.
GetInt16(String) | Gets the value of the specified column as a 16-bit signed integer. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt16(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetInt16 Method : GetInt16(Int32) Method

i
Gets the value of the specified column as a 16-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetInt16( _
   ByVal i As Integer _
) As Short
C#
public override short GetInt16(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyInt16(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    short recievedShort = reader.GetInt16(reader.GetOrdinal("Int16Col"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyInt16(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedShort As Short = reader.GetInt16(reader.GetOrdinal("Int16Col"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt32 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetInt32 Method

Gets the value of the specified column as a 32-bit signed integer.

Overload List

Overload | Description
GetInt32(Int32) | Gets the value of the specified column as a 32-bit signed integer.
GetInt32(String) | Gets the value of the specified column as a 32-bit signed integer. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt32(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetInt32 Method : GetInt32(Int32) Method

i
Gets the value of the specified column as a 32-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetInt32( _
   ByVal i As Integer _
) As Integer
C#
public override int GetInt32(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyInt32(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    int recievedInt = reader.GetInt32(reader.GetOrdinal("Int32Col"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt64 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetInt64 Method

Gets the value of the specified column as a 64-bit signed integer.

Overload List

Overload | Description
GetInt64(Int32) | Gets the value of the specified column as a 64-bit signed integer.
GetInt64(String) | Gets the value of the specified column as a 64-bit signed integer. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetInt64(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetInt64 Method : GetInt64(Int32) Method

i
Gets the value of the specified column as a 64-bit signed integer.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetInt64( _
   ByVal i As Integer _
) As Long
C#
public override long GetInt64(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyInt64(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    long recievedLong = reader.GetInt64(reader.GetOrdinal("Int64Col"));
    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetName Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetName Method

i

Gets the name of the specified column.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetName( _
   ByVal i As Integer _
) As String
C#
public override string GetName(
   int i
)

Parameters

i

Return Value

A string that is the name of the specified column.

Example

This sample shows how to retrieve names and types of all columns in a table.
C#csharp Copy Code
public void GetFields(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    for (int i=0;i < reader.FieldCount;i++)
    {
      string fieldType = reader.GetDataTypeName(i);
      string fieldName = reader.GetName(i);
      string fieldType2 = reader.GetFieldType(i).FullName;
      Console.WriteLine(fieldName+"\t"+ fieldType+"\t"+ fieldType2);
    }
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetFields(ByVal myConnection As OracleConnection
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim i As Integer
    For i = 0 To reader.FieldCount - 1
      Dim fieldType As String = reader.GetDataTypeName(i)
      Dim fieldName As String = reader.GetName(i)
      Console.WriteLine(fieldName & " " & fieldType)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
GetFieldType Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetNativeOracleArray Method

Gets the value of the specified column as an NativeOracleArray object.

Overload List

Overload | Description
GetNativeOracleArray(Int32) | Gets the value of the specified column as an NativeOracleArray object.
GetNativeOracleArray(String) | Gets the value of the specified column as an NativeOracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleArray(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleArray Method : GetNativeOracleArray(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an NativeOracleArray object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleArray( _
   ByVal i As Integer _
) As NativeOracleArray
C#
public NativeOracleArray GetNativeOracleArray(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an NativeOracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleArray(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleArray Method : GetNativeOracleArray(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an NativeOracleArray object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleArray( _
   ByVal name As String _
) As NativeOracleArray
C#
public NativeOracleArray GetNativeOracleArray(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an NativeOracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetNativeOracleObject Method

Gets the value of the specified column as an NativeOracleObject object.

Overload List

Overload | Description
GetNativeOracleObject(Int32) | Gets the value of the specified column as an NativeOracleObject object.
GetNativeOracleObject(String) | Gets the value of the specified column as an NativeOracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleObject(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleObject Method : GetNativeOracleObject(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an NativeOracleObject object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleObject( _
   ByVal i As Integer _
) As NativeOracleObject
C#
public NativeOracleObject GetNativeOracleObject(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an NativeOracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleObject(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleObject Method : GetNativeOracleObject(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an NativeOracleObject object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleObject( _
   ByVal name As String _
) As NativeOracleObject
C#
public NativeOracleObject GetNativeOracleObject(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an NativeOracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetNativeOracleTable Method

Gets the value of the specified column as an NativeOracleTable object.

Overload List

Overload | Description
GetNativeOracleTable(Int32) | Gets the value of the specified column as an NativeOracleTable object.
GetNativeOracleTable(String) | Gets the value of the specified column as an NativeOracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleTable(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleTable Method : GetNativeOracleTable(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an NativeOracleTable object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleTable( _
   ByVal i As Integer _
) As NativeOracleTable
C#
public NativeOracleTable GetNativeOracleTable(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an NativeOracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeOracleTable(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetNativeOracleTable Method : GetNativeOracleTable(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an NativeOracleTable object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNativeOracleTable( _
   ByVal name As String _
) As NativeOracleTable
C#
public NativeOracleTable GetNativeOracleTable(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an NativeOracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetObjectType Method

Gets the value of the specified column as an OracleType object.

Overload List

Overload | Description
GetObjectType(Int32) | Gets the value of the specified column as an OracleType object.
GetObjectType(String) | Gets the value of the specified column as an OracleType object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetObjectType Method : GetObjectType(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleType object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObjectType( _
   ByVal i As Integer _
) As OracleType
C#
public OracleType GetObjectType(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleType object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetObjectType Method : GetObjectType(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleType object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObjectType( _
   ByVal name As String _
) As OracleType
C#
public OracleType GetObjectType(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleType object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleAnyData Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleAnyData Method

Gets the value of the specified column as an OracleAnyData object.

Overload List

Overload | Description
GetOracleAnyData(Int32) | Gets the value of the specified column as an OracleAnyData object.
GetOracleAnyData(String) | Gets the value of the specified column as an OracleAnyData object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleAnyData(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleAnyData Method : GetOracleAnyData(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleAnyData object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleAnyData( _
   ByVal i As Integer _
) As OracleAnyData
C#
public OracleAnyData GetOracleAnyData(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleAnyData object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
OracleAnyData Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleAnyData(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleAnyData Method : GetOracleAnyData(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleAnyData object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleAnyData( _
   ByVal name As String _
) As OracleAnyData
C#
public OracleAnyData GetOracleAnyData(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleAnyData object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
OracleAnyData Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleArray Method

Gets the value of the specified column as an OracleArray object.

Overload List

Overload | Description
GetOracleArray(Int32) | Gets the value of the specified column as an OracleArray object.
GetOracleArray(String) | Gets the value of the specified column as an OracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleArray(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleArray Method : GetOracleArray(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleArray object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleArray( _
   ByVal i As Integer _
) As OracleArray
C#
public OracleArray GetOracleArray(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleArray(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleArray Method : GetOracleArray(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleArray object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleArray( _
   ByVal name As String _
) As OracleArray
C#
public OracleArray GetOracleArray(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleArray object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBFile Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleBFile Method

Gets the value of the specified column as an OracleBFile object.

Overload List

Overload | Description
GetOracleBFile(Int32) | Gets the value of the specified column as an OracleBFile object.
GetOracleBFile(String) | Gets the value of the specified column as an OracleBFile object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBFile(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleBFile Method : GetOracleBFile(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleBFile object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleBFile( _
   ByVal i As Integer _
) As OracleBFile
C#
public OracleBFile GetOracleBFile(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleBFile object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBFile(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleBFile Method : GetOracleBFile(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleBFile object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleBFile( _
   ByVal name As String _
) As OracleBFile
C#
public OracleBFile GetOracleBFile(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleBFile object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBinary Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleBinary Method

Gets the value of the specified column as an OracleBinary object.

Overload List

Overload | Description
GetOracleBinary(Int32) | Gets the value of the specified column as an OracleBinary object.
GetOracleBinary(String) | Gets the value of the specified column as an OracleBinary object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBinary(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleBinary Method : GetOracleBinary(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleBinary object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleBinary( _
   ByVal i As Integer _
) As OracleBinary
C#
public OracleBinary GetOracleBinary(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleBinary object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleBinary(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleBinary Method : GetOracleBinary(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleBinary object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleBinary( _
   ByVal name As String _
) As OracleBinary
C#
public OracleBinary GetOracleBinary(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleBinary object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleCursor Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleCursor Method

Gets the value of the specified column as an OracleCursor object.

Overload List

Overload | Description
GetOracleCursor(Int32) | Gets the value of the specified column as an OracleCursor object.
GetOracleCursor(String) | Gets the value of the specified column as an OracleCursor object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleCursor(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleCursor Method : GetOracleCursor(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleCursor object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleCursor( _
   ByVal i As Integer _
) As OracleCursor
C#
public OracleCursor GetOracleCursor(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleCursor object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleCursor(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleCursor Method : GetOracleCursor(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleCursor object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleCursor( _
   ByVal name As String _
) As OracleCursor
C#
public OracleCursor GetOracleCursor(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleCursor object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleDate Method

Gets the value of the specified column as an OracleDate object.

Overload List

Overload | Description
GetOracleDate(Int32) | Gets the value of the specified column as an OracleDate object.
GetOracleDate(String) | Gets the value of the specified column as an OracleDate object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleDate(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleDate Method : GetOracleDate(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleDate object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleDate( _
   ByVal i As Integer _
) As OracleDate
C#
public OracleDate GetOracleDate(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleDate object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleDate(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleDate Method : GetOracleDate(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleDate object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleDate( _
   ByVal name As String _
) As OracleDate
C#
public OracleDate GetOracleDate(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleDate object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleDateTime Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleDateTime Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleDateTime object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleDateTime( _
   ByVal i As Integer _
) As OracleDateTime
C#
public OracleDateTime GetOracleDateTime(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleDateTime object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalDS Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleIntervalDS Method

Gets the value of the specified column as an OracleIntervalDS object.

Overload List

Overload | Description
GetOracleIntervalDS(Int32) | Gets the value of the specified column as an OracleIntervalDS object.
GetOracleIntervalDS(String) | Gets the value of the specified column as an OracleIntervalDS object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalDS(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleIntervalDS Method : GetOracleIntervalDS(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleIntervalDS object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleIntervalDS( _
   ByVal i As Integer _
) As OracleIntervalDS
C#
public OracleIntervalDS GetOracleIntervalDS(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleIntervalDS object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalDS(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleIntervalDS Method : GetOracleIntervalDS(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleIntervalDS object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleIntervalDS( _
   ByVal name As String _
) As OracleIntervalDS
C#
public OracleIntervalDS GetOracleIntervalDS(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleIntervalDS object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalYM Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleIntervalYM Method

Gets the value of the specified column as an OracleIntervalYM object.

Overload List

Overload | Description
GetOracleIntervalYM(Int32) | Gets the value of the specified column as an OracleIntervalYM object.
GetOracleIntervalYM(String) | Gets the value of the specified column as an OracleIntervalYM object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalYM(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleIntervalYM Method : GetOracleIntervalYM(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleIntervalYM object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleIntervalYM( _
   ByVal i As Integer _
) As OracleIntervalYM
C#
public OracleIntervalYM GetOracleIntervalYM(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleIntervalYM object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleIntervalYM(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleIntervalYM Method : GetOracleIntervalYM(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleIntervalYM object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleIntervalYM( _
   ByVal name As String _
) As OracleIntervalYM
C#
public OracleIntervalYM GetOracleIntervalYM(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleIntervalYM object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleLob Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleLob Method

Gets the value of the specified column as a OracleLob object.

Overload List

Overload | Description
GetOracleLob(Int32) | Gets the value of the specified column as a OracleLob object.
GetOracleLob(String) | Gets the value of the specified column as a OracleLob object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleLob(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleLob Method : GetOracleLob(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as a OracleLob object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleLob( _
   ByVal i As Integer _
) As OracleLob
C#
public OracleLob GetOracleLob(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a OracleLob object.

Remarks

Refer to "Working with BLOB and CLOB Data" article for detailed information.

Example

This example shows how to download a LOB field from a table using GetOracleLob method.
C#csharp Copy Code
public void DownloadLob(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Pictures", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default);
  try
  {
    while (myReader.Read())
    {
      OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"));
      if(!myLob.IsNull)
      {
        string FN = myReader.GetString(myReader.GetOrdinal("PicName"));
        FileStream fs = new FileStream("D:\\Tmp\\"+FN+".bmp", FileMode.Create);
        BinaryWriter w = new BinaryWriter(fs);
        w.Write(myLob.Value);
        w.Close();
        fs.Close();
        Console.WriteLine(FN+" downloaded.");
      }
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub DownloadLob(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Pictures", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default)
  Try
    While myReader.Read()
      Dim myLob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"))
      If Not myLob.IsNull Then
        Dim FN As String = myReader.GetString(myReader.GetOrdinal("PicName"))
        Dim fs As FileStream = New FileStream("D:\Tmp\" + FN + ".bmp", FileMode.Create)
        Dim w As BinaryWriter = New BinaryWriter(fs)
        w.Write(myLob.Value)
        w.Close()
        fs.Close()
        Console.WriteLine(String.Concat(FN, " downloaded."))
      End If
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
OracleLob Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleLob(String) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleLob Method : GetOracleLob(String) Method

name
Gets the value of the specified column as a OracleLob object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleLob( _
   ByVal name As String _
) As OracleLob
C#
public OracleLob GetOracleLob(
   string name
)

Parameters

name

Return Value

The value of the specified column as a OracleLob object.

Remarks

Refer to "Working with BLOB and CLOB Data" article for detailed information.

Example

This example shows how to download a LOB field from a table using GetOracleLob method.
C#csharp Copy Code
public void DownloadLob(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Pictures", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default);
  try
  {
    while (myReader.Read())
    {
      OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"));
      if(!myLob.IsNull)
      {
        string FN = myReader.GetString(myReader.GetOrdinal("PicName"));
        FileStream fs = new FileStream("D:\\Tmp\\"+FN+".bmp", FileMode.Create);
        BinaryWriter w = new BinaryWriter(fs);
        w.Write(myLob.Value);
        w.Close();
        fs.Close();
        Console.WriteLine(FN+" downloaded.");
      }
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub DownloadLob(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Test.Pictures", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default)
  Try
    While myReader.Read()
      Dim myLob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"))
      If Not myLob.IsNull Then
        Dim FN As String = myReader.GetString(myReader.GetOrdinal("PicName"))
        Dim fs As FileStream = New FileStream("D:\Tmp\" + FN + ".bmp", FileMode.Create)
        Dim w As BinaryWriter = New BinaryWriter(fs)
        w.Write(myLob.Value)
        w.Close()
        fs.Close()
        Console.WriteLine(String.Concat(FN, " downloaded."))
      End If
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
OracleLob Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleMonthSpan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleMonthSpan Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleMonthSpan object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleMonthSpan( _
   ByVal i As Integer _
) As OracleMonthSpan
C#
public OracleMonthSpan GetOracleMonthSpan(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleMonthSpan object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleNumber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleNumber Method

Gets the value of the specified column as an OracleNumber object.

Overload List

Overload | Description
GetOracleNumber(Int32) | Gets the value of the specified column as an OracleNumber object.
GetOracleNumber(String) | Gets the value of the specified column as an OracleNumber object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleNumber(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleNumber Method : GetOracleNumber(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleNumber object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleNumber( _
   ByVal i As Integer _
) As OracleNumber
C#
public OracleNumber GetOracleNumber(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleNumber object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleNumber(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleNumber Method : GetOracleNumber(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleNumber object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleNumber( _
   ByVal name As String _
) As OracleNumber
C#
public OracleNumber GetOracleNumber(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleNumber object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleObject Method

Gets the value of the specified column as an OracleObject object.

Overload List

Overload | Description
GetOracleObject(Int32) | Gets the value of the specified column as an OracleObject object.
GetOracleObject(String) | Gets the value of the specified column as an OracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleObject(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleObject Method : GetOracleObject(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleObject object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleObject( _
   ByVal i As Integer _
) As OracleObject
C#
public OracleObject GetOracleObject(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleObject(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleObject Method : GetOracleObject(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleObject object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleObject( _
   ByVal name As String _
) As OracleObject
C#
public OracleObject GetOracleObject(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleRef Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleRef Method

Gets the value of the specified column as an OracleRef object.

Overload List

Overload | Description
GetOracleRef(Int32) | Gets the value of the specified column as an OracleRef object.
GetOracleRef(String) | Gets the value of the specified column as an OracleRef object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleRef(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleRef Method : GetOracleRef(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleRef object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleRef( _
   ByVal i As Integer _
) As OracleRef
C#
public OracleRef GetOracleRef(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleRef object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleRef(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleRef Method : GetOracleRef(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleRef object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleRef( _
   ByVal name As String _
) As OracleRef
C#
public OracleRef GetOracleRef(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleRef object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleString Method

Gets the value of the specified column as an OracleString object.

Overload List

Overload | Description
GetOracleString(Int32) | Gets the value of the specified column as an OracleString object.
GetOracleString(String) | Gets the value of the specified column as an OracleString object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleString(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleString Method : GetOracleString(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleString object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleString( _
   ByVal i As Integer _
) As OracleString
C#
public OracleString GetOracleString(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleString object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleString(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleString Method : GetOracleString(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleString object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleString( _
   ByVal name As String _
) As OracleString
C#
public OracleString GetOracleString(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleString object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleTable Method

Gets the value of the specified column as an OracleTable object.

Overload List

Overload | Description
GetOracleTable(Int32) | Gets the value of the specified column as an OracleTable object.
GetOracleTable(String) | Gets the value of the specified column as an OracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTable(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleTable Method : GetOracleTable(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleTable object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleTable( _
   ByVal i As Integer _
) As OracleTable
C#
public OracleTable GetOracleTable(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTable(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleTable Method : GetOracleTable(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleTable object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleTable( _
   ByVal name As String _
) As OracleTable
C#
public OracleTable GetOracleTable(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTimeSpan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleTimeSpan Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleTimeSpan object.

Syntax

Visual Basic (Declaration)
Public Function GetOracleTimeSpan( _
   ByVal i As Integer _
) As OracleTimeSpan
C#
public OracleTimeSpan GetOracleTimeSpan(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleTimeSpan object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTimeStamp Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleTimeStamp Method

Gets the value of the specified column as an OracleTimeStamp object.

Overload List

Overload | Description
GetOracleTimeStamp(Int32) | Gets the value of the specified column as an OracleTimeStamp object.
GetOracleTimeStamp(String) | Gets the value of the specified column as an OracleTimeStamp object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTimeStamp(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleTimeStamp Method : GetOracleTimeStamp(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleTimeStamp object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleTimeStamp( _
   ByVal i As Integer _
) As OracleTimeStamp
C#
public OracleTimeStamp GetOracleTimeStamp(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleTimeStamp object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleTimeStamp(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleTimeStamp Method : GetOracleTimeStamp(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleTimeStamp object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleTimeStamp( _
   ByVal name As String _
) As OracleTimeStamp
C#
public OracleTimeStamp GetOracleTimeStamp(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleTimeStamp object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleValue Method

Gets the value of the column at the specified ordinal in its Oracle format wrapped by dotConnect for Oracle.

Overload List

Overload | Description
GetOracleValue(Int32) | Gets the value of the column at the specified ordinal in its Oracle format wrapped by dotConnect for Oracle.
GetOracleValue(String) | Gets the value of the specified column in its Oracle format wrapped by dotConnect for Oracle.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleValue Method : GetOracleValue(Int32) Method

i
The zero-based column ordinal.
Gets the value of the column at the specified ordinal in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal i As Integer _
) As Object
C#
public object GetOracleValue(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the column as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see GetValue method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleValue Method : GetOracleValue(String) Method

name
The name of the column to get value of.
Gets the value of the specified column in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal name As String _
) As Object
C#
public object GetOracleValue(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the column as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see GetValue method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValues Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleValues Method

Gets all the column values as the dotConnect for Oracle wrapped types.

Overload List

Overload | Description
GetOracleValues(Object[]) | Gets all the column values as the dotConnect for Oracle wrapped types.
GetOracleValues() | Gets all the column values as the dotConnect for Oracle wrapped types.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValues(Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleValues Method : GetOracleValues(Object[]) Method

values
An array of objects to hold the dotConnect for Oracle wrapped types as the column values.
Gets all the column values as the dotConnect for Oracle wrapped types.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValues( _
   ByVal values() As Object _
) As Integer
C#
public int GetOracleValues(
   object[] values
)

Parameters

values
An array of objects to hold the dotConnect for Oracle wrapped types as the column values.

Return Value

The number of column values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValues() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleValues Method : GetOracleValues() Method

Gets all the column values as the dotConnect for Oracle wrapped types.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValues() As Object()
C#
public object[] GetOracleValues()

Return Value

An array of objects with the dotConnect for Oracle wrapped types as the column values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleXml Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetOracleXml Method

Gets the value of the specified column as an OracleXml object.

Overload List

Overload | Description
GetOracleXml(Int32) | Gets the value of the specified column as an OracleXml object.
GetOracleXml(String) | Gets the value of the specified column as an OracleXml object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleXml(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleXml Method : GetOracleXml(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as an OracleXml object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleXml( _
   ByVal i As Integer _
) As OracleXml
C#
public OracleXml GetOracleXml(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as an OracleXml object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleXml(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetOracleXml Method : GetOracleXml(String) Method

name
The name of the column to get value of.
Gets the value of the specified column as an OracleXml object.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleXml( _
   ByVal name As String _
) As OracleXml
C#
public OracleXml GetOracleXml(
   string name
)

Parameters

name
The name of the column to get value of.

Return Value

The value of the specified column as an OracleXml object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificFieldType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetProviderSpecificFieldType Method

Gets the System.Type that is the provider-specific data type of the object.

Overload List

Overload | Description
GetProviderSpecificFieldType(Int32) | Gets the System.Type that is the provider-specific data type of the object.
GetProviderSpecificFieldType(String) | Returns the provider-specific field type of the specified column. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificFieldType(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetProviderSpecificFieldType Method : GetProviderSpecificFieldType(Int32) Method

i
Gets the System.Type that is the provider-specific data type of the object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProviderSpecificFieldType( _
   ByVal i As Integer _
) As Type
C#
public override Type GetProviderSpecificFieldType(
   int i
)

Parameters

i

Return Value

The System.Type that is the provider-specific data type of the object.

Example

C#csharp Copy Code
static void GetMyFieldType(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();

    for (short i = 0; i < reader.FieldCount; i++) {
      object someValue = reader.GetProviderSpecificValue(i);
      Console.Write(reader.GetProviderSpecificFieldType(i).FullName + " : ");
      Console.WriteLine(someValue.ToString());
    }

    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyFieldType(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    For i As Short = 0 To reader.FieldCount - 1
      Dim someValue As Object = reader.GetProviderSpecificValue(i)
      Console.Write((reader.GetProviderSpecificFieldType(i).FullName & " : "))
      Console.WriteLine(someValue.ToString)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetProviderSpecificValue Method

Gets the value of the specified column. If possible, a provider-specific type is used.

Overload List

Overload | Description
GetProviderSpecificValue(Int32) | Gets the value of the specified column. If possible, a provider-specific type is used.
GetProviderSpecificValue(String) | Gets the value of the specified column as an instance of System.Object (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValue(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetProviderSpecificValue Method : GetProviderSpecificValue(Int32) Method

i
Gets the value of the specified column. If possible, a provider-specific type is used.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProviderSpecificValue( _
   ByVal i As Integer _
) As Object
C#
public override object GetProviderSpecificValue(
   int i
)

Parameters

i

Return Value

The value to return.

Remarks

This method returns System.DBNull for null data source columns.

Example

C#csharp Copy Code
static void GetMyFieldType(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();

    for (short i = 0; i < reader.FieldCount; i++) {
      object someValue = reader.GetProviderSpecificValue(i);
      Console.Write(reader.GetProviderSpecificFieldType(i).FullName + " : ");
      Console.WriteLine(someValue.ToString());
    }

    reader.Close();
  }
  finally {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyFieldType(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    For i As Short = 0 To reader.FieldCount - 1
      Dim someValue As Object = reader.GetProviderSpecificValue(i)
      Console.Write((reader.GetProviderSpecificFieldType(i).FullName & " : "))
      Console.WriteLine(someValue.ToString)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValues Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetProviderSpecificValues Method

Gets all column values in the collection for the current row. If possible, a provider-specific type is used.

Overload List

Overload | Description
GetProviderSpecificValues(Object[]) | Gets all column values for the current row. If possible, a provider-specific type is used.
GetProviderSpecificValues() | Gets all column values for the current row. If possible, a provider-specific type is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValues(Object[]) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetProviderSpecificValues Method : GetProviderSpecificValues(Object[]) Method

values
An array of System.Object into which to copy the column values.
Gets all column values for the current row. If possible, a provider-specific type is used.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProviderSpecificValues( _
   ByVal values() As Object _
) As Integer
C#
public override int GetProviderSpecificValues(
   object[] values
)

Parameters

values
An array of System.Object into which to copy the column values.

Return Value

The number of instances of System.Object in the array.

Remarks

This method is equivalent to the GetValues(Object[]) method, the only difference is that this method uses a provider-specific type whenever possible.

Example

C#csharp Copy Code
static void GetMyValues(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();

    object[] someValues = new object[5];
    int number = reader.GetProviderSpecificValues(someValues);

    for (short i = 0; i < number; i++)
    {
      Console.WriteLine(someValues[i].ToString());
    }

    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyValues(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim someValues As Object() = New Object() {}
    Dim number As Integer = reader.GetProviderSpecificValues(someValues)
    For i As Short = 0 To number - 1
      Console.WriteLine(someValues(i).ToString)
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValues() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetProviderSpecificValues Method : GetProviderSpecificValues() Method

Gets all column values for the current row. If possible, a provider-specific type is used.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetProviderSpecificValues() As Object()
C#
public object[] GetProviderSpecificValues()

Return Value

An array of System.Object with the column values.

Remarks

This method is equivalent to the GetValues method, the only difference is that this method uses a provider-specific type whenever possible.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetString Method

Gets the value of the specified column as a string.

Overload List

Overload | Description
GetString(Int32) | Gets the value of the specified column as a string.
GetString(String) | Gets the value of the specified column as an instance of System.String (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetString(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetString Method : GetString(Int32) Method

i
Gets the value of the specified column as a string.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetString( _
   ByVal i As Integer _
) As String
C#
public override string GetString(
   int i
)

Parameters

i

Return Value

The value of the specified column.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyString(OracleConnection myConnection) {
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    string recievedString = reader.GetString(reader.GetOrdinal("StringCol"));
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyString(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedString As String = reader.GetString(reader.GetOrdinal("StringCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetTimeSpan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetTimeSpan Method

Gets the value of the specified column as a System.TimeSpan.

Overload List

Overload | Description
GetTimeSpan(Int32) | Gets the value of the specified column as a System.TimeSpan.
GetTimeSpan(String) |

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetTimeSpan(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetTimeSpan Method : GetTimeSpan(Int32) Method

i
The zero-based column ordinal.
Gets the value of the specified column as a System.TimeSpan.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTimeSpan( _
   ByVal i As Integer _
) As TimeSpan
C#
public TimeSpan GetTimeSpan(
   int i
)

Parameters

i
The zero-based column ordinal.

Return Value

The value of the specified column as a System.TimeSpan.

Remarks

Call IsDBNull to check for null values before calling this method.

Example

C#csharp Copy Code
static void GetMyTimeSpan(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    TimeSpan recievedTime = reader.GetTimeSpan(reader.GetOrdinal("TimeCol"));
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyTimeSpan(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    Dim recievedTime As TimeSpan = reader.GetTimeSpan(reader.GetOrdinal("TimeCol"))
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetTimeSpan(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetTimeSpan Method : GetTimeSpan(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Function GetTimeSpan( _
   ByVal name As String _
) As TimeSpan
C#
public TimeSpan GetTimeSpan(
   string name
)

Parameters

name

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetValue Method

Gets the value of the specified column in its native format.

Overload List

Overload | Description
GetValue(Int32) | Gets the value of the specified column in its native format.
GetValue(String) | Gets the value of the specified column in its native format. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValue(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetValue Method : GetValue(Int32) Method

i
Gets the value of the specified column in its native format.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetValue( _
   ByVal i As Integer _
) As Object
C#
public override object GetValue(
   int i
)

Parameters

i

Return Value

The value to return.

Remarks

This method returns System.DBNull for null data source columns.

Example

C#csharp Copy Code
static void GetMyValue(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();

    for (short i = 0; i < reader.FieldCount; i++)
    {
      if (reader.IsDBNull(i))
        Console.WriteLine("NULL");
      else
      {
        object someValue = reader.GetValue(i);
        Console.WriteLine(someValue.ToString());
      }
    }

    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyValue(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    For i As Short = 0 To reader.FieldCount - 1
      If reader.IsDBNull(i) Then
        Console.WriteLine("NULL")
      Else
        Console.WriteLine(reader.GetValue(i).ToString)
      End If
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
GetValues Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValues Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : GetValues Method

Gets all column values for the current row.

Overload List

Overload | Description
GetValues(Object[]) | Gets all column values for the current row.
GetValues() | Gets all column values for the current row.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValues(Object[]) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetValues Method : GetValues(Object[]) Method

values
An array of System.Object into which to copy the attribute column values.
Gets all column values for the current row.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetValues( _
   ByVal values() As Object _
) As Integer
C#
public override int GetValues(
   object[] values
)

Parameters

values
An array of System.Object into which to copy the attribute column values.

Return Value

The number of instances of System.Object in the array.

Remarks

For most applications, the GetValues method provides an efficient way for retrieving all column values, rather than retrieving each column value individually.

You can pass an System.Object array that contains fewer than the number of column values contained in the resulting row. Only the amount of data the System.Object array holds is copied to the array. You can also pass an System.Object array whose length is more than the number of columns contained in the resulting row.

This method returns System.DBNull for redundant array elements.

Example

The example shows how to retrieve several fields at once. Note that only the first three fields are retrieved, though there may be more in the table.
C#csharp Copy Code
public void GetObjects(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Emp");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();
    object[] objs = new object[3];
    int quant = reader.GetValues(objs);
    for (int i=0;i < quant;i++)
    {
      Console.WriteLine(objs[i]);
    }
    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetObjects(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    reader.Read()
    Dim objs(3) As Object
    Dim quant As Integer = reader.GetValues(objs)
    Dim i As Integer
    For i = 0 To quant - 1
      Console.WriteLine(objs(i))
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
GetValue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetValues() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > GetValues Method : GetValues() Method

Gets all column values for the current row.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetValues() As Object()
C#
public object[] GetValues()

Return Value

An array of System.Object with the column values.

Remarks

For most applications, the GetValues method provides an efficient way for retrieving all column values, rather than retrieving each column value individually.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List
GetValue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : IsDBNull Method

Gets a value indicating whether the column contains non-existent or missing values.

Overload List

Overload | Description
IsDBNull(Int32) | Gets a value indicating whether the column contains non-existent or missing values.
IsDBNull(String) | Gets a value indicating whether the column contains non-existent or missing values. (Inherited from Devart.Common.DbDataReaderBase)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDBNull(Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class > IsDBNull Method : IsDBNull(Int32) Method

i
Gets a value indicating whether the column contains non-existent or missing values.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function IsDBNull( _
   ByVal i As Integer _
) As Boolean
C#
public override bool IsDBNull(
   int i
)

Parameters

i

Return Value

true if the specified column value is equivalent to System.DBNull; otherwise, false.

Remarks

To avoid raising an error, call this method to check for null column values before calling the typed Get methods (for example, GetByte, GetChar, and so on).

Example

C#csharp Copy Code
static void GetMyValue(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.AllTypes");
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    reader.Read();

    for (short i = 0; i < reader.FieldCount; i++)
    {
      if (reader.IsDBNull(i))
        Console.WriteLine("NULL");
      else
      {
        object someValue = reader.GetValue(i);
        Console.WriteLine(someValue.ToString());
      }
    }

    reader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Shared Sub GetMyValue(ByVal myConnection As OracleConnection)
  Dim cmd As New OracleCommand("SELECT * FROM Test.AllTypes")
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader
    reader.Read()
    For i As Short = 0 To reader.FieldCount - 1
      If reader.IsDBNull(i) Then
        Console.WriteLine("NULL")
      Else
        Console.WriteLine(reader.GetValue(i).ToString)
      End If
    Next i
    reader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NextResult Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : NextResult Method

Advances the data reader to the next result, when reading the results of multiple REF CURSORs in PL/SQL statement.

Syntax

Visual Basic (Declaration)
Public Overrides Function NextResult() As Boolean
C#
public override bool NextResult()

Return Value

true if there are more cursors; otherwise, false.

Remarks

Used to process multiple cursors, which can be generated by executing PL/SQL statements.

By default, the OracleDataReader is positioned on the first cursor.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : Read Method

Advances the OracleDataReader to the next record.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read() As Boolean
C#
public override bool Read()

Return Value

true if there are more rows; otherwise, false.

Remarks

The default position of the OracleDataReader is prior to the first record. Therefore, you must call Read to begin accessing any data.

While the OracleDataReader is in use, the associated OracleConnection is busy serving it until you call Close.

Example

The following example creates a OracleConnection, a Devart.Data.Oracle.OracleCommand, and a OracleDataReader. The example reads through the data, writing it out to the console. Finally, the example closes the OracleDataReader, then the OracleConnection.
C#csharp Copy Code
public void ReadMyData(string myConnString)
{
  string mySelectQuery = "SELECT DeptNo, DName FROM Test.Dept";
  OracleConnection myConnection = new OracleConnection(myConnString);
  OracleCommand myCommand = new OracleCommand(mySelectQuery,myConnection);
  myConnection.Open();
  OracleDataReader myReader;
  myReader = myCommand.ExecuteReader();
  // Always call Read before accessing data.
  while (myReader.Read()) {
    Console.WriteLine(myReader.GetInt32(0) + ", " + myReader.GetString(1));
  }
  // always call Close when done reading.
  myReader.Close();
  // Close the connection when done with it.
  myConnection.Close();
}
C#Visual Basic Copy Code
Public Sub ReadMyData(myConnString As String)
  Dim mySelectQuery As String = "SELECT DeptNo, DName FROM Test.Dept"
  Dim myConnection As New OracleConnection(myConnString)
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader
  myReader = myCommand.ExecuteReader()
  ' Always call Read before accessing data.
  While myReader.Read()
    Console.WriteLine(myReader.GetInt32(0).ToString() + ", " _
      + myReader.GetString(1))
  End While
  ' always call Close when done reading.
  myReader.Close()
  ' Close the connection when done with it.
  myConnection.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDataReader Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataReader Class

For a list of all members of this type, see OracleDataReader members.

Public Properties

 | Name | Description
public Property | Depth | Overridden. Gets a value indicating the depth of nesting for the current row.
public Property | EndOfData | Overridden. Indicates whether the OracleDataReader has been read completely.
public Property | FieldCount | Overridden. Gets the number of columns in the current row.
public Property | HasRows | Overridden. Gets a value indicating whether the OracleDataReader contains one or more rows.
public Property | IsClosed | Gets a value indicating whether the System.Data.Common.DbDataReader is closed. (Inherited from System.Data.Common.DbDataReader)
public Property | Item | Overloaded. Gets the value of the specified column as an instance of System.Object. (Inherited from System.Data.Common.DbDataReader)
public Property | RecordsAffected | Overridden. Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
public Property | VisibleFieldCount | Gets the number of fields in the System.Data.Common.DbDataReader that are not hidden. (Inherited from System.Data.Common.DbDataReader)
Top

See Also

Reference

OracleDataReader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Depth Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : Depth Property

Gets a value indicating the depth of nesting for the current row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Depth As Integer
C#
public override int Depth {get;}

Property Value

Depth of nesting for the current row.

Remarks

You can obtain nested tables from queries using methods GetValue and M:Devart.Common.DbDataReader.GetData. In this case use property Depth to obtain depth of current result set. Root result set has depth 0.

To get nested tables from server you can use queries like this:

SELECT CURSOR(SELECT * FROM emp e WHERE e.deptno = d.deptno), d.* FROM dept d

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndOfData Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : EndOfData Property

Indicates whether the OracleDataReader has been read completely.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EndOfData As Boolean
C#
public override bool EndOfData {get;}

Property Value

true if there is no more data in OracleDataReader. This property is false if there is more data to read, or there were no data at all.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FieldCount Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : FieldCount Property

Gets the number of columns in the current row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FieldCount As Integer
C#
public override int FieldCount {get;}

Property Value

When not positioned in a valid record set, 0; otherwise the number of columns in the current record. The default value is -1.

Remarks

After executing a query that does not return rows, FieldCount returns 0.

Example

This sample demonstrates how to iterate through fields in a row using FieldCount property.
C#csharp Copy Code
public void FetchResults(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.FetchSize = 100;
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    while (reader.Read())
    {
      for (int i=0;i<reader.FieldCount;i++)
      {
        Console.Write("\t"+reader[i]);
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub FetchResults(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.FetchSize = 100
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    While reader.Read()
      Dim i
      For i = 0 To reader.FieldCount - 1
        Console.Write(String.Concat(" ", reader(i)))
      Next i
      Console.WriteLine()
    End While
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
HasRows Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : HasRows Property

Gets a value indicating whether the OracleDataReader contains one or more rows.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HasRows As Boolean
C#
public override bool HasRows {get;}

Property Value

true if the OracleDataReader contains one or more rows; otherwise, false.

Remarks

Note that this property returns true even if all rows were read out.

Example

This sample shows how to optimize reading from a data source using HasRows property.
C#csharp Copy Code
public void FetchResults(OracleConnection myConnection)
{
  OracleCommand cmd = new OracleCommand("SELECT * FROM Test.Dept");
  cmd.FetchSize = 100;
  cmd.Connection = myConnection;
  myConnection.Open();
  try
  {
    OracleDataReader reader = cmd.ExecuteReader();
    if (reader.HasRows)
    {
      while (reader.Read())
      {
        for (int i=0;i<reader.FieldCount;i++)
        {
          Console.Write("\t"+reader[i]);
        }
        Console.WriteLine();
      }
    }
    else
    {
      Console.WriteLine("No rows detected.");
    }
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub FetchResults(ByVal myConnection As OracleConnection)
  Dim cmd As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  cmd.FetchSize = 100
  cmd.Connection = myConnection
  myConnection.Open()
  Try
    Dim reader As OracleDataReader = cmd.ExecuteReader()
    If reader.HasRows Then
      While reader.Read()
        Dim i
        For i = 0 To reader.FieldCount - 1
          Console.Write(String.Concat(" ", reader(i)))
        Next i
        Console.WriteLine()
      End While
    Else
      Console.WriteLine("No rows detected.")
    End If
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecordsAffected Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataReader Class : RecordsAffected Property

Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property RecordsAffected As Integer
C#
public override int RecordsAffected {get;}

Property Value

The number of rows changed, inserted, or deleted. -1 for SELECT statements; 0 if no rows were affected, or the statement failed.

Remarks

The value of this property is cumulative. For example, if two records are inserted in the first statement in batch mode, and the second statement affected 3 records, the value of RecordsAffected will be 5.

IsClosed and RecordsAffected are the only properties that you can call after the OracleDataReader is closed.

Example

This sample shows how to find out how many rows have been affected during last query. You can do it even if the OracleDataReader has been closed.
C#csharp Copy Code
public void ProcessReader (OracleDataReader myReader)
{
  if (!myReader.IsClosed)
  {
    while (myReader.Read())
    {
      for (int i=0;i<myReader.FieldCount;i++)
      {
        Console.Write("\t"+myReader[i]);
      }
      Console.WriteLine();
    }
  }
  else
  {
    Console.WriteLine("The DataReader is closed. Rows affected in last action: "+myReader.RecordsAffected);
  }
}
C#Visual Basic Copy Code
Public Sub ProcessReader(ByVal myReader As OracleDataReader)
  If Not myReader.IsClosed Then
    Dim i As Integer
    While myReader.Read()
      For i = 0 To myReader.FieldCount - 1
        Console.Write(" " & myReader(i))
      Next i
      Console.WriteLine()
    End While
  Else
    Console.WriteLine("The DataReader is closed. Rows affected in last action: " & myReader.RecordsAffected)
  End If
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataReader Class
OracleDataReader Members
IsClosed Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSet Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSet Class

Represents an in-memory cache of data with support for Oracle-specific features.

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Data.DataSet
Devart.Common.DbDataSet
Devart.Data.Oracle.OracleDataSet

Syntax

Visual Basic (Declaration)
Public Class OracleDataSet
   Inherits Devart.Common.DbDataSet
   Implements IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable
C#
public class OracleDataSet : Devart.Common.DbDataSet, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, IDisposable, IServiceProvider, ISerializable, IXmlSerializable

Remarks

Refer to topic General Concepts in Database Application Development for information on how to use the OracleDataSet class best.

This class supports cross-form data binding with the InterForm Technology.

To migrate from a standard typed DataSet, change its Custom Tool property to dcOracleDataSetGenerator. You will also need to delete all TableAdapters from the old DataSet.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

This sample shows the use of untyped OracleDataSet with comprehensive OracleDataTables. You can do the same operations in design time by drag&drop-ing OracleDataSet from Toolbox to Form Designer and editting it via DataSet Manager and DataSet Editor. Otherwise, you can always generate typed OracleDataSet using DataSet Wizard.
C#csharp Copy Code
static OracleDataSet GetDataSet(string connStr) {
        // retrieving data from DEPT table
        OracleDataTable dept = new OracleDataTable("select * from dept", connStr);
        dept.FetchAll = true;
        dept.Active = true;

        // retrieving data from EMP table
        OracleDataTable emp = new OracleDataTable("select * from emp", connStr);
        emp.FetchAll = true;
        emp.Active = true;

        // adding data tables to OracleDataSet
        OracleDataSet dataSet = new OracleDataSet();
        dataSet.Tables.Add(dept);
        dataSet.Tables.Add(emp);

        // linking tables to allow navigation from parent table rows
        // to corresponding child table rows
        DataColumn parentColumn = dataSet.Tables["DEPT"].Columns["DEPTNO"];
        DataColumn childColumn = dataSet.Tables["EMP"].Columns["DEPTNO"];
        DataRelation relation = new System.Data.DataRelation("DeptsEmps", parentColumn, childColumn);
        dataSet.Relations.Add(relation);

        return dataSet;
}
C#Visual Basic Copy Code
Public Function GetDataSet(ByVal connStr As String) As OracleDataSet
        ' retrieving data from DEPT table
        Dim dept As New OracleDataTable("select * from dept", connStr)
        dept.FetchAll = True
        dept.Active = True

        ' retrieving data from EMP table
        Dim emp As New OracleDataTable("select * from emp", connStr)
        emp.FetchAll = True
        emp.Active = True

        ' adding data tables to OracleDataSet
        Dim dataSet As New OracleDataSet()
        dataSet.Tables.Add(dept)
        dataSet.Tables.Add(emp)

        ' linking tables to allow navigation from parent table rows
        ' to corresponding child table rows
        Dim parentColumn As DataColumn = dataSet.Tables("DEPT").Columns("DEPTNO")
        Dim childColumn As DataColumn = dataSet.Tables("EMP").Columns("DEPTNO")
        Dim relation As New System.Data.DataRelation("DeptsEmps", parentColumn, childColumn)
        dataSet.Relations.Add(relation)
        Return dataSet
End Function

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDataSet Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDataSet Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleDataSet Class

The following tables list the members exposed by OracleDataSet.

Public Constructors

 | Name | Description
public Constructor | OracleDataSet Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CaseSensitive | Gets or sets a value indicating whether string comparisons within System.Data.DataTable objects are case-sensitive. (Inherited from System.Data.DataSet)
public Property | Connection | Associated Devart.Data.Oracle.OracleConnection.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSetName | Gets or sets the name of the current System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | DefaultViewManager | Gets a custom view of the data contained in the System.Data.DataSet to allow filtering, searching, and navigating using a custom System.Data.DataViewManager. (Inherited from System.Data.DataSet)
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from System.Data.DataSet)
public Property | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from System.Data.DataSet)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the System.Data.DataTable objects within this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataSet)
public Property | Name | Gets or sets name of the Devart.Common.DbDataSet. (Inherited from Devart.Common.DbDataSet)
public Property | Namespace | Gets or sets the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Owner | Gets or sets a form or other container that the Devart.Common.DbDataSet instance belongs to. (Inherited from Devart.Common.DbDataSet)
public Property | Prefix | Gets or sets an XML prefix that aliases the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Relations | Gets a collection of relations in the OracleDataSet.
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the Devart.Common.DbDataSet used during remoting. (Inherited from Devart.Common.DbDataSet)
public Property | SchemaSerializationMode | Gets or sets a System.Data.SchemaSerializationMode for a System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | Tables | Gets collection of tables
Top

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this System.Data.DataSet since it was loaded or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | BeginInit | Begins the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Clear | Clears the Devart.Common.DbDataSet of any data by removing all rows in all tables. (Inherited from Devart.Common.DbDataSet)
public Method | Clone | Copies the structure of the System.Data.DataSet, including all System.Data.DataTable schemas, relations, and constraints. Does not copy any data. (Inherited from System.Data.DataSet)
public Method | Copy | Copies both the structure and data for this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | CreateDataReader | Overloaded. Returns a System.Data.DataTableReader with one result set per System.Data.DataTable, in the same sequence as the tables appear in the System.Data.DataSet.Tables collection. (Inherited from System.Data.DataSet)
public Method | CreateDataTable | Overridden. Creates and returns new OracleDataTable object.
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndInit | Ends the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Fill | Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataSet with rows from the data source. (Inherited from Devart.Common.DbDataSet)
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataSet that contains all changes made to it since it was loaded or since System.Data.DataSet.AcceptChanges was last called. (Inherited from System.Data.DataSet)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | GetXml | Returns the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetXmlSchema | Returns the XML Schema for the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | HasChanges | Overloaded. Gets a value indicating whether the System.Data.DataSet has changes, including new, deleted, or modified rows. (Inherited from System.Data.DataSet)
public Method | InferXmlSchema | Overloaded. Applies the XML schema from the specified System.Xml.XmlReader to the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | Load | Overloaded. Fills a System.Data.DataSet with values from a data source using the supplied System.Data.IDataReader, using an array of System.Data.DataTable instances to supply the schema and namespace information. (Inherited from System.Data.DataSet)
public Method | Merge | Overloaded. Merges a specified System.Data.DataSet and its schema into the current DataSet. (Inherited from System.Data.DataSet)
public Method | ReadXml | Overloaded. Reads XML schema and data into the Devart.Common.DbDataSet. (Inherited from Devart.Common.DbDataSet)
public Method | ReadXmlSchema | Overloaded. Reads the XML schema from the specified System.Xml.XmlReader into the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | RejectChanges | Rolls back all the changes made to the System.Data.DataSet since it was created, or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | Reset | Clears all tables and removes all relations, foreign constraints, and tables from the System.Data.DataSet. Subclasses should override System.Data.DataSet.Reset to restore a System.Data.DataSet to its original state. (Inherited from System.Data.DataSet)
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source. (Inherited from Devart.Common.DbDataSet)
public Method | WriteXml | Overloaded. Writes the current data for the System.Data.DataSet using the specified System.IO.Stream. (Inherited from System.Data.DataSet)
public Method | WriteXmlSchema | Overloaded. Writes the System.Data.DataSet structure as an XML schema to the specified System.IO.Stream object. (Inherited from System.Data.DataSet)
Top

Public Events

 | Name | Description
public Event | Disposed | Adds an event handler to listen to the System.ComponentModel.MarshalByValueComponent.Disposed event on the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Event | Initialized | Occurs after the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Event | MergeFailed | Occurs when a target and source System.Data.DataRow have the same primary key value, and System.Data.DataSet.EnforceConstraints is set to true. (Inherited from System.Data.DataSet)
Top

See Also

Reference

OracleDataSet Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSet Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class : OracleDataSet Constructor

Overload List

Overload | Description
OracleDataSet Constructor() | Initializes a new instance of a OracleDataSet class with the given name.
OracleDataSet Constructor(SerializationInfo,StreamingContext,Boolean) | This API supports the .NET Framework infrastructure and is not intended to be used directly from your code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSet Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class > OracleDataSet Constructor : OracleDataSet Constructor()

Initializes a new instance of a OracleDataSet class with the given name.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleDataSet()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSet Constructor(SerializationInfo,StreamingContext,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class > OracleDataSet Constructor : OracleDataSet Constructor(SerializationInfo,StreamingContext,Boolean)

info
Contains the data needed to serialize or deserialize an OracleDataSet object.
context
Describes the source and destination of a given serialized stream, and provides an additional caller-defined context.
ConstructSchema
Value that determines whether to construct schema or not.
This API supports the .NET Framework infrastructure and is not intended to be used directly from your code.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext, _
   ByVal ConstructSchema As Boolean _
)
C#
public OracleDataSet(
   SerializationInfo info,
   StreamingContext context,
   bool ConstructSchema
)

Parameters

info
Contains the data needed to serialize or deserialize an OracleDataSet object.
context
Describes the source and destination of a given serialized stream, and provides an additional caller-defined context.
ConstructSchema
Value that determines whether to construct schema or not.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDataSet Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSet Class

For a list of all members of this type, see OracleDataSet members.

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this System.Data.DataSet since it was loaded or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | BeginInit | Begins the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Clear | Clears the Devart.Common.DbDataSet of any data by removing all rows in all tables. (Inherited from Devart.Common.DbDataSet)
public Method | Clone | Copies the structure of the System.Data.DataSet, including all System.Data.DataTable schemas, relations, and constraints. Does not copy any data. (Inherited from System.Data.DataSet)
public Method | Copy | Copies both the structure and data for this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | CreateDataReader | Overloaded. Returns a System.Data.DataTableReader with one result set per System.Data.DataTable, in the same sequence as the tables appear in the System.Data.DataSet.Tables collection. (Inherited from System.Data.DataSet)
public Method | CreateDataTable | Overridden. Creates and returns new OracleDataTable object.
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndInit | Ends the initialization of a System.Data.DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataSet)
public Method | Fill | Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataSet with rows from the data source. (Inherited from Devart.Common.DbDataSet)
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataSet that contains all changes made to it since it was loaded or since System.Data.DataSet.AcceptChanges was last called. (Inherited from System.Data.DataSet)
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | GetXml | Returns the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | GetXmlSchema | Returns the XML Schema for the XML representation of the data stored in the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | HasChanges | Overloaded. Gets a value indicating whether the System.Data.DataSet has changes, including new, deleted, or modified rows. (Inherited from System.Data.DataSet)
public Method | InferXmlSchema | Overloaded. Applies the XML schema from the specified System.Xml.XmlReader to the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | Load | Overloaded. Fills a System.Data.DataSet with values from a data source using the supplied System.Data.IDataReader, using an array of System.Data.DataTable instances to supply the schema and namespace information. (Inherited from System.Data.DataSet)
public Method | Merge | Overloaded. Merges a specified System.Data.DataSet and its schema into the current DataSet. (Inherited from System.Data.DataSet)
public Method | ReadXml | Overloaded. Reads XML schema and data into the Devart.Common.DbDataSet. (Inherited from Devart.Common.DbDataSet)
public Method | ReadXmlSchema | Overloaded. Reads the XML schema from the specified System.Xml.XmlReader into the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Method | RejectChanges | Rolls back all the changes made to the System.Data.DataSet since it was created, or since the last time System.Data.DataSet.AcceptChanges was called. (Inherited from System.Data.DataSet)
public Method | Reset | Clears all tables and removes all relations, foreign constraints, and tables from the System.Data.DataSet. Subclasses should override System.Data.DataSet.Reset to restore a System.Data.DataSet to its original state. (Inherited from System.Data.DataSet)
public Method | Update | Executes the appropriate commands to delete, insert, or update rows in the data source. (Inherited from Devart.Common.DbDataSet)
public Method | WriteXml | Overloaded. Writes the current data for the System.Data.DataSet using the specified System.IO.Stream. (Inherited from System.Data.DataSet)
public Method | WriteXmlSchema | Overloaded. Writes the System.Data.DataSet structure as an XML schema to the specified System.IO.Stream object. (Inherited from System.Data.DataSet)
Top

See Also

Reference

OracleDataSet Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateDataTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class : CreateDataTable Method

Creates and returns new OracleDataTable object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateDataTable() As DbDataTable
C#
public override DbDataTable CreateDataTable()

Return Value

The new OracleDataTable object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDataSet Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSet Class

For a list of all members of this type, see OracleDataSet members.

Public Properties

 | Name | Description
public Property | CaseSensitive | Gets or sets a value indicating whether string comparisons within System.Data.DataTable objects are case-sensitive. (Inherited from System.Data.DataSet)
public Property | Connection | Associated Devart.Data.Oracle.OracleConnection.
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSetName | Gets or sets the name of the current System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | DefaultViewManager | Gets a custom view of the data contained in the System.Data.DataSet to allow filtering, searching, and navigating using a custom System.Data.DataViewManager. (Inherited from System.Data.DataSet)
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from System.Data.DataSet)
public Property | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from System.Data.DataSet)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the System.Data.DataTable objects within this System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataSet)
public Property | Name | Gets or sets name of the Devart.Common.DbDataSet. (Inherited from Devart.Common.DbDataSet)
public Property | Namespace | Gets or sets the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Owner | Gets or sets a form or other container that the Devart.Common.DbDataSet instance belongs to. (Inherited from Devart.Common.DbDataSet)
public Property | Prefix | Gets or sets an XML prefix that aliases the namespace of the System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Relations | Gets a collection of relations in the OracleDataSet.
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the Devart.Common.DbDataSet used during remoting. (Inherited from Devart.Common.DbDataSet)
public Property | SchemaSerializationMode | Gets or sets a System.Data.SchemaSerializationMode for a System.Data.DataSet. (Inherited from System.Data.DataSet)
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | Tables | Gets collection of tables
Top

See Also

Reference

OracleDataSet Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class : Connection Property

Associated OracleConnection.

Syntax

Visual Basic (Declaration)
Public Shadows Property Connection As OracleConnection
C#
public new OracleConnection Connection {get; set;}

Property Value

OracleConnection used by OracleDataSet.

Remarks

This property supports the InterForm technology.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Relations Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class : Relations Property

Gets a collection of relations in the OracleDataSet.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Relations As DataRelationCollection
C#
public new DataRelationCollection Relations {get;}

Property Value

A collection of relations.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tables Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSet Class : Tables Property

Gets collection of tables

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Tables As DataTableCollection
C#
public new DataTableCollection Tables {get;}

Property Value

Collection of tables in DataSet

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSet Class
OracleDataSet Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSourceEnumerator Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSourceEnumerator Class

Provides a mechanism for enumerating all known Oracle servers (TNS aliases).

Inheritance Hierarchy

System.Object
System.Data.Common.DbDataSourceEnumerator
Devart.Data.Oracle.OracleDataSourceEnumerator

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleDataSourceEnumerator
   Inherits System.Data.Common.DbDataSourceEnumerator
C#
public sealed class OracleDataSourceEnumerator : System.Data.Common.DbDataSourceEnumerator

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

This sample shows the use of OracleDataSourceEnumerator class.
C#csharp Copy Code
OracleHomeCollection homes = OracleConnection.Homes;
foreach (OracleHome h in homes) {
    Console.WriteLine("=== Home={0} ===", h.Name);
    OracleDataSourceEnumerator en = new OracleDataSourceEnumerator();
    DataTable tbl = en.GetDataSources(h.Name);
    foreach (DataRow row in tbl.Rows) {
        Console.WriteLine(row["InstanceName"]);
    }
}
Console.ReadLine();
C#Visual Basic Copy Code
Dim homes As OracleHomeCollection = OracleConnection.Homes
For Each h As OracleHome In homes
        Console.WriteLine("=== Home={0} ===", h.Name)
    Dim en As New OracleDataSourceEnumerator()
    Dim tbl As DataTable = en.GetDataSources(h.Name)
    For Each row As DataRow In tbl.Rows
                Console.WriteLine(row("InstanceName"))
        Next
Next
Console.ReadLine()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDataSourceEnumerator Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDataSourceEnumerator Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleDataSourceEnumerator Class

The following tables list the members exposed by OracleDataSourceEnumerator.

Public Constructors

 | Name | Description
public Constructor | OracleDataSourceEnumerator Constructor | Initializes a new instance of the OracleDataSourceEnumerator class.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleDataSourceEnumerator.
Top

Public Methods

 | Name | Description
public Method | GetDataSources | Overloaded. Overridden. Retrieves a DataTable containing information about all TNS aliases described in the default Oracle home.
Top

See Also

Reference

OracleDataSourceEnumerator Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataSourceEnumerator Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSourceEnumerator Class : OracleDataSourceEnumerator Constructor

Initializes a new instance of the OracleDataSourceEnumerator class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleDataSourceEnumerator()

Remarks

The base constructor initializes all fields to their default values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSourceEnumerator Class
OracleDataSourceEnumerator Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDataSourceEnumerator Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSourceEnumerator Class

For a list of all members of this type, see OracleDataSourceEnumerator members.

Public Methods

 | Name | Description
public Method | GetDataSources | Overloaded. Overridden. Retrieves a DataTable containing information about all TNS aliases described in the default Oracle home.
Top

See Also

Reference

OracleDataSourceEnumerator Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataSources Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSourceEnumerator Class : GetDataSources Method

Retrieves a DataTable containing information about all TNS aliases described in the default Oracle home.

Overload List

Overload | Description
GetDataSources() | Retrieves a DataTable containing information about all TNS aliases described in the default Oracle home.
GetDataSources(String) | Retrieves a DataTable containing information about all TNS aliases described in the specified Oracle home.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSourceEnumerator Class
OracleDataSourceEnumerator Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataSources() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSourceEnumerator Class > GetDataSources Method : GetDataSources() Method

Retrieves a DataTable containing information about all TNS aliases described in the default Oracle home.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides NotOverridable Function GetDataSources() As DataTable
C#
public override DataTable GetDataSources()

Return Value

A DataTable containing information about all TNS aliases described in the default Oracle home.

Remarks

This method returns a DataTable with the following columns:
Column | Description
InstanceName | Description
ServerName | The name of the Oracle server.
ServiceName | The Oracle service name (SID)
Protocol | The protocol to use for connection.
Port | The port to connect to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSourceEnumerator Class
OracleDataSourceEnumerator Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDataSources(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSourceEnumerator Class > GetDataSources Method : GetDataSources(String) Method

homeName
Name of the Oracle home to read TNS aliases from.
Retrieves a DataTable containing information about all TNS aliases described in the specified Oracle home.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDataSources( _
   ByVal homeName As String _
) As DataTable
C#
public DataTable GetDataSources(
   string homeName
)

Parameters

homeName
Name of the Oracle home to read TNS aliases from.

Return Value

A DataTable containing information about all TNS aliases described in the specified Oracle home.

Remarks

This method returns a DataTable with the following columns:
Column | Description
InstanceName | Description
ServerName | The name of the Oracle server.
ServiceName | The Oracle service name (SID)
Protocol | The protocol to use for connection.
Port | The port to connect to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSourceEnumerator Class
OracleDataSourceEnumerator Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDataSourceEnumerator Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSourceEnumerator Class

For a list of all members of this type, see OracleDataSourceEnumerator members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleDataSourceEnumerator.
Top

See Also

Reference

OracleDataSourceEnumerator Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Instance Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataSourceEnumerator Class : Instance Property

Returns the instance of OracleDataSourceEnumerator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As OracleDataSourceEnumerator
C#
public static OracleDataSourceEnumerator Instance {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataSourceEnumerator Class
OracleDataSourceEnumerator Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataTable Class

Represents a single object that provides all of the functionality needed to retrieve and manipulate data from an Oracle data source.

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Data.DataTable
Devart.Common.DbDataTable
Devart.Data.Oracle.OracleDataTable

Syntax

Visual Basic (Declaration)
Public Class OracleDataTable
   Inherits Devart.Common.DbDataTable
   Implements IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, ITypedList, IDisposable, IServiceProvider, ISerializable, IXmlSerializable
C#
public class OracleDataTable : Devart.Common.DbDataTable, IComponent, IListSource, ISupportInitialize, ISupportInitializeNotification, ITypedList, IDisposable, IServiceProvider, ISerializable, IXmlSerializable

Remarks

The OracleDataTable class extends the Devart.Common.DbDataTable class to provide a single object that can be used to access and update data from a data source. Actually, OracleDataTable replaces Devart.Data.Oracle.OracleConnection, OracleCommand, OracleDataAdapter, and OracleCommandBuilder classes with all-in-one class. When a OracleDataTable object is created, the default values of its constituent parts are set to reasonable defaults, meaning that the programmer can create a single object and immediately use it to retrieve and manipulate data from a data source.

By using OracleDataTable you can avoid explicit creation of Devart.Data.Oracle.OracleConnection and OracleCommand objects. When appropriate form of constructor is used, these objects are created automatically when you retrieve data from a data source. It allows you to cut down the size of the written code.

OracleDataTable allows you to automate loading of subsets of data either by selecting P:Devart.Common.DbTable.StartRecord and MaxRecords properties or by using Fill or FillPage methods that support passing parameter values into the query text.

The OracleDataTable class is designed to employ both connected and disconnected data access models. It also provides functionality for asynchronous fill operations.

The OracleDataTable class can be fully adjusted at design-time. You may retrieve data at design-time from a data source by setting P:Devart.Common.DbTable.Active property to true.

For more information on advanced features of OracleDataTable please refer to topic OracleDataTable Advanced Features.

This class supports cross-form data binding with the InterForm Technology.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

ExecutePageReader method puts on following restrictions on the executable statement:

- you cannot execute stored procedures and PL/SQL blocks;

- you may specify only SQL statement that can be placed into the subquery.

To use ExecutePageReader method it is recommended to optimize a query for retrieving a first row, otherwise using this method is ineffective.

Note that OracleDataTable supports advanced data binding for such Oracle objects as nested tables, varrays, and Oracle objects. Use DataSource and DataMember properties of DataGrid to render OracleTable, OracleArray, and OracleObject objects.

Example

This sample shows easiness of use of OracleDataTable. The sample creates a OracleDataTable object, passing it SQL query text and connection string, retrieves data from a table and modifies it. Content of the table is printed to console then. Notice that no other component needs to be created by programmer.
C#csharp Copy Code
public void UseDataTable()
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept",
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  try
  {
    myDataTable.FetchAll = true;
        myDataTable.Active = true;
    myDataTable.Rows[3]["DName"] = "Researches";
    Console.WriteLine(myDataTable.Update()+" rows updated.");
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable()
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Try
    myDataTable.FetchAll = True
        myDataTable.Active = True
    myDataTable.Rows(3)("DName") = "Researches"
    Console.WriteLine(myDataTable.Update() & " rows updated.")
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDataTable Members
Devart.Data.Oracle Namespace
OracleConnection Class
OracleDataReader Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDataTable Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleDataTable Class

The following tables list the members exposed by OracleDataTable.

Public Constructors

 | Name | Description
public Constructor | OracleDataTable Constructor | Overloaded. Initializes a new instance of the OracleDataTable class.Initializes a new instance of the OracleDataTable class.
Top

Public Properties

 | Name | Description
public Property | Active | Gets or sets whether a Devart.Common.DbDataTable is filled with data from a data source. (Inherited from Devart.Common.DbDataTable)
public Property | CachedUpdates | Enables or disables cached updates mode. (Inherited from Devart.Common.DbDataTable)
public Property | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from System.Data.DataTable)
public Property | ChildRelations | Gets the collection of child relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Columns | Gets the collection of columns that belong to this table. (Inherited from Devart.Common.DbDataTable)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the Devart.Common.DbDataTable. (Inherited from Devart.Common.DbDataTable)
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used to connect to the data source.
public Property | Constraints | Gets the collection of constraints maintained by this table. (Inherited from Devart.Common.DbDataTable)
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSet | Gets the System.Data.DataSet to which this table belongs. (Inherited from System.Data.DataTable)
public Property | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from System.Data.DataTable)
public Property | DeleteCommand | Gets or sets an Oracle statement to delete records from the data set.
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from System.Data.DataTable)
public Property | ExtendedProperties | Gets the collection of customized user information. (Inherited from System.Data.DataTable)
public Property | FetchAll | Determines whether data is requested from server entirely or partially. (Inherited from Devart.Common.DbDataTable)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the System.Data.DataSet to which the table belongs. (Inherited from System.Data.DataTable)
public Property | IdentityInsert | Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.
public Property | IdentityUpdate | Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.
public Property | InsertCommand | Gets or sets an Oracle statement to insert new records into the data source.
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataTable)
public Property | MaxRecords | Gets or sets max number of records to fetch starting from Devart.Common.DbDataTable.StartRecord. (Inherited from Devart.Common.DbDataTable)
public Property | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from System.Data.DataTable)
public Property | MissingSchemaAction | Determines the action to take when existing DataSet schema does not match incoming data. (Inherited from Devart.Common.DbDataTable)
public Property | Name | Gets or sets name of the component. (Inherited from Devart.Common.DbDataTable)
public Property | Namespace | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | NonBlocking | Gets or sets data request mode. (Inherited from Devart.Common.DbDataTable)
public Property | ObjectView | Indicates how Oracle objects are represented in DataSet and visual grids like DataGrid.
public Property | Owner | Gets or sets form that the component resides on. (Inherited from Devart.Common.DbDataTable)
public Property | ParentRelation | Gets or sets a Devart.Common.ParentDataRelation object that is used for server side master-detail relation. (Inherited from Devart.Common.DbDataTable)
public Property | ParentRelations | Gets the collection of parent relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Prefix | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from Devart.Common.DbDataTable)
public Property | QueryRecordCount | Determines whether Devart.Common.DbDataTable should perfrom additional request to determine quantity of records in the result set. (Inherited from Devart.Common.DbDataTable)
public Property | Quoted | Gets or sets whether the Devart.Common.DbDataTable quotes all the names of data source objects. (Inherited from Devart.Common.DbDataTable)
public Property | ReadLobMode | Determines how LOB data is fetched and represented.
public Property | RecordCount | Gets number of rows in the result set. (Inherited from Devart.Common.DbDataTable)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the Devart.Common.DbDataTable should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbDataTable)
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the Devart.Common.DbDataTable used during remoting. (Inherited from Devart.Common.DbDataTable)
public Property | ReturnProviderSpecificTypes | Determines whether to use provider-specific types whenever possible. (Inherited from Devart.Common.DbDataTable)
public Property | Rows | Gets the collection of rows that belong to this table. (Inherited from System.Data.DataTable)
public Property | SchemaTable | Gets the schema table corresponding to the Devart.Common.DbDataTable.SelectCommand query. (Inherited from Devart.Common.DbDataTable)
public Property | SelectCommand | Gets or sets an Oracle statement used to select records in the data source.
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | SplitObjects | Determines how attributes of Oracle objects are stored and represented in OracleDataTable.
public Property | StartRecord | Gets or sets record number to start. (Inherited from Devart.Common.DbDataTable)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the Devart.Common.DbDataTable.Rows collection. (Inherited from Devart.Common.DbDataTable)
public Property | TableMapping | Gets a System.Data.Common.DataTableMapping object that provides the master mapping between a source table and a OracleDataTable.
public Property | TableName | Gets or sets the name of the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch. (Inherited from Devart.Common.DbDataTable)
public Property | UpdateCommand | Gets or sets an Oracle statement used to update records in the data source.
public Property | UpdatingFields | Gets or sets string containing list of field names used to generate update commands.
public Property | UpdatingKeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
Top

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this table since the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | BeginFill | Starts an asynchronous invocation of the Devart.Common.DbDataTable.Fill method. (Inherited from Devart.Common.DbDataTable)
public Method | BeginInit | Begins the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | BeginLoadData | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from System.Data.DataTable)
public Method | CancelFetch | Stops asynchronous fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Clear | Clears Devart.Common.DbDataTable and stops Fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Clone | Clones the structure of the System.Data.DataTable, including all System.Data.DataTable schemas and constraints. (Inherited from System.Data.DataTable)
public Method | Close | Disconnects Devart.Common.DbDataTable from the data source and frees server resources allocated for the query. (Inherited from Devart.Common.DbDataTable)
public Method | Compute | Computes the given expression on the current rows that pass the filter criteria. (Inherited from System.Data.DataTable)
public Method | Copy | Copies both the structure and data for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | CreateDataReader | Returns a System.Data.DataTableReader corresponding to the data within this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndFill | Ends an asynchronous invocation of the Devart.Common.DbDataTable.Fill method. (Inherited from Devart.Common.DbDataTable)
public Method | EndInit | Ends the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | EndLoadData | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from System.Data.DataTable)
public Method | Fill | Overloaded. Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataTable with rows from the data source. (Inherited from Devart.Common.DbDataTable)
public Method | FillPage | Overloaded. Overridden. Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.
public Method | FillSchema | Configures the schema to match that in the data source. (Inherited from Devart.Common.DbDataTable)
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataTable that contains all changes made to it since it was loaded or System.Data.DataTable.AcceptChanges was last called. (Inherited from System.Data.DataTable)
public Method | GetErrors | Gets an array of System.Data.DataRow objects that contain errors. (Inherited from System.Data.DataTable)
public Method | GetItemProperties | Used internally.
public Method | GetListName | Used internally.
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | ImportRow | Copies a System.Data.DataRow into a System.Data.DataTable, preserving any property settings, as well as original and current values. (Inherited from System.Data.DataTable)
public Method | Load | Overloaded. Fills a System.Data.DataTable with values from a data source using the supplied System.Data.IDataReader. If the System.Data.DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from System.Data.DataTable)
public Method | LoadDataRow | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from System.Data.DataTable)
public Method | Merge | Overloaded. Merge the specified System.Data.DataTable with the current System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | NewRow | Creates a new System.Data.DataRow with the same schema as the table. (Inherited from System.Data.DataTable)
public Method | Open | Fetches data and sets the Devart.Common.DbDataTable.Active property to true. (Inherited from Devart.Common.DbDataTable)
public Method | Read | Reads the next data row when Devart.Common.DbDataTable operates in connected model. (Inherited from Devart.Common.DbDataTable)
public Method | ReadComplete | Fills a row with data not fetched in the initial fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | ReadXml | Overloaded. Reads XML schema and data into the System.Data.DataTable using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | ReadXmlSchema | Overloaded. Reads an XML schema into the System.Data.DataTable using the specified stream. (Inherited from System.Data.DataTable)
public Method | RefreshRow | (Inherited from Devart.Common.DbDataTable)
public Method | RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | Reset | Resets the System.Data.DataTable to its original state. Reset removes all data, indexes, relations, and columns of the table. If a DataSet includes a DataTable, the table will still be part of the DataSet after the table is reset. (Inherited from System.Data.DataTable)
public Method | Select | Overloaded. Gets an array of DataRow objects. (Inherited from Devart.Common.DbDataTable)
public Method | SuspendFill | Overloaded. Suspends asynchronous fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Update | Overridden. Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | UpdateRows | Executes the appropriate commands to delete, insert, or update the specified rows in the data source. (Inherited from Devart.Common.DbDataTable)
public Method | WriteXml | Overloaded. Writes the current contents of the System.Data.DataTable as XML using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | WriteXmlSchema | Overloaded. Writes the current data structure of the System.Data.DataTable as an XML schema to the specified stream. (Inherited from System.Data.DataTable)
Top

Public Events

 | Name | Description
public Event | ColumnChanged | Occurs after a value has been changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | ColumnChanging | Occurs when a value is being changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Devart.Common.DbDataTable)
public Event | FetchFinished | Occurs when a result set is completely fetched. (Inherited from Devart.Common.DbDataTable)
public Event | FillError | Occurs when an error is raised during a fill operation. (Inherited from Devart.Common.DbDataTable)
public Event | Initialized | Occurs after the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Event | RowChanged | Occurs after a System.Data.DataRow has been changed successfully. (Inherited from System.Data.DataTable)
public Event | RowChanging | Occurs when a System.Data.DataRow is changing. (Inherited from System.Data.DataTable)
public Event | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from System.Data.DataTable)
public Event | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from System.Data.DataTable)
public Event | RowFetched | Occurs when another row is completely fetched. (Inherited from Devart.Common.DbDataTable)
public Event | RowUpdated | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | RowUpdating | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | TableCleared | Occurs after a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableClearing | Occurs when a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableNewRow | Occurs when a new System.Data.DataRow is inserted. (Inherited from System.Data.DataTable)
Top

See Also

Reference

OracleDataTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : OracleDataTable Constructor

Initializes a new instance of the OracleDataTable class.Initializes a new instance of the OracleDataTable class.

Overload List

Overload | Description
OracleDataTable Constructor() | Initializes a new instance of the OracleDataTable class.
OracleDataTable Constructor(String) | Initializes a new instance of the OracleDataTable class.
OracleDataTable Constructor(OracleCommand) | Initializes a new instance of the OracleDataTable class.
OracleDataTable Constructor(OracleCommand,OracleConnection) | Initializes a new instance of the OracleDataTable class.
OracleDataTable Constructor(String,OracleConnection) | Initializes a new instance of the OracleDataTable class.
OracleDataTable Constructor(String,String) | Initializes a new instance of the OracleDataTable class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor()

Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleDataTable()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor(String)

tableName
Name of the table to work with.
Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As String _
)
C#
public OracleDataTable(
   string tableName
)

Parameters

tableName
Name of the table to work with.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor(OracleCommand)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor(OracleCommand)

selectCommand
A Devart.Data.Oracle.OracleCommand object used to select rows from the data source.
Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommand As OracleCommand _
)
C#
public OracleDataTable(
   OracleCommand selectCommand
)

Parameters

selectCommand
A Devart.Data.Oracle.OracleCommand object used to select rows from the data source.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept",myConnection);
  OracleDataTable myDataTable = new OracleDataTable(myCommand);
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept", myConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable(myCommand)
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor(OracleCommand,OracleConnection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor(OracleCommand,OracleConnection)

selectCommand
A Devart.Data.Oracle.OracleCommand object used to select rows from the data source.
connection
A OracleConnection used to connect to the data source.
Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommand As OracleCommand, _
   ByVal connection As OracleConnection _
)
C#
public OracleDataTable(
   OracleCommand selectCommand,
   OracleConnection connection
)

Parameters

selectCommand
A Devart.Data.Oracle.OracleCommand object used to select rows from the data source.
connection
A OracleConnection used to connect to the data source.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept");
  OracleDataTable myDataTable = new OracleDataTable(myCommand,myConnection);
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept")
  Dim myDataTable As OracleDataTable = New OracleDataTable(myCommand, myConnection)
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor(String,OracleConnection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor(String,OracleConnection)

selectCommandText
The text of the selection command.
connection
A OracleConnection used to connect to the data source.
Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommandText As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleDataTable(
   string selectCommandText,
   OracleConnection connection
)

Parameters

selectCommandText
The text of the selection command.
connection
A OracleConnection used to connect to the data source.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept", myConnection);
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", myConnection)
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDataTable Constructor(String,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class > OracleDataTable Constructor : OracleDataTable Constructor(String,String)

selectCommandText
The text of the selection command.
connectionString
Connection string used to connect to the data source.
Initializes a new instance of the OracleDataTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal selectCommandText As String, _
   ByVal connectionString As String _
)
C#
public OracleDataTable(
   string selectCommandText,
   string connectionString
)

Parameters

selectCommandText
The text of the selection command.
connectionString
Connection string used to connect to the data source.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable()
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept",
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable()
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDataTable Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataTable Class

For a list of all members of this type, see OracleDataTable members.

Public Methods

 | Name | Description
public Method | AcceptChanges | Commits all the changes made to this table since the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | BeginFill | Starts an asynchronous invocation of the Devart.Common.DbDataTable.Fill method. (Inherited from Devart.Common.DbDataTable)
public Method | BeginInit | Begins the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | BeginLoadData | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from System.Data.DataTable)
public Method | CancelFetch | Stops asynchronous fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Clear | Clears Devart.Common.DbDataTable and stops Fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Clone | Clones the structure of the System.Data.DataTable, including all System.Data.DataTable schemas and constraints. (Inherited from System.Data.DataTable)
public Method | Close | Disconnects Devart.Common.DbDataTable from the data source and frees server resources allocated for the query. (Inherited from Devart.Common.DbDataTable)
public Method | Compute | Computes the given expression on the current rows that pass the filter criteria. (Inherited from System.Data.DataTable)
public Method | Copy | Copies both the structure and data for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | CreateDataReader | Returns a System.Data.DataTableReader corresponding to the data within this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | Dispose | Releases all resources used by the System.ComponentModel.MarshalByValueComponent. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | EndFill | Ends an asynchronous invocation of the Devart.Common.DbDataTable.Fill method. (Inherited from Devart.Common.DbDataTable)
public Method | EndInit | Ends the initialization of a System.Data.DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from System.Data.DataTable)
public Method | EndLoadData | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from System.Data.DataTable)
public Method | Fill | Overloaded. Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataTable with rows from the data source. (Inherited from Devart.Common.DbDataTable)
public Method | FillPage | Overloaded. Overridden. Fills the System.Data.DataTable.Rows collection of the Devart.Common.DbDataTable with rows from the data source starting at the row indicated by startRecord and including up to the number of rows indicated by maxRecords.
public Method | FillSchema | Configures the schema to match that in the data source. (Inherited from Devart.Common.DbDataTable)
public Method | GetChanges | Overloaded. Gets a copy of the System.Data.DataTable that contains all changes made to it since it was loaded or System.Data.DataTable.AcceptChanges was last called. (Inherited from System.Data.DataTable)
public Method | GetErrors | Gets an array of System.Data.DataRow objects that contain errors. (Inherited from System.Data.DataTable)
public Method | GetItemProperties | Used internally.
public Method | GetListName | Used internally.
public Method | GetObjectData | Populates a serialization information object with the data needed to serialize the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | GetService | Gets the implementer of the System.IServiceProvider. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Method | ImportRow | Copies a System.Data.DataRow into a System.Data.DataTable, preserving any property settings, as well as original and current values. (Inherited from System.Data.DataTable)
public Method | Load | Overloaded. Fills a System.Data.DataTable with values from a data source using the supplied System.Data.IDataReader. If the System.Data.DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from System.Data.DataTable)
public Method | LoadDataRow | Overloaded. Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from System.Data.DataTable)
public Method | Merge | Overloaded. Merge the specified System.Data.DataTable with the current System.Data.DataTable. (Inherited from System.Data.DataTable)
public Method | NewRow | Creates a new System.Data.DataRow with the same schema as the table. (Inherited from System.Data.DataTable)
public Method | Open | Fetches data and sets the Devart.Common.DbDataTable.Active property to true. (Inherited from Devart.Common.DbDataTable)
public Method | Read | Reads the next data row when Devart.Common.DbDataTable operates in connected model. (Inherited from Devart.Common.DbDataTable)
public Method | ReadComplete | Fills a row with data not fetched in the initial fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | ReadXml | Overloaded. Reads XML schema and data into the System.Data.DataTable using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | ReadXmlSchema | Overloaded. Reads an XML schema into the System.Data.DataTable using the specified stream. (Inherited from System.Data.DataTable)
public Method | RefreshRow | (Inherited from Devart.Common.DbDataTable)
public Method | RejectChanges | Rolls back all changes that have been made to the table since it was loaded, or the last time System.Data.DataTable.AcceptChanges was called. (Inherited from System.Data.DataTable)
public Method | Reset | Resets the System.Data.DataTable to its original state. Reset removes all data, indexes, relations, and columns of the table. If a DataSet includes a DataTable, the table will still be part of the DataSet after the table is reset. (Inherited from System.Data.DataTable)
public Method | Select | Overloaded. Gets an array of DataRow objects. (Inherited from Devart.Common.DbDataTable)
public Method | SuspendFill | Overloaded. Suspends asynchronous fill operation. (Inherited from Devart.Common.DbDataTable)
public Method | Update | Overridden. Executes the appropriate commands to delete, insert, or update rows in the data source.
public Method | UpdateRows | Executes the appropriate commands to delete, insert, or update the specified rows in the data source. (Inherited from Devart.Common.DbDataTable)
public Method | WriteXml | Overloaded. Writes the current contents of the System.Data.DataTable as XML using the specified System.IO.Stream. (Inherited from System.Data.DataTable)
public Method | WriteXmlSchema | Overloaded. Writes the current data structure of the System.Data.DataTable as an XML schema to the specified stream. (Inherited from System.Data.DataTable)
Top

See Also

Reference

OracleDataTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetItemProperties Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : GetItemProperties Method

listAccessors
Used internally.

Syntax

Visual Basic (Declaration)
Public Function GetItemProperties( _
   ByVal listAccessors() As PropertyDescriptor _
) As PropertyDescriptorCollection
C#
public PropertyDescriptorCollection GetItemProperties(
   PropertyDescriptor[] listAccessors
)

Parameters

listAccessors

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetListName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : GetListName Method

listAccessors
Used internally.

Syntax

Visual Basic (Declaration)
Public Function GetListName( _
   ByVal listAccessors() As PropertyDescriptor _
) As String
C#
public string GetListName(
   PropertyDescriptor[] listAccessors
)

Parameters

listAccessors

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Update Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : Update Method

Executes the appropriate commands to delete, insert, or update rows in the data source.

Syntax

Visual Basic (Declaration)
Public Overrides Function Update() As Integer
C#
public override int Update()

Return Value

The number of rows successfully updated from the OracleDataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDataTable Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataTable Class

For a list of all members of this type, see OracleDataTable members.

Public Properties

 | Name | Description
public Property | Active | Gets or sets whether a Devart.Common.DbDataTable is filled with data from a data source. (Inherited from Devart.Common.DbDataTable)
public Property | CachedUpdates | Enables or disables cached updates mode. (Inherited from Devart.Common.DbDataTable)
public Property | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from System.Data.DataTable)
public Property | ChildRelations | Gets the collection of child relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Columns | Gets the collection of columns that belong to this table. (Inherited from Devart.Common.DbDataTable)
public Property | ConflictOption | Specifies which System.Data.ConflictOption is to be used by the Devart.Common.DbDataTable. (Inherited from Devart.Common.DbDataTable)
public Property | Connection | Gets or sets the Devart.Data.Oracle.OracleConnection used to connect to the data source.
public Property | Constraints | Gets the collection of constraints maintained by this table. (Inherited from Devart.Common.DbDataTable)
public Property | Container | Gets the container for the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DataSet | Gets the System.Data.DataSet to which this table belongs. (Inherited from System.Data.DataTable)
public Property | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from System.Data.DataTable)
public Property | DeleteCommand | Gets or sets an Oracle statement to delete records from the data set.
public Property | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from System.Data.DataTable)
public Property | ExtendedProperties | Gets the collection of customized user information. (Inherited from System.Data.DataTable)
public Property | FetchAll | Determines whether data is requested from server entirely or partially. (Inherited from Devart.Common.DbDataTable)
public Property | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the System.Data.DataSet to which the table belongs. (Inherited from System.Data.DataTable)
public Property | IdentityInsert | Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.
public Property | IdentityUpdate | Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.
public Property | InsertCommand | Gets or sets an Oracle statement to insert new records into the data source.
public Property | IsInitialized | Gets a value that indicates whether the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Property | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from System.Data.DataTable)
public Property | MaxRecords | Gets or sets max number of records to fetch starting from Devart.Common.DbDataTable.StartRecord. (Inherited from Devart.Common.DbDataTable)
public Property | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from System.Data.DataTable)
public Property | MissingSchemaAction | Determines the action to take when existing DataSet schema does not match incoming data. (Inherited from Devart.Common.DbDataTable)
public Property | Name | Gets or sets name of the component. (Inherited from Devart.Common.DbDataTable)
public Property | Namespace | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | NonBlocking | Gets or sets data request mode. (Inherited from Devart.Common.DbDataTable)
public Property | ObjectView | Indicates how Oracle objects are represented in DataSet and visual grids like DataGrid.
public Property | Owner | Gets or sets form that the component resides on. (Inherited from Devart.Common.DbDataTable)
public Property | ParentRelation | Gets or sets a Devart.Common.ParentDataRelation object that is used for server side master-detail relation. (Inherited from Devart.Common.DbDataTable)
public Property | ParentRelations | Gets the collection of parent relations for this System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | Prefix | Gets or sets the namespace for the XML representation of the data stored in the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from Devart.Common.DbDataTable)
public Property | QueryRecordCount | Determines whether Devart.Common.DbDataTable should perfrom additional request to determine quantity of records in the result set. (Inherited from Devart.Common.DbDataTable)
public Property | Quoted | Gets or sets whether the Devart.Common.DbDataTable quotes all the names of data source objects. (Inherited from Devart.Common.DbDataTable)
public Property | ReadLobMode | Determines how LOB data is fetched and represented.
public Property | RecordCount | Gets number of rows in the result set. (Inherited from Devart.Common.DbDataTable)
public Property | RefreshingFields | Gets or sets list of fields whose values should be retrieved after a DML statement execution.
public Property | RefreshMode | Gets or sets a value that indicates whether and how the Devart.Common.DbDataTable should retrieve field values adjusted by server after an update. (Inherited from Devart.Common.DbDataTable)
public Property | RemotingFormat | Gets or sets a System.Data.SerializationFormat for the Devart.Common.DbDataTable used during remoting. (Inherited from Devart.Common.DbDataTable)
public Property | ReturnProviderSpecificTypes | Determines whether to use provider-specific types whenever possible. (Inherited from Devart.Common.DbDataTable)
public Property | Rows | Gets the collection of rows that belong to this table. (Inherited from System.Data.DataTable)
public Property | SchemaTable | Gets the schema table corresponding to the Devart.Common.DbDataTable.SelectCommand query. (Inherited from Devart.Common.DbDataTable)
public Property | SelectCommand | Gets or sets an Oracle statement used to select records in the data source.
public Property | Site | Gets or sets the site of the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Property | SplitObjects | Determines how attributes of Oracle objects are stored and represented in OracleDataTable.
public Property | StartRecord | Gets or sets record number to start. (Inherited from Devart.Common.DbDataTable)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the Devart.Common.DbDataTable.Rows collection. (Inherited from Devart.Common.DbDataTable)
public Property | TableMapping | Gets a System.Data.Common.DataTableMapping object that provides the master mapping between a source table and a OracleDataTable.
public Property | TableName | Gets or sets the name of the System.Data.DataTable. (Inherited from System.Data.DataTable)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch. (Inherited from Devart.Common.DbDataTable)
public Property | UpdateCommand | Gets or sets an Oracle statement used to update records in the data source.
public Property | UpdatingFields | Gets or sets string containing list of field names used to generate update commands.
public Property | UpdatingKeyFields | Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.
public Property | UpdatingTable | Gets or sets table name to generate update statements for.
Top

See Also

Reference

OracleDataTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : Connection Property

Gets or sets the OracleConnection used to connect to the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property Connection As OracleConnection
C#
public new OracleConnection Connection {get; set;}

Property Value

A OracleConnection object which provides a connection to the data source.

Remarks

This property is used by DeleteCommand, InsertCommand, SelectCommand, and UpdateCommand, in case when these properties do not have own created connection.

This property supports the InterForm technology.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable();
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = new OracleCommand("SELECT * FROM Test.Dept");
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = New OracleCommand("SELECT * FROM Test.Dept")
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : DeleteCommand Property

Gets or sets an Oracle statement to delete records from the data set.

Syntax

Visual Basic (Declaration)
Public Shadows Property DeleteCommand As OracleCommand
C#
public new OracleCommand DeleteCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to delete records in the data source that correspond to deleted rows in the System.Data.DataSet.

Remarks

Typically you do not need to use DeleteCommand when working with OracleDataTable. All simple update operations are performed automatically using embedded CommandBuilder. DeleteCommand enables you to perform specific operations like shown in the sample below.

DeleteCommand uses its own Connection if it is created. Otherwise DeleteCommand uses Connection.

Example

This sample shows how to modify and display data using OracleDataTable.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept", myConnection);
  try
  {
    myDataTable.Active = true;
    myDataTable.Rows[1].Delete();
    myDataTable.DeleteCommand = new OracleCommand("DELETE FROM Test.Emp WHERE DeptNo = :DeptNo;DELETE FROM Test.Dept WHERE DeptNo = :DeptNo", myConnection);
    myDataTable.DeleteCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original;
    myDataTable.Update();

    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", myConnection)
  Try
    myDataTable.Active = True
    myDataTable.Rows(2).Delete()
    myDataTable.DeleteCommand = New OracleCommand("DELETE FROM Test.Emp WHERE DeptNo = :DeptNo;DELETE FROM Test.Dept WHERE DeptNo = :DeptNo", myConnection)
    myDataTable.DeleteCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original
    myDataTable.Update()

    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
InsertCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IdentityInsert Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : IdentityInsert Property

Determines whether the row identity column value is database-generated or it is provided by DataSet when inserting the DataSet data into the database. This property is ignored if IdentityType for the identity column is None or GeneratedAlways.

Syntax

Visual Basic (Declaration)
Public Property IdentityInsert As Boolean
C#
public bool IdentityInsert {get; set;}

Property Value

If true, identity column values are inserted into the database for columns with OracleIdentityType equal to GeneratedByDefault or GeneratedByDefaultOnNull; otherwise they are not inserted. Default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IdentityUpdate Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : IdentityUpdate Property

Determines whether the row identity column value is database-generated or it is provided by DataSet when updating the DataSet data in the database. This property is ignored if OracleIdentityType for the identity column is None or GeneratedAlways.

Syntax

Visual Basic (Declaration)
Public Property IdentityUpdate As Boolean
C#
public bool IdentityUpdate {get; set;}

Property Value

If true, identity column values are inserted into the database for columns with OracleIdentityType equal to GeneratedByDefault or GeneratedByDefaultOnNull; otherwise they are not inserted. Default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : InsertCommand Property

Gets or sets an Oracle statement to insert new records into the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property InsertCommand As OracleCommand
C#
public new OracleCommand InsertCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to insert records in the data source that correspond to new rows in the System.Data.DataSet.

Remarks

InsertCommand uses its own Connection if it is created. Otherwise InsertCommand uses Connection.

Example

This sample shows how to modify and display data using OracleDataTable.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept", myConnection);
  try
  {
    myDataTable.Active = true;
    myDataTable.Rows.Add(new object[] {30,"Sales2"});
    myDataTable.InsertCommand = new OracleCommand("INSERT INTO Test.Dept (DeptNo, DName, Loc) " +
      "VALUES (:DeptNo, :DName, 'Unverified')", myConnection);
    myDataTable.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo");
    myDataTable.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName");
    Console.WriteLine(myDataTable.Update()+" rows updated.");
    myDataTable.Active = false;
    //Refresh the table to check custom updates
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", myConnection)
  Try
    myDataTable.Active = True
    Dim rowVals() As Object = {30, "Sales2"}
    myDataTable.Rows.Add(rowVals)
    myDataTable.InsertCommand = New OracleCommand("INSERT INTO Test.Dept (DeptNo, DName, Loc) " & _
        "VALUES (:DeptNo, :DName, 'Unverified')", myConnection)
    myDataTable.InsertCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo")
    myDataTable.InsertCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName")
    Console.WriteLine(myDataTable.Update() & " rows updated.")
    myDataTable.Active = False
    ' Refresh the table to check custom updates
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
DeleteCommand Property
SelectCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectView Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : ObjectView Property

Indicates how Oracle objects are represented in DataSet and visual grids like DataGrid.

Syntax

Visual Basic (Declaration)
Public Property ObjectView As Boolean
C#
public bool ObjectView {get; set;}

Property Value

If true, Oracle objects are shown as expandable secondary rows; otherwise the appearance depends on SplitObjects property.

Remarks

This feature is not supported in some grids, for example, GridView.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadLobMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : ReadLobMode Property

Determines how LOB data is fetched and represented.

Syntax

Visual Basic (Declaration)
Public Property ReadLobMode As ReadLobMode
C#
public ReadLobMode ReadLobMode {get; set;}

Property Value

One of ReadLobMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
ReadLobMode Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshingFields Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : RefreshingFields Property

Gets or sets list of fields whose values should be retrieved after a DML statement execution.

Syntax

Visual Basic (Declaration)
Public Shadows Property RefreshingFields As String
C#
public new string RefreshingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Remarks

This property is used in conjunction with Devart.Common.DbDataTable.RefreshMode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : SelectCommand Property

Gets or sets an Oracle statement used to select records in the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property SelectCommand As OracleCommand
C#
public new OracleCommand SelectCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand that is used during a fill operation to select records from the data source for placement in the System.Data.DataSet.

Remarks

SelectCommand uses its own Connection if it is created. Otherwise SelectCommand uses Connection.

This property supports the InterForm technology.

Example

This sample shows how to create a OracleDataTable and retrieve data from a table.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable();
  myDataTable.Connection = myConnection;
  myDataTable.SelectCommand = new OracleCommand("SELECT * FROM Test.Dept");
  try
  {
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable
  myDataTable.Connection = myConnection
  myDataTable.SelectCommand = New OracleCommand("SELECT * FROM Test.Dept")
  Try
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
DeleteCommand Property
InsertCommand Property
UpdateCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SplitObjects Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : SplitObjects Property

Determines how attributes of Oracle objects are stored and represented in OracleDataTable.

Syntax

Visual Basic (Declaration)
Public Property SplitObjects As Boolean
C#
public bool SplitObjects {get; set;}

Property Value

If true, Oracle objects are decomposed to individual attributes. Otherwise objects are represented as OracleObject.

Remarks

This property has no effect when ObjectView property is true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableMapping Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : TableMapping Property

Gets a System.Data.Common.DataTableMapping object that provides the master mapping between a source table and a OracleDataTable.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property TableMapping As DataTableMapping
C#
public new DataTableMapping TableMapping {get;}

Property Value

A System.Data.Common.DataTableMapping object that provides the master mapping between the returned records and the OracleDataTable.

Remarks

When reconciling changes, the OracleDataAdapter uses the System.Data.Common.DataTableMapping to associate the column names used by the data source with the column names used by the OracleDataTable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateCommand Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : UpdateCommand Property

Gets or sets an Oracle statement used to update records in the data source.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdateCommand As OracleCommand
C#
public new OracleCommand UpdateCommand {get; set;}

Property Value

A Devart.Data.Oracle.OracleCommand used during an update operation to update records in the data source that correspond to modified rows in the System.Data.DataSet.

Remarks

UpdateCommand uses its own Connection if it is created. Otherwise UpdateCommand uses Connection.

Example

This sample shows how to modify and display data using OracleDataTable.
C#csharp Copy Code
public void UseDataTable(OracleConnection myConnection)
{
  OracleDataTable myDataTable = new OracleDataTable("SELECT * FROM Test.Dept", myConnection);
  try
  {
    myDataTable.Active = true;
    myDataTable.Rows[3]["DName"] = "Researches";
    myDataTable.UpdateCommand = new OracleCommand("UPDATE Test.Dept SET DeptNo = :DeptNo, DName = :DName, Loc = 'Modified' " +
        "WHERE DeptNo = :oldDeptNo", myConnection);
    myDataTable.UpdateCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo");
    myDataTable.UpdateCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName");
    myDataTable.UpdateCommand.Parameters.Add("oldDeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original;
    Console.WriteLine(myDataTable.Update()+" rows updated.");
    myDataTable.Active = false;
    //Refresh the table to check custom updates
    myDataTable.Active = true;
    foreach(DataRow myRow in myDataTable.Rows)
    {
      foreach(DataColumn myCol in myDataTable.Columns)
      {
        Console.Write(myRow[myCol]+"\t");
      }
      Console.WriteLine();
    }
  }
  finally
  {
    myDataTable.Active = false;
  }
}
C#Visual Basic Copy Code
Public Sub UseDataTable(ByVal myConnection As OracleConnection)
  Dim myDataTable As OracleDataTable = New OracleDataTable("SELECT * FROM Test.Dept", myConnection)
  Try
    myDataTable.Active = True
    myDataTable.Rows(3)("DName") = "Researches"
    myDataTable.UpdateCommand = New OracleCommand("UPDATE Test.Dept SET DeptNo = :DeptNo, DName = :DName, Loc='Modified' " & _
        "WHERE DeptNo = :oldDeptNo", myConnection)
    myDataTable.UpdateCommand.Parameters.Add("DeptNo", OracleDbType.Integer, 0, "DeptNo")
    myDataTable.UpdateCommand.Parameters.Add("DName", OracleDbType.VarChar, 15, "DName")
    myDataTable.UpdateCommand.Parameters.Add("oldDeptNo", OracleDbType.Integer, 0, "DeptNo").SourceVersion = DataRowVersion.Original
    Console.WriteLine(myDataTable.Update() & " rows updated.")
    myDataTable.Active = False
    ' Refresh the table to check custom updates
    myDataTable.Active = True
    Dim myRow As DataRow
    Dim myCol As DataColumn
    For Each myRow In myDataTable.Rows
      For Each myCol In myDataTable.Columns
        Console.Write(myRow(myCol) & Chr(9))
      Next myCol
      Console.WriteLine()
    Next myRow
  Finally
    myDataTable.Active = False
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members
DeleteCommand Property
InsertCommand Property
SelectCommand Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingFields Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : UpdatingFields Property

Gets or sets string containing list of field names used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdatingFields As String
C#
public new string UpdatingFields {get; set;}

Property Value

The string containing list of field names separated by semicolon.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingKeyFields Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : UpdatingKeyFields Property

Gets or sets string containing list of key field names separated by semicolon. They are used to generate update commands.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdatingKeyFields As String
C#
public new string UpdatingKeyFields {get; set;}

Property Value

The string containing list of key field names separated by semicolon.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdatingTable Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : UpdatingTable Property

Gets or sets table name to generate update statements for.

Syntax

Visual Basic (Declaration)
Public Shadows Property UpdatingTable As String
C#
public new string UpdatingTable {get; set;}

Property Value

The name of the table.

Remarks

Use the UpdatingTable property to generate SQL statements for specific table in a complicated query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleDataTable Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataTable Class

For a list of all members of this type, see OracleDataTable members.

Public Events

 | Name | Description
public Event | ColumnChanged | Occurs after a value has been changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | ColumnChanging | Occurs when a value is being changed for the specified System.Data.DataColumn in a System.Data.DataRow. (Inherited from System.Data.DataTable)
public Event | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Devart.Common.DbDataTable)
public Event | FetchFinished | Occurs when a result set is completely fetched. (Inherited from Devart.Common.DbDataTable)
public Event | FillError | Occurs when an error is raised during a fill operation. (Inherited from Devart.Common.DbDataTable)
public Event | Initialized | Occurs after the System.Data.DataTable is initialized. (Inherited from System.Data.DataTable)
public Event | RowChanged | Occurs after a System.Data.DataRow has been changed successfully. (Inherited from System.Data.DataTable)
public Event | RowChanging | Occurs when a System.Data.DataRow is changing. (Inherited from System.Data.DataTable)
public Event | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from System.Data.DataTable)
public Event | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from System.Data.DataTable)
public Event | RowFetched | Occurs when another row is completely fetched. (Inherited from Devart.Common.DbDataTable)
public Event | RowUpdated | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | RowUpdating | Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.
public Event | TableCleared | Occurs after a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableClearing | Occurs when a System.Data.DataTable is cleared. (Inherited from System.Data.DataTable)
public Event | TableNewRow | Occurs when a new System.Data.DataRow is inserted. (Inherited from System.Data.DataTable)
Top

See Also

Reference

OracleDataTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowUpdated Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : RowUpdated Event

Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) after a command is executed against the data source. The attempt to update is made, so the event fires.

Syntax

Visual Basic (Declaration)
Public Event RowUpdated As OracleRowUpdatedEventHandler
C#
public event OracleRowUpdatedEventHandler RowUpdated

Event Data

The event handler receives an argument of type OracleRowUpdatedEventArgs containing data related to this event. The following OracleRowUpdatedEventArgs properties provide information specific to this event.

Property | Description
Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
Errors (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command was executed.
RecordsAffected (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
RowCount (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows processed in a batch of updated records.
StatementType (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property.
TableMapping (Inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.Common.DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

Remarks

The event handler receives an argument of type OracleRowUpdatedEventArgs containing data related to this event. The following OracleRowUpdatedEventArgs properties provide information specific to this event.
Property | Description
OracleRowUpdatedEventArgs.Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) is called.
Errors (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets any errors generated by the .NET data provider when the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet) was executed.
RecordsAffected (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement.
Row (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
StatementType (System.Data.Common.RowUpdatedEventArgs) | Gets the type of SQL statement executed.
Status (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the UpdateStatus of the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet).
TableMapping (inherited from System.Data.Common.RowUpdatedEventArgs) | Gets the DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

When using the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method, there are two events that occur per data row updated. The order of execution is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowUpdating Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDataTable Class : RowUpdating Event

Occurs during System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) before a command is executed against the data source. The attempt to update is made, so the event fires.

Syntax

Visual Basic (Declaration)
Public Event RowUpdating As OracleRowUpdatingEventHandler
C#
public event OracleRowUpdatingEventHandler RowUpdating

Event Data

The event handler receives an argument of type OracleRowUpdatingEventArgs containing data related to this event. The following OracleRowUpdatingEventArgs properties provide information specific to this event.

Property | Description
Command | Gets or sets the Devart.Data.Oracle.OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.
Errors (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command executes.
Row (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.DataRow that will be sent to the server as part of an insert, update, or delete operation.
StatementType (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets or sets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property.
TableMapping (Inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.Common.DataTableMapping to send through the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

Remarks

The event handler receives an argument of type OracleRowUpdatingEventArgs containing data related to this event. The following OracleRowUpdatingEventArgs properties provide information specific to this event.
Property | Description
OracleRowUpdatedEventArgs.Command | Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) is called.
Errors (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets any errors generated by the .NET data provider when the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet) was executed.
Row (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the System.Data.DataRow to sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).
StatementType (System.Data.Common.RowUpdatingEventArgs) | Gets the type of SQL statement to execute.
Status (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the UpdateStatus of the System.Data.Common.DbDataAdapter.Command(System.Data.DataSet).
TableMapping (inherited from System.Data.Common.RowUpdatingEventArgs) | Gets the DataTableMapping to sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet).

When using the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet) method, there are two events that occur per data row updated. The order of execution is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDataTable Class
OracleDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDependency Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDependency Class

Represents a dependency between an application and an Oracle database.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleDependency

Syntax

Visual Basic (Declaration)
Public Class OracleDependency
   Implements IDisposable
C#
public class OracleDependency : IDisposable

Remarks

The OracleDependency class enables the application to receive notifications about changes in some portions of data or database state. This feature is available since Oracle 10.2.0.2.

When you create an OracleDependency instance and add an OracleCommand object to it, a new OracleNotificationRequest is created, prepared, and assigned to the OracleCommand.Notification property. Upon the first execution of the OracleCommand, the OracleDependency object registers the notification and starts listening for messages from Oracle server on a port specified by the Port property. Every time a notification is received the OracleDependency fires the OracleDependency.OnChange event. For continuous notifications (OracleNotificationRequest.IsNotifiedOnce is false) the registration stops when the OracleNotificationRequest.Timeout is expired, OracleCommand is disposed, or current Oracle session is terminated.

This feature requires that the user has the appropriate privileges, specified with grant change notification to... statement.

This feature is not available in Direct mode.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is not available in Mobile Edition.

Example

To execute the following sample, you need that user Scott have the privilege to register change notifications. To grant him this privilege, the following script should be executed:

grant change notification to Scott

In the sample, the following actions are performed:

  1. an OracleDependency instance is registered for a simple select command;
  2. an insert command is executed, changing the result set associated with the select command;
  3. the notification is sent, it raises the OnChange event, which is then processed.
C#csharp Copy Code
static void Main(string[] args)
{
        // Open the connection
        OracleConnection connection = new OracleConnection
                ("Server = Ora; User Id = Scott; Password = tiger;");
        connection.Open();

        // Create the Select command retrieving all data from the Dept table.
        OracleCommand selectCommand = new OracleCommand("select * from dept", connection);

        // Create an OracleDependency object and set it to track the resul set returned by selectCommand.
        OracleDependency dependency = new OracleDependency(selectCommand);

        // Setting object-based change notification registration
        dependency.QueryBasedNotification = false;

        // When the IsNotifiedOnce property is true, only the first change
        // of the traced result set will generate a notification.
        // Otherwise, notifications will be sent on each change
        // during the selectCommand.Notification.Timeout period.
        selectCommand.Notification.IsNotifiedOnce = true;
        // Specifies whether notifications will contain information on rows changed.
        selectCommand.Notification.RowLevelDetails = true;

        // Set the event handler to the OnChange event.
        dependency.OnChange += new OnChangeEventHandler(OnDeptChange);

        // When the select command is executed at the first time, a notification
        // on changes of the corresponding result set is registered on the server.
        selectCommand.ExecuteReader();

        // Set and execute an insert command. The Dept table data will be changed,
        // and a notification will be sent, causing the OnChange event of the 'dependency' object.
        OracleCommand insertCommand = new OracleCommand
                ("insert into dept values (100, 'New department', 'Some location')", connection);
        insertCommand.ExecuteNonQuery();

        // Pause the current thread to process the event.
        Thread.Sleep(10000);

}

// A simple event handler to handle the OnChange event.
// Prints the change notification details.
static void OnDeptChange(Object sender, OracleNotificationEventArgs args)
{
        DataTable dt = args.Details;

        Console.WriteLine("The following database objects were changed:");
        foreach (string resource in args.ResourceNames)
                Console.WriteLine(resource);

        Console.WriteLine("\n Details:");
        Console.Write(new string('*', 80));
        for (int rows = 0; rows < dt.Rows.Count; rows++)
        {
                Console.WriteLine("Resource name: " + dt.Rows[rows].ItemArray[0]);
                string type = Enum.GetName(typeof(OracleNotificationInfo), dt.Rows[rows].ItemArray[1]);
                Console.WriteLine("Change type: " + type);
                Console.Write(new string('*', 80));
        }
}
C#Visual Basic Copy Code
Sub Main(ByVal args() As String)
        ' Open the connection
        Dim connection = New OracleConnection( _
                "Server = Ora; User Id = Scott; Password = tiger;")
        connection.Open()

        ' Create the Select command retrieving all data from the Dept table.
        Dim selectCommand = New OracleCommand("select * from dept", connection)

        ' Create an OracleDependency object and set it to track the resul set returned by selectCommand.
        Dim dependency As OracleDependency = New OracleDependency(selectCommand)

        ' Setting object-based change notification registration
        dependency.QueryBasedNotification = False

        ' When the IsNotifiedOnce property is true, only the first change
        ' of the traced result set will generate a notification.
        ' Otherwise, notifications will be sent on each change
        ' during the selectCommand.Notification.Timeout period.
        selectCommand.Notification.IsNotifiedOnce = True
        ' Specifies whether notifications will contain information on rows changed.
        selectCommand.Notification.RowLevelDetails = True

        ' Set the event handler to the OnChange event.
        AddHandler dependency.OnChange, AddressOf OnDeptChange

        ' When the select command is executed at the first time, a notification
        ' on changes of the corresponding result set is registered on the server.
        selectCommand.ExecuteReader()

        ' Set and execute an insert command. The Dept table data will be changed,
        ' and a notification will be sent, causing the OnChange event of the 'dependency' object.
        Dim insertCommand = New OracleCommand( _
                "insert into dept values (100, 'New department', 'Some location')", connection)
        insertCommand.ExecuteNonQuery()

        ' Pause the current thread to process the event.
        Thread.Sleep(10000)

End Sub

' A simple event handler to handle the OnChange event.
' Prints the change notification details.
Sub OnDeptChange(ByVal sender As Object, ByVal args As OracleNotificationEventArgs)
        Dim dt As DataTable = args.Details

        Console.WriteLine("The following database objects were changed:")
        For Each resource As String In args.ResourceNames
                Console.WriteLine(resource)
        Next

        Console.WriteLine(vbCrLf + "Details: ")
        Console.Write(New String("*", 80))

        For rows As Integer = 0 To dt.Rows.Count - 1
                Console.WriteLine("Resource name: " + dt.Rows(rows).ItemArray(0))
        Dim type As String = [Enum].GetName( _
                GetType(OracleNotificationInfo), dt.Rows(rows).ItemArray(1))
        Console.WriteLine("Change type: " + type)
        Console.Write(New String("*", 80))
        Next
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDependency Members
Devart.Data.Oracle Namespace
OracleNotificationRequest Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDependency Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleDependency Class

The following tables list the members exposed by OracleDependency.

Public Constructors

 | Name | Description
public Constructor | OracleDependency Constructor | Overloaded. Initializes a new instance of the OracleDependency class.
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Enabled | Specifies whether the application listens for database notifications.
static (Shared in Visual Basic) | Port | Gets or sets the port number that the notification listener listens on.
public Property | QueryBasedNotification | Specifies whether the change notification registration is object-based or query-based. By default, true.
Top

Public Methods

 | Name | Description
public Method | AddCommandDependency | Adds new OracleCommand object to the current OracleDependency instance.
public Method | Dispose | Releases all resources allocated by this object.
Top

Public Events

 | Name | Description
public Event | OnChange | Occurs when a database notification associated with the OracleDependency is received from the database.
Top

See Also

Reference

OracleDependency Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDependency Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : OracleDependency Constructor

Initializes a new instance of the OracleDependency class.

Overload List

Overload | Description
OracleDependency Constructor() | Initializes a new instance of the OracleDependency class.
OracleDependency Constructor(OracleCommand) | Initializes a new instance of the OracleDependency class and binds an Devart.Data.Oracle.OracleCommand object.
OracleDependency Constructor(OracleCommand,Boolean,Int32,Boolean) | Initializes a new instance of the OracleDependency class, binds an Devart.Data.Oracle.OracleCommand object, and adjusts some parameters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDependency Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class > OracleDependency Constructor : OracleDependency Constructor()

Initializes a new instance of the OracleDependency class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleDependency()

Remarks

This constructor uses the default values for OracleNotificationRequest properties. The OracleNotificationRequest.IsNotifiedOnce is set to true, OracleNotificationRequest.IsPersistent is set to false, and OracleNotificationRequest.Timeout is set to 50000 seconds. In other words, this overload creates a one-time notification request that is valid for approximately 14 hours.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDependency Constructor(OracleCommand)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class > OracleDependency Constructor : OracleDependency Constructor(OracleCommand)

cmd
An Devart.Data.Oracle.OracleCommand object to bind.
Initializes a new instance of the OracleDependency class and binds an Devart.Data.Oracle.OracleCommand object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cmd As OracleCommand _
)
C#
public OracleDependency(
   OracleCommand cmd
)

Parameters

cmd
An Devart.Data.Oracle.OracleCommand object to bind.

Remarks

The OracleDependency registers the notification for the attached Devart.Data.Oracle.OracleCommand object when either of its Execute methods is invoked.

This constructor uses the default values for OracleNotificationRequest properties. The OracleNotificationRequest.IsNotifiedOnce is set to true, OracleNotificationRequest.IsPersistent is set to false, and OracleNotificationRequest.Timeout is set to 50000 seconds. In other words, this overload creates a one-time notification request that is valid for approximately 14 hours.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDependency Constructor(OracleCommand,Boolean,Int32,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class > OracleDependency Constructor : OracleDependency Constructor(OracleCommand,Boolean,Int32,Boolean)

cmd
An Devart.Data.Oracle.OracleCommand object to bind.
isNotifiedOnce
true, if the registration is to be removed upon notification; otherwise, false.
timeout
Specifies the time in seconds that the registration remains alive.
isPersistent
true, if invalidation message should be queued persistently in the database before delivery; otherwise, false.
Initializes a new instance of the OracleDependency class, binds an Devart.Data.Oracle.OracleCommand object, and adjusts some parameters.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cmd As OracleCommand, _
   ByVal isNotifiedOnce As Boolean, _
   ByVal timeout As Integer, _
   ByVal isPersistent As Boolean _
)
C#
public OracleDependency(
   OracleCommand cmd,
   bool isNotifiedOnce,
   int timeout,
   bool isPersistent
)

Parameters

cmd
An Devart.Data.Oracle.OracleCommand object to bind.
isNotifiedOnce
true, if the registration is to be removed upon notification; otherwise, false.
timeout
Specifies the time in seconds that the registration remains alive.
isPersistent
true, if invalidation message should be queued persistently in the database before delivery; otherwise, false.

Remarks

The OracleDependency registers the notification for the attached Devart.Data.Oracle.OracleCommand object when either of its Execute methods is invoked.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members
Overload List
OracleNotificationRequest Class


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDependency Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDependency Class

For a list of all members of this type, see OracleDependency members.

Public Methods

 | Name | Description
public Method | AddCommandDependency | Adds new OracleCommand object to the current OracleDependency instance.
public Method | Dispose | Releases all resources allocated by this object.
Top

See Also

Reference

OracleDependency Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddCommandDependency Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : AddCommandDependency Method

cmd
A Devart.Data.Oracle.OracleCommand object to add.
Adds new Devart.Data.Oracle.OracleCommand object to the current OracleDependency instance.

Syntax

Visual Basic (Declaration)
Public Sub AddCommandDependency( _
   ByVal cmd As OracleCommand _
)
C#
public void AddCommandDependency(
   OracleCommand cmd
)

Parameters

cmd
A Devart.Data.Oracle.OracleCommand object to add.

Remarks

The AddCommandDependency method creates a new OracleNotificationRequest object and assigns it to the OracleCommand.Notification property. The values of OracleNotificationRequest.IsNotifiedOnce, OracleNotificationRequest.IsPersistent, and OracleNotificationRequest.Timeout properties of OracleNotificationRequest are inherited from OracleDependency, either default or specified in the constructor.

Many Devart.Data.Oracle.OracleCommand objects can be attached to single OracleDependency object, but same Devart.Data.Oracle.OracleCommand object cannot be used with several OracleDependency objects.

You can also bind an Devart.Data.Oracle.OracleCommand object using some of the OracleDependency constructors.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : Dispose() Method

Releases all resources allocated by this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDependency Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDependency Class

For a list of all members of this type, see OracleDependency members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Enabled | Specifies whether the application listens for database notifications.
static (Shared in Visual Basic) | Port | Gets or sets the port number that the notification listener listens on.
public Property | QueryBasedNotification | Specifies whether the change notification registration is object-based or query-based. By default, true.
Top

See Also

Reference

OracleDependency Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enabled Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : Enabled Property

Specifies whether the application listens for database notifications.

Syntax

Visual Basic (Declaration)
Public Shared Property Enabled As Boolean
C#
public static bool Enabled {get; set;}

Property Value

true, if listening to notifications is on. Otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Port Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : Port Property

Gets or sets the port number that the notification listener listens on.

Syntax

Visual Basic (Declaration)
Public Shared Property Port As Integer
C#
public static int Port {get; set;}

Property Value

The port number to listen on. If the port number is set to 0, a random port number is assigned for the listener when the listener is started.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueryBasedNotification Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : QueryBasedNotification Property

Specifies whether the change notification registration is object-based or query-based. By default, true.

Syntax

Visual Basic (Declaration)
Public Property QueryBasedNotification As Boolean
C#
public bool QueryBasedNotification {get; set;}

Property Value

If set to true, the change notification registration is query-based; otherwise it is object-based.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleDependency Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDependency Class

For a list of all members of this type, see OracleDependency members.

Public Events

 | Name | Description
public Event | OnChange | Occurs when a database notification associated with the OracleDependency is received from the database.
Top

See Also

Reference

OracleDependency Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OnChange Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : OnChange Event

Occurs when a database notification associated with the OracleDependency is received from the database.

Syntax

Visual Basic (Declaration)
Public Event OnChange As OnChangeEventHandler
C#
public event OnChangeEventHandler OnChange

Event Data

The event handler receives an argument of type OracleNotificationEventArgs containing data related to this event. The following OracleNotificationEventArgs properties provide information specific to this event.

Property | Description
Details | Gets detailed information about the current notification.
ResourceNames | Gets the database resources related to the current notification.
Type | Identifies the database event source for the notification.

Remarks

The information related to the notification is stored in the Devart.Data.Oracle.OracleNotificationEventArgs class. The OnChange event occurs if any result set associated with the dependency changes. This event also occurs for other actions related to database or registration status, such as database shutdowns and startups, or registration timeouts.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members
OracleNotificationEventArgs Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleError Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleError Class

Represents an Oracle error returned by the server.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleError

Syntax

Visual Basic (Declaration)
Public Class OracleError
C#
public class OracleError

Remarks

Use this class in conjunction with OracleErrorCollection and OracleException to obtain an Oracle error information. This class is often used when the user executes DML array binding operations to obtain multiply error information.

Example

In the following sample, we try to insert to the Dept table several rows with the same primary key. Provided that the table is empty, there should be an ORA-24381 error (errors in DML array) and three ORA-00001 errors (unique constraint violation) in OracleErrorCollection of the exception thrown.
C#csharp Copy Code
// Open a connection and configure a command inserting rows to the Dept table.
OracleConnection conn = new OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110");
conn.Open();

OracleCommand cmd = new OracleCommand("INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)", conn);

cmd.Parameters.Add("deptno_p", OracleDbType.Integer);
cmd.Parameters.Add("dname_p", OracleDbType.VarChar);
cmd.Parameters.Add("loc_p", OracleDbType.VarChar);

// Populate the parameter collection with arrays.
// Notice that the deptno_p parameter array consists of identical numbers.
cmd.Parameters["deptno_p"].Value = new int[] { 10, 10, 10, 10 };
cmd.Parameters["dname_p"].Value = new string[] {
   "ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS" };
cmd.Parameters["loc_p"].Value = new string[] {
   "NEW YORK", "DALLAS", "CHICAGO", "BOSTON" };

try {
  cmd.ExecuteArray(4);
}
// An exception will be thrown as the unique constraint is violated.
catch (OracleException ex) {
  OracleErrorCollection errorCollection = ex.Errors;
  foreach (Devart.Data.Oracle.OracleError error in errorCollection) {
    // Ignore the first non-informative exception ('errors in DML array')
    if (error.Code != 24381)
      Console.WriteLine(error.Message);
  }
}

Console.Read();
C#Visual Basic Copy Code
' Open a connection and configure a command inserting rows to the Dept table.
Dim conn = New OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110")
conn.Open()

Dim cmd = New OracleCommand("INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)", conn)

cmd.Parameters.Add("deptno_p", OracleDbType.Integer)
cmd.Parameters.Add("dname_p", OracleDbType.VarChar)
cmd.Parameters.Add("loc_p", OracleDbType.VarChar)

' Populate the parameter collection with arrays.
' Notice that the deptno_p parameter array consists of identical numbers.
cmd.Parameters("deptno_p").Value = New Integer() {10, 10, 10, 10}
cmd.Parameters("dname_p").Value = New String() {"ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS"}
cmd.Parameters("loc_p").Value = New String() {"NEW YORK", "DALLAS", "CHICAGO", "BOSTON"}

Try
    cmd.ExecuteArray(4)
    ' An exception will be thrown as the unique constraint is violated.
Catch ex As OracleException
    Dim ErrorCollection As OracleErrorCollection = ex.Errors
    For Each OraError As Devart.Data.Oracle.OracleError In ErrorCollection
        ' Ignore the first non-informative exception ('errors in DML array')
        If OraError.Code <> 24381 Then _
            Console.WriteLine(OraError.Message)
    Next
End Try

Console.Read()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleError Members
Devart.Data.Oracle Namespace
OracleErrorCollection Class
OracleException Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleError Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleError Class

The following tables list the members exposed by OracleError.

Public Properties

 | Name | Description
public Property | ArrayBindIndex | Represents row offset within DML array binding operation that generates the error.
public Property | Code | Gets a code that identifies the type of the error.
public Property | IsRecoverable | Indicates whether the error is recoverable, i. e. the application can choose to re-submit the existing transaction based on the current transaction status.
public Property | LineNumber | Gets number of line where source of the error is located.
public Property | LinePosition | Gets number of column in a line where source of the error is located.
public Property | Message | Gets a message that describes the current exception.
public Property | ObjectName | Gets the name of the object.
public Property | ObjectOwner | Gets the owner of the object.
public Property | ObjectType | Gets the type of the object.
Top

Public Methods

 | Name | Description
public Method | GetObjectData |
public Method | ToString | Creates and returns a string representation of the current exception.
Top

See Also

Reference

OracleError Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleError Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleError Class

For a list of all members of this type, see OracleError members.

Public Methods

 | Name | Description
public Method | GetObjectData |
public Method | ToString | Creates and returns a string representation of the current exception.
Top

See Also

Reference

OracleError Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectData Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string representation of the current exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleError Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleError Class

For a list of all members of this type, see OracleError members.

Public Properties

 | Name | Description
public Property | ArrayBindIndex | Represents row offset within DML array binding operation that generates the error.
public Property | Code | Gets a code that identifies the type of the error.
public Property | IsRecoverable | Indicates whether the error is recoverable, i. e. the application can choose to re-submit the existing transaction based on the current transaction status.
public Property | LineNumber | Gets number of line where source of the error is located.
public Property | LinePosition | Gets number of column in a line where source of the error is located.
public Property | Message | Gets a message that describes the current exception.
public Property | ObjectName | Gets the name of the object.
public Property | ObjectOwner | Gets the owner of the object.
public Property | ObjectType | Gets the type of the object.
Top

See Also

Reference

OracleError Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ArrayBindIndex Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : ArrayBindIndex Property

Represents row offset within DML array binding operation that generates the error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrayBindIndex As Integer
C#
public int ArrayBindIndex {get;}

Property Value

Returns one-based row index that generates the error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Code Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : Code Property

Gets a code that identifies the type of the error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As Integer
C#
public int Code {get;}

Property Value

A code that identifies the type of the error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsRecoverable Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : IsRecoverable Property

Indicates whether the error is recoverable, i. e. the application can choose to re-submit the existing transaction based on the current transaction status.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRecoverable As Boolean
C#
public bool IsRecoverable {get;}

Property Value

true if the error is recoverable; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members
LogicalTransactionId Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LineNumber Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : LineNumber Property

Gets number of line where source of the error is located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber {get;}

Property Value

Number of line with error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LinePosition Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : LinePosition Property

Gets number of column in a line where source of the error is located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinePosition As Integer
C#
public int LinePosition {get;}

Property Value

Column number.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Message Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : Message Property

Gets a message that describes the current exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string ("").

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : ObjectName Property

Gets the name of the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectName As String
C#
public string ObjectName {get;}

Property Value

The name of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectOwner Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : ObjectOwner Property

Gets the owner of the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectOwner As String
C#
public string ObjectOwner {get;}

Property Value

The owner of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleError Class : ObjectType Property

Gets the type of the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As OracleObjectType
C#
public OracleObjectType ObjectType {get;}

Property Value

One of the OracleObjectType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleError Class
OracleError Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleErrorCollection Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleErrorCollection Class

Collects errors of an exception generated by dotConnect for Oracle. This class cannot be inherited.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleErrorCollection

Syntax

Visual Basic (Declaration)
Public Class OracleErrorCollection
   Implements ICollection, IEnumerable
C#
public class OracleErrorCollection : ICollection, IEnumerable

Remarks

This class is created by OracleException to collect instances of the OracleError class. OracleErrorCollection always contains at least one instance of the OracleError class. This class is often used when a user executes DML array binding operations to obtain detailed information in case of multiple errors.

Example

In the following sample, we try to insert to the Dept table several rows with the same primary key. Provided that the table is empty, there should be an ORA-24381 error (errors in DML array) and three ORA-00001 errors (unique constraint violation) in OracleErrorCollection of the exception thrown.
C#csharp Copy Code
// Open a connection and configure a command inserting rows to the Dept table.
OracleConnection conn = new OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110");
conn.Open();

OracleCommand cmd = new OracleCommand("INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)", conn);

cmd.Parameters.Add("deptno_p", OracleDbType.Integer);
cmd.Parameters.Add("dname_p", OracleDbType.VarChar);
cmd.Parameters.Add("loc_p", OracleDbType.VarChar);

// Populate the parameter collection with arrays.
// Notice that the deptno_p parameter array consists of identical numbers.
cmd.Parameters["deptno_p"].Value = new int[] { 10, 10, 10, 10 };
cmd.Parameters["dname_p"].Value = new string[] {
   "ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS" };
cmd.Parameters["loc_p"].Value = new string[] {
   "NEW YORK", "DALLAS", "CHICAGO", "BOSTON" };

try {
  cmd.ExecuteArray(4);
}
// An exception will be thrown as the unique constraint is violated.
catch (OracleException ex) {
  OracleErrorCollection errorCollection = ex.Errors;
  foreach (Devart.Data.Oracle.OracleError error in errorCollection) {
    // Ignore the first non-informative exception ('errors in DML array')
    if (error.Code != 24381)
      Console.WriteLine(error.Message);
  }
}

Console.Read();
C#Visual Basic Copy Code
' Open a connection and configure a command inserting rows to the Dept table.
Dim conn = New OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110")
conn.Open()

Dim cmd = New OracleCommand("INSERT INTO dept VALUES(:deptno_p, :dname_p, :loc_p)", conn)

cmd.Parameters.Add("deptno_p", OracleDbType.Integer)
cmd.Parameters.Add("dname_p", OracleDbType.VarChar)
cmd.Parameters.Add("loc_p", OracleDbType.VarChar)

' Populate the parameter collection with arrays.
' Notice that the deptno_p parameter array consists of identical numbers.
cmd.Parameters("deptno_p").Value = New Integer() {10, 10, 10, 10}
cmd.Parameters("dname_p").Value = New String() {"ACCOUNTING", "RESEARCH", "SALES", "OPERATIONS"}
cmd.Parameters("loc_p").Value = New String() {"NEW YORK", "DALLAS", "CHICAGO", "BOSTON"}

Try
    cmd.ExecuteArray(4)
    ' An exception will be thrown as the unique constraint is violated.
Catch ex As OracleException
    Dim ErrorCollection As OracleErrorCollection = ex.Errors
    For Each OraError As Devart.Data.Oracle.OracleError In ErrorCollection
        ' Ignore the first non-informative exception ('errors in DML array')
        If OraError.Code <> 24381 Then _
            Console.WriteLine(OraError.Message)
    Next
End Try

Console.Read()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleErrorCollection Members
Devart.Data.Oracle Namespace
OracleError Class
OracleException Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleErrorCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleErrorCollection Class

The following tables list the members exposed by OracleErrorCollection.

Public Properties

 | Name | Description
public Property | Count | Gets the number of errors in the collection.
public Property | Item | Gets the error at the specified index. In C#, this property is the indexer for the OracleErrorCollection class.
Top

Public Methods

 | Name | Description
public Method | CopyTo | Copies the elements of the OracleErrorCollection collection into an System.Array starting at the specified index within the array.
public Method | GetEnumerator | This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.
public Method | GetObjectData |
Top

See Also

Reference

OracleErrorCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleErrorCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleErrorCollection Class

For a list of all members of this type, see OracleErrorCollection members.

Public Methods

 | Name | Description
public Method | CopyTo | Copies the elements of the OracleErrorCollection collection into an System.Array starting at the specified index within the array.
public Method | GetEnumerator | This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.
public Method | GetObjectData |
Top

See Also

Reference

OracleErrorCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleErrorCollection Class : CopyTo Method

array
The System.Array to copy elements into.
index
The index from which to start copying into the array parameter.
Copies the elements of the OracleErrorCollection collection into an System.Array starting at the specified index within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   Array array,
   int index
)

Parameters

array
The System.Array to copy elements into.
index
The index from which to start copying into the array parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleErrorCollection Class
OracleErrorCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleErrorCollection Class : GetEnumerator Method

This member supports the .NET Framework infrastructure and is not intended to be used directly from your code.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
C#
public IEnumerator GetEnumerator()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleErrorCollection Class
OracleErrorCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectData Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleErrorCollection Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
context

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleErrorCollection Class
OracleErrorCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleErrorCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleErrorCollection Class

For a list of all members of this type, see OracleErrorCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of errors in the collection.
public Property | Item | Gets the error at the specified index. In C#, this property is the indexer for the OracleErrorCollection class.
Top

See Also

Reference

OracleErrorCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleErrorCollection Class : Count Property

Gets the number of errors in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The total number of errors in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleErrorCollection Class
OracleErrorCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleErrorCollection Class : Item Property

index
The zero-based index of the error to retrieve.
Gets the error at the specified index. In C#, this property is the indexer for the OracleErrorCollection class.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As OracleError
C#
public OracleError this(
   int index
) {get;}

Parameters

index
The zero-based index of the error to retrieve.

Property Value

An OracleError that contains the error at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleErrorCollection Class
OracleErrorCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleException Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleException Class

The exception that is generated when Oracle returns an error.

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.Runtime.InteropServices.ExternalException
System.Data.Common.DbException
Devart.Data.Oracle.OracleException

Syntax

Visual Basic (Declaration)
Public Class OracleException
   Inherits System.Data.Common.DbException
   Implements _Exception, ISerializable
C#
public class OracleException : System.Data.Common.DbException, _Exception, ISerializable

Remarks

This class is created whenever dotConnect for Oracle encounters an error generated by the server, or OracleConnection has been closed before attempting to execute an operation on the server.

Example

The following example generates a OracleException due to a non-existing table, and then displays the exception.
C#csharp Copy Code
public void ThrowOracleException()
{
  string mySelectQuery = "SELECT * FROM NONEXISTINGTABLE";
  OracleConnection myConnection =
    new OracleConnection(
        "User Id=Scott;Password=tiger;Data Source=Ora;");
  OracleCommand myCommand = new OracleCommand(mySelectQuery,myConnection);
  try
  {
    myCommand.Connection.Open();
  }
  catch (OracleException myException)
  {
    MessageBox.Show("Message: " + myException.Message + "\n");
  }
}
C#Visual Basic Copy Code
Public Sub ThrowOracleException()
  Dim mySelectQuery As String = "SELECT * FROM NONEXISTINGTABLE"
  Dim myConnection As New OracleConnection( _
    "User Id=Scott;Password=tiger;Data Source=Ora;")
  Dim myCommand As New OracleCommand(mySelectQuery, myConnection)
  Try
    myCommand.Connection.Open()
  Catch myException As OracleException
    MessageBox.Show("Message: " + myException.Message + ControlChars.Cr)
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleException Members
Devart.Data.Oracle Namespace
OracleConnection Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleException Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleException Class

The following tables list the members exposed by OracleException.

Public Properties

 | Name | Description
public Property | Code | Gets a code that identifies the type of error.
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | ErrorCode | Gets the HRESULT of the error. (Inherited from System.Runtime.InteropServices.ExternalException)
public Property | Errors | This property specifies a collection of one or more OracleError objects that contain information about exceptions generated by the Oracle database.
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | IsRecoverable | Determines whether an application can chose to re-submit the existing transaction based on the current transaction status or it must roll-back, re-execute, and re-submit the current transaction.
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Offset | Gets a position of the incorrect symbol at the SQL statement.
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | Overridden. Populates a SerializationInfo with the data needed to serialize the target object.
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

OracleException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleException Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleException Class

For a list of all members of this type, see OracleException members.

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | Overridden. Populates a SerializationInfo with the data needed to serialize the target object.
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

OracleException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectData Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleException Class : GetObjectData Method

info
A System.Runtime.Serialization.SerializationInfo object to populate.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.
Populates a SerializationInfo with the data needed to serialize the target object.

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
C#
public override void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)

Parameters

info
A System.Runtime.Serialization.SerializationInfo object to populate.
context
The System.Runtime.Serialization.StreamingContext that contains contextual information about the source or destination.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleException Class
OracleException Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleException Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleException Class

For a list of all members of this type, see OracleException members.

Public Properties

 | Name | Description
public Property | Code | Gets a code that identifies the type of error.
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | ErrorCode | Gets the HRESULT of the error. (Inherited from System.Runtime.InteropServices.ExternalException)
public Property | Errors | This property specifies a collection of one or more OracleError objects that contain information about exceptions generated by the Oracle database.
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | IsRecoverable | Determines whether an application can chose to re-submit the existing transaction based on the current transaction status or it must roll-back, re-execute, and re-submit the current transaction.
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Offset | Gets a position of the incorrect symbol at the SQL statement.
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OracleException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Code Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleException Class : Code Property

Gets a code that identifies the type of error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As Integer
C#
public int Code {get;}

Property Value

A code that identifies the type of error. For example, for ORA-12345 error it returns 12345.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleException Class
OracleException Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Errors Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleException Class : Errors Property

This property specifies a collection of one or more OracleError objects that contain information about exceptions generated by the Oracle database.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Errors As OracleErrorCollection
C#
public OracleErrorCollection Errors {get;}

Property Value

An OracleErrorCollection.

Remarks

This property is initialized only when errors occur during DML array binding operation. The Errors property contains at least one instance of OracleError objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleException Class
OracleException Members
OracleError Class
OracleErrorCollection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsRecoverable Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleException Class : IsRecoverable Property

Determines whether an application can chose to re-submit the existing transaction based on the current transaction status or it must roll-back, re-execute, and re-submit the current transaction.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsRecoverable As Boolean
C#
public bool IsRecoverable {get;}

Property Value

true if application can chose to re-submit the existing transaction based on the current transaction status; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleException Class
OracleException Members
GetLogicalTransactionStatus Method
LogicalTransactionId Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Offset Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleException Class : Offset Property

Gets a position of the incorrect symbol at the SQL statement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
C#
public int Offset {get;}

Property Value

A position of the incorrect symbol at the SQL statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleException Class
OracleException Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleFailoverEventsArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverEventsArgs Class

Provides data for the OracleConnection.Failover event of the OracleConnection class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleFailoverEventsArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleFailoverEventsArgs
   Inherits System.EventArgs
C#
public sealed class OracleFailoverEventsArgs : System.EventArgs

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleFailoverEventsArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleFailoverEventsArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverEventsArgs Class

The following tables list the members exposed by OracleFailoverEventsArgs.

Public Properties

 | Name | Description
public Property | Retry | Gives the ability to retry connection to another Oracle server in case if previous reconnection failed.
public Property | State | Represents Transparent Application Failover stage.
public Property | Type | Specifies the type of failover.
Top

See Also

Reference

OracleFailoverEventsArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleFailoverEventsArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverEventsArgs Class

For a list of all members of this type, see OracleFailoverEventsArgs members.

Public Properties

 | Name | Description
public Property | Retry | Gives the ability to retry connection to another Oracle server in case if previous reconnection failed.
public Property | State | Represents Transparent Application Failover stage.
public Property | Type | Specifies the type of failover.
Top

See Also

Reference

OracleFailoverEventsArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Retry Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleFailoverEventsArgs Class : Retry Property

Gives the ability to retry connection to another Oracle server in case if previous reconnection failed.

Syntax

Visual Basic (Declaration)
Public Property Retry As Boolean
C#
public bool Retry {get; set;}

Property Value

true if one more attempt to reconnect can be made; otherwise, false.

Remarks

Using this property you may control reconnection attempts while connection to another Oracle instance will be successful.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleFailoverEventsArgs Class
OracleFailoverEventsArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
State Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleFailoverEventsArgs Class : State Property

Represents Transparent Application Failover stage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As OracleFailoverState
C#
public OracleFailoverState State {get;}

Property Value

An OracleFailoverState.

Remarks

Look at OracleFailoverState members for stage description.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleFailoverEventsArgs Class
OracleFailoverEventsArgs Members
OracleFailoverState Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Type Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleFailoverEventsArgs Class : Type Property

Specifies the type of failover.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As OracleFailoverType
C#
public OracleFailoverType Type {get;}

Property Value

An OracleFailoverType.

Remarks

Look at OracleFailoverType mebers for failover types description.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleFailoverEventsArgs Class
OracleFailoverEventsArgs Members
OracleFailoverType Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleGlobalization Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleGlobalization Class

Manages the Oracle globalization settings of the application, and local computer. Oracle globalization settings of the local computer are read-only.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleGlobalization

Syntax

Visual Basic (Declaration)
Public Class OracleGlobalization
C#
public class OracleGlobalization

Example

The following example changes the date format of application.
C#csharp Copy Code
public void ChangeDateFormat(){
        // Get application's globalization info
        OracleGlobalization glob = OracleGlobalization.GetApplicationInfo();

        // Prints "glob.DateFormat = DD.MM.YYYY"
        Console.WriteLine("glob.DateFormat = " + glob.DateFormat);

        // Set date format on application's globalization info
        glob.DateFormat = "MM.DD.YYYY";
        OracleGlobalization.SetApplicationInfo(glob);
        OracleGlobalization.GetApplicationInfo(glob);

        // Prints "glob.DateFormat = MM.DD.YYYY"
        Console.WriteLine("glob.DateFormat = " + glob.DateFormat);
}
C#Visual Basic Copy Code
Public Sub ChangeDateFormat()
        ' Get application's globalization info
        Dim glob As OracleGlobalization = OracleGlobalization.GetApplicationInfo()

        ' Prints "glob.DateFormat = DD.MM.YYYY"
        Console.WriteLine("glob.DateFormat = " + glob.DateFormat)

        ' Set date format on application's globalization info
        glob.DateFormat = "MM.DD.YYYY"
        OracleGlobalization.SetApplicationInfo(glob)
        OracleGlobalization.GetApplicationInfo(glob)

        ' Prints "glob.DateFormat = MM.DD.YYYY"
        Console.WriteLine("glob.DateFormat = " + glob.DateFormat)
End Sub 'ChangeDateFormat

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleGlobalization Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleGlobalization Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleGlobalization Class

The following tables list the members exposed by OracleGlobalization.

Public Properties

 | Name | Description
public Property | ClientCharacterSet | Gets or sets a client character set.
public Property | Currency | Specifies the string to use as a local currency symbol for the L number format element.
public Property | DateFormat | Specifies the date format for Oracle DATE type as a string.
public Property | DateLanguage | Specifies the language used to spell names of days and months, and date abbreviations.
public Property | DualCurrency | Specifies the dual currency symbol for the U number format element.
public Property | ISOCurrency | Specifies the string to use as an international currency symbol for the C number format element.
public Property | Language | Specifies the default language of the database.
public Property | NCharConversionException | Determines whether or not data loss during an implicit or explicit character type conversion reports an error.
public Property | NumericCharacters | Specifies the characters used for the decimal character and the group separator character for numeric values in strings.
public Property | Territory | Specifies the name of the territory.
public Property | TimeStampFormat | Specifies the string format for TimeStamp types.
public Property | TimeStampTZFormat | Specifies the string format for TimeStampTZ types.
public Property | TimeZone | Specifies the time zone region name or hour offset.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of an OracleGlobalization object.
static (Shared in Visual Basic) | GetApplicationInfo | Overloaded. Populates an OracleGlobalization instance with Oracle globalization settings of the application.
static (Shared in Visual Basic) | GetSystemInfo | Overloaded. Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.
static (Shared in Visual Basic) | SetApplicationInfo | Sets Oracle globalization parameters to the current application.
Top

See Also

Reference

OracleGlobalization Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleGlobalization Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleGlobalization Class

For a list of all members of this type, see OracleGlobalization members.

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of an OracleGlobalization object.
static (Shared in Visual Basic) | GetApplicationInfo | Overloaded. Populates an OracleGlobalization instance with Oracle globalization settings of the application.
static (Shared in Visual Basic) | GetSystemInfo | Overloaded. Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.
static (Shared in Visual Basic) | SetApplicationInfo | Sets Oracle globalization parameters to the current application.
Top

See Also

Reference

OracleGlobalization Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : Clone Method

Creates a copy of an OracleGlobalization object.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleGlobalization
C#
public OracleGlobalization Clone()

Return Value

An OracleGlobalization object

Remarks

The cloned object has the same property values as that of the object being cloned.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetApplicationInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : GetApplicationInfo Method

Populates an OracleGlobalization instance with Oracle globalization settings of the application.

Overload List

Overload | Description
GetApplicationInfo() | Returns an OracleGlobalization instance with Oracle globalization settings of the application.
GetApplicationInfo(OracleGlobalization) | Populates an OracleGlobalization instance with Oracle globalization settings of the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetApplicationInfo() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetApplicationInfo Method : GetApplicationInfo() Method

Returns an OracleGlobalization instance with Oracle globalization settings of the application.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetApplicationInfo() As OracleGlobalization
C#
public static OracleGlobalization GetApplicationInfo()

Return Value

An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetApplicationInfo(OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetApplicationInfo Method : GetApplicationInfo(OracleGlobalization) Method

oraGlob
An OracleGlobalization instance.
Populates an OracleGlobalization instance with Oracle globalization settings of the application.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub GetApplicationInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public static void GetApplicationInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSystemInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : GetSystemInfo Method

Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.

Overload List

Overload | Description
GetSystemInfo() | Returns an OracleGlobalization instance with Oracle globalization settings of the operating system.
GetSystemInfo(CultureInfo) | Returns an OracleGlobalization instance with Oracle globalization settings of the operating system.
GetSystemInfo(OracleGlobalization) | Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.
GetSystemInfo(OracleGlobalization,CultureInfo) | Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSystemInfo() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetSystemInfo Method : GetSystemInfo() Method

Returns an OracleGlobalization instance with Oracle globalization settings of the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetSystemInfo() As OracleGlobalization
C#
public static OracleGlobalization GetSystemInfo()

Return Value

An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSystemInfo(CultureInfo) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetSystemInfo Method : GetSystemInfo(CultureInfo) Method

culture
A CultureInfo instance.
Returns an OracleGlobalization instance with Oracle globalization settings of the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetSystemInfo( _
   ByVal culture As CultureInfo _
) As OracleGlobalization
C#
public static OracleGlobalization GetSystemInfo(
   CultureInfo culture
)

Parameters

culture
A CultureInfo instance.

Return Value

An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSystemInfo(OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetSystemInfo Method : GetSystemInfo(OracleGlobalization) Method

oraGlob
An OracleGlobalization instance.
Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub GetSystemInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public static void GetSystemInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSystemInfo(OracleGlobalization,CultureInfo) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class > GetSystemInfo Method : GetSystemInfo(OracleGlobalization,CultureInfo) Method

oraGlob
An OracleGlobalization instance.
culture
A CultureInfo instance.
Populates an OracleGlobalization instance with Oracle globalization settings of the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub GetSystemInfo( _
   ByVal oraGlob As OracleGlobalization, _
   ByVal culture As CultureInfo _
)
C#
public static void GetSystemInfo(
   OracleGlobalization oraGlob,
   CultureInfo culture
)

Parameters

oraGlob
An OracleGlobalization instance.
culture
A CultureInfo instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetApplicationInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : SetApplicationInfo Method

oraGlob
An OracleGlobalization instance.
Sets Oracle globalization parameters to the current application.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetApplicationInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public static void SetApplicationInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleGlobalization Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleGlobalization Class

For a list of all members of this type, see OracleGlobalization members.

Public Properties

 | Name | Description
public Property | ClientCharacterSet | Gets or sets a client character set.
public Property | Currency | Specifies the string to use as a local currency symbol for the L number format element.
public Property | DateFormat | Specifies the date format for Oracle DATE type as a string.
public Property | DateLanguage | Specifies the language used to spell names of days and months, and date abbreviations.
public Property | DualCurrency | Specifies the dual currency symbol for the U number format element.
public Property | ISOCurrency | Specifies the string to use as an international currency symbol for the C number format element.
public Property | Language | Specifies the default language of the database.
public Property | NCharConversionException | Determines whether or not data loss during an implicit or explicit character type conversion reports an error.
public Property | NumericCharacters | Specifies the characters used for the decimal character and the group separator character for numeric values in strings.
public Property | Territory | Specifies the name of the territory.
public Property | TimeStampFormat | Specifies the string format for TimeStamp types.
public Property | TimeStampTZFormat | Specifies the string format for TimeStampTZ types.
public Property | TimeZone | Specifies the time zone region name or hour offset.
Top

See Also

Reference

OracleGlobalization Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientCharacterSet Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : ClientCharacterSet Property

Gets or sets a client character set.

Syntax

Visual Basic (Declaration)
Public Property ClientCharacterSet As String
C#
public string ClientCharacterSet {get; set;}

Property Value

A string that provides the name of the local computer character set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Currency Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : Currency Property

Specifies the string to use as a local currency symbol for the L number format element.

Syntax

Visual Basic (Declaration)
Public Property Currency As String
C#
public string Currency {get; set;}

Property Value

The string to use as a local currency symbol.

Remarks

The default value is the NLS_CURRENCY setting of the local computer. See Oracle SQL reference for more information about number format elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DateFormat Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : DateFormat Property

Specifies the date format for Oracle DATE type as a string.

Syntax

Visual Basic (Declaration)
Public Property DateFormat As String
C#
public string DateFormat {get; set;}

Property Value

The date format for Oracle DATE type as a string.

Remarks

The default value is the NLS_DATE_FORMAT setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DateLanguage Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : DateLanguage Property

Specifies the language used to spell names of days and months, and date abbreviations.

Syntax

Visual Basic (Declaration)
Public Property DateLanguage As String
C#
public string DateLanguage {get; set;}

Property Value

A string specifying the language.

Remarks

The default value is the NLS_DATE_LANGUAGE setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DualCurrency Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : DualCurrency Property

Specifies the dual currency symbol for the U number format element.

Syntax

Visual Basic (Declaration)
Public Property DualCurrency As String
C#
public string DualCurrency {get; set;}

Property Value

A string that provides the dual currency symbol.

Remarks

The default value is the NLS_DUAL_CURRENCY setting of the local computer. See Oracle SQL reference for more information about number format elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ISOCurrency Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : ISOCurrency Property

Specifies the string to use as an international currency symbol for the C number format element.

Syntax

Visual Basic (Declaration)
Public Property ISOCurrency As String
C#
public string ISOCurrency {get; set;}

Property Value

The string used as an international currency symbol.

Remarks

The default value is the NLS_ISO_CURRENCY setting of the local computer. See Oracle SQL reference for more information about number format elements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Language Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : Language Property

Specifies the default language of the database.

Syntax

Visual Basic (Declaration)
Public Property Language As String
C#
public string Language {get; set;}

Property Value

The default language of the database.

Remarks

Language is used for messages, day and month names, and sorting algorithms. It also determines NLS_DATE_LANGUAGE and NLS_SORT parameter values. The default value is the NLS_LANGUAGE setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NCharConversionException Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : NCharConversionException Property

Determines whether or not data loss during an implicit or explicit character type conversion reports an error.

Syntax

Visual Basic (Declaration)
Public Property NCharConversionException As Boolean
C#
public bool NCharConversionException {get; set;}

Property Value

If true, an exception is fired when a conversion causes a data loss.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NumericCharacters Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : NumericCharacters Property

Specifies the characters used for the decimal character and the group separator character for numeric values in strings.

Syntax

Visual Basic (Declaration)
Public Property NumericCharacters As String
C#
public string NumericCharacters {get; set;}

Property Value

A string that represents the characters used.

Remarks

The default value is the NLS_NUMERIC_CHARACTERS setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Territory Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : Territory Property

Specifies the name of the territory.

Syntax

Visual Basic (Declaration)
Public Property Territory As String
C#
public string Territory {get; set;}

Property Value

A string that provides the name of the territory.

Remarks

The default value is the NLS_TERRITORY setting of the local computer. Changing this property changes other globalization properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeStampFormat Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : TimeStampFormat Property

Specifies the string format for TimeStamp types.

Syntax

Visual Basic (Declaration)
Public Property TimeStampFormat As String
C#
public string TimeStampFormat {get; set;}

Property Value

The string format for TimeStamp types.

Remarks

The default value is the NLS_TIMESTAMP_FORMAT setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeStampTZFormat Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : TimeStampTZFormat Property

Specifies the string format for TimeStampTZ types.

Syntax

Visual Basic (Declaration)
Public Property TimeStampTZFormat As String
C#
public string TimeStampTZFormat {get; set;}

Property Value

The string format for TimeStampTZ types.

Remarks

The default value is the NLS_TIMESTAMP_TZ_FORMAT setting of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeZone Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleGlobalization Class : TimeZone Property

Specifies the time zone region name or hour offset.

Syntax

Visual Basic (Declaration)
Public Property TimeZone As String
C#
public string TimeZone {get; set;}

Property Value

The string represents the time zone region name or the time zone offset.

Remarks

The default value is the time zone region name of the local computer.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleGlobalization Class
OracleGlobalization Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHAEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventArgs Class

Provides data for the OracleConnection.HAEvent event of the OracleConnection class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleHAEventArgs

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleHAEventArgs
   Inherits System.EventArgs
C#
public sealed class OracleHAEventArgs : System.EventArgs

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleHAEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleHAEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventArgs Class

The following tables list the members exposed by OracleHAEventArgs.

Public Properties

 | Name | Description
public Property | DatabaseDomainName | Gets the domain name of the database affected by the event.
public Property | DatabaseName | Gets the name of the database affected by the event.
public Property | HostName | Gets the host that triggered the event.
public Property | InstanceName | Gets the name of the instance that triggered the event.
public Property | Reason | Gets the reason why the event was triggered.
public Property | ServiceName | Gets the name of the service that triggered the event.
public Property | Source | Gets the source that triggered the event.
public Property | Status | Gets the status of the source that triggered the event.
public Property | Time | Gets the time when the event was triggered on the server.
Top

See Also

Reference

OracleHAEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleHAEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventArgs Class

For a list of all members of this type, see OracleHAEventArgs members.

Public Properties

 | Name | Description
public Property | DatabaseDomainName | Gets the domain name of the database affected by the event.
public Property | DatabaseName | Gets the name of the database affected by the event.
public Property | HostName | Gets the host that triggered the event.
public Property | InstanceName | Gets the name of the instance that triggered the event.
public Property | Reason | Gets the reason why the event was triggered.
public Property | ServiceName | Gets the name of the service that triggered the event.
public Property | Source | Gets the source that triggered the event.
public Property | Status | Gets the status of the source that triggered the event.
public Property | Time | Gets the time when the event was triggered on the server.
Top

See Also

Reference

OracleHAEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DatabaseDomainName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : DatabaseDomainName Property

Gets the domain name of the database affected by the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseDomainName As String
C#
public string DatabaseDomainName {get;}

Property Value

The domain name of the database affected by the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DatabaseName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : DatabaseName Property

Gets the name of the database affected by the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
C#
public string DatabaseName {get;}

Property Value

The name of the database affected by the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
HostName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : HostName Property

Gets the host that triggered the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HostName As String
C#
public string HostName {get;}

Property Value

The host that triggered the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InstanceName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : InstanceName Property

Gets the name of the instance that triggered the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InstanceName As String
C#
public string InstanceName {get;}

Property Value

The name of the instance that triggered the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Reason Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : Reason Property

Gets the reason why the event was triggered.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reason As String
C#
public string Reason {get;}

Property Value

The reason why the event was triggered. Possible values include Data_Guard_Failover, Failure, Dependency, User, Autostart, and Restart.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ServiceName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : ServiceName Property

Gets the name of the service that triggered the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServiceName As String
C#
public string ServiceName {get;}

Property Value

The name of the service that triggered the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Source Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : Source Property

Gets the source that triggered the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As OracleHAEventSource
C#
public OracleHAEventSource Source {get;}

Property Value

One of the OracleHAEventSource values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Status Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : Status Property

Gets the status of the source that triggered the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As OracleHAEventStatus
C#
public OracleHAEventStatus Status {get;}

Property Value

One of the OracleHAEventStatus values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Time Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHAEventArgs Class : Time Property

Gets the time when the event was triggered on the server.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Time As Date
C#
public DateTime Time {get;}

Property Value

The time when the event was triggered on the server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHAEventArgs Class
OracleHAEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHome Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHome Class

Represents an Oracle home.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleHome

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleHome
C#
public sealed class OracleHome

Remarks

Use the OracleHome properties to retrieve name, version, physical path and language settings (the NLS_LANG variable) for the specifed Oracle home. Use the GetClientInfo method to get the Oracle globalization settings of current Oracle home, such as date format, time zone, currency and language. Use the GetServerList method to see the list of Oracle servers (TNS names) available for the current Oracle home.

OracleHome has no public constructors, it can only be retrieved from the OracleHomeCollection. The complete collection of all available Oracle homes can be get from the static interface of the OracleConnection class. See OracleHomeCollection and the OracleConnection.Homes property of the OracleConnection class.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

In this example we retrieve the globalization settings of the "OraClient" Oracle home; after that, we try to connect as Scott to all servers described in the tnsnames.ora file of OraClient.
C#csharp Copy Code
// Get the OracleHome instance corresponding to the "OraClient" Oracle home.
OracleHome home = OracleConnection.Homes["OraClient"];

            // Print some globalization settings of the current home.
OracleGlobalization glob = home.GetClientInfo();
Console.WriteLine("The Oracle home is registered for: " + glob.Territory);
Console.WriteLine("Character set is " + glob.ClientCharacterSet);
Console.WriteLine("Time zone is " + glob.TimeZone);
Console.WriteLine("Date format is " + glob.DateFormat);

            // Create a connection.
OracleConnection conn = new OracleConnection();
conn.UserId = "Scott";
conn.Password = "tiger";

            // Try to connect to each server available for the current Oracle home.
            Console.WriteLine("\nTrying to connect as Scott/tiger:\n");
string[] servers = home.GetServerList();
            foreach (string serverName in servers)
            {
                conn.Server = serverName;
                try
                {
                    conn.Open();
                    Console.WriteLine("Successfully connected to " + serverName);
                }
                catch(Exception ex)
                {
                    Console.WriteLine("Failed connecting to " + serverName + ": " + ex.Message);
                }
                finally
                {
                    conn.Close();
                }
            }

            Console.ReadLine();
C#Visual Basic Copy Code
' Get the OracleHome instance corresponding to the "OraClient" Oracle home.
Dim home As OracleHome = OracleConnection.Homes.Item("OraClient")

' Print some globalization settings of the current home.
Dim glob As OracleGlobalization = home.GetClientInfo()
Console.WriteLine("The Oracle home is registered for: " + glob.Territory)
Console.WriteLine("Character set is " + glob.ClientCharacterSet)
Console.WriteLine("Time zone is " + glob.TimeZone)
Console.WriteLine("Date format is " + glob.DateFormat)

' Create a connection.
Dim conn As OracleConnection = New OracleConnection()
conn.UserId = "Scott"
conn.Password = "tiger"

' Try to connect to each server available for the current Oracle home.
Console.WriteLine(vbCrLf + "Trying to connect as Scott/tiger:" + vbCrLf)
Dim servers As Array = home.GetServerList()
For Each serverName In servers
conn.Server = serverName
    Try
conn.Open()
Console.WriteLine("Successfully connected to " + serverName)
Catch ex As Exception
Console.WriteLine("Failed connecting to " + serverName + ": " + ex.Message)
    Finally
conn.Close()
    End Try
Next

Console.ReadLine()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleHome Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleHome Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleHome Class

The following tables list the members exposed by OracleHome.

Public Properties

 | Name | Description
public Property | ClientVersion | Gets version of Oracle client.
public Property | Name | Gets the name of Oracle home.
public Property | NlsLang | Gets NLS_LANG parameter of the specified Oracle home.
public Property | Path | Gets a path where the specified Oracle instance is located.
Top

Public Methods

 | Name | Description
public Method | GetClientInfo | Overloaded. Populates an OracleGlobalization object with client side information.
public Method | GetServerList | Returns an array of available TNS aliases.
Top

See Also

Reference

OracleHome Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleHome Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHome Class

For a list of all members of this type, see OracleHome members.

Public Methods

 | Name | Description
public Method | GetClientInfo | Overloaded. Populates an OracleGlobalization object with client side information.
public Method | GetServerList | Returns an array of available TNS aliases.
Top

See Also

Reference

OracleHome Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetClientInfo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : GetClientInfo Method

Populates an OracleGlobalization object with client side information.

Overload List

Overload | Description
GetClientInfo() | Populates an OracleGlobalization object with client side information.
GetClientInfo(OracleGlobalization) | Populates an OracleGlobalization object with client side information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetClientInfo() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class > GetClientInfo Method : GetClientInfo() Method

Populates an OracleGlobalization object with client side information.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetClientInfo() As OracleGlobalization
C#
public OracleGlobalization GetClientInfo()

Return Value

A new OracleGlobalization object with the Oracle globalization settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetClientInfo(OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class > GetClientInfo Method : GetClientInfo(OracleGlobalization) Method

oraGlob
An OracleGlobalization object to be populated with the Oracle globalization settings.
Populates an OracleGlobalization object with client side information.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetClientInfo( _
   ByVal oraGlob As OracleGlobalization _
)
C#
public void GetClientInfo(
   OracleGlobalization oraGlob
)

Parameters

oraGlob
An OracleGlobalization object to be populated with the Oracle globalization settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetServerList() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : GetServerList() Method

Returns an array of available TNS aliases.

Syntax

Visual Basic (Declaration)
Public Function GetServerList() As String()
C#
public string[] GetServerList()

Return Value

An array of available TNS aliases.

Remarks

Use GetServerList() function to read TNS aliases from TNSNAMES.ORA configuration file found in the home directory.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleHome Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHome Class

For a list of all members of this type, see OracleHome members.

Public Properties

 | Name | Description
public Property | ClientVersion | Gets version of Oracle client.
public Property | Name | Gets the name of Oracle home.
public Property | NlsLang | Gets NLS_LANG parameter of the specified Oracle home.
public Property | Path | Gets a path where the specified Oracle instance is located.
Top

See Also

Reference

OracleHome Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ClientVersion Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : ClientVersion Property

Gets version of Oracle client.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClientVersion As String
C#
public string ClientVersion {get;}

Property Value

Version of Oracle client.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : Name Property

Gets the name of Oracle home.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

The name of Oracle home.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NlsLang Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : NlsLang Property

Gets NLS_LANG parameter of the specified Oracle home.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NlsLang As String
C#
public string NlsLang {get;}

Property Value

A value of NLS_LANG parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Path Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : Path Property

Gets a path where the specified Oracle instance is located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Path As String
C#
public string Path {get;}

Property Value

A path for the specified Oracle home.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHomeCollection Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHomeCollection Class

Represents a list of available Oracle homes.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleHomeCollection

Syntax

Visual Basic (Declaration)
Public Class OracleHomeCollection
   Implements ICollection(Of OracleHome), IEnumerable(Of OracleHome), IList(Of OracleHome), IEnumerable
C#
public class OracleHomeCollection : ICollection<OracleHome>, IEnumerable<OracleHome>, IList<OracleHome>, IEnumerable

Remarks

You can use this collection to get information about the Oracle homes installed at your system. To see all available Oracle homes, use the OracleConnection.Homes property of the static interface of the OracleConnection class. Use the DefaultHome property to retrieve the OracleHome object representing the system's default Oracle home. Use the Item(String) property to get the information about the Oracle home with the specified name.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

In this sample we retrieve the Oracle home which is default in the system. After that, we iterate through all available homes trying to connect to the "OraServer" Oracle server as Scott.
C#csharp Copy Code
// Get the complete collection of Oracle homes available in this system.
OracleHomeCollection homes = OracleConnection.Homes;

            // Check the default Oracle home.
OracleHome defaultHome = homes.DefaultHome;
Console.WriteLine("The default Oracle home in this system is " + defaultHome.Name);

            // Create a connection.
OracleConnection conn = new OracleConnection();
conn.Server = "OraServer";
conn.UserId = "Scott";
conn.Password = "tiger";

            // Try to connect to the "OraServer" Oracle server as Scott/tiger using each of Oracle homes available.
Console.WriteLine("\nTrying to connect to server \"OraServer\" as Scott/tiger:\n");
foreach (OracleHome home in homes)
            {
                conn.Home = home.Name;
                try
                {
                    conn.Open();
                    Console.WriteLine("Successfully connected using " + home.Name);
                }
                catch (Exception ex)
                {
                    Console.WriteLine("Failed trying to connect via " + home.Name + ": " + ex.Message);
                }
                finally
                {
                    conn.Close();
                }
            }

Console.ReadLine();
C#Visual Basic Copy Code
' Get the complete collection of Oracle homes available in this system.
Dim homes As OracleHomeCollection = OracleConnection.Homes

' Check the default Oracle home.
Dim defaultHome As OracleHome = homes.DefaultHome
Console.WriteLine("The default Oracle home in this system is " + defaultHome.Name)

' Create a connection.
Dim conn As OracleConnection = New OracleConnection()
conn.Server = "OraServer"
conn.UserId = "Scott"
conn.Password = "tiger"

' Try to connect to the "OraServer" Oracle server as Scott/tiger using each of Oracle homes available.
Console.WriteLine(vbCrLf + "Trying to connect to server ""OraServer"" as Scott/tiger:" + vbCrLf)

For Each home In homes
conn.Home = home.Name
    Try
conn.Open()
Console.WriteLine("Successfully connected using " + home.Name)
Catch ex As Exception
Console.WriteLine("Failed trying to connect via " + home.Name + ": " + ex.Message)
    Finally
conn.Close()
    End Try
Next

Console.ReadLine()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleHomeCollection Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleHomeCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleHomeCollection Class

The following tables list the members exposed by OracleHomeCollection.

Public Properties

 | Name | Description
public Property | Count | Returns the number of OracleHome objects in the collection.
public Property | DefaultHome | Gets the default Oracle home information.
public Property | Item | Gets an information about Oracle home with the specified home name.
Top

Public Methods

 | Name | Description
public Method | Contains | Determines whether Oracle home with the specified name is present at the system.
Top

See Also

Reference

OracleHomeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleHomeCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHomeCollection Class

For a list of all members of this type, see OracleHomeCollection members.

Public Methods

 | Name | Description
public Method | Contains | Determines whether Oracle home with the specified name is present at the system.
Top

See Also

Reference

OracleHomeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : Contains(String) Method

name
The name of Oracle home to search for.
Determines whether Oracle home with the specified name is present at the system.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal name As String _
) As Boolean
C#
public bool Contains(
   string name
)

Parameters

name
The name of Oracle home to search for.

Return Value

true if Oracle home with the specified name is found; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleHomeCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHomeCollection Class

For a list of all members of this type, see OracleHomeCollection members.

Public Properties

 | Name | Description
public Property | Count | Returns the number of OracleHome objects in the collection.
public Property | DefaultHome | Gets the default Oracle home information.
public Property | Item | Gets an information about Oracle home with the specified home name.
Top

See Also

Reference

OracleHomeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : Count Property

Returns the number of OracleHome objects in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of OracleHome objects in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DefaultHome Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : DefaultHome Property

Gets the default Oracle home information.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultHome As OracleHome
C#
public OracleHome DefaultHome {get;}

Property Value

Default Oracle home information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : Item(String) Property

name
The name of Oracle home.
Gets an information about Oracle home with the specified home name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item( _
   ByVal name As String _
) As OracleHome
C#
public OracleHome Item(
   string name
) {get;}

Parameters

name
The name of Oracle home.

Property Value

Oracle home information.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleInfoMessageEventArgs Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleInfoMessageEventArgs Class

Provides data for the OracleConnection.InfoMessage event.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleInfoMessageEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleInfoMessageEventArgs
   Inherits System.EventArgs
C#
public class OracleInfoMessageEventArgs : System.EventArgs

Remarks

The OracleConnection.InfoMessage event contains warning sent from the database.

Example

The following example demonstrates registering InfoMessage event handler that prints out the warning info.
C#csharp Copy Code
class OracleInfoMessage {
        public static void WarningPrinter(object src, OracleInfoMessageEventArgs args)
        {
                Console.WriteLine("Source object is: " + src.GetType().Name);
                Console.WriteLine("InfoMessageArgs.Message is " + args.Message);
                Console.WriteLine("InfoMessageArgs.Source is " + args.Source);
        }
        static void Main()
        {
                OracleConnection con = new OracleConnection("User Id=scott;" +
                        "Password=tiger;Data Source=ora1110;");

                con.Open();

                OracleCommand cmd = con.CreateCommand();

                // Register to the InfoMessageHandler
                cmd.Connection.InfoMessage +=
                        new OracleInfoMessageEventHandler(WarningPrinter);

                cmd.CommandText = "CREATE OR REPLACE PACKAGE BODY PACKAGEWITHNOSPECIFICATION AS" +
                        "PROCEDURE GET_ALL_DEPTS (cur OUT SYS_REFCURSOR) AS" +
                        "BEGIN" +
                        " OPEN cur FOR SELECT * FROM DEPT;" +
                        "END;" +
                        "END PACKAGEWITHNOSPECIFICATION;";

                // Execute the statement that produces a warning
                cmd.ExecuteNonQuery();

                // Clean up
                cmd.Dispose();
                con.Dispose();
        }
}
C#Visual Basic Copy Code
Module Module1
        Public Sub WarningPrinter(ByVal src As Object, ByVal args As OracleInfoMessageEventArgs)
                Console.WriteLine("Source object is: " + src.GetType().Name)
                Console.WriteLine("InfoMessageArgs.Message is " + args.Message)
                Console.WriteLine("InfoMessageArgs.Source is " + args.Source)
        End Sub 'WarningPrinter
        Sub Main()
                Dim con As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora1110;")
                con.Open()
                Dim cmd As OracleCommand = con.CreateCommand()
                ' Register to the InfoMessageHandler
                AddHandler cmd.Connection.InfoMessage, _
                New OracleInfoMessageEventHandler(AddressOf WarningPrinter)
                'command.Connection.InfoMessage += New OracleInfoMessageEventHandler(WarningPrinter)
                cmd.CommandText = "CREATE OR REPLACE PACKAGE BODY PACKAGEWITHNOSPECIFICATION AS" & _
                "PROCEDURE GET_ALL_DEPTS (cur OUT SYS_REFCURSOR) AS" & _
                "BEGIN" & _
                " OPEN cur FOR SELECT * FROM DEPT;" & _
                "END;" & _
                "END PACKAGEWITHNOSPECIFICATION;"
                ' Execute the statement that produces a warning
                cmd.ExecuteNonQuery()

                ' Clean up
                cmd.Dispose()
                con.Dispose()
        End Sub
End Module

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleInfoMessageEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleInfoMessageEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleInfoMessageEventArgs Class

The following tables list the members exposed by OracleInfoMessageEventArgs.

Public Properties

 | Name | Description
public Property | Code | Gets the Oracle specific message code.
public Property | Errors | Returns collection of errors generated by OracleCommand.
public Property | Message | Gets the full text of the message sent from the Oracle database.
public Property | Source | Gets the name of the application or the object that threw the event.
Top

See Also

Reference

OracleInfoMessageEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleInfoMessageEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleInfoMessageEventArgs Class

For a list of all members of this type, see OracleInfoMessageEventArgs members.

Public Properties

 | Name | Description
public Property | Code | Gets the Oracle specific message code.
public Property | Errors | Returns collection of errors generated by OracleCommand.
public Property | Message | Gets the full text of the message sent from the Oracle database.
public Property | Source | Gets the name of the application or the object that threw the event.
Top

See Also

Reference

OracleInfoMessageEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Code Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleInfoMessageEventArgs Class : Code Property

Gets the Oracle specific message code.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As Integer
C#
public int Code {get;}

Property Value

Oracle specific message code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleInfoMessageEventArgs Class
OracleInfoMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Errors Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleInfoMessageEventArgs Class : Errors Property

Returns collection of errors generated by Devart.Data.Oracle.OracleCommand.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Errors As OracleErrorCollection
C#
public OracleErrorCollection Errors {get;}

Property Value

Collection of errors.

Remarks

You can query the Error objects in this collection for the error number and message text, as well as the source of the error. There are also details about the database, stored procedure, and line number that the message came from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleInfoMessageEventArgs Class
OracleInfoMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Message Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleInfoMessageEventArgs Class : Message Property

Gets the full text of the message sent from the Oracle database.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message {get;}

Property Value

Message that Oracle returns.

Remarks

You can use this property to obtain the Oracle message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleInfoMessageEventArgs Class
OracleInfoMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Source Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleInfoMessageEventArgs Class : Source Property

Gets the name of the application or the object that threw the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As String
C#
public string Source {get;}

Property Value

The name of the application or the object that threw the event.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleInfoMessageEventArgs Class
OracleInfoMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoader Class

Serves to load external data into the Oracle database.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbLoader
Devart.Data.Oracle.OracleLoader

Syntax

Visual Basic (Declaration)
Public Class OracleLoader
   Inherits Devart.Common.DbLoader
   Implements IComponent, IDisposable
C#
public class OracleLoader : Devart.Common.DbLoader, IComponent, IDisposable

Remarks

In OCI mode OracleLoader uses direct path load interface to speed up loading. In Direct mode it uses array binding feature. To specify the name of table to load set TableName property. Use Columns property to access individual columns. See example below and Loader sample for detailed information.

As an alternative to providing values in code, demonstrated in the sample below, you can use the Devart.Common.DbLoader.LoadTable method overloads to load data directly from a DataTable, IDataReader, or an array of DataRows.

If you use direct path loading without PartitionName specified, the PRIMARY KEY, UNIQUE, and NOT NULL constaints of the target table are enabled when loading data with OracleLoader. Additionally, you can turn off disabling constraints even when PartitionName is specified with OracleLoaderOptions.KeepConstraints option. Keeping these constraints enebled may cause the following consequences:

  • An attempt to insert NULL into NOT NULL column leads to ORA-01400 at the end of the load.
  • UNIQUE constraints are verified when indexes are rebuilt on OracleLoader.Close(). If UNIQUE constraint is violated, the index state becomes Unusable.
  • The PRIMARY KEY constraint means that column is UNIQUE and NOT NULL simultaneously.

Restrictions of OracleLoader (only for direct path loading):

  • triggers are not supported; use DML Arrays to overcome this limitation
  • check constraints are not supported
  • referential integrity constraints are not supported

The following types are supported when using direct path loading:

  • OracleDbType.Blob
  • OracleDbType.Char
  • OracleDbType.Clob
  • OracleDbType.Integer
  • OracleDbType.IntervalDS
  • OracleDbType.IntervalYM
  • OracleDbType.Double
  • OracleDbType.Date
  • OracleDbType.Number
  • OracleDbType.Raw
  • OracleDbType.Timestamp
  • OracleDbType.TimestampLTZ
  • OracleDbType.TimestampTZ
  • OracleDbType.VarChar

If an unsupported type is found, OracleLoader works via array binding.

You can additionally tweak OracleLoader behavior via its Options property. It allows you to configure OracleLoader to always use array binding even when direct path can be used, not to disable check constraint, aditionally disable indexes, trigger, table logging, etc. See OracleLoaderOptions for more information.

When array binding is used in the OCI connection mode with Oracle 11g Release 2 or higher, OracleLoader generates SQL with the /* APPEND_VALUES */ hint to avoid logging inserts for tables with logging disabled (NOLOGGING).

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example creates an OracleLoader, then populates Columns collection from table description, loads data, flushes the buffer and disposes internal OracleLoader structures. The OracleLoader requires open connection.

The following table is used in this example:

CREATE TABLE LOAD_TABLE(
  ID NUMBER,
  CHAR_FIELD VARCHAR(20),
  DATE_FIELD DATE,
  CONSTRAINT PK_LOAD_TABLE PRIMARY KEY (ID)
);
C#csharp Copy Code
public void LoadData(OracleConnection conn)
{
  // OracleLoader requires open connection
  if (conn.State == ConnectionState.Closed)
    conn.Open();
  OracleLoader loader = new OracleLoader();
  // Specify connection that OracleLoader will use for loading
  loader.Connection = conn;
  // Set table name that will be loaded into
  loader.TableName = "load_table";
  // Populate Columns collection from table description
  loader.CreateColumns();
  // Prepare OracleLoader for loading
  loader.Open();
  for (int i = 0; i < 10000; i++)
  {
    loader.SetValue("id", i);
    loader.SetValue("char_field", "test string");
    loader.SetValue("date_field", DateTime.Now);
    loader.NextRow();
  }
  // Flush buffer and dispose internal OracleLoader structures
  loader.Close();
}
C#Visual Basic Copy Code
Public Sub LoadData(conn As OracleConnection)
  ' OracleLoader requires open connection
  If conn.State = ConnectionState.Closed
    conn.Open()
  End If
  Dim loader As OracleLoader
  loader = new OracleLoader
  ' Specify connection that OracleLoader will use for loading
  loader.Connection = conn
  ' Set table name that will be loaded into
  loader.TableName = "load_table"
  ' Populate Columns collection from table description
  loader.CreateColumns()
  ' Prepare OracleLoader for loading
  loader.Open()
  Dim i As Integer
  For i = 0 To 9999
    loader.SetValue("id", i)
    loader.SetValue("char_field", "test string")
    loader.SetValue("date_field", DateTime.Now)
    loader.NextRow()
  Next i
  ' Flush buffer and dispose internal OracleLoader structures
  loader.Close()
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoader Members
Devart.Data.Oracle Namespace
OracleLoaderColumn Class
OracleLoaderColumnCollection Class
OracleDbType Enumeration


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLoader Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleLoader Class

The following tables list the members exposed by OracleLoader.

Public Constructors

 | Name | Description
public Constructor | OracleLoader Constructor | Overloaded. Initializes a new instance of the OracleLoader class.
Top

Public Properties

 | Name | Description
public Property | BufferSize | Gets or sets a size of data packet loaded to the server. (Inherited from Devart.Common.DbLoader)
public Property | Columns | Gets the Devart.Data.Oracle.OracleLoaderColumnCollection collection.
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleLoader.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Item | Overloaded. Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection. (Inherited from Devart.Common.DbLoader)
public Property | NotifyAfter | Gets or sets the number of loaded rows, after which to generate OracleLoader.RowsCopied event.
public Property | Options | This property allow configuring OracleLoader behavior.
public Property | PartitionName | Gets or sets the name of the table partition from a partitioned table to load data into.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableName | Gets or sets table name that will be loaded.
Top

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes loading session and flushes remaining rows to the table.
public Method | CreateColumns | Overridden. Retrieves table columns information from the table specified in the TableName property and populates columns collection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | LoadTable | Overloaded. Loads data into the table from the specified DataTable. (Inherited from Devart.Common.DbLoader)
public Method | NextRow | Overridden. Advances OracleLoader to the next row.
public Method | Open | Overridden. Prepares OracleLoader for the loading.
public Method | SetDate | Overloaded. Sets the System.DateTime value of the column at the specified ordinal.
public Method | SetDouble | Overloaded. Sets the double-precision floating point value of the column at the specified ordinal.
public Method | SetInt | Overloaded. Sets the integer value of the column at the specified ordinal.
public Method | SetNull | Overloaded. Sets the value of the column with the specified name or ordinal to NULL. (Inherited from Devart.Common.DbLoader)
public Method | SetNumber | Overloaded. Sets the number value of the column at the specified ordinal.
public Method | SetOracleObject | Overloaded. Sets the OracleObject value of the column at the specified ordinal.
public Method | SetString | Overloaded. Sets the System.String value of the column at the specified ordinal.
public Method | SetTimeStamp | Overloaded. Sets the OracleTimeStamp value of the column at the specified ordinal.
public Method | SetValue | Overloaded. Overridden. Sets the value of the column at the specified ordinal and name.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raises when an error occurs during a load operation.
public Event | RowsCopied | This event occurs each time after NotifyAfter number of rows copied. You can use this event to track and show data loading operation progress or abort the operation when necessary.
Top

See Also

Reference

OracleLoader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : OracleLoader Constructor

Initializes a new instance of the OracleLoader class.

Overload List

Overload | Description
OracleLoader Constructor() | Creates an OracleLoader object without Connection and with empty TableName.
OracleLoader Constructor(OracleLoaderOptions) | Creates a new instance of OracleLoader and initializes its Options property with a specified OracleLoaderOptions value.
OracleLoader Constructor(String) | Initializes a new instance of the OracleLoader class with table name that will be loaded.
OracleLoader Constructor(String,OracleConnection) | Initializes a new instance of the OracleLoader class with table name that will be loaded and a OracleConnection object.
OracleLoader Constructor(String,OracleConnection,OracleLoaderOptions) | Creates a new instance of OracleLoader and initializes its Options, TableName, and Connection properties with specified values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > OracleLoader Constructor : OracleLoader Constructor()

Creates an OracleLoader object without Connection and with empty TableName.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleLoader()

Remarks

To use an OracleLoader object created with this constructor you must set Connection and TableName properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor(OracleLoaderOptions)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > OracleLoader Constructor : OracleLoader Constructor(OracleLoaderOptions)

options
The OracleLoaderOptions value to assign to the Options property of the new OracleLoader instance.
Creates a new instance of OracleLoader and initializes its Options property with a specified OracleLoaderOptions value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal options As OracleLoaderOptions _
)
C#
public OracleLoader(
   OracleLoaderOptions options
)

Parameters

options
The OracleLoaderOptions value to assign to the Options property of the new OracleLoader instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor(String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > OracleLoader Constructor : OracleLoader Constructor(String)

tableName
Name of the table that will be loaded.
Initializes a new instance of the OracleLoader class with table name that will be loaded.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As String _
)
C#
public OracleLoader(
   string tableName
)

Parameters

tableName
Name of the table that will be loaded.

Remarks

The constructor initializes all fields to their default values and set TableName to tableName parameter.

Example

The following example creates a OracleLoader and sets some of its properties. Then prepares data and loads it into the table.
C#csharp Copy Code
public void CreateMyLoader()
{
  // Create and open connection
  OracleConnection conn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  conn.Open();

  // Create loader instance
  OracleLoader loader = new OracleLoader("loader_test");
  // Set loader properties
  loader.Connection = conn;

  // Prepare for loading
  loader.Open();

  // Set row values
  for (int i = 0; i < 10000; i++) {
    loader.SetValue(0, i);
    loader.SetValue(1, "test string");
    loader.SetValue(2, DateTime.Now);
    // Load next table row
    loader.NextRow();
  }

  // Flush buffer and finish loading
  loader.Close();
}
C#Visual Basic Copy Code
Public Sub CreateMyLoader()
  ' Create and open connection
  Dim conn As OracleConnection = new OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  conn.Open()

  ' Create loader instance
  Dim loader As OracleLoader = new OracleLoader("loader_test")
  ' Set loader properties
  loader.Connection = conn

  ' Prepare for loading
  loader.Open()

  ' Set row values
  Dim i As Integer
  For i = 0 To 10000
    loader.SetValue(0, i)
    loader.SetValue(1, "test string")
    loader.SetValue(2, DateTime.Now)
    ' Load next table row
    loader.NextRow()
  next

  ' Flush buffer and finish loading
  loader.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List
OracleLoaderColumn Class
OracleLoaderColumnCollection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor(String,OracleConnection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > OracleLoader Constructor : OracleLoader Constructor(String,OracleConnection)

tableName
Name of the table that will be loaded.
connection
A OracleConnection object that represents the connection to a data source.
Initializes a new instance of the OracleLoader class with table name that will be loaded and a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleLoader(
   string tableName,
   OracleConnection connection
)

Parameters

tableName
Name of the table that will be loaded.
connection
A OracleConnection object that represents the connection to a data source.

Remarks

Use this constructor to set TableName and Connection properties at the time of initialization.

Example

The following example creates a OracleLoader and sets some of its properties. Then prepares data and loads it into the table.
C#csharp Copy Code
public void CreateMyLoader()
{
  // Create and open connection
  OracleConnection conn = new OracleConnection(
      "User Id=Scott;Password=tiger;Data Source=Ora;");
  conn.Open();

  // Create loader instance
  OracleLoader loader = new OracleLoader("loader_test", conn);

  // Prepare for loading
  loader.Open();

  // Set row values
  for (int i = 0; i < 10000; i++) {
    loader.SetValue(0, i);
    loader.SetValue(1, "test string");
    loader.SetValue(2, DateTime.Now);
    // Load next table row
    loader.NextRow();
  }

  // Flush buffer and finish loading
  loader.Close();
}
C#Visual Basic Copy Code
Public Sub CreateMyLoader()
  ' Create and open connection
  Dim conn As OracleConnection = new OracleConnection( _
      "User Id=Scott;Password=tiger;Data Source=Ora;")
  conn.Open()

  ' Create loader instance
  Dim loader As OracleLoader = new OracleLoader("loader_test", conn)

  ' Prepare for loading
  loader.Open()

  ' Set row values
  Dim i As Integer
  For i = 0 To 10000
    loader.SetValue(0, i)
    loader.SetValue(1, "test string")
    loader.SetValue(2, DateTime.Now)
    ' Load next table row
    loader.NextRow()
  next

  ' Flush buffer and finish loading
  loader.Close()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List
OracleLoaderColumn Class
OracleLoaderColumnCollection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoader Constructor(String,OracleConnection,OracleLoaderOptions)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > OracleLoader Constructor : OracleLoader Constructor(String,OracleConnection,OracleLoaderOptions)

tableName
The name of the target table for loading data.
connection
The OracleConnection object to assign to the Connection property of the new OracleLoader instance.
options
The OracleLoaderOptions value to assign to the Options property of the new OracleLoader instance.
Creates a new instance of OracleLoader and initializes its Options, TableName, and Connection properties with specified values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As String, _
   ByVal connection As OracleConnection, _
   ByVal options As OracleLoaderOptions _
)
C#
public OracleLoader(
   string tableName,
   OracleConnection connection,
   OracleLoaderOptions options
)

Parameters

tableName
The name of the target table for loading data.
connection
The OracleConnection object to assign to the Connection property of the new OracleLoader instance.
options
The OracleLoaderOptions value to assign to the Options property of the new OracleLoader instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleLoader Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoader Class

For a list of all members of this type, see OracleLoader members.

Public Methods

 | Name | Description
public Method | Close | Overridden. Closes loading session and flushes remaining rows to the table.
public Method | CreateColumns | Overridden. Retrieves table columns information from the table specified in the TableName property and populates columns collection.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | LoadTable | Overloaded. Loads data into the table from the specified DataTable. (Inherited from Devart.Common.DbLoader)
public Method | NextRow | Overridden. Advances OracleLoader to the next row.
public Method | Open | Overridden. Prepares OracleLoader for the loading.
public Method | SetDate | Overloaded. Sets the System.DateTime value of the column at the specified ordinal.
public Method | SetDouble | Overloaded. Sets the double-precision floating point value of the column at the specified ordinal.
public Method | SetInt | Overloaded. Sets the integer value of the column at the specified ordinal.
public Method | SetNull | Overloaded. Sets the value of the column with the specified name or ordinal to NULL. (Inherited from Devart.Common.DbLoader)
public Method | SetNumber | Overloaded. Sets the number value of the column at the specified ordinal.
public Method | SetOracleObject | Overloaded. Sets the OracleObject value of the column at the specified ordinal.
public Method | SetString | Overloaded. Sets the System.String value of the column at the specified ordinal.
public Method | SetTimeStamp | Overloaded. Sets the OracleTimeStamp value of the column at the specified ordinal.
public Method | SetValue | Overloaded. Overridden. Sets the value of the column at the specified ordinal and name.
Top

See Also

Reference

OracleLoader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Close Method

Closes loading session and flushes remaining rows to the table.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

You must call Close method after finishing of loading session. If rows exist in the loader internal buffer, they will be flushed to the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateColumns() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : CreateColumns() Method

Retrieves table columns information from the table specified in the TableName property and populates columns collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub CreateColumns()
C#
public override void CreateColumns()

Remarks

If Columns property consists of some columns they will be deleted before calling CreateColumns() method. TableName property must be set before calling this method.

CreateColumns() retrieves all columns from the table. It means that when inserting the data, SQL INSERT statement is generated for all of the columns, regardless of how many you have assigned with SetValue method. The columns you have omitted are considered to be of NULL value. If you want to generate the statements for chosen columns only, you have to manually edit the collection.

Note: This method is not supported in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Note that "GENERATED ALWAYS AS IDENTITY" columns, introduced in Oracle 12c should not be included in the Columns collection. In the OCI mode, dotConnect for Oracle automatically detects such columns and skips them when creating the Columns collection. In the OracleConnection.Direct mode you should manually delete such columns from the created collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NextRow Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : NextRow Method

Advances OracleLoader to the next row.

Syntax

Visual Basic (Declaration)
Public Overrides Sub NextRow()
C#
public override void NextRow()

Remarks

Call this method after you put the row to the OracleLoader internal buffer. If OracleLoader rows buffer is full NextRow method flushes rows buffer to the loading table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Open Method

Prepares OracleLoader for the loading.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Open()
C#
public override void Open()

Remarks

Use Open method to prepare internal OracleLoader structures for loading. If you do not call this method explicitly it will be called automatically.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetDate Method

Sets the System.DateTime value of the column at the specified ordinal.

Overload List

Overload | Description
SetDate(String,DateTime) | Sets the System.DateTime value of the column with the specified name.
SetDate(Int32,DateTime) | Sets the System.DateTime value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDate(String,DateTime) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetDate Method : SetDate(String,DateTime) Method

name
The name of the column.
value
System.DateTime value for the specified column.
Sets the System.DateTime value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDate( _
   ByVal name As String, _
   ByVal value As Date _
)
C#
public void SetDate(
   string name,
   DateTime value
)

Parameters

name
The name of the column.
value
System.DateTime value for the specified column.

Remarks

Use SetDate(String,DateTime) method to set column with specific name in the current row to the System.DateTime value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDate(Int32,DateTime) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetDate Method : SetDate(Int32,DateTime) Method

i
Zero-based index of the column.
value
System.DateTime value for the specified column.
Sets the System.DateTime value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDate( _
   ByVal i As Integer, _
   ByVal value As Date _
)
C#
public void SetDate(
   int i,
   DateTime value
)

Parameters

i
Zero-based index of the column.
value
System.DateTime value for the specified column.

Remarks

Use SetDate(Int32,DateTime) method to set column with specific index in the current row to the System.DateTime value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDouble Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetDouble Method

Sets the double-precision floating point value of the column at the specified ordinal.

Overload List

Overload | Description
SetDouble(String,Double) | Sets the double-precision floating point value of the column with the specified name.
SetDouble(Int32,Double) | Sets the double-precision floating point value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDouble(String,Double) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetDouble Method : SetDouble(String,Double) Method

name
The name of the column.
value
Double-precision floating point value for the specified column.
Sets the double-precision floating point value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDouble( _
   ByVal name As String, _
   ByVal value As Double _
)
C#
public void SetDouble(
   string name,
   double value
)

Parameters

name
The name of the column.
value
Double-precision floating point value for the specified column.

Remarks

Use SetDouble(String,Double) method to set column with specific name in the current row to the double-precision floating point value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetDouble(Int32,Double) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetDouble Method : SetDouble(Int32,Double) Method

i
Zero-based index of the column.
value
Double-precision floating point value for the specified column.
Sets the double-precision floating point value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetDouble( _
   ByVal i As Integer, _
   ByVal value As Double _
)
C#
public void SetDouble(
   int i,
   double value
)

Parameters

i
Zero-based index of the column.
value
Double-precision floating point value for the specified column.

Remarks

Use SetDouble(Int32,Double) method to set column with specific index in the current row to the integer value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetInt Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetInt Method

Sets the integer value of the column at the specified ordinal.

Overload List

Overload | Description
SetInt(String,Int32) | Sets the integer value of the column with the specified name.
SetInt(Int32,Int32) | Sets the integer value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetInt(String,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetInt Method : SetInt(String,Int32) Method

name
The name of the column.
value
Integer value for the specified column.
Sets the integer value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetInt( _
   ByVal name As String, _
   ByVal value As Integer _
)
C#
public void SetInt(
   string name,
   int value
)

Parameters

name
The name of the column.
value
Integer value for the specified column.

Remarks

Use SetInt(String,Int32) method to set column with specific name in the current row to the integer value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetInt(Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetInt Method : SetInt(Int32,Int32) Method

i
Zero-based index of the column.
value
Integer value for the specified column.
Sets the integer value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetInt( _
   ByVal i As Integer, _
   ByVal value As Integer _
)
C#
public void SetInt(
   int i,
   int value
)

Parameters

i
Zero-based index of the column.
value
Integer value for the specified column.

Remarks

Use SetInt(Int32,Int32) method to set column with specific index in the current row to the integer value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNumber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetNumber Method

Sets the number value of the column at the specified ordinal.

Overload List

Overload | Description
SetNumber(String,OracleNumber) | Sets the number value of the column with the specified name.
SetNumber(Int32,OracleNumber) | Sets the number value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNumber(String,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetNumber Method : SetNumber(String,OracleNumber) Method

name
The name of the column.
value
OracleNumber value for the specified column.
Sets the number value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetNumber( _
   ByVal name As String, _
   ByVal value As OracleNumber _
)
C#
public void SetNumber(
   string name,
   OracleNumber value
)

Parameters

name
The name of the column.
value
OracleNumber value for the specified column.

Remarks

Use SetNumber(String,OracleNumber) method to set column with specific name in the current row to the number value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetNumber(Int32,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetNumber Method : SetNumber(Int32,OracleNumber) Method

i
Zero-based index of the column.
value
OracleNumber value for the specified column.
Sets the number value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetNumber( _
   ByVal i As Integer, _
   ByVal value As OracleNumber _
)
C#
public void SetNumber(
   int i,
   OracleNumber value
)

Parameters

i
Zero-based index of the column.
value
OracleNumber value for the specified column.

Remarks

Use SetNumber(Int32,OracleNumber) method to set column with specific index in the current row to the number value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetOracleObject Method

Sets the OracleObject value of the column at the specified ordinal.

Overload List

Overload | Description
SetOracleObject(String,OracleObject) |
SetOracleObject(Int32,OracleObject) | Sets the OracleObject value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetOracleObject(String,OracleObject) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetOracleObject Method : SetOracleObject(String,OracleObject) Method

name
value

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetOracleObject( _
   ByVal name As String, _
   ByVal value As OracleObject _
)
C#
public void SetOracleObject(
   string name,
   OracleObject value
)

Parameters

name
value

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetOracleObject(Int32,OracleObject) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetOracleObject Method : SetOracleObject(Int32,OracleObject) Method

i
Zero-based index of the column.
value
An OracleObject value.
Sets the OracleObject value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetOracleObject( _
   ByVal i As Integer, _
   ByVal value As OracleObject _
)
C#
public void SetOracleObject(
   int i,
   OracleObject value
)

Parameters

i
Zero-based index of the column.
value
An OracleObject value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetString Method

Sets the System.String value of the column at the specified ordinal.

Overload List

Overload | Description
SetString(String,String) | Sets the System.String value of the column with the specified name.
SetString(Int32,String) | Sets the System.String value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetString(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetString Method : SetString(String,String) Method

name
The name of the column.
value
System.String value for the specified column.
Sets the System.String value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetString( _
   ByVal name As String, _
   ByVal value As String _
)
C#
public void SetString(
   string name,
   string value
)

Parameters

name
The name of the column.
value
System.String value for the specified column.

Remarks

Use SetString(String,String) method to set column with specific name in the current row to the System.String value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetString(Int32,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetString Method : SetString(Int32,String) Method

i
Zero-based index of the column.
value
System.String value for the specified column.
Sets the System.String value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetString( _
   ByVal i As Integer, _
   ByVal value As String _
)
C#
public void SetString(
   int i,
   string value
)

Parameters

i
Zero-based index of the column.
value
System.String value for the specified column.

Remarks

Use SetString(Int32,String) method to set column with specific index in the current row to the System.String value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetTimeStamp Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetTimeStamp Method

Sets the OracleTimeStamp value of the column at the specified ordinal.

Overload List

Overload | Description
SetTimeStamp(String,OracleTimeStamp) | Sets the OracleTimeStamp value of the column with the specified name.
SetTimeStamp(Int32,OracleTimeStamp) | Sets the OracleTimeStamp value of the column at the specified ordinal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetTimeStamp(String,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetTimeStamp Method : SetTimeStamp(String,OracleTimeStamp) Method

name
The name of the column.
value
OracleTimeStamp value for the specified column.
Sets the OracleTimeStamp value of the column with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetTimeStamp( _
   ByVal name As String, _
   ByVal value As OracleTimeStamp _
)
C#
public void SetTimeStamp(
   string name,
   OracleTimeStamp value
)

Parameters

name
The name of the column.
value
OracleTimeStamp value for the specified column.

Remarks

Use SetTimeStamp(String,OracleTimeStamp) method to set column with specific name in the current row to the OracleTimeStamp value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetTimeStamp(Int32,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetTimeStamp Method : SetTimeStamp(Int32,OracleTimeStamp) Method

i
Zero-based index of the column.
value
OracleTimeStamp value for the specified column.
Sets the OracleTimeStamp value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetTimeStamp( _
   ByVal i As Integer, _
   ByVal value As OracleTimeStamp _
)
C#
public void SetTimeStamp(
   int i,
   OracleTimeStamp value
)

Parameters

i
Zero-based index of the column.
value
OracleTimeStamp value for the specified column.

Remarks

Use SetTimeStamp(Int32,OracleTimeStamp) method to set column with specific index in the current row to the OracleTimeStamp value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : SetValue Method

Sets the value of the column at the specified ordinal and name.

Overload List

Overload | Description
SetValue(Int32,Object) | Sets the value of the column at the specified ordinal.
SetValue(String,Object) | Sets the value of the column with the specified name. (Inherited from Devart.Common.DbLoader)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetValue(Int32,Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class > SetValue Method : SetValue(Int32,Object) Method

i
Zero-based index of the column.
value
Column value.
Sets the value of the column at the specified ordinal.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub SetValue( _
   ByVal i As Integer, _
   ByVal value As Object _
)
C#
public override void SetValue(
   int i,
   object value
)

Parameters

i
Zero-based index of the column.
value
Column value.

Remarks

Use SetValue(Int32,Object) method to set column with specific index in the current row to the value. To assign a column NULL value use Devart.Common.DbLoader.SetNull method instead.

The columns that you did not explicitly assign a value are considered to be NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
Overload List
SetNull Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLoader Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoader Class

For a list of all members of this type, see OracleLoader members.

Public Properties

 | Name | Description
public Property | BufferSize | Gets or sets a size of data packet loaded to the server. (Inherited from Devart.Common.DbLoader)
public Property | Columns | Gets the Devart.Data.Oracle.OracleLoaderColumnCollection collection.
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleLoader.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Item | Overloaded. Sets the value of the column with the specified name for Devart.Common.DbLoaderColumnCollection. (Inherited from Devart.Common.DbLoader)
public Property | NotifyAfter | Gets or sets the number of loaded rows, after which to generate OracleLoader.RowsCopied event.
public Property | Options | This property allow configuring OracleLoader behavior.
public Property | PartitionName | Gets or sets the name of the table partition from a partitioned table to load data into.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableName | Gets or sets table name that will be loaded.
Top

See Also

Reference

OracleLoader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Columns Property

Gets the Devart.Data.Oracle.OracleLoaderColumnCollection collection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Columns As OracleLoaderColumnCollection
C#
public new OracleLoaderColumnCollection Columns {get;}

Property Value

Columns which loaded table consist of.

Remarks

You may manually add columns to the Devart.Data.Oracle.OracleLoaderColumnCollection or call CreateColumns() method to populate columns collection from the table description.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Connection Property

Gets or sets the OracleConnection used by this instance of the OracleLoader.

Syntax

Visual Basic (Declaration)
Public Shadows Property Connection As OracleConnection
C#
public new OracleConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Remarks

OracleLoader instance uses OracleConnection during loading and for populating columns collection when CreateColumns() method is called. For these operations OracleLoader requires open connection.

This property supports the InterForm technology.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotifyAfter Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : NotifyAfter Property

Gets or sets the number of loaded rows, after which to generate RowsCopied event.

Syntax

Visual Basic (Declaration)
Public Property NotifyAfter As Integer
C#
public int NotifyAfter {get; set;}

Property Value

The number of loaded rows, after which to generate RowsCopied event.

Remarks

Default value is 0. It means that the RowsCopied event never occurs.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Options Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Options Property

This property allow configuring OracleLoader behavior.

Syntax

Visual Basic (Declaration)
Public Property Options As OracleLoaderOptions
C#
public OracleLoaderOptions Options {get; set;}

Property Value

A value of OracleLoaderOptions type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PartitionName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : PartitionName Property

Gets or sets the name of the table partition from a partitioned table to load data into.

Syntax

Visual Basic (Declaration)
Public Property PartitionName As String
C#
public string PartitionName {get; set;}

Property Value

The name of the table partition from a partitioned table to load data into.

Remarks

When loading data via Direct Path interface (in the OCI connection mode), OracleLoader additionally disables the destination table primary key and foreign keys to the table when the PartitionName property is set in order to avoid the "ORA-26017: global indexes not allowed for direct path load of table partition" error. After the data are loaded, OracleLoader enables these constraints again.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : TableName Property

Gets or sets table name that will be loaded.

Syntax

Visual Basic (Declaration)
Public Shadows Property TableName As String
C#
public new string TableName {get; set;}

Property Value

Name of the table that will be loaded.

Remarks

TableName property must be specified before beginning of loading data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
SetValue Method


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleLoader Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoader Class

For a list of all members of this type, see OracleLoader members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Raises when an error occurs during a load operation.
public Event | RowsCopied | This event occurs each time after NotifyAfter number of rows copied. You can use this event to track and show data loading operation progress or abort the operation when necessary.
Top

See Also

Reference

OracleLoader Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Error Event
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : Error Event

Raises when an error occurs during a load operation.

Syntax

Visual Basic (Declaration)
Public Event Error As OracleLoaderErrorEventHandler
C#
public event OracleLoaderErrorEventHandler Error

Event Data

The event handler receives an argument of type OracleLoaderErrorEventArgs containing data related to this event. The following OracleLoaderErrorEventArgs properties provide information specific to this event.

Property | Description
Column | Gets column number where an error occurred.
Exception | Gets the OracleException instance that an OracleLoader throws.
Ignore | Gets or sets whether the current error will be ignored or not.
Row | Gets row number where an error occurred.

Remarks

The event handler receives an argument of OracleLoaderErrorEventArgs type containing data related to this event. The following OracleLoaderErrorEventArgs properties provide information specific to this event:
Property | Description
OracleLoaderErrorEventArgs.Column | Gets column where an error occurred.
OracleLoaderErrorEventArgs.Row | Gets row where an error occurred.
OracleLoaderErrorEventArgs.Exception | Gets OracleException object with error specific information.
OracleLoaderErrorEventArgs.Ignore | Specifies whether current error will be ignored.

Clients that want to process errors raised by the server should create an OracleLoaderErrorEventHandler delegate to listen to this event.

Example

The following sample demonstrates using the Error event. Perform the following script against the database before executing the code:

CREATE TABLE DEPT(
  DEPTNO INTEGER PRIMARY KEY,
  DNAME VARCHAR(14),
  LOC VARCHAR(13)
);

INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');
INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');
INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');
INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');
C#csharp Copy Code
static void Main(string[] args)
{
        OracleConnection connection = new OracleConnection("your connection string");
        connection.Open();
        connection.AutoCommit = true;

        OracleLoader loader = new OracleLoader();
        loader.Connection = connection;
        loader.Error += new OracleLoaderErrorEventHandler(loader_Error);
        loader.TableName = "dept";
        loader.CreateColumns();
        loader.Open();

        loader.SetValue("deptno", 10);
        loader.SetValue("dname", "test");
        loader.SetValue("loc", "test");
        loader.NextRow();

        loader.SetValue("deptno", 20);
        loader.SetValue("dname", "test");
        loader.SetValue("loc", "test");
        loader.NextRow();

        loader.SetValue("deptno", 92);
        loader.SetValue("dname", "test");
        loader.SetValue("loc", "test");
        loader.NextRow();
        loader.Close();
}

static void loader_Error(object sender, OracleLoaderErrorEventArgs e)
{
        if (e.Exception.Errors == null)
                Console.WriteLine(e.Exception.Message);
        else
        {
                foreach (OracleError error in e.Exception.Errors)
                        Console.WriteLine(error.Message);
        }
        e.Ignore = true;
}
C#Visual Basic Copy Code
Sub Main()
        Dim connection As New OracleConnection("your connection string")
        connection.Open()
        connection.AutoCommit = True

        Dim loader As New OracleLoader()
        loader.Connection = connection
        AddHandler loader.Error, New OracleLoaderErrorEventHandler(AddressOf loader_Error)
        loader.TableName = "dept"
        loader.CreateColumns()
        loader.Open()

        loader.SetValue("deptno", 10)
        loader.SetValue("dname", "test")
        loader.SetValue("loc", "test")
        loader.NextRow()

        loader.SetValue("deptno", 20)
        loader.SetValue("dname", "test")
        loader.SetValue("loc", "test")
        loader.NextRow()

        loader.SetValue("deptno", 92)
        loader.SetValue("dname", "test")
        loader.SetValue("loc", "test")
        loader.NextRow()
        loader.Close()
End Sub

Sub loader_Error(sender As Object, e As OracleLoaderErrorEventArgs)
        If e.Exception.Errors Is Nothing Then
                Console.WriteLine(e.Exception.Message)
        Else
                For Each err As OracleError In e.Exception.Errors
                        Console.WriteLine(err.Message)
                Next
        End If
        e.Ignore = True
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowsCopied Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : RowsCopied Event

This event occurs each time after NotifyAfter number of rows copied. You can use this event to track and show data loading operation progress or abort the operation when necessary.

Syntax

Visual Basic (Declaration)
Public Event RowsCopied As OracleLoaderRowsCopiedEventHandler
C#
public event OracleLoaderRowsCopiedEventHandler RowsCopied

Event Data

The event handler receives an argument of type OracleLoaderRowsCopiedEventArgs containing data related to this event. The following OracleLoaderRowsCopiedEventArgs properties provide information specific to this event.

Property | Description
Abort | Specifies whether to abort the data loading operation.
RowsCopied | Gets the number of rows processed since the previous RowsCopied event call.

Remarks

This evect can be useful to display the data loading operation progress, when the operation is started via the Devart.Common.DbLoader.LoadTable method.

To abort the operation, set OracleLoaderRowsCopiedEventArgs.Abort to true. In this case OracleLoader frees all resources correctly and generates System.OperationCanceledException, which you can catch and process in your code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members
OracleLoaderRowsCopiedEventArgs Class
OracleLoaderRowsCopiedEventHandler Delegate


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumn Class

Represents the attributes for column loading.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Common.DbLoaderColumn
Devart.Data.Oracle.OracleLoaderColumn

Syntax

Visual Basic (Declaration)
Public Class OracleLoaderColumn
   Inherits Devart.Common.DbLoaderColumn
C#
public class OracleLoaderColumn : Devart.Common.DbLoaderColumn

Remarks

Each OracleLoader uses a Columns to maintain a collection of Devart.Data.Oracle.OracleLoaderColumn objects. The Devart.Data.Oracle.OracleLoaderColumn object represents the attributes for column loading. Every Devart.Data.Oracle.OracleLoaderColumn object corresponds to one of the table fields with the same name as its Devart.Common.DbLoaderColumn.Name property.

You can manually make changes to the Columns collection to exclude some columns from INSERT statement generated by OracleLoader object.

Note: This class is available with dotConnect for Oracle Professional edition only.

Example

This sample shows how to perform loading of data into a table with the last column set to default value.
C#csharp Copy Code
public void LoadData(OracleConnection myConnection)
{
  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  try
  {
    loader.CreateColumns();
    //Do not insert data in the last column
    loader.Columns.RemoveAt(loader.Columns.Count-1);
    loader.Open();
    for (int i = 1; i <= 100; i++)
    {
      loader.SetValue("id", i);
      loader.SetValue(1, "test string");
      loader.SetValue("date_field", DateTime.Now);
      loader.NextRow();
    }
    loader.Close();
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub LoadData(ByVal myConnection As OracleConnection)
  myConnection.Open()
  Dim loader As OracleLoader
  loader = New OracleLoader
  loader.Connection = myConnection
  loader.TableName = "load_table"
  Try
    loader.CreateColumns()
    ' Do not insert data in the last column
    loader.Columns.RemoveAt(loader.Columns.Count - 1)
    loader.Open()
    Dim i As Integer
    For i = 1 To 100
      loader.SetValue("id", i)
      loader.SetValue(1, "test string")
      loader.SetValue("date_field", DateTime.Now)
      loader.NextRow()
    Next i
    loader.Close()
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderColumn Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumn Class

The following tables list the members exposed by OracleLoaderColumn.

Public Constructors

 | Name | Description
public Constructor | OracleLoaderColumn Constructor | Overloaded. Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class.
Top

Public Properties

 | Name | Description
public Property | DateFormat | Gets or sets date format of the Devart.Data.Oracle.OracleLoaderColumn.
public Property | Name | Gets or sets the name of the Devart.Common.DbLoaderColumn. (Inherited from Devart.Common.DbLoaderColumn)
public Property | ObjectTypeName | Gets or sets the name of the user-defined type.
public Property | OracleDbType | Gets or sets the OracleDbType of the column.
public Property | Precision | Overridden. Gets or sets precision of values within the column.
public Property | Scale | Gets or sets the number of decimal places to which column value is resolved. (Inherited from Devart.Common.DbLoaderColumn)
public Property | Size | Overridden. Gets or sets the maximum size, in bytes, of the data within the column.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleLoaderColumn Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : OracleLoaderColumn Constructor

Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class.

Overload List

Overload | Description
OracleLoaderColumn Constructor() | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class.
OracleLoaderColumn Constructor(String,OracleDbType) | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name and column data type.
OracleLoaderColumn Constructor(String,OracleDbType,Int32) | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type and column size.
OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32) | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type, column size, precision and scale.
OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32,String) | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type, column size, precision, scale and date format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class > OracleLoaderColumn Constructor : OracleLoaderColumn Constructor()

Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleLoaderColumn()

Remarks

Use this constructor to create an Devart.Data.Oracle.OracleLoaderColumn instance

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor(String,OracleDbType)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class > OracleLoaderColumn Constructor : OracleLoaderColumn Constructor(String,OracleDbType)

name
The name of the column.
dbType
Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name and column data type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dbType As OracleDbType _
)
C#
public OracleLoaderColumn(
   string name,
   OracleDbType dbType
)

Parameters

name
The name of the column.
dbType

Remarks

Use this constructor to create a Devart.Data.Oracle.OracleLoaderColumn instance with column name and column data type.

Example

The following example creates a Devart.Data.Oracle.OracleLoaderColumn and sets some of its properties.
C#csharp Copy Code
public void CreateMyLoaderColumn()
{
  OracleLoaderColumn column = new OracleLoaderColumn("DName", OracleDbType.VarChar);
  column.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateMyLoaderColumn()
  Dim column As OracleLoaderColumn
  column = New OracleLoaderColumn("DName", OracleDbType.VarChar)
  column.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor(String,OracleDbType,Int32)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class > OracleLoaderColumn Constructor : OracleLoaderColumn Constructor(String,OracleDbType,Int32)

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data (only for strings).
Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type and column size.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer _
)
C#
public OracleLoaderColumn(
   string name,
   OracleDbType dbType,
   int size
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data (only for strings).

Remarks

Use this constructor to create a Devart.Data.Oracle.OracleLoaderColumn instance with column name, column data type and column data size.

Example

The following example creates a Devart.Data.Oracle.OracleLoaderColumn and sets some of its properties.
C#csharp Copy Code
public void CreateMyLoaderColumn(OracleLoader loader)
{
  ...
  OracleLoaderColumn column = new OracleLoaderColumn("dname", OracleDbType.VarChar, 25);
  loader.Add(column);
  ...
}
C#Visual Basic Copy Code
Public Sub CreateMyLoaderColumn(loader as OracleLoader)
  ...
  Dim column as OracleLoaderColumn = new OracleLoaderColumn("dname", OracleDbType.VarChar, 25)
  loader.Add(column)
  ...
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class > OracleLoaderColumn Constructor : OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32)

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.
Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type, column size, precision and scale.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal precision As Integer, _
   ByVal scale As Integer _
)
C#
public OracleLoaderColumn(
   string name,
   OracleDbType dbType,
   int size,
   int precision,
   int scale
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.

Remarks

Use this constructor to create a Devart.Data.Oracle.OracleLoaderColumn instance with custom column name, data type, data size, precision and scale.

Example

The following example creates a Devart.Data.Oracle.OracleLoaderColumn and sets some of its properties.
C#csharp Copy Code
public void CreateMyLoaderColumn(OracleLoader loader)
{
  ...
  OracleLoaderColumn column = new OracleLoaderColumn("deptno", OracleDbType.Integer, 0, 6, 0);
  loader.Add(column);
  ...
}
C#Visual Basic Copy Code
Public Sub CreateMyLoaderColumn(loader as OracleLoader)
  ...
  Dim column as OracleLoaderColumn = new OracleLoaderColumn("deptno", OracleDbType.Integer, 0, 6, 0)
  loader.Add(column)
  ...
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class > OracleLoaderColumn Constructor : OracleLoaderColumn Constructor(String,OracleDbType,Int32,Int32,Int32,String)

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.
dateFormat
Date format for the column.
Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumn class with the column name, column data type, column size, precision, scale and date format.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal precision As Integer, _
   ByVal scale As Integer, _
   ByVal dateFormat As String _
)
C#
public OracleLoaderColumn(
   string name,
   OracleDbType dbType,
   int size,
   int precision,
   int scale,
   string dateFormat
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of column data.
precision
The precision of the column.
scale
The scale of the column.
dateFormat
Date format for the column.

Remarks

Use this constructor to create a Devart.Data.Oracle.OracleLoaderColumn instance with custom column name, data type, data size, precision and scale.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumn Class

For a list of all members of this type, see OracleLoaderColumn members.

Public Properties

 | Name | Description
public Property | DateFormat | Gets or sets date format of the Devart.Data.Oracle.OracleLoaderColumn.
public Property | Name | Gets or sets the name of the Devart.Common.DbLoaderColumn. (Inherited from Devart.Common.DbLoaderColumn)
public Property | ObjectTypeName | Gets or sets the name of the user-defined type.
public Property | OracleDbType | Gets or sets the OracleDbType of the column.
public Property | Precision | Overridden. Gets or sets precision of values within the column.
public Property | Scale | Gets or sets the number of decimal places to which column value is resolved. (Inherited from Devart.Common.DbLoaderColumn)
public Property | Size | Overridden. Gets or sets the maximum size, in bytes, of the data within the column.
Top

See Also

Reference

OracleLoaderColumn Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DateFormat Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : DateFormat Property

Gets or sets date format of the Devart.Data.Oracle.OracleLoaderColumn.

Syntax

Visual Basic (Declaration)
Public Property DateFormat As String
C#
public string DateFormat {get; set;}

Property Value

The date format into which loaded data will be converted.

Remarks

Set DateFormat property to specify conversion mask for the column. OracleLoader uses DateFormat to convert string representation of date to it internal representation. If not set, the date format defaults to the date conversion mask set in the direct path context.

Format string must use Oracle datetime format model. For example, format string 'DD-MON-RR' will correspond to '27-OCT-89' date string representation.

Example

The following example creates an Devart.Data.Oracle.OracleLoaderColumn and sets DateFormat property.
C#csharp Copy Code
public void CreateOraLoaderColumn(OracleLoader loader)
{
  ...
  OracleLoaderColumn column = new OracleLoaderColumn("hiredate", OracleDbType.Date);
  column.DateFormat = "DD-MON-YYYY";
  ...
}
C#Visual Basic Copy Code
Public Sub CreateOraLoaderColumn(loader as OracleLoader)
  ...
  Dim column As OracleLoaderColumn = new OracleLoaderColumn("hiredate", OracleDbType.Date)
  column.DateFormat = "DD-MON-YYYY"
  ...
End Sub 'CreateOraLoaderColumn

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : ObjectTypeName Property

Gets or sets the name of the user-defined type.

Syntax

Visual Basic (Declaration)
Public Property ObjectTypeName As String
C#
public string ObjectTypeName {get; set;}

Property Value

The name of the user-defined type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDbType Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : OracleDbType Property

Gets or sets the OracleDbType of the column.

Syntax

Visual Basic (Declaration)
Public Property OracleDbType As OracleDbType
C#
public OracleDbType OracleDbType {get; set;}

Property Value

A OracleDbType value of the column. The default value is OracleDbType.VarChar.

Remarks

Use OracleDbType property to specify Oracle data type for the column.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{
  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetDataColumns(ByVal myConnection As OracleConnection)
  myConnection.Open()
  Dim loader As OracleLoader
  loader = New OracleLoader
  loader.Connection = myConnection
  loader.TableName = "load_table"
  Dim myColumn As OracleLoaderColumn
  Try
    loader.CreateColumns()
    Dim i As Integer
    For i = 0 To loader.Columns.Count - 1
      myColumn = loader.Columns(i)
      Console.WriteLine(myColumn.Name)
      Console.WriteLine(myColumn.OracleDbType.ToString())
      Console.WriteLine(myColumn.Size)
      Console.WriteLine(myColumn.Scale)
      Console.WriteLine(myColumn.Precision)
      Console.WriteLine()
    Next i
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
CreateColumns Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Precision Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : Precision Property

Gets or sets precision of values within the column.

Syntax

Visual Basic (Declaration)
Public Overrides Property Precision As Integer
C#
public override int Precision {get; set;}

Property Value

Precision of the data within the column.

Remarks

Use Precision property to set precision of values for the column. Precision is used only for numeric columns.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Size Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumn Class : Size Property

Gets or sets the maximum size, in bytes, of the data within the column.

Syntax

Visual Basic (Declaration)
Public Overrides Property Size As Integer
C#
public override int Size {get; set;}

Property Value

The maximum size, in bytes, of the data within the column.

Remarks

Use Size property to set maximum size in bytes of data for the column. Size is used only for string columns.

Example

C#csharp Copy Code
public void GetDataColumns(OracleConnection myConnection)
{
  myConnection.Open();
  OracleLoader loader = new OracleLoader();
  loader.Connection = myConnection;
  loader.TableName = "load_table";
  OracleLoaderColumn myColumn;
  try
  {
    loader.CreateColumns();
    for (int i = 0; i < loader.Columns.Count; i++)
    {
      myColumn = loader.Columns[i];
      Console.WriteLine(myColumn.Name);
      Console.WriteLine(myColumn.OracleDbType.ToString());
      Console.WriteLine(myColumn.Size);
      Console.WriteLine(myColumn.Scale);
      Console.WriteLine(myColumn.Precision);
      Console.WriteLine();
    }
   }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub GetDataColumns(ByVal myConnection As OracleConnection)
  myConnection.Open()
  Dim loader As OracleLoader
  loader = New OracleLoader
  loader.Connection = myConnection
  loader.TableName = "load_table"
  Dim myColumn As OracleLoaderColumn
  Try
    loader.CreateColumns()
    Dim i As Integer
    For i = 0 To loader.Columns.Count - 1
      myColumn = loader.Columns(i)
      Console.WriteLine(myColumn.Name)
      Console.WriteLine(myColumn.OracleDbType.ToString())
      Console.WriteLine(myColumn.Size)
      Console.WriteLine(myColumn.Scale)
      Console.WriteLine(myColumn.Precision)
      Console.WriteLine()
    Next i
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumn Class
OracleLoaderColumn Members
CreateColumns Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumnCollection Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumnCollection Class

Represents a collection of columns relevant to a OracleLoader.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.DbLoaderColumnCollection
Devart.Data.Oracle.OracleLoaderColumnCollection

Syntax

Visual Basic (Declaration)
Public Class OracleLoaderColumnCollection
   Inherits Devart.Common.DbLoaderColumnCollection
   Implements ICollection, IEnumerable, IList
C#
public class OracleLoaderColumnCollection : Devart.Common.DbLoaderColumnCollection, ICollection, IEnumerable, IList

Remarks

Use Devart.Data.Oracle.OracleLoaderColumnCollection class to add or remove columns that will be loaded. Order and number of columns in the collection must be equal to the order and number of columns in the loaded table.

Note: This class is available with dotConnect for Oracle Professional edition only.

Example

Following example displays all loader columns.
C#csharp Copy Code
public void DisplayColumns(string tableName, OracleConnection conn) {

  // Create loader instance
  OracleLoader loader = new OracleLoader();

  // Set up working connection
  // Connection must be opened
  loader.Connection = conn;

  // Set up table name for loading
  loader.TableName = tableName;

  // Create column collection for loading table
  loader.CreateColumns();

  // Iterate through column collection
  foreach (OracleLoaderColumn column in loader.Columns)
    Console.WriteLine(column.Name);
}
C#Visual Basic Copy Code
Public Sub DisplayColumns(tableName as string, conn as OracleConnection)

  ' Create loader instance
  Dim loader as OracleLoader = new OracleLoader()

  ' Set up working connection
  ' Connection must be opened
  loader.Connection = conn

  ' Set up table name for loading
  loader.TableName = tableName

  ' Create column collection for loading table
  loader.CreateColumns()

  ' Iterate through column collection
  Dim column as OracleLoaderColumn
  For Each column in loader.Columns
    Console.WriteLine(column.Name)
  Next
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderColumnCollection Members
Devart.Data.Oracle Namespace
OracleLoader Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumnCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumnCollection Class

The following tables list the members exposed by OracleLoaderColumnCollection.

Public Constructors

 | Name | Description
public Constructor | OracleLoaderColumnCollection Constructor | Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumnCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets or sets the Devart.Data.Oracle.OracleLoaderColumn at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | CopyTo | Copies Devart.Common.DbLoaderColumn objects from the Devart.Common.DbLoaderColumnCollection to the specified array. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location in the collection of the Devart.Common.DbLoaderColumn object. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | Insert | Inserts a Devart.Common.DbLoaderColumn into the collection at the specified index. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | Remove | Removes the specified Devart.Common.DbLoaderColumn object from the collection. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleLoaderColumnCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderColumnCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class : OracleLoaderColumnCollection Constructor

Initializes a new instance of the Devart.Data.Oracle.OracleLoaderColumnCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleLoaderColumnCollection()

Remarks

The base constructor initializes all fields to their default values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumnCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumnCollection Class

For a list of all members of this type, see OracleLoaderColumnCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a Devart.Common.DbLoaderColumn object exists in the collection. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | CopyTo | Copies Devart.Common.DbLoaderColumn objects from the Devart.Common.DbLoaderColumnCollection to the specified array. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location in the collection of the Devart.Common.DbLoaderColumn object. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | Insert | Inserts a Devart.Common.DbLoaderColumn into the collection at the specified index. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | Remove | Removes the specified Devart.Common.DbLoaderColumn object from the collection. (Inherited from Devart.Common.DbLoaderColumnCollection)
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleLoaderColumnCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class : Add Method

Adds the specified Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection.

Overload List

Overload | Description
Add(String,OracleDbType) | Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name.
Add(String,OracleDbType,Int32) | Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, and column size.
Add(String,OracleDbType,Int32,Int32) | Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, precision, and scale.
Add(String,OracleDbType,Int32,Int32,Int32,String) | Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, column size, precision, scale and date format.
Add | Adds the specified Devart.Common.DbLoaderColumn to the Devart.Common.DbLoaderColumnCollection. (Inherited from Devart.Common.DbLoaderColumnCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Add Method : Add(String,OracleDbType) Method

name
The name of the column.
dbType
One of the OracleDbType values.
Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal dbType As OracleDbType _
) As Integer
C#
public int Add(
   string name,
   OracleDbType dbType
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.

Return Value

The new column's index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Add Method : Add(String,OracleDbType,Int32) Method

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of the column data (only for strings).
Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, and column size.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer _
) As Integer
C#
public int Add(
   string name,
   OracleDbType dbType,
   int size
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of the column data (only for strings).

Return Value

The new column's index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Add Method : Add(String,OracleDbType,Int32,Int32) Method

name
The name of the column.
dbType
One of the OracleDbType values.
precision
The precision of the column.
scale
The scale of the column.
Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, precision, and scale.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal precision As Integer, _
   ByVal scale As Integer _
) As Integer
C#
public int Add(
   string name,
   OracleDbType dbType,
   int precision,
   int scale
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
precision
The precision of the column.
scale
The scale of the column.

Return Value

The new column's index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,Int32,Int32,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Add Method : Add(String,OracleDbType,Int32,Int32,Int32,String) Method

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of the column data (only for strings).
precision
The precision of the column.
scale
The scale of the column.
dateFormat
The date format of the column.
Adds an Devart.Data.Oracle.OracleLoaderColumn to the Devart.Data.Oracle.OracleLoaderColumnCollection given the column name, column data type, column size, precision, scale and date format.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal precision As Integer, _
   ByVal scale As Integer, _
   ByVal dateFormat As String _
) As Integer
C#
public int Add(
   string name,
   OracleDbType dbType,
   int size,
   int precision,
   int scale,
   string dateFormat
)

Parameters

name
The name of the column.
dbType
One of the OracleDbType values.
size
Maximum size of the column data (only for strings).
precision
The precision of the column.
scale
The scale of the column.
dateFormat
The date format of the column.

Return Value

The new column's index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumnCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumnCollection Class

For a list of all members of this type, see OracleLoaderColumnCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Overloaded. Gets or sets the Devart.Data.Oracle.OracleLoaderColumn at the specified index.
Top

See Also

Reference

OracleLoaderColumnCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class : Item Property

Gets or sets the Devart.Data.Oracle.OracleLoaderColumn at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the Devart.Data.Oracle.OracleLoaderColumn at the specified index.
Item(String) | Gets or sets the Devart.Data.Oracle.OracleLoaderColumn with the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the column.
Gets or sets the Devart.Data.Oracle.OracleLoaderColumn at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Property Item( _
   ByVal index As Integer _
) As OracleLoaderColumn
C#
public new OracleLoaderColumn Item(
   int index
) {get; set;}

Parameters

index
The zero-based index of the column.

Property Value

The Devart.Data.Oracle.OracleLoaderColumn at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderColumnCollection Class > Item Property : Item(String) Property

name
The name of the column.
Gets or sets the Devart.Data.Oracle.OracleLoaderColumn with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Property Item( _
   ByVal name As String _
) As OracleLoaderColumn
C#
public new OracleLoaderColumn Item(
   string name
) {get; set;}

Parameters

name
The name of the column.

Property Value

The Devart.Data.Oracle.OracleLoaderColumn with the specified name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderColumnCollection Class
OracleLoaderColumnCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderErrorEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderErrorEventArgs Class

Provides data for the OracleLoader.Error event of the OracleLoader class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleLoaderErrorEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleLoaderErrorEventArgs
   Inherits System.EventArgs
C#
public class OracleLoaderErrorEventArgs : System.EventArgs

Remarks

The OracleLoader.Error event contains all information about an error and properties that allow to ignore the error or throw an exception.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderErrorEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLoaderErrorEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderErrorEventArgs Class

The following tables list the members exposed by OracleLoaderErrorEventArgs.

Public Properties

 | Name | Description
public Property | Column | Gets column number where an error occurred.
public Property | Exception | Gets the OracleException instance that an OracleLoader throws.
public Property | Ignore | Gets or sets whether the current error will be ignored or not.
public Property | Row | Gets row number where an error occurred.
Top

See Also

Reference

OracleLoaderErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLoaderErrorEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderErrorEventArgs Class

For a list of all members of this type, see OracleLoaderErrorEventArgs members.

Public Properties

 | Name | Description
public Property | Column | Gets column number where an error occurred.
public Property | Exception | Gets the OracleException instance that an OracleLoader throws.
public Property | Ignore | Gets or sets whether the current error will be ignored or not.
public Property | Row | Gets row number where an error occurred.
Top

See Also

Reference

OracleLoaderErrorEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Column Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderErrorEventArgs Class : Column Property

Gets column number where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Integer
C#
public int Column {get;}

Property Value

Number of the column with the error.

Remarks

Use OracleLoaderErrorEventArgs.Column property to determine the column where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderErrorEventArgs Class
OracleLoaderErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Exception Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderErrorEventArgs Class : Exception Property

Gets the OracleException instance that an OracleLoader throws.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As OracleException
C#
public OracleException Exception {get;}

Property Value

An OracleException instance that contains information specific to the OracleLoader error.

Remarks

If set the OracleLoaderErrorEventArgs.Exception property in Error event handler to false, OracleLoader throws this OracleException instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderErrorEventArgs Class
OracleLoaderErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Ignore Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderErrorEventArgs Class : Ignore Property

Gets or sets whether the current error will be ignored or not.

Syntax

Visual Basic (Declaration)
Public Property Ignore As Boolean
C#
public bool Ignore {get; set;}

Property Value

If the value is true current error will be ignored, otherwise an exception will be thrown.

Remarks

You may use OracleLoaderErrorEventArgs.Ignore property to ignore all or some errors during table loading.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderErrorEventArgs Class
OracleLoaderErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Row Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderErrorEventArgs Class : Row Property

Gets row number where an error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As Integer
C#
public int Row {get;}

Property Value

Number of the row with the error.

Remarks

Use OracleLoaderErrorEventArgs.Row property to determine the row where an error occurred.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderErrorEventArgs Class
OracleLoaderErrorEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderRowsCopiedEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderRowsCopiedEventArgs Class

Provides data for the OracleLoader.Error event of the OracleLoader class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleLoaderRowsCopiedEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleLoaderRowsCopiedEventArgs
   Inherits System.EventArgs
C#
public class OracleLoaderRowsCopiedEventArgs : System.EventArgs

Remarks

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderRowsCopiedEventArgs Members
Devart.Data.Oracle Namespace
OracleLoaderRowsCopiedEventHandler Delegate
RowsCopied Event


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLoaderRowsCopiedEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderRowsCopiedEventArgs Class

The following tables list the members exposed by OracleLoaderRowsCopiedEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleLoaderRowsCopiedEventArgs Constructor | Initializes a new instance of OracleLoaderRowsCopiedEventArgs class with the number of rows copied.
Top

Public Properties

 | Name | Description
public Property | Abort | Specifies whether to abort the data loading operation.
public Property | RowsCopied | Gets the number of rows processed since the previous OracleLoader.RowsCopied event call.
Top

See Also

Reference

OracleLoaderRowsCopiedEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderRowsCopiedEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderRowsCopiedEventArgs Class : OracleLoaderRowsCopiedEventArgs Constructor

rowsCopied
The number of rows copied.
Initializes a new instance of OracleLoaderRowsCopiedEventArgs class with the number of rows copied.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowsCopied As Integer _
)
C#
public OracleLoaderRowsCopiedEventArgs(
   int rowsCopied
)

Parameters

rowsCopied
The number of rows copied.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderRowsCopiedEventArgs Class
OracleLoaderRowsCopiedEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLoaderRowsCopiedEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderRowsCopiedEventArgs Class

For a list of all members of this type, see OracleLoaderRowsCopiedEventArgs members.

Public Properties

 | Name | Description
public Property | Abort | Specifies whether to abort the data loading operation.
public Property | RowsCopied | Gets the number of rows processed since the previous OracleLoader.RowsCopied event call.
Top

See Also

Reference

OracleLoaderRowsCopiedEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Abort Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderRowsCopiedEventArgs Class : Abort Property

Specifies whether to abort the data loading operation.

Syntax

Visual Basic (Declaration)
Public Property Abort As Boolean
C#
public bool Abort {get; set;}

Property Value

true if the data loading operation should be aborted; otherwise, false.

Remarks

Set OracleLoaderRowsCopiedEventArgs.Abort to true in the RowsCopied event handler in order to abort data loading operation. In this case OracleLoader frees all resources correctly and generates System.OperationCanceledException, which you can catch and process in your code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderRowsCopiedEventArgs Class
OracleLoaderRowsCopiedEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowsCopied Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoaderRowsCopiedEventArgs Class : RowsCopied Property

Gets the number of rows processed since the previous RowsCopied event call.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowsCopied As Integer
C#
public int RowsCopied {get;}

Property Value

The number of rows processed since the previous RowsCopied event call.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoaderRowsCopiedEventArgs Class
OracleLoaderRowsCopiedEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLob Class

Represents LOB data type stored on an Oracle server.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Devart.Data.Oracle.OracleLob
Devart.Data.Oracle.OracleBFile

Syntax

Visual Basic (Declaration)
Public Class OracleLob
   Inherits System.IO.Stream
   Implements INullable, ICloneable, IComparable, IDisposable
C#
public class OracleLob : System.IO.Stream, INullable, ICloneable, IComparable, IDisposable

Remarks

An OracleLob differs from an OracleBFile in that data is stored on the server instead of in the physical file in the operating system. It also supports writing, unlike an OracleBFile, which is always read-only.

An OracleLob may be one of these OracleDbType data types:

OracleDBType data type | Description
OracleDbType.Blob | A variable-length stream of binary data.
OracleDbType.BFile | A reference to the physical file in the operating system where Oracle is installed.
OracleDbType.Clob | A variable-length stream (single-byte and multibyte character data).
OracleDbType.NClob | National character data of variable length.

To read data use Read and OracleLob.Seek methods.

Example

In this example two functions are presented. First can upload a file onto a server, and second can retrieve a LOB field and paste it into a file. Notice that two classes used here (BinaryWriter and BinaryReader) to provide more flexible stream manipulation are actually redundant for simple data transfer operations.

The following table is used for the sample:

CREATE TABLE Pictures (
  ID NUMBER(4) NOT NULL PRIMARY KEY,
  PicName VARCHAR2(50),
  Picture BLOB
)
C#csharp Copy Code
public void DownloadBlob(OracleConnection myConnection)
{
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Pictures", myConnection);
  myConnection.Open();
  OracleDataReader myReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default);
  try
  {
    while (myReader.Read())
    {
      OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"));
      if (!myLob.IsNull)
      {
        string FN = myReader.GetString(myReader.GetOrdinal("PicName"));
        FileStream fs = new FileStream("D:\\Tmp\\" + FN + ".bmp", FileMode.Create);
        BinaryWriter w = new BinaryWriter(fs);
        w.Write((byte[])myLob.Value);
        w.Close();
        fs.Close();
        Console.WriteLine(FN + " downloaded.");
      }
    }
  }
  finally
  {
    myReader.Close();
    myConnection.Close();
  }
}

public void UploadBlob(OracleConnection myConnection)
{
  FileStream fs = new FileStream("D:\\Tmp\\_Water.bmp", FileMode.Open, FileAccess.Read);
  BinaryReader r = new BinaryReader(fs);
  myConnection.Open();
  OracleLob myLob = new OracleLob(myConnection,OracleDbType.Blob);
  int streamLength = (int)fs.Length;
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength);
  OracleCommand myCommand = new OracleCommand("INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'Water',:Pictures)", myConnection);
  OracleParameter myParam = myCommand.Parameters.Add("Pictures", OracleDbType.Blob);
  myParam.OracleValue = myLob;
  try
  {
    Console.WriteLine(myCommand.ExecuteNonQuery() + " rows affected.");
  }
  finally
  {
    myConnection.Close();
    r.Close();
    fs.Close();
  }
}
C#Visual Basic Copy Code
Public Sub DownloadBlob(ByVal myConnection As OracleConnection)
  Dim myCommand As New OracleCommand("SELECT * FROM Pictures", myConnection)
  myConnection.Open()
  Dim myReader As OracleDataReader = myCommand.ExecuteReader(System.Data.CommandBehavior.Default)
  Try
    While myReader.Read()
      Dim myLob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"))
      If Not myLob.IsNull Then
        Dim FN As String = myReader.GetString(myReader.GetOrdinal("PicName"))
        Dim fs As FileStream = New FileStream("D:\Tmp\" + FN + ".bmp", FileMode.Create)
        Dim w As BinaryWriter = New BinaryWriter(fs)
        w.Write(myLob.Value)
        w.Close()
        fs.Close()
        Console.WriteLine(String.Concat(FN, " downloaded."))
      End If
    End While
  Finally
    myReader.Close()
    myConnection.Close()
  End Try
End Sub

Public Sub UploadBlob(ByVal myConnection As OracleConnection)
  Dim fs As FileStream = New FileStream("D:\Tmp\_Water.bmp", FileMode.Open, FileAccess.Read)
  Dim r As BinaryReader = New BinaryReader(fs)
  myConnection.Open()
  Dim myLob As OracleLob = New OracleLob(myConnection, OracleDbType.Blob)
  Dim streamLength As Int32 = fs.Length
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength)
  Dim myCommand As OracleCommand = New OracleCommand("INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'Water',:Pictures)", myConnection)
  Dim myParam As OracleParameter = myCommand.Parameters.Add("Pictures", OracleDbType.Blob)
  myParam.OracleValue = myLob
  Try
    Console.WriteLine(myCommand.ExecuteNonQuery() & " rows affected.")
  Finally
    myConnection.Close()
    r.Close()
    fs.Close()
  End Try
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLob Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLob Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleLob Class

The following tables list the members exposed by OracleLob.

Public Constructors

 | Name | Description
public Constructor | OracleLob Constructor | Overloaded. Initializes a new instance of the OracleLob class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxSize | Represents the maximum number of bytes a LOB can hold, which is 4 294 967 295 (2^32 - 1) bytes.
static (Shared in Visual Basic) | Null | Deprecated. Represents a null OracleLob object. Use NullBlob or NullClob or NullNClob instead.
static (Shared in Visual Basic) | NullBlob | Represents a null OracleLob object.
static (Shared in Visual Basic) | NullClob | Represents a null OracleLob object.
static (Shared in Visual Basic) | NullNClob | Represents a null OracleLob object.
Top

Public Properties

 | Name | Description
public Property | Cached | Specifies whether the OracleLob is cached.
public Property | CanRead | Overridden. Gets a value indicating whether the OracleLob stream can be read.
public Property | CanSeek | Overridden. Gets a value indicating whether forward and backward seek operations can be performed.
public Property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Gets a value indicating whether the OracleLob object supports writing.
public Property | ChunkSize | Gets a value indicating the minimum number of bytes used during read/write operations.
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleLob.
public Property | IsBatched | Gets a value indicating whether the application called the OracleLob.BeginBatch method.
public Property | IsEmpty | Gets a value indicating whether the OracleLob is empty or not.
public Property | IsNull | Gets a value indicating whether the OracleLob is a OracleLob.Null stream.
public Property | IsTemporary | Gets a value indicating whether the OracleLob is a temporary LOB.
public Property | Length | Overridden. Gets the size of the OracleLob.
public Property | LobType | Gets the LOB data type.
public Property | Position | Overridden. Gets the current read position in the OracleLob stream.
public Property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from System.IO.Stream)
public Property | Value | Gets the value of the OracleLob object.
public Property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | Append | Overloaded. Appends the supplied data to the current OracleLob instance.
public Method | BeginBatch | Overloaded. Prevents server-side triggers from firing while performing multiple write operations.
public Method | BeginRead | Begins an asynchronous read operation. (Inherited from System.IO.Stream)
public Method | BeginWrite | Begins an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Clone | Creates a copy of the current OracleLob object.
public Method | Close | Overridden. Closes the current stream and releases any resources associated with it.
public Method | CopyTo | Overloaded. Copies data from this OracleLob to a destination OracleLob.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleLob object.
public Method | EndBatch | Allows server-side triggers to resume firing after performing multiple write operations.
public Method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from System.IO.Stream)
public Method | EndWrite | Ends an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Erase | Overloaded. Erases data from the specified OracleLob.
public Method | Flush | Overridden. Flush/write all buffers for the current OracleLob.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleLob object is equal to the current OracleLob.
public Method | Read | Overloaded. Overridden. Reads a sequence of bytes from the current OracleLob stream and advances the position within the stream by the number of bytes read.
public Method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Sets the position on the current OracleLob stream.
public Method | SetLength | Overridden. Sets length for OracleLob value.
public Method | ToString | Converts the current OracleLob object to a System.String.
public Method | Write | Overloaded. Overridden. Writes a sequence of bytes to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.
public Method | WriteByte | Overridden. Writes a byte to the current position in the Lob and advances the position within the stream by one byte.
Top

See Also

Reference

OracleLob Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : OracleLob Constructor

Initializes a new instance of the OracleLob class.

Overload List

Overload | Description
OracleLob Constructor(OracleDbType) | Initializes a new instance of the OracleLob class with the specified Oracle LOB type.
OracleLob Constructor(OracleDbType,Boolean) | Initializes a new instance of the OracleLob class with the specified Oracle LOB type.
OracleLob Constructor(OracleConnection,OracleDbType) | Initializes a new instance of the OracleLob class with the specified OracleConnection and Oracle LOB type.
OracleLob Constructor(OracleConnection,OracleDbType,Boolean) | Initializes a new instance of the OracleLob class with the specified OracleConnection and Oracle LOB type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Constructor(OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > OracleLob Constructor : OracleLob Constructor(OracleDbType)

lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
Initializes a new instance of the OracleLob class with the specified Oracle LOB type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lobType As OracleDbType _
)
C#
public OracleLob(
   OracleDbType lobType
)

Parameters

lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Constructor(OracleDbType,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > OracleLob Constructor : OracleLob Constructor(OracleDbType,Boolean)

lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
isUnicode
Determines whether the data of the new OracleLob instance will be in the Unicode encoding or in client encoding.
Initializes a new instance of the OracleLob class with the specified Oracle LOB type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lobType As OracleDbType, _
   ByVal isUnicode As Boolean _
)
C#
public OracleLob(
   OracleDbType lobType,
   bool isUnicode
)

Parameters

lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
isUnicode
Determines whether the data of the new OracleLob instance will be in the Unicode encoding or in client encoding.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Constructor(OracleConnection,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > OracleLob Constructor : OracleLob Constructor(OracleConnection,OracleDbType)

connection
The OracleConnection object.
lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
Initializes a new instance of the OracleLob class with the specified OracleConnection and Oracle LOB type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal lobType As OracleDbType _
)
C#
public OracleLob(
   OracleConnection connection,
   OracleDbType lobType
)

Parameters

connection
The OracleConnection object.
lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.

Remarks

The connection must be opened explicitly by the application. OracleLob object does not open the connection implicitly.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLob Constructor(OracleConnection,OracleDbType,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > OracleLob Constructor : OracleLob Constructor(OracleConnection,OracleDbType,Boolean)

connection
The OracleConnection object.
lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
isCaching
true if the OracleLob should be read into the cache; otherwise, false.
Initializes a new instance of the OracleLob class with the specified OracleConnection and Oracle LOB type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal lobType As OracleDbType, _
   ByVal isCaching As Boolean _
)
C#
public OracleLob(
   OracleConnection connection,
   OracleDbType lobType,
   bool isCaching
)

Parameters

connection
The OracleConnection object.
lobType
One of the OracleDbType values. May be OracleDbType.Blob, OracleDbType.BFile, OracleDbType.Clob, or OracleDbType.NClob.
isCaching
true if the OracleLob should be read into the cache; otherwise, false.

Remarks

The connection must be opened explicitly by the application. OracleLob object does not open the connection implicitly.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleLob Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLob Class

For a list of all members of this type, see OracleLob members.

Public Methods

 | Name | Description
public Method | Append | Overloaded. Appends the supplied data to the current OracleLob instance.
public Method | BeginBatch | Overloaded. Prevents server-side triggers from firing while performing multiple write operations.
public Method | BeginRead | Begins an asynchronous read operation. (Inherited from System.IO.Stream)
public Method | BeginWrite | Begins an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Clone | Creates a copy of the current OracleLob object.
public Method | Close | Overridden. Closes the current stream and releases any resources associated with it.
public Method | CopyTo | Overloaded. Copies data from this OracleLob to a destination OracleLob.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the OracleLob object.
public Method | EndBatch | Allows server-side triggers to resume firing after performing multiple write operations.
public Method | EndRead | Waits for the pending asynchronous read to complete. (Inherited from System.IO.Stream)
public Method | EndWrite | Ends an asynchronous write operation. (Inherited from System.IO.Stream)
public Method | Erase | Overloaded. Erases data from the specified OracleLob.
public Method | Flush | Overridden. Flush/write all buffers for the current OracleLob.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleLob object is equal to the current OracleLob.
public Method | Read | Overloaded. Overridden. Reads a sequence of bytes from the current OracleLob stream and advances the position within the stream by the number of bytes read.
public Method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Sets the position on the current OracleLob stream.
public Method | SetLength | Overridden. Sets length for OracleLob value.
public Method | ToString | Converts the current OracleLob object to a System.String.
public Method | Write | Overloaded. Overridden. Writes a sequence of bytes to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.
public Method | WriteByte | Overridden. Writes a byte to the current position in the Lob and advances the position within the stream by one byte.
Top

See Also

Reference

OracleLob Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Append Method

Appends the supplied data to the current OracleLob instance.

Overload List

Overload | Description
Append(OracleLob) | Appends the supplied data to the current OracleLob instance.
Append(String) | Appends the supplied string to the current OracleLob instance.
Append(OracleString) | Appends the supplied string to the current OracleLob instance.
Append(Char[],Int32,Int32) | Appends the supplied character data to the end current OracleLob instance.
Append(Byte[],Int32,Int32) | Appends the supplied character data to the end current OracleLob instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append(OracleLob) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Append Method : Append(OracleLob) Method

source
Lob data to add.
Appends the supplied data to the current OracleLob instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal source As OracleLob _
)
C#
public void Append(
   OracleLob source
)

Parameters

source
Lob data to add.

Remarks

To write to the OracleLob you must have a local transaction started.

All data from the source OracleLob is appended to the end of the current OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Append Method : Append(String) Method

value
The string to append.
Appends the supplied string to the current OracleLob instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal value As String _
)
C#
public void Append(
   string value
)

Parameters

value
The string to append.

Remarks

To write to the OracleLob you must have a local transaction started.

All data from the source System.String is appended to the end of the current OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append(OracleString) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Append Method : Append(OracleString) Method

value
The string to append.
Appends the supplied string to the current OracleLob instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal value As OracleString _
)
C#
public void Append(
   OracleString value
)

Parameters

value
The string to append.

Remarks

To write to the OracleLob you must have a local transaction started.

All data from the source OracleString is appended to the end of the current OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append(Char[],Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Append Method : Append(Char[],Int32,Int32) Method

buffer
The source character data.
offset
The zero-based offset in the buffer from which to read the data.
count
The number of characters to add.
Appends the supplied character data to the end current OracleLob instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal buffer() As Char, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
C#
public void Append(
   char[] buffer,
   int offset,
   int count
)

Parameters

buffer
The source character data.
offset
The zero-based offset in the buffer from which to read the data.
count
The number of characters to add.

Remarks

To write to the OracleLob you must have a local transaction started.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Append(Byte[],Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Append Method : Append(Byte[],Int32,Int32) Method

buffer
The source data buffer.
offset
The zero-based offset in the buffer from which to read the data.
count
The number of bytes to add.
Appends the supplied character data to the end current OracleLob instance.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
C#
public void Append(
   byte[] buffer,
   int offset,
   int count
)

Parameters

buffer
The source data buffer.
offset
The zero-based offset in the buffer from which to read the data.
count
The number of bytes to add.

Remarks

To write to the OracleLob you must have a local transaction started.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBatch Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : BeginBatch Method

Prevents server-side triggers from firing while performing multiple write operations.

Overload List

Overload | Description
BeginBatch() | Prevents server-side triggers from firing while performing multiple write operations.
BeginBatch(OracleLobOpenMode) | Prevents server-side triggers from firing while performing multiple write operations, and specifies one of the OracleLobOpenMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBatch() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > BeginBatch Method : BeginBatch() Method

Prevents server-side triggers from firing while performing multiple write operations.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginBatch()
C#
public void BeginBatch()

Remarks

To write to the OracleLob you must have a local transaction started.

If you call BeginBatch() more than one time within the same transaction Oracle throws an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginBatch(OracleLobOpenMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > BeginBatch Method : BeginBatch(OracleLobOpenMode) Method

openMode
One of the OracleLobOpenMode values.
Prevents server-side triggers from firing while performing multiple write operations, and specifies one of the OracleLobOpenMode values.

Syntax

Visual Basic (Declaration)
Public Overloads Sub BeginBatch( _
   ByVal openMode As OracleLobOpenMode _
)
C#
public void BeginBatch(
   OracleLobOpenMode openMode
)

Parameters

openMode
One of the OracleLobOpenMode values.

Remarks

To write to the OracleLob you must have a local transaction started.

If you call BeginBatch(OracleLobOpenMode) more than one time within the same transaction Oracle throws an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Clone Method

Creates a copy of the current OracleLob object.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
C#
public virtual object Clone()

Return Value

A new OracleLob object.

Remarks

Creates a new OracleLob object with the properties that have the same values as those of the original object. However, changing properties of the new object has no influence on the values of the same properties of the original object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Close Method

Closes the current stream and releases any resources associated with it.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()

Remarks

After closing OracleLob object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : CopyTo Method

Copies data from this OracleLob to a destination OracleLob.

Overload List

Overload | Description
CopyTo(OracleLob) | Copies data from this OracleLob to a destination OracleLob.
CopyTo(OracleLob,Int64) | Copies data from this OracleLob to a destination OracleLob with the specified destination offset.
CopyTo(Int64,OracleLob,Int64,Int64) | Copies data from this OracleLob to a destination OracleLob with the specified amount of data, source offset and destination offset.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(OracleLob) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > CopyTo Method : CopyTo(OracleLob) Method

dest
The destination OracleLob.
Copies data from this OracleLob to a destination OracleLob.

Syntax

Visual Basic (Declaration)
Public Overloads Function CopyTo( _
   ByVal dest As OracleLob _
) As Long
C#
public long CopyTo(
   OracleLob dest
)

Parameters

dest
The destination OracleLob.

Return Value

The number of bytes copied.

Remarks

The current and destination OracleLob objects must have the same data types.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(OracleLob,Int64) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > CopyTo Method : CopyTo(OracleLob,Int64) Method

dest
The destination OracleLob.
destOffset
The offset to which to copy.
Copies data from this OracleLob to a destination OracleLob with the specified destination offset.

Syntax

Visual Basic (Declaration)
Public Overloads Function CopyTo( _
   ByVal dest As OracleLob, _
   ByVal destOffset As Long _
) As Long
C#
public long CopyTo(
   OracleLob dest,
   long destOffset
)

Parameters

dest
The destination OracleLob.
destOffset
The offset to which to copy.

Return Value

The number of bytes copied.

Remarks

The current and destination OracleLob objects must have the same data types.

If the destination offset is beyond the end of the LOB data, zeros are written into the OracleDbType.Blob and spaces into the OracleDbType.Clob and OracleDbType.NClob data types until the destination offset is met.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(Int64,OracleLob,Int64,Int64) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > CopyTo Method : CopyTo(Int64,OracleLob,Int64,Int64) Method

srcOffset
The offset from which to copy.
dest
The destination OracleLob.
destOffset
The offset to which to copy.
amount
The quantity of data, in bytes, to copy.
Copies data from this OracleLob to a destination OracleLob with the specified amount of data, source offset and destination offset.

Syntax

Visual Basic (Declaration)
Public Overloads Function CopyTo( _
   ByVal srcOffset As Long, _
   ByVal dest As OracleLob, _
   ByVal destOffset As Long, _
   ByVal amount As Long _
) As Long
C#
public long CopyTo(
   long srcOffset,
   OracleLob dest,
   long destOffset,
   long amount
)

Parameters

srcOffset
The offset from which to copy.
dest
The destination OracleLob.
destOffset
The offset to which to copy.
amount
The quantity of data, in bytes, to copy.

Return Value

The number of bytes copied.

Remarks

The current and destination OracleLob objects must have the same data types.

If the destination offset is beyond the end of the LOB data, zeros are written into the OracleDbType.Blob and spaces into the OracleDbType.Clob and OracleDbType.NClob data types until the destination offset is met.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Dispose() Method

Disposes the resources allocated by the OracleLob object. Disposes the resources allocated by the OracleLob object.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Dispose()
C#
public new void Dispose()

Remarks

After closing OracleLob object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndBatch Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : EndBatch Method

Allows server-side triggers to resume firing after performing multiple write operations.

Syntax

Visual Basic (Declaration)
Public Sub EndBatch()
C#
public void EndBatch()

Remarks

Call the BeginBatch method before you begin performing write operations on the OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Erase Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Erase Method

Erases data from the specified OracleLob.

Overload List

Overload | Description
Erase() | Erases all data from the OracleLob.
Erase(Int64,Int64) | Erases the specified amount of data from the OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Erase() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Erase Method : Erase() Method

Erases all data from the OracleLob.

Syntax

Visual Basic (Declaration)
Public Overloads Function Erase() As Long
C#
public long Erase()

Return Value

The number of bytes erased.

Remarks

The OracleLob length remains the same for a OracleDbType.Blob data type, and the erased data is replaced by 0x00. OracleDbType.Clob and OracleDbType.NClob data types are replaced by spaces.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Erase(Int64,Int64) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Erase Method : Erase(Int64,Int64) Method

offset
The offset from which to erase.
amount
The quantity of data, in bytes, to erase.
Erases the specified amount of data from the OracleLob.

Syntax

Visual Basic (Declaration)
Public Overloads Function Erase( _
   ByVal offset As Long, _
   ByVal amount As Long _
) As Long
C#
public long Erase(
   long offset,
   long amount
)

Parameters

offset
The offset from which to erase.
amount
The quantity of data, in bytes, to erase.

Return Value

The number of bytes erased.

Remarks

Replaces the specified amount of data with 0x00 for OracleDbType.Blob, and with spaces for OracleDbType.Clob and OracleDbType.NClob data types.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Flush Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Flush Method

Flush/write all buffers for the current OracleLob.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
C#
public override void Flush()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : IsEqual Method

val
The OracleLob to compare with the current OracleLob.
Determines whether the specified OracleLob object is equal to the current OracleLob.

Syntax

Visual Basic (Declaration)
Public Function IsEqual( _
   ByVal val As OracleLob _
) As Boolean
C#
public bool IsEqual(
   OracleLob val
)

Parameters

val
The OracleLob to compare with the current OracleLob.

Return Value

true if the specified OracleLob object is equal to the current one; otherwise, false.

Remarks

Compares the LOB data referenced by the two OracleLob. Two OracleLob objects are equal if and only if they both refer to the same LOB value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Read Method

Reads a sequence of bytes from the current OracleLob stream and advances the position within the stream by the number of bytes read.

Overload List

Overload | Description
Read(Byte[],Int32,Int32) | Reads a sequence of bytes from the current OracleLob stream and advances the position within the stream by the number of bytes read.
Read(Char[],Int32,Int32) | Reads a sequence of characters from the current OracleLob stream and advances the position within the stream by the number of bytes read.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read(Byte[],Int32,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Read Method : Read(Byte[],Int32,Int32) Method

buffer
The byte array buffer to be populated.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to read.
Reads a sequence of bytes from the current OracleLob stream and advances the position within the stream by the number of bytes read.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)

Parameters

buffer
The byte array buffer to be populated.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to read.

Return Value

The total number of bytes read into the buffer.

Remarks

The Read method reads a maximum of count bytes from the current stream and stores them in buffer beginning at offset position. The current position within the stream is advanced by the number of bytes read. The Read method returns 0 if the position is at the end of the stream.

Example

In the example below a OracleLob is created with 10 bytes in it. Then Devart.Data.Oracle.OracleLob.Position is changed using Seek method. An attempt to read 10 bytes is made afterwards, however, only 5 bytes remain till the end of the stream, so TargetArray is populated with 5 bytes only.
C#csharp Copy Code
public void ReadFromMyLob()
{
        byte[] myByteArray = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
        byte[] TargetArray = new Byte[15];
        OracleLob myLob = new OracleLob(OracleDbType.Blob);
        myLob.Write(myByteArray, 0, 10);
        myLob.Seek(5, SeekOrigin.Begin);
        Console.WriteLine(myLob.Read(TargetArray, 0, 10) + " bytes are read");
}
C#Visual Basic Copy Code
Public Sub ReadFromMyLob()
        Dim myByteArray As Byte() = New Byte() { 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 }
        Dim TargetArray As Byte() = New Byte(15  - 1) {}
        Dim myLob As New OracleLob(3)
        myLob.Write(myByteArray, 0, 10)
        myLob.Seek(5, SeekOrigin.Begin)
        Console.WriteLine((myLob.Read(TargetArray, 0, 10) & " bytes are read"))
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Seek Method
Write Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Read(Char[],Int32,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Read Method : Read(Char[],Int32,Int32) Method

buffer
The character array buffer to be populated.
offset
The zero-based offset in the buffer.
count
The amount of bytes to read.
Reads a sequence of characters from the current OracleLob stream and advances the position within the stream by the number of bytes read.

Syntax

Visual Basic (Declaration)
Public Overloads Function Read( _
   ByVal buffer() As Char, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
C#
public int Read(
   char[] buffer,
   int offset,
   int count
)

Parameters

buffer
The character array buffer to be populated.
offset
The zero-based offset in the buffer.
count
The amount of bytes to read.

Return Value

The total number of characters read into the buffer.

Remarks

The Read method reads a maximum of count bytes from the current stream and stores them in buffer beginning at offset position. The current position within the stream is advanced by the number of bytes read. The Read method returns 0 if the position is at the end of the stream.

Example

In the example below a OracleLob is created with 10 bytes in it. Then Devart.Data.Oracle.OracleLob.Position is changed using Seek method. An attempt to read 10 bytes is made afterwards, however, only 5 bytes remain till the end of the stream, so TargetArray is populated with 5 bytes only.
C#csharp Copy Code
public void ReadFromMyLob()
{
  byte[] myByteArray = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
  byte[] TargetArray = new Byte[15];
  OracleLob myLob = new OracleLob(myByteArray);
  myLob.Seek(5, SeekOrigin.Begin);
  Console.WriteLine(myLob.Read(TargetArray, 0, 10) + " bytes are read");
}
C#Visual Basic Copy Code
Public Sub ReadFromMyLob()
  Dim myByteArray() As Byte = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10}
  Dim TargetArray(15) As Byte
  Dim myLob As OracleLob = New OracleLob(myByteArray)
  myLob.Seek(5, SeekOrigin.Begin)
  Console.WriteLine(String.Concat(myLob.Read(TargetArray, 0, 10), " bytes are read"))
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Seek Method
Write Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Seek Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Seek Method

offset
A byte offset relative to origin.
origin
A value of System.IO.SeekOrigin type indicating the reference point used to obtain the new position.
Sets the position on the current OracleLob stream.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)

Parameters

offset
A byte offset relative to origin.
origin
A value of System.IO.SeekOrigin type indicating the reference point used to obtain the new position.

Return Value

The new position within the current stream.

Remarks

If offset is negative, the new position is required to precede the position specified by origin by the number of bytes specified by offset. If offset is zero (0), the new position is required to be the position specified by origin. If offset is positive, the new position is required to follow the position specified by origin by the number of bytes specified by offset.

Example

The first line of the example sets stream position to the very first element.
C#csharp Copy Code
myLob.Seek(0, SeekOrigin.Begin);
Console.WriteLine(myLob.Position);
Console.WriteLine(myLob.ReadByte());
C#Visual Basic Copy Code
myLob.Seek(0, SeekOrigin.Begin)
Console.WriteLine(myLob.Position)
Console.WriteLine(myLob.ReadByte())

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
CanSeek Property
Position Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetLength Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : SetLength Method

len
The size of the OracleLob in bytes.
Sets length for OracleLob value.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal len As Long _
)
C#
public override void SetLength(
   long len
)

Parameters

len
The size of the OracleLob in bytes.

Remarks

If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined.

Example

C#csharp Copy Code
OracleDataReader pictureReader = myCommand.ExecuteReader();
pictureReader.Read();
OracleLob pictureBlob = pictureReader.GetOracleLob(pictureReader.GetOrdinal("Picture"));
if (pictureBlob.Length > 100)
  pictureBlob.SetLength(100);
C#Visual Basic Copy Code
Dim pictureReader As OracleDataReader = myCommand.ExecuteReader
pictureReader.Read()
Dim pictureBlob As OracleLob = pictureReader.GetOracleLob(pictureReader.GetOrdinal("Picture"))
If (pictureBlob.Length > 100) Then
  pictureBlob.SetLength(CLng(100))
End If

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Length Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : ToString Method

Converts the current OracleLob object to a System.String.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String with the same value as the OracleLob.

Remarks

If a Value is actually a sequence of bytes that represent a string, you can use ToString method to obtain that string. The default encoding is used.

Example

The example shows a code fragment that gets a OracleLob field from a OracleReader and writes it to the console.
C#csharp Copy Code
...
OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("TextColumnName"));
Console.WriteLine(myLob.ToString());
...
C#Visual Basic Copy Code
...
Dim Lob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("TextColumnName"))
Console.WriteLine(myLob.ToString())
...

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Value Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Write Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Write Method

Writes a sequence of bytes to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Overload List

Overload | Description
Write(Byte[],Int32,Int32) | Writes a sequence of bytes to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.
Write(String) | Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.
Write(OracleString) | Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.
Write(Char[],Int32,Int32) | Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Write(Byte[],Int32,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Write Method : Write(Byte[],Int32,Int32) Method

buffer
An array of bytes.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to be written to the current stream.
Writes a sequence of bytes to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)

Parameters

buffer
An array of bytes.
offset
The zero-based byte offset in the buffer.
count
The amount of bytes to be written to the current stream.

Remarks

If the write operation is successful, the position within the stream advances by the number of bytes written.

Note that writing data to OracleLob object results in immediate data transfer to server.

Example

In this example data is written to OracleLob object from a stream.
C#csharp Copy Code
public void UploadBlob(OracleConnection myConnection)
{
  FileStream fs = new FileStream("D:\\Tmp\\_Water.bmp", FileMode.Open, FileAccess.Read);
  BinaryReader r = new BinaryReader(fs);
  myConnection.Open();
  OracleLob myLob = new OracleLob(myConnection,OracleDbType.Blob);
  int streamLength = (int)fs.Length;
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength);
  OracleCommand myCommand = new OracleCommand("INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'Water',:Pictures)", myConnection);
  OracleParameter myParam = myCommand.Parameters.Add("Pictures", OracleDbType.Blob);
  myParam.OracleValue = myLob;
  try
  {
    Console.WriteLine(myCommand.ExecuteNonQuery() + " rows affected.");
  }
  finally
  {
    myConnection.Close();
    r.Close();
    fs.Close();
  }
}
C#Visual Basic Copy Code
Public Sub UploadBlob(ByVal myConnection As OracleConnection)
  Dim fs As FileStream = New FileStream("D:\Tmp\_Water.bmp", FileMode.Open, FileAccess.Read)
  Dim r As BinaryReader = New BinaryReader(fs)
  myConnection.Open()
  Dim myLob As OracleLob = New OracleLob(myConnection, OracleDbType.Blob)
  Dim streamLength As Int32 = fs.Length
  myLob.Write(r.ReadBytes(streamLength), 0, streamLength)
  Dim myCommand As OracleCommand = New OracleCommand("INSERT INTO Pictures (ID, PicName, Picture) VALUES(1,'Water',:Pictures)", myConnection)
  Dim myParam As OracleParameter = myCommand.Parameters.Add("Pictures", OracleDbType.Blob)
  myParam.OracleValue = myLob
  Try
    Console.WriteLine(myCommand.ExecuteNonQuery() & " rows affected.")
  Finally
    myConnection.Close()
    r.Close()
    fs.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Read Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Write(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Write Method : Write(String) Method

value
The string to write.
Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal value As String _
)
C#
public void Write(
   string value
)

Parameters

value
The string to write.

Remarks

If the write operation is successful, the position within the stream advances by the number of bytes written.

Example

In the example a byte array is filled and written to a newly created OracleLob instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Read Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Write(OracleString) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Write Method : Write(OracleString) Method

value
The string to write.
Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal value As OracleString _
)
C#
public void Write(
   OracleString value
)

Parameters

value
The string to write.

Remarks

If the write operation is successful, the position within the stream advances by the number of bytes written.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Read Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Write(Char[],Int32,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class > Write Method : Write(Char[],Int32,Int32) Method

buffer
An array of characters.
offset
The zero-based byte offset in the buffer.
count
The number of characters to write.
Writes a string to the current OracleLob stream, and advances the current position within this stream by the number of bytes written.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Write( _
   ByVal buffer() As Char, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
C#
public void Write(
   char[] buffer,
   int offset,
   int count
)

Parameters

buffer
An array of characters.
offset
The zero-based byte offset in the buffer.
count
The number of characters to write.

Remarks

If the write operation is successful, the position within the stream advances by the number of bytes written.

Example

In the example a byte array is filled and written to a newly created OracleLob instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Overload List
Read Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
WriteByte Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : WriteByte Method

value
The byte to write to the Lob.
Writes a byte to the current position in the Lob and advances the position within the stream by one byte.

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteByte( _
   ByVal value As Byte _
)
C#
public override void WriteByte(
   byte value
)

Parameters

value
The byte to write to the Lob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLob Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLob Class

For a list of all members of this type, see OracleLob members.

Public Properties

 | Name | Description
public Property | Cached | Specifies whether the OracleLob is cached.
public Property | CanRead | Overridden. Gets a value indicating whether the OracleLob stream can be read.
public Property | CanSeek | Overridden. Gets a value indicating whether forward and backward seek operations can be performed.
public Property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Gets a value indicating whether the OracleLob object supports writing.
public Property | ChunkSize | Gets a value indicating the minimum number of bytes used during read/write operations.
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleLob.
public Property | IsBatched | Gets a value indicating whether the application called the OracleLob.BeginBatch method.
public Property | IsEmpty | Gets a value indicating whether the OracleLob is empty or not.
public Property | IsNull | Gets a value indicating whether the OracleLob is a OracleLob.Null stream.
public Property | IsTemporary | Gets a value indicating whether the OracleLob is a temporary LOB.
public Property | Length | Overridden. Gets the size of the OracleLob.
public Property | LobType | Gets the LOB data type.
public Property | Position | Overridden. Gets the current read position in the OracleLob stream.
public Property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from System.IO.Stream)
public Property | Value | Gets the value of the OracleLob object.
public Property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from System.IO.Stream)
Top

See Also

Reference

OracleLob Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cached Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Cached Property

Specifies whether the OracleLob is cached.

Syntax

Visual Basic (Declaration)
Public Property Cached As Boolean
C#
public bool Cached {get; set;}

Property Value

true if entire OracleLob is cached in the memory; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CanRead Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : CanRead Property

Gets a value indicating whether the OracleLob stream can be read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
C#
public override bool CanRead {get;}

Property Value

true if the OracleLob stream supports reading; false if a OracleLob is closed, disposed, or Null.

Remarks

Use CanRead property to determine whether OracleLob object supports reading. OracleLob can not be read from if it has Null value.

Example

C#csharp Copy Code
static void ReverseBlob()
{
        byte[] byteArray = { (byte)'A', (byte)'B', (byte)'C' };
        OracleLob blobFrom = new OracleLob(OracleDbType.Blob);
        blobFrom.Write(byteArray, 0, byteArray.Length);
        //blobFrom.ToString() = "ABC"

        OracleLob blobTo = new OracleLob(OracleDbType.Blob);
        ........
        //reverse OracleLob
        if (blobFrom.CanSeek && blobFrom.CanRead && blobTo.CanWrite)
                for (blobFrom.Seek(-1, System.IO.SeekOrigin.End); ;blobFrom.Position -= 2)
                {
                        blobTo.WriteByte((byte)blobFrom.ReadByte());
                        if (blobFrom.Position == 1) break;
                }
        //blobTo.ToString() = "CBA";
}
C#Visual Basic Copy Code
Private Sub ReverseBlob()
        Dim byteArray As Byte() = New Byte() {AscW("A"c), AscW("B"c), AscW("C"c)}
        Dim blobFrom As New OracleLob(OracleDbType.Blob)
        blobFrom.Write(byteArray, 0, byteArray.Length)
        ' blobFrom.ToString() = "ABC"

        Dim blobTo As New OracleLob(OracleDbType.Blob)
        ........
        ' reverse OracleLob
        If ((blobFrom.CanSeek AndAlso blobFrom.CanRead) AndAlso blobTo.CanWrite) Then
                blobFrom.Seek(CLng(-1), System.IO.SeekOrigin.End)
                Do While True
                        blobTo.WriteByte(CByte(blobFrom.ReadByte))
                        If (blobFrom.Position = 1) Then
                                Return
                        End If
                        blobFrom.Position = blobFrom.Position - 2
                Loop
        End If
        ' blobTo.ToString() = "CBA";
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CanSeek Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : CanSeek Property

Gets a value indicating whether forward and backward seek operations can be performed.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
C#
public override bool CanSeek {get;}

Property Value

true if the OracleLob stream supports seeking; false if a OracleLob is closed, disposed, or Null.

Remarks

Use this property to find out if a OracleLob supports Seek operation. OracleLob does not support seeking if it has Null value as well as if it has been disposed or closed.

Example

C#csharp Copy Code
static void ReverseBlob()
{
        byte[] byteArray = { (byte)'A', (byte)'B', (byte)'C' };
        OracleLob blobFrom = new OracleLob(OracleDbType.Blob);
        blobFrom.Write(byteArray, 0, byteArray.Length);
        //blobFrom.ToString() = "ABC"

        OracleLob blobTo = new OracleLob(OracleDbType.Blob);
        ........
        //reverse OracleLob
        if (blobFrom.CanSeek && blobFrom.CanRead && blobTo.CanWrite)
                for (blobFrom.Seek(-1, System.IO.SeekOrigin.End); ;blobFrom.Position -= 2)
                {
                        blobTo.WriteByte((byte)blobFrom.ReadByte());
                        if (blobFrom.Position == 1) break;
                }
        //blobTo.ToString() = "CBA";
}
C#Visual Basic Copy Code
Private Sub ReverseBlob()
        Dim byteArray As Byte() = New Byte() {AscW("A"c), AscW("B"c), AscW("C"c)}
        Dim blobFrom As New OracleLob(OracleDbType.Blob)
        blobFrom.Write(byteArray, 0, byteArray.Length)
        ' blobFrom.ToString() = "ABC"

        Dim blobTo As New OracleLob(OracleDbType.Blob)
        ........
        ' reverse OracleLob
        If ((blobFrom.CanSeek AndAlso blobFrom.CanRead) AndAlso blobTo.CanWrite) Then
                blobFrom.Seek(CLng(-1), System.IO.SeekOrigin.End)
                Do While True
                        blobTo.WriteByte(CByte(blobFrom.ReadByte))
                        If (blobFrom.Position = 1) Then
                                Return
                        End If
                        blobFrom.Position = blobFrom.Position - 2
                Loop
        End If
        ' blobTo.ToString() = "CBA";
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CanWrite Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : CanWrite Property

Gets a value indicating whether the OracleLob object supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
C#
public override bool CanWrite {get;}

Property Value

true if the OracleLob stream can be written; false if a OracleLob is closed, disposed or Null.

Remarks

Use this property to determine whether you can write to the instance of OracleLob class.

Example

C#csharp Copy Code
static void ReverseBlob()
{
        byte[] byteArray = { (byte)'A', (byte)'B', (byte)'C' };
        OracleLob blobFrom = new OracleLob(OracleDbType.Blob);
        blobFrom.Write(byteArray, 0, byteArray.Length);
        //blobFrom.ToString() = "ABC"

        OracleLob blobTo = new OracleLob(OracleDbType.Blob);
        ........
        //reverse OracleLob
        if (blobFrom.CanSeek && blobFrom.CanRead && blobTo.CanWrite)
                for (blobFrom.Seek(-1, System.IO.SeekOrigin.End); ;blobFrom.Position -= 2)
                {
                        blobTo.WriteByte((byte)blobFrom.ReadByte());
                        if (blobFrom.Position == 1) break;
                }
        //blobTo.ToString() = "CBA";
}
C#Visual Basic Copy Code
Private Sub ReverseBlob()
        Dim byteArray As Byte() = New Byte() {AscW("A"c), AscW("B"c), AscW("C"c)}
        Dim blobFrom As New OracleLob(OracleDbType.Blob)
        blobFrom.Write(byteArray, 0, byteArray.Length)
        ' blobFrom.ToString() = "ABC"

        Dim blobTo As New OracleLob(OracleDbType.Blob)
        ........
        ' reverse OracleLob
        If ((blobFrom.CanSeek AndAlso blobFrom.CanRead) AndAlso blobTo.CanWrite) Then
                blobFrom.Seek(CLng(-1), System.IO.SeekOrigin.End)
                Do While True
                        blobTo.WriteByte(CByte(blobFrom.ReadByte))
                        If (blobFrom.Position = 1) Then
                                Return
                        End If
                        blobFrom.Position = blobFrom.Position - 2
                Loop
        End If
        ' blobTo.ToString() = "CBA";
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ChunkSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : ChunkSize Property

Gets a value indicating the minimum number of bytes used during read/write operations.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChunkSize As Integer
C#
public int ChunkSize {get;}

Property Value

The minimum number of bytes to retrieve or send.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Connection Property

Gets or sets the OracleConnection used by this instance of the OracleLob.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The connection to a database. The default value is a null reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsBatched Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : IsBatched Property

Gets a value indicating whether the application called the BeginBatch method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBatched As Boolean
C#
public bool IsBatched {get;}

Property Value

true if application called the BeginBatch method; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsEmpty Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : IsEmpty Property

Gets a value indicating whether the OracleLob is empty or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Property Value

true if the OracleLob is empty; otherwise, false.

Remarks

IsEmpty is true also if OracleLob has Null value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : IsNull Property

Gets a value indicating whether the OracleLob is a Null stream.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true, if the OracleLob is a Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsTemporary Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : IsTemporary Property

Gets a value indicating whether the OracleLob is a temporary LOB.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsTemporary As Boolean
C#
public bool IsTemporary {get;}

Property Value

true if the OracleLob is a temporary LOB; otherwise, false.

Remarks

LOB is considered temporary if it has no references from tables on the server. Temporary LOBs are used to insert new data into tables.

Note that temporary LOBs are destroyed when a transaction is committed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Length Property

Gets the size of the OracleLob.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
C#
public override long Length {get;}

Property Value

The size of the OracleLob in bytes.

Remarks

The size of the OracleLob is always returned in bytes for all data types.

Example

C#csharp Copy Code
OracleDataReader pictureReader = myCommand.ExecuteReader();
pictureReader.Read();
OracleLob pictureBlob = pictureReader.GetOracleLob(pictureReader.GetOrdinal("Picture"));
if (pictureBlob.Length > 100)
  pictureBlob.SetLength(100);
C#Visual Basic Copy Code
Dim pictureReader As OracleDataReader = myCommand.ExecuteReader
pictureReader.Read()
Dim pictureBlob As OracleLob = pictureReader.GetOracleLob(pictureReader.GetOrdinal("Picture"))
If (pictureBlob.Length > 100) Then
  pictureBlob.SetLength(CLng(100))
End If

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
SetLength Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LobType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : LobType Property

Gets the LOB data type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LobType As OracleDbType
C#
public OracleDbType LobType {get;}

Property Value

One of the OracleDbType LOB data types.

Remarks

An OracleLob may be one of these OracleDbType data types:

OracleDBType data type | Description
T:Devart.Data.Oracle.OracleDbType.Blob | A variable-length stream of binary data.
T:Devart.Data.Oracle.OracleDbType.Clob | A variable-length stream character string.
T:Devart.Data.Oracle.OracleDbType.NClob | National variable-length character data.
T:Devart.Data.Oracle.OracleDbType.BFile | A reference to the physical file in the operating system where Oracle is installed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Position Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Position Property

Gets the current read position in the OracleLob stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
C#
public override long Position {get; set;}

Property Value

The current position within the OracleLob stream.

Remarks

The stream must support seeking to get or set the position. Use the Devart.Data.Oracle.OracleLob.CanSeek property to determine whether the stream supports seeking.

Example

C#csharp Copy Code
static void ReverseBlob()
{
        byte[] byteArray = { (byte)'A', (byte)'B', (byte)'C' };
        OracleLob blobFrom = new OracleLob(OracleDbType.Blob);
        blobFrom.Write(byteArray, 0, byteArray.Length);
        //blobFrom.ToString() = "ABC"

        OracleLob blobTo = new OracleLob(OracleDbType.Blob);
        ........
        //reverse OracleLob
        if (blobFrom.CanSeek && blobFrom.CanRead && blobTo.CanWrite)
                for (blobFrom.Seek(-1, System.IO.SeekOrigin.End); ;blobFrom.Position -= 2)
                {
                        blobTo.WriteByte((byte)blobFrom.ReadByte());
                        if (blobFrom.Position == 1) break;
                }
        //blobTo.ToString() = "CBA";
}
C#Visual Basic Copy Code
Private Sub ReverseBlob()
        Dim byteArray As Byte() = New Byte() {AscW("A"c), AscW("B"c), AscW("C"c)}
        Dim blobFrom As New OracleLob(OracleDbType.Blob)
        blobFrom.Write(byteArray, 0, byteArray.Length)
        ' blobFrom.ToString() = "ABC"

        Dim blobTo As New OracleLob(OracleDbType.Blob)
        ........
        ' reverse OracleLob
        If ((blobFrom.CanSeek AndAlso blobFrom.CanRead) AndAlso blobTo.CanWrite) Then
                blobFrom.Seek(CLng(-1), System.IO.SeekOrigin.End)
                Do While True
                        blobTo.WriteByte(CByte(blobFrom.ReadByte))
                        If (blobFrom.Position = 1) Then
                                Return
                        End If
                        blobFrom.Position = blobFrom.Position - 2
                Loop
        End If
        ' blobTo.ToString() = "CBA";
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
CanSeek Property
Seek Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Value Property

Gets the value of the OracleLob object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

For OracleDbType.Blob and OracleDbType.BFile, an array of type Byte[]. For OracleDbType.Clob and OracleDbType.NClob, a string. For null data, Null.

Remarks

Check the IsNull property before reading the Value property to avoid raising an exception.

Example

This code fragment downloads a LOB field from a table to a file. Value property is initialized by calling GetOracleLob method and then written to a stream.
C#csharp Copy Code
OracleLob myLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"));
if(!myLob.IsNull)
{
  string FN = myReader.GetString(myReader.GetOrdinal("PicName"));
  FileStream fs = new FileStream("D:\\Tmp\\"+FN+".bmp", FileMode.Create);
  fs.Write(myLob.Value,0,(int)myLob.Length);
  fs.Close();
  Console.WriteLine(FN+" downloaded.");
}
C#Visual Basic Copy Code
Dim myLob As OracleLob = myReader.GetOracleLob(myReader.GetOrdinal("Picture"))
If Not myLob.IsNull Then
  Dim FN As String = myReader.GetString(myReader.GetOrdinal("PicName"))
  Dim fs As FileStream = New FileStream("D:\Tmp\" + FN + ".bmp", FileMode.Create)
  fs.Write(myLob.Value, 0, Convert.ToInt32(myLob.Length))
  fs.Close()
  Console.WriteLine(String.Concat(FN, " downloaded."))
End If

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members
Read Method
Write Method


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleLob Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLob Class

For a list of all members of this type, see OracleLob members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxSize | Represents the maximum number of bytes a LOB can hold, which is 4 294 967 295 (2^32 - 1) bytes.
static (Shared in Visual Basic) | Null | Deprecated. Represents a null OracleLob object. Use NullBlob or NullClob or NullNClob instead.
static (Shared in Visual Basic) | NullBlob | Represents a null OracleLob object.
static (Shared in Visual Basic) | NullClob | Represents a null OracleLob object.
static (Shared in Visual Basic) | NullNClob | Represents a null OracleLob object.
Top

See Also

Reference

OracleLob Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxSize Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : MaxSize Field

Represents the maximum number of bytes a LOB can hold, which is 4 294 967 295 (2^32 - 1) bytes.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxSize As Long
C#
public static readonly long MaxSize

Remarks

The MaxSize field can be useful to check whether the operation exceeds the maximum length allowed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Null Field

Deprecated. Represents a null OracleLob object. Use NullBlob or NullClob or NullNClob instead.

Syntax

Visual Basic (Declaration)
Public Shadows Shared ReadOnly Null As OracleLob
C#
public new static readonly OracleLob Null

Remarks

Use field Null to assign to a OracleLob in order to represent a Null value. In this case a LOB inserted in a field of a table will be Null rather than zero-length byte array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NullBlob Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : NullBlob Field

Represents a null OracleLob object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NullBlob As OracleLob
C#
public static readonly OracleLob NullBlob

Remarks

Use this field to assign to a OracleLob in order to represent a Null Blob value. In this case a Blob inserted in a field of a table will be Null rather than zero-length byte array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NullClob Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : NullClob Field

Represents a null OracleLob object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NullClob As OracleLob
C#
public static readonly OracleLob NullClob

Remarks

Use this field to assign to a OracleLob in order to represent a Null Clob value. In this case a Clob inserted in a field of a table will be Null rather than zero-length byte array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NullNClob Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : NullNClob Field

Represents a null OracleLob object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NullNClob As OracleLob
C#
public static readonly OracleLob NullNClob

Remarks

Use this field to assign to a OracleLob in order to represent a Null NClob value. In this case an NClob inserted in a field of a table will be Null rather than zero-length byte array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLogicalTransaction Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransaction Class

This class allows you to find out whether the transaction, running during the last database outage, was successfully committed and completed and determine whether your application should commit, complete, or rollback the transaction in order to avoid logical corruption because of committing duplicate transactions.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleLogicalTransaction

Syntax

Visual Basic (Declaration)
Public Class OracleLogicalTransaction
   Implements IDisposable
C#
public class OracleLogicalTransaction : IDisposable

Remarks

This class requires OCI connection mode and Oracle 12c. It also requires Transaction Guard enabled on the Oracle server.

You can use it in the following way:

  1. When an application receives a FAN down event or error, FAN automatically aborts the dead connection and OracleException generated. First, you need to check the OracleException.IsRecoverable property. If the value is true, you can re-submit the existing transaction based on the current transaction status. Otherwise, you should roll back, re-execute, and re-submit the current transaction.
  2. Retrieve the last logical transaction from the failed connection via the OracleConnection.OracleLogicalTransaction property.
  3. Execute its GetOutcome method to get the status of the transaction.
  4. After this, you should analyse the values of the Committed and UserCallCompleted properties, which mean whether the transaction was successfully committed and completed respectively, and act accordingly.

If both properties are true, it means the transaction was successful. The result can be returned to the application.

If both properties are false, it means the transaction was unsuccessful and it can be resubmitted again.

If Committed is true, and UserCallCompleted is false, it means the transaction was commited, but the information returned may be incomplete and/or not all expected work was completed. The application may not continue as expected.

Example

The following example demonstrates how to use the OracleLogicalTransaction class and its members in order to correctly process database outages and resubmit or rollback the last running transaction depending on its status.
C#csharp Copy Code
using System;
using Devart.Data.Oracle;

class Test
{
        static void Main()
        {
                string constr = "User Id=Scott;Password=tiger;Data Source=Ora;";
                OracleConnection connection = new OracleConnection(constr);
                OracleTransaction transaction = null;
                OracleCommand command = null;

                try
                {
                        connection.Open();
                        transaction = connection.BeginTransaction();
                        command = new OracleCommand(connection, "update emp set dept=10 where empno=4321");
                        command.ExecuteNonQuery();
                }
                catch(Exception e)
                {
                        Console.WriteLine(e.ToString());
                        return;
                }

                try
                {
                        transaction.Commit();
                }
                catch(OracleException e)
                {
                        if (e.IsRecoverable)
                        {
                                OracleLogicalTransaction logicalTransaction = connection.OracleLogicalTransaction;
                                logicalTransaction.GetOutcome(); // or logicalTransaction.GetOutcome("scott", "tiger", "inst1");

                                if (!logicalTransaction.Committed && !logicalTransaction.UserCallCompleted)
                                {
                                        // any chosen processing here if a retry is desired.
                                }
                                else
                                {
                                        // transaction committed, but was not fully completed
                                }
                        }
                        else
                        {
                                // Not recoverable transaction. Rollback (and re-execute).
                        }
                }
        }
}
C#Visual Basic Copy Code
Imports Devart.Data.Oracle

Class Test
        Private Shared Sub Main()
                Dim constr As String = "User Id=Scott;Password=tiger;Data Source=Ora;"
                Dim connection As New OracleConnection(constr)
                Dim transaction As OracleTransaction = Nothing
                Dim command As OracleCommand = Nothing

                Try
                        connection.Open()
                        transaction = connection.BeginTransaction()
                        command = New OracleCommand(connection, "update emp set dept=10 where empno=4321")
                        command.ExecuteNonQuery()
                Catch e As Exception
                        Console.WriteLine(e.ToString())
                        Return
                End Try

                Try
                        transaction.Commit()
                Catch e As OracleException
                        If e.IsRecoverable Then
                                Dim logicalTransaction As OracleLogicalTransaction = connection.OracleLogicalTransaction
                                logicalTransaction.GetOutcome()
                                ' or logicalTransaction.GetOutcome("scott", "tiger", "inst1");

                                If Not logicalTransaction.Committed AndAlso Not logicalTransaction.UserCallCompleted Then
                                        ' any chosen processing here if a retry is desired.
                                Else
                                        ' transaction committed, but was not fully completed
                                End If
                        Else
                                ' Not recoverable transaction. Rollback (and re-execute).
                        End If
                End Try
        End Sub
End Class

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLogicalTransaction Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLogicalTransaction Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransaction Class

The following tables list the members exposed by OracleLogicalTransaction.

Public Properties

 | Name | Description
public Property | Committed | Indicates whether the transaction was committed or not.
public Property | DataSource | Returns the data source (TNS alias) of a connection, this object is related to.
public Property | UserCallCompleted | Indicates whether the transaction was successfully completed.
public Property | UserId | Returns the user id of the connection, this object is related to.
Top

Public Methods

 | Name | Description
public Method | Dispose | Closes OracleLogicalTransaction object and releases any resources or memory allocated by it.
public Method | GetOutcome | Overloaded. Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.
Top

See Also

Reference

OracleLogicalTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleLogicalTransaction Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransaction Class

For a list of all members of this type, see OracleLogicalTransaction members.

Public Methods

 | Name | Description
public Method | Dispose | Closes OracleLogicalTransaction object and releases any resources or memory allocated by it.
public Method | GetOutcome | Overloaded. Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.
Top

See Also

Reference

OracleLogicalTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : Dispose Method

Closes OracleLogicalTransaction object and releases any resources or memory allocated by it.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOutcome Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : GetOutcome Method

Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.

Overload List

Overload | Description
GetOutcome() | Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.
GetOutcome(String,String,String) | Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOutcome() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class > GetOutcome Method : GetOutcome() Method

Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetOutcome()
C#
public void GetOutcome()

Remarks

See OracleLogicalTransaction for the example of using this method.

This method uses a cloned OracleConnection, from which the current object is obtained. The OracleConnectionStringBuilder.Pooling connection string parameter is set to false for the used connection, and this connection is closed and disposed after the necessary information is retrieved. Subsequent calls to this method won't cause an additional round-trip to the database server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOutcome(String,String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class > GetOutcome Method : GetOutcome(String,String,String) Method

userId
User Id to use for the connection.
password
Password to use for the connection.
dataSource
Data source to connect to.
Retrieves the transaction status from the server and retrieves the necessary information for filling the Committed and UserCallCompleted properties.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GetOutcome( _
   ByVal userId As String, _
   ByVal password As String, _
   ByVal dataSource As String _
)
C#
public void GetOutcome(
   string userId,
   string password,
   string dataSource
)

Parameters

userId
User Id to use for the connection.
password
Password to use for the connection.
dataSource
Data source to connect to.

Remarks

See OracleLogicalTransaction for the example of using this method.

This method uses OracleConnection with the provided parameters. The OracleConnectionStringBuilder.Pooling connection string parameter is set to false for the used connection, and this connection is closed and disposed after the necessary information is retrieved. Subsequent calls to this method won't cause an additional round-trip to the database server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLogicalTransaction Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransaction Class

For a list of all members of this type, see OracleLogicalTransaction members.

Public Properties

 | Name | Description
public Property | Committed | Indicates whether the transaction was committed or not.
public Property | DataSource | Returns the data source (TNS alias) of a connection, this object is related to.
public Property | UserCallCompleted | Indicates whether the transaction was successfully completed.
public Property | UserId | Returns the user id of the connection, this object is related to.
Top

See Also

Reference

OracleLogicalTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Committed Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : Committed Property

Indicates whether the transaction was committed or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Committed As Nullable(Of Boolean)
C#
public Nullable<bool> Committed {get;}

Property Value

true if the transaction was committed; otherwise, false. If GetOutcome was not called prior to accessing this property, it returns null.

Remarks

See OracleLogicalTransaction for the example of using this property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DataSource Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : DataSource Property

Returns the data source (TNS alias) of a connection, this object is related to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As String
C#
public string DataSource {get;}

Property Value

The data source (TNS alias) of a connection, this object is related to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members
DataSource Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserCallCompleted Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : UserCallCompleted Property

Indicates whether the transaction was successfully completed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserCallCompleted As Nullable(Of Boolean)
C#
public Nullable<bool> UserCallCompleted {get;}

Property Value

true if the transaction was successfully completed; otherwise, false. If GetOutcome was not called prior to accessing this property, it returns null.

Remarks

See OracleLogicalTransaction for the example of using this property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransaction Class : UserId Property

Returns the user id of the connection, this object is related to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserId As String
C#
public string UserId {get;}

Property Value

The user id of the connection, this object is related to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransaction Class
OracleLogicalTransaction Members
UserId Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLogicalTransactionStatus Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransactionStatus Class

Indicates the logical status of the transaction.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleLogicalTransactionStatus

Syntax

Visual Basic (Declaration)
Public Class OracleLogicalTransactionStatus
C#
public class OracleLogicalTransactionStatus

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLogicalTransactionStatus Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleLogicalTransactionStatus Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransactionStatus Class

The following tables list the members exposed by OracleLogicalTransactionStatus.

Public Properties

 | Name | Description
public Property | Committed | Indicates whether the transaction committed successfully.
public Property | UserCallCompleted | Indicates whether the transaction completed successfully.
Top

See Also

Reference

OracleLogicalTransactionStatus Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleLogicalTransactionStatus Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLogicalTransactionStatus Class

For a list of all members of this type, see OracleLogicalTransactionStatus members.

Public Properties

 | Name | Description
public Property | Committed | Indicates whether the transaction committed successfully.
public Property | UserCallCompleted | Indicates whether the transaction completed successfully.
Top

See Also

Reference

OracleLogicalTransactionStatus Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Committed Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransactionStatus Class : Committed Property

Indicates whether the transaction committed successfully.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Committed As Boolean
C#
public bool Committed {get;}

Property Value

true if the transaction committed successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransactionStatus Class
OracleLogicalTransactionStatus Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserCallCompleted Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLogicalTransactionStatus Class : UserCallCompleted Property

Indicates whether the transaction completed successfully.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UserCallCompleted As Boolean
C#
public bool UserCallCompleted {get;}

Property Value

true if the transaction completed successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLogicalTransactionStatus Class
OracleLogicalTransactionStatus Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleMetaDataCollectionNames Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMetaDataCollectionNames Class

Enumerates collection names you can use for metadata retrieval purposes.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleMetaDataCollectionNames

Syntax

Visual Basic (Declaration)
Public Class OracleMetaDataCollectionNames
C#
public class OracleMetaDataCollectionNames

Remarks

These strings can be used as arguments for Devart.Common.DbConnectionBase.GetSchema overloads.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleMetaDataCollectionNames Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleMetaDataCollectionNames Class Members
See Also Fields support@devart.com
Devart.Data.Oracle Namespace : OracleMetaDataCollectionNames Class

The following tables list the members exposed by OracleMetaDataCollectionNames.

Public Fields

 | Name | Description
public Field | Arguments | The name of the metadata collection for stored procedure/function arguments.
public Field | Clusters | The name of the metadata collection for database clusters.
public Field | Columns | The name of the metadata collection for table columns.
public Field | ForeignKeyColumns | The name of the metadata collection for columns used in foreign keys.
public Field | ForeignKeys | The name of the metadata collection for foreign keys.
public Field | Functions | The name of the metadata collection for functions.
public Field | IndexColumns | The name of the metadata collection for columns used in indexes.
public Field | Indexes | The name of the metadata collection for table indexes.
public Field | MetaDataCollections | The name of the metadata collection for metadata collection definitions.
public Field | PackageBodies | The name of the metadata collection for Oracle package bodies.
public Field | Packages | The name of the metadata collection for Oracle packages.
public Field | PrimaryKeyColumns | The name of the metadata collection for columns used in primary keys.
public Field | PrimaryKeys | The name of the metadata collection for primary keys.
public Field | Procedures | The name of the metadata collection for stored procedures.
public Field | QueuePublishers | The name of the metadata collection for registered queue publishers.
public Field | Queues | The name of the metadata collection for queues.
public Field | QueueSubscribers | The name of the metadata collection for registered queue subscribers.
public Field | QueueTables | The name of the metadata collection for Advanced Queuing queue tables.
public Field | ReservedWords | The name of metadata collection for the reserved words.
public Field | Restrictions | The name of the metadata collection for metadata restrictions.
public Field | Sequences | The name of the metadata collection for Oracle sequences.
public Field | SSISTables | The name of the metadata collection for SSIS tables.
public Field | Synonyms | The name of the metadata collection for object name synonyms.
public Field | Tables | The name of the metadata collection for Oracle tables.
public Field | Triggers | The name of the metadata collection for triggers.
public Field | Users | The name of the metadata collection for database users.
public Field | Views | The name of the metadata collection for database views.
Top

See Also

Reference

OracleMetaDataCollectionNames Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleMetaDataCollectionNames Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMetaDataCollectionNames Class

For a list of all members of this type, see OracleMetaDataCollectionNames members.

Public Fields

 | Name | Description
public Field | Arguments | The name of the metadata collection for stored procedure/function arguments.
public Field | Clusters | The name of the metadata collection for database clusters.
public Field | Columns | The name of the metadata collection for table columns.
public Field | ForeignKeyColumns | The name of the metadata collection for columns used in foreign keys.
public Field | ForeignKeys | The name of the metadata collection for foreign keys.
public Field | Functions | The name of the metadata collection for functions.
public Field | IndexColumns | The name of the metadata collection for columns used in indexes.
public Field | Indexes | The name of the metadata collection for table indexes.
public Field | MetaDataCollections | The name of the metadata collection for metadata collection definitions.
public Field | PackageBodies | The name of the metadata collection for Oracle package bodies.
public Field | Packages | The name of the metadata collection for Oracle packages.
public Field | PrimaryKeyColumns | The name of the metadata collection for columns used in primary keys.
public Field | PrimaryKeys | The name of the metadata collection for primary keys.
public Field | Procedures | The name of the metadata collection for stored procedures.
public Field | QueuePublishers | The name of the metadata collection for registered queue publishers.
public Field | Queues | The name of the metadata collection for queues.
public Field | QueueSubscribers | The name of the metadata collection for registered queue subscribers.
public Field | QueueTables | The name of the metadata collection for Advanced Queuing queue tables.
public Field | ReservedWords | The name of metadata collection for the reserved words.
public Field | Restrictions | The name of the metadata collection for metadata restrictions.
public Field | Sequences | The name of the metadata collection for Oracle sequences.
public Field | SSISTables | The name of the metadata collection for SSIS tables.
public Field | Synonyms | The name of the metadata collection for object name synonyms.
public Field | Tables | The name of the metadata collection for Oracle tables.
public Field | Triggers | The name of the metadata collection for triggers.
public Field | Users | The name of the metadata collection for database users.
public Field | Views | The name of the metadata collection for database views.
Top

See Also

Reference

OracleMetaDataCollectionNames Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Arguments Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Arguments Field

The name of the metadata collection for stored procedure/function arguments.

Syntax

Visual Basic (Declaration)
Public Const Arguments As String
C#
public const string Arguments

Field Value

The value is "Arguments".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clusters Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Clusters Field

The name of the metadata collection for database clusters.

Syntax

Visual Basic (Declaration)
Public Const Clusters As String
C#
public const string Clusters

Field Value

The value is "Clusters".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Columns Field

The name of the metadata collection for table columns.

Syntax

Visual Basic (Declaration)
Public Const Columns As String
C#
public const string Columns

Field Value

The value is "Columns".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ForeignKeyColumns Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : ForeignKeyColumns Field

The name of the metadata collection for columns used in foreign keys.

Syntax

Visual Basic (Declaration)
Public Const ForeignKeyColumns As String
C#
public const string ForeignKeyColumns

Field Value

The value is "ForeignKeyColumns".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ForeignKeys Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : ForeignKeys Field

The name of the metadata collection for foreign keys.

Syntax

Visual Basic (Declaration)
Public Const ForeignKeys As String
C#
public const string ForeignKeys

Field Value

The value is "ForeignKeys".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Functions Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Functions Field

The name of the metadata collection for functions.

Syntax

Visual Basic (Declaration)
Public Const Functions As String
C#
public const string Functions

Field Value

The value is "Functions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexColumns Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : IndexColumns Field

The name of the metadata collection for columns used in indexes.

Syntax

Visual Basic (Declaration)
Public Const IndexColumns As String
C#
public const string IndexColumns

Field Value

The value is "IndexColumns".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Indexes Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Indexes Field

The name of the metadata collection for table indexes.

Syntax

Visual Basic (Declaration)
Public Const Indexes As String
C#
public const string Indexes

Field Value

The value is "Indexes".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MetaDataCollections Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : MetaDataCollections Field

The name of the metadata collection for metadata collection definitions.

Syntax

Visual Basic (Declaration)
Public Const MetaDataCollections As String
C#
public const string MetaDataCollections

Field Value

The value is "MetaDataCollections".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PackageBodies Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : PackageBodies Field

The name of the metadata collection for Oracle package bodies.

Syntax

Visual Basic (Declaration)
Public Const PackageBodies As String
C#
public const string PackageBodies

Field Value

The value is "PackageBodies".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Packages Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Packages Field

The name of the metadata collection for Oracle packages.

Syntax

Visual Basic (Declaration)
Public Const Packages As String
C#
public const string Packages

Field Value

The value is "Packages".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PrimaryKeyColumns Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : PrimaryKeyColumns Field

The name of the metadata collection for columns used in primary keys.

Syntax

Visual Basic (Declaration)
Public Const PrimaryKeyColumns As String
C#
public const string PrimaryKeyColumns

Field Value

The value is "PrimaryKeyColumns".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PrimaryKeys Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : PrimaryKeys Field

The name of the metadata collection for primary keys.

Syntax

Visual Basic (Declaration)
Public Const PrimaryKeys As String
C#
public const string PrimaryKeys

Field Value

The value is "PrimaryKeys".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Procedures Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Procedures Field

The name of the metadata collection for stored procedures.

Syntax

Visual Basic (Declaration)
Public Const Procedures As String
C#
public const string Procedures

Field Value

The value is "Procedures".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueuePublishers Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : QueuePublishers Field

The name of the metadata collection for registered queue publishers.

Syntax

Visual Basic (Declaration)
Public Const QueuePublishers As String
C#
public const string QueuePublishers

Field Value

The value is "QueuePublishers".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Queues Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Queues Field

The name of the metadata collection for queues.

Syntax

Visual Basic (Declaration)
Public Const Queues As String
C#
public const string Queues

Field Value

The value is "Queues".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueSubscribers Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : QueueSubscribers Field

The name of the metadata collection for registered queue subscribers.

Syntax

Visual Basic (Declaration)
Public Const QueueSubscribers As String
C#
public const string QueueSubscribers

Field Value

The value is "QueueSubscribers".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueTables Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : QueueTables Field

The name of the metadata collection for Advanced Queuing queue tables.

Syntax

Visual Basic (Declaration)
Public Const QueueTables As String
C#
public const string QueueTables

Field Value

The value is "QueueTables".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReservedWords Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : ReservedWords Field

The name of metadata collection for the reserved words.

Syntax

Visual Basic (Declaration)
Public Const ReservedWords As String
C#
public const string ReservedWords

Field Value

The value is "ReservedWords".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Restrictions Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Restrictions Field

The name of the metadata collection for metadata restrictions.

Syntax

Visual Basic (Declaration)
Public Const Restrictions As String
C#
public const string Restrictions

Field Value

The value is "Restrictions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sequences Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Sequences Field

The name of the metadata collection for Oracle sequences.

Syntax

Visual Basic (Declaration)
Public Const Sequences As String
C#
public const string Sequences

Field Value

The value is "Sequences".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SSISTables Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : SSISTables Field

The name of the metadata collection for SSIS tables.

Syntax

Visual Basic (Declaration)
Public Const SSISTables As String
C#
public const string SSISTables

Field Value

The value is "SSISTables".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Synonyms Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Synonyms Field

The name of the metadata collection for object name synonyms.

Syntax

Visual Basic (Declaration)
Public Const Synonyms As String
C#
public const string Synonyms

Field Value

The value is "Synonyms".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tables Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Tables Field

The name of the metadata collection for Oracle tables.

Syntax

Visual Basic (Declaration)
Public Const Tables As String
C#
public const string Tables

Field Value

The value is "Tables".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Triggers Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Triggers Field

The name of the metadata collection for triggers.

Syntax

Visual Basic (Declaration)
Public Const Triggers As String
C#
public const string Triggers

Field Value

The value is "Triggers".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Users Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Users Field

The name of the metadata collection for database users.

Syntax

Visual Basic (Declaration)
Public Const Users As String
C#
public const string Users

Field Value

The value is "Users".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Views Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMetaDataCollectionNames Class : Views Field

The name of the metadata collection for database views.

Syntax

Visual Basic (Declaration)
Public Const Views As String
C#
public const string Views

Field Value

The value is "Views".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMetaDataCollectionNames Class
OracleMetaDataCollectionNames Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleMonitor Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMonitor Class

Monitors dynamic SQL execution in applications that use dotConnect for Oracle.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbMonitor
Devart.Common.DbMonitorHelper
Devart.Data.Oracle.OracleMonitor

Syntax

Visual Basic (Declaration)
Public Class OracleMonitor
   Inherits Devart.Common.DbMonitorHelper
   Implements IComponent, IDisposable
C#
public class OracleMonitor : Devart.Common.DbMonitorHelper, IComponent, IDisposable

Remarks

To enable monitoring just drop Devart.Data.Oracle.OracleMonitor component to the form and set IsActive property to true. If dbMonitor application has already been started you can see messages and SQL statements that your application executes. For monitoring you need only one Devart.Data.Oracle.OracleMonitor component on any of the forms your application consists of.

For example on how to trap SQL events in your application please refer to description of Devart.Common.DbMonitor.TraceEvent event of Devart.Common.DbMonitor.

For monitoring multithreaded applications with dbMonitor tool you have to specify ApartmentState.MTA attribute as shown in the example below.

See also Using dbMonitor topic.

Example

This sample shows how to enable SQL monitoring in console and web applications. To activate monitoring for web applications, a Devart.Data.Oracle.OracleMonitor object may be added to the Application collection at the first load of the default page.
C#csharp Copy Code
// Console application
[MTAThread]
static void Main(string[] args)
{
  OracleMonitor myMonitor = new OracleMonitor();
  myMonitor.IsActive = true;
  ...
}

// Web application
void Page_Load(object sender, EventArgs e)
{
        if (Application["mon"] == null)
        Application.Add("mon", new Devart.Data.Oracle.OracleMonitor() {IsActive = true});
}
C#Visual Basic Copy Code
' Console application
<MTAThread()> _
Sub Main()
  Dim myMonitor As OracleMonitor = New OracleMonitor
  myMonitor.IsActive = True
  ...
End Sub

// Web application
Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs) Handles Me.Load
        If Application("mon") Is Nothing Then
                Application.Add("mon", New Devart.Data.Oracle.OracleMonitor() With {.IsActive = True})
    End If
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleMonitor Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleMonitor Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleMonitor Class

The following tables list the members exposed by OracleMonitor.

Public Constructors

 | Name | Description
public Constructor | OracleMonitor Constructor | Initializes a new instance of the Devart.Data.Oracle.OracleMonitor class.
Top

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default. (Inherited from Devart.Common.DbMonitor)
public Property | IsActive | Overridden. Gets or sets whether Devart.Data.Oracle.OracleMonitor should watch SQL execution.
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default. (Inherited from Devart.Common.DbMonitor)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window. (Inherited from Devart.Common.DbMonitor)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when Devart.Common.DbMonitor object signals about some database activity. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

OracleMonitor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleMonitor Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMonitor Class : OracleMonitor Constructor

Initializes a new instance of the OracleMonitor class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleMonitor()

Remarks

The base constructor initializes all fields to their default values. To activate monitoring after OracleMonitor construction set IsActive property to true. To disable monitoring set this property to false. Monitoring will be automatically deactivated after OracleMonitor instance destruction.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMonitor Class
OracleMonitor Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleMonitor Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMonitor Class

For a list of all members of this type, see OracleMonitor members.

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default. (Inherited from Devart.Common.DbMonitor)
public Property | IsActive | Overridden. Gets or sets whether Devart.Data.Oracle.OracleMonitor should watch SQL execution.
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default. (Inherited from Devart.Common.DbMonitor)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

OracleMonitor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsActive Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleMonitor Class : IsActive Property

Gets or sets whether OracleMonitor should watch SQL execution.

Syntax

Visual Basic (Declaration)
Public Overrides Property IsActive As Boolean
C#
public override bool IsActive {get; set;}

Property Value

true if the OracleMonitor object should detect SQL queries peformed by the application; false otherwise.

Remarks

Set this property to true to enable monitoring of SQL statements.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleMonitor Class
OracleMonitor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNotificationEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationEventArgs Class

Provides data for the OracleDependency.OnChange event.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleNotificationEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleNotificationEventArgs
   Inherits System.EventArgs
C#
public class OracleNotificationEventArgs : System.EventArgs

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleNotificationEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleNotificationEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationEventArgs Class

The following tables list the members exposed by OracleNotificationEventArgs.

Public Properties

 | Name | Description
public Property | Details | Gets detailed information about the current notification.
public Property | ResourceNames | Gets the database resources related to the current notification.
public Property | Type | Identifies the database event source for the notification.
Top

See Also

Reference

OracleNotificationEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleNotificationEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationEventArgs Class

For a list of all members of this type, see OracleNotificationEventArgs members.

Public Properties

 | Name | Description
public Property | Details | Gets detailed information about the current notification.
public Property | ResourceNames | Gets the database resources related to the current notification.
public Property | Type | Identifies the database event source for the notification.
Top

See Also

Reference

OracleNotificationEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Details Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationEventArgs Class : Details Property

Gets detailed information about the current notification.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Details As DataTable
C#
public DataTable Details {get;}

Property Value

A DataTable object.

Remarks

The returned DataTable object contains column data about the current notification in the following order:

Column Name | Description
ResourceName | A string that represents the name of the invalidated object in the format <SchemaName>.<ObjectName>.
Info | One of the OracleNotificationInfo values. Represents the information about the database event that occurs on a resource.
Rowid | A string that represents the rowid for the invalidated table row. This value can be NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationEventArgs Class
OracleNotificationEventArgs Members
OracleNotificationInfo Enumeration
RowLevelDetails Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ResourceNames Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationEventArgs Class : ResourceNames Property

Gets the database resources related to the current notification.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ResourceNames As String()
C#
public string[] ResourceNames {get;}

Property Value

The list of related resources.

Remarks

The ResourceNames property contains information about the invalidated object names in the format <SchemaName>.<ObjectName>. To obtain more detailed information about the changes for invalidated objects, use the Details property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationEventArgs Class
OracleNotificationEventArgs Members
Details Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Type Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationEventArgs Class : Type Property

Identifies the database event source for the notification.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As OracleNotificationType
C#
public OracleNotificationType Type {get;}

Property Value

One of the OracleNotificationType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationEventArgs Class
OracleNotificationEventArgs Members
OracleNotificationType Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNotificationRequest Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationRequest Class

Represents a notification request to be subscribed in the database.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleNotificationRequest

Syntax

Visual Basic (Declaration)
Public Class OracleNotificationRequest
   Implements IDisposable
C#
public class OracleNotificationRequest : IDisposable

Remarks

The properties of OracleNotificationRequest are common for all notification requests bound for same OracleDependency object, can be adjusted only before the listener has started. The initial values of the properties are inherited from the OracleDependency object. You can adjust them in one of the OracleDependency constructors.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleNotificationRequest Members
Devart.Data.Oracle Namespace
OracleNotificationEventArgs Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleNotificationRequest Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationRequest Class

The following tables list the members exposed by OracleNotificationRequest.

Public Properties

 | Name | Description
public Property | IsNotifiedOnce | Indicates whether the registration is to be removed upon notification.
public Property | IsPersistent | Indicates whether the invalidation message should be queued persistently in the database before delivery.
public Property | Operations | Allows specifying a filter for the operations, for which notifications should be retrieved.
public Property | QueryBasedNotificationMode | Allows specifying the best-effort or guaranteed mode for query result notification.
public Property | RowLevelDetails | Indicates whether detailed information should be included in the notification data.
public Property | Timeout | Specifies the time in seconds that the registration remains alive.
Top

See Also

Reference

OracleNotificationRequest Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleNotificationRequest Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationRequest Class

For a list of all members of this type, see OracleNotificationRequest members.

Public Properties

 | Name | Description
public Property | IsNotifiedOnce | Indicates whether the registration is to be removed upon notification.
public Property | IsPersistent | Indicates whether the invalidation message should be queued persistently in the database before delivery.
public Property | Operations | Allows specifying a filter for the operations, for which notifications should be retrieved.
public Property | QueryBasedNotificationMode | Allows specifying the best-effort or guaranteed mode for query result notification.
public Property | RowLevelDetails | Indicates whether detailed information should be included in the notification data.
public Property | Timeout | Specifies the time in seconds that the registration remains alive.
Top

See Also

Reference

OracleNotificationRequest Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNotifiedOnce Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : IsNotifiedOnce Property

Indicates whether the registration is to be removed upon notification.

Syntax

Visual Basic (Declaration)
Public Property IsNotifiedOnce As Boolean
C#
public bool IsNotifiedOnce {get; set;}

Property Value

true, if the registration is to be removed upon notification; otherwise, false.

Remarks

The default value is true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsPersistent Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : IsPersistent Property

Indicates whether the invalidation message should be queued persistently in the database before delivery.

Syntax

Visual Basic (Declaration)
Public Property IsPersistent As Boolean
C#
public bool IsPersistent {get; set;}

Property Value

true, if invalidation message should be queued persistently in the database before delivery; otherwise, false.

Remarks

When the OracleNotificationRequest.IsPersistent property is set to true, the message is queued persistently in the database and cannot be lost upon database failures or shutdowns. The database performs faster if the message is stored in an in-memory queue rather than a database queue.

The default value is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Operations Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : Operations Property

Allows specifying a filter for the operations, for which notifications should be retrieved.

Syntax

Visual Basic (Declaration)
Public Property Operations As OracleNotificationInfo
C#
public OracleNotificationInfo Operations {get; set;}

Property Value

The filter for the operations, for which notifications should be retrieved.

Remarks

This property is used only for Object Change Notification

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members
OracleNotificationInfo Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueryBasedNotificationMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : QueryBasedNotificationMode Property

Allows specifying the best-effort or guaranteed mode for query result notification.

Syntax

Visual Basic (Declaration)
Public Property QueryBasedNotificationMode As OracleQueryBasedNotificationMode
C#
public OracleQueryBasedNotificationMode QueryBasedNotificationMode {get; set;}

Property Value

One of the OracleQueryBasedNotificationMode values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members
OracleQueryBasedNotificationMode Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RowLevelDetails Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : RowLevelDetails Property

Indicates whether detailed information should be included in the notification data.

Syntax

Visual Basic (Declaration)
Public Property RowLevelDetails As Boolean
C#
public bool RowLevelDetails {get; set;}

Property Value

true, if detailed information should be included; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members
Details Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Timeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNotificationRequest Class : Timeout Property

Specifies the time in seconds that the registration remains alive.

Syntax

Visual Basic (Declaration)
Public Property Timeout As Integer
C#
public int Timeout {get; set;}

Property Value

The timeout in seconds. The default value is 50000.

Remarks

The value 0 indicates that the registration should never expire. The valid values for timeout are between 0 and 4294967295.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNotificationRequest Class
OracleNotificationRequest Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMapping Class

Represents a mapping between .NET and Oracle number types.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleNumberMapping

Syntax

Visual Basic (Declaration)
Public Class OracleNumberMapping
   Implements ICloneable
C#
public class OracleNumberMapping : ICloneable

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleNumberMapping Members
Devart.Data.Oracle Namespace
OracleNumberMappingCollection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMapping Class

The following tables list the members exposed by OracleNumberMapping.

Public Constructors

 | Name | Description
public Constructor | OracleNumberMapping Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | FromPrecision | Gets the minimal precision of Oracle number for which it is mapped to the specified .NET type.
public Property | NumberType | Gets the Oracle number type being mapped.
public Property | ToPrecision | Gets the maximal precision of Oracle number for which it is mapped to the specified .NET type.
public Property | ValueType | Gets the .NET type to which the Oracle number is mapped.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a new OracleNumberMapping object that is a copy of the current instance.
public Method | Equals | Overloaded. Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
public Method | GetHashCode | Gets the hash code of the current OracleNumberMapping object.
public Method | ToString | Returns the OracleNumberMapping object as the string representation.
Top

See Also

Reference

OracleNumberMapping Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : OracleNumberMapping Constructor

Overload List

Overload | Description
OracleNumberMapping Constructor() | Creates an OracleNumberMapping object with default mapping.
OracleNumberMapping Constructor(OracleNumberType,Int32,Type) | Initializes a new instance of the OracleNumberMapping class.
OracleNumberMapping Constructor(OracleNumberType,Int32,Int32,Type) | Initializes a new instance of the OracleNumberMapping class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class > OracleNumberMapping Constructor : OracleNumberMapping Constructor()

Creates an OracleNumberMapping object with default mapping.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleNumberMapping()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Constructor(OracleNumberType,Int32,Type)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class > OracleNumberMapping Constructor : OracleNumberMapping Constructor(OracleNumberType,Int32,Type)

numberType
The Oracle number type being mapped.
precision
The precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.
Initializes a new instance of the OracleNumberMapping class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal numberType As OracleNumberType, _
   ByVal precision As Integer, _
   ByVal valueType As Type _
)
C#
public OracleNumberMapping(
   OracleNumberType numberType,
   int precision,
   Type valueType
)

Parameters

numberType
The Oracle number type being mapped.
precision
The precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Constructor(OracleNumberType,Int32,Int32,Type)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class > OracleNumberMapping Constructor : OracleNumberMapping Constructor(OracleNumberType,Int32,Int32,Type)

numberType
The Oracle number type being mapped.
fromPrecision
The minimal precision of Oracle number for which it should be mapped to the specified .NET type.
toPrecision
The maximal precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.
Initializes a new instance of the OracleNumberMapping class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal numberType As OracleNumberType, _
   ByVal fromPrecision As Integer, _
   ByVal toPrecision As Integer, _
   ByVal valueType As Type _
)
C#
public OracleNumberMapping(
   OracleNumberType numberType,
   int fromPrecision,
   int toPrecision,
   Type valueType
)

Parameters

numberType
The Oracle number type being mapped.
fromPrecision
The minimal precision of Oracle number for which it should be mapped to the specified .NET type.
toPrecision
The maximal precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMapping Class

For a list of all members of this type, see OracleNumberMapping members.

Public Methods

 | Name | Description
public Method | Clone | Creates a new OracleNumberMapping object that is a copy of the current instance.
public Method | Equals | Overloaded. Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
public Method | GetHashCode | Gets the hash code of the current OracleNumberMapping object.
public Method | ToString | Returns the OracleNumberMapping object as the string representation.
Top

See Also

Reference

OracleNumberMapping Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : Clone Method

Creates a new OracleNumberMapping object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new OracleNumberMapping object that is a copy of this instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : Equals Method

Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.

Overload List

Overload | Description
Equals(Object) | Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
Equals(OracleNumberMapping) | Indicates whether the current OracleNumberMapping object is equal to the one passed as the other parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class > Equals Method : Equals(Object) Method

obj
The OracleNumberMapping instance to compare the current one with.
Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The OracleNumberMapping instance to compare the current one with.

Return Value

true if the OracleNumberMapping objects are eual; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleNumberMapping) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class > Equals Method : Equals(OracleNumberMapping) Method

other
The OracleNumberMapping to compare with.
Indicates whether the current OracleNumberMapping object is equal to the one passed as the other parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As OracleNumberMapping _
) As Boolean
C#
public bool Equals(
   OracleNumberMapping other
)

Parameters

other
The OracleNumberMapping to compare with.

Return Value

true if the objects are eual; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : GetHashCode Method

Gets the hash code of the current OracleNumberMapping object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current OracleNumberMapping object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : ToString Method

Returns the OracleNumberMapping object as the string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The string representation of the current OracleNumberMapping object.

Remarks

Here are some examples of the OracleNumberMapping string representation: "(Integer, 1, 1, System.Boolean)", "(FLOAT,12,15,System.Decimal)", "(NUMBER,7,9,System.Single)".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleNumberMapping Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMapping Class

For a list of all members of this type, see OracleNumberMapping members.

Public Properties

 | Name | Description
public Property | FromPrecision | Gets the minimal precision of Oracle number for which it is mapped to the specified .NET type.
public Property | NumberType | Gets the Oracle number type being mapped.
public Property | ToPrecision | Gets the maximal precision of Oracle number for which it is mapped to the specified .NET type.
public Property | ValueType | Gets the .NET type to which the Oracle number is mapped.
Top

See Also

Reference

OracleNumberMapping Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FromPrecision Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : FromPrecision Property

Gets the minimal precision of Oracle number for which it is mapped to the specified .NET type.

Syntax

Visual Basic (Declaration)
Public Property FromPrecision As Integer
C#
public int FromPrecision {get; set;}

Property Value

The minimal precision of Oracle number for which it is mapped to the specified .NET type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NumberType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : NumberType Property

Gets the Oracle number type being mapped.

Syntax

Visual Basic (Declaration)
Public Property NumberType As OracleNumberType
C#
public OracleNumberType NumberType {get; set;}

Property Value

The Oracle number type being mapped.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToPrecision Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : ToPrecision Property

Gets the maximal precision of Oracle number for which it is mapped to the specified .NET type.

Syntax

Visual Basic (Declaration)
Public Property ToPrecision As Integer
C#
public int ToPrecision {get; set;}

Property Value

The maximal precision of Oracle number for which it is mapped to the specified .NET type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ValueType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMapping Class : ValueType Property

Gets the .NET type to which the Oracle number is mapped.

Syntax

Visual Basic (Declaration)
Public Property ValueType As Type
C#
public Type ValueType {get; set;}

Property Value

The .NET type to which the Oracle number is mapped.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMapping Class
OracleNumberMapping Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMappingCollection Class

Represents a collection of OracleNumberMapping objects.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleNumberMappingCollection

Syntax

Visual Basic (Declaration)
Public Class OracleNumberMappingCollection
   Implements ICollection(Of OracleNumberMapping), IEnumerable(Of OracleNumberMapping), IList(Of OracleNumberMapping), ICollection, IEnumerable, IList, ICloneable
C#
public class OracleNumberMappingCollection : ICollection<OracleNumberMapping>, IEnumerable<OracleNumberMapping>, IList<OracleNumberMapping>, ICollection, IEnumerable, IList, ICloneable

Remarks

Use this collection to set the OracleConnection.NumberMappings property of OracleConnection objects. It specifies to which .NET types the Oracle number types will be mapped.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleNumberMappingCollection Members
Devart.Data.Oracle Namespace
NumberMappings Property
OracleNumberMapping Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMappingCollection Class

The following tables list the members exposed by OracleNumberMappingCollection.

Public Constructors

 | Name | Description
public Constructor | OracleNumberMappingCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements contained in the collection.
public Property | Item | Gets or sets OracleNumberMapping object at the specified index in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an OracleNumberMapping object to the collection.
public Method | AddRange | Overloaded. Adds OracleNumberMapping objects from the specified values parameter.
public Method | Clear | Removes all objects from the collection.
public Method | Clone | Creates a new Devart.Data.Oracle.OracleNumberMappingCollection object that is a copy of the current instance.
public Method | Contains | Indicates whether the collection contains the specified OracleNumberMapping object.
public Method | Equals | Overloaded. Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
public Method | GetEnumerator | Returns an enumerator for the Devart.Data.Oracle.OracleNumberMappingCollection.
public Method | GetHashCode | Gets the hash code of the current Devart.Data.Oracle.OracleNumberMappingCollection object.
public Method | GetMappedType | This method allows you to test your number mapping configuration and see what type will be used for the specified precision and scale values.
public Method | IndexOf | Gets the location of the OracleNumberMapping object in the collection.
public Method | Insert | Inserts the specified OracleNumberMapping object into the collection at the specified index.
static (Shared in Visual Basic) | Parse | Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance.
public Method | Remove | Removes the specified OracleNumberMapping object from the collection.
public Method | RemoveAt | Removes a OracleNumberMapping object at the specified index from the collection.
public Method | ToString | Returns the OracleNumberMapping object as the string representation.
static (Shared in Visual Basic) | TryParse | Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance as an out parameter.
Top

See Also

Reference

OracleNumberMappingCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : OracleNumberMappingCollection Constructor

Overload List

Overload | Description
OracleNumberMappingCollection Constructor() | Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection with capacity = 4.
OracleNumberMappingCollection Constructor(Int32) | Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection and allows you to set its capacity.
OracleNumberMappingCollection Constructor(IEnumerable<OracleNumberMapping>) | Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection with capacity = 4.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > OracleNumberMappingCollection Constructor : OracleNumberMappingCollection Constructor()

Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection with capacity = 4.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleNumberMappingCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Constructor(Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > OracleNumberMappingCollection Constructor : OracleNumberMappingCollection Constructor(Int32)

capacity
The capacity of the new collection.
Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection and allows you to set its capacity.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal capacity As Integer _
)
C#
public OracleNumberMappingCollection(
   int capacity
)

Parameters

capacity
The capacity of the new collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Constructor(IEnumerable<OracleNumberMapping>)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > OracleNumberMappingCollection Constructor : OracleNumberMappingCollection Constructor(IEnumerable<OracleNumberMapping>)

values
Creates an empty Devart.Data.Oracle.OracleNumberMappingCollection with capacity = 4.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal values As IEnumerable(Of OracleNumberMapping) _
)
C#
public OracleNumberMappingCollection(
   IEnumerable<OracleNumberMapping> values
)

Parameters

values

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMappingCollection Class

For a list of all members of this type, see OracleNumberMappingCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an OracleNumberMapping object to the collection.
public Method | AddRange | Overloaded. Adds OracleNumberMapping objects from the specified values parameter.
public Method | Clear | Removes all objects from the collection.
public Method | Clone | Creates a new Devart.Data.Oracle.OracleNumberMappingCollection object that is a copy of the current instance.
public Method | Contains | Indicates whether the collection contains the specified OracleNumberMapping object.
public Method | Equals | Overloaded. Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
public Method | GetEnumerator | Returns an enumerator for the Devart.Data.Oracle.OracleNumberMappingCollection.
public Method | GetHashCode | Gets the hash code of the current Devart.Data.Oracle.OracleNumberMappingCollection object.
public Method | GetMappedType | This method allows you to test your number mapping configuration and see what type will be used for the specified precision and scale values.
public Method | IndexOf | Gets the location of the OracleNumberMapping object in the collection.
public Method | Insert | Inserts the specified OracleNumberMapping object into the collection at the specified index.
static (Shared in Visual Basic) | Parse | Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance.
public Method | Remove | Removes the specified OracleNumberMapping object from the collection.
public Method | RemoveAt | Removes a OracleNumberMapping object at the specified index from the collection.
public Method | ToString | Returns the OracleNumberMapping object as the string representation.
static (Shared in Visual Basic) | TryParse | Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance as an out parameter.
Top

See Also

Reference

OracleNumberMappingCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Add Method

Adds an OracleNumberMapping object to the collection.

Overload List

Overload | Description
Add(OracleNumberMapping) | Adds the specified OracleNumberMapping object to the collection.
Add(OracleNumberType,Int32,Type) | Creates a new instance of the OracleNumberMapping class and adds it to the collection.
Add(OracleNumberType,Int32,Int32,Type) | Creates a new instance of the OracleNumberMapping class and adds it to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleNumberMapping) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > Add Method : Add(OracleNumberMapping) Method

value
The OracleNumberMapping object to be added.
Adds the specified OracleNumberMapping object to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal value As OracleNumberMapping _
)
C#
public void Add(
   OracleNumberMapping value
)

Parameters

value
The OracleNumberMapping object to be added.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleNumberType,Int32,Type) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > Add Method : Add(OracleNumberType,Int32,Type) Method

numberType
The Oracle number type being mapped.
precision
The precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.
Creates a new instance of the OracleNumberMapping class and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal numberType As OracleNumberType, _
   ByVal precision As Integer, _
   ByVal valueType As Type _
) As OracleNumberMapping
C#
public OracleNumberMapping Add(
   OracleNumberType numberType,
   int precision,
   Type valueType
)

Parameters

numberType
The Oracle number type being mapped.
precision
The precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.

Return Value

The created OracleNumberMapping object.

Example

This sample demonstrates how to override default number mapping rules.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection();

// Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, typeof(Int64));

// Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, typeof(bool));
C#Visual Basic Copy Code
Dim oracleConnection as New OracleConnection

' Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, GetType(Int64))

' Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, GetType(Boolean))

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleNumberType,Int32,Int32,Type) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > Add Method : Add(OracleNumberType,Int32,Int32,Type) Method

numberType
The Oracle number type being mapped.
fromPrecision
The minimal precision of Oracle number for which it should be mapped to the specified .NET type.
toPrecision
The maximal precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.
Creates a new instance of the OracleNumberMapping class and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal numberType As OracleNumberType, _
   ByVal fromPrecision As Integer, _
   ByVal toPrecision As Integer, _
   ByVal valueType As Type _
) As OracleNumberMapping
C#
public OracleNumberMapping Add(
   OracleNumberType numberType,
   int fromPrecision,
   int toPrecision,
   Type valueType
)

Parameters

numberType
The Oracle number type being mapped.
fromPrecision
The minimal precision of Oracle number for which it should be mapped to the specified .NET type.
toPrecision
The maximal precision of Oracle number for which it should be mapped to the specified .NET type.
valueType
The .NET type to which the Oracle number is mapped.

Return Value

The created OracleNumberMapping object.

Example

This sample demonstrates how to override default number mapping rules for the connection.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection();

// Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, typeof(Int64));

// Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, typeof(bool));
C#Visual Basic Copy Code
Dim oracleConnection as New OracleConnection

' Map NUMBER(10)..NUMBER(18)  to Int64
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 10, 18, GetType(Int64))

' Map NUMBER(1)  to Boolean
oracleConnection.NumberMappings.Add(OracleNumberType.Integer, 1, GetType(Boolean))

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddRange Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : AddRange Method

Adds OracleNumberMapping objects from the specified values parameter.

Overload List

Overload | Description
AddRange(IEnumerable) | Adds OracleNumberMapping objects from the specified values parameter.
AddRange(IEnumerable<OracleNumberMapping>) |

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddRange(IEnumerable) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > AddRange Method : AddRange(IEnumerable) Method

values
The enumerator that is used to get OracleNumberMapping objects to add to the collection.
Adds OracleNumberMapping objects from the specified values parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal values As IEnumerable _
)
C#
public void AddRange(
   IEnumerable values
)

Parameters

values
The enumerator that is used to get OracleNumberMapping objects to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddRange(IEnumerable<OracleNumberMapping>) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > AddRange Method : AddRange(IEnumerable<OracleNumberMapping>) Method

values

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal values As IEnumerable(Of OracleNumberMapping) _
)
C#
public void AddRange(
   IEnumerable<OracleNumberMapping> values
)

Parameters

values

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Clear Method

Removes all objects from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Clone Method

Creates a new Devart.Data.Oracle.OracleNumberMappingCollection object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleNumberMappingCollection
C#
public OracleNumberMappingCollection Clone()

Return Value

A new Devart.Data.Oracle.OracleNumberMappingCollection object that is a copy of this instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Contains Method

value
The OracleNumberMapping object to find.
Indicates whether the collection contains the specified OracleNumberMapping object.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As OracleNumberMapping _
) As Boolean
C#
public bool Contains(
   OracleNumberMapping value
)

Parameters

value
The OracleNumberMapping object to find.

Return Value

true if the OracleNumberMapping is in the collection; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Equals Method

Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.

Overload List

Overload | Description
Equals(Object) | Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.
Equals(OracleNumberMappingCollection) | Indicates whether the current Devart.Data.Oracle.OracleNumberMappingCollection object is equal to the one passed as the other parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > Equals Method : Equals(Object) Method

obj
The OracleNumberMapping instance to compare the current one with.
Indicates whether the current OracleNumberMapping instance is equal to the one passed as the other parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The OracleNumberMapping instance to compare the current one with.

Return Value

true if the OracleNumberMapping objects are eual; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleNumberMappingCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class > Equals Method : Equals(OracleNumberMappingCollection) Method

other
The Devart.Data.Oracle.OracleNumberMappingCollection to compare with.
Indicates whether the current Devart.Data.Oracle.OracleNumberMappingCollection object is equal to the one passed as the other parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Function Equals( _
   ByVal other As OracleNumberMappingCollection _
) As Boolean
C#
public bool Equals(
   OracleNumberMappingCollection other
)

Parameters

other
The Devart.Data.Oracle.OracleNumberMappingCollection to compare with.

Return Value

true if the objects are eual; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : GetEnumerator Method

Returns an enumerator for the Devart.Data.Oracle.OracleNumberMappingCollection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of OracleNumberMapping)
C#
public IEnumerator<OracleNumberMapping> GetEnumerator()

Return Value

An enumerator for the Devart.Data.Oracle.OracleNumberMappingCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : GetHashCode Method

Gets the hash code of the current Devart.Data.Oracle.OracleNumberMappingCollection object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current Devart.Data.Oracle.OracleNumberMappingCollection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetMappedType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : GetMappedType Method

precision
The specified precision.
scale
The specified scale.
This method allows you to test your number mapping configuration and see what type will be used for the specified precision and scale values.

Syntax

Visual Basic (Declaration)
Public Function GetMappedType( _
   ByVal precision As Integer, _
   ByVal scale As Integer _
) As Type
C#
public Type GetMappedType(
   int precision,
   int scale
)

Parameters

precision
The specified precision.
scale
The specified scale.

Return Value

The .NET type that will be used to map the Oracle number types with the specified precision and scale.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : IndexOf Method

value
The OracleNumberMapping object to find.
Gets the location of the OracleNumberMapping object in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As OracleNumberMapping _
) As Integer
C#
public int IndexOf(
   OracleNumberMapping value
)

Parameters

value
The OracleNumberMapping object to find.

Return Value

The zero-based location of the OracleNumberMapping in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Insert Method

index
The zero-based index where to insert the object.
value
The OracleNumberMapping object to add to the collection.
Inserts the specified OracleNumberMapping object into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OracleNumberMapping _
)
C#
public void Insert(
   int index,
   OracleNumberMapping value
)

Parameters

index
The zero-based index where to insert the object.
value
The OracleNumberMapping object to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Parse Method

value
The string representation of Devart.Data.Oracle.OracleNumberMappingCollection to parse.
Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal value As String _
) As OracleNumberMappingCollection
C#
public static OracleNumberMappingCollection Parse(
   string value
)

Parameters

value
The string representation of Devart.Data.Oracle.OracleNumberMappingCollection to parse.

Return Value

Devart.Data.Oracle.OracleNumberMappingCollection instance, corresponding to the string representation.

Remarks

If the string value is not valid, throws an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Remove Method

value
The OracleNumberMapping object to remove from the collection.
Removes the specified OracleNumberMapping object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As OracleNumberMapping _
)
C#
public void Remove(
   OracleNumberMapping value
)

Parameters

value
The OracleNumberMapping object to remove from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveAt Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : RemoveAt Method

index
The zero-based index of the object to remove.
Removes a OracleNumberMapping object at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
C#
public void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the object to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : ToString Method

Returns the OracleNumberMapping object as the string representation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The string representation of the current OracleNumberMapping object.

Remarks

An example of an Devart.Data.Oracle.OracleNumberMappingCollection string representation: " ((Integer, 1, 5, System.Int16), (FLOAT,12,15,System.Decimal), (NUMBER,7,9,System.Single))"

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,OracleNumberMappingCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : TryParse(String,OracleNumberMappingCollection) Method

value
The string representation of Devart.Data.Oracle.OracleNumberMappingCollection to parse.
numberMappings
Devart.Data.Oracle.OracleNumberMappingCollection instance, corresponding to the string representation.
Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance as an out parameter.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal value As String, _
   ByRef numberMappings As OracleNumberMappingCollection _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleNumberMappingCollection numberMappings
)

Parameters

value
The string representation of Devart.Data.Oracle.OracleNumberMappingCollection to parse.
numberMappings
Devart.Data.Oracle.OracleNumberMappingCollection instance, corresponding to the string representation.

Return Value

true if the string value is valid and is correctly parsed; otherwise, false.

Remarks

An example of an Devart.Data.Oracle.OracleNumberMappingCollection string representation: " ((Integer, 1, 5, System.Int16), (FLOAT,12,15,System.Decimal), (NUMBER,7,9,System.Single))"

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleNumberMappingCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberMappingCollection Class

For a list of all members of this type, see OracleNumberMappingCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements contained in the collection.
public Property | Item | Gets or sets OracleNumberMapping object at the specified index in the collection.
Top

See Also

Reference

OracleNumberMappingCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Count Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Count Property

Gets the number of elements contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Property Value

The number of elements contained in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : Item Property

index
The zero-based index of the agent.
Gets or sets OracleNumberMapping object at the specified index in the collection.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OracleNumberMapping
C#
public OracleNumberMapping this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the agent.

Property Value

The OracleNumberMapping object at the specified index in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleObject Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleObject Class

Represents a client-side cached Oracle object of type defined by user.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleObject

Syntax

Visual Basic (Declaration)
Public Class OracleObject
   Inherits System.MarshalByRefObject
   Implements ICustomOracleObject, IListSource, INullable, ICloneable
C#
public class OracleObject : System.MarshalByRefObject, ICustomOracleObject, IListSource, INullable, ICloneable

Remarks

To retrieve values of object attributes OracleObject class uses Item indexed property.

You can create an instance of OracleObject by one of the following ways:

- execute a query that returns an object as one of the fields calling OracleDataReader.GetOracleObject method;

- return an OracleObject instance as a parameter value of OracleDbType.Object type;

- get the OracleObject as a value of owned OracleObject attribute.

Also you can create an instance of OracleObject manually.

You can use OracleObject to pass object as a parameter value.

Note that OracleObject can be used in data binding with DataGrid as it implements IListSource interface.

Example

This example demonstrates how to retrieve OracleObject instance from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Address");
  while (dataReader.Read()) {
    OracleObject oraObj = dataReader.GetOracleObject(index);
    if (!oraObj.IsNull) {
      string country = (string)oraObj["Country"];
      string city = (string)oraObj["City"];
      string street = (string)oraObj["Street"];
      decimal Apartment = (decimal)oraObj["Apartment"];
      Console.WriteLine(dataReader.GetString(0) + "   " +
                        dataReader.GetString(1) + "   " + "Adress: " + country +
                        ", " + city + ", " + street + ", "+ Apartment.ToString()
                        + "   " + dataReader.GetString(3));
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Address")
  While dataReader.Read()
    Dim oraObj As OracleObject = dataReader.GetOracleObject(index)
    If Not oraObj.IsNull Then
      Dim country As String = oraObj("Country")
      Dim city As String = oraObj("City")
      Dim street As String = oraObj("Street")
      Dim Apartment As Decimal = oraObj("Apartment")
      Console.WriteLine(dataReader.GetString(0) & "   " & dataReader.GetString(1) & "   " & _
          "Adress: " & country & ", " & city & ", " & street & ", " & _
          Apartment.ToString() & "   " & dataReader.GetString(3))
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleObject Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleObject Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleObject Class

The following tables list the members exposed by OracleObject.

Public Constructors

 | Name | Description
public Constructor | OracleObject Constructor | Overloaded. Initializes a new instance of the OracleObject class.
Top

Public Properties

 | Name | Description
public Property | IsNull | Indicates whether or not the OracleObject represents a null value.
public Property | Item | Overloaded. Gets or sets the OracleAttribute or OracleArray element by the specified path.
static (Shared in Visual Basic) | Null | Represents a null value of an OracleObject object.
public Property | ObjectType | Gets an OracleType of the specified object.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current instance.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | ExecuteMethod | Overloaded. Invokes the specified method of an object of user-defined type.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Overloaded. Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleObject Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : OracleObject Constructor

Initializes a new instance of the OracleObject class.

Overload List

Overload | Description
OracleObject Constructor(String,OracleConnection) | Initializes a new instance of the OracleObject class.
OracleObject Constructor(OracleType) | Initializes a new instance of the OracleObject class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleObject Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > OracleObject Constructor : OracleObject Constructor(String,OracleConnection)

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.
Initializes a new instance of the OracleObject class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleObject(
   string typeName,
   OracleConnection connection
)

Parameters

typeName
Name of the object type at the Oracle server.
connection
An OracleConnection used to describe object type at the Oracle server.

Remarks

Use this constructor to create an OracleObject and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of OracleParameter initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleObject Constructor(OracleType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > OracleObject Constructor : OracleObject Constructor(OracleType)

oraType
An OracleType to create a new instance of the OracleObject.
Initializes a new instance of the OracleObject class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oraType As OracleType _
)
C#
public OracleObject(
   OracleType oraType
)

Parameters

oraType
An OracleType to create a new instance of the OracleObject.

Remarks

Use this constructor to create an OracleObject and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of OracleParameter initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleObject Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleObject Class

For a list of all members of this type, see OracleObject members.

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current instance.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | ExecuteMethod | Overloaded. Invokes the specified method of an object of user-defined type.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Overloaded. Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : Clone Method

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
C#
public object Clone()

Return Value

A new OracleObject object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : ExecuteMethod Method

Invokes the specified method of an object of user-defined type.

Overload List

Overload | Description
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Object[]) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Type,Object[]) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection,Boolean) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(OracleConnection,String,Object[]) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(OracleConnection,String,Type,Object[]) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(OracleConnection,String,OracleParameterCollection) | Calls the method of an Oracle object with the specified set of parameters.
ExecuteMethod(OracleConnection,String,OracleParameterCollection,Boolean) | Calls the method of an Oracle object with the specified set of parameters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Object[]) Method

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
The list of input parameters passed to the method.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ExecuteMethod( _
   ByVal obj As ICustomOracleObject, _
   ByVal connection As OracleConnection, _
   ByVal typeName As String, _
   ByVal methodName As String, _
   ByVal ParamArray parameters() As Object _
)
C#
public static void ExecuteMethod(
   ICustomOracleObject obj,
   OracleConnection connection,
   string typeName,
   string methodName,
   params object[] parameters
)

Parameters

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
The list of input parameters passed to the method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Type,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,Type,Object[]) Method

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
resultType
The type of the method's return value.
parameters
The list of input parameters passed to the method.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ExecuteMethod( _
   ByVal obj As ICustomOracleObject, _
   ByVal connection As OracleConnection, _
   ByVal typeName As String, _
   ByVal methodName As String, _
   ByVal resultType As Type, _
   ByVal ParamArray parameters() As Object _
) As Object
C#
public static object ExecuteMethod(
   ICustomOracleObject obj,
   OracleConnection connection,
   string typeName,
   string methodName,
   Type resultType,
   params object[] parameters
)

Parameters

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
resultType
The type of the method's return value.
parameters
The list of input parameters passed to the method.

Return Value

The method's return value casted to the resultType type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection) Method

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ExecuteMethod( _
   ByVal obj As ICustomOracleObject, _
   ByVal connection As OracleConnection, _
   ByVal typeName As String, _
   ByVal methodName As String, _
   ByVal parameters As OracleParameterCollection _
) As Object
C#
public static object ExecuteMethod(
   ICustomOracleObject obj,
   OracleConnection connection,
   string typeName,
   string methodName,
   OracleParameterCollection parameters
)

Parameters

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.

Return Value

The return value of the UDT method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(ICustomOracleObject,OracleConnection,String,String,OracleParameterCollection,Boolean) Method

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
parameterCheck
A boolean specifying whether the parameter set should be generated automatically based on the UDT method's declaration.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ExecuteMethod( _
   ByVal obj As ICustomOracleObject, _
   ByVal connection As OracleConnection, _
   ByVal typeName As String, _
   ByVal methodName As String, _
   ByVal parameters As OracleParameterCollection, _
   ByVal parameterCheck As Boolean _
) As Object
C#
public static object ExecuteMethod(
   ICustomOracleObject obj,
   OracleConnection connection,
   string typeName,
   string methodName,
   OracleParameterCollection parameters,
   bool parameterCheck
)

Parameters

obj
The object which method to execute. Can be either typed (i.e., an instance of a wizard-generated class) or untyped (i.e., an OracleObject instance).
connection
The connection to the Oracle database where the UDT used is declared.
typeName
The user-defined type which obj is an instance of.
methodName
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
parameterCheck
A boolean specifying whether the parameter set should be generated automatically based on the UDT method's declaration.

Return Value

The return value of the UDT method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(OracleConnection,String,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(OracleConnection,String,Object[]) Method

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
The list of input parameters passed to the method.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteMethod( _
   ByVal connection As OracleConnection, _
   ByVal name As String, _
   ByVal ParamArray parameters() As Object _
)
C#
public void ExecuteMethod(
   OracleConnection connection,
   string name,
   params object[] parameters
)

Parameters

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
The list of input parameters passed to the method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(OracleConnection,String,Type,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(OracleConnection,String,Type,Object[]) Method

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
resultType
The type of the method's return value.
parameters
The list of input parameters passed to the method.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteMethod( _
   ByVal connection As OracleConnection, _
   ByVal name As String, _
   ByVal resultType As Type, _
   ByVal ParamArray parameters() As Object _
) As Object
C#
public object ExecuteMethod(
   OracleConnection connection,
   string name,
   Type resultType,
   params object[] parameters
)

Parameters

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
resultType
The type of the method's return value.
parameters
The list of input parameters passed to the method.

Return Value

The method's return value casted to the resultType type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(OracleConnection,String,OracleParameterCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(OracleConnection,String,OracleParameterCollection) Method

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteMethod( _
   ByVal connection As OracleConnection, _
   ByVal name As String, _
   ByVal parameters As OracleParameterCollection _
) As Object
C#
public object ExecuteMethod(
   OracleConnection connection,
   string name,
   OracleParameterCollection parameters
)

Parameters

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.

Return Value

The return value of the UDT method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteMethod(OracleConnection,String,OracleParameterCollection,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > ExecuteMethod Method : ExecuteMethod(OracleConnection,String,OracleParameterCollection,Boolean) Method

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
parameterCheck
A boolean specifying whether the parameter set should be generated automatically based on the UDT method's declaration.
Calls the method of an Oracle object with the specified set of parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteMethod( _
   ByVal connection As OracleConnection, _
   ByVal name As String, _
   ByVal parameters As OracleParameterCollection, _
   ByVal parameterCheck As Boolean _
) As Object
C#
public object ExecuteMethod(
   OracleConnection connection,
   string name,
   OracleParameterCollection parameters,
   bool parameterCheck
)

Parameters

connection
The connection to the Oracle database where the UDT used is declared.
name
The method to be invoked.
parameters
An OracleParameterCollection collection of method parameters.
parameterCheck
A boolean specifying whether the parameter set should be generated automatically based on the UDT method's declaration.

Return Value

The return value of the UDT method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : GetOracleValue Method

Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Overload List

Overload | Description
GetOracleValue(OracleAttribute) | Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.
GetOracleValue(String) | Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(OracleAttribute) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > GetOracleValue Method : GetOracleValue(OracleAttribute) Method

attribute
An OracleAttribute object.
Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal attribute As OracleAttribute _
) As Object
C#
public object GetOracleValue(
   OracleAttribute attribute
)

Parameters

attribute
An OracleAttribute object.

Return Value

The value of the attribute as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetOracleValue(String) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > GetOracleValue Method : GetOracleValue(String) Method

attributeName
String that represents a full path to the attribute or the element of the array.
Gets the value of the attribute in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetOracleValue( _
   ByVal attributeName As String _
) As Object
C#
public object GetOracleValue(
   string attributeName
)

Parameters

attributeName
String that represents a full path to the attribute or the element of the array.

Return Value

The value of the attribute as the dotConnect for Oracle wrapped type.

Remarks

GetOracleValue returns data using the native Oracle types. To retrieve data using the .NET Framework types, see Item property.

Example

This example demonstrates how to retrieve OracleObject instance from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Address");
  while (dataReader.Read()) {
    OracleObject oraObj = dataReader.GetOracleObject(index);
    if (!oraObj.IsNull) {
      string country = (string)oraObj.GetOracleValue("Country");
      string city = (string)oraObj.GetOracleValue("City");
      string street = (string)oraObj.GetOracleValue("Street");
      decimal Apartment = (decimal)oraObj["Apartment"];
      Console.WriteLine(dataReader.GetString(0) + "   " + dataReader.GetString(1) + "   " + "Adress: " + country + ", " + city + ", " + street + ", "+ Apartment.ToString() + "   " + dataReader.GetString(3));
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Address")
  While dataReader.Read()
    Dim oraObj As OracleObject = dataReader.GetOracleObject(index)
    If Not oraObj.IsNull Then
      Dim country As String = oraObj.GetOracleValue("Country")
      Dim city As String = oraObj.GetOracleValue("City")
      Dim street As String = oraObj.GetOracleValue("Street")
      Dim Apartment As Decimal = oraObj("Apartment")
      Console.WriteLine(dataReader.GetString(0) & "   " & dataReader.GetString(1) & "   " & "Adress: " & country & ", " & city & ", " & street & ", " & Apartment.ToString() & "   " & dataReader.GetString(3))
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleObject Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleObject Class

For a list of all members of this type, see OracleObject members.

Public Properties

 | Name | Description
public Property | IsNull | Indicates whether or not the OracleObject represents a null value.
public Property | Item | Overloaded. Gets or sets the OracleAttribute or OracleArray element by the specified path.
static (Shared in Visual Basic) | Null | Represents a null value of an OracleObject object.
public Property | ObjectType | Gets an OracleType of the specified object.
Top

See Also

Reference

OracleObject Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : IsNull Property

Indicates whether or not the OracleObject represents a null value.

Syntax

Visual Basic (Declaration)
Public Property IsNull As Boolean
C#
public bool IsNull {get; set;}

Property Value

true if the OracleObject represents a null value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : Item Property

Gets or sets the OracleAttribute or OracleArray element by the specified path.

Overload List

Overload | Description
Item(String) | Gets or sets the OracleAttribute or OracleArray element by the specified path.
Item(OracleAttribute) | Gets or sets the value of the specified attribute.

Remarks

You can get an attribute value of embedded object if you specify full path to this attribute.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > Item Property : Item(String) Property

Name
String that represents a full path to the attribute or the element of the array. Note that it is case-sensitive.
Gets or sets the OracleAttribute or OracleArray element by the specified path.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal Name As String _
) As Object
C#
public object Item(
   string Name
) {get; set;}

Parameters

Name
String that represents a full path to the attribute or the element of the array. Note that it is case-sensitive.

Property Value

An OracleAttribute or OracleArray element by the specified path.

Remarks

You can get an attribute value of embedded object if you specify full path to this attribute.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(OracleAttribute) Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class > Item Property : Item(OracleAttribute) Property

attribute
An OracleAttribute object.
Gets or sets the value of the specified attribute.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal attribute As OracleAttribute _
) As Object
C#
public object Item(
   OracleAttribute attribute
) {get; set;}

Parameters

attribute
An OracleAttribute object.

Property Value

The value of the specified attribute.

Remarks

The Item property allows retrieving values of the attributes of the OracleObject.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : Null Property

Represents a null value of an OracleObject object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Null As OracleObject
C#
public static OracleObject Null {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleObject Class : ObjectType Property

Gets an OracleType of the specified object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectType As OracleType
C#
public OracleType ObjectType {get;}

Property Value

An OracleType of the specified object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleObject Class
OracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePackage Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePackage Class

Provides access to packages stored in the Oracle database.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OraclePackage

Syntax

Visual Basic (Declaration)
Public Class OraclePackage
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public class OraclePackage : System.ComponentModel.Component, IComponent, IDisposable

Remarks

Use OraclePackage component to get access to packages stored in the Oracle database. Packages may encapsulate sets of procedures and functions along with related variables and constants. For a list of Oracle supplied packages refer to Oracle online documents.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example executes procedure with/without parameters and returns value.
C#csharp Copy Code
public void ExecuteStoredProc(OracleConnection conn)
{
  OraclePackage package = new OraclePackage();

  // Set active connection
  // Connection must be opened
  package.Connection = conn;

  // Set package name where stored procedure exists
  package.PackageName = "dbms_random";

  // Execute procedure with parameters
  package.ExecuteProcedure("initialize", 10);

  // Execute procedure and return value
  object randomInt = package.ExecuteProcedure("random",typeof(Int));

  // Print returned value
  Console.WriteLine(randomInt);

  // Execute procedure without parameters
  package.ExecuteProcedure("terminate");
}
C#Visual Basic Copy Code
Public Sub ExecuteStoredProc(conn As OracleConnection)
  Dim package As New OraclePackage()

  ' Set active connection
  ' Connection must be opened
  package.Connection = conn

  ' Set package name where stored procedure exists
  package.PackageName = "dbms_random"

  ' Execute procedure with parameters
  package.ExecuteProcedure("initialize", 10)

  ' Execute procedure and return value
  Dim randomInt As Object
  randomInt = package.ExecuteProcedure("random", GetType(Int))

  ' Print returned value
  Console.WriteLine(randomInt)

  ' Execute procedure without parameters
  package.ExecuteProcedure("terminate")
End Sub ' ExecuteStoredProc

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePackage Members
Devart.Data.Oracle Namespace
OracleCommand Class
OracleConnection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePackage Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OraclePackage Class

The following tables list the members exposed by OraclePackage.

Public Constructors

 | Name | Description
public Constructor | OraclePackage Constructor | Initializes a new instance of the OraclePackage class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OraclePackage.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets a name of component that will be displayed in DBMonitor application.
public Property | PackageName | Gets or sets Oracle package name where procedures or variables exist.
public Property | Parameters | Contains parameters of the currently executed package procedure.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | DescribeProcedure | Returns collection of parameters required to execute a procedure.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | ExecProc | Obsolete. Executes stored procedure or function.
public Method | ExecuteProcedure | Overloaded. Executes stored procedure or function.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetVariable | Returns a value of the variable in the package mapped to the specified type.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | SetVariable | Assigns specified value to a variable from the package.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePackage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePackage Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : OraclePackage Constructor

Initializes a new instance of the OraclePackage class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OraclePackage()

Remarks

The base constructor initializes all fields to their default values. The following table shows initial values set to the read/write properties when a new instance of OraclePackage is created.
Properties | Initial value
Connection | null
PackageName | an empty string ("")

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePackage Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePackage Class

For a list of all members of this type, see OraclePackage members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | DescribeProcedure | Returns collection of parameters required to execute a procedure.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | ExecProc | Obsolete. Executes stored procedure or function.
public Method | ExecuteProcedure | Overloaded. Executes stored procedure or function.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetVariable | Returns a value of the variable in the package mapped to the specified type.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | SetVariable | Assigns specified value to a variable from the package.
Top

See Also

Reference

OraclePackage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DescribeProcedure Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : DescribeProcedure Method

name
Name of the procedure.
Returns collection of parameters required to execute a procedure.

Syntax

Visual Basic (Declaration)
Public Function DescribeProcedure( _
   ByVal name As String _
) As OracleParameterCollection
C#
public OracleParameterCollection DescribeProcedure(
   string name
)

Parameters

name
Name of the procedure.

Return Value

Collection of parameters required to execute a procedure.

Remarks

You can use DescribeProcedure method to obtain collection of parameters that can be passed to one of ExecuteProcedure overloads. It is most efficient to to describe a procedure and execute it several times then changing parameters' values only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
ExecuteProcedure Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecProc Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : ExecProc Method

name
The name of the stored procedure or function.
parameters
Array of parameters to be passed to the stored procedure.
Obsolete. Executes stored procedure or function.

Syntax

Visual Basic (Declaration)
Public Function ExecProc( _
   ByVal name As String, _
   ByVal ParamArray parameters() As Object _
) As Object
C#
public object ExecProc(
   string name,
   params object[] parameters
)

Parameters

name
The name of the stored procedure or function.
parameters
Array of parameters to be passed to the stored procedure.

Return Value

The value that function returns.

Remarks

Parameters in parameters array must be positioned in the order in which they were declared in stored procedure declaration. If number of parameters passed to stored procedure through this method is greater than number of formal parameters unnecessary parameters will be ignored. If number of parameters is less than number of formal parameters missing parameters values will be NULL. If stored procedure of function with the specified name does not exist an exception will be thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteProcedure Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : ExecuteProcedure Method

Executes stored procedure or function.

Overload List

Overload | Description
ExecuteProcedure(String,Object[]) | Executes stored procedure or function.
ExecuteProcedure(String,Type,Object[]) | Executes stored procedure or function.
ExecuteProcedure(String,OracleParameterCollection) | Executes stored procedure or function.
ExecuteProcedure(String,OracleParameterCollection,Boolean) | Executes stored procedure or function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteProcedure(String,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class > ExecuteProcedure Method : ExecuteProcedure(String,Object[]) Method

name
The name of the stored procedure or function.
parameters
Array of parameters to be passed to the stored procedure.
Executes stored procedure or function.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ExecuteProcedure( _
   ByVal name As String, _
   ByVal ParamArray parameters() As Object _
)
C#
public void ExecuteProcedure(
   string name,
   params object[] parameters
)

Parameters

name
The name of the stored procedure or function.
parameters
Array of parameters to be passed to the stored procedure.

Remarks

If a procedure with specified name cannot be found in the package an exception is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteProcedure(String,Type,Object[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class > ExecuteProcedure Method : ExecuteProcedure(String,Type,Object[]) Method

name
The name of the stored procedure or function.
resultType
Determines whether to invoke a procedure or a function.
parameters
Parameters to be passed to the procedure as arguments.
Executes stored procedure or function.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteProcedure( _
   ByVal name As String, _
   ByVal resultType As Type, _
   ByVal ParamArray parameters() As Object _
) As Object
C#
public object ExecuteProcedure(
   string name,
   Type resultType,
   params object[] parameters
)

Parameters

name
The name of the stored procedure or function.
resultType
Determines whether to invoke a procedure or a function.
parameters
Parameters to be passed to the procedure as arguments.

Return Value

Return value of the stored function.

Remarks

If resultType is null, ExecuteProcedure method tries to execute a stored procedure; otherwise it invokes stored function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteProcedure(String,OracleParameterCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class > ExecuteProcedure Method : ExecuteProcedure(String,OracleParameterCollection) Method

name
The name of the stored procedure or function.
parameters
Parameters to be passed to the procedure as arguments.
Executes stored procedure or function.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteProcedure( _
   ByVal name As String, _
   ByVal parameters As OracleParameterCollection _
) As Object
C#
public object ExecuteProcedure(
   string name,
   OracleParameterCollection parameters
)

Parameters

name
The name of the stored procedure or function.
parameters
Parameters to be passed to the procedure as arguments.

Return Value

Return value of the stored function.

Remarks

If a procedure with specified name cannot be found in the package an exception is thrown. This is also the case when you specify wrong parameters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteProcedure(String,OracleParameterCollection,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class > ExecuteProcedure Method : ExecuteProcedure(String,OracleParameterCollection,Boolean) Method

name
The name of the stored procedure or function.
parameters
Parameters to be passed to the procedure as arguments.
parameterCheck
If true, collection of parameters is automatically adjusted to correspond to stored procedure's declaration.
Executes stored procedure or function.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteProcedure( _
   ByVal name As String, _
   ByVal parameters As OracleParameterCollection, _
   ByVal parameterCheck As Boolean _
) As Object
C#
public object ExecuteProcedure(
   string name,
   OracleParameterCollection parameters,
   bool parameterCheck
)

Parameters

name
The name of the stored procedure or function.
parameters
Parameters to be passed to the procedure as arguments.
parameterCheck
If true, collection of parameters is automatically adjusted to correspond to stored procedure's declaration.

Return Value

Return value of the stored function.

Remarks

When collection of parameters does not correspond strictly to declaration of a stored procedure, behavior of ExecuteProcedure depends on parameterCheck value. When parameterCheck is true, missing parameters are added to the collection and wrong parameters are removed from it. For stored functions, routine result is placed in a parameter with Devart.Common.DbParameterBase.Direction set to ReturnValue and Devart.Common.DbParameterBase.ParameterName "Result". For more information on this mode please refer to article Using Parameters.

If a procedure with specified name cannot be found in the package an exception is thrown. This is also the case when you specify wrong parameters and parameterCheck is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetVariable Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : GetVariable Method

variableName
Name of the variable in the package.
dbType
One of the OracleDbType values.
Returns a value of the variable in the package mapped to the specified type.

Syntax

Visual Basic (Declaration)
Public Function GetVariable( _
   ByVal variableName As String, _
   ByVal dbType As OracleDbType _
) As Object
C#
public object GetVariable(
   string variableName,
   OracleDbType dbType
)

Parameters

variableName
Name of the variable in the package.
dbType
One of the OracleDbType values.

Return Value

A value of the variable in the package.

Remarks

Use GetVariable method to obtain the value of a package variable or constant declared within Oracle package. If the name does not exist an exception will be thrown.

Example

The following example obtains and then prints the variable value.
C#csharp Copy Code
public void GetPackageVariableValue(OracleConnection conn)
{
  OraclePackage package = new OraclePackage();

  // Set active connection
  // Connection must be opened
  package.Connection = conn;

  // Set package name where stored procedure exists
  package.PackageName = "oranet_pack";

  // Get variable value
  object pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar);

  // Print variable value
  Console.WriteLine(pkgVar);

  // Set variable to specific value
  package.SetVariable("package_variable", "test string");

  // Get variable value
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar);

  // Print variable value
  Console.WriteLine(pkgVar);
}
C#Visual Basic Copy Code
Public Sub GetPackageVariableValue(conn As OracleConnection)
  Dim package As New OraclePackage()

  ' Set active connection
  ' Connection must be opened
  package.Connection = conn

  ' Set package name where stored procedure exists
  package.PackageName = "oranet_pack"

  ' Get variable value
  Dim pkgVar As Object
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar)

  ' Print variable value
  Console.WriteLine(pkgVar)

  ' Set variable to specific value
  package.SetVariable("package_variable", "test string")

  ' Get variable value
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar)

  ' Print variable value
  Console.WriteLine(pkgVar)
End Sub 'GetPackageVariableValue

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetVariable Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : SetVariable Method

variableName
Name of the variable in the package.
value
A value that will be assigned to the variable.
Assigns specified value to a variable from the package.

Syntax

Visual Basic (Declaration)
Public Sub SetVariable( _
   ByVal variableName As String, _
   ByVal value As Object _
)
C#
public void SetVariable(
   string variableName,
   object value
)

Parameters

variableName
Name of the variable in the package.
value
A value that will be assigned to the variable.

Remarks

Use SetVariable method to set the value of a package variable or constant declared within Oracle package. If the name does not exist an exception will be thrown.

Example

The following example sets the new variable value.
C#csharp Copy Code
public void GetPackageVariableValue(OracleConnection conn)
{
  OraclePackage package = new OraclePackage();

  // Set active connection
  // Connection must be opened
  package.Connection = conn;

  // Set package name where stored procedure exists
  package.PackageName = "oranet_pack";

  // Get variable value
  object pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar);

  // Print variable value
  Console.WriteLine(pkgVar);

  // Set variable to specific value
  package.SetVariable("package_variable", "test string");

  // Get variable value
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar);

  // Print variable value
  Console.WriteLine(pkgVar);
}
C#Visual Basic Copy Code
Public Sub GetPackageVariableValue(conn As OracleConnection)
  Dim package As New OraclePackage()

  ' Set active connection
  ' Connection must be opened
  package.Connection = conn

  ' Set package name where stored procedure exists
  package.PackageName = "oranet_pack"

  ' Get variable value
  Dim pkgVar As Object
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar)

  ' Print variable value
  Console.WriteLine(pkgVar)

  ' Set variable to specific value
  package.SetVariable("package_variable", "test string")

  ' Get variable value
  pkgVar = package.GetVariable("package_variable", OracleDbType.VarChar)

  ' Print variable value
  Console.WriteLine(pkgVar)
End Sub 'GetPackageVariableValue

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePackage Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePackage Class

For a list of all members of this type, see OraclePackage members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OraclePackage.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets a name of component that will be displayed in DBMonitor application.
public Property | PackageName | Gets or sets Oracle package name where procedures or variables exist.
public Property | Parameters | Contains parameters of the currently executed package procedure.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePackage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : Connection Property

Gets or sets the OracleConnection used by this instance of the OraclePackage.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The connection to a database. The default value is a null reference.

Remarks

You must set Connection property before executing any procedure. If the connection was closed OraclePackage opens it automatically.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : Name Property

Gets or sets a name of component that will be displayed in DBMonitor application.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

The name of the component.

Remarks

This property value assigns automatically with the name of the component at design-time. If the component was created at run-time and property value was not set that component will be displayed in the DBMonitor with object type name followed by unique number in parentheses.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PackageName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : PackageName Property

Gets or sets Oracle package name where procedures or variables exist.

Syntax

Visual Basic (Declaration)
Public Property PackageName As String
C#
public string PackageName {get; set;}

Property Value

The name of the package within Oracle database. The default value is an empty string ("").

Remarks

You must set PackageName property before the execution of any procedure. If the package does not exist an exception will be thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parameters Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePackage Class : Parameters Property

Contains parameters of the currently executed package procedure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parameters As OracleParameterCollection
C#
public OracleParameterCollection Parameters {get;}

Property Value

The OracleParameterCollection instance.

Remarks

Use this property to set parameters values before the execution of package procedure or obtain out parameters values after executing package procedure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePackage Class
OraclePackage Members
ExecProc Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameter Class

Represents a parameter to a OracleCommand, and optionally, its mapping to System.Data.DataSet columns.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbParameter
Devart.Common.DbParameterBase
Devart.Data.Oracle.OracleParameter

Syntax

Visual Basic (Declaration)
Public Class OracleParameter
   Inherits Devart.Common.DbParameterBase
   Implements IDataParameter, IDbDataParameter, ICloneable
C#
public class OracleParameter : Devart.Common.DbParameterBase, IDataParameter, IDbDataParameter, ICloneable

Remarks

Parameter names are not case-sensitive.

Refer to article Using Parameters in dotConnect for Oracle to obtain detailed information on the matter together with some advanced examples.

Example

The following example creates multiple instances of OracleParameter through the OracleParameterCollection within the OracleDataAdapter. These parameters are used to select data from Oracle and place the data in the System.Data.DataSet. This example assumes that a System.Data.DataSet and a OracleDataAdapter have already been created with the appropriate schema, commands, and connection.
C#csharp Copy Code
public void AddOracleParameters()
{
  // ...
  // create myDataSet and myDataAdapter
  // ...
  myDataAdapter.SelectCommand.Parameters.Add("DName", OracleDbType.VarChar, 15).Value = "DEVELOPMENT";
  myDataAdapter.SelectCommand.Parameters.Add("DeptNo", OracleDbType.Integer).Value = 50;
  myDataAdapter.Fill(myDataSet);
}
C#Visual Basic Copy Code
Public Sub AddOracleParameters()
  ' ...
  ' create myDataSet and myDataAdapter
  ' ...
  myDataAdapter.SelectCommand.Parameters.Add("DName", OracleDbType.VarChar, 15).Value = "DEVELOPMENT"
  myDataAdapter.SelectCommand.Parameters.Add("DeptNo", OracleDbType.Integer).Value = 50
  myDataAdapter.Fill(myDataSet)
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleParameter Members
Devart.Data.Oracle Namespace
OracleCommand Class
OracleDataAdapter Class
OracleDbType Enumeration


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleParameter Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleParameter Class

The following tables list the members exposed by OracleParameter.

Public Constructors

 | Name | Description
public Constructor | OracleParameter Constructor | Overloaded. Initializes a new instance of the OracleParameter class.
Top

Public Properties

 | Name | Description
public Property | ArrayLength | Gets or sets the length of the DML array, PL/SQL table, or VARRAY and TABLE object types.
public Property | DbType | Overridden. Gets or sets the System.Data.DbType of the parameter.
public Property | Direction | Gets or sets a value that indicates whether the parameter is input-only, output-only, bidirectional, or a stored procedure return value parameter. (Inherited from System.Data.Common.DbParameter)
public Property | IsNullable | Gets or sets a value that indicates whether the parameter accepts null values. (Inherited from System.Data.Common.DbParameter)
public Property | Item | Gets the value of the element at the specified index for DML array or PL/SQL tables.
public Property | ObjectTypeName | Gets or sets a name for the Oracle object type.
public Property | OracleDbType | Gets or sets the OracleDbType of the parameter.
public Property | OracleValue | Gets or sets the value of the parameter in its Oracle format wrapped by dotConnect for Oracle.
public Property | ParameterName | Overridden. Gets or sets the name of the OracleParameter.
public Property | Precision | Gets or sets the maximum number of digits used to represent the Devart.Common.DbParameterBase.Value property.
public Property | RecordTypeName | Gets or sets a name for the PL/SQL record type.
public Property | Scale | Gets or sets the number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
public Property | Size | Gets or sets the maximum size, in bytes, of the data within the column. (Inherited from System.Data.Common.DbParameter)
public Property | SourceColumn | Gets or sets the name of the source column mapped to the System.Data.DataSet and used for loading or returning the System.Data.Common.DbParameter.Value. (Inherited from System.Data.Common.DbParameter)
public Property | SourceColumnNullMapping | Sets or gets a value which indicates whether the source column is nullable. This allows System.Data.Common.DbCommandBuilder to correctly generate Update statements for nullable columns. (Inherited from System.Data.Common.DbParameter)
public Property | SourceVersion | Gets or sets the System.Data.DataRowVersion to use when you load System.Data.Common.DbParameter.Value. (Inherited from System.Data.Common.DbParameter)
public Property | Value | Overridden. Gets or sets the value of the parameter.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current OracleParameter instance.
public Method | CopyTo |
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ResetDbType | Overridden. Clears explicit OracleDbType assignment.
public Method | ToString | Gets a string containing the ParameterName.
Top

See Also

Reference

OracleParameter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : OracleParameter Constructor

Initializes a new instance of the OracleParameter class.

Overload List

Overload | Description
OracleParameter Constructor() | Initializes a new instance of the OracleParameter class.
OracleParameter Constructor(String,Object) | Initializes a new instance of the OracleParameter class with the parameter name and a OracleParameter object.
OracleParameter Constructor(String,OracleDbType) | Initializes a new instance of the OracleParameter class with the parameter name and data type.
OracleParameter Constructor(String,OracleDbType,Int32) | Initializes a new instance of the OracleParameter class with the parameter name, data type, and width.
OracleParameter Constructor(String,OracleDbType,ParameterDirection) | Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.
OracleParameter Constructor(String,OracleDbType,String) | Initializes a new instance of the OracleParameter class with the parameter name, data type.
OracleParameter Constructor(String,OracleDbType,Int32,String) | Initializes a new instance of the OracleParameter class with the parameter name, data type, width, and source column name. For internal use.
OracleParameter Constructor(String,OracleDbType,Object,ParameterDirection) | Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.
OracleParameter Constructor(String,OracleDbType,Int32,Object,ParameterDirection) | Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object) | Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, and other properties.
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object) | Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String) | Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String) | Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor()
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor()

Initializes a new instance of the OracleParameter class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleParameter()

Remarks

The base constructor initializes all fields to their default values.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter();
  myParameter.ParameterName = "DName";
  myParameter.OracleDbType = OracleDbType.VarChar;
  myParameter.Direction = ParameterDirection.Input;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter()
  myParameter.ParameterName = "DName"
  myParameter.OracleDbType = OracleDbType.VarChar
  myParameter.Direction = ParameterDirection.Input
  myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,Object)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,Object)

parameterName
The name of the parameter.
value
An Object that is the value of the OracleParameter.
Initializes a new instance of the OracleParameter class with the parameter name and a OracleParameter object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal value As Object _
)
C#
public OracleParameter(
   string parameterName,
   object value
)

Parameters

parameterName
The name of the parameter.
value
An Object that is the value of the OracleParameter.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
        OracleParameter myParameter = new OracleParameter("DName", "e.g.: some string value");
        myParameter.Direction = ParameterDirection.Input;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
        Dim myParameter As New OracleParameter("DName", "e.g.: some string value")
        myParameter.Direction = ParameterDirection.Input
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
Initializes a new instance of the OracleParameter class with the parameter name and data type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar);
  myParameter.Direction = ParameterDirection.Input;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar)
    myParameter.Direction = ParameterDirection.Input
    myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
Initializes a new instance of the OracleParameter class with the parameter name, data type, and width.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15);
  myParameter.Direction = ParameterDirection.Input;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15)
    myParameter.Direction = ParameterDirection.Input
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,ParameterDirection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,ParameterDirection)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal direction As ParameterDirection _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar);
  myParameter.Direction = ParameterDirection.Input;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar)
    myParameter.Direction = ParameterDirection.Input
    myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,String)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
objectTypeName
String representing a name for the Oracle object type.
Initializes a new instance of the OracleParameter class with the parameter name, data type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal objectTypeName As String _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
objectTypeName
String representing a name for the Oracle object type.

Example

The following example creates a new OracleParameter of OracleObject type. For more detailed example of working with OracleObject type, refer to Objects article.
C#csharp Copy Code
public void CreateOracleParameter()
{
        OracleParameter myParameter = new OracleParameter("DName", OracleDbType.Object, "TPerson");
        myParameter.Direction = ParameterDirection.Input;
        ((OracleObject)myParameter.Value)["ADDRESS"] = "69 Camden Road, London, NW1 9EU";
        ((OracleObject)myParameter.Value)["Name"] = "Alex";
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
        Dim myParameter As New OracleParameter("DName", OracleDbType.Object, "TPerson")
        myParameter.Direction = ParameterDirection.Input
        CType(myParameter.Value, OracleObject)("ADDRESS") = "69 Camden Road, London, NW1 9EU"
        CType(myParameter.Value, OracleObject)("Name") = "Alex"
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,String)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
sourceColumn
The name of the source column.
Initializes a new instance of the OracleParameter class with the parameter name, data type, width, and source column name. For internal use.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal sourceColumn As String _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   string sourceColumn
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
sourceColumn
The name of the source column.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15, "DName");
  myParameter.Direction = ParameterDirection.Input;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15, "DName")
    myParameter.Direction = ParameterDirection.Input
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Object,ParameterDirection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Object,ParameterDirection)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal value As Object, _
   ByVal direction As ParameterDirection _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   object value,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar);
  myParameter.Direction = ParameterDirection.Input;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar)
    myParameter.Direction = ParameterDirection.Input
    myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,Object,ParameterDirection)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,Object,ParameterDirection)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Initializes a new instance of the OracleParameter class with the parameter name, data type, and parameter direction.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal value As Object, _
   ByVal direction As ParameterDirection _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   object value,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar);
  myParameter.Direction = ParameterDirection.Input;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
    Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar)
    myParameter.Direction = ParameterDirection.Input
    myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
An Object that is the value of the OracleParameter.
Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, and other properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal sourceColumnNullMapping As Boolean, _
   ByVal value As Object _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   string sourceColumn,
   DataRowVersion sourceVersion,
   bool sourceColumnNullMapping,
   object value
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
An Object that is the value of the OracleParameter.

Example

The following example creates a new OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
        OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar,
                15, ParameterDirection.Output, "DName", DataRowVersion.Current, true, "DEVELOPMENT");
        MessageBox.Show(myParameter.ToString());
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
        Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15, _
                ParameterDirection.Output, "DName", DataRowVersion.Current, True, "DEVELOPMENT")
        MessageBox.Show(myParameter.ToString())
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
An Object that is the value of the OracleParameter.
Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
An Object that is the value of the OracleParameter.

Example

The following example creates a new OracleParameter and displays the Devart.Common.DbParameterBase.ParameterName.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, true, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT");
  MessageBox.Show(myParameter.ToString());
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, True, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT")
  MessageBox.Show(myParameter.ToString())
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
An Object that is the value of the OracleParameter.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
String representing a name for the Oracle object type.
Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object, _
   ByVal arrayLength As Integer, _
   ByVal objectTypeName As String _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value,
   int arrayLength,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
An Object that is the value of the OracleParameter.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
String representing a name for the Oracle object type.

Example

The following example creates a new OracleParameter and displays the Devart.Common.DbParameterBase.ParameterName.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, true, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT");
  MessageBox.Show(myParameter.ToString());
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, True, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT")
  MessageBox.Show(myParameter.ToString())
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class > OracleParameter Constructor : OracleParameter Constructor(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String)

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
An Object that is the value of the OracleParameter.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
String representing a name for the Oracle object type.
Initializes a new instance of the OracleParameter class with the parameter name, data type, width, source column name, parameter direction, numeric precision, and other properties.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal sourceColumnNullMapping As Boolean, _
   ByVal value As Object, _
   ByVal arrayLength As Integer, _
   ByVal objectTypeName As String _
)
C#
public OracleParameter(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   bool sourceColumnNullMapping,
   object value,
   int arrayLength,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data within the column.
direction
One of the System.Data.ParameterDirection values.
isNullable
true if the value of the field can be null; otherwise, false.
precision
The total number of digits to the left and right of the decimal point to which Devart.Common.DbParameterBase.Value is resolved.
scale
The total number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
An Object that is the value of the OracleParameter.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
String representing a name for the Oracle object type.

Example

The following example creates a new OracleParameter and displays the Devart.Common.DbParameterBase.ParameterName.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, true, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT");
  MessageBox.Show(myParameter.ToString());
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15, ParameterDirection.Output, True, 0, 0, "DName", DataRowVersion.Current, "DEVELOPMENT")
  MessageBox.Show(myParameter.ToString())
End Sub 'CreateOracleParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleParameter Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameter Class

For a list of all members of this type, see OracleParameter members.

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current OracleParameter instance.
public Method | CopyTo |
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ResetDbType | Overridden. Clears explicit OracleDbType assignment.
public Method | ToString | Gets a string containing the ParameterName.
Top

See Also

Reference

OracleParameter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : Clone Method

Creates a new object that is a copy of the current OracleParameter instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleParameter
C#
public OracleParameter Clone()

Return Value

A new OracleParameter object in which all property values are the same as the original.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : CopyTo Method

destination

Syntax

Visual Basic (Declaration)
Public Shadows Sub CopyTo( _
   ByVal destination As DbParameter _
)
C#
public new void CopyTo(
   DbParameter destination
)

Parameters

destination

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ResetDbType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : ResetDbType Method

Clears explicit OracleDbType assignment.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ResetDbType()
C#
public override void ResetDbType()

Remarks

After calling this method parameter's type is defined by OracleParameter.OracleValue property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : ToString Method

Gets a string containing the Devart.Common.DbParameterBase.ParameterName.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string containing the Devart.Common.DbParameterBase.ParameterName.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleParameter Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameter Class

For a list of all members of this type, see OracleParameter members.

Public Properties

 | Name | Description
public Property | ArrayLength | Gets or sets the length of the DML array, PL/SQL table, or VARRAY and TABLE object types.
public Property | DbType | Overridden. Gets or sets the System.Data.DbType of the parameter.
public Property | Direction | Gets or sets a value that indicates whether the parameter is input-only, output-only, bidirectional, or a stored procedure return value parameter. (Inherited from System.Data.Common.DbParameter)
public Property | IsNullable | Gets or sets a value that indicates whether the parameter accepts null values. (Inherited from System.Data.Common.DbParameter)
public Property | Item | Gets the value of the element at the specified index for DML array or PL/SQL tables.
public Property | ObjectTypeName | Gets or sets a name for the Oracle object type.
public Property | OracleDbType | Gets or sets the OracleDbType of the parameter.
public Property | OracleValue | Gets or sets the value of the parameter in its Oracle format wrapped by dotConnect for Oracle.
public Property | ParameterName | Overridden. Gets or sets the name of the OracleParameter.
public Property | Precision | Gets or sets the maximum number of digits used to represent the Devart.Common.DbParameterBase.Value property.
public Property | RecordTypeName | Gets or sets a name for the PL/SQL record type.
public Property | Scale | Gets or sets the number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.
public Property | Size | Gets or sets the maximum size, in bytes, of the data within the column. (Inherited from System.Data.Common.DbParameter)
public Property | SourceColumn | Gets or sets the name of the source column mapped to the System.Data.DataSet and used for loading or returning the System.Data.Common.DbParameter.Value. (Inherited from System.Data.Common.DbParameter)
public Property | SourceColumnNullMapping | Sets or gets a value which indicates whether the source column is nullable. This allows System.Data.Common.DbCommandBuilder to correctly generate Update statements for nullable columns. (Inherited from System.Data.Common.DbParameter)
public Property | SourceVersion | Gets or sets the System.Data.DataRowVersion to use when you load System.Data.Common.DbParameter.Value. (Inherited from System.Data.Common.DbParameter)
public Property | Value | Overridden. Gets or sets the value of the parameter.
Top

See Also

Reference

OracleParameter Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ArrayLength Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : ArrayLength Property

Gets or sets the length of the DML array, PL/SQL table, or VARRAY and TABLE object types.

Syntax

Visual Basic (Declaration)
Public Property ArrayLength As Integer
C#
public int ArrayLength {get; set;}

Property Value

A length of the DML array or PL/SQL table, or VARRAY and TABLE object types.

Remarks

An array length representing a value of DML array or PL/SQL table, or VARRAY and TABLE object types is set equal to a value of the ArrayLength property. If you use DML array or PL/SQL table output parameter you must obligatory set ArrayLength property. If you use output parameter of VARRAY or TABLE type ArrayLength property will be set automatically after command execution.

For PL/SQL parameters, only the following data types are allowed: Boolean, VarChar, Char, NVarChar, NChar, Number, Integer, Double, Float, Date.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbType Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : DbType Property

Gets or sets the System.Data.DbType of the parameter.

Syntax

Visual Basic (Declaration)
Public Overrides Property DbType As DbType
C#
public override DbType DbType {get; set;}

Property Value

One of the System.Data.DbType values. The default value is System.String.

Remarks

The P:Devart.Data.Oracle.OracleParameter.OracleType and DbType are linked. Therefore, setting the changes the P:Devart.Data.Oracle.OracleParameter.OracleType to a supporting OracleType.

For a list of the supported data types, see the appropriate OracleType member.

Example

The following example creates a OracleParameter and sets some of its properties, including the DbType property.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter();
  myParameter.ParameterName = "DName";
  myParameter.DbType = DbType.String;
  myParameter.Direction = ParameterDirection.Output;
  myParameter.Size = 15;
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter()
  myParameter.ParameterName = "DName"
  myParameter.DbType = DbType.String
  myParameter.Direction = ParameterDirection.Output
  myParameter.Size = 15
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
P:Devart.Data.Oracle.OracleParameter.OracleType


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : Item Property

index
The zero-based index.
Gets the value of the element at the specified index for DML array or PL/SQL tables.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Object
C#
public object this(
   int index
) {get; set;}

Parameters

index
The zero-based index.

Property Value

A value of the element of DML array or PL/SQL tables.

Remarks

By default dotConnect for Oracle reserves maximum memory that the DML array might require. To prevent redundant memory consumption it is recommended to set P:Devart.Common.DbParameter.Size to size of biggest array element.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : ObjectTypeName Property

Gets or sets a name for the Oracle object type.

Syntax

Visual Basic (Declaration)
Public Property ObjectTypeName As String
C#
public string ObjectTypeName {get; set;}

Property Value

System.String representing a name for the Oracle object type.

Remarks

You need to set the ObjectTypeName property for OracleDbType.Array, OracleDbType.Object, and OracleDbType.Table of the OracleDbType data types.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDbType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : OracleDbType Property

Gets or sets the OracleDbType of the parameter.

Syntax

Visual Basic (Declaration)
Public Property OracleDbType As OracleDbType
C#
public OracleDbType OracleDbType {get; set;}

Property Value

A OracleDbType value that is the OracleDbType of the parameter.

Remarks

The OracleDbType and DbType are linked. Therefore, setting the DbType changes the OracleDbType to a supporting OracleDbType.

For a list of the supported data types, see the appropriate OracleDbType member. For more information, see "Using Parameters with a DataAdapter" in the Microsoft .NET Framework SDK documentation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members
DbType Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleValue Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : OracleValue Property

Gets or sets the value of the parameter in its Oracle format wrapped by dotConnect for Oracle.

Syntax

Visual Basic (Declaration)
Public Property OracleValue As Object
C#
public object OracleValue {get; set;}

Property Value

A value of the parameter in its Oracle format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParameterName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : ParameterName Property

Gets or sets the name of the OracleParameter.

Syntax

Visual Basic (Declaration)
Public Overrides Property ParameterName As String
C#
public override string ParameterName {get; set;}

Property Value

The name of the OracleParameter. The default value is an empty string ("").

Remarks

You must set ParameterName before executing a Devart.Data.Oracle.OracleCommand that relies on this parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Precision Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : Precision Property

Gets or sets the maximum number of digits used to represent the Devart.Common.DbParameterBase.Value property.

Syntax

Visual Basic (Declaration)
Public Property Precision As Byte
C#
public byte Precision {get; set;}

Property Value

The maximum number of digits used to represent the Devart.Common.DbParameterBase.Value property. The default value is 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecordTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : RecordTypeName Property

Gets or sets a name for the PL/SQL record type.

Syntax

Visual Basic (Declaration)
Public Property RecordTypeName As String
C#
public string RecordTypeName {get; set;}

Property Value

System.String representing a name for the PL/SQL record type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Scale Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : Scale Property

Gets or sets the number of decimal places to which Devart.Common.DbParameterBase.Value is resolved.

Syntax

Visual Basic (Declaration)
Public Property Scale As Byte
C#
public byte Scale {get; set;}

Property Value

The number of decimal places to which Devart.Common.DbParameterBase.Value is resolved. The default value is 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameter Class : Value Property

Gets or sets the value of the parameter.

Syntax

Visual Basic (Declaration)
Public Overrides Property Value As Object
C#
public override object Value {get; set;}

Property Value

An System.Object that is the value of the parameter. The default value is null.

Remarks

For input parameters, the value is bound to the Devart.Data.Oracle.OracleCommand that is sent to the server. For output and return-value parameters, the value is set on completion of the Devart.Data.Oracle.OracleCommand and after the OracleDataReader is closed.

When sending a null parameter value to the server, the user must specify System.DBNull, not null. A null value in the system is an empty object that has no value. System.DBNull is used to represent null values.

If the application specifies the database type, the bound value is converted to that type when the provider sends the data to the server. The provider attempts to convert any type of value if it supports the IConvertible interface. Conversion errors may result if the specified type is not compatible with the value.

Both the DbType and OracleDbType properties can be inferred by setting OracleParameter.Value. If applicable, the size, precision and scale will also be inferred from OracleParameter.Value.

The OracleParameter.Value property is overwritten by the System.Data.Common.DbDataAdapter.Update() method.

Example

The following example creates a OracleParameter and sets some of its properties.
C#csharp Copy Code
public void CreateOracleParameter()
{
  OracleParameter myParameter = new OracleParameter("DName", OracleDbType.VarChar, 15);
  myParameter.Value = "PRODUCTION";
}
C#Visual Basic Copy Code
Public Sub CreateOracleParameter()
  Dim myParameter As New OracleParameter("DName", OracleDbType.VarChar, 15)
  myParameter.Value = "PRODUCTION"
End Sub 'CreatePgSqlParameter

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameter Class
OracleParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameterCollection Class

Collects all parameters relevant to a OracleCommand as well as their respective mappings to System.Data.DataSet columns.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbParameterCollection
Devart.Common.DbParameterBaseCollection
Devart.Data.Oracle.OracleParameterCollection

Syntax

Visual Basic (Declaration)
Public Class OracleParameterCollection
   Inherits Devart.Common.DbParameterBaseCollection
   Implements ICollection, IEnumerable, IList, IDataParameterCollection
C#
public class OracleParameterCollection : Devart.Common.DbParameterBaseCollection, ICollection, IEnumerable, IList, IDataParameterCollection

Remarks

The number of parameters in the collection must be equal to the number of parameter placeholders within the command text, or Oracle raises an error.

Example

The following example adds instance of OracleParameter to collection.
C#csharp Copy Code
public void AddOracleParameters()
{
  // Create myConnection and myCommand.

  myCommand.CommandText = "DELETE Test.Dept WHERE DeptNo = :DeptNo";
  myCommand.Parameters.Add("DeptNo", OracleDbType.Integer).Value = 50;
  myCommand.ExecuteNonQuery();
}
C#Visual Basic Copy Code
Public Sub AddOracleParameters()
  // Create myConnection and myCommand.

  myCommand.CommandText = "DELETE Test.Dept WHERE DeptNo = :DeptNo"
  myCommand.Parameters.Add("DeptNo", OracleDbType.Integer).Value = 50
  myCommand.ExecuteNonQuery()

End Sub 'AddOracleParameters

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleParameterCollection Members
Devart.Data.Oracle Namespace
OracleParameter Class
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleParameterCollection Class

The following tables list the members exposed by OracleParameterCollection.

Public Constructors

 | Name | Description
public Constructor | OracleParameterCollection Constructor | Initializes a new instance of OracleParameterCollection.
Top

Public Properties

 | Name | Description
public Property | Count | Specifies the number of items in the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsFixedSize | Specifies whether the collection is a fixed size. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsReadOnly | Specifies whether the collection is read-only. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsSynchronized | Specifies whether the collection is synchronized. (Inherited from System.Data.Common.DbParameterCollection)
public Property | Item | Overloaded. Gets or sets the OracleParameter at the specified index.
public Property | SyncRoot | Specifies the System.Object to be used to synchronize access to the collection. (Inherited from System.Data.Common.DbParameterCollection)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified OracleParameter to the OracleParameterCollection.
public Method | AddRange | Adds an array of items with the specified values to the System.Data.Common.DbParameterCollection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | AddWithValue | Adds a OracleParameter to the OracleParameterCollection given the parameter name and value.
public Method | Clear | Removes all System.Data.Common.DbParameter values from the System.Data.Common.DbParameterCollection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | Contains | Overloaded. Indicates whether a System.Data.Common.DbParameter with the specified System.Data.Common.DbParameter.Value is contained in the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | CopyTo | Copies an array of items to the collection starting at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetEnumerator | Exposes the System.Collections.IEnumerable.GetEnumerator method, which supports a simple iteration over a collection by a .NET Framework data provider. (Inherited from System.Data.Common.DbParameterCollection)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IndexOf | Overloaded. Returns the index of the specified System.Data.Common.DbParameter object. (Inherited from System.Data.Common.DbParameterCollection)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts the specified index of the System.Data.Common.DbParameter object with the specified name into the collection at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Method | Remove | Removes the specified System.Data.Common.DbParameter object from the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | RemoveAt | Overloaded. Removes the System.Data.Common.DbParameter object at the specified from the collection. (Inherited from System.Data.Common.DbParameterCollection)
Top

See Also

Reference

OracleParameterCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class : OracleParameterCollection Constructor

Initializes a new instance of OracleParameterCollection.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleParameterCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameterCollection Class

For a list of all members of this type, see OracleParameterCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified OracleParameter to the OracleParameterCollection.
public Method | AddRange | Adds an array of items with the specified values to the System.Data.Common.DbParameterCollection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | AddWithValue | Adds a OracleParameter to the OracleParameterCollection given the parameter name and value.
public Method | Clear | Removes all System.Data.Common.DbParameter values from the System.Data.Common.DbParameterCollection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | Contains | Overloaded. Indicates whether a System.Data.Common.DbParameter with the specified System.Data.Common.DbParameter.Value is contained in the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | CopyTo | Copies an array of items to the collection starting at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetEnumerator | Exposes the System.Collections.IEnumerable.GetEnumerator method, which supports a simple iteration over a collection by a .NET Framework data provider. (Inherited from System.Data.Common.DbParameterCollection)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IndexOf | Overloaded. Returns the index of the specified System.Data.Common.DbParameter object. (Inherited from System.Data.Common.DbParameterCollection)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts the specified index of the System.Data.Common.DbParameter object with the specified name into the collection at the specified index. (Inherited from System.Data.Common.DbParameterCollection)
public Method | Remove | Removes the specified System.Data.Common.DbParameter object from the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Method | RemoveAt | Overloaded. Removes the System.Data.Common.DbParameter object at the specified from the collection. (Inherited from System.Data.Common.DbParameterCollection)
Top

See Also

Reference

OracleParameterCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class : Add Method

Adds the specified OracleParameter to the OracleParameterCollection.

Overload List

Overload | Description
Add(String,Object) | Adds a OracleParameter to the OracleParameterCollection given the parameter name and value.
Add(String,OracleDbType) | Adds a OracleParameter to the OracleParameterCollection given the parameter name and data type.
Add(String,OracleDbType,Int32) | Adds a OracleParameter to the OracleParameterCollection given the the parameter name, data type, and data size.
Add(String,OracleDbType,ParameterDirection) | Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, and direction.
Add(String,OracleDbType,String) | Adds the specified OracleParameter of the Object type to the OracleParameterCollection.
Add(String,OracleDbType,Int32,String) | Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, column width, and source column name. For internal use.
Add(String,OracleDbType,Object,ParameterDirection) | Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, value, and parameter direction.
Add(String,OracleDbType,Int32,Object,ParameterDirection) | Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, data size, parameter value, and direction.
Add(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object) | Adds the specified OracleParameter to the OracleParameterCollection. For internal use.
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object) | Adds the specified OracleParameter to the OracleParameterCollection. For internal use.
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String) | Adds the specified OracleParameter to the OracleParameterCollection. For internal use.
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String) | Adds the specified OracleParameter to the OracleParameterCollection. For internal use.
Add(OracleParameter) | Adds the specified OracleParameter to the OracleParameterCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,Object) Method

parameterName
The name of the parameter.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
Adds a OracleParameter to the OracleParameterCollection given the parameter name and value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal value As Object _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   object value
)

Parameters

parameterName
The name of the parameter.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType) Method

parameterName
The name of the parameter.
type
One of the OracleDbType values.
Adds a OracleParameter to the OracleParameterCollection given the parameter name and data type.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal type As OracleDbType _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType type
)

Parameters

parameterName
The name of the parameter.
type
One of the OracleDbType values.

Return Value

The new OracleParameter object.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, and returns a reference to the new OracleParameter.
C#csharp Copy Code
public void CreateOracleParamColl(OracleConnection myConn) {
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn);
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  object myParm = new OracleParameter("DeptNo", OracleDbType.Integer);
  int pIndex = myParamCollection.Add(myParm);
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myConn As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  Dim myParm As Object = New OracleParameter("DeptNo", OracleDbType.Integer)
  Dim pIndex As Integer = myParamCollection.Add(myParm)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
Adds a OracleParameter to the OracleParameterCollection given the the parameter name, data type, and data size.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.

Return Value

The new OracleParameter object.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, and returns a reference to the new OracleParameter.
C#csharp Copy Code
public void CreateOracleParamColl(OracleConnection myConn) {
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn);
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  OracleParameter myNewParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40);
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myConn As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  Dim myNewParameter As OracleParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,ParameterDirection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,ParameterDirection) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, and direction.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal direction As ParameterDirection _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Return Value

The new OracleParameter object.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, and returns a reference to the new OracleParameter.
C#csharp Copy Code
public void CreateOracleParamColl(OracleConnection myConn) {
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn);
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  object myParm = new OracleParameter("DeptNo", OracleDbType.Integer);
  int pIndex = myParamCollection.Add(myParm);
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myConn As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  Dim myParm As Object = New OracleParameter("DeptNo", OracleDbType.Integer)
  Dim pIndex As Integer = myParamCollection.Add(myParm)
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,String) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
objectTypeName
The name of the object type that is the type of the parameter.
Adds the specified OracleParameter of the Object type to the OracleParameterCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal objectTypeName As String _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
objectTypeName
The name of the object type that is the type of the parameter.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,String) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,String) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
sourceColumn
The name of the source column.
Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, column width, and source column name. For internal use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal sourceColumn As String _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   string sourceColumn
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
sourceColumn
The name of the source column.

Return Value

The new OracleParameter object.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, and returns a reference to the new OracleParameter.
C#csharp Copy Code
public void CreateOracleParamColl(OracleConnection myConn) {
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn);
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  OracleParameter myNewParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40, "DeptNo");
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myConn As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  Dim myNewParameter As OracleParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40, "DeptNo")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Object,ParameterDirection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Object,ParameterDirection) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, value, and parameter direction.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal value As Object, _
   ByVal direction As ParameterDirection _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   object value,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Return Value

The new OracleParameter object.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, and returns a reference to the new OracleParameter.
C#csharp Copy Code
public void CreateOracleParamColl(OracleConnection myConn) {
  OracleCommand myCommand = new OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn);
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  OracleParameter myNewParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40, "DeptNo");
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myConn As OracleConnection)
  Dim myCommand As OracleCommand = New OracleCommand("SELECT * FROM Test.Dept WHERE DeptNo = :DeptNo", myConn)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  Dim myNewParameter As OracleParameter = myParamCollection.Add("DeptNo", OracleDbType.Integer, 40, "DeptNo")
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,Object,ParameterDirection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,Object,ParameterDirection) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
Adds a OracleParameter to the OracleParameterCollection given the parameter name, data type, data size, parameter value, and direction.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal value As Object, _
   ByVal direction As ParameterDirection _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   object value,
   ParameterDirection direction
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
direction
Specifies whether the parameter is input, output, both, or it is the return value.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,ParameterDirection,String,DataRowVersion,Boolean,Object) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
sourceColumn
The name of the source column. For internal use.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
Adds the specified OracleParameter to the OracleParameterCollection. For internal use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal sourceColumnNullMapping As Boolean, _
   ByVal value As Object _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   string sourceColumn,
   DataRowVersion sourceVersion,
   bool sourceColumnNullMapping,
   object value
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
sourceColumn
The name of the source column. For internal use.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable.
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
Adds the specified OracleParameter to the OracleParameterCollection. For internal use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable.
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Object,Int32,String) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable.
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
Adds the specified OracleParameter to the OracleParameterCollection. For internal use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal value As Object, _
   ByVal arrayLength As Integer, _
   ByVal objectTypeName As String _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   object value,
   int arrayLength,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable.
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(String,OracleDbType,Int32,ParameterDirection,Boolean,Byte,Byte,String,DataRowVersion,Boolean,Object,Int32,String) Method

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
The name of the object type that is the type of the parameter.
Adds the specified OracleParameter to the OracleParameterCollection. For internal use.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal parameterName As String, _
   ByVal dbType As OracleDbType, _
   ByVal size As Integer, _
   ByVal direction As ParameterDirection, _
   ByVal isNullable As Boolean, _
   ByVal precision As Byte, _
   ByVal scale As Byte, _
   ByVal sourceColumn As String, _
   ByVal sourceVersion As DataRowVersion, _
   ByVal sourceColumnNullMapping As Boolean, _
   ByVal value As Object, _
   ByVal arrayLength As Integer, _
   ByVal objectTypeName As String _
) As OracleParameter
C#
public OracleParameter Add(
   string parameterName,
   OracleDbType dbType,
   int size,
   ParameterDirection direction,
   bool isNullable,
   byte precision,
   byte scale,
   string sourceColumn,
   DataRowVersion sourceVersion,
   bool sourceColumnNullMapping,
   object value,
   int arrayLength,
   string objectTypeName
)

Parameters

parameterName
The name of the parameter.
dbType
One of the OracleDbType values.
size
The maximum size, in bytes, of the data the parameter can contain.
direction
Specifies whether the parameter is input, output, both, or it is the return value.
isNullable
Specifies whether the parameter is nullable
precision
The maximum number of digits used to represent the parameter value.
scale
The number of decimal places to which the parameter value is resolved.
sourceColumn
The name of the source column.
sourceVersion
One of the System.Data.DataRowVersion values.
sourceColumnNullMapping
Specifies whether the source column is nullable.
value
The Devart.Common.DbParameterBase.Value of the OracleParameter to add to the collection.
arrayLength
A length of the DML array or PL/SQL table.
objectTypeName
The name of the object type that is the type of the parameter.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleParameter) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Add Method : Add(OracleParameter) Method

value
The OracleParameter to add to the collection.
Adds the specified OracleParameter to the OracleParameterCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As OracleParameter _
) As OracleParameter
C#
public OracleParameter Add(
   OracleParameter value
)

Parameters

value
The OracleParameter to add to the collection.

Return Value

The new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddWithValue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class : AddWithValue Method

parameterName
Name of the parameter.
value
Value of the parameter.
Adds a OracleParameter to the OracleParameterCollection given the parameter name and value.

Syntax

Visual Basic (Declaration)
Public Function AddWithValue( _
   ByVal parameterName As String, _
   ByVal value As Object _
) As OracleParameter
C#
public OracleParameter AddWithValue(
   string parameterName,
   object value
)

Parameters

parameterName
Name of the parameter.
value
Value of the parameter.

Return Value

A new OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleParameterCollection Class

For a list of all members of this type, see OracleParameterCollection members.

Public Properties

 | Name | Description
public Property | Count | Specifies the number of items in the collection. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsFixedSize | Specifies whether the collection is a fixed size. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsReadOnly | Specifies whether the collection is read-only. (Inherited from System.Data.Common.DbParameterCollection)
public Property | IsSynchronized | Specifies whether the collection is synchronized. (Inherited from System.Data.Common.DbParameterCollection)
public Property | Item | Overloaded. Gets or sets the OracleParameter at the specified index.
public Property | SyncRoot | Specifies the System.Object to be used to synchronize access to the collection. (Inherited from System.Data.Common.DbParameterCollection)
Top

See Also

Reference

OracleParameterCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class : Item Property

Gets or sets the OracleParameter at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets or sets the OracleParameter at the specified index.
Item(String) | Gets or sets the OracleParameter with the specified name.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, displays the names of its OracleParameter objects, and then clears the collection.
C#csharp Copy Code
public void CreateOracleParamColl(OracleCommand myCommand) {
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  myParamCollection.Add("DeptNo", OracleDbType.Integer);
  myParamCollection.Add("DName", OracleDbType.VarChar);
  myParamCollection.Add("Loc", OracleDbType.VarChar);
  string myParamNames = "";
  for (int i=0; i < myParamCollection.Count; i++)
    myParamNames += myParamCollection[i].ToString() + "\n";
  MessageBox.Show(myParamNames);
  myParamCollection.Clear();
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myCommand As OracleCommand)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  myParamCollection.Add("DeptNo", OracleDbType.Integer)
  myParamCollection.Add("DName", OracleDbType.VarChar)
  myParamCollection.Add("Loc", OracleDbType.VarChar)
  Dim myParamNames As String = ""
  Dim i As Integer
  For i = 0 To myParamCollection.Count - 1
    myParamNames += myParamCollection(i).ToString() + ControlChars.Cr
  Next i
  MessageBox.Show(myParamNames)
  myParamCollection.Clear()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(Int32) Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the parameter to retrieve.
Gets or sets the OracleParameter at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Property Item( _
   ByVal index As Integer _
) As OracleParameter
C#
public new OracleParameter Item(
   int index
) {get; set;}

Parameters

index
The zero-based index of the parameter to retrieve.

Property Value

The OracleParameter at the specified index.

Example

The following example creates a OracleParameterCollection, adds instances of OracleParameter to the collection, displays the names of its OracleParameter objects, and then clears the collection.
C#csharp Copy Code
public void CreateOracleParamColl(OracleCommand myCommand) {
  OracleParameterCollection myParamCollection = myCommand.Parameters;
  myParamCollection.Add("DeptNo", OracleDbType.Integer);
  myParamCollection.Add("DName", OracleDbType.VarChar);
  myParamCollection.Add("Loc", OracleDbType.VarChar);
  string myParamNames = "";
  for (int i=0; i < myParamCollection.Count; i++)
    myParamNames += myParamCollection[i].ToString() + "\n";
  MessageBox.Show(myParamNames);
  myParamCollection.Clear();
}
C#Visual Basic Copy Code
Public Sub CreateOracleParamColl(myCommand As OracleCommand)
  Dim myParamCollection As OracleParameterCollection = myCommand.Parameters
  myParamCollection.Add("DeptNo", OracleDbType.Integer)
  myParamCollection.Add("DName", OracleDbType.VarChar)
  myParamCollection.Add("Loc", OracleDbType.VarChar)
  Dim myParamNames As String = ""
  Dim i As Integer
  For i = 0 To myParamCollection.Count - 1
    myParamNames += myParamCollection(i).ToString() + ControlChars.Cr
  Next i
  MessageBox.Show(myParamNames)
  myParamCollection.Clear()
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item(String) Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class > Item Property : Item(String) Property

parameterName
The name of the parameter to retrieve.
Gets or sets the OracleParameter with the specified name.

Syntax

Visual Basic (Declaration)
Public Overloads Shadows Property Item( _
   ByVal parameterName As String _
) As OracleParameter
C#
public new OracleParameter Item(
   string parameterName
) {get; set;}

Parameters

parameterName
The name of the parameter to retrieve.

Property Value

The OracleParameter with the specified name.

Example

The following example searches for a OracleParameter with a given Devart.Common.DbParameterBase.ParameterName within a OracleParameterCollection. If the parameter exists, the example displays the name and index of the parameter. If the parameter does not exist, the example displays an error. This example assumes that a OracleParameterCollection has already been created.
C#csharp Copy Code
public void SearchOracleParams() {
  // ...
  // create OracleParameterCollection myParameters
  // ...
  if (!myParameters.Contains("DName"))
    MessageBox.Show("ERROR: no such parameter in the collection");
  else
    MessageBox.Show("Name: " + myParameters["DName"].ToString() +
      "Index: " + myParameters.IndexOf("DName").ToString());
}
C#Visual Basic Copy Code
Public Sub SearchOracleParams()
  ' ...
  ' create OracleParameterCollection myParameters
  ' ...
  If Not myParameters.Contains("DName") Then
    MessageBox.Show("ERROR: no such parameter in the collection")
  Else
    MessageBox.Show("Name: "  & myParameters("DName").ToString()  & _
      "Index: "  & myParameters.IndexOf("DName").ToString())
  End If
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePermission Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermission Class

Enables dotConnect for Oracle to ensure that a user has an adequate security level to access an Oracle database. This class cannot be inherited.

Inheritance Hierarchy

System.Object
System.Security.CodeAccessPermission
Devart.Data.Oracle.OraclePermission

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OraclePermission
   Inherits System.Security.CodeAccessPermission
   Implements IPermission, ISecurityEncodable, IStackWalk, IUnrestrictedPermission
C#
public sealed class OraclePermission : System.Security.CodeAccessPermission, IPermission, ISecurityEncodable, IStackWalk, IUnrestrictedPermission

Remarks

This class is intended for future use when dotConnect for Oracle is enabled for partial trust scenarios. The provider currently requires FullTrust permission. For more information, see Code Access Security and ADO.NET.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePermission Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePermission Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OraclePermission Class

The following tables list the members exposed by OraclePermission.

Public Constructors

 | Name | Description
public Constructor | OraclePermission Constructor | Initializes a new instance of the OraclePermission class with one of the System.Security.Permissions.PermissionState values.
Top

Public Properties

 | Name | Description
public Property | AllowBlankPassword | Gets a value indicating whether a blank password is allowed.
Top

Public Methods

 | Name | Description
public Method | Assert | Declares that the calling code can access the resource protected by a permission demand through the code that calls this method, even if callers higher in the stack have not been granted permission to access the resource. Using System.Security.CodeAccessPermission.Assert can create security issues. (Inherited from System.Security.CodeAccessPermission)
public Method | Copy | Overridden. Creates and returns an identical copy of the current permission object.
public Method | Demand | Forces a System.Security.SecurityException at run time if all callers higher in the call stack have not been granted the permission specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | Deny | Prevents callers higher in the call stack from using the code that calls this method to access the resource specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | FromXml | Overridden. Reconstructs a security object with the specified state from XML encoding.
public Method | Intersect | Overridden. Returns a new permission object representing the intersection of the current permission object and the specified permission object.
public Method | IsSubsetOf | Overridden. Returns a value indicating whether the current permission object is a subset of the specified permission object.
public Method | IsUnrestricted | Returns a value indicating whether the permission can be represented as unrestricted without any knowledge of the permission semantics.
public Method | PermitOnly | Prevents callers higher in the call stack from using the code that calls this method to access all resources except for the resource specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | ToXml | Overridden. Creates XML encoding of the security object and its current state.
public Method | Union | When overridden in a derived class, creates a permission that is the union of the current permission and the specified permission. (Inherited from System.Security.CodeAccessPermission)
Top

See Also

Reference

OraclePermission Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePermission Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : OraclePermission Constructor

state
One of the System.Security.Permissions.PermissionState values.
Initializes a new instance of the OraclePermission class with one of the System.Security.Permissions.PermissionState values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal state As PermissionState _
)
C#
public OraclePermission(
   PermissionState state
)

Parameters

state
One of the System.Security.Permissions.PermissionState values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePermission Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermission Class

For a list of all members of this type, see OraclePermission members.

Public Methods

 | Name | Description
public Method | Assert | Declares that the calling code can access the resource protected by a permission demand through the code that calls this method, even if callers higher in the stack have not been granted permission to access the resource. Using System.Security.CodeAccessPermission.Assert can create security issues. (Inherited from System.Security.CodeAccessPermission)
public Method | Copy | Overridden. Creates and returns an identical copy of the current permission object.
public Method | Demand | Forces a System.Security.SecurityException at run time if all callers higher in the call stack have not been granted the permission specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | Deny | Prevents callers higher in the call stack from using the code that calls this method to access the resource specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | FromXml | Overridden. Reconstructs a security object with the specified state from XML encoding.
public Method | Intersect | Overridden. Returns a new permission object representing the intersection of the current permission object and the specified permission object.
public Method | IsSubsetOf | Overridden. Returns a value indicating whether the current permission object is a subset of the specified permission object.
public Method | IsUnrestricted | Returns a value indicating whether the permission can be represented as unrestricted without any knowledge of the permission semantics.
public Method | PermitOnly | Prevents callers higher in the call stack from using the code that calls this method to access all resources except for the resource specified by the current instance. (Inherited from System.Security.CodeAccessPermission)
public Method | ToXml | Overridden. Creates XML encoding of the security object and its current state.
public Method | Union | When overridden in a derived class, creates a permission that is the union of the current permission and the specified permission. (Inherited from System.Security.CodeAccessPermission)
Top

See Also

Reference

OraclePermission Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Copy Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : Copy Method

Creates and returns an identical copy of the current permission object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Copy() As IPermission
C#
public override IPermission Copy()

Return Value

A copy of the current permission object.

Remarks

A copy of a permission object represents the same access to resources as the original permission object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FromXml Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : FromXml Method

passedElement
The XML encoding used to reconstruct the security object.
Reconstructs a security object with the specified state from XML encoding.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub FromXml( _
   ByVal passedElement As SecurityElement _
)
C#
public override void FromXml(
   SecurityElement passedElement
)

Parameters

passedElement
The XML encoding used to reconstruct the security object.

Remarks

Custom code that extends security objects need to implement the ToXml and FromXml methods to make the objects security-encodable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Intersect Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : Intersect Method

target
A permission object to intersect with the current permission object. It must have the same type as the current permission object.
Returns a new permission object representing the intersection of the current permission object and the specified permission object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Intersect( _
   ByVal target As IPermission _
) As IPermission
C#
public override IPermission Intersect(
   IPermission target
)

Parameters

target
A permission object to intersect with the current permission object. It must have the same type as the current permission object.

Return Value

A new permission object that represents the intersection of the current permission object and the specified permission object. If the intersection is empty, new permission object is a null reference.

Remarks

The intersection of two permissions is a permission that describes the set of operations that they both describe in common. Only a demand that passes both original permissions will pass the intersection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsSubsetOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : IsSubsetOf Method

target
A permission object to be tested for the subset relationship. This object must have the same type as the current permission object.
Returns a value indicating whether the current permission object is a subset of the specified permission object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function IsSubsetOf( _
   ByVal target As IPermission _
) As Boolean
C#
public override bool IsSubsetOf(
   IPermission target
)

Parameters

target
A permission object to be tested for the subset relationship. This object must have the same type as the current permission object.

Return Value

true if the current permission object is a subset of the specified permission object; otherwise, %[LangWord] false%.

Remarks

The current permission object is a subset of the specified permission object if the current permission object specifies a set of operations that is completely contained by the specified permission object. For example, a permission that represents access to C:\example.txt is a subset of a permission that represents access to C:\. If IsSubsetOf method returns true, the current permission object represents no more access to the protected resource than does the specified permission object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsUnrestricted Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : IsUnrestricted Method

Returns a value indicating whether the permission can be represented as unrestricted without any knowledge of the permission semantics.

Syntax

Visual Basic (Declaration)
Public Function IsUnrestricted() As Boolean
C#
public bool IsUnrestricted()

Return Value

true if the permission can be represented as unrestricted; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToXml Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : ToXml Method

Creates XML encoding of the security object and its current state.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToXml() As SecurityElement
C#
public override SecurityElement ToXml()

Return Value

XML encoding of the security object, including any state information.

Remarks

Custom code that extends security objects need to implement the ToXml and FromXml methods to make the objects security-encodable.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePermission Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermission Class

For a list of all members of this type, see OraclePermission members.

Public Properties

 | Name | Description
public Property | AllowBlankPassword | Gets a value indicating whether a blank password is allowed.
Top

See Also

Reference

OraclePermission Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AllowBlankPassword Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : AllowBlankPassword Property

Gets a value indicating whether a blank password is allowed.

Syntax

Visual Basic (Declaration)
Public Property AllowBlankPassword As Boolean
C#
public bool AllowBlankPassword {get; set;}

Property Value

true if a blank password is allowed; otherwise, false.

Remarks

The System.Security.Permissions.PermissionState enumeration takes precedence over the AllowBlankPassword property. Therefore, if you set AllowBlankPassword to false, you must also set System.Security.Permissions.PermissionState to None to prevent a user from making a connection using a blank password.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePermissionAttribute Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermissionAttribute Class

Associates a security action with a custom security attribute.

Inheritance Hierarchy

System.Object
System.Attribute
System.Security.Permissions.SecurityAttribute
System.Security.Permissions.CodeAccessSecurityAttribute
Devart.Data.Oracle.OraclePermissionAttribute

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OraclePermissionAttribute
   Inherits System.Security.Permissions.CodeAccessSecurityAttribute
   Implements _Attribute
C#
public sealed class OraclePermissionAttribute : System.Security.Permissions.CodeAccessSecurityAttribute, _Attribute

Remarks

This class is intended for future use when dotConnect for Oracle is enabled for partial trust scenarios. The provider currently requires FullTrust permission. At present, using the OraclePermissionAttribute class has no effect. For more information, see Code Access Security and ADO.NET.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePermissionAttribute Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePermissionAttribute Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OraclePermissionAttribute Class

The following tables list the members exposed by OraclePermissionAttribute.

Public Constructors

 | Name | Description
public Constructor | OraclePermissionAttribute Constructor | Initializes a new instance of the OraclePermissionAttribute class.
Top

Public Properties

 | Name | Description
public Property | Action | Gets or sets a security action. (Inherited from System.Security.Permissions.SecurityAttribute)
public Property | AllowBlankPassword | Gets a value indicating whether a blank password is allowed.
public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
public Property | Unrestricted | Gets or sets a value indicating whether full (unrestricted) permission to the resource protected by the attribute is declared. (Inherited from System.Security.Permissions.SecurityAttribute)
Top

Public Methods

 | Name | Description
public Method | CreatePermission | Overridden. Returns an OraclePermission object that is configured according to the attribute properties.
public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

OraclePermissionAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePermissionAttribute Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermissionAttribute Class : OraclePermissionAttribute Constructor

action
One of the System.Security.Permissions.SecurityAction values representing an action that can be performed using declarative security.
Initializes a new instance of the OraclePermissionAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal action As SecurityAction _
)
C#
public OraclePermissionAttribute(
   SecurityAction action
)

Parameters

action
One of the System.Security.Permissions.SecurityAction values representing an action that can be performed using declarative security.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermissionAttribute Class
OraclePermissionAttribute Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePermissionAttribute Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermissionAttribute Class

For a list of all members of this type, see OraclePermissionAttribute members.

Public Methods

 | Name | Description
public Method | CreatePermission | Overridden. Returns an OraclePermission object that is configured according to the attribute properties.
public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

OraclePermissionAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreatePermission Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermissionAttribute Class : CreatePermission Method

Returns an OraclePermission object that is configured according to the attribute properties.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function CreatePermission() As IPermission
C#
public override IPermission CreatePermission()

Return Value

An OraclePermission object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermissionAttribute Class
OraclePermissionAttribute Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePermissionAttribute Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePermissionAttribute Class

For a list of all members of this type, see OraclePermissionAttribute members.

Public Properties

 | Name | Description
public Property | Action | Gets or sets a security action. (Inherited from System.Security.Permissions.SecurityAttribute)
public Property | AllowBlankPassword | Gets a value indicating whether a blank password is allowed.
public Property | TypeId | When implemented in a derived class, gets a unique identifier for this System.Attribute. (Inherited from System.Attribute)
public Property | Unrestricted | Gets or sets a value indicating whether full (unrestricted) permission to the resource protected by the attribute is declared. (Inherited from System.Security.Permissions.SecurityAttribute)
Top

See Also

Reference

OraclePermissionAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AllowBlankPassword Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermissionAttribute Class : AllowBlankPassword Property

Gets a value indicating whether a blank password is allowed.

Syntax

Visual Basic (Declaration)
Public Property AllowBlankPassword As Boolean
C#
public bool AllowBlankPassword {get; set;}

Property Value

true if a blank password is allowed; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermissionAttribute Class
OraclePermissionAttribute Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipe Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipe Class

Represents Oracle pipe.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OraclePipe

Syntax

Visual Basic (Declaration)
Public Class OraclePipe
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public class OraclePipe : System.ComponentModel.Component, IComponent, IDisposable

Remarks

A pipe is an area of memory used by one process to pass information to another. Pipes are designed to collect information on client side and transfer it to a stored procedure, and vice versa.

On server side, package DBMS_PIPE allows different sessions to communicate over named pipes. You can use the procedures pack_message and send_message to pack a message into a pipe and then send it to another session in the same instance or to a waiting application written with dotConnect for Oracle. To receive incoming message on a server you can use the procedures receive_message and unpack_message to receive and unpack (read) the message.

On client side use Receive and Send(OraclePipeMessageCollection) methods to handle the data, which is represented as OraclePipeMessageCollection.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePipe Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePipe Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OraclePipe Class

The following tables list the members exposed by OraclePipe.

Public Constructors

 | Name | Description
public Constructor | OraclePipe Constructor | Overloaded. Initializes a new instance of the OraclePipe class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets OracleConnection used by OraclePipe.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | MaxPipeSize | Gets or sets maximum space reserved for the pipe.
public Property | PipeName | Gets or sets the name of the pipe.
public Property | ReceiveTimeout | Gets or sets timeout for Receive method to execute.
public Property | SendTimeout | Gets or sets timeout for Send(OraclePipeMessageCollection) method to execute.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Purge | Purges pipe contents.
public Method | Receive | Receives pipe contents.
public Method | Send | Overloaded. Sends data through Oracle pipe.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePipe Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipe Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : OraclePipe Constructor

Initializes a new instance of the OraclePipe class.

Overload List

Overload | Description
OraclePipe Constructor() | Initializes a new instance of the OraclePipe class.
OraclePipe Constructor(OracleConnection,String) | Initializes a new instance of the OraclePipe class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipe Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class > OraclePipe Constructor : OraclePipe Constructor()

Initializes a new instance of the OraclePipe class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OraclePipe()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipe Constructor(OracleConnection,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class > OraclePipe Constructor : OraclePipe Constructor(OracleConnection,String)

connection
OracleConnection used by OraclePipe.
pipeName
Name of the pipe.
Initializes a new instance of the OraclePipe class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal pipeName As String _
)
C#
public OraclePipe(
   OracleConnection connection,
   string pipeName
)

Parameters

connection
OracleConnection used by OraclePipe.
pipeName
Name of the pipe.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePipe Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipe Class

For a list of all members of this type, see OraclePipe members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Purge | Purges pipe contents.
public Method | Receive | Receives pipe contents.
public Method | Send | Overloaded. Sends data through Oracle pipe.
Top

See Also

Reference

OraclePipe Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Purge Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : Purge Method

Purges pipe contents.

Syntax

Visual Basic (Declaration)
Public Sub Purge()
C#
public void Purge()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Receive Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : Receive Method

Receives pipe contents.

Syntax

Visual Basic (Declaration)
Public Function Receive() As OraclePipeMessageCollection
C#
public OraclePipeMessageCollection Receive()

Return Value

An OraclePipeMessageCollection that represents pipe contents. If the pipe does not exist, the return value is null. If the pipe is empty, the collection returned has zero length.

Remarks

If the message could not be received during the ReceiveTimeout, an exception is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members
Send Method
ReceiveTimeout Property
PipeName Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Send Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : Send Method

Sends data through Oracle pipe.

Overload List

Overload | Description
Send(OraclePipeMessage) | Sends an OraclePipeMessage through the pipe.
Send(OraclePipeMessageCollection) | Sends data as an OraclePipeMessageCollection through the pipe.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Send(OraclePipeMessage) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class > Send Method : Send(OraclePipeMessage) Method

message
OraclePipeMessage to send.
Sends an OraclePipeMessage through the pipe.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Send( _
   ByVal message As OraclePipeMessage _
)
C#
public void Send(
   OraclePipeMessage message
)

Parameters

message
OraclePipeMessage to send.

Remarks

If the message could not be sent during the SendTimeout, an exception is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Send(OraclePipeMessageCollection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class > Send Method : Send(OraclePipeMessageCollection) Method

messages
OraclePipeMessageCollection to send to server.
Sends data as an OraclePipeMessageCollection through the pipe.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Send( _
   ByVal messages As OraclePipeMessageCollection _
)
C#
public void Send(
   OraclePipeMessageCollection messages
)

Parameters

messages
OraclePipeMessageCollection to send to server.

Remarks

If the message could not be sent during the SendTimeout, an exception is thrown.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePipe Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipe Class

For a list of all members of this type, see OraclePipe members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets OracleConnection used by OraclePipe.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | MaxPipeSize | Gets or sets maximum space reserved for the pipe.
public Property | PipeName | Gets or sets the name of the pipe.
public Property | ReceiveTimeout | Gets or sets timeout for Receive method to execute.
public Property | SendTimeout | Gets or sets timeout for Send(OraclePipeMessageCollection) method to execute.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePipe Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : Connection Property

Gets or sets OracleConnection used by OraclePipe.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

OracleConnection used by OraclePipe.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxPipeSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : MaxPipeSize Property

Gets or sets maximum space reserved for the pipe.

Syntax

Visual Basic (Declaration)
Public Property MaxPipeSize As Integer
C#
public int MaxPipeSize {get; set;}

Property Value

The maximum allowed space in bytes. The default maxpipesize is 8192 bytes.

Remarks

The total size of all of the messages on the pipe cannot exceed this amount. The message is blocked if it exceeds this maximum.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PipeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : PipeName Property

Gets or sets the name of the pipe.

Syntax

Visual Basic (Declaration)
Public Property PipeName As String
C#
public string PipeName {get; set;}

Property Value

The name of the pipe.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReceiveTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : ReceiveTimeout Property

Gets or sets timeout for Receive method to execute.

Syntax

Visual Basic (Declaration)
Public Property ReceiveTimeout As Integer
C#
public int ReceiveTimeout {get; set;}

Property Value

Maximum time allowed to fetch the pipe contents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SendTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipe Class : SendTimeout Property

Gets or sets timeout for Send(OraclePipeMessageCollection) method to execute.

Syntax

Visual Basic (Declaration)
Public Property SendTimeout As Integer
C#
public int SendTimeout {get; set;}

Property Value

Maximum time allowed to send the pipe data in seconds.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipe Class
OraclePipe Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipeMessage Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessage Class

Represents elementary piece of data to transfer through Oracle pipe.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OraclePipeMessage

Syntax

Visual Basic (Declaration)
Public Class OraclePipeMessage
C#
public class OraclePipeMessage

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePipeMessage Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessage Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessage Class

The following tables list the members exposed by OraclePipeMessage.

Public Constructors

 | Name | Description
public Constructor | OraclePipeMessage Constructor | Initializes a new instance of the OraclePipeMessage class.
Top

Public Properties

 | Name | Description
public Property | Type | Gets or sets type of the OraclePipeMessage.
public Property | Value | Gets or sets the value of the OraclePipeMessage.
Top

Public Methods

 | Name | Description
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OraclePipeMessage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipeMessage Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessage Class : OraclePipeMessage Constructor

value
An System.Object that is the value of the OraclePipeMessage. The default value is null.
type
One of OracleDbType values.
Initializes a new instance of the OraclePipeMessage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Object, _
   ByVal type As OracleDbType _
)
C#
public OraclePipeMessage(
   object value,
   OracleDbType type
)

Parameters

value
An System.Object that is the value of the OraclePipeMessage. The default value is null.
type
One of OracleDbType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessage Class
OraclePipeMessage Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessage Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessage Class

For a list of all members of this type, see OraclePipeMessage members.

Public Methods

 | Name | Description
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OraclePipeMessage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessage Class : ToString Method

Returns string representation of the object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

The string representation of the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessage Class
OraclePipeMessage Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessage Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessage Class

For a list of all members of this type, see OraclePipeMessage members.

Public Properties

 | Name | Description
public Property | Type | Gets or sets type of the OraclePipeMessage.
public Property | Value | Gets or sets the value of the OraclePipeMessage.
Top

See Also

Reference

OraclePipeMessage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Type Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessage Class : Type Property

Gets or sets type of the OraclePipeMessage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As OracleDbType
C#
public OracleDbType Type {get;}

Property Value

One of OracleDbType values.

Remarks

The following types are supported in OraclePipeMessage:

  • OracleDbType.VarChar
  • OracleDbType.Char
  • OracleDbType.Integer
  • OracleDbType.Double
  • OracleDbType.Date
  • OracleDbType.Number

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessage Class
OraclePipeMessage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessage Class : Value Property

Gets or sets the value of the OraclePipeMessage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Object
C#
public object Value {get;}

Property Value

An System.Object that is the value of the OraclePipeMessage. The default value is null.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessage Class
OraclePipeMessage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipeMessageCollection Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessageCollection Class

Represents data transferred through Oracle pipe.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Data.Oracle.OraclePipeMessageCollection

Syntax

Visual Basic (Declaration)
Public Class OraclePipeMessageCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public class OraclePipeMessageCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OraclePipeMessageCollection Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessageCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessageCollection Class

The following tables list the members exposed by OraclePipeMessageCollection.

Public Constructors

 | Name | Description
public Constructor | OraclePipeMessageCollection Constructor | Initializes a new instance of the OraclePipeMessageCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the OraclePipeMessage at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Adds the specified OraclePipeMessage to the OraclePipeMessageCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a OraclePipeMessage object exists in the collection.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the OraclePipeMessage object.
public Method | Insert | Inserts a OraclePipeMessage into the collection at the specified index.
public Method | Remove | Removes the specified OraclePipeMessage object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OraclePipeMessageCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePipeMessageCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : OraclePipeMessageCollection Constructor

Initializes a new instance of the OraclePipeMessageCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OraclePipeMessageCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessageCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessageCollection Class

For a list of all members of this type, see OraclePipeMessageCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds the specified OraclePipeMessage to the OraclePipeMessageCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether a OraclePipeMessage object exists in the collection.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the location in the collection of the OraclePipeMessage object.
public Method | Insert | Inserts a OraclePipeMessage into the collection at the specified index.
public Method | Remove | Removes the specified OraclePipeMessage object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | ToString | Returns string representation of the object.
Top

See Also

Reference

OraclePipeMessageCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : Add Method

value
The OraclePipeMessage to add to the collection.
Adds the specified OraclePipeMessage to the OraclePipeMessageCollection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As OraclePipeMessage _
) As Integer
C#
public int Add(
   OraclePipeMessage value
)

Parameters

value
The OraclePipeMessage to add to the collection.

Return Value

Index of the new OraclePipeMessage object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : Contains Method

value
The value of the OraclePipeMessage object to find.
Gets a value indicating whether a OraclePipeMessage object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As OraclePipeMessage _
) As Boolean
C#
public bool Contains(
   OraclePipeMessage value
)

Parameters

value
The value of the OraclePipeMessage object to find.

Return Value

true if the collection contains the OraclePipeMessage; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : IndexOf Method

value
The OraclePipeMessage object to find.
Gets the location in the collection of the OraclePipeMessage object.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As OraclePipeMessage _
) As Integer
C#
public int IndexOf(
   OraclePipeMessage value
)

Parameters

value
The OraclePipeMessage object to find.

Return Value

The zero-based location in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : Insert Method

index
The zero-based index where the object is to be inserted within the collection.
value
The OraclePipeMessage to add to the collection.
Inserts a OraclePipeMessage into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OraclePipeMessage _
)
C#
public void Insert(
   int index,
   OraclePipeMessage value
)

Parameters

index
The zero-based index where the object is to be inserted within the collection.
value
The OraclePipeMessage to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : Remove Method

value
OraclePipeMessage object to remove.
Removes the specified OraclePipeMessage object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As OraclePipeMessage _
)
C#
public void Remove(
   OraclePipeMessage value
)

Parameters

value
OraclePipeMessage object to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : ToString Method

Returns string representation of the object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OraclePipeMessageCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipeMessageCollection Class

For a list of all members of this type, see OraclePipeMessageCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the OraclePipeMessage at the specified index.
Top

See Also

Reference

OraclePipeMessageCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePipeMessageCollection Class : Item Property

index
The zero-based index of the object.
Gets or sets the OraclePipeMessage at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OraclePipeMessage
C#
public OraclePipeMessage this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the object.

Property Value

The OraclePipeMessage at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePipeMessageCollection Class
OraclePipeMessageCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleProviderException Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderException Class

The exception that is thrown when dotConnect for Oracle returns a provider (non-database) error.

Inheritance Hierarchy

System.Object
System.Exception
Devart.Common.DbProviderException
Devart.Data.Oracle.OracleProviderException

Syntax

Visual Basic (Declaration)
Public Class OracleProviderException
   Inherits Devart.Common.DbProviderException
   Implements _Exception, ISerializable
C#
public class OracleProviderException : Devart.Common.DbProviderException, _Exception, ISerializable

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleProviderException Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleProviderException Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleProviderException Class

The following tables list the members exposed by OracleProviderException.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

OracleProviderException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderFactory Class

Represents a factory required to create inheritors of generic base classes to use with dotConnect for Oracle.

Inheritance Hierarchy

System.Object
System.Data.Common.DbProviderFactory
Devart.Data.Oracle.OracleProviderFactory
Devart.Data.Oracle.OracleClientFactory

Syntax

Visual Basic (Declaration)
Public Class OracleProviderFactory
   Inherits System.Data.Common.DbProviderFactory
   Implements IServiceProvider
C#
public class OracleProviderFactory : System.Data.Common.DbProviderFactory, IServiceProvider

Remarks

You can use OracleProviderFactory class to implement a code where user chooses which DBMS to use.

To obtain an instance of the class you can use the DbProviderFactories.GetFactory method with the invariant name Devart.Data.Oracle.

Example

This sample routine creates and returns T:Devart.Common.DbConnection object.
C#csharp Copy Code
public DbConnection GetConnectionBaseClass2(DbProviderFactory factory)
{
// if our factory supports creating a DbConnection, return it.
if ((factory.SupportedClasses & DbProviderSupportedClasses.DbConnection) > 0)
  return factory.CreateConnection();
else
  return null;
}
C#Visual Basic Copy Code
Public Function GetConnectionBaseClass2(ByVal factory As DbProviderFactory) As DbConnection
  'if our factory supports creating a DbConnection, return it.
  If ((factory.SupportedClasses And DbProviderSupportedClasses.DbConnection) > 0) Then
    Return factory.CreateConnection()
  Else
    Return Nothing
  End If
End Function

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleProviderFactory Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleProviderFactory Class

The following tables list the members exposed by OracleProviderFactory.

Public Constructors

 | Name | Description
public Constructor | OracleProviderFactory Constructor | Creates an instance of OracleProviderFactory.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleProviderFactory.
Top

Public Properties

 | Name | Description
public Property | CanCreateDataSourceEnumerator | Overridden. Gets a value indicating whether the OracleProviderFactory can create a Devart.Common.DbDataSourceEnumerator object.
Top

Public Methods

 | Name | Description
public Method | CreateCommand | Overridden. Creates and returns a OracleCommand object.
public Method | CreateCommandBuilder | Overridden. Creates and returns a OracleCommandBuilder object.
public Method | CreateConnection | Overridden. Creates and returns a OracleConnection object.
public Method | CreateConnectionStringBuilder | Overridden. Creates and returns a OracleConnectionStringBuilder object.
public Method | CreateDataAdapter | Overridden. Creates and returns a OracleDataAdapter object.
public Method | CreateDataSourceEnumerator | Overridden. Returns a new instance of the dotConnect for Oracle class that implements the System.Data.Common.DbDataSourceEnumerator class.
public Method | CreateParameter | Overridden. Creates and returns a OracleParameter object.
public Method | CreatePermission | Returns a new instance of the provider's class that implements the provider's version of the System.Security.CodeAccessPermission class. (Inherited from System.Data.Common.DbProviderFactory)
Top

See Also

Reference

OracleProviderFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : OracleProviderFactory Constructor

Creates an instance of OracleProviderFactory.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleProviderFactory()

Remarks

Only one instance of OracleProviderFactory can exist in the application.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderFactory Class

For a list of all members of this type, see OracleProviderFactory members.

Public Methods

 | Name | Description
public Method | CreateCommand | Overridden. Creates and returns a OracleCommand object.
public Method | CreateCommandBuilder | Overridden. Creates and returns a OracleCommandBuilder object.
public Method | CreateConnection | Overridden. Creates and returns a OracleConnection object.
public Method | CreateConnectionStringBuilder | Overridden. Creates and returns a OracleConnectionStringBuilder object.
public Method | CreateDataAdapter | Overridden. Creates and returns a OracleDataAdapter object.
public Method | CreateDataSourceEnumerator | Overridden. Returns a new instance of the dotConnect for Oracle class that implements the System.Data.Common.DbDataSourceEnumerator class.
public Method | CreateParameter | Overridden. Creates and returns a OracleParameter object.
public Method | CreatePermission | Returns a new instance of the provider's class that implements the provider's version of the System.Security.CodeAccessPermission class. (Inherited from System.Data.Common.DbProviderFactory)
Top

See Also

Reference

OracleProviderFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommand Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateCommand Method

Creates and returns a Devart.Data.Oracle.OracleCommand object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateCommand() As DbCommand
C#
public override DbCommand CreateCommand()

Return Value

A Devart.Data.Oracle.OracleCommand object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateCommandBuilder Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateCommandBuilder Method

Creates and returns a OracleCommandBuilder object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateCommandBuilder() As DbCommandBuilder
C#
public override DbCommandBuilder CreateCommandBuilder()

Return Value

A OracleCommandBuilder object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateConnection Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateConnection Method

Creates and returns a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateConnection() As DbConnection
C#
public override DbConnection CreateConnection()

Return Value

A OracleConnection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateConnectionStringBuilder Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateConnectionStringBuilder Method

Creates and returns a OracleConnectionStringBuilder object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateConnectionStringBuilder() As DbConnectionStringBuilder
C#
public override DbConnectionStringBuilder CreateConnectionStringBuilder()

Return Value

A OracleConnectionStringBuilder object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateDataAdapter Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateDataAdapter Method

Creates and returns a OracleDataAdapter object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateDataAdapter() As DbDataAdapter
C#
public override DbDataAdapter CreateDataAdapter()

Return Value

A OracleDataAdapter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateDataSourceEnumerator Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateDataSourceEnumerator Method

Returns a new instance of the dotConnect for Oracle class that implements the System.Data.Common.DbDataSourceEnumerator class.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateDataSourceEnumerator() As DbDataSourceEnumerator
C#
public override DbDataSourceEnumerator CreateDataSourceEnumerator()

Return Value

A new instance of System.Data.Common.DbDataSourceEnumerator.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateParameter Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CreateParameter Method

Creates and returns a OracleParameter object.

Syntax

Visual Basic (Declaration)
Public Overrides Function CreateParameter() As DbParameter
C#
public override DbParameter CreateParameter()

Return Value

A OracleParameter object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderFactory Class

For a list of all members of this type, see OracleProviderFactory members.

Public Properties

 | Name | Description
public Property | CanCreateDataSourceEnumerator | Overridden. Gets a value indicating whether the OracleProviderFactory can create a Devart.Common.DbDataSourceEnumerator object.
Top

See Also

Reference

OracleProviderFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CanCreateDataSourceEnumerator Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : CanCreateDataSourceEnumerator Property

Gets a value indicating whether the OracleProviderFactory can create a Devart.Common.DbDataSourceEnumerator object.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanCreateDataSourceEnumerator As Boolean
C#
public override bool CanCreateDataSourceEnumerator {get;}

Property Value

true, if a Devart.Common.DbDataSourceEnumerator object can be created; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleProviderFactory Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderFactory Class

For a list of all members of this type, see OracleProviderFactory members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Instance | Returns the instance of OracleProviderFactory.
Top

See Also

Reference

OracleProviderFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Instance Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleProviderFactory Class : Instance Field

Returns the instance of OracleProviderFactory.

Syntax

Visual Basic (Declaration)
Public Shared Instance As OracleProviderFactory
C#
public static OracleProviderFactory Instance

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleProviderFactory Class
OracleProviderFactory Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueue Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueue Class

Represents Oracle Streams Advanced Queuing (AQ).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OracleQueue

Syntax

Visual Basic (Declaration)
Public Class OracleQueue
   Inherits System.ComponentModel.Component
   Implements IComponent, ISupportInitialize, IDisposable
C#
public class OracleQueue : System.ComponentModel.Component, IComponent, ISupportInitialize, IDisposable

Remarks

This class provides an interface for using queues: adding, deleting messages, listing queues. It is not to be used for administration of queues and queue tables, or for permissions management. For these purposes the OracleQueueAdmin and OracleQueueTable components should be used.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example demonstrates usage of OracleQueue, OracleQueueAdmin, OracleQueueTable, OracleQueueTableOptions, and Devart.Data.Oracle.OracleQueueMessage classes. For detailed description of advanced queuing and more samples, refer to the Advanced Queuing Technology article.
C#csharp Copy Code
static void Main(string[] args)
{
        using (OracleConnection oracleConnection = new OracleConnection(
                        "User Id=system;Password=manager;Server=ora;Direct=False;")) {
                oracleConnection.Open();
                OracleCommand oracleCommand = new OracleCommand(
                        "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
                        "mestext VARCHAR2(80));", oracleConnection);
                oracleCommand.ExecuteNonQuery();
                OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueTable.Options.PayloadTypeName = "message";
                oracleQueueTable.CreateQueueTable();
                OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
                        "QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueAdmin.CreateQueue();
                oracleQueueAdmin.StartQueue();
                OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleObject mes = new OracleObject("message", oracleConnection);
                mes["nickname"] = oracleConnection.UserId;
                mes["mestext"] = "Hello, world!";
                oracleEnqueueQueue.Enqueue(mes);
                OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
                if (msg != null && msg.ObjectPayload != null) {
                        Console.WriteLine(msg.ObjectPayload["nickname"]);
                        Console.WriteLine(msg.ObjectPayload["mestext"]);
                }
                oracleQueueAdmin.StopQueue();
                oracleQueueAdmin.DropQueue();
                oracleQueueTable.DropQueueTable();
                oracleConnection.Close();
        }
}
C#Visual Basic Copy Code
Sub Main()
        Using oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora;Direct=False;")
                oracleConnection.Open()
                Dim oracleCommand As New OracleCommand("CREATE OR REPLACE TYPE message " & _
                        "AS OBJECT (nickname VARCHAR2(15), mestext VARCHAR2(80));", oracleConnection)
                OracleCommand.ExecuteNonQuery()
                Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueTable.Options.PayloadTypeName = "message"
                oracleQueueTable.CreateQueueTable()
                Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
                        "QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueAdmin.CreateQueue()
                oracleQueueAdmin.StartQueue()
                Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim mes As New OracleObject("message", oracleConnection)
                mes.Item("nickname") = oracleConnection.UserId
                mes.Item("mestext") = "Hello, world!"
                oracleEnqueueQueue.Enqueue(mes)
                Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
                If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
                        Console.WriteLine(msg.ObjectPayload.Item("nickname"))
                        Console.WriteLine(msg.ObjectPayload.Item("mestext"))
                End If
                oracleQueueAdmin.StopQueue()
                oracleQueueAdmin.DropQueue()
                oracleQueueTable.DropQueueTable()
                oracleConnection.Close()
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueue Members
Devart.Data.Oracle Namespace
OracleQueueAdmin Class
OracleQueueTable Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueue Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleQueue Class

The following tables list the members exposed by OracleQueue.

Public Constructors

 | Name | Description
public Constructor | OracleQueue Constructor | Overloaded. Initializes a new instance of the OracleQueue class.
Top

Public Properties

 | Name | Description
public Property | AsyncNotification | Switches asynchronous listening on or off.
public Property | Connection | Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DequeueOptions | Gets or sets dequeue options, which are used to dequeue messages from queues by default.
public Property | EnqueueMessageProperties | Gets or sets message properties used by default when inserting messages into queues.
public Property | EnqueueOptions | Gets or sets enqueue options used for inserting messages into queues by default.
public Property | PayloadArrayTypeName | Gets or sets array type name for object type queues.
public Property | PayloadTypeName | Gets or sets the type of message payload.
static (Shared in Visual Basic) | Port | Gets or sets the TCP port, at which notifications are delivered.
public Property | QueueName | Gets or sets the name of the queue.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | BeginInit | Begins the initialization of an OracleQueue. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dequeue | Overloaded. Dequeues a message from the specified queue.
public Method | DequeueArray | Overloaded. Dequeues an array of messages.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndInit | Ends the initialization of an OracleQueue. The initialization occurs at run time.
public Method | Enqueue | Overloaded. Adds a message to the specified queue.
public Method | EnqueueArray | Overloaded. Enqueues an array of messages.
public Method | FindPayloadArrayType | Makes an attempt to find PayloadArrayTypeName for PayloadTypeName. PayloadTypeName property has to be set.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Listen | Overloaded. This procedure listens on one or more queues on behalf of a list of agents. The address field of the agent indicates the queue the agent wants to monitor. Only local queues are supported as addresses.
public Method | ReadPayloadTypeName | Sends an inquiry to a server and determines payload type, which depends on the queue type on which the operation is being performed. This can be object type or 'RAW'.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | OnMessage | Triggers when AsyncNotification property is true and message notification arrives.
Top

See Also

Reference

OracleQueue Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueue Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : OracleQueue Constructor

Initializes a new instance of the OracleQueue class.

Overload List

Overload | Description
OracleQueue Constructor() | Initializes a new instance of the OracleQueue class.
OracleQueue Constructor(String) | Initializes a new instance of the OracleQueue class.
OracleQueue Constructor(String,OracleConnection) | Initializes a new instance of the OracleQueue class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueue Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > OracleQueue Constructor : OracleQueue Constructor()

Initializes a new instance of the OracleQueue class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueue Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > OracleQueue Constructor : OracleQueue Constructor(String)

name
The name of the queue created on a server.
Initializes a new instance of the OracleQueue class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public OracleQueue(
   string name
)

Parameters

name
The name of the queue created on a server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueue Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > OracleQueue Constructor : OracleQueue Constructor(String,OracleConnection)

name
The name of the queue created on a server.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Initializes a new instance of the OracleQueue class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueue(
   string name,
   OracleConnection connection
)

Parameters

name
The name of the queue created on a server.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Remarks

These fields must be initialized before calling any function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueue Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueue Class

For a list of all members of this type, see OracleQueue members.

Public Methods

 | Name | Description
public Method | BeginInit | Begins the initialization of an OracleQueue. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dequeue | Overloaded. Dequeues a message from the specified queue.
public Method | DequeueArray | Overloaded. Dequeues an array of messages.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | EndInit | Ends the initialization of an OracleQueue. The initialization occurs at run time.
public Method | Enqueue | Overloaded. Adds a message to the specified queue.
public Method | EnqueueArray | Overloaded. Enqueues an array of messages.
public Method | FindPayloadArrayType | Makes an attempt to find PayloadArrayTypeName for PayloadTypeName. PayloadTypeName property has to be set.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Listen | Overloaded. This procedure listens on one or more queues on behalf of a list of agents. The address field of the agent indicates the queue the agent wants to monitor. Only local queues are supported as addresses.
public Method | ReadPayloadTypeName | Sends an inquiry to a server and determines payload type, which depends on the queue type on which the operation is being performed. This can be object type or 'RAW'.
Top

See Also

Reference

OracleQueue Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : BeginInit Method

Begins the initialization of an OracleQueue. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
C#
public void BeginInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dequeue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : Dequeue Method

Dequeues a message from the specified queue.

Overload List

Overload | Description
Dequeue() | Dequeues a message from the specified queue.
Dequeue(OracleQueueDequeueOptions) | Dequeues a message from the specified queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dequeue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Dequeue Method : Dequeue() Method

Dequeues a message from the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Dequeue() As OracleQueueMessage
C#
public OracleQueueMessage Dequeue()

Return Value

Returns the message received.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dequeue(OracleQueueDequeueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Dequeue Method : Dequeue(OracleQueueDequeueOptions) Method

deqOptions
Options for dequeueing. If skipped, they are derived from OracleQueue.DequeueOptions property.
Dequeues a message from the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Dequeue( _
   ByVal deqOptions As OracleQueueDequeueOptions _
) As OracleQueueMessage
C#
public OracleQueueMessage Dequeue(
   OracleQueueDequeueOptions deqOptions
)

Parameters

deqOptions
Options for dequeueing. If skipped, they are derived from OracleQueue.DequeueOptions property.

Return Value

Returns the message received.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : DequeueArray Method

Dequeues an array of messages.

Overload List

Overload | Description
DequeueArray(Int32) | Dequeues an array of messages.
DequeueArray(Int32,OracleQueueDequeueOptions) | Dequeues an array of messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueArray(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > DequeueArray Method : DequeueArray(Int32) Method

size
The number of elements to dequeue.
Dequeues an array of messages.

Syntax

Visual Basic (Declaration)
Public Overloads Function DequeueArray( _
   ByVal size As Integer _
) As OracleQueueMessage()
C#
public OracleQueueMessage[] DequeueArray(
   int size
)

Parameters

size
The number of elements to dequeue.

Return Value

Returns the array of received messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueArray(Int32,OracleQueueDequeueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > DequeueArray Method : DequeueArray(Int32,OracleQueueDequeueOptions) Method

size
The number of elements to dequeue.
deqOptions
Dequeue options. If skipped, they are obtained from OracleQueue.DequeueOptions property.
Dequeues an array of messages.

Syntax

Visual Basic (Declaration)
Public Overloads Function DequeueArray( _
   ByVal size As Integer, _
   ByVal deqOptions As OracleQueueDequeueOptions _
) As OracleQueueMessage()
C#
public OracleQueueMessage[] DequeueArray(
   int size,
   OracleQueueDequeueOptions deqOptions
)

Parameters

size
The number of elements to dequeue.
deqOptions
Dequeue options. If skipped, they are obtained from OracleQueue.DequeueOptions property.

Return Value

Returns the array of received messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : EndInit Method

Ends the initialization of an OracleQueue. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
C#
public void EndInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : Enqueue Method

Adds a message to the specified queue.

Overload List

Overload | Description
Enqueue(OracleQueueMessage) | Adds a message to the specified queue.
Enqueue(OracleQueueMessage,OracleQueueEnqueueOptions) | Adds a message to the specified queue.
Enqueue(OracleBinary) | Adds a message to the queue of RAW objects.
Enqueue(OracleBinary,OracleQueueMessageProperties,OracleQueueEnqueueOptions) | Adds a message to the queue of RAW objects.
Enqueue(Byte[]) | Adds a message to the queue of RAW objects.
Enqueue(Byte[],OracleQueueMessageProperties,OracleQueueEnqueueOptions) | Adds a message to the queue of RAW objects.
Enqueue(String) | Inserts a message into a queue of RAW objects. String is converted to a byte array using default encoding.
Enqueue(String,OracleQueueMessageProperties,OracleQueueEnqueueOptions) | Inserts a message into a queue of RAW objects. String is converted to a byte array using default encoding.
Enqueue(OracleObject) | Adds a message to the specified queue.
Enqueue(OracleObject,OracleQueueMessageProperties,OracleQueueEnqueueOptions) | Adds a message to the specified queue.
Enqueue(OracleXml) | Adds a message to the queue of XML objects.
Enqueue(OracleXml,OracleQueueMessageProperties,OracleQueueEnqueueOptions) | Adds a message to the queue of XML objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleQueueMessage) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleQueueMessage) Method

message
A message to be enqueued.
Adds a message to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal message As OracleQueueMessage _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleQueueMessage message
)

Parameters

message
A message to be enqueued.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleQueueMessage,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleQueueMessage,OracleQueueEnqueueOptions) Method

message
A message to be enqueued.
enqOptions
Options for inserting a message into a queue. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds a message to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal message As OracleQueueMessage, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleQueueMessage message,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

message
A message to be enqueued.
enqOptions
Options for inserting a message into a queue. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleBinary) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleBinary) Method

payload
RAW message payload.
Adds a message to the queue of RAW objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleBinary _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleBinary payload
)

Parameters

payload
RAW message payload.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleBinary,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleBinary,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method

payload
RAW message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds a message to the queue of RAW objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleBinary, _
   ByVal messageProperties As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleBinary payload,
   OracleQueueMessageProperties messageProperties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payload
RAW message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(Byte[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(Byte[]) Method

payload
RAW message payload.
Adds a message to the queue of RAW objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload() As Byte _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   byte[] payload
)

Parameters

payload
RAW message payload.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(Byte[],OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(Byte[],OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method

payload
RAW message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds a message to the queue of RAW objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload() As Byte, _
   ByVal messageProperties As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   byte[] payload,
   OracleQueueMessageProperties messageProperties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payload
RAW message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(String) Method

payload
String message payload.
Inserts a message into a queue of RAW objects. String is converted to a byte array using default encoding.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As String _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   string payload
)

Parameters

payload
String message payload.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(String,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(String,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method

payload
String message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Inserts a message into a queue of RAW objects. String is converted to a byte array using default encoding.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As String, _
   ByVal messageProperties As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   string payload,
   OracleQueueMessageProperties messageProperties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payload
String message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleObject) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleObject) Method

payload
Instance of message object.
Adds a message to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleObject _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleObject payload
)

Parameters

payload
Instance of message object.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleObject,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleObject,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method

payload
Instance of message object.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds a message to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleObject, _
   ByVal messageProperties As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleObject payload,
   OracleQueueMessageProperties messageProperties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payload
Instance of message object.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleXml) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleXml) Method

payload
XML message payload.
Adds a message to the queue of XML objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleXml _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleXml payload
)

Parameters

payload
XML message payload.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enqueue(OracleXml,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Enqueue Method : Enqueue(OracleXml,OracleQueueMessageProperties,OracleQueueEnqueueOptions) Method

payload
XML message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds a message to the queue of XML objects.

Syntax

Visual Basic (Declaration)
Public Overloads Function Enqueue( _
   ByVal payload As OracleXml, _
   ByVal messageProperties As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId
C#
public OracleQueueMessageId Enqueue(
   OracleXml payload,
   OracleQueueMessageProperties messageProperties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payload
XML message payload.
messageProperties
Message properties. If skipped or null, they are obtained from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

System generated identification of the message. This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : EnqueueArray Method

Enqueues an array of messages.

Overload List

Overload | Description
EnqueueArray(OracleBinary[]) | Adds an array of messages into a queue of the RAW type.
EnqueueArray(OracleBinary[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) | Inserts an array of messages into a queue of type 'RAW'.
EnqueueArray(String[]) | Adds an array of messages into a queue of the RAW type. Strings are converted to byte array using default encoding.
EnqueueArray(String[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) | Adds an array of messages of user-defined type to the specified queue.
EnqueueArray(OracleObject[]) | Adds an array of messages of user-defined type to the specified queue.
EnqueueArray(OracleObject[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) | Adds an array of messages of user-defined type to the specified queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(OracleBinary[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(OracleBinary[]) Method

payloads
Array of RAW payloads.
Adds an array of messages into a queue of the RAW type.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As OracleBinary _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   OracleBinary[] payloads
)

Parameters

payloads
Array of RAW payloads.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(OracleBinary[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(OracleBinary[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method

payloads
Array of RAW payloads.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Inserts an array of messages into a queue of type 'RAW'.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As OracleBinary, _
   ByVal properties() As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   OracleBinary[] payloads,
   OracleQueueMessageProperties[] properties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payloads
Array of RAW payloads.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(String[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(String[]) Method

payloads
Array of string message payloads.
Adds an array of messages into a queue of the RAW type. Strings are converted to byte array using default encoding.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As String _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   string[] payloads
)

Parameters

payloads
Array of string message payloads.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(String[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(String[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method

payloads
Array of string message payloads.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds an array of messages of user-defined type to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As String, _
   ByVal properties() As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   string[] payloads,
   OracleQueueMessageProperties[] properties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payloads
Array of string message payloads.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(OracleObject[]) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(OracleObject[]) Method

payloads
Array of objects from which messages will be constructed.
Adds an array of messages of user-defined type to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As OracleObject _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   OracleObject[] payloads
)

Parameters

payloads
Array of objects from which messages will be constructed.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueArray(OracleObject[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > EnqueueArray Method : EnqueueArray(OracleObject[],OracleQueueMessageProperties[],OracleQueueEnqueueOptions) Method

payloads
Array of objects from which messages will be constructed.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.
Adds an array of messages of user-defined type to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Function EnqueueArray( _
   ByVal payloads() As OracleObject, _
   ByVal properties() As OracleQueueMessageProperties, _
   ByVal enqOptions As OracleQueueEnqueueOptions _
) As OracleQueueMessageId()
C#
public OracleQueueMessageId[] EnqueueArray(
   OracleObject[] payloads,
   OracleQueueMessageProperties[] properties,
   OracleQueueEnqueueOptions enqOptions
)

Parameters

payloads
Array of objects from which messages will be constructed.
properties
Array of messages properties. If skipped or null, it is derived from EnqueueMessageProperties property.
enqOptions
Options for inserting. If skipped or null, they are obtained from OracleQueue.EnqueueOptions property.

Return Value

Returns an array of message IDs of the enqueued messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FindPayloadArrayType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : FindPayloadArrayType Method

Makes an attempt to find PayloadArrayTypeName for PayloadTypeName. PayloadTypeName property has to be set.

Syntax

Visual Basic (Declaration)
Public Function FindPayloadArrayType() As String
C#
public string FindPayloadArrayType()

Return Value

Returns PayloadArrayTypeName. If not found, returns null.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : Listen Method

This procedure listens on one or more queues on behalf of a list of agents. The address field of the agent indicates the queue the agent wants to monitor. Only local queues are supported as addresses.

Overload List

Overload | Description
Listen(OracleQueueAgentCollection) | Listens on one or more queues on behalf of a list of agents.
Listen(OracleQueueAgentCollection,Int32) | Listens on one or more queues on behalf of a list of agents.
Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode) | Listens on one or more queues on behalf of a list of agents.
Listen(OracleQueueAgentCollection,OracleConnection) | Listens on one or more queues on behalf of a list of agents.
Listen(OracleQueueAgentCollection,Int32,OracleConnection) | Listens on one or more queues on behalf of a list of agents.
Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode,OracleConnection) | Listens on one or more queues on behalf of a list of agents.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection) Method

agents
List of agents to listen for.
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Function Listen( _
   ByVal agents As OracleQueueAgentCollection _
) As OracleQueueAgent
C#
public OracleQueueAgent Listen(
   OracleQueueAgentCollection agents
)

Parameters

agents
List of agents to listen for.

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection,Int32) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection,Int32) Method

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Function Listen( _
   ByVal agents As OracleQueueAgentCollection, _
   ByVal waitTimeout As Integer _
) As OracleQueueAgent
C#
public OracleQueueAgent Listen(
   OracleQueueAgentCollection agents,
   int waitTimeout
)

Parameters

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection,Int32) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode) Method

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
listenDeliveryMode
The caller specifies whether it is interested in persistent, buffered messages or both types of messages, specifying a delivery mode. (Only for Oracle 10.2 and greater.)
messageDeliveryMode
Returns the message type along with the queue and consumer for which there is a message (only for Oracle 10.2 and greater).
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Function Listen( _
   ByVal agents As OracleQueueAgentCollection, _
   ByVal waitTimeout As Integer, _
   ByVal listenDeliveryMode As OracleQueueDeliveryMode, _
   ByRef messageDeliveryMode As OracleQueueDeliveryMode _
) As OracleQueueAgent
C#
public OracleQueueAgent Listen(
   OracleQueueAgentCollection agents,
   int waitTimeout,
   OracleQueueDeliveryMode listenDeliveryMode,
   out OracleQueueDeliveryMode messageDeliveryMode
)

Parameters

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
listenDeliveryMode
The caller specifies whether it is interested in persistent, buffered messages or both types of messages, specifying a delivery mode. (Only for Oracle 10.2 and greater.)
messageDeliveryMode
Returns the message type along with the queue and consumer for which there is a message (only for Oracle 10.2 and greater).

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection,OracleConnection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection,OracleConnection) Method

agents
List of agents to listen for.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Listen( _
   ByVal agents As OracleQueueAgentCollection, _
   ByVal connection As OracleConnection _
) As OracleQueueAgent
C#
public static OracleQueueAgent Listen(
   OracleQueueAgentCollection agents,
   OracleConnection connection
)

Parameters

agents
List of agents to listen for.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection,OracleConnection) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection,Int32,OracleConnection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection,Int32,OracleConnection) Method

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Listen( _
   ByVal agents As OracleQueueAgentCollection, _
   ByVal waitTimeout As Integer, _
   ByVal connection As OracleConnection _
) As OracleQueueAgent
C#
public static OracleQueueAgent Listen(
   OracleQueueAgentCollection agents,
   int waitTimeout,
   OracleConnection connection
)

Parameters

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection,Int32,OracleConnection) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode,OracleConnection) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class > Listen Method : Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode,OracleConnection) Method

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
listenDeliveryMode
The caller specifies whether it is interested in persistent, buffered messages or both types of messages, specifying a delivery mode. (Only for Oracle 10.2 and greater.)
messageDeliveryMode
Returns the message type along with the queue and consumer for which there is a message (only for Oracle 10.2 and greater).
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Listens on one or more queues on behalf of a list of agents.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Listen( _
   ByVal agents As OracleQueueAgentCollection, _
   ByVal waitTimeout As Integer, _
   ByVal listenDeliveryMode As OracleQueueDeliveryMode, _
   ByRef messageDeliveryMode As OracleQueueDeliveryMode, _
   ByVal connection As OracleConnection _
) As OracleQueueAgent
C#
public static OracleQueueAgent Listen(
   OracleQueueAgentCollection agents,
   int waitTimeout,
   OracleQueueDeliveryMode listenDeliveryMode,
   out OracleQueueDeliveryMode messageDeliveryMode,
   OracleConnection connection
)

Parameters

agents
List of agents to listen for.
waitTimeout
Time out for the listen call in seconds. By default, the call will block forever.
listenDeliveryMode
The caller specifies whether it is interested in persistent, buffered messages or both types of messages, specifying a delivery mode. (Only for Oracle 10.2 and greater.)
messageDeliveryMode
Returns the message type along with the queue and consumer for which there is a message (only for Oracle 10.2 and greater).
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Return Value

Agent with a message available for consumption.

Example

The following example demonstrates the usage of Listen(OracleQueueAgentCollection,Int32,OracleQueueDeliveryMode,OracleQueueDeliveryMode,OracleConnection) method.
C#csharp Copy Code
OracleConnection oracleConnection = new OracleConnection(
        "User Id=system;Password=manager;Server=ora11;");
oracleConnection.Open();

OracleQueueTable oracleQueueTable = new OracleQueueTable(
        "QUEUE_TABLE_MESSAGE", oracleConnection);

// Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = true;
oracleQueueTable.Options.PayloadTypeName = "RAW";
oracleQueueTable.CreateQueueTable();
OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin(
        "MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection);
oracleQueueAdmin.CreateQueue();
oracleQueueAdmin.StartQueue();

oracleQueueAdmin.AddSubscriber(new OracleQueueAgent("Bob"));

OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);

OracleQueueMessage message = new OracleQueueMessage();
message.StringPayload = "Message for Bob.";
message.MessageProperties.RecipientList.Add(new OracleQueueAgent("Bob"));
oracleEnqueueQueue.Enqueue(message);

OracleQueue oracleDequeueQueue = new OracleQueue();
oracleDequeueQueue.Connection = oracleConnection;

OracleQueueAgentCollection coll = new OracleQueueAgentCollection();
coll.Add(new OracleQueueAgent("Bob", "MESSAGE_QUEUE"));

// listening only for 60 seconds instead of blocking thread forever
OracleQueueAgent agent = oracleDequeueQueue.Listen(coll, 60);

Console.WriteLine("The following consumer received a message: {0}", agent.Name);
oracleDequeueQueue.QueueName = agent.Address;
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name;
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload);

oracleQueueAdmin.StopQueue();
oracleQueueAdmin.DropQueue();
oracleQueueTable.DropQueueTable();

oracleConnection.Close();
C#Visual Basic Copy Code
Dim oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora11;")
oracleConnection.Open()

Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)

' Set the table to serve multiple consumers.
oracleQueueTable.Options.MultipleConsumers = True
oracleQueueTable.Options.PayloadTypeName = "RAW"
oracleQueueTable.CreateQueueTable()
Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", "QUEUE_TABLE_MESSAGE", oracleConnection)
oracleQueueAdmin.CreateQueue()
oracleQueueAdmin.StartQueue()

oracleQueueAdmin.AddSubscriber(New OracleQueueAgent("Bob"))

Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)

Dim message As New OracleQueueMessage()
message.StringPayload = "Message for Bob."
message.MessageProperties.RecipientList.Add(New OracleQueueAgent("Bob"))
oracleEnqueueQueue.Enqueue(message)

Dim oracleDequeueQueue As New OracleQueue()
oracleDequeueQueue.Connection = oracleConnection

Dim coll As New OracleQueueAgentCollection()
coll.Add(New OracleQueueAgent("Bob", "MESSAGE_QUEUE"))

' listening only for 60 seconds instead of blocking thread forever
Dim agent As OracleQueueAgent = oracleDequeueQueue.Listen(coll, 60)

Console.WriteLine("The following consumer received a message: {0}", agent.Name)
oracleDequeueQueue.QueueName = agent.Address
oracleDequeueQueue.DequeueOptions.ConsumerName = agent.Name
Console.WriteLine("The message: {0}", oracleDequeueQueue.Dequeue().StringPayload)

oracleQueueAdmin.StopQueue()
oracleQueueAdmin.DropQueue()
oracleQueueTable.DropQueueTable()

oracleConnection.Close()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadPayloadTypeName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : ReadPayloadTypeName Method

Sends an inquiry to a server and determines payload type, which depends on the queue type on which the operation is being performed. This can be object type or 'RAW'.

Syntax

Visual Basic (Declaration)
Public Function ReadPayloadTypeName() As String
C#
public string ReadPayloadTypeName()

Remarks

When determined, PayloadTypeName property is set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueue Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueue Class

For a list of all members of this type, see OracleQueue members.

Public Properties

 | Name | Description
public Property | AsyncNotification | Switches asynchronous listening on or off.
public Property | Connection | Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | DequeueOptions | Gets or sets dequeue options, which are used to dequeue messages from queues by default.
public Property | EnqueueMessageProperties | Gets or sets message properties used by default when inserting messages into queues.
public Property | EnqueueOptions | Gets or sets enqueue options used for inserting messages into queues by default.
public Property | PayloadArrayTypeName | Gets or sets array type name for object type queues.
public Property | PayloadTypeName | Gets or sets the type of message payload.
static (Shared in Visual Basic) | Port | Gets or sets the TCP port, at which notifications are delivered.
public Property | QueueName | Gets or sets the name of the queue.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueue Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AsyncNotification Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : AsyncNotification Property

Switches asynchronous listening on or off.

Syntax

Visual Basic (Declaration)
Public Property AsyncNotification As Boolean
C#
public bool AsyncNotification {get; set;}

Property Value

true if the asynchronous listening is on; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : Connection Property

Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The OracleConnection to the Oracle server which provides AQ functionality.

Remarks

It has to be set and opened before calling any function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueOptions Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : DequeueOptions Property

Gets or sets dequeue options, which are used to dequeue messages from queues by default.

Syntax

Visual Basic (Declaration)
Public Property DequeueOptions As OracleQueueDequeueOptions
C#
public OracleQueueDequeueOptions DequeueOptions {get; set;}

Property Value

Dequeue options, which are used to dequeue messages from queues by default.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueMessageProperties Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : EnqueueMessageProperties Property

Gets or sets message properties used by default when inserting messages into queues.

Syntax

Visual Basic (Declaration)
Public Property EnqueueMessageProperties As OracleQueueMessageProperties
C#
public OracleQueueMessageProperties EnqueueMessageProperties {get; set;}

Property Value

Message properties used by default when inserting messages into queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueOptions Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : EnqueueOptions Property

Gets or sets enqueue options used for inserting messages into queues by default.

Syntax

Visual Basic (Declaration)
Public Property EnqueueOptions As OracleQueueEnqueueOptions
C#
public OracleQueueEnqueueOptions EnqueueOptions {get; set;}

Property Value

Enqueue options used for inserting messages into queues by default.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PayloadArrayTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : PayloadArrayTypeName Property

Gets or sets array type name for object type queues.

Syntax

Visual Basic (Declaration)
Public Property PayloadArrayTypeName As String
C#
public string PayloadArrayTypeName {get; set;}

Property Value

Array type name for object type queues.

Remarks

It is to be set only if a queue has object type payloads and Oracle server version is greater than 10.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PayloadTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : PayloadTypeName Property

Gets or sets the type of message payload.

Syntax

Visual Basic (Declaration)
Public Property PayloadTypeName As String
C#
public string PayloadTypeName {get; set;}

Property Value

Object type name or 'RAW'.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Port Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : Port Property

Gets or sets the TCP port, at which notifications are delivered.

Syntax

Visual Basic (Declaration)
Public Shared Property Port As Integer
C#
public static int Port {get; set;}

Property Value

The TCP port, at which notifications are delivered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : QueueName Property

Gets or sets the name of the queue.

Syntax

Visual Basic (Declaration)
Public Property QueueName As String
C#
public string QueueName {get; set;}

Property Value

The name of the queue.

Remarks

This field has to be set before calling any function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleQueue Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueue Class

For a list of all members of this type, see OracleQueue members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | OnMessage | Triggers when AsyncNotification property is true and message notification arrives.
Top

See Also

Reference

OracleQueue Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OnMessage Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueue Class : OnMessage Event

Triggers when AsyncNotification property is true and message notification arrives.

Syntax

Visual Basic (Declaration)
Public Event OnMessage As OracleQueueMessageEventHandler
C#
public event OracleQueueMessageEventHandler OnMessage

Event Data

The event handler receives an argument of type OracleQueueMessageEventArgs containing data related to this event. The following OracleQueueMessageEventArgs properties provide information specific to this event.

Property | Description
MessageId | Gets OracleQueueMessage.MessageId property of the OracleQueueMessage object received.
MessageProperties | Gets the OracleQueueMessage.MessageProperties

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueue Class
OracleQueue Members
OracleQueueMessageEventHandler Delegate


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAdmin Class

Manages Oracle Streams Advanced Queuing (AQ) configuration and administration information.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OracleQueueAdmin

Syntax

Visual Basic (Declaration)
Public Class OracleQueueAdmin
   Inherits System.ComponentModel.Component
   Implements IComponent, ISupportInitialize, IDisposable
C#
public class OracleQueueAdmin : System.ComponentModel.Component, IComponent, ISupportInitialize, IDisposable

Remarks

This class provides an interface for configurating queues and managing their lifecycle. For using queues themselves (like adding and deleting messages), the OracleQueue component should be used. For managing the database tables where queues are stored, please use the OracleQueueTable class.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example demonstrates usage of OracleQueue, OracleQueueAdmin, OracleQueueTable, OracleQueueTableOptions, and Devart.Data.Oracle.OracleQueueMessage classes. For detailed description of advanced queuing and more samples, refer to the Advanced Queuing Technology article.
C#csharp Copy Code
static void Main(string[] args)
{
        using (OracleConnection oracleConnection = new OracleConnection(
                        "User Id=system;Password=manager;Server=ora;Direct=False;")) {
                oracleConnection.Open();
                OracleCommand oracleCommand = new OracleCommand(
                        "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
                        "mestext VARCHAR2(80));", oracleConnection);
                oracleCommand.ExecuteNonQuery();
                OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueTable.Options.PayloadTypeName = "message";
                oracleQueueTable.CreateQueueTable();
                OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
                        "QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueAdmin.CreateQueue();
                oracleQueueAdmin.StartQueue();
                OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleObject mes = new OracleObject("message", oracleConnection);
                mes["nickname"] = oracleConnection.UserId;
                mes["mestext"] = "Hello, world!";
                oracleEnqueueQueue.Enqueue(mes);
                OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
                if (msg != null && msg.ObjectPayload != null) {
                Console.WriteLine(msg.ObjectPayload["nickname"]);
                Console.WriteLine(msg.ObjectPayload["mestext"]);
            }
            oracleQueueAdmin.StopQueue();
            oracleQueueAdmin.DropQueue();
            oracleQueueTable.DropQueueTable();
            oracleConnection.Close();
        }
}
C#Visual Basic Copy Code
Sub Main()
        Using oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora;Direct=False;")
                oracleConnection.Open()
                Dim oracleCommand As New OracleCommand("CREATE OR REPLACE TYPE message " & _
                        "AS OBJECT (nickname VARCHAR2(15), mestext VARCHAR2(80));", oracleConnection)
                OracleCommand.ExecuteNonQuery()
                Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueTable.Options.PayloadTypeName = "message"
                oracleQueueTable.CreateQueueTable()
                Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
                        "QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueAdmin.CreateQueue()
                oracleQueueAdmin.StartQueue()
                Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim mes As New OracleObject("message", oracleConnection)
                mes.Item("nickname") = oracleConnection.UserId
                mes.Item("mestext") = "Hello, world!"
                oracleEnqueueQueue.Enqueue(mes)
                Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
                If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
                        Console.WriteLine(msg.ObjectPayload.Item("nickname"))
                        Console.WriteLine(msg.ObjectPayload.Item("mestext"))
                End If
                oracleQueueAdmin.StopQueue()
                oracleQueueAdmin.DropQueue()
                oracleQueueTable.DropQueueTable()
                oracleConnection.Close()
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueAdmin Members
Devart.Data.Oracle Namespace
OracleQueueTable Class
OracleQueue Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAdmin Class

The following tables list the members exposed by OracleQueueAdmin.

Public Constructors

 | Name | Description
public Constructor | OracleQueueAdmin Constructor | Overloaded. Initializes a new instance of the OracleQueueAdmin class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Options | Gets or sets queue options used for its creation.
public Property | QueueName | The name of the source queue.
public Property | QueueTableName | Gets or sets the name of the queue table, to which the queue belongs.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | AddSubscriber | Overloaded. Adds a subscriber to the queue.
public Method | AlterComment | Changes the OracleQueueOptions.Comment property of the Options object.
public Method | AlterMaxRetries | Sets the OracleQueueOptions.MaxRetries property of Options.
public Method | AlterPropagationSchedule | Overloaded. Alters parameters of the schedule by which messages are propagated.
public Method | AlterQueue | Alters existing properties of a queue.
public Method | AlterRetentionTime | Sets the OracleQueueOptions.RetentionTime property of OracleQueueAdmin.Options.
public Method | AlterRetryDelay | Sets the OracleQueueOptions.RetryDelay property of OracleQueueAdmin.Options.
public Method | AlterSubscriber | Overloaded. Alters existing properties of a subscriber to a specified queue.
public Method | BeginInit | Begins the initialization of an OracleQueueAdmin. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateQueue | Overloaded. This function creates a nonpersistent RAW queue.
public Method | DisablePropagationSchedule | Overloaded. Disables a propagation schedule.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | DropQueue | Overloaded. Drops an existing queue.
public Method | EnablePropagationSchedule | Overloaded. Enables a previously disabled propagation schedule.
public Method | EndInit | Ends the initialization of an OracleQueueAdmin. The initialization occurs at run time.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSubscribers | Gets the subscribers of multiconsumer queue.
public Method | GrantQueuePrivilege | Overloaded. Grants privileges on a queue to users and roles.
public Method | GrantSystemPrivilege | Overloaded. Grants Oracle Streams AQ system privileges to users and roles.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ReadQueueProperties | Reads options for a queue specified in the QueueName property from a server. The queue has to be already created.
public Method | RemoveSubscriber | Overloaded. Removes a subscriber from the queue.
public Method | RevokeQueuePrivilege | Revokes privileges on a queue from users and roles. The privileges are Enqueue or Dequeue.
public Method | RevokeSystemPrivilege | Overloaded. Revokes Oracle Streams AQ system privileges from users and roles.
public Method | SchedulePropagation | Overloaded. Schedules propagation of messages from a queue to a destination identified by a specific database link.
public Method | StartDequeue | Enables the specified queue for dequeuing.
public Method | StartEnqueue | Enables the specified queue for enqueuing.
public Method | StartQueue | Overloaded. Enables the specified queue for enqueuing or dequeuing.
public Method | StopDequeue | Overloaded. Disables dequeuing for the specified queue.
public Method | StopEnqueue | Overloaded. Disables enqueuing for the specified queue.
public Method | StopQueue | Overloaded. Disables enqueuing or dequeuing on the specified queue.
public Method | UnschedulePropagation | Overloaded. Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.
public Method | VerifyQueueTypes | Overloaded. Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueAdmin Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : OracleQueueAdmin Constructor

Initializes a new instance of the OracleQueueAdmin class.

Overload List

Overload | Description
OracleQueueAdmin Constructor() | Initializes a new instance of the OracleQueueAdmin class.
OracleQueueAdmin Constructor(String) | Initializes a new instance of the OracleQueueAdmin class.
OracleQueueAdmin Constructor(String,String) | Initializes a new instance of the OracleQueueAdmin class.
OracleQueueAdmin Constructor(String,OracleConnection) | Initializes a new instance of the OracleQueueAdmin class.
OracleQueueAdmin Constructor(String,String,OracleConnection) | Initializes a new instance of the OracleQueueAdmin class.
OracleQueueAdmin Constructor(String,String,OracleQueueOptions,OracleConnection) | Initializes a new instance of the OracleQueueAdmin class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor()

Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueAdmin()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor(String)

queueName
The name of the queue.
Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueName As String _
)
C#
public OracleQueueAdmin(
   string queueName
)

Parameters

queueName
The name of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor(String,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor(String,String)

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.
Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueName As String, _
   ByVal queueTableName As String _
)
C#
public OracleQueueAdmin(
   string queueName,
   string queueTableName
)

Parameters

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor(String,OracleConnection)

queueName
The name of the queue.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueueAdmin(
   string queueName,
   OracleConnection connection
)

Parameters

queueName
The name of the queue.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor(String,String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor(String,String,OracleConnection)

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueName As String, _
   ByVal queueTableName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueueAdmin(
   string queueName,
   string queueTableName,
   OracleConnection connection
)

Parameters

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Constructor(String,String,OracleQueueOptions,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > OracleQueueAdmin Constructor : OracleQueueAdmin Constructor(String,String,OracleQueueOptions,OracleConnection)

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.
options
OracleQueueOptions that are used upon creation.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Initializes a new instance of the OracleQueueAdmin class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueName As String, _
   ByVal queueTableName As String, _
   ByVal options As OracleQueueOptions, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueueAdmin(
   string queueName,
   string queueTableName,
   OracleQueueOptions options,
   OracleConnection connection
)

Parameters

queueName
The name of the queue.
queueTableName
The name of queue table, to which the queue will belong.
options
OracleQueueOptions that are used upon creation.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAdmin Class

For a list of all members of this type, see OracleQueueAdmin members.

Public Methods

 | Name | Description
public Method | AddSubscriber | Overloaded. Adds a subscriber to the queue.
public Method | AlterComment | Changes the OracleQueueOptions.Comment property of the Options object.
public Method | AlterMaxRetries | Sets the OracleQueueOptions.MaxRetries property of Options.
public Method | AlterPropagationSchedule | Overloaded. Alters parameters of the schedule by which messages are propagated.
public Method | AlterQueue | Alters existing properties of a queue.
public Method | AlterRetentionTime | Sets the OracleQueueOptions.RetentionTime property of OracleQueueAdmin.Options.
public Method | AlterRetryDelay | Sets the OracleQueueOptions.RetryDelay property of OracleQueueAdmin.Options.
public Method | AlterSubscriber | Overloaded. Alters existing properties of a subscriber to a specified queue.
public Method | BeginInit | Begins the initialization of an OracleQueueAdmin. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateQueue | Overloaded. This function creates a nonpersistent RAW queue.
public Method | DisablePropagationSchedule | Overloaded. Disables a propagation schedule.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | DropQueue | Overloaded. Drops an existing queue.
public Method | EnablePropagationSchedule | Overloaded. Enables a previously disabled propagation schedule.
public Method | EndInit | Ends the initialization of an OracleQueueAdmin. The initialization occurs at run time.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetSubscribers | Gets the subscribers of multiconsumer queue.
public Method | GrantQueuePrivilege | Overloaded. Grants privileges on a queue to users and roles.
public Method | GrantSystemPrivilege | Overloaded. Grants Oracle Streams AQ system privileges to users and roles.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | ReadQueueProperties | Reads options for a queue specified in the QueueName property from a server. The queue has to be already created.
public Method | RemoveSubscriber | Overloaded. Removes a subscriber from the queue.
public Method | RevokeQueuePrivilege | Revokes privileges on a queue from users and roles. The privileges are Enqueue or Dequeue.
public Method | RevokeSystemPrivilege | Overloaded. Revokes Oracle Streams AQ system privileges from users and roles.
public Method | SchedulePropagation | Overloaded. Schedules propagation of messages from a queue to a destination identified by a specific database link.
public Method | StartDequeue | Enables the specified queue for dequeuing.
public Method | StartEnqueue | Enables the specified queue for enqueuing.
public Method | StartQueue | Overloaded. Enables the specified queue for enqueuing or dequeuing.
public Method | StopDequeue | Overloaded. Disables dequeuing for the specified queue.
public Method | StopEnqueue | Overloaded. Disables enqueuing for the specified queue.
public Method | StopQueue | Overloaded. Disables enqueuing or dequeuing on the specified queue.
public Method | UnschedulePropagation | Overloaded. Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.
public Method | VerifyQueueTypes | Overloaded. Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.
Top

See Also

Reference

OracleQueueAdmin Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AddSubscriber Method

Adds a subscriber to the queue.

Overload List

Overload | Description
AddSubscriber(OracleQueueAgent) | Adds a subscriber to the queue.
AddSubscriber(OracleQueueAgent,String) | Adds a subscriber to the queue.
AddSubscriber(OracleQueueAgent,String,String) | Adds a subscriber to the queue.
AddSubscriber(OracleQueueAgent,String,String,Boolean) | Adds a subscriber to the queue.
AddSubscriber(OracleQueueAgent,String,String,Boolean,OracleQueueDeliveryMode) | Adds a subscriber to the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber(OracleQueueAgent) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AddSubscriber Method : AddSubscriber(OracleQueueAgent) Method

subscriber
Agent on whose behalf the subscription is being defined.
Adds a subscriber to the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddSubscriber( _
   ByVal subscriber As OracleQueueAgent _
)
C#
public void AddSubscriber(
   OracleQueueAgent subscriber
)

Parameters

subscriber
Agent on whose behalf the subscription is being defined.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber(OracleQueueAgent,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AddSubscriber Method : AddSubscriber(OracleQueueAgent,String) Method

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
Adds a subscriber to the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddSubscriber( _
   ByVal subscriber As OracleQueueAgent, _
   ByVal rule As String _
)
C#
public void AddSubscriber(
   OracleQueueAgent subscriber,
   string rule
)

Parameters

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber(OracleQueueAgent,String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AddSubscriber Method : AddSubscriber(OracleQueueAgent,String,String) Method

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.
Adds a subscriber to the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddSubscriber( _
   ByVal subscriber As OracleQueueAgent, _
   ByVal rule As String, _
   ByVal transformation As String _
)
C#
public void AddSubscriber(
   OracleQueueAgent subscriber,
   string rule,
   string transformation
)

Parameters

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber(OracleQueueAgent,String,String,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AddSubscriber Method : AddSubscriber(OracleQueueAgent,String,String,Boolean) Method

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.
queueToQueue
If TRUE, propagation is from queue to queue. Supported only in Oracle 10.2 and greater.
Adds a subscriber to the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddSubscriber( _
   ByVal subscriber As OracleQueueAgent, _
   ByVal rule As String, _
   ByVal transformation As String, _
   ByVal queueToQueue As Boolean _
)
C#
public void AddSubscriber(
   OracleQueueAgent subscriber,
   string rule,
   string transformation,
   bool queueToQueue
)

Parameters

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.
queueToQueue
If TRUE, propagation is from queue to queue. Supported only in Oracle 10.2 and greater.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSubscriber(OracleQueueAgent,String,String,Boolean,OracleQueueDeliveryMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AddSubscriber Method : AddSubscriber(OracleQueueAgent,String,String,Boolean,OracleQueueDeliveryMode) Method

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.
queueToQueue
If TRUE, propagation is from queue to queue. Supported only in Oracle 10.2 and greater.
deliveryMode
Delivery mode of the messages the subscriber is interested in. Supported only in Oracle 10.2 and higher.
Adds a subscriber to the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddSubscriber( _
   ByVal subscriber As OracleQueueAgent, _
   ByVal rule As String, _
   ByVal transformation As String, _
   ByVal queueToQueue As Boolean, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public void AddSubscriber(
   OracleQueueAgent subscriber,
   string rule,
   string transformation,
   bool queueToQueue,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

subscriber
Agent on whose behalf the subscription is being defined.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. A rule is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message. The source type of the transformation must match the type of the queue. If the subscriber is remote, the transformation is applied before propagation to the remote queue.
queueToQueue
If TRUE, propagation is from queue to queue. Supported only in Oracle 10.2 and greater.
deliveryMode
Delivery mode of the messages the subscriber is interested in. Supported only in Oracle 10.2 and higher.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterComment Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterComment Method

comment
A user-defined string comment.
Changes the OracleQueueOptions.Comment property of the Options object.

Syntax

Visual Basic (Declaration)
Public Sub AlterComment( _
   ByVal comment As String _
)
C#
public void AlterComment(
   string comment
)

Parameters

comment
A user-defined string comment.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
OracleQueueOptions Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterMaxRetries Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterMaxRetries Method

maxRetries
The number of times a dequeue with the OracleQueueDequeueMode.Remove mode can be attempted on a message.
Sets the OracleQueueOptions.MaxRetries property of Options.

Syntax

Visual Basic (Declaration)
Public Sub AlterMaxRetries( _
   ByVal maxRetries As Integer _
)
C#
public void AlterMaxRetries(
   int maxRetries
)

Parameters

maxRetries
The number of times a dequeue with the OracleQueueDequeueMode.Remove mode can be attempted on a message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterPropagationSchedule Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterPropagationSchedule Method

Alters parameters of the schedule by which messages are propagated.

Overload List

Overload | Description
AlterPropagationSchedule(String,Double,String,Double) | Alters parameters of the schedule by which messages are propagated.
AlterPropagationSchedule(String,Double,String,Double,String) | Alters parameters of the schedule by which messages are propagated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterPropagationSchedule(String,Double,String,Double) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AlterPropagationSchedule Method : AlterPropagationSchedule(String,Double,String,Double) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, then the default domain name is used.
duration
Duration of the propagation window in seconds.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is NULL, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued.
Alters parameters of the schedule by which messages are propagated.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AlterPropagationSchedule( _
   ByVal destination As String, _
   ByVal duration As Double, _
   ByVal nextTime As String, _
   ByVal latency As Double _
)
C#
public void AlterPropagationSchedule(
   string destination,
   double duration,
   string nextTime,
   double latency
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, then the default domain name is used.
duration
Duration of the propagation window in seconds.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is NULL, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterPropagationSchedule(String,Double,String,Double,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AlterPropagationSchedule Method : AlterPropagationSchedule(String,Double,String,Double,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
duration
Duration of the propagation window in seconds.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is NULL, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.
Alters parameters of the schedule by which messages are propagated.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AlterPropagationSchedule( _
   ByVal destination As String, _
   ByVal duration As Double, _
   ByVal nextTime As String, _
   ByVal latency As Double, _
   ByVal destinationQueue As String _
)
C#
public void AlterPropagationSchedule(
   string destination,
   double duration,
   string nextTime,
   double latency,
   string destinationQueue
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
duration
Duration of the propagation window in seconds.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is NULL, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterQueue Method

maxRetries
Limits the number of times a dequeue with OracleQueueDequeueMode.Remove mode can be attempted on a message. The maximum value of maxRetries is 2^31 -1. If this parameter less than zero, it is ignored.
retryDelay
Delay time in seconds before this message is scheduled for processing again after an application rollback. If this parameter less than zero, it is ignored.
retentionTime
Retention time in seconds for which a message is retained in the queue table after being dequeued. If this parameter less than zero, it is ignored.
comment
User-specified description of the queue. If this parameter is null or is string.Empty, it is ignored.
Alters existing properties of a queue.

Syntax

Visual Basic (Declaration)
Public Sub AlterQueue( _
   ByVal maxRetries As Integer, _
   ByVal retryDelay As Double, _
   ByVal retentionTime As Double, _
   ByVal comment As String _
)
C#
public void AlterQueue(
   int maxRetries,
   double retryDelay,
   double retentionTime,
   string comment
)

Parameters

maxRetries
Limits the number of times a dequeue with OracleQueueDequeueMode.Remove mode can be attempted on a message. The maximum value of maxRetries is 2^31 -1. If this parameter less than zero, it is ignored.
retryDelay
Delay time in seconds before this message is scheduled for processing again after an application rollback. If this parameter less than zero, it is ignored.
retentionTime
Retention time in seconds for which a message is retained in the queue table after being dequeued. If this parameter less than zero, it is ignored.
comment
User-specified description of the queue. If this parameter is null or is string.Empty, it is ignored.

Remarks

The parameters OracleQueueOptions.MaxRetries, OracleQueueOptions.RetentionTime, and OracleQueueOptions.RetryDelay are not supported for nonpersistent queues. Note that maxRetries and retryDelay are supported for all single consumer queues and 8.1-compatible or higher multiconsumer queues but not for 8.0-compatible multiconsumer queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
AlterMaxRetries Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterRetentionTime Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterRetentionTime Method

retentionTime
Number of seconds for which a message is retained in the queue table after being dequeued from the queue. 0 for no retention.
Sets the OracleQueueOptions.RetentionTime property of OracleQueueAdmin.Options.

Syntax

Visual Basic (Declaration)
Public Sub AlterRetentionTime( _
   ByVal retentionTime As Double _
)
C#
public void AlterRetentionTime(
   double retentionTime
)

Parameters

retentionTime
Number of seconds for which a message is retained in the queue table after being dequeued from the queue. 0 for no retention.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterRetryDelay Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterRetryDelay Method

retryDelay
Delay time, in seconds, before this message is scheduled for processing again after an application rollback. If 0, the message will be scheduled as soon as possible.
Sets the OracleQueueOptions.RetryDelay property of OracleQueueAdmin.Options.

Syntax

Visual Basic (Declaration)
Public Sub AlterRetryDelay( _
   ByVal retryDelay As Double _
)
C#
public void AlterRetryDelay(
   double retryDelay
)

Parameters

retryDelay
Delay time, in seconds, before this message is scheduled for processing again after an application rollback. If 0, the message will be scheduled as soon as possible.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterSubscriber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : AlterSubscriber Method

Alters existing properties of a subscriber to a specified queue.

Overload List

Overload | Description
AlterSubscriber(String,String,String,String) | Alters existing properties of a subscriber to the specified queue.
AlterSubscriber(OracleQueueAgent,String,String) | Alters existing properties of a subscriber to the specified queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterSubscriber(String,String,String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AlterSubscriber Method : AlterSubscriber(String,String,String,String) Method

name
Subscriber's name.
address
Protocol-specific address of the subscriber. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. The rule parameter cannot exceed 4000 characters. To eliminate the rule, set the rule parameter to NULL.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message.
Alters existing properties of a subscriber to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AlterSubscriber( _
   ByVal name As String, _
   ByVal address As String, _
   ByVal rule As String, _
   ByVal transformation As String _
)
C#
public void AlterSubscriber(
   string name,
   string address,
   string rule,
   string transformation
)

Parameters

name
Subscriber's name.
address
Protocol-specific address of the subscriber. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. The rule parameter cannot exceed 4000 characters. To eliminate the rule, set the rule parameter to NULL.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterSubscriber(OracleQueueAgent,String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > AlterSubscriber Method : AlterSubscriber(OracleQueueAgent,String,String) Method

subscriber
Agent on whose behalf the subscription is being altered.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. The rule parameter cannot exceed 4000 characters. To eliminate the rule, set the rule parameter to NULL.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message.
Alters existing properties of a subscriber to the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AlterSubscriber( _
   ByVal subscriber As OracleQueueAgent, _
   ByVal rule As String, _
   ByVal transformation As String _
)
C#
public void AlterSubscriber(
   OracleQueueAgent subscriber,
   string rule,
   string transformation
)

Parameters

subscriber
Agent on whose behalf the subscription is being altered.
rule
A conditional expression based on the message properties, the message data properties and PL/SQL functions. The rule parameter cannot exceed 4000 characters. To eliminate the rule, set the rule parameter to NULL.
transformation
Specifies a transformation that will be applied when this subscriber dequeues the message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : BeginInit Method

Begins the initialization of an OracleQueueAdmin. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
C#
public void BeginInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : CreateQueue Method

This function creates a nonpersistent RAW queue.

Overload List

Overload | Description
CreateQueue() | Creates a queue according to the current OracleQueueAdmin properties.
CreateQueue(String,Boolean,String,OracleConnection) | This function creates a nonpersistent RAW queue.
CreateQueue(String,String,OracleConnection) | Creates a database-stored queue with default options.
CreateQueue(String,String,OracleQueueOptions,OracleConnection) | Creates a database-stored queue with corresponding options.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > CreateQueue Method : CreateQueue() Method

Creates a queue according to the current OracleQueueAdmin properties.

Syntax

Visual Basic (Declaration)
Public Overloads Function CreateQueue() As OracleQueue
C#
public OracleQueue CreateQueue()

Return Value

OracleQueue instance, which corresponds to the queue created on a server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue(String,Boolean,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > CreateQueue Method : CreateQueue(String,Boolean,String,OracleConnection) Method

name
Unique name of the queue to be created.
multipleConsumers
FALSE means queues created in the table can only have one consumer for each message. TRUE means queues created in the table can have multiple consumers for each message.
comment
User-specified description of the queue.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.
This function creates a nonpersistent RAW queue.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateQueue( _
   ByVal name As String, _
   ByVal multipleConsumers As Boolean, _
   ByVal comment As String, _
   ByVal connection As OracleConnection _
) As OracleQueue
C#
public static OracleQueue CreateQueue(
   string name,
   bool multipleConsumers,
   string comment,
   OracleConnection connection
)

Parameters

name
Unique name of the queue to be created.
multipleConsumers
FALSE means queues created in the table can only have one consumer for each message. TRUE means queues created in the table can have multiple consumers for each message.
comment
User-specified description of the queue.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.

Return Value

Returns OracleQueue instance, which corresponds to the queue created on a server.

Remarks

The queue may be either single-consumer or multiconsumer queue. All queue names must be unique within a schema. The queues are created in a 8.1-compatible or higher system-created queue table (AQ$_MEM_SC or AQ$_MEM_MC) in the same schema as that specified by the queue name. After a queue is created, it can be enabled by calling StartQueue method. By default, the queue is created with both enqueue and dequeue disabled. You cannot dequeue from a nonpersistent queue. The only way to retrieve a message from a nonpersistent queue is by using the asynchrone notification mechanism. You cannot invoke the Listen call on a nonpersistent queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List
DropQueue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue(String,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > CreateQueue Method : CreateQueue(String,String,OracleConnection) Method

name
Unique name for the queue to be created.
queueTable
The name of queue table (existent on a server), which the queue will belong to.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.
Creates a database-stored queue with default options.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateQueue( _
   ByVal name As String, _
   ByVal queueTable As String, _
   ByVal connection As OracleConnection _
) As OracleQueue
C#
public static OracleQueue CreateQueue(
   string name,
   string queueTable,
   OracleConnection connection
)

Parameters

name
Unique name for the queue to be created.
queueTable
The name of queue table (existent on a server), which the queue will belong to.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue(String,String,OracleQueueOptions,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > CreateQueue Method : CreateQueue(String,String,OracleQueueOptions,OracleConnection) Method

name
Unique name for the queue to be created.
queueTable
The name of queue table (existent on a server), which the queue will belong to.
queueOptions
Options for creating a queue.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.
Creates a database-stored queue with corresponding options.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateQueue( _
   ByVal name As String, _
   ByVal queueTable As String, _
   ByVal queueOptions As OracleQueueOptions, _
   ByVal connection As OracleConnection _
) As OracleQueue
C#
public static OracleQueue CreateQueue(
   string name,
   string queueTable,
   OracleQueueOptions queueOptions,
   OracleConnection connection
)

Parameters

name
Unique name for the queue to be created.
queueTable
The name of queue table (existent on a server), which the queue will belong to.
queueOptions
Options for creating a queue.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.

Return Value

OracleQueue instance, which corresponds to the queue created on a server.

Remarks

All queue names must be unique within a schema. After a queue is created with CreateQueue, it can be enabled by calling StartQueue method. By default, the queue is created with both enqueue and dequeue disabled.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List
OracleQueueOptions Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DisablePropagationSchedule Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : DisablePropagationSchedule Method

Disables a propagation schedule.

Overload List

Overload | Description
DisablePropagationSchedule() | Disables the propagation schedule.
DisablePropagationSchedule(String) | Disables the propagation schedule.
DisablePropagationSchedule(String,String) | Disables the propagation schedule.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DisablePropagationSchedule() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > DisablePropagationSchedule Method : DisablePropagationSchedule() Method

Disables the propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DisablePropagationSchedule()
C#
public void DisablePropagationSchedule()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DisablePropagationSchedule(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > DisablePropagationSchedule Method : DisablePropagationSchedule(String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
Disables the propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DisablePropagationSchedule( _
   ByVal destination As String _
)
C#
public void DisablePropagationSchedule(
   string destination
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DisablePropagationSchedule(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > DisablePropagationSchedule Method : DisablePropagationSchedule(String,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.
Disables the propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DisablePropagationSchedule( _
   ByVal destination As String, _
   ByVal destinationQueue As String _
)
C#
public void DisablePropagationSchedule(
   string destination,
   string destinationQueue
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : DropQueue Method

Drops an existing queue.

Overload List

Overload | Description
DropQueue() | Drops the default queue.
DropQueue(String,OracleConnection) | Drops an existing queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > DropQueue Method : DropQueue() Method

Drops the default queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DropQueue()
C#
public void DropQueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueue(String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > DropQueue Method : DropQueue(String,OracleConnection) Method

name
Name of the queue that is to be dropped.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.
Drops an existing queue.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub DropQueue( _
   ByVal name As String, _
   ByVal connection As OracleConnection _
)
C#
public static void DropQueue(
   string name,
   OracleConnection connection
)

Parameters

name
Name of the queue that is to be dropped.
connection
An OracleConnection to the Oracle server, which provides the AQ functionality.

Remarks

DropQueue is not allowed unless StopQueue has been called to disable the queue for both enqueuing and dequeuing. All the queue data is deleted as part of the drop operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List
StopQueue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnablePropagationSchedule Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : EnablePropagationSchedule Method

Enables a previously disabled propagation schedule.

Overload List

Overload | Description
EnablePropagationSchedule() | Enables a previously disabled propagation schedule.
EnablePropagationSchedule(String) | Enables a previously disabled propagation schedule.
EnablePropagationSchedule(String,String) | Enables a previously disabled propagation schedule.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnablePropagationSchedule() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > EnablePropagationSchedule Method : EnablePropagationSchedule() Method

Enables a previously disabled propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub EnablePropagationSchedule()
C#
public void EnablePropagationSchedule()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnablePropagationSchedule(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > EnablePropagationSchedule Method : EnablePropagationSchedule(String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
Enables a previously disabled propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub EnablePropagationSchedule( _
   ByVal destination As String _
)
C#
public void EnablePropagationSchedule(
   string destination
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnablePropagationSchedule(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > EnablePropagationSchedule Method : EnablePropagationSchedule(String,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.
Enables a previously disabled propagation schedule.

Syntax

Visual Basic (Declaration)
Public Overloads Sub EnablePropagationSchedule( _
   ByVal destination As String, _
   ByVal destinationQueue As String _
)
C#
public void EnablePropagationSchedule(
   string destination,
   string destinationQueue
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : EndInit Method

Ends the initialization of an OracleQueueAdmin. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
C#
public void EndInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSubscribers Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : GetSubscribers Method

Gets the subscribers of multiconsumer queue.

Syntax

Visual Basic (Declaration)
Public Function GetSubscribers() As OracleQueueAgentCollection
C#
public OracleQueueAgentCollection GetSubscribers()

Return Value

Collection of subscribers.

Remarks

This function returns the subscribers to an 8.0-compatible multiconsumer queue in the OracleQueueAgentCollection. Each element of the collection is of type OracleQueueAgent. This functionality is provided for 8.1-compatible queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
OracleQueueAgent Class
AddSubscriber Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantQueuePrivilege Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : GrantQueuePrivilege Method

Grants privileges on a queue to users and roles.

Overload List

Overload | Description
GrantQueuePrivilege(OracleQueuePrivilege,String) | Grants privileges on a queue to users and roles.
GrantQueuePrivilege(OracleQueuePrivilege,String,Boolean) | Grants privileges on a queue to users and roles.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantQueuePrivilege(OracleQueuePrivilege,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantQueuePrivilege Method : GrantQueuePrivilege(OracleQueuePrivilege,String) Method

privilege
Queue privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
Grants privileges on a queue to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GrantQueuePrivilege( _
   ByVal privilege As OracleQueuePrivilege, _
   ByVal grantee As String _
)
C#
public void GrantQueuePrivilege(
   OracleQueuePrivilege privilege,
   string grantee
)

Parameters

privilege
Queue privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantQueuePrivilege(OracleQueuePrivilege,String,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantQueuePrivilege Method : GrantQueuePrivilege(OracleQueuePrivilege,String,Boolean) Method

privilege
Queue privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
grantOption
Specifies if the access privilege is granted with the GRANT option or not. If the privilege is granted with the GRANT option, the grantee is allowed to use this procedure to grant the access privilege to other users or roles, regardless of the ownership of the queue table.
Grants privileges on a queue to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GrantQueuePrivilege( _
   ByVal privilege As OracleQueuePrivilege, _
   ByVal grantee As String, _
   ByVal grantOption As Boolean _
)
C#
public void GrantQueuePrivilege(
   OracleQueuePrivilege privilege,
   string grantee,
   bool grantOption
)

Parameters

privilege
Queue privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
grantOption
Specifies if the access privilege is granted with the GRANT option or not. If the privilege is granted with the GRANT option, the grantee is allowed to use this procedure to grant the access privilege to other users or roles, regardless of the ownership of the queue table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantSystemPrivilege Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : GrantSystemPrivilege Method

Grants Oracle Streams AQ system privileges to users and roles.

Overload List

Overload | Description
GrantSystemPrivilege(OracleQueueSystemPrivilege,String) | Grants Oracle Streams AQ system privileges to users and roles.
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean) | Grants Oracle Streams AQ system privileges to users and roles.
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) | Grants Oracle Streams AQ system privileges to users and roles.
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean,OracleConnection) | Grants Oracle Streams AQ system privileges to users and roles.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantSystemPrivilege(OracleQueueSystemPrivilege,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantSystemPrivilege Method : GrantSystemPrivilege(OracleQueueSystemPrivilege,String) Method

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
Grants Oracle Streams AQ system privileges to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GrantSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String _
)
C#
public void GrantSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee
)

Parameters

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantSystemPrivilege Method : GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean) Method

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
adminOption
Specifies if the system privilege is granted with the ADMIN option or not. If the privilege is granted with the ADMIN option, the grantee is allowed to use this procedure to grant the system privilege to other users or roles.
Grants Oracle Streams AQ system privileges to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub GrantSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String, _
   ByVal adminOption As Boolean _
)
C#
public void GrantSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee,
   bool adminOption
)

Parameters

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
adminOption
Specifies if the system privilege is granted with the ADMIN option or not. If the privilege is granted with the ADMIN option, the grantee is allowed to use this procedure to grant the system privilege to other users or roles.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantSystemPrivilege Method : GrantSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) Method

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Grants Oracle Streams AQ system privileges to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub GrantSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String, _
   ByVal connection As OracleConnection _
)
C#
public static void GrantSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee,
   OracleConnection connection
)

Parameters

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > GrantSystemPrivilege Method : GrantSystemPrivilege(OracleQueueSystemPrivilege,String,Boolean,OracleConnection) Method

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
adminOption
Specifies if the system privilege is granted with the ADMIN option or not. If the privilege is granted with the ADMIN option, the grantee is allowed to use this procedure to grant the system privilege to other users or roles.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Grants Oracle Streams AQ system privileges to users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub GrantSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String, _
   ByVal adminOption As Boolean, _
   ByVal connection As OracleConnection _
)
C#
public static void GrantSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee,
   bool adminOption,
   OracleConnection connection
)

Parameters

privilege
The Oracle Streams AQ system privilege to grant.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
adminOption
Specifies if the system privilege is granted with the ADMIN option or not. If the privilege is granted with the ADMIN option, the grantee is allowed to use this procedure to grant the system privilege to other users or roles.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadQueueProperties Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : ReadQueueProperties Method

Reads options for a queue specified in the QueueName property from a server. The queue has to be already created.

Syntax

Visual Basic (Declaration)
Public Sub ReadQueueProperties()
C#
public void ReadQueueProperties()

Remarks

Sets Options and QueueTableName properties up.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveSubscriber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : RemoveSubscriber Method

Removes a subscriber from the queue.

Overload List

Overload | Description
RemoveSubscriber(String,String) | Removes a subscriber from the queue.
RemoveSubscriber(OracleQueueAgent) | Removes a subscriber from the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveSubscriber(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > RemoveSubscriber Method : RemoveSubscriber(String,String) Method

name
The name of the subscriber.
address
Protocol-specific address of the subscriber. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
Removes a subscriber from the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveSubscriber( _
   ByVal name As String, _
   ByVal address As String _
)
C#
public void RemoveSubscriber(
   string name,
   string address
)

Parameters

name
The name of the subscriber.
address
Protocol-specific address of the subscriber. If the protocol is zero, the address is of the form [schema.]queue[@dblink].

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RemoveSubscriber(OracleQueueAgent) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > RemoveSubscriber Method : RemoveSubscriber(OracleQueueAgent) Method

subscriber
Agent who is being removed.
Removes a subscriber from the queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub RemoveSubscriber( _
   ByVal subscriber As OracleQueueAgent _
)
C#
public void RemoveSubscriber(
   OracleQueueAgent subscriber
)

Parameters

subscriber
Agent who is being removed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RevokeQueuePrivilege Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : RevokeQueuePrivilege Method

privilege
Queue privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role. If the privilege has been propagated by the grantee through the GRANT option, the propagated privilege is also revoked.
Revokes privileges on a queue from users and roles. The privileges are Enqueue or Dequeue.

Syntax

Visual Basic (Declaration)
Public Sub RevokeQueuePrivilege( _
   ByVal privilege As OracleQueuePrivilege, _
   ByVal grantee As String _
)
C#
public void RevokeQueuePrivilege(
   OracleQueuePrivilege privilege,
   string grantee
)

Parameters

privilege
Queue privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role. If the privilege has been propagated by the grantee through the GRANT option, the propagated privilege is also revoked.

Remarks

To revoke a privilege, the revoker must be the original grantor of the privilege. The privileges propagated through the GRANT option are revoked if the grantor's privileges are revoked.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
GrantQueuePrivilege Method
GrantSystemPrivilege Method
RevokeSystemPrivilege Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RevokeSystemPrivilege Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : RevokeSystemPrivilege Method

Revokes Oracle Streams AQ system privileges from users and roles.

Overload List

Overload | Description
RevokeSystemPrivilege(OracleQueueSystemPrivilege,String) | Revokes Oracle Streams AQ system privileges from users and roles.
RevokeSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) | Revokes Oracle Streams AQ system privileges from users and roles.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RevokeSystemPrivilege(OracleQueueSystemPrivilege,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > RevokeSystemPrivilege Method : RevokeSystemPrivilege(OracleQueueSystemPrivilege,String) Method

privilege
The Oracle Streams AQ system privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
Revokes Oracle Streams AQ system privileges from users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub RevokeSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String _
)
C#
public void RevokeSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee
)

Parameters

privilege
The Oracle Streams AQ system privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RevokeSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > RevokeSystemPrivilege Method : RevokeSystemPrivilege(OracleQueueSystemPrivilege,String,OracleConnection) Method

privilege
The Oracle Streams AQ system privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
connection
A OracleConnection that represents the connection to an instance of Oracle server.
Revokes Oracle Streams AQ system privileges from users and roles.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub RevokeSystemPrivilege( _
   ByVal privilege As OracleQueueSystemPrivilege, _
   ByVal grantee As String, _
   ByVal connection As OracleConnection _
)
C#
public static void RevokeSystemPrivilege(
   OracleQueueSystemPrivilege privilege,
   string grantee,
   OracleConnection connection
)

Parameters

privilege
The Oracle Streams AQ system privilege to revoke.
grantee
Grantee(s). The grantee(s) can be a user, a role, or the PUBLIC role.
connection
A OracleConnection that represents the connection to an instance of Oracle server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : SchedulePropagation Method

Schedules propagation of messages from a queue to a destination identified by a specific database link.

Overload List

Overload | Description
SchedulePropagation() | Enables propagation schedule with default parameters.
SchedulePropagation(String) | Enables schedule for message propagation to the specified destination.
SchedulePropagation(String,DateTime) | Enables schedule for message propagation messages to the specified destination starting at the specified time.
SchedulePropagation(String,DateTime,Double) | Enables schedule for message propagation to the specified destination within the specified period.
SchedulePropagation(String,DateTime,Double,String) | Enables schedule for message propagation with the specified options.
SchedulePropagation(String,DateTime,Double,String,Double) | Enables schedule for message propagation with the specified options.
SchedulePropagation(String,DateTime,Double,String,Double,String) | Enables schedule for message propagation with the specified options.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation() Method

Enables propagation schedule with default parameters.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation()
C#
public void SchedulePropagation()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
Enables schedule for message propagation to the specified destination.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String _
)
C#
public void SchedulePropagation(
   string destination
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String,DateTime) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String,DateTime) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
Enables schedule for message propagation messages to the specified destination starting at the specified time.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String, _
   ByVal startTime As Date _
)
C#
public void SchedulePropagation(
   string destination,
   DateTime startTime
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String,DateTime,Double) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String,DateTime,Double) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
Enables schedule for message propagation to the specified destination within the specified period.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String, _
   ByVal startTime As Date, _
   ByVal duration As Double _
)
C#
public void SchedulePropagation(
   string destination,
   DateTime startTime,
   double duration
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String,DateTime,Double,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String,DateTime,Double,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.
Enables schedule for message propagation with the specified options.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String, _
   ByVal startTime As Date, _
   ByVal duration As Double, _
   ByVal nextTime As String _
)
C#
public void SchedulePropagation(
   string destination,
   DateTime startTime,
   double duration,
   string nextTime
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String,DateTime,Double,String,Double) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String,DateTime,Double,String,Double) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued. If this value is negative or not set, the default value is 60.
Enables schedule for message propagation with the specified options.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String, _
   ByVal startTime As Date, _
   ByVal duration As Double, _
   ByVal nextTime As String, _
   ByVal latency As Double _
)
C#
public void SchedulePropagation(
   string destination,
   DateTime startTime,
   double duration,
   string nextTime,
   double latency
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued. If this value is negative or not set, the default value is 60.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchedulePropagation(String,DateTime,Double,String,Double,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > SchedulePropagation Method : SchedulePropagation(String,DateTime,Double,String,Double,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued. If this value is negative or not set, the default value is 60.
destinationQueue
The name of the target queue to which messages are to be propagated in the form of a dblink.
Enables schedule for message propagation with the specified options.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SchedulePropagation( _
   ByVal destination As String, _
   ByVal startTime As Date, _
   ByVal duration As Double, _
   ByVal nextTime As String, _
   ByVal latency As Double, _
   ByVal destinationQueue As String _
)
C#
public void SchedulePropagation(
   string destination,
   DateTime startTime,
   double duration,
   string nextTime,
   double latency,
   string destinationQueue
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
startTime
Initial start time for the propagation window for messages from the source queue to the destination.
duration
Duration of the propagation window in seconds. A negative value means the propagation window is forever or until the propagation is unscheduled.
nextTime
Date function to compute the start of the next propagation window from the end of the current window. If this value is null, propagation is stopped at the end of the current window.
latency
Maximum wait, in seconds, in the propagation window for a message to be propagated after it is enqueued. If this value is negative or not set, the default value is 60.
destinationQueue
The name of the target queue to which messages are to be propagated in the form of a dblink.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartDequeue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StartDequeue Method

Enables the specified queue for dequeuing.

Syntax

Visual Basic (Declaration)
Public Sub StartDequeue()
C#
public void StartDequeue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartEnqueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StartEnqueue Method

Enables the specified queue for enqueuing.

Syntax

Visual Basic (Declaration)
Public Sub StartEnqueue()
C#
public void StartEnqueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
StartDequeue Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StartQueue Method

Enables the specified queue for enqueuing or dequeuing.

Overload List

Overload | Description
StartQueue() | Enables the specified queue for both enqueuing and dequeuing.
StartQueue(Boolean,Boolean) | Enables enqueuing, dequeuing or both for the current queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartQueue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StartQueue Method : StartQueue() Method

Enables the specified queue for both enqueuing and dequeuing.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StartQueue()
C#
public void StartQueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StartQueue(Boolean,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StartQueue Method : StartQueue(Boolean,Boolean) Method

enqueue
Specifies whether Enqueue should be enabled on this queue. true means enable Enqueue. false means do not alter the current setting.
dequeue
Specifies whether Dequeue should be enabled on this queue. true means enable Dequeue. false means do not alter the current setting.
Enables enqueuing, dequeuing or both for the current queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StartQueue( _
   ByVal enqueue As Boolean, _
   ByVal dequeue As Boolean _
)
C#
public void StartQueue(
   bool enqueue,
   bool dequeue
)

Parameters

enqueue
Specifies whether Enqueue should be enabled on this queue. true means enable Enqueue. false means do not alter the current setting.
dequeue
Specifies whether Dequeue should be enabled on this queue. true means enable Dequeue. false means do not alter the current setting.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopDequeue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StopDequeue Method

Disables dequeuing for the specified queue.

Overload List

Overload | Description
StopDequeue() | Disables dequeuing for the specified queue.
StopDequeue(Boolean) | Disables dequeuing for the specified queue, allowing to wait for the end of all outstanding transactions.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopDequeue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopDequeue Method : StopDequeue() Method

Disables dequeuing for the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopDequeue()
C#
public void StopDequeue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopDequeue(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopDequeue Method : StopDequeue(Boolean) Method

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.
Disables dequeuing for the specified queue, allowing to wait for the end of all outstanding transactions.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopDequeue( _
   ByVal wait As Boolean _
)
C#
public void StopDequeue(
   bool wait
)

Parameters

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopEnqueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StopEnqueue Method

Disables enqueuing for the specified queue.

Overload List

Overload | Description
StopEnqueue() | Disables enqueuing for the specified queue.
StopEnqueue(Boolean) | Disables enqueuing for the specified queue, allowing to wait for the end of all outstanding transactions.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopEnqueue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopEnqueue Method : StopEnqueue() Method

Disables enqueuing for the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopEnqueue()
C#
public void StopEnqueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopEnqueue(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopEnqueue Method : StopEnqueue(Boolean) Method

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.
Disables enqueuing for the specified queue, allowing to wait for the end of all outstanding transactions.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopEnqueue( _
   ByVal wait As Boolean _
)
C#
public void StopEnqueue(
   bool wait
)

Parameters

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : StopQueue Method

Disables enqueuing or dequeuing on the specified queue.

Overload List

Overload | Description
StopQueue() | Disables enqueuing and dequeuing on the specified queue.
StopQueue(Boolean) | Disables enqueuing and dequeuing for the specified queue, allowing to wait for the end of all outstanding transactions.
StopQueue(Boolean,Boolean,Boolean) | Disables enqueuing, dequeuing, or both for the specified queue, allowing to wait for the end of all outstanding transactions.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopQueue() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopQueue Method : StopQueue() Method

Disables enqueuing and dequeuing on the specified queue.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopQueue()
C#
public void StopQueue()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopQueue(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopQueue Method : StopQueue(Boolean) Method

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.
Disables enqueuing and dequeuing for the specified queue, allowing to wait for the end of all outstanding transactions.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopQueue( _
   ByVal wait As Boolean _
)
C#
public void StopQueue(
   bool wait
)

Parameters

wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StopQueue(Boolean,Boolean,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > StopQueue Method : StopQueue(Boolean,Boolean,Boolean) Method

enqueue
Specifies whether Enqueue should be disabled on this queue. true means disable Enqueue. false means do not alter the current setting.
dequeue
Specifies whether Dequeue should be disabled on this queue. true means disable Dequeue. false means do not alter the current setting.
wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.
Disables enqueuing, dequeuing, or both for the specified queue, allowing to wait for the end of all outstanding transactions.

Syntax

Visual Basic (Declaration)
Public Overloads Sub StopQueue( _
   ByVal enqueue As Boolean, _
   ByVal dequeue As Boolean, _
   ByVal wait As Boolean _
)
C#
public void StopQueue(
   bool enqueue,
   bool dequeue,
   bool wait
)

Parameters

enqueue
Specifies whether Enqueue should be disabled on this queue. true means disable Enqueue. false means do not alter the current setting.
dequeue
Specifies whether Dequeue should be disabled on this queue. true means disable Dequeue. false means do not alter the current setting.
wait
Specifies whether to wait for the completion of outstanding transactions. true means wait if there are any outstanding transactions. In this state no new transactions are allowed to enqueue to or dequeue from this queue. false means return immediately either with a success or an error.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnschedulePropagation Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : UnschedulePropagation Method

Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.

Overload List

Overload | Description
UnschedulePropagation() | Unschedules previously scheduled propagation of messages.
UnschedulePropagation(String) | Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.
UnschedulePropagation(String,String) | Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnschedulePropagation() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > UnschedulePropagation Method : UnschedulePropagation() Method

Unschedules previously scheduled propagation of messages.

Syntax

Visual Basic (Declaration)
Public Overloads Sub UnschedulePropagation()
C#
public void UnschedulePropagation()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnschedulePropagation(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > UnschedulePropagation Method : UnschedulePropagation(String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.

Syntax

Visual Basic (Declaration)
Public Overloads Sub UnschedulePropagation( _
   ByVal destination As String _
)
C#
public void UnschedulePropagation(
   string destination
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnschedulePropagation(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > UnschedulePropagation Method : UnschedulePropagation(String,String) Method

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.
Unschedules previously scheduled propagation of messages from a queue to a destination identified by a specific database link.

Syntax

Visual Basic (Declaration)
Public Overloads Sub UnschedulePropagation( _
   ByVal destination As String, _
   ByVal destinationQueue As String _
)
C#
public void UnschedulePropagation(
   string destination,
   string destinationQueue
)

Parameters

destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
destinationQueue
Name of the target queue to which messages are to be propagated in the form of a dblink.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
VerifyQueueTypes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : VerifyQueueTypes Method

Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.

Overload List

Overload | Description
VerifyQueueTypes(String) | Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.
VerifyQueueTypes(String,String) | Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
VerifyQueueTypes(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > VerifyQueueTypes Method : VerifyQueueTypes(String) Method

destQueueName
The name of the destination queue where messages are to be propagated, including the schema name. If the schema name is not specified, it defaults to the schema name of the user.
Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.

Syntax

Visual Basic (Declaration)
Public Overloads Function VerifyQueueTypes( _
   ByVal destQueueName As String _
) As Boolean
C#
public bool VerifyQueueTypes(
   string destQueueName
)

Parameters

destQueueName
The name of the destination queue where messages are to be propagated, including the schema name. If the schema name is not specified, it defaults to the schema name of the user.

Return Value

true if the source and destination queues have identical types; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
VerifyQueueTypes(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class > VerifyQueueTypes Method : VerifyQueueTypes(String,String) Method

destQueueName
The name of the destination queue where messages are to be propagated, including the schema name. If the schema name is not specified, it defaults to the schema name of the user.
destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.
Verifies that the source and destination queues have identical types. The source queue is the queue specified in QueueName.

Syntax

Visual Basic (Declaration)
Public Overloads Function VerifyQueueTypes( _
   ByVal destQueueName As String, _
   ByVal destination As String _
) As Boolean
C#
public bool VerifyQueueTypes(
   string destQueueName,
   string destination
)

Parameters

destQueueName
The name of the destination queue where messages are to be propagated, including the schema name. If the schema name is not specified, it defaults to the schema name of the user.
destination
Destination database link. Messages in the source queue for recipients at this destination are propagated. If it is NULL, the destination is the local database and messages are propagated to other queues in the local database. The length of this field is currently limited to 128 bytes, and if the name is not fully qualified, the default domain name is used.

Return Value

If there is no error, and if the source and destination queue types match, the result is true. If they do not match, the result is false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAdmin Class

For a list of all members of this type, see OracleQueueAdmin members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Options | Gets or sets queue options used for its creation.
public Property | QueueName | The name of the source queue.
public Property | QueueTableName | Gets or sets the name of the queue table, to which the queue belongs.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueAdmin Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : Connection Property

Gets or sets the OracleConnection to the Oracle server which provides AQ functionality.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The OracleConnection to the Oracle server which provides AQ functionality.

Remarks

It has to be set and opened before calling any function.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Options Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : Options Property

Gets or sets queue options used for its creation.

Syntax

Visual Basic (Declaration)
Public Property Options As OracleQueueOptions
C#
public OracleQueueOptions Options {get; set;}

Property Value

Queue options used for its creation.

Remarks

For existing queue this property is set implicitly when calling ReadQueueProperties method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
ReadQueueProperties Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : QueueName Property

The name of the source queue.

Syntax

Visual Basic (Declaration)
Public Property QueueName As String
C#
public string QueueName {get; set;}

Property Value

The name of the source queue. The default value is String.Empty.

Remarks

Has to be set before calling any method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueTableName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAdmin Class : QueueTableName Property

Gets or sets the name of the queue table, to which the queue belongs.

Syntax

Visual Basic (Declaration)
Public Property QueueTableName As String
C#
public string QueueTableName {get; set;}

Property Value

The name of the queue table, to which the queue belongs.

Remarks

The default value is String.Empty. For existing queue this property is set implicitly when calling ReadQueueProperties method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAdmin Class
OracleQueueAdmin Members
ReadQueueProperties Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgent Class

Identifies a producer or a consumer of a message.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueAgent

Syntax

Visual Basic (Declaration)
Public Class OracleQueueAgent
C#
public class OracleQueueAgent

Remarks

An example of using this class is available in Advanced Queuing Technology > A Simple Example of Point-to-Multipoint Messaging article.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueAgent Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgent Class

The following tables list the members exposed by OracleQueueAgent.

Public Constructors

 | Name | Description
public Constructor | OracleQueueAgent Constructor | Overloaded. Initializes a new instance of the OracleQueueAgent class.Initializes a new instance of the OracleQueueAgent class.
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets protocol-specific address of the recipient. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
public Property | Name | Gets or sets the name of a producer or consumer of a message.
public Property | Protocol | Gets or sets the protocol to interpret the address and propagate the message.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueAgent objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the OracleQueueAgent instance.
public Method | ToString | Returns the name of the current OracleQueueAgent object.
Top

See Also

Reference

OracleQueueAgent Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : OracleQueueAgent Constructor

Initializes a new instance of the OracleQueueAgent class.Initializes a new instance of the OracleQueueAgent class.

Overload List

Overload | Description
OracleQueueAgent Constructor() | Initializes a new instance of the OracleQueueAgent class.
OracleQueueAgent Constructor(String) | Initializes a new instance of the OracleQueueAgent class.
OracleQueueAgent Constructor(String,String) | Initializes a new instance of the OracleQueueAgent class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class > OracleQueueAgent Constructor : OracleQueueAgent Constructor()

Initializes a new instance of the OracleQueueAgent class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueAgent()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class > OracleQueueAgent Constructor : OracleQueueAgent Constructor(String)

name
The name of a producer or consumer of a message.
Initializes a new instance of the OracleQueueAgent class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public OracleQueueAgent(
   string name
)

Parameters

name
The name of a producer or consumer of a message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Constructor(String,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class > OracleQueueAgent Constructor : OracleQueueAgent Constructor(String,String)

name
The name of a producer or consumer of a message.
address
Protocol-specific address of the recipient. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
Initializes a new instance of the OracleQueueAgent class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal address As String _
)
C#
public OracleQueueAgent(
   string name,
   string address
)

Parameters

name
The name of a producer or consumer of a message.
address
Protocol-specific address of the recipient. If the protocol is zero, the address is of the form [schema.]queue[@dblink].

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgent Class

For a list of all members of this type, see OracleQueueAgent members.

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueAgent objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the OracleQueueAgent instance.
public Method | ToString | Returns the name of the current OracleQueueAgent object.
Top

See Also

Reference

OracleQueueAgent Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : Equals Method

obj
The object to be compared.
Compares two OracleQueueAgent objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared OracleQueueAgent objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : GetHashCode Method

Returns hash code of the OracleQueueAgent instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the OracleQueueAgent instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : ToString Method

Returns the name of the current OracleQueueAgent object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Name of the current OracleQueueAgent object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgent Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgent Class

For a list of all members of this type, see OracleQueueAgent members.

Public Properties

 | Name | Description
public Property | Address | Gets or sets protocol-specific address of the recipient. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
public Property | Name | Gets or sets the name of a producer or consumer of a message.
public Property | Protocol | Gets or sets the protocol to interpret the address and propagate the message.
Top

See Also

Reference

OracleQueueAgent Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Address Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : Address Property

Gets or sets protocol-specific address of the recipient. If the protocol is zero, the address is of the form [schema.]queue[@dblink].

Syntax

Visual Basic (Declaration)
Public Property Address As String
C#
public string Address {get; set;}

Property Value

The address of the recipient.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : Name Property

Gets or sets the name of a producer or consumer of a message.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Property Value

Agent name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Protocol Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgent Class : Protocol Property

Gets or sets the protocol to interpret the address and propagate the message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Protocol As Integer
C#
public int Protocol {get;}

Property Value

The protocol to interpret the address and propagate the message.

Remarks

This field is reserved for future usage and is always zero.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgent Class
OracleQueueAgent Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgentCollection Class

Represents a collection of OracleQueueAgent objects.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Data.Oracle.OracleQueueAgentCollection

Syntax

Visual Basic (Declaration)
Public Class OracleQueueAgentCollection
   Inherits System.Collections.CollectionBase
   Implements ICollection, IEnumerable, IList
C#
public class OracleQueueAgentCollection : System.Collections.CollectionBase, ICollection, IEnumerable, IList

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueAgentCollection Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgentCollection Class

The following tables list the members exposed by OracleQueueAgentCollection.

Public Constructors

 | Name | Description
public Constructor | OracleQueueAgentCollection Constructor | Overloaded. Initializes a new instance of the OracleQueueAgentCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets the OracleQueueAgent at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether an OracleQueueAgent object exists in the collection.
public Method | CopyTo | Copies OracleQueueAgent objects from the OracleQueueAgentCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the index of the OracleQueueAgent object in the collection.
public Method | Insert | Inserts an OracleQueueAgent into the collection at the specified index.
public Method | Remove | Removes the specified OracleQueueAgent object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleQueueAgentCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : OracleQueueAgentCollection Constructor

Initializes a new instance of the OracleQueueAgentCollection class.

Overload List

Overload | Description
OracleQueueAgentCollection Constructor() | Initializes a new instance of the OracleQueueAgentCollection class.
OracleQueueAgentCollection Constructor(OracleQueueAgent[]) | Initializes a new instance of the OracleQueueAgentCollection class with the specified array of OracleQueueAgent objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class > OracleQueueAgentCollection Constructor : OracleQueueAgentCollection Constructor()

Initializes a new instance of the OracleQueueAgentCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueAgentCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Constructor(OracleQueueAgent[])
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class > OracleQueueAgentCollection Constructor : OracleQueueAgentCollection Constructor(OracleQueueAgent[])

agents
The array of OracleQueueAgent objects used to initialize collection.
Initializes a new instance of the OracleQueueAgentCollection class with the specified array of OracleQueueAgent objects.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal agents() As OracleQueueAgent _
)
C#
public OracleQueueAgentCollection(
   OracleQueueAgent[] agents
)

Parameters

agents
The array of OracleQueueAgent objects used to initialize collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgentCollection Class

For a list of all members of this type, see OracleQueueAgentCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Gets a value indicating whether an OracleQueueAgent object exists in the collection.
public Method | CopyTo | Copies OracleQueueAgent objects from the OracleQueueAgentCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Gets the index of the OracleQueueAgent object in the collection.
public Method | Insert | Inserts an OracleQueueAgent into the collection at the specified index.
public Method | Remove | Removes the specified OracleQueueAgent object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleQueueAgentCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : Add Method

Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.

Overload List

Overload | Description
Add(OracleQueueAgent) | Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.
Add(String,String) | Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleQueueAgent) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class > Add Method : Add(OracleQueueAgent) Method

agent
The OracleQueueAgent to add.
Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal agent As OracleQueueAgent _
)
C#
public void Add(
   OracleQueueAgent agent
)

Parameters

agent
The OracleQueueAgent to add.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class > Add Method : Add(String,String) Method

name
The agent's name.
address
Protocol-specific address of the agent. If the protocol is zero, the address is of the form [schema.]queue[@dblink].
Adds the specified OracleQueueAgent to the OracleQueueAgentCollection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal name As String, _
   ByVal address As String _
)
C#
public void Add(
   string name,
   string address
)

Parameters

name
The agent's name.
address
Protocol-specific address of the agent. If the protocol is zero, the address is of the form [schema.]queue[@dblink].

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : Contains Method

agent
The agent to find.
Gets a value indicating whether an OracleQueueAgent object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal agent As OracleQueueAgent _
) As Boolean
C#
public bool Contains(
   OracleQueueAgent agent
)

Parameters

agent
The agent to find.

Return Value

true if the OracleQueueAgent is in the collection; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : CopyTo Method

arr
The array into which to copy the OracleQueueAgent objects.
index
The zero-based index of the array.
Copies OracleQueueAgent objects from the OracleQueueAgentCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal arr() As OracleQueueAgent, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   OracleQueueAgent[] arr,
   int index
)

Parameters

arr
The array into which to copy the OracleQueueAgent objects.
index
The zero-based index of the array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : IndexOf Method

agent
The OracleQueueAgent object to find.
Gets the index of the OracleQueueAgent object in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal agent As OracleQueueAgent _
) As Integer
C#
public int IndexOf(
   OracleQueueAgent agent
)

Parameters

agent
The OracleQueueAgent object to find.

Return Value

The index of the OracleQueueAgent object in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : Insert Method

index
The zero-based index where the agent is to be inserted within the collection.
agent
The OracleQueueAgent to add to the collection.
Inserts an OracleQueueAgent into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal agent As OracleQueueAgent _
)
C#
public void Insert(
   int index,
   OracleQueueAgent agent
)

Parameters

index
The zero-based index where the agent is to be inserted within the collection.
agent
The OracleQueueAgent to add to the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : Remove Method

agent
The OracleQueueAgent object to remove from the collection.
Removes the specified OracleQueueAgent object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal agent As OracleQueueAgent _
)
C#
public void Remove(
   OracleQueueAgent agent
)

Parameters

agent
The OracleQueueAgent object to remove from the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueAgentCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAgentCollection Class

For a list of all members of this type, see OracleQueueAgentCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets the OracleQueueAgent at the specified index.
Top

See Also

Reference

OracleQueueAgentCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueAgentCollection Class : Item Property

index
The zero-based index of the agent.
Gets the OracleQueueAgent at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As OracleQueueAgent
C#
public OracleQueueAgent this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the agent.

Property Value

The OracleQueueAgent at the specified index in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueAgentCollection Class
OracleQueueAgentCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDequeueOptions Class

Represents the options available for the dequeue operation.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueDequeueOptions

Syntax

Visual Basic (Declaration)
Public Class OracleQueueDequeueOptions
C#
public class OracleQueueDequeueOptions

Remarks

Specify these options via OracleQueue.DequeueOptions property for OracleQueue object that is used for dequeuing. For more information about advanced queuing technology and samples, refer to Advanced Queuing Technology article.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueDequeueOptions Members
Devart.Data.Oracle Namespace
OracleQueueEnqueueOptions Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDequeueOptions Class

The following tables list the members exposed by OracleQueueDequeueOptions.

Public Constructors

 | Name | Description
public Constructor | OracleQueueDequeueOptions Constructor | Overloaded. Initializes a new instance of the OracleQueueDequeueOptions class.
Top

Public Properties

 | Name | Description
public Property | ConsumerName | Gets or sets the name of the consumer.
public Property | Correlation | Specifies the correlation identifier of the message to be dequeued.
public Property | DeliveryMode | The dequeuer specifies the delivery mode of the messages it wishes to dequeue in the dequeue options.
public Property | DequeueCondition | A conditional expression based on the message properties, the message data properties, and PL/SQL functions.
public Property | DequeueMode | Gets or sets the behavior on dequeuing the message.
public Property | MessageId | Gets or sets the message identifier of the message to be dequeued.
public Property | Navigation | Specifies the position of the message that will be retrieved.
public Property | Transformation | Gets or sets the transformation that will be applied after dequeuing the message.
public Property | Visibility | Specifies whether the new message is dequeued as part of the current transaction.
public Property | WaitTimeout | Gets or sets the wait time in seconds if there is currently no message available which matches the search criteria.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueDequeueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the OracleQueueDequeueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueDequeueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : OracleQueueDequeueOptions Constructor

Initializes a new instance of the OracleQueueDequeueOptions class.

Overload List

Overload | Description
OracleQueueDequeueOptions Constructor() | Initializes a new instance of the OracleQueueDequeueOptions class with default settings.
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,String,String,String,OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueDequeueOptions class.
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,OracleQueueMessageId,String,String,String,OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueDequeueOptions class.
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,Byte[],String,String,String,OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueDequeueOptions class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class > OracleQueueDequeueOptions Constructor : OracleQueueDequeueOptions Constructor()

Initializes a new instance of the OracleQueueDequeueOptions class with default settings.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueDequeueOptions()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,String,String,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class > OracleQueueDequeueOptions Constructor : OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,String,String,String,OracleQueueDeliveryMode)

consumerName
The name of the consumer.
dequeueMode
The locking behavior associated with the dequeue.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The wait time in seconds.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation.
Initializes a new instance of the OracleQueueDequeueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal consumerName As String, _
   ByVal dequeueMode As OracleQueueDequeueMode, _
   ByVal navigation As OracleQueueNavigation, _
   ByVal visibility As OracleQueueVisibility, _
   ByVal waitTimeout As Integer, _
   ByVal correlation As String, _
   ByVal dequeueCondition As String, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueDequeueOptions(
   string consumerName,
   OracleQueueDequeueMode dequeueMode,
   OracleQueueNavigation navigation,
   OracleQueueVisibility visibility,
   int waitTimeout,
   string correlation,
   string dequeueCondition,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

consumerName
The name of the consumer.
dequeueMode
The locking behavior associated with the dequeue.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The wait time in seconds.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,OracleQueueMessageId,String,String,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class > OracleQueueDequeueOptions Constructor : OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,OracleQueueMessageId,String,String,String,OracleQueueDeliveryMode)

consumerName
The name of the consumer.
dequeueMode
The messages dequeuing behaviour.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The time in seconds to wait if there is currently no message available for dequeuing. -1 for unlimited wait time.
messageId
The message identifier of the message to be dequeued.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation. Specifies whether messages are persistent or buffered.
Initializes a new instance of the OracleQueueDequeueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal consumerName As String, _
   ByVal dequeueMode As OracleQueueDequeueMode, _
   ByVal navigation As OracleQueueNavigation, _
   ByVal visibility As OracleQueueVisibility, _
   ByVal waitTimeout As Integer, _
   ByVal messageId As OracleQueueMessageId, _
   ByVal correlation As String, _
   ByVal dequeueCondition As String, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueDequeueOptions(
   string consumerName,
   OracleQueueDequeueMode dequeueMode,
   OracleQueueNavigation navigation,
   OracleQueueVisibility visibility,
   int waitTimeout,
   OracleQueueMessageId messageId,
   string correlation,
   string dequeueCondition,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

consumerName
The name of the consumer.
dequeueMode
The messages dequeuing behaviour.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The time in seconds to wait if there is currently no message available for dequeuing. -1 for unlimited wait time.
messageId
The message identifier of the message to be dequeued.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation. Specifies whether messages are persistent or buffered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,Byte[],String,String,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class > OracleQueueDequeueOptions Constructor : OracleQueueDequeueOptions Constructor(String,OracleQueueDequeueMode,OracleQueueNavigation,OracleQueueVisibility,Int32,Byte[],String,String,String,OracleQueueDeliveryMode)

consumerName
The name of the consumer.
dequeueMode
The locking behavior associated with the dequeue.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The wait time in seconds.
messageId
The message identifier of the message to be dequeued.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation.
Initializes a new instance of the OracleQueueDequeueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal consumerName As String, _
   ByVal dequeueMode As OracleQueueDequeueMode, _
   ByVal navigation As OracleQueueNavigation, _
   ByVal visibility As OracleQueueVisibility, _
   ByVal waitTimeout As Integer, _
   ByVal messageId() As Byte, _
   ByVal correlation As String, _
   ByVal dequeueCondition As String, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueDequeueOptions(
   string consumerName,
   OracleQueueDequeueMode dequeueMode,
   OracleQueueNavigation navigation,
   OracleQueueVisibility visibility,
   int waitTimeout,
   byte[] messageId,
   string correlation,
   string dequeueCondition,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

consumerName
The name of the consumer.
dequeueMode
The locking behavior associated with the dequeue.
navigation
The position of the message that will be retrieved.
visibility
OracleQueueVisibility that is used upon creation.
waitTimeout
The wait time in seconds.
messageId
The message identifier of the message to be dequeued.
correlation
The correlation identifier of the message to be dequeued.
dequeueCondition
DequeueCondition that is used upon creation.
transformation
The transformation that will be applied after dequeuing the message.
deliveryMode
DeliveryMode that is used upon creation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDequeueOptions Class

For a list of all members of this type, see OracleQueueDequeueOptions members.

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueDequeueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the OracleQueueDequeueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueDequeueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : Equals Method

obj
The object to be compared.
Compares two OracleQueueDequeueOptions objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared OracleQueueDequeueOptions objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : GetHashCode Method

Returns hash code of the OracleQueueDequeueOptions instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the OracleQueueDequeueOptions instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : ToString Method

Gets the object's type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns "OracleQueueDequeueOptions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueOptions Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDequeueOptions Class

For a list of all members of this type, see OracleQueueDequeueOptions members.

Public Properties

 | Name | Description
public Property | ConsumerName | Gets or sets the name of the consumer.
public Property | Correlation | Specifies the correlation identifier of the message to be dequeued.
public Property | DeliveryMode | The dequeuer specifies the delivery mode of the messages it wishes to dequeue in the dequeue options.
public Property | DequeueCondition | A conditional expression based on the message properties, the message data properties, and PL/SQL functions.
public Property | DequeueMode | Gets or sets the behavior on dequeuing the message.
public Property | MessageId | Gets or sets the message identifier of the message to be dequeued.
public Property | Navigation | Specifies the position of the message that will be retrieved.
public Property | Transformation | Gets or sets the transformation that will be applied after dequeuing the message.
public Property | Visibility | Specifies whether the new message is dequeued as part of the current transaction.
public Property | WaitTimeout | Gets or sets the wait time in seconds if there is currently no message available which matches the search criteria.
Top

See Also

Reference

OracleQueueDequeueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ConsumerName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : ConsumerName Property

Gets or sets the name of the consumer.

Syntax

Visual Basic (Declaration)
Public Property ConsumerName As String
C#
public string ConsumerName {get; set;}

Property Value

The default value is null.

Remarks

Only those messages matching the consumer name are accessed. If a queue is not set up for multiple consumers, this field should be set to NULL.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Correlation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : Correlation Property

Specifies the correlation identifier of the message to be dequeued.

Syntax

Visual Basic (Declaration)
Public Property Correlation As String
C#
public string Correlation {get; set;}

Remarks

Special pattern matching characters, such as the percent sign (%) and the underscore (_) can be used. If more than one message satisfies the pattern, the order of dequeuing is undetermined.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeliveryMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : DeliveryMode Property

The dequeuer specifies the delivery mode of the messages it wishes to dequeue in the dequeue options.

Syntax

Visual Basic (Declaration)
Public Property DeliveryMode As OracleQueueDeliveryMode
C#
public OracleQueueDeliveryMode DeliveryMode {get; set;}

Property Value

The default value is OracleQueueDeliveryMode.Persistent.

Remarks

The message properties of the dequeued message indicate the delivery mode of the dequeued message. Array dequeue is only supported for buffered messages with an array size of '1'. Note: this property is used only for Oracle servers 10.2 and greater.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueCondition Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : DequeueCondition Property

A conditional expression based on the message properties, the message data properties, and PL/SQL functions.

Syntax

Visual Basic (Declaration)
Public Property DequeueCondition As String
C#
public string DequeueCondition {get; set;}

Remarks

A DequeueCondition is specified as a Boolean expression using syntax similar to the WHERE clause of a SQL query. This Boolean expression can include conditions on message properties, user data properties (object payloads only), and PL/SQL or SQL functions (as specified in the WHERE clause of a SQL query). To specify dequeue conditions on a message payload (object payload), use attributes of the object type in clauses. You must prefix each attribute with tab.user_data as a qualifier to indicate the specific column of the queue table that stores the payload. The DequeueCondition parameter cannot exceed 4000 characters. If more than one message satisfies the dequeue condition, the order of dequeuing is undetermined.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DequeueMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : DequeueMode Property

Gets or sets the behavior on dequeuing the message.

Syntax

Visual Basic (Declaration)
Public Property DequeueMode As OracleQueueDequeueMode
C#
public OracleQueueDequeueMode DequeueMode {get; set;}

Property Value

The default value is OracleQueueDequeueMode.Remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : MessageId Property

Gets or sets the message identifier of the message to be dequeued.

Syntax

Visual Basic (Declaration)
Public Property MessageId As OracleQueueMessageId
C#
public OracleQueueMessageId MessageId {get; set;}

Remarks

Only messages in the READY state are dequeued unless MessageId is specified.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Navigation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : Navigation Property

Specifies the position of the message that will be retrieved.

Syntax

Visual Basic (Declaration)
Public Property Navigation As OracleQueueNavigation
C#
public OracleQueueNavigation Navigation {get; set;}

Property Value

The default value is OracleQueueNavigation.NextMessage.

Remarks

First, the position is determined. Second, the search criterion is applied. Finally, the message is retrieved.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transformation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : Transformation Property

Gets or sets the transformation that will be applied after dequeuing the message.

Syntax

Visual Basic (Declaration)
Public Property Transformation As String
C#
public string Transformation {get; set;}

Remarks

The source type of the transformation must match the type of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Visibility Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : Visibility Property

Specifies whether the new message is dequeued as part of the current transaction.

Syntax

Visual Basic (Declaration)
Public Property Visibility As OracleQueueVisibility
C#
public OracleQueueVisibility Visibility {get; set;}

Property Value

One of the OracleQueueVisibility values. The default value is OracleQueueVisibility.OnCommit.

Remarks

The Visibility parameter is ignored when using the OracleQueueDequeueMode.Browse dequeue mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
WaitTimeout Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueDequeueOptions Class : WaitTimeout Property

Gets or sets the wait time in seconds if there is currently no message available which matches the search criteria.

Syntax

Visual Basic (Declaration)
Public Property WaitTimeout As Integer
C#
public int WaitTimeout {get; set;}

Property Value

The default value is -1 which means wait forever.

Remarks

If WaitTimeout less than 0, wait forever (by default). WaitTimeout 0 means do not wait at all; if there are no messages, an exception is raised.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueDequeueOptions Class
OracleQueueDequeueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueEnqueueOptions Class

Represents the options available for the enqueue operation.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueEnqueueOptions

Syntax

Visual Basic (Declaration)
Public Class OracleQueueEnqueueOptions
C#
public class OracleQueueEnqueueOptions

Remarks

Specify these options via OracleQueue.EnqueueOptions property for OracleQueue object that is used for enqueuing. For more information about advanced queuing technology and samples, refer to Advanced Queuing Technology article.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueEnqueueOptions Members
Devart.Data.Oracle Namespace
OracleQueueDequeueOptions Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueEnqueueOptions Class

The following tables list the members exposed by OracleQueueEnqueueOptions.

Public Constructors

 | Name | Description
public Constructor | OracleQueueEnqueueOptions Constructor | Overloaded. Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.
Top

Public Properties

 | Name | Description
public Property | DeliveryMode | The enqueuer specifies the delivery mode of the messages it wishes to enqueue in the enqueue options.
public Property | RelativeMessageId | Gets or sets the message identifier of the message which is referenced in the sequence deviation operation.
public Property | SequenceDeviation | Specifies whether the message being enqueued should be dequeued before other messages already in the queue.
public Property | Transformation | Gets or sets the transformation that will be applied before enqueuing the message.
public Property | Visibility | Gets or sets the transactional behavior of the enqueue request.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two Devart.Data.Oracle.OracleQueueEnqueueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current Devart.Data.Oracle.OracleQueueEnqueueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueEnqueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : OracleQueueEnqueueOptions Constructor

Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Overload List

Overload | Description
OracleQueueEnqueueOptions Constructor() | Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode) | Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,Byte[],OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode) | Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueMessageId,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode) | Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class > OracleQueueEnqueueOptions Constructor : OracleQueueEnqueueOptions Constructor()

Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueEnqueueOptions()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class > OracleQueueEnqueueOptions Constructor : OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)

visibility
The transactional behavior of the enqueue request.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.
Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visibility As OracleQueueVisibility, _
   ByVal sequenceDeviation As OracleQueueSequenceDeviation, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueEnqueueOptions(
   OracleQueueVisibility visibility,
   OracleQueueSequenceDeviation sequenceDeviation,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

visibility
The transactional behavior of the enqueue request.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,Byte[],OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class > OracleQueueEnqueueOptions Constructor : OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,Byte[],OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)

visibility
The transactional behavior of the enqueue request.
relativeMessageID
The message identifier of the message which is referenced in the sequence deviation operation.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.
Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visibility As OracleQueueVisibility, _
   ByVal relativeMessageID() As Byte, _
   ByVal sequenceDeviation As OracleQueueSequenceDeviation, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueEnqueueOptions(
   OracleQueueVisibility visibility,
   byte[] relativeMessageID,
   OracleQueueSequenceDeviation sequenceDeviation,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

visibility
The transactional behavior of the enqueue request.
relativeMessageID
The message identifier of the message which is referenced in the sequence deviation operation.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueMessageId,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class > OracleQueueEnqueueOptions Constructor : OracleQueueEnqueueOptions Constructor(OracleQueueVisibility,OracleQueueMessageId,OracleQueueSequenceDeviation,String,OracleQueueDeliveryMode)

visibility
The transactional behavior of the enqueue request.
relativeMessageID
The message identifier of the message which is referenced in the sequence deviation operation.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.
Initializes a new instance of the Devart.Data.Oracle.OracleQueueEnqueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visibility As OracleQueueVisibility, _
   ByVal relativeMessageID As OracleQueueMessageId, _
   ByVal sequenceDeviation As OracleQueueSequenceDeviation, _
   ByVal transformation As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueEnqueueOptions(
   OracleQueueVisibility visibility,
   OracleQueueMessageId relativeMessageID,
   OracleQueueSequenceDeviation sequenceDeviation,
   string transformation,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

visibility
The transactional behavior of the enqueue request.
relativeMessageID
The message identifier of the message which is referenced in the sequence deviation operation.
sequenceDeviation
OracleQueueSequenceDeviation that is used upon creation.
transformation
The transformation that will be applied before enqueuing the message.
deliveryMode
OracleQueueDeliveryMode that is used upon creation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueEnqueueOptions Class

For a list of all members of this type, see OracleQueueEnqueueOptions members.

Public Methods

 | Name | Description
public Method | Equals | Compares two Devart.Data.Oracle.OracleQueueEnqueueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current Devart.Data.Oracle.OracleQueueEnqueueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueEnqueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : Equals Method

obj
The object to be compared.
Compares two Devart.Data.Oracle.OracleQueueEnqueueOptions objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared Devart.Data.Oracle.OracleQueueEnqueueOptions objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : GetHashCode Method

Returns hash code of the current Devart.Data.Oracle.OracleQueueEnqueueOptions instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current Devart.Data.Oracle.OracleQueueEnqueueOptions instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : ToString Method

Gets the object's type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns "OracleQueueEnqueueOptions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueEnqueueOptions Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueEnqueueOptions Class

For a list of all members of this type, see OracleQueueEnqueueOptions members.

Public Properties

 | Name | Description
public Property | DeliveryMode | The enqueuer specifies the delivery mode of the messages it wishes to enqueue in the enqueue options.
public Property | RelativeMessageId | Gets or sets the message identifier of the message which is referenced in the sequence deviation operation.
public Property | SequenceDeviation | Specifies whether the message being enqueued should be dequeued before other messages already in the queue.
public Property | Transformation | Gets or sets the transformation that will be applied before enqueuing the message.
public Property | Visibility | Gets or sets the transactional behavior of the enqueue request.
Top

See Also

Reference

OracleQueueEnqueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeliveryMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : DeliveryMode Property

The enqueuer specifies the delivery mode of the messages it wishes to enqueue in the enqueue options.

Syntax

Visual Basic (Declaration)
Public Property DeliveryMode As OracleQueueDeliveryMode
C#
public OracleQueueDeliveryMode DeliveryMode {get; set;}

Property Value

The default value is OracleQueueDeliveryMode.Persistent.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RelativeMessageId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : RelativeMessageId Property

Gets or sets the message identifier of the message which is referenced in the sequence deviation operation.

Syntax

Visual Basic (Declaration)
Public Property RelativeMessageId As OracleQueueMessageId
C#
public OracleQueueMessageId RelativeMessageId {get; set;}

Remarks

This field is valid only if OracleQueueSequenceDeviation.Before is specified in SequenceDeviation property. This parameter is ignored if sequence deviation is not specified.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SequenceDeviation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : SequenceDeviation Property

Specifies whether the message being enqueued should be dequeued before other messages already in the queue.

Syntax

Visual Basic (Declaration)
Public Property SequenceDeviation As OracleQueueSequenceDeviation
C#
public OracleQueueSequenceDeviation SequenceDeviation {get; set;}

Property Value

One of the OracleQueueSequenceDeviation values.

Remarks

This property can be used to change the order of processing two messages. Specifying this property for a message introduces some restrictions for the delay and priority values that can be specified for this message. The delay of this message must be less than or equal to the delay of the message before which this message is to be enqueued. The priority of this message must be greater than or equal to the priority of the message before which this message is to be enqueued.

Note: the SequenceDeviation attribute has no effect in releases prior to Oracle Streams AQ 10g Release 1 (10.1) if OracleQueueTableOptions.MessageGrouping is set to Transactional. The sequence deviation feature is deprecated in Oracle Streams AQ 10g Release 2 (10.2).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transformation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : Transformation Property

Gets or sets the transformation that will be applied before enqueuing the message.

Syntax

Visual Basic (Declaration)
Public Property Transformation As String
C#
public string Transformation {get; set;}

Remarks

The return type of the transformation function must match the type of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Visibility Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueEnqueueOptions Class : Visibility Property

Gets or sets the transactional behavior of the enqueue request.

Syntax

Visual Basic (Declaration)
Public Property Visibility As OracleQueueVisibility
C#
public OracleQueueVisibility Visibility {get; set;}

Property Value

The default value is OracleQueueVisibility.OnCommit.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueEnqueueOptions Class
OracleQueueEnqueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessage Class

Represents queue messages.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueMessage

Syntax

Visual Basic (Declaration)
Public Class OracleQueueMessage
C#
public class OracleQueueMessage

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example demonstrates usage of OracleQueue, OracleQueueAdmin, OracleQueueTable, OracleQueueTableOptions, and Devart.Data.Oracle.OracleQueueMessage classes. For detailed description of advanced queuing and more samples, refer to the Advanced Queuing Technology article.
C#csharp Copy Code
static void Main(string[] args)
{
        using (OracleConnection oracleConnection = new OracleConnection(
                        "User Id=system;Password=manager;Server=ora;Direct=False;")) {
                oracleConnection.Open();
                OracleCommand oracleCommand = new OracleCommand(
                        "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
                        "mestext VARCHAR2(80));", oracleConnection);
                oracleCommand.ExecuteNonQuery();
                OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueTable.Options.PayloadTypeName = "message";
                oracleQueueTable.CreateQueueTable();
                OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
                        "QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueAdmin.CreateQueue();
                oracleQueueAdmin.StartQueue();
                OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleObject mes = new OracleObject("message", oracleConnection);
                mes["nickname"] = oracleConnection.UserId;
                mes["mestext"] = "Hello, world!";
                oracleEnqueueQueue.Enqueue(mes);
                OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
                if (msg != null && msg.ObjectPayload != null) {
                        Console.WriteLine(msg.ObjectPayload["nickname"]);
                        Console.WriteLine(msg.ObjectPayload["mestext"]);
                }
                oracleQueueAdmin.StopQueue();
                oracleQueueAdmin.DropQueue();
                oracleQueueTable.DropQueueTable();
                oracleConnection.Close();
        }
}
C#Visual Basic Copy Code
Sub Main()
        Using oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora;Direct=False;")
                oracleConnection.Open()
                Dim oracleCommand As New OracleCommand("CREATE OR REPLACE TYPE message " & _
                        "AS OBJECT (nickname VARCHAR2(15), mestext VARCHAR2(80));", oracleConnection)
                OracleCommand.ExecuteNonQuery()
                Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueTable.Options.PayloadTypeName = "message"
                oracleQueueTable.CreateQueueTable()
                Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
                        "QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueAdmin.CreateQueue()
                oracleQueueAdmin.StartQueue()
                Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim mes As New OracleObject("message", oracleConnection)
                mes.Item("nickname") = oracleConnection.UserId
                mes.Item("mestext") = "Hello, world!"
                oracleEnqueueQueue.Enqueue(mes)
                Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
                If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
                        Console.WriteLine(msg.ObjectPayload.Item("nickname"))
                        Console.WriteLine(msg.ObjectPayload.Item("mestext"))
                End If
                oracleQueueAdmin.StopQueue()
                oracleQueueAdmin.DropQueue()
                oracleQueueTable.DropQueueTable()
                oracleConnection.Close()
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueMessage Members
Devart.Data.Oracle Namespace
OracleQueueMessageProperties Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessage Class

The following tables list the members exposed by OracleQueueMessage.

Public Constructors

 | Name | Description
public Constructor | OracleQueueMessage Constructor | Overloaded. Initializes a new instance of the Devart.Data.Oracle.OracleQueueMessage class.
Top

Public Properties

 | Name | Description
public Property | MessageId | Gets or sets system generated identification of the message.
public Property | MessageProperties | Gets or sets the information that AQ uses to manage individual messages.
public Property | ObjectPayload | Gets or sets payload of object type for object type queues.
public Property | RawPayload | Gets or sets payload of type RAW for RAW queues.
public Property | StringPayload | Gets or sets string representation of payload of RAW type for RAW queues.
public Property | XmlPayload | Gets or sets XML representation of XMLTYPE queue payload.
Top

See Also

Reference

OracleQueueMessage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : OracleQueueMessage Constructor

Initializes a new instance of the OracleQueueMessage class.

Overload List

Overload | Description
OracleQueueMessage Constructor() | Initializes an empty message.
OracleQueueMessage Constructor(OracleBinary) | Initializes a message of RAW type.
OracleQueueMessage Constructor(OracleBinary,OracleQueueMessageProperties) | Initializes a message of RAW type.
OracleQueueMessage Constructor(Byte[]) | Initializes a message of RAW type.
OracleQueueMessage Constructor(Byte[],OracleQueueMessageProperties) | Initializes a message of RAW type.
OracleQueueMessage Constructor(OracleObject) | Initializes a message of user-defined type.
OracleQueueMessage Constructor(OracleObject,OracleQueueMessageProperties) | Initializes a message of user-defined type.
OracleQueueMessage Constructor(OracleXml) | Initializes a message of XML type.
OracleQueueMessage Constructor(OracleXml,OracleQueueMessageProperties) | Initializes a message of XML type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor()

Initializes an empty message.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueMessage()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleBinary)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleBinary)

rawPayload
The RAW payload of message.
Initializes a message of RAW type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawPayload As OracleBinary _
)
C#
public OracleQueueMessage(
   OracleBinary rawPayload
)

Parameters

rawPayload
The RAW payload of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleBinary,OracleQueueMessageProperties)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleBinary,OracleQueueMessageProperties)

rawPayload
The RAW payload of message.
messageProperties
The properties of message.
Initializes a message of RAW type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawPayload As OracleBinary, _
   ByVal messageProperties As OracleQueueMessageProperties _
)
C#
public OracleQueueMessage(
   OracleBinary rawPayload,
   OracleQueueMessageProperties messageProperties
)

Parameters

rawPayload
The RAW payload of message.
messageProperties
The properties of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(Byte[])
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(Byte[])

rawPayload
The character content of message.
Initializes a message of RAW type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawPayload() As Byte _
)
C#
public OracleQueueMessage(
   byte[] rawPayload
)

Parameters

rawPayload
The character content of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(Byte[],OracleQueueMessageProperties)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(Byte[],OracleQueueMessageProperties)

rawPayload
The character content of message.
messageProperties
The properties of message.
Initializes a message of RAW type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rawPayload() As Byte, _
   ByVal messageProperties As OracleQueueMessageProperties _
)
C#
public OracleQueueMessage(
   byte[] rawPayload,
   OracleQueueMessageProperties messageProperties
)

Parameters

rawPayload
The character content of message.
messageProperties
The properties of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleObject)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleObject)

objectPayload
The object payload of message.
Initializes a message of user-defined type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectPayload As OracleObject _
)
C#
public OracleQueueMessage(
   OracleObject objectPayload
)

Parameters

objectPayload
The object payload of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleObject,OracleQueueMessageProperties)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleObject,OracleQueueMessageProperties)

objectPayload
The object payload of message.
messageProperties
The properties of message.
Initializes a message of user-defined type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectPayload As OracleObject, _
   ByVal messageProperties As OracleQueueMessageProperties _
)
C#
public OracleQueueMessage(
   OracleObject objectPayload,
   OracleQueueMessageProperties messageProperties
)

Parameters

objectPayload
The object payload of message.
messageProperties
The properties of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleXml)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleXml)

xmlPayload
The XML content of message.
Initializes a message of XML type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xmlPayload As OracleXml _
)
C#
public OracleQueueMessage(
   OracleXml xmlPayload
)

Parameters

xmlPayload
The XML content of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Constructor(OracleXml,OracleQueueMessageProperties)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class > OracleQueueMessage Constructor : OracleQueueMessage Constructor(OracleXml,OracleQueueMessageProperties)

xmlPayload
The XML content of message.
messageProperties
The properties of message.
Initializes a message of XML type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal xmlPayload As OracleXml, _
   ByVal messageProperties As OracleQueueMessageProperties _
)
C#
public OracleQueueMessage(
   OracleXml xmlPayload,
   OracleQueueMessageProperties messageProperties
)

Parameters

xmlPayload
The XML content of message.
messageProperties
The properties of message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessage Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessage Class

For a list of all members of this type, see OracleQueueMessage members.

Public Properties

 | Name | Description
public Property | MessageId | Gets or sets system generated identification of the message.
public Property | MessageProperties | Gets or sets the information that AQ uses to manage individual messages.
public Property | ObjectPayload | Gets or sets payload of object type for object type queues.
public Property | RawPayload | Gets or sets payload of type RAW for RAW queues.
public Property | StringPayload | Gets or sets string representation of payload of RAW type for RAW queues.
public Property | XmlPayload | Gets or sets XML representation of XMLTYPE queue payload.
Top

See Also

Reference

OracleQueueMessage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : MessageId Property

Gets or sets system generated identification of the message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageId As OracleQueueMessageId
C#
public OracleQueueMessageId MessageId {get;}

Property Value

System generated identification of the message.

Remarks

This is a globally unique identifier that can be used to identify the message at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageProperties Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : MessageProperties Property

Gets or sets the information that AQ uses to manage individual messages.

Syntax

Visual Basic (Declaration)
Public Property MessageProperties As OracleQueueMessageProperties
C#
public OracleQueueMessageProperties MessageProperties {get; set;}

Property Value

The information that AQ uses to manage individual messages.

Remarks

These are set at enqueue time, and their values are returned at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
OracleQueueMessage Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectPayload Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : ObjectPayload Property

Gets or sets payload of object type for object type queues.

Syntax

Visual Basic (Declaration)
Public Property ObjectPayload As OracleObject
C#
public OracleObject ObjectPayload {get; set;}

Property Value

Message payload of object type for object type queues.

Remarks

This property cannot be set if either RawPayload, XmlPayload, or StringPayload property is set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
RawPayload Property
StringPayload Property
XmlPayload Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RawPayload Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : RawPayload Property

Gets or sets payload of type RAW for RAW queues.

Syntax

Visual Basic (Declaration)
Public Property RawPayload As OracleBinary
C#
public OracleBinary RawPayload {get; set;}

Property Value

Message payload of type RAW for RAW queues.

Remarks

This property and ObjectPayload property cannot be both set at the same time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
StringPayload Property
ObjectPayload Property
XmlPayload Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StringPayload Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : StringPayload Property

Gets or sets string representation of payload of RAW type for RAW queues.

Syntax

Visual Basic (Declaration)
Public Property StringPayload As String
C#
public string StringPayload {get; set;}

Property Value

String representation of message payload of RAW type for RAW queues.

Remarks

This property and ObjectPayload property cannot be both set at the same time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
RawPayload Property
ObjectPayload Property
XmlPayload Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
XmlPayload Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessage Class : XmlPayload Property

Gets or sets XML representation of XMLTYPE queue payload.

Syntax

Visual Basic (Declaration)
Public Property XmlPayload As OracleXml
C#
public OracleXml XmlPayload {get; set;}

Property Value

XML representation of XMLTYPE queue payload.

Remarks

This property and ObjectPayload property cannot be both set at the same time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessage Class
OracleQueueMessage Members
RawPayload Property
ObjectPayload Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageEventArgs Class

Provides data for the OracleQueue.OnMessage event of the OracleQueue class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.OracleQueueMessageEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleQueueMessageEventArgs
   Inherits System.EventArgs
C#
public class OracleQueueMessageEventArgs : System.EventArgs

Remarks

Refer to Advanced Queuing Technology article to get information about advanced queuing technology and samples.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueMessageEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageEventArgs Class

The following tables list the members exposed by OracleQueueMessageEventArgs.

Public Properties

 | Name | Description
public Property | MessageId | Gets OracleQueueMessage.MessageId property of the Devart.Data.Oracle.OracleQueueMessage object received.
public Property | MessageProperties | Gets the OracleQueueMessage.MessageProperties
Top

See Also

Reference

OracleQueueMessageEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageEventArgs Class

For a list of all members of this type, see OracleQueueMessageEventArgs members.

Public Properties

 | Name | Description
public Property | MessageId | Gets OracleQueueMessage.MessageId property of the Devart.Data.Oracle.OracleQueueMessage object received.
public Property | MessageProperties | Gets the OracleQueueMessage.MessageProperties
Top

See Also

Reference

OracleQueueMessageEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageEventArgs Class : MessageId Property

Gets OracleQueueMessage.MessageId property of the OracleQueueMessage object received.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageId As OracleQueueMessageId
C#
public OracleQueueMessageId MessageId {get;}

Property Value

OracleQueueMessage.MessageId property of the OracleQueueMessage object received.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageEventArgs Class
OracleQueueMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageProperties Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageEventArgs Class : MessageProperties Property

Gets the OracleQueueMessage.MessageProperties

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MessageProperties As OracleQueueMessageProperties
C#
public OracleQueueMessageProperties MessageProperties {get;}

Property Value

OracleQueueMessage.MessageProperties

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageEventArgs Class
OracleQueueMessageEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageProperties Class

Describes the information that AQ uses to manage individual messages.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueMessageProperties

Syntax

Visual Basic (Declaration)
Public Class OracleQueueMessageProperties
C#
public class OracleQueueMessageProperties

Remarks

Refer to Advanced Queuing Technology article to get information about advanced queuing technology and samples.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueMessageProperties Members
Devart.Data.Oracle Namespace
OracleQueueMessage Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageProperties Class

The following tables list the members exposed by OracleQueueMessageProperties.

Public Constructors

 | Name | Description
public Constructor | OracleQueueMessageProperties Constructor | Overloaded. Initializes a new instance of the Devart.Data.Oracle.OracleQueueMessageProperties class.
Top

Public Properties

 | Name | Description
public Property | Attempts | Gets the number of attempts that have been made to dequeue the message.
public Property | Correlation | Gets the identifier supplied by the producer of the message at enqueue time.
public Property | Delay | Specifies the delay of the enqueued message. The default value is 0.
public Property | DeliveryMode | Gets or sets delivery mode of the messages.
public Property | EnqueueTime | Specifies the time the message was enqueued.
public Property | ExceptionQueue | Gets or sets the name of the queue into which the message is moved if it cannot be processed successfully.
public Property | Expiration | Specifies the expiration of the message. It determines, in seconds, the duration the message is available for dequeuing. Default is -1.
public Property | OriginalMessageId | This parameter is used by Oracle Streams AQ for propagating messages.
public Property | Priority | Specifies the priority of the message. A smaller number indicates higher priority. The priority can be any number, including negative numbers. Default is 1.
public Property | RecipientList | Gets or sets the collection of queue subscribers.
public Property | SenderId | The application-sender identification specified at enqueue time by the message producer.
public Property | State | Specifies the state of the message at the time of the dequeue. This parameter cannot be set at enqueue time.
public Property | TransactionGroup | Specifies the transaction_group for the dequeued message.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two Devart.Data.Oracle.OracleQueueMessageProperties objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current Devart.Data.Oracle.OracleQueueMessageProperties instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueMessageProperties Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : OracleQueueMessageProperties Constructor

Initializes a new instance of the OracleQueueMessageProperties class.

Overload List

Overload | Description
OracleQueueMessageProperties Constructor() | Initializes a new instance of the OracleQueueMessageProperties class with default settings.
OracleQueueMessageProperties Constructor(Int32,Int32) | Initializes a new instance of the OracleQueueMessageProperties class.
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String) | Initializes a new instance of the OracleQueueMessageProperties class.
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,Byte[],OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueMessageProperties class.
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueMessageId,OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueMessageProperties class.
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueDeliveryMode) | Initializes a new instance of the OracleQueueMessageProperties class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor()

Initializes a new instance of the OracleQueueMessageProperties class with default settings.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueMessageProperties()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor(Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor(Int32,Int32)

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
Initializes a new instance of the OracleQueueMessageProperties class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priority As Integer, _
   ByVal delay As Integer _
)
C#
public OracleQueueMessageProperties(
   int priority,
   int delay
)

Parameters

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String)

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
Initializes a new instance of the OracleQueueMessageProperties class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priority As Integer, _
   ByVal delay As Integer, _
   ByVal expiration As Integer, _
   ByVal correlation As String _
)
C#
public OracleQueueMessageProperties(
   int priority,
   int delay,
   int expiration,
   string correlation
)

Parameters

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,Byte[],OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,Byte[],OracleQueueDeliveryMode)

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
originalMessageId
The identification of original message, which is used by Oracle Streams AQ for propagating messages.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.
Initializes a new instance of the OracleQueueMessageProperties class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priority As Integer, _
   ByVal delay As Integer, _
   ByVal expiration As Integer, _
   ByVal correlation As String, _
   ByVal recipientList() As OracleQueueAgent, _
   ByVal exceptionQueue As String, _
   ByVal senderId As OracleQueueAgent, _
   ByVal originalMessageId() As Byte, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueMessageProperties(
   int priority,
   int delay,
   int expiration,
   string correlation,
   OracleQueueAgent[] recipientList,
   string exceptionQueue,
   OracleQueueAgent senderId,
   byte[] originalMessageId,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
originalMessageId
The identification of original message, which is used by Oracle Streams AQ for propagating messages.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueMessageId,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueMessageId,OracleQueueDeliveryMode)

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
originalMessageId
The identification of original message, which is used by Oracle Streams AQ for propagating messages.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.
Initializes a new instance of the OracleQueueMessageProperties class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priority As Integer, _
   ByVal delay As Integer, _
   ByVal expiration As Integer, _
   ByVal correlation As String, _
   ByVal recipientList() As OracleQueueAgent, _
   ByVal exceptionQueue As String, _
   ByVal senderId As OracleQueueAgent, _
   ByVal originalMessageId As OracleQueueMessageId, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueMessageProperties(
   int priority,
   int delay,
   int expiration,
   string correlation,
   OracleQueueAgent[] recipientList,
   string exceptionQueue,
   OracleQueueAgent senderId,
   OracleQueueMessageId originalMessageId,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
originalMessageId
The identification of original message, which is used by Oracle Streams AQ for propagating messages.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueDeliveryMode)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class > OracleQueueMessageProperties Constructor : OracleQueueMessageProperties Constructor(Int32,Int32,Int32,String,OracleQueueAgent[],String,OracleQueueAgent,OracleQueueDeliveryMode)

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.
Initializes a new instance of the OracleQueueMessageProperties class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal priority As Integer, _
   ByVal delay As Integer, _
   ByVal expiration As Integer, _
   ByVal correlation As String, _
   ByVal recipientList() As OracleQueueAgent, _
   ByVal exceptionQueue As String, _
   ByVal senderId As OracleQueueAgent, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public OracleQueueMessageProperties(
   int priority,
   int delay,
   int expiration,
   string correlation,
   OracleQueueAgent[] recipientList,
   string exceptionQueue,
   OracleQueueAgent senderId,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

priority
The message priority; a smaller number indicates higher priority.
delay
The number of seconds after which a message is available for dequeuing.
expiration
The expiration time of message in seconds - the duration while the message is available for dequeuing.
correlation
The identifier supplied by the producer of the message.
recipientList
The list of the queue subscribers. This parameter is only valid for queues that allow multiple consumers.
exceptionQueue
The name of the corresponding exception queue; it is the queue the message is moved into if it cannot be processed successfully.
senderId
The OracleQueueAgent object representing the message sender.
deliveryMode
The message delivery mode. Specifies whether the message is persistent or buffered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageProperties Class

For a list of all members of this type, see OracleQueueMessageProperties members.

Public Methods

 | Name | Description
public Method | Equals | Compares two Devart.Data.Oracle.OracleQueueMessageProperties objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current Devart.Data.Oracle.OracleQueueMessageProperties instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueMessageProperties Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Equals Method

obj
The object to be compared.
Compares two OracleQueueMessageProperties objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared OracleQueueMessageProperties objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : GetHashCode Method

Returns hash code of the current OracleQueueMessageProperties instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current OracleQueueMessageProperties instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : ToString Method

Gets the object's type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns "OracleQueueMessageProperties".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageProperties Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageProperties Class

For a list of all members of this type, see OracleQueueMessageProperties members.

Public Properties

 | Name | Description
public Property | Attempts | Gets the number of attempts that have been made to dequeue the message.
public Property | Correlation | Gets the identifier supplied by the producer of the message at enqueue time.
public Property | Delay | Specifies the delay of the enqueued message. The default value is 0.
public Property | DeliveryMode | Gets or sets delivery mode of the messages.
public Property | EnqueueTime | Specifies the time the message was enqueued.
public Property | ExceptionQueue | Gets or sets the name of the queue into which the message is moved if it cannot be processed successfully.
public Property | Expiration | Specifies the expiration of the message. It determines, in seconds, the duration the message is available for dequeuing. Default is -1.
public Property | OriginalMessageId | This parameter is used by Oracle Streams AQ for propagating messages.
public Property | Priority | Specifies the priority of the message. A smaller number indicates higher priority. The priority can be any number, including negative numbers. Default is 1.
public Property | RecipientList | Gets or sets the collection of queue subscribers.
public Property | SenderId | The application-sender identification specified at enqueue time by the message producer.
public Property | State | Specifies the state of the message at the time of the dequeue. This parameter cannot be set at enqueue time.
public Property | TransactionGroup | Specifies the transaction_group for the dequeued message.
Top

See Also

Reference

OracleQueueMessageProperties Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Attempts Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Attempts Property

Gets the number of attempts that have been made to dequeue the message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attempts As Integer
C#
public int Attempts {get;}

Property Value

The number of attempts that have been made to dequeue the message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Correlation Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Correlation Property

Gets the identifier supplied by the producer of the message at enqueue time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Correlation As String
C#
public string Correlation {get;}

Property Value

The identifier supplied by the producer of the message at enqueue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Delay Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Delay Property

Specifies the delay of the enqueued message. The default value is 0.

Syntax

Visual Basic (Declaration)
Public Property Delay As Integer
C#
public int Delay {get; set;}

Property Value

The delay of the enqueued message. The default value is 0.

Remarks

The delay represents the number of seconds after which a message is available for dequeuing. Dequeuing by message id overrides the delay specification. A message enqueued with delay set is in the OracleQueueMessageState.Waiting state, and when the delay expires, the message goes to the OracleQueueMessageState.Ready state. Delay processing requires the queue monitor to be started. However the queue monitor is started automatically by the system if needed. Delay is set by the producer who enqueues the message.

If this property is equal to zero, the message is available for immediate dequeuing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
State Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeliveryMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : DeliveryMode Property

Gets or sets delivery mode of the messages.

Syntax

Visual Basic (Declaration)
Public Property DeliveryMode As OracleQueueDeliveryMode
C#
public OracleQueueDeliveryMode DeliveryMode {get; set;}

Property Value

Delivery mode of the messages.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EnqueueTime Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : EnqueueTime Property

Specifies the time the message was enqueued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnqueueTime As Date
C#
public DateTime EnqueueTime {get;}

Property Value

The time the message was enqueued.

Remarks

This value is determined by the system and cannot be set by the user at enqueue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExceptionQueue Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : ExceptionQueue Property

Gets or sets the name of the queue into which the message is moved if it cannot be processed successfully.

Syntax

Visual Basic (Declaration)
Public Property ExceptionQueue As String
C#
public string ExceptionQueue {get; set;}

Property Value

The name of the queue into which the message is moved if it cannot be processed successfully.

Remarks

Messages are moved automatically into the exception queue. Messages are moved into the exception queue in the following cases:

  • The number of unsuccessful dequeue attempts has exceeded the specification for the OracleQueueOptions.MaxRetries parameter.
  • For multiconsumer queues, the message becomes eligible to be moved to the exception queue even if failed dequeue attempts exceeds the OracleQueueOptions.MaxRetries parameter for only one of the consumers. But the message will not be moved until either all other consumers have successfully consumed the message or failed more than OracleQueueOptions.MaxRetries.
  • If a dequeue transaction fails because the server process dies (including ALTER SYSTEM KILL SESSION) or SHUTDOWN ABORT on the instance.
  • A message was not dequeued before the expiration time elapsed.
  • Message propagation to the specified destination queue failed with one of the following errors:
    There were no recipients for the multiconsumer destination queue.
    Recipients were specified for a single-consumer destination queue.
    Destination queue was an exception queue.
    There was an error when applying transformation.

The default is the exception queue associated with the queue table. If the exception queue specified does not exist at the time of the move, the message is moved to the default exception queue associated with the queue table, and a warning is logged in the alert file. If the default exception queue is specified, then the parameter returns a NULL value at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
OracleQueueOptions Class
OracleQueue Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Expiration Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Expiration Property

Specifies the expiration of the message. It determines, in seconds, the duration the message is available for dequeuing. Default is -1.

Syntax

Visual Basic (Declaration)
Public Property Expiration As Integer
C#
public int Expiration {get; set;}

Property Value

The number of seconds message remains in OracleQueueMessageState.Ready state.

Remarks

This parameter is an offset from the time the message is ready for dequeue. Expiration processing requires the queue monitor to be running. However the queue monitor is started automatically by the system if needed.

If Expiration = -1 the message does not expire.

If the message is not dequeued before it expires, then it is moved to the exception queue in the OracleQueueMessageState.Expired state.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
State Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OriginalMessageId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : OriginalMessageId Property

This parameter is used by Oracle Streams AQ for propagating messages.

Syntax

Visual Basic (Declaration)
Public Property OriginalMessageId As OracleQueueMessageId
C#
public OracleQueueMessageId OriginalMessageId {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Priority Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : Priority Property

Specifies the priority of the message. A smaller number indicates higher priority. The priority can be any number, including negative numbers. Default is 1.

Syntax

Visual Basic (Declaration)
Public Property Priority As Integer
C#
public int Priority {get; set;}

Property Value

The priority of the message.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RecipientList Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : RecipientList Property

Gets or sets the collection of queue subscribers.

Syntax

Visual Basic (Declaration)
Public Property RecipientList As OracleQueueAgentCollection
C#
public OracleQueueAgentCollection RecipientList {get; set;}

Property Value

The collection of queue subscribers.

Remarks

This parameter is only valid for queues that allow multiple consumers. If empty, the queue will be available for any consumer. This parameter is not returned to a consumer at dequeue time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members
OracleQueue Class
OracleQueueAgent Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SenderId Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : SenderId Property

The application-sender identification specified at enqueue time by the message producer.

Syntax

Visual Basic (Declaration)
Public Property SenderId As OracleQueueAgent
C#
public OracleQueueAgent SenderId {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
State Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : State Property

Specifies the state of the message at the time of the dequeue. This parameter cannot be set at enqueue time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As OracleQueueMessageState
C#
public OracleQueueMessageState State {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TransactionGroup Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageProperties Class : TransactionGroup Property

Specifies the transaction_group for the dequeued message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TransactionGroup As String
C#
public string TransactionGroup {get;}

Remarks

Messages belonging to the same transaction group will have the same value for this attribute. This attribute is only set by the OracleQueue.DequeueArray. This attribute cannot be used to set the transaction group of a message through OracleQueue.Enqueue or OracleQueue.EnqueueArray calls.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageProperties Class
OracleQueueMessageProperties Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueOptions Class

Queue options that are used upon creation.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueOptions

Syntax

Visual Basic (Declaration)
Public Class OracleQueueOptions
C#
public class OracleQueueOptions

Remarks

Specify these options via Options property of the OracleQueueAdmin class to make settings for the queue that will be created. For more information about advanced queuing technology and samples, refer to Advanced Queuing Technology article.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueOptions Members
Devart.Data.Oracle Namespace
OracleQueue Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueOptions Class

The following tables list the members exposed by OracleQueueOptions.

Public Constructors

 | Name | Description
public Constructor | OracleQueueOptions Constructor | Overloaded. Initializes a new instance of the OracleQueueOptions class.
Top

Public Properties

 | Name | Description
public Property | Comment | Gets or sets user-specified description of the queue.
public Property | MaxRetries | Limits the number of retries to dequeue the message in the Remove mode. Default value is 0, which means retries are unlimited.
public Property | QueueType | Gets or sets the queue type.
public Property | RetentionTime | Gets or sets the number of seconds for which a message is retained in the queue table after being dequeued from the queue. The default is 0, no retention.
public Property | RetryDelay | Gets or sets delay time, in seconds, before this message is scheduled for processing again after an application rollback.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current OracleQueueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : OracleQueueOptions Constructor

Initializes a new instance of the OracleQueueOptions class.

Overload List

Overload | Description
OracleQueueOptions Constructor() | Initializes a new instance of the OracleQueueOptions class.
OracleQueueOptions Constructor(OracleQueueType,String) | Initializes a new instance of the OracleQueueOptions class.
OracleQueueOptions Constructor(OracleQueueType,Double,Double,Double,String) | Initializes a new instance of the OracleQueueOptions class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class > OracleQueueOptions Constructor : OracleQueueOptions Constructor()

Initializes a new instance of the OracleQueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueOptions()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Constructor(OracleQueueType,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class > OracleQueueOptions Constructor : OracleQueueOptions Constructor(OracleQueueType,String)

queueType
The queue type, one from OracleQueueType. Specifies if the queue is normal, service or nonpersistent with RAW message payload.
comment
User-specified description of the queue.
Initializes a new instance of the OracleQueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueType As OracleQueueType, _
   ByVal comment As String _
)
C#
public OracleQueueOptions(
   OracleQueueType queueType,
   string comment
)

Parameters

queueType
The queue type, one from OracleQueueType. Specifies if the queue is normal, service or nonpersistent with RAW message payload.
comment
User-specified description of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Constructor(OracleQueueType,Double,Double,Double,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class > OracleQueueOptions Constructor : OracleQueueOptions Constructor(OracleQueueType,Double,Double,Double,String)

queueType
The queue type, one from OracleQueueType. Specifies if the queue is normal, service or nonpersistent with RAW message payload.
maxRetries
The number of retries to dequeue the message in the Remove mode. 0 means retries can be unlimited.
retryDelay
Delay time, in seconds, before the message can be processed again after the previous attempt. 0 means the retry can be made as soon as possible.
retentionTime
Time in seconds while the message is retained in the queue table after being dequeued. 0 for no retention.
comment
User-specified description of the queue.
Initializes a new instance of the OracleQueueOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal queueType As OracleQueueType, _
   ByVal maxRetries As Double, _
   ByVal retryDelay As Double, _
   ByVal retentionTime As Double, _
   ByVal comment As String _
)
C#
public OracleQueueOptions(
   OracleQueueType queueType,
   double maxRetries,
   double retryDelay,
   double retentionTime,
   string comment
)

Parameters

queueType
The queue type, one from OracleQueueType. Specifies if the queue is normal, service or nonpersistent with RAW message payload.
maxRetries
The number of retries to dequeue the message in the Remove mode. 0 means retries can be unlimited.
retryDelay
Delay time, in seconds, before the message can be processed again after the previous attempt. 0 means the retry can be made as soon as possible.
retentionTime
Time in seconds while the message is retained in the queue table after being dequeued. 0 for no retention.
comment
User-specified description of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueOptions Class

For a list of all members of this type, see OracleQueueOptions members.

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current OracleQueueOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : Equals Method

obj
The object to be compared.
Compares two OracleQueueOptions objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared OracleQueueOptions objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : GetHashCode Method

Returns hash code of the current OracleQueueOptions instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current OracleQueueOptions instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : ToString Method

Gets the object's type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns "OracleQueueOptions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueOptions Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueOptions Class

For a list of all members of this type, see OracleQueueOptions members.

Public Properties

 | Name | Description
public Property | Comment | Gets or sets user-specified description of the queue.
public Property | MaxRetries | Limits the number of retries to dequeue the message in the Remove mode. Default value is 0, which means retries are unlimited.
public Property | QueueType | Gets or sets the queue type.
public Property | RetentionTime | Gets or sets the number of seconds for which a message is retained in the queue table after being dequeued from the queue. The default is 0, no retention.
public Property | RetryDelay | Gets or sets delay time, in seconds, before this message is scheduled for processing again after an application rollback.
Top

See Also

Reference

OracleQueueOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Comment Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : Comment Property

Gets or sets user-specified description of the queue.

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment {get; set;}

Property Value

User-specified description of the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxRetries Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : MaxRetries Property

Limits the number of retries to dequeue the message in the Remove mode. Default value is 0, which means retries are unlimited.

Syntax

Visual Basic (Declaration)
Public Property MaxRetries As Double
C#
public double MaxRetries {get; set;}

Property Value

The number of times a dequeue with the OracleQueueDequeueMode.Remove mode can be attempted on a message.

Remarks

Default value is 0, which means retries are unlimited. Note that MaxRetries is supported for all single consumer queues and 8.1-compatible or higher multiconsumer queues but not for 8.0-compatible multiconsumer queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : QueueType Property

Gets or sets the queue type.

Syntax

Visual Basic (Declaration)
Public Property QueueType As OracleQueueType
C#
public OracleQueueType QueueType {get; set;}

Property Value

The queue type, one from OracleQueueType. Specifies if the queue is normal, service or nonpersistent with RAW message payload. Default value is OracleQueueType.Normal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RetentionTime Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : RetentionTime Property

Gets or sets the number of seconds for which a message is retained in the queue table after being dequeued from the queue. The default is 0, no retention.

Syntax

Visual Basic (Declaration)
Public Property RetentionTime As Double
C#
public double RetentionTime {get; set;}

Property Value

Number of seconds for which a message is retained in the queue table after being dequeued from the queue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RetryDelay Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueOptions Class : RetryDelay Property

Gets or sets delay time, in seconds, before this message is scheduled for processing again after an application rollback.

Syntax

Visual Basic (Declaration)
Public Property RetryDelay As Double
C#
public double RetryDelay {get; set;}

Property Value

Delay time, in seconds, before this message is scheduled for processing again after an application rollback.

Remarks

The default value is 0, which means the message can be retried as soon as possible. This parameter has no effect if MaxRetries is set to 0. Note that RetryDelay is supported for single consumer queues and 8.1-compatible or higher multiconsumer queues but not for 8.0-compatible multiconsumer queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueOptions Class
OracleQueueOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTable Class

Represent queue table for messages of a predefined type.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OracleQueueTable

Syntax

Visual Basic (Declaration)
Public Class OracleQueueTable
   Inherits System.ComponentModel.Component
   Implements IComponent, ISupportInitialize, IDisposable
C#
public class OracleQueueTable : System.ComponentModel.Component, IComponent, ISupportInitialize, IDisposable

Remarks

This class is used to manage, create and drop the database table where message queues are stored. To use or configure queues themselves, either OracleQueue or OracleQueueAdmin class should be used.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Example

The following example demonstrates usage of OracleQueue, OracleQueueAdmin, OracleQueueTable, OracleQueueTableOptions, and Devart.Data.Oracle.OracleQueueMessage classes. For detailed description of advanced queuing and more samples, refer to the Advanced Queuing Technology article.
C#csharp Copy Code
static void Main(string[] args)
{
        using (OracleConnection oracleConnection = new OracleConnection(
                        "User Id=system;Password=manager;Server=ora;Direct=False;")) {
                oracleConnection.Open();
                OracleCommand oracleCommand = new OracleCommand(
                        "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
                        "mestext VARCHAR2(80));", oracleConnection);
                oracleCommand.ExecuteNonQuery();
                OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueTable.Options.PayloadTypeName = "message";
                oracleQueueTable.CreateQueueTable();
                OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
                        "QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueAdmin.CreateQueue();
                oracleQueueAdmin.StartQueue();
                OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleObject mes = new OracleObject("message", oracleConnection);
                mes["nickname"] = oracleConnection.UserId;
                mes["mestext"] = "Hello, world!";
                oracleEnqueueQueue.Enqueue(mes);
                OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
                if (msg != null && msg.ObjectPayload != null) {
                        Console.WriteLine(msg.ObjectPayload["nickname"]);
                        Console.WriteLine(msg.ObjectPayload["mestext"]);
                }
                oracleQueueAdmin.StopQueue();
                oracleQueueAdmin.DropQueue();
                oracleQueueTable.DropQueueTable();
                oracleConnection.Close();
        }
}
C#Visual Basic Copy Code
Sub Main()
        Using oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora;Direct=False;")
                oracleConnection.Open()
                Dim oracleCommand As New OracleCommand("CREATE OR REPLACE TYPE message " & _
                        "AS OBJECT (nickname VARCHAR2(15), mestext VARCHAR2(80));", oracleConnection)
                OracleCommand.ExecuteNonQuery()
                Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueTable.Options.PayloadTypeName = "message"
                oracleQueueTable.CreateQueueTable()
                Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
                        "QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueAdmin.CreateQueue()
                oracleQueueAdmin.StartQueue()
                Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim mes As New OracleObject("message", oracleConnection)
                mes.Item("nickname") = oracleConnection.UserId
                mes.Item("mestext") = "Hello, world!"
                oracleEnqueueQueue.Enqueue(mes)
                Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
                If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
                        Console.WriteLine(msg.ObjectPayload.Item("nickname"))
                        Console.WriteLine(msg.ObjectPayload.Item("mestext"))
                End If
                oracleQueueAdmin.StopQueue()
                oracleQueueAdmin.DropQueue()
                oracleQueueTable.DropQueueTable()
                oracleConnection.Close()
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueTable Members
Devart.Data.Oracle Namespace
OracleQueue Class
OracleQueueAdmin Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueTable Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTable Class

The following tables list the members exposed by OracleQueueTable.

Public Constructors

 | Name | Description
public Constructor | OracleQueueTable Constructor | Overloaded. Initializes a new instance of the OracleQueueTable class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets an OracleConnection to the Oracle server which provides the AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Options | Gets or sets queue table properties.
public Property | QueueTableName | Gets or sets the name of the database table which will contain queues.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

Public Methods

 | Name | Description
public Method | AlterComment | Sets the user-defined description of the queue table.
public Method | AlterPrimaryInstance | Changes the primary Oracle instance that is used to operate the queue table.
public Method | AlterQueueTable | Alters the existing properties of a queue table.
public Method | AlterSecondaryInstance | Changes the secondary Oracle instance that is used to operate the queue table.
public Method | BeginInit | Begins the initialization of an OracleQueueTable. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateQueue | Creates new queue in the current queue table.
public Method | CreateQueueTable | Overloaded. Creates a queue table for storing queues in the database.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | DropQueueTable | Overloaded. Drops an existing queue table.
public Method | EndInit | Ends the initialization of an OracleQueueTable. The initialization occurs at run time.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetQueueNames | Returns a list of names of all queues, which belongs to the given queue table.
static (Shared in Visual Basic) | GetQueueTable | Creates an instance of OracleQueueTable, related to queue table existent on a server.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | MigrateQueueTable | Ugrades an 8.0-compatible queue table to an 8.1-compatible or higher queue table, or downgrades an 8.1-compatible or higher queue table to an 8.0-compatible queue table.
public Method | PurgeQueueTable | Overloaded. Purges messages from queue tables. You can perform various purge operations on both single-consumer and multiconsumer queue tables for persistent queues.
public Method | ReadQueueTableProperties | Reads the options of the queue table with name as in QueueTableName from the Oracle database. After that, assigns the read data to the Options property.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : OracleQueueTable Constructor

Initializes a new instance of the OracleQueueTable class.

Overload List

Overload | Description
OracleQueueTable Constructor() | Initializes a new instance of the OracleQueueTable class.
OracleQueueTable Constructor(String) | Initializes a new instance of the OracleQueueTable class.
OracleQueueTable Constructor(String,OracleConnection) | Initializes a new instance of the OracleQueueTable class.
OracleQueueTable Constructor(String,OracleQueueTableOptions,OracleConnection) | Initializes a new instance of the OracleQueueTable class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > OracleQueueTable Constructor : OracleQueueTable Constructor()

Initializes a new instance of the OracleQueueTable class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueTable()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > OracleQueueTable Constructor : OracleQueueTable Constructor(String)

name
The name of the database table which will contain queues.
Initializes a new instance of the OracleQueueTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public OracleQueueTable(
   string name
)

Parameters

name
The name of the database table which will contain queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > OracleQueueTable Constructor : OracleQueueTable Constructor(String,OracleConnection)

name
The name of the database table which will contain queues.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.
Initializes a new instance of the OracleQueueTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueueTable(
   string name,
   OracleConnection connection
)

Parameters

name
The name of the database table which will contain queues.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTable Constructor(String,OracleQueueTableOptions,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > OracleQueueTable Constructor : OracleQueueTable Constructor(String,OracleQueueTableOptions,OracleConnection)

name
The name of the database table which will contain queues.
options
Queue table properties, that are used for its creation.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.
Initializes a new instance of the OracleQueueTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal options As OracleQueueTableOptions, _
   ByVal connection As OracleConnection _
)
C#
public OracleQueueTable(
   string name,
   OracleQueueTableOptions options,
   OracleConnection connection
)

Parameters

name
The name of the database table which will contain queues.
options
Queue table properties, that are used for its creation.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueTable Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTable Class

For a list of all members of this type, see OracleQueueTable members.

Public Methods

 | Name | Description
public Method | AlterComment | Sets the user-defined description of the queue table.
public Method | AlterPrimaryInstance | Changes the primary Oracle instance that is used to operate the queue table.
public Method | AlterQueueTable | Alters the existing properties of a queue table.
public Method | AlterSecondaryInstance | Changes the secondary Oracle instance that is used to operate the queue table.
public Method | BeginInit | Begins the initialization of an OracleQueueTable. The initialization occurs at run time.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CreateQueue | Creates new queue in the current queue table.
public Method | CreateQueueTable | Overloaded. Creates a queue table for storing queues in the database.
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | DropQueueTable | Overloaded. Drops an existing queue table.
public Method | EndInit | Ends the initialization of an OracleQueueTable. The initialization occurs at run time.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetQueueNames | Returns a list of names of all queues, which belongs to the given queue table.
static (Shared in Visual Basic) | GetQueueTable | Creates an instance of OracleQueueTable, related to queue table existent on a server.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | MigrateQueueTable | Ugrades an 8.0-compatible queue table to an 8.1-compatible or higher queue table, or downgrades an 8.1-compatible or higher queue table to an 8.0-compatible queue table.
public Method | PurgeQueueTable | Overloaded. Purges messages from queue tables. You can perform various purge operations on both single-consumer and multiconsumer queue tables for persistent queues.
public Method | ReadQueueTableProperties | Reads the options of the queue table with name as in QueueTableName from the Oracle database. After that, assigns the read data to the Options property.
Top

See Also

Reference

OracleQueueTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterComment Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : AlterComment Method

comment
The user-defined commect to set.
Sets the user-defined description of the queue table.

Syntax

Visual Basic (Declaration)
Public Sub AlterComment( _
   ByVal comment As String _
)
C#
public void AlterComment(
   string comment
)

Parameters

comment
The user-defined commect to set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterPrimaryInstance Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : AlterPrimaryInstance Method

primaryInstance
The Oracle instance identifier. 0 means any available instance can be the queue table's owner.
Changes the primary Oracle instance that is used to operate the queue table.

Syntax

Visual Basic (Declaration)
Public Sub AlterPrimaryInstance( _
   ByVal primaryInstance As Integer _
)
C#
public void AlterPrimaryInstance(
   int primaryInstance
)

Parameters

primaryInstance
The Oracle instance identifier. 0 means any available instance can be the queue table's owner.

Remarks

Does nothing if primaryInstance parameter is less than 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : AlterQueueTable Method

comment
Modifies the user-specified description of the queue table.
primaryInstance
The primary owner of the queue table. Queue monitor scheduling and propagation for the queues in the queue table will be done in this instance. 0 to use any available instance.
secondaryInstance
The queue table fails over to the secondary instance if the primary instance is not available. 0 to use any available instance.
Alters the existing properties of a queue table.

Syntax

Visual Basic (Declaration)
Public Sub AlterQueueTable( _
   ByVal comment As String, _
   ByVal primaryInstance As Integer, _
   ByVal secondaryInstance As Integer _
)
C#
public void AlterQueueTable(
   string comment,
   int primaryInstance,
   int secondaryInstance
)

Parameters

comment
Modifies the user-specified description of the queue table.
primaryInstance
The primary owner of the queue table. Queue monitor scheduling and propagation for the queues in the queue table will be done in this instance. 0 to use any available instance.
secondaryInstance
The queue table fails over to the secondary instance if the primary instance is not available. 0 to use any available instance.

Remarks

If comment is null, then Comment value is not altered. If primaryInstance < 0, then PrimaryInstance value is not altered. If secondaryInstance < 0, then SecondaryInstance value is not altered.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
CreateQueueTable Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AlterSecondaryInstance Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : AlterSecondaryInstance Method

secondaryInstance
The Oracle instance identifier. 0 means any available instance can be the queue table's owner.
Changes the secondary Oracle instance that is used to operate the queue table.

Syntax

Visual Basic (Declaration)
Public Sub AlterSecondaryInstance( _
   ByVal secondaryInstance As Integer _
)
C#
public void AlterSecondaryInstance(
   int secondaryInstance
)

Parameters

secondaryInstance
The Oracle instance identifier. 0 means any available instance can be the queue table's owner.

Remarks

Does nothing if primaryInstance parameter is less than 0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : BeginInit Method

Begins the initialization of an OracleQueueTable. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
C#
public void BeginInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueue Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : CreateQueue Method

queueName
Name of the queue to be created.
options
Options of the queue to be created.
Creates new queue in the current queue table.

Syntax

Visual Basic (Declaration)
Public Function CreateQueue( _
   ByVal queueName As String, _
   ByVal options As OracleQueueOptions _
) As OracleQueue
C#
public OracleQueue CreateQueue(
   string queueName,
   OracleQueueOptions options
)

Parameters

queueName
Name of the queue to be created.
options
Options of the queue to be created.

Return Value

OracleQueue instance, related to the queue created.

Remarks

Options of the queue to be created must not contradict to the options of queue table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
CreateQueue Method
OracleQueueOptions Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : CreateQueueTable Method

Creates a queue table for storing queues in the database.

Overload List

Overload | Description
CreateQueueTable() | Creates a queue table for storing queues in the database. Uses Connection for connecting to the database, sets the name and parameters of the table in database relying on QueueTableName and Options.
CreateQueueTable(String,OracleQueueTableOptions,OracleConnection) | Creates a queue table for storing queues in the database. Uses the specified connection for connecting to the database, sets the specified name and properties to the created table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueueTable() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > CreateQueueTable Method : CreateQueueTable() Method

Creates a queue table for storing queues in the database. Uses Connection for connecting to the database, sets the name and parameters of the table in database relying on QueueTableName and Options.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CreateQueueTable()
C#
public void CreateQueueTable()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateQueueTable(String,OracleQueueTableOptions,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > CreateQueueTable Method : CreateQueueTable(String,OracleQueueTableOptions,OracleConnection) Method

name
Name of the queue table in the database.
options
Parameters for creating the queue table in the database.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.
Creates a queue table for storing queues in the database. Uses the specified connection for connecting to the database, sets the specified name and properties to the created table.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function CreateQueueTable( _
   ByVal name As String, _
   ByVal options As OracleQueueTableOptions, _
   ByVal connection As OracleConnection _
) As OracleQueueTable
C#
public static OracleQueueTable CreateQueueTable(
   string name,
   OracleQueueTableOptions options,
   OracleConnection connection
)

Parameters

name
Name of the queue table in the database.
options
Parameters for creating the queue table in the database.
connection
An OracleConnection to the Oracle server which provides the AQ functionality.

Return Value

Returns the OracleQueueTable instance with Name, Options and Connection set as in the arguments.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : DropQueueTable Method

Drops an existing queue table.

Overload List

Overload | Description
DropQueueTable() | Drops an existing queue table. Does not stop and drop the existing queues, thus failing if there are any.
DropQueueTable(Boolean) | Drops an existing queue table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueueTable() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > DropQueueTable Method : DropQueueTable() Method

Drops an existing queue table. Does not stop and drop the existing queues, thus failing if there are any.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DropQueueTable()
C#
public void DropQueueTable()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DropQueueTable(Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > DropQueueTable Method : DropQueueTable(Boolean) Method

force
false means the operation does not succeed if there are any queues in the table. true means all queues in the table are stopped and dropped automatically.
Drops an existing queue table.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DropQueueTable( _
   ByVal force As Boolean _
)
C#
public void DropQueueTable(
   bool force
)

Parameters

force
false means the operation does not succeed if there are any queues in the table. true means all queues in the table are stopped and dropped automatically.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
EndInit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : EndInit Method

Ends the initialization of an OracleQueueTable. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
C#
public void EndInit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetQueueNames Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : GetQueueNames Method

Returns a list of names of all queues, which belongs to the given queue table.

Syntax

Visual Basic (Declaration)
Public Function GetQueueNames() As String()
C#
public string[] GetQueueNames()

Return Value

Array of names of all queues, which belongs to the given queue table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
OracleQueue Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : GetQueueTable Method

name
Name of existent queue table.
connection
Connection to Oracle server.
Creates an instance of OracleQueueTable, related to queue table existent on a server.

Syntax

Visual Basic (Declaration)
Public Shared Function GetQueueTable( _
   ByVal name As String, _
   ByVal connection As OracleConnection _
) As OracleQueueTable
C#
public static OracleQueueTable GetQueueTable(
   string name,
   OracleConnection connection
)

Parameters

name
Name of existent queue table.
connection
Connection to Oracle server.

Return Value

OracleQueueTable instance, related to queue table existent on a server.

Remarks

Returning instance has valid Options state.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
CreateQueueTable Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MigrateQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : MigrateQueueTable Method

compatible
Oracle AQ version to migrate to.
Ugrades an 8.0-compatible queue table to an 8.1-compatible or higher queue table, or downgrades an 8.1-compatible or higher queue table to an 8.0-compatible queue table.

Syntax

Visual Basic (Declaration)
Public Sub MigrateQueueTable( _
   ByVal compatible As OracleQueueCompatible _
)
C#
public void MigrateQueueTable(
   OracleQueueCompatible compatible
)

Parameters

compatible
Oracle AQ version to migrate to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
OracleQueueTableOptions Class
OracleQueueCompatible Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : PurgeQueueTable Method

Purges messages from queue tables. You can perform various purge operations on both single-consumer and multiconsumer queue tables for persistent queues.

Overload List

Overload | Description
PurgeQueueTable() | Purges messages from queue tables.
PurgeQueueTable(String) | Purges messages from queue tables.
PurgeQueueTable(String,Boolean) | Purges messages from queue tables.
PurgeQueueTable(String,OracleQueueDeliveryMode) | Purges messages from queue tables.
PurgeQueueTable(String,Boolean,OracleQueueDeliveryMode) | Purges messages from queue tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > PurgeQueueTable Method : PurgeQueueTable() Method

Purges messages from queue tables.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PurgeQueueTable()
C#
public void PurgeQueueTable()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > PurgeQueueTable Method : PurgeQueueTable(String) Method

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
Purges messages from queue tables.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PurgeQueueTable( _
   ByVal condition As String _
)
C#
public void PurgeQueueTable(
   string condition
)

Parameters

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable(String,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > PurgeQueueTable Method : PurgeQueueTable(String,Boolean) Method

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
block
If block is true, then an exclusive lock on all the queues in the queue table is held while purging the queue table. This will cause concurrent enqueuers and dequeuers to block while the queue table is purged. The purge call always succeeds if block is true. This will not block enqueuers and dequeuers, but it can cause the purge to fail with an error during high concurrency times.
Purges messages from queue tables.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PurgeQueueTable( _
   ByVal condition As String, _
   ByVal block As Boolean _
)
C#
public void PurgeQueueTable(
   string condition,
   bool block
)

Parameters

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
block
If block is true, then an exclusive lock on all the queues in the queue table is held while purging the queue table. This will cause concurrent enqueuers and dequeuers to block while the queue table is purged. The purge call always succeeds if block is true. This will not block enqueuers and dequeuers, but it can cause the purge to fail with an error during high concurrency times.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable(String,OracleQueueDeliveryMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > PurgeQueueTable Method : PurgeQueueTable(String,OracleQueueDeliveryMode) Method

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
deliveryMode
This parameter is used to specify delivery mode of messages are to be purged. You cannot implement arbitrary purge conditions if buffered messages have to be purged. (Used in Oracle Server 10.2 only.)
Purges messages from queue tables.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PurgeQueueTable( _
   ByVal condition As String, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public void PurgeQueueTable(
   string condition,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
deliveryMode
This parameter is used to specify delivery mode of messages are to be purged. You cannot implement arbitrary purge conditions if buffered messages have to be purged. (Used in Oracle Server 10.2 only.)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PurgeQueueTable(String,Boolean,OracleQueueDeliveryMode) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class > PurgeQueueTable Method : PurgeQueueTable(String,Boolean,OracleQueueDeliveryMode) Method

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
block
If block is true, then an exclusive lock on all the queues in the queue table is held while purging the queue table. This will cause concurrent enqueuers and dequeuers to block while the queue table is purged. The purge call always succeeds if block is true. This will not block enqueuers and dequeuers, but it can cause the purge to fail with an error during high concurrency times.
deliveryMode
This parameter is used to specify delivery mode of messages are to be purged. You cannot implement arbitrary purge conditions if buffered messages have to be purged. (Used in Oracle Server 10.2 only.)
Purges messages from queue tables.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PurgeQueueTable( _
   ByVal condition As String, _
   ByVal block As Boolean, _
   ByVal deliveryMode As OracleQueueDeliveryMode _
)
C#
public void PurgeQueueTable(
   string condition,
   bool block,
   OracleQueueDeliveryMode deliveryMode
)

Parameters

condition
Specifies the purge condition to use when purging the queue table. The purge condition must be in the format of a SQL WHERE clause, and it is case-sensitive. The condition is based on the columns of aq$queue_table view.
block
If block is true, then an exclusive lock on all the queues in the queue table is held while purging the queue table. This will cause concurrent enqueuers and dequeuers to block while the queue table is purged. The purge call always succeeds if block is true. This will not block enqueuers and dequeuers, but it can cause the purge to fail with an error during high concurrency times.
deliveryMode
This parameter is used to specify delivery mode of messages are to be purged. You cannot implement arbitrary purge conditions if buffered messages have to be purged. (Used in Oracle Server 10.2 only.)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadQueueTableProperties Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : ReadQueueTableProperties Method

Reads the options of the queue table with name as in QueueTableName from the Oracle database. After that, assigns the read data to the Options property.

Syntax

Visual Basic (Declaration)
Public Sub ReadQueueTableProperties()
C#
public void ReadQueueTableProperties()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
CreateQueueTable Method
GetQueueTable Method


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueTable Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTable Class

For a list of all members of this type, see OracleQueueTable members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets an OracleConnection to the Oracle server which provides the AQ functionality.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Options | Gets or sets queue table properties.
public Property | QueueTableName | Gets or sets the name of the database table which will contain queues.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : Connection Property

Gets or sets an OracleConnection to the Oracle server which provides the AQ functionality.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

An OracleConnection to the Oracle server which provides the AQ functionality.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Options Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : Options Property

Gets or sets queue table properties.

Syntax

Visual Basic (Declaration)
Public Property Options As OracleQueueTableOptions
C#
public OracleQueueTableOptions Options {get; set;}

Property Value

Queue table properties, that are used for its creation.

Remarks

This property has to be set to create a new queue table. If using existent queue table, this property is set when calling GetQueueTable or ReadQueueTableProperties methods.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members
ReadQueueTableProperties Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
QueueTableName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTable Class : QueueTableName Property

Gets or sets the name of the database table which will contain queues.

Syntax

Visual Basic (Declaration)
Public Property QueueTableName As String
C#
public string QueueTableName {get; set;}

Property Value

The name of the database table which will contain queues.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTable Class
OracleQueueTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTableOptions Class

Queue table properties, that are used for its creation.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleQueueTableOptions

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleQueueTableOptions
C#
public sealed class OracleQueueTableOptions

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Example

The following example demonstrates usage of OracleQueue, OracleQueueAdmin, OracleQueueTable, OracleQueueTableOptions, and Devart.Data.Oracle.OracleQueueMessage classes. For detailed description of advanced queuing and more samples, refer to the Advanced Queuing Technology article.
C#csharp Copy Code
static void Main(string[] args)
{
        using (OracleConnection oracleConnection = new OracleConnection(
                        "User Id=system;Password=manager;Server=ora;Direct=False;")) {
                oracleConnection.Open();
                OracleCommand oracleCommand = new OracleCommand(
                        "CREATE OR REPLACE TYPE message AS OBJECT (nickname VARCHAR2(15), " +
                        "mestext VARCHAR2(80));", oracleConnection);
                oracleCommand.ExecuteNonQuery();
                OracleQueueTable oracleQueueTable = new OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueTable.Options.PayloadTypeName = "message";
                oracleQueueTable.CreateQueueTable();
                OracleQueueAdmin oracleQueueAdmin = new OracleQueueAdmin("MESSAGE_QUEUE",
                        "QUEUE_TABLE_MESSAGE", oracleConnection);
                oracleQueueAdmin.CreateQueue();
                oracleQueueAdmin.StartQueue();
                OracleQueue oracleEnqueueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleObject mes = new OracleObject("message", oracleConnection);
                mes["nickname"] = oracleConnection.UserId;
                mes["mestext"] = "Hello, world!";
                oracleEnqueueQueue.Enqueue(mes);
                OracleQueue oracleDequeueQueue = new OracleQueue("MESSAGE_QUEUE", oracleConnection);
                OracleQueueMessage msg = oracleDequeueQueue.Dequeue();
                if (msg != null && msg.ObjectPayload != null) {
                        Console.WriteLine(msg.ObjectPayload["nickname"]);
                        Console.WriteLine(msg.ObjectPayload["mestext"]);
                }
                oracleQueueAdmin.StopQueue();
                oracleQueueAdmin.DropQueue();
                oracleQueueTable.DropQueueTable();
                oracleConnection.Close();
        }
}
C#Visual Basic Copy Code
Sub Main()
        Using oracleConnection As New OracleConnection("User Id=system;Password=manager;Server=ora;Direct=False;")
                oracleConnection.Open()
                Dim oracleCommand As New OracleCommand("CREATE OR REPLACE TYPE message " & _
                        "AS OBJECT (nickname VARCHAR2(15), mestext VARCHAR2(80));", oracleConnection)
                OracleCommand.ExecuteNonQuery()
                Dim oracleQueueTable As New OracleQueueTable("QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueTable.Options.PayloadTypeName = "message"
                oracleQueueTable.CreateQueueTable()
                Dim oracleQueueAdmin As New OracleQueueAdmin("MESSAGE_QUEUE", _
                        "QUEUE_TABLE_MESSAGE", oracleConnection)
                oracleQueueAdmin.CreateQueue()
                oracleQueueAdmin.StartQueue()
                Dim oracleEnqueueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim mes As New OracleObject("message", oracleConnection)
                mes.Item("nickname") = oracleConnection.UserId
                mes.Item("mestext") = "Hello, world!"
                oracleEnqueueQueue.Enqueue(mes)
                Dim oracleDequeueQueue As New OracleQueue("MESSAGE_QUEUE", oracleConnection)
                Dim msg As OracleQueueMessage = oracleDequeueQueue.Dequeue()
                If ((Not msg Is Nothing) AndAlso (Not msg.ObjectPayload Is Nothing)) Then
                        Console.WriteLine(msg.ObjectPayload.Item("nickname"))
                        Console.WriteLine(msg.ObjectPayload.Item("mestext"))
                End If
                oracleQueueAdmin.StopQueue()
                oracleQueueAdmin.DropQueue()
                oracleQueueTable.DropQueueTable()
                oracleConnection.Close()
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueTableOptions Members
Devart.Data.Oracle Namespace
OracleQueueTable Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTableOptions Class

The following tables list the members exposed by OracleQueueTableOptions.

Public Constructors

 | Name | Description
public Constructor | OracleQueueTableOptions Constructor | Overloaded. Initializes a new instance of the OracleQueueTableOptions class.
Top

Public Properties

 | Name | Description
public Property | Comment | User-specified description of the queue table.
public Property | Compatible | The lowest database version with which the queue is compatible. Default OracleQueueCompatible.Default.
public Property | MessageGrouping | Gets or sets message grouping behavior for queues created in the table. Default value is OracleQueueMessageGrouping.None.
public Property | MultipleConsumers | FALSE means queues created in the table can only have one consumer for each message. This is the default. TRUE means queues created in the table can have multiple consumers for each message.
public Property | PayloadTypeName | Name of the queue payload type
public Property | PrimaryInstance | The primary owner of the queue table. Queue monitor scheduling and propagation for the queues in the queue table are done in this instance. The default value for primary instance is 0, which means queue monitor scheduling and propagation will be done in any available instance.
public Property | SecondaryInstance | The queue table fails over to the secondary instance if the primary instance is not available. The default value is 0, which means that the queue table will fail over to any available instance.
public Property | Secure | Specifies whether the queue table is used for secure queues. Default value is false.
public Property | SortOrder | Specifies which parameter is used to order messages in the queue. The queue will be sorted by this parameter in the ascending order. Default value is OracleQueueSortOrder.EnqueueTime.
public Property | StorageClause | Storage parameter.
Top

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueTableOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current OracleQueueTableOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueTableOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : OracleQueueTableOptions Constructor

Initializes a new instance of the OracleQueueTableOptions class.

Overload List

Overload | Description
OracleQueueTableOptions Constructor() | Initializes a new instance of the OracleQueueTableOptions class.
OracleQueueTableOptions Constructor(String) | Initializes a new instance of the OracleQueueTableOptions class.
OracleQueueTableOptions Constructor(String,String,OracleQueueSortOrder,Boolean,OracleQueueMessageGrouping,String,OracleQueueCompatible,Int32,Int32,Boolean) | Initializes a new instance of the OracleQueueTableOptions class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class > OracleQueueTableOptions Constructor : OracleQueueTableOptions Constructor()

Initializes a new instance of the OracleQueueTableOptions class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleQueueTableOptions()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class > OracleQueueTableOptions Constructor : OracleQueueTableOptions Constructor(String)

payloadTypeName
Type of the user data stored, either user-defined type or RAW.
Initializes a new instance of the OracleQueueTableOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal payloadTypeName As String _
)
C#
public OracleQueueTableOptions(
   string payloadTypeName
)

Parameters

payloadTypeName
Type of the user data stored, either user-defined type or RAW.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Constructor(String,String,OracleQueueSortOrder,Boolean,OracleQueueMessageGrouping,String,OracleQueueCompatible,Int32,Int32,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class > OracleQueueTableOptions Constructor : OracleQueueTableOptions Constructor(String,String,OracleQueueSortOrder,Boolean,OracleQueueMessageGrouping,String,OracleQueueCompatible,Int32,Int32,Boolean)

payloadTypeName
Type of the user data stored, either user-defined type or RAW.
storageClause
The storage parameter included to the CREATE TABLE statement.
sortOrder
Specifies which properties are used to order messages in the queue. Default value is Ascending.
multipleConsumers
Specifies whether the queues created in the table can have multiple consumers.
messageGrouping
Specifies the message grouping behaviour.
comment
The user-defined description of the table.
compatible
The lowest database version with which the queue is compatible.
primaryInstance
The primary Oracle instance which will be used to operate the table. 0 to use any available instance.
secondaryInstance
The secondary Oracle instance which will be used to operate the table when the primary instance is unavailable. 0 to use any available instance.
secure
Specifies whether the queue table is used for secure queues. If true, AQ agents must be associated explicitly with one or more database users who can perform queue operations, such as enqueue or dequeue.
Initializes a new instance of the OracleQueueTableOptions class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal payloadTypeName As String, _
   ByVal storageClause As String, _
   ByVal sortOrder As OracleQueueSortOrder, _
   ByVal multipleConsumers As Boolean, _
   ByVal messageGrouping As OracleQueueMessageGrouping, _
   ByVal comment As String, _
   ByVal compatible As OracleQueueCompatible, _
   ByVal primaryInstance As Integer, _
   ByVal secondaryInstance As Integer, _
   ByVal secure As Boolean _
)
C#
public OracleQueueTableOptions(
   string payloadTypeName,
   string storageClause,
   OracleQueueSortOrder sortOrder,
   bool multipleConsumers,
   OracleQueueMessageGrouping messageGrouping,
   string comment,
   OracleQueueCompatible compatible,
   int primaryInstance,
   int secondaryInstance,
   bool secure
)

Parameters

payloadTypeName
Type of the user data stored, either user-defined type or RAW.
storageClause
The storage parameter included to the CREATE TABLE statement.
sortOrder
Specifies which properties are used to order messages in the queue. Default value is Ascending.
multipleConsumers
Specifies whether the queues created in the table can have multiple consumers.
messageGrouping
Specifies the message grouping behaviour.
comment
The user-defined description of the table.
compatible
The lowest database version with which the queue is compatible.
primaryInstance
The primary Oracle instance which will be used to operate the table. 0 to use any available instance.
secondaryInstance
The secondary Oracle instance which will be used to operate the table when the primary instance is unavailable. 0 to use any available instance.
secure
Specifies whether the queue table is used for secure queues. If true, AQ agents must be associated explicitly with one or more database users who can perform queue operations, such as enqueue or dequeue.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTableOptions Class

For a list of all members of this type, see OracleQueueTableOptions members.

Public Methods

 | Name | Description
public Method | Equals | Compares two OracleQueueTableOptions objects to determine if they are equal.
public Method | GetHashCode | Returns hash code of the current OracleQueueTableOptions instance.
public Method | ToString | Gets the object's type.
Top

See Also

Reference

OracleQueueTableOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : Equals Method

obj
The object to be compared.
Compares two OracleQueueTableOptions objects to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

true if the compared OracleQueueTableOptions objects are identical; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : GetHashCode Method

Returns hash code of the current OracleQueueTableOptions instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

The hash code of the current OracleQueueTableOptions instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : ToString Method

Gets the object's type.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

Returns "OracleQueueTableOptions".

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueTableOptions Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTableOptions Class

For a list of all members of this type, see OracleQueueTableOptions members.

Public Properties

 | Name | Description
public Property | Comment | User-specified description of the queue table.
public Property | Compatible | The lowest database version with which the queue is compatible. Default OracleQueueCompatible.Default.
public Property | MessageGrouping | Gets or sets message grouping behavior for queues created in the table. Default value is OracleQueueMessageGrouping.None.
public Property | MultipleConsumers | FALSE means queues created in the table can only have one consumer for each message. This is the default. TRUE means queues created in the table can have multiple consumers for each message.
public Property | PayloadTypeName | Name of the queue payload type
public Property | PrimaryInstance | The primary owner of the queue table. Queue monitor scheduling and propagation for the queues in the queue table are done in this instance. The default value for primary instance is 0, which means queue monitor scheduling and propagation will be done in any available instance.
public Property | SecondaryInstance | The queue table fails over to the secondary instance if the primary instance is not available. The default value is 0, which means that the queue table will fail over to any available instance.
public Property | Secure | Specifies whether the queue table is used for secure queues. Default value is false.
public Property | SortOrder | Specifies which parameter is used to order messages in the queue. The queue will be sorted by this parameter in the ascending order. Default value is OracleQueueSortOrder.EnqueueTime.
public Property | StorageClause | Storage parameter.
Top

See Also

Reference

OracleQueueTableOptions Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Comment Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : Comment Property

User-specified description of the queue table.

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Compatible Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : Compatible Property

The lowest database version with which the queue is compatible. Default OracleQueueCompatible.Default.

Syntax

Visual Basic (Declaration)
Public Property Compatible As OracleQueueCompatible
C#
public OracleQueueCompatible Compatible {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MessageGrouping Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : MessageGrouping Property

Gets or sets message grouping behavior for queues created in the table. Default value is OracleQueueMessageGrouping.None.

Syntax

Visual Basic (Declaration)
Public Property MessageGrouping As OracleQueueMessageGrouping
C#
public OracleQueueMessageGrouping MessageGrouping {get; set;}

Property Value

Message grouping behavior for queues created in the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MultipleConsumers Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : MultipleConsumers Property

FALSE means queues created in the table can only have one consumer for each message. This is the default. TRUE means queues created in the table can have multiple consumers for each message.

Syntax

Visual Basic (Declaration)
Public Property MultipleConsumers As Boolean
C#
public bool MultipleConsumers {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PayloadTypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : PayloadTypeName Property

Name of the queue payload type

Syntax

Visual Basic (Declaration)
Public Property PayloadTypeName As String
C#
public string PayloadTypeName {get; set;}

Property Value

Can be RAW or some user-defined object type. To specify the payload type as an object type, you must define the object type in the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PrimaryInstance Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : PrimaryInstance Property

The primary owner of the queue table. Queue monitor scheduling and propagation for the queues in the queue table are done in this instance. The default value for primary instance is 0, which means queue monitor scheduling and propagation will be done in any available instance.

Syntax

Visual Basic (Declaration)
Public Property PrimaryInstance As Integer
C#
public int PrimaryInstance {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SecondaryInstance Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : SecondaryInstance Property

The queue table fails over to the secondary instance if the primary instance is not available. The default value is 0, which means that the queue table will fail over to any available instance.

Syntax

Visual Basic (Declaration)
Public Property SecondaryInstance As Integer
C#
public int SecondaryInstance {get; set;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Secure Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : Secure Property

Specifies whether the queue table is used for secure queues. Default value is false.

Syntax

Visual Basic (Declaration)
Public Property Secure As Boolean
C#
public bool Secure {get; set;}

Property Value

true if the queue table can be used for secure queues; otherwise, false.

Remarks

This parameter must be set to true if you want to use the queue table for secure queues. Secure queues are queues for which AQ agents must be associated explicitly with one or more database users who can perform queue operations, such as enqueue and dequeue. The owner of a secure queue can perform all queue operations on the queue, but other users cannot perform queue operations on a secure queue, unless they are configured as secure queue users.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SortOrder Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : SortOrder Property

Specifies which parameter is used to order messages in the queue. The queue will be sorted by this parameter in the ascending order. Default value is OracleQueueSortOrder.EnqueueTime.

Syntax

Visual Basic (Declaration)
Public Property SortOrder As OracleQueueSortOrder
C#
public OracleQueueSortOrder SortOrder {get; set;}

Property Value

One of the OracleQueueSortOrder values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StorageClause Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueTableOptions Class : StorageClause Property

Storage parameter.

Syntax

Visual Basic (Declaration)
Public Property StorageClause As String
C#
public string StorageClause {get; set;}

Remarks

The storage parameter is included in the CREATE TABLE statement when the queue table is created. The StorageClause property can take any text that can be used in a standard CREATE TABLE storage clause argument. If a tablespace is not specified here, then the queue table and all its related objects are created in the default user tablespace. If a tablespace is specified here, then the queue table and all its related objects are created in the tablespace specified in the storage clause.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueTableOptions Class
OracleQueueTableOptions Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRef Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRef Class

Represents a reference to the object (REF).

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleRef

Syntax

Visual Basic (Declaration)
Public Class OracleRef
   Inherits System.MarshalByRefObject
   Implements INullable, ICloneable, IDisposable
C#
public class OracleRef : System.MarshalByRefObject, INullable, ICloneable, IDisposable

Remarks

The OracleRef class is designed to work with references to objects (REF) and get object value represented by an NativeOracleObject or an OracleObject.

Example

This example demonstrates how to retrieve OracleRef object from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE OR REPLACE TYPE TCar AS OBJECT (
  Model VARCHAR2(20),
  Color VARCHAR2(20),
  Year NUMBER
);

CREATE TABLE CarTable of TCar;

INSERT INTO CarTable
  (Model, Color, Year)
VALUES
  ('Mersedes Bens','Black',1999);
INSERT INTO CarTable
  (Model, Color, Year)
VALUES
  ('Ford Taurus','Blue',1998);
INSERT INTO CarTable
  (Model, Color, Year)
VALUES
  ('Renault Cleo','Red',2003);
INSERT INTO CarTable
  (Model, Color, Year)
VALUES
  ('BMW 500','Black',2004);

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT REF(car) FROM CarTable car", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  while (dataReader.Read()) {
    OracleRef oraRef = dataReader.GetOracleRef(0);
    if (!oraRef.IsNull) {
      OracleObject oraObj = (OracleObject)oraRef.GetObject();
      Console.WriteLine(oraObj["Model"]);
      Console.WriteLine("\tColor: " + oraObj["Color"]);
      Console.WriteLine("\tYear: " + oraObj["Year"].ToString());
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT REF(car) FROM CarTable car", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  While dataReader.Read()
    Dim oraRef As OracleRef = dataReader.GetOracleRef(0)
    If Not oraRef.IsNull Then
      Dim oraObj As OracleObject = oraRef.GetObject()
      Console.WriteLine(oraObj("Model"))
      Console.WriteLine(Chr(9) & "Color: " & oraObj("Model"))
      Console.WriteLine(Chr(9) & "Year: " & oraObj("Year"))
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleRef Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleRef Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleRef Class

The following tables list the members exposed by OracleRef.

Public Constructors

 | Name | Description
public Constructor | OracleRef Constructor | Overloaded. Initializes a new instance of the OracleRef class.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets the OracleConnection used by this instance of the OracleRef.
public Property | IsNull | Gets a value indicating whether the reference to the object is null.
public Property | IsPinned | Gets a value indicating whether the object has been received through the specified reference.
public Property | RefType | Gets type of the object that OracleRef is referred to.
public Property | Value | Gets or sets a hexadecimal string representation of the reference to an Oracle object.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of the current OracleRef instance.
public Method | Close | Closes the OracleRef instance and releases any resources associated with it.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Closes the OracleRef instance and releases any resources associated with it.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNativeObject | Gets pinned NativeOracleObject object associated with the specified reference.
public Method | GetObject | Gets pinned OracleObject object associated with the specified reference.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleRef object is equal to the current OracleRef.
public Method | Pin | Overloaded. Creates an object associated with the specified reference.
public Method | ToString | Converts a REF to a hexadecimal string.
public Method | Unpin | Removes an object associated with the specified reference.
Top

See Also

Reference

OracleRef Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRef Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : OracleRef Constructor

Initializes a new instance of the OracleRef class.

Overload List

Overload | Description
OracleRef Constructor(String) | Initializes a new instance of the OracleRef class.
OracleRef Constructor(String,OracleType) | Initializes a new instance of the OracleRef class.
OracleRef Constructor(String,OracleType,OracleConnection) | Initializes a new instance of the OracleRef class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRef Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class > OracleRef Constructor : OracleRef Constructor(String)

value
A hexadecimal string representation of the reference to an Oracle object.
Initializes a new instance of the OracleRef class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
C#
public OracleRef(
   string value
)

Parameters

value
A hexadecimal string representation of the reference to an Oracle object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRef Constructor(String,OracleType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class > OracleRef Constructor : OracleRef Constructor(String,OracleType)

value
A hexadecimal string representation of the reference to an Oracle object.
refType
A type of an Oracle object.
Initializes a new instance of the OracleRef class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal refType As OracleType _
)
C#
public OracleRef(
   string value,
   OracleType refType
)

Parameters

value
A hexadecimal string representation of the reference to an Oracle object.
refType
A type of an Oracle object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRef Constructor(String,OracleType,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class > OracleRef Constructor : OracleRef Constructor(String,OracleType,OracleConnection)

value
A hexadecimal string representation of the reference to an Oracle object.
refType
A type of an Oracle object.
connection
OracleConnection that will be linked with the new OracleRef instance.
Initializes a new instance of the OracleRef class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal refType As OracleType, _
   ByVal connection As OracleConnection _
)
C#
public OracleRef(
   string value,
   OracleType refType,
   OracleConnection connection
)

Parameters

value
A hexadecimal string representation of the reference to an Oracle object.
refType
A type of an Oracle object.
connection
OracleConnection that will be linked with the new OracleRef instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleRef Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRef Class

For a list of all members of this type, see OracleRef members.

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of the current OracleRef instance.
public Method | Close | Closes the OracleRef instance and releases any resources associated with it.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Closes the OracleRef instance and releases any resources associated with it.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNativeObject | Gets pinned NativeOracleObject object associated with the specified reference.
public Method | GetObject | Gets pinned OracleObject object associated with the specified reference.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | IsEqual | Determines whether the specified OracleRef object is equal to the current OracleRef.
public Method | Pin | Overloaded. Creates an object associated with the specified reference.
public Method | ToString | Converts a REF to a hexadecimal string.
public Method | Unpin | Removes an object associated with the specified reference.
Top

See Also

Reference

OracleRef Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Clone Method

Creates a copy of the current OracleRef instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleRef
C#
public OracleRef Clone()

Return Value

An OracleRef instance, identical to the current one.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Close Method

Closes the OracleRef instance and releases any resources associated with it.

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()

Remarks

After closing OracleRef object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Dispose Method

Closes the OracleRef instance and releases any resources associated with it.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

After closing OracleRef object call of any method of this object will throw an System.ObjectDisposedException.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNativeObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : GetNativeObject Method

Gets pinned NativeOracleObject object associated with the specified reference.

Syntax

Visual Basic (Declaration)
Public Function GetNativeObject() As NativeOracleObjectBase
C#
public NativeOracleObjectBase GetNativeObject()

Return Value

An NativeOracleObjectBase associated with the specified reference.

Remarks

To get the object use NativeOracleObjectBase.Flush and Refresh methods.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : GetObject Method

Gets pinned OracleObject object associated with the specified reference.

Syntax

Visual Basic (Declaration)
Public Function GetObject() As Object
C#
public object GetObject()

Return Value

An OracleObject associated with the specified reference.

Remarks

To get the object use NativeOracleObjectBase.Flush and Refresh methods.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : IsEqual Method

other
The OracleRef object to compare with the current OracleRef.
Determines whether the specified OracleRef object is equal to the current OracleRef.

Syntax

Visual Basic (Declaration)
Public Function IsEqual( _
   ByVal other As OracleRef _
) As Boolean
C#
public bool IsEqual(
   OracleRef other
)

Parameters

other
The OracleRef object to compare with the current OracleRef.

Return Value

true if reference to the object is null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pin Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Pin Method

Creates an object associated with the specified reference.

Overload List

Overload | Description
Pin() | Creates an object associated with the specified reference.
Pin(OracleConnection) | Creates an object associated with the specified reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pin() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class > Pin Method : Pin() Method

Creates an object associated with the specified reference.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Pin()
C#
public void Pin()

Remarks

Use GetObject method to retrieve object value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pin(OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class > Pin Method : Pin(OracleConnection) Method

connection
A connection to a data source.
Creates an object associated with the specified reference.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Pin( _
   ByVal connection As OracleConnection _
)
C#
public void Pin(
   OracleConnection connection
)

Parameters

connection
A connection to a data source.

Remarks

Use GetObject method to retrieve the object value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : ToString Method

Converts a REF to a hexadecimal string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A hexadecimal string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unpin Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Unpin Method

Removes an object associated with the specified reference.

Syntax

Visual Basic (Declaration)
Public Sub Unpin()
C#
public void Unpin()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleRef Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRef Class

For a list of all members of this type, see OracleRef members.

Public Properties

 | Name | Description
public Property | Connection | Gets the OracleConnection used by this instance of the OracleRef.
public Property | IsNull | Gets a value indicating whether the reference to the object is null.
public Property | IsPinned | Gets a value indicating whether the object has been received through the specified reference.
public Property | RefType | Gets type of the object that OracleRef is referred to.
public Property | Value | Gets or sets a hexadecimal string representation of the reference to an Oracle object.
Top

See Also

Reference

OracleRef Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Connection Property

Gets the OracleConnection used by this instance of the OracleRef.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Remarks

The connection can be set via the Pin(OracleConnection) overload. Also you can get a ready OracleRef object via the OracleDataReader.GetOracleRef method.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : IsNull Property

Gets a value indicating whether the reference to the object is null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if reference to the object is null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsPinned Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : IsPinned Property

Gets a value indicating whether the object has been received through the specified reference.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPinned As Boolean
C#
public bool IsPinned {get;}

Property Value

true if the object is received by the specified reference; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : RefType Property

Gets type of the object that OracleRef is referred to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RefType As OracleType
C#
public OracleType RefType {get;}

Property Value

The OracleType of the object that OracleRef is referred to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRef Class : Value Property

Gets or sets a hexadecimal string representation of the reference to an Oracle object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
C#
public string Value {get;}

Property Value

Hexadecimal string representation of the reference to an Oracle object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRef Class
OracleRef Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatedEventArgs Class

Provides data for the OracleDataAdapter.RowUpdated event.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Data.Common.RowUpdatedEventArgs
Devart.Data.Oracle.OracleRowUpdatedEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleRowUpdatedEventArgs
   Inherits System.Data.Common.RowUpdatedEventArgs
C#
public class OracleRowUpdatedEventArgs : System.Data.Common.RowUpdatedEventArgs

Remarks

The OracleDataAdapter.RowUpdated event is raised when an update to a row is completed.

When using the System.Data.Common.DbDataAdapter.Update() method, there are two events that occur for each data row updated: OracleDataAdapter.RowUpdating and OracleDataAdapter.RowUpdated. The order of execution for an System.Data.Common.DbDataAdapter.Update() is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The OracleDataAdapter.RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleRowUpdatedEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventArgs Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatedEventArgs Class

The following tables list the members exposed by OracleRowUpdatedEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleRowUpdatedEventArgs Constructor | Initializes a new instance of the OracleRowUpdatedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Command | Gets the OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
public Property | Errors | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command was executed. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | Row | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | RowCount | Gets the number of rows processed in a batch of updated records. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | StatementType | Gets the type of SQL statement executed. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | Status | Gets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | TableMapping | Gets the System.Data.Common.DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatedEventArgs)
Top

Public Methods

 | Name | Description
public Method | CopyToRows | Overloaded. Copies references to the modified rows into the provided array. (Inherited from System.Data.Common.RowUpdatedEventArgs)
Top

See Also

Reference

OracleRowUpdatedEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRowUpdatedEventArgs Class : OracleRowUpdatedEventArgs Constructor

row
The System.Data.DataRow sent through an update operation.
command
The Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through System.Data.Common.DbDataAdapter.Update().
Initializes a new instance of the OracleRowUpdatedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal row As DataRow, _
   ByVal command As IDbCommand, _
   ByVal statementType As StatementType, _
   ByVal tableMapping As DataTableMapping _
)
C#
public OracleRowUpdatedEventArgs(
   DataRow row,
   IDbCommand command,
   StatementType statementType,
   DataTableMapping tableMapping
)

Parameters

row
The System.Data.DataRow sent through an update operation.
command
The Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through System.Data.Common.DbDataAdapter.Update().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRowUpdatedEventArgs Class
OracleRowUpdatedEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatedEventArgs Class

For a list of all members of this type, see OracleRowUpdatedEventArgs members.

Public Properties

 | Name | Description
public Property | Command | Gets the OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.
public Property | Errors | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command was executed. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | RecordsAffected | Gets the number of rows changed, inserted, or deleted by execution of the SQL statement. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | Row | Gets the System.Data.DataRow sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | RowCount | Gets the number of rows processed in a batch of updated records. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | StatementType | Gets the type of SQL statement executed. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | Status | Gets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property. (Inherited from System.Data.Common.RowUpdatedEventArgs)
public Property | TableMapping | Gets the System.Data.Common.DataTableMapping sent through an System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatedEventArgs)
Top

See Also

Reference

OracleRowUpdatedEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Command Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRowUpdatedEventArgs Class : Command Property

Gets the Devart.Data.Oracle.OracleCommand executed when System.Data.Common.DbDataAdapter.Update() is called.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Command As OracleCommand
C#
public new OracleCommand Command {get;}

Property Value

The Devart.Data.Oracle.OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRowUpdatedEventArgs Class
OracleRowUpdatedEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatingEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatingEventArgs Class

Provides data for the OracleDataAdapter.RowUpdating event. This class cannot be inherited.

Inheritance Hierarchy

System.Object
System.EventArgs
System.Data.Common.RowUpdatingEventArgs
Devart.Data.Oracle.OracleRowUpdatingEventArgs

Syntax

Visual Basic (Declaration)
Public Class OracleRowUpdatingEventArgs
   Inherits System.Data.Common.RowUpdatingEventArgs
C#
public class OracleRowUpdatingEventArgs : System.Data.Common.RowUpdatingEventArgs

Remarks

The OracleDataAdapter.RowUpdating event is raised before an update to a row.

When using the System.Data.Common.DbDataAdapter.Update() method, there are two events that occur for each data row updated: OracleDataAdapter.RowUpdating and OracleDataAdapter.RowUpdated. The order of execution for an update operation is as follows:

  1. The values in the System.Data.DataRow are moved to the parameter values.
  2. The OracleDataAdapter.RowUpdating event is raised.
  3. The command executes.
  4. If the System.Data.UpdateRowSource enumeration is set to System.Data.UpdateRowSource.FirstReturnedRecordS, the first returned result is placed in the System.Data.DataRow.
  5. If there are output parameters, they are placed in the System.Data.DataRow.
  6. The OracleDataAdapter.RowUpdated event is raised.
  7. System.Data.DataRow.AcceptChanges is called.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleRowUpdatingEventArgs Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleRowUpdatingEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatingEventArgs Class

The following tables list the members exposed by OracleRowUpdatingEventArgs.

Public Constructors

 | Name | Description
public Constructor | OracleRowUpdatingEventArgs Constructor | Initializes a new instance of the OracleRowUpdatingEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Command | Gets or sets the OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.
public Property | Errors | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command executes. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | Row | Gets the System.Data.DataRow that will be sent to the server as part of an insert, update, or delete operation. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | StatementType | Gets the type of SQL statement to execute. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | Status | Gets or sets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | TableMapping | Gets the System.Data.Common.DataTableMapping to send through the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatingEventArgs)
Top

See Also

Reference

OracleRowUpdatingEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatingEventArgs Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRowUpdatingEventArgs Class : OracleRowUpdatingEventArgs Constructor

row
The System.Data.DataRow to update.
command
The Devart.Data.Oracle.OracleCommand to execute during System.Data.Common.DbDataAdapter.Update() is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through System.Data.Common.DbDataAdapter.Update().
Initializes a new instance of the OracleRowUpdatingEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal row As DataRow, _
   ByVal command As IDbCommand, _
   ByVal statementType As StatementType, _
   ByVal tableMapping As DataTableMapping _
)
C#
public OracleRowUpdatingEventArgs(
   DataRow row,
   IDbCommand command,
   StatementType statementType,
   DataTableMapping tableMapping
)

Parameters

row
The System.Data.DataRow to update.
command
The Devart.Data.Oracle.OracleCommand to execute during System.Data.Common.DbDataAdapter.Update() is called.
statementType
One of the System.Data.StatementType values that specifies the type of query executed.
tableMapping
The System.Data.Common.DataTableMapping sent through System.Data.Common.DbDataAdapter.Update().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRowUpdatingEventArgs Class
OracleRowUpdatingEventArgs Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleRowUpdatingEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatingEventArgs Class

For a list of all members of this type, see OracleRowUpdatingEventArgs members.

Public Properties

 | Name | Description
public Property | Command | Gets or sets the OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.
public Property | Errors | Gets any errors generated by the .NET Framework data provider when the System.Data.Common.RowUpdatedEventArgs.Command executes. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | Row | Gets the System.Data.DataRow that will be sent to the server as part of an insert, update, or delete operation. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | StatementType | Gets the type of SQL statement to execute. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | Status | Gets or sets the System.Data.UpdateStatus of the System.Data.Common.RowUpdatedEventArgs.Command property. (Inherited from System.Data.Common.RowUpdatingEventArgs)
public Property | TableMapping | Gets the System.Data.Common.DataTableMapping to send through the System.Data.Common.DbDataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.RowUpdatingEventArgs)
Top

See Also

Reference

OracleRowUpdatingEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Command Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleRowUpdatingEventArgs Class : Command Property

Gets or sets the Devart.Data.Oracle.OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.

Syntax

Visual Basic (Declaration)
Public Shadows Property Command As OracleCommand
C#
public new OracleCommand Command {get; set;}

Property Value

The Devart.Data.Oracle.OracleCommand to execute when System.Data.Common.DbDataAdapter.Update() is called.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleRowUpdatingEventArgs Class
OracleRowUpdatingEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleScript Class

Serves to execute series of SQL statements separated by special symbols, like SQL*Plus scripts.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Common.DbScript
Devart.Data.Oracle.OracleScript

Syntax

Visual Basic (Declaration)
Public Class OracleScript
   Inherits Devart.Common.DbScript
   Implements IComponent, IDisposable
C#
public class OracleScript : Devart.Common.DbScript, IComponent, IDisposable

Remarks

Often it is necessary to execute several SQL statements one by one. Sometimes it can be performed by anonymous PL/SQL block. But unfortunately it doesn't work always. For example DDL statements cannot be used in PL/SQL. Another way is using a lot of components such as OracleCommand. Usually it isn't a good solution. With only one OracleScript component you can execute several SQL statements as one. This sequence of statements is named script. To separate single statements use semicolon (;) or slash (/) symbols and for PL/SQL only slash. Note: Slash must be the first character in the line.

If you are SQL*Plus user or need to execute scripts written for SQL*Plus with OracleScript, you may find some useful hints in the OracleScript Hints for SQL*Plus Users article.

Example

Following example executes a script and handles script errors.
C#csharp Copy Code
public void ExecuteScript(string sql, OracleConnection conn) {
        OracleScript script = new OracleScript(sql, conn);
        script.Error += new ScriptErrorEventHandler(this.OnError);
        script.Execute();
}

public void OnError(object sender, Devart.Common.ScriptErrorEventArgs e) {
        Console.WriteLine(e.Exception.Message);
        e.Ignore = true;
}
C#Visual Basic Copy Code
Public Sub ExecuteScript(ByVal Sql As String, ByVal conn As OracleConnection)
        Dim Script As OracleScript = New OracleScript(Sql, conn)
        AddHandler Script.Error, AddressOf OnError
        Script.Execute()
End Sub

Public Sub OnError(ByVal Sender As Object, ByVal e As Devart.Common.ScriptErrorEventArgs)
        Console.WriteLine(e.Exception.Message)
        e.Ignore = True
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleScript Members
Devart.Data.Oracle Namespace
OracleCommand Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleScript Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleScript Class

The following tables list the members exposed by OracleScript.

Public Constructors

 | Name | Description
public Constructor | OracleScript Constructor | Overloaded. Initializes a new instance of the OracleScript class.
Top

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time before terminating an attempt to execute a script and generating an error. (Inherited from Devart.Common.DbScript)
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleScript.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets the name of component that will be displayed in dbMonitor application. (Inherited from Devart.Common.DbScript)
public Property | ScriptText | Gets or sets text of the script.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Statements | Gets the collection of statements that make up the script.
Top

Public Methods

 | Name | Description
public Method | Cancel | Tries to cancel the execution of a Devart.Common.DbScript descendant. (Inherited from Devart.Common.DbScript)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes the script specified in Devart.Common.DbScript.ScriptText property. (Inherited from Devart.Common.DbScript)
public Method | ExecuteNext | Overloaded. Executes the next statement from the script.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Prepares a stream to be executed as SQL script. (Inherited from Devart.Common.DbScript)
public Method | Reset | Positions Devart.Common.DbScript.ExecuteNext method on the first statement in the script. (Inherited from Devart.Common.DbScript)
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when a SQL statement within script has produced an error. (Inherited from Devart.Common.DbScript)
public Event | Progress | Occurs when a SQL statement within script has successfully executed. (Inherited from Devart.Common.DbScript)
public Event | SqlStatementExecute | Occurs when a SQL statement within script is about to execute.
Top

See Also

Reference

OracleScript Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : OracleScript Constructor

Initializes a new instance of the OracleScript class.

Overload List

Overload | Description
OracleScript Constructor() | Initializes a new instance of the OracleScript class.
OracleScript Constructor(Stream) | Initializes a new instance of the OracleScript class with a Stream object to get SQL statements from.
OracleScript Constructor(TextReader) | Initializes a new instance of the OracleScript class with a TextReader object to get SQL statements from.
OracleScript Constructor(String) | Initializes a new instance of the OracleScript class with the text of the query.
OracleScript Constructor(Stream,OracleConnection) | Initializes a new instance of the OracleScript class with a Stream object to get SQL statements from and a OracleConnection object.
OracleScript Constructor(TextReader,OracleConnection) | Initializes a new instance of the OracleScript class with a TextReader object to get SQL statements from and a OracleConnection object.
OracleScript Constructor(String,OracleConnection) | Initializes a new instance of the OracleScript class with the text of the query and a OracleConnection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor()

Initializes a new instance of the OracleScript class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleScript()

Remarks

The base constructor initializes all fields to their default values. The following table shows initial values set to the read/write properties when a new instance of OracleScript is created.
Properties | Initial Value
Connection | null
Devart.Common.DbScript.Name | name of the component at design-time
ScriptText | an empty string ("")

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(Stream)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(Stream)

stream
A Stream object that contains the script text.
Initializes a new instance of the OracleScript class with a Stream object to get SQL statements from.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
C#
public OracleScript(
   Stream stream
)

Parameters

stream
A Stream object that contains the script text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(TextReader)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(TextReader)

reader
A TextReader object that contains the script text.
Initializes a new instance of the OracleScript class with a TextReader object to get SQL statements from.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reader As TextReader _
)
C#
public OracleScript(
   TextReader reader
)

Parameters

reader
A TextReader object that contains the script text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(String)
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(String)

scriptText
The text of the query.
Initializes a new instance of the OracleScript class with the text of the query.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scriptText As String _
)
C#
public OracleScript(
   string scriptText
)

Parameters

scriptText
The text of the query.

Example

The following example creates an OracleScript and sets some of its properties.
C#csharp Copy Code
public void CreateScript(OracleConnection conn)
{
  ...
  OracleScript script = new OracleScript(scriptText);
  script.Connection = conn;
  ...
}
C#Visual Basic Copy Code
Public Sub CreateOraLoaderColumn(scriptText as string, conn as OracleConnection)
  ...
  Dim script as OracleScript = new OracleScript(scriptText)
  script.Connection = conn
  ...
End Sub 'CreateOraLoaderColumn

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(Stream,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(Stream,OracleConnection)

stream
A Stream object that contains the script text.
connection
A OracleConnection object that represents the connection to a database.
Initializes a new instance of the OracleScript class with a Stream object to get SQL statements from and a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal connection As OracleConnection _
)
C#
public OracleScript(
   Stream stream,
   OracleConnection connection
)

Parameters

stream
A Stream object that contains the script text.
connection
A OracleConnection object that represents the connection to a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(TextReader,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(TextReader,OracleConnection)

reader
A TextReader object that contains the script text.
connection
A OracleConnection object that represents the connection to a database.
Initializes a new instance of the OracleScript class with a TextReader object to get SQL statements from and a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal reader As TextReader, _
   ByVal connection As OracleConnection _
)
C#
public OracleScript(
   TextReader reader,
   OracleConnection connection
)

Parameters

reader
A TextReader object that contains the script text.
connection
A OracleConnection object that represents the connection to a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleScript Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > OracleScript Constructor : OracleScript Constructor(String,OracleConnection)

scriptText
The text of the query.
connection
A OracleConnection object that represents the connection to a database.
Initializes a new instance of the OracleScript class with the text of the query and a OracleConnection object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scriptText As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleScript(
   string scriptText,
   OracleConnection connection
)

Parameters

scriptText
The text of the query.
connection
A OracleConnection object that represents the connection to a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleScript Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleScript Class

For a list of all members of this type, see OracleScript members.

Public Methods

 | Name | Description
public Method | Cancel | Tries to cancel the execution of a Devart.Common.DbScript descendant. (Inherited from Devart.Common.DbScript)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | Execute | Executes the script specified in Devart.Common.DbScript.ScriptText property. (Inherited from Devart.Common.DbScript)
public Method | ExecuteNext | Overloaded. Executes the next statement from the script.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Open | Overloaded. Prepares a stream to be executed as SQL script. (Inherited from Devart.Common.DbScript)
public Method | Reset | Positions Devart.Common.DbScript.ExecuteNext method on the first statement in the script. (Inherited from Devart.Common.DbScript)
Top

See Also

Reference

OracleScript Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNext Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : ExecuteNext Method

Executes the next statement from the script.

Overload List

Overload | Description
ExecuteNext(OracleDataReader) | Executes the next statement from the script.
ExecuteNext(IDataReader) | Executes the next statement from the script. (Inherited from Devart.Common.DbScript)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNext(OracleDataReader) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class > ExecuteNext Method : ExecuteNext(OracleDataReader) Method

reader
An OracleDataReader to store result set.
Executes the next statement from the script.

Syntax

Visual Basic (Declaration)
Public Overloads Function ExecuteNext( _
   ByRef reader As OracleDataReader _
) As Boolean
C#
public bool ExecuteNext(
   out OracleDataReader reader
)

Parameters

reader
An OracleDataReader to store result set.

Return Value

true if there are more statements to execute; otherwise, false.

Remarks

Use the ExecuteNext(OracleDataReader) method to execute the statements from the script one by one. Text of the script should be specified by ScriptText property.

After the method has executed, the Devart.Common.DbScript.Progress event fires, where you can obtain statement text and process query results. If the statement has produced an error, event Devart.Common.DbScript.Error fires.

To restart execution from the beginning of the script call Devart.Common.DbScript.Reset method. When ScriptText property is modified, OracleScript automatically positions on the first statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleScript Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleScript Class

For a list of all members of this type, see OracleScript members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time before terminating an attempt to execute a script and generating an error. (Inherited from Devart.Common.DbScript)
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleScript.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Name | Gets or sets the name of component that will be displayed in dbMonitor application. (Inherited from Devart.Common.DbScript)
public Property | ScriptText | Gets or sets text of the script.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Statements | Gets the collection of statements that make up the script.
Top

See Also

Reference

OracleScript Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : Connection Property

Gets or sets the OracleConnection used by this instance of the OracleScript.

Syntax

Visual Basic (Declaration)
Public Shadows Property Connection As OracleConnection
C#
public new OracleConnection Connection {get; set;}

Property Value

The connection to a data source. The default value is a null reference.

Remarks

You must set Connection property before the script execution.

This property supports the InterForm technology.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
OracleConnection Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptText Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : ScriptText Property

Gets or sets text of the script.

Syntax

Visual Basic (Declaration)
Public Shadows Property ScriptText As String
C#
public new string ScriptText {get; set;}

Property Value

Script text. The default value is an empty string ("").

Remarks

Use ScriptText property to specify text of the script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Statements Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : Statements Property

Gets the collection of statements that make up the script.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Statements As OracleSqlStatementCollection
C#
public new OracleSqlStatementCollection Statements {get;}

Property Value

The collection of the script statements.

Remarks

Use the Statements to obtain OracleSqlStatementCollection, which allows accessing individual statements of the script and executing them manually. The collection is read-only, so you cannot modify it in any way. It is also bound to the originating OracleScript object, which means that if you have altered ScriptText, a previously obtained collection will be cleared.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleScript Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleScript Class

For a list of all members of this type, see OracleScript members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | Error | Occurs when a SQL statement within script has produced an error. (Inherited from Devart.Common.DbScript)
public Event | Progress | Occurs when a SQL statement within script has successfully executed. (Inherited from Devart.Common.DbScript)
public Event | SqlStatementExecute | Occurs when a SQL statement within script is about to execute.
Top

See Also

Reference

OracleScript Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementExecute Event
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleScript Class : SqlStatementExecute Event

Occurs when a SQL statement within script is about to execute.

Syntax

Visual Basic (Declaration)
Public Event SqlStatementExecute As SqlStatementExecuteEventHandler
C#
public event SqlStatementExecuteEventHandler SqlStatementExecute

Event Data

The event handler receives an argument of type SqlStatementExecuteEventArgs containing data related to this event. The following SqlStatementExecuteEventArgs properties provide information specific to this event.

Property | Description
Length (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets length of the statement in symbols.
LineNumber (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets number of line in the whole script where the statement can be located.
LinePosition (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets position of the statement in its line.
Offset (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets offset of the statement in the whole script text.
Reader | Gets or sets an OracleDataReader that represents statement resultset.
SqlPlusStatementType | Gets type of SQL*Plus statement.
StatementStatus (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Determines status of the statement and script execution.
StatementType (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets type of the statement.
Text (Inherited from Devart.Common.DbStatementExecuteEventArgs) | Gets the SQL statement that is about to be executed.

Remarks

You can find a sample of using this event in the OracleScript Hints for SQL*Plus Users article.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleScript Class
OracleScript Members
SqlStatementExecuteEventHandler Delegate
SqlStatementExecuteEventArgs Class


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSelectStatement Class

Represents a SELECT statement.

Inheritance Hierarchy

System.Object
Devart.Common.SelectStatement
Devart.Data.Oracle.OracleSelectStatement

Syntax

Visual Basic (Declaration)
Public NotInheritable Class OracleSelectStatement
   Inherits Devart.Common.SelectStatement
C#
public sealed class OracleSelectStatement : Devart.Common.SelectStatement

Example

The following example demonstrates how to use the Devart.Data.Oracle.OracleSelectStatement class.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();

stmt.Columns.Add(new SelectColumn("test", "td", "dname", "Department"));
stmt.Columns.Add(new SelectColumn("", "td", "loc", "Location"));
stmt.Columns.Add(new SelectColumn("", "te", "ename", "Name"));

stmt.Tables.Add(new SelectTable("test", "dept", "td"));
stmt.Tables.Add(new SelectTable("", "emp", "te"));

stmt.GroupBy.Add(new SelectColumn("", "te", "empno", ""));
stmt.OrderBy.Add(new SelectColumn("", "te", "ename", ""));
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement

stmt.Columns.Add(New SelectColumn("test", "td", "dname", "Department"))
stmt.Columns.Add(New SelectColumn("", "td", "loc", "Location"))
stmt.Columns.Add(New SelectColumn("", "te", "ename", "Name"))

stmt.Tables.Add(New SelectTable("test", "dept", "td"))
stmt.Tables.Add(New SelectTable("", "emp", "te"))

stmt.GroupBy.Add(New SelectColumn("", "te", "empno", ""))
stmt.OrderBy.Add(New SelectColumn("", "te", "ename", ""))

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSelectStatement Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleSelectStatement Class

The following tables list the members exposed by OracleSelectStatement.

Public Constructors

 | Name | Description
public Constructor | OracleSelectStatement Constructor | Creates a new instance of the Devart.Data.Oracle.OracleSelectStatement class.
Top

Public Properties

 | Name | Description
public Property | All | Gets or sets the value, indicating if the all records are selected or only the unique ones. (Inherited from Devart.Common.SelectStatement)
public Property | Columns | Contains list of columns and expressions used in the select-list of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Distinct | Gets or sets whether statement should request unique rows only. (Inherited from Devart.Common.SelectStatement)
public Property | GroupBy | Contains list of columns used in the GROUP BY clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Having | Gets or sets HAVING clause of the statement. (Inherited from Devart.Common.SelectStatement)
public Property | OrderBy | Contains list of columns used in the ORDER BY clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Tables | Contains list of tables and subqueries used in the FROM clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Where | Gets or sets WHERE clause of the statement. (Inherited from Devart.Common.SelectStatement)
Top

Public Methods

 | Name | Description
public Method | AddHavingCondition | Adds new condition to HAVING clause of the statement, represented by the Having property. (Inherited from Devart.Common.SelectStatement)
public Method | AddWhereCondition | Adds new condition to WHERE clause of the statement, represented by the Where property. (Inherited from Devart.Common.SelectStatement)
public Method | Clear | Overridden. Clears all parts of the Devart.Data.Oracle.OracleSelectStatement.
static (Shared in Visual Basic) | Parse | Converts the specified SELECT statement to a Devart.Data.Oracle.OracleSelectStatement object.
static (Shared in Visual Basic) | TryParse | Tries to convert the specified SELECT statement to a Devart.Data.Oracle.OracleSelectStatement object.
Top

See Also

Reference

OracleSelectStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Constructor
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : OracleSelectStatement Constructor

Creates a new instance of the OracleSelectStatement class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleSelectStatement()

Example

The following example demonstrates how to use the OracleSelectStatement constructor.
C#csharp Copy Code
OracleSelectStatement stmt = new OracleSelectStatement();
stmt.Columns.Add(new SelectColumn("JOB"));
stmt.Tables.Add(new SelectTable("emp"));

stmt.Distinct = true;

//select distinct JOB from emp
string queryText = stmt.ToString();
C#Visual Basic Copy Code
Dim stmt As New OracleSelectStatement
stmt.Columns.Add(New SelectColumn("JOB"))
stmt.Tables.Add(New SelectTable("emp"))
stmt.Distinct = True

'select distinct JOB from emp
Dim queryText As String = stmt.ToString

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSelectStatement Class

For a list of all members of this type, see OracleSelectStatement members.

Public Methods

 | Name | Description
public Method | AddHavingCondition | Adds new condition to HAVING clause of the statement, represented by the Having property. (Inherited from Devart.Common.SelectStatement)
public Method | AddWhereCondition | Adds new condition to WHERE clause of the statement, represented by the Where property. (Inherited from Devart.Common.SelectStatement)
public Method | Clear | Overridden. Clears all parts of the Devart.Data.Oracle.OracleSelectStatement.
static (Shared in Visual Basic) | Parse | Converts the specified SELECT statement to a Devart.Data.Oracle.OracleSelectStatement object.
static (Shared in Visual Basic) | TryParse | Tries to convert the specified SELECT statement to a Devart.Data.Oracle.OracleSelectStatement object.
Top

See Also

Reference

OracleSelectStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : Clear Method

Clears all parts of the OracleSelectStatement.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Clear()
C#
public override void Clear()

Remarks

Call OracleSelectStatement to empty all properties of the OracleSelectStatement object.

Example

The following example demonstrates how to use the Clear method.
C#csharp Copy Code
private void RefreshStatement(OracleSelectStatement stmt)
{
  stmt.Clear();
  stmt.Columns.Add(new SelectColumn("ENAME"));
  stmt.Columns.Add(new SelectColumn("", "emp", "JOB", "j"));
  stmt.Columns.Add(new SelectColumn("test", "", "emp", "HIREDATE", "hd"));

  stmt.Tables.Add(new SelectTable("emp"));

  //select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  string queryText = stmt.ToString();
}
C#Visual Basic Copy Code
Private Sub RefreshStatement(ByVal stmt As OracleSelectStatement)
  stmt.Clear()
  stmt.Columns.Add(New SelectColumn("ENAME"))
  stmt.Columns.Add(New SelectColumn("", "emp", "JOB", "j"))
  stmt.Columns.Add(New SelectColumn("test", "", "emp", "HIREDATE", "hd"))
  stmt.Tables.Add(New SelectTable("emp"))
  'select ENAME,emp.JOB j,Test.emp.HIREDATE hd from emp
  Dim queryText As String = stmt.ToString
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String,ParserBehavior) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : Parse(String,ParserBehavior) Method

text
The statement to parse.
behavior
One of the Devart.Common.ParserBehavior values. Determines what parts of the statement to analyze.
Converts the specified SELECT statement to a OracleSelectStatement object.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal text As String, _
   ByVal behavior As ParserBehavior _
) As OracleSelectStatement
C#
public static OracleSelectStatement Parse(
   string text,
   ParserBehavior behavior
)

Parameters

text
The statement to parse.
behavior
One of the Devart.Common.ParserBehavior values. Determines what parts of the statement to analyze.

Return Value

A OracleSelectStatement object that represents the specified SELECT statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members
TryParse(String,ParserBehavior,OracleSelectStatement) Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,ParserBehavior,OracleSelectStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : TryParse(String,ParserBehavior,OracleSelectStatement) Method

text
The statement to parse.
behavior
One of the Devart.Common.ParserBehavior values. Determines what parts of the statement to analyze.
statement
A OracleSelectStatement object that represents the specified SELECT statement.
Tries to convert the specified SELECT statement to a OracleSelectStatement object.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal text As String, _
   ByVal behavior As ParserBehavior, _
   ByRef statement As OracleSelectStatement _
) As Boolean
C#
public static bool TryParse(
   string text,
   ParserBehavior behavior,
   out OracleSelectStatement statement
)

Parameters

text
The statement to parse.
behavior
One of the Devart.Common.ParserBehavior values. Determines what parts of the statement to analyze.
statement
A OracleSelectStatement object that represents the specified SELECT statement.

Return Value

true if the conversion was successful; otherwise, false

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members
Parse(String,ParserBehavior) Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSqlStatement Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatement Class

Represents a SQL statement.

Inheritance Hierarchy

System.Object
Devart.Common.SqlStatement
Devart.Data.Oracle.OracleSqlStatement

Syntax

Visual Basic (Declaration)
Public Class OracleSqlStatement
   Inherits Devart.Common.SqlStatement
C#
public class OracleSqlStatement : Devart.Common.SqlStatement

Example

The following example demonstrates how to use the OracleSqlStatement class.
C#csharp Copy Code
string script =
        "DROP TABLE DEPT;" +
        "CREATE TABLE DEPT (" +
        "  DEPTNO NUMBER(38) NOT NULL," +
        "  DNAME VARCHAR2(14)," +
        "  LOC VARCHAR2(13)" +
        ");" +
        "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" +
        "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" +
        "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" +
        "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" +
        "SELECT * FROM DEPT";
OracleConnection myConn = new OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110");

OracleScript myScript = new OracleScript(script, myConn);
OracleSqlStatementCollection myColl = myScript.Statements;
IDataReader myReader;
myConn.Open();
foreach (OracleSqlStatement myStatement in myColl)
{
    Console.WriteLine(myStatement.Text);
    try
    {
        myReader = myStatement.Execute();
        Console.WriteLine("  Records affected " + myReader.RecordsAffected);
        while (myReader.Read())
        {
            Console.WriteLine(myReader.GetString(0));
        }
        myReader.Close();
        Console.WriteLine();
     }
     catch
     {
         Console.WriteLine("  Failed");
     }
}
myConn.Close();
C#Visual Basic Copy Code
Dim script As String = _
        "DROP TABLE DEPT;" & _
        "CREATE TABLE DEPT (" + _
        "  DEPTNO NUMBER(38) NOT NULL," & _
        "  DNAME VARCHAR2(14)," & _
        "  LOC VARCHAR2(13)" & _
        ");" & _
        "INSERT INTO DEPT VALUES (10,'ACCOUNTING','NEW YORK');" & _
        "INSERT INTO DEPT VALUES (20,'RESEARCH','DALLAS');" & _
        "INSERT INTO DEPT VALUES (30,'SALES','CHICAGO');" & _
        "INSERT INTO DEPT VALUES (40,'OPERATIONS','BOSTON');" & _
        "SELECT * FROM DEPT";
Dim myConn As New OracleConnection("User Id=Scott;Password=tiger;Data Source=Ora1110")

Dim myScript As New OracleScript(script, myConn)
Dim myColl As OracleSqlStatementCollection = myScript.Statements
myConn.Open
Dim myStatement As OracleSqlStatement
For Each myStatement In myColl
    Console.WriteLine(myStatement.Text)
    Try
        Dim myReader As IDataReader = myStatement.Execute
        Console.WriteLine(("  Records affected " & myReader.RecordsAffected))
        Do While myReader.Read
            Console.WriteLine(myReader.GetString(0))
        Loop
        myReader.Close
        Console.WriteLine
    Catch obj1 As Object
        Console.WriteLine("  Failed")
    End Try
Next
myConn.Close

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSqlStatement Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatement Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatement Class

The following tables list the members exposed by OracleSqlStatement.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols. (Inherited from Devart.Common.SqlStatement)
public Property | LineNumber | Gets number of line in the whole script where the statement can be located. (Inherited from Devart.Common.SqlStatement)
public Property | LinePosition | Gets position of the statement in its line. (Inherited from Devart.Common.SqlStatement)
public Property | Offset | Gets offset of the statement in the whole script text. (Inherited from Devart.Common.SqlStatement)
public Property | SqlPlusStatementType | Gets type of SQL*PLUS statement.
public Property | StatementType | Gets type of the statement. (Inherited from Devart.Common.SqlStatement)
public Property | Text | Gets SQL statement to be executed. (Inherited from Devart.Common.SqlStatement)
Top

Public Methods

 | Name | Description
public Method | Execute | Executes the statement.
public Method | ExecuteNonQuery | Executes the statement. (Inherited from Devart.Common.SqlStatement)
Top

See Also

Reference

OracleSqlStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatement Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatement Class

For a list of all members of this type, see OracleSqlStatement members.

Public Methods

 | Name | Description
public Method | Execute | Executes the statement.
public Method | ExecuteNonQuery | Executes the statement. (Inherited from Devart.Common.SqlStatement)
Top

See Also

Reference

OracleSqlStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Execute Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatement Class : Execute Method

Executes the statement. Executes the statement.

Syntax

Visual Basic (Declaration)
Public Shadows Function Execute() As OracleDataReader
C#
public new OracleDataReader Execute()

Return Value

An OracleDataReader to store result set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatement Class
OracleSqlStatement Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatement Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatement Class

For a list of all members of this type, see OracleSqlStatement members.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols. (Inherited from Devart.Common.SqlStatement)
public Property | LineNumber | Gets number of line in the whole script where the statement can be located. (Inherited from Devart.Common.SqlStatement)
public Property | LinePosition | Gets position of the statement in its line. (Inherited from Devart.Common.SqlStatement)
public Property | Offset | Gets offset of the statement in the whole script text. (Inherited from Devart.Common.SqlStatement)
public Property | SqlPlusStatementType | Gets type of SQL*PLUS statement.
public Property | StatementType | Gets type of the statement. (Inherited from Devart.Common.SqlStatement)
public Property | Text | Gets SQL statement to be executed. (Inherited from Devart.Common.SqlStatement)
Top

See Also

Reference

OracleSqlStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlPlusStatementType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatement Class : SqlPlusStatementType Property

Gets type of SQL*PLUS statement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlPlusStatementType As SqlPlusStatementType
C#
public SqlPlusStatementType SqlPlusStatementType {get;}

Property Value

One of the SqlPlusStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatement Class
OracleSqlStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSqlStatementCollection Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatementCollection Class

Represents a list of OracleSqlStatement objects.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Devart.Common.SqlStatementCollection
Devart.Data.Oracle.OracleSqlStatementCollection

Syntax

Visual Basic (Declaration)
Public Class OracleSqlStatementCollection
   Inherits Devart.Common.SqlStatementCollection
   Implements ICollection(Of OracleSqlStatement), IEnumerable(Of OracleSqlStatement), IList(Of OracleSqlStatement), ICollection, IEnumerable, IList
C#
public class OracleSqlStatementCollection : Devart.Common.SqlStatementCollection, ICollection<OracleSqlStatement>, IEnumerable<OracleSqlStatement>, IList<OracleSqlStatement>, ICollection, IEnumerable, IList

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSqlStatementCollection Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatementCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatementCollection Class

The following tables list the members exposed by OracleSqlStatementCollection.

Public Constructors

 | Name | Description
public Constructor | OracleSqlStatementCollection Constructor | Initializes a new instance of the OracleSqlStatementCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the OracleSqlStatement at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an OracleSqlStatement object to the end of collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a OracleSqlStatement object exists in the collection.
public Method | CopyTo | Overloaded. Copies OracleSqlStatement objects from the OracleSqlStatementCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location of the OracleSqlStatement object in the collection.
public Method | Insert | Overloaded. Inserts an OracleSqlStatement object into collection in the specified location.
public Method | Remove | Overloaded. Removes an OracleSqlStatement object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleSqlStatementCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSqlStatementCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : OracleSqlStatementCollection Constructor

Initializes a new instance of the OracleSqlStatementCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleSqlStatementCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatementCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatementCollection Class

For a list of all members of this type, see OracleSqlStatementCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds an OracleSqlStatement object to the end of collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Overloaded. Gets a value indicating whether a OracleSqlStatement object exists in the collection.
public Method | CopyTo | Overloaded. Copies OracleSqlStatement objects from the OracleSqlStatementCollection to the specified array.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Gets the location of the OracleSqlStatement object in the collection.
public Method | Insert | Overloaded. Inserts an OracleSqlStatement object into collection in the specified location.
public Method | Remove | Overloaded. Removes an OracleSqlStatement object from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleSqlStatementCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : Add Method

Adds an OracleSqlStatement object to the end of collection.

Overload List

Overload | Description
Add(OracleSqlStatement) | Adds an OracleSqlStatement object to the end of collection.
Add | Not used in Devart.Common.SqlStatementCollection. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleSqlStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > Add Method : Add(OracleSqlStatement) Method

value
Instance of an OracleSqlStatement to be added.
Adds an OracleSqlStatement object to the end of collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal value As OracleSqlStatement _
) As Integer
C#
public int Add(
   OracleSqlStatement value
)

Parameters

value
Instance of an OracleSqlStatement to be added.

Return Value

Index af the added OracleSqlStatement in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : Contains Method

Gets a value indicating whether a OracleSqlStatement object exists in the collection.

Overload List

Overload | Description
Contains(OracleSqlStatement) | Gets a value indicating whether a OracleSqlStatement object exists in the collection.
Contains | Gets a value indicating whether a Devart.Common.SqlStatement object exists in the collection. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains(OracleSqlStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > Contains Method : Contains(OracleSqlStatement) Method

value
The OracleSqlStatement object to find.
Gets a value indicating whether a OracleSqlStatement object exists in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal value As OracleSqlStatement _
) As Boolean
C#
public bool Contains(
   OracleSqlStatement value
)

Parameters

value
The OracleSqlStatement object to find.

Return Value

true if the collection contains the OracleSqlStatement; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : CopyTo Method

Copies OracleSqlStatement objects from the OracleSqlStatementCollection to the specified array.

Overload List

Overload | Description
CopyTo(OracleSqlStatement[],Int32) | Copies OracleSqlStatement objects from the OracleSqlStatementCollection to the specified array.
CopyTo | Copies Devart.Common.SqlStatement objects from the Devart.Common.SqlStatementCollection to the specified array. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CopyTo(OracleSqlStatement[],Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > CopyTo Method : CopyTo(OracleSqlStatement[],Int32) Method

array
The array to copy the OracleSqlStatement objects into.
index
The zero-based index in array at which copying begins.
Copies OracleSqlStatement objects from the OracleSqlStatementCollection to the specified array.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As OracleSqlStatement, _
   ByVal index As Integer _
)
C#
public void CopyTo(
   OracleSqlStatement[] array,
   int index
)

Parameters

array
The array to copy the OracleSqlStatement objects into.
index
The zero-based index in array at which copying begins.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : IndexOf Method

Gets the location of the OracleSqlStatement object in the collection.

Overload List

Overload | Description
IndexOf(OracleSqlStatement) | Gets the location of the OracleSqlStatement object in the collection.
IndexOf | Gets the location in the collection of the Devart.Common.SqlStatement object. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IndexOf(OracleSqlStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > IndexOf Method : IndexOf(OracleSqlStatement) Method

value
The OracleSqlStatement object to find.
Gets the location of the OracleSqlStatement object in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As OracleSqlStatement _
) As Integer
C#
public int IndexOf(
   OracleSqlStatement value
)

Parameters

value
The OracleSqlStatement object to find.

Return Value

The zero-based location of the OracleSqlStatement in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : Insert Method

Inserts an OracleSqlStatement object into collection in the specified location.

Overload List

Overload | Description
Insert(Int32,OracleSqlStatement) | Inserts an OracleSqlStatement object into collection in the specified location.
Insert | Not used in Devart.Common.SqlStatementCollection. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Insert(Int32,OracleSqlStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > Insert Method : Insert(Int32,OracleSqlStatement) Method

index
A location OracleSqlStatement should be inserted in. Must be non-negative and less than the size of the collection.
value
An OracleSqlStatement object to insert.
Inserts an OracleSqlStatement object into collection in the specified location.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Insert( _
   ByVal index As Integer, _
   ByVal value As OracleSqlStatement _
)
C#
public void Insert(
   int index,
   OracleSqlStatement value
)

Parameters

index
A location OracleSqlStatement should be inserted in. Must be non-negative and less than the size of the collection.
value
An OracleSqlStatement object to insert.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : Remove Method

Removes an OracleSqlStatement object from the collection.

Overload List

Overload | Description
Remove(OracleSqlStatement) | Removes an OracleSqlStatement object from the collection.
Remove | Not used in Devart.Common.SqlStatementCollection. (Inherited from Devart.Common.SqlStatementCollection)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Remove(OracleSqlStatement) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class > Remove Method : Remove(OracleSqlStatement) Method

value
An OracleSqlStatement object to remove.
Removes an OracleSqlStatement object from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Remove( _
   ByVal value As OracleSqlStatement _
)
C#
public void Remove(
   OracleSqlStatement value
)

Parameters

value
An OracleSqlStatement object to remove.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSqlStatementCollection Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSqlStatementCollection Class

For a list of all members of this type, see OracleSqlStatementCollection members.

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the OracleSqlStatement at the specified index.
Top

See Also

Reference

OracleSqlStatementCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSqlStatementCollection Class : Item Property

index
The zero-based index of the statement.
Gets or sets the OracleSqlStatement at the specified index.

Syntax

Visual Basic (Declaration)
Public Shadows Default Property Item( _
   ByVal index As Integer _
) As OracleSqlStatement
C#
public new OracleSqlStatement this(
   int index
) {get; set;}

Parameters

index
The zero-based index of the statement.

Property Value

The OracleSqlStatement at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSqlStatementCollection Class
OracleSqlStatementCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTable Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTable Class

Represents a client-side cached Oracle Nested table type.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleArray
Devart.Data.Oracle.OracleTable

Syntax

Visual Basic (Declaration)
Public Class OracleTable
   Inherits OracleArray
   Implements ICustomOracleArray, ICollection, IEnumerable, IList, IListSource, INullable, ICloneable
C#
public class OracleTable : OracleArray, ICustomOracleArray, ICollection, IEnumerable, IList, IListSource, INullable, ICloneable

Remarks

The behavior of the OracleTable is similar to OracleArray class. The main difference is that OracleTable can contain unlimited number of the elements.

Note that OracleTable can be used in data binding with DataGrid as it implements IListSource interface.

Example

This example demonstrates how to retrieve OracleTable object from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE OR REPLACE TYPE TEmployees AS
  TABLE OF VARCHAR2(40);

CREATE TABLE CompanyEmpObject (
  Code NUMBER PRIMARY KEY,
  Company VARCHAR2(40),
  Employees TEmployees
)NESTED TABLE Employees STORE AS N_TAB;

INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (1, 'Microsoft', TEmployees('PROGRAMMER', 'MANAGER', 'ELECTRICIAN', 'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (2, 'Borland', TEmployees('PROGRAMMER', 'ELECTRICIAN', 'COURIER'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (3, 'MC Donalds', TEmployees('SHOP ASSISTANT', 'CLERK',  'CLEANUP MEN'));
INSERT INTO CompanyEmpObject
  (Code, Company, Employees)
VALUES
  (4, 'Ford', TEmployees('MECHANICIAN', 'MANAGER'));

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM CompanyEmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Employees");
  while (dataReader.Read()) {
    OracleTable oraTable = dataReader.GetOracleTable(index);
    if (!oraTable.IsNull) {
      string[] employees = new string[oraTable.Count];
      for (int i = 0; i < oraTable.Count; i++)
        employees[i] = (string)oraTable[i];

      Console.WriteLine("Company: " + dataReader.GetString(1));
      foreach (string str in employees)
        Console.WriteLine("\t" + str);
    }
    else{
      Console.WriteLine("Company: " + dataReader.GetString(1));
      Console.WriteLine("No vacancies");
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
Console.ReadLine();
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM CompanyEmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Employees")
  While dataReader.Read()
    Dim oraTable As OracleTable = dataReader.GetOracleTable(index)
    If Not oraTable.IsNull Then
      Dim employees(oraTable.Count) As String
      Dim I As Integer
      For I = 0 To oraTable.Count - 1
        employees(I) = oraTable(I)
      Next I
      Console.WriteLine("Company: " & dataReader.GetString(1))
      For Each str As String In employees
        Console.WriteLine(Chr(9) & str)
      Next
    Else
      Console.WriteLine("Company: " & dataReader.GetString(1))
      Console.WriteLine("No vacancies")
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleTable Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleTable Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleTable Class

The following tables list the members exposed by OracleTable.

Public Constructors

 | Name | Description
public Constructor | OracleTable Constructor | Initializes a new instance of the OracleTable class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets the number of elements that the OracleArray can contain. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | Count | Gets the number of elements contained in the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsFixedSize | Gets a value indicating whether the OracleArray has a fixed size. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsNull | Indicates whether or not the OracleArray represents a null value. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsReadOnly | Gets a value indicating whether the OracleArray is read-only. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsSynchronized | Gets a value indicating whether access to the OracleArray is synchronized (thread-safe). (Inherited from Devart.Data.Oracle.OracleArray)
public Property | Item | Gets or sets the element at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
static (Shared in Visual Basic) | Null | Represents a null value of an OracleTable object.
public Property | ObjectType | Gets type of the objects in the array. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Clear | Removes all elements from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Clone | Creates a copy of an OracleArray object. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Contains | Determines whether an element is in the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | CopyTo | Copies the entire OracleArray to a compatible System.Array starting at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | GetEnumerator | Returns an enumerator for the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | IndexOf | Gets the location in the collection of the OracleArray object. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Insert | Inserts an OracleArray into the collection at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Remove | Removes the specified element from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | RemoveAt | Removes the element at the specified index from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
Top

See Also

Reference

OracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTable Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTable Class : OracleTable Constructor

oraType
An OracleType to create a new instance of the OracleTable. This should be the nested table type, not the type of objects of which the table consists.
Initializes a new instance of the OracleTable class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oraType As OracleType _
)
C#
public OracleTable(
   OracleType oraType
)

Parameters

oraType
An OracleType to create a new instance of the OracleTable. This should be the nested table type, not the type of objects of which the table consists.

Remarks

Use this constructor to create an OracleTable and pass it as a parameter by assigning to Devart.Common.DbParameterBase.Value at the time of initialization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTable Class
OracleTable Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleTable Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTable Class

For a list of all members of this type, see OracleTable members.

Public Properties

 | Name | Description
public Property | Capacity | Gets the number of elements that the OracleArray can contain. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | Count | Gets the number of elements contained in the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsFixedSize | Gets a value indicating whether the OracleArray has a fixed size. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsNull | Indicates whether or not the OracleArray represents a null value. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsReadOnly | Gets a value indicating whether the OracleArray is read-only. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | IsSynchronized | Gets a value indicating whether access to the OracleArray is synchronized (thread-safe). (Inherited from Devart.Data.Oracle.OracleArray)
public Property | Item | Gets or sets the element at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
static (Shared in Visual Basic) | Null | Represents a null value of an OracleTable object.
public Property | ObjectType | Gets type of the objects in the array. (Inherited from Devart.Data.Oracle.OracleArray)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
Top

See Also

Reference

OracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTable Class : Null Property

Represents a null value of an OracleTable object.

Syntax

Visual Basic (Declaration)
Public Shared Shadows ReadOnly Property Null As OracleTable
C#
public new static OracleTable Null {get;}

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTable Class
OracleTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTrace Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

Controls server side SQL and PL/SQL tracing.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Devart.Data.Oracle.OracleTrace

Syntax

Visual Basic (Declaration)
Public Class OracleTrace
   Inherits System.ComponentModel.Component
   Implements IComponent, IDisposable
C#
public class OracleTrace : System.ComponentModel.Component, IComponent, IDisposable

Remarks

Use OracleTrace component to start and stop the SQL trace for a session. The component also provides access to functionality of DBMS_TRACE package to control the PL/SQL trace. See Using OracleTrace Component for more information.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleTrace Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleTrace Class Members
See Also Fields Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

The following tables list the members exposed by OracleTrace.

Public Constructors

 | Name | Description
public Constructor | OracleTrace Constructor | Overloaded. Initializes a new instance of the OracleTrace class.
Top

Public Fields

 | Name | Description
public Field | DefaultTraceFileSize | Specifies the server default trace file size. Stands for the server default value of the trace file maximum size.
public Field | UnlimitedTraceFileSize | Specifies the unlimited size of the trace file.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets OracleConnection object used for communicating with server.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Enabled | Gets or sets a value that indicates whether tracing is enabled.
public Property | MaxTraceFileSize | Gets or sets the maximum size of SQL trace dump file.
public Property | PlSqlTraceMode | Gets or sets the trace mode for the PL/SQL trace.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | SqlTraceMode | Gets or sets the trace mode for the SQL trace.
public Property | State | Gets a value that indicates which trace modes are active.
public Property | TraceFileIdentifier | Gets or sets a file name suffix for the SQL trace dump file.
Top

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetTraceFileName | Returns the name for a dump file on the database server where SQL trace data is written.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | PlSqlTraceComment | Sets a comment on PL/SQL trace.
public Method | PlSqlTraceLimit | Overloaded. Limits the amount of storage used in the database for the PL/SQL trace data.
public Method | PlSqlTracePause | Pauses PL/SQL tracing.
public Method | PlSqlTraceResume | Resumes PL/SQL tracing.
public Method | PlSqlTraceRunNumber | Returns a run number for the current PL/SQL trace.
public Method | PlSqlTraceStart | Starts PL/SQL tracing. This method leaves the SQL tracing state unchanged.
public Method | PlSqlTraceStop | Stops PL/SQL tracing. This method leaves the SQL tracing state unchanged.
public Method | SqlTraceStart | Starts SQL tracing. This method leaves the PL/SQL tracing state unchanged.
public Method | SqlTraceStop | Stops SQL tracing. This method leaves the PL/SQL tracing state unchanged.
Top

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleTrace Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTrace Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : OracleTrace Constructor

Initializes a new instance of the OracleTrace class.

Overload List

Overload | Description
OracleTrace Constructor() | Initializes a new instance of the OracleTrace class.
OracleTrace Constructor(OracleConnection) | Initializes a new instance of the OracleTrace class and assigns an OracleConnection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTrace Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class > OracleTrace Constructor : OracleTrace Constructor()

Initializes a new instance of the OracleTrace class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleTrace()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTrace Constructor(OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class > OracleTrace Constructor : OracleTrace Constructor(OracleConnection)

connection
An OracleConnection object to use.
Initializes a new instance of the OracleTrace class and assigns an OracleConnection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection _
)
C#
public OracleTrace(
   OracleConnection connection
)

Parameters

connection
An OracleConnection object to use.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleTrace Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

For a list of all members of this type, see OracleTrace members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetTraceFileName | Returns the name for a dump file on the database server where SQL trace data is written.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | PlSqlTraceComment | Sets a comment on PL/SQL trace.
public Method | PlSqlTraceLimit | Overloaded. Limits the amount of storage used in the database for the PL/SQL trace data.
public Method | PlSqlTracePause | Pauses PL/SQL tracing.
public Method | PlSqlTraceResume | Resumes PL/SQL tracing.
public Method | PlSqlTraceRunNumber | Returns a run number for the current PL/SQL trace.
public Method | PlSqlTraceStart | Starts PL/SQL tracing. This method leaves the SQL tracing state unchanged.
public Method | PlSqlTraceStop | Stops PL/SQL tracing. This method leaves the SQL tracing state unchanged.
public Method | SqlTraceStart | Starts SQL tracing. This method leaves the PL/SQL tracing state unchanged.
public Method | SqlTraceStop | Stops SQL tracing. This method leaves the PL/SQL tracing state unchanged.
Top

See Also

Reference

OracleTrace Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetTraceFileName Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : GetTraceFileName Method

Returns the name for a dump file on the database server where SQL trace data is written.

Syntax

Visual Basic (Declaration)
Public Function GetTraceFileName() As String
C#
public string GetTraceFileName()

Return Value

The full path to the dump file.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceComment Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceComment Method

comment
The comment to set.
Sets a comment on PL/SQL trace.

Syntax

Visual Basic (Declaration)
Public Sub PlSqlTraceComment( _
   ByVal comment As String _
)
C#
public void PlSqlTraceComment(
   string comment
)

Parameters

comment
The comment to set.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceLimit Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceLimit Method

Limits the amount of storage used in the database for the PL/SQL trace data.

Overload List

Overload | Description
PlSqlTraceLimit() | Limits the amount of storage used in the database for the PL/SQL trace data to the default value 8192 bytes.
PlSqlTraceLimit(Int32) | Limits the amount of storage used in the database for the PL/SQL trace data to the given value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceLimit() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class > PlSqlTraceLimit Method : PlSqlTraceLimit() Method

Limits the amount of storage used in the database for the PL/SQL trace data to the default value 8192 bytes.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PlSqlTraceLimit()
C#
public void PlSqlTraceLimit()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceLimit(Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class > PlSqlTraceLimit Method : PlSqlTraceLimit(Int32) Method

limit
The limit size in bytes.
Limits the amount of storage used in the database for the PL/SQL trace data to the given value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub PlSqlTraceLimit( _
   ByVal limit As Integer _
)
C#
public void PlSqlTraceLimit(
   int limit
)

Parameters

limit
The limit size in bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTracePause Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTracePause Method

Pauses PL/SQL tracing.

Syntax

Visual Basic (Declaration)
Public Sub PlSqlTracePause()
C#
public void PlSqlTracePause()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceResume Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceResume Method

Resumes PL/SQL tracing.

Syntax

Visual Basic (Declaration)
Public Sub PlSqlTraceResume()
C#
public void PlSqlTraceResume()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceRunNumber Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceRunNumber Method

Returns a run number for the current PL/SQL trace.

Syntax

Visual Basic (Declaration)
Public Function PlSqlTraceRunNumber() As Integer
C#
public int PlSqlTraceRunNumber()

Return Value

A run number.

Remarks

This number can be used to retrieve information from trace tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceStart Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceStart Method

Starts PL/SQL tracing. This method leaves the SQL tracing state unchanged.

Syntax

Visual Basic (Declaration)
Public Sub PlSqlTraceStart()
C#
public void PlSqlTraceStart()

Remarks

Another way to start the PL/SQL tracing is setting the Enabled property to true, which starts both SQL and PL/SQL tracing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceStop Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceStop Method

Stops PL/SQL tracing. This method leaves the SQL tracing state unchanged.

Syntax

Visual Basic (Declaration)
Public Sub PlSqlTraceStop()
C#
public void PlSqlTraceStop()

Remarks

Another way to stop the PL/SQL tracing is setting the Enabled property to false, which stops both SQL and PL/SQL tracing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlTraceStart Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : SqlTraceStart Method

Starts SQL tracing. This method leaves the PL/SQL tracing state unchanged.

Syntax

Visual Basic (Declaration)
Public Sub SqlTraceStart()
C#
public void SqlTraceStart()

Remarks

Another way to start the SQL tracing is setting the Enabled property to true, which starts both SQL and PL/SQL tracing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlTraceStop Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : SqlTraceStop Method

Stops SQL tracing. This method leaves the PL/SQL tracing state unchanged.

Syntax

Visual Basic (Declaration)
Public Sub SqlTraceStop()
C#
public void SqlTraceStop()

Remarks

Another way to stop the SQL tracing is setting the Enabled property to false, which stops both SQL and PL/SQL tracing.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleTrace Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

For a list of all members of this type, see OracleTrace members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets OracleConnection object used for communicating with server.
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | Enabled | Gets or sets a value that indicates whether tracing is enabled.
public Property | MaxTraceFileSize | Gets or sets the maximum size of SQL trace dump file.
public Property | PlSqlTraceMode | Gets or sets the trace mode for the PL/SQL trace.
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | SqlTraceMode | Gets or sets the trace mode for the SQL trace.
public Property | State | Gets a value that indicates which trace modes are active.
public Property | TraceFileIdentifier | Gets or sets a file name suffix for the SQL trace dump file.
Top

See Also

Reference

OracleTrace Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : Connection Property

Gets or sets OracleConnection object used for communicating with server.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

A OracleConnection object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Enabled Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : Enabled Property

Gets or sets a value that indicates whether tracing is enabled.

Syntax

Visual Basic (Declaration)
Public Property Enabled As Boolean
C#
public bool Enabled {get; set;}

Property Value

true if the tracing is enabled; otherwise, false. true if both SQL and PL/SQL traces are enabled; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxTraceFileSize Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : MaxTraceFileSize Property

Gets or sets the maximum size of SQL trace dump file.

Syntax

Visual Basic (Declaration)
Public Property MaxTraceFileSize As Integer
C#
public int MaxTraceFileSize {get; set;}

Property Value

The maximum size of SQL trace dump file.

Remarks

Assign to DefaultTraceFileSize to use the default server value. Assign to UnlimitedTraceFileSize for unlimited trace file.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : PlSqlTraceMode Property

Gets or sets the trace mode for the PL/SQL trace.

Syntax

Visual Basic (Declaration)
Public Property PlSqlTraceMode As PlSqlTraceMode
C#
public PlSqlTraceMode PlSqlTraceMode {get; set;}

Property Value

One of the PlSqlTraceMode values.

Remarks

Specifies the types of events which will be traced. Can be set to trace calls, exceptions, SQL executions and/or all PL/SQL lines; there are two modes for each: trace all events and trace events occured in the enabled PL/SQL units only.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlTraceMode Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : SqlTraceMode Property

Gets or sets the trace mode for the SQL trace.

Syntax

Visual Basic (Declaration)
Public Property SqlTraceMode As SqlTraceMode
C#
public SqlTraceMode SqlTraceMode {get; set;}

Property Value

One of the SqlTraceMode values.

Remarks

Specifies which statistics will be collected while tracing. Can be set to collect the basic SQL execution statistics, the bind variables' values, the wait events information and/or the performance statistics.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
State Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : State Property

Gets a value that indicates which trace modes are active.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property State As TraceState
C#
public TraceState State {get;}

Property Value

One of the TraceState values.

Remarks

Indicates whether the SQL trace, the PL/SQL trace or both are active.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TraceFileIdentifier Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : TraceFileIdentifier Property

Gets or sets a file name suffix for the SQL trace dump file.

Syntax

Visual Basic (Declaration)
Public Property TraceFileIdentifier As String
C#
public string TraceFileIdentifier {get; set;}

Property Value

A file name suffix.

Remarks

It is applied to the trace log file at the nearest SQL trace start.] The default value is an empty string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleTrace Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

For a list of all members of this type, see OracleTrace members.

Public Fields

 | Name | Description
public Field | DefaultTraceFileSize | Specifies the server default trace file size. Stands for the server default value of the trace file maximum size.
public Field | UnlimitedTraceFileSize | Specifies the unlimited size of the trace file.
Top

See Also

Reference

OracleTrace Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DefaultTraceFileSize Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : DefaultTraceFileSize Field

Specifies the server default trace file size. Stands for the server default value of the trace file maximum size.

Syntax

Visual Basic (Declaration)
Public Const DefaultTraceFileSize As Integer
C#
public const int DefaultTraceFileSize

Remarks

This value is 0. It can be assigned to the MaxTraceFileSize property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnlimitedTraceFileSize Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTrace Class : UnlimitedTraceFileSize Field

Specifies the unlimited size of the trace file.

Syntax

Visual Basic (Declaration)
Public Const UnlimitedTraceFileSize As Integer
C#
public const int UnlimitedTraceFileSize

Remarks

It can be assigned to the MaxTraceFileSize property so that the trace file size will be unlimited.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTrace Class
OracleTrace Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTransaction Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTransaction Class

Represents a SQL transaction to be made in the Oracle database.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Data.Common.DbTransaction
Devart.Common.DbTransactionBase
Devart.Data.Oracle.OracleTransaction

Syntax

Visual Basic (Declaration)
Public Class OracleTransaction
   Inherits Devart.Common.DbTransactionBase
   Implements IDbTransaction, IDisposable
C#
public class OracleTransaction : Devart.Common.DbTransactionBase, IDbTransaction, IDisposable

Remarks

The application creates a OracleTransaction object by calling OracleConnection.BeginTransaction on the OracleConnection object. All subsequent operations associated with the transaction (for example, committing or aborting the transaction), are performed on the OracleTransaction object.

The correlation between OracleConnection and OracleTransaction is always 1:1.

Example

The following example creates a OracleConnection and a OracleTransaction. It also demonstrates how to use the OracleConnection.BeginTransaction, Commit, and Rollback methods.
C#csharp Copy Code
public static void RunOracleTransaction(string myConnString) {
        using (OracleConnection myConnection = new OracleConnection(myConnString)) {
                myConnection.Open();
                // Start a local transaction
                OracleTransaction myTrans = myConnection.BeginTransaction(System.Data.IsolationLevel.ReadCommitted);
                OracleCommand myCommand = myConnection.CreateCommand();
                try {
                        myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(52, 'DEVELOPMENT')";
                        myCommand.ExecuteNonQuery();
                        myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(62, 'PRODUCTION')";
                        myCommand.ExecuteNonQuery();
                        myTrans.Commit();
                        Console.WriteLine("Both records are written to database.");
                }
                catch (Exception e) {
                        myTrans.Rollback();
                        Console.WriteLine(e.ToString());
                        Console.WriteLine("Neither record was written to database.");
                }
                finally {
                        myCommand.Dispose();
                        myTrans.Dispose();
                }
    }
}
C#Visual Basic Copy Code
Public Shared Sub RunOracleTransaction(myConnString As String)
        Using myConnection As New OracleConnection(myConnString)
                myConnection.Open()
                ' Start a local transaction
                Dim myTrans As OracleTransaction = myConnection.BeginTransaction(System.Data.IsolationLevel.ReadCommitted)
                Dim myCommand As OracleCommand = myConnection.CreateCommand()
                Try
                        myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(52, 'DEVELOPMENT')"
                        myCommand.ExecuteNonQuery()
                        myCommand.CommandText = "INSERT INTO Dept(DeptNo, DName) Values(62, 'PRODUCTION')"
                        myCommand.ExecuteNonQuery()
                        myTrans.Commit()
                        Console.WriteLine("Both records are written to database.")
                Catch e As Exception
                        myTrans.Rollback()
                        Console.WriteLine(e.ToString())
                        Console.WriteLine("Neither record was written to database.")
                Finally
                        myCommand.Dispose()
                        myTrans.Dispose()
                End Try
    End Using
End Sub

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleTransaction Members
Devart.Data.Oracle Namespace
OracleDataReader Class
OracleConnection Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleTransaction Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle Namespace : OracleTransaction Class

The following tables list the members exposed by OracleTransaction.

Public Properties

 | Name | Description
public Property | Connection | Gets the OracleConnection object associated with the transaction, or a null reference (Nothing in Visual Basic) if the transaction is no longer valid.
public Property | IsolationLevel | Specifies the System.Data.IsolationLevel for this transaction. (Inherited from System.Data.Common.DbTransaction)
Top

Public Methods

 | Name | Description
public Method | Commit | Overridden. Commits the database transaction.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases the unmanaged resources used by the System.Data.Common.DbTransaction. (Inherited from System.Data.Common.DbTransaction)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Rollback | Overloaded. Overridden. Rollback rolls back a database transaction.
public Method | Save | Creates a savepoint within the current transaction.
Top

Public Events

 | Name | Description
public Event | StateChanged | Occurs when the state of the transaction is changed. (Inherited from Devart.Common.DbTransactionBase)
public Event | StateChanging | Occurs when the state of the transaction is changing. (Inherited from Devart.Common.DbTransactionBase)
Top

See Also

Reference

OracleTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleTransaction Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTransaction Class

For a list of all members of this type, see OracleTransaction members.

Public Methods

 | Name | Description
public Method | Commit | Overridden. Commits the database transaction.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases the unmanaged resources used by the System.Data.Common.DbTransaction. (Inherited from System.Data.Common.DbTransaction)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Rollback | Overloaded. Overridden. Rollback rolls back a database transaction.
public Method | Save | Creates a savepoint within the current transaction.
Top

See Also

Reference

OracleTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Commit Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class : Commit Method

Commits the database transaction.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Commit()
C#
public override void Commit()

Remarks

The Commit method is equivalent to the SQL COMMIT statement.

Example

The following example creates a OracleConnection and a OracleTransaction. It also demonstrates how to use the OracleConnection.BeginTransaction, Commit, and Rollback methods.
C#csharp Copy Code
public void RunOracleTransaction(string myConnString)
{
  OracleConnection myConnection = new OracleConnection(myConnString);
  myConnection.Open();

  OracleCommand myCommand = new OracleCommand();
  OracleTransaction myTrans;

  // Start a local transaction
  myTrans = myConnection.BeginTransaction();
  // Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans;

  try
  {
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')";
    myCommand.ExecuteNonQuery();
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')";
    myCommand.ExecuteNonQuery();
    myTrans.Commit();
    Console.WriteLine("Both records are written to database.");
  }
  catch(Exception e)
  {
    myTrans.Rollback();
    Console.WriteLine(e.ToString());
    Console.WriteLine("Neither record was written to database.");
  }
  finally
  {
    myConnection.Close();
  }
}
C#Visual Basic Copy Code
Public Sub RunOracleTransaction(myConnString As String)
  Dim myConnection As New OracleConnection(myConnString)
  myConnection.Open()

  Dim myCommand As New OracleCommand()
  Dim myTrans As OracleTransaction

  ' Start a local transaction
  myTrans = myConnection.BeginTransaction()
  ' Assign transaction object for a pending local transaction
  myCommand.Transaction = myTrans

  Try
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(50, 'DEVELOPMENT')"
    myCommand.ExecuteNonQuery()
    myCommand.CommandText = "INSERT INTO Test.Dept(DeptNo, DName) Values(60, 'PRODUCTION')"
    myCommand.ExecuteNonQuery()
    myTrans.Commit()
    Console.WriteLine("Both records are written to database.")
  Catch e As Exception
    myTrans.Rollback()
    Console.WriteLine(e.ToString())
    Console.WriteLine("Neither record was written to database.")
  Finally
    myConnection.Close()
  End Try
End Sub

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members
BeginTransaction Method
Rollback Method


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Rollback Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class : Rollback Method

Rollback rolls back a database transaction.

Overload List

Overload | Description
Rollback() | Rollback rolls back a database transaction.
Rollback(String) | Rollback rolls back a database transaction to the specified savepoint.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Rollback() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class > Rollback Method : Rollback() Method

Rollback rolls back a database transaction.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Rollback()
C#
public override void Rollback()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Rollback(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class > Rollback Method : Rollback(String) Method

savePointName
Name of the savepoint to rollback the transaction to.
Rollback rolls back a database transaction to the specified savepoint.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Rollback( _
   ByVal savePointName As String _
)
C#
public void Rollback(
   string savePointName
)

Parameters

savePointName
Name of the savepoint to rollback the transaction to.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Save Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class : Save Method

savePointName
The name of the savepoint being created in the current transaction.
Creates a savepoint within the current transaction.

Syntax

Visual Basic (Declaration)
Public Sub Save( _
   ByVal savePointName As String _
)
C#
public void Save(
   string savePointName
)

Parameters

savePointName
The name of the savepoint being created in the current transaction.

Remarks

After creating a savepoint the transaction does not enter a completed state and can be used for further operations.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleTransaction Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTransaction Class

For a list of all members of this type, see OracleTransaction members.

Public Properties

 | Name | Description
public Property | Connection | Gets the OracleConnection object associated with the transaction, or a null reference (Nothing in Visual Basic) if the transaction is no longer valid.
public Property | IsolationLevel | Specifies the System.Data.IsolationLevel for this transaction. (Inherited from System.Data.Common.DbTransaction)
Top

See Also

Reference

OracleTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTransaction Class : Connection Property

Gets the OracleConnection object associated with the transaction, or a null reference (Nothing in Visual Basic) if the transaction is no longer valid.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Connection As OracleConnection
C#
public new OracleConnection Connection {get;}

Property Value

The OracleConnection object associated with the transaction.

Remarks

A single application may have multiple database connections, and each connection may have a transaction. This property enables you to determine the OracleConnection object associated with a particular transaction created by BeginTransaction().

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTransaction Class
OracleTransaction Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleType Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleType Class

Represents any Oracle object type defined by the user such as OracleObject, OracleArray or OracleTable.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Devart.Data.Oracle.OracleType

Syntax

Visual Basic (Declaration)
Public Class OracleType
   Inherits System.MarshalByRefObject
   Implements IComparable
C#
public class OracleType : System.MarshalByRefObject, IComparable

Remarks

An OracleType class serves to retrieve metadata. Use OracleType object for getting description information about the type. You can get name of the type, attributes collection and description of the element of the collection by ItemObjectType property.

An OracleType does not have constructor and can be created only by calling static GetObjectType function.

Example

This example demonstrates how to retrieve OracleType object from server and display its elements. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Address");
  while (dataReader.Read()) {
    OracleObject oraObj = dataReader.GetOracleObject(index);
    OracleType oraType = dataReader.GetObjectType(index);
    if (!oraObj.IsNull & oraType != null) {
      Console.WriteLine(dataReader.GetString(1) +" - " + dataReader.GetString(3));
      Console.WriteLine("Adress:");
      for (int i = 0; i < oraType.Attributes.Count; i++)
        Console.WriteLine( "\t" + oraObj[oraType.Attributes[i]]);
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Address")
  While dataReader.Read()
    Dim oraObj As OracleObject = dataReader.GetOracleObject(index)
    Dim oraType As OracleType = dataReader.GetObjectType(index)
    If Not oraObj.IsNull And Not oraType Is Nothing Then
      Console.WriteLine(dataReader.GetString(1) & " - " & dataReader.GetString(3))
      Console.WriteLine("Adress:")
      Dim I As Integer
      For I = 0 To oraType.Attributes.Count - 1
        Console.WriteLine(Chr(9) & oraObj(oraType.Attributes(I)))
      Next I
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleType Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleType Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleType Class

The following tables list the members exposed by OracleType.

Public Properties

 | Name | Description
public Property | ArrayCapacity | Gets the number of elements that the OracleArray or OracleTable can contain.
public Property | Attributes | Gets a collection of the OracleAttribute objects for the Oracle object type.
public Property | DbType | Determines what type the OracleType represents - OBJECT, VARRAY or Nested table.
public Property | IsDescribed | Gets the value indicating whether the OracleType is described on the server.
public Property | ItemDbType | Gets type of the element from the collection.
public Property | ItemObjectType | Gets object type of the element for VARRAY or Nested table types.
public Property | Name | Gets type name of the object.
public Property | SchemaName | Gets the name of the schema that the type belongs to.
public Property | TypeName | Gets the name of the type on the server.
public Property | UdtType | Gets or sets the user-defined type.
Top

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleType with the specified object and returns an integer that represents their relative values.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Describe | Describes the OracleType on the server.
public Method | Equals | Determines whether the specified OracleType is equal to the current OracleType object.
public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetObjectType | Overloaded. Gets type of the object as OracleType.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleType Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleType Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleType Class

For a list of all members of this type, see OracleType members.

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleType with the specified object and returns an integer that represents their relative values.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Describe | Describes the OracleType on the server.
public Method | Equals | Determines whether the specified OracleType is equal to the current OracleType object.
public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | GetObjectType | Overloaded. Gets type of the object as OracleType.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleType Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : CompareTo Method

obj
The object to be compared.
Compares the current OracleType with the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleType structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleType object is less than the object.
Zero | The current OracleType object is the same to the object.
Greater than zero | The current OracleType object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Describe Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : Describe Method

connection
An OracleConnection to use.
Describes the OracleType on the server.

Syntax

Visual Basic (Declaration)
Public Sub Describe( _
   ByVal connection As OracleConnection _
)
C#
public void Describe(
   OracleConnection connection
)

Parameters

connection
An OracleConnection to use.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : Equals Method

value
The object to compare with the current object.
Determines whether the specified OracleType is equal to the current OracleType object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to compare with the current object.

Return Value

true if the specified OracleType is equal to the current object; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A hash code for the current OracleType.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : GetObjectType Method

Gets type of the object as OracleType.

Overload List

Overload | Description
GetObjectType(String,OracleConnection) | Gets type of the object as OracleType.
GetObjectType(String,String,String) | Gets type of the object as OracleType.
GetObjectType(String,String,OracleConnection) | Gets type of the object as OracleType.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType(String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class > GetObjectType Method : GetObjectType(String,OracleConnection) Method

name
The name of the object type at the server.
connection
The OracleConnection object used to describe type at the server.
Gets type of the object as OracleType.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetObjectType( _
   ByVal name As String, _
   ByVal connection As OracleConnection _
) As OracleType
C#
public static OracleType GetObjectType(
   string name,
   OracleConnection connection
)

Parameters

name
The name of the object type at the server.
connection
The OracleConnection object used to describe type at the server.

Return Value

The OracleType that represents describe of the object type.

Remarks

The name of the type can be specified as [schemaname].[typename] or just [typename]. At the last case the current schema will be used.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType(String,String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class > GetObjectType Method : GetObjectType(String,String,String) Method

schemaName
The name of the schema that contains typeName object type.
typeName
The name of the object type at the server.
connectionString
The connection string used to describe the type at the server.
Gets type of the object as OracleType.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetObjectType( _
   ByVal schemaName As String, _
   ByVal typeName As String, _
   ByVal connectionString As String _
) As OracleType
C#
public static OracleType GetObjectType(
   string schemaName,
   string typeName,
   string connectionString
)

Parameters

schemaName
The name of the schema that contains typeName object type.
typeName
The name of the object type at the server.
connectionString
The connection string used to describe the type at the server.

Return Value

The OracleType that represents describe of the object type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetObjectType(String,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class > GetObjectType Method : GetObjectType(String,String,OracleConnection) Method

schemaName
The name of the schema that contains typeName object type.
typeName
The name of the object type at the server.
connection
The OracleConnection object used to describe type at the server.
Gets type of the object as OracleType.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetObjectType( _
   ByVal schemaName As String, _
   ByVal typeName As String, _
   ByVal connection As OracleConnection _
) As OracleType
C#
public static OracleType GetObjectType(
   string schemaName,
   string typeName,
   OracleConnection connection
)

Parameters

schemaName
The name of the schema that contains typeName object type.
typeName
The name of the object type at the server.
connection
The OracleConnection object used to describe type at the server.

Return Value

The OracleType that represents describe of the object type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleType Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleType Class

For a list of all members of this type, see OracleType members.

Public Properties

 | Name | Description
public Property | ArrayCapacity | Gets the number of elements that the OracleArray or OracleTable can contain.
public Property | Attributes | Gets a collection of the OracleAttribute objects for the Oracle object type.
public Property | DbType | Determines what type the OracleType represents - OBJECT, VARRAY or Nested table.
public Property | IsDescribed | Gets the value indicating whether the OracleType is described on the server.
public Property | ItemDbType | Gets type of the element from the collection.
public Property | ItemObjectType | Gets object type of the element for VARRAY or Nested table types.
public Property | Name | Gets type name of the object.
public Property | SchemaName | Gets the name of the schema that the type belongs to.
public Property | TypeName | Gets the name of the type on the server.
public Property | UdtType | Gets or sets the user-defined type.
Top

See Also

Reference

OracleType Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ArrayCapacity Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : ArrayCapacity Property

Gets the number of elements that the OracleArray or OracleTable can contain.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrayCapacity As Integer
C#
public int ArrayCapacity {get;}

Property Value

The number of elements that the OracleArray or OracleTable can contain.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Attributes Property
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : Attributes Property

Gets a collection of the OracleAttribute objects for the Oracle object type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Attributes As OracleAttributeCollection
C#
public OracleAttributeCollection Attributes {get;}

Property Value

An OracleAttributeCollection if OracleType is the Oracle object type; otherwise, null.

Remarks

The OracleAttributeCollection represents only describe information for the OracleType.

Example

This example demonstrates how to retrieve OracleType object from server and display its attributes. To create required type and table and fill it with data you can use the following script:

CREATE TYPE TAddress AS OBJECT (
  Country VARCHAR2(30),
  City VARCHAR2(30),
  Street VARCHAR2(30),
  Apartment NUMBER
);

CREATE TABLE EmpObject (
  Code NUMBER PRIMARY KEY,
  Person VARCHAR2(40),
  Address TAddress,
  Job VARCHAR2(9)
);

INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (1, 'SMITH', TAddress('UK', 'London', 'Street', 12), 'CLERK');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (2, 'JONES', TAddress('USA', 'New York', 'Street', 418), 'MANAGER');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (3, 'SCOTT', TAddress('CANADA', 'Ottawa', 'Street', 26),'PRESIDENT');
INSERT INTO EmpObject
  (Code, Person, Address, Job)
VALUES
  (4, 'MARTIN', TAddress('FRANCE', 'Paris', 'Street', 162), 'ANALYST');

C#csharp Copy Code
OracleConnection connection = new OracleConnection("User Id=scott;Password=tiger;Data Source=ora");
OracleCommand command = new OracleCommand("SELECT * FROM EmpObject", connection);
connection.Open();
OracleDataReader dataReader = command.ExecuteReader();
try{
  int index = dataReader.GetOrdinal("Address");
  while (dataReader.Read()) {
    OracleObject oraObj = dataReader.GetOracleObject(index);
    OracleType oraType = dataReader.GetObjectType(index);
    if (!oraObj.IsNull && oraType != null) {
      Console.WriteLine(dataReader.GetString(1) + " - " + dataReader.GetString(3));
      Console.WriteLine("Adress:");
      for (int i = 0; i < oraType.Attributes.Count; i++)
        Console.WriteLine( "\t" + oraObj[oraType.Attributes[i]]);
    }
  }
}
catch (Devart.Data.Oracle.OracleException ex) {
  Console.WriteLine(ex.Message);
}
finally{
  dataReader.Close();
  connection.Close();
}
C#Visual Basic Copy Code
Dim connection As New OracleConnection("User Id=scott;Password=tiger;Data Source=ora")
Dim command As New OracleCommand("SELECT * FROM EmpObject", connection)
connection.Open()
Dim dataReader As OracleDataReader = command.ExecuteReader()
Try
  Dim index As Integer = dataReader.GetOrdinal("Address")
  While dataReader.Read()
    Dim oraObj As OracleObject = dataReader.GetOracleObject(index)
    Dim oraType As OracleType = dataReader.GetObjectType(index)
    If Not oraObj.IsNull And Not oraType Is Nothing Then
      Console.WriteLine(dataReader.GetString(1) & " - " & dataReader.GetString(3))
      Console.WriteLine("Adress:")
      Dim I As Integer
      For I = 0 To oraType.Attributes.Count - 1
        Console.WriteLine(Chr(9) & oraObj(oraType.Attributes(I)))
      Next I
    End If
  End While
Catch ex As Devart.Data.Oracle.OracleException
  Console.WriteLine(ex.Message)
Finally
  dataReader.Close()
  connection.Close()
End Try

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : DbType Property

Determines what type the OracleType represents - OBJECT, VARRAY or Nested table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbType As OracleDbType
C#
public OracleDbType DbType {get;}

Property Value

One of the OracleObject, OracleArray or OracleTable values from the OracleDbType enumeration.

Remarks

Values from the OracleDbType enumeration correspond to the following Oracle definitions:

- Object - a type representing as OBJECT;

- Array - a type representing as VARRAY;

- Table - a type representing as Nested table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsDescribed Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : IsDescribed Property

Gets the value indicating whether the OracleType is described on the server.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDescribed As Boolean
C#
public bool IsDescribed {get;}

Property Value

true if the specified OracleType is described on the server; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ItemDbType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : ItemDbType Property

Gets type of the element from the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemDbType As OracleDbType
C#
public OracleDbType ItemDbType {get;}

Property Value

One of the values from OracleDbType enumeration.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ItemObjectType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : ItemObjectType Property

Gets object type of the element for VARRAY or Nested table types.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ItemObjectType As OracleType
C#
public OracleType ItemObjectType {get;}

Property Value

The OracleType of the element from the collection, or null if the OracleType is not VARRAY or Nested table type.

Remarks

Use DbType property to determine whether given OracleType is representing as VARRAY or Nested table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Name Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : Name Property

Gets type name of the object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Property Value

String that represents name of the type.

Remarks

Name of the type is retrieved in [schemaname].[typename] format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchemaName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : SchemaName Property

Gets the name of the schema that the type belongs to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaName As String
C#
public string SchemaName {get;}

Property Value

The name of the schema.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TypeName Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : TypeName Property

Gets the name of the type on the server.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName {get;}

Property Value

The name of the type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UdtType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleType Class : UdtType Property

Gets or sets the user-defined type.

Syntax

Visual Basic (Declaration)
Public Property UdtType As Type
C#
public Type UdtType {get; set;}

Property Value

A System.Type defined by user.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleType Class
OracleType Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Class
Members Example See Also support@devart.com
Devart.Data.Oracle Namespace : OracleXml Class

Represents an Oracle XMLType instance.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.OracleXml

Syntax

Visual Basic (Declaration)
Public Class OracleXml
   Implements INullable, IDisposable
C#
public class OracleXml : INullable, IDisposable

Remarks

Use OracleXml object to represent XML data at Oracle database. Values of OracleXml type can be retrived from OracleDataReader and passed to OracleParameter object.

A number of OracleXml properties and its methods are not supported in the OracleConnection.Direct mode. See the property descriptions to determine whether they are supported in the Direct mode.

Example

This sample demonstrates how you can operate with the OracleXml class. Here a simple OracleXml object is created and inserted into the database. After that, it is shown how to transform XML via the XSL schema and extract its fragments using XPath expressions.

To run this sample, you need to execute the following script in your Oracle database:

CREATE TABLE CDs (
   ID NUMBER,
   DISC XMLTYPE
)

This sample works only with the OCI mode connection.

C#csharp Copy Code
// Initialize and open a connection to the Oracle server
OracleConnection connection = new OracleConnection();
connection.Server = "Ora";
connection.UserId = "Scott";
connection.Password = "tiger";
connection.Open();

// Initialize an OracleXml instance with simple xml content
string content = @"
        <catalog>
        <cd>
        <title>Empire Burlesque</title>
        <artist>Bob Dylan</artist>
        <country>USA</country>
        <company>Columbia</company>
        <price>10.90</price>
        <year>1985</year>
        </cd>
        </catalog>
        ";
OracleXml xml = new OracleXml(content, connection);

// Insert the xml object into the table with a field of the Oracle XML type
OracleCommand command = new OracleCommand("insert into CDs(id, disc) values(10, :disc)", connection);
command.Parameters.Add(new OracleParameter("disc", xml));
command.ExecuteNonQuery();

// Use an XSL transformation to create an HTML page representing the content of the xml object.
string transformation = @"
        <xsl:stylesheet version=""1.0"" xmlns:xsl=""http://www.w3.org/1999/XSL/Transform"">

        <xsl:template match=""/"">
        <html>
        <body>
        <h2>My CD Collection</h2>
        <table border=""1"">
        <tr bgcolor=""#9acd32"">
        <th>Title</th>
        <th>Artist</th>
        </tr>
        <xsl:for-each select=""catalog/cd"">
        <tr>
        <td><xsl:value-of select=""title""/></td>
        <td><xsl:value-of select=""artist""/></td>
        </tr>
        </xsl:for-each>
        </table>
        </body>
        </html>
        </xsl:template>

        </xsl:stylesheet>
        ";
OracleXml transformed = xml.Transform(transformation);
Console.WriteLine(transformed.Value);

// Retrieve an XML fragment by the XPath expression specified:
OracleXml extracted = xml.Extract("catalog/cd/price", "");
Console.WriteLine("The price elements:");
Console.WriteLine(extracted.Value);

Console.ReadLine();
C#Visual Basic Copy Code
' Initialize and open a connection to the Oracle server
Dim connection As New OracleConnection()
connection.Server = "Ora"
connection.UserId = "Scott"
connection.Password = "tiger"
connection.Open()

' Initialize an OracleXml instance with simple xml content
Dim content As String = "<catalog>" + vbCrLf + &
        "<cd>" + vbCrLf + &
        "<title>Empire Burlesque</title>" + vbCrLf + &
        "<artist>Bob Dylan</artist>" + vbCrLf + &
        "<country>USA</country>" + vbCrLf + &
        "<company>Columbia</company>" + vbCrLf + &
        "<price>10.90</price>" + vbCrLf + &
        "<year>1985</year>" + vbCrLf + &
        "</cd>" + vbCrLf + &
        "</catalog>"

Dim xml As New OracleXml(content, connection)

' Insert the xml object into the field of the Oracle XML type
Dim command As New OracleCommand("insert into CDs(id, disc) values(10, :disc)", connection)
command.Parameters.Add(New OracleParameter("disc", xml))
command.ExecuteNonQuery()

' Use an XSL transformation to create an HTML page representing the content of the xml object.
Dim transformation As String = "<xsl:stylesheet version=""1.0"" xmlns:xsl=""http://www.w3.org/1999/XSL/Transform"">" + vbCrLf + &
        "<xsl:template match=""/"">" + vbCrLf + &
        "<html>" + vbCrLf + &
        "<body>" + vbCrLf + &
        "<h2>My CD Collection</h2>" + vbCrLf + &
        "<table border=""1"">" + vbCrLf + &
        "<tr bgcolor=""#9acd32"">" + vbCrLf + &
        "<th>Title</th>" + vbCrLf + &
        "<th>Artist</th>" + vbCrLf + &
        "</tr>" + vbCrLf + &
        "<xsl:for-each select=""catalog/cd"">" + vbCrLf + &
        "<tr>" + vbCrLf + &
        "<td><xsl:value-of select=""title""/></td>" + vbCrLf + &
        "<td><xsl:value-of select=""artist""/></td>" + vbCrLf + &
        "</tr>" + vbCrLf + &
        "</xsl:for-each>" + vbCrLf + &
        "</table>" + vbCrLf + &
        "</body>" + vbCrLf + &
        "</html>" + vbCrLf + &
        "</xsl:template>" + vbCrLf + &
        "</xsl:stylesheet>"
Dim transformed = xml.Transform(transformation)
Console.WriteLine(transformed.Value)

' Retrieve an XML fragment by the XPath expression specified:
Dim extracted = xml.Extract("catalog/cd/price", "")
Console.WriteLine("The price elements:")
Console.WriteLine(extracted.Value)

Console.ReadLine()

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleXml Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleXml Class Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleXml Class

The following tables list the members exposed by OracleXml.

Public Constructors

 | Name | Description
public Constructor | OracleXml Constructor | Overloaded. Initializes a new instance of the OracleXml class.Initializes a new instance of the OracleXml class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null value of an OracleXml object.
Top

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleXml.
public Property | IsEmpty | Indicates whether the OracleXml object is empty.
public Property | IsFragment | Indicates whether the OracleXml object is a collection of XML elements without the root element.
public Property | IsNull | Indicates whether the OracleXml object is null.
public Property | IsSchemaBased | Indicates whether the OracleXml object data is based on an XML schema.
public Property | RootElement | Returns the name of the top-level or root element of the schema-based XML data in this OracleXml object.
public Property | Schema | Returns the XML schema of the XML data in this OracleXml object.
public Property | SchemaUrl | Returns the URL in the database of the XML schema for the XML data in this OracleXml object.
public Property | Value | Gets a string representing XML data of the specified OracleXml object.
Top

Public Methods

 | Name | Description
public Method | Dispose | Releases all resources allocated by this object.
public Method | Extract | Overloaded. Extracts a fragment of XML by the specified XPath expression.
public Method | GetXmlDocument | Converts the specified OracleXml to the System.Xml.XmlDocument object that includes XML data of this object.
public Method | GetXmlReader | Returns System.Xml.XmlReader object connected with XML data of the OracleXml.
public Method | IsExists | Overloaded. Determines whether XML node exists by the specified XPath expression.
public Method | ToString | Converts the specified OracleXml object to a System.String representing XML data.
public Method | Transform | Overloaded. Transforms the current OracleXml object according to the specified XSL schema.
public Method | Validate | Validates whether or not the XML data of the OracleXml object conforms to the given XML schema.
Top

See Also

Reference

OracleXml Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : OracleXml Constructor

Initializes a new instance of the OracleXml class.Initializes a new instance of the OracleXml class.

Overload List

Overload | Description
OracleXml Constructor() | Initializes an empty OracleXml object.
OracleXml Constructor(String) | Initializes an OracleXml object with the specified XML data as string.
OracleXml Constructor(Char[]) | Initializes an OracleXml object with the specified XML data as an array of symbols.
OracleXml Constructor(OracleLob) | Initializes an OracleXml object with the specified connection and XML data defined as an Oracle LOB.
OracleXml Constructor(OracleConnection) | Initializes an empty OracleXml object with the specified connection.
OracleXml Constructor(OracleLob,OracleConnection) | Initializes a new instance of the OracleXml class with the specified XML data as OracleLob object.
OracleXml Constructor(Char[],OracleConnection) | Initializes a new instance of the OracleXml class with the specified XML data as an array of symbols.
OracleXml Constructor(String,OracleConnection) | Initializes a new instance of the OracleXml class with the specified connection and XML data defined as a string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor()
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor()

Initializes an empty OracleXml object.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleXml()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(String)

value
A string containing XML data.
Initializes an OracleXml object with the specified XML data as string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
C#
public OracleXml(
   string value
)

Parameters

value
A string containing XML data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(Char[])
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(Char[])

value
An array of symbols containing XML data.
Initializes an OracleXml object with the specified XML data as an array of symbols.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Char _
)
C#
public OracleXml(
   char[] value
)

Parameters

value
An array of symbols containing XML data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(OracleLob)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(OracleLob)

lob
An OracleLob object containing XML data.
Initializes an OracleXml object with the specified connection and XML data defined as an Oracle LOB.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lob As OracleLob _
)
C#
public OracleXml(
   OracleLob lob
)

Parameters

lob
An OracleLob object containing XML data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(OracleConnection)

connection
An OCI connection used for XML parsing and transformation.
Initializes an empty OracleXml object with the specified connection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection _
)
C#
public OracleXml(
   OracleConnection connection
)

Parameters

connection
An OCI connection used for XML parsing and transformation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(OracleLob,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(OracleLob,OracleConnection)

lob
An OracleLob object containing XML data.
connection
An OCI connection used for XML parsing and transformation.
Initializes a new instance of the OracleXml class with the specified XML data as OracleLob object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal lob As OracleLob, _
   ByVal connection As OracleConnection _
)
C#
public OracleXml(
   OracleLob lob,
   OracleConnection connection
)

Parameters

lob
An OracleLob object containing XML data.
connection
An OCI connection used for XML parsing and transformation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(Char[],OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(Char[],OracleConnection)

value
An array of symbols containing XML data.
connection
An OCI connection used for XML parsing and transformation.
Initializes a new instance of the OracleXml class with the specified XML data as an array of symbols.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Char, _
   ByVal connection As OracleConnection _
)
C#
public OracleXml(
   char[] value,
   OracleConnection connection
)

Parameters

value
An array of symbols containing XML data.
connection
An OCI connection used for XML parsing and transformation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleXml Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > OracleXml Constructor : OracleXml Constructor(String,OracleConnection)

value
A string containing XML data.
connection
An OCI connection used for XML parsing and transformation.
Initializes a new instance of the OracleXml class with the specified connection and XML data defined as a string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleXml(
   string value,
   OracleConnection connection
)

Parameters

value
A string containing XML data.
connection
An OCI connection used for XML parsing and transformation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleXml Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleXml Class

For a list of all members of this type, see OracleXml members.

Public Methods

 | Name | Description
public Method | Dispose | Releases all resources allocated by this object.
public Method | Extract | Overloaded. Extracts a fragment of XML by the specified XPath expression.
public Method | GetXmlDocument | Converts the specified OracleXml to the System.Xml.XmlDocument object that includes XML data of this object.
public Method | GetXmlReader | Returns System.Xml.XmlReader object connected with XML data of the OracleXml.
public Method | IsExists | Overloaded. Determines whether XML node exists by the specified XPath expression.
public Method | ToString | Converts the specified OracleXml object to a System.String representing XML data.
public Method | Transform | Overloaded. Transforms the current OracleXml object according to the specified XSL schema.
public Method | Validate | Validates whether or not the XML data of the OracleXml object conforms to the given XML schema.
Top

See Also

Reference

OracleXml Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Dispose Method

Releases all resources allocated by this object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Remarks

Use OracleLob.Dispose to free resources taken by an OracleXml instance, i.e. after performing large data transfer. After disposing OracleXml object call of any method of this object will throw an System.ObjectDisposedException.

This method is actually the same as OracleLob.Close method.

This method closes the LOB locator associated with the OracleLob.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Extract Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Extract Method

Extracts a fragment of XML by the specified XPath expression.

Overload List

Overload | Description
Extract(String,String) | Extracts a fragment of XML by the specified XPath expression.
Extract(String,XmlNamespaceManager) | Extracts a fragment of XML by the specified XPath expression.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Extract(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > Extract Method : Extract(String,String) Method

xpathExpr
The XPath expression.
nsMap
Parameter used for namespace resolution of the XPath expression.
Extracts a fragment of XML by the specified XPath expression.

Syntax

Visual Basic (Declaration)
Public Overloads Function Extract( _
   ByVal xpathExpr As String, _
   ByVal nsMap As String _
) As OracleXml
C#
public OracleXml Extract(
   string xpathExpr,
   string nsMap
)

Parameters

xpathExpr
The XPath expression.
nsMap
Parameter used for namespace resolution of the XPath expression.

Return Value

XML fragment represented as OracleXml.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Extract(String,XmlNamespaceManager) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > Extract Method : Extract(String,XmlNamespaceManager) Method

xpathExpr
The XPath expression.
nsMgr
Parameter used for namespace resolution of the XPath expression.
Extracts a fragment of XML by the specified XPath expression.

Syntax

Visual Basic (Declaration)
Public Overloads Function Extract( _
   ByVal xpathExpr As String, _
   ByVal nsMgr As XmlNamespaceManager _
) As OracleXml
C#
public OracleXml Extract(
   string xpathExpr,
   XmlNamespaceManager nsMgr
)

Parameters

xpathExpr
The XPath expression.
nsMgr
Parameter used for namespace resolution of the XPath expression.

Return Value

XML fragment represented as OracleXml.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetXmlDocument Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : GetXmlDocument Method

Converts the specified OracleXml to the System.Xml.XmlDocument object that includes XML data of this object.

Syntax

Visual Basic (Declaration)
Public Function GetXmlDocument() As XmlDocument
C#
public XmlDocument GetXmlDocument()

Return Value

A System.Xml.XmlDocument object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetXmlReader Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : GetXmlReader Method

Returns System.Xml.XmlReader object connected with XML data of the OracleXml.

Syntax

Visual Basic (Declaration)
Public Function GetXmlReader() As XmlReader
C#
public XmlReader GetXmlReader()

Return Value

A System.Xml.XmlReader object.

Remarks

You can use this method to work with XML data through native .NET Framework classes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsExists Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : IsExists Method

Determines whether XML node exists by the specified XPath expression.

Overload List

Overload | Description
IsExists(String,String) | Determines by the specified XPath expression whether XML node exists.
IsExists(String,XmlNamespaceManager) | Determines by the specified XPath expression whether XML node exists.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsExists(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > IsExists Method : IsExists(String,String) Method

xpathExpr
The XPath expression.
nsMap
Parameter used for namespace resolution of the XPath expression.
Determines by the specified XPath expression whether XML node exists.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsExists( _
   ByVal xpathExpr As String, _
   ByVal nsMap As String _
) As Boolean
C#
public bool IsExists(
   string xpathExpr,
   string nsMap
)

Parameters

xpathExpr
The XPath expression.
nsMap
Parameter used for namespace resolution of the XPath expression.

Return Value

true if the specified node is found; otherwise, false.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsExists(String,XmlNamespaceManager) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > IsExists Method : IsExists(String,XmlNamespaceManager) Method

xpathExpr
The XPath expression.
nsMgr
Parameter used for namespace resolution of the XPath expression.
Determines by the specified XPath expression whether XML node exists.

Syntax

Visual Basic (Declaration)
Public Overloads Function IsExists( _
   ByVal xpathExpr As String, _
   ByVal nsMgr As XmlNamespaceManager _
) As Boolean
C#
public bool IsExists(
   string xpathExpr,
   XmlNamespaceManager nsMgr
)

Parameters

xpathExpr
The XPath expression.
nsMgr
Parameter used for namespace resolution of the XPath expression.

Return Value

true if the specified node is found; otherwise, false.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : ToString Method

Converts the specified OracleXml object to a System.String representing XML data.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String object containing XML data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transform Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Transform Method

Transforms the current OracleXml object according to the specified XSL schema.

Overload List

Overload | Description
Transform(OracleXml) | Transforms the current OracleXml object according to the specified XSL schema.
Transform(String) | Transforms the current OracleXml object according to the specified XSL schema.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transform(OracleXml) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > Transform Method : Transform(OracleXml) Method

xsldoc
XSL schema to transform OracleXml.
Transforms the current OracleXml object according to the specified XSL schema.

Syntax

Visual Basic (Declaration)
Public Overloads Function Transform( _
   ByVal xsldoc As OracleXml _
) As OracleXml
C#
public OracleXml Transform(
   OracleXml xsldoc
)

Parameters

xsldoc
XSL schema to transform OracleXml.

Return Value

A new OracleXml received as a result of the transformation.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Transform(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class > Transform Method : Transform(String) Method

xsldoc
XSL schema to transform OracleXml.
Transforms the current OracleXml object according to the specified XSL schema.

Syntax

Visual Basic (Declaration)
Public Overloads Function Transform( _
   ByVal xsldoc As String _
) As OracleXml
C#
public OracleXml Transform(
   string xsldoc
)

Parameters

xsldoc
XSL schema to transform OracleXml.

Return Value

A new OracleXml received as a result of the transformation.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Validate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Validate Method

schemaUrl
The URL in the database of the XML schema.
Validates whether or not the XML data of the OracleXml object conforms to the given XML schema.

Syntax

Visual Basic (Declaration)
Public Function Validate( _
   ByVal schemaUrl As String _
) As Boolean
C#
public bool Validate(
   string schemaUrl
)

Parameters

schemaUrl
The URL in the database of the XML schema.

Return Value

true, if the data of the OracleXml object conforms to the given XML schema. Otherwise false.

Remarks

This method is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleXml Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleXml Class

For a list of all members of this type, see OracleXml members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets the OracleConnection used by this instance of the OracleXml.
public Property | IsEmpty | Indicates whether the OracleXml object is empty.
public Property | IsFragment | Indicates whether the OracleXml object is a collection of XML elements without the root element.
public Property | IsNull | Indicates whether the OracleXml object is null.
public Property | IsSchemaBased | Indicates whether the OracleXml object data is based on an XML schema.
public Property | RootElement | Returns the name of the top-level or root element of the schema-based XML data in this OracleXml object.
public Property | Schema | Returns the XML schema of the XML data in this OracleXml object.
public Property | SchemaUrl | Returns the URL in the database of the XML schema for the XML data in this OracleXml object.
public Property | Value | Gets a string representing XML data of the specified OracleXml object.
Top

See Also

Reference

OracleXml Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Connection Property

Gets or sets the OracleConnection used by this instance of the OracleXml.

Syntax

Visual Basic (Declaration)
Public Property Connection As OracleConnection
C#
public OracleConnection Connection {get; set;}

Property Value

The connection to a database. The default value is a null reference.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsEmpty Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : IsEmpty Property

Indicates whether the OracleXml object is empty.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty {get;}

Property Value

true, if the Value property is an empty XML documentl. Otherwise false.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsFragment Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : IsFragment Property

Indicates whether the OracleXml object is a collection of XML elements without the root element.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFragment As Boolean
C#
public bool IsFragment {get;}

Property Value

true, if the Value property contains a collection of XML elements without the root element. Otherwise false.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : IsNull Property

Indicates whether the OracleXml object is null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true, if the Value property is null. Otherwise false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsSchemaBased Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : IsSchemaBased Property

Indicates whether the OracleXml object data is based on an XML schema.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSchemaBased As Boolean
C#
public bool IsSchemaBased {get;}

Property Value

true, if the OracleXml object data is based on an XML schema. Otherwise false.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RootElement Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : RootElement Property

Returns the name of the top-level or root element of the schema-based XML data in this OracleXml object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootElement As String
C#
public string RootElement {get;}

Property Value

The name of the top-level or root element of the schema-based XML data in this OracleXml object.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Schema Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Schema Property

Returns the XML schema of the XML data in this OracleXml object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As OracleXml
C#
public OracleXml Schema {get;}

Property Value

The XML schema of the XML data in this OracleXml object.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SchemaUrl Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : SchemaUrl Property

Returns the URL in the database of the XML schema for the XML data in this OracleXml object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SchemaUrl As String
C#
public string SchemaUrl {get;}

Property Value

The URL in the database of the XML schema for the XML data in this OracleXml object.

Remarks

This property is not supported in the OracleConnection.Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Value Property

Gets a string representing XML data of the specified OracleXml object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
C#
public string Value {get;}

Property Value

A System.String containing XML data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleXml Class Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleXml Class

For a list of all members of this type, see OracleXml members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null value of an OracleXml object.
Top

See Also

Reference

OracleXml Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleXml Class : Null Field

Represents a null value of an OracleXml object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleXml
C#
public static readonly OracleXml Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleXml Class
OracleXml Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementExecuteEventArgs Class
Members See Also support@devart.com
Devart.Data.Oracle Namespace : SqlStatementExecuteEventArgs Class

Provides data for the OracleScript.SqlStatementExecute event of the OracleScript class.

Inheritance Hierarchy

System.Object
System.EventArgs
Devart.Data.Oracle.SqlStatementExecuteEventArgs

Syntax

Visual Basic (Declaration)
Public Class SqlStatementExecuteEventArgs
   Inherits Devart.Common.DbStatementExecuteEventArgs
C#
public class SqlStatementExecuteEventArgs : Devart.Common.DbStatementExecuteEventArgs

Remarks

The OracleScript.SqlStatementExecute event contains all information about a statement. See a sample in the OracleScript Hints for SQL*Plus Users article.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SqlStatementExecuteEventArgs Members
Devart.Data.Oracle Namespace
SqlStatementExecute Event
SqlStatementExecuteEventHandler Delegate


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SqlStatementExecuteEventArgs Class Members
See Also Properties support@devart.com
Devart.Data.Oracle Namespace : SqlStatementExecuteEventArgs Class

The following tables list the members exposed by SqlStatementExecuteEventArgs.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | LineNumber | Gets number of line in the whole script where the statement can be located. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | LinePosition | Gets position of the statement in its line. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Offset | Gets offset of the statement in the whole script text. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Reader | Gets or sets an OracleDataReader that represents statement resultset.
public Property | SqlPlusStatementType | Gets type of SQL*Plus statement.
public Property | StatementStatus | Determines status of the statement and script execution. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | StatementType | Gets type of the statement. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Text | Gets the SQL statement that is about to be executed. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
Top

See Also

Reference

SqlStatementExecuteEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SqlStatementExecuteEventArgs Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : SqlStatementExecuteEventArgs Class

For a list of all members of this type, see SqlStatementExecuteEventArgs members.

Public Properties

 | Name | Description
public Property | Length | Gets length of the statement in symbols. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | LineNumber | Gets number of line in the whole script where the statement can be located. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | LinePosition | Gets position of the statement in its line. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Offset | Gets offset of the statement in the whole script text. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Reader | Gets or sets an OracleDataReader that represents statement resultset.
public Property | SqlPlusStatementType | Gets type of SQL*Plus statement.
public Property | StatementStatus | Determines status of the statement and script execution. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | StatementType | Gets type of the statement. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
public Property | Text | Gets the SQL statement that is about to be executed. (Inherited from Devart.Common.DbStatementExecuteEventArgs)
Top

See Also

Reference

SqlStatementExecuteEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Reader Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : Reader Property

Gets or sets an OracleDataReader that represents statement resultset.

Syntax

Visual Basic (Declaration)
Public Shadows Property Reader As OracleDataReader
C#
public new OracleDataReader Reader {get; set;}

Property Value

An OracleDataReader object. This property can be null.

Remarks

Use this property when you set StatementStatus to F:Devart.Data.Oracle.OracleSqlStatementStatus.SkipStatement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlPlusStatementType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : SqlPlusStatementType Property

Gets type of SQL*Plus statement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SqlPlusStatementType As SqlPlusStatementType
C#
public SqlPlusStatementType SqlPlusStatementType {get;}

Property Value

One of the SqlPlusStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%ItemTitle%% - Enumerations

Devart.Data.Oracle Namespace - Enumerations
See Also Inheritance Hierarchy support@devart.com

Enumerations

 | Enumeration | Description
Enumeration | DirectUtils.SecurityLevel | Determines the configuration of Oracle Advanced Security data encryption and data integrity for the Direct mode.
Enumeration | OracleConnectMode | Holds fields which allow to open a session with specified privileges.
Enumeration | OracleDbType | Specifies the data type of a field, property, Devart.Data.Oracle.OracleParameter or OracleAttribute.
Enumeration | OracleFailoverState | Represents Transparent Application Failover state.
Enumeration | OracleFailoverType | Represents Transparent Application Failover type.
Enumeration | OracleHAEventSource | Indicates the source of a HA event.
Enumeration | OracleHAEventStatus | Indicates the status of the HA event source.
Enumeration | OracleIdentityType | Specifies how Oracle identity column values are generated.
Enumeration | OracleLoaderOptions | Allows configuring behavior of the OracleLoader class.
Enumeration | OracleLobOpenMode | Specifies whether an OracleLob should be opened in read-only or read/write mode.
Enumeration | OracleNotificationInfo | Specifies the operation, for which a notification is received from Oracle server.
Enumeration | OracleNotificationType | Specifies the type of notification received from Oracle server.
Enumeration | OracleNumberType | Enumerates main Oracle number types.
Enumeration | OracleObjectType | Describes Oracle object type for the OracleError class. Object type is a logical structure of data stored in a database. A brief definitions of corresponding Oracle structures are given below.
Enumeration | OraclePdbOpenMode | Specifies the open mode for starting a PDB Oracle instance with the OracleDatabase.Startup method of the OracleDatabase class (for Oracle 12c and higher).
Enumeration | OracleQueryBasedNotificationMode | Specifies the mode for query-based notifications.
Enumeration | OracleQueueCompatible | Specifies the lowest database version with which the queue is compatible.
Enumeration | OracleQueueDeliveryMode | Specifies whether the message is persistent or buffered. If buffered, it will be lost after the application's shutdown. Persistent messages are stored in the database table.
Enumeration | OracleQueueDequeueMode | Specifies how the messages will be dequeued.
Enumeration | OracleQueueMessageGrouping | Specifies the message grouping behaviour.
Enumeration | OracleQueueMessageState | Specifies the state of the message.
Enumeration | OracleQueueNavigation | Specifies which message will be dequeued next.
Enumeration | OracleQueuePrivilege | The privilege to enqueue or dequeue messages on the queue.
Enumeration | OracleQueueSequenceDeviation | Specifies whether the message being enqueued should be dequeued before other messages already in the queue.
Enumeration | OracleQueueSortOrder | Specifies which parameters are used to order messages in the queue. The order is ascending.
Enumeration | OracleQueueSystemPrivilege | The AQ administration privilige granted to or revoked from a user or role.
Enumeration | OracleQueueType | Specifies whether the queue is normal, service or nonpersistent with RAW message payload.
Enumeration | OracleQueueVisibility | Specifies the visibility options for an enqueue operation.
Enumeration | OracleServerType | Specifies whether the connection is established to an Oracle database or to TimesTen database.
Enumeration | OracleShutdownMode | Specifies the shutdown mode for the OracleDatabase.Shutdown method that shuts down an Oracle Database instance.
Enumeration | OracleStartupMode | Specifies the database startup mode.
Enumeration | PlSqlTraceMode | Defines the level of PL/SQL trace for the OracleTrace component.
Enumeration | ReadLobMode | Determines how LOB data is fetched and represented.
Enumeration | SqlPlusStatementType | Describes type of SQL*Plus command. Unless the corresponding SQL*Plus command name is explicitly specified, it coincides with the enumeration member's title. The functionality of corresponding commands in SQL*Plus is given below.
Enumeration | SqlTraceMode | Defines the level of SQL trace for the OracleTrace component.
Enumeration | TraceState | Specifies type of the trace mode in the OracleTrace component.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DirectUtils.SecurityLevel Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : DirectUtils.SecurityLevel Enumeration

Determines the configuration of Oracle Advanced Security data encryption and data integrity for the Direct mode.

Syntax

Visual Basic (Declaration)
Public Enum DirectUtils.SecurityLevel
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum DirectUtils.SecurityLevel : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Accepted | The security service is enabled when required or requested by the server.
Rejected | The security service is not enabled, even when required by the server. If server requires it, connection fails.
Requested | The security service is enabled unless the server rejects it.
Required | The security service is required to be enabled. If the server is configured to reject security service, connection fails.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.DirectUtils.SecurityLevel

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectMode Enumeration

Holds fields which allow to open a session with specified privileges.

Syntax

Visual Basic (Declaration)
Public Enum OracleConnectMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleConnectMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Default | The default value. Opens an unprivileged session.
SysAsm | Opens a session with SYSASM privilege.
SysBackup | Opens a session with SYSBACKUP privilege.
SysDba | Opens a session with SYSDBA privilege.
SysDg | Opens a session with SYSDG privilege.
SysKm | Opens a session with SYSKM privilege.
SysOper | Opens a session with SYSOPER privilege.

Remarks

The OracleConnectMode enumerator is used with OracleConnection.ConnectMode property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleConnectMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDbType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDbType Enumeration

Specifies the data type of a field, property, Devart.Data.Oracle.OracleParameter or OracleAttribute.

Syntax

Visual Basic (Declaration)
Public Enum OracleDbType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleDbType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
AnyData | An ANYDATA TYPE contains an instance of a given type, plus a description of the type. In this sense, an ANYDATA is self-describing. An ANYDATA can be persistently stored in the database.
Array | An Oracle VARRAY data type representing a variable-length array. May be represented as the OracleArray class. This type does not have corresponding .NET Framework type.
BFile | An Oracle BFILE data type that contains a reference to binary data stored in an external file. May be represented as the OracleBFile class or array of System.Byte.
Blob | A LOB data type that contains a variable-length stream of binary data. Represented as the array of System.Byte.
Boolean | A simple type representing Boolean values of true or false. Corresponds to the server PL/SQL BOOLEAN type.
Byte | Corresponds to TT_TINYINT TimesTen type and NUMBER Oracle type. May be represented as the OracleNumber structure or System.Byte.
Char | A CHAR data type that contains a fixed-length character string. Represented as the System.String.
Clob | An Oracle CLOB data type that contains a variable-length character data. May be represented as the OracleLob class or the System.String.
Cursor | An Oracle REF CURSOR. This type does not have corresponding .NET Framework type. The OracleDataReader object can be used to retrieve cursor content.
Date | An Oracle DATE data type. May be represented as the OracleDate class.
Double | An Oracle NUMBER(p, s) [p >= 10 or s > 0] data type and BINARY_DOUBLE number data type of Oracle 10g that contains a double-precision floating-point value. A floating point type representing values ranging from approximately -1.79 x 10(308) to 1.79 x 10(308) with a precision of 15-16 digits. May be represented as the OracleNumber structure or the System.Double.
Float | An Oracle 10g BINARY_FLOAT number data type that contains a single-precision floating-point value. A floating point type representing values ranging from approximately -3.4 x 10(38) to 3.4 x 10(38). May be represented as the System.Single.
Int16 | Corresponds to TT_SMALLINT TimesTen type and NUMBER Oracle type. May be represented as the OracleNumber structure or System.Int16.
Int64 | Corresponds to TT_BIGINT TimesTen type and NUMBER Oracle type. May be represented as the OracleNumber structure or the System.Int64.
Integer | An Oracle NUMBER(p) [p < 10] data type that contains a signed 32-bit integers with values between -2147483648 and 2147483647. May be represented as the OracleNumber structure or the System.Int32.
IntervalDS | An Oracle INTERVAL DAY TO SECOND data type that contains an interval of time in days, hours, minutes, and seconds. May be represented as the OracleIntervalDS structure or the System.TimeSpan.
IntervalYM | An Oracle INTERVAL YEAR TO MONTH data type that contains an interval of time in years and months. May be represented as the OracleIntervalYM structure or the System.Int64.
Long | An Oracle LONG data type that contains a variable-length character string. May be represented as the OracleString structure or the System.String.
LongRaw | An Oracle LONG RAW data type that contains a variable-length stream of binary data. May be represented as the OracleBinary structure or array of System.Byte.
NChar | An Oracle NCHAR data type that contains a fixed-length national character string. May be represented as the OracleString structure or the System.String.
NClob | An Oracle NCLOB data type that contains a national variable-length character data. May be represented as the OracleLob class or the System.String.
Number | An Oracle NUMBER data type that contains variable-length numeric data with a maximum precision and scale of 38. May be represented as the OracleNumber structure or the System.Decimal.
NVarChar | An Oracle NVARCHAR data type that contains a variable-length national character string. May be represented as the OracleString structure or the System.String.
Object | One of the Oracle object types defined by the user. May be represented as the OracleObject class. This type does not have corresponding .NET Framework type.
Raw | An Oracle RAW data type that contains a fixed-length stream of binary data ranging between 1 and 4,000 bytes. May be represented as the OracleBinary structure or array of System.Byte.
Ref | An Oracle REF data type that contains a reference to the object. May be represented as the OracleRef class. This type does not have corresponding .NET Framework type.
RowId | The string representation of an Oracle ROWID data type. May be represented as the OracleString structure or the System.String.
Table | An Oracle NESTED TABLE data type, an unordered set of data elements, all of the same type. May be represented as the OracleTable class. This type does not have corresponding .NET Framework type.
TimeStamp | A TIMESTAMP data type that contains date and time, including seconds. Represented as the System.DateTime.
TimeStampLTZ | An Oracle TIMESTAMP WITH LOCAL TIMEZONE data type that contains date, time, and a reference to the original time zone. May be represented as the OracleTimeStamp structure or the System.DateTime.
TimeStampTZ | An Oracle TIMESTAMP WITH TIMEZONE data type that contains date, time, and a specified time zone. May be represented as the OracleTimeStamp structure or the System.DateTime.
VarChar | A VARCHAR data type that contains a variable-length character string. Represented as the System.String.
Xml | An Oracle XMLType type that contains XML data. May be represented as the OracleXml object.

Remarks

This table shows mappings between OracleDbType values, Oracle data types, Microsoft .NET Framework types.

The next table shows mapping of System.Data.DbType members to OracleDbType.

DbType member | Corresponding OracleDbType member
AnsiString | VarChar
AnsiStringFixedLength | Char
Binary | Blob
Byte | Integer
Boolean | Boolean
Currency | Number
Date | Date
DateTime | TimeStamp
DateTime2 | TimeStamp
DateTimeOffset | TimeStampTZ
Decimal | Number
Double | Double
Guid | Raw
Int16 | Integer
Int32 | Integer
Int64 | Number
Object | Object*
SByte | Integer
Single | Float
String | VarChar
StringFixedLength | Char
Time | IntervalDS
UInt16 | Integer
UInt32 | Number
UInt64 | Number
VarNumeric | Number
Xml | Xml

*) OracleDbType is not actually assigned, it is determined later based on the OracleParameter.Value property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleDbType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleFailoverState Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverState Enumeration

Represents Transparent Application Failover state.

Syntax

Visual Basic (Declaration)
Public Enum OracleFailoverState
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleFailoverState : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Abort | Indicates that failover was unsuccessful and there is no option to retry.
Begin | Indicates that failover has detected a lost connection and failover is starting.
End | Indicates successful completion of failover.
Error | Indicates that an error occurred while trying to re-establish a connection.
Reauth | Indicates that an user handle has been re-authenticated.
Unknown | Unknown stage is detected. This may indicate application failover internal error.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleFailoverState

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleFailoverType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverType Enumeration

Represents Transparent Application Failover type.

Syntax

Visual Basic (Declaration)
Public Enum OracleFailoverType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleFailoverType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
None | Indicates that the user not requested any failover type.
Select | Indicates that the user requested select failover.
Session | Indicates that the user requested only session failover.
Transaction | Indicates that the user requested transaction failover.
Unknown | Unknown type is detected. This may indicate application failover internal error.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleFailoverType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHAEventSource Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventSource Enumeration

Indicates the source of a HA event.

Syntax

Visual Basic (Declaration)
Public Enum OracleHAEventSource
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleHAEventSource : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Database | The source of an event is a database.
Instance | The source of an event is an instance.
Node | The source of an event is a node.
Service | The source of an event is a service.
ServiceMember | The source of an event is a service member.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleHAEventSource

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHAEventStatus Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventStatus Enumeration

Indicates the status of the HA event source.

Syntax

Visual Basic (Declaration)
Public Enum OracleHAEventStatus
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleHAEventStatus : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Down | The source of the event is down.
Up | The source of the event is up.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleHAEventStatus

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIdentityType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIdentityType Enumeration

Specifies how Oracle identity column values are generated.

Syntax

Visual Basic (Declaration)
Public Enum OracleIdentityType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleIdentityType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
GeneratedAlways | Unique values are generated for every insertion. This column does not allow updates or inserts.
GeneratedByDefault | The values are generated only if no explicit value is provided for this column.
GeneratedByDefaultOnNull | The values are generated only if no explicit value is provided or a NULL value is inserted into this column.
None | The values are not generated.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleIdentityType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderOptions Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderOptions Enumeration

Allows configuring behavior of the OracleLoader class.

Syntax

Visual Basic (Declaration)
Public Enum OracleLoaderOptions
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleLoaderOptions : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Default | Default behavior.
DisableIndexes | Disable table indexes when loading data. Applied only when array binding is used for loading data.
DisableTriggers | Disable table triggers when loading data. Applied both for array binding and direct path loading.
KeepConstraints |
NoLogging | Disables table logging when loading data. Applied only when array binding is used for loading data.
UseArrayBinding | Use array binding for loading data even when direct path interface can be used.
UseInternalTransaction | Use a transaction for loading data. Applied only when array binding is used for loading data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleLoaderOptions

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLobOpenMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLobOpenMode Enumeration

Specifies whether an OracleLob should be opened in read-only or read/write mode.

Syntax

Visual Basic (Declaration)
Public Enum OracleLobOpenMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleLobOpenMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
ReadOnly | The OracleLob is opened in read-only mode.
ReadWrite | The OracleLob is opened in read/write mode.

Remarks

Use OracleLobOpenMode enumerator with OracleLob.BeginBatch method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleLobOpenMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNotificationInfo Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationInfo Enumeration

Specifies the operation, for which a notification is received from Oracle server.

Syntax

Visual Basic (Declaration)
Public Enum OracleNotificationInfo
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleNotificationInfo : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
AllOps | Any operation (used for operations filter only).
AllRows | All rows in a table are affected (for example, table is truncated, a column is added, and so on).
Alter | An object is altered.
Delete | A row is deleted.
Drop | An object or database is dropped.
Insert | A row is inserted.
Unknown | The reason is unknown.
Update | A row is updated.

Remarks

To obtain the detailed notification information, consult the OracleNotificationEventArgs.Details property. This enumeration is actual when OracleNotificationEventArgs.Type is OracleNotificationType.Change.

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleNotificationInfo

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNotificationType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNotificationType Enumeration

Specifies the type of notification received from Oracle server.

Syntax

Visual Basic (Declaration)
Public Enum OracleNotificationType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleNotificationType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Change | A database object or its data is modified. For detailed information refer to the OracleNotificationEventArgs.Details property.
DropDb | A database is dropped.
End | The registration expires.
Error | An error is encountered while processing the notification.
None | A notification of unknown type is received.
QueryChange | A query-based change occurs in the database when using OracleDependency.
Shutdown | A database shuts down.
Shutdown_any | A database instance in a Real Application Cluster environment shuts down.
Startup | A database starts.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleNotificationType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumberType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumberType Enumeration

Enumerates main Oracle number types.

Syntax

Visual Basic (Declaration)
Public Enum OracleNumberType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleNumberType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Float | Corresponds to the FLOAT Oracle type.
Integer | Corresponds to the NUMBER Oracle type when the scale equals 0.
Number | Corresponds to the NUMBER Oracle type with any scale value.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleNumberType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleObjectType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleObjectType Enumeration

Describes Oracle object type for the OracleError class. Object type is a logical structure of data stored in a database. A brief definitions of corresponding Oracle structures are given below.

Syntax

Visual Basic (Declaration)
Public Enum OracleObjectType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleObjectType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
ConsumerGroup | A collection of user sessions that are grouped together based on their processing needs. When a session is created, it is automatically mapped to a consumer group based on mapping rules that you have set up.
EvaluationContext | A database object that defines external data that can be referenced in rule conditions. The external data can exist as variables, table data, or both.
Function | A schema object, similar to a procedure, that always returns a single value.
Index | Index is a schema object that contains an entry for each indexed row of the table or table cluster and provide direct, fast access to rows. Oracle Database supports several types of index. An index-organized table is a table in which the data is stored in an index structure.
Library | A schema object associated with an operating-system shared library. The name of this schema object can then be used in the call_spec of CREATE FUNCTION or CREATE PROCEDURE statements, or when declaring a function or procedure in a package or type, so that SQL and PL/SQL can call to third-generation-language (3GL) functions and procedures.
Lob | Large object. An Oracle data type designed to hold large amounts of data.
Operator | An Oracle structure that represents user-defined operator for manipulating data items.
Package | An encapsulated collection of related procedures, functions, and other program objects stored together in the database.
PackageBody | A collection of object definitions declared in a package.
Procedure | A schema object that consists of a set of SQL statements and other PL/SQL constructs, grouped together, stored in the database, and run as a unit to solve a specific problem or perform a set of related tasks.
Synonym | A synonym is an alias for another schema object. Because a synonym is simply an alias, it requires no storage other than its definition in the data dictionary.
Table | Basic unit of data storage in Oracle Database. Data in tables is stored in rows and columns.
Trigger | A PL/SQL procedure that fires when a table or view is modified or when specific user or database actions occur. Procedures are explicitly run, whereas triggers are implicitly run.
Type | An object type, represented by varying array (varray), a nested table type, or an Oracle object type.
TypeBody | A container for the member methods defined in the object type specification.
Unknown | Object type is not defined.
View | A customized presentation of data in one or more tables or other views. You can think of it as of stored query. View does not actually contain data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleObjectType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePdbOpenMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePdbOpenMode Enumeration

Specifies the open mode for starting a PDB Oracle instance with the OracleDatabase.Startup method of the OracleDatabase class (for Oracle 12c and higher).

Syntax

Visual Basic (Declaration)
Public Enum OraclePdbOpenMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OraclePdbOpenMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
ReadOnly | A PDB instance is opened as read-only.
ReadWrite | A PDB instance is opened for reading and writing.
Upgrade | A PDB instance is opened, and operations that prepare the environment for the upgrade are performed.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OraclePdbOpenMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueryBasedNotificationMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueryBasedNotificationMode Enumeration

Specifies the mode for query-based notifications.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueryBasedNotificationMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueryBasedNotificationMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
BestEffort | The best-effort mode. No notifications are lost, however, false positives may occur in this mode.
Guaranteed | The guaranteed mode. Any database change notification ensures that a change occurred to the queried result set. However some complex queries cannot be registered in this mode. The best-effort mode is used for them.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueryBasedNotificationMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueCompatible Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueCompatible Enumeration

Specifies the lowest database version with which the queue is compatible.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueCompatible
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueCompatible : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Default | The queue compatibility is set according to the database compatibility settings.
ver100 | The queue is compatible with version 10.0 or higher.
ver80 | The queue is compatible with version 8.0 or higher.
ver81 | The queue is compatible with version 8.1 or higher.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueCompatible

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDeliveryMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDeliveryMode Enumeration

Specifies whether the message is persistent or buffered. If buffered, it will be lost after the application's shutdown. Persistent messages are stored in the database table.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueDeliveryMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueDeliveryMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Buffered | Message is buffered.
Persistent | Message is persistent.
PersistentOrBuffered | Message is either persistent or buffered.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueDeliveryMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueDequeueMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueDequeueMode Enumeration

Specifies how the messages will be dequeued.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueDequeueMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueDequeueMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Browse | Read the message without acquiring any lock on the message.
Locked | Read and obtain a write lock on the message.
Remove | Read the message and delete it.
RemoveNoData | Mark the message as updated or deleted.
Unknown | The dequeuing behaviour is not set.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueDequeueMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageGrouping Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageGrouping Enumeration

Specifies the message grouping behaviour.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueMessageGrouping
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueMessageGrouping : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
None | Message grouping is disabled, each message is treated individually. This is default value.
Transactional | Message grouping is enabled. All messages enqueued in one transaction are considered part of the same group and can be dequeued as a group of related messages.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueMessageGrouping

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageState Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageState Enumeration

Specifies the state of the message.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueMessageState
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueMessageState : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Expired | The message has been moved to the exception queue.
Processed | The message has been processed and is retained.
Ready | The message is ready to be processed.
Waiting | The message delay has not yet been reached.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueMessageState

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueNavigation Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueNavigation Enumeration

Specifies which message will be dequeued next.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueNavigation
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueNavigation : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
FirstMessage | Retrieves the first message which is available and matches the search criteria. This setting resets the position to the beginning of the queue.
FirstMessageMultiGroup | Indicates that a call to DequeueArray will reset the position to the beginning of the queue and dequeue messages (possibly across different transaction groups) that are available and match the search criteria, until reaching the array length limit. (Supported in Oracle server 10g and greater.)
NextMessage | Retrieve the next message that is available and matches the search criteria. If the previous message belongs to a message group, AQ retrieves the next available message that matches the search criteria and belongs to the message group.
NextMessageMultiGroup | Indicates that a call to DequeueArray will dequeue the next set of messages (possibly across different transaction groups) that are available and match the search criteria, until reaching the array length limit. (Supported in Oracle server 10g and greater.)
NextTransaction | Skip the remainder of the current transaction group (if any) and retrieve the first message of the next transaction group. This setting can only be used if message grouping is enabled for the current queue.
Unknown | The next dequeud message is not specified.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueNavigation

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueuePrivilege Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueuePrivilege Enumeration

The privilege to enqueue or dequeue messages on the queue.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueuePrivilege
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueuePrivilege : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
All | Ability to execute both Enqueue and Dequeue for specified queue.
Dequeue | Ability to execute Dequeue for specified queue.
Enqueue | Ability to execute Enqueue for specified queue.
Unknown | The privilege is not specified.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueuePrivilege

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueSequenceDeviation Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueSequenceDeviation Enumeration

Specifies whether the message being enqueued should be dequeued before other messages already in the queue.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueSequenceDeviation
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueSequenceDeviation : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Before | The message is enqueued ahead of the message specified by OracleQueueEnqueueOptions.RelativeMessageId.
Top | The message is enqueued ahead of any other messages.
Unknown | No sequence deviation.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueSequenceDeviation

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueSortOrder Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueSortOrder Enumeration

Specifies which parameters are used to order messages in the queue. The order is ascending.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueSortOrder
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueSortOrder : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
EnqueueTime | Sort by enqueue time. This is the default value.
EnqueueTimePriority | Sort by enqueue time and then by priority.
Priority | Sort by priority.
PriorityEnqueueTime | Sort by priority and then by enqueue time.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueSortOrder

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueSystemPrivilege Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueSystemPrivilege Enumeration

The AQ administration privilige granted to or revoked from a user or role.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueSystemPrivilege
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueSystemPrivilege : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
DequeueAny | Means users granted this privilege are allowed to dequeue messages from any queues in the database.
EnqueueAny | Means users granted this privilege are allowed to enqueue messages to any queues in the database.
ManageAny | Means users granted this privilege are allowed to run OracleQueueAdmin methods calls on any schemas in the database.
Unknown | The system privilege is not specified.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueSystemPrivilege

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueType Enumeration

Specifies whether the queue is normal, service or nonpersistent with RAW message payload.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Exception | Exception queue, which is the repository for all expired and non-serviceable messages. Messages cannot be directly enqueued to the exception queue.
NonPersistentMultiConsumers | Nonpersistent queue, which is not stored in a database table. Multiconsumer variant.
NonPersistentSingleConsumers | Nonpersistent queue, which is not stored in a database table. Single consumer variant.
Normal | Normal queue.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueVisibility Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueVisibility Enumeration

Specifies the visibility options for an enqueue operation.

Syntax

Visual Basic (Declaration)
Public Enum OracleQueueVisibility
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleQueueVisibility : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Immediate | The enqueue operation is not part of the current transaction, but an autonomous transaction which commits at the end of the operation. This is the only value allowed when enqueuing to a non-persistent queue.
OnCommit | The enqueue is part of the current transaction. The operation is complete when the transaction commits.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleQueueVisibility

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleServerType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleServerType Enumeration

Specifies whether the connection is established to an Oracle database or to TimesTen database.

Syntax

Visual Basic (Declaration)
Public Enum OracleServerType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleServerType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Oracle | This is the connection to an Oracle database.
TimesTen | This is the connection to TimesTen database.
Undefined | The server type is undefined.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleServerType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleShutdownMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleShutdownMode Enumeration

Specifies the shutdown mode for the OracleDatabase.Shutdown method that shuts down an Oracle Database instance.

Syntax

Visual Basic (Declaration)
Public Enum OracleShutdownMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleShutdownMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Abort | Does not wait for current calls to complete or users to disconnect from the database. All uncommitted transactions are terminated and are not rolled back.
Default | Refuses new connections and waits for connected users to disconnect.
Final | Shuts down the database. This value is not recommended to use when calling the OracleDatabase.Shutdown the first time. This mode should be used only if the database is already closed and dismounted. Otherwise, the method might wait indefinitely. Use this value only for the second OracleDatabase.Shutdown call after the database has been closed and dismounted.
Immediate | Does not wait for current calls to complete or open connections to close. All uncommitted transactions are terminated and rolled back.
Transactional | Refuses new connections and does not allow any new transactions. Waits for active transactions to commit.
TransactionalLocal | Refuses new connections and does not allow any new transactions. Waits for local transactions only to commit.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleShutdownMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleStartupMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleStartupMode Enumeration

Specifies the database startup mode.

Syntax

Visual Basic (Declaration)
Public Enum OracleStartupMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum OracleStartupMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Default | Starts the database with access allowed for all users.
Force | Shuts down a running instance in OracleShutdownMode.Abort mode and starts a new instance.
Restrict | Starts the database with access allowed only for users with the CREATE SESSION and RESTRICTED SESSION privileges.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.OracleStartupMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PlSqlTraceMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : PlSqlTraceMode Enumeration

Defines the level of PL/SQL trace for the OracleTrace component.

Syntax

Visual Basic (Declaration)
Public Enum PlSqlTraceMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum PlSqlTraceMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
AllCalls | Trace all calls.
AllExceptions | Trace all exceptions.
AllLines | Trace all lines.
AllSql | Trace all SQL executions.
EnabledCalls | Trace calls to enabled PL/SQL units only.
EnabledExceptions | Trace exceptions raised in the enabled PL/SQL units only.
EnabledLines | Trace lines in enabled PL/SQL units only.
EnabledSql | Trace SQL executions in the enabled PL/SQL units only.
Unknown | Unknown mode.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.PlSqlTraceMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ReadLobMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : ReadLobMode Enumeration

Determines how LOB data is fetched and represented.

Syntax

Visual Basic (Declaration)
Public Enum ReadLobMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum ReadLobMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
CachedDirect | LOB objects are treated as instances OracleLob, fetched immediately, and stored in cache, so on consequent data fetch operations the LOB object will not be requested again from the server.
Deferred | LOB objects are treated as instances OracleLob. The actual LOB data is fetched only when the field value is requested. The cache is not used.
DefferedCachedDirect | LOB objects are treated as instances OracleLob. The actual LOB data is fetched only when the field value is requested. The cache is used.
Direct | LOB objects are treated as instances OracleLob, and fetched immediately. The cache is not used, so on consequent data fetch operations the LOB object will be read again from the server.
Value | LOB objects are treated as byte arrays or strings, and fetched immediately.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.ReadLobMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlPlusStatementType Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : SqlPlusStatementType Enumeration

Describes type of SQL*Plus command. Unless the corresponding SQL*Plus command name is explicitly specified, it coincides with the enumeration member's title. The functionality of corresponding commands in SQL*Plus is given below.

Syntax

Visual Basic (Declaration)
Public Enum SqlPlusStatementType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum SqlPlusStatementType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Accept | Represents the ACCEPT SQL*Plus command. In SQL*Plus this command reads a line of input and stores it in a given user variable.
Append | Represents the APPEND SQL*Plus command. In SQL*Plus this command adds specified text to the end of the current line in the buffer.
Archive | Represents the ARCHIVE SQL*Plus command. In SQL*Plus this command starts or stops the automatic archiving of online redo log files, manually (explicitly) archives specified redo log files, or displays information about redo log files.
Attribute | Represents the ATTRIBUTE SQL*Plus command. In SQL*Plus this command specifies display characteristics for a given attribute of an Object Type column, and lists the current display characteristics for a single attribute or all attributes.
Break | Represents the BREAK SQL*Plus command. In SQL*Plus this command specifies where and how formatting will change in a report, or lists the current break definition.
Btitle | Represents the BTITLE SQL*Plus command. In SQL*Plus this command places and formats a specified title at the bottom of each report page, or lists the current BTITLE definition.
Change | Represents the CHANGE SQL*Plus command. In SQL*Plus this command changes text on the current line in the buffer.
Clear | Represents the CLEAR SQL*Plus command. In SQL*Plus this command resets or erases the current clause or setting for the specified option, such as BREAKS or COLUMNS.
Column | Represents the COLUMN SQL*Plus command. In SQL*Plus this command specifies display characteristics for a given column, or lists the current display characteristics for a single column or for all columns.
Compute | Represents the COMPUTE SQL*Plus command. In SQL*Plus this command calculates and prints summary lines, using various standard computations, on subsets of selected rows, or lists all COMPUTE definitions.
Connect | Represents the CONNECT SQL*Plus command. In SQL*Plus this command connects a given user to Oracle.
Copy | Represents the COPY SQL*Plus command. In SQL*Plus this command copies results from a query to a table in a local or remote database.
Define | Represents the DEFINE SQL*Plus command. In SQL*Plus this command specifies a user variable and assigns it a CHAR value, or lists the value and variable type of a single variable or all variables.
Del | Represents the DEL SQL*Plus command. In SQL*Plus this command deletes one or more lines of the buffer.
Describe | Represents the DESCRIBE SQL*Plus command. In SQL*Plus this command lists the column definitions for the specified table, view, or synonym or the specifications for the specified function or procedure.
Disconnect | Represents the DISCONNECT SQL*Plus command. In SQL*Plus this command commits pending changes to the database and logs the current user off Oracle, but does not exit SQL*Plus.
Edit | Represents the EDIT SQL*Plus command. In SQL*Plus this command invokes a host operating system text editor on the contents of the specified file or on the contents of the buffer.
Execute | Represents the EXECUTE SQL*Plus command. In SQL*Plus this command executes a single PL/SQL statement.
Get | Represents the GET SQL*Plus command. In SQL*Plus this command loads a host operating system file into the SQL buffer.
Help | Represents the HELP SQL*Plus command. In SQL*Plus this command accesses the SQL*Plus help system.
Host | Represents the HOST SQL*Plus command. In SQL*Plus this command executes a host operating system command without leaving SQL*Plus.
Input | Represents the INPUT SQL*Plus command. In SQL*Plus this command adds one or more new lines after the current line in the buffer.
List | Represents the LIST SQL*Plus command. In SQL*Plus this command lists one or more lines of the SQL buffer.
Password | Represents the PASSWORD SQL*Plus command. In SQL*Plus this command allows a password to be changed without echoing the password on an input device.
Pause | Represents the PAUSE SQL*Plus command. In SQL*Plus this command displays the specified text, then waits for the user to press Return.
Print | Represents the PRINT SQL*Plus command. In SQL*Plus this command displays the current value of a bind variable.
Prompt | Represents the PROMPT SQL*Plus command. In SQL*Plus this command sends the specified message to the user's screen.
Quit | Represents the QUIT SQL*Plus command. This command terminates SQL*Plus and returns control to the operating system.
Recover | Represents the RECOVER SQL*Plus command. In SQL*Plus this command performs media recovery on one or more tablespaces, one or more datafiles, or the entire database.
Remark | Represents the REMARK SQL*Plus command. In SQL*Plus this command begins a comment in a script.
Repfooter | Represents the REPFOOTER SQL*Plus command. In SQL*Plus this command places and formats a specified report footer at the bottom of each report, or lists the current REPFOOTER definition.
Repheader | Represents the REPHEADER SQL*Plus command. In SQL*Plus this command places and formats a specified report header at the top of each report, or lists the current REPHEADER definition.
Run | Represents the RUN SQL*Plus command. In SQL*Plus this command lists and executes the SQL command or PL/SQL block currently stored in the SQL buffer.
Save | Represents the SAVE SQL*Plus command. In SQL*Plus this command saves the contents of the SQL buffer in a host operating system file (a script).
Set | Represents the SET SQL*Plus command. In SQL*Plus this command sets a system variable to alter the SQL*Plus environment for your current session.
Show | Represents the SHOW SQL*Plus command. In SQL*Plus this command shows the value of a SQL*Plus system variable or the current SQL*Plus environment.
Shutdown | Represents the SHUTDOWN SQL*Plus command. In SQL*Plus this command shuts down a currently running Oracle instance.
Spool | Represents the SPOOL SQL*Plus command. In SQL*Plus this command stores query results in an operating system file and, optionally, sends the file to a printer.
Start | Represents the START SQL*Plus command. In SQL*Plus this command executes the contents of the specified script. The script can only be called from a url.
StartEx | Represents the @@ SQL*Plus command. In SQL*Plus this command runs a script; looks for the specified script in the same path as the script from which it was called.
Startup | Represents the STARTUP SQL*Plus command. In SQL*Plus this command starts an Oracle instance and optionally mounts and opens a database.
Store | Represents the STORE SQL*Plus command. In SQL*Plus this command saves attributes of the current SQL*Plus environment in a host operating system file (a script).
Timing | Represents the TIMING SQL*Plus command. In SQL*Plus this command records timing data for an elapsed period of time, lists the current timer's title and timing data, or lists the number of active timers.
Ttitle | Represents the TTITLE SQL*Plus command. In SQL*Plus this command places and formats a specified title at the top of each report page, or lists the current TTITLE definition.
Undefine | Represents the UNDEFINE SQL*Plus command. In SQL*Plus this command deletes one or more user variables that you defined either explicitly (with the DEFINE command) or implicitly (with an argument to the START command).
Unknown | The SQL*Plus command type is not set.
Variable | Represents the VARIABLE SQL*Plus command. In SQL*Plus this command declares a bind variable that can be referenced in PL/SQL.
Whenever | Represents the "WHENEVER OSERROR" or "WHENEVER SQLERROR" SQL*Plus command. This command exits SQL*Plus if either an operating system command or SQL command or PL/SQL block generates an error.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.SqlPlusStatementType

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlTraceMode Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : SqlTraceMode Enumeration

Defines the level of SQL trace for the OracleTrace component.

Syntax

Visual Basic (Declaration)
Public Enum SqlTraceMode
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum SqlTraceMode : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
BasicStatistics | BASIC statistics level (no advisories or statistics are collected).
BindVariables | Bind variables values are collected.
TimedStatistics | Duration of operation performance is collected.
Unknown | Unknown mode.
WaitEvents | Event wait information is collected.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.SqlTraceMode

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TraceState Enumeration
See Also support@devart.com
Devart.Data.Oracle Namespace : TraceState Enumeration

Specifies type of the trace mode in the OracleTrace component.

Syntax

Visual Basic (Declaration)
Public Enum TraceState
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum TraceState : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
PlSqlTrace | SQL trace.
SqlTrace | PL/SQL trace.
Unknown | Unknown state.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Oracle.TraceState

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Oracle Namespace


%%ItemTitle%% - Structures

Devart.Data.Oracle Namespace - Structures
See Also Inheritance Hierarchy support@devart.com

Structures

 | Structure | Description
Structure | OracleBinary | Represents a variable-length binary data to be stored in or retrieved from a database.
Structure | OracleDate | Represents the Oracle DATE data type.
Structure | OracleIntervalDS | Represents the Oracle INTERVAL DAY TO SECOND data type. Each object of the OracleIntervalDS class stores a period of time in term of days, hours, minutes, seconds, and fractional seconds.
Structure | OracleIntervalYM | Represents the Oracle INTERVAL YEAR TO MONTH data type. Each object of the OracleIntervalYM class stores a period of time in years and months.
Structure | OracleNumber | Represents the Oracle NUMBER or any numeric type.
Structure | OracleQueueMessageId | Represents the system-generated identification of the message.
Structure | OracleString | Represents a variable-length stream of characters to be stored in or retrieved from the database.
Structure | OracleTimeStamp | Represents the Oracle TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME ZONE data types.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBinary Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

Represents a variable-length binary data to be stored in or retrieved from a database.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleBinary

Syntax

Visual Basic (Declaration)
Public Structure OracleBinary
   Inherits System.ValueType
   Implements INullable, IComparable, ISerializable, IXmlSerializable
C#
public struct OracleBinary : System.ValueType, INullable, IComparable, ISerializable, IXmlSerializable

Remarks

Corresponds to Oracle RAW and LONG RAW data types. To obtain an OracleBinary object call the OracleDataReader.GetOracleBinary method of the OracleDataReader class.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleBinary Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleBinary Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

The following tables list the members exposed by OracleBinary.

Public Constructors

 | Name | Description
public Constructor | OracleBinary Constructor | Initializes a new instance of the OracleBinary structure, setting the Value property to the provided array of bytes.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleBinary structure.
Top

Public Properties

 | Name | Description
public Property | IsNull | Gets a value indicating whether the Value property of the OracleBinary is Null.
public Property | Item | Gets the single byte in an OracleBinary at the specified index.
public Property | Length | Gets the length of the binary data.
public Property | Value | Gets the value of the OracleBinary structure.
Top

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleBinary object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Concat | Concatenates two OracleBinary structures.
public Method | Equals | Overloaded. Compares two OracleBinary structures to determine if they are equal.
public Method | GetHashCode | Returns a hash code for the OracleBinary structure.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleBinary values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleBinary values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleBinary values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleBinary values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleBinary values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String to its OracleBinary equivalent.
public Method | ToString | Converts the specified OracleBinary structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the hexadecimal representation representation of a binary data to OracleBinary.
Top

Public Operators

public Operator Addition | Concatenates two OracleBinary values.
public Operator Equality | Compares two OracleBinary structures to determine if they are equal.
public Operator Explicit Type Conversion | Converts an OracleBinary value to a byte array.
public Operator Greater Than | Compares two OracleBinary structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleBinary structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts a byte array to an OracleBinary structure.
public Operator Inequality | Compares two OracleBinary structures to determine if they are not equal.
public Operator Less Than | Compares two OracleBinary structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleBinary structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleBinary Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBinary Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : OracleBinary Constructor

value
The byte array to be stored in the Value property.
Initializes a new instance of the OracleBinary structure, setting the Value property to the provided array of bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Byte _
)
C#
public OracleBinary(
   byte[] value
)

Parameters

value
The byte array to be stored in the Value property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleBinary Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

For a list of all members of this type, see OracleBinary members.

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleBinary object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Concat | Concatenates two OracleBinary structures.
public Method | Equals | Overloaded. Compares two OracleBinary structures to determine if they are equal.
public Method | GetHashCode | Returns a hash code for the OracleBinary structure.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleBinary values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleBinary values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleBinary values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleBinary values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleBinary values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String to its OracleBinary equivalent.
public Method | ToString | Converts the specified OracleBinary structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the hexadecimal representation representation of a binary data to OracleBinary.
Top

See Also

Reference

OracleBinary Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleBinary object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleBinary structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleBinary object is less than the object.
Zero | The current OracleBinary object is the same to the object.
Greater than zero | The current OracleBinary object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Concat Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Concat Method

value1
First OracleBinary.
value2
Second OracleBinary.
Concatenates two OracleBinary structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Concat( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As OracleBinary
C#
public static OracleBinary Concat(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

A new OracleBinary structure.

Remarks

If either argument has a null value, the returned OracleBinary structure has a null value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Equals Method

Compares two OracleBinary structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleBinary object.
Equals(OracleBinary,OracleBinary) | Determines whether two OracleBinary values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleBinary object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleBinary and has the same binary data; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleBinary,OracleBinary) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure > Equals Method : Equals(OracleBinary,OracleBinary) Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether two OracleBinary values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool Equals(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if two OracleBinary values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : GetHashCode Method

Returns a hash code for the OracleBinary structure.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : GreaterThan Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether the first of two OracleBinary values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool GreaterThan(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : GreaterThanOrEqual Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether the first of two OracleBinary values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : LessThan Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether the first of two OracleBinary values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool LessThan(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : LessThanOrEqual Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether the first of two OracleBinary values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : NotEquals Method

value1
First OracleBinary.
value2
Second OracleBinary.
Determines whether two OracleBinary values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public static bool NotEquals(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if two OracleBinary values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Parse Method

str
The System.String to be parsed.
Converts the specified System.String to its OracleBinary equivalent.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal str As String _
) As OracleBinary
C#
public static OracleBinary Parse(
   string str
)

Parameters

str
The System.String to be parsed.

Return Value

An OracleBinary structure equal to the specified System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : ToString Method

Converts the specified OracleBinary structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : TryParse Method

str
A string, containing a hexadecimal representation of a binary data to convert.
value
If the conversion was successful, this parameter contains the result OracleBinary value; otherwise it contains Null.
Converts the hexadecimal representation representation of a binary data to OracleBinary.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal str As String, _
   ByRef value As OracleBinary _
) As Boolean
C#
public static bool TryParse(
   string str,
   out OracleBinary value
)

Parameters

str
A string, containing a hexadecimal representation of a binary data to convert.
value
If the conversion was successful, this parameter contains the result OracleBinary value; otherwise it contains Null.

Return Value

true if the string was converted successfully; otherwise, false.

Remarks

The string must contain only hexadecimal characters in order for conversion to be successful.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleBinary Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

For a list of all members of this type, see OracleBinary members.

Public Properties

 | Name | Description
public Property | IsNull | Gets a value indicating whether the Value property of the OracleBinary is Null.
public Property | Item | Gets the single byte in an OracleBinary at the specified index.
public Property | Length | Gets the length of the binary data.
public Property | Value | Gets the value of the OracleBinary structure.
Top

See Also

Reference

OracleBinary Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : IsNull Property

Gets a value indicating whether the Value property of the OracleBinary is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Item Property

index
The zero-based index.
Gets the single byte in an OracleBinary at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Byte
C#
public byte this(
   int index
) {get;}

Parameters

index
The zero-based index.

Property Value

A byte at the specified index.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Length Property

Gets the length of the binary data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

The length of the binary data.

Remarks

Check the IsNull property before reading the Length property to avoid raising an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Value Property

Gets the value of the OracleBinary structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Byte()
C#
public byte[] Value {get;}

Property Value

The value of the OracleBinary structure.

Remarks

Check the IsNull property before reading the Value property to avoid raising an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleBinary Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

For a list of all members of this type, see OracleBinary members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleBinary structure.
Top

See Also

Reference

OracleBinary Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Null Field

Represents a null value that can be assigned to the Value property of an OracleBinary structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleBinary
C#
public static readonly OracleBinary Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleBinary Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleBinary Structure

The following tables list the members exposed by OracleBinary.

Public Operators

public Operator Addition | Concatenates two OracleBinary values.
public Operator Equality | Compares two OracleBinary structures to determine if they are equal.
public Operator Explicit Type Conversion | Converts an OracleBinary value to a byte array.
public Operator Greater Than | Compares two OracleBinary structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleBinary structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts a byte array to an OracleBinary structure.
public Operator Inequality | Compares two OracleBinary structures to determine if they are not equal.
public Operator Less Than | Compares two OracleBinary structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleBinary structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleBinary Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Addition Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Concatenates two OracleBinary values.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As OracleBinary
C#
public OracleBinary operator +(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

A new OracleBinary object.

Remarks

If either argument has a null value, the returned OracleBinary structure has a null value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Equality Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if they are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator ==(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if two OracleBinary are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Explicit Type Conversion Operator

val
An OracleBinary object.
Converts an OracleBinary value to a byte array.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal val As OracleBinary _
) As Byte()
C#
public byte[] operator explicit(
   OracleBinary val
)

Parameters

val
An OracleBinary object.

Return Value

The byte array.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Greater Than Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator >(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Greater Than or Equal Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator >=(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Implicit Type Conversion Operator

bytes
A byte array.
Converts a byte array to an OracleBinary structure.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal bytes() As Byte _
) As OracleBinary
C#
public OracleBinary operator implicit(
   byte[] bytes
)

Parameters

bytes
A byte array.

Return Value

The OracleBinary object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Inequality Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if they are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator !=(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if two OracleBinary values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Less Than Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator <(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : Less Than or Equal Operator

value1
First OracleBinary.
value2
Second OracleBinary.
Compares two OracleBinary structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleBinary, _
   ByVal value2 As OracleBinary _
) As Boolean
C#
public bool operator <=(
   OracleBinary value1,
   OracleBinary value2
)

Parameters

value1
First OracleBinary.
value2
Second OracleBinary.

Return Value

true if the first of two OracleBinary values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

Represents the Oracle DATE data type.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleDate

Syntax

Visual Basic (Declaration)
Public Structure OracleDate
   Inherits System.ValueType
   Implements INullable, IComparable, ISerializable, IXmlSerializable
C#
public struct OracleDate : System.ValueType, INullable, IComparable, ISerializable, IXmlSerializable

Remarks

To obtain an OracleDate object call the OracleDataReader.GetOracleDate method of the OracleDataReader class.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleDate Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleDate Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

The following tables list the members exposed by OracleDate.

Public Constructors

 | Name | Description
public Constructor | OracleDate Constructor | Overloaded. Initializes a new instance of the OracleDate structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleDate structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleDate structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleDate structure.
Top

Public Properties

 | Name | Description
public Property | BinData | Gets an array of bytes that represents an Oracle DATE data type in Oracle internal format.
public Property | Day | Gets the value of the OracleDate structure as a day.
public Property | Hour | Gets the value of the OracleDate structure as an hour.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleDate is Null.
public Property | IsValidDateTime | Indicates whether this OracleDate can be correctly converted to System.DateTime and whether Value can be accessed without an exception.
public Property | Minute | Gets the value of the OracleDate structure as a minute.
public Property | Month | Gets the value of the OracleDate structure as a month.
public Property | Second | Gets the value of the OracleDate structure as a second.
public Property | Value | Gets the value of the OracleDate structure.
public Property | Year | Gets the value of the OracleDate structure as a year.
Top

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleDate object to the specified object and returns an integer that represents their relative values.
public Method | Equals | Overloaded. Compares two OracleDate structures to determine if they are equal.
public Method | GetDaysBetween | Calculates the number of days between the current OracleDate instance and the specified OracleDate structure.
public Method | GetHashCode | Gets a hash code for the OracleDate instance.
static (Shared in Visual Basic) | GetSysDate | Gets an OracleDate structure that represents the current date and time.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleDate values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleDate values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleDate values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleDate values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleDate values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts the specified System.String representation of a date and time to its OracleDate equivalent.
public Method | ToOracleTimeStamp | Converts the current OracleDate structure to an Oracle TIMESTAMP.
public Method | ToString | Overloaded. Converts the specified OracleDate structure to a System.String.
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleDate.
Top

Public Operators

public Operator Equality | Determines whether two OracleDate values are the same.
public Operator Explicit Type Conversion | Overloaded. Converts an OracleDate structure to a System.DateTime structure.
public Operator Greater Than | Compares two OracleDate structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleDate structures to determine if the first is greater than or equal to the second.
public Operator Inequality | Determines whether two OracleDate values are not equal.
public Operator Less Than | Compares two OracleDate structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleDate structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleDate Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : OracleDate Constructor

Initializes a new instance of the OracleDate structure.

Overload List

Overload | Description
OracleDate Constructor(DateTime) | Initializes a new instance of the OracleDate structure with the specified System.DateTime.
OracleDate Constructor(Int32,Int32,Int32) | Initializes a new instance of the OracleDate structure with the specified year, month, and day.
OracleDate Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Initializes a new instance of the OracleDate structure with the specified year, month, day, hour, minute, and second.
OracleDate Constructor(Byte[]) | Initializes a new instance of the OracleDate structure with the provided byte array, which is in the OCIDate format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Constructor(DateTime)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > OracleDate Constructor : OracleDate Constructor(DateTime)

dt
The specified System.DateTime.
Initializes a new instance of the OracleDate structure with the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dt As Date _
)
C#
public OracleDate(
   DateTime dt
)

Parameters

dt
The specified System.DateTime.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Constructor(Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > OracleDate Constructor : OracleDate Constructor(Int32,Int32,Int32)

year
The specified year.
month
The specified month.
day
The specified day.
Initializes a new instance of the OracleDate structure with the specified year, month, and day.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
)
C#
public OracleDate(
   int year,
   int month,
   int day
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > OracleDate Constructor : OracleDate Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
Initializes a new instance of the OracleDate structure with the specified year, month, day, hour, minute, and second.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer _
)
C#
public OracleDate(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleDate Constructor(Byte[])
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > OracleDate Constructor : OracleDate Constructor(Byte[])

bytes
The byte array, which should be in the OCIDate format.
Initializes a new instance of the OracleDate structure with the provided byte array, which is in the OCIDate format.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bytes() As Byte _
)
C#
public OracleDate(
   byte[] bytes
)

Parameters

bytes
The byte array, which should be in the OCIDate format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleDate Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

For a list of all members of this type, see OracleDate members.

Public Methods

 | Name | Description
public Method | CompareTo | Compares the current OracleDate object to the specified object and returns an integer that represents their relative values.
public Method | Equals | Overloaded. Compares two OracleDate structures to determine if they are equal.
public Method | GetDaysBetween | Calculates the number of days between the current OracleDate instance and the specified OracleDate structure.
public Method | GetHashCode | Gets a hash code for the OracleDate instance.
static (Shared in Visual Basic) | GetSysDate | Gets an OracleDate structure that represents the current date and time.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleDate values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleDate values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleDate values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleDate values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleDate values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts the specified System.String representation of a date and time to its OracleDate equivalent.
public Method | ToOracleTimeStamp | Converts the current OracleDate structure to an Oracle TIMESTAMP.
public Method | ToString | Overloaded. Converts the specified OracleDate structure to a System.String.
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleDate.
Top

See Also

Reference

OracleDate Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleDate object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleDate structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleDate object is less than the object.
Zero | The current OracleDate object is the same to the object.
Greater than zero | The current OracleDate object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Equals Method

Compares two OracleDate structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleDate object.
Equals(OracleDate,OracleDate) | Determines whether two OracleDate values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleDate object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleDate and has the same date and time; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleDate,OracleDate) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Equals Method : Equals(OracleDate,OracleDate) Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether two OracleDate values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool Equals(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if two OracleDate values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDaysBetween Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : GetDaysBetween Method

val
The specified OracleDate structure.
Calculates the number of days between the current OracleDate instance and the specified OracleDate structure.

Syntax

Visual Basic (Declaration)
Public Function GetDaysBetween( _
   ByVal val As OracleDate _
) As Integer
C#
public int GetDaysBetween(
   OracleDate val
)

Parameters

val
The specified OracleDate structure.

Return Value

The number of days between the current OracleDate instance and the specified OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : GetHashCode Method

Gets a hash code for the OracleDate instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSysDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : GetSysDate Method

Gets an OracleDate structure that represents the current date and time.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSysDate() As OracleDate
C#
public static OracleDate GetSysDate()

Return Value

An OracleDate structure that represents the current date and time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : GreaterThan Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether the first of two OracleDate values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool GreaterThan(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : GreaterThanOrEqual Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether the first of two OracleDate values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : LessThan Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether the first of two OracleDate values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool LessThan(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : LessThanOrEqual Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether the first of two OracleDate values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : NotEquals Method

value1
First OracleDate.
value2
Second OracleDate.
Determines whether two OracleDate values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public static bool NotEquals(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if two OracleDate values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Parse Method

Converts the specified System.String representation of a date and time to its OracleDate equivalent.

Overload List

Overload | Description
Parse(String) | Converts the specified System.String representation of a date and time to its OracleDate equivalent.
Parse(String,String) | Converts the specified System.String representation of a date and time to its OracleDate equivalent using the specified format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Parse Method : Parse(String) Method

value
The System.String to be parsed.
Converts the specified System.String representation of a date and time to its OracleDate equivalent.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String _
) As OracleDate
C#
public static OracleDate Parse(
   string value
)

Parameters

value
The System.String to be parsed.

Return Value

An OracleDate structure equal to the date and time represented by the specified System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Parse Method : Parse(String,String) Method

value
A System.String to be parsed.
format
A System.String containing Oracle date format to be parsed.
Converts the specified System.String representation of a date and time to its OracleDate equivalent using the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String, _
   ByVal format As String _
) As OracleDate
C#
public static OracleDate Parse(
   string value,
   string format
)

Parameters

value
A System.String to be parsed.
format
A System.String containing Oracle date format to be parsed.

Return Value

An OracleDate structure equal to the date and time represented by the specified System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToOracleTimeStamp Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : ToOracleTimeStamp Method

Converts the current OracleDate structure to an Oracle TIMESTAMP.

Syntax

Visual Basic (Declaration)
Public Function ToOracleTimeStamp() As OracleTimeStamp
C#
public OracleTimeStamp ToOracleTimeStamp()

Return Value

A OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : ToString Method

Converts the specified OracleDate structure to a System.String.

Overload List

Overload | Description
ToString() | Converts the specified OracleDate structure to a System.String.
ToString(String) | Converts the specified OracleDate structure to a System.String with the specified format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > ToString Method : ToString() Method

Converts the specified OracleDate structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String representing the Value property of the OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > ToString Method : ToString(String) Method

format
The date format to use.
Converts the specified OracleDate structure to a System.String with the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String _
) As String
C#
public string ToString(
   string format
)

Parameters

format
The date format to use.

Return Value

A System.String representing the Value property of the OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : TryParse Method

Converts the string representation of a date to OracleDate.

Overload List

Overload | Description
TryParse(String,OracleDate) | Converts the string representation of a date to OracleDate.
TryParse(String,String,OracleDate) | Converts the string representation of a date to OracleDate.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,OracleDate) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > TryParse Method : TryParse(String,OracleDate) Method

value
A string, containing a date to convert.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.
Converts the string representation of a date to OracleDate.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As OracleDate _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleDate result
)

Parameters

value
A string, containing a date to convert.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,String,OracleDate) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > TryParse Method : TryParse(String,String,OracleDate) Method

value
A string, containing a date to convert.
format
The date format to use for conversion.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.
Converts the string representation of a date to OracleDate.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByVal format As String, _
   ByRef result As OracleDate _
) As Boolean
C#
public static bool TryParse(
   string value,
   string format,
   out OracleDate result
)

Parameters

value
A string, containing a date to convert.
format
The date format to use for conversion.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleDate Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

For a list of all members of this type, see OracleDate members.

Public Properties

 | Name | Description
public Property | BinData | Gets an array of bytes that represents an Oracle DATE data type in Oracle internal format.
public Property | Day | Gets the value of the OracleDate structure as a day.
public Property | Hour | Gets the value of the OracleDate structure as an hour.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleDate is Null.
public Property | IsValidDateTime | Indicates whether this OracleDate can be correctly converted to System.DateTime and whether Value can be accessed without an exception.
public Property | Minute | Gets the value of the OracleDate structure as a minute.
public Property | Month | Gets the value of the OracleDate structure as a month.
public Property | Second | Gets the value of the OracleDate structure as a second.
public Property | Value | Gets the value of the OracleDate structure.
public Property | Year | Gets the value of the OracleDate structure as a year.
Top

See Also

Reference

OracleDate Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BinData Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : BinData Property

Gets an array of bytes that represents an Oracle DATE data type in Oracle internal format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BinData As Byte()
C#
public byte[] BinData {get;}

Property Value

An array of bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Day Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Day Property

Gets the value of the OracleDate structure as a day.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Day As Integer
C#
public int Day {get;}

Property Value

A number that represents the day value between 1 and 31.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Hour Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Hour Property

Gets the value of the OracleDate structure as an hour.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hour As Integer
C#
public int Hour {get;}

Property Value

A number that represents the hour value between 0 and 23.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : IsNull Property

Gets a value indicating whether the Value property of the OracleDate is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsValidDateTime Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : IsValidDateTime Property

Indicates whether this OracleDate can be correctly converted to System.DateTime and whether Value can be accessed without an exception.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValidDateTime As Boolean
C#
public bool IsValidDateTime {get;}

Property Value

true if this OracleDate can be correctly converted to System.DateTime and Value can be accessed without an exception; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Minute Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Minute Property

Gets the value of the OracleDate structure as a minute.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minute As Integer
C#
public int Minute {get;}

Property Value

A number that represents the minute value between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Month Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Month Property

Gets the value of the OracleDate structure as a month.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Month As Integer
C#
public int Month {get;}

Property Value

A number that represents the month value between 1 and 12.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Second Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Second Property

Gets the value of the OracleDate structure as a second.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Second As Integer
C#
public int Second {get;}

Property Value

A number that represents the second value between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Value Property

Gets the value of the OracleDate structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Date
C#
public DateTime Value {get;}

Property Value

The value of the OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
IsValidDateTime Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Year Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Year Property

Gets the value of the OracleDate structure as a year.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Year As Integer
C#
public int Year {get;}

Property Value

A number that represents the year value between -4712 and 9999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleDate Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

For a list of all members of this type, see OracleDate members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleDate structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleDate structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleDate structure.
Top

See Also

Reference

OracleDate Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : MaxValue Field

Represents the maximum valid date value for an OracleDate structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As OracleDate
C#
public static readonly OracleDate MaxValue

Remarks

The maximum valid date for an OracleDate structure is December 31, 9999 23:59:59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : MinValue Field

Represents the minimum valid date value for an OracleDate structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinValue As OracleDate
C#
public static readonly OracleDate MinValue

Remarks

The minimum valid date for an OracleDate structure is January 1, -4712.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Null Field

Represents a null value that can be assigned to the Value property of an OracleDate structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleDate
C#
public static readonly OracleDate Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleDate Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleDate Structure

The following tables list the members exposed by OracleDate.

Public Operators

public Operator Equality | Determines whether two OracleDate values are the same.
public Operator Explicit Type Conversion | Overloaded. Converts an OracleDate structure to a System.DateTime structure.
public Operator Greater Than | Compares two OracleDate structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleDate structures to determine if the first is greater than or equal to the second.
public Operator Inequality | Determines whether two OracleDate values are not equal.
public Operator Less Than | Compares two OracleDate structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleDate structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleDate Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Equality Operator

value1
First OracleDate.
value2
Second OracleDate.
Determines whether two OracleDate values are the same.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator ==(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if two OracleDate values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Explicit Type Conversion Operator

Converts an OracleDate structure to a System.DateTime structure.

Overload List

Overload | Description
Explicit Type Conversion(DateTime,OracleDate) | Converts an OracleDate structure to a System.DateTime structure.
Explicit Type Conversion(OracleDate,DateTime) | Converts a System.DateTime structure to an OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(DateTime,OracleDate) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Explicit Type Conversion Operator : Explicit Type Conversion(DateTime,OracleDate) Operator

val
An OracleDate structure.
Converts an OracleDate structure to a System.DateTime structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleDate _
) As Date
C#
public DateTime operator explicit(
   OracleDate val
)

Parameters

val
An OracleDate structure.

Return Value

A System.DateTime structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(OracleDate,DateTime) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure > Explicit Type Conversion Operator : Explicit Type Conversion(OracleDate,DateTime) Operator

dt
A System.DateTime structure.
Converts a System.DateTime structure to an OracleDate structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal dt As Date _
) As OracleDate
C#
public OracleDate operator explicit(
   DateTime dt
)

Parameters

dt
A System.DateTime structure.

Return Value

An OracleDate structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Greater Than Operator

value1
First OracleDate.
value2
Second OracleDate.
Compares two OracleDate structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator >(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Greater Than or Equal Operator

value1
First OracleDate.
value2
Second OracleDate.
Compares two OracleDate structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator >=(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Inequality Operator

value1
First OracleDate.
value2
Second OracleDate.
Determines whether two OracleDate values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator !=(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if two OracleDate values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Less Than Operator

value1
First OracleDate.
value2
Second OracleDate.
Compares two OracleDate structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator <(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDate Structure : Less Than or Equal Operator

value1
First OracleDate.
value2
Second OracleDate.
Compares two OracleDate structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleDate, _
   ByVal value2 As OracleDate _
) As Boolean
C#
public bool operator <=(
   OracleDate value1,
   OracleDate value2
)

Parameters

value1
First OracleDate.
value2
Second OracleDate.

Return Value

true if the first of two OracleDate values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDate Structure
OracleDate Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

Represents the Oracle INTERVAL DAY TO SECOND data type. Each object of the OracleIntervalDS class stores a period of time in term of days, hours, minutes, seconds, and fractional seconds.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleIntervalDS

Syntax

Visual Basic (Declaration)
Public Structure OracleIntervalDS
   Inherits System.ValueType
   Implements INullable, IComparable, ISerializable, IXmlSerializable
C#
public struct OracleIntervalDS : System.ValueType, INullable, IComparable, ISerializable, IXmlSerializable

Remarks

To obtain an OracleIntervalDS object call the OracleDataReader.GetOracleIntervalDS method of the OracleDataReader class.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleIntervalDS Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

The following tables list the members exposed by OracleIntervalDS.

Public Constructors

 | Name | Description
public Constructor | OracleIntervalDS Constructor | Overloaded. Initializes a new instance of the OracleIntervalDS structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleIntervalDS structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleIntervalDS structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleIntervalDS structure.
static (Shared in Visual Basic) | Zero | Represents a zero value for an OracleIntervalDS structure.
Top

Public Properties

 | Name | Description
public Property | Days | Gets the days component of the OracleIntervalDS.
public Property | Hours | Gets the hours component of the OracleIntervalDS.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleIntervalDS is Null.
public Property | Milliseconds | Gets the milliseconds component of the OracleIntervalDS.
public Property | Minutes | Gets the minutes component of the OracleIntervalDS.
public Property | Nanoseconds | Gets the nanoseconds component of the OracleIntervalDS.
public Property | Seconds | Gets the seconds component of the OracleIntervalDS.
public Property | TotalDays | Gets the total number, in days, that represent the time period in the OracleIntervalDS structure.
public Property | Value | Gets the value of the OracleIntervalDS structure.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two time intervals.
public Method | CompareTo | Compares the current OracleIntervalDS object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Divide | Divides an OracleIntervalDS value by a number.
public Method | Equals | Overloaded. Compares two OracleIntervalDS structures to determine if they are equal.
public Method | GetHashCode | Gets a hash code for the OracleIntervalDS instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleIntervalDS values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleIntervalDS values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleIntervalDS values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleIntervalDS values is less than or equal to the second.
static (Shared in Visual Basic) | Multiply | Multiplies an OracleIntervalDS value by a number.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleIntervalDS values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String representation of a date and time to its OracleIntervalDS equivalent.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleIntervalDS structure from another.
public Method | ToString | Converts the specified OracleIntervalDS structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.
Top

Public Operators

public Operator Addition | Adds two OracleIntervalDS values.
public Operator Division | Divides an OracleIntervalDS value by a number.
public Operator Equality | Determines whether two OracleIntervalDS values are the same.
public Operator Explicit Type Conversion | Converts an OracleIntervalDS structure to a System.TimeSpan structure.
public Operator Greater Than | Compares two OracleIntervalDS structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleIntervalDS structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts a System.TimeSpan structure to an OracleIntervalDS structure.
public Operator Inequality | Determines whether two OracleIntervalDS values are not equal.
public Operator Less Than | Compares two OracleIntervalDS structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleIntervalDS structures to determine if the first is less than or equal to the second.
public Operator Multiplication | Multiplies an OracleIntervalDS value by a number.
public Operator Subtraction | Subtracts one OracleIntervalDS structure from another.
public Operator Unary Negation | Changes sign of an OracleIntervalDS structure.
Top

See Also

Reference

OracleIntervalDS Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : OracleIntervalDS Constructor

Initializes a new instance of the OracleIntervalDS structure.

Overload List

Overload | Description
OracleIntervalDS Constructor(TimeSpan) | Initializes a new instance of the OracleIntervalDS structure with the specified System.TimeSpan.
OracleIntervalDS Constructor(Double) | Initializes a new instance of the OracleIntervalDS structure with the specified total number of days.
OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Double) | Initializes a new instance of the OracleIntervalDS structure with the specified days, hours, minutes, seconds, and milliseconds.
OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Int32) | Initializes a new instance of the OracleIntervalDS structure with the specified days, hours, minutes, seconds, and nanoseconds.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Constructor(TimeSpan)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > OracleIntervalDS Constructor : OracleIntervalDS Constructor(TimeSpan)

ts
The specified System.TimeSpan.
Initializes a new instance of the OracleIntervalDS structure with the specified System.TimeSpan.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ts As TimeSpan _
)
C#
public OracleIntervalDS(
   TimeSpan ts
)

Parameters

ts
The specified System.TimeSpan.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Constructor(Double)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > OracleIntervalDS Constructor : OracleIntervalDS Constructor(Double)

totalDays
The specified total number of days for a time interval.
Initializes a new instance of the OracleIntervalDS structure with the specified total number of days.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal totalDays As Double _
)
C#
public OracleIntervalDS(
   double totalDays
)

Parameters

totalDays
The specified total number of days for a time interval.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Double)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > OracleIntervalDS Constructor : OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Double)

days
Number of days.
hours
Number of hours.
minutes
Number of minutes.
seconds
Number of seconds.
milliSeconds
Number of milliseconds.
Initializes a new instance of the OracleIntervalDS structure with the specified days, hours, minutes, seconds, and milliseconds.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal days As Integer, _
   ByVal hours As Integer, _
   ByVal minutes As Integer, _
   ByVal seconds As Integer, _
   ByVal milliSeconds As Double _
)
C#
public OracleIntervalDS(
   int days,
   int hours,
   int minutes,
   int seconds,
   double milliSeconds
)

Parameters

days
Number of days.
hours
Number of hours.
minutes
Number of minutes.
seconds
Number of seconds.
milliSeconds
Number of milliseconds.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > OracleIntervalDS Constructor : OracleIntervalDS Constructor(Int32,Int32,Int32,Int32,Int32)

days
Number of days.
hours
Number of hours.
minutes
Number of minutes.
seconds
Number of seconds.
nanoSeconds
Number of nanoseconds.
Initializes a new instance of the OracleIntervalDS structure with the specified days, hours, minutes, seconds, and nanoseconds.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal days As Integer, _
   ByVal hours As Integer, _
   ByVal minutes As Integer, _
   ByVal seconds As Integer, _
   ByVal nanoSeconds As Integer _
)
C#
public OracleIntervalDS(
   int days,
   int hours,
   int minutes,
   int seconds,
   int nanoSeconds
)

Parameters

days
Number of days.
hours
Number of hours.
minutes
Number of minutes.
seconds
Number of seconds.
nanoSeconds
Number of nanoseconds.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

For a list of all members of this type, see OracleIntervalDS members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two time intervals.
public Method | CompareTo | Compares the current OracleIntervalDS object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Divide | Divides an OracleIntervalDS value by a number.
public Method | Equals | Overloaded. Compares two OracleIntervalDS structures to determine if they are equal.
public Method | GetHashCode | Gets a hash code for the OracleIntervalDS instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleIntervalDS values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleIntervalDS values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleIntervalDS values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleIntervalDS values is less than or equal to the second.
static (Shared in Visual Basic) | Multiply | Multiplies an OracleIntervalDS value by a number.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleIntervalDS values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String representation of a date and time to its OracleIntervalDS equivalent.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleIntervalDS structure from another.
public Method | ToString | Converts the specified OracleIntervalDS structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.
Top

See Also

Reference

OracleIntervalDS Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Add Method

Adds two time intervals.

Overload List

Overload | Description
Add(OracleIntervalDS,OracleIntervalDS) | Adds two OracleIntervalDS values.
Add(Int32,Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32,Int32,Int32,Boolean) | Adds two time intervals represented by their constituent parts.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleIntervalDS,OracleIntervalDS) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > Add Method : Add(OracleIntervalDS,OracleIntervalDS) Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Adds two OracleIntervalDS values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Add( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As OracleIntervalDS
C#
public static OracleIntervalDS Add(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(Int32,Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32,Int32,Int32,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > Add Method : Add(Int32,Int32,Int32,Int32,Int32,Boolean,Int32,Int32,Int32,Int32,Int32,Boolean) Method

day1
Number of days in the first interval.
hour1
Number of hours in the first interval.
minute1
Number of minutes in the first interval.
second1
Number of seconds in the first interval.
fsecond1
Fractional part of a second in the first interval.
isPositive1
true if the first time interval is a positive value; otherwise, false.
day2
Number of days in the second interval.
hour2
Number of hours in the second interval.
minute2
Number of minutes in the second interval.
second2
Number of seconds in the second interval.
fsecond2
Fractional part of a second in the second interval.
isPositive2
true if the second time interval is a positive value; otherwise, false.
Adds two time intervals represented by their constituent parts.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Add( _
   ByVal day1 As Integer, _
   ByVal hour1 As Integer, _
   ByVal minute1 As Integer, _
   ByVal second1 As Integer, _
   ByVal fsecond1 As Integer, _
   ByVal isPositive1 As Boolean, _
   ByVal day2 As Integer, _
   ByVal hour2 As Integer, _
   ByVal minute2 As Integer, _
   ByVal second2 As Integer, _
   ByVal fsecond2 As Integer, _
   ByVal isPositive2 As Boolean _
) As OracleIntervalDS
C#
public static OracleIntervalDS Add(
   int day1,
   int hour1,
   int minute1,
   int second1,
   int fsecond1,
   bool isPositive1,
   int day2,
   int hour2,
   int minute2,
   int second2,
   int fsecond2,
   bool isPositive2
)

Parameters

day1
Number of days in the first interval.
hour1
Number of hours in the first interval.
minute1
Number of minutes in the first interval.
second1
Number of seconds in the first interval.
fsecond1
Fractional part of a second in the first interval.
isPositive1
true if the first time interval is a positive value; otherwise, false.
day2
Number of days in the second interval.
hour2
Number of hours in the second interval.
minute2
Number of minutes in the second interval.
second2
Number of seconds in the second interval.
fsecond2
Fractional part of a second in the second interval.
isPositive2
true if the second time interval is a positive value; otherwise, false.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleIntervalDS object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleIntervalDS structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleIntervalDS object is less than the object.
Zero | The current OracleIntervalDS object is the same to the object.
Greater than zero | The current OracleIntervalDS object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Divide Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Divide Method

value
The specified OracleIntervalDS.
divisor
A divisor.
Divides an OracleIntervalDS value by a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Divide( _
   ByVal value As OracleIntervalDS, _
   ByVal divisor As OracleNumber _
) As OracleIntervalDS
C#
public static OracleIntervalDS Divide(
   OracleIntervalDS value,
   OracleNumber divisor
)

Parameters

value
The specified OracleIntervalDS.
divisor
A divisor.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Equals Method

Compares two OracleIntervalDS structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleIntervalDS object.
Equals(OracleIntervalDS,OracleIntervalDS) | Determines whether two OracleIntervalDS values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleIntervalDS object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleIntervalDS and has the same time interval; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleIntervalDS,OracleIntervalDS) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure > Equals Method : Equals(OracleIntervalDS,OracleIntervalDS) Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether two OracleIntervalDS values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool Equals(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if two OracleIntervalDS values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : GetHashCode Method

Gets a hash code for the OracleIntervalDS instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : GreaterThan Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether the first of two OracleIntervalDS values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool GreaterThan(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : GreaterThanOrEqual Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether the first of two OracleIntervalDS values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : LessThan Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether the first of two OracleIntervalDS values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool LessThan(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : LessThanOrEqual Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether the first of two OracleIntervalDS values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiply(OracleIntervalDS,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Multiply(OracleIntervalDS,OracleNumber) Method

value
The specified OracleIntervalDS.
multiplier
A multiplier.
Multiplies an OracleIntervalDS value by a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Multiply( _
   ByVal value As OracleIntervalDS, _
   ByVal multiplier As OracleNumber _
) As OracleIntervalDS
C#
public static OracleIntervalDS Multiply(
   OracleIntervalDS value,
   OracleNumber multiplier
)

Parameters

value
The specified OracleIntervalDS.
multiplier
A multiplier.

Return Value

A new OracleIntervalDS instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : NotEquals Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether two OracleIntervalDS values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public static bool NotEquals(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if two OracleIntervalDS values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Parse Method

value
The System.String to be parsed.
Converts the specified System.String representation of a date and time to its OracleIntervalDS equivalent.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal value As String _
) As OracleIntervalDS
C#
public static OracleIntervalDS Parse(
   string value
)

Parameters

value
The System.String to be parsed.

Return Value

An OracleIntervalDS structure equal to the date and time represented by the specified System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtract Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Subtract Method

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Subtracts one OracleIntervalDS structure from another.

Syntax

Visual Basic (Declaration)
Public Shared Function Subtract( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As OracleIntervalDS
C#
public static OracleIntervalDS Subtract(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : ToString Method

Converts the specified OracleIntervalDS structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String representing the Value property of the OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : TryParse Method

value
A string, containing an interval to convert.
result
If the conversion was successful, this parameter contains the result OracleIntervalDS value; otherwise Null value.
Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As OracleIntervalDS _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleIntervalDS result
)

Parameters

value
A string, containing an interval to convert.
result
If the conversion was successful, this parameter contains the result OracleIntervalDS value; otherwise Null value.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

For a list of all members of this type, see OracleIntervalDS members.

Public Properties

 | Name | Description
public Property | Days | Gets the days component of the OracleIntervalDS.
public Property | Hours | Gets the hours component of the OracleIntervalDS.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleIntervalDS is Null.
public Property | Milliseconds | Gets the milliseconds component of the OracleIntervalDS.
public Property | Minutes | Gets the minutes component of the OracleIntervalDS.
public Property | Nanoseconds | Gets the nanoseconds component of the OracleIntervalDS.
public Property | Seconds | Gets the seconds component of the OracleIntervalDS.
public Property | TotalDays | Gets the total number, in days, that represent the time period in the OracleIntervalDS structure.
public Property | Value | Gets the value of the OracleIntervalDS structure.
Top

See Also

Reference

OracleIntervalDS Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Days Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Days Property

Gets the days component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Days As Integer
C#
public int Days {get;}

Property Value

The day component of the OracleIntervalDS.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Hours Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Hours Property

Gets the hours component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hours As Integer
C#
public int Hours {get;}

Property Value

The hour component of the OracleIntervalDS, between 0 and 23.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : IsNull Property

Gets a value indicating whether the Value property of the OracleIntervalDS is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Milliseconds Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Milliseconds Property

Gets the milliseconds component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Milliseconds As Double
C#
public double Milliseconds {get;}

Property Value

The millisecond component of the OracleIntervalDS.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Minutes Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Minutes Property

Gets the minutes component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minutes As Integer
C#
public int Minutes {get;}

Property Value

The minute component of the OracleIntervalDS, between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Nanoseconds Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Nanoseconds Property

Gets the nanoseconds component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nanoseconds As Integer
C#
public int Nanoseconds {get;}

Property Value

The nanosecond component of the OracleIntervalDS.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Seconds Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Seconds Property

Gets the seconds component of the OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Seconds As Integer
C#
public int Seconds {get;}

Property Value

The second component of the OracleIntervalDS, between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TotalDays Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : TotalDays Property

Gets the total number, in days, that represent the time period in the OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalDays As Double
C#
public double TotalDays {get;}

Property Value

The total number of days.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Value Property

Gets the value of the OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As TimeSpan
C#
public TimeSpan Value {get;}

Property Value

The value of the OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

For a list of all members of this type, see OracleIntervalDS members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleIntervalDS structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleIntervalDS structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleIntervalDS structure.
static (Shared in Visual Basic) | Zero | Represents a zero value for an OracleIntervalDS structure.
Top

See Also

Reference

OracleIntervalDS Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : MaxValue Field

Represents the maximum valid date value for an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As OracleIntervalDS
C#
public static readonly OracleIntervalDS MaxValue

Remarks

The maximum Day value is 999999999, Hour is 23, Minute is 59, Second is 59, and Nanosecond is 999999999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : MinValue Field

Represents the minimum valid date value for an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinValue As OracleIntervalDS
C#
public static readonly OracleIntervalDS MinValue

Remarks

The minimum Day value is -999999999, Hour is -23, Minute is -59, Second is -59, and Nanosecond is -999999999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Null Field

Represents a null value that can be assigned to the Value property of an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleIntervalDS
C#
public static readonly OracleIntervalDS Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Zero Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Zero Field

Represents a zero value for an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As OracleIntervalDS
C#
public static readonly OracleIntervalDS Zero

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleIntervalDS Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalDS Structure

The following tables list the members exposed by OracleIntervalDS.

Public Operators

public Operator Addition | Adds two OracleIntervalDS values.
public Operator Division | Divides an OracleIntervalDS value by a number.
public Operator Equality | Determines whether two OracleIntervalDS values are the same.
public Operator Explicit Type Conversion | Converts an OracleIntervalDS structure to a System.TimeSpan structure.
public Operator Greater Than | Compares two OracleIntervalDS structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleIntervalDS structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts a System.TimeSpan structure to an OracleIntervalDS structure.
public Operator Inequality | Determines whether two OracleIntervalDS values are not equal.
public Operator Less Than | Compares two OracleIntervalDS structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleIntervalDS structures to determine if the first is less than or equal to the second.
public Operator Multiplication | Multiplies an OracleIntervalDS value by a number.
public Operator Subtraction | Subtracts one OracleIntervalDS structure from another.
public Operator Unary Negation | Changes sign of an OracleIntervalDS structure.
Top

See Also

Reference

OracleIntervalDS Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Addition Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Adds two OracleIntervalDS values.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As OracleIntervalDS
C#
public OracleIntervalDS operator +(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

An OracleIntervalDS.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Division Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Division Operator

value1
The specified OracleIntervalDS.
divisor
A divisor.
Divides an OracleIntervalDS value by a number.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal value1 As OracleIntervalDS, _
   ByVal divisor As Integer _
) As OracleIntervalDS
C#
public OracleIntervalDS operator /(
   OracleIntervalDS value1,
   int divisor
)

Parameters

value1
The specified OracleIntervalDS.
divisor
A divisor.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Equality Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether two OracleIntervalDS values are the same.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator ==(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if two OracleIntervalDS values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Explicit Type Conversion Operator

value
An OracleIntervalDS structure to convert to System.TimeSpan.
Converts an OracleIntervalDS structure to a System.TimeSpan structure.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal value As OracleIntervalDS _
) As TimeSpan
C#
public TimeSpan operator explicit(
   OracleIntervalDS value
)

Parameters

value
An OracleIntervalDS structure to convert to System.TimeSpan.

Return Value

A System.TimeSpan structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Greater Than Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Compares two OracleIntervalDS structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator >(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Greater Than or Equal Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Compares two OracleIntervalDS structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator >=(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Implicit Type Conversion Operator

value
A System.TimeSpan structure.
Converts a System.TimeSpan structure to an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As TimeSpan _
) As OracleIntervalDS
C#
public OracleIntervalDS operator implicit(
   TimeSpan value
)

Parameters

value
A System.TimeSpan structure.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Inequality Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Determines whether two OracleIntervalDS values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator !=(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if two OracleIntervalDS values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Less Than Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Compares two OracleIntervalDS structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator <(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Less Than or Equal Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Compares two OracleIntervalDS structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As Boolean
C#
public bool operator <=(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

true if the first of two OracleIntervalDS values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiplication Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Multiplication Operator

value1
The specified OracleIntervalDS.
multiplier
A multiplier.
Multiplies an OracleIntervalDS value by a number.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal value1 As OracleIntervalDS, _
   ByVal multiplier As Integer _
) As OracleIntervalDS
C#
public OracleIntervalDS operator *(
   OracleIntervalDS value1,
   int multiplier
)

Parameters

value1
The specified OracleIntervalDS.
multiplier
A multiplier.

Return Value

A new OracleIntervalDS instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Subtraction Operator

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.
Subtracts one OracleIntervalDS structure from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value1 As OracleIntervalDS, _
   ByVal value2 As OracleIntervalDS _
) As OracleIntervalDS
C#
public OracleIntervalDS operator -(
   OracleIntervalDS value1,
   OracleIntervalDS value2
)

Parameters

value1
First OracleIntervalDS.
value2
Second OracleIntervalDS.

Return Value

An OracleIntervalDS structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unary Negation Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Unary Negation Operator

value1
The specified OracleIntervalDS.
Changes sign of an OracleIntervalDS structure.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value1 As OracleIntervalDS _
) As OracleIntervalDS
C#
public OracleIntervalDS operator -(
   OracleIntervalDS value1
)

Parameters

value1
The specified OracleIntervalDS.

Return Value

An OracleIntervalDS structure.

Remarks

Unary Negation makes negative values from positive ones and vice versa.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

Represents the Oracle INTERVAL YEAR TO MONTH data type. Each object of the OracleIntervalYM class stores a period of time in years and months.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleIntervalYM

Syntax

Visual Basic (Declaration)
Public Structure OracleIntervalYM
   Inherits System.ValueType
   Implements INullable, IComparable, ISerializable, IXmlSerializable
C#
public struct OracleIntervalYM : System.ValueType, INullable, IComparable, ISerializable, IXmlSerializable

Remarks

To obtain an OracleIntervalYM object call the OracleDataReader.GetOracleIntervalYM method of the OracleDataReader class.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleIntervalYM Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

The following tables list the members exposed by OracleIntervalYM.

Public Constructors

 | Name | Description
public Constructor | OracleIntervalYM Constructor | Overloaded. Initializes a new instance of the OracleIntervalYM structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleIntervalYM structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleIntervalYM structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleIntervalYM structure.
static (Shared in Visual Basic) | Zero | Represents a zero value for an OracleIntervalYM structure.
Top

Public Properties

 | Name | Description
public Property | IsNull | Gets a value indicating whether the Value property of the OracleIntervalYM is Null.
public Property | Months | Gets the months component of the OracleIntervalYM.
public Property | TotalYears | Gets the total number, in years, that represents the period of time in the current OracleIntervalYM structure.
public Property | Value | Gets the value of the OracleIntervalYM structure.
public Property | Years | Gets the years component of the OracleIntervalYM.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two time intervals.
public Method | CompareTo | Compares the current OracleIntervalYM object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Divide | Divides an OracleIntervalYM value by a number.
public Method | Equals | Overloaded. Compares two OracleIntervalYM structures to determine if they are equal.
public Method | GetHashCode | Gets a hash code for the OracleIntervalYM instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleIntervalYM values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleIntervalYM values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleIntervalYM values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleIntervalYM values is less than or equal to the second.
static (Shared in Visual Basic) | Multiply | Multiplies an OracleIntervalYM value by a number.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleIntervalYM values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String representation of a date to its OracleIntervalYM equivalent.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleIntervalYM structure from another.
public Method | ToString | Converts the current OracleIntervalYM structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.
Top

Public Operators

public Operator Addition | Adds two OracleIntervalYM values.
public Operator Division | Divides an OracleIntervalYM value by a number.
public Operator Equality | Determines whether two OracleIntervalYM values are equal.
public Operator Greater Than | Compares two OracleIntervalYM structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleIntervalYM structures to determine if the first is greater than or equal to the second.
public Operator Inequality | Determines whether two OracleIntervalYM values are not equal.
public Operator Less Than | Compares two OracleIntervalYM structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleIntervalYM structures to determine if the first is less than or equal to the second.
public Operator Multiplication | Multiplies an OracleIntervalYM value by a number.
public Operator Subtraction | Subtracts one OracleIntervalYM structure from another.
public Operator Unary Negation | Changes sign of an OracleIntervalYM structure.
Top

See Also

Reference

OracleIntervalYM Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : OracleIntervalYM Constructor

Initializes a new instance of the OracleIntervalYM structure.

Overload List

Overload | Description
OracleIntervalYM Constructor(Int64) | Initializes a new instance of the OracleIntervalYM structure with the specified total number of months.
OracleIntervalYM Constructor(Double) | Initializes a new instance of the OracleIntervalYM structure with the specified total number of years.
OracleIntervalYM Constructor(Int32,Int32) | Initializes a new instance of the OracleIntervalYM structure with the specified number years and months.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Constructor(Int64)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > OracleIntervalYM Constructor : OracleIntervalYM Constructor(Int64)

totalMonths
Number of total months.
Initializes a new instance of the OracleIntervalYM structure with the specified total number of months.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal totalMonths As Long _
)
C#
public OracleIntervalYM(
   long totalMonths
)

Parameters

totalMonths
Number of total months.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Constructor(Double)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > OracleIntervalYM Constructor : OracleIntervalYM Constructor(Double)

totalYears
Number of total years.
Initializes a new instance of the OracleIntervalYM structure with the specified total number of years.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal totalYears As Double _
)
C#
public OracleIntervalYM(
   double totalYears
)

Parameters

totalYears
Number of total years.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Constructor(Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > OracleIntervalYM Constructor : OracleIntervalYM Constructor(Int32,Int32)

years
Number of years.
months
Number of months.
Initializes a new instance of the OracleIntervalYM structure with the specified number years and months.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal years As Integer, _
   ByVal months As Integer _
)
C#
public OracleIntervalYM(
   int years,
   int months
)

Parameters

years
Number of years.
months
Number of months.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

For a list of all members of this type, see OracleIntervalYM members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two time intervals.
public Method | CompareTo | Compares the current OracleIntervalYM object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Divide | Divides an OracleIntervalYM value by a number.
public Method | Equals | Overloaded. Compares two OracleIntervalYM structures to determine if they are equal.
public Method | GetHashCode | Gets a hash code for the OracleIntervalYM instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleIntervalYM values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleIntervalYM values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleIntervalYM values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleIntervalYM values is less than or equal to the second.
static (Shared in Visual Basic) | Multiply | Multiplies an OracleIntervalYM value by a number.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleIntervalYM values are not equal.
static (Shared in Visual Basic) | Parse | Converts the specified System.String representation of a date to its OracleIntervalYM equivalent.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleIntervalYM structure from another.
public Method | ToString | Converts the current OracleIntervalYM structure to a System.String.
static (Shared in Visual Basic) | TryParse | Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.
Top

See Also

Reference

OracleIntervalYM Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Add Method

Adds two time intervals.

Overload List

Overload | Description
Add(OracleIntervalYM,OracleIntervalYM) | Adds two OracleIntervalYM values.
Add(Int32,Int32,Boolean,Int32,Int32,Boolean) | Adds two time intervals represented by their constituent parts.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(OracleIntervalYM,OracleIntervalYM) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > Add Method : Add(OracleIntervalYM,OracleIntervalYM) Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Adds two OracleIntervalYM values.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Add( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As OracleIntervalYM
C#
public static OracleIntervalYM Add(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add(Int32,Int32,Boolean,Int32,Int32,Boolean) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > Add Method : Add(Int32,Int32,Boolean,Int32,Int32,Boolean) Method

year1
Number of years in the first interval.
month1
Number of months in the first interval.
isPositive1
true if the first time interval is a positive value; otherwise, false.
year2
Number of years in the second interval.
month2
Number of months in the second interval.
isPositive2
true if the second time interval is a positive value; otherwise, false.
Adds two time intervals represented by their constituent parts.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Add( _
   ByVal year1 As Integer, _
   ByVal month1 As Integer, _
   ByVal isPositive1 As Boolean, _
   ByVal year2 As Integer, _
   ByVal month2 As Integer, _
   ByVal isPositive2 As Boolean _
) As OracleIntervalYM
C#
public static OracleIntervalYM Add(
   int year1,
   int month1,
   bool isPositive1,
   int year2,
   int month2,
   bool isPositive2
)

Parameters

year1
Number of years in the first interval.
month1
Number of months in the first interval.
isPositive1
true if the first time interval is a positive value; otherwise, false.
year2
Number of years in the second interval.
month2
Number of months in the second interval.
isPositive2
true if the second time interval is a positive value; otherwise, false.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleIntervalYM object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleIntervalYM structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleIntervalYM object is less than the object.
Zero | The current OracleIntervalYM object is the same to the object.
Greater than zero | The current OracleIntervalYM object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Divide Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Divide Method

value
The specified OracleIntervalYM.
divisor
A divisor.
Divides an OracleIntervalYM value by a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Divide( _
   ByVal value As OracleIntervalYM, _
   ByVal divisor As OracleNumber _
) As OracleIntervalYM
C#
public static OracleIntervalYM Divide(
   OracleIntervalYM value,
   OracleNumber divisor
)

Parameters

value
The specified OracleIntervalYM.
divisor
A divisor.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Equals Method

Compares two OracleIntervalYM structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleIntervalYM object.
Equals(OracleIntervalYM,OracleIntervalYM) | Determines whether two OracleIntervalYM values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleIntervalYM object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleIntervalYM and has the same time interval; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleIntervalYM,OracleIntervalYM) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure > Equals Method : Equals(OracleIntervalYM,OracleIntervalYM) Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether two OracleIntervalYM values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool Equals(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if two OracleIntervalYM values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : GetHashCode Method

Gets a hash code for the OracleIntervalYM instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : GreaterThan Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether the first of two OracleIntervalYM values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool GreaterThan(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : GreaterThanOrEqual Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether the first of two OracleIntervalYM values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : LessThan Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether the first of two OracleIntervalYM values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool LessThan(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : LessThanOrEqual Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether the first of two OracleIntervalYM values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiply(OracleIntervalYM,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Multiply(OracleIntervalYM,OracleNumber) Method

value
The specified OracleIntervalYM.
multiplier
A multiplier.
Multiplies an OracleIntervalYM value by a number.

Syntax

Visual Basic (Declaration)
Public Shared Function Multiply( _
   ByVal value As OracleIntervalYM, _
   ByVal multiplier As OracleNumber _
) As OracleIntervalYM
C#
public static OracleIntervalYM Multiply(
   OracleIntervalYM value,
   OracleNumber multiplier
)

Parameters

value
The specified OracleIntervalYM.
multiplier
A multiplier.

Return Value

A new OracleIntervalYM instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : NotEquals Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether two OracleIntervalYM values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public static bool NotEquals(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if two OracleIntervalYM values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Parse Method

value
The System.String to be parsed.
Converts the specified System.String representation of a date to its OracleIntervalYM equivalent.

Syntax

Visual Basic (Declaration)
Public Shared Function Parse( _
   ByVal value As String _
) As OracleIntervalYM
C#
public static OracleIntervalYM Parse(
   string value
)

Parameters

value
The System.String to be parsed.

Return Value

An OracleIntervalYM structure equal to the date represented by the specified System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtract Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Subtract Method

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Subtracts one OracleIntervalYM structure from another.

Syntax

Visual Basic (Declaration)
Public Shared Function Subtract( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As OracleIntervalYM
C#
public static OracleIntervalYM Subtract(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : ToString Method

Converts the current OracleIntervalYM structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String representing the Value property of the OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : TryParse Method

value
A string, containing an interval to convert.
result
If the conversion was successful, this parameter contains the result OracleIntervalDS value; otherwise Null value.
Converts the string representation of an interval in days, hours, minits, seconds, and fractional seconds to OracleIntervalDS.

Syntax

Visual Basic (Declaration)
Public Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As OracleIntervalYM _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleIntervalYM result
)

Parameters

value
A string, containing an interval to convert.
result
If the conversion was successful, this parameter contains the result OracleIntervalDS value; otherwise Null value.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

For a list of all members of this type, see OracleIntervalYM members.

Public Properties

 | Name | Description
public Property | IsNull | Gets a value indicating whether the Value property of the OracleIntervalYM is Null.
public Property | Months | Gets the months component of the OracleIntervalYM.
public Property | TotalYears | Gets the total number, in years, that represents the period of time in the current OracleIntervalYM structure.
public Property | Value | Gets the value of the OracleIntervalYM structure.
public Property | Years | Gets the years component of the OracleIntervalYM.
Top

See Also

Reference

OracleIntervalYM Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : IsNull Property

Gets a value indicating whether the Value property of the OracleIntervalYM is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Months Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Months Property

Gets the months component of the OracleIntervalYM.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Months As Integer
C#
public int Months {get;}

Property Value

The months component of the OracleIntervalYM.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TotalYears Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : TotalYears Property

Gets the total number, in years, that represents the period of time in the current OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TotalYears As Double
C#
public double TotalYears {get;}

Property Value

The total number of years.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Value Property

Gets the value of the OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Long
C#
public long Value {get;}

Property Value

The value of the OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Years Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Years Property

Gets the years component of the OracleIntervalYM.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Years As Integer
C#
public int Years {get;}

Property Value

The years component of the OracleIntervalYM.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

For a list of all members of this type, see OracleIntervalYM members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date value for an OracleIntervalYM structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date value for an OracleIntervalYM structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to the Value property of an OracleIntervalYM structure.
static (Shared in Visual Basic) | Zero | Represents a zero value for an OracleIntervalYM structure.
Top

See Also

Reference

OracleIntervalYM Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : MaxValue Field

Represents the maximum valid date value for an OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As OracleIntervalYM
C#
public static readonly OracleIntervalYM MaxValue

Remarks

The maximum Year value is 999999999 and Month is 11.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : MinValue Field

Represents the minimum valid date value for an OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinValue As OracleIntervalYM
C#
public static readonly OracleIntervalYM MinValue

Remarks

The minimum Year value is -999999999 and Month is -11.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Null Field

Represents a null value that can be assigned to the Value property of an OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleIntervalYM
C#
public static readonly OracleIntervalYM Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Zero Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Zero Field

Represents a zero value for an OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As OracleIntervalYM
C#
public static readonly OracleIntervalYM Zero

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleIntervalYM Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleIntervalYM Structure

The following tables list the members exposed by OracleIntervalYM.

Public Operators

public Operator Addition | Adds two OracleIntervalYM values.
public Operator Division | Divides an OracleIntervalYM value by a number.
public Operator Equality | Determines whether two OracleIntervalYM values are equal.
public Operator Greater Than | Compares two OracleIntervalYM structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleIntervalYM structures to determine if the first is greater than or equal to the second.
public Operator Inequality | Determines whether two OracleIntervalYM values are not equal.
public Operator Less Than | Compares two OracleIntervalYM structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleIntervalYM structures to determine if the first is less than or equal to the second.
public Operator Multiplication | Multiplies an OracleIntervalYM value by a number.
public Operator Subtraction | Subtracts one OracleIntervalYM structure from another.
public Operator Unary Negation | Changes sign of an OracleIntervalYM structure.
Top

See Also

Reference

OracleIntervalYM Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Addition Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Adds two OracleIntervalYM values.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As OracleIntervalYM
C#
public OracleIntervalYM operator +(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Division Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Division Operator

value1
The specified OracleIntervalYM.
divisor
A divisor.
Divides an OracleIntervalYM value by a number.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal value1 As OracleIntervalYM, _
   ByVal divisor As Integer _
) As OracleIntervalYM
C#
public OracleIntervalYM operator /(
   OracleIntervalYM value1,
   int divisor
)

Parameters

value1
The specified OracleIntervalYM.
divisor
A divisor.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Equality Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether two OracleIntervalYM values are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator ==(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if two OracleIntervalYM values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Greater Than Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Compares two OracleIntervalYM structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator >(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Greater Than or Equal Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Compares two OracleIntervalYM structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator >=(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Inequality Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Determines whether two OracleIntervalYM values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator !=(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if two OracleIntervalYM values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Less Than Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Compares two OracleIntervalYM structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator <(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Less Than or Equal Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Compares two OracleIntervalYM structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As Boolean
C#
public bool operator <=(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

true if the first of two OracleIntervalYM values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiplication Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Multiplication Operator

value1
The specified OracleIntervalYM.
multiplier
A multiplier.
Multiplies an OracleIntervalYM value by a number.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal value1 As OracleIntervalYM, _
   ByVal multiplier As Integer _
) As OracleIntervalYM
C#
public OracleIntervalYM operator *(
   OracleIntervalYM value1,
   int multiplier
)

Parameters

value1
The specified OracleIntervalYM.
multiplier
A multiplier.

Return Value

A new OracleIntervalYM instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Subtraction Operator

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.
Subtracts one OracleIntervalYM structure from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value1 As OracleIntervalYM, _
   ByVal value2 As OracleIntervalYM _
) As OracleIntervalYM
C#
public OracleIntervalYM operator -(
   OracleIntervalYM value1,
   OracleIntervalYM value2
)

Parameters

value1
First OracleIntervalYM.
value2
Second OracleIntervalYM.

Return Value

An OracleIntervalYM structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unary Negation Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Unary Negation Operator

value1
The specified OracleIntervalYM.
Changes sign of an OracleIntervalYM structure.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value1 As OracleIntervalYM _
) As OracleIntervalYM
C#
public OracleIntervalYM operator -(
   OracleIntervalYM value1
)

Parameters

value1
The specified OracleIntervalYM.

Return Value

An OracleIntervalYM structure.

Remarks

Unary Negation makes negative values from positive ones and vice versa.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

Represents the Oracle NUMBER or any numeric type.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleNumber

Syntax

Visual Basic (Declaration)
Public Structure OracleNumber
   Inherits System.ValueType
   Implements INullable, IComparable, IConvertible, IFormattable, ISerializable, IXmlSerializable
C#
public struct OracleNumber : System.ValueType, INullable, IComparable, IConvertible, IFormattable, ISerializable, IXmlSerializable

Remarks

To obtain an OracleNumber object call the OracleDataReader.GetOracleNumber method of the OracleDataReader class.

When in Devart.Data.Oracle.OracleConnection.Direct mode, some members of OracleNumber are not available.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleNumber Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleNumber Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

The following tables list the members exposed by OracleNumber.

Public Constructors

 | Name | Description
public Constructor | OracleNumber Constructor | Overloaded. Initializes a new instance of the OracleNumber structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxPrecision | Represents the maximum precision, which is 38.
static (Shared in Visual Basic) | MaxScale | Represents the maximum scale, which is 127.
static (Shared in Visual Basic) | MaxValue | Represents the maximum value of an OracleNumber structure.
static (Shared in Visual Basic) | MinScale | Represents the minimum scale, which is -84.
static (Shared in Visual Basic) | MinValue | Represents the minimum value of an OracleNumber structure.
static (Shared in Visual Basic) | NegativeOne | Represents the negative one value.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleNumber object.
static (Shared in Visual Basic) | One | Represents the positive one value.
static (Shared in Visual Basic) | Pi | Represents the numeric Pi value.
static (Shared in Visual Basic) | Zero | Represents the zero value.
Top

Public Properties

 | Name | Description
public Property | BinData | Gets OracleNumber value as binary data.
public Property | IsInt | Indicates whether the current instance of OracleNumber is an integer number.
public Property | IsNull | Indicates whether the Value property of the OracleNumber is Null.
public Property | IsPositive | Indicates whether the current instance of OracleNumber is greater than zero.
public Property | IsZero | Indicates whether the current instance of OracleNumber is zero.
public Property | Value | Gets the value of the OracleNumber structure.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Abs | Gets the absolute value of the OracleNumber.
static (Shared in Visual Basic) | Acos | Calculates an angle in radian whose cosine is the specified OracleNumber structure.
static (Shared in Visual Basic) | Add | Adds two OracleNumber values.
static (Shared in Visual Basic) | Asin | Calculates an angle in radian whose sine is the specified OracleNumber structure.
static (Shared in Visual Basic) | Atan | Calculates an angle in radian whose tangent is the specified OracleNumber structure.
static (Shared in Visual Basic) | Atan2 | Calculates an angle in radian whose tangent is the quotient of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Ceiling | Returns the smallest integer number greater than or equal to the specified OracleNumber number.
public Method | CompareTo | Compares the current OracleNumber object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Cos | Calculates the cosine of the specified angle in radian.
static (Shared in Visual Basic) | Cosh | Calculates the hyperbolic cosine of the specified angle in radian.
static (Shared in Visual Basic) | Divide | Divides one OracleNumber value by another.
public Method | Equals | Overloaded. Compares two OracleNumber structures to determine if they are equal.
static (Shared in Visual Basic) | Exp | Calculates a new OracleNumber with its value set to e raised to the specified OracleNumber.
static (Shared in Visual Basic) | Floor | Returns the largest integer number less than or equal to the specified OracleNumber number.
public Method | GetHashCode | Gets a hash code for the OracleNumber instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleNumber values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleNumber values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleNumber values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleNumber values is less than or equal to the second.
static (Shared in Visual Basic) | Log | Overloaded. Performs a logarithmic calculation on an OracleNumber.
static (Shared in Visual Basic) | Log10 | Calculates a new OracleNumber with its value set to base 10 logarithm of the specified OracleNumber.
static (Shared in Visual Basic) | Max | Gets the maximum value of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Min | Gets the minimum value of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Modulo | Calculates the modulus from the results of dividing the first OracleNumber by the second.
static (Shared in Visual Basic) | Multiply | Multiplies two OracleNumber structures.
static (Shared in Visual Basic) | Negate | Negates the value of the specified OracleNumber.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleNumber values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts a System.String representation of a number to its OracleNumber equivalent.
static (Shared in Visual Basic) | Pow | Overloaded. Returns a specified OracleNumber raised to the specified power.
static (Shared in Visual Basic) | Round | Rounds the specified OracleNumber off to the specified precision.
static (Shared in Visual Basic) | Shift | Shifts the OracleNumber value to the specified number of digits to the right.
static (Shared in Visual Basic) | Sign | Gets the sign of the OracleNumber structure.
static (Shared in Visual Basic) | Sin | Calculates the sine of the specified angle in radian.
static (Shared in Visual Basic) | Sinh | Calculates the hyperbolic sine of the specified angle in radian.
static (Shared in Visual Basic) | Sqrt | Calculates the square root of the OracleNumber parameter.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleNumber structure from another.
static (Shared in Visual Basic) | Tan | Calculates the tangent of the specified angle in radian.
static (Shared in Visual Basic) | Tanh | Calculates the hyperbolic tangent of the specified angle in radian.
static (Shared in Visual Basic) | ToDecimal | Converts the OracleNumber parameter to System.Decimal.
static (Shared in Visual Basic) | ToDouble | Converts the OracleNumber parameter to System.Double.
static (Shared in Visual Basic) | ToFloat | Converts the OracleNumber parameter to System.Float.
static (Shared in Visual Basic) | ToInt32 | Converts the OracleNumber parameter to System.Int32.
static (Shared in Visual Basic) | ToInt64 | Converts the OracleNumber parameter to System.Int64.
public Method | ToString | Overloaded. Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.
static (Shared in Visual Basic) | Truncate | Truncates the OracleNumber at a specified position.
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleNumber.
Top

Public Operators

public Operator Addition | Calculates the sum of the two OracleNumber structures.
public Operator Division | Divides one OracleNumber value by another.
public Operator Equality | Determines whether two OracleNumber values are equal.
public Operator Explicit Type Conversion | Overloaded. Converts the System.Double parameter to the OracleNumber.
public Operator Greater Than | Compares two OracleNumber structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleNumber structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Overloaded. Converts the System.Decimal parameter to the OracleNumber.
public Operator Inequality | Determines whether two OracleNumber values are not equal.
public Operator Less Than | Compares two OracleNumber structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleNumber structures to determine if the first is less than or equal to the second.
public Operator Modulus | Divides the value of the first OracleNumber by the value of the second, and returns the remainder.
public Operator Multiplication | Multiplies two OracleNumber structures.
public Operator Subtraction | Subtracts one OracleNumber structure from another.
public Operator Unary Negation | Negates the passed OracleNumber structure.
Top

See Also

Reference

OracleNumber Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : OracleNumber Constructor

Initializes a new instance of the OracleNumber structure.

Overload List

Overload | Description
OracleNumber Constructor(Decimal) | Initializes a new instance of the OracleNumber structure with the specified System.Decimal value.
OracleNumber Constructor(Double) | Initializes a new instance of the OracleNumber structure with the specified System.Double value.
OracleNumber Constructor(Single) | Initializes a new instance of the OracleNumber structure with the specified System.Single value.
OracleNumber Constructor(Int32) | Initializes a new instance of the OracleNumber structure with the specified System.Int32 value.
OracleNumber Constructor(Int64) | Initializes a new instance of the OracleNumber structure with the specified System.Int64 value.
OracleNumber Constructor(Byte[]) | Initializes a new instance of the OracleNumber structure with the specified System.byte[] value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Decimal)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Decimal)

value
The System.Decimal value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.Decimal value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Decimal _
)
C#
public OracleNumber(
   decimal value
)

Parameters

value
The System.Decimal value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Double)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Double)

value
The System.Double value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.Double value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Double _
)
C#
public OracleNumber(
   double value
)

Parameters

value
The System.Double value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Single)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Single)

value
The System.Single value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.Single value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Single _
)
C#
public OracleNumber(
   float value
)

Parameters

value
The System.Single value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Int32)

value
The System.Int32 value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.Int32 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Integer _
)
C#
public OracleNumber(
   int value
)

Parameters

value
The System.Int32 value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Int64)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Int64)

value
The System.Int64 value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.Int64 value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Long _
)
C#
public OracleNumber(
   long value
)

Parameters

value
The System.Int64 value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleNumber Constructor(Byte[])
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > OracleNumber Constructor : OracleNumber Constructor(Byte[])

value
The System.byte[] value to be stored as an OracleNumber.
Initializes a new instance of the OracleNumber structure with the specified System.byte[] value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value() As Byte _
)
C#
public OracleNumber(
   byte[] value
)

Parameters

value
The System.byte[] value to be stored as an OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleNumber Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

For a list of all members of this type, see OracleNumber members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Abs | Gets the absolute value of the OracleNumber.
static (Shared in Visual Basic) | Acos | Calculates an angle in radian whose cosine is the specified OracleNumber structure.
static (Shared in Visual Basic) | Add | Adds two OracleNumber values.
static (Shared in Visual Basic) | Asin | Calculates an angle in radian whose sine is the specified OracleNumber structure.
static (Shared in Visual Basic) | Atan | Calculates an angle in radian whose tangent is the specified OracleNumber structure.
static (Shared in Visual Basic) | Atan2 | Calculates an angle in radian whose tangent is the quotient of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Ceiling | Returns the smallest integer number greater than or equal to the specified OracleNumber number.
public Method | CompareTo | Compares the current OracleNumber object to the specified object and returns an integer that represents their relative values.
static (Shared in Visual Basic) | Cos | Calculates the cosine of the specified angle in radian.
static (Shared in Visual Basic) | Cosh | Calculates the hyperbolic cosine of the specified angle in radian.
static (Shared in Visual Basic) | Divide | Divides one OracleNumber value by another.
public Method | Equals | Overloaded. Compares two OracleNumber structures to determine if they are equal.
static (Shared in Visual Basic) | Exp | Calculates a new OracleNumber with its value set to e raised to the specified OracleNumber.
static (Shared in Visual Basic) | Floor | Returns the largest integer number less than or equal to the specified OracleNumber number.
public Method | GetHashCode | Gets a hash code for the OracleNumber instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleNumber values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleNumber values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleNumber values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleNumber values is less than or equal to the second.
static (Shared in Visual Basic) | Log | Overloaded. Performs a logarithmic calculation on an OracleNumber.
static (Shared in Visual Basic) | Log10 | Calculates a new OracleNumber with its value set to base 10 logarithm of the specified OracleNumber.
static (Shared in Visual Basic) | Max | Gets the maximum value of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Min | Gets the minimum value of the two specified OracleNumber structures.
static (Shared in Visual Basic) | Modulo | Calculates the modulus from the results of dividing the first OracleNumber by the second.
static (Shared in Visual Basic) | Multiply | Multiplies two OracleNumber structures.
static (Shared in Visual Basic) | Negate | Negates the value of the specified OracleNumber.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleNumber values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts a System.String representation of a number to its OracleNumber equivalent.
static (Shared in Visual Basic) | Pow | Overloaded. Returns a specified OracleNumber raised to the specified power.
static (Shared in Visual Basic) | Round | Rounds the specified OracleNumber off to the specified precision.
static (Shared in Visual Basic) | Shift | Shifts the OracleNumber value to the specified number of digits to the right.
static (Shared in Visual Basic) | Sign | Gets the sign of the OracleNumber structure.
static (Shared in Visual Basic) | Sin | Calculates the sine of the specified angle in radian.
static (Shared in Visual Basic) | Sinh | Calculates the hyperbolic sine of the specified angle in radian.
static (Shared in Visual Basic) | Sqrt | Calculates the square root of the OracleNumber parameter.
static (Shared in Visual Basic) | Subtract | Subtracts one OracleNumber structure from another.
static (Shared in Visual Basic) | Tan | Calculates the tangent of the specified angle in radian.
static (Shared in Visual Basic) | Tanh | Calculates the hyperbolic tangent of the specified angle in radian.
static (Shared in Visual Basic) | ToDecimal | Converts the OracleNumber parameter to System.Decimal.
static (Shared in Visual Basic) | ToDouble | Converts the OracleNumber parameter to System.Double.
static (Shared in Visual Basic) | ToFloat | Converts the OracleNumber parameter to System.Float.
static (Shared in Visual Basic) | ToInt32 | Converts the OracleNumber parameter to System.Int32.
static (Shared in Visual Basic) | ToInt64 | Converts the OracleNumber parameter to System.Int64.
public Method | ToString | Overloaded. Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.
static (Shared in Visual Basic) | Truncate | Truncates the OracleNumber at a specified position.
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleNumber.
Top

See Also

Reference

OracleNumber Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Abs Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Abs Method

value
An OracleNumber structure.
Gets the absolute value of the OracleNumber.

Syntax

Visual Basic (Declaration)
Public Shared Function Abs( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Abs(
   OracleNumber value
)

Parameters

value
An OracleNumber structure.

Return Value

An OracleNumber structure whose Value property contains the unsigned number representing the absolute value of the OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Acos Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Acos Method

value
An OracleNumber structure.
Calculates an angle in radian whose cosine is the specified OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared Function Acos( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Acos(
   OracleNumber value
)

Parameters

value
An OracleNumber structure.

Return Value

An OracleNumber structure that represents an angle in radian.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Add Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Add Method

value1
First OracleNumber.
value2
Second OracleNumber.
Adds two OracleNumber values.

Syntax

Visual Basic (Declaration)
Public Shared Function Add( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Add(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Asin Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Asin Method

value
An OracleNumber structure.
Calculates an angle in radian whose sine is the specified OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared Function Asin( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Asin(
   OracleNumber value
)

Parameters

value
An OracleNumber structure.

Return Value

An OracleNumber structure that represents an angle in radian.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Atan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Atan Method

value
An OracleNumber structure.
Calculates an angle in radian whose tangent is the specified OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared Function Atan( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Atan(
   OracleNumber value
)

Parameters

value
An OracleNumber structure.

Return Value

An OracleNumber structure that represents an angle in radian.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Atan2 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Atan2 Method

value1
An OracleNumber structure that represents the y-coordinate.
value2
An OracleNumber structure that represents the x-coordinate.
Calculates an angle in radian whose tangent is the quotient of the two specified OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Atan2( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Atan2(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
An OracleNumber structure that represents the y-coordinate.
value2
An OracleNumber structure that represents the x-coordinate.

Return Value

An OracleNumber structure that represents an angle in radian.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Ceiling Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Ceiling Method

value
The specified OracleNumber structure.
Returns the smallest integer number greater than or equal to the specified OracleNumber number.

Syntax

Visual Basic (Declaration)
Public Shared Function Ceiling( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Ceiling(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber representing the smallest integer number greater than or equal to the specified OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleNumber object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleNumber structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleNumber object is less than the object.
Zero | The current OracleNumber object is the same to the object.
Greater than zero | The current OracleNumber object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cos Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Cos Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the cosine of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Cos( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Cos(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Cosh Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Cosh Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the hyperbolic cosine of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Cosh( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Cosh(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Divide Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Divide Method

value1
First OracleNumber.
value2
Second OracleNumber.
Divides one OracleNumber value by another.

Syntax

Visual Basic (Declaration)
Public Shared Function Divide( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Divide(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Equals Method

Compares two OracleNumber structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleNumber object.
Equals(OracleNumber,OracleNumber) | Determines whether two OracleNumber values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleNumber object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleNumber and has the same value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleNumber,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Equals Method : Equals(OracleNumber,OracleNumber) Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether two OracleNumber values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool Equals(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if two OracleNumber values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Exp Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Exp Method

value
The specified OracleNumber structure.
Calculates a new OracleNumber with its value set to e raised to the specified OracleNumber.

Syntax

Visual Basic (Declaration)
Public Shared Function Exp( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Exp(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Floor Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Floor Method

value
The specified OracleNumber structure.
Returns the largest integer number less than or equal to the specified OracleNumber number.

Syntax

Visual Basic (Declaration)
Public Shared Function Floor( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Floor(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber representing the largest integer number less than or equal to the specified OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : GetHashCode Method

Gets a hash code for the OracleNumber instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : GreaterThan Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether the first of two OracleNumber values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool GreaterThan(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : GreaterThanOrEqual Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether the first of two OracleNumber values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : LessThan Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether the first of two OracleNumber values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool LessThan(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : LessThanOrEqual Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether the first of two OracleNumber values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Log Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Log Method

Performs a logarithmic calculation on an OracleNumber.

Overload List

Overload | Description
Log(OracleNumber) | Calculates a new OracleNumber with its value set to the natural logarithm (base e) of the specified OracleNumber.
Log(OracleNumber,Int32) | Calculates a new OracleNumber with its value set to the logarithm of the OracleNumber in the specified base.
Log(OracleNumber,OracleNumber) | Calculates the OracleNumber with its value set to the logarithm of the specified OracleNumber structure in the supplied base.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Log(OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Log Method : Log(OracleNumber) Method

value
The specified OracleNumber structure.
Calculates a new OracleNumber with its value set to the natural logarithm (base e) of the specified OracleNumber.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Log( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Log(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber structure with its value set to the natural logarithm.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Log(OracleNumber,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Log Method : Log(OracleNumber,Int32) Method

value
The specified OracleNumber structure.
logBase
The specified base of the logarithm.
Calculates a new OracleNumber with its value set to the logarithm of the OracleNumber in the specified base.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Log( _
   ByVal value As OracleNumber, _
   ByVal logBase As Integer _
) As OracleNumber
C#
public static OracleNumber Log(
   OracleNumber value,
   int logBase
)

Parameters

value
The specified OracleNumber structure.
logBase
The specified base of the logarithm.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Log(OracleNumber,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Log Method : Log(OracleNumber,OracleNumber) Method

value
An OracleNumber structure whose logarithm is to be calculated.
logBase
An OracleNumber structure that specifies the base of the logarithm.
Calculates the OracleNumber with its value set to the logarithm of the specified OracleNumber structure in the supplied base.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Log( _
   ByVal value As OracleNumber, _
   ByVal logBase As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Log(
   OracleNumber value,
   OracleNumber logBase
)

Parameters

value
An OracleNumber structure whose logarithm is to be calculated.
logBase
An OracleNumber structure that specifies the base of the logarithm.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Log10 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Log10 Method

value
The specified OracleNumber structure.
Calculates a new OracleNumber with its value set to base 10 logarithm of the specified OracleNumber.

Syntax

Visual Basic (Declaration)
Public Shared Function Log10( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Log10(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber structure with its value set to base 10 logarithm.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Max Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Max Method

value1
First OracleNumber.
value2
Second OracleNumber.
Gets the maximum value of the two specified OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Max( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Max(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

An OracleNumber structure that has the greater value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Min Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Min Method

value1
First OracleNumber.
value2
Second OracleNumber.
Gets the minimum value of the two specified OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Min( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Min(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

An OracleNumber structure that has the smaller value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Modulo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Modulo Method

value1
First OracleNumber.
value2
Second OracleNumber.
Calculates the modulus from the results of dividing the first OracleNumber by the second.

Syntax

Visual Basic (Declaration)
Public Shared Function Modulo( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Modulo(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiply Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Multiply Method

value1
First OracleNumber.
value2
Second OracleNumber.
Multiplies two OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Multiply( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Multiply(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Negate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Negate Method

value
The specified OracleNumber structure.
Negates the value of the specified OracleNumber.

Syntax

Visual Basic (Declaration)
Public Shared Function Negate( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Negate(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : NotEquals Method

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether two OracleNumber values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public static bool NotEquals(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if two OracleNumber values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Parse Method

Converts a System.String representation of a number to its OracleNumber equivalent.

Overload List

Overload | Description
Parse(String) | Converts a System.String representation of a number to its OracleNumber equivalent.
Parse(String,String) | Converts a System.String representation of a number to its OracleNumber equivalent using the specified format.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Parse Method : Parse(String) Method

value
The System.String to be parsed.
Converts a System.String representation of a number to its OracleNumber equivalent.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String _
) As OracleNumber
C#
public static OracleNumber Parse(
   string value
)

Parameters

value
The System.String to be parsed.

Return Value

A new OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String,String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Parse Method : Parse(String,String) Method

value
The System.String to be parsed.
format
The format to use.
Converts a System.String representation of a number to its OracleNumber equivalent using the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String, _
   ByVal format As String _
) As OracleNumber
C#
public static OracleNumber Parse(
   string value,
   string format
)

Parameters

value
The System.String to be parsed.
format
The format to use.

Return Value

A new OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pow Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Pow Method

Returns a specified OracleNumber raised to the specified power.

Overload List

Overload | Description
Pow(OracleNumber,Int32) | Calculates a new OracleNumber structure with its value set to the specified OracleNumber structure raised to the specified power.
Pow(OracleNumber,OracleNumber) | Calculates a new OracleNumber structure with its value set to the specified OracleNumber structure raised to the specified OracleNumber power.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pow(OracleNumber,Int32) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Pow Method : Pow(OracleNumber,Int32) Method

value
The specified OracleNumber structure.
power
A value that specifies the power.
Calculates a new OracleNumber structure with its value set to the specified OracleNumber structure raised to the specified power.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Pow( _
   ByVal value As OracleNumber, _
   ByVal power As Integer _
) As OracleNumber
C#
public static OracleNumber Pow(
   OracleNumber value,
   int power
)

Parameters

value
The specified OracleNumber structure.
power
A value that specifies the power.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pow(OracleNumber,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Pow Method : Pow(OracleNumber,OracleNumber) Method

value
The specified OracleNumber structure.
power
The OracleNumber structure that specifies the power.
Calculates a new OracleNumber structure with its value set to the specified OracleNumber structure raised to the specified OracleNumber power.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Pow( _
   ByVal value As OracleNumber, _
   ByVal power As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Pow(
   OracleNumber value,
   OracleNumber power
)

Parameters

value
The specified OracleNumber structure.
power
The OracleNumber structure that specifies the power.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Round Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Round Method

value
The specified OracleNumber structure.
position
The number of significant fractional digits (precision) in the return value.
Rounds the specified OracleNumber off to the specified precision.

Syntax

Visual Basic (Declaration)
Public Shared Function Round( _
   ByVal value As OracleNumber, _
   ByVal position As Integer _
) As OracleNumber
C#
public static OracleNumber Round(
   OracleNumber value,
   int position
)

Parameters

value
The specified OracleNumber structure.
position
The number of significant fractional digits (precision) in the return value.

Return Value

An OracleNumber structure containing the results of the rounding operation.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Shift Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Shift Method

value
The specified OracleNumber structure.
digits
The specified number of places to be shifted.
Shifts the OracleNumber value to the specified number of digits to the right.

Syntax

Visual Basic (Declaration)
Public Shared Function Shift( _
   ByVal value As OracleNumber, _
   ByVal digits As Integer _
) As OracleNumber
C#
public static OracleNumber Shift(
   OracleNumber value,
   int digits
)

Parameters

value
The specified OracleNumber structure.
digits
The specified number of places to be shifted.

Return Value

A new OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sign Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Sign Method

value
The specified OracleNumber structure.
Gets the sign of the OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared Function Sign( _
   ByVal value As OracleNumber _
) As Integer
C#
public static int Sign(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A number indicating the sign of the OracleNumber structure.

Remarks

Return Value | Condition
-1 | If the specified OracleNumber is less than 0.
0 | If the specified OracleNumber is equal to 0.
1 | If the specified OracleNumber is greater than 0.
This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sin Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Sin Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the sine of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Sin( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Sin(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sinh Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Sinh Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the hyperbolic sine of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Sinh( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Sinh(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Sqrt Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Sqrt Method

value
The specified OracleNumber structure.
Calculates the square root of the OracleNumber parameter.

Syntax

Visual Basic (Declaration)
Public Shared Function Sqrt( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Sqrt(
   OracleNumber value
)

Parameters

value
The specified OracleNumber structure.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtract Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Subtract Method

value1
First OracleNumber.
value2
Second OracleNumber.
Subtracts one OracleNumber structure from another.

Syntax

Visual Basic (Declaration)
Public Shared Function Subtract( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Subtract(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Tan Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the tangent of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Tan( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Tan(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tanh Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Tanh Method

value
An OracleNumber structure that represents an angle in radian.
Calculates the hyperbolic tangent of the specified angle in radian.

Syntax

Visual Basic (Declaration)
Public Shared Function Tanh( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public static OracleNumber Tanh(
   OracleNumber value
)

Parameters

value
An OracleNumber structure that represents an angle in radian.

Return Value

An OracleNumber instance.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToDecimal Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToDecimal Method

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Decimal.

Syntax

Visual Basic (Declaration)
Public Shared Function ToDecimal( _
   ByVal val As OracleNumber _
) As Decimal
C#
public static decimal ToDecimal(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Decimal structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToDouble Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToDouble Method

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Double.

Syntax

Visual Basic (Declaration)
Public Shared Function ToDouble( _
   ByVal val As OracleNumber _
) As Double
C#
public static double ToDouble(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Double structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToFloat Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToFloat Method

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Float.

Syntax

Visual Basic (Declaration)
Public Shared Function ToFloat( _
   ByVal val As OracleNumber _
) As Single
C#
public static float ToFloat(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Float structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToInt32 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToInt32 Method

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Int32.

Syntax

Visual Basic (Declaration)
Public Shared Function ToInt32( _
   ByVal val As OracleNumber _
) As Integer
C#
public static int ToInt32(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Int32 structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToInt64 Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToInt64 Method

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Int64.

Syntax

Visual Basic (Declaration)
Public Shared Function ToInt64( _
   ByVal val As OracleNumber _
) As Long
C#
public static long ToInt64(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Int64 structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : ToString Method

Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.Converts the current OracleNumber structure to a System.String.

Overload List

Overload | Description
ToString() | Converts the current OracleNumber structure to a System.String.
ToString(String) | Converts the current OracleNumber structure to a System.String using the specified format.
ToString(IFormatProvider) | Converts the current OracleNumber structure to a System.String.
ToString(String,IFormatProvider) | Converts the current OracleNumber structure to a System.String.
ToString(String,OracleGlobalization) | Converts the current OracleNumber structure to a System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > ToString Method : ToString() Method

Converts the current OracleNumber structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String representing the OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > ToString Method : ToString(String) Method

format
The format to use.
Converts the current OracleNumber structure to a System.String using the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String _
) As String
C#
public string ToString(
   string format
)

Parameters

format
The format to use.

Return Value

A System.String representing the OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(IFormatProvider) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > ToString Method : ToString(IFormatProvider) Method

provider
Converts the current OracleNumber structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal provider As IFormatProvider _
) As String
C#
public string ToString(
   IFormatProvider provider
)

Parameters

provider

Return Value

A System.String representing the OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(String,IFormatProvider) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > ToString Method : ToString(String,IFormatProvider) Method

format
provider
Converts the current OracleNumber structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String, _
   ByVal provider As IFormatProvider _
) As String
C#
public string ToString(
   string format,
   IFormatProvider provider
)

Parameters

format
provider

Return Value

A System.String representing the OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(String,OracleGlobalization) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > ToString Method : ToString(String,OracleGlobalization) Method

format
globalization
Converts the current OracleNumber structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String, _
   ByVal globalization As OracleGlobalization _
) As String
C#
public string ToString(
   string format,
   OracleGlobalization globalization
)

Parameters

format
globalization

Return Value

A System.String representing the OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Truncate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Truncate Method

value
The specified OracleNumber structure.
position
The decimal position to which the number will be truncated.
Truncates the OracleNumber at a specified position.

Syntax

Visual Basic (Declaration)
Public Shared Function Truncate( _
   ByVal value As OracleNumber, _
   ByVal position As Integer _
) As OracleNumber
C#
public static OracleNumber Truncate(
   OracleNumber value,
   int position
)

Parameters

value
The specified OracleNumber structure.
position
The decimal position to which the number will be truncated.

Return Value

A new OracleNumber structure.

Remarks

This method is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : TryParse Method

Converts the string representation of a date to OracleNumber.

Overload List

Overload | Description
TryParse(String,OracleNumber) | Converts the string representation of a date to OracleNumber.
TryParse(String,String,OracleNumber) | Converts the string representation of a number to OracleNumber. A return value indicates whether the conversion succeeded or failed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > TryParse Method : TryParse(String,OracleNumber) Method

value
A string, containing a number to convert.
result
If the conversion was successful, this parameter contains the result OracleNumber value; otherwise it contains Zero.
Converts the string representation of a date to OracleNumber.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As OracleNumber _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleNumber result
)

Parameters

value
A string, containing a number to convert.
result
If the conversion was successful, this parameter contains the result OracleNumber value; otherwise it contains Zero.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,String,OracleNumber) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > TryParse Method : TryParse(String,String,OracleNumber) Method

value
A string, containing a number to convert.
format
The number format to use for conversion.
result
If the conversion was successful, this parameter contains the result OracleNumber value; otherwise it contains Zero.
Converts the string representation of a number to OracleNumber. A return value indicates whether the conversion succeeded or failed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByVal format As String, _
   ByRef result As OracleNumber _
) As Boolean
C#
public static bool TryParse(
   string value,
   string format,
   out OracleNumber result
)

Parameters

value
A string, containing a number to convert.
format
The number format to use for conversion.
result
If the conversion was successful, this parameter contains the result OracleNumber value; otherwise it contains Zero.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleNumber Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

For a list of all members of this type, see OracleNumber members.

Public Properties

 | Name | Description
public Property | BinData | Gets OracleNumber value as binary data.
public Property | IsInt | Indicates whether the current instance of OracleNumber is an integer number.
public Property | IsNull | Indicates whether the Value property of the OracleNumber is Null.
public Property | IsPositive | Indicates whether the current instance of OracleNumber is greater than zero.
public Property | IsZero | Indicates whether the current instance of OracleNumber is zero.
public Property | Value | Gets the value of the OracleNumber structure.
Top

See Also

Reference

OracleNumber Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BinData Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : BinData Property

Gets OracleNumber value as binary data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BinData As Byte()
C#
public byte[] BinData {get;}

Property Value

An array of bytes that represents the current OracleNumber object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsInt Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : IsInt Property

Indicates whether the current instance of OracleNumber is an integer number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInt As Boolean
C#
public bool IsInt {get;}

Property Value

true if the current instance of OracleNumber is an integer number; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : IsNull Property

Indicates whether the Value property of the OracleNumber is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsPositive Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : IsPositive Property

Indicates whether the current instance of OracleNumber is greater than zero.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPositive As Boolean
C#
public bool IsPositive {get;}

Property Value

true if the current instance of OracleNumber is greater than zero; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsZero Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : IsZero Property

Indicates whether the current instance of OracleNumber is zero.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsZero As Boolean
C#
public bool IsZero {get;}

Property Value

true if the current instance of OracleNumber is zero; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Value Property

Gets the value of the OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Decimal
C#
public decimal Value {get;}

Property Value

A decimal value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleNumber Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

For a list of all members of this type, see OracleNumber members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxPrecision | Represents the maximum precision, which is 38.
static (Shared in Visual Basic) | MaxScale | Represents the maximum scale, which is 127.
static (Shared in Visual Basic) | MaxValue | Represents the maximum value of an OracleNumber structure.
static (Shared in Visual Basic) | MinScale | Represents the minimum scale, which is -84.
static (Shared in Visual Basic) | MinValue | Represents the minimum value of an OracleNumber structure.
static (Shared in Visual Basic) | NegativeOne | Represents the negative one value.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleNumber object.
static (Shared in Visual Basic) | One | Represents the positive one value.
static (Shared in Visual Basic) | Pi | Represents the numeric Pi value.
static (Shared in Visual Basic) | Zero | Represents the zero value.
Top

See Also

Reference

OracleNumber Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxPrecision Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : MaxPrecision Field

Represents the maximum precision, which is 38.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxPrecision As OracleNumber
C#
public static readonly OracleNumber MaxPrecision

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxScale Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : MaxScale Field

Represents the maximum scale, which is 127.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxScale As OracleNumber
C#
public static readonly OracleNumber MaxScale

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : MaxValue Field

Represents the maximum value of an OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As OracleNumber
C#
public static readonly OracleNumber MaxValue

Remarks

The maximum value is 9.9...9 x 10(125) (38 nines followed by 88 zeroes).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinScale Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : MinScale Field

Represents the minimum scale, which is -84.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinScale As OracleNumber
C#
public static readonly OracleNumber MinScale

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : MinValue Field

Represents the minimum value of an OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinValue As OracleNumber
C#
public static readonly OracleNumber MinValue

Remarks

The minimum value is -1.0 x 10(130).

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NegativeOne Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : NegativeOne Field

Represents the negative one value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NegativeOne As OracleNumber
C#
public static readonly OracleNumber NegativeOne

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Null Field

Represents a null value that can be assigned to an OracleNumber object.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleNumber
C#
public static readonly OracleNumber Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
One Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : One Field

Represents the positive one value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly One As OracleNumber
C#
public static readonly OracleNumber One

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Pi Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Pi Field

Represents the numeric Pi value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Pi As OracleNumber
C#
public static readonly OracleNumber Pi

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Zero Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Zero Field

Represents the zero value.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Zero As OracleNumber
C#
public static readonly OracleNumber Zero

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleNumber Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleNumber Structure

The following tables list the members exposed by OracleNumber.

Public Operators

public Operator Addition | Calculates the sum of the two OracleNumber structures.
public Operator Division | Divides one OracleNumber value by another.
public Operator Equality | Determines whether two OracleNumber values are equal.
public Operator Explicit Type Conversion | Overloaded. Converts the System.Double parameter to the OracleNumber.
public Operator Greater Than | Compares two OracleNumber structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleNumber structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Overloaded. Converts the System.Decimal parameter to the OracleNumber.
public Operator Inequality | Determines whether two OracleNumber values are not equal.
public Operator Less Than | Compares two OracleNumber structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleNumber structures to determine if the first is less than or equal to the second.
public Operator Modulus | Divides the value of the first OracleNumber by the value of the second, and returns the remainder.
public Operator Multiplication | Multiplies two OracleNumber structures.
public Operator Subtraction | Subtracts one OracleNumber structure from another.
public Operator Unary Negation | Negates the passed OracleNumber structure.
Top

See Also

Reference

OracleNumber Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Addition Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Calculates the sum of the two OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator +(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This member is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Division Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Division Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Divides one OracleNumber value by another.

Syntax

Visual Basic (Declaration)
Public Operator /( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator /(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This member is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Equality Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether two OracleNumber values are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator ==(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if two OracleNumber values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Explicit Type Conversion Operator

Converts the System.Double parameter to the OracleNumber.

Overload List

Overload | Description
Explicit Type Conversion(OracleNumber,Double) | Converts the System.Double parameter to the OracleNumber.
Explicit Type Conversion(OracleNumber,Single) |
Explicit Type Conversion(OracleNumber,String) | Converts the System.String parameter to the OracleNumber.
Explicit Type Conversion(Decimal,OracleNumber) | Converts the OracleNumber parameter to System.Decimal.
Explicit Type Conversion(Int32,OracleNumber) | Converts the OracleNumber parameter to System.Int32.
Explicit Type Conversion(Int64,OracleNumber) | Converts the OracleNumber parameter to System.Int64.
Explicit Type Conversion(Double,OracleNumber) | Converts the OracleNumber parameter to System.Double.
Explicit Type Conversion(Single,OracleNumber) |

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(OracleNumber,Double) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(OracleNumber,Double) Operator

value
The specified System.Double.
Converts the System.Double parameter to the OracleNumber.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal value As Double _
) As OracleNumber
C#
public OracleNumber operator explicit(
   double value
)

Parameters

value
The specified System.Double.

Return Value

A OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(OracleNumber,Single) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(OracleNumber,Single) Operator

value

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal value As Single _
) As OracleNumber
C#
public OracleNumber operator explicit(
   float value
)

Parameters

value

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(OracleNumber,String) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(OracleNumber,String) Operator

value
The System.String that represents a numeric value.
Converts the System.String parameter to the OracleNumber.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal value As String _
) As OracleNumber
C#
public OracleNumber operator explicit(
   string value
)

Parameters

value
The System.String that represents a numeric value.

Return Value

A OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(Decimal,OracleNumber) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Decimal,OracleNumber) Operator

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Decimal.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleNumber _
) As Decimal
C#
public decimal operator explicit(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Decimal structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(Int32,OracleNumber) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Int32,OracleNumber) Operator

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Int32.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleNumber _
) As Integer
C#
public int operator explicit(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Int32 structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(Int64,OracleNumber) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Int64,OracleNumber) Operator

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Int64.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleNumber _
) As Long
C#
public long operator explicit(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Int64 structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(Double,OracleNumber) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Double,OracleNumber) Operator

val
The OracleNumber structure to be converted.
Converts the OracleNumber parameter to System.Double.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleNumber _
) As Double
C#
public double operator explicit(
   OracleNumber val
)

Parameters

val
The OracleNumber structure to be converted.

Return Value

A new System.Double structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion(Single,OracleNumber) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Explicit Type Conversion Operator : Explicit Type Conversion(Single,OracleNumber) Operator

val

Syntax

Visual Basic (Declaration)
Overloads Public Operator Narrowing CType( _
   ByVal val As OracleNumber _
) As Single
C#
public float operator explicit(
   OracleNumber val
)

Parameters

val

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Greater Than Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Compares two OracleNumber structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator >(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Greater Than or Equal Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Compares two OracleNumber structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator >=(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Implicit Type Conversion Operator

Converts the System.Decimal parameter to the OracleNumber.

Overload List

Overload | Description
Implicit Type Conversion(OracleNumber,Decimal) | Converts the System.Decimal parameter to the OracleNumber.
Implicit Type Conversion(OracleNumber,Int32) | Converts the System.Int32 parameter to the OracleNumber.
Implicit Type Conversion(OracleNumber,Int64) | Converts the System.Int64 parameter to the OracleNumber.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion(OracleNumber,Decimal) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Implicit Type Conversion Operator : Implicit Type Conversion(OracleNumber,Decimal) Operator

value
The specified System.Decimal.
Converts the System.Decimal parameter to the OracleNumber.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Decimal _
) As OracleNumber
C#
public OracleNumber operator implicit(
   decimal value
)

Parameters

value
The specified System.Decimal.

Return Value

A OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion(OracleNumber,Int32) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Implicit Type Conversion Operator : Implicit Type Conversion(OracleNumber,Int32) Operator

value
The specified System.Int32.
Converts the System.Int32 parameter to the OracleNumber.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Integer _
) As OracleNumber
C#
public OracleNumber operator implicit(
   int value
)

Parameters

value
The specified System.Int32.

Return Value

A OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion(OracleNumber,Int64) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure > Implicit Type Conversion Operator : Implicit Type Conversion(OracleNumber,Int64) Operator

value
The specified System.Int64.
Converts the System.Int64 parameter to the OracleNumber.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Long _
) As OracleNumber
C#
public OracleNumber operator implicit(
   long value
)

Parameters

value
The specified System.Int64.

Return Value

A OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Inequality Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Determines whether two OracleNumber values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator !=(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if two OracleNumber values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Less Than Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Compares two OracleNumber structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator <(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Less Than or Equal Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Compares two OracleNumber structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As Boolean
C#
public bool operator <=(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

true if the first of two OracleNumber values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Modulus Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Modulus Operator

value
First OracleNumber.
devider
Second OracleNumber.
Divides the value of the first OracleNumber by the value of the second, and returns the remainder.

Syntax

Visual Basic (Declaration)
Public Operator Mod( _
   ByVal value As OracleNumber, _
   ByVal devider As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator %(
   OracleNumber value,
   OracleNumber devider
)

Parameters

value
First OracleNumber.
devider
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This member is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiplication Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Multiplication Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Multiplies two OracleNumber structures.

Syntax

Visual Basic (Declaration)
Public Operator *( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator *(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This member is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Subtraction Operator

value1
First OracleNumber.
value2
Second OracleNumber.
Subtracts one OracleNumber structure from another.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value1 As OracleNumber, _
   ByVal value2 As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator -(
   OracleNumber value1,
   OracleNumber value2
)

Parameters

value1
First OracleNumber.
value2
Second OracleNumber.

Return Value

A new OracleNumber structure.

Remarks

This member is not available in Direct mode.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Unary Negation Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumber Structure : Unary Negation Operator

value
The OracleNumber structure to negate.
Negates the passed OracleNumber structure.

Syntax

Visual Basic (Declaration)
Public Operator -( _
   ByVal value As OracleNumber _
) As OracleNumber
C#
public OracleNumber operator -(
   OracleNumber value
)

Parameters

value
The OracleNumber structure to negate.

Return Value

An OracleNumber structure that returns Zero when added to the passed OracleNumber structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumber Structure
OracleNumber Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageId Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageId Structure

Represents the system-generated identification of the message.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleQueueMessageId

Syntax

Visual Basic (Declaration)
Public Structure OracleQueueMessageId
   Inherits System.ValueType
C#
public struct OracleQueueMessageId : System.ValueType

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueMessageId Members
Devart.Data.Oracle Namespace
OracleQueueMessage Class
OracleQueueMessageProperties Class


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageId Structure Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageId Structure

The following tables list the members exposed by OracleQueueMessageId.

Public Constructors

 | Name | Description
public Constructor | OracleQueueMessageId Constructor | Initializes a new instance of the OracleQueueMessageId class.
Top

Public Properties

 | Name | Description
public Property | Value | Gets or sets the identification of the message value in the form of array of bytes.
Top

Public Methods

 | Name | Description
public Method | ToString | Converts byte array to string in hexadecimal notation.
Top

See Also

Reference

OracleQueueMessageId Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageId Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageId Structure : OracleQueueMessageId Constructor

messageId
Array of bytes, that contain identification of the message. Its length must be equal to 16.
Initializes a new instance of the OracleQueueMessageId class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal messageId() As Byte _
)
C#
public OracleQueueMessageId(
   byte[] messageId
)

Parameters

messageId
Array of bytes, that contain identification of the message. Its length must be equal to 16.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageId Structure
OracleQueueMessageId Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageId Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageId Structure

For a list of all members of this type, see OracleQueueMessageId members.

Public Methods

 | Name | Description
public Method | ToString | Converts byte array to string in hexadecimal notation.
Top

See Also

Reference

OracleQueueMessageId Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageId Structure : ToString Method

Converts byte array to string in hexadecimal notation.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

String of bytes in hexadecimal notation with a spaces.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageId Structure
OracleQueueMessageId Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleQueueMessageId Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageId Structure

For a list of all members of this type, see OracleQueueMessageId members.

Public Properties

 | Name | Description
public Property | Value | Gets or sets the identification of the message value in the form of array of bytes.
Top

See Also

Reference

OracleQueueMessageId Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleQueueMessageId Structure : Value Property

Gets or sets the identification of the message value in the form of array of bytes.

Syntax

Visual Basic (Declaration)
Public Property Value As Byte()
C#
public byte[] Value {get; set;}

Property Value

The identification of the message value in the form of array of bytes.

Remarks

When setting this field one should remember that length of the array has to be equal to 16.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleQueueMessageId Structure
OracleQueueMessageId Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

Represents a variable-length stream of characters to be stored in or retrieved from the database.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleString

Syntax

Visual Basic (Declaration)
Public Structure OracleString
   Inherits System.ValueType
   Implements INullable, ICloneable, IComparable, ISerializable, IXmlSerializable
C#
public struct OracleString : System.ValueType, INullable, ICloneable, IComparable, ISerializable, IXmlSerializable

Remarks

Corresponds to Oracle CHAR, NCHAR, VARCHAR, NVARCHAR, LONG, and ROWID data types. To obtain an OracleString object call the OracleDataReader.GetOracleString method of the OracleDataReader class.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleString Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleString Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

The following tables list the members exposed by OracleString.

Public Constructors

 | Name | Description
public Constructor | OracleString Constructor | Overloaded. Initializes a new instance of the OracleString structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty string that can be assigned to the Value property of an OracleString structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleString structure.
Top

Public Properties

 | Name | Description
public Property | IsCaseIgnored | Specifies whether case shoud be ignored in comparison. Default value is false.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleString is Null.
public Property | Item | Gets the character at the specified index.
public Property | Length | Gets the length of the string that is stored in the specified OracleString structure.
public Property | Value | Gets the string that is stored in the specified OracleString structure.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of the current OracleString instance.
public Method | CompareTo | Overloaded. Compares the current OracleString object to another one.
static (Shared in Visual Basic) | Concat | Concatenates two OracleString structures.
public Method | Equals | Overloaded. Compares two OracleString structures to determine if they are equal.
public Method | GetHashCode | Returns a hash code for the OracleString structure.
public Method | GetNonUnicodeBytes | Retuns the OracleString contents as an array of bytes in the client encoding.
public Method | GetUnicodeBytes | Retuns the OracleString contents as an array of bytes in the client encoding.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleString values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleString values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleString values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleString values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleString values are not equal.
public Method | ToString | Converts the current OracleString object to a System.String.
Top

Public Operators

public Operator Addition | Concatenates two OracleString structures.
public Operator Equality | Determines whether two OracleString values are equal.
public Operator Explicit Type Conversion | Converts the OracleString object to a System.String.
public Operator Greater Than | Compares two OracleString structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleString structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts the specified System.String to an OracleString.
public Operator Inequality | Determines whether two OracleString values are not equal.
public Operator Less Than | Compares two OracleString structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleString structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleString Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : OracleString Constructor

Initializes a new instance of the OracleString structure.

Overload List

Overload | Description
OracleString Constructor(String) | Initializes a new instance of the OracleString structure, setting the Value property to the specified string.
OracleString Constructor(String,Boolean) | Initializes a new instance of the OracleString structure, setting the Value property to the specified string.
OracleString Constructor(Byte[],Boolean) | Initializes a new instance of the OracleString structure with the specified array of bytes.
OracleString Constructor(Byte[],Boolean,Boolean) | Initializes a new instance of the OracleString structure with the specified array of bytes.
OracleString Constructor(Byte[],Int32,Int32,Boolean) | Initializes a new instance of the OracleString structure with the specified array of bytes, offset in the array, and number of bytes to take.
OracleString Constructor(Byte[],Int32,Int32,Boolean,Boolean) | Initializes a new instance of the OracleString structure with the specified array of bytes, offset in the array, and number of bytes to take.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(String)

value
The specified string.
Initializes a new instance of the OracleString structure, setting the Value property to the specified string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String _
)
C#
public OracleString(
   string value
)

Parameters

value
The specified string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(String,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(String,Boolean)

value
The specified string.
isCaseIgnored
Specifies if case is ignored in comparisons.
Initializes a new instance of the OracleString structure, setting the Value property to the specified string.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As String, _
   ByVal isCaseIgnored As Boolean _
)
C#
public OracleString(
   string value,
   bool isCaseIgnored
)

Parameters

value
The specified string.
isCaseIgnored
Specifies if case is ignored in comparisons.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(Byte[],Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(Byte[],Boolean)

bytes
The specified byte array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
Initializes a new instance of the OracleString structure with the specified array of bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bytes() As Byte, _
   ByVal isUnicode As Boolean _
)
C#
public OracleString(
   byte[] bytes,
   bool isUnicode
)

Parameters

bytes
The specified byte array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(Byte[],Boolean,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(Byte[],Boolean,Boolean)

bytes
The specified byte array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
isCaseIgnored
Specifies if case is ignored in comparisons.
Initializes a new instance of the OracleString structure with the specified array of bytes.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bytes() As Byte, _
   ByVal isUnicode As Boolean, _
   ByVal isCaseIgnored As Boolean _
)
C#
public OracleString(
   byte[] bytes,
   bool isUnicode,
   bool isCaseIgnored
)

Parameters

bytes
The specified byte array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
isCaseIgnored
Specifies if case is ignored in comparisons.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(Byte[],Int32,Int32,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(Byte[],Int32,Int32,Boolean)

bytes
The specified byte array.
index
The starting index to copy data from the array.
count
The number of bytes to copy from the array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
Initializes a new instance of the OracleString structure with the specified array of bytes, offset in the array, and number of bytes to take.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bytes() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal isUnicode As Boolean _
)
C#
public OracleString(
   byte[] bytes,
   int index,
   int count,
   bool isUnicode
)

Parameters

bytes
The specified byte array.
index
The starting index to copy data from the array.
count
The number of bytes to copy from the array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleString Constructor(Byte[],Int32,Int32,Boolean,Boolean)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > OracleString Constructor : OracleString Constructor(Byte[],Int32,Int32,Boolean,Boolean)

bytes
The specified byte array.
index
The starting index to copy data from the array.
count
The number of bytes to copy from the array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
isCaseIgnored
Specifies if case is ignored in comparisons.
Initializes a new instance of the OracleString structure with the specified array of bytes, offset in the array, and number of bytes to take.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bytes() As Byte, _
   ByVal index As Integer, _
   ByVal count As Integer, _
   ByVal isUnicode As Boolean, _
   ByVal isCaseIgnored As Boolean _
)
C#
public OracleString(
   byte[] bytes,
   int index,
   int count,
   bool isUnicode,
   bool isCaseIgnored
)

Parameters

bytes
The specified byte array.
index
The starting index to copy data from the array.
count
The number of bytes to copy from the array.
isUnicode
Specifies whether the byte array is in Unicode encoding or in local encoding.
isCaseIgnored
Specifies if case is ignored in comparisons.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleString Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

For a list of all members of this type, see OracleString members.

Public Methods

 | Name | Description
public Method | Clone | Creates a copy of the current OracleString instance.
public Method | CompareTo | Overloaded. Compares the current OracleString object to another one.
static (Shared in Visual Basic) | Concat | Concatenates two OracleString structures.
public Method | Equals | Overloaded. Compares two OracleString structures to determine if they are equal.
public Method | GetHashCode | Returns a hash code for the OracleString structure.
public Method | GetNonUnicodeBytes | Retuns the OracleString contents as an array of bytes in the client encoding.
public Method | GetUnicodeBytes | Retuns the OracleString contents as an array of bytes in the client encoding.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleString values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleString values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleString values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleString values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleString values are not equal.
public Method | ToString | Converts the current OracleString object to a System.String.
Top

See Also

Reference

OracleString Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Clone Method

Creates a copy of the current OracleString instance.

Syntax

Visual Basic (Declaration)
Public Function Clone() As OracleString
C#
public OracleString Clone()

Return Value

An OracleString instance, identical to the current one.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : CompareTo Method

Compares the current OracleString object to another one.

Overload List

Overload | Description
CompareTo(Object) | Compares the current OracleString object to the specified object and returns an integer that represents their relative values.
CompareTo(OracleString) | Compares the current OracleString object to the specified one and returns an integer that represents their relative values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > CompareTo Method : CompareTo(Object) Method

other
The object to be compared.
Compares the current OracleString object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal other As Object _
) As Integer
C#
public int CompareTo(
   object other
)

Parameters

other
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleString structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleString object is less than the object.
Zero | The current OracleString object is the same to the object.
Greater than zero | The current OracleString object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo(OracleString) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > CompareTo Method : CompareTo(OracleString) Method

other
The OracleString to be compared.
Compares the current OracleString object to the specified one and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Overloads Function CompareTo( _
   ByVal other As OracleString _
) As Integer
C#
public int CompareTo(
   OracleString other
)

Parameters

other
The OracleString to be compared.

Return Value

A signed number indicating the relative values of the current OracleString structure and the specified one.
Return Value | Condition
Less than zero | The value of the current OracleString object is less than the specified one.
Zero | The current OracleString object is the same to the specified one.
Greater than zero | The current OracleString object is greater than the specified one.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Concat Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Concat Method

value1
First OracleString.
value2
Second OracleString.
Concatenates two OracleString structures.

Syntax

Visual Basic (Declaration)
Public Shared Function Concat( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As OracleString
C#
public static OracleString Concat(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

A new OracleString structure containing the newly concatenated value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Equals Method

Compares two OracleString structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleString object.
Equals(OracleString,OracleString) | Determines whether two OracleString values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleString object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleString and has the same value; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleString,OracleString) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure > Equals Method : Equals(OracleString,OracleString) Method

value1
First OracleString.
value2
Second OracleString.
Determines whether two OracleString values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool Equals(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if two OracleString values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : GetHashCode Method

Returns a hash code for the OracleString structure.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetNonUnicodeBytes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : GetNonUnicodeBytes Method

Retuns the OracleString contents as an array of bytes in the client encoding.

Syntax

Visual Basic (Declaration)
Public Function GetNonUnicodeBytes() As Byte()
C#
public byte[] GetNonUnicodeBytes()

Return Value

The array of bytes in the client encoding that represents the contents of OracleString/

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetUnicodeBytes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : GetUnicodeBytes Method

Retuns the OracleString contents as an array of bytes in the client encoding.

Syntax

Visual Basic (Declaration)
Public Function GetUnicodeBytes() As Byte()
C#
public byte[] GetUnicodeBytes()

Return Value

The array of bytes in the Unicode encoding that represents the contents of OracleString/

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : GreaterThan Method

value1
First OracleString.
value2
Second OracleString.
Determines whether the first of two OracleString values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool GreaterThan(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleString values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : GreaterThanOrEqual Method

value1
First OracleString.
value2
Second OracleString.
Determines whether the first of two OracleString values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleString values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : LessThan Method

value1
First OracleString.
value2
Second OracleString.
Determines whether the first of two OracleString values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool LessThan(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleBinary values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : LessThanOrEqual Method

value1
First OracleString.
value2
Second OracleString.
Determines whether the first of two OracleString values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleBinary values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : NotEquals Method

value1
First OracleString.
value2
Second OracleString.
Determines whether two OracleString values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public static bool NotEquals(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if two OracleString values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : ToString Method

Converts the current OracleString object to a System.String.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String with the same value as the OracleString structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleString Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

For a list of all members of this type, see OracleString members.

Public Properties

 | Name | Description
public Property | IsCaseIgnored | Specifies whether case shoud be ignored in comparison. Default value is false.
public Property | IsNull | Gets a value indicating whether the Value property of the OracleString is Null.
public Property | Item | Gets the character at the specified index.
public Property | Length | Gets the length of the string that is stored in the specified OracleString structure.
public Property | Value | Gets the string that is stored in the specified OracleString structure.
Top

See Also

Reference

OracleString Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsCaseIgnored Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : IsCaseIgnored Property

Specifies whether case shoud be ignored in comparison. Default value is false.

Syntax

Visual Basic (Declaration)
Public Property IsCaseIgnored As Boolean
C#
public bool IsCaseIgnored {get; set;}

Property Value

true if case shoud be ignored in comparison; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : IsNull Property

Gets a value indicating whether the Value property of the OracleString is Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the Value is Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Item Property

index
The zero-based index of the character.
Gets the character at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Char
C#
public char this(
   int index
) {get;}

Parameters

index
The zero-based index of the character.

Property Value

A character on the specified index in OracleString.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Length Property

Gets the length of the string that is stored in the specified OracleString structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

The length of the string.

Remarks

Check the IsNull property before reading the Length property to avoid raising an exception.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Value Property

Gets the string that is stored in the specified OracleString structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As String
C#
public string Value {get;}

Property Value

The string that is stored.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleString Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

For a list of all members of this type, see OracleString members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty string that can be assigned to the Value property of an OracleString structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleString structure.
Top

See Also

Reference

OracleString Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Empty Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Empty Field

Represents an empty string that can be assigned to the Value property of an OracleString structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As OracleString
C#
public static readonly OracleString Empty

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Null Field

Represents a null value that can be assigned to an OracleString structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleString
C#
public static readonly OracleString Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleString Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleString Structure

The following tables list the members exposed by OracleString.

Public Operators

public Operator Addition | Concatenates two OracleString structures.
public Operator Equality | Determines whether two OracleString values are equal.
public Operator Explicit Type Conversion | Converts the OracleString object to a System.String.
public Operator Greater Than | Compares two OracleString structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleString structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Converts the specified System.String to an OracleString.
public Operator Inequality | Determines whether two OracleString values are not equal.
public Operator Less Than | Compares two OracleString structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleString structures to determine if the first is less than or equal to the second.
Top

See Also

Reference

OracleString Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Addition Operator

value1
First OracleString.
value2
Second OracleString.
Concatenates two OracleString structures.

Syntax

Visual Basic (Declaration)
Public Operator +( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As OracleString
C#
public OracleString operator +(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

A new OracleString structure containing the newly concatenated value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Equality Operator

value1
First OracleString.
value2
Second OracleString.
Determines whether two OracleString values are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator ==(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if two OracleString values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Explicit Type Conversion Operator

value
The OracleString to be converted.
Converts the OracleString object to a System.String.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal value As OracleString _
) As String
C#
public string operator explicit(
   OracleString value
)

Parameters

value
The OracleString to be converted.

Return Value

A System.String.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Greater Than Operator

value1
First OracleString.
value2
Second OracleString.
Compares two OracleString structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator >(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleBinary values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Greater Than or Equal Operator

value1
First OracleString.
value2
Second OracleString.
Compares two OracleString structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator >=(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleBinary values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Implicit Type Conversion Operator

value
The System.String to be converted.
Converts the specified System.String to an OracleString.

Syntax

Visual Basic (Declaration)
Public Operator Widening CType( _
   ByVal value As String _
) As OracleString
C#
public OracleString operator implicit(
   string value
)

Parameters

value
The System.String to be converted.

Return Value

An OracleString.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Inequality Operator

value1
First OracleString.
value2
Second OracleString.
Determines whether two OracleString values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator !=(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if two OracleString values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Less Than Operator

value1
First OracleString.
value2
Second OracleString.
Compares two OracleString structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator <(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleString values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleString Structure : Less Than or Equal Operator

value1
First OracleString.
value2
Second OracleString.
Compares two OracleString structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleString, _
   ByVal value2 As OracleString _
) As Boolean
C#
public bool operator <=(
   OracleString value1,
   OracleString value2
)

Parameters

value1
First OracleString.
value2
Second OracleString.

Return Value

true if the first of two OracleString values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleString Structure
OracleString Members
IsCaseIgnored Property


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure
Members See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

Represents the Oracle TIMESTAMP, TIMESTAMP WITH TIME ZONE, TIMESTAMP WITH LOCAL TIME ZONE data types.

Inheritance Hierarchy

System.Object
System.ValueType
Devart.Data.Oracle.OracleTimeStamp

Syntax

Visual Basic (Declaration)
Public Structure OracleTimeStamp
   Inherits System.ValueType
   Implements INullable, IComparable, IXmlSerializable
C#
public struct OracleTimeStamp : System.ValueType, INullable, IComparable, IXmlSerializable

Remarks

To obtain an OracleTimeStamp object call the OracleDataReader.GetOracleTimeStamp method of the OracleDataReader or Devart.Data.Oracle.OracleParameter class.

When Oracle Client and server have timezone files of different versions, Oracle Client returns the following error when reading TIMESTAMP WITH TIME ZONE values with time zone explicitly specified by name: "ORA-01805: possible error in date/time operation". This error means that there is a chance, that you will get a timestamp with incorrect time zone value. dotConnect for Oracle ignores this error and returns an OracleTimeStamp object in this case, but it is not guaranteed that you will get correct time zone values in such case.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleTimeStamp Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure Members
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

The following tables list the members exposed by OracleTimeStamp.

Public Constructors

 | Name | Description
public Constructor | OracleTimeStamp Constructor | Overloaded. Initializes a new instance of the OracleTimeStamp structure.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date and time for an OracleTimeStamp structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date and time for an OracleTimeStamp structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleTimeStamp structure.
Top

Public Properties

 | Name | Description
public Property | Day | Gets the day component of an OracleTimeStamp.
public Property | Hour | Gets the hour component of an OracleTimeStamp.
public Property | IsNull | Gets a value indicating whether the OracleTimeStamp structure represents Null.
public Property | Millisecond | Gets the millisecond component of an OracleTimeStamp.
public Property | Minute | Gets the minute component of an OracleTimeStamp.
public Property | Month | Gets the month component of an OracleTimeStamp.
public Property | Nanosecond | Gets the nanosecond component of an OracleTimeStamp.
public Property | Second | Gets the second component of an OracleTimeStamp.
public Property | TimeStampType | Gets the Oracle TIMESTAMP type that represents an OracleTimeStamp object.
public Property | TimeZone | Gets the time zone of the OracleTimeStamp that represents OracleDbType.TimeStampTZ.
public Property | TimeZoneOffset | Gets the time zone portion in hours and minutes for the current OracleTimeStamp that represents OracleDbType.TimeStampTZ.
public Property | Value | Gets the date and time that is stored in the OracleTimeStamp structure.
public Property | Year | Gets the year component of an OracleTimeStamp.
Top

Public Methods

 | Name | Description
public Method | AddDays | Adds the specified number of days to the current OracleTimeStamp instance.
public Method | AddHours | Adds the specified number of hours to the current OracleTimeStamp instance.
public Method | AddMilliseconds | Adds the specified number of milliseconds to the current OracleTimeStamp instance.
public Method | AddMinutes | Adds the specified number of minutes to the current OracleTimeStamp instance.
public Method | AddMonths | Adds the specified number of months to the current OracleTimeStamp instance.
public Method | AddNanoseconds | Adds the specified number of nanoseconds to the current OracleTimeStamp instance.
public Method | AddSeconds | Adds the specified number of seconds to the current OracleTimeStamp instance.
public Method | AddYears | Adds the specified number of years to the current OracleTimeStamp instance.
public Method | CompareTo | Compares the current OracleTimeStamp object to the specified object and returns an integer that represents their relative values.
public Method | Equals | Overloaded. Compares two OracleTimeStamp structures to determine if they are equal.
public Method | GetDaysBetween | Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalDS that represents the time difference between the specified OracleTimeStamp structure and the current instance.
public Method | GetHashCode | Gets a hash code for the OracleTimeStamp instance.
static (Shared in Visual Basic) | GetSysDate | Gets an OracleTimeStamp structure that represents the current date and time.
public Method | GetYearsBetween | Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalYM that represents the time difference between the specified OracleTimeStamp structure and the current instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleTimeStamp values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleTimeStamp values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleTimeStamp values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleTimeStamp values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleTimeStamp values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts the specified System.String representation of a date to its OracleTimeStamp equivalent.
public Method | ToOracleDate | Converts the current OracleTimeStamp structure to an OracleDate structure.
public Method | ToString | Overloaded. Converts the current OracleTimeStamp structure to a System.String.Converts the current OracleTimeStamp structure to a System.String.
public Method | ToUniversalTime | Converts the current date and time to Coordinated Universal Time (UTC).
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleTimeStamp.
Top

Public Operators

public Operator Addition | Overloaded. Adds the specified object to the OracleTimeStamp and returns a new OracleTimeStamp structure.
public Operator Equality | Determines whether two OracleTimeStamp values are equal.
public Operator Explicit Type Conversion | Converts the System.DateTime parameter to the OracleTimeStamp.
public Operator Greater Than | Compares two OracleTimeStamp structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleTimeStamp structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Overloaded. Converts the System.DateTime parameter to the OracleTimeStamp.
public Operator Inequality | Determines whether two OracleTimeStamp values are not equal.
public Operator Less Than | Compares two OracleTimeStamp structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleTimeStamp structures to determine if the first is less than or equal to the second.
public Operator Subtraction | Overloaded. Subtracts the specified object from the OracleTimeStamp value and returns a new OracleTimeStamp structure.
Top

See Also

Reference

OracleTimeStamp Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : OracleTimeStamp Constructor

Initializes a new instance of the OracleTimeStamp structure.

Overload List

Overload | Description
OracleTimeStamp Constructor(DateTime) | Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime.
OracleTimeStamp Constructor(DateTime,TimeSpan) | Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and time zone.
OracleTimeStamp Constructor(DateTime,String) | Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and time zone.
OracleTimeStamp Constructor(Int32,Int32,Int32) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, and day.
OracleTimeStamp Constructor(Int32,Int32,Int32,TimeSpan) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and time zone.
OracleTimeStamp Constructor(Int32,Int32,Int32,String) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and time zone.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, and second.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, and nanosecond.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and time zone.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and time zone.
OracleTimeStamp Constructor(DateTime,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and Oracle TIMESTAMP type.
OracleTimeStamp Constructor(Int32,Int32,Int32,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and Oracle TIMESTAMP type.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, and Oracle TIMESTAMP type.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and Oracle TIMESTAMP type.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, time zone, and Oracle TIMESTAMP type.
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,OracleDbType) | Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, time zone, and Oracle TIMESTAMP type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(DateTime)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(DateTime)

dt
The specified System.DateTime.
Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dt As Date _
)
C#
public OracleTimeStamp(
   DateTime dt
)

Parameters

dt
The specified System.DateTime.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(DateTime,TimeSpan)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(DateTime,TimeSpan)

dt
The specified System.DateTime.
timeZone
The specified time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dt As Date, _
   ByVal timeZone As TimeSpan _
)
C#
public OracleTimeStamp(
   DateTime dt,
   TimeSpan timeZone
)

Parameters

dt
The specified System.DateTime.
timeZone
The specified time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(DateTime,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(DateTime,String)

dt
The specified System.DateTime.
timeZone
A System.String that represents the time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dt As Date, _
   ByVal timeZone As String _
)
C#
public OracleTimeStamp(
   DateTime dt,
   string timeZone
)

Parameters

dt
The specified System.DateTime.
timeZone
A System.String that represents the time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32)

year
The specified year.
month
The specified month.
day
The specified day.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, and day.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,TimeSpan)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,TimeSpan)

year
The specified year.
month
The specified month.
day
The specified day.
timeZone
The specified time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal timeZone As TimeSpan _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   TimeSpan timeZone
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
timeZone
The specified time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,String)

year
The specified year.
month
The specified month.
day
The specified day.
timeZone
A System.String that represents the time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal timeZone As String _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   string timeZone
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
timeZone
A System.String that represents the time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, and second.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, and nanosecond.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
The specified time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer, _
   ByVal timeZone As TimeSpan _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond,
   TimeSpan timeZone
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
The specified time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
A System.String that represents the time zone.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and time zone.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer, _
   ByVal timeZone As String _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond,
   string timeZone
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
A System.String that represents the time zone.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(DateTime,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(DateTime,OracleDbType)

dt
The specified System.DateTime.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified System.DateTime and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dt As Date, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   DateTime dt,
   OracleDbType dbType
)

Parameters

dt
The specified System.DateTime.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,OracleDbType)

year
The specified year.
month
The specified month.
day
The specified day.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   OracleDbType dbType
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   OracleDbType dbType
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,OracleDbType)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond,
   OracleDbType dbType
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,TimeSpan,OracleDbType)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
The specified time zone.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, time zone, and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer, _
   ByVal timeZone As TimeSpan, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond,
   TimeSpan timeZone,
   OracleDbType dbType
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
The specified time zone.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,OracleDbType)
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > OracleTimeStamp Constructor : OracleTimeStamp Constructor(Int32,Int32,Int32,Int32,Int32,Int32,Int32,String,OracleDbType)

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
A System.String that represents the time zone.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.
Initializes a new instance of the OracleTimeStamp structure with the specified year, month, day, hour, minute, second, nanosecond, time zone, and Oracle TIMESTAMP type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal year As Integer, _
   ByVal month As Integer, _
   ByVal day As Integer, _
   ByVal hour As Integer, _
   ByVal minute As Integer, _
   ByVal second As Integer, _
   ByVal nanosecond As Integer, _
   ByVal timeZone As String, _
   ByVal dbType As OracleDbType _
)
C#
public OracleTimeStamp(
   int year,
   int month,
   int day,
   int hour,
   int minute,
   int second,
   int nanosecond,
   string timeZone,
   OracleDbType dbType
)

Parameters

year
The specified year.
month
The specified month.
day
The specified day.
hour
The specified hour.
minute
The specified minute.
second
The specified second.
nanosecond
The specified nanosecond.
timeZone
A System.String that represents the time zone.
dbType
One of the OracleDbType values. May be OracleDbType.TimeStamp, OracleDbType.TimeStampTZ, or OracleDbType.TimeStampLTZ.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

For a list of all members of this type, see OracleTimeStamp members.

Public Methods

 | Name | Description
public Method | AddDays | Adds the specified number of days to the current OracleTimeStamp instance.
public Method | AddHours | Adds the specified number of hours to the current OracleTimeStamp instance.
public Method | AddMilliseconds | Adds the specified number of milliseconds to the current OracleTimeStamp instance.
public Method | AddMinutes | Adds the specified number of minutes to the current OracleTimeStamp instance.
public Method | AddMonths | Adds the specified number of months to the current OracleTimeStamp instance.
public Method | AddNanoseconds | Adds the specified number of nanoseconds to the current OracleTimeStamp instance.
public Method | AddSeconds | Adds the specified number of seconds to the current OracleTimeStamp instance.
public Method | AddYears | Adds the specified number of years to the current OracleTimeStamp instance.
public Method | CompareTo | Compares the current OracleTimeStamp object to the specified object and returns an integer that represents their relative values.
public Method | Equals | Overloaded. Compares two OracleTimeStamp structures to determine if they are equal.
public Method | GetDaysBetween | Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalDS that represents the time difference between the specified OracleTimeStamp structure and the current instance.
public Method | GetHashCode | Gets a hash code for the OracleTimeStamp instance.
static (Shared in Visual Basic) | GetSysDate | Gets an OracleTimeStamp structure that represents the current date and time.
public Method | GetYearsBetween | Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalYM that represents the time difference between the specified OracleTimeStamp structure and the current instance.
static (Shared in Visual Basic) | GreaterThan | Determines whether the first of two OracleTimeStamp values is greater than the second.
static (Shared in Visual Basic) | GreaterThanOrEqual | Determines whether the first of two OracleTimeStamp values is greater than or equal to the second.
static (Shared in Visual Basic) | LessThan | Determines whether the first of two OracleTimeStamp values is less than the second.
static (Shared in Visual Basic) | LessThanOrEqual | Determines whether the first of two OracleTimeStamp values is less than or equal to the second.
static (Shared in Visual Basic) | NotEquals | Determines whether two OracleTimeStamp values are not equal.
static (Shared in Visual Basic) | Parse | Overloaded. Converts the specified System.String representation of a date to its OracleTimeStamp equivalent.
public Method | ToOracleDate | Converts the current OracleTimeStamp structure to an OracleDate structure.
public Method | ToString | Overloaded. Converts the current OracleTimeStamp structure to a System.String.Converts the current OracleTimeStamp structure to a System.String.
public Method | ToUniversalTime | Converts the current date and time to Coordinated Universal Time (UTC).
static (Shared in Visual Basic) | TryParse | Overloaded. Converts the string representation of a date to OracleTimeStamp.
Top

See Also

Reference

OracleTimeStamp Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddDays Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddDays Method

days
The specified number of days.
Adds the specified number of days to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddDays( _
   ByVal days As Double _
) As OracleTimeStamp
C#
public OracleTimeStamp AddDays(
   double days
)

Parameters

days
The specified number of days.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddHours Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddHours Method

hours
The specified number of hours.
Adds the specified number of hours to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddHours( _
   ByVal hours As Double _
) As OracleTimeStamp
C#
public OracleTimeStamp AddHours(
   double hours
)

Parameters

hours
The specified number of hours.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddMilliseconds Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddMilliseconds Method

milliseconds
The specified number of milliseconds.
Adds the specified number of milliseconds to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddMilliseconds( _
   ByVal milliseconds As Double _
) As OracleTimeStamp
C#
public OracleTimeStamp AddMilliseconds(
   double milliseconds
)

Parameters

milliseconds
The specified number of milliseconds.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddMinutes Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddMinutes Method

minutes
The specified number of minutes.
Adds the specified number of minutes to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddMinutes( _
   ByVal minutes As Double _
) As OracleTimeStamp
C#
public OracleTimeStamp AddMinutes(
   double minutes
)

Parameters

minutes
The specified number of minutes.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddMonths Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddMonths Method

months
The specified number of months.
Adds the specified number of months to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddMonths( _
   ByVal months As Long _
) As OracleTimeStamp
C#
public OracleTimeStamp AddMonths(
   long months
)

Parameters

months
The specified number of months.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddNanoseconds Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddNanoseconds Method

nanoseconds
The specified number of nanoseconds.
Adds the specified number of nanoseconds to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddNanoseconds( _
   ByVal nanoseconds As Long _
) As OracleTimeStamp
C#
public OracleTimeStamp AddNanoseconds(
   long nanoseconds
)

Parameters

nanoseconds
The specified number of nanoseconds.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddSeconds Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddSeconds Method

seconds
The specified number of seconds.
Adds the specified number of seconds to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddSeconds( _
   ByVal seconds As Double _
) As OracleTimeStamp
C#
public OracleTimeStamp AddSeconds(
   double seconds
)

Parameters

seconds
The specified number of seconds.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddYears Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : AddYears Method

years
The specified number of years.
Adds the specified number of years to the current OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Function AddYears( _
   ByVal years As Integer _
) As OracleTimeStamp
C#
public OracleTimeStamp AddYears(
   int years
)

Parameters

years
The specified number of years.

Return Value

An OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CompareTo Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : CompareTo Method

obj
The object to be compared.
Compares the current OracleTimeStamp object to the specified object and returns an integer that represents their relative values.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
C#
public int CompareTo(
   object obj
)

Parameters

obj
The object to be compared.

Return Value

A signed number indicating the relative values of the current OracleTimeStamp structure and the object.
Return Value | Condition
Less than zero | The value of the current OracleTimeStamp object is less than the object.
Zero | The current OracleTimeStamp object is the same to the object.
Greater than zero | The current OracleTimeStamp object is greater than the object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Equals Method

Compares two OracleTimeStamp structures to determine if they are equal.

Overload List

Overload | Description
Equals(Object) | Compares the specified object parameter to the Value property of the OracleTimeStamp object.
Equals(OracleTimeStamp,OracleTimeStamp) | Determines whether two OracleTimeStamp values are equal.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(Object) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Equals Method : Equals(Object) Method

value
The object to be compared.
Compares the specified object parameter to the Value property of the OracleTimeStamp object.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function Equals( _
   ByVal value As Object _
) As Boolean
C#
public override bool Equals(
   object value
)

Parameters

value
The object to be compared.

Return Value

true if object is an instance of the OracleTimeStamp and has the same date and time; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equals(OracleTimeStamp,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Equals Method : Equals(OracleTimeStamp,OracleTimeStamp) Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether two OracleTimeStamp values are equal.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Equals( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool Equals(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if two OracleTimeStamp values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDaysBetween Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GetDaysBetween Method

value
The OracleTimeStamp value being subtracted.
Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalDS that represents the time difference between the specified OracleTimeStamp structure and the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetDaysBetween( _
   ByVal value As OracleTimeStamp _
) As OracleIntervalDS
C#
public OracleIntervalDS GetDaysBetween(
   OracleTimeStamp value
)

Parameters

value
The OracleTimeStamp value being subtracted.

Return Value

An OracleIntervalDS representing the interval between two OracleTimeStamp values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetHashCode Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GetHashCode Method

Gets a hash code for the OracleTimeStamp instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode()

Return Value

A 32-bit signed integer hash code.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetSysDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GetSysDate Method

Gets an OracleTimeStamp structure that represents the current date and time.

Syntax

Visual Basic (Declaration)
Public Shared Function GetSysDate() As OracleTimeStamp
C#
public static OracleTimeStamp GetSysDate()

Return Value

An OracleTimeStamp structure that represents the current date and time.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetYearsBetween Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GetYearsBetween Method

value
The OracleTimeStamp value being subtracted.
Subtracts the specified OracleTimeStamp value from the current instance and returns an OracleIntervalYM that represents the time difference between the specified OracleTimeStamp structure and the current instance.

Syntax

Visual Basic (Declaration)
Public Function GetYearsBetween( _
   ByVal value As OracleTimeStamp _
) As OracleIntervalYM
C#
public OracleIntervalYM GetYearsBetween(
   OracleTimeStamp value
)

Parameters

value
The OracleTimeStamp value being subtracted.

Return Value

An OracleIntervalYM representing the interval between two OracleTimeStamp values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GreaterThan Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether the first of two OracleTimeStamp values is greater than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThan( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool GreaterThan(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GreaterThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : GreaterThanOrEqual Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether the first of two OracleTimeStamp values is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function GreaterThanOrEqual( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool GreaterThanOrEqual(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThan Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : LessThan Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether the first of two OracleTimeStamp values is less than the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThan( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool LessThan(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LessThanOrEqual Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : LessThanOrEqual Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether the first of two OracleTimeStamp values is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Shared Function LessThanOrEqual( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool LessThanOrEqual(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
NotEquals Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : NotEquals Method

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether two OracleTimeStamp values are not equal.

Syntax

Visual Basic (Declaration)
Public Shared Function NotEquals( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public static bool NotEquals(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if two OracleTimeStamp values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Parse Method

Converts the specified System.String representation of a date to its OracleTimeStamp equivalent.

Overload List

Overload | Description
Parse(String,String,OracleDbType) | Converts the specified System.String representation of a date to its OracleTimeStamp equivalent using specified format and OracleDbType.
Parse(String) | Converts the specified System.String representation of a date to its OracleTimeStamp equivalent.
Parse(String,OracleDbType) | Converts the specified System.String representation of a date to its OracleTimeStamp equivalent using specified OracleDbType.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String,String,OracleDbType) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Parse Method : Parse(String,String,OracleDbType) Method

value
The System.String to be parsed.
format
A System.String that describes elements contained within value.
timeStampType
A OracleDbType value. Only OracleDbType.TimeStamp, OracleDbType.TimeStampLTZ, and OracleDbType.TimeStampTZ are allowed.
Converts the specified System.String representation of a date to its OracleTimeStamp equivalent using specified format and OracleDbType.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String, _
   ByVal format As String, _
   ByVal timeStampType As OracleDbType _
) As OracleTimeStamp
C#
public static OracleTimeStamp Parse(
   string value,
   string format,
   OracleDbType timeStampType
)

Parameters

value
The System.String to be parsed.
format
A System.String that describes elements contained within value.
timeStampType
A OracleDbType value. Only OracleDbType.TimeStamp, OracleDbType.TimeStampLTZ, and OracleDbType.TimeStampTZ are allowed.

Return Value

An OracleTimeStamp structure equal to the date represented by the specified System.String.

Example

The following example demonstrates how to parse a string using your own format with and without a time zone.
C#csharp Copy Code
OracleTimeStamp newts = OracleTimeStamp.Parse("10/03/05 3:04 PM", "mm/dd/yyyy HH:MI AM", OracleDbType.TimeStampLTZ);
OracleTimeStamp newts2 = OracleTimeStamp.Parse("10/03/05 3:04 +03:00 PM", "mm/dd/yyyy HH:MI TZH:TZM AM", OracleDbType.TimeStampTZ);
C#Visual Basic Copy Code
Dim newts As OracleTimeStamp = OracleTimeStamp.Parse("10/03/05 3:04 PM", "mm/dd/yyyy HH:MI AM", OracleDbType.TimeStampLTZ)
Dim newts2 As OracleTimeStamp = OracleTimeStamp.Parse("10/03/05 3:04 +03:00 PM", "mm/dd/yyyy HH:MI TZH:TZM AM", OracleDbType.TimeStampTZ)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Parse Method : Parse(String) Method

value
The System.String to be parsed.
Converts the specified System.String representation of a date to its OracleTimeStamp equivalent.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String _
) As OracleTimeStamp
C#
public static OracleTimeStamp Parse(
   string value
)

Parameters

value
The System.String to be parsed.

Return Value

An OracleTimeStamp structure equal to the date represented by the specified System.String.

Remarks

The value format must correspond to your local windows settings.

Example

The following example demonstrates usage of Parse method on a machine that has default Windows XP settings. If you have custom settings or use non-English version of the operating system you must change the format of value parameter.
C#csharp Copy Code
OracleTimeStamp newts = OracleTimeStamp.Parse("12/25/2005 3:40:15 PM");
C#Visual Basic Copy Code
Dim newts As OracleTimeStamp = OracleTimeStamp.Parse("12/25/2005 3:40:15 PM")

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse(String,OracleDbType) Method
See Also Example support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Parse Method : Parse(String,OracleDbType) Method

value
The System.String to be parsed.
timeStampType
A OracleDbType value. Only OracleDbType.TimeStamp, OracleDbType.TimeStampLTZ, and OracleDbType.TimeStampTZ are allowed.
Converts the specified System.String representation of a date to its OracleTimeStamp equivalent using specified OracleDbType.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Parse( _
   ByVal value As String, _
   ByVal timeStampType As OracleDbType _
) As OracleTimeStamp
C#
public static OracleTimeStamp Parse(
   string value,
   OracleDbType timeStampType
)

Parameters

value
The System.String to be parsed.
timeStampType
A OracleDbType value. Only OracleDbType.TimeStamp, OracleDbType.TimeStampLTZ, and OracleDbType.TimeStampTZ are allowed.

Return Value

An OracleTimeStamp structure equal to the date represented by the specified System.String.

Remarks

This overload of Parse method allows to control how the time stamp is actually stored.

Example

The following example demonstrates usage of Parse method on a machine that has default Windows XP settings. If you have custom settings or use non-English version of the operating system you must change the format of value parameter.
C#csharp Copy Code
OracleTimeStamp newts = OracleTimeStamp.Parse("10/03/05 3:04:05 AM +03:00", OracleDbType.TimeStampTZ);
C#Visual Basic Copy Code
Dim newts As OracleTimeStamp = OracleTimeStamp.Parse("10/03/05 3:04:05 AM +03:00", OracleDbType.TimeStampTZ)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List
OracleDbType Enumeration


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToOracleDate Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : ToOracleDate Method

Converts the current OracleTimeStamp structure to an OracleDate structure.

Syntax

Visual Basic (Declaration)
Public Function ToOracleDate() As OracleDate
C#
public OracleDate ToOracleDate()

Return Value

The OracleDate structure contained the date and time in the current instance.

Remarks

The fractional second precision of the OracleTimeStamp value can be lost during the conversion.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : ToString Method

Converts the current OracleTimeStamp structure to a System.String.Converts the current OracleTimeStamp structure to a System.String.

Overload List

Overload | Description
ToString() | Converts the current OracleTimeStamp structure to a System.String.
ToString(String) | Converts the current OracleTimeStamp structure to a System.String using provided format string.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString() Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > ToString Method : ToString() Method

Converts the current OracleTimeStamp structure to a System.String.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A System.String object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString(String) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > ToString Method : ToString(String) Method

format
Format to use for converting the string.
Converts the current OracleTimeStamp structure to a System.String using provided format string.

Syntax

Visual Basic (Declaration)
Public Overloads Function ToString( _
   ByVal format As String _
) As String
C#
public string ToString(
   string format
)

Parameters

format
Format to use for converting the string.

Return Value

A System.String object.

Remarks

For information on how to build a format string refer to Oracle documentation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToUniversalTime Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : ToUniversalTime Method

Converts the current date and time to Coordinated Universal Time (UTC).

Syntax

Visual Basic (Declaration)
Public Function ToUniversalTime() As OracleTimeStamp
C#
public OracleTimeStamp ToUniversalTime()

Return Value

An OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : TryParse Method

Converts the string representation of a date to OracleTimeStamp.

Overload List

Overload | Description
TryParse(String,String,OracleDbType,OracleTimeStamp) | Converts the string representation of a date to OracleTimeStamp.
TryParse(String,OracleTimeStamp) | Converts the string representation of a date to OracleDate.
TryParse(String,OracleDbType,OracleTimeStamp) | Converts the string representation of a date to OracleDate.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,String,OracleDbType,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > TryParse Method : TryParse(String,String,OracleDbType,OracleTimeStamp) Method

value
A string, containing a timestamp to convert.
format
The timestamp format to use for conversion.
timeStampType
The type of the Oracle TIMESTAMP.
result
If the conversion was successful, this parameter contains the result OracleTimeStamp value; otherwise it contains MinValue.
Converts the string representation of a date to OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByVal format As String, _
   ByVal timeStampType As OracleDbType, _
   ByRef result As OracleTimeStamp _
) As Boolean
C#
public static bool TryParse(
   string value,
   string format,
   OracleDbType timeStampType,
   out OracleTimeStamp result
)

Parameters

value
A string, containing a timestamp to convert.
format
The timestamp format to use for conversion.
timeStampType
The type of the Oracle TIMESTAMP.
result
If the conversion was successful, this parameter contains the result OracleTimeStamp value; otherwise it contains MinValue.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > TryParse Method : TryParse(String,OracleTimeStamp) Method

value
A string, containing a date to convert.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.
Converts the string representation of a date to OracleDate.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByRef result As OracleTimeStamp _
) As Boolean
C#
public static bool TryParse(
   string value,
   out OracleTimeStamp result
)

Parameters

value
A string, containing a date to convert.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse(String,OracleDbType,OracleTimeStamp) Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > TryParse Method : TryParse(String,OracleDbType,OracleTimeStamp) Method

value
A string, containing a date to convert.
timeStampType
The type of the Oracle TIMESTAMP.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.
Converts the string representation of a date to OracleDate.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal value As String, _
   ByVal timeStampType As OracleDbType, _
   ByRef result As OracleTimeStamp _
) As Boolean
C#
public static bool TryParse(
   string value,
   OracleDbType timeStampType,
   out OracleTimeStamp result
)

Parameters

value
A string, containing a date to convert.
timeStampType
The type of the Oracle TIMESTAMP.
result
If the conversion was successful, this parameter contains the result OracleDate value; otherwise it contains MinValue.

Return Value

true if the string was converted successfully; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

For a list of all members of this type, see OracleTimeStamp members.

Public Properties

 | Name | Description
public Property | Day | Gets the day component of an OracleTimeStamp.
public Property | Hour | Gets the hour component of an OracleTimeStamp.
public Property | IsNull | Gets a value indicating whether the OracleTimeStamp structure represents Null.
public Property | Millisecond | Gets the millisecond component of an OracleTimeStamp.
public Property | Minute | Gets the minute component of an OracleTimeStamp.
public Property | Month | Gets the month component of an OracleTimeStamp.
public Property | Nanosecond | Gets the nanosecond component of an OracleTimeStamp.
public Property | Second | Gets the second component of an OracleTimeStamp.
public Property | TimeStampType | Gets the Oracle TIMESTAMP type that represents an OracleTimeStamp object.
public Property | TimeZone | Gets the time zone of the OracleTimeStamp that represents OracleDbType.TimeStampTZ.
public Property | TimeZoneOffset | Gets the time zone portion in hours and minutes for the current OracleTimeStamp that represents OracleDbType.TimeStampTZ.
public Property | Value | Gets the date and time that is stored in the OracleTimeStamp structure.
public Property | Year | Gets the year component of an OracleTimeStamp.
Top

See Also

Reference

OracleTimeStamp Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Day Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Day Property

Gets the day component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Day As Integer
C#
public int Day {get;}

Property Value

A number that represents a day value between 1 and 31.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Hour Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Hour Property

Gets the hour component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hour As Integer
C#
public int Hour {get;}

Property Value

A number that represents an hour value between 0 and 23.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsNull Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : IsNull Property

Gets a value indicating whether the OracleTimeStamp structure represents Null.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull {get;}

Property Value

true if the OracleTimeStamp structure represents Null; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Millisecond Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Millisecond Property

Gets the millisecond component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Millisecond As Double
C#
public double Millisecond {get;}

Property Value

A number that represents a millisecond value between 0 and 999999999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Minute Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Minute Property

Gets the minute component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minute As Integer
C#
public int Minute {get;}

Property Value

A number that represents a minute value between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Month Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Month Property

Gets the month component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Month As Integer
C#
public int Month {get;}

Property Value

A number that represents a month value between 1 and 12.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Nanosecond Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Nanosecond Property

Gets the nanosecond component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nanosecond As Integer
C#
public int Nanosecond {get;}

Property Value

A number that represents a nanosecond value between 0 and 999999999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Second Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Second Property

Gets the second component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Second As Integer
C#
public int Second {get;}

Property Value

A number that represents a second value between 0 and 59.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeStampType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : TimeStampType Property

Gets the Oracle TIMESTAMP type that represents an OracleTimeStamp object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeStampType As OracleDbType
C#
public OracleDbType TimeStampType {get;}

Property Value

One of the OracleDbType values. May be TimeStamp, TimeStampTZ, or TimeStampLTZ.

Remarks

The value of TimeStampType property is specified in the constructor depending its parameters or can be set explicitly by the corresponding constructor.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeZone Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : TimeZone Property

Gets the time zone of the OracleTimeStamp that represents OracleDbType.TimeStampTZ.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeZone As String
C#
public string TimeZone {get;}

Property Value

A System.String that represents the time zone.

Remarks

If no time zone is set in the constructor, the TimeZone property is specified by the current Oracle client settings.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TimeZoneOffset Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : TimeZoneOffset Property

Gets the time zone portion in hours and minutes for the current OracleTimeStamp that represents OracleDbType.TimeStampTZ.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimeZoneOffset As TimeSpan
C#
public TimeSpan TimeZoneOffset {get;}

Property Value

A System.TimeSpan.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Value Property

Gets the date and time that is stored in the OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As Date
C#
public DateTime Value {get;}

Property Value

A System.DateTime object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Year Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Year Property

Gets the year component of an OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Year As Integer
C#
public int Year {get;}

Property Value

A number that represents a year value between -4712 and 9999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%% $$Fields$$

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure Fields
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

For a list of all members of this type, see OracleTimeStamp members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxValue | Represents the maximum valid date and time for an OracleTimeStamp structure.
static (Shared in Visual Basic) | MinValue | Represents the minimum valid date and time for an OracleTimeStamp structure.
static (Shared in Visual Basic) | Null | Represents a null value that can be assigned to an OracleTimeStamp structure.
Top

See Also

Reference

OracleTimeStamp Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MaxValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : MaxValue Field

Represents the maximum valid date and time for an OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxValue As OracleTimeStamp
C#
public static readonly OracleTimeStamp MaxValue

Remarks

The maximum valid date for an OracleTimeStamp structure is December 31, 9999 23:59:59.999999999.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
MinValue Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : MinValue Field

Represents the minimum valid date and time for an OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinValue As OracleTimeStamp
C#
public static readonly OracleTimeStamp MinValue

Remarks

The minimum valid date for an OracleTimeStamp structure is January 1, -4712 0:0:0.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Null Field
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Null Field

Represents a null value that can be assigned to an OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Null As OracleTimeStamp
C#
public static readonly OracleTimeStamp Null

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%% Operators

[image]
dotConnect for Oracle Documentation
OracleTimeStamp Structure Operators
See Also Fields Properties Methods support@devart.com
Devart.Data.Oracle Namespace : OracleTimeStamp Structure

The following tables list the members exposed by OracleTimeStamp.

Public Operators

public Operator Addition | Overloaded. Adds the specified object to the OracleTimeStamp and returns a new OracleTimeStamp structure.
public Operator Equality | Determines whether two OracleTimeStamp values are equal.
public Operator Explicit Type Conversion | Converts the System.DateTime parameter to the OracleTimeStamp.
public Operator Greater Than | Compares two OracleTimeStamp structures to determine if the first is greater than the second.
public Operator Greater Than or Equal | Compares two OracleTimeStamp structures to determine if the first is greater than or equal to the second.
public Operator Implicit Type Conversion | Overloaded. Converts the System.DateTime parameter to the OracleTimeStamp.
public Operator Inequality | Determines whether two OracleTimeStamp values are not equal.
public Operator Less Than | Compares two OracleTimeStamp structures to determine if the first is less than the second.
public Operator Less Than or Equal | Compares two OracleTimeStamp structures to determine if the first is less than or equal to the second.
public Operator Subtraction | Overloaded. Subtracts the specified object from the OracleTimeStamp value and returns a new OracleTimeStamp structure.
Top

See Also

Reference

OracleTimeStamp Structure
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Addition Operator

Adds the specified object to the OracleTimeStamp and returns a new OracleTimeStamp structure.

Overload List

Overload | Description
Addition(OracleTimeStamp,OracleIntervalDS) | Adds the specified OracleIntervalDS to the OracleTimeStamp and returns a new OracleTimeStamp structure.
Addition(OracleTimeStamp,OracleIntervalYM) | Adds the specified OracleIntervalYM to the OracleTimeStamp and returns a new OracleTimeStamp structure.
Addition(OracleTimeStamp,TimeSpan) | Adds the specified System.TimeSpan to the OracleTimeStamp and returns a new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition(OracleTimeStamp,OracleIntervalDS) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Addition Operator : Addition(OracleTimeStamp,OracleIntervalDS) Operator

value1
The OracleTimeStamp.
value2
The specified OracleIntervalDS.
Adds the specified OracleIntervalDS to the OracleTimeStamp and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator +( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleIntervalDS _
) As OracleTimeStamp
C#
public OracleTimeStamp operator +(
   OracleTimeStamp value1,
   OracleIntervalDS value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified OracleIntervalDS.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition(OracleTimeStamp,OracleIntervalYM) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Addition Operator : Addition(OracleTimeStamp,OracleIntervalYM) Operator

value1
The OracleTimeStamp.
value2
The specified OracleIntervalYM.
Adds the specified OracleIntervalYM to the OracleTimeStamp and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator +( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleIntervalYM _
) As OracleTimeStamp
C#
public OracleTimeStamp operator +(
   OracleTimeStamp value1,
   OracleIntervalYM value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified OracleIntervalYM.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Addition(OracleTimeStamp,TimeSpan) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Addition Operator : Addition(OracleTimeStamp,TimeSpan) Operator

value1
The OracleTimeStamp.
value2
The specified System.TimeSpan.
Adds the specified System.TimeSpan to the OracleTimeStamp and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator +( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As TimeSpan _
) As OracleTimeStamp
C#
public OracleTimeStamp operator +(
   OracleTimeStamp value1,
   TimeSpan value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified System.TimeSpan.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Equality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Equality Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether two OracleTimeStamp values are equal.

Syntax

Visual Basic (Declaration)
Public Operator =( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator ==(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if two OracleTimeStamp values are equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Explicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Explicit Type Conversion Operator

value
The specified System.DateTime.
Converts the System.DateTime parameter to the OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Public Operator Narrowing CType( _
   ByVal value As OracleTimeStamp _
) As Date
C#
public DateTime operator explicit(
   OracleTimeStamp value
)

Parameters

value
The specified System.DateTime.

Return Value

A OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Greater Than Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Compares two OracleTimeStamp structures to determine if the first is greater than the second.

Syntax

Visual Basic (Declaration)
Public Operator >( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator >(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is greater than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Greater Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Greater Than or Equal Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Compares two OracleTimeStamp structures to determine if the first is greater than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator >=( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator >=(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is greater than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Implicit Type Conversion Operator

Converts the System.DateTime parameter to the OracleTimeStamp.

Overload List

Overload | Description
Implicit Type Conversion(OracleTimeStamp,DateTime) | Converts the System.DateTime parameter to the OracleTimeStamp.
Implicit Type Conversion(OracleTimeStamp,OracleDate) | Converts the OracleDate parameter to the OracleTimeStamp.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion(OracleTimeStamp,DateTime) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Implicit Type Conversion Operator : Implicit Type Conversion(OracleTimeStamp,DateTime) Operator

value
The specified System.DateTime.
Converts the System.DateTime parameter to the OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As Date _
) As OracleTimeStamp
C#
public OracleTimeStamp operator implicit(
   DateTime value
)

Parameters

value
The specified System.DateTime.

Return Value

A OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Implicit Type Conversion(OracleTimeStamp,OracleDate) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Implicit Type Conversion Operator : Implicit Type Conversion(OracleTimeStamp,OracleDate) Operator

value
The specified OracleDate.
Converts the OracleDate parameter to the OracleTimeStamp.

Syntax

Visual Basic (Declaration)
Overloads Public Operator Widening CType( _
   ByVal value As OracleDate _
) As OracleTimeStamp
C#
public OracleTimeStamp operator implicit(
   OracleDate value
)

Parameters

value
The specified OracleDate.

Return Value

A OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Inequality Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Inequality Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Determines whether two OracleTimeStamp values are not equal.

Syntax

Visual Basic (Declaration)
Public Operator <>( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator !=(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if two OracleTimeStamp values are not equal; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Less Than Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Compares two OracleTimeStamp structures to determine if the first is less than the second.

Syntax

Visual Basic (Declaration)
Public Operator <( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator <(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is less than the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Less Than or Equal Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Less Than or Equal Operator

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.
Compares two OracleTimeStamp structures to determine if the first is less than or equal to the second.

Syntax

Visual Basic (Declaration)
Public Operator <=( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleTimeStamp _
) As Boolean
C#
public bool operator <=(
   OracleTimeStamp value1,
   OracleTimeStamp value2
)

Parameters

value1
First OracleTimeStamp.
value2
Second OracleTimeStamp.

Return Value

true if the first of two OracleTimeStamp values is less than or equal to the second; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure : Subtraction Operator

Subtracts the specified object from the OracleTimeStamp value and returns a new OracleTimeStamp structure.

Overload List

Overload | Description
Subtraction(OracleTimeStamp,OracleIntervalDS) | Subtracts the specified OracleIntervalDS value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.
Subtraction(OracleTimeStamp,OracleIntervalYM) | Subtracts the specified OracleIntervalYM value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.
Subtraction(OracleTimeStamp,TimeSpan) | Subtracts the specified System.TimeSpan value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction(OracleTimeStamp,OracleIntervalDS) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Subtraction Operator : Subtraction(OracleTimeStamp,OracleIntervalDS) Operator

value1
The OracleTimeStamp.
value2
The specified OracleIntervalDS.
Subtracts the specified OracleIntervalDS value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator -( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleIntervalDS _
) As OracleTimeStamp
C#
public OracleTimeStamp operator -(
   OracleTimeStamp value1,
   OracleIntervalDS value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified OracleIntervalDS.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction(OracleTimeStamp,OracleIntervalYM) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Subtraction Operator : Subtraction(OracleTimeStamp,OracleIntervalYM) Operator

value1
The OracleTimeStamp.
value2
The specified OracleIntervalYM.
Subtracts the specified OracleIntervalYM value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator -( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As OracleIntervalYM _
) As OracleTimeStamp
C#
public OracleTimeStamp operator -(
   OracleTimeStamp value1,
   OracleIntervalYM value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified OracleIntervalYM.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Subtraction(OracleTimeStamp,TimeSpan) Operator
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleTimeStamp Structure > Subtraction Operator : Subtraction(OracleTimeStamp,TimeSpan) Operator

value1
The OracleTimeStamp.
value2
The specified System.TimeSpan.
Subtracts the specified System.TimeSpan value from the OracleTimeStamp value and returns a new OracleTimeStamp structure.

Syntax

Visual Basic (Declaration)
Overloads Public Operator -( _
   ByVal value1 As OracleTimeStamp, _
   ByVal value2 As TimeSpan _
) As OracleTimeStamp
C#
public OracleTimeStamp operator -(
   OracleTimeStamp value1,
   TimeSpan value2
)

Parameters

value1
The OracleTimeStamp.
value2
The specified System.TimeSpan.

Return Value

A new OracleTimeStamp structure.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleTimeStamp Structure
OracleTimeStamp Members
Overload List


%%ItemTitle%% - Interfaces

Devart.Data.Oracle Namespace - Interfaces
See Also Inheritance Hierarchy support@devart.com

Interfaces

 | Interface | Description
Interface | ICustomOracleArray | Represents an Oracle ARRAY.
Interface | ICustomOracleObject | Represents an Oracle OBJECT.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ICustomOracleArray Interface
Members See Also support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleArray Interface

Represents an Oracle ARRAY.

Syntax

Visual Basic (Declaration)
Public Interface ICustomOracleArray
C#
public interface ICustomOracleArray

Remarks

Implement this interface to build your own representation of Oracle ARRAY.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ICustomOracleArray Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
ICustomOracleArray Interface Members
See Also Methods support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleArray Interface

The following tables list the members exposed by ICustomOracleArray.

Public Methods

 | Name | Description
Method | FromOracleArray | Copies data from an NativeOracleArray instance.
Method | ToOracleArray | Copies data to a new NativeOracleArray instance.
Top

See Also

Reference

ICustomOracleArray Interface
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
ICustomOracleArray Interface Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleArray Interface

For a list of all members of this type, see ICustomOracleArray members.

Public Methods

 | Name | Description
Method | FromOracleArray | Copies data from an NativeOracleArray instance.
Method | ToOracleArray | Copies data to a new NativeOracleArray instance.
Top

See Also

Reference

ICustomOracleArray Interface
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FromOracleArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > ICustomOracleArray Interface : FromOracleArray Method

oraArray
An NativeOracleArray instance to copy data from.
Copies data from an NativeOracleArray instance.

Syntax

Visual Basic (Declaration)
Sub FromOracleArray( _
   ByVal oraArray As NativeOracleArray _
)
C#
void FromOracleArray(
   NativeOracleArray oraArray
)

Parameters

oraArray
An NativeOracleArray instance to copy data from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ICustomOracleArray Interface
ICustomOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToOracleArray Method
See Also support@devart.com
Devart.Data.Oracle Namespace > ICustomOracleArray Interface : ToOracleArray Method

con
An Devart.Data.Oracle.OracleConnection object.
Copies data to a new NativeOracleArray instance.

Syntax

Visual Basic (Declaration)
Function ToOracleArray( _
   ByVal con As OracleConnection _
) As NativeOracleArray
C#
NativeOracleArray ToOracleArray(
   OracleConnection con
)

Parameters

con
An Devart.Data.Oracle.OracleConnection object.

Return Value

A new NativeOracleArray instance filled with data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ICustomOracleArray Interface
ICustomOracleArray Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ICustomOracleObject Interface
Members See Also support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleObject Interface

Represents an Oracle OBJECT.

Syntax

Visual Basic (Declaration)
Public Interface ICustomOracleObject
C#
public interface ICustomOracleObject

Remarks

Implement this interface to build your own representation of Oracle OBJECT.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

ICustomOracleObject Members
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
ICustomOracleObject Interface Members
See Also Methods support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleObject Interface

The following tables list the members exposed by ICustomOracleObject.

Public Methods

 | Name | Description
Method | FromOracleObject | Copies data from an NativeOracleObject instance.
Method | ToOracleObject | Copies data to a new NativeOracleObject instance.
Top

See Also

Reference

ICustomOracleObject Interface
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
ICustomOracleObject Interface Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : ICustomOracleObject Interface

For a list of all members of this type, see ICustomOracleObject members.

Public Methods

 | Name | Description
Method | FromOracleObject | Copies data from an NativeOracleObject instance.
Method | ToOracleObject | Copies data to a new NativeOracleObject instance.
Top

See Also

Reference

ICustomOracleObject Interface
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FromOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > ICustomOracleObject Interface : FromOracleObject Method

oraObject
An NativeOracleObject instance to copy data from.
Copies data from an NativeOracleObject instance.

Syntax

Visual Basic (Declaration)
Sub FromOracleObject( _
   ByVal oraObject As NativeOracleObject _
)
C#
void FromOracleObject(
   NativeOracleObject oraObject
)

Parameters

oraObject
An NativeOracleObject instance to copy data from.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ICustomOracleObject Interface
ICustomOracleObject Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToOracleObject Method
See Also support@devart.com
Devart.Data.Oracle Namespace > ICustomOracleObject Interface : ToOracleObject Method

con
An Devart.Data.Oracle.OracleConnection object.
Copies data to a new NativeOracleObject instance.

Syntax

Visual Basic (Declaration)
Function ToOracleObject( _
   ByVal con As OracleConnection _
) As NativeOracleObject
C#
NativeOracleObject ToOracleObject(
   OracleConnection con
)

Parameters

con
An Devart.Data.Oracle.OracleConnection object.

Return Value

A new NativeOracleObject instance filled with data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ICustomOracleObject Interface
ICustomOracleObject Members


%%ItemTitle%% - Delegates

Devart.Data.Oracle Namespace - Delegates
See Also Inheritance Hierarchy support@devart.com

Delegates

 | Delegate | Description
Delegate | OnChangeEventHandler | Represents the method that will handle the OracleDependency.OnChange event of an OracleDependency.
Delegate | OracleAlerterAlertEventHandler | Represents the method that will handle the OracleAlerter.Alert event of an OracleAlerter.
Delegate | OracleAlerterErrorEventHandler | Represents the method that will handle the OracleAlerter.Error event of an OracleAlerter.
Delegate | OracleAlerterFinishEventHandler | Represents the method that will handle the OracleAlerter.Stopped event of an OracleAlerter.
Delegate | OracleConnectionErrorEventHandler | Represents the method that will handle the OracleConnection.Error event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleFailoverEventHandler | Represents the method that will handle the OracleConnection.Failover event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleHAEventHandler | Represents the method that will handle the OracleConnection.HAEvent event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleInfoMessageEventHandler | Represents the method that will handle the OracleConnection.InfoMessage event of an Devart.Data.Oracle.OracleConnection.
Delegate | OracleLoaderErrorEventHandler | Represents the method that will handle the OracleLoader.Error event of an OracleLoader.
Delegate | OracleLoaderRowsCopiedEventHandler | Represents the method that will handle the OracleLoader.RowsCopied event of an OracleLoader.
Delegate | OracleQueueMessageEventHandler | Represents the method that will handle the OracleQueue.OnMessage event of an OracleQueue.
Delegate | OracleRowUpdatedEventHandler | Represents the method that will handle the OracleDataAdapter.RowUpdated event of an OracleDataAdapter.
Delegate | OracleRowUpdatingEventHandler | Represents the method that will handle the OracleDataAdapter.RowUpdating event of an OracleDataAdapter.
Delegate | SqlStatementExecuteEventHandler | Represents the method that will handle the OracleScript.SqlStatementExecute event of an OracleScript.

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OnChangeEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OnChangeEventHandler Delegate

sender
The source of the event.
eventArgs
An OracleNotificationEventArgs object that contains the event data.
Represents the method that will handle the OnChange event of an OracleDependency.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OnChangeEventHandler( _
   ByVal sender As Object, _
   ByVal eventArgs As OracleNotificationEventArgs _
)
C#
public delegate void OnChangeEventHandler(
   object sender,
   OracleNotificationEventArgs eventArgs
)

Parameters

sender
The source of the event.
eventArgs
An OracleNotificationEventArgs object that contains the event data.

Remarks

When you create an OracleLoaderErrorEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Note: This delegate is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OnChangeEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterAlertEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterAlertEventHandler Delegate

sender
The source of the event.
e
An OracleAlerterAlertEventArgs object that contains the event data.
Represents the method that will handle the Devart.Data.Oracle.OracleAlerter.Alert event of an OracleAlerter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleAlerterAlertEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleAlerterAlertEventArgs _
)
C#
public delegate void OracleAlerterAlertEventHandler(
   object sender,
   OracleAlerterAlertEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleAlerterAlertEventArgs object that contains the event data.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterAlertEventHandler Members
Devart.Data.Oracle Namespace
Alert Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterErrorEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterErrorEventHandler Delegate

sender
The source of the event.
e
An OracleAlerterErrorEventArgs object that contains the event data.
Represents the method that will handle the OracleAlerter.Error event of an OracleAlerter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleAlerterErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleAlerterErrorEventArgs _
)
C#
public delegate void OracleAlerterErrorEventHandler(
   object sender,
   OracleAlerterErrorEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleAlerterErrorEventArgs object that contains the event data.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterErrorEventHandler Members
Devart.Data.Oracle Namespace
Error Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAlerterFinishEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAlerterFinishEventHandler Delegate

sender
The source of the event.
e
An OracleAlerterFinishEventArgs object that contains the event data.
Represents the method that will handle the Devart.Data.Oracle.OracleAlerter.Stopped event of an OracleAlerter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleAlerterFinishEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleAlerterFinishEventArgs _
)
C#
public delegate void OracleAlerterFinishEventHandler(
   object sender,
   OracleAlerterFinishEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleAlerterFinishEventArgs object that contains the event data.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleAlerterFinishEventHandler Members
Devart.Data.Oracle Namespace
Stopped Event


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleConnectionErrorEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleConnectionErrorEventHandler Delegate

sender
The source of the event.
e
An OracleConnectionErrorEventArgs object that contains the event data.
Represents the method that will handle the OracleConnection.Error event of an OracleConnection.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleConnectionErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleConnectionErrorEventArgs _
)
C#
public delegate void OracleConnectionErrorEventHandler(
   object sender,
   OracleConnectionErrorEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleConnectionErrorEventArgs object that contains the event data.

Remarks

When you create an OracleConnectionErrorEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleConnectionErrorEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleFailoverEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleFailoverEventHandler Delegate

sender
The source of the event.
e
An OracleFailoverEventsArgs object that contains the event data.
Represents the method that will handle the OracleConnection.Failover event of an OracleConnection.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleFailoverEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleFailoverEventsArgs _
)
C#
public delegate void OracleFailoverEventHandler(
   object sender,
   OracleFailoverEventsArgs e
)

Parameters

sender
The source of the event.
e
An OracleFailoverEventsArgs object that contains the event data.

Remarks

When you create anOracleFailoverEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleFailoverEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleHAEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleHAEventHandler Delegate

e
An Devart.Data.Oracle.OracleHAEventArgs object that contains the event data.
Represents the method that will handle the OracleConnection.HAEvent event of an OracleConnection.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleHAEventHandler( _
   ByVal e As OracleHAEventArgs _
)
C#
public delegate void OracleHAEventHandler(
   OracleHAEventArgs e
)

Parameters

e
An Devart.Data.Oracle.OracleHAEventArgs object that contains the event data.

Remarks

When you create an Devart.Data.Oracle.OracleHAEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation. Note that you need to set the OracleConnectionStringBuilder.HAEvents connection string parameter to true in order to receive HA events.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleHAEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleInfoMessageEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleInfoMessageEventHandler Delegate

sender
The source of the event.
e
An OracleInfoMessageEventArgs object that contains the event data.
Represents the method that will handle the InfoMessage event of an OracleConnection.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleInfoMessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleInfoMessageEventArgs _
)
C#
public delegate void OracleInfoMessageEventHandler(
   object sender,
   OracleInfoMessageEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleInfoMessageEventArgs object that contains the event data.

Remarks

When you create an OracleInfoMessageEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleInfoMessageEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderErrorEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderErrorEventHandler Delegate

sender
The source of the event.
e
An OracleLoaderErrorEventArgs object that contains the event data.
Represents the method that will handle the Error event of an OracleLoader.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleLoaderErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleLoaderErrorEventArgs _
)
C#
public delegate void OracleLoaderErrorEventHandler(
   object sender,
   OracleLoaderErrorEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleLoaderErrorEventArgs object that contains the event data.

Remarks

When you create an OracleLoaderErrorEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Note: This delegate is available in dotConnect for Oracle Professional and Developer editions only.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderErrorEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleLoaderRowsCopiedEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderRowsCopiedEventHandler Delegate

sender
The source of the event.
e
An OracleLoaderRowsCopiedEventArgs object that contains the event data.
Represents the method that will handle the RowsCopied event of an OracleLoader.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleLoaderRowsCopiedEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleLoaderRowsCopiedEventArgs _
)
C#
public delegate void OracleLoaderRowsCopiedEventHandler(
   object sender,
   OracleLoaderRowsCopiedEventArgs e
)

Parameters

sender
The source of the event.
e
An OracleLoaderRowsCopiedEventArgs object that contains the event data.

Remarks

When you create an OracleLoaderRowsCopiedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Note: This delegate is available in dotConnect for Oracle Professional and Developer editions only.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleLoaderRowsCopiedEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleQueueMessageEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueMessageEventHandler Delegate

sender
The source of the event.
e

An OracleQueueMessageEventArgs object that contains the event data.

Note: This delegate is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Represents the method that will handle the OracleQueue.OnMessage event of an OracleQueue.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleQueueMessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleQueueMessageEventArgs _
)
C#
public delegate void OracleQueueMessageEventHandler(
   object sender,
   OracleQueueMessageEventArgs e
)

Parameters

sender
The source of the event.
e

An OracleQueueMessageEventArgs object that contains the event data.

Note: This delegate is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleQueueMessageEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatedEventHandler Delegate

sender
The source of the event.
e
The OracleRowUpdatedEventArgs object that contains the event data.
Represents the method that will handle the RowUpdated event of an OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleRowUpdatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleRowUpdatedEventArgs _
)
C#
public delegate void OracleRowUpdatedEventHandler(
   object sender,
   OracleRowUpdatedEventArgs e
)

Parameters

sender
The source of the event.
e
The OracleRowUpdatedEventArgs object that contains the event data.

Remarks

The handler is not required to perform any action, and your code should avoid generating exceptions or allowing exceptions to propagate to the calling method. Any exceptions that do reach the caller are ignored. When you create an OracleRowUpdatedEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleRowUpdatedEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleRowUpdatingEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatingEventHandler Delegate

sender
The source of the event.
e
The OracleRowUpdatingEventArgs object that contains the event data.
Represents the method that will handle the OracleDataAdapter.RowUpdating event of an OracleDataAdapter.

Syntax

Visual Basic (Declaration)
Public Delegate Sub OracleRowUpdatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As OracleRowUpdatingEventArgs _
)
C#
public delegate void OracleRowUpdatingEventHandler(
   object sender,
   OracleRowUpdatingEventArgs e
)

Parameters

sender
The source of the event.
e
The OracleRowUpdatingEventArgs object that contains the event data.

Remarks

The handler is not required to perform any action, and your code should avoid generating exceptions or allowing exceptions to propagate to the calling method. Any exceptions that do reach the caller are ignored.

Use the handler to process OracleRowUpdatingEventArgs and to specify how updates are processed. For example, you may opt to skip the update of the current row or skip the update of all remaining rows. Note that the rows are updated in the order that they were received from the data source.

When you create an OracleRowUpdatingEventArgs delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleRowUpdatingEventHandler Members
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SqlStatementExecuteEventHandler Delegate
See Also support@devart.com
Devart.Data.Oracle Namespace : SqlStatementExecuteEventHandler Delegate

sender
The source of the event.
e
An Devart.Data.Oracle.SqlStatementExecuteEventArgs object that contains the event data.
Represents the method that will handle the OracleScript.SqlStatementExecute event of an OracleScript.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SqlStatementExecuteEventHandler( _
   ByVal sender As Object, _
   ByVal e As SqlStatementExecuteEventArgs _
)
C#
public delegate void SqlStatementExecuteEventHandler(
   object sender,
   SqlStatementExecuteEventArgs e
)

Parameters

sender
The source of the event.
e
An Devart.Data.Oracle.SqlStatementExecuteEventArgs object that contains the event data.

Remarks

When you create an Devart.Data.Oracle.SqlStatementExecuteEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate. For more information about event handler delegates, see "Events and Delegates" in the .NET Framework SDK documentation. See a sample in the OracleScript Hints for SQL*Plus Users article.

Requirements

Namespace: Devart.Data.Oracle

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SqlStatementExecuteEventHandler Members
Devart.Data.Oracle Namespace
SqlStatementExecute Event
SqlStatementExecuteEventArgs Class


Devart.Data.Oracle.Synchronization Assembly
See Also support@devart.com

Namespaces

Namespace | Description
Devart.Data.Oracle.Synchronization |


%%ItemTitle%%

Devart.Data.Oracle.Synchronization Namespace
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | OracleSyncDescriptionBuilder | Provides synchronization scope and table information for an Oracle database that is involved in synchronization.
Class | OracleSyncProvider | A synchronization provider for synchronizing Oracle databases.
Class | OracleSyncScopeDeprovisioning | Removes scopes, templates, and other synchronization elements from an Oracle database that was previously provisioned for synchronization.
Class | OracleSyncScopeProvisioning | Represents the provisioning of an Oracle database for a particular scope.
Class | OracleSyncTableProvisioning | Represents the provisioning of an Oracle database table.

See Also

Reference

Devart.Data.Oracle.Synchronization Assembly


%%ItemTitle%% - Classes

Devart.Data.Oracle.Synchronization Namespace - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | OracleSyncDescriptionBuilder | Provides synchronization scope and table information for an Oracle database that is involved in synchronization.
Class | OracleSyncProvider | A synchronization provider for synchronizing Oracle databases.
Class | OracleSyncScopeDeprovisioning | Removes scopes, templates, and other synchronization elements from an Oracle database that was previously provisioned for synchronization.
Class | OracleSyncScopeProvisioning | Represents the provisioning of an Oracle database for a particular scope.
Class | OracleSyncTableProvisioning | Represents the provisioning of an Oracle database table.

See Also

Reference

Devart.Data.Oracle.Synchronization Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncDescriptionBuilder Class
Members See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncDescriptionBuilder Class

Provides synchronization scope and table information for an Oracle database that is involved in synchronization.

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.Synchronization.OracleSyncDescriptionBuilder

Syntax

Visual Basic (Declaration)
Public Class OracleSyncDescriptionBuilder
C#
public class OracleSyncDescriptionBuilder

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSyncDescriptionBuilder Members
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSyncDescriptionBuilder Class Members
See Also Methods support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncDescriptionBuilder Class

The following tables list the members exposed by OracleSyncDescriptionBuilder.

Public Constructors

 | Name | Description
public Constructor | OracleSyncDescriptionBuilder Constructor | Initializes a new instance of the OracleSyncDescriptionBuilder class.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDescriptionForScope | Overloaded. Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.
static (Shared in Visual Basic) | GetDescriptionForTable | Overloaded. Returns a Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.
Top

See Also

Reference

OracleSyncDescriptionBuilder Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncDescriptionBuilder Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class : OracleSyncDescriptionBuilder Constructor

Initializes a new instance of the OracleSyncDescriptionBuilder class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleSyncDescriptionBuilder()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSyncDescriptionBuilder Class Methods
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncDescriptionBuilder Class

For a list of all members of this type, see OracleSyncDescriptionBuilder members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDescriptionForScope | Overloaded. Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.
static (Shared in Visual Basic) | GetDescriptionForTable | Overloaded. Returns a Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.
Top

See Also

Reference

OracleSyncDescriptionBuilder Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForScope Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class : GetDescriptionForScope Method

Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Overload List

Overload | Description
GetDescriptionForScope(String,OracleConnection) | Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.
GetDescriptionForScope(String,String,OracleConnection) | Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.
GetDescriptionForScope(String,String,String,OracleConnection) | Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForScope(String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class > GetDescriptionForScope Method : GetDescriptionForScope(String,OracleConnection) Method

scopeName
The synchronization scope to get description for.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.
Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetDescriptionForScope( _
   ByVal scopeName As String, _
   ByVal connection As OracleConnection _
) As DbSyncScopeDescription
C#
public static DbSyncScopeDescription GetDescriptionForScope(
   string scopeName,
   OracleConnection connection
)

Parameters

scopeName
The synchronization scope to get description for.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.

Return Value

A Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForScope(String,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class > GetDescriptionForScope Method : GetDescriptionForScope(String,String,OracleConnection) Method

scopeName
The synchronization scope to get description for.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.
Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetDescriptionForScope( _
   ByVal scopeName As String, _
   ByVal objectPrefix As String, _
   ByVal connection As OracleConnection _
) As DbSyncScopeDescription
C#
public static DbSyncScopeDescription GetDescriptionForScope(
   string scopeName,
   string objectPrefix,
   OracleConnection connection
)

Parameters

scopeName
The synchronization scope to get description for.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.

Return Value

A Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForScope(String,String,String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class > GetDescriptionForScope Method : GetDescriptionForScope(String,String,String,OracleConnection) Method

scopeName
The synchronization scope to get description for.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
objectSchema
The schema containing Sync Framework metadata objects.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.
Returns a Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetDescriptionForScope( _
   ByVal scopeName As String, _
   ByVal objectPrefix As String, _
   ByVal objectSchema As String, _
   ByVal connection As OracleConnection _
) As DbSyncScopeDescription
C#
public static DbSyncScopeDescription GetDescriptionForScope(
   string scopeName,
   string objectPrefix,
   string objectSchema,
   OracleConnection connection
)

Parameters

scopeName
The synchronization scope to get description for.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
objectSchema
The schema containing Sync Framework metadata objects.
connection
A OracleConnection object that contains a connection to the database with the provisioned synchronization scope to get description for.

Return Value

A Microsoft.Synchronization.Data.DbSyncScopeDescription object that contains information about the specified synchronization scope that is defined for an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForTable Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class : GetDescriptionForTable Method

Returns a Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.

Overload List

Overload | Description
GetDescriptionForTable(String,OracleConnection) | Returns a Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.
GetDescriptionForTable(String,Collection<String>,OracleConnection) |

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForTable(String,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class > GetDescriptionForTable Method : GetDescriptionForTable(String,OracleConnection) Method

tableName
The name of the table to get description for.
connection
A OracleConnection object that contains a connection to the database with the provisioned table to get description for.
Returns a Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetDescriptionForTable( _
   ByVal tableName As String, _
   ByVal connection As OracleConnection _
) As DbSyncTableDescription
C#
public static DbSyncTableDescription GetDescriptionForTable(
   string tableName,
   OracleConnection connection
)

Parameters

tableName
The name of the table to get description for.
connection
A OracleConnection object that contains a connection to the database with the provisioned table to get description for.

Return Value

A Microsoft.Synchronization.Data.DbSyncTableDescription object that contains information about the specified table in an Oracle database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetDescriptionForTable(String,Collection<String>,OracleConnection) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncDescriptionBuilder Class > GetDescriptionForTable Method : GetDescriptionForTable(String,Collection<String>,OracleConnection) Method

tableName
columnNames
connection

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetDescriptionForTable( _
   ByVal tableName As String, _
   ByVal columnNames As Collection(Of String), _
   ByVal connection As OracleConnection _
) As DbSyncTableDescription
C#
public static DbSyncTableDescription GetDescriptionForTable(
   string tableName,
   Collection<string> columnNames,
   OracleConnection connection
)

Parameters

tableName
columnNames
connection

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncDescriptionBuilder Class
OracleSyncDescriptionBuilder Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Class
Members See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncProvider Class

A synchronization provider for synchronizing Oracle databases.

Inheritance Hierarchy

System.Object
Microsoft.Synchronization.SyncProvider
Microsoft.Synchronization.KnowledgeSyncProvider
Microsoft.Synchronization.Data.RelationalSyncProvider
Microsoft.Synchronization.Data.DbSyncProvider
Devart.Data.Synchronization.DbSyncProviderBase
Devart.Data.Oracle.Synchronization.OracleSyncProvider

Syntax

Visual Basic (Declaration)
Public Class OracleSyncProvider
   Inherits Devart.Data.Synchronization.DbSyncProviderBase
   Implements IDisposable
C#
public class OracleSyncProvider : Devart.Data.Synchronization.DbSyncProviderBase, IDisposable

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSyncProvider Members
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncProvider Class

The following tables list the members exposed by OracleSyncProvider.

Public Constructors

 | Name | Description
public Constructor | OracleSyncProvider Constructor | Overloaded. Initializes a new instance of the OracleSyncProvider class.
Top

Public Properties

 | Name | Description
public Property | ApplicationTransactionSize | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | BatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ChangeTracking | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | CleanupBatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Configuration | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Connection | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | DestinationCallbacks | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | IdFormats | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | MemoryDataCacheSize | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.DbSyncProviderBase)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.DbSyncProviderBase)
public Property | ScopeName | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | SelectNewTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectOverlappingScopesCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectTableMaxTimestampsCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncAdapters | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncProviderPosition | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | UpdateScopeCleanupTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | UpdateScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
Top

Public Methods

 | Name | Description
public Method | BeginSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | CleanupMetadata | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | Dispose | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Method | EndSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetScopeDescription | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | GetSyncBatchParameters | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
Top

Public Events

 | Name | Description
public Event | ApplyChangeFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyMetadataFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchSpooled | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesSelected | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | DbConnectionFailure | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SelectingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncPeerOutdated | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncProgress | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
Top

See Also

Reference

OracleSyncProvider Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncProvider Class : OracleSyncProvider Constructor

Initializes a new instance of the OracleSyncProvider class.

Overload List

Overload | Description
OracleSyncProvider Constructor() | Initializes a new instance of the OracleSyncProvider class with default values.
OracleSyncProvider Constructor(String,OracleConnection) | Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name and connection.
OracleSyncProvider Constructor(String,OracleConnection,String) | Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name, connection, and object preffix.
OracleSyncProvider Constructor(String,OracleConnection,String,String) | Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name, connection, object preffix, and object schema.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncProvider Class
OracleSyncProvider Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Constructor()
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncProvider Class > OracleSyncProvider Constructor : OracleSyncProvider Constructor()

Initializes a new instance of the OracleSyncProvider class with default values.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public OracleSyncProvider()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncProvider Class
OracleSyncProvider Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Constructor(String,OracleConnection)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncProvider Class > OracleSyncProvider Constructor : OracleSyncProvider Constructor(String,OracleConnection)

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.
Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name and connection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scopeName As String, _
   ByVal connection As OracleConnection _
)
C#
public OracleSyncProvider(
   string scopeName,
   OracleConnection connection
)

Parameters

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncProvider Class
OracleSyncProvider Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Constructor(String,OracleConnection,String)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncProvider Class > OracleSyncProvider Constructor : OracleSyncProvider Constructor(String,OracleConnection,String)

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name, connection, and object preffix.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scopeName As String, _
   ByVal connection As OracleConnection, _
   ByVal objectPrefix As String _
)
C#
public OracleSyncProvider(
   string scopeName,
   OracleConnection connection,
   string objectPrefix
)

Parameters

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncProvider Class
OracleSyncProvider Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Constructor(String,OracleConnection,String,String)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncProvider Class > OracleSyncProvider Constructor : OracleSyncProvider Constructor(String,OracleConnection,String,String)

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
objectSchema
The schema containing Sync Framework metadata objects.
Initializes a new instance of the OracleSyncProvider class with the specified synchronization scope name, connection, object preffix, and object schema.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scopeName As String, _
   ByVal connection As OracleConnection, _
   ByVal objectPrefix As String, _
   ByVal objectSchema As String _
)
C#
public OracleSyncProvider(
   string scopeName,
   OracleConnection connection,
   string objectPrefix,
   string objectSchema
)

Parameters

scopeName
The name of the scope to synchronize.
connection
The connection to the database to synchronize.
objectPrefix
The preffix for names of Sync Framework metadata objects. Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the scope.
objectSchema
The schema containing Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncProvider Class
OracleSyncProvider Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeDeprovisioning Class
Members See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeDeprovisioning Class

Removes scopes, templates, and other synchronization elements from an Oracle database that was previously provisioned for synchronization.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncScopeDeprovisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeDeprovisioning

Syntax

Visual Basic (Declaration)
Public Class OracleSyncScopeDeprovisioning
   Inherits Devart.Data.Synchronization.SyncScopeDeprovisioning
C#
public class OracleSyncScopeDeprovisioning : Devart.Data.Synchronization.SyncScopeDeprovisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSyncScopeDeprovisioning Members
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeDeprovisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeDeprovisioning Class

The following tables list the members exposed by OracleSyncScopeDeprovisioning.

Public Constructors

 | Name | Description
public Constructor | OracleSyncScopeDeprovisioning Constructor | Initializes a new instance of the OracleSyncScopeDeprovisioning class with the specified connection.
Top

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
Top

Public Methods

 | Name | Description
public Method | DeprovisionScope | Deprovisions the specified scope by removing all associated synchronization elements from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | DeprovisionStore | Removes all Sync Framework metadata tables, triggers, and stored procedures from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | DeprovisionTemplate | Deprovisions the specified template and all scopes that were created from the specified template by removing all associated synchronization elements from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionScope | Generates a script that can be used to deprovision a scope. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionStore | Generates a script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionTemplate | Generates a script that can be used to deprovision a template and all scopes that were created from that template. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
Top

See Also

Reference

OracleSyncScopeDeprovisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeDeprovisioning Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeDeprovisioning Class : OracleSyncScopeDeprovisioning Constructor

connection
A connection to perform the deprovisioning operation over.
Initializes a new instance of the OracleSyncScopeDeprovisioning class with the specified connection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection _
)
C#
public OracleSyncScopeDeprovisioning(
   OracleConnection connection
)

Parameters

connection
A connection to perform the deprovisioning operation over.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeDeprovisioning Class
OracleSyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Class
Members See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeProvisioning Class

Represents the provisioning of an Oracle database for a particular scope.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncScopeProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeProvisioning

Syntax

Visual Basic (Declaration)
Public Class OracleSyncScopeProvisioning
   Inherits Devart.Data.Synchronization.SyncScopeProvisioning
C#
public class OracleSyncScopeProvisioning : Devart.Data.Synchronization.SyncScopeProvisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSyncScopeProvisioning Members
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeProvisioning Class

The following tables list the members exposed by OracleSyncScopeProvisioning.

Public Constructors

 | Name | Description
public Constructor | OracleSyncScopeProvisioning Constructor | Overloaded. Initializes a new instance of the OracleSyncScopeProvisioning class.
Top

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ScopeName | Gets the name of the scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | Tables | Gets a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | UserComment | Gets or sets the user-specified comment about the scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
Top

Public Methods

 | Name | Description
public Method | Apply | Applies the provisioning script to a database by using the connection that was specified in the constructor. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | PopulateFromScopeDescription | Sets the scope description from which the database should be provisioned. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | PopulateFromTemplate | Sets the template-based scope description from which the database should be provisioned. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | ScopeExists | Indicates whether the specified scope exists in the database, the connection, specified in the constructor. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | Script | Generates the SQL script to provision the database for a particular scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateProceduresDefault | Specifies whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateProceduresForAdditionalScopeDefault | Specifies whether to create additional stored procedures for a scope that contains tables that have already been provisioned for other scopes. For example, this scope adds a filter column to a table that has already been provisioned without the filter column. Set this option to Create to ensure that an additional change enumeration procedure is created that can handle the filter column. The default setting is Skip. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTableDefault | Specifies whether to create tables that store user data to synchronize. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTrackingTableDefault | Specifies whether to create tables that store change-tracking metadata. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTriggersDefault | Specifies whether to create the triggers (on synchronized tables) that update tracking tables. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetPopulateTrackingTableDefault | Specifies whether to insert metadata into change-tracking tables for rows that already exist in the provisioned tables. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | TemplateExists | Indicates whether the specified template exists in the database. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
Top

See Also

Reference

OracleSyncScopeProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeProvisioning Class : OracleSyncScopeProvisioning Constructor

Initializes a new instance of the OracleSyncScopeProvisioning class.

Overload List

Overload | Description
OracleSyncScopeProvisioning Constructor(OracleConnection) | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection.
OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription) | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and sychronization scope description.
OracleSyncScopeProvisioning Constructor(OracleConnection,SyncScopeProvisioningType) | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and provisioning type.
OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription,SyncScopeProvisioningType) | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection, sychronization scope description, and provisioning type.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeProvisioning Class
OracleSyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Constructor(OracleConnection)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeProvisioning Class > OracleSyncScopeProvisioning Constructor : OracleSyncScopeProvisioning Constructor(OracleConnection)

connection
A connection to perform the provisioning operation over.
Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection _
)
C#
public OracleSyncScopeProvisioning(
   OracleConnection connection
)

Parameters

connection
A connection to perform the provisioning operation over.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeProvisioning Class
OracleSyncScopeProvisioning Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeProvisioning Class > OracleSyncScopeProvisioning Constructor : OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription)

connection
A connection to perform the provisioning operation over.
scopeDescription
The description of the scope to provision.
Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and sychronization scope description.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal scopeDescription As DbSyncScopeDescription _
)
C#
public OracleSyncScopeProvisioning(
   OracleConnection connection,
   DbSyncScopeDescription scopeDescription
)

Parameters

connection
A connection to perform the provisioning operation over.
scopeDescription
The description of the scope to provision.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeProvisioning Class
OracleSyncScopeProvisioning Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Constructor(OracleConnection,SyncScopeProvisioningType)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeProvisioning Class > OracleSyncScopeProvisioning Constructor : OracleSyncScopeProvisioning Constructor(OracleConnection,SyncScopeProvisioningType)

connection
A connection to perform the provisioning operation over.
provisioningType
The kind of provisioning that this object will perform - scope provisioning or template provisioning.
Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and provisioning type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal provisioningType As SyncScopeProvisioningType _
)
C#
public OracleSyncScopeProvisioning(
   OracleConnection connection,
   SyncScopeProvisioningType provisioningType
)

Parameters

connection
A connection to perform the provisioning operation over.
provisioningType
The kind of provisioning that this object will perform - scope provisioning or template provisioning.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeProvisioning Class
OracleSyncScopeProvisioning Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription,SyncScopeProvisioningType)
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncScopeProvisioning Class > OracleSyncScopeProvisioning Constructor : OracleSyncScopeProvisioning Constructor(OracleConnection,DbSyncScopeDescription,SyncScopeProvisioningType)

connection
A connection to perform the provisioning operation over.
scopeDescription
The description of the scope to provision.
provisioningType
The kind of provisioning that this object will perform - scope provisioning or template provisioning.
Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection, sychronization scope description, and provisioning type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal scopeDescription As DbSyncScopeDescription, _
   ByVal provisioningType As SyncScopeProvisioningType _
)
C#
public OracleSyncScopeProvisioning(
   OracleConnection connection,
   DbSyncScopeDescription scopeDescription,
   SyncScopeProvisioningType provisioningType
)

Parameters

connection
A connection to perform the provisioning operation over.
scopeDescription
The description of the scope to provision.
provisioningType
The kind of provisioning that this object will perform - scope provisioning or template provisioning.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncScopeProvisioning Class
OracleSyncScopeProvisioning Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Class
Members See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncTableProvisioning Class

Represents the provisioning of an Oracle database table.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncTableProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncTableProvisioning

Syntax

Visual Basic (Declaration)
Public Class OracleSyncTableProvisioning
   Inherits Devart.Data.Synchronization.SyncTableProvisioning
C#
public class OracleSyncTableProvisioning : Devart.Data.Synchronization.SyncTableProvisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Oracle.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

OracleSyncTableProvisioning Members
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncTableProvisioning Class

The following tables list the members exposed by OracleSyncTableProvisioning.

Public Constructors

 | Name | Description
public Constructor | OracleSyncTableProvisioning Constructor | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and table description.
Top

Public Properties

 | Name | Description
public Property | CreateProcedures | Determines whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateProceduresForAdditionalScope | Determines whether to create sets of stored procedures that insert, update, and delete data and synchronization metadata for any additional scopes. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTable | Determines whether to create the table that is synchronized. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTrackingTable | Determines whether to create the table that store change-tracking metadata for the synchronized table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTriggers | Determines whether to create the triggers on the provisioned table, that update tracking the table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterColumns | Gets the list of columns that are used for filtering data. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | GlobalName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | LocalName | Gets or sets the name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | PopulateTrackingTable | Specifies whether to insert metadata into the change-tracking table for rows that already exist in the provisioned table. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | UnquotedGlobalName | Gets or sets the name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | UnquotedLocalName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
Top

Public Methods

 | Name | Description
public Method | AddFilterColumn | Adds a column that is used in the Devart.Data.Synchronization.SyncTableProvisioning.FilterClause to filter data rows for synchronization. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Method | Apply | Overloaded. Applies the provisioning script to a database.
public Method | Script | Generates the SQL script to provision the table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
Top

See Also

Reference

OracleSyncTableProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncTableProvisioning Class : OracleSyncTableProvisioning Constructor

connection
A connection to perform the provisioning operation over.
tableDescription
The description of the table to provision.
Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and table description.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal connection As OracleConnection, _
   ByVal tableDescription As DbSyncTableDescription _
)
C#
public OracleSyncTableProvisioning(
   OracleConnection connection,
   DbSyncTableDescription tableDescription
)

Parameters

connection
A connection to perform the provisioning operation over.
tableDescription
The description of the table to provision.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncTableProvisioning Class
OracleSyncTableProvisioning Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Class Methods
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncTableProvisioning Class

For a list of all members of this type, see OracleSyncTableProvisioning members.

Public Methods

 | Name | Description
public Method | AddFilterColumn | Adds a column that is used in the Devart.Data.Synchronization.SyncTableProvisioning.FilterClause to filter data rows for synchronization. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Method | Apply | Overloaded. Applies the provisioning script to a database.
public Method | Script | Generates the SQL script to provision the table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
Top

See Also

Reference

OracleSyncTableProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Apply Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncTableProvisioning Class : Apply Method

Applies the provisioning script to a database.

Overload List

Overload | Description
Apply(OracleTransaction) | Applies the provisioning script to an Oracle database within the specified transaction.
Apply() | Applies the provisioning script to a database. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncTableProvisioning Class
OracleSyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Apply(OracleTransaction) Method
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncTableProvisioning Class > Apply Method : Apply(OracleTransaction) Method

transaction
The transaction object to use for the provisioning operation.
Applies the provisioning script to an Oracle database within the specified transaction.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Apply( _
   ByVal transaction As OracleTransaction _
)
C#
public void Apply(
   OracleTransaction transaction
)

Parameters

transaction
The transaction object to use for the provisioning operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncTableProvisioning Class
OracleSyncTableProvisioning Members
Overload List


Devart.Data.Synchronization Assembly
See Also support@devart.com

Namespaces

Namespace | Description
Devart.Data.Synchronization |


%%ItemTitle%%

Devart.Data.Synchronization Namespace
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbSyncProviderBase | Base class for OracleSyncProvider.
Class | SyncProviderAdapterConfiguration | Represents synchronization adapter configuration for a table in a database.
Class | SyncProviderAdapterConfigurationCollection | Represents a collection of SyncProviderAdapterConfiguration objects.
Class | SyncProviderAdapterParameters | Represents a set of filter template parameters and the name of their associated table.
Class | SyncProviderAdapterParametersCollection | Represents the collection of filter template parameter sets that are associated with the database tables used by this adapter.
Class | SyncProviderFilterParameter | Represents a filter template parameter with its value.
Class | SyncProviderScopeConfiguration | Represents configuration information that is used by OracleSyncProvider for a particular scope.
Class | SyncProviderScopeParameters | Represents the collection of parameter sets associated with all of the tables in the scope.
Class | SyncScopeDeprovisioning | Removes scopes, templates, and other synchronization elements from a database that was previously provisioned for synchronization.
Class | SyncScopeProvisioning | Represents the provisioning of a database for a particular scope.
Class | SyncSqlParameterCollection | Represents a collection of System.Data.Common.DbParameter objects that can be indexed by the name of the parameter.
Class | SyncTableProvisioning | Represents the provisioning of a database table.
Class | SyncTableProvisioningCollection | Represents a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that can be indexed by the name of the table to provision.

Enumerations

 | Enumeration | Description
Enumeration | SyncScopeProvisioningType | Defines the kind of provisioning.

See Also

Reference

Devart.Data.Synchronization Assembly


%%ItemTitle%% - Classes

Devart.Data.Synchronization Namespace - Classes
See Also Inheritance Hierarchy support@devart.com

Classes

 | Class | Description
Class | DbSyncProviderBase | Base class for OracleSyncProvider.
Class | SyncProviderAdapterConfiguration | Represents synchronization adapter configuration for a table in a database.
Class | SyncProviderAdapterConfigurationCollection | Represents a collection of SyncProviderAdapterConfiguration objects.
Class | SyncProviderAdapterParameters | Represents a set of filter template parameters and the name of their associated table.
Class | SyncProviderAdapterParametersCollection | Represents the collection of filter template parameter sets that are associated with the database tables used by this adapter.
Class | SyncProviderFilterParameter | Represents a filter template parameter with its value.
Class | SyncProviderScopeConfiguration | Represents configuration information that is used by OracleSyncProvider for a particular scope.
Class | SyncProviderScopeParameters | Represents the collection of parameter sets associated with all of the tables in the scope.
Class | SyncScopeDeprovisioning | Removes scopes, templates, and other synchronization elements from a database that was previously provisioned for synchronization.
Class | SyncScopeProvisioning | Represents the provisioning of a database for a particular scope.
Class | SyncSqlParameterCollection | Represents a collection of System.Data.Common.DbParameter objects that can be indexed by the name of the parameter.
Class | SyncTableProvisioning | Represents the provisioning of a database table.
Class | SyncTableProvisioningCollection | Represents a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that can be indexed by the name of the table to provision.

See Also

Reference

Devart.Data.Synchronization Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DbSyncProviderBase Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : DbSyncProviderBase Class

Base class for OracleSyncProvider.

Inheritance Hierarchy

System.Object
Microsoft.Synchronization.SyncProvider
Microsoft.Synchronization.KnowledgeSyncProvider
Microsoft.Synchronization.Data.RelationalSyncProvider
Microsoft.Synchronization.Data.DbSyncProvider
Devart.Data.Synchronization.DbSyncProviderBase
Devart.Data.Oracle.Synchronization.OracleSyncProvider

Syntax

Visual Basic (Declaration)
Public MustInherit Class DbSyncProviderBase
   Inherits Microsoft.Synchronization.Data.DbSyncProvider
   Implements IDisposable
C#
public abstract class DbSyncProviderBase : Microsoft.Synchronization.Data.DbSyncProvider, IDisposable

Remarks

Abstract DbSyncProviderBase class implements some of OracleSyncProvider functionality that is DBMS-independent.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

DbSyncProviderBase Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
DbSyncProviderBase Class Members
See Also Properties Methods Events support@devart.com
Devart.Data.Synchronization Namespace : DbSyncProviderBase Class

The following tables list the members exposed by DbSyncProviderBase.

Public Properties

 | Name | Description
public Property | ApplicationTransactionSize | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | BatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ChangeTracking | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | CleanupBatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Configuration | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Connection | Overridden. Sets the connection to the database.
public Property | DestinationCallbacks | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | IdFormats | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | MemoryDataCacheSize | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | ScopeName | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | SelectNewTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectOverlappingScopesCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectTableMaxTimestampsCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncAdapters | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncProviderPosition | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | UpdateScopeCleanupTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | UpdateScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
Top

Public Methods

 | Name | Description
public Method | BeginSession | Overridden. This method is called by the Microsoft.Synchronization.SyncOrchestrator class to indicate that a synchronization session has started.
public Method | CleanupMetadata | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | Dispose | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Method | EndSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetScopeDescription | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | GetSyncBatchParameters | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
Top

Public Events

 | Name | Description
public Event | ApplyChangeFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyMetadataFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchSpooled | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesSelected | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | DbConnectionFailure | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SelectingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncPeerOutdated | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncProgress | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
Top

See Also

Reference

DbSyncProviderBase Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbSyncProviderBase Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : DbSyncProviderBase Class

For a list of all members of this type, see DbSyncProviderBase members.

Public Methods

 | Name | Description
public Method | BeginSession | Overridden. This method is called by the Microsoft.Synchronization.SyncOrchestrator class to indicate that a synchronization session has started.
public Method | CleanupMetadata | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | Dispose | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Method | EndSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetScopeDescription | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | GetSyncBatchParameters | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
Top

See Also

Reference

DbSyncProviderBase Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
BeginSession Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > DbSyncProviderBase Class : BeginSession Method

position
Determines whether the provider is associated with the local or remote database.
syncSessionContext
A Microsoft.Synchronization.SyncSessionContext object containing the information about the current synchronization session.
This method is called by the Microsoft.Synchronization.SyncOrchestrator class to indicate that a synchronization session has started.

Syntax

Visual Basic (Declaration)
Public Overrides Sub BeginSession( _
   ByVal position As SyncProviderPosition, _
   ByVal syncSessionContext As SyncSessionContext _
)
C#
public override void BeginSession(
   SyncProviderPosition position,
   SyncSessionContext syncSessionContext
)

Parameters

position
Determines whether the provider is associated with the local or remote database.
syncSessionContext
A Microsoft.Synchronization.SyncSessionContext object containing the information about the current synchronization session.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbSyncProviderBase Class
DbSyncProviderBase Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbSyncProviderBase Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : DbSyncProviderBase Class

For a list of all members of this type, see DbSyncProviderBase members.

Public Properties

 | Name | Description
public Property | ApplicationTransactionSize | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | BatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ChangeTracking | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | CleanupBatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Configuration | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Connection | Overridden. Sets the connection to the database.
public Property | DestinationCallbacks | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | IdFormats | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | MemoryDataCacheSize | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | ScopeName | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | SelectNewTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectOverlappingScopesCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectTableMaxTimestampsCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncAdapters | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncProviderPosition | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | UpdateScopeCleanupTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | UpdateScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
Top

See Also

Reference

DbSyncProviderBase Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Connection Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > DbSyncProviderBase Class : Connection Property

Sets the connection to the database.

Syntax

Visual Basic (Declaration)
Public Overrides WriteOnly Property Connection As IDbConnection
C#
public override IDbConnection Connection {set;}

Property Value

The connection to the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbSyncProviderBase Class
DbSyncProviderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectPrefix Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > DbSyncProviderBase Class : ObjectPrefix Property

Gets or sets the optional preffix for names of Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefix As String
C#
public string ObjectPrefix {get; set;}

Property Value

The preffix for names of Sync Framework metadata objects.

Remarks

Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbSyncProviderBase Class
DbSyncProviderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectSchema Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > DbSyncProviderBase Class : ObjectSchema Property

Gets or sets the schema containing Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema {get; set;}

Property Value

The schema containing Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbSyncProviderBase Class
DbSyncProviderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfiguration Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfiguration Class

Represents synchronization adapter configuration for a table in a database.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderAdapterConfiguration

Syntax

Visual Basic (Declaration)
Public Class SyncProviderAdapterConfiguration
C#
public class SyncProviderAdapterConfiguration

Remarks

Sync Framework uses this class to create a Microsoft.Synchronization.Data.DbSyncAdapter object for each table that is provisioned for synchronization.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderAdapterConfiguration Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfiguration Class Members
See Also Properties support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfiguration Class

The following tables list the members exposed by SyncProviderAdapterConfiguration.

Public Constructors

 | Name | Description
public Constructor | SyncProviderAdapterConfiguration Constructor | Initializes a new instance of the SyncProviderAdapterConfiguration class.
Top

Public Properties

 | Name | Description
public Property | Columns | Gets the collection of Microsoft.Synchronization.Data.DbSyncColumnDescription objects, representing all columns in a table.
public Property | DeleteMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to delete metadata from a tracking table.
public Property | DeleteProcName | Gets or sets the name of the stored procedure that Sync Framework uses to delete data from a synchronized table during synchronization.
public Property | DeleteTriggerName | Gets or sets the name of the delete trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter data to be synchronized.
public Property | FilterColumns | Gets the list of columns that are used for filtering data.
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.
public Property | GlobalTableName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | InsertMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to insert metadata into a tracking table.
public Property | InsertProcName | Gets or sets the name of the stored procedure that Sync Framework uses to insert data into a synchronized table during synchronization.
public Property | InsertTriggerName | Gets or sets the name of the insert trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.
public Property | SelectRowProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select conflicting rows from a synchronized table during synchronization.
public Property | TableName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
public Property | TrackingTableName | Gets the name, not including database-specific delimiters, of the tracking table for a specific table that is synchronized.
public Property | TrackingTableNameShort | Gets the name of the tracking table for a specific table that is synchronized, not including database-specific delimiters and the name of the schema.
public Property | UnmappedElements | Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.
public Property | UpdateMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to update metadata in a tracking table.
public Property | UpdateProcName | Gets or sets the name of the stored procedure that Sync Framework uses to update data in a synchronized table during synchronization.
public Property | UpdateTriggerName | Gets or sets the name of the update trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
Top

See Also

Reference

SyncProviderAdapterConfiguration Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfiguration Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : SyncProviderAdapterConfiguration Constructor

Initializes a new instance of the SyncProviderAdapterConfiguration class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderAdapterConfiguration()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfiguration Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfiguration Class

For a list of all members of this type, see SyncProviderAdapterConfiguration members.

Public Properties

 | Name | Description
public Property | Columns | Gets the collection of Microsoft.Synchronization.Data.DbSyncColumnDescription objects, representing all columns in a table.
public Property | DeleteMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to delete metadata from a tracking table.
public Property | DeleteProcName | Gets or sets the name of the stored procedure that Sync Framework uses to delete data from a synchronized table during synchronization.
public Property | DeleteTriggerName | Gets or sets the name of the delete trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter data to be synchronized.
public Property | FilterColumns | Gets the list of columns that are used for filtering data.
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.
public Property | GlobalTableName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | InsertMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to insert metadata into a tracking table.
public Property | InsertProcName | Gets or sets the name of the stored procedure that Sync Framework uses to insert data into a synchronized table during synchronization.
public Property | InsertTriggerName | Gets or sets the name of the insert trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.
public Property | SelectRowProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select conflicting rows from a synchronized table during synchronization.
public Property | TableName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
public Property | TrackingTableName | Gets the name, not including database-specific delimiters, of the tracking table for a specific table that is synchronized.
public Property | TrackingTableNameShort | Gets the name of the tracking table for a specific table that is synchronized, not including database-specific delimiters and the name of the schema.
public Property | UnmappedElements | Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.
public Property | UpdateMetadataProcName | Gets or sets the name of the stored procedure that Sync Framework uses to update metadata in a tracking table.
public Property | UpdateProcName | Gets or sets the name of the stored procedure that Sync Framework uses to update data in a synchronized table during synchronization.
public Property | UpdateTriggerName | Gets or sets the name of the update trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.
Top

See Also

Reference

SyncProviderAdapterConfiguration Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Columns Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : Columns Property

Gets the collection of Microsoft.Synchronization.Data.DbSyncColumnDescription objects, representing all columns in a table.

Syntax

Visual Basic (Declaration)
Public Property Columns As Collection(Of DbSyncColumnDescription)
C#
public Collection<DbSyncColumnDescription> Columns {get; set;}

Property Value

The collection of Microsoft.Synchronization.Data.DbSyncColumnDescription objects, representing all columns in a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteMetadataProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : DeleteMetadataProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to delete metadata from a tracking table.

Syntax

Visual Basic (Declaration)
Public Property DeleteMetadataProcName As String
C#
public string DeleteMetadataProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to delete metadata from a tracking table.

Remarks

Default value is "TableName_deletemetadata", where TableName stands for the name of the provisioned table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : DeleteProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to delete data from a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property DeleteProcName As String
C#
public string DeleteProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to delete data from a synchronized table during synchronization.

Remarks

Default value is "TableName_delete", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeleteTriggerName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : DeleteTriggerName Property

Gets or sets the name of the delete trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Syntax

Visual Basic (Declaration)
Public Property DeleteTriggerName As String
C#
public string DeleteTriggerName {get; set;}

Property Value

The name of the delete trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Remarks

Default value is "TableName_delete_trigger", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterClause Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : FilterClause Property

Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter data to be synchronized.

Syntax

Visual Basic (Declaration)
Public Property FilterClause As String
C#
public string FilterClause {get; set;}

Property Value

The filter condition (a WHERE clause without the WHERE keyword) to filter data to be synchronized.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterColumns Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : FilterColumns Property

Gets the list of columns that are used for filtering data.

Syntax

Visual Basic (Declaration)
Public Property FilterColumns As Collection(Of String)
C#
public Collection<string> FilterColumns {get; set;}

Property Value

The list of columns that are used for filtering data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterParameters Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : FilterParameters Property

Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.

Syntax

Visual Basic (Declaration)
Public Property FilterParameters As Collection(Of SyncProviderFilterParameter)
C#
public Collection<SyncProviderFilterParameter> FilterParameters {get; set;}

Property Value

The collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GlobalTableName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : GlobalTableName Property

Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Syntax

Visual Basic (Declaration)
Public Property GlobalTableName As String
C#
public string GlobalTableName {get; set;}

Property Value

The name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertMetadataProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : InsertMetadataProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to insert metadata into a tracking table.

Syntax

Visual Basic (Declaration)
Public Property InsertMetadataProcName As String
C#
public string InsertMetadataProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to insert metadata into a tracking table.

Remarks

Default value is "TableName_insertmetadata", where TableName stands for the name of the provisioned table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : InsertProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to insert data into a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property InsertProcName As String
C#
public string InsertProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to insert data into a synchronized table during synchronization.

Remarks

Default value is "TableName_delete", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
InsertTriggerName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : InsertTriggerName Property

Gets or sets the name of the insert trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Syntax

Visual Basic (Declaration)
Public Property InsertTriggerName As String
C#
public string InsertTriggerName {get; set;}

Property Value

The name of the insert trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Remarks

Default value is "TableName_insert_trigger", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectChangesProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : SelectChangesProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property SelectChangesProcName As String
C#
public string SelectChangesProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.

Remarks

Default value is "TableName_selectchanges", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectRowProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : SelectRowProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to select conflicting rows from a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property SelectRowProcName As String
C#
public string SelectRowProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to select conflicting rows from a synchronized table during synchronization.

Remarks

Default value is "TableName_selectrow", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : TableName Property

Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName {get; set;}

Property Value

The name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TrackingTableName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : TrackingTableName Property

Gets the name, not including database-specific delimiters, of the tracking table for a specific table that is synchronized.

Syntax

Visual Basic (Declaration)
Public Property TrackingTableName As String
C#
public string TrackingTableName {get; set;}

Property Value

The name, not including database-specific delimiters, of the tracking table for a specific table that is synchronized.

Remarks

Default value is "TableName_tracking", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TrackingTableNameShort Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : TrackingTableNameShort Property

Gets the name of the tracking table for a specific table that is synchronized, not including database-specific delimiters and the name of the schema.

Syntax

Visual Basic (Declaration)
Public Property TrackingTableNameShort As String
C#
public string TrackingTableNameShort {get; set;}

Property Value

The name of the tracking table for a specific table that is synchronized, not including database-specific delimiters and the name of the schema.

Remarks

Default value is "TableName_tracking", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnmappedElements Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : UnmappedElements Property

Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.

Syntax

Visual Basic (Declaration)
Public Property UnmappedElements As XmlElement()
C#
public XmlElement[] UnmappedElements {get; set;}

Property Value

The array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateMetadataProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : UpdateMetadataProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to update metadata in a tracking table.

Syntax

Visual Basic (Declaration)
Public Property UpdateMetadataProcName As String
C#
public string UpdateMetadataProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to update metadata in a tracking table.

Remarks

Default value is "TableName_updatemetadata", where TableName stands for the name of the provisioned table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : UpdateProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to update data in a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property UpdateProcName As String
C#
public string UpdateProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to update data in a synchronized table during synchronization.

Remarks

Default value is "TableName_update", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UpdateTriggerName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfiguration Class : UpdateTriggerName Property

Gets or sets the name of the update trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Syntax

Visual Basic (Declaration)
Public Property UpdateTriggerName As String
C#
public string UpdateTriggerName {get; set;}

Property Value

The name of the update trigger that Sync Framework creates on a synchronized table to update metadata in a tracking table.

Remarks

Default value is "TableName_update_trigger", where TableName stands for the name of the synchronized table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfiguration Class
SyncProviderAdapterConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfigurationCollection Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfigurationCollection Class

Represents a collection of SyncProviderAdapterConfiguration objects.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Devart.Data.Synchronization.SyncProviderAdapterConfigurationCollection

Syntax

Visual Basic (Declaration)
Public Class SyncProviderAdapterConfigurationCollection
   Inherits System.Collections.ObjectModel.Collection(Of SyncProviderAdapterConfiguration)
   Implements ICollection(Of SyncProviderAdapterConfiguration), IEnumerable(Of SyncProviderAdapterConfiguration), IList(Of SyncProviderAdapterConfiguration), ICollection, IEnumerable, IList
C#
public class SyncProviderAdapterConfigurationCollection : System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>, ICollection<SyncProviderAdapterConfiguration>, IEnumerable<SyncProviderAdapterConfiguration>, IList<SyncProviderAdapterConfiguration>, ICollection, IEnumerable, IList

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderAdapterConfigurationCollection Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfigurationCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfigurationCollection Class

The following tables list the members exposed by SyncProviderAdapterConfigurationCollection.

Public Constructors

 | Name | Description
public Constructor | SyncProviderAdapterConfigurationCollection Constructor | Initializes a new instance of the SyncProviderAdapterConfigurationCollection class.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Property | Item | An indexer property that gets the SyncProviderAdapterConfiguration object that is associated with the specified table.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
Top

See Also

Reference

SyncProviderAdapterConfigurationCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfigurationCollection Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfigurationCollection Class : SyncProviderAdapterConfigurationCollection Constructor

Initializes a new instance of the SyncProviderAdapterConfigurationCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderAdapterConfigurationCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfigurationCollection Class
SyncProviderAdapterConfigurationCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfigurationCollection Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfigurationCollection Class

For a list of all members of this type, see SyncProviderAdapterConfigurationCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Property | Item | An indexer property that gets the SyncProviderAdapterConfiguration object that is associated with the specified table.
Top

See Also

Reference

SyncProviderAdapterConfigurationCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterConfigurationCollection Class : Item Property

globalTableName
The name of the table to look up.
An indexer property that gets the SyncProviderAdapterConfiguration object that is associated with the specified table.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Default Property Item( _
   ByVal globalTableName As String _
) As SyncProviderAdapterConfiguration
C#
public new SyncProviderAdapterConfiguration this(
   string globalTableName
) {get;}

Parameters

globalTableName
The name of the table to look up.

Property Value

The SyncProviderAdapterConfiguration object that is associated with globalTableName. Null if the specified table is not found.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterConfigurationCollection Class
SyncProviderAdapterConfigurationCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParameters Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParameters Class

Represents a set of filter template parameters and the name of their associated table.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderAdapterParameters

Syntax

Visual Basic (Declaration)
Public Class SyncProviderAdapterParameters
C#
public class SyncProviderAdapterParameters

Remarks

This class is primarily used by Sync Framework for XML serialization.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderAdapterParameters Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParameters Class Members
See Also Properties support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParameters Class

The following tables list the members exposed by SyncProviderAdapterParameters.

Public Constructors

 | Name | Description
public Constructor | SyncProviderAdapterParameters Constructor | Initializes a new instance of the SyncProviderAdapterParameters class.
Top

Public Properties

 | Name | Description
public Property | FilterParameters | Gets the collection of filter template parameters for the associated table, specified in TableName.
public Property | TableName | Gets or sets the name of the database table that is associated with these parameters.
Top

See Also

Reference

SyncProviderAdapterParameters Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParameters Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterParameters Class : SyncProviderAdapterParameters Constructor

Initializes a new instance of the SyncProviderAdapterParameters class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderAdapterParameters()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterParameters Class
SyncProviderAdapterParameters Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParameters Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParameters Class

For a list of all members of this type, see SyncProviderAdapterParameters members.

Public Properties

 | Name | Description
public Property | FilterParameters | Gets the collection of filter template parameters for the associated table, specified in TableName.
public Property | TableName | Gets or sets the name of the database table that is associated with these parameters.
Top

See Also

Reference

SyncProviderAdapterParameters Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterParameters Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterParameters Class : FilterParameters Property

Gets the collection of filter template parameters for the associated table, specified in TableName.

Syntax

Visual Basic (Declaration)
Public Property FilterParameters As Collection(Of SyncProviderFilterParameter)
C#
public Collection<SyncProviderFilterParameter> FilterParameters {get; set;}

Property Value

The collection of filter template parameters for the associated table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterParameters Class
SyncProviderAdapterParameters Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TableName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterParameters Class : TableName Property

Gets or sets the name of the database table that is associated with these parameters.

Syntax

Visual Basic (Declaration)
Public Property TableName As String
C#
public string TableName {get; set;}

Property Value

The name of the database table that is associated with these parameters.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterParameters Class
SyncProviderAdapterParameters Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParametersCollection Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParametersCollection Class

Represents the collection of filter template parameter sets that are associated with the database tables used by this adapter.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Devart.Data.Synchronization.SyncProviderAdapterParametersCollection

Syntax

Visual Basic (Declaration)
Public Class SyncProviderAdapterParametersCollection
   Inherits System.Collections.ObjectModel.Collection(Of SyncProviderAdapterParameters)
   Implements ICollection(Of SyncProviderAdapterParameters), IEnumerable(Of SyncProviderAdapterParameters), IList(Of SyncProviderAdapterParameters), ICollection, IEnumerable, IList
C#
public class SyncProviderAdapterParametersCollection : System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>, ICollection<SyncProviderAdapterParameters>, IEnumerable<SyncProviderAdapterParameters>, IList<SyncProviderAdapterParameters>, ICollection, IEnumerable, IList

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderAdapterParametersCollection Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParametersCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParametersCollection Class

The following tables list the members exposed by SyncProviderAdapterParametersCollection.

Public Constructors

 | Name | Description
public Constructor | SyncProviderAdapterParametersCollection Constructor | Initializes a new instance of the SyncProviderAdapterParametersCollection class.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Property | Item | An indexer property that gets the SyncProviderAdapterParameters object that is associated with the specified table.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
Top

See Also

Reference

SyncProviderAdapterParametersCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParametersCollection Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterParametersCollection Class : SyncProviderAdapterParametersCollection Constructor

Initializes a new instance of the SyncProviderAdapterParametersCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderAdapterParametersCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterParametersCollection Class
SyncProviderAdapterParametersCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParametersCollection Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParametersCollection Class

For a list of all members of this type, see SyncProviderAdapterParametersCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Property | Item | An indexer property that gets the SyncProviderAdapterParameters object that is associated with the specified table.
Top

See Also

Reference

SyncProviderAdapterParametersCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderAdapterParametersCollection Class : Item Property

tableName
The name of the table to look up.
An indexer property that gets the SyncProviderAdapterParameters object that is associated with the specified table.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Default Property Item( _
   ByVal tableName As String _
) As SyncProviderAdapterParameters
C#
public new SyncProviderAdapterParameters this(
   string tableName
) {get;}

Parameters

tableName
The name of the table to look up.

Property Value

The SyncProviderAdapterParameters object that is associated with the table name. Null if the specified table is not found.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderAdapterParametersCollection Class
SyncProviderAdapterParametersCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderFilterParameter Class

Represents a filter template parameter with its value.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderFilterParameter

Syntax

Visual Basic (Declaration)
Public Class SyncProviderFilterParameter
C#
public class SyncProviderFilterParameter

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderFilterParameter Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Class Members
See Also Properties support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderFilterParameter Class

The following tables list the members exposed by SyncProviderFilterParameter.

Public Constructors

 | Name | Description
public Constructor | SyncProviderFilterParameter Constructor | Overloaded. Initializes a new instance of the SyncProviderFilterParameter class.
Top

Public Properties

 | Name | Description
public Property | ParameterName | Gets or sets the name of the parameter that is used in Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause.
public Property | Value | Gets or set the value of the filter parameter.
Top

See Also

Reference

SyncProviderFilterParameter Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderFilterParameter Class : SyncProviderFilterParameter Constructor

Initializes a new instance of the SyncProviderFilterParameter class.

Overload List

Overload | Description
SyncProviderFilterParameter Constructor() | Initializes a new instance of the SyncProviderFilterParameter class with default values.
SyncProviderFilterParameter Constructor(DbParameter) | Initializes a new instance of the SyncProviderFilterParameter class with the specified System.Data.Common.DbParameter instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderFilterParameter Class
SyncProviderFilterParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Constructor()
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderFilterParameter Class > SyncProviderFilterParameter Constructor : SyncProviderFilterParameter Constructor()

Initializes a new instance of the SyncProviderFilterParameter class with default values.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderFilterParameter()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderFilterParameter Class
SyncProviderFilterParameter Members
Overload List


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Constructor(DbParameter)
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderFilterParameter Class > SyncProviderFilterParameter Constructor : SyncProviderFilterParameter Constructor(DbParameter)

parameter
A System.Data.Common.DbParameter instance, having the desired name and value.
Initializes a new instance of the SyncProviderFilterParameter class with the specified System.Data.Common.DbParameter instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameter As DbParameter _
)
C#
public SyncProviderFilterParameter(
   DbParameter parameter
)

Parameters

parameter
A System.Data.Common.DbParameter instance, having the desired name and value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderFilterParameter Class
SyncProviderFilterParameter Members
Overload List


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderFilterParameter Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderFilterParameter Class

For a list of all members of this type, see SyncProviderFilterParameter members.

Public Properties

 | Name | Description
public Property | ParameterName | Gets or sets the name of the parameter that is used in Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause.
public Property | Value | Gets or set the value of the filter parameter.
Top

See Also

Reference

SyncProviderFilterParameter Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParameterName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderFilterParameter Class : ParameterName Property

Gets or sets the name of the parameter that is used in Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause.

Syntax

Visual Basic (Declaration)
Public Property ParameterName As String
C#
public string ParameterName {get; set;}

Property Value

The name of the parameter that is used in Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderFilterParameter Class
SyncProviderFilterParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Value Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderFilterParameter Class : Value Property

Gets or set the value of the filter parameter.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
C#
public object Value {get; set;}

Property Value

The value of the filter parameter.

Remarks

This value is passed to the select_changes stored procedure to control which items are enumerated during synchronization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderFilterParameter Class
SyncProviderFilterParameter Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderScopeConfiguration Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeConfiguration Class

Represents configuration information that is used by OracleSyncProvider for a particular scope.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderScopeConfiguration

Syntax

Visual Basic (Declaration)
Public Class SyncProviderScopeConfiguration
C#
public class SyncProviderScopeConfiguration

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderScopeConfiguration Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderScopeConfiguration Class Members
See Also Properties support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeConfiguration Class

The following tables list the members exposed by SyncProviderScopeConfiguration.

Public Constructors

 | Name | Description
public Constructor | SyncProviderScopeConfiguration Constructor | Initializes a new instance of the SyncProviderScopeConfiguration class.
Top

Public Properties

 | Name | Description
public Property | AdapterConfigurations | Gets or sets a list of SyncProviderAdapterConfiguration objects, each of which is associated with a table in a database.
public Property | IsTemplate | Determines whether the associated scope is a template.
public Property | UnmappedElements | Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.
Top

See Also

Reference

SyncProviderScopeConfiguration Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderScopeConfiguration Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeConfiguration Class : SyncProviderScopeConfiguration Constructor

Initializes a new instance of the SyncProviderScopeConfiguration class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderScopeConfiguration()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeConfiguration Class
SyncProviderScopeConfiguration Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderScopeConfiguration Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeConfiguration Class

For a list of all members of this type, see SyncProviderScopeConfiguration members.

Public Properties

 | Name | Description
public Property | AdapterConfigurations | Gets or sets a list of SyncProviderAdapterConfiguration objects, each of which is associated with a table in a database.
public Property | IsTemplate | Determines whether the associated scope is a template.
public Property | UnmappedElements | Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.
Top

See Also

Reference

SyncProviderScopeConfiguration Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AdapterConfigurations Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeConfiguration Class : AdapterConfigurations Property

Gets or sets a list of SyncProviderAdapterConfiguration objects, each of which is associated with a table in a database.

Syntax

Visual Basic (Declaration)
Public Property AdapterConfigurations As SyncProviderAdapterConfigurationCollection
C#
public SyncProviderAdapterConfigurationCollection AdapterConfigurations {get; set;}

Property Value

A list of SyncProviderAdapterConfiguration objects, each of which is associated with a table in a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeConfiguration Class
SyncProviderScopeConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
IsTemplate Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeConfiguration Class : IsTemplate Property

Determines whether the associated scope is a template.

Syntax

Visual Basic (Declaration)
Public Property IsTemplate As Boolean
C#
public bool IsTemplate {get; set;}

Property Value

true, if the associated scope is a template; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeConfiguration Class
SyncProviderScopeConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnmappedElements Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeConfiguration Class : UnmappedElements Property

Gets or sets the array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.

Syntax

Visual Basic (Declaration)
Public Property UnmappedElements As XmlElement()
C#
public XmlElement[] UnmappedElements {get; set;}

Property Value

The array of any XML configuration elements that are not recognized by Sync Framework when an adapter is configured.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeConfiguration Class
SyncProviderScopeConfiguration Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderScopeParameters Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeParameters Class

Represents the collection of parameter sets associated with all of the tables in the scope.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderScopeParameters

Syntax

Visual Basic (Declaration)
Public Class SyncProviderScopeParameters
C#
public class SyncProviderScopeParameters

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncProviderScopeParameters Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncProviderScopeParameters Class Members
See Also Properties support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeParameters Class

The following tables list the members exposed by SyncProviderScopeParameters.

Public Constructors

 | Name | Description
public Constructor | SyncProviderScopeParameters Constructor | Initializes a new instance of the SyncProviderScopeParameters class.
Top

Public Properties

 | Name | Description
public Property | AdapterParameters | Gets the collection of parameter sets associated with all of the tables in the scope.
Top

See Also

Reference

SyncProviderScopeParameters Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncProviderScopeParameters Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeParameters Class : SyncProviderScopeParameters Constructor

Initializes a new instance of the SyncProviderScopeParameters class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncProviderScopeParameters()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeParameters Class
SyncProviderScopeParameters Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncProviderScopeParameters Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderScopeParameters Class

For a list of all members of this type, see SyncProviderScopeParameters members.

Public Properties

 | Name | Description
public Property | AdapterParameters | Gets the collection of parameter sets associated with all of the tables in the scope.
Top

See Also

Reference

SyncProviderScopeParameters Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AdapterParameters Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncProviderScopeParameters Class : AdapterParameters Property

Gets the collection of parameter sets associated with all of the tables in the scope.

Syntax

Visual Basic (Declaration)
Public Property AdapterParameters As SyncProviderAdapterParametersCollection
C#
public SyncProviderAdapterParametersCollection AdapterParameters {get; set;}

Property Value

The collection of parameter sets associated with all of the tables in the scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncProviderScopeParameters Class
SyncProviderScopeParameters Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncScopeDeprovisioning Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeDeprovisioning Class

Removes scopes, templates, and other synchronization elements from a database that was previously provisioned for synchronization.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncScopeDeprovisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeDeprovisioning

Syntax

Visual Basic (Declaration)
Public MustInherit Class SyncScopeDeprovisioning
C#
public abstract class SyncScopeDeprovisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncScopeDeprovisioning Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncScopeDeprovisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeDeprovisioning Class

The following tables list the members exposed by SyncScopeDeprovisioning.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
Top

Public Methods

 | Name | Description
public Method | DeprovisionScope | Deprovisions the specified scope by removing all associated synchronization elements from the database.
public Method | DeprovisionStore | Removes all Sync Framework metadata tables, triggers, and stored procedures from the database.
public Method | DeprovisionTemplate | Deprovisions the specified template and all scopes that were created from the specified template by removing all associated synchronization elements from the database.
public Method | ScriptDeprovisionScope | Generates a script that can be used to deprovision a scope.
public Method | ScriptDeprovisionStore | Generates a script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database.
public Method | ScriptDeprovisionTemplate | Generates a script that can be used to deprovision a template and all scopes that were created from that template.
Top

See Also

Reference

SyncScopeDeprovisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncScopeDeprovisioning Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeDeprovisioning Class

For a list of all members of this type, see SyncScopeDeprovisioning members.

Public Methods

 | Name | Description
public Method | DeprovisionScope | Deprovisions the specified scope by removing all associated synchronization elements from the database.
public Method | DeprovisionStore | Removes all Sync Framework metadata tables, triggers, and stored procedures from the database.
public Method | DeprovisionTemplate | Deprovisions the specified template and all scopes that were created from the specified template by removing all associated synchronization elements from the database.
public Method | ScriptDeprovisionScope | Generates a script that can be used to deprovision a scope.
public Method | ScriptDeprovisionStore | Generates a script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database.
public Method | ScriptDeprovisionTemplate | Generates a script that can be used to deprovision a template and all scopes that were created from that template.
Top

See Also

Reference

SyncScopeDeprovisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeprovisionScope Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : DeprovisionScope Method

scopeName
The name of the scope to deprovision.
Deprovisions the specified scope by removing all associated synchronization elements from the database.

Syntax

Visual Basic (Declaration)
Public Sub DeprovisionScope( _
   ByVal scopeName As String _
)
C#
public void DeprovisionScope(
   string scopeName
)

Parameters

scopeName
The name of the scope to deprovision.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeprovisionStore Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : DeprovisionStore Method

Removes all Sync Framework metadata tables, triggers, and stored procedures from the database.

Syntax

Visual Basic (Declaration)
Public Sub DeprovisionStore()
C#
public void DeprovisionStore()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
DeprovisionTemplate Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : DeprovisionTemplate Method

templateName
The name of the template to deprovision.
Deprovisions the specified template and all scopes that were created from the specified template by removing all associated synchronization elements from the database.

Syntax

Visual Basic (Declaration)
Public Sub DeprovisionTemplate( _
   ByVal templateName As String _
)
C#
public void DeprovisionTemplate(
   string templateName
)

Parameters

templateName
The name of the template to deprovision.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptDeprovisionScope Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : ScriptDeprovisionScope Method

scopeName
The name of the scope to deprovision.
Generates a script that can be used to deprovision a scope.

Syntax

Visual Basic (Declaration)
Public Function ScriptDeprovisionScope( _
   ByVal scopeName As String _
) As String
C#
public string ScriptDeprovisionScope(
   string scopeName
)

Parameters

scopeName
The name of the scope to deprovision.

Return Value

A script that can be used to deprovision a scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptDeprovisionStore Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : ScriptDeprovisionStore Method

Generates a script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database.

Syntax

Visual Basic (Declaration)
Public Function ScriptDeprovisionStore() As String
C#
public string ScriptDeprovisionStore()

Return Value

A script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScriptDeprovisionTemplate Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : ScriptDeprovisionTemplate Method

templateName
The name of the template to deprovision.
Generates a script that can be used to deprovision a template and all scopes that were created from that template.

Syntax

Visual Basic (Declaration)
Public Function ScriptDeprovisionTemplate( _
   ByVal templateName As String _
) As String
C#
public string ScriptDeprovisionTemplate(
   string templateName
)

Parameters

templateName
The name of the template to deprovision.

Return Value

A script that can be used to deprovision a template and all scopes that were created from that template.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncScopeDeprovisioning Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeDeprovisioning Class

For a list of all members of this type, see SyncScopeDeprovisioning members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
Top

See Also

Reference

SyncScopeDeprovisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandTimeout Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : CommandTimeout Property

Gets or sets the wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Property Value

The wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectPrefix Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : ObjectPrefix Property

Gets or sets the optional preffix for names of Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefix As String
C#
public string ObjectPrefix {get; set;}

Property Value

The preffix for names of Sync Framework metadata objects.

Remarks

Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectSchema Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeDeprovisioning Class : ObjectSchema Property

Gets or sets the schema containing Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema {get; set;}

Property Value

The schema containing Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeDeprovisioning Class
SyncScopeDeprovisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncScopeProvisioning Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeProvisioning Class

Represents the provisioning of a database for a particular scope.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncScopeProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeProvisioning

Syntax

Visual Basic (Declaration)
Public MustInherit Class SyncScopeProvisioning
C#
public abstract class SyncScopeProvisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncScopeProvisioning Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncScopeProvisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeProvisioning Class

The following tables list the members exposed by SyncScopeProvisioning.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | ScopeName | Gets the name of the scope.
public Property | Tables | Gets a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables.
public Property | UserComment | Gets or sets the user-specified comment about the scope.
Top

Public Methods

 | Name | Description
public Method | Apply | Applies the provisioning script to a database by using the connection that was specified in the constructor.
public Method | PopulateFromScopeDescription | Sets the scope description from which the database should be provisioned.
public Method | PopulateFromTemplate | Sets the template-based scope description from which the database should be provisioned.
public Method | ScopeExists | Indicates whether the specified scope exists in the database, the connection, specified in the constructor.
public Method | Script | Generates the SQL script to provision the database for a particular scope.
public Method | SetCreateProceduresDefault | Specifies whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. The default value is CreateOrUseExisting.
public Method | SetCreateProceduresForAdditionalScopeDefault | Specifies whether to create additional stored procedures for a scope that contains tables that have already been provisioned for other scopes. For example, this scope adds a filter column to a table that has already been provisioned without the filter column. Set this option to Create to ensure that an additional change enumeration procedure is created that can handle the filter column. The default setting is Skip.
public Method | SetCreateTableDefault | Specifies whether to create tables that store user data to synchronize. The default value is CreateOrUseExisting.
public Method | SetCreateTrackingTableDefault | Specifies whether to create tables that store change-tracking metadata. The default value is CreateOrUseExisting.
public Method | SetCreateTriggersDefault | Specifies whether to create the triggers (on synchronized tables) that update tracking tables. The default value is CreateOrUseExisting.
public Method | SetPopulateTrackingTableDefault | Specifies whether to insert metadata into change-tracking tables for rows that already exist in the provisioned tables. The default value is CreateOrUseExisting.
public Method | TemplateExists | Indicates whether the specified template exists in the database.
Top

See Also

Reference

SyncScopeProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncScopeProvisioning Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeProvisioning Class

For a list of all members of this type, see SyncScopeProvisioning members.

Public Methods

 | Name | Description
public Method | Apply | Applies the provisioning script to a database by using the connection that was specified in the constructor.
public Method | PopulateFromScopeDescription | Sets the scope description from which the database should be provisioned.
public Method | PopulateFromTemplate | Sets the template-based scope description from which the database should be provisioned.
public Method | ScopeExists | Indicates whether the specified scope exists in the database, the connection, specified in the constructor.
public Method | Script | Generates the SQL script to provision the database for a particular scope.
public Method | SetCreateProceduresDefault | Specifies whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. The default value is CreateOrUseExisting.
public Method | SetCreateProceduresForAdditionalScopeDefault | Specifies whether to create additional stored procedures for a scope that contains tables that have already been provisioned for other scopes. For example, this scope adds a filter column to a table that has already been provisioned without the filter column. Set this option to Create to ensure that an additional change enumeration procedure is created that can handle the filter column. The default setting is Skip.
public Method | SetCreateTableDefault | Specifies whether to create tables that store user data to synchronize. The default value is CreateOrUseExisting.
public Method | SetCreateTrackingTableDefault | Specifies whether to create tables that store change-tracking metadata. The default value is CreateOrUseExisting.
public Method | SetCreateTriggersDefault | Specifies whether to create the triggers (on synchronized tables) that update tracking tables. The default value is CreateOrUseExisting.
public Method | SetPopulateTrackingTableDefault | Specifies whether to insert metadata into change-tracking tables for rows that already exist in the provisioned tables. The default value is CreateOrUseExisting.
public Method | TemplateExists | Indicates whether the specified template exists in the database.
Top

See Also

Reference

SyncScopeProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Apply Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : Apply Method

Applies the provisioning script to a database by using the connection that was specified in the constructor.

Syntax

Visual Basic (Declaration)
Public Sub Apply()
C#
public void Apply()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PopulateFromScopeDescription Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : PopulateFromScopeDescription Method

scopeDescription
The scope configuration for provisioning the database.
Sets the scope description from which the database should be provisioned.

Syntax

Visual Basic (Declaration)
Public Sub PopulateFromScopeDescription( _
   ByVal scopeDescription As DbSyncScopeDescription _
)
C#
public void PopulateFromScopeDescription(
   DbSyncScopeDescription scopeDescription
)

Parameters

scopeDescription
The scope configuration for provisioning the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PopulateFromTemplate Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : PopulateFromTemplate Method

scopeName
The name of the scope.
templateName
The name of the template.
Sets the template-based scope description from which the database should be provisioned.

Syntax

Visual Basic (Declaration)
Public Sub PopulateFromTemplate( _
   ByVal scopeName As String, _
   ByVal templateName As String _
)
C#
public void PopulateFromTemplate(
   string scopeName,
   string templateName
)

Parameters

scopeName
The name of the scope.
templateName
The name of the template.

Remarks

You will need to specify values for filter parameters for a template-based scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScopeExists Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : ScopeExists Method

scopeName
The name of the scope to check.
Indicates whether the specified scope exists in the database, the connection, specified in the constructor.

Syntax

Visual Basic (Declaration)
Public Function ScopeExists( _
   ByVal scopeName As String _
) As Boolean
C#
public bool ScopeExists(
   string scopeName
)

Parameters

scopeName
The name of the scope to check.

Return Value

true, if the specified scope exists in the database; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Script Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : Script Method

Generates the SQL script to provision the database for a particular scope.

Syntax

Visual Basic (Declaration)
Public Function Script() As String
C#
public string Script()

Return Value

The SQL script to provision the database for a particular scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetCreateProceduresDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetCreateProceduresDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the stored procedures.
Specifies whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Sub SetCreateProceduresDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetCreateProceduresDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the stored procedures.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetCreateProceduresForAdditionalScopeDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetCreateProceduresForAdditionalScopeDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the stored procedures.
Specifies whether to create additional stored procedures for a scope that contains tables that have already been provisioned for other scopes. For example, this scope adds a filter column to a table that has already been provisioned without the filter column. Set this option to Create to ensure that an additional change enumeration procedure is created that can handle the filter column. The default setting is Skip.

Syntax

Visual Basic (Declaration)
Public Sub SetCreateProceduresForAdditionalScopeDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetCreateProceduresForAdditionalScopeDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the stored procedures.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetCreateTableDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetCreateTableDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the tables that are synchronized.
Specifies whether to create tables that store user data to synchronize. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Sub SetCreateTableDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetCreateTableDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the tables that are synchronized.

Remarks

If the tables to synchronize data of already exist in the database, and you are not defining any table schema by using Microsoft.Synchronization.Data.DbSyncTableDescription objects, use the Skip value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetCreateTrackingTableDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetCreateTrackingTableDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the tracking tables.
Specifies whether to create tables that store change-tracking metadata. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Sub SetCreateTrackingTableDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetCreateTrackingTableDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the tracking tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetCreateTriggersDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetCreateTriggersDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the triggers (on synchronized tables) that update tracking tables.
Specifies whether to create the triggers (on synchronized tables) that update tracking tables. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Sub SetCreateTriggersDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetCreateTriggersDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to create the triggers (on synchronized tables) that update tracking tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SetPopulateTrackingTableDefault Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : SetPopulateTrackingTableDefault Method

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to insert metadata into change-tracking tables for rows that already exist in base tables.
Specifies whether to insert metadata into change-tracking tables for rows that already exist in the provisioned tables. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Sub SetPopulateTrackingTableDefault( _
   ByVal defaultOption As DbSyncCreationOption _
)
C#
public void SetPopulateTrackingTableDefault(
   DbSyncCreationOption defaultOption
)

Parameters

defaultOption
One of the Microsoft.Synchronization.Data.DbSyncCreationOption values that specifies whether to insert metadata into change-tracking tables for rows that already exist in base tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TemplateExists Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : TemplateExists Method

templateName
The name of the template to check.
Indicates whether the specified template exists in the database.

Syntax

Visual Basic (Declaration)
Public Function TemplateExists( _
   ByVal templateName As String _
) As Boolean
C#
public bool TemplateExists(
   string templateName
)

Parameters

templateName
The name of the template to check.

Return Value

true, if the specified template exists in the database; otherwise, false.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncScopeProvisioning Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeProvisioning Class

For a list of all members of this type, see SyncScopeProvisioning members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | ScopeName | Gets the name of the scope.
public Property | Tables | Gets a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables.
public Property | UserComment | Gets or sets the user-specified comment about the scope.
Top

See Also

Reference

SyncScopeProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CommandTimeout Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : CommandTimeout Property

Gets or sets the wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated.

Syntax

Visual Basic (Declaration)
Public Property CommandTimeout As Integer
C#
public int CommandTimeout {get; set;}

Property Value

The wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectPrefix Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : ObjectPrefix Property

Gets or sets the optional preffix for names of Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefix As String
C#
public string ObjectPrefix {get; set;}

Property Value

The preffix for names of Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectSchema Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : ObjectSchema Property

Gets or sets the schema containing Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema {get; set;}

Property Value

The schema containing Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ScopeName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : ScopeName Property

Gets the name of the scope.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ScopeName As String
C#
public string ScopeName {get;}

Property Value

The name of the scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Tables Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : Tables Property

Gets a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tables As SyncTableProvisioningCollection
C#
public SyncTableProvisioningCollection Tables {get;}

Property Value

A collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UserComment Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncScopeProvisioning Class : UserComment Property

Gets or sets the user-specified comment about the scope.

Syntax

Visual Basic (Declaration)
Public Property UserComment As String
C#
public string UserComment {get; set;}

Property Value

The user-specified comment about the scope.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncScopeProvisioning Class
SyncScopeProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncSqlParameterCollection Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncSqlParameterCollection Class

Represents a collection of System.Data.Common.DbParameter objects that can be indexed by the name of the parameter.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Devart.Data.Synchronization.SyncSqlParameterCollection

Syntax

Visual Basic (Declaration)
Public Class SyncSqlParameterCollection
   Inherits System.Collections.ObjectModel.Collection(Of DbParameter)
   Implements ICollection(Of DbParameter), IEnumerable(Of DbParameter), IList(Of DbParameter), ICollection, IEnumerable, IList
C#
public class SyncSqlParameterCollection : System.Collections.ObjectModel.Collection<DbParameter>, ICollection<DbParameter>, IEnumerable<DbParameter>, IList<DbParameter>, ICollection, IEnumerable, IList

Remarks

This class is used to represent the collection of template filter parameters.

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncSqlParameterCollection Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncSqlParameterCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncSqlParameterCollection Class

The following tables list the members exposed by SyncSqlParameterCollection.

Public Constructors

 | Name | Description
public Constructor | SyncSqlParameterCollection Constructor | Initializes a new instance of the SyncSqlParameterCollection class.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Property | Item | An indexer property that gets the System.Data.Common.DbParameter object with the specified name in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
Top

See Also

Reference

SyncSqlParameterCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncSqlParameterCollection Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncSqlParameterCollection Class : SyncSqlParameterCollection Constructor

Initializes a new instance of the SyncSqlParameterCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncSqlParameterCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncSqlParameterCollection Class
SyncSqlParameterCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncSqlParameterCollection Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncSqlParameterCollection Class

For a list of all members of this type, see SyncSqlParameterCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Property | Item | An indexer property that gets the System.Data.Common.DbParameter object with the specified name in the collection.
Top

See Also

Reference

SyncSqlParameterCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncSqlParameterCollection Class : Item Property

parameterName
The name of the parameter to retrieve.
An indexer property that gets the System.Data.Common.DbParameter object with the specified name in the collection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Default Property Item( _
   ByVal parameterName As String _
) As DbParameter
C#
public new DbParameter this(
   string parameterName
) {get;}

Parameters

parameterName
The name of the parameter to retrieve.

Property Value

The System.Data.Common.DbParameter object with the specified name. Null if there is no parameter with such name in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncSqlParameterCollection Class
SyncSqlParameterCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncTableProvisioning Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioning Class

Represents the provisioning of a database table.

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncTableProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncTableProvisioning

Syntax

Visual Basic (Declaration)
Public MustInherit Class SyncTableProvisioning
C#
public abstract class SyncTableProvisioning

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncTableProvisioning Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioning Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioning Class

The following tables list the members exposed by SyncTableProvisioning.

Public Properties

 | Name | Description
public Property | CreateProcedures | Determines whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata.
public Property | CreateProceduresForAdditionalScope | Determines whether to create sets of stored procedures that insert, update, and delete data and synchronization metadata for any additional scopes.
public Property | CreateTable | Determines whether to create the table that is synchronized.
public Property | CreateTrackingTable | Determines whether to create the table that store change-tracking metadata for the synchronized table.
public Property | CreateTriggers | Determines whether to create the triggers on the provisioned table, that update tracking the table.
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized.
public Property | FilterColumns | Gets the list of columns that are used for filtering data.
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.
public Property | GlobalName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | LocalName | Gets or sets the name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | PopulateTrackingTable | Specifies whether to insert metadata into the change-tracking table for rows that already exist in the provisioned table. The default value is CreateOrUseExisting.
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.
public Property | UnquotedGlobalName | Gets or sets the name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | UnquotedLocalName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
Top

Public Methods

 | Name | Description
public Method | AddFilterColumn | Adds a column that is used in the Devart.Data.Synchronization.SyncTableProvisioning.FilterClause to filter data rows for synchronization.
public Method | Apply | Applies the provisioning script to a database.
public Method | Script | Generates the SQL script to provision the table.
public Method | ToString | Returns a string that represents the SqlSyncTableProvisioning object.
Top

See Also

Reference

SyncTableProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioning Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioning Class

For a list of all members of this type, see SyncTableProvisioning members.

Public Methods

 | Name | Description
public Method | AddFilterColumn | Adds a column that is used in the Devart.Data.Synchronization.SyncTableProvisioning.FilterClause to filter data rows for synchronization.
public Method | Apply | Applies the provisioning script to a database.
public Method | Script | Generates the SQL script to provision the table.
public Method | ToString | Returns a string that represents the SqlSyncTableProvisioning object.
Top

See Also

Reference

SyncTableProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
AddFilterColumn Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : AddFilterColumn Method

name
The name of the filter column to add.
Adds a column that is used in the Devart.Data.Synchronization.SyncTableProvisioning.FilterClause to filter data rows for synchronization.

Syntax

Visual Basic (Declaration)
Public Sub AddFilterColumn( _
   ByVal name As String _
)
C#
public void AddFilterColumn(
   string name
)

Parameters

name
The name of the filter column to add.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Apply() Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : Apply() Method

Applies the provisioning script to a database.

Syntax

Visual Basic (Declaration)
Public Sub Apply()
C#
public void Apply()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Script Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : Script Method

Generates the SQL script to provision the table.

Syntax

Visual Basic (Declaration)
Public Function Script() As String
C#
public string Script()

Return Value

The SQL script to provision the table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : ToString Method

Returns a string that represents the SqlSyncTableProvisioning object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()

Return Value

A string that represents the SqlSyncTableProvisioning object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioning Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioning Class

For a list of all members of this type, see SyncTableProvisioning members.

Public Properties

 | Name | Description
public Property | CreateProcedures | Determines whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata.
public Property | CreateProceduresForAdditionalScope | Determines whether to create sets of stored procedures that insert, update, and delete data and synchronization metadata for any additional scopes.
public Property | CreateTable | Determines whether to create the table that is synchronized.
public Property | CreateTrackingTable | Determines whether to create the table that store change-tracking metadata for the synchronized table.
public Property | CreateTriggers | Determines whether to create the triggers on the provisioned table, that update tracking the table.
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized.
public Property | FilterColumns | Gets the list of columns that are used for filtering data.
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.
public Property | GlobalName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | LocalName | Gets or sets the name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects.
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects.
public Property | PopulateTrackingTable | Specifies whether to insert metadata into the change-tracking table for rows that already exist in the provisioned table. The default value is CreateOrUseExisting.
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.
public Property | UnquotedGlobalName | Gets or sets the name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.
public Property | UnquotedLocalName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.
Top

See Also

Reference

SyncTableProvisioning Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateProcedures Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : CreateProcedures Property

Determines whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata.

Syntax

Visual Basic (Declaration)
Public Property CreateProcedures As DbSyncCreationOption
C#
public DbSyncCreationOption CreateProcedures {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateProceduresForAdditionalScope Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : CreateProceduresForAdditionalScope Property

Determines whether to create sets of stored procedures that insert, update, and delete data and synchronization metadata for any additional scopes.

Syntax

Visual Basic (Declaration)
Public Property CreateProceduresForAdditionalScope As DbSyncCreationOption
C#
public DbSyncCreationOption CreateProceduresForAdditionalScope {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateTable Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : CreateTable Property

Determines whether to create the table that is synchronized.

Syntax

Visual Basic (Declaration)
Public Property CreateTable As DbSyncCreationOption
C#
public DbSyncCreationOption CreateTable {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Remarks

If the table to synchronize data of already exists in the database, and you are not defining any table schema by using a Microsoft.Synchronization.Data.DbSyncTableDescription object, use the Skip value.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateTrackingTable Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : CreateTrackingTable Property

Determines whether to create the table that store change-tracking metadata for the synchronized table.

Syntax

Visual Basic (Declaration)
Public Property CreateTrackingTable As DbSyncCreationOption
C#
public DbSyncCreationOption CreateTrackingTable {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateTriggers Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : CreateTriggers Property

Determines whether to create the triggers on the provisioned table, that update tracking the table.

Syntax

Visual Basic (Declaration)
Public Property CreateTriggers As DbSyncCreationOption
C#
public DbSyncCreationOption CreateTriggers {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterClause Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : FilterClause Property

Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized.

Syntax

Visual Basic (Declaration)
Public Property FilterClause As String
C#
public string FilterClause {get; set;}

Property Value

The filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterColumns Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : FilterColumns Property

Gets the list of columns that are used for filtering data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterColumns As Collection(Of DbSyncColumnDescription)
C#
public Collection<DbSyncColumnDescription> FilterColumns {get;}

Property Value

The list of columns that are used for filtering data.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
FilterParameters Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : FilterParameters Property

Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterParameters As SyncSqlParameterCollection
C#
public SyncSqlParameterCollection FilterParameters {get;}

Property Value

The collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GlobalName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : GlobalName Property

Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GlobalName As String
C#
public string GlobalName {get;}

Property Value

The name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LocalName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : LocalName Property

Gets or sets the name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalName As String
C#
public virtual string LocalName {get;}

Property Value

The name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectPrefix Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : ObjectPrefix Property

Gets or sets the optional preffix for names of Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectPrefix As String
C#
public string ObjectPrefix {get; set;}

Property Value

The preffix for names of Sync Framework metadata objects.

Remarks

Must match to the preffix, specified in the Devart.Data.Synchronization.SyncScopeProvisioning.ObjectPrefix property of the Devart.Data.Synchronization.SyncScopeProvisioning class descendant, that was used to provision the database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ObjectSchema Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : ObjectSchema Property

Gets or sets the schema containing Sync Framework metadata objects.

Syntax

Visual Basic (Declaration)
Public Property ObjectSchema As String
C#
public string ObjectSchema {get; set;}

Property Value

The schema containing Sync Framework metadata objects.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
PopulateTrackingTable Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : PopulateTrackingTable Property

Specifies whether to insert metadata into the change-tracking table for rows that already exist in the provisioned table. The default value is CreateOrUseExisting.

Syntax

Visual Basic (Declaration)
Public Property PopulateTrackingTable As DbSyncCreationOption
C#
public DbSyncCreationOption PopulateTrackingTable {get; set;}

Property Value

One of the Microsoft.Synchronization.Data.DbSyncCreationOption values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SelectChangesProcName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : SelectChangesProcName Property

Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.

Syntax

Visual Basic (Declaration)
Public Property SelectChangesProcName As String
C#
public string SelectChangesProcName {get; set;}

Property Value

The name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnquotedGlobalName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : UnquotedGlobalName Property

Gets or sets the name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnquotedGlobalName As String
C#
public string UnquotedGlobalName {get;}

Property Value

The name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
UnquotedLocalName Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : UnquotedLocalName Property

Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UnquotedLocalName As String
C#
public string UnquotedLocalName {get;}

Property Value

The name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncTableProvisioningCollection Class
Members See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioningCollection Class

Represents a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that can be indexed by the name of the table to provision.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
Devart.Data.Synchronization.SyncTableProvisioningCollection

Syntax

Visual Basic (Declaration)
Public Class SyncTableProvisioningCollection
   Inherits System.Collections.ObjectModel.Collection(Of SyncTableProvisioning)
   Implements ICollection(Of SyncTableProvisioning), IEnumerable(Of SyncTableProvisioning), IList(Of SyncTableProvisioning), ICollection, IEnumerable, IList
C#
public class SyncTableProvisioningCollection : System.Collections.ObjectModel.Collection<SyncTableProvisioning>, ICollection<SyncTableProvisioning>, IEnumerable<SyncTableProvisioning>, IList<SyncTableProvisioning>, ICollection, IEnumerable, IList

Remarks

Note: This class is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

SyncTableProvisioningCollection Members
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Members$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioningCollection Class Members
See Also Properties Methods support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioningCollection Class

The following tables list the members exposed by SyncTableProvisioningCollection.

Public Constructors

 | Name | Description
public Constructor | SyncTableProvisioningCollection Constructor | Initializes a new instance of the SyncTableProvisioningCollection class.
Top

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Property | Item | An indexer property that gets the Devart.Data.Synchronization.SyncTableProvisioning object, corresponding to the provisioned table with the specified name, in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
Top

See Also

Reference

SyncTableProvisioningCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncTableProvisioningCollection Constructor
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioningCollection Class : SyncTableProvisioningCollection Constructor

Initializes a new instance of the SyncTableProvisioningCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public SyncTableProvisioningCollection()

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioningCollection Class
SyncTableProvisioningCollection Members


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioningCollection Class Properties
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioningCollection Class

For a list of all members of this type, see SyncTableProvisioningCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of elements actually contained in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Property | Item | An indexer property that gets the Devart.Data.Synchronization.SyncTableProvisioning object, corresponding to the provisioned table with the specified name, in the collection.
Top

See Also

Reference

SyncTableProvisioningCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioningCollection Class : Item Property

globalTableName
The name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table, the Devart.Data.Synchronization.SyncTableProvisioning object for which to retrieve.
An indexer property that gets the Devart.Data.Synchronization.SyncTableProvisioning object, corresponding to the provisioned table with the specified name, in the collection.

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Default Property Item( _
   ByVal globalTableName As String _
) As SyncTableProvisioning
C#
public new SyncTableProvisioning this(
   string globalTableName
) {get;}

Parameters

globalTableName
The name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table, the Devart.Data.Synchronization.SyncTableProvisioning object for which to retrieve.

Property Value

The Devart.Data.Synchronization.SyncTableProvisioning object, corresponding to the provisioned table with the specified name, in the collection. Null if there is no Devart.Data.Synchronization.SyncTableProvisioning object, corresponding to the table with such a name, in the collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioningCollection Class
SyncTableProvisioningCollection Members


%%ItemTitle%% - Enumerations

Devart.Data.Synchronization Namespace - Enumerations
See Also Inheritance Hierarchy support@devart.com

Enumerations

 | Enumeration | Description
Enumeration | SyncScopeProvisioningType | Defines the kind of provisioning.

See Also

Reference

Devart.Data.Synchronization Assembly


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
SyncScopeProvisioningType Enumeration
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncScopeProvisioningType Enumeration

Defines the kind of provisioning.

Syntax

Visual Basic (Declaration)
Public Enum SyncScopeProvisioningType
   Inherits System.Enum
   Implements IComparable, IConvertible, IFormattable
C#
public enum SyncScopeProvisioningType : System.Enum, IComparable, IConvertible, IFormattable

Members

Member | Description
Scope | Scope provisioning. After a scope is provisioned, the database can be synchronized for the specified scope.
Template | Template provisioning. After a template is provisioned, synchronization scopes can be created based on the template.

Remarks

Note: This enumeration is not available in .NET Standard 1.3 compatible assembly. It is available only in the assembly for full .NET Framework.

This class is available only in Professional and Developer Editions. It is not available in Standard and Mobile Editions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Devart.Data.Synchronization.SyncScopeProvisioningType

Requirements

Namespace: Devart.Data.Synchronization

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

Assembly: Devart.Data.Synchronization

See Also

Reference

Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Class Events
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncProvider Class

For a list of all members of this type, see OracleSyncProvider members.

Public Events

 | Name | Description
public Event | ApplyChangeFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyMetadataFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchSpooled | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesSelected | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | DbConnectionFailure | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SelectingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncPeerOutdated | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncProgress | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
Top

See Also

Reference

OracleSyncProvider Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Class Methods
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncProvider Class

For a list of all members of this type, see OracleSyncProvider members.

Public Methods

 | Name | Description
public Method | BeginSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | CleanupMetadata | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | Dispose | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Method | EndSession | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | GetScopeDescription | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Method | GetSyncBatchParameters | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Method | ProcessFullEnumerationChangeBatch | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
Top

See Also

Reference

OracleSyncProvider Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSyncProvider Class Properties
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncProvider Class

For a list of all members of this type, see OracleSyncProvider members.

Public Properties

 | Name | Description
public Property | ApplicationTransactionSize | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | BatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ChangeTracking | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | CleanupBatchingDirectory | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Configuration | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | Connection | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | DestinationCallbacks | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | IdFormats | (Inherited from Microsoft.Synchronization.KnowledgeSyncProvider)
public Property | MemoryDataCacheSize | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.DbSyncProviderBase)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.DbSyncProviderBase)
public Property | ScopeName | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | SelectNewTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectOverlappingScopesCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SelectTableMaxTimestampsCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncAdapters | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | SyncProviderPosition | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Property | UpdateScopeCleanupTimestampCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
public Property | UpdateScopeInfoCommand | (Inherited from Microsoft.Synchronization.Data.DbSyncProvider)
Top

See Also

Reference

OracleSyncProvider Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeDeprovisioning Class Methods
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeDeprovisioning Class

For a list of all members of this type, see OracleSyncScopeDeprovisioning members.

Public Methods

 | Name | Description
public Method | DeprovisionScope | Deprovisions the specified scope by removing all associated synchronization elements from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | DeprovisionStore | Removes all Sync Framework metadata tables, triggers, and stored procedures from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | DeprovisionTemplate | Deprovisions the specified template and all scopes that were created from the specified template by removing all associated synchronization elements from the database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionScope | Generates a script that can be used to deprovision a scope. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionStore | Generates a script that can be used to remove all Sync Framework metadata, triggers, and stored procedures from a database. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Method | ScriptDeprovisionTemplate | Generates a script that can be used to deprovision a template and all scopes that were created from that template. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
Top

See Also

Reference

OracleSyncScopeDeprovisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeDeprovisioning Class Properties
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeDeprovisioning Class

For a list of all members of this type, see OracleSyncScopeDeprovisioning members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a deprovisioning command to execute before the command is stopped and an error is generated. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeDeprovisioning)
Top

See Also

Reference

OracleSyncScopeDeprovisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Class Methods
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeProvisioning Class

For a list of all members of this type, see OracleSyncScopeProvisioning members.

Public Methods

 | Name | Description
public Method | Apply | Applies the provisioning script to a database by using the connection that was specified in the constructor. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | PopulateFromScopeDescription | Sets the scope description from which the database should be provisioned. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | PopulateFromTemplate | Sets the template-based scope description from which the database should be provisioned. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | ScopeExists | Indicates whether the specified scope exists in the database, the connection, specified in the constructor. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | Script | Generates the SQL script to provision the database for a particular scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateProceduresDefault | Specifies whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateProceduresForAdditionalScopeDefault | Specifies whether to create additional stored procedures for a scope that contains tables that have already been provisioned for other scopes. For example, this scope adds a filter column to a table that has already been provisioned without the filter column. Set this option to Create to ensure that an additional change enumeration procedure is created that can handle the filter column. The default setting is Skip. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTableDefault | Specifies whether to create tables that store user data to synchronize. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTrackingTableDefault | Specifies whether to create tables that store change-tracking metadata. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetCreateTriggersDefault | Specifies whether to create the triggers (on synchronized tables) that update tracking tables. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | SetPopulateTrackingTableDefault | Specifies whether to insert metadata into change-tracking tables for rows that already exist in the provisioned tables. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Method | TemplateExists | Indicates whether the specified template exists in the database. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
Top

See Also

Reference

OracleSyncScopeProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSyncScopeProvisioning Class Properties
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncScopeProvisioning Class

For a list of all members of this type, see OracleSyncScopeProvisioning members.

Public Properties

 | Name | Description
public Property | CommandTimeout | Gets or sets the wait time, in seconds, for a provisioning command to execute before the command is stopped and an error is generated. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | ScopeName | Gets the name of the scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | Tables | Gets a collection of Devart.Data.Synchronization.SyncTableProvisioning objects that represent the provisioning of database tables. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
public Property | UserComment | Gets or sets the user-specified comment about the scope. (Inherited from Devart.Data.Synchronization.SyncScopeProvisioning)
Top

See Also

Reference

OracleSyncScopeProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Class Properties
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace : OracleSyncTableProvisioning Class

For a list of all members of this type, see OracleSyncTableProvisioning members.

Public Properties

 | Name | Description
public Property | CreateProcedures | Determines whether to create a set of stored procedures that insert, update, and delete data and synchronization metadata. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateProceduresForAdditionalScope | Determines whether to create sets of stored procedures that insert, update, and delete data and synchronization metadata for any additional scopes. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTable | Determines whether to create the table that is synchronized. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTrackingTable | Determines whether to create the table that store change-tracking metadata for the synchronized table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | CreateTriggers | Determines whether to create the triggers on the provisioned table, that update tracking the table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterClause | Gets or sets the filter condition (a WHERE clause without the WHERE keyword) to filter table data to be synchronized. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterColumns | Gets the list of columns that are used for filtering data. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | FilterParameters | Gets the collection of parameters, used for filtering and specified in the Devart.Data.Synchronization.SyncProviderAdapterConfiguration.FilterClause property. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | GlobalName | Gets or sets the name, including database-specific delimiters, that other nodes in a synchronization topology use to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | LocalName | Gets or sets the name, including database-specific delimiters, that the local node in a synchronization topology uses to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | ObjectPrefix | Gets or sets the optional preffix for names of Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | ObjectSchema | Gets or sets the schema containing Sync Framework metadata objects. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | PopulateTrackingTable | Specifies whether to insert metadata into the change-tracking table for rows that already exist in the provisioned table. The default value is CreateOrUseExisting. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | SelectChangesProcName | Gets or sets the name of the stored procedure that Sync Framework uses to select changes from a synchronized table during synchronization. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | UnquotedGlobalName | Gets or sets the name, not including database-specific delimiters, that other nodes in a synchronization topology use to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
public Property | UnquotedLocalName | Gets or sets the name, not including database-specific delimiters, that the local node in a synchronization topology uses to identify a table. (Inherited from Devart.Data.Synchronization.SyncTableProvisioning)
Top

See Also

Reference

OracleSyncTableProvisioning Class
Devart.Data.Oracle.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSyncTableProvisioning Constructor
See Also support@devart.com
Devart.Data.Oracle.Synchronization Namespace > OracleSyncTableProvisioning Class : OracleSyncTableProvisioning Constructor

Overload List

Overload | Description
OracleSyncTableProvisioning Constructor | Initializes a new instance of the OracleSyncScopeProvisioning class with the specified connection and table description.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSyncTableProvisioning Class
OracleSyncTableProvisioning Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Data.Oracle.Synchronization Namespace Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
Devart.Data.Oracle.Synchronization.OracleSyncDescriptionBuilder
Devart.Data.Synchronization.DbSyncProviderBase
Microsoft.Synchronization.Data.DbSyncProvider
Microsoft.Synchronization.Data.RelationalSyncProvider
Microsoft.Synchronization.KnowledgeSyncProvider
Microsoft.Synchronization.SyncProvider
Devart.Data.Oracle.Synchronization.OracleSyncProvider
Devart.Data.Synchronization.SyncScopeDeprovisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeDeprovisioning
Devart.Data.Synchronization.SyncScopeProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncScopeProvisioning
Devart.Data.Synchronization.SyncTableProvisioning
Devart.Data.Oracle.Synchronization.OracleSyncTableProvisioning

See Also

Reference

Devart.Data.Oracle.Synchronization Assembly


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbMonitorHelper Class Events
See Also support@devart.com
Devart.Common Namespace : DbMonitorHelper Class

For a list of all members of this type, see DbMonitorHelper members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when DbMonitor object signals about some database activity. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

DbMonitorHelper Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbMonitorHelper Class Methods
See Also support@devart.com
Devart.Common Namespace : DbMonitorHelper Class

For a list of all members of this type, see DbMonitorHelper members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

DbMonitorHelper Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbMonitorHelper Class Properties
See Also support@devart.com
Devart.Common Namespace : DbMonitorHelper Class

For a list of all members of this type, see DbMonitorHelper members.

Public Properties

 | Name | Description
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | EventQueueLimit | Gets or sets the maximal number of events that may be placed to a queue waiting to be processed by the dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | Host | Gets or sets the host where the dbMonitor application is running, 'localhost' by default. (Inherited from Devart.Common.DbMonitor)
public Property | IsActive | Enables or disables monitoring applications. (Inherited from Devart.Common.DbMonitor)
public Property | Port | Gets or sets the port of the dbMonitor application to which to connect, 1000 by default. (Inherited from Devart.Common.DbMonitor)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | UseApp | Disables or enables sending database interaction events to dbMonitor application. (Inherited from Devart.Common.DbMonitor)
public Property | UseIdeOutput | Enables or disables writing log messages to the IDE output window. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

DbMonitorHelper Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Common Namespace > SelectColumn Class : ToString Method

Returns the current SelectColumn object in the text form.

Overload List

Overload | Description
ToString | Returns the current SelectColumn object in the text form.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectColumn Class
SelectColumn Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ToString Method
See Also support@devart.com
Devart.Common Namespace > SelectTable Class : ToString Method

Returns the current SelectTable object in the text form.

Overload List

Overload | Description
ToString | Returns the current SelectTable object in the text form.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SelectTable Class
SelectTable Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Common Namespace (Devart.Data.Oracle) Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
Devart.Common.DbMonitor
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbMonitorHelper
Devart.Data.Oracle.OracleMonitor
Devart.Common.SelectStatement
Devart.Data.Oracle.OracleSelectStatement
Devart.Common.SelectStatementNode
Devart.Common.SelectColumn
Devart.Common.SelectTable
System.Collections.CollectionBase
Devart.Common.SelectColumnCollection
Devart.Common.SelectTableCollection
System.Data.Common.DbConnection
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbConnectionBase
Devart.Data.Oracle.OracleConnection

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
NativeOracleTable Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleTable Class

For a list of all members of this type, see NativeOracleTable members.

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Clear | Removes all elements from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Contains | Determines whether an element is in the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | CopyTo | Copies the entire NativeOracleArray to a compatible System.Array starting at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Disposes the resources allocated by the NativeOracleObjectBase object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Flush | Flushes updated data to the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | GetEnumerator | Returns an enumerator for the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | IndexOf | Gets the location in the collection of the NativeOracleArray object. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Insert | Inserts an NativeOracleArray into the collection at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | Refresh | Refreshes object data from the server. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Method | Remove | Removes the specified element from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Method | RemoveAt | Removes the element at the specified index from the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
Top

See Also

Reference

NativeOracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
NativeOracleTable Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : NativeOracleTable Class

For a list of all members of this type, see NativeOracleTable members.

Public Properties

 | Name | Description
public Property | Connection | Gets or sets Devart.Data.Oracle.OracleConnection used by NativeOracleObjectBase descendant. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | Count | Gets the number of elements contained in the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsFixedSize | Gets a value indicating whether the NativeOracleArray has a fixed size. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsNull | Indicates whether or not the NativeOracleObject represents a null value. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | IsReadOnly | Gets a value indicating whether the NativeOracleArray is read-only. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | IsSynchronized | Gets a value indicating whether access to the NativeOracleArray is synchronized (thread-safe). (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | Item | Overloaded. Gets or sets the element at the specified index. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | ObjectType | Gets an OracleType of the specified object. (Inherited from Devart.Data.Oracle.NativeOracleObjectBase)
public Property | SyncRoot | Gets an object that can be used to synchronize access to the NativeOracleArray. (Inherited from Devart.Data.Oracle.NativeOracleArray)
public Property | Value | Gets the value of the NativeOracleArray as .NET Framework array of the elements of the same type. (Inherited from Devart.Data.Oracle.NativeOracleArray)
Top

See Also

Reference

NativeOracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleAnyData Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleAnyData Class : OracleAnyData Constructor

Overload List

Overload | Description
OracleAnyData Constructor | Initializes a new instance of the OracleAnyData class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleAnyData Class
OracleAnyData Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleAttribute Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttribute Class

For a list of all members of this type, see OracleAttribute members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleAttribute Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleAttributeCollection Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleAttributeCollection Class

For a list of all members of this type, see OracleAttributeCollection members.

Public Methods

 | Name | Description
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

OracleAttributeCollection Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleBinary Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleBinary Structure : OracleBinary Constructor

Overload List

Overload | Description
OracleBinary Constructor | Initializes a new instance of the OracleBinary structure, setting the Value property to the provided array of bytes.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleBinary Structure
OracleBinary Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleClientFactory Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleClientFactory Class

For a list of all members of this type, see OracleClientFactory members.

Public Methods

 | Name | Description
public Method | CreateCommand | Returns a new instance of the provider's class that implements the System.Data.Common.DbCommand class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateCommandBuilder | Returns a new instance of the provider's class that implements the System.Data.Common.DbCommandBuilder class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateConnection | Returns a new instance of the provider's class that implements the System.Data.Common.DbConnection class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateConnectionStringBuilder | Returns a new instance of the provider's class that implements the System.Data.Common.DbConnectionStringBuilder class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateDataAdapter | Returns a new instance of the provider's class that implements the System.Data.Common.DbDataAdapter class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateDataSourceEnumerator | Returns a new instance of the provider's class that implements the System.Data.Common.DbDataSourceEnumerator class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreateParameter | Returns a new instance of the provider's class that implements the System.Data.Common.DbParameter class. (Inherited from System.Data.Common.DbProviderFactory)
public Method | CreatePermission | Returns a new instance of the provider's class that implements the provider's version of the System.Security.CodeAccessPermission class. (Inherited from System.Data.Common.DbProviderFactory)
Top

See Also

Reference

OracleClientFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleClientFactory Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleClientFactory Class

For a list of all members of this type, see OracleClientFactory members.

Public Properties

 | Name | Description
public Property | CanCreateDataSourceEnumerator | Specifies whether the specific System.Data.Common.DbProviderFactory supports the System.Data.Common.DbDataSourceEnumerator class. (Inherited from System.Data.Common.DbProviderFactory)
Top

See Also

Reference

OracleClientFactory Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleCommand Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommand Class

For a list of all members of this type, see OracleCommand members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleCommand Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleCommandBuilder Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleCommandBuilder Class

For a list of all members of this type, see OracleCommandBuilder members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleCommandBuilder Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleCursor Class : Dispose Method

Disposes the resources allocated by the OracleCursor object.

Overload List

Overload | Description
Dispose | Disposes the resources allocated by the OracleCursor object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleCursor Class
OracleCursor Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : Dispose Method

Releases all resources allocated by this object.

Overload List

Overload | Description
Dispose | Releases all resources allocated by this object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNonQuery Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDatabase Class : ExecuteNonQuery Method

Executes SQL statement against this Oracle Database instance.

Overload List

Overload | Description
ExecuteNonQuery | Executes SQL statement against this Oracle Database instance.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDatabase Class
OracleDatabase Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleDataSet Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleDataSet Class

For a list of all members of this type, see OracleDataSet members.

Public Events

 | Name | Description
public Event | Disposed | Adds an event handler to listen to the System.ComponentModel.MarshalByValueComponent.Disposed event on the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Event | Initialized | Occurs after the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Event | MergeFailed | Occurs when a target and source System.Data.DataRow have the same primary key value, and System.Data.DataSet.EnforceConstraints is set to true. (Inherited from System.Data.DataSet)
Top

See Also

Reference

OracleDataSet Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleDependency Class : Dispose Method

Releases all resources allocated by this object.

Overload List

Overload | Description
Dispose | Releases all resources allocated by this object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleDependency Class
OracleDependency Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Contains Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : Contains Method

Determines whether Oracle home with the specified name is present at the system.

Overload List

Overload | Description
Contains | Determines whether Oracle home with the specified name is present at the system.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Item Property
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHomeCollection Class : Item Property

Gets an information about Oracle home with the specified home name.

Overload List

Overload | Description
Item | Gets an information about Oracle home with the specified home name.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHomeCollection Class
OracleHomeCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetServerList Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleHome Class : GetServerList Method

Returns an array of available TNS aliases.

Overload List

Overload | Description
GetServerList | Returns an array of available TNS aliases.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleHome Class
OracleHome Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiply Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalDS Structure : Multiply Method

Multiplies an OracleIntervalDS value by a number.

Overload List

Overload | Description
Multiply | Multiplies an OracleIntervalDS value by a number.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalDS Structure
OracleIntervalDS Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Multiply Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleIntervalYM Structure : Multiply Method

Multiplies an OracleIntervalYM value by a number.

Overload List

Overload | Description
Multiply | Multiplies an OracleIntervalYM value by a number.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleIntervalYM Structure
OracleIntervalYM Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleLoaderColumn Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleLoaderColumn Class

For a list of all members of this type, see OracleLoaderColumn members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleLoaderColumn Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
CreateColumns Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLoader Class : CreateColumns Method

Retrieves table columns information from the table specified in the TableName property and populates columns collection.

Overload List

Overload | Description
CreateColumns | Retrieves table columns information from the table specified in the TableName property and populates columns collection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLoader Class
OracleLoader Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Dispose Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleLob Class : Dispose Method

Disposes the resources allocated by the OracleLob object.

Overload List

Overload | Description
Dispose | Disposes the resources allocated by the OracleLob object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleLob Class
OracleLob Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleMonitor Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMonitor Class

For a list of all members of this type, see OracleMonitor members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | TraceEvent | Occurs when Devart.Common.DbMonitor object signals about some database activity. (Inherited from Devart.Common.DbMonitor)
Top

See Also

Reference

OracleMonitor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleMonitor Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleMonitor Class

For a list of all members of this type, see OracleMonitor members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

OracleMonitor Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleNumberMappingCollection Class : TryParse Method

Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance as an out parameter.

Overload List

Overload | Description
TryParse | Parses a string representation of an Devart.Data.Oracle.OracleNumberMappingCollection and returns Devart.Data.Oracle.OracleNumberMappingCollection instance as an out parameter.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleNumberMappingCollection Class
OracleNumberMappingCollection Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OraclePackage Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePackage Class

For a list of all members of this type, see OraclePackage members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePackage Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleParameterCollection Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleParameterCollection Class : OracleParameterCollection Constructor

Overload List

Overload | Description
OracleParameterCollection Constructor | Initializes a new instance of OracleParameterCollection.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleParameterCollection Class
OracleParameterCollection Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OraclePermission Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OraclePermission Class : OraclePermission Constructor

Overload List

Overload | Description
OraclePermission Constructor | Initializes a new instance of the OraclePermission class with one of the System.Security.Permissions.PermissionState values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OraclePermission Class
OraclePermission Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OraclePipe Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OraclePipe Class

For a list of all members of this type, see OraclePipe members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OraclePipe Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleProviderException Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderException Class

For a list of all members of this type, see OracleProviderException members.

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

OracleProviderException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleProviderException Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleProviderException Class

For a list of all members of this type, see OracleProviderException members.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

OracleProviderException Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleQueueAdmin Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueAdmin Class

For a list of all members of this type, see OracleQueueAdmin members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueAdmin Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleQueueTable Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleQueueTable Class

For a list of all members of this type, see OracleQueueTable members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleQueueTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleRowUpdatedEventArgs Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleRowUpdatedEventArgs Class

For a list of all members of this type, see OracleRowUpdatedEventArgs members.

Public Methods

 | Name | Description
public Method | CopyToRows | Overloaded. Copies references to the modified rows into the provided array. (Inherited from System.Data.Common.RowUpdatedEventArgs)
Top

See Also

Reference

OracleRowUpdatedEventArgs Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Class Properties
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleSelectStatement Class

For a list of all members of this type, see OracleSelectStatement members.

Public Properties

 | Name | Description
public Property | All | Gets or sets the value, indicating if the all records are selected or only the unique ones. (Inherited from Devart.Common.SelectStatement)
public Property | Columns | Contains list of columns and expressions used in the select-list of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Distinct | Gets or sets whether statement should request unique rows only. (Inherited from Devart.Common.SelectStatement)
public Property | GroupBy | Contains list of columns used in the GROUP BY clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Having | Gets or sets HAVING clause of the statement. (Inherited from Devart.Common.SelectStatement)
public Property | OrderBy | Contains list of columns used in the ORDER BY clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Tables | Contains list of tables and subqueries used in the FROM clause of the current SelectStatement object. (Inherited from Devart.Common.SelectStatement)
public Property | Where | Gets or sets WHERE clause of the statement. (Inherited from Devart.Common.SelectStatement)
Top

See Also

Reference

OracleSelectStatement Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
OracleSelectStatement Constructor
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : OracleSelectStatement Constructor

Overload List

Overload | Description
OracleSelectStatement Constructor | Creates a new instance of the OracleSelectStatement class.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Parse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : Parse Method

Converts the specified SELECT statement to a OracleSelectStatement object.

Overload List

Overload | Description
Parse | Converts the specified SELECT statement to a OracleSelectStatement object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
TryParse Method
See Also support@devart.com
Devart.Data.Oracle Namespace > OracleSelectStatement Class : TryParse Method

Tries to convert the specified SELECT statement to a OracleSelectStatement object.

Overload List

Overload | Description
TryParse | Tries to convert the specified SELECT statement to a OracleSelectStatement object.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

OracleSelectStatement Class
OracleSelectStatement Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
OracleTable Class Methods
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTable Class

For a list of all members of this type, see OracleTable members.

Public Methods

 | Name | Description
public Method | Add | Adds an object of specified OracleType.ItemDbType type to the end of the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Clear | Removes all elements from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Clone | Creates a copy of an OracleArray object. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Contains | Determines whether an element is in the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | CopyTo | Copies the entire OracleArray to a compatible System.Array starting at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | GetEnumerator | Returns an enumerator for the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | GetOracleValue | Gets the value of the array element at the specified ordinal in its Oracle format. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | IndexOf | Gets the location in the collection of the OracleArray object. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Insert | Inserts an OracleArray into the collection at the specified index. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | Remove | Removes the specified element from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
public Method | RemoveAt | Removes the element at the specified index from the OracleArray. (Inherited from Devart.Data.Oracle.OracleArray)
Top

See Also

Reference

OracleTable Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleTrace Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTrace Class

For a list of all members of this type, see OracleTrace members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

OracleTrace Class
Devart.Data.Oracle Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
OracleTransaction Class Events
See Also support@devart.com
Devart.Data.Oracle Namespace : OracleTransaction Class

For a list of all members of this type, see OracleTransaction members.

Public Events

 | Name | Description
public Event | StateChanged | Occurs when the state of the transaction is changed. (Inherited from Devart.Common.DbTransactionBase)
public Event | StateChanging | Occurs when the state of the transaction is changing. (Inherited from Devart.Common.DbTransactionBase)
Top

See Also

Reference

OracleTransaction Class
Devart.Data.Oracle Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Length Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : Length Property

Gets length of the statement in symbols.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length {get;}

Property Value

Length of the statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LineNumber Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : LineNumber Property

Gets number of line in the whole script where the statement can be located.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LineNumber As Integer
C#
public int LineNumber {get;}

Property Value

Number of line in the whole script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
LinePosition Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : LinePosition Property

Gets position of the statement in its line.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LinePosition As Integer
C#
public int LinePosition {get;}

Property Value

Position of the statement.

Remarks

Read the property to get offset of the statement from the beginning of the line where it can be located.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Offset Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : Offset Property

Gets offset of the statement in the whole script text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset As Integer
C#
public int Offset {get;}

Property Value

Offset of the statement in the script text.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementStatus Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : StatementStatus Property

Determines status of the statement and script execution.

Syntax

Visual Basic (Declaration)
Public Property StatementStatus As SqlStatementStatus
C#
public SqlStatementStatus StatementStatus {get; set;}

Property Value

One of the Devart.Common.SqlStatementStatus values. The default value is Devart.Common.SqlStatementStatus.Continue.

Remarks

By setting this property you can control what should be done with the statement.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
StatementType Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : StatementType Property

Gets type of the statement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StatementType As SqlStatementType
C#
public SqlStatementType StatementType {get;}

Property Value

One of the Devart.Common.SqlStatementType values.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Text Property
See Also support@devart.com
Devart.Data.Oracle Namespace > SqlStatementExecuteEventArgs Class : Text Property

Gets the SQL statement that is about to be executed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Property Value

The SQL statement to be executed.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SqlStatementExecuteEventArgs Class
SqlStatementExecuteEventArgs Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Data.Oracle Namespace Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
Devart.Common.DbCommandBase
System.Data.Common.DbCommand
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleCommand
Devart.Common.DbCommandBuilder
Devart.Common.DbCommandBuilderBase
System.Data.Common.DbCommandBuilder
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleCommandBuilder
Devart.Common.DbConnectionBase
System.Data.Common.DbConnection
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleConnection
Devart.Common.DbConnectionStringBuilder
System.Data.Common.DbConnectionStringBuilder
Devart.Data.Oracle.OracleConnectionStringBuilder
Devart.Common.DbDataAdapter
System.Data.Common.DbDataAdapter
System.Data.Common.DataAdapter
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleDataAdapter
Devart.Common.DbDataReaderBase
System.Data.Common.DbDataReader
System.MarshalByRefObject
Devart.Data.Oracle.OracleDataReader
Devart.Common.DbDataSet
System.Data.DataSet
System.ComponentModel.MarshalByValueComponent
Devart.Data.Oracle.OracleDataSet
Devart.Common.DbDataTable
System.Data.DataTable
System.ComponentModel.MarshalByValueComponent
Devart.Data.Oracle.OracleDataTable
Devart.Common.DbLoader
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleLoader
Devart.Common.DbLoaderColumn
System.MarshalByRefObject
Devart.Data.Oracle.OracleLoaderColumn
Devart.Common.DbLoaderColumnCollection
System.Collections.CollectionBase
Devart.Data.Oracle.OracleLoaderColumnCollection
Devart.Common.DbMonitorHelper
Devart.Common.DbMonitor
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleMonitor
Devart.Common.DbParameterBase
System.Data.Common.DbParameter
System.MarshalByRefObject
Devart.Data.Oracle.OracleParameter
Devart.Common.DbParameterBaseCollection
System.Data.Common.DbParameterCollection
System.MarshalByRefObject
Devart.Data.Oracle.OracleParameterCollection
Devart.Common.DbProviderException
System.Exception
Devart.Data.Oracle.OracleProviderException
Devart.Common.DbScript
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleScript
Devart.Common.DbStatementExecuteEventArgs
System.EventArgs
Devart.Data.Oracle.SqlStatementExecuteEventArgs
Devart.Common.DbTransactionBase
System.Data.Common.DbTransaction
System.MarshalByRefObject
Devart.Data.Oracle.OracleTransaction
Devart.Common.SelectStatement
Devart.Data.Oracle.OracleSelectStatement
Devart.Common.SqlStatement
Devart.Data.Oracle.OracleSqlStatement
Devart.Common.SqlStatementCollection
System.Collections.CollectionBase
Devart.Data.Oracle.OracleSqlStatementCollection
Devart.Data.Oracle.DirectUtils
Devart.Data.Oracle.OracleAlert
Devart.Data.Oracle.OracleAnyData
Devart.Data.Oracle.OracleArray
Devart.Data.Oracle.OracleTable
Devart.Data.Oracle.OracleDatabase
Devart.Data.Oracle.OracleDependency
Devart.Data.Oracle.OracleError
Devart.Data.Oracle.OracleErrorCollection
Devart.Data.Oracle.OracleGlobalization
Devart.Data.Oracle.OracleHome
Devart.Data.Oracle.OracleHomeCollection
Devart.Data.Oracle.OracleLogicalTransaction
Devart.Data.Oracle.OracleLogicalTransactionStatus
Devart.Data.Oracle.OracleMetaDataCollectionNames
Devart.Data.Oracle.OracleNotificationRequest
Devart.Data.Oracle.OracleNumberMapping
Devart.Data.Oracle.OracleNumberMappingCollection
Devart.Data.Oracle.OraclePipeMessage
Devart.Data.Oracle.OracleQueueAgent
Devart.Data.Oracle.OracleQueueDequeueOptions
Devart.Data.Oracle.OracleQueueEnqueueOptions
Devart.Data.Oracle.OracleQueueMessage
Devart.Data.Oracle.OracleQueueMessageProperties
Devart.Data.Oracle.OracleQueueOptions
Devart.Data.Oracle.OracleQueueTableOptions
Devart.Data.Oracle.OracleXml
System.Collections.CollectionBase
Devart.Data.Oracle.OracleAttributeCollection
Devart.Data.Oracle.OraclePipeMessageCollection
Devart.Data.Oracle.OracleQueueAgentCollection
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.Oracle.OracleAlerter
Devart.Data.Oracle.OraclePackage
Devart.Data.Oracle.OraclePipe
Devart.Data.Oracle.OracleQueue
Devart.Data.Oracle.OracleQueueAdmin
Devart.Data.Oracle.OracleQueueTable
Devart.Data.Oracle.OracleTrace
System.Data.Common.DbDataSourceEnumerator
Devart.Data.Oracle.OracleDataSourceEnumerator
System.Data.Common.DbException
System.Runtime.InteropServices.ExternalException
System.SystemException
System.Exception
Devart.Data.Oracle.OracleException
System.Data.Common.DbProviderFactory
Devart.Data.Oracle.OracleProviderFactory
Devart.Data.Oracle.OracleClientFactory
System.Data.Common.RowUpdatedEventArgs
System.EventArgs
Devart.Data.Oracle.OracleRowUpdatedEventArgs
System.Data.Common.RowUpdatingEventArgs
System.EventArgs
Devart.Data.Oracle.OracleRowUpdatingEventArgs
System.EventArgs
Devart.Data.Oracle.OracleAlerterAlertEventArgs
Devart.Data.Oracle.OracleAlerterErrorEventArgs
Devart.Data.Oracle.OracleAlerterFinishEventArgs
Devart.Data.Oracle.OracleConnectionErrorEventArgs
Devart.Data.Oracle.OracleFailoverEventsArgs
Devart.Data.Oracle.OracleHAEventArgs
Devart.Data.Oracle.OracleInfoMessageEventArgs
Devart.Data.Oracle.OracleLoaderErrorEventArgs
Devart.Data.Oracle.OracleLoaderRowsCopiedEventArgs
Devart.Data.Oracle.OracleNotificationEventArgs
Devart.Data.Oracle.OracleQueueMessageEventArgs
System.IO.Stream
System.MarshalByRefObject
Devart.Data.Oracle.OracleLob
Devart.Data.Oracle.OracleBFile
System.MarshalByRefObject
Devart.Data.Oracle.NativeOracleObjectBase
Devart.Data.Oracle.NativeOracleArray
Devart.Data.Oracle.NativeOracleTable
Devart.Data.Oracle.NativeOracleObject
Devart.Data.Oracle.OracleArrayDataReader
Devart.Data.Oracle.OracleAttribute
Devart.Data.Oracle.OracleCursor
Devart.Data.Oracle.OracleObject
Devart.Data.Oracle.OracleRef
Devart.Data.Oracle.OracleType
System.Security.CodeAccessPermission
Devart.Data.Oracle.OraclePermission
System.Security.Permissions.CodeAccessSecurityAttribute
System.Security.Permissions.SecurityAttribute
System.Attribute
Devart.Data.Oracle.OraclePermissionAttribute
System.ValueType
Devart.Data.Oracle.OracleBinary
Devart.Data.Oracle.OracleDate
Devart.Data.Oracle.OracleIntervalDS
Devart.Data.Oracle.OracleIntervalYM
Devart.Data.Oracle.OracleNumber
Devart.Data.Oracle.OracleQueueMessageId
Devart.Data.Oracle.OracleString
Devart.Data.Oracle.OracleTimeStamp

See Also

Reference

Devart.Data.Oracle Assembly


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbSyncProviderBase Class Events
See Also support@devart.com
Devart.Data.Synchronization Namespace : DbSyncProviderBase Class

For a list of all members of this type, see DbSyncProviderBase members.

Public Events

 | Name | Description
public Event | ApplyChangeFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ApplyMetadataFailed | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | BatchSpooled | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesApplied | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | ChangesSelected | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | DbConnectionFailure | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SelectingChanges | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncPeerOutdated | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
public Event | SyncProgress | (Inherited from Microsoft.Synchronization.Data.RelationalSyncProvider)
Top

See Also

Reference

DbSyncProviderBase Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterConfigurationCollection Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterConfigurationCollection Class

For a list of all members of this type, see SyncProviderAdapterConfigurationCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterConfiguration>)
Top

See Also

Reference

SyncProviderAdapterConfigurationCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncProviderAdapterParametersCollection Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncProviderAdapterParametersCollection Class

For a list of all members of this type, see SyncProviderAdapterParametersCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncProviderAdapterParameters>)
Top

See Also

Reference

SyncProviderAdapterParametersCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncSqlParameterCollection Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncSqlParameterCollection Class

For a list of all members of this type, see SyncSqlParameterCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<DbParameter>)
Top

See Also

Reference

SyncSqlParameterCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
SyncTableProvisioningCollection Class Methods
See Also support@devart.com
Devart.Data.Synchronization Namespace : SyncTableProvisioningCollection Class

For a list of all members of this type, see SyncTableProvisioningCollection members.

Public Methods

 | Name | Description
public Method | Add | Adds an object to the end of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Clear | Removes all elements from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Contains | Determines whether an element is in the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | CopyTo | Copies the entire Collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | GetEnumerator | Returns an enumerator that iterates through the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Insert | Inserts an element into the Collection at the specified index. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | Remove | Removes the first occurrence of a specific object from the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
public Method | RemoveAt | Removes the element at the specified index of the Collection. (Inherited from System.Collections.ObjectModel.Collection<SyncTableProvisioning>)
Top

See Also

Reference

SyncTableProvisioningCollection Class
Devart.Data.Synchronization Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Apply Method
See Also support@devart.com
Devart.Data.Synchronization Namespace > SyncTableProvisioning Class : Apply Method

Applies the provisioning script to a database.

Overload List

Overload | Description
Apply | Applies the provisioning script to a database.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

SyncTableProvisioning Class
SyncTableProvisioning Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Data.Synchronization Namespace Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
Devart.Data.Synchronization.SyncProviderAdapterConfiguration
Devart.Data.Synchronization.SyncProviderAdapterParameters
Devart.Data.Synchronization.SyncProviderFilterParameter
Devart.Data.Synchronization.SyncProviderScopeConfiguration
Devart.Data.Synchronization.SyncProviderScopeParameters
Devart.Data.Synchronization.SyncScopeDeprovisioning
Devart.Data.Synchronization.SyncScopeProvisioning
Devart.Data.Synchronization.SyncTableProvisioning
Microsoft.Synchronization.Data.DbSyncProvider
Microsoft.Synchronization.Data.RelationalSyncProvider
Microsoft.Synchronization.KnowledgeSyncProvider
Microsoft.Synchronization.SyncProvider
Devart.Data.Synchronization.DbSyncProviderBase
System.Collections.ObjectModel.Collection<T>
Devart.Data.Synchronization.SyncProviderAdapterConfigurationCollection
Devart.Data.Synchronization.SyncProviderAdapterParametersCollection
Devart.Data.Synchronization.SyncSqlParameterCollection
Devart.Data.Synchronization.SyncTableProvisioningCollection

See Also

Reference

Devart.Data.Synchronization Assembly


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbCommandBase Class Events
See Also support@devart.com
Devart.Common Namespace : DbCommandBase Class

For a list of all members of this type, see DbCommandBase members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilder Class Events
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilder Class

For a list of all members of this type, see DbCommandBuilder members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBuilder Class
Devart.Common Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbCommandBuilderBase Class Events
See Also support@devart.com
Devart.Common Namespace : DbCommandBuilderBase Class

For a list of all members of this type, see DbCommandBuilderBase members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbCommandBuilderBase Class
Devart.Common Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbDataAdapter Class Events
See Also support@devart.com
Devart.Common Namespace : DbDataAdapter Class

For a list of all members of this type, see DbDataAdapter members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | FillError | Returned when an error occurs during a fill operation. (Inherited from System.Data.Common.DataAdapter)
Top

See Also

Reference

DbDataAdapter Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbDataAdapter Class Properties
See Also support@devart.com
Devart.Common Namespace : DbDataAdapter Class

For a list of all members of this type, see DbDataAdapter members.

Public Properties

 | Name | Description
public Property | AcceptChangesDuringFill | Gets or sets a value indicating whether System.Data.DataRow.AcceptChanges is called on a System.Data.DataRow after it is added to the System.Data.DataTable during any of the Fill operations. (Inherited from System.Data.Common.DataAdapter)
public Property | AcceptChangesDuringUpdate | Gets or sets whether System.Data.DataRow.AcceptChanges is called during a System.Data.Common.DataAdapter.Update(System.Data.DataSet). (Inherited from System.Data.Common.DataAdapter)
public Property | Container | Gets the System.ComponentModel.IContainer that contains the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | ContinueUpdateOnError | Gets or sets a value that specifies whether to generate an exception when an error is encountered during a row update. (Inherited from System.Data.Common.DataAdapter)
public Property | DeleteCommand | Gets or sets a command for deleting records from the data set. (Inherited from System.Data.Common.DbDataAdapter)
public Property | FillLoadOption | Gets or sets the System.Data.LoadOption that determines how the adapter fills the System.Data.DataTable from the System.Data.Common.DbDataReader. (Inherited from System.Data.Common.DataAdapter)
public Property | InsertCommand | Gets or sets a command used to insert new records into the data source. (Inherited from System.Data.Common.DbDataAdapter)
public Property | MissingMappingAction | Determines the action to take when incoming data does not have a matching table or column. (Inherited from System.Data.Common.DataAdapter)
public Property | MissingSchemaAction | Determines the action to take when existing System.Data.DataSet schema does not match incoming data. (Inherited from System.Data.Common.DataAdapter)
public Property | ReturnProviderSpecificTypes | Gets or sets whether the Fill method should return provider-specific values or common CLS-compliant values. (Inherited from System.Data.Common.DataAdapter)
public Property | SelectCommand | Gets or sets a command used to select records in the data source. (Inherited from System.Data.Common.DbDataAdapter)
public Property | Site | Gets or sets the System.ComponentModel.ISite of the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Property | TableMappings | Gets a collection that provides the master mapping between a source table and a System.Data.DataTable. (Inherited from System.Data.Common.DataAdapter)
public Property | UpdateBatchSize | Gets or sets a value that enables or disables batch processing support, and specifies the number of commands that can be executed in a batch. (Inherited from System.Data.Common.DbDataAdapter)
public Property | UpdateCommand | Gets or sets a command used to update records in the data source. (Inherited from System.Data.Common.DbDataAdapter)
Top

See Also

Reference

DbDataAdapter Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificFieldType Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetProviderSpecificFieldType Method

Returns the provider-specific field type of the specified column.

Overload List

Overload | Description
GetProviderSpecificFieldType | Returns the provider-specific field type of the specified column.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
GetProviderSpecificValue Method
See Also support@devart.com
Devart.Common Namespace > DbDataReaderBase Class : GetProviderSpecificValue Method

Gets the value of the specified column as an instance of System.Object

Overload List

Overload | Description
GetProviderSpecificValue | Gets the value of the specified column as an instance of System.Object

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataReaderBase Class
DbDataReaderBase Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbDataSet Class Events
See Also support@devart.com
Devart.Common Namespace : DbDataSet Class

For a list of all members of this type, see DbDataSet members.

Public Events

 | Name | Description
public Event | Disposed | Adds an event handler to listen to the System.ComponentModel.MarshalByValueComponent.Disposed event on the component. (Inherited from System.ComponentModel.MarshalByValueComponent)
public Event | Initialized | Occurs after the System.Data.DataSet is initialized. (Inherited from System.Data.DataSet)
public Event | MergeFailed | Occurs when a target and source System.Data.DataRow have the same primary key value, and System.Data.DataSet.EnforceConstraints is set to true. (Inherited from System.Data.DataSet)
Top

See Also

Reference

DbDataSet Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clear Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Clear Method

Clears DbDataTable and stops Fill operation.

Overload List

Overload | Description
Clear | Clears DbDataTable and stops Fill operation.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Clone Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Clone Method

Clones the structure of the DbDataTable, including all System.Data.DataTable schemes and constraints.

Overload List

Overload | Description
Clone | Clones the structure of the DbDataTable, including all System.Data.DataTable schemes and constraints.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Close Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Close Method

Disconnects DbDataTable from the data source and frees server resources allocated for the query.

Overload List

Overload | Description
Close | Disconnects DbDataTable from the data source and frees server resources allocated for the query.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Open Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Open Method

Fetches data and sets the Active property to true.

Overload List

Overload | Description
Open | Fetches data and sets the Active property to true.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
RefreshRow Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : RefreshRow Method

Refreshes the specified row with values from server.

Overload List

Overload | Description
RefreshRow | Refreshes the specified row with values from server.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
Update Method
See Also support@devart.com
Devart.Common Namespace > DbDataTable Class : Update Method

Executes the appropriate commands to delete, insert, or update rows in the data source.

Overload List

Overload | Description
Update | Executes the appropriate commands to delete, insert, or update rows in the data source.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbDataTable Class
DbDataTable Members


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbDump Class Events
See Also support@devart.com
Devart.Common Namespace : DbDump Class

For a list of all members of this type, see DbDump members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbDump Class
Devart.Common Namespace


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DbLoader Class Events
See Also support@devart.com
Devart.Common Namespace : DbLoader Class

For a list of all members of this type, see DbLoader members.

Public Events

 | Name | Description
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

DbLoader Class
Devart.Common Namespace


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbMonitor Class Methods
See Also support@devart.com
Devart.Common Namespace : DbMonitor Class

For a list of all members of this type, see DbMonitor members.

Public Methods

 | Name | Description
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases all resources used by the System.ComponentModel.Component. (Inherited from System.ComponentModel.Component)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

DbMonitor Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
DbProviderException Class Properties
See Also support@devart.com
Devart.Common Namespace : DbProviderException Class

For a list of all members of this type, see DbProviderException members.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DbProviderException Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ExecuteNext Method
See Also support@devart.com
Devart.Common Namespace > DbScript Class : ExecuteNext Method

Executes the next statement from the script.

Overload List

Overload | Description
ExecuteNext | Executes the next statement from the script.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

DbScript Class
DbScript Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
DbTransactionBase Class Methods
See Also support@devart.com
Devart.Common Namespace : DbTransactionBase Class

For a list of all members of this type, see DbTransactionBase members.

Public Methods

 | Name | Description
public Method | Commit | Commits the database transaction. (Inherited from System.Data.Common.DbTransaction)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | Releases the unmanaged resources used by the System.Data.Common.DbTransaction. (Inherited from System.Data.Common.DbTransaction)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Rollback | Rolls back a transaction from a pending state. (Inherited from System.Data.Common.DbTransaction)
Top

See Also

Reference

DbTransactionBase Class
Devart.Common Namespace


%%PageItemTitle%%

[image]
dotConnect for Oracle Documentation
ParentDataRelation Constructor
See Also support@devart.com
Devart.Common Namespace > ParentDataRelation Class : ParentDataRelation Constructor

Overload List

Overload | Description
ParentDataRelation Constructor | Initializes a new instance of the ParentDataRelation class using the specified parent DbDataTable and matched arrays of parent and child column names.

Requirements

Platforms:Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family, Windows 7, Windows 8, Windows 10, Windows Server 2012 family.

See Also

Reference

ParentDataRelation Class
ParentDataRelation Members


%%PageItemTitle%% $$Methods$$

[image]
dotConnect for Oracle Documentation
QueryRecordCountException Class Methods
See Also support@devart.com
Devart.Common Namespace : QueryRecordCountException Class

For a list of all members of this type, see QueryRecordCountException members.

Public Methods

 | Name | Description
public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Top

See Also

Reference

QueryRecordCountException Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
QueryRecordCountException Class Properties
See Also support@devart.com
Devart.Common Namespace : QueryRecordCountException Class

For a list of all members of this type, see QueryRecordCountException members.

Public Properties

 | Name | Description
public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

QueryRecordCountException Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangedEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : TransactionStateChangedEventArgs Class

For a list of all members of this type, see TransactionStateChangedEventArgs members.

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs. (Inherited from Devart.Common.TransactionStateChangeEventArgs)
Top

See Also

Reference

TransactionStateChangedEventArgs Class
Devart.Common Namespace


%%PageItemTitle%% $$Properties$$

[image]
dotConnect for Oracle Documentation
TransactionStateChangingEventArgs Class Properties
See Also support@devart.com
Devart.Common Namespace : TransactionStateChangingEventArgs Class

For a list of all members of this type, see TransactionStateChangingEventArgs members.

Public Properties

 | Name | Description
public Property | Action | Indicates the operation that is being performed or has been performed in the transaction when the DbTransactionBase.StateChanged or DbTransactionBase.StateChanging event occurs. (Inherited from Devart.Common.TransactionStateChangeEventArgs)
Top

See Also

Reference

TransactionStateChangingEventArgs Class
Devart.Common Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Common Namespace (Devart.Data) Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
Devart.Common.ParentDataRelation
Devart.Common.SqlStatement
System.Collections.CollectionBase
Devart.Common.DbLoaderColumnCollection
Devart.Common.SqlStatementCollection
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbDump
Devart.Common.DbLoader
Devart.Common.DbMonitor
Devart.Common.DbScript
System.Data.Common.DbCommand
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbCommandBase
System.Data.Common.DbCommandBuilder
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbCommandBuilderBase
Devart.Common.DbCommandBuilder
System.Data.Common.DbConnectionStringBuilder
Devart.Common.DbConnectionStringBuilder
System.Data.Common.DbDataAdapter
System.Data.Common.DataAdapter
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Common.DbDataAdapter
System.Data.Common.DbDataReader
System.MarshalByRefObject
Devart.Common.DbDataReaderBase
System.Data.Common.DbDataSourceEnumerator
Devart.Common.DbDataSourceEnumerator
System.Data.Common.DbParameter
System.MarshalByRefObject
Devart.Common.DbParameterBase
System.Data.Common.DbParameterCollection
System.MarshalByRefObject
Devart.Common.DbParameterBaseCollection
System.Data.Common.DbTransaction
System.MarshalByRefObject
Devart.Common.DbTransactionBase
System.Data.DataSet
System.ComponentModel.MarshalByValueComponent
Devart.Common.DbDataSet
System.Data.DataTable
System.ComponentModel.MarshalByValueComponent
Devart.Common.DbDataTable
System.EventArgs
Devart.Common.MonitorEventArgs
Devart.Common.ScriptErrorEventArgs
Devart.Common.ScriptProgressEventArgs
Devart.Common.TransactionStateChangeEventArgs
Devart.Common.TransactionStateChangedEventArgs
Devart.Common.TransactionStateChangingEventArgs
System.Exception
Devart.Common.DbProviderException
Devart.Common.QueryRecordCountException
System.MarshalByRefObject
Devart.Common.DbLoaderColumn

See Also

Reference

Devart.Data Assembly


%%PageItemTitle%% $$Events$$

[image]
dotConnect for Oracle Documentation
DataLink Class Events
See Also support@devart.com
Devart.Data Namespace : DataLink Class

For a list of all members of this type, see DataLink members.

Public Events

 | Name | Description
public Event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from System.Windows.Forms.BindingSource)
public Event | BindingComplete | Occurs when all the clients have been bound to this System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from System.Windows.Forms.BindingSource)
public Event | CurrentItemChanged | Occurs when a property value of the System.Windows.Forms.BindingSource.Current property has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataError | Occurs when a currency-related exception is silently handled by the System.Windows.Forms.BindingSource. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataMemberChanged | Occurs when the System.Windows.Forms.BindingSource.DataMember property value has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | DataSourceChanged | Occurs when the System.Windows.Forms.BindingSource.DataSource property value has changed. (Inherited from System.Windows.Forms.BindingSource)
public Event | Disposed | Occurs when the component is disposed by a call to the System.ComponentModel.Component.Dispose method. (Inherited from System.ComponentModel.Component)
public Event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from System.Windows.Forms.BindingSource)
public Event | PositionChanged | Occurs after the value of the System.Windows.Forms.BindingSource.Position property has changed. (Inherited from System.Windows.Forms.BindingSource)
Top

See Also

Reference

DataLink Class
Devart.Data Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Devart.Data Namespace Inheritance Hierarchy
See Also support@devart.com

Inheritance Hierarchy

System.Object
System.Windows.Forms.BindingSource
System.ComponentModel.Component
System.MarshalByRefObject
Devart.Data.DataLink

See Also

Reference

Devart.Data Assembly


dotConnect for Oracle Namespaces

dotConnect for Oracle Reference
support@devart.com

dotConnect for Oracle provides you with two namespaces: Devart.Common and Devart.Data.Oracle. Classes in Devart.Common namespace represent functionality of ADO.NET 2 API. Namespace Devart.Data.Oracle extends Devart.Common functionality and adds Oracle-specific features. Thus you can use advantages of ADO.NET 2 features regardless of what .NET framework you are using.

Namespace | Description
Devart.Common | Devart.Common namespace contains classes shared by the Devart data providers.
Devart.Data.Oracle | This namespace is the dotConnect for Oracle.