DlhSoft.Windows.Controls Namespace

[image]

.NET Framework Class Library
DlhSoft.Windows.Controls Namespace
Send Feedback

Classes

Class | Description
ContentControl | Represents a control that can be used to present an items. Use Content property to set the entity data item managed by the control. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to select the content from.
DateTimePicker | Represents a combo box that allows selecting a date and edit a date and time value.
ItemsControl | Represents a control that can be used to present a collection of items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.
ListBox | Contains a list of selectable entity data items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.
ListView | Represents a control that displays a list of entity data items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.
TreeCommands | Provides a standard set of tree related commands.
TreeGridViewColumn | Represents a column that displays hierarchical data.
TreeListView | Represents a control that displays a tree-list of node data items. Use Items property to add node data items to an ItemCollection managed by the control, or set ItemsSource to your own node data item collection. It is recommended to set at least these data member properties: IndentationMemberPath. These data member properties can also be set: IsExpandedMemberPath. Alternatively you can set the NodeManagerSource to a customized node manager to use and to ignore the items collection and any associated data member properties. It is recommended to use a single NodeManager instance for each set of distinct node data items and data member properties at any specific time, and to use the Dispose method to release the resources used by an instance that is no longer needed.
TreeListViewItem | Represents an item in the TreeListView control aware of its indentation and expansion state (can be expanded or collapsed). It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.
TreeListViewItemControl | Displays the indented content of a TreeListViewItem providing an expander that allows the user to expand or collapse the node in the hierarchy.
Send feedback on this topic to DlhSoft.


ContentControl Class

[image]

.NET Framework Class Library
ContentControl Class
Members See Also Send Feedback

Represents a control that can be used to present an items. Use Content property to set the entity data item managed by the control. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to select the content from.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[TemplatePartAttribute(Name = "PART_ContentControlHost", Type = typeof(ContentControl))]
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public class ContentControl : ContentControlBase
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "PART_ContentControlHost", Type := GetType(ContentControl))> _
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public Class ContentControl _
    Inherits ContentControlBase

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ContentControlBase
DlhSoft.Windows.Controls..::.ContentControl
DlhSoft.Windows.Controls..::.TreeListViewItem

See Also

ContentControl Members
DlhSoft.Windows.Controls Namespace


ContentControl Members

[image] [image]

.NET Framework Class Library
ContentControl Members
ContentControl Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ContentControl type exposes the following members.

Constructors

Name | Description
ContentControl | Initializes a new instance of the ContentControl class.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ContentControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ContentControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity. (Inherited from ContentControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ContentControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ContentControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ContentControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContentControlHostContentTemplate | Gets the content template to be used within the ContentControl host.
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeContentTemplateDataContext | Initializes the data context of the ContentControl to be used as a content template.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ContentControlBase..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties. (Inherited from ContentControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides ContentControlBase..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes. (Inherited from ContentControlBase.)
OnContentStringFormatChanged | Called when the ContentStringFormat property changes.
OnContentTemplateChanged | Called when the ContentTemplate property changes.
OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes.
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ContentControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ContentControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ContentControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetContentControlHost | Resets the content control host based on the current property values of this ContentControl.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Inherited from ContentControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
ContentStringFormatProperty | Identifies the ContentStringFormat dependency property.
ContentTemplateProperty | Identifies the ContentTemplate dependency property.
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector dependency property.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseContentControl | Gets the base ContentControl used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase. (Inherited from ContentControlBase.)
ContentStringFormat | Gets or sets a composite string that specifies how to format the content in the ContentControl if it is displayed as string. This is a dependency property.
ContentTemplate | Gets or sets the DataTemplate to be used to display the content. This is a dependency property.
ContentTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display the content. This is a dependency property.
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property. (Inherited from ContentControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property. (Inherited from ContentControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available. (Inherited from ContentControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ContentControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property. (Inherited from ContentControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentControl Constructor

[image]

.NET Framework Class Library
ContentControl Constructor
ContentControl Class See Also Send Feedback

Initializes a new instance of the ContentControl class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ContentControl()
Visual Basic (Declaration)
Public Sub New

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentControl Fields

[image] [image]

.NET Framework Class Library
ContentControl Fields
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Fields

Name | Description
ContentStringFormatProperty | Identifies the ContentStringFormat dependency property.
ContentTemplateProperty | Identifies the ContentTemplate dependency property.
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector dependency property.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property.

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentStringFormatProperty Field

[image]

.NET Framework Class Library
ContentControl..::.ContentStringFormatProperty Field
ContentControl Class See Also Send Feedback

Identifies the ContentStringFormat dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ContentStringFormatProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentStringFormatProperty As DependencyProperty

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentTemplateProperty Field

[image]

.NET Framework Class Library
ContentControl..::.ContentTemplateProperty Field
ContentControl Class See Also Send Feedback

Identifies the ContentTemplate dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ContentTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentTemplateProperty As DependencyProperty

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentTemplateSelectorProperty Field

[image]

.NET Framework Class Library
ContentControl..::.ContentTemplateSelectorProperty Field
ContentControl Class See Also Send Feedback

Identifies the ContentTemplateSelector dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ContentTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentTemplateSelectorProperty As DependencyProperty

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


DisplayMemberPathProperty Field

[image]

.NET Framework Class Library
ContentControl..::.DisplayMemberPathProperty Field
ContentControl Class See Also Send Feedback

Identifies the DisplayMemberPath dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty DisplayMemberPathProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisplayMemberPathProperty As DependencyProperty

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentControl Methods

[image] [image]

.NET Framework Class Library
ContentControl Methods
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ContentControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ContentControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity. (Inherited from ContentControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ContentControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ContentControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ContentControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContentControlHostContentTemplate | Gets the content template to be used within the ContentControl host.
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeContentTemplateDataContext | Initializes the data context of the ContentControl to be used as a content template.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ContentControlBase..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties. (Inherited from ContentControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides ContentControlBase..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes. (Inherited from ContentControlBase.)
OnContentStringFormatChanged | Called when the ContentStringFormat property changes.
OnContentTemplateChanged | Called when the ContentTemplate property changes.
OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes.
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ContentControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ContentControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ContentControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetContentControlHost | Resets the content control host based on the current property values of this ContentControl.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Inherited from ContentControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ContentControl..::.AddHandler Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ContentControl..::.ApplyAnimationClock Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ContentControl..::.BeginAnimation Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ContentControl..::.BeginStoryboard Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ContentControl..::.BringIntoView Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ContentControl..::.ClearValue Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


GetContentControlHostContentTemplate Method

[image]

.NET Framework Class Library
ContentControl..::.GetContentControlHostContentTemplate Method
ContentControl Class See Also Send Feedback

Gets the content template to be used within the ContentControl host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual DataTemplate GetContentControlHostContentTemplate()
Visual Basic (Declaration)
Protected Friend Overridable Function GetContentControlHostContentTemplate As DataTemplate

Return Value

The content template to be used within the ContentControl host.

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ContentControl..::.HitTestCore Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


InitializeContentTemplateDataContext Method

[image]

.NET Framework Class Library
ContentControl..::.InitializeContentTemplateDataContext Method
ContentControl Class See Also Send Feedback

Initializes the data context of the ContentControl to be used as a content template.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeContentTemplateDataContext(
    FrameworkElementFactory contentControlFactory
)
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeContentTemplateDataContext ( _
    contentControlFactory As FrameworkElementFactory _
)

Parameters

contentControlFactory
Type: System.Windows..::.FrameworkElementFactory
The source ContentControl factory to set the data context for.

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
ContentControl..::.InitializeTemplateParts Method
ContentControl Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub InitializeTemplateParts

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ContentControl..::.OnApplyTemplate Method
ContentControl Class See Also Send Feedback

When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


OnContentStringFormatChanged Method

[image]

.NET Framework Class Library
ContentControl..::.OnContentStringFormatChanged Method
ContentControl Class See Also Send Feedback

Called when the ContentStringFormat property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnContentStringFormatChanged(
    string oldContentStringFormat,
    string newContentStringFormat
)
Visual Basic (Declaration)
Protected Overridable Sub OnContentStringFormatChanged ( _
    oldContentStringFormat As String, _
    newContentStringFormat As String _
)

Parameters

oldContentStringFormat
Type: System..::.String
newContentStringFormat
Type: System..::.String

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


OnContentTemplateChanged Method

[image]

.NET Framework Class Library
ContentControl..::.OnContentTemplateChanged Method
ContentControl Class See Also Send Feedback

Called when the ContentTemplate property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnContentTemplateChanged(
    DataTemplate oldContentTemplate,
    DataTemplate newContentTemplate
)
Visual Basic (Declaration)
Protected Overridable Sub OnContentTemplateChanged ( _
    oldContentTemplate As DataTemplate, _
    newContentTemplate As DataTemplate _
)

Parameters

oldContentTemplate
Type: System.Windows..::.DataTemplate
newContentTemplate
Type: System.Windows..::.DataTemplate

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


OnContentTemplateSelectorChanged Method

[image]

.NET Framework Class Library
ContentControl..::.OnContentTemplateSelectorChanged Method
ContentControl Class See Also Send Feedback

Called when the ContentTemplateSelector property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnContentTemplateSelectorChanged(
    DataTemplateSelector oldContentTemplateSelector,
    DataTemplateSelector newContentTemplateSelector
)
Visual Basic (Declaration)
Protected Overridable Sub OnContentTemplateSelectorChanged ( _
    oldContentTemplateSelector As DataTemplateSelector, _
    newContentTemplateSelector As DataTemplateSelector _
)

Parameters

oldContentTemplateSelector
Type: System.Windows.Controls..::.DataTemplateSelector
newContentTemplateSelector
Type: System.Windows.Controls..::.DataTemplateSelector

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


OnDisplayMemberPathChanged Method

[image]

.NET Framework Class Library
ContentControl..::.OnDisplayMemberPathChanged Method
ContentControl Class See Also Send Feedback

Called when the DisplayMemberPath property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnDisplayMemberPathChanged(
    string oldDisplayMemberPath,
    string newDisplayMemberPath
)
Visual Basic (Declaration)
Protected Overridable Sub OnDisplayMemberPathChanged ( _
    oldDisplayMemberPath As String, _
    newDisplayMemberPath As String _
)

Parameters

oldDisplayMemberPath
Type: System..::.String
newDisplayMemberPath
Type: System..::.String

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ResetContentControlHost Method

[image]

.NET Framework Class Library
ContentControl..::.ResetContentControlHost Method
ContentControl Class See Also Send Feedback

Resets the content control host based on the current property values of this ContentControl.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void ResetContentControlHost()
Visual Basic (Declaration)
Protected Friend Overridable Sub ResetContentControlHost

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ContentControl..::.SetBinding Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ContentControl..::.SetValue Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ContentControl..::.TransformToAncestor Method
ContentControl Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ContentControl Class
ContentControl Members
DlhSoft.Windows.Controls Namespace


ContentControl Properties

[image] [image]

.NET Framework Class Library
ContentControl Properties
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseContentControl | Gets the base ContentControl used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase. (Inherited from ContentControlBase.)
ContentStringFormat | Gets or sets a composite string that specifies how to format the content in the ContentControl if it is displayed as string. This is a dependency property.
ContentTemplate | Gets or sets the DataTemplate to be used to display the content. This is a dependency property.
ContentTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display the content. This is a dependency property.
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property. (Inherited from ContentControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property. (Inherited from ContentControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available. (Inherited from ContentControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ContentControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property. (Inherited from ContentControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


BaseContentControl Property

[image]

.NET Framework Class Library
ContentControl..::.BaseContentControl Property
ContentControl Class See Also Send Feedback

Gets the base ContentControl used as the core for this control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public ContentControl BaseContentControl { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property BaseContentControl As ContentControl

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentStringFormat Property

[image]

.NET Framework Class Library
ContentControl..::.ContentStringFormat Property
ContentControl Class See Also Send Feedback

Gets or sets a composite string that specifies how to format the content in the ContentControl if it is displayed as string. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string ContentStringFormat { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ContentStringFormat As String

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentTemplate Property

[image]

.NET Framework Class Library
ContentControl..::.ContentTemplate Property
ContentControl Class See Also Send Feedback

Gets or sets the DataTemplate to be used to display the content. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DataTemplate ContentTemplate { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ContentTemplate As DataTemplate

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentTemplateSelector Property

[image]

.NET Framework Class Library
ContentControl..::.ContentTemplateSelector Property
ContentControl Class See Also Send Feedback

Allows the application writer to provide custom logic for choosing a template used to display the content. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DataTemplateSelector ContentTemplateSelector { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ContentTemplateSelector As DataTemplateSelector

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


DisplayMemberPath Property

[image]

.NET Framework Class Library
ContentControl..::.DisplayMemberPath Property
ContentControl Class See Also Send Feedback

Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string DisplayMemberPath { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property DisplayMemberPath As String

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


ContentControl Events

[image] [image]

.NET Framework Class Library
ContentControl Events
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ContentControl Class
DlhSoft.Windows.Controls Namespace


DateTimePicker Class

[image]

.NET Framework Class Library
DateTimePicker Class
Members See Also Send Feedback

Represents a combo box that allows selecting a date and edit a date and time value.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.ComboBox)]
public class DateTimePicker : ComboBox
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.ComboBox)> _
Public Class DateTimePicker _
    Inherits ComboBox

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls.Primitives..::.Selector
System.Windows.Controls..::.ComboBox
DlhSoft.Windows.Controls..::.DateTimePicker

See Also

DateTimePicker Members
DlhSoft.Windows.Controls Namespace


DateTimePicker Members

[image] [image]

.NET Framework Class Library
DateTimePicker Members
DateTimePicker Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The DateTimePicker type exposes the following members.

Constructors

Name | Description
DateTimePicker | Initializes a new instance of the DateTimePicker class.

Methods

Name | Description
AddChild | (Inherited from ItemsControl.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | (Inherited from ItemsControl.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from ItemsControl.)
BeginStoryboard | Overloaded.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearContainerForItemOverride | (Inherited from Selector.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
ContainerFromElement | (Inherited from ItemsControl.)
EndInit | (Inherited from ItemsControl.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | (Inherited from ComboBox.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
IsItemItsOwnContainerOverride | (Inherited from ComboBox.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | (Inherited from ItemsControl.)
OnApplyTemplate | (Inherited from ComboBox.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from ComboBox.)
OnDisplayMemberPathChanged | (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnDropDownClosed | (Inherited from ComboBox.)
OnDropDownOpened | (Inherited from ComboBox.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnGroupStyleSelectorChanged | (Inherited from ItemsControl.)
OnInitialized | (Inherited from Selector.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from ComboBox.)
OnIsMouseCapturedChanged | (Inherited from ComboBox.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | (Inherited from ItemsControl.)
OnItemContainerStyleChanged | (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | (Inherited from ItemsControl.)
OnItemsChanged | (Inherited from Selector.)
OnItemsPanelChanged | (Inherited from ItemsControl.)
OnItemsSourceChanged | (Inherited from Selector.)
OnItemStringFormatChanged | (Inherited from ItemsControl.)
OnItemTemplateChanged | (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | (Inherited from ItemsControl.)
OnKeyDown | (Inherited from ComboBox.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from ComboBox.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from ComboBox.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | (Inherited from ComboBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from ItemsControl.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
PrepareContainerForItemOverride | (Inherited from ComboBox.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldApplyItemContainerStyle | (Inherited from ItemsControl.)
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeGroupStyle | (Inherited from ItemsControl.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeItems | (Inherited from ItemsControl.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | (Inherited from ItemsControl.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
DefaultTimeOfDayProperty | Identifies the DefaultTimeOfDay dependency property.
MonthStartProperty | Identifies the MonthStart dependency property.
TodayDateTimeProperty | Identifies the TodayDateTime dependency property.
TodayTextProperty | Identifies the TodayText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DefaultTimeOfDay | Gets or sets the default time of day to be used when a date is specified or selected. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
GroupStyle | (Inherited from ItemsControl.)
GroupStyleSelector | (Inherited from ItemsControl.)
HandlesScrolling | (Inherited from ComboBox.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsDropDownOpen | (Inherited from ComboBox.)
IsEditable | (Inherited from ComboBox.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsFocused | (Inherited from UIElement.)
IsGrouping | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsReadOnly | (Inherited from ComboBox.)
IsSealed | (Inherited from DependencyObject.)
IsSelectionBoxHighlighted | (Inherited from ComboBox.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | (Inherited from ItemsControl.)
IsTextSearchEnabled | (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
ItemBindingGroup | (Inherited from ItemsControl.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ItemsControl.)
ItemContainerStyleSelector | (Inherited from ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemStringFormat | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LogicalChildren | (Inherited from ItemsControl.)
Margin | (Inherited from FrameworkElement.)
MaxDropDownHeight | (Inherited from ComboBox.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthItems | Gest the collection of month items representing the days of the month.
MonthStart | Gets the month that is displayed in the control popup. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedValue | (Inherited from Selector.)
SelectedValuePath | (Inherited from Selector.)
SelectionBoxItem | (Inherited from ComboBox.)
SelectionBoxItemStringFormat | (Inherited from ComboBox.)
SelectionBoxItemTemplate | (Inherited from ComboBox.)
SnapsToDevicePixels | (Inherited from UIElement.)
StaysOpenOnEdit | (Inherited from ComboBox.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
Text | (Inherited from ComboBox.)
TodayDateTime | Gets the date and time to be used when the today selection button is clicked in the control popup. This is a dependency property.
TodayText | Gets or sets the text that is displayed as a label on the today selection button in the control popup. This is a dependency property.
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
WeekItems | Gest the collection of week items representing the days of the week.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
DropDownClosed | (Inherited from ComboBox.)
DropDownOpened | (Inherited from ComboBox.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IAddChild..::.AddChild | (Inherited from ItemsControl.)
IAddChild..::.AddText | (Inherited from ItemsControl.)
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DateTimePicker Constructor

[image]

.NET Framework Class Library
DateTimePicker Constructor
DateTimePicker Class See Also Send Feedback

Initializes a new instance of the DateTimePicker class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public DateTimePicker()
Visual Basic (Declaration)
Public Sub New

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DateTimePicker Fields

[image] [image]

.NET Framework Class Library
DateTimePicker Fields
DateTimePicker Class See Also Send Feedback

The DateTimePicker type exposes the following members.

Fields

Name | Description
DefaultTimeOfDayProperty | Identifies the DefaultTimeOfDay dependency property.
MonthStartProperty | Identifies the MonthStart dependency property.
TodayDateTimeProperty | Identifies the TodayDateTime dependency property.
TodayTextProperty | Identifies the TodayText dependency property.

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DefaultTimeOfDayProperty Field

[image]

.NET Framework Class Library
DateTimePicker..::.DefaultTimeOfDayProperty Field
DateTimePicker Class See Also Send Feedback

Identifies the DefaultTimeOfDay dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty DefaultTimeOfDayProperty
Visual Basic (Declaration)
Public Shared ReadOnly DefaultTimeOfDayProperty As DependencyProperty

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


MonthStartProperty Field

[image]

.NET Framework Class Library
DateTimePicker..::.MonthStartProperty Field
DateTimePicker Class See Also Send Feedback

Identifies the MonthStart dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty MonthStartProperty
Visual Basic (Declaration)
Public Shared ReadOnly MonthStartProperty As DependencyProperty

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


TodayDateTimeProperty Field

[image]

.NET Framework Class Library
DateTimePicker..::.TodayDateTimeProperty Field
DateTimePicker Class See Also Send Feedback

Identifies the TodayDateTime dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty TodayDateTimeProperty
Visual Basic (Declaration)
Public Shared ReadOnly TodayDateTimeProperty As DependencyProperty

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


TodayTextProperty Field

[image]

.NET Framework Class Library
DateTimePicker..::.TodayTextProperty Field
DateTimePicker Class See Also Send Feedback

Identifies the TodayText dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty TodayTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TodayTextProperty As DependencyProperty

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DateTimePicker Methods

[image] [image]

.NET Framework Class Library
DateTimePicker Methods
DateTimePicker Class See Also Send Feedback

The DateTimePicker type exposes the following members.

Methods

Name | Description
AddChild | (Inherited from ItemsControl.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | (Inherited from ItemsControl.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from ItemsControl.)
BeginStoryboard | Overloaded.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearContainerForItemOverride | (Inherited from Selector.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
ContainerFromElement | (Inherited from ItemsControl.)
EndInit | (Inherited from ItemsControl.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | (Inherited from ComboBox.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
IsItemItsOwnContainerOverride | (Inherited from ComboBox.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | (Inherited from ItemsControl.)
OnApplyTemplate | (Inherited from ComboBox.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from ComboBox.)
OnDisplayMemberPathChanged | (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnDropDownClosed | (Inherited from ComboBox.)
OnDropDownOpened | (Inherited from ComboBox.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnGroupStyleSelectorChanged | (Inherited from ItemsControl.)
OnInitialized | (Inherited from Selector.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from ComboBox.)
OnIsMouseCapturedChanged | (Inherited from ComboBox.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | (Inherited from ItemsControl.)
OnItemContainerStyleChanged | (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | (Inherited from ItemsControl.)
OnItemsChanged | (Inherited from Selector.)
OnItemsPanelChanged | (Inherited from ItemsControl.)
OnItemsSourceChanged | (Inherited from Selector.)
OnItemStringFormatChanged | (Inherited from ItemsControl.)
OnItemTemplateChanged | (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | (Inherited from ItemsControl.)
OnKeyDown | (Inherited from ComboBox.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from ComboBox.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from ComboBox.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | (Inherited from ComboBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from ItemsControl.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
PrepareContainerForItemOverride | (Inherited from ComboBox.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldApplyItemContainerStyle | (Inherited from ItemsControl.)
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeGroupStyle | (Inherited from ItemsControl.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeItems | (Inherited from ItemsControl.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | (Inherited from ItemsControl.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IAddChild..::.AddChild | (Inherited from ItemsControl.)
IAddChild..::.AddText | (Inherited from ItemsControl.)
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.AddHandler Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.ApplyAnimationClock Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.BeginAnimation Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.BeginStoryboard Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.BringIntoView Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.ClearValue Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.HitTestCore Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.SetBinding Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.SetValue Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
DateTimePicker..::.TransformToAncestor Method
DateTimePicker Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

DateTimePicker Class
DateTimePicker Members
DlhSoft.Windows.Controls Namespace


DateTimePicker Properties

[image] [image]

.NET Framework Class Library
DateTimePicker Properties
DateTimePicker Class See Also Send Feedback

The DateTimePicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DefaultTimeOfDay | Gets or sets the default time of day to be used when a date is specified or selected. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
GroupStyle | (Inherited from ItemsControl.)
GroupStyleSelector | (Inherited from ItemsControl.)
HandlesScrolling | (Inherited from ComboBox.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | (Inherited from ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsDropDownOpen | (Inherited from ComboBox.)
IsEditable | (Inherited from ComboBox.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsFocused | (Inherited from UIElement.)
IsGrouping | (Inherited from ItemsControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsReadOnly | (Inherited from ComboBox.)
IsSealed | (Inherited from DependencyObject.)
IsSelectionBoxHighlighted | (Inherited from ComboBox.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | (Inherited from ItemsControl.)
IsTextSearchEnabled | (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
ItemBindingGroup | (Inherited from ItemsControl.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ItemsControl.)
ItemContainerStyleSelector | (Inherited from ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemStringFormat | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LogicalChildren | (Inherited from ItemsControl.)
Margin | (Inherited from FrameworkElement.)
MaxDropDownHeight | (Inherited from ComboBox.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthItems | Gest the collection of month items representing the days of the month.
MonthStart | Gets the month that is displayed in the control popup. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedValue | (Inherited from Selector.)
SelectedValuePath | (Inherited from Selector.)
SelectionBoxItem | (Inherited from ComboBox.)
SelectionBoxItemStringFormat | (Inherited from ComboBox.)
SelectionBoxItemTemplate | (Inherited from ComboBox.)
SnapsToDevicePixels | (Inherited from UIElement.)
StaysOpenOnEdit | (Inherited from ComboBox.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
Text | (Inherited from ComboBox.)
TodayDateTime | Gets the date and time to be used when the today selection button is clicked in the control popup. This is a dependency property.
TodayText | Gets or sets the text that is displayed as a label on the today selection button in the control popup. This is a dependency property.
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
WeekItems | Gest the collection of week items representing the days of the week.
Width | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DefaultTimeOfDay Property

[image]

.NET Framework Class Library
DateTimePicker..::.DefaultTimeOfDay Property
DateTimePicker Class See Also Send Feedback

Gets or sets the default time of day to be used when a date is specified or selected. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public TimeSpan DefaultTimeOfDay { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property DefaultTimeOfDay As TimeSpan

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


MonthItems Property

[image]

.NET Framework Class Library
DateTimePicker..::.MonthItems Property
DateTimePicker Class See Also Send Feedback

Gest the collection of month items representing the days of the month.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ObservableCollection<Object> MonthItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthItems As ObservableCollection(Of Object)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


MonthStart Property

[image]

.NET Framework Class Library
DateTimePicker..::.MonthStart Property
DateTimePicker Class See Also Send Feedback

Gets the month that is displayed in the control popup. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DateTime MonthStart { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property MonthStart As DateTime

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


TodayDateTime Property

[image]

.NET Framework Class Library
DateTimePicker..::.TodayDateTime Property
DateTimePicker Class See Also Send Feedback

Gets the date and time to be used when the today selection button is clicked in the control popup. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DateTime TodayDateTime { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property TodayDateTime As DateTime

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


TodayText Property

[image]

.NET Framework Class Library
DateTimePicker..::.TodayText Property
DateTimePicker Class See Also Send Feedback

Gets or sets the text that is displayed as a label on the today selection button in the control popup. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string TodayText { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property TodayText As String

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


WeekItems Property

[image]

.NET Framework Class Library
DateTimePicker..::.WeekItems Property
DateTimePicker Class See Also Send Feedback

Gest the collection of week items representing the days of the week.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ObservableCollection<Object> WeekItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property WeekItems As ObservableCollection(Of Object)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


DateTimePicker Events

[image] [image]

.NET Framework Class Library
DateTimePicker Events
DateTimePicker Class See Also Send Feedback

The DateTimePicker type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
DropDownClosed | (Inherited from ComboBox.)
DropDownOpened | (Inherited from ComboBox.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

DateTimePicker Class
DlhSoft.Windows.Controls Namespace


ItemsControl Class

[image]

.NET Framework Class Library
ItemsControl Class
Members See Also Send Feedback

Represents a control that can be used to present a collection of items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
[TemplatePartAttribute(Name = "PART_ItemsControlHost", Type = typeof(ItemsControl))]
public class ItemsControl : ItemsControlBase
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
<TemplatePartAttribute(Name := "PART_ItemsControlHost", Type := GetType(ItemsControl))> _
Public Class ItemsControl _
    Inherits ItemsControlBase

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl
DlhSoft.Windows.Controls.Primitives..::.Selector

See Also

ItemsControl Members
DlhSoft.Windows.Controls Namespace


ItemsControl Members

[image] [image]

.NET Framework Class Library
ItemsControl Members
ItemsControl Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ItemsControl type exposes the following members.

Constructors

Name | Description
ItemsControl | Initializes a new instance of the ItemsControl class.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ItemsControl host using the LoadedEntities. (Inherited from ItemsControlBase.)
BindItemsSource | Binds the item source collection to the current ItemsSource property. (Inherited from ItemsControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ItemsControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host.
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ItemsControlBase..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes.
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides ItemsControlBase..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes.
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes.
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes.
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes.
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes.
OnItemTemplateChanged | Called when the ItemTemplate property changes.
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes.
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the items control host based on the current property values of this ItemsControl.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
AlternationCountProperty | Identifies the AlternationCount dependency property.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property.
IsTextSearchCaseSensitiveProperty | Identifies the IsTextSearchCaseSensitive dependency property.
IsTextSearchEnabledProperty | Identifies the IsTextSearchEnabled dependency property.
ItemBindingGroupProperty | Identifies the ItemBindingGroup dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
ItemsPanelProperty | Identifies the ItemsPanel dependency property.
ItemStringFormatProperty | Identifies the ItemStringFormat dependency property.
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property.
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ItemsControl host is available. (Inherited from ItemsControlBase.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property.
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property.
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property.
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property.
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property.
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property.
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property.
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property.
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsControl Constructor

[image]

.NET Framework Class Library
ItemsControl Constructor
ItemsControl Class See Also Send Feedback

Initializes a new instance of the ItemsControl class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ItemsControl()
Visual Basic (Declaration)
Public Sub New

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsControl Fields

[image] [image]

.NET Framework Class Library
ItemsControl Fields
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Fields

Name | Description
AlternationCountProperty | Identifies the AlternationCount dependency property.
DisplayMemberPathProperty | Identifies the DisplayMemberPath dependency property.
IsTextSearchCaseSensitiveProperty | Identifies the IsTextSearchCaseSensitive dependency property.
IsTextSearchEnabledProperty | Identifies the IsTextSearchEnabled dependency property.
ItemBindingGroupProperty | Identifies the ItemBindingGroup dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
ItemsPanelProperty | Identifies the ItemsPanel dependency property.
ItemStringFormatProperty | Identifies the ItemStringFormat dependency property.
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


AlternationCountProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.AlternationCountProperty Field
ItemsControl Class See Also Send Feedback

Identifies the AlternationCount dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty AlternationCountProperty
Visual Basic (Declaration)
Public Shared ReadOnly AlternationCountProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


DisplayMemberPathProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.DisplayMemberPathProperty Field
ItemsControl Class See Also Send Feedback

Identifies the DisplayMemberPath dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty DisplayMemberPathProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisplayMemberPathProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


IsTextSearchCaseSensitiveProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.IsTextSearchCaseSensitiveProperty Field
ItemsControl Class See Also Send Feedback

Identifies the IsTextSearchCaseSensitive dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsTextSearchCaseSensitiveProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsTextSearchCaseSensitiveProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


IsTextSearchEnabledProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.IsTextSearchEnabledProperty Field
ItemsControl Class See Also Send Feedback

Identifies the IsTextSearchEnabled dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsTextSearchEnabledProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsTextSearchEnabledProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemBindingGroupProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemBindingGroupProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemBindingGroup dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemBindingGroupProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemBindingGroupProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemContainerStyleProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemContainerStyleProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemContainerStyle dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemContainerStyleSelectorProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemContainerStyleSelectorProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemContainerStyleSelector dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleSelectorProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsPanelProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemsPanelProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemsPanel dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemsPanelProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsPanelProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemStringFormatProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemStringFormatProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemStringFormat dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemStringFormatProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemStringFormatProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemTemplateProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemTemplateProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemTemplate dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemTemplateSelectorProperty Field

[image]

.NET Framework Class Library
ItemsControl..::.ItemTemplateSelectorProperty Field
ItemsControl Class See Also Send Feedback

Identifies the ItemTemplateSelector dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsControl Methods

[image] [image]

.NET Framework Class Library
ItemsControl Methods
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ItemsControl host using the LoadedEntities. (Inherited from ItemsControlBase.)
BindItemsSource | Binds the item source collection to the current ItemsSource property. (Inherited from ItemsControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ItemsControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host.
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ItemsControlBase..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes.
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides ItemsControlBase..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes.
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes.
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes.
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes.
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes.
OnItemTemplateChanged | Called when the ItemTemplate property changes.
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes.
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the items control host based on the current property values of this ItemsControl.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.AddHandler Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.ApplyAnimationClock Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.BeginAnimation Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.BeginStoryboard Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.BringIntoView Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.ClearValue Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


GetItemsControlHostItemTemplate Method

[image]

.NET Framework Class Library
ItemsControl..::.GetItemsControlHostItemTemplate Method
ItemsControl Class See Also Send Feedback

Gets the item template to be used within the ItemsControl host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual DataTemplate GetItemsControlHostItemTemplate()
Visual Basic (Declaration)
Protected Friend Overridable Function GetItemsControlHostItemTemplate As DataTemplate

Return Value

The item template to be used within the ItemsControl host.

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.HitTestCore Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


InitializeItemTemplateDataContext Method

[image]

.NET Framework Class Library
ItemsControl..::.InitializeItemTemplateDataContext Method
ItemsControl Class See Also Send Feedback

Initializes the data context of the ContentControl to be used as an item template.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeItemTemplateDataContext(
    FrameworkElementFactory contentControlFactory
)
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeItemTemplateDataContext ( _
    contentControlFactory As FrameworkElementFactory _
)

Parameters

contentControlFactory
Type: System.Windows..::.FrameworkElementFactory
The source ContentControl factory to set the data context for.

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
ItemsControl..::.InitializeTemplateParts Method
ItemsControl Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub InitializeTemplateParts

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


Move Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.Move Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)
Move(Object, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


OnAlternationCountChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnAlternationCountChanged Method
ItemsControl Class See Also Send Feedback

Called when the AlternationCount property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnAlternationCountChanged(
    int oldAlternationCount,
    int newAlternationCount
)
Visual Basic (Declaration)
Protected Overridable Sub OnAlternationCountChanged ( _
    oldAlternationCount As Integer, _
    newAlternationCount As Integer _
)

Parameters

oldAlternationCount
Type: System..::.Int32
newAlternationCount
Type: System..::.Int32

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ItemsControl..::.OnApplyTemplate Method
ItemsControl Class See Also Send Feedback

When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnDisplayMemberPathChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnDisplayMemberPathChanged Method
ItemsControl Class See Also Send Feedback

Called when the DisplayMemberPath property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnDisplayMemberPathChanged(
    string oldDisplayMemberPath,
    string newDisplayMemberPath
)
Visual Basic (Declaration)
Protected Overridable Sub OnDisplayMemberPathChanged ( _
    oldDisplayMemberPath As String, _
    newDisplayMemberPath As String _
)

Parameters

oldDisplayMemberPath
Type: System..::.String
newDisplayMemberPath
Type: System..::.String

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemBindingGroupChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemBindingGroupChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemBindingGroup property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemBindingGroupChanged(
    BindingGroup oldItemBindingGroup,
    BindingGroup newItemBindingGroup
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemBindingGroupChanged ( _
    oldItemBindingGroup As BindingGroup, _
    newItemBindingGroup As BindingGroup _
)

Parameters

oldItemBindingGroup
Type: System.Windows.Data..::.BindingGroup
newItemBindingGroup
Type: System.Windows.Data..::.BindingGroup

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemContainerStyleChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemContainerStyleChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemContainerStyle property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemContainerStyleChanged(
    Style oldItemContainerStyle,
    Style newItemContainerStyle
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemContainerStyleChanged ( _
    oldItemContainerStyle As Style, _
    newItemContainerStyle As Style _
)

Parameters

oldItemContainerStyle
Type: System.Windows..::.Style
newItemContainerStyle
Type: System.Windows..::.Style

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemContainerStyleSelectorChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemContainerStyleSelectorChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemContainerStyleSelector property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemContainerStyleSelectorChanged(
    StyleSelector oldItemContainerStyleSelector,
    StyleSelector newItemContainerStyleSelector
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemContainerStyleSelectorChanged ( _
    oldItemContainerStyleSelector As StyleSelector, _
    newItemContainerStyleSelector As StyleSelector _
)

Parameters

oldItemContainerStyleSelector
Type: System.Windows.Controls..::.StyleSelector
newItemContainerStyleSelector
Type: System.Windows.Controls..::.StyleSelector

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemsPanelChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemsPanelChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemsPanel property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemsPanelChanged(
    ItemsPanelTemplate oldItemsPanel,
    ItemsPanelTemplate newItemsPanel
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemsPanelChanged ( _
    oldItemsPanel As ItemsPanelTemplate, _
    newItemsPanel As ItemsPanelTemplate _
)

Parameters

oldItemsPanel
Type: System.Windows.Controls..::.ItemsPanelTemplate
newItemsPanel
Type: System.Windows.Controls..::.ItemsPanelTemplate

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemStringFormatChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemStringFormatChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemStringFormat property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemStringFormatChanged(
    string oldItemStringFormat,
    string newItemStringFormat
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemStringFormatChanged ( _
    oldItemStringFormat As String, _
    newItemStringFormat As String _
)

Parameters

oldItemStringFormat
Type: System..::.String
newItemStringFormat
Type: System..::.String

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemTemplateChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemTemplateChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemTemplate property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemTemplateChanged(
    DataTemplate oldItemTemplate,
    DataTemplate newItemTemplate
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemTemplateChanged ( _
    oldItemTemplate As DataTemplate, _
    newItemTemplate As DataTemplate _
)

Parameters

oldItemTemplate
Type: System.Windows..::.DataTemplate
newItemTemplate
Type: System.Windows..::.DataTemplate

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


OnItemTemplateSelectorChanged Method

[image]

.NET Framework Class Library
ItemsControl..::.OnItemTemplateSelectorChanged Method
ItemsControl Class See Also Send Feedback

Called when the ItemTemplateSelector property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemTemplateSelectorChanged(
    DataTemplateSelector oldItemTemplateSelector,
    DataTemplateSelector newItemTemplateSelector
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemTemplateSelectorChanged ( _
    oldItemTemplateSelector As DataTemplateSelector, _
    newItemTemplateSelector As DataTemplateSelector _
)

Parameters

oldItemTemplateSelector
Type: System.Windows.Controls..::.DataTemplateSelector
newItemTemplateSelector
Type: System.Windows.Controls..::.DataTemplateSelector

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ResetItemsControlHost Method

[image]

.NET Framework Class Library
ItemsControl..::.ResetItemsControlHost Method
ItemsControl Class See Also Send Feedback

Resets the items control host based on the current property values of this ItemsControl.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void ResetItemsControlHost()
Visual Basic (Declaration)
Protected Friend Overridable Sub ResetItemsControlHost

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.SetBinding Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.SetValue Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ItemsControl..::.TransformToAncestor Method
ItemsControl Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ItemsControl Class
ItemsControl Members
DlhSoft.Windows.Controls Namespace


ItemsControl Properties

[image] [image]

.NET Framework Class Library
ItemsControl Properties
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property.
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ItemsControl host is available. (Inherited from ItemsControlBase.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property.
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property.
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property.
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property.
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property.
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property.
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property.
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property.
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


AlternationCount Property

[image]

.NET Framework Class Library
ItemsControl..::.AlternationCount Property
ItemsControl Class See Also Send Feedback

Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int AlternationCount { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property AlternationCount As Integer

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


BaseItemsControl Property

[image]

.NET Framework Class Library
ItemsControl..::.BaseItemsControl Property
ItemsControl Class See Also Send Feedback

Gets the base ItemsControl used as the core for this control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public ItemsControl BaseItemsControl { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property BaseItemsControl As ItemsControl

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


DisplayMemberPath Property

[image]

.NET Framework Class Library
ItemsControl..::.DisplayMemberPath Property
ItemsControl Class See Also Send Feedback

Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string DisplayMemberPath { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property DisplayMemberPath As String

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


IsTextSearchCaseSensitive Property

[image]

.NET Framework Class Library
ItemsControl..::.IsTextSearchCaseSensitive Property
ItemsControl Class See Also Send Feedback

Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsTextSearchCaseSensitive { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsTextSearchCaseSensitive As Boolean

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


IsTextSearchEnabled Property

[image]

.NET Framework Class Library
ItemsControl..::.IsTextSearchEnabled Property
ItemsControl Class See Also Send Feedback

Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsTextSearchEnabled { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsTextSearchEnabled As Boolean

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemBindingGroup Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemBindingGroup Property
ItemsControl Class See Also Send Feedback

Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public BindingGroup ItemBindingGroup { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemBindingGroup As BindingGroup

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemContainerStyle Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemContainerStyle Property
ItemsControl Class See Also Send Feedback

Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Style ItemContainerStyle { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemContainerStyle As Style

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemContainerStyleSelector Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemContainerStyleSelector Property
ItemsControl Class See Also Send Feedback

Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public StyleSelector ItemContainerStyleSelector { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemContainerStyleSelector As StyleSelector

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsPanel Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemsPanel Property
ItemsControl Class See Also Send Feedback

Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public ItemsPanelTemplate ItemsPanel { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemsPanel As ItemsPanelTemplate

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemStringFormat Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemStringFormat Property
ItemsControl Class See Also Send Feedback

Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string ItemStringFormat { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemStringFormat As String

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemTemplate Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemTemplate Property
ItemsControl Class See Also Send Feedback

Gets or sets the DataTemplate to be used to display each item. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DataTemplate ItemTemplate { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemTemplate As DataTemplate

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemTemplateSelector Property

[image]

.NET Framework Class Library
ItemsControl..::.ItemTemplateSelector Property
ItemsControl Class See Also Send Feedback

Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DataTemplateSelector ItemTemplateSelector { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemTemplateSelector As DataTemplateSelector

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ItemsControl Events

[image] [image]

.NET Framework Class Library
ItemsControl Events
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ItemsControl Class
DlhSoft.Windows.Controls Namespace


ListBox Class

[image]

.NET Framework Class Library
ListBox Class
Members See Also Send Feedback

Contains a list of selectable entity data items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.ListBox)]
public class ListBox : Selector
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.ListBox)> _
Public Class ListBox _
    Inherits Selector

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl
DlhSoft.Windows.Controls.Primitives..::.Selector
DlhSoft.Windows.Controls..::.ListBox
DlhSoft.Windows.Controls..::.ListView

See Also

ListBox Members
DlhSoft.Windows.Controls Namespace


ListBox Members

[image] [image]

.NET Framework Class Library
ListBox Members
ListBox Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ListBox type exposes the following members.

Constructors

Name | Description
ListBox | Initializes a new instance of the ListBox class.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection.
AddSelectedEntityItem | Adds an entity item to the selection.
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListBox host using the LoadedEntities. (Overrides Selector..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from Selector.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from Selector.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ItemsControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Overrides Selector..::.OnSelectionChanged(Object, SelectionChangedEventArgs).)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection.
RemoveSelectedEntityItem | Removes an entity item from the selection.
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListBox host based on the current property values of this ListBox. (Overrides Selector..::.ResetItemsControlHost()()().)
ScrollIntoView | Causes the object to scroll into view.
SelectAll | Selects all the items in a ListBox.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox.
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host.
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListBox host.
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
SelectedEntitiesProperty | Identifies the SelectedEntities dependency property.
SelectedItemsProperty | Identifies the SelectedItems dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListBox host is available. (Overrides Selector..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
ListBoxHost | Gets the ListBox host template part used internally by this ListBox.
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedEntities | Gets the currently selected entities. This is a dependency property.
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property.
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBox Constructor

[image]

.NET Framework Class Library
ListBox Constructor
ListBox Class See Also Send Feedback

Initializes a new instance of the ListBox class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ListBox()
Visual Basic (Declaration)
Public Sub New

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBox Fields

[image] [image]

.NET Framework Class Library
ListBox Fields
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Fields

Name | Description
SelectedEntitiesProperty | Identifies the SelectedEntities dependency property.
SelectedItemsProperty | Identifies the SelectedItems dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectedEntitiesProperty Field

[image]

.NET Framework Class Library
ListBox..::.SelectedEntitiesProperty Field
ListBox Class See Also Send Feedback

Identifies the SelectedEntities dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedEntitiesProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedEntitiesProperty As DependencyProperty

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectedItemsProperty Field

[image]

.NET Framework Class Library
ListBox..::.SelectedItemsProperty Field
ListBox Class See Also Send Feedback

Identifies the SelectedItems dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemsProperty As DependencyProperty

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectionModeProperty Field

[image]

.NET Framework Class Library
ListBox..::.SelectionModeProperty Field
ListBox Class See Also Send Feedback

Identifies the SelectionMode dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBox Methods

[image] [image]

.NET Framework Class Library
ListBox Methods
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection.
AddSelectedEntityItem | Adds an entity item to the selection.
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListBox host using the LoadedEntities. (Overrides Selector..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from Selector.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from Selector.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ItemsControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Overrides Selector..::.OnSelectionChanged(Object, SelectionChangedEventArgs).)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection.
RemoveSelectedEntityItem | Removes an entity item from the selection.
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListBox host based on the current property values of this ListBox. (Overrides Selector..::.ResetItemsControlHost()()().)
ScrollIntoView | Causes the object to scroll into view.
SelectAll | Selects all the items in a ListBox.
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox.
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host.
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListBox host.
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ListBox..::.AddHandler Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


AddSelectedEntity Method

[image]

.NET Framework Class Library
ListBox..::.AddSelectedEntity Method
ListBox Class See Also Send Feedback

Adds an entity to the selection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void AddSelectedEntity(
    Entity entity
)
Visual Basic (Declaration)
Protected Friend Overridable Sub AddSelectedEntity ( _
    entity As Entity _
)

Parameters

entity
Type: DlhSoft.Windows.Data..::.Entity
The entity to add to the selection.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


AddSelectedEntityItem Method

[image]

.NET Framework Class Library
ListBox..::.AddSelectedEntityItem Method
ListBox Class See Also Send Feedback

Adds an entity item to the selection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void AddSelectedEntityItem(
    Entity entity
)
Visual Basic (Declaration)
Protected Friend Overridable Sub AddSelectedEntityItem ( _
    entity As Entity _
)

Parameters

entity
Type: DlhSoft.Windows.Data..::.Entity
The entity to add to the selection.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ListBox..::.ApplyAnimationClock Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ListBox..::.BeginAnimation Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ListBox..::.BeginStoryboard Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


BindItems Method

[image]

.NET Framework Class Library
ListBox..::.BindItems Method
ListBox Class See Also Send Feedback

Binds the ListBox host using the LoadedEntities.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void BindItems()
Visual Basic (Declaration)
Protected Friend Overrides Sub BindItems

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ListBox..::.BringIntoView Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ListBox..::.ClearValue Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ListBox..::.HitTestCore Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


Move Method

[image] [image]

.NET Framework Class Library
ListBox..::.Move Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)
Move(Object, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


OnSelectionChanged Method

[image]

.NET Framework Class Library
ListBox..::.OnSelectionChanged Method
ListBox Class See Also Send Feedback

Invoked when the selection in ListBox host is changed and updates the selection of the ListBox.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void OnSelectionChanged(
    Object sender,
    SelectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overrides Sub OnSelectionChanged ( _
    sender As Object, _
    e As SelectionChangedEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Controls..::.SelectionChangedEventArgs

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


RemoveSelectedEntity Method

[image]

.NET Framework Class Library
ListBox..::.RemoveSelectedEntity Method
ListBox Class See Also Send Feedback

Removes an entity from the selection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void RemoveSelectedEntity(
    Entity entity
)
Visual Basic (Declaration)
Protected Friend Overridable Sub RemoveSelectedEntity ( _
    entity As Entity _
)

Parameters

entity
Type: DlhSoft.Windows.Data..::.Entity
The entity to remove from the selection.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


RemoveSelectedEntityItem Method

[image]

.NET Framework Class Library
ListBox..::.RemoveSelectedEntityItem Method
ListBox Class See Also Send Feedback

Removes an entity item from the selection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void RemoveSelectedEntityItem(
    Entity entity
)
Visual Basic (Declaration)
Protected Friend Overridable Sub RemoveSelectedEntityItem ( _
    entity As Entity _
)

Parameters

entity
Type: DlhSoft.Windows.Data..::.Entity
The entity to remove from the selection.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ResetItemsControlHost Method

[image]

.NET Framework Class Library
ListBox..::.ResetItemsControlHost Method
ListBox Class See Also Send Feedback

Resets the ListBox host based on the current property values of this ListBox.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void ResetItemsControlHost()
Visual Basic (Declaration)
Protected Friend Overrides Sub ResetItemsControlHost

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ScrollIntoView Method

[image]

.NET Framework Class Library
ListBox..::.ScrollIntoView Method
ListBox Class See Also Send Feedback

Causes the object to scroll into view.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void ScrollIntoView(
    Object item
)
Visual Basic (Declaration)
Public Sub ScrollIntoView ( _
    item As Object _
)

Parameters

item
Type: System..::.Object
Object to scroll.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectAll Method

[image]

.NET Framework Class Library
ListBox..::.SelectAll Method
ListBox Class See Also Send Feedback

Selects all the items in a ListBox.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void SelectAll()
Visual Basic (Declaration)
Public Sub SelectAll

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ListBox..::.SetBinding Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ListBox..::.SetValue Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ListBox..::.TransformToAncestor Method
ListBox Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ListBox Class
ListBox Members
DlhSoft.Windows.Controls Namespace


UnselectAll Method

[image]

.NET Framework Class Library
ListBox..::.UnselectAll Method
ListBox Class See Also Send Feedback

Unselects all the items in a ListBox.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void UnselectAll()
Visual Basic (Declaration)
Public Sub UnselectAll

Exceptions

Exception | Condition
System..::.NotSupportedException |

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


UpdateSelectedEntities Method

[image]

.NET Framework Class Library
ListBox..::.UpdateSelectedEntities Method
ListBox Class See Also Send Feedback

Updates the internal selected entity collection to reflect the selection changes in the ListBox host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void UpdateSelectedEntities(
    IList addedItems,
    IList removedItems
)
Visual Basic (Declaration)
Protected Friend Overridable Sub UpdateSelectedEntities ( _
    addedItems As IList, _
    removedItems As IList _
)

Parameters

addedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were selected.
removedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were unselected.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


UpdateSelectedEntityItems Method

[image]

.NET Framework Class Library
ListBox..::.UpdateSelectedEntityItems Method
ListBox Class See Also Send Feedback

Updates the internal selected item collection to reflect the selection changes in the ListBox host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void UpdateSelectedEntityItems(
    IList addedItems,
    IList removedItems
)
Visual Basic (Declaration)
Protected Friend Overridable Sub UpdateSelectedEntityItems ( _
    addedItems As IList, _
    removedItems As IList _
)

Parameters

addedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were selected.
removedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were unselected.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBox Properties

[image] [image]

.NET Framework Class Library
ListBox Properties
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListBox host is available. (Overrides Selector..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
ListBoxHost | Gets the ListBox host template part used internally by this ListBox.
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedEntities | Gets the currently selected entities. This is a dependency property.
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property.
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


BaseListBox Property

[image]

.NET Framework Class Library
ListBox..::.BaseListBox Property
ListBox Class See Also Send Feedback

Gets the base ListBox used as the core for this control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public ListBox BaseListBox { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property BaseListBox As ListBox

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


IsItemsControlHostInitialized Property

[image]

.NET Framework Class Library
ListBox..::.IsItemsControlHostInitialized Property
ListBox Class See Also Send Feedback

Gets a value indicating whether the control is initialized and the ListBox host is available.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override bool IsItemsControlHostInitialized { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property IsItemsControlHostInitialized As Boolean

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBoxHost Property

[image]

.NET Framework Class Library
ListBox..::.ListBoxHost Property
ListBox Class See Also Send Feedback

Gets the ListBox host template part used internally by this ListBox.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal ListBox ListBoxHost { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property ListBoxHost As ListBox

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectedEntities Property

[image]

.NET Framework Class Library
ListBox..::.SelectedEntities Property
ListBox Class See Also Send Feedback

Gets the currently selected entities. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IList<Entity> SelectedEntities { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedEntities As IList(Of Entity)

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectedItems Property

[image]

.NET Framework Class Library
ListBox..::.SelectedItems Property
ListBox Class See Also Send Feedback

Gets the currently selected items. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IList SelectedItems { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedItems As IList

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


SelectionMode Property

[image]

.NET Framework Class Library
ListBox..::.SelectionMode Property
ListBox Class See Also Send Feedback

Gets or sets the selection behavior for a ListBox. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As SelectionMode

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListBox Events

[image] [image]

.NET Framework Class Library
ListBox Events
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ListBox Class
DlhSoft.Windows.Controls Namespace


ListView Class

[image]

.NET Framework Class Library
ListView Class
Members See Also Send Feedback

Represents a control that displays a list of entity data items. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.ListBox)]
public class ListView : ListBox
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.ListBox)> _
Public Class ListView _
    Inherits ListBox

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl
DlhSoft.Windows.Controls.Primitives..::.Selector
DlhSoft.Windows.Controls..::.ListBox
DlhSoft.Windows.Controls..::.ListView
DlhSoft.Windows.Controls..::.TreeListView

See Also

ListView Members
DlhSoft.Windows.Controls Namespace


ListView Members

[image] [image]

.NET Framework Class Library
ListView Members
ListView Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ListView type exposes the following members.

Constructors

Name | Description
ListView | Initializes a new instance of the ListView class.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection. (Inherited from ListBox.)
AddSelectedEntityItem | Adds an entity item to the selection. (Inherited from ListBox.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListBox host using the LoadedEntities. (Inherited from ListBox.)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Overrides Selector..::.ClearTemplateParts()()().)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColumnCellTemplate | Gets the column cell template of a specified GridViewColumn.
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeGridViewColumns | Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection.
InitializeGridViewColumnTemplateDataContext | Initializes the data context of the ContentControl to be used as a template of a GridViewColumn.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides Selector..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Overrides ItemsControlBase..::.LoadEntities()()().)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides ItemsControl..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationDeferredScrollRatioChanged | Called when the IsAsyncPresentationDeferredScrollRatio property changes.
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Inherited from ListBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection. (Inherited from ListBox.)
RemoveSelectedEntityItem | Removes an entity item from the selection. (Inherited from ListBox.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListView host based on the current property values of this ListView. (Overrides ListBox..::.ResetItemsControlHost()()().)
ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox. (Inherited from ListBox.)
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IsAsyncPresentationDeferredScrollRatioProperty | Identifies the IsAsyncPresentationDeferredScrollRatio dependency property.
IsGridViewProperty | Identifies the IsGridView dependency property.
ViewProperty | Identifies the View dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control. (Inherited from ListBox.)
BaseListView | Gets the base ListView used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationDeferredScrollRatio | Gets or sets the scroll ratio for which data loading should be deferred within this ListView when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsGridView | Gets a value that indicates whether the ListView control is using a GridView as its View. This is a dependency property.
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListView host is available. (Overrides ListBox..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
ListBoxHost | Gets the ListBox host template part used internally by this ListBox. (Inherited from ListBox.)
ListViewHost | Gets the ListView host template part used internally by this ListView.
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScrollViewer | Gets a reference to the internal ScrollViewer control instance used by the ListView control.
SelectedEntities | Gets the currently selected entities. This is a dependency property. (Inherited from ListBox.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property. (Inherited from ListBox.)
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property. (Inherited from ListBox.)
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets an object that defines how the data is styled and organized in a ListView control. This is a dependency property.
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ListView Constructor

[image]

.NET Framework Class Library
ListView Constructor
ListView Class See Also Send Feedback

Initializes a new instance of the ListView class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ListView()
Visual Basic (Declaration)
Public Sub New

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ListView Fields

[image] [image]

.NET Framework Class Library
ListView Fields
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Fields

Name | Description
IsAsyncPresentationDeferredScrollRatioProperty | Identifies the IsAsyncPresentationDeferredScrollRatio dependency property.
IsGridViewProperty | Identifies the IsGridView dependency property.
ViewProperty | Identifies the View dependency property.

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


IsAsyncPresentationDeferredScrollRatioProperty Field

[image]

.NET Framework Class Library
ListView..::.IsAsyncPresentationDeferredScrollRatioProperty Field
ListView Class See Also Send Feedback

Identifies the IsAsyncPresentationDeferredScrollRatio dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsAsyncPresentationDeferredScrollRatioProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsAsyncPresentationDeferredScrollRatioProperty As DependencyProperty

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


IsGridViewProperty Field

[image]

.NET Framework Class Library
ListView..::.IsGridViewProperty Field
ListView Class See Also Send Feedback

Identifies the IsGridView dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsGridViewProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsGridViewProperty As DependencyProperty

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ViewProperty Field

[image]

.NET Framework Class Library
ListView..::.ViewProperty Field
ListView Class See Also Send Feedback

Identifies the View dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ViewProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewProperty As DependencyProperty

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ListView Methods

[image] [image]

.NET Framework Class Library
ListView Methods
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection. (Inherited from ListBox.)
AddSelectedEntityItem | Adds an entity item to the selection. (Inherited from ListBox.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListBox host using the LoadedEntities. (Inherited from ListBox.)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Overrides Selector..::.ClearTemplateParts()()().)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColumnCellTemplate | Gets the column cell template of a specified GridViewColumn.
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeGridViewColumns | Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection.
InitializeGridViewColumnTemplateDataContext | Initializes the data context of the ContentControl to be used as a template of a GridViewColumn.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides Selector..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Overrides ItemsControlBase..::.LoadEntities()()().)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides ItemsControl..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationDeferredScrollRatioChanged | Called when the IsAsyncPresentationDeferredScrollRatio property changes.
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Inherited from ListBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection. (Inherited from ListBox.)
RemoveSelectedEntityItem | Removes an entity item from the selection. (Inherited from ListBox.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListView host based on the current property values of this ListView. (Overrides ListBox..::.ResetItemsControlHost()()().)
ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox. (Inherited from ListBox.)
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ListView..::.AddHandler Method
ListView Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ListView..::.ApplyAnimationClock Method
ListView Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ListView..::.BeginAnimation Method
ListView Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ListView..::.BeginStoryboard Method
ListView Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ListView..::.BringIntoView Method
ListView Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


ClearTemplateParts Method

[image]

.NET Framework Class Library
ListView..::.ClearTemplateParts Method
ListView Class See Also Send Feedback

Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void ClearTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub ClearTemplateParts

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ListView..::.ClearValue Method
ListView Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


GetColumnCellTemplate Method

[image]

.NET Framework Class Library
ListView..::.GetColumnCellTemplate Method
ListView Class See Also Send Feedback

Gets the column cell template of a specified GridViewColumn.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual DataTemplate GetColumnCellTemplate(
    GridViewColumn gridViewColumn,
    DataTemplate contentTemplate
)
Visual Basic (Declaration)
Protected Friend Overridable Function GetColumnCellTemplate ( _
    gridViewColumn As GridViewColumn, _
    contentTemplate As DataTemplate _
) As DataTemplate

Parameters

gridViewColumn
Type: System.Windows.Controls..::.GridViewColumn
The column to get the cell template for.
contentTemplate
Type: System.Windows..::.DataTemplate
The content template to be used.

Return Value

The column cell template of the specified GridViewColumn.

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ListView..::.HitTestCore Method
ListView Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


InitializeGridViewColumns Method

[image]

.NET Framework Class Library
ListView..::.InitializeGridViewColumns Method
ListView Class See Also Send Feedback

Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeGridViewColumns(
    GridViewColumnCollection referencedGridViewColumns,
    GridViewColumnCollection sourceGridViewColumns
)
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeGridViewColumns ( _
    referencedGridViewColumns As GridViewColumnCollection, _
    sourceGridViewColumns As GridViewColumnCollection _
)

Parameters

referencedGridViewColumns
Type: System.Windows.Controls..::.GridViewColumnCollection
The GridViewColumnCollection to be used.
sourceGridViewColumns
Type: System.Windows.Controls..::.GridViewColumnCollection
The source GridViewColumnCollection to be considered.

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


InitializeGridViewColumnTemplateDataContext Method

[image]

.NET Framework Class Library
ListView..::.InitializeGridViewColumnTemplateDataContext Method
ListView Class See Also Send Feedback

Initializes the data context of the ContentControl to be used as a template of a GridViewColumn.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeGridViewColumnTemplateDataContext(
    FrameworkElementFactory contentControlFactory
)
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeGridViewColumnTemplateDataContext ( _
    contentControlFactory As FrameworkElementFactory _
)

Parameters

contentControlFactory
Type: System.Windows..::.FrameworkElementFactory
The source ContentControl factory to set the data context for.

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
ListView..::.InitializeTemplateParts Method
ListView Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub InitializeTemplateParts

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


LoadEntities Method

[image]

.NET Framework Class Library
ListView..::.LoadEntities Method
ListView Class See Also Send Feedback

Prepares the entity items to be presented by the control based on the current items and data binding properties.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void LoadEntities()
Visual Basic (Declaration)
Protected Friend Overrides Sub LoadEntities

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


Move Method

[image] [image]

.NET Framework Class Library
ListView..::.Move Method
ListView Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)
Move(Object, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ListView..::.OnApplyTemplate Method
ListView Class See Also Send Feedback

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


OnIsAsyncPresentationDeferredScrollRatioChanged Method

[image]

.NET Framework Class Library
ListView..::.OnIsAsyncPresentationDeferredScrollRatioChanged Method
ListView Class See Also Send Feedback

Called when the IsAsyncPresentationDeferredScrollRatio property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationDeferredScrollRatioChanged(
    double oldValue,
    double newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationDeferredScrollRatioChanged ( _
    oldValue As Double, _
    newValue As Double _
)

Parameters

oldValue
Type: System..::.Double
newValue
Type: System..::.Double

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ResetItemsControlHost Method

[image]

.NET Framework Class Library
ListView..::.ResetItemsControlHost Method
ListView Class See Also Send Feedback

Resets the ListView host based on the current property values of this ListView.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void ResetItemsControlHost()
Visual Basic (Declaration)
Protected Friend Overrides Sub ResetItemsControlHost

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ListView..::.SetBinding Method
ListView Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ListView..::.SetValue Method
ListView Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ListView..::.TransformToAncestor Method
ListView Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ListView Class
ListView Members
DlhSoft.Windows.Controls Namespace


ListView Properties

[image] [image]

.NET Framework Class Library
ListView Properties
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control. (Inherited from ListBox.)
BaseListView | Gets the base ListView used as the core for this control.
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationDeferredScrollRatio | Gets or sets the scroll ratio for which data loading should be deferred within this ListView when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsGridView | Gets a value that indicates whether the ListView control is using a GridView as its View. This is a dependency property.
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListView host is available. (Overrides ListBox..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
ListBoxHost | Gets the ListBox host template part used internally by this ListBox. (Inherited from ListBox.)
ListViewHost | Gets the ListView host template part used internally by this ListView.
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScrollViewer | Gets a reference to the internal ScrollViewer control instance used by the ListView control.
SelectedEntities | Gets the currently selected entities. This is a dependency property. (Inherited from ListBox.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property. (Inherited from ListBox.)
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property. (Inherited from ListBox.)
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets an object that defines how the data is styled and organized in a ListView control. This is a dependency property.
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


BaseListView Property

[image]

.NET Framework Class Library
ListView..::.BaseListView Property
ListView Class See Also Send Feedback

Gets the base ListView used as the core for this control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public ListView BaseListView { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property BaseListView As ListView

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


IsAsyncPresentationDeferredScrollRatio Property

[image]

.NET Framework Class Library
ListView..::.IsAsyncPresentationDeferredScrollRatio Property
ListView Class See Also Send Feedback

Gets or sets the scroll ratio for which data loading should be deferred within this ListView when IsAsyncPresentationEnabled property is set to true. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public double IsAsyncPresentationDeferredScrollRatio { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsAsyncPresentationDeferredScrollRatio As Double

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


IsGridView Property

[image]

.NET Framework Class Library
ListView..::.IsGridView Property
ListView Class See Also Send Feedback

Gets a value that indicates whether the ListView control is using a GridView as its View. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsGridView { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsGridView As Boolean

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


IsItemsControlHostInitialized Property

[image]

.NET Framework Class Library
ListView..::.IsItemsControlHostInitialized Property
ListView Class See Also Send Feedback

Gets a value indicating whether the control is initialized and the ListView host is available.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override bool IsItemsControlHostInitialized { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property IsItemsControlHostInitialized As Boolean

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ListViewHost Property

[image]

.NET Framework Class Library
ListView..::.ListViewHost Property
ListView Class See Also Send Feedback

Gets the ListView host template part used internally by this ListView.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal ListView ListViewHost { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property ListViewHost As ListView

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ScrollViewer Property

[image]

.NET Framework Class Library
ListView..::.ScrollViewer Property
ListView Class See Also Send Feedback

Gets a reference to the internal ScrollViewer control instance used by the ListView control.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal ScrollViewer ScrollViewer { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property ScrollViewer As ScrollViewer

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


View Property

[image]

.NET Framework Class Library
ListView..::.View Property
ListView Class See Also Send Feedback

Gets or sets an object that defines how the data is styled and organized in a ListView control. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ViewBase View { get; set; }
Visual Basic (Declaration)
Public Property View As ViewBase

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


ListView Events

[image] [image]

.NET Framework Class Library
ListView Events
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ListView Class
DlhSoft.Windows.Controls Namespace


TreeCommands Class

[image]

.NET Framework Class Library
TreeCommands Class
Members See Also Send Feedback

Provides a standard set of tree related commands.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static class TreeCommands
Visual Basic (Declaration)
Public NotInheritable Class TreeCommands

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Controls..::.TreeCommands

See Also

TreeCommands Members
DlhSoft.Windows.Controls Namespace


TreeCommands Members

[image] [image]

.NET Framework Class Library
TreeCommands Members
TreeCommands Class Fields See Also Send Feedback

The TreeCommands type exposes the following members.

Fields

Name | Description
Collapse | Gets the value that indicates the Collapse command.
CollapseAll | Gets the value that indicates the Collapse All command.
CollapseBranch | Gets the value that indicates the Collapse Branch command.
Expand | Gets the value that indicates the Expand command.
ExpandAll | Gets the value that indicates the Expand All command.
ExpandBranch | Gets the value that indicates the Expand Branch command.

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


TreeCommands Fields

[image] [image]

.NET Framework Class Library
TreeCommands Fields
TreeCommands Class See Also Send Feedback

The TreeCommands type exposes the following members.

Fields

Name | Description
Collapse | Gets the value that indicates the Collapse command.
CollapseAll | Gets the value that indicates the Collapse All command.
CollapseBranch | Gets the value that indicates the Collapse Branch command.
Expand | Gets the value that indicates the Expand command.
ExpandAll | Gets the value that indicates the Expand All command.
ExpandBranch | Gets the value that indicates the Expand Branch command.

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


Collapse Field

[image]

.NET Framework Class Library
TreeCommands..::.Collapse Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Collapse command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand Collapse
Visual Basic (Declaration)
Public Shared ReadOnly Collapse As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


CollapseAll Field

[image]

.NET Framework Class Library
TreeCommands..::.CollapseAll Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Collapse All command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand CollapseAll
Visual Basic (Declaration)
Public Shared ReadOnly CollapseAll As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


CollapseBranch Field

[image]

.NET Framework Class Library
TreeCommands..::.CollapseBranch Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Collapse Branch command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand CollapseBranch
Visual Basic (Declaration)
Public Shared ReadOnly CollapseBranch As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


Expand Field

[image]

.NET Framework Class Library
TreeCommands..::.Expand Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Expand command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand Expand
Visual Basic (Declaration)
Public Shared ReadOnly Expand As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


ExpandAll Field

[image]

.NET Framework Class Library
TreeCommands..::.ExpandAll Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Expand All command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand ExpandAll
Visual Basic (Declaration)
Public Shared ReadOnly ExpandAll As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


ExpandBranch Field

[image]

.NET Framework Class Library
TreeCommands..::.ExpandBranch Field
TreeCommands Class See Also Send Feedback

Gets the value that indicates the Expand Branch command.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly RoutedUICommand ExpandBranch
Visual Basic (Declaration)
Public Shared ReadOnly ExpandBranch As RoutedUICommand

See Also

TreeCommands Class
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Class

[image]

.NET Framework Class Library
TreeGridViewColumn Class
Members See Also Send Feedback

Represents a column that displays hierarchical data.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public class TreeGridViewColumn : GridViewColumn
Visual Basic (Declaration)
Public Class TreeGridViewColumn _
    Inherits GridViewColumn

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Controls..::.GridViewColumn
DlhSoft.Windows.Controls..::.TreeGridViewColumn

See Also

TreeGridViewColumn Members
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Members

[image] [image]

.NET Framework Class Library
TreeGridViewColumn Members
TreeGridViewColumn Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The TreeGridViewColumn type exposes the following members.

Constructors

Name | Description
TreeGridViewColumn |

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnHeaderStringFormatChanged | (Inherited from GridViewColumn.)
OnPropertyChanged | Overloaded.
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | (Inherited from GridViewColumn.)
VerifyAccess | (Inherited from DispatcherObject.)

Properties

Name | Description
ActualWidth | (Inherited from GridViewColumn.)
CellTemplate | (Inherited from GridViewColumn.)
CellTemplateSelector | (Inherited from GridViewColumn.)
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberBinding | (Inherited from GridViewColumn.)
Header | (Inherited from GridViewColumn.)
HeaderContainerStyle | (Inherited from GridViewColumn.)
HeaderStringFormat | (Inherited from GridViewColumn.)
HeaderTemplate | (Inherited from GridViewColumn.)
HeaderTemplateSelector | (Inherited from GridViewColumn.)
IsSealed | (Inherited from DependencyObject.)
Width | (Inherited from GridViewColumn.)

Events

Name Description

Explicit Interface Implementations

Name | Description
INotifyPropertyChanged..::.PropertyChanged | (Inherited from GridViewColumn.)

See Also

TreeGridViewColumn Class
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Constructor

[image]

.NET Framework Class Library
TreeGridViewColumn Constructor
TreeGridViewColumn Class See Also Send Feedback

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public TreeGridViewColumn()
Visual Basic (Declaration)
Public Sub New

See Also

TreeGridViewColumn Class
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Methods

[image] [image]

.NET Framework Class Library
TreeGridViewColumn Methods
TreeGridViewColumn Class See Also Send Feedback

The TreeGridViewColumn type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnHeaderStringFormatChanged | (Inherited from GridViewColumn.)
OnPropertyChanged | Overloaded.
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | (Inherited from GridViewColumn.)
VerifyAccess | (Inherited from DispatcherObject.)

See Also

TreeGridViewColumn Class
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
TreeGridViewColumn..::.ClearValue Method
TreeGridViewColumn Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

TreeGridViewColumn Class
TreeGridViewColumn Members
DlhSoft.Windows.Controls Namespace


OnPropertyChanged Method

[image] [image]

.NET Framework Class Library
TreeGridViewColumn..::.OnPropertyChanged Method
TreeGridViewColumn Class See Also Send Feedback

Overload List

Name | Description
OnPropertyChanged(PropertyChangedEventArgs) | (Inherited from GridViewColumn.)
OnPropertyChanged(DependencyPropertyChangedEventArgs) | (Inherited from DependencyObject.)

See Also

TreeGridViewColumn Class
TreeGridViewColumn Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
TreeGridViewColumn..::.SetValue Method
TreeGridViewColumn Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

TreeGridViewColumn Class
TreeGridViewColumn Members
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Properties

[image] [image]

.NET Framework Class Library
TreeGridViewColumn Properties
TreeGridViewColumn Class See Also Send Feedback

The TreeGridViewColumn type exposes the following members.

Properties

Name | Description
ActualWidth | (Inherited from GridViewColumn.)
CellTemplate | (Inherited from GridViewColumn.)
CellTemplateSelector | (Inherited from GridViewColumn.)
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberBinding | (Inherited from GridViewColumn.)
Header | (Inherited from GridViewColumn.)
HeaderContainerStyle | (Inherited from GridViewColumn.)
HeaderStringFormat | (Inherited from GridViewColumn.)
HeaderTemplate | (Inherited from GridViewColumn.)
HeaderTemplateSelector | (Inherited from GridViewColumn.)
IsSealed | (Inherited from DependencyObject.)
Width | (Inherited from GridViewColumn.)

See Also

TreeGridViewColumn Class
DlhSoft.Windows.Controls Namespace


TreeGridViewColumn Events

[image] [image]

.NET Framework Class Library
TreeGridViewColumn Events
TreeGridViewColumn Class See Also Send Feedback

Events

Name Description

Explicit Interface Implementations

Name | Description
INotifyPropertyChanged..::.PropertyChanged | (Inherited from GridViewColumn.)

See Also

TreeGridViewColumn Class
DlhSoft.Windows.Controls Namespace


TreeListView Class

[image]

.NET Framework Class Library
TreeListView Class
Members See Also Send Feedback

Represents a control that displays a tree-list of node data items. Use Items property to add node data items to an ItemCollection managed by the control, or set ItemsSource to your own node data item collection. It is recommended to set at least these data member properties: IndentationMemberPath. These data member properties can also be set: IsExpandedMemberPath. Alternatively you can set the NodeManagerSource to a customized node manager to use and to ignore the items collection and any associated data member properties. It is recommended to use a single NodeManager instance for each set of distinct node data items and data member properties at any specific time, and to use the Dispose method to release the resources used by an instance that is no longer needed.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.ListBox)]
public class TreeListView : ListView
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.ListBox)> _
Public Class TreeListView _
    Inherits ListView

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl
DlhSoft.Windows.Controls.Primitives..::.Selector
DlhSoft.Windows.Controls..::.ListBox
DlhSoft.Windows.Controls..::.ListView
DlhSoft.Windows.Controls..::.TreeListView

See Also

TreeListView Members
DlhSoft.Windows.Controls Namespace


TreeListView Members

[image] [image]

.NET Framework Class Library
TreeListView Members
TreeListView Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The TreeListView type exposes the following members.

Constructors

Name | Description
TreeListView | Initializes a new instance of the TreeListView class. The initial values of the data member properties are set to appropriate property paths for using NodeItem objects.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection. (Inherited from ListBox.)
AddSelectedEntityItem | Adds an entity item to the selection. (Inherited from ListBox.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListView host using the LoadedEntities. (Overrides ListBox..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ListView.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses the selected nodes in this TreeListView when possible.
CollapseAll | Collapses all nodes in this TreeListView that are not already collapsed.
CollapseBranch | Collapses the branches of the selected nodes in this TreeListView when possible.
CreateEntityManager | Establishes the node manager to be used internally by this TreeListView. (Overrides ItemsControlBase..::.CreateEntityManager(IEnumerable).)
DecreaseIndentation | Decreases the indentation of the selected nodes in this TreeListView when possible.
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Expand | Expands the selected nodes in this TreeListView when possible.
ExpandAll | Expands all nodes in this TreeListView that are not already expanded.
ExpandBranch | Expands the branches of the selected nodes in this TreeListView when possible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColumnCellTemplate | Overloaded.
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ListView host. (Overrides ItemsControl..::.GetItemsControlHostItemTemplate()()().)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetNode | Gets the node in the TreeListView that wraps the specified item.
GetNodeAt | Gets the node in the TreeListView at the specified index.
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
IncreaseIndentation | Increases the indentation of the selected nodes in this TreeListView when possible.
InitializeGridViewColumns | Overloaded.
InitializeGridViewColumnTemplateDataContext | Initializes the data context of the ContentControl to be used as a template of a GridViewColumn. (Inherited from ListView.)
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from ListView.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the node items to be presented by the control based on the current items and data binding properties. (Overrides ListView..::.LoadEntities()()().)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ListView.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnIndentationMemberPathChanged | Called when the IndentationMemberPath property changes.
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationDeferredScrollRatioChanged | Called when the IsAsyncPresentationDeferredScrollRatio property changes. (Inherited from ListView.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsExpandedMemberPathChanged | Called when the IsExpandedMemberPath property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsNodeExpansionReadOnlyChanged | Called when the IsNodeExpansionReadOnly property changes.
OnIsNodeIndentationReadOnlyChanged | Overloaded.
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLeafCountChanged | Called when the LeafCount property changes.
OnLeafNodesChanged | Called when the LeafNodes property changes.
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnNodeManagerSourceChanged | Called when the NodeManagerSource property changes.
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnRootCountChanged | Called when the RootCount property changes.
OnRootNodesChanged | Called when the RootNodes property changes.
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Inherited from ListBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection. (Inherited from ListBox.)
RemoveSelectedEntityItem | Removes an entity item from the selection. (Inherited from ListBox.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListView host based on the current property values of this ListView. (Inherited from ListView.)
ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox. (Inherited from ListBox.)
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListView host. (Overrides ListBox..::.UpdateSelectedEntityItems(IList, IList).)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IndentationMemberPathProperty | Identifies the IndentationMemberPath dependency property.
IsExpandedMemberPathProperty | Identifies the IsExpandedMemberPath dependency property.
IsNodeExpansionReadOnlyProperty | Identifies the IsNodeExpansionReadOnly dependency property.
IsNodeIndentationReadOnlyProperty | Identifies the IsNodeIndentationReadOnly dependency property.
LeafCountProperty | Identifies the LeafCount dependency property.
LeafNodesProperty | Identifies the LeafNodes dependency property.
ManagedNodesProperty | Identifies the ManagedNodes dependency property.
NodeManagerProperty | Identifies the NodeManager dependency property.
NodeManagerSourceProperty | Identifies the NodeManagerSource dependency property.
RootCountProperty | Identifies the RootCount dependency property.
RootNodesProperty | Identifies the RootNodes dependency property.
SelectedNodeProperty | Identifies the SelectedNode dependency property.
SelectedNodesProperty | Identifies the SelectedNodes dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control. (Inherited from ListBox.)
BaseListView | Gets the base ListView used as the core for this control. (Inherited from ListView.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CanCollapse | Gets a value indicating whether any of the selected nodes in this TreeListView can be collapsed.
CanCollapseAll | Gets a value indicating whether any node in this TreeListView can be collapsed.
CanCollapseBranch | Gets a value indicating whether the branch can be collapsed for any of the selected nodes in this TreeListView.
CanDecreaseIndentation | Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be decreased.
CanExpand | Gets a value indicating whether any of the selected nodes in this TreeListView can be expanded.
CanExpandAll | Gets a value indicating whether any node in this TreeListView can be expanded.
CanExpandBranch | Gets a value indicating whether the branch can be expanded for any of the selected nodes in this TreeListView.
CanIncreaseIndentation | Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be increased.
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IndentationMemberPath | Gets or sets the path to an Int32 value on the source node item to serve as the indentation level in the hierarchical collection, or null to indicate that the indentation level is not provided by the source node item. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationDeferredScrollRatio | Gets or sets the scroll ratio for which data loading should be deferred within this ListView when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ListView.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsExpandedMemberPath | Gets or sets the path to a Boolean value on the source node item to serve as the expansion indicator in the hierarchical collection, or null to indicate that the expansion indicator is not provided by the source node item. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsGridView | Gets a value that indicates whether the ListView control is using a GridView as its View. This is a dependency property. (Inherited from ListView.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListView host is available. (Inherited from ListView.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsNodeExpansionReadOnly | Gets or sets a value indicating whether the node expansion state is read-only in the TreeListView control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.
IsNodeIndentationReadOnly | Gets or sets a value indicating whether the node indentation is read-only in the TreeListView control so that the user cannot update it using the keyboard or by executing specific commands. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the node in the TreeListView that wraps the specified item.
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LeafCount | Gets the count of leaf nodes managed by this TreeListView. This is a dependency property.
LeafNodes | Gets the leaf nodes managed by this TreeListView. This is a dependency property.
ListBoxHost | Gets the ListBox host template part used internally by this ListBox. (Inherited from ListBox.)
ListViewHost | Gets the ListView host template part used internally by this ListView. (Inherited from ListView.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ManagedNodes | Gets the node collection managed by this TreeListView. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NodeManager | Gets the NodeManager object that is used internally for managing nodes displayed by this TreeListView. This is a dependency property.
NodeManagerSource | Gets or sets a custom NodeManager object to use internally within this TreeListView. When this property is set to a node manager instance the control items collection and the associated data member properties are ignored. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RootCount | Gets the count of root nodes managed by this TreeListView. This is a dependency property.
RootNodes | Gets the root nodes managed by this TreeListView. This is a dependency property.
ScrollViewer | Gets a reference to the internal ScrollViewer control instance used by the ListView control. (Inherited from ListView.)
SelectedEntities | Gets the currently selected entities. This is a dependency property. (Inherited from ListBox.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property. (Inherited from ListBox.)
SelectedNode | Gets or sets the first node in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedNodes | Gets the currently selected nodes. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property. (Inherited from ListBox.)
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets an object that defines how the data is styled and organized in a ListView control. This is a dependency property. (Inherited from ListView.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListView Constructor

[image]

.NET Framework Class Library
TreeListView Constructor
TreeListView Class See Also Send Feedback

Initializes a new instance of the TreeListView class. The initial values of the data member properties are set to appropriate property paths for using NodeItem objects.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public TreeListView()
Visual Basic (Declaration)
Public Sub New

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListView Fields

[image] [image]

.NET Framework Class Library
TreeListView Fields
TreeListView Class See Also Send Feedback

The TreeListView type exposes the following members.

Fields

Name | Description
IndentationMemberPathProperty | Identifies the IndentationMemberPath dependency property.
IsExpandedMemberPathProperty | Identifies the IsExpandedMemberPath dependency property.
IsNodeExpansionReadOnlyProperty | Identifies the IsNodeExpansionReadOnly dependency property.
IsNodeIndentationReadOnlyProperty | Identifies the IsNodeIndentationReadOnly dependency property.
LeafCountProperty | Identifies the LeafCount dependency property.
LeafNodesProperty | Identifies the LeafNodes dependency property.
ManagedNodesProperty | Identifies the ManagedNodes dependency property.
NodeManagerProperty | Identifies the NodeManager dependency property.
NodeManagerSourceProperty | Identifies the NodeManagerSource dependency property.
RootCountProperty | Identifies the RootCount dependency property.
RootNodesProperty | Identifies the RootNodes dependency property.
SelectedNodeProperty | Identifies the SelectedNode dependency property.
SelectedNodesProperty | Identifies the SelectedNodes dependency property.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IndentationMemberPathProperty Field

[image]

.NET Framework Class Library
TreeListView..::.IndentationMemberPathProperty Field
TreeListView Class See Also Send Feedback

Identifies the IndentationMemberPath dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IndentationMemberPathProperty
Visual Basic (Declaration)
Public Shared ReadOnly IndentationMemberPathProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsExpandedMemberPathProperty Field

[image]

.NET Framework Class Library
TreeListView..::.IsExpandedMemberPathProperty Field
TreeListView Class See Also Send Feedback

Identifies the IsExpandedMemberPath dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedMemberPathProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedMemberPathProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsNodeExpansionReadOnlyProperty Field

[image]

.NET Framework Class Library
TreeListView..::.IsNodeExpansionReadOnlyProperty Field
TreeListView Class See Also Send Feedback

Identifies the IsNodeExpansionReadOnly dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsNodeExpansionReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsNodeExpansionReadOnlyProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsNodeIndentationReadOnlyProperty Field

[image]

.NET Framework Class Library
TreeListView..::.IsNodeIndentationReadOnlyProperty Field
TreeListView Class See Also Send Feedback

Identifies the IsNodeIndentationReadOnly dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsNodeIndentationReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsNodeIndentationReadOnlyProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


LeafCountProperty Field

[image]

.NET Framework Class Library
TreeListView..::.LeafCountProperty Field
TreeListView Class See Also Send Feedback

Identifies the LeafCount dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty LeafCountProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeafCountProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


LeafNodesProperty Field

[image]

.NET Framework Class Library
TreeListView..::.LeafNodesProperty Field
TreeListView Class See Also Send Feedback

Identifies the LeafNodes dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty LeafNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeafNodesProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


ManagedNodesProperty Field

[image]

.NET Framework Class Library
TreeListView..::.ManagedNodesProperty Field
TreeListView Class See Also Send Feedback

Identifies the ManagedNodes dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ManagedNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly ManagedNodesProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


NodeManagerProperty Field

[image]

.NET Framework Class Library
TreeListView..::.NodeManagerProperty Field
TreeListView Class See Also Send Feedback

Identifies the NodeManager dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty NodeManagerProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeManagerProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


NodeManagerSourceProperty Field

[image]

.NET Framework Class Library
TreeListView..::.NodeManagerSourceProperty Field
TreeListView Class See Also Send Feedback

Identifies the NodeManagerSource dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty NodeManagerSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeManagerSourceProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


RootCountProperty Field

[image]

.NET Framework Class Library
TreeListView..::.RootCountProperty Field
TreeListView Class See Also Send Feedback

Identifies the RootCount dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty RootCountProperty
Visual Basic (Declaration)
Public Shared ReadOnly RootCountProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


RootNodesProperty Field

[image]

.NET Framework Class Library
TreeListView..::.RootNodesProperty Field
TreeListView Class See Also Send Feedback

Identifies the RootNodes dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty RootNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly RootNodesProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


SelectedNodeProperty Field

[image]

.NET Framework Class Library
TreeListView..::.SelectedNodeProperty Field
TreeListView Class See Also Send Feedback

Identifies the SelectedNode dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedNodeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedNodeProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


SelectedNodesProperty Field

[image]

.NET Framework Class Library
TreeListView..::.SelectedNodesProperty Field
TreeListView Class See Also Send Feedback

Identifies the SelectedNodes dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedNodesProperty As DependencyProperty

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListView Methods

[image] [image]

.NET Framework Class Library
TreeListView Methods
TreeListView Class See Also Send Feedback

The TreeListView type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddSelectedEntity | Adds an entity to the selection. (Inherited from ListBox.)
AddSelectedEntityItem | Adds an entity item to the selection. (Inherited from ListBox.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the ListView host using the LoadedEntities. (Overrides ListBox..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Inherited from Selector.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ListView.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses the selected nodes in this TreeListView when possible.
CollapseAll | Collapses all nodes in this TreeListView that are not already collapsed.
CollapseBranch | Collapses the branches of the selected nodes in this TreeListView when possible.
CreateEntityManager | Establishes the node manager to be used internally by this TreeListView. (Overrides ItemsControlBase..::.CreateEntityManager(IEnumerable).)
DecreaseIndentation | Decreases the indentation of the selected nodes in this TreeListView when possible.
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Expand | Expands the selected nodes in this TreeListView when possible.
ExpandAll | Expands all nodes in this TreeListView that are not already expanded.
ExpandBranch | Expands the branches of the selected nodes in this TreeListView when possible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColumnCellTemplate | Overloaded.
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ListView host. (Overrides ItemsControl..::.GetItemsControlHostItemTemplate()()().)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetNode | Gets the node in the TreeListView that wraps the specified item.
GetNodeAt | Gets the node in the TreeListView at the specified index.
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
IncreaseIndentation | Increases the indentation of the selected nodes in this TreeListView when possible.
InitializeGridViewColumns | Overloaded.
InitializeGridViewColumnTemplateDataContext | Initializes the data context of the ContentControl to be used as a template of a GridViewColumn. (Inherited from ListView.)
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from ListView.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the node items to be presented by the control based on the current items and data binding properties. (Overrides ListView..::.LoadEntities()()().)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ListView.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnIndentationMemberPathChanged | Called when the IndentationMemberPath property changes.
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationDeferredScrollRatioChanged | Called when the IsAsyncPresentationDeferredScrollRatio property changes. (Inherited from ListView.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsExpandedMemberPathChanged | Called when the IsExpandedMemberPath property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsNodeExpansionReadOnlyChanged | Called when the IsNodeExpansionReadOnly property changes.
OnIsNodeIndentationReadOnlyChanged | Overloaded.
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLeafCountChanged | Called when the LeafCount property changes.
OnLeafNodesChanged | Called when the LeafNodes property changes.
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnNodeManagerSourceChanged | Called when the NodeManagerSource property changes.
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnRootCountChanged | Called when the RootCount property changes.
OnRootNodesChanged | Called when the RootNodes property changes.
OnSelectionChanged | Invoked when the selection in ListBox host is changed and updates the selection of the ListBox. (Inherited from ListBox.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveSelectedEntity | Removes an entity from the selection. (Inherited from ListBox.)
RemoveSelectedEntityItem | Removes an entity item from the selection. (Inherited from ListBox.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the ListView host based on the current property values of this ListView. (Inherited from ListView.)
ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
SelectAll | Selects all the items in a ListBox. (Inherited from ListBox.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UnselectAll | Unselects all the items in a ListBox. (Inherited from ListBox.)
UpdateLayout | (Inherited from UIElement.)
UpdateSelectedEntities | Updates the internal selected entity collection to reflect the selection changes in the ListBox host. (Inherited from ListBox.)
UpdateSelectedEntityItems | Updates the internal selected item collection to reflect the selection changes in the ListView host. (Overrides ListBox..::.UpdateSelectedEntityItems(IList, IList).)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
TreeListView..::.AddHandler Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
TreeListView..::.ApplyAnimationClock Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
TreeListView..::.BeginAnimation Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
TreeListView..::.BeginStoryboard Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


BindItems Method

[image]

.NET Framework Class Library
TreeListView..::.BindItems Method
TreeListView Class See Also Send Feedback

Binds the ListView host using the LoadedEntities.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected override void BindItems()
Visual Basic (Declaration)
Protected Overrides Sub BindItems

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
TreeListView..::.BringIntoView Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
TreeListView..::.ClearValue Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


Collapse Method

[image]

.NET Framework Class Library
TreeListView..::.Collapse Method
TreeListView Class See Also Send Feedback

Collapses the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CollapseAll Method

[image]

.NET Framework Class Library
TreeListView..::.CollapseAll Method
TreeListView Class See Also Send Feedback

Collapses all nodes in this TreeListView that are not already collapsed.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void CollapseAll()
Visual Basic (Declaration)
Public Sub CollapseAll

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CollapseBranch Method

[image]

.NET Framework Class Library
TreeListView..::.CollapseBranch Method
TreeListView Class See Also Send Feedback

Collapses the branches of the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void CollapseBranch()
Visual Basic (Declaration)
Public Sub CollapseBranch

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CreateEntityManager Method

[image]

.NET Framework Class Library
TreeListView..::.CreateEntityManager Method
TreeListView Class See Also Send Feedback

Establishes the node manager to be used internally by this TreeListView.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected override EntityManager CreateEntityManager(
    IEnumerable items
)
Visual Basic (Declaration)
Protected Overrides Function CreateEntityManager ( _
    items As IEnumerable _
) As EntityManager

Parameters

items
Type: System.Collections..::.IEnumerable
Item collection to be managed.

Return Value

The node manager to be used internally by this TreeListView.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


DecreaseIndentation Method

[image]

.NET Framework Class Library
TreeListView..::.DecreaseIndentation Method
TreeListView Class See Also Send Feedback

Decreases the indentation of the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void DecreaseIndentation()
Visual Basic (Declaration)
Public Sub DecreaseIndentation

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


Expand Method

[image]

.NET Framework Class Library
TreeListView..::.Expand Method
TreeListView Class See Also Send Feedback

Expands the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


ExpandAll Method

[image]

.NET Framework Class Library
TreeListView..::.ExpandAll Method
TreeListView Class See Also Send Feedback

Expands all nodes in this TreeListView that are not already expanded.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void ExpandAll()
Visual Basic (Declaration)
Public Sub ExpandAll

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


ExpandBranch Method

[image]

.NET Framework Class Library
TreeListView..::.ExpandBranch Method
TreeListView Class See Also Send Feedback

Expands the branches of the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void ExpandBranch()
Visual Basic (Declaration)
Public Sub ExpandBranch

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


GetColumnCellTemplate Method

[image] [image]

.NET Framework Class Library
TreeListView..::.GetColumnCellTemplate Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
GetColumnCellTemplate(GridViewColumn, DataTemplate) | Gets the column cell template of a specified GridViewColumn. (Inherited from ListView.)
GetColumnCellTemplate(GridViewColumn, DataTemplate) | Gets the column cell template of a specified GridViewColumn.

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


GetColumnCellTemplate Method (GridViewColumn, DataTemplate)

[image]

.NET Framework Class Library
TreeListView..::.GetColumnCellTemplate Method (GridViewColumn, DataTemplate)
TreeListView Class See Also Send Feedback

Gets the column cell template of a specified GridViewColumn.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual DataTemplate GetColumnCellTemplate(
    GridViewColumn gridViewColumn,
    DataTemplate contentTemplate
)
Visual Basic (Declaration)
Protected Overridable Function GetColumnCellTemplate ( _
    gridViewColumn As GridViewColumn, _
    contentTemplate As DataTemplate _
) As DataTemplate

Parameters

gridViewColumn
Type: System.Windows.Controls..::.GridViewColumn
The column to get the cell template for.
contentTemplate
Type: System.Windows..::.DataTemplate
The content template to be used.

Return Value

The column cell template of the specified GridViewColumn.

See Also

TreeListView Class
GetColumnCellTemplate Overload
DlhSoft.Windows.Controls Namespace


GetItemsControlHostItemTemplate Method

[image]

.NET Framework Class Library
TreeListView..::.GetItemsControlHostItemTemplate Method
TreeListView Class See Also Send Feedback

Gets the item template to be used within the ListView host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected override DataTemplate GetItemsControlHostItemTemplate()
Visual Basic (Declaration)
Protected Overrides Function GetItemsControlHostItemTemplate As DataTemplate

Return Value

The item template to be used within the ListView host.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


GetNode Method

[image]

.NET Framework Class Library
TreeListView..::.GetNode Method
TreeListView Class See Also Send Feedback

Gets the node in the TreeListView that wraps the specified item.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public Node GetNode(
    Object item
)
Visual Basic (Declaration)
Public Function GetNode ( _
    item As Object _
) As Node

Parameters

item
Type: System..::.Object
The item to get the node for.

Return Value

The node in the hierarchy that wraps the specified item.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


GetNodeAt Method

[image]

.NET Framework Class Library
TreeListView..::.GetNodeAt Method
TreeListView Class See Also Send Feedback

Gets the node in the TreeListView at the specified index.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public Node GetNodeAt(
    int index
)
Visual Basic (Declaration)
Public Function GetNodeAt ( _
    index As Integer _
) As Node

Parameters

index
Type: System..::.Int32
The zero-based index of the node to be get.

Return Value

The node in the hierarchy at the specified index.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
TreeListView..::.HitTestCore Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


IncreaseIndentation Method

[image]

.NET Framework Class Library
TreeListView..::.IncreaseIndentation Method
TreeListView Class See Also Send Feedback

Increases the indentation of the selected nodes in this TreeListView when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void IncreaseIndentation()
Visual Basic (Declaration)
Public Sub IncreaseIndentation

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


InitializeGridViewColumns Method

[image] [image]

.NET Framework Class Library
TreeListView..::.InitializeGridViewColumns Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
InitializeGridViewColumns(GridViewColumnCollection, GridViewColumnCollection) | Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection. (Inherited from ListView.)
InitializeGridViewColumns(GridViewColumnCollection, GridViewColumnCollection) | Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection.

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


InitializeGridViewColumns Method (GridViewColumnCollection, GridViewColumnCollection)

[image]

.NET Framework Class Library
TreeListView..::.InitializeGridViewColumns Method (GridViewColumnCollection, GridViewColumnCollection)
TreeListView Class See Also Send Feedback

Initializes the GridViewColumnCollection to be used based on a specified source GridViewColumnCollection.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void InitializeGridViewColumns(
    GridViewColumnCollection referencedGridViewColumns,
    GridViewColumnCollection sourceGridViewColumns
)
Visual Basic (Declaration)
Protected Overridable Sub InitializeGridViewColumns ( _
    referencedGridViewColumns As GridViewColumnCollection, _
    sourceGridViewColumns As GridViewColumnCollection _
)

Parameters

referencedGridViewColumns
Type: System.Windows.Controls..::.GridViewColumnCollection
The GridViewColumnCollection to be used.
sourceGridViewColumns
Type: System.Windows.Controls..::.GridViewColumnCollection
The source GridViewColumnCollection to be considered.

See Also

TreeListView Class
InitializeGridViewColumns Overload
DlhSoft.Windows.Controls Namespace


LoadEntities Method

[image]

.NET Framework Class Library
TreeListView..::.LoadEntities Method
TreeListView Class See Also Send Feedback

Prepares the node items to be presented by the control based on the current items and data binding properties.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected override void LoadEntities()
Visual Basic (Declaration)
Protected Overrides Sub LoadEntities

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


Move Method

[image] [image]

.NET Framework Class Library
TreeListView..::.Move Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)
Move(Object, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


OnIndentationMemberPathChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnIndentationMemberPathChanged Method
TreeListView Class See Also Send Feedback

Called when the IndentationMemberPath property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIndentationMemberPathChanged(
    string oldIndentationMemberPath,
    string newIndentationMemberPath
)
Visual Basic (Declaration)
Protected Overridable Sub OnIndentationMemberPathChanged ( _
    oldIndentationMemberPath As String, _
    newIndentationMemberPath As String _
)

Parameters

oldIndentationMemberPath
Type: System..::.String
newIndentationMemberPath
Type: System..::.String

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnIsExpandedMemberPathChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnIsExpandedMemberPathChanged Method
TreeListView Class See Also Send Feedback

Called when the IsExpandedMemberPath property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsExpandedMemberPathChanged(
    string oldIsExpandedMemberPath,
    string newIsExpandedMemberPath
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsExpandedMemberPathChanged ( _
    oldIsExpandedMemberPath As String, _
    newIsExpandedMemberPath As String _
)

Parameters

oldIsExpandedMemberPath
Type: System..::.String
newIsExpandedMemberPath
Type: System..::.String

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnIsNodeExpansionReadOnlyChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnIsNodeExpansionReadOnlyChanged Method
TreeListView Class See Also Send Feedback

Called when the IsNodeExpansionReadOnly property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsNodeExpansionReadOnlyChanged(
    bool oldIsNodeExpansionReadOnly,
    bool newIsNodeExpansionReadOnly
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsNodeExpansionReadOnlyChanged ( _
    oldIsNodeExpansionReadOnly As Boolean, _
    newIsNodeExpansionReadOnly As Boolean _
)

Parameters

oldIsNodeExpansionReadOnly
Type: System..::.Boolean
newIsNodeExpansionReadOnly
Type: System..::.Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnIsNodeIndentationReadOnlyChanged Method

[image] [image]

.NET Framework Class Library
TreeListView..::.OnIsNodeIndentationReadOnlyChanged Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
OnIsNodeIndentationReadOnlyChanged()()() | Called when the IsNodeIndentationReadOnly property changes.
OnIsNodeIndentationReadOnlyChanged(Boolean, Boolean) | Called when the IsNodeIndentationReadOnly property changes.

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


OnIsNodeIndentationReadOnlyChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnIsNodeIndentationReadOnlyChanged Method
TreeListView Class See Also Send Feedback

Called when the IsNodeIndentationReadOnly property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsNodeIndentationReadOnlyChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnIsNodeIndentationReadOnlyChanged

See Also

TreeListView Class
OnIsNodeIndentationReadOnlyChanged Overload
DlhSoft.Windows.Controls Namespace


OnIsNodeIndentationReadOnlyChanged Method (Boolean, Boolean)

[image]

.NET Framework Class Library
TreeListView..::.OnIsNodeIndentationReadOnlyChanged Method (Boolean, Boolean)
TreeListView Class See Also Send Feedback

Called when the IsNodeIndentationReadOnly property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsNodeIndentationReadOnlyChanged(
    bool oldIsNodeIndentationReadOnly,
    bool newIsNodeIndentationReadOnly
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsNodeIndentationReadOnlyChanged ( _
    oldIsNodeIndentationReadOnly As Boolean, _
    newIsNodeIndentationReadOnly As Boolean _
)

Parameters

oldIsNodeIndentationReadOnly
Type: System..::.Boolean
newIsNodeIndentationReadOnly
Type: System..::.Boolean

See Also

TreeListView Class
OnIsNodeIndentationReadOnlyChanged Overload
DlhSoft.Windows.Controls Namespace


OnLeafCountChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnLeafCountChanged Method
TreeListView Class See Also Send Feedback

Called when the LeafCount property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnLeafCountChanged(
    int oldLeafCount,
    int newLeafCount
)
Visual Basic (Declaration)
Protected Overridable Sub OnLeafCountChanged ( _
    oldLeafCount As Integer, _
    newLeafCount As Integer _
)

Parameters

oldLeafCount
Type: System..::.Int32
newLeafCount
Type: System..::.Int32

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnLeafNodesChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnLeafNodesChanged Method
TreeListView Class See Also Send Feedback

Called when the LeafNodes property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnLeafNodesChanged(
    IEnumerable<Node> oldLeafNodes,
    IEnumerable<Node> newLeafNodes
)
Visual Basic (Declaration)
Protected Overridable Sub OnLeafNodesChanged ( _
    oldLeafNodes As IEnumerable(Of Node), _
    newLeafNodes As IEnumerable(Of Node) _
)

Parameters

oldLeafNodes
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)
newLeafNodes
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnNodeManagerSourceChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnNodeManagerSourceChanged Method
TreeListView Class See Also Send Feedback

Called when the NodeManagerSource property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnNodeManagerSourceChanged(
    NodeManager oldValue,
    NodeManager newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnNodeManagerSourceChanged ( _
    oldValue As NodeManager, _
    newValue As NodeManager _
)

Parameters

oldValue
Type: DlhSoft.Windows.Data..::.NodeManager
newValue
Type: DlhSoft.Windows.Data..::.NodeManager

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnRootCountChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnRootCountChanged Method
TreeListView Class See Also Send Feedback

Called when the RootCount property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnRootCountChanged(
    int oldRootCount,
    int newRootCount
)
Visual Basic (Declaration)
Protected Overridable Sub OnRootCountChanged ( _
    oldRootCount As Integer, _
    newRootCount As Integer _
)

Parameters

oldRootCount
Type: System..::.Int32
newRootCount
Type: System..::.Int32

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


OnRootNodesChanged Method

[image]

.NET Framework Class Library
TreeListView..::.OnRootNodesChanged Method
TreeListView Class See Also Send Feedback

Called when the RootNodes property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnRootNodesChanged(
    IEnumerable<Node> oldRootNodes,
    IEnumerable<Node> newRootNodes
)
Visual Basic (Declaration)
Protected Overridable Sub OnRootNodesChanged ( _
    oldRootNodes As IEnumerable(Of Node), _
    newRootNodes As IEnumerable(Of Node) _
)

Parameters

oldRootNodes
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)
newRootNodes
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
TreeListView..::.SetBinding Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
TreeListView..::.SetValue Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
TreeListView..::.TransformToAncestor Method
TreeListView Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

TreeListView Class
TreeListView Members
DlhSoft.Windows.Controls Namespace


UpdateSelectedEntityItems Method

[image]

.NET Framework Class Library
TreeListView..::.UpdateSelectedEntityItems Method
TreeListView Class See Also Send Feedback

Updates the internal selected item collection to reflect the selection changes in the ListView host.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected override void UpdateSelectedEntityItems(
    IList addedItems,
    IList removedItems
)
Visual Basic (Declaration)
Protected Overrides Sub UpdateSelectedEntityItems ( _
    addedItems As IList, _
    removedItems As IList _
)

Parameters

addedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were selected.
removedItems
Type: System.Collections..::.IList
Gets a list that contains the entities that were unselected.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListView Properties

[image] [image]

.NET Framework Class Library
TreeListView Properties
TreeListView Class See Also Send Feedback

The TreeListView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BaseListBox | Gets the base ListBox used as the core for this control. (Inherited from ListBox.)
BaseListView | Gets the base ListView used as the core for this control. (Inherited from ListView.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CanCollapse | Gets a value indicating whether any of the selected nodes in this TreeListView can be collapsed.
CanCollapseAll | Gets a value indicating whether any node in this TreeListView can be collapsed.
CanCollapseBranch | Gets a value indicating whether the branch can be collapsed for any of the selected nodes in this TreeListView.
CanDecreaseIndentation | Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be decreased.
CanExpand | Gets a value indicating whether any of the selected nodes in this TreeListView can be expanded.
CanExpandAll | Gets a value indicating whether any node in this TreeListView can be expanded.
CanExpandBranch | Gets a value indicating whether the branch can be expanded for any of the selected nodes in this TreeListView.
CanIncreaseIndentation | Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be increased.
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IndentationMemberPath | Gets or sets the path to an Int32 value on the source node item to serve as the indentation level in the hierarchical collection, or null to indicate that the indentation level is not provided by the source node item. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationDeferredScrollRatio | Gets or sets the scroll ratio for which data loading should be deferred within this ListView when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ListView.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsExpandedMemberPath | Gets or sets the path to a Boolean value on the source node item to serve as the expansion indicator in the hierarchical collection, or null to indicate that the expansion indicator is not provided by the source node item. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsGridView | Gets a value that indicates whether the ListView control is using a GridView as its View. This is a dependency property. (Inherited from ListView.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ListView host is available. (Inherited from ListView.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsNodeExpansionReadOnly | Gets or sets a value indicating whether the node expansion state is read-only in the TreeListView control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.
IsNodeIndentationReadOnly | Gets or sets a value indicating whether the node indentation is read-only in the TreeListView control so that the user cannot update it using the keyboard or by executing specific commands. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property. (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the node in the TreeListView that wraps the specified item.
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LeafCount | Gets the count of leaf nodes managed by this TreeListView. This is a dependency property.
LeafNodes | Gets the leaf nodes managed by this TreeListView. This is a dependency property.
ListBoxHost | Gets the ListBox host template part used internally by this ListBox. (Inherited from ListBox.)
ListViewHost | Gets the ListView host template part used internally by this ListView. (Inherited from ListView.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ManagedNodes | Gets the node collection managed by this TreeListView. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NodeManager | Gets the NodeManager object that is used internally for managing nodes displayed by this TreeListView. This is a dependency property.
NodeManagerSource | Gets or sets a custom NodeManager object to use internally within this TreeListView. When this property is set to a node manager instance the control items collection and the associated data member properties are ignored. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RootCount | Gets the count of root nodes managed by this TreeListView. This is a dependency property.
RootNodes | Gets the root nodes managed by this TreeListView. This is a dependency property.
ScrollViewer | Gets a reference to the internal ScrollViewer control instance used by the ListView control. (Inherited from ListView.)
SelectedEntities | Gets the currently selected entities. This is a dependency property. (Inherited from ListBox.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property. (Inherited from Selector.)
SelectedItems | Gets the currently selected items. This is a dependency property. (Inherited from ListBox.)
SelectedNode | Gets or sets the first node in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedNodes | Gets the currently selected nodes. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property. (Inherited from Selector.)
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property. (Inherited from Selector.)
SelectionMode | Gets or sets the selection behavior for a ListBox. This is a dependency property. (Inherited from ListBox.)
SelectorHost | Gets the selector host template part used internally by this Selector. (Inherited from Selector.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets an object that defines how the data is styled and organized in a ListView control. This is a dependency property. (Inherited from ListView.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanCollapse Property

[image]

.NET Framework Class Library
TreeListView..::.CanCollapse Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether any of the selected nodes in this TreeListView can be collapsed.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapse { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapse As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanCollapseAll Property

[image]

.NET Framework Class Library
TreeListView..::.CanCollapseAll Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether any node in this TreeListView can be collapsed.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapseAll { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapseAll As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanCollapseBranch Property

[image]

.NET Framework Class Library
TreeListView..::.CanCollapseBranch Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether the branch can be collapsed for any of the selected nodes in this TreeListView.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapseBranch { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapseBranch As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanDecreaseIndentation Property

[image]

.NET Framework Class Library
TreeListView..::.CanDecreaseIndentation Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be decreased.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanDecreaseIndentation { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanDecreaseIndentation As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanExpand Property

[image]

.NET Framework Class Library
TreeListView..::.CanExpand Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether any of the selected nodes in this TreeListView can be expanded.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpand { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpand As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanExpandAll Property

[image]

.NET Framework Class Library
TreeListView..::.CanExpandAll Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether any node in this TreeListView can be expanded.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpandAll { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpandAll As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanExpandBranch Property

[image]

.NET Framework Class Library
TreeListView..::.CanExpandBranch Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether the branch can be expanded for any of the selected nodes in this TreeListView.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpandBranch { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpandBranch As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


CanIncreaseIndentation Property

[image]

.NET Framework Class Library
TreeListView..::.CanIncreaseIndentation Property
TreeListView Class See Also Send Feedback

Gets a value indicating whether the indentation for any of the selected nodes in this TreeListView can be increased.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanIncreaseIndentation { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanIncreaseIndentation As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IndentationMemberPath Property

[image]

.NET Framework Class Library
TreeListView..::.IndentationMemberPath Property
TreeListView Class See Also Send Feedback

Gets or sets the path to an Int32 value on the source node item to serve as the indentation level in the hierarchical collection, or null to indicate that the indentation level is not provided by the source node item. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string IndentationMemberPath { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IndentationMemberPath As String

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsExpandedMemberPath Property

[image]

.NET Framework Class Library
TreeListView..::.IsExpandedMemberPath Property
TreeListView Class See Also Send Feedback

Gets or sets the path to a Boolean value on the source node item to serve as the expansion indicator in the hierarchical collection, or null to indicate that the expansion indicator is not provided by the source node item. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string IsExpandedMemberPath { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpandedMemberPath As String

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsNodeExpansionReadOnly Property

[image]

.NET Framework Class Library
TreeListView..::.IsNodeExpansionReadOnly Property
TreeListView Class See Also Send Feedback

Gets or sets a value indicating whether the node expansion state is read-only in the TreeListView control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsNodeExpansionReadOnly { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsNodeExpansionReadOnly As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


IsNodeIndentationReadOnly Property

[image]

.NET Framework Class Library
TreeListView..::.IsNodeIndentationReadOnly Property
TreeListView Class See Also Send Feedback

Gets or sets a value indicating whether the node indentation is read-only in the TreeListView control so that the user cannot update it using the keyboard or by executing specific commands. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsNodeIndentationReadOnly { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsNodeIndentationReadOnly As Boolean

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


Item Property

[image]

.NET Framework Class Library
TreeListView..::.Item Property
TreeListView Class See Also Send Feedback

Gets the node in the TreeListView that wraps the specified item.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public Node Item[
    Object item
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    item As Object _
) As Node

Parameters

item
Type: System..::.Object
The item to get the node for.

Return Value

The node in the hierarchy that wraps the specified item.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


LeafCount Property

[image]

.NET Framework Class Library
TreeListView..::.LeafCount Property
TreeListView Class See Also Send Feedback

Gets the count of leaf nodes managed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int LeafCount { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property LeafCount As Integer

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


LeafNodes Property

[image]

.NET Framework Class Library
TreeListView..::.LeafNodes Property
TreeListView Class See Also Send Feedback

Gets the leaf nodes managed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable<Node> LeafNodes { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property LeafNodes As IEnumerable(Of Node)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


ManagedNodes Property

[image]

.NET Framework Class Library
TreeListView..::.ManagedNodes Property
TreeListView Class See Also Send Feedback

Gets the node collection managed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public ReadOnlyNodeCollection ManagedNodes { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ManagedNodes As ReadOnlyNodeCollection

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


NodeManager Property

[image]

.NET Framework Class Library
TreeListView..::.NodeManager Property
TreeListView Class See Also Send Feedback

Gets the NodeManager object that is used internally for managing nodes displayed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public NodeManager NodeManager { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property NodeManager As NodeManager

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


NodeManagerSource Property

[image]

.NET Framework Class Library
TreeListView..::.NodeManagerSource Property
TreeListView Class See Also Send Feedback

Gets or sets a custom NodeManager object to use internally within this TreeListView. When this property is set to a node manager instance the control items collection and the associated data member properties are ignored. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public NodeManager NodeManagerSource { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property NodeManagerSource As NodeManager

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


RootCount Property

[image]

.NET Framework Class Library
TreeListView..::.RootCount Property
TreeListView Class See Also Send Feedback

Gets the count of root nodes managed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int RootCount { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property RootCount As Integer

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


RootNodes Property

[image]

.NET Framework Class Library
TreeListView..::.RootNodes Property
TreeListView Class See Also Send Feedback

Gets the root nodes managed by this TreeListView. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable<Node> RootNodes { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property RootNodes As IEnumerable(Of Node)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


SelectedNode Property

[image]

.NET Framework Class Library
TreeListView..::.SelectedNode Property
TreeListView Class See Also Send Feedback

Gets or sets the first node in the current selection or returns null if the selection is empty. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Node SelectedNode { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedNode As Node

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


SelectedNodes Property

[image]

.NET Framework Class Library
TreeListView..::.SelectedNodes Property
TreeListView Class See Also Send Feedback

Gets the currently selected nodes. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IList<Node> SelectedNodes { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedNodes As IList(Of Node)

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListView Events

[image] [image]

.NET Framework Class Library
TreeListView Events
TreeListView Class See Also Send Feedback

The TreeListView type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

TreeListView Class
DlhSoft.Windows.Controls Namespace


TreeListViewItem Class

[image]

.NET Framework Class Library
TreeListViewItem Class
Members See Also Send Feedback

Represents an item in the TreeListView control aware of its indentation and expansion state (can be expanded or collapsed). It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None)]
public class TreeListViewItem : ContentControl,
    IEntityItem
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None)> _
Public Class TreeListViewItem _
    Inherits ContentControl _
    Implements IEntityItem

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ContentControlBase
DlhSoft.Windows.Controls..::.ContentControl
DlhSoft.Windows.Controls..::.TreeListViewItem

See Also

TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


TreeListViewItem Members

[image] [image]

.NET Framework Class Library
TreeListViewItem Members
TreeListViewItem Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The TreeListViewItem type exposes the following members.

Constructors

Name | Description
TreeListViewItem |

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ContentControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ContentControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity. (Inherited from ContentControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ContentControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ContentControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ContentControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContentControlHostContentTemplate | Gets the content template to be used within the ContentControl host. (Inherited from ContentControl.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeContentTemplateDataContext | Initializes the data context of the ContentControl to be used as a content template. (Inherited from ContentControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from ContentControl.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties. (Inherited from ContentControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ContentControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes. (Inherited from ContentControlBase.)
OnContentStringFormatChanged | Called when the ContentStringFormat property changes. (Inherited from ContentControl.)
OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ContentControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ContentControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ContentControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ContentControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetContentControlHost | Resets the content control host based on the current property values of this ContentControl. (Inherited from ContentControl.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Inherited from ContentControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseContentControl | Gets the base ContentControl used as the core for this control. (Inherited from ContentControl.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase. (Inherited from ContentControlBase.)
ContentStringFormat | Gets or sets a composite string that specifies how to format the content in the ContentControl if it is displayed as string. This is a dependency property. (Inherited from ContentControl.)
ContentTemplate | Gets or sets the DataTemplate to be used to display the content. This is a dependency property. (Inherited from ContentControl.)
ContentTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display the content. This is a dependency property. (Inherited from ContentControl.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ContentControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property. (Inherited from ContentControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property. (Inherited from ContentControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Indentation | Gets or sets the indentation level of this TreeListViewItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available. (Inherited from ContentControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ContentControlBase.)
IsExpanded | Gets or sets the expansion indicator of this TreeListViewItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property. (Inherited from ContentControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


TreeListViewItem Constructor

[image]

.NET Framework Class Library
TreeListViewItem Constructor
TreeListViewItem Class See Also Send Feedback

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public TreeListViewItem()
Visual Basic (Declaration)
Public Sub New

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


TreeListViewItem Fields

[image] [image]

.NET Framework Class Library
TreeListViewItem Fields
TreeListViewItem Class See Also Send Feedback

The TreeListViewItem type exposes the following members.

Fields

Name | Description
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


IndentationProperty Field

[image]

.NET Framework Class Library
TreeListViewItem..::.IndentationProperty Field
TreeListViewItem Class See Also Send Feedback

Identifies the Indentation dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IndentationProperty
Visual Basic (Declaration)
Public Shared ReadOnly IndentationProperty As DependencyProperty

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


IsExpandedProperty Field

[image]

.NET Framework Class Library
TreeListViewItem..::.IsExpandedProperty Field
TreeListViewItem Class See Also Send Feedback

Identifies the IsExpanded dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


TreeListViewItem Methods

[image] [image]

.NET Framework Class Library
TreeListViewItem Methods
TreeListViewItem Class See Also Send Feedback

The TreeListViewItem type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ContentControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ContentControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity. (Inherited from ContentControlBase.)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Inherited from ContentControlBase.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ContentControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ContentControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContentControlHostContentTemplate | Gets the content template to be used within the ContentControl host. (Inherited from ContentControl.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeContentTemplateDataContext | Initializes the data context of the ContentControl to be used as a content template. (Inherited from ContentControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Inherited from ContentControl.)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties. (Inherited from ContentControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ContentControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes. (Inherited from ContentControlBase.)
OnContentStringFormatChanged | Called when the ContentStringFormat property changes. (Inherited from ContentControl.)
OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ContentControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ContentControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ContentControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ContentControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetContentControlHost | Resets the content control host based on the current property values of this ContentControl. (Inherited from ContentControl.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Inherited from ContentControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.AddHandler Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.ApplyAnimationClock Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.BeginAnimation Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.BeginStoryboard Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.BringIntoView Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.ClearValue Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.HitTestCore Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.SetBinding Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.SetValue Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
TreeListViewItem..::.TransformToAncestor Method
TreeListViewItem Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

TreeListViewItem Class
TreeListViewItem Members
DlhSoft.Windows.Controls Namespace


TreeListViewItem Properties

[image] [image]

.NET Framework Class Library
TreeListViewItem Properties
TreeListViewItem Class See Also Send Feedback

The TreeListViewItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseContentControl | Gets the base ContentControl used as the core for this control. (Inherited from ContentControl.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase. (Inherited from ContentControlBase.)
ContentStringFormat | Gets or sets a composite string that specifies how to format the content in the ContentControl if it is displayed as string. This is a dependency property. (Inherited from ContentControl.)
ContentTemplate | Gets or sets the DataTemplate to be used to display the content. This is a dependency property. (Inherited from ContentControl.)
ContentTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display the content. This is a dependency property. (Inherited from ContentControl.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ContentControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property. (Inherited from ContentControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property. (Inherited from ContentControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Indentation | Gets or sets the indentation level of this TreeListViewItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available. (Inherited from ContentControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ContentControlBase.)
IsExpanded | Gets or sets the expansion indicator of this TreeListViewItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property. (Inherited from ContentControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property. (Inherited from ContentControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


Indentation Property

[image]

.NET Framework Class Library
TreeListViewItem..::.Indentation Property
TreeListViewItem Class See Also Send Feedback

Gets or sets the indentation level of this TreeListViewItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int Indentation { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Indentation As Integer

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


IsExpanded Property

[image]

.NET Framework Class Library
TreeListViewItem..::.IsExpanded Property
TreeListViewItem Class See Also Send Feedback

Gets or sets the expansion indicator of this TreeListViewItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpanded As Boolean

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


TreeListViewItem Events

[image] [image]

.NET Framework Class Library
TreeListViewItem Events
TreeListViewItem Class See Also Send Feedback

The TreeListViewItem type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

TreeListViewItem Class
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Class

[image]

.NET Framework Class Library
TreeListViewItemControl Class
Members See Also Send Feedback

Displays the indented content of a TreeListViewItem providing an expander that allows the user to expand or collapse the node in the hierarchy.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
[TemplatePartAttribute(Name = "PART_ToggleButton", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "PART_Content", Type = typeof(FrameworkElement))]
public class TreeListViewItemControl : Control
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
<TemplatePartAttribute(Name := "PART_ToggleButton", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "PART_Content", Type := GetType(FrameworkElement))> _
Public Class TreeListViewItemControl _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls..::.TreeListViewItemControl

See Also

TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Members

[image] [image]

.NET Framework Class Library
TreeListViewItemControl Members
TreeListViewItemControl Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The TreeListViewItemControl type exposes the following members.

Constructors

Name | Description
TreeListViewItemControl | Initializes a new instance of the TreeListViewItemControl class.

Methods

Name | Description
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses the node in this TreeListViewItemControl when possible.
EndInit | (Inherited from FrameworkElement.)
Equals | (Inherited from DependencyObject.)
Expand | Expands the node in this TreeListViewItemControl when possible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from DependencyObject.)
GetIsExpanderVisible | Gets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsExpanderVisibleChanged | Called when the IsExpanderVisible property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsNodeExpansionReadOnlyChanged | Called when the IsNodeExpansionReadOnly property changes.
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnNodeChanged | Called when the Node property changes.
OnNodeContentTemplateChanged | Called when the NodeContentTemplate property changes.
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetIsExpanderVisible | Sets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | (Inherited from Control.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IsExpanderVisibleProperty | Identifies the IsExpanderVisible attached property.
IsNodeExpansionReadOnlyProperty | Identifies the IsNodeExpansionReadOnly dependency property.
NodeContentTemplateProperty | Identifies the NodeContentTemplate dependency property.
NodeProperty | Identifies the Node dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CanCollapse | Gets a value indicating whether the node in this TreeListViewItemControl can be collapseed.
CanExpand | Gets a value indicating whether the node in this TreeListViewItemControl can be expanded.
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsExpanderVisible | Gets or sets a value indicating whether the expansion toggle button is visible within this TreeListViewItemControl. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsNodeExpansionReadOnly | Gets or sets a value indicating whether the node expansion state is read-only in the TreeListViewItemControl control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LogicalChildren | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Node | Gets or sets the node to be presented by this control. This is a dependency property.
NodeContentTemplate | Gets or sets the data template to be used to display the specified node. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Constructor

[image]

.NET Framework Class Library
TreeListViewItemControl Constructor
TreeListViewItemControl Class See Also Send Feedback

Initializes a new instance of the TreeListViewItemControl class.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public TreeListViewItemControl()
Visual Basic (Declaration)
Public Sub New

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Fields

[image] [image]

.NET Framework Class Library
TreeListViewItemControl Fields
TreeListViewItemControl Class See Also Send Feedback

The TreeListViewItemControl type exposes the following members.

Fields

Name | Description
IsExpanderVisibleProperty | Identifies the IsExpanderVisible attached property.
IsNodeExpansionReadOnlyProperty | Identifies the IsNodeExpansionReadOnly dependency property.
NodeContentTemplateProperty | Identifies the NodeContentTemplate dependency property.
NodeProperty | Identifies the Node dependency property.

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


IsExpanderVisibleProperty Field

[image]

.NET Framework Class Library
TreeListViewItemControl..::.IsExpanderVisibleProperty Field
TreeListViewItemControl Class See Also Send Feedback

Identifies the IsExpanderVisible attached property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsExpanderVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpanderVisibleProperty As DependencyProperty

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


IsNodeExpansionReadOnlyProperty Field

[image]

.NET Framework Class Library
TreeListViewItemControl..::.IsNodeExpansionReadOnlyProperty Field
TreeListViewItemControl Class See Also Send Feedback

Identifies the IsNodeExpansionReadOnly dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsNodeExpansionReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsNodeExpansionReadOnlyProperty As DependencyProperty

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


NodeContentTemplateProperty Field

[image]

.NET Framework Class Library
TreeListViewItemControl..::.NodeContentTemplateProperty Field
TreeListViewItemControl Class See Also Send Feedback

Identifies the NodeContentTemplate dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty NodeContentTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeContentTemplateProperty As DependencyProperty

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


NodeProperty Field

[image]

.NET Framework Class Library
TreeListViewItemControl..::.NodeProperty Field
TreeListViewItemControl Class See Also Send Feedback

Identifies the Node dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static readonly DependencyProperty NodeProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeProperty As DependencyProperty

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Methods

[image] [image]

.NET Framework Class Library
TreeListViewItemControl Methods
TreeListViewItemControl Class See Also Send Feedback

The TreeListViewItemControl type exposes the following members.

Methods

Name | Description
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses the node in this TreeListViewItemControl when possible.
EndInit | (Inherited from FrameworkElement.)
Equals | (Inherited from DependencyObject.)
Expand | Expands the node in this TreeListViewItemControl when possible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from DependencyObject.)
GetIsExpanderVisible | Gets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsExpanderVisibleChanged | Called when the IsExpanderVisible property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsNodeExpansionReadOnlyChanged | Called when the IsNodeExpansionReadOnly property changes.
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnNodeChanged | Called when the Node property changes.
OnNodeContentTemplateChanged | Called when the NodeContentTemplate property changes.
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetIsExpanderVisible | Sets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | (Inherited from Control.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.AddHandler Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.ApplyAnimationClock Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.BeginAnimation Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.BeginStoryboard Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.BringIntoView Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.ClearValue Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


Collapse Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.Collapse Method
TreeListViewItemControl Class See Also Send Feedback

Collapses the node in this TreeListViewItemControl when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


Expand Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.Expand Method
TreeListViewItemControl Class See Also Send Feedback

Expands the node in this TreeListViewItemControl when possible.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


GetIsExpanderVisible Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.GetIsExpanderVisible Method
TreeListViewItemControl Class See Also Send Feedback

Gets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static bool GetIsExpanderVisible(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetIsExpanderVisible ( _
    element As DependencyObject _
) As Boolean

Parameters

element
Type: System.Windows..::.DependencyObject

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.HitTestCore Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.OnApplyTemplate Method
TreeListViewItemControl Class See Also Send Feedback

Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


OnIsExpanderVisibleChanged Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.OnIsExpanderVisibleChanged Method
TreeListViewItemControl Class See Also Send Feedback

Called when the IsExpanderVisible property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsExpanderVisibleChanged(
    bool oldIsExpanderVisible,
    bool newIsExpanderVisible
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsExpanderVisibleChanged ( _
    oldIsExpanderVisible As Boolean, _
    newIsExpanderVisible As Boolean _
)

Parameters

oldIsExpanderVisible
Type: System..::.Boolean
newIsExpanderVisible
Type: System..::.Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


OnIsNodeExpansionReadOnlyChanged Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.OnIsNodeExpansionReadOnlyChanged Method
TreeListViewItemControl Class See Also Send Feedback

Called when the IsNodeExpansionReadOnly property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnIsNodeExpansionReadOnlyChanged(
    bool oldIsNodeExpansionReadOnly,
    bool newIsNodeExpansionReadOnly
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsNodeExpansionReadOnlyChanged ( _
    oldIsNodeExpansionReadOnly As Boolean, _
    newIsNodeExpansionReadOnly As Boolean _
)

Parameters

oldIsNodeExpansionReadOnly
Type: System..::.Boolean
newIsNodeExpansionReadOnly
Type: System..::.Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


OnNodeChanged Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.OnNodeChanged Method
TreeListViewItemControl Class See Also Send Feedback

Called when the Node property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnNodeChanged(
    Node oldNode,
    Node newNode
)
Visual Basic (Declaration)
Protected Overridable Sub OnNodeChanged ( _
    oldNode As Node, _
    newNode As Node _
)

Parameters

oldNode
Type: DlhSoft.Windows.Data..::.Node
newNode
Type: DlhSoft.Windows.Data..::.Node

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


OnNodeContentTemplateChanged Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.OnNodeContentTemplateChanged Method
TreeListViewItemControl Class See Also Send Feedback

Called when the NodeContentTemplate property changes.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
protected virtual void OnNodeContentTemplateChanged(
    DataTemplate oldNodeContentTemplate,
    DataTemplate newNodeContentTemplate
)
Visual Basic (Declaration)
Protected Overridable Sub OnNodeContentTemplateChanged ( _
    oldNodeContentTemplate As DataTemplate, _
    newNodeContentTemplate As DataTemplate _
)

Parameters

oldNodeContentTemplate
Type: System.Windows..::.DataTemplate
newNodeContentTemplate
Type: System.Windows..::.DataTemplate

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.SetBinding Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


SetIsExpanderVisible Method

[image]

.NET Framework Class Library
TreeListViewItemControl..::.SetIsExpanderVisible Method
TreeListViewItemControl Class See Also Send Feedback

Sets a value indicating whether node expansion toggle button is enabled for a specified element such as a node item within TreeListViewItemControl.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public static void SetIsExpanderVisible(
    DependencyObject element,
    bool isExpanderVisible
)
Visual Basic (Declaration)
Public Shared Sub SetIsExpanderVisible ( _
    element As DependencyObject, _
    isExpanderVisible As Boolean _
)

Parameters

element
Type: System.Windows..::.DependencyObject
isExpanderVisible
Type: System..::.Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.SetValue Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
TreeListViewItemControl..::.TransformToAncestor Method
TreeListViewItemControl Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

TreeListViewItemControl Class
TreeListViewItemControl Members
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Properties

[image] [image]

.NET Framework Class Library
TreeListViewItemControl Properties
TreeListViewItemControl Class See Also Send Feedback

The TreeListViewItemControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CanCollapse | Gets a value indicating whether the node in this TreeListViewItemControl can be collapseed.
CanExpand | Gets a value indicating whether the node in this TreeListViewItemControl can be expanded.
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsExpanderVisible | Gets or sets a value indicating whether the expansion toggle button is visible within this TreeListViewItemControl. This is a dependency property.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsNodeExpansionReadOnly | Gets or sets a value indicating whether the node expansion state is read-only in the TreeListViewItemControl control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LogicalChildren | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Node | Gets or sets the node to be presented by this control. This is a dependency property.
NodeContentTemplate | Gets or sets the data template to be used to display the specified node. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


CanCollapse Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.CanCollapse Property
TreeListViewItemControl Class See Also Send Feedback

Gets a value indicating whether the node in this TreeListViewItemControl can be collapseed.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapse { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapse As Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


CanExpand Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.CanExpand Property
TreeListViewItemControl Class See Also Send Feedback

Gets a value indicating whether the node in this TreeListViewItemControl can be expanded.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpand { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpand As Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


IsExpanderVisible Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.IsExpanderVisible Property
TreeListViewItemControl Class See Also Send Feedback

Gets or sets a value indicating whether the expansion toggle button is visible within this TreeListViewItemControl. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpanderVisible { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpanderVisible As Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


IsNodeExpansionReadOnly Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.IsNodeExpansionReadOnly Property
TreeListViewItemControl Class See Also Send Feedback

Gets or sets a value indicating whether the node expansion state is read-only in the TreeListViewItemControl control so that the user cannot update it using the keyboard or mouse or by executing specific commands. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsNodeExpansionReadOnly { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsNodeExpansionReadOnly As Boolean

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


Node Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.Node Property
TreeListViewItemControl Class See Also Send Feedback

Gets or sets the node to be presented by this control. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Node Node { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Node As Node

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


NodeContentTemplate Property

[image]

.NET Framework Class Library
TreeListViewItemControl..::.NodeContentTemplate Property
TreeListViewItemControl Class See Also Send Feedback

Gets or sets the data template to be used to display the specified node. This is a dependency property.

Namespace: DlhSoft.Windows.Controls
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public DataTemplate NodeContentTemplate { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property NodeContentTemplate As DataTemplate

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


TreeListViewItemControl Events

[image] [image]

.NET Framework Class Library
TreeListViewItemControl Events
TreeListViewItemControl Class See Also Send Feedback

The TreeListViewItemControl type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

TreeListViewItemControl Class
DlhSoft.Windows.Controls Namespace


DlhSoft.Windows.Controls.Primitives Namespace

[image]

.NET Framework Class Library
DlhSoft.Windows.Controls.Primitives Namespace
Send Feedback

Classes

Class | Description
ContentControlBase | Represents the base of a control that can be used to present an item.
ItemCollection | Holds the list of items that constitute the content of an items control.
ItemsControlBase | Represents the base of a control that can be used to present a collection of items.
Selector | Represents a control that can be used to select items from among its child elements. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.


ContentControlBase Class

[image]

.NET Framework Class Library
ContentControlBase Class
Members See Also Send Feedback

Represents the base of a control that can be used to present an item.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[ContentPropertyAttribute("Content")]
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public class ContentControlBase : Control,
    IAddChild
Visual Basic (Declaration)
<ContentPropertyAttribute("Content")> _
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public Class ContentControlBase _
    Inherits Control _
    Implements IAddChild

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ContentControlBase
DlhSoft.Windows.Controls..::.ContentControl

See Also

ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Members

[image] [image]

.NET Framework Class Library
ContentControlBase Members
ContentControlBase Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ContentControlBase type exposes the following members.

Constructors

Name | Description
ContentControlBase | Initializes a new instance of the ContentControlBase class.

Methods

Name | Description
AddChild | Adds a child object.
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object.
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginInternalInitialization | Signals the start of an internal initialization operation.
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.
EndInit | (Inherited from FrameworkElement.)
EndInternalInitialization | Signals the end of an internal initialization operation.
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties.
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes.
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes.
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Overrides Control..::.ToString()()().)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
ContentProperty | Identifies the Content dependency property.
EntityManagerProperty | Identifies the EntityManager dependency property.
EntityManagerSourceProperty | Identifies the EntityManagerSource dependency property.
HasContentProperty | Identifies the HasContent dependency property.
IsAsyncPresentationEnabledProperty | Identifies the IsAsyncPresentationEnabled dependency property.
IsLoadingEntityProperty | Identifies the IsLoadingEntity dependency property.
LoadedEntityProperty | Identifies the LoadedEntity dependency property.
ManagedEntityProperty | Identifies the ManagedEntity dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property.
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase.
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property.
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property.
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property.
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available.
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property.
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property.
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Constructor

[image]

.NET Framework Class Library
ContentControlBase Constructor
ContentControlBase Class See Also Send Feedback

Initializes a new instance of the ContentControlBase class.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ContentControlBase()
Visual Basic (Declaration)
Public Sub New

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Fields

[image] [image]

.NET Framework Class Library
ContentControlBase Fields
ContentControlBase Class See Also Send Feedback

The ContentControlBase type exposes the following members.

Fields

Name | Description
ContentProperty | Identifies the Content dependency property.
EntityManagerProperty | Identifies the EntityManager dependency property.
EntityManagerSourceProperty | Identifies the EntityManagerSource dependency property.
HasContentProperty | Identifies the HasContent dependency property.
IsAsyncPresentationEnabledProperty | Identifies the IsAsyncPresentationEnabled dependency property.
IsLoadingEntityProperty | Identifies the IsLoadingEntity dependency property.
LoadedEntityProperty | Identifies the LoadedEntity dependency property.
ManagedEntityProperty | Identifies the ManagedEntity dependency property.

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.ContentProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the Content dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.EntityManagerProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the EntityManager dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty EntityManagerProperty
Visual Basic (Declaration)
Public Shared ReadOnly EntityManagerProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerSourceProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.EntityManagerSourceProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the EntityManagerSource dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty EntityManagerSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly EntityManagerSourceProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HasContentProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.HasContentProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the HasContent dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty HasContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HasContentProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.IsAsyncPresentationEnabledProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the IsAsyncPresentationEnabled dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsAsyncPresentationEnabledProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsAsyncPresentationEnabledProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsLoadingEntityProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.IsLoadingEntityProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the IsLoadingEntity dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsLoadingEntityProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsLoadingEntityProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntityProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.LoadedEntityProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the LoadedEntity dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty LoadedEntityProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadedEntityProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ManagedEntityProperty Field

[image]

.NET Framework Class Library
ContentControlBase..::.ManagedEntityProperty Field
ContentControlBase Class See Also Send Feedback

Identifies the ManagedEntity dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ManagedEntityProperty
Visual Basic (Declaration)
Public Shared ReadOnly ManagedEntityProperty As DependencyProperty

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Methods

[image] [image]

.NET Framework Class Library
ContentControlBase Methods
ContentControlBase Class See Also Send Feedback

The ContentControlBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object.
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object.
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginInternalInitialization | Signals the start of an internal initialization operation.
BeginStoryboard | Overloaded.
BindContent | Binds the ContentControl host using the LoadedEntity.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.
EndInit | (Inherited from FrameworkElement.)
EndInternalInitialization | Signals the end of an internal initialization operation.
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntity | Prepares the entity item to be presented by the control based on the current content and data binding properties.
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveFocus | (Inherited from FrameworkElement.)
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContentChanged | Called when the Content property changes.
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes.
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ContentControlBase object. (Overrides Control..::.ToString()()().)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


AddChild Method

[image]

.NET Framework Class Library
ContentControlBase..::.AddChild Method
ContentControlBase Class See Also Send Feedback

Adds a child object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public virtual void AddChild(
    Object value
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    value As Object _
)

Parameters

value
Type: System..::.Object
The child object to add.

Implements

IAddChild..::.AddChild(Object)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.AddHandler Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


AddText Method

[image]

.NET Framework Class Library
ContentControlBase..::.AddText Method
ContentControlBase Class See Also Send Feedback

Adds a text child object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public virtual void AddText(
    string text
)
Visual Basic (Declaration)
Public Overridable Sub AddText ( _
    text As String _
)

Parameters

text
Type: System..::.String
The child object to add.

Implements

IAddChild..::.AddText(String)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.ApplyAnimationClock Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.BeginAnimation Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginInternalInitialization Method

[image]

.NET Framework Class Library
ContentControlBase..::.BeginInternalInitialization Method
ContentControlBase Class See Also Send Feedback

Signals the start of an internal initialization operation.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal static bool BeginInternalInitialization()
Visual Basic (Declaration)
Protected Friend Shared Function BeginInternalInitialization As Boolean

Return Value

The previous initialization state, to be passed later to the EndInternalInitialization method.

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.BeginStoryboard Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BindContent Method

[image]

.NET Framework Class Library
ContentControlBase..::.BindContent Method
ContentControlBase Class See Also Send Feedback

Binds the ContentControl host using the LoadedEntity.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void BindContent()
Visual Basic (Declaration)
Protected Friend Overridable Sub BindContent

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.BringIntoView Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ClearTemplateParts Method

[image]

.NET Framework Class Library
ContentControlBase..::.ClearTemplateParts Method
ContentControlBase Class See Also Send Feedback

Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void ClearTemplateParts()
Visual Basic (Declaration)
Protected Friend Overridable Sub ClearTemplateParts

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.ClearValue Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


CreateEntityManager Method

[image]

.NET Framework Class Library
ContentControlBase..::.CreateEntityManager Method
ContentControlBase Class See Also Send Feedback

Establishes the entity manager to be used internally by this ContentControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual EntityManager CreateEntityManager(
    Object item
)
Visual Basic (Declaration)
Protected Overridable Function CreateEntityManager ( _
    item As Object _
) As EntityManager

Parameters

item
Type: System..::.Object
Item to be managed.

Return Value

The entity manager to be used internally by this ContentControlBase.

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EndInternalInitialization Method

[image]

.NET Framework Class Library
ContentControlBase..::.EndInternalInitialization Method
ContentControlBase Class See Also Send Feedback

Signals the end of an internal initialization operation.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal static void EndInternalInitialization(
    bool previousState
)
Visual Basic (Declaration)
Protected Friend Shared Sub EndInternalInitialization ( _
    previousState As Boolean _
)

Parameters

previousState
Type: System..::.Boolean
The previous initialization state, returned before by the BeginInternalInitialization method.

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EnsureEntityManagers Method

[image]

.NET Framework Class Library
ContentControlBase..::.EnsureEntityManagers Method
ContentControlBase Class See Also Send Feedback

Ensures that the appropriate entity managers are initialized and available from within the control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void EnsureEntityManagers()
Visual Basic (Declaration)
Public Sub EnsureEntityManagers

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.HitTestCore Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
ContentControlBase..::.InitializeTemplateParts Method
ContentControlBase Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeTemplateParts

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadEntity Method

[image]

.NET Framework Class Library
ContentControlBase..::.LoadEntity Method
ContentControlBase Class See Also Send Feedback

Prepares the entity item to be presented by the control based on the current content and data binding properties.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void LoadEntity()
Visual Basic (Declaration)
Protected Friend Overridable Sub LoadEntity

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ContentControlBase..::.OnApplyTemplate Method
ContentControlBase Class See Also Send Feedback

When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnContentChanged Method

[image]

.NET Framework Class Library
ContentControlBase..::.OnContentChanged Method
ContentControlBase Class See Also Send Feedback

Called when the Content property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnContentChanged(
    Object oldValue,
    Object newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnContentChanged ( _
    oldValue As Object, _
    newValue As Object _
)

Parameters

oldValue
Type: System..::.Object
newValue
Type: System..::.Object

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnDataPropertyChanged Method

[image]

.NET Framework Class Library
ContentControlBase..::.OnDataPropertyChanged Method
ContentControlBase Class See Also Send Feedback

Signals that a data binding property such as Content is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal void OnDataPropertyChanged()
Visual Basic (Declaration)
Protected Friend Sub OnDataPropertyChanged

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnEntityManagerSourceChanged Method

[image]

.NET Framework Class Library
ContentControlBase..::.OnEntityManagerSourceChanged Method
ContentControlBase Class See Also Send Feedback

Called when the EntityManagerSource property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnEntityManagerSourceChanged(
    EntityManager oldValue,
    EntityManager newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnEntityManagerSourceChanged ( _
    oldValue As EntityManager, _
    newValue As EntityManager _
)

Parameters

oldValue
Type: DlhSoft.Windows.Data..::.EntityManager
newValue
Type: DlhSoft.Windows.Data..::.EntityManager

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnIsAsyncPresentationEnabledChanged Method

[image]

.NET Framework Class Library
ContentControlBase..::.OnIsAsyncPresentationEnabledChanged Method
ContentControlBase Class See Also Send Feedback

Called when the IsAsyncPresentationEnabled property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationEnabledChanged(
    bool oldValue,
    bool newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationEnabledChanged ( _
    oldValue As Boolean, _
    newValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean
newValue
Type: System..::.Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.SetBinding Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.SetValue Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ToString Method

[image]

.NET Framework Class Library
ContentControlBase..::.ToString Method
ContentControlBase Class See Also Send Feedback

Provides a string representation of this ContentControlBase object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The string representation of the object.

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ContentControlBase..::.TransformToAncestor Method
ContentControlBase Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ContentControlBase Class
ContentControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Properties

[image] [image]

.NET Framework Class Library
ContentControlBase Properties
ContentControlBase Class See Also Send Feedback

The ContentControlBase type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
Content | Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property.
ContentControlHost | Gets the ContentControl host template part used internally by this ContentControlBase.
ContextMenu | (Inherited from FrameworkElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property.
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property.
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasContent | Gets a value that indicates whether the ContentControlBase has content. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property.
IsContentControlHostInitialized | Gets a value indicating whether the control is initialized and the ContentControl host is available.
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntity | Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property.
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntity | Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property.
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntity | Gets the entity collection managed by this ContentControlBase. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Content Property

[image]

.NET Framework Class Library
ContentControlBase..::.Content Property
ContentControlBase Class See Also Send Feedback

Gets or sets an item used to generate the content of this ContentControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Content { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Content As Object

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlHost Property

[image]

.NET Framework Class Library
ContentControlBase..::.ContentControlHost Property
ContentControlBase Class See Also Send Feedback

Gets the ContentControl host template part used internally by this ContentControlBase.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal ContentControl ContentControlHost { get; internal set; }
Visual Basic (Declaration)
Protected Friend Property ContentControlHost As ContentControl

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManager Property

[image]

.NET Framework Class Library
ContentControlBase..::.EntityManager Property
ContentControlBase Class See Also Send Feedback

Gets the EntityManager object that is used internally for managing the entity displayed by this ContentControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager EntityManager { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property EntityManager As EntityManager

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerSource Property

[image]

.NET Framework Class Library
ContentControlBase..::.EntityManagerSource Property
ContentControlBase Class See Also Send Feedback

Gets or sets a custom EntityManager object to use internally within this ContentControlBase. When this property is set to an entity manager instance the control content is ignored. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager EntityManagerSource { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property EntityManagerSource As EntityManager

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HasContent Property

[image]

.NET Framework Class Library
ContentControlBase..::.HasContent Property
ContentControlBase Class See Also Send Feedback

Gets a value that indicates whether the ContentControlBase has content. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool HasContent { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public Property HasContent As Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabled Property

[image]

.NET Framework Class Library
ContentControlBase..::.IsAsyncPresentationEnabled Property
ContentControlBase Class See Also Send Feedback

Gets or sets a value indicating whether to load managed entity asynchronously within this ContentControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsAsyncPresentationEnabled { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsAsyncPresentationEnabled As Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsContentControlHostInitialized Property

[image]

.NET Framework Class Library
ContentControlBase..::.IsContentControlHostInitialized Property
ContentControlBase Class See Also Send Feedback

Gets a value indicating whether the control is initialized and the ContentControl host is available.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual bool IsContentControlHostInitialized { get; }
Visual Basic (Declaration)
Protected Friend Overridable ReadOnly Property IsContentControlHostInitialized As Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsEntityManagerInternal Property

[image]

.NET Framework Class Library
ContentControlBase..::.IsEntityManagerInternal Property
ContentControlBase Class See Also Send Feedback

Gets a value that indicates whether the current EntityManager is internal.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected bool IsEntityManagerInternal { get; }
Visual Basic (Declaration)
Protected ReadOnly Property IsEntityManagerInternal As Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsLoadingEntity Property

[image]

.NET Framework Class Library
ContentControlBase..::.IsLoadingEntity Property
ContentControlBase Class See Also Send Feedback

Gets a value indicating whether the control is currently loading entity (asynchronously). This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsLoadingEntity { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsLoadingEntity As Boolean

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntity Property

[image]

.NET Framework Class Library
ContentControlBase..::.LoadedEntity Property
ContentControlBase Class See Also Send Feedback

Gets the entities that are currently loaded within this ContentControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Object LoadedEntity { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property LoadedEntity As Object

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ManagedEntity Property

[image]

.NET Framework Class Library
ContentControlBase..::.ManagedEntity Property
ContentControlBase Class See Also Send Feedback

Gets the entity collection managed by this ContentControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Entity ManagedEntity { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ManagedEntity As Entity

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ContentControlBase Events

[image] [image]

.NET Framework Class Library
ContentControlBase Events
ContentControlBase Class See Also Send Feedback

The ContentControlBase type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ContentControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Class

[image]

.NET Framework Class Library
ItemCollection Class
Members See Also Send Feedback

Holds the list of items that constitute the content of an items control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class ItemCollection : IList,
    INotifyCollectionChanged
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class ItemCollection _
    Implements IList, INotifyCollectionChanged

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Controls.Primitives..::.ItemCollection

See Also

ItemCollection Members
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Members

[image] [image]

.NET Framework Class Library
ItemCollection Members
ItemCollection Class Constructors Methods Properties Events See Also Send Feedback

The ItemCollection type exposes the following members.

Constructors

Name | Description
ItemCollection |

Methods

Name | Description
Add | Adds an item to the ItemCollection.
Clear | Removes all items from the ItemCollection.
Contains | Determines whether the ItemCollection contains a specific value.
CopyTo | Copies the elements of the ItemCollection to an array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the ItemCollection.
Insert | Inserts an item to the ItemCollection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event.
Remove | Removes the first occurrence of a specific object from the ItemCollection.
RemoveAt | Removes the ItemCollection item at the specified index.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ItemCollection.
IsFixedSize | Gets a value indicating whether the ItemCollection has a fixed size.
IsReadOnly | Gets a value indicating whether the ItemCollection is read-only.
IsSynchronized | Gets a value indicating whether access to the ItemCollection is synchronized (thread safe).
Item | Gets or sets the element at the specified index.
SyncRoot | Gets an object that can be used to syncrhonize access to the ItemCollection.

Events

Name | Description
CollectionChanged | Occurs when the collection changes.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Constructor

[image]

.NET Framework Class Library
ItemCollection Constructor
ItemCollection Class See Also Send Feedback

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ItemCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Methods

[image] [image]

.NET Framework Class Library
ItemCollection Methods
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ItemCollection.
Clear | Removes all items from the ItemCollection.
Contains | Determines whether the ItemCollection contains a specific value.
CopyTo | Copies the elements of the ItemCollection to an array, starting at a particular array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index of a specific item in the ItemCollection.
Insert | Inserts an item to the ItemCollection at the specified index.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event.
Remove | Removes the first occurrence of a specific object from the ItemCollection.
RemoveAt | Removes the ItemCollection item at the specified index.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Add Method

[image]

.NET Framework Class Library
ItemCollection..::.Add Method
ItemCollection Class See Also Send Feedback

Adds an item to the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public int Add(
    Object item
)
Visual Basic (Declaration)
Public Function Add ( _
    item As Object _
) As Integer

Parameters

item
Type: System..::.Object
The object to add to the ItemCollection.

Return Value

The position into which the new element was inserted.

Implements

IList..::.Add(Object)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Clear Method

[image]

.NET Framework Class Library
ItemCollection..::.Clear Method
ItemCollection Class See Also Send Feedback

Removes all items from the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

Implements

IList..::.Clear()()()

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Contains Method

[image]

.NET Framework Class Library
ItemCollection..::.Contains Method
ItemCollection Class See Also Send Feedback

Determines whether the ItemCollection contains a specific value.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public bool Contains(
    Object item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to locate in the ItemCollection

Return Value

True if item is found in the ItemCollection; otherwise, false.

Implements

IList..::.Contains(Object)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


CopyTo Method

[image]

.NET Framework Class Library
ItemCollection..::.CopyTo Method
ItemCollection Class See Also Send Feedback

Copies the elements of the ItemCollection to an array, starting at a particular array index.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)

Parameters

array
Type: System..::.Array
The one-dimensional array that is the destination of the elements copied from ItemCollection. The array must have zero-based indexing.
index
Type: System..::.Int32
The zero-based index in array at which copying begins.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
ItemCollection..::.GetEnumerator Method
ItemCollection Class See Also Send Feedback

Returns an enumerator that iterates through a collection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator

Return Value

An enumerator object that can be used to iterate through the collection.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


IndexOf Method

[image]

.NET Framework Class Library
ItemCollection..::.IndexOf Method
ItemCollection Class See Also Send Feedback

Determines the index of a specific item in the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public int IndexOf(
    Object item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Object _
) As Integer

Parameters

item
Type: System..::.Object
The object to locate in the ItemCollection.

Return Value

The index of value if found in the list; otherwise, -1.

Implements

IList..::.IndexOf(Object)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Insert Method

[image]

.NET Framework Class Library
ItemCollection..::.Insert Method
ItemCollection Class See Also Send Feedback

Inserts an item to the ItemCollection at the specified index.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void Insert(
    int index,
    Object item
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    item As Object _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value should be inserted.
item
Type: System..::.Object
The object to insert into the ItemCollection.

Implements

IList..::.Insert(Int32, Object)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
ItemCollection..::.OnCollectionChanged Method
ItemCollection Class See Also Send Feedback

Raises the CollectionChanged event.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
Event arguments.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Remove Method

[image]

.NET Framework Class Library
ItemCollection..::.Remove Method
ItemCollection Class See Also Send Feedback

Removes the first occurrence of a specific object from the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void Remove(
    Object item
)
Visual Basic (Declaration)
Public Sub Remove ( _
    item As Object _
)

Parameters

item
Type: System..::.Object
The object to remove from the ItemCollection.

Implements

IList..::.Remove(Object)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


RemoveAt Method

[image]

.NET Framework Class Library
ItemCollection..::.RemoveAt Method
ItemCollection Class See Also Send Feedback

Removes the ItemCollection item at the specified index.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the item to remove.

Implements

IList..::.RemoveAt(Int32)

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Properties

[image] [image]

.NET Framework Class Library
ItemCollection Properties
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ItemCollection.
IsFixedSize | Gets a value indicating whether the ItemCollection has a fixed size.
IsReadOnly | Gets a value indicating whether the ItemCollection is read-only.
IsSynchronized | Gets a value indicating whether access to the ItemCollection is synchronized (thread safe).
Item | Gets or sets the element at the specified index.
SyncRoot | Gets an object that can be used to syncrhonize access to the ItemCollection.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Count Property

[image]

.NET Framework Class Library
ItemCollection..::.Count Property
ItemCollection Class See Also Send Feedback

Gets the number of elements contained in the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


IsFixedSize Property

[image]

.NET Framework Class Library
ItemCollection..::.IsFixedSize Property
ItemCollection Class See Also Send Feedback

Gets a value indicating whether the ItemCollection has a fixed size.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean

Implements

IList..::.IsFixedSize

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
ItemCollection..::.IsReadOnly Property
ItemCollection Class See Also Send Feedback

Gets a value indicating whether the ItemCollection is read-only.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean

Implements

IList..::.IsReadOnly

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


IsSynchronized Property

[image]

.NET Framework Class Library
ItemCollection..::.IsSynchronized Property
ItemCollection Class See Also Send Feedback

Gets a value indicating whether access to the ItemCollection is synchronized (thread safe).

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


Item Property

[image]

.NET Framework Class Library
ItemCollection..::.Item Property
ItemCollection Class See Also Send Feedback

Gets or sets the element at the specified index.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Property Item ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32
The zero-based index of the element to get or set.

Return Value

The element at the specified index.

Implements

IList..::.Item[([(Int32])])

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


SyncRoot Property

[image]

.NET Framework Class Library
ItemCollection..::.SyncRoot Property
ItemCollection Class See Also Send Feedback

Gets an object that can be used to syncrhonize access to the ItemCollection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemCollection Events

[image] [image]

.NET Framework Class Library
ItemCollection Events
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs when the collection changes.

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


CollectionChanged Event

[image]

.NET Framework Class Library
ItemCollection..::.CollectionChanged Event
ItemCollection Class See Also Send Feedback

Occurs when the collection changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Implements

INotifyCollectionChanged..::.CollectionChanged

See Also

ItemCollection Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Class

[image]

.NET Framework Class Library
ItemsControlBase Class
Members See Also Send Feedback

Represents the base of a control that can be used to present a collection of items.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[ContentPropertyAttribute("Items")]
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public class ItemsControlBase : Control,
    IAddChild
Visual Basic (Declaration)
<ContentPropertyAttribute("Items")> _
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public Class ItemsControlBase _
    Inherits Control _
    Implements IAddChild

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl

See Also

ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Members

[image] [image]

.NET Framework Class Library
ItemsControlBase Members
ItemsControlBase Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ItemsControlBase type exposes the following members.

Constructors

Name | Description
ItemsControlBase | Initializes a new instance of the ItemsControlBase class.

Methods

Name | Description
AddChild | Adds a child object.
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object.
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginInternalInitialization | Signals the start of an internal initialization operation.
BeginStoryboard | Overloaded.
BindItems | Binds the ItemsControl host using the LoadedEntities.
BindItemsSource | Binds the item source collection to the current ItemsSource property.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.
EndInit | (Inherited from FrameworkElement.)
EndInternalInitialization | Signals the end of an internal initialization operation.
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item.
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index.
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties.
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection.
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes.
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event.
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes.
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes.
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemsChanged | Invoked when the Items property changes.
OnItemsSourceChanged | Called when the ItemsSource property changes.
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Overrides Control..::.ToString()()().)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
CountProperty | Identifies the Count dependency property.
EntityManagerProperty | Identifies the EntityManager dependency property.
EntityManagerSourceProperty | Identifies the EntityManagerSource dependency property.
HasItemsProperty | Identifies the HasItems dependency property.
IsAsyncPresentationEnabledMinCountProperty | Identifies the IsAsyncPresentationEnabledMinCount dependency property.
IsAsyncPresentationEnabledPageSizeProperty | Identifies the IsAsyncPresentationEnabledPageSize dependency property.
IsAsyncPresentationEnabledProperty | Identifies the IsAsyncPresentationEnabled dependency property.
IsLoadingEntitiesProperty | Identifies the IsLoadingEntities dependency property.
ItemsSourceProperty | Identifies the ItemsSource dependency property.
LoadedEntitiesProperty | Identifies the LoadedEntities dependency property.
LoadedEntitiesSourceProperty | Identifies the LoadedEntitiesSource dependency property.
ManagedEntitiesProperty | Identifies the ManagedEntities dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property.
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property.
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred.
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property.
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ItemsControl host is available.
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property.
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item.
Items | Gets the collection used to generate the content of this ItemsControlBase.
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase.
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property.
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property.
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property.
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities.
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed.
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Constructor

[image]

.NET Framework Class Library
ItemsControlBase Constructor
ItemsControlBase Class See Also Send Feedback

Initializes a new instance of the ItemsControlBase class.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public ItemsControlBase()
Visual Basic (Declaration)
Public Sub New

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Fields

[image] [image]

.NET Framework Class Library
ItemsControlBase Fields
ItemsControlBase Class See Also Send Feedback

The ItemsControlBase type exposes the following members.

Fields

Name | Description
CountProperty | Identifies the Count dependency property.
EntityManagerProperty | Identifies the EntityManager dependency property.
EntityManagerSourceProperty | Identifies the EntityManagerSource dependency property.
HasItemsProperty | Identifies the HasItems dependency property.
IsAsyncPresentationEnabledMinCountProperty | Identifies the IsAsyncPresentationEnabledMinCount dependency property.
IsAsyncPresentationEnabledPageSizeProperty | Identifies the IsAsyncPresentationEnabledPageSize dependency property.
IsAsyncPresentationEnabledProperty | Identifies the IsAsyncPresentationEnabled dependency property.
IsLoadingEntitiesProperty | Identifies the IsLoadingEntities dependency property.
ItemsSourceProperty | Identifies the ItemsSource dependency property.
LoadedEntitiesProperty | Identifies the LoadedEntities dependency property.
LoadedEntitiesSourceProperty | Identifies the LoadedEntitiesSource dependency property.
ManagedEntitiesProperty | Identifies the ManagedEntities dependency property.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


CountProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.CountProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the Count dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty CountProperty
Visual Basic (Declaration)
Public Shared ReadOnly CountProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.EntityManagerProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the EntityManager dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty EntityManagerProperty
Visual Basic (Declaration)
Public Shared ReadOnly EntityManagerProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerSourceProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.EntityManagerSourceProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the EntityManagerSource dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty EntityManagerSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly EntityManagerSourceProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HasItemsProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.HasItemsProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the HasItems dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty HasItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly HasItemsProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledMinCountProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabledMinCountProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the IsAsyncPresentationEnabledMinCount dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsAsyncPresentationEnabledMinCountProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsAsyncPresentationEnabledMinCountProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledPageSizeProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabledPageSizeProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the IsAsyncPresentationEnabledPageSize dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsAsyncPresentationEnabledPageSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsAsyncPresentationEnabledPageSizeProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabledProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the IsAsyncPresentationEnabled dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsAsyncPresentationEnabledProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsAsyncPresentationEnabledProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsLoadingEntitiesProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.IsLoadingEntitiesProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the IsLoadingEntities dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsLoadingEntitiesProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsLoadingEntitiesProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsSourceProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.ItemsSourceProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the ItemsSource dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntitiesProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.LoadedEntitiesProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the LoadedEntities dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty LoadedEntitiesProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadedEntitiesProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntitiesSourceProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.LoadedEntitiesSourceProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the LoadedEntitiesSource dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty LoadedEntitiesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly LoadedEntitiesSourceProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ManagedEntitiesProperty Field

[image]

.NET Framework Class Library
ItemsControlBase..::.ManagedEntitiesProperty Field
ItemsControlBase Class See Also Send Feedback

Identifies the ManagedEntities dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty ManagedEntitiesProperty
Visual Basic (Declaration)
Public Shared ReadOnly ManagedEntitiesProperty As DependencyProperty

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Methods

[image] [image]

.NET Framework Class Library
ItemsControlBase Methods
ItemsControlBase Class See Also Send Feedback

The ItemsControlBase type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object.
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object.
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginInternalInitialization | Signals the start of an internal initialization operation.
BeginStoryboard | Overloaded.
BindItems | Binds the ItemsControl host using the LoadedEntities.
BindItemsSource | Binds the item source collection to the current ItemsSource property.
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.
EndInit | (Inherited from FrameworkElement.)
EndInternalInitialization | Signals the end of an internal initialization operation.
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item.
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index.
GetHashCode | (Inherited from DependencyObject.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties.
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection.
OnAccessKey | (Inherited from UIElement.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes.
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event.
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes.
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes.
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes.
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemsChanged | Invoked when the Items property changes.
OnItemsSourceChanged | Called when the ItemsSource property changes.
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Overrides Control..::.ToString()()().)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


AddChild Method

[image]

.NET Framework Class Library
ItemsControlBase..::.AddChild Method
ItemsControlBase Class See Also Send Feedback

Adds a child object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public virtual void AddChild(
    Object value
)
Visual Basic (Declaration)
Public Overridable Sub AddChild ( _
    value As Object _
)

Parameters

value
Type: System..::.Object
The child object to add.

Implements

IAddChild..::.AddChild(Object)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.AddHandler Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


AddText Method

[image]

.NET Framework Class Library
ItemsControlBase..::.AddText Method
ItemsControlBase Class See Also Send Feedback

Adds a text child object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public virtual void AddText(
    string text
)
Visual Basic (Declaration)
Public Overridable Sub AddText ( _
    text As String _
)

Parameters

text
Type: System..::.String
The child object to add.

Implements

IAddChild..::.AddText(String)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.ApplyAnimationClock Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.BeginAnimation Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginInternalInitialization Method

[image]

.NET Framework Class Library
ItemsControlBase..::.BeginInternalInitialization Method
ItemsControlBase Class See Also Send Feedback

Signals the start of an internal initialization operation.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal static bool BeginInternalInitialization()
Visual Basic (Declaration)
Protected Friend Shared Function BeginInternalInitialization As Boolean

Return Value

The previous initialization state, to be passed later to the EndInternalInitialization method.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.BeginStoryboard Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


BindItems Method

[image]

.NET Framework Class Library
ItemsControlBase..::.BindItems Method
ItemsControlBase Class See Also Send Feedback

Binds the ItemsControl host using the LoadedEntities.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void BindItems()
Visual Basic (Declaration)
Protected Friend Overridable Sub BindItems

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


BindItemsSource Method

[image]

.NET Framework Class Library
ItemsControlBase..::.BindItemsSource Method
ItemsControlBase Class See Also Send Feedback

Binds the item source collection to the current ItemsSource property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void BindItemsSource()
Visual Basic (Declaration)
Protected Friend Overridable Sub BindItemsSource

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.BringIntoView Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ClearTemplateParts Method

[image]

.NET Framework Class Library
ItemsControlBase..::.ClearTemplateParts Method
ItemsControlBase Class See Also Send Feedback

Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void ClearTemplateParts()
Visual Basic (Declaration)
Protected Friend Overridable Sub ClearTemplateParts

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.ClearValue Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


CreateEntityManager Method

[image]

.NET Framework Class Library
ItemsControlBase..::.CreateEntityManager Method
ItemsControlBase Class See Also Send Feedback

Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual EntityManager CreateEntityManager(
    IEnumerable items
)
Visual Basic (Declaration)
Protected Overridable Function CreateEntityManager ( _
    items As IEnumerable _
) As EntityManager

Parameters

items
Type: System.Collections..::.IEnumerable
Item collection to be managed.

Return Value

The entity manager to be used internally by this ItemsControlBase.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EndInternalInitialization Method

[image]

.NET Framework Class Library
ItemsControlBase..::.EndInternalInitialization Method
ItemsControlBase Class See Also Send Feedback

Signals the end of an internal initialization operation.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal static void EndInternalInitialization(
    bool previousState
)
Visual Basic (Declaration)
Protected Friend Shared Sub EndInternalInitialization ( _
    previousState As Boolean _
)

Parameters

previousState
Type: System..::.Boolean
The previous initialization state, returned before by the BeginInternalInitialization method.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EnsureEntityManagers Method

[image]

.NET Framework Class Library
ItemsControlBase..::.EnsureEntityManagers Method
ItemsControlBase Class See Also Send Feedback

Ensures that the appropriate entity managers are initialized and available from within the control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void EnsureEntityManagers()
Visual Basic (Declaration)
Public Sub EnsureEntityManagers

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


GetEntity Method

[image]

.NET Framework Class Library
ItemsControlBase..::.GetEntity Method
ItemsControlBase Class See Also Send Feedback

Gets the entity in the ItemsControlBase that wraps the specified item.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Entity GetEntity(
    Object item
)
Visual Basic (Declaration)
Public Function GetEntity ( _
    item As Object _
) As Entity

Parameters

item
Type: System..::.Object
The item to get the entity for.

Return Value

The entity in the collection that wraps the specified item.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


GetEntityAt Method

[image]

.NET Framework Class Library
ItemsControlBase..::.GetEntityAt Method
ItemsControlBase Class See Also Send Feedback

Gets the entity in the ItemsControlBase at the specified index.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Entity GetEntityAt(
    int index
)
Visual Basic (Declaration)
Public Function GetEntityAt ( _
    index As Integer _
) As Entity

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to be get.

Return Value

The entity in the collection at the specified index.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.HitTestCore Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
ItemsControlBase..::.InitializeTemplateParts Method
ItemsControlBase Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overridable Sub InitializeTemplateParts

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadEntities Method

[image]

.NET Framework Class Library
ItemsControlBase..::.LoadEntities Method
ItemsControlBase Class See Also Send Feedback

Prepares the entity items to be presented by the control based on the current items and data binding properties.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void LoadEntities()
Visual Basic (Declaration)
Protected Friend Overridable Sub LoadEntities

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Move Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.Move Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection.
Move(Object, Int32) | Moves an item to a new index in the managed collection.

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


Move Method (Int32, Int32)

[image]

.NET Framework Class Library
ItemsControlBase..::.Move Method (Int32, Int32)
ItemsControlBase Class See Also Send Feedback

Moves an item to a new index in the managed collection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void Move(
    int fromIndex,
    int toIndex
)
Visual Basic (Declaration)
Public Sub Move ( _
    fromIndex As Integer, _
    toIndex As Integer _
)

Parameters

fromIndex
Type: System..::.Int32
The index to move the item from.
toIndex
Type: System..::.Int32
The index to move the item to.

See Also

ItemsControlBase Class
Move Overload
DlhSoft.Windows.Controls.Primitives Namespace


Move Method (Object, Int32)

[image]

.NET Framework Class Library
ItemsControlBase..::.Move Method (Object, Int32)
ItemsControlBase Class See Also Send Feedback

Moves an item to a new index in the managed collection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void Move(
    Object item,
    int toIndex
)
Visual Basic (Declaration)
Public Sub Move ( _
    item As Object, _
    toIndex As Integer _
)

Parameters

item
Type: System..::.Object
The item to move.
toIndex
Type: System..::.Int32
The index to move the item to.

See Also

ItemsControlBase Class
Move Overload
DlhSoft.Windows.Controls.Primitives Namespace


MoveRange Method

[image]

.NET Framework Class Library
ItemsControlBase..::.MoveRange Method
ItemsControlBase Class See Also Send Feedback

Moves a range of items to a new index in the managed collection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public void MoveRange(
    int fromIndex,
    int count,
    int toIndex
)
Visual Basic (Declaration)
Public Sub MoveRange ( _
    fromIndex As Integer, _
    count As Integer, _
    toIndex As Integer _
)

Parameters

fromIndex
Type: System..::.Int32
The index to move the items from.
count
Type: System..::.Int32
The count of items to move.
toIndex
Type: System..::.Int32
The index to move the items to.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnApplyTemplate Method
ItemsControlBase Class See Also Send Feedback

When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnCountChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnCountChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the Count property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnCountChanged(
    int oldCount,
    int newCount
)
Visual Basic (Declaration)
Protected Overridable Sub OnCountChanged ( _
    oldCount As Integer, _
    newCount As Integer _
)

Parameters

oldCount
Type: System..::.Int32
newCount
Type: System..::.Int32

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnDataPropertyChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnDataPropertyChanged Method
ItemsControlBase Class See Also Send Feedback

Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal void OnDataPropertyChanged()
Visual Basic (Declaration)
Protected Friend Sub OnDataPropertyChanged

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnEntityManagerSourceChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnEntityManagerSourceChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the EntityManagerSource property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnEntityManagerSourceChanged(
    EntityManager oldValue,
    EntityManager newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnEntityManagerSourceChanged ( _
    oldValue As EntityManager, _
    newValue As EntityManager _
)

Parameters

oldValue
Type: DlhSoft.Windows.Data..::.EntityManager
newValue
Type: DlhSoft.Windows.Data..::.EntityManager

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnIsAsyncPresentationDeferredChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnIsAsyncPresentationDeferredChanged Method
ItemsControlBase Class See Also Send Feedback

Raises the IsAsyncPresentationDeferredChanged event.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationDeferredChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationDeferredChanged

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnIsAsyncPresentationEnabledChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnIsAsyncPresentationEnabledChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the IsAsyncPresentationEnabled property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationEnabledChanged(
    bool oldValue,
    bool newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationEnabledChanged ( _
    oldValue As Boolean, _
    newValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean
newValue
Type: System..::.Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnIsAsyncPresentationEnabledMinCountChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnIsAsyncPresentationEnabledMinCountChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the IsAsyncPresentationEnabledMinCount property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationEnabledMinCountChanged(
    int oldValue,
    int newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationEnabledMinCountChanged ( _
    oldValue As Integer, _
    newValue As Integer _
)

Parameters

oldValue
Type: System..::.Int32
newValue
Type: System..::.Int32

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnIsAsyncPresentationEnabledPageSizeChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnIsAsyncPresentationEnabledPageSizeChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the IsAsyncPresentationEnabledPageSize property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnIsAsyncPresentationEnabledPageSizeChanged(
    int oldValue,
    int newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsAsyncPresentationEnabledPageSizeChanged ( _
    oldValue As Integer, _
    newValue As Integer _
)

Parameters

oldValue
Type: System..::.Int32
newValue
Type: System..::.Int32

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnItemsChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnItemsChanged Method
ItemsControlBase Class See Also Send Feedback

Invoked when the Items property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
Information about the change.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


OnItemsSourceChanged Method

[image]

.NET Framework Class Library
ItemsControlBase..::.OnItemsSourceChanged Method
ItemsControlBase Class See Also Send Feedback

Called when the ItemsSource property changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected virtual void OnItemsSourceChanged(
    IEnumerable oldValue,
    IEnumerable newValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemsSourceChanged ( _
    oldValue As IEnumerable, _
    newValue As IEnumerable _
)

Parameters

oldValue
Type: System.Collections..::.IEnumerable
newValue
Type: System.Collections..::.IEnumerable

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.SetBinding Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.SetValue Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ToString Method

[image]

.NET Framework Class Library
ItemsControlBase..::.ToString Method
ItemsControlBase Class See Also Send Feedback

Provides a string representation of this ItemsControlBase object.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The string representation of the object.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
ItemsControlBase..::.TransformToAncestor Method
ItemsControlBase Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

ItemsControlBase Class
ItemsControlBase Members
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Properties

[image] [image]

.NET Framework Class Library
ItemsControlBase Properties
ItemsControlBase Class See Also Send Feedback

The ItemsControlBase type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property.
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property.
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred.
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property.
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal.
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the ItemsControl host is available.
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property.
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item.
Items | Gets the collection used to generate the content of this ItemsControlBase.
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase.
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property.
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property.
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property.
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities.
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Count Property

[image]

.NET Framework Class Library
ItemsControlBase..::.Count Property
ItemsControlBase Class See Also Send Feedback

Gets the count of entities managed by this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int Count { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Count As Integer

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManager Property

[image]

.NET Framework Class Library
ItemsControlBase..::.EntityManager Property
ItemsControlBase Class See Also Send Feedback

Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager EntityManager { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property EntityManager As EntityManager

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


EntityManagerSource Property

[image]

.NET Framework Class Library
ItemsControlBase..::.EntityManagerSource Property
ItemsControlBase Class See Also Send Feedback

Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager EntityManagerSource { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property EntityManagerSource As EntityManager

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


HasItems Property

[image]

.NET Framework Class Library
ItemsControlBase..::.HasItems Property
ItemsControlBase Class See Also Send Feedback

Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(false)]
public bool HasItems { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public Property HasItems As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationDeferred Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationDeferred Property
ItemsControlBase Class See Also Send Feedback

Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public virtual bool IsAsyncPresentationDeferred { get; protected set; }
Visual Basic (Declaration)
Public Overridable Property IsAsyncPresentationDeferred As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabled Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabled Property
ItemsControlBase Class See Also Send Feedback

Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsAsyncPresentationEnabled { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsAsyncPresentationEnabled As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledMinCount Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabledMinCount Property
ItemsControlBase Class See Also Send Feedback

Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int IsAsyncPresentationEnabledMinCount { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsAsyncPresentationEnabledMinCount As Integer

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationEnabledPageSize Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationEnabledPageSize Property
ItemsControlBase Class See Also Send Feedback

Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int IsAsyncPresentationEnabledPageSize { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsAsyncPresentationEnabledPageSize As Integer

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsEntityManagerInternal Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsEntityManagerInternal Property
ItemsControlBase Class See Also Send Feedback

Gets a value that indicates whether the current EntityManager is internal.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected bool IsEntityManagerInternal { get; }
Visual Basic (Declaration)
Protected ReadOnly Property IsEntityManagerInternal As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsItemsControlHostInitialized Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsItemsControlHostInitialized Property
ItemsControlBase Class See Also Send Feedback

Gets a value indicating whether the control is initialized and the ItemsControl host is available.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual bool IsItemsControlHostInitialized { get; }
Visual Basic (Declaration)
Protected Friend Overridable ReadOnly Property IsItemsControlHostInitialized As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsLoadingEntities Property

[image]

.NET Framework Class Library
ItemsControlBase..::.IsLoadingEntities Property
ItemsControlBase Class See Also Send Feedback

Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsLoadingEntities { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsLoadingEntities As Boolean

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Item Property

[image]

.NET Framework Class Library
ItemsControlBase..::.Item Property
ItemsControlBase Class See Also Send Feedback

Gets the entity in the ItemsControlBase that wraps the specified item.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Entity Item[
    Object item
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    item As Object _
) As Entity

Parameters

item
Type: System..::.Object
The item to get the entity for.

Return Value

The entity in the collection that wraps the specified item.

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Items Property

[image]

.NET Framework Class Library
ItemsControlBase..::.Items Property
ItemsControlBase Class See Also Send Feedback

Gets the collection used to generate the content of this ItemsControlBase.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public ItemCollection Items { get; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public ReadOnly Property Items As ItemCollection

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlHost Property

[image]

.NET Framework Class Library
ItemsControlBase..::.ItemsControlHost Property
ItemsControlBase Class See Also Send Feedback

Gets the ItemsControl host template part used internally by this ItemsControlBase.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal ItemsControl ItemsControlHost { get; internal set; }
Visual Basic (Declaration)
Protected Friend Property ItemsControlHost As ItemsControl

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsSource Property

[image]

.NET Framework Class Library
ItemsControlBase..::.ItemsSource Property
ItemsControlBase Class See Also Send Feedback

Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable ItemsSource { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ItemsSource As IEnumerable

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntities Property

[image]

.NET Framework Class Library
ItemsControlBase..::.LoadedEntities Property
ItemsControlBase Class See Also Send Feedback

Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable LoadedEntities { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property LoadedEntities As IEnumerable

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


LoadedEntitiesSource Property

[image]

.NET Framework Class Library
ItemsControlBase..::.LoadedEntitiesSource Property
ItemsControlBase Class See Also Send Feedback

Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable LoadedEntitiesSource { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property LoadedEntitiesSource As IEnumerable

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ManagedEntities Property

[image]

.NET Framework Class Library
ItemsControlBase..::.ManagedEntities Property
ItemsControlBase Class See Also Send Feedback

Gets the entity collection managed by this ItemsControlBase. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public ReadOnlyEntityCollection ManagedEntities { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ManagedEntities As ReadOnlyEntityCollection

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


VisibilityFilter Property

[image]

.NET Framework Class Library
ItemsControlBase..::.VisibilityFilter Property
ItemsControlBase Class See Also Send Feedback

Gets or sets the visibility filter to apply on the managed entities.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Predicate<Entity> VisibilityFilter { get; set; }
Visual Basic (Declaration)
Public Property VisibilityFilter As Predicate(Of Entity)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


ItemsControlBase Events

[image] [image]

.NET Framework Class Library
ItemsControlBase Events
ItemsControlBase Class See Also Send Feedback

The ItemsControlBase type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed.
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


IsAsyncPresentationDeferredChanged Event

[image]

.NET Framework Class Library
ItemsControlBase..::.IsAsyncPresentationDeferredChanged Event
ItemsControlBase Class See Also Send Feedback

Occurs when IsAsyncPresentationDeferred value is changed.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public event EventHandler IsAsyncPresentationDeferredChanged
Visual Basic (Declaration)
Public Event IsAsyncPresentationDeferredChanged As EventHandler

See Also

ItemsControlBase Class
DlhSoft.Windows.Controls.Primitives Namespace


Selector Class

[image]

.NET Framework Class Library
Selector Class
Members See Also Send Feedback

Represents a control that can be used to select items from among its child elements. Use Items property to add entity data items to an ItemCollection managed by the control, or set ItemsSource to your own entity data item collection. Alternatively you can set the EntityManagerSource to a customized entity manager to use and to ignore the items collection.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public abstract class Selector : ItemsControl
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public MustInherit Class Selector _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
DlhSoft.Windows.Controls.Primitives..::.ItemsControlBase
DlhSoft.Windows.Controls..::.ItemsControl
DlhSoft.Windows.Controls.Primitives..::.Selector
DlhSoft.Windows.Controls..::.ListBox

See Also

Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


Selector Members

[image] [image]

.NET Framework Class Library
Selector Members
Selector Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The Selector type exposes the following members.

Constructors

Name | Description
Selector | Initializes a new instance of the Selector class.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the Selector host using the LoadedEntities. (Overrides ItemsControlBase..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Overrides ItemsControlBase..::.BindItemsSource()()().)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Overrides ItemsControlBase..::.ClearTemplateParts()()().)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ItemsControl..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ItemsControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Called when the selection changes.
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the selector host based on the current property values of this Selector. (Overrides ItemsControl..::.ResetItemsControlHost()()().)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty | Identifies the IsSynchronizedWithCurrentItem dependency property.
SelectedEntityProperty | Identifies the SelectedEntity dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
SelectedValueProperty | Identifies the SelectedValue dependency property.
SelectionChangedEvent | Identifies the SelectionChanged routed event.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the selector host is available. (Overrides ItemsControlBase..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property.
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property.
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property.
SelectorHost | Gets the selector host template part used internally by this Selector.
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes.
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


Selector Constructor

[image]

.NET Framework Class Library
Selector Constructor
Selector Class See Also Send Feedback

Initializes a new instance of the Selector class.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Selector()
Visual Basic (Declaration)
Public Sub New

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


Selector Fields

[image] [image]

.NET Framework Class Library
Selector Fields
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty | Identifies the IsSynchronizedWithCurrentItem dependency property.
SelectedEntityProperty | Identifies the SelectedEntity dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
SelectedValueProperty | Identifies the SelectedValue dependency property.
SelectionChangedEvent | Identifies the SelectionChanged routed event.

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


IsSynchronizedWithCurrentItemProperty Field

[image]

.NET Framework Class Library
Selector..::.IsSynchronizedWithCurrentItemProperty Field
Selector Class See Also Send Feedback

Identifies the IsSynchronizedWithCurrentItem dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty IsSynchronizedWithCurrentItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSynchronizedWithCurrentItemProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedEntityProperty Field

[image]

.NET Framework Class Library
Selector..::.SelectedEntityProperty Field
Selector Class See Also Send Feedback

Identifies the SelectedEntity dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedEntityProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedEntityProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedIndexProperty Field

[image]

.NET Framework Class Library
Selector..::.SelectedIndexProperty Field
Selector Class See Also Send Feedback

Identifies the SelectedIndex dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedIndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedItemProperty Field

[image]

.NET Framework Class Library
Selector..::.SelectedItemProperty Field
Selector Class See Also Send Feedback

Identifies the SelectedItem dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedValuePathProperty Field

[image]

.NET Framework Class Library
Selector..::.SelectedValuePathProperty Field
Selector Class See Also Send Feedback

Identifies the SelectedValuePath dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedValuePathProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedValuePathProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedValueProperty Field

[image]

.NET Framework Class Library
Selector..::.SelectedValueProperty Field
Selector Class See Also Send Feedback

Identifies the SelectedValue dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly DependencyProperty SelectedValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedValueProperty As DependencyProperty

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectionChangedEvent Field

[image]

.NET Framework Class Library
Selector..::.SelectionChangedEvent Field
Selector Class See Also Send Feedback

Identifies the SelectionChanged routed event.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public static readonly RoutedEvent SelectionChangedEvent
Visual Basic (Declaration)
Public Shared ReadOnly SelectionChangedEvent As RoutedEvent

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


Selector Methods

[image] [image]

.NET Framework Class Library
Selector Methods
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Methods

Name | Description
AddChild | Adds a child object. (Inherited from ItemsControlBase.)
AddHandler | Overloaded.
AddLogicalChild | (Inherited from FrameworkElement.)
AddText | Adds a text child object. (Inherited from ItemsControlBase.)
AddToEventRoute | (Inherited from UIElement.)
AddVisualChild | (Inherited from Visual.)
ApplyAnimationClock | Overloaded.
ApplyTemplate | (Inherited from FrameworkElement.)
Arrange | (Inherited from UIElement.)
ArrangeCore | (Inherited from FrameworkElement.)
ArrangeOverride | (Inherited from Control.)
BeginAnimation | Overloaded.
BeginInit | (Inherited from FrameworkElement.)
BeginStoryboard | Overloaded.
BindItems | Binds the Selector host using the LoadedEntities. (Overrides ItemsControlBase..::.BindItems()()().)
BindItemsSource | Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed. (Overrides ItemsControlBase..::.BindItemsSource()()().)
BringIntoView | Overloaded.
CaptureMouse | (Inherited from UIElement.)
CaptureStylus | (Inherited from UIElement.)
CaptureTouch | (Inherited from UIElement.)
CheckAccess | (Inherited from DispatcherObject.)
ClearTemplateParts | Invoked before a template is applied to the control to ensure that the old template parts are properly cleared. (Overrides ItemsControlBase..::.ClearTemplateParts()()().)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
CreateEntityManager | Establishes the entity manager to be used internally by this ItemsControlBase. Inheriters should override this method to be able to provide an instance of their own entity manager type. (Inherited from ItemsControlBase.)
EndInit | (Inherited from FrameworkElement.)
EnsureEntityManagers | Ensures that the appropriate entity managers are initialized and available from within the control. (Inherited from ItemsControlBase.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindCommonVisualAncestor | (Inherited from Visual.)
FindName | (Inherited from FrameworkElement.)
FindResource | (Inherited from FrameworkElement.)
Focus | (Inherited from UIElement.)
GetAnimationBaseValue | (Inherited from UIElement.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetEntity | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
GetEntityAt | Gets the entity in the ItemsControlBase at the specified index. (Inherited from ItemsControlBase.)
GetHashCode | (Inherited from DependencyObject.)
GetItemsControlHostItemTemplate | Gets the item template to be used within the ItemsControl host. (Inherited from ItemsControl.)
GetLayoutClip | (Inherited from FrameworkElement.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetTemplateChild | (Inherited from FrameworkElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUIParentCore | (Inherited from FrameworkElement.)
GetValue | (Inherited from DependencyObject.)
GetVisualChild | (Inherited from FrameworkElement.)
HitTestCore | Overloaded.
InitializeItemTemplateDataContext | Initializes the data context of the ContentControl to be used as an item template. (Inherited from ItemsControl.)
InitializeTemplateParts | Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control. (Overrides ItemsControl..::.InitializeTemplateParts()()().)
InputHitTest | (Inherited from UIElement.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
InvalidateProperty | (Inherited from DependencyObject.)
InvalidateVisual | (Inherited from UIElement.)
IsAncestorOf | (Inherited from Visual.)
IsDescendantOf | (Inherited from Visual.)
LoadEntities | Prepares the entity items to be presented by the control based on the current items and data binding properties. (Inherited from ItemsControlBase.)
Measure | (Inherited from UIElement.)
MeasureCore | (Inherited from FrameworkElement.)
MeasureOverride | (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | Overloaded.
MoveFocus | (Inherited from FrameworkElement.)
MoveRange | Moves a range of items to a new index in the managed collection. (Inherited from ItemsControlBase.)
OnAccessKey | (Inherited from UIElement.)
OnAlternationCountChanged | Called when the AlternationCount property changes. (Inherited from ItemsControl.)
OnApplyTemplate | When overriden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from ItemsControl.)
OnChildDesiredSizeChanged | (Inherited from UIElement.)
OnContextMenuClosing | (Inherited from FrameworkElement.)
OnContextMenuOpening | (Inherited from FrameworkElement.)
OnCountChanged | Called when the Count property changes. (Inherited from ItemsControlBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDataPropertyChanged | Signals that a data binding property such as ItemsSource is changed. Inheriters should call this method from the PropertyChanged callbacks of their own data binding properties. (Inherited from ItemsControlBase.)
OnDisplayMemberPathChanged | Called when the DisplayMemberPath property changes. (Inherited from ItemsControl.)
OnDragEnter | (Inherited from UIElement.)
OnDragLeave | (Inherited from UIElement.)
OnDragOver | (Inherited from UIElement.)
OnDrop | (Inherited from UIElement.)
OnEntityManagerSourceChanged | Called when the EntityManagerSource property changes. (Inherited from ItemsControlBase.)
OnGiveFeedback | (Inherited from UIElement.)
OnGotFocus | (Inherited from FrameworkElement.)
OnGotKeyboardFocus | (Inherited from UIElement.)
OnGotMouseCapture | (Inherited from UIElement.)
OnGotStylusCapture | (Inherited from UIElement.)
OnGotTouchCapture | (Inherited from UIElement.)
OnInitialized | (Inherited from FrameworkElement.)
OnIsAsyncPresentationDeferredChanged | Raises the IsAsyncPresentationDeferredChanged event. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledChanged | Called when the IsAsyncPresentationEnabled property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledMinCountChanged | Called when the IsAsyncPresentationEnabledMinCount property changes. (Inherited from ItemsControlBase.)
OnIsAsyncPresentationEnabledPageSizeChanged | Called when the IsAsyncPresentationEnabledPageSize property changes. (Inherited from ItemsControlBase.)
OnIsKeyboardFocusedChanged | (Inherited from UIElement.)
OnIsKeyboardFocusWithinChanged | (Inherited from UIElement.)
OnIsMouseCapturedChanged | (Inherited from UIElement.)
OnIsMouseCaptureWithinChanged | (Inherited from UIElement.)
OnIsMouseDirectlyOverChanged | (Inherited from UIElement.)
OnIsStylusCapturedChanged | (Inherited from UIElement.)
OnIsStylusCaptureWithinChanged | (Inherited from UIElement.)
OnIsStylusDirectlyOverChanged | (Inherited from UIElement.)
OnItemBindingGroupChanged | Called when the ItemBindingGroup property changes. (Inherited from ItemsControl.)
OnItemContainerStyleChanged | Called when the ItemContainerStyle property changes. (Inherited from ItemsControl.)
OnItemContainerStyleSelectorChanged | Called when the ItemContainerStyleSelector property changes. (Inherited from ItemsControl.)
OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControlBase.)
OnItemsPanelChanged | Called when the ItemsPanel property changes. (Inherited from ItemsControl.)
OnItemsSourceChanged | Called when the ItemsSource property changes. (Inherited from ItemsControlBase.)
OnItemStringFormatChanged | Called when the ItemStringFormat property changes. (Inherited from ItemsControl.)
OnItemTemplateChanged | Called when the ItemTemplate property changes. (Inherited from ItemsControl.)
OnItemTemplateSelectorChanged | Called when the ItemTemplateSelector property changes. (Inherited from ItemsControl.)
OnKeyDown | (Inherited from UIElement.)
OnKeyUp | (Inherited from UIElement.)
OnLostFocus | (Inherited from UIElement.)
OnLostKeyboardFocus | (Inherited from UIElement.)
OnLostMouseCapture | (Inherited from UIElement.)
OnLostStylusCapture | (Inherited from UIElement.)
OnLostTouchCapture | (Inherited from UIElement.)
OnManipulationBoundaryFeedback | (Inherited from UIElement.)
OnManipulationCompleted | (Inherited from UIElement.)
OnManipulationDelta | (Inherited from UIElement.)
OnManipulationInertiaStarting | (Inherited from UIElement.)
OnManipulationStarted | (Inherited from UIElement.)
OnManipulationStarting | (Inherited from UIElement.)
OnMouseDoubleClick | (Inherited from Control.)
OnMouseDown | (Inherited from UIElement.)
OnMouseEnter | (Inherited from UIElement.)
OnMouseLeave | (Inherited from UIElement.)
OnMouseLeftButtonDown | (Inherited from UIElement.)
OnMouseLeftButtonUp | (Inherited from UIElement.)
OnMouseMove | (Inherited from UIElement.)
OnMouseRightButtonDown | (Inherited from UIElement.)
OnMouseRightButtonUp | (Inherited from UIElement.)
OnMouseUp | (Inherited from UIElement.)
OnMouseWheel | (Inherited from UIElement.)
OnPreviewDragEnter | (Inherited from UIElement.)
OnPreviewDragLeave | (Inherited from UIElement.)
OnPreviewDragOver | (Inherited from UIElement.)
OnPreviewDrop | (Inherited from UIElement.)
OnPreviewGiveFeedback | (Inherited from UIElement.)
OnPreviewGotKeyboardFocus | (Inherited from UIElement.)
OnPreviewKeyDown | (Inherited from UIElement.)
OnPreviewKeyUp | (Inherited from UIElement.)
OnPreviewLostKeyboardFocus | (Inherited from UIElement.)
OnPreviewMouseDoubleClick | (Inherited from Control.)
OnPreviewMouseDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonDown | (Inherited from UIElement.)
OnPreviewMouseLeftButtonUp | (Inherited from UIElement.)
OnPreviewMouseMove | (Inherited from UIElement.)
OnPreviewMouseRightButtonDown | (Inherited from UIElement.)
OnPreviewMouseRightButtonUp | (Inherited from UIElement.)
OnPreviewMouseUp | (Inherited from UIElement.)
OnPreviewMouseWheel | (Inherited from UIElement.)
OnPreviewQueryContinueDrag | (Inherited from UIElement.)
OnPreviewStylusButtonDown | (Inherited from UIElement.)
OnPreviewStylusButtonUp | (Inherited from UIElement.)
OnPreviewStylusDown | (Inherited from UIElement.)
OnPreviewStylusInAirMove | (Inherited from UIElement.)
OnPreviewStylusInRange | (Inherited from UIElement.)
OnPreviewStylusMove | (Inherited from UIElement.)
OnPreviewStylusOutOfRange | (Inherited from UIElement.)
OnPreviewStylusSystemGesture | (Inherited from UIElement.)
OnPreviewStylusUp | (Inherited from UIElement.)
OnPreviewTextInput | (Inherited from UIElement.)
OnPreviewTouchDown | (Inherited from UIElement.)
OnPreviewTouchMove | (Inherited from UIElement.)
OnPreviewTouchUp | (Inherited from UIElement.)
OnPropertyChanged | (Inherited from FrameworkElement.)
OnQueryContinueDrag | (Inherited from UIElement.)
OnQueryCursor | (Inherited from UIElement.)
OnRender | (Inherited from UIElement.)
OnRenderSizeChanged | (Inherited from FrameworkElement.)
OnSelectionChanged | Called when the selection changes.
OnStyleChanged | (Inherited from FrameworkElement.)
OnStylusButtonDown | (Inherited from UIElement.)
OnStylusButtonUp | (Inherited from UIElement.)
OnStylusDown | (Inherited from UIElement.)
OnStylusEnter | (Inherited from UIElement.)
OnStylusInAirMove | (Inherited from UIElement.)
OnStylusInRange | (Inherited from UIElement.)
OnStylusLeave | (Inherited from UIElement.)
OnStylusMove | (Inherited from UIElement.)
OnStylusOutOfRange | (Inherited from UIElement.)
OnStylusSystemGesture | (Inherited from UIElement.)
OnStylusUp | (Inherited from UIElement.)
OnTemplateChanged | (Inherited from Control.)
OnTextInput | (Inherited from UIElement.)
OnToolTipClosing | (Inherited from FrameworkElement.)
OnToolTipOpening | (Inherited from FrameworkElement.)
OnTouchDown | (Inherited from UIElement.)
OnTouchEnter | (Inherited from UIElement.)
OnTouchLeave | (Inherited from UIElement.)
OnTouchMove | (Inherited from UIElement.)
OnTouchUp | (Inherited from UIElement.)
OnVisualChildrenChanged | (Inherited from Visual.)
OnVisualParentChanged | (Inherited from FrameworkElement.)
ParentLayoutInvalidated | (Inherited from FrameworkElement.)
PointFromScreen | (Inherited from Visual.)
PointToScreen | (Inherited from Visual.)
PredictFocus | (Inherited from FrameworkElement.)
RaiseEvent | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
RegisterName | (Inherited from FrameworkElement.)
ReleaseAllTouchCaptures | (Inherited from UIElement.)
ReleaseMouseCapture | (Inherited from UIElement.)
ReleaseStylusCapture | (Inherited from UIElement.)
ReleaseTouchCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveLogicalChild | (Inherited from FrameworkElement.)
RemoveVisualChild | (Inherited from Visual.)
ResetItemsControlHost | Resets the selector host based on the current property values of this Selector. (Overrides ItemsControl..::.ResetItemsControlHost()()().)
SetBinding | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetResourceReference | (Inherited from FrameworkElement.)
SetValue | Overloaded.
ShouldSerializeCommandBindings | (Inherited from UIElement.)
ShouldSerializeInputBindings | (Inherited from UIElement.)
ShouldSerializeProperty | (Inherited from DependencyObject.)
ShouldSerializeResources | (Inherited from FrameworkElement.)
ShouldSerializeStyle | (Inherited from FrameworkElement.)
ShouldSerializeTriggers | (Inherited from FrameworkElement.)
ToString | Provides a string representation of this ItemsControlBase object. (Inherited from ItemsControlBase.)
TransformToAncestor | Overloaded.
TransformToDescendant | (Inherited from Visual.)
TransformToVisual | (Inherited from Visual.)
TranslatePoint | (Inherited from UIElement.)
TryFindResource | (Inherited from FrameworkElement.)
UnregisterName | (Inherited from FrameworkElement.)
UpdateLayout | (Inherited from UIElement.)
VerifyAccess | (Inherited from DispatcherObject.)

Explicit Interface Implementations

Name | Description
IQueryAmbient..::.IsAmbientPropertyAvailable | (Inherited from FrameworkElement.)

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


AddHandler Method

[image] [image]

.NET Framework Class Library
Selector..::.AddHandler Method
Selector Class See Also Send Feedback

Overload List

Name | Description
AddHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


ApplyAnimationClock Method

[image] [image]

.NET Framework Class Library
Selector..::.ApplyAnimationClock Method
Selector Class See Also Send Feedback

Overload List

Name | Description
ApplyAnimationClock(DependencyProperty, AnimationClock) | (Inherited from UIElement.)
ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | (Inherited from UIElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginAnimation Method

[image] [image]

.NET Framework Class Library
Selector..::.BeginAnimation Method
Selector Class See Also Send Feedback

Overload List

Name | Description
BeginAnimation(DependencyProperty, AnimationTimeline) | (Inherited from UIElement.)
BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | (Inherited from UIElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


BeginStoryboard Method

[image] [image]

.NET Framework Class Library
Selector..::.BeginStoryboard Method
Selector Class See Also Send Feedback

Overload List

Name | Description
BeginStoryboard(Storyboard) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior) | (Inherited from FrameworkElement.)
BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


BindItems Method

[image]

.NET Framework Class Library
Selector..::.BindItems Method
Selector Class See Also Send Feedback

Binds the Selector host using the LoadedEntities.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void BindItems()
Visual Basic (Declaration)
Protected Friend Overrides Sub BindItems

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


BindItemsSource Method

[image]

.NET Framework Class Library
Selector..::.BindItemsSource Method
Selector Class See Also Send Feedback

Binds items source using current data binding properties and initiates synchronizing the selected item with the current item in the collection view if needed.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void BindItemsSource()
Visual Basic (Declaration)
Protected Friend Overrides Sub BindItemsSource

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


BringIntoView Method

[image] [image]

.NET Framework Class Library
Selector..::.BringIntoView Method
Selector Class See Also Send Feedback

Overload List

Name | Description
BringIntoView()()() | (Inherited from FrameworkElement.)
BringIntoView(Rect) | (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


ClearTemplateParts Method

[image]

.NET Framework Class Library
Selector..::.ClearTemplateParts Method
Selector Class See Also Send Feedback

Invoked before a template is applied to the control to ensure that the old template parts are properly cleared.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void ClearTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub ClearTemplateParts

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
Selector..::.ClearValue Method
Selector Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


HitTestCore Method

[image] [image]

.NET Framework Class Library
Selector..::.HitTestCore Method
Selector Class See Also Send Feedback

Overload List

Name | Description
HitTestCore(PointHitTestParameters) | (Inherited from UIElement.)
HitTestCore(GeometryHitTestParameters) | (Inherited from UIElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


InitializeTemplateParts Method

[image]

.NET Framework Class Library
Selector..::.InitializeTemplateParts Method
Selector Class See Also Send Feedback

Invoked when the template is applied to the control to ensure that the required template parts are identified and properly initialized within the control.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void InitializeTemplateParts()
Visual Basic (Declaration)
Protected Friend Overrides Sub InitializeTemplateParts

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


Move Method

[image] [image]

.NET Framework Class Library
Selector..::.Move Method
Selector Class See Also Send Feedback

Overload List

Name | Description
Move(Int32, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)
Move(Object, Int32) | Moves an item to a new index in the managed collection. (Inherited from ItemsControlBase.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


OnSelectionChanged Method

[image]

.NET Framework Class Library
Selector..::.OnSelectionChanged Method
Selector Class See Also Send Feedback

Called when the selection changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal virtual void OnSelectionChanged(
    Object sender,
    SelectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnSelectionChanged ( _
    sender As Object, _
    e As SelectionChangedEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Controls..::.SelectionChangedEventArgs

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


ResetItemsControlHost Method

[image]

.NET Framework Class Library
Selector..::.ResetItemsControlHost Method
Selector Class See Also Send Feedback

Resets the selector host based on the current property values of this Selector.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override void ResetItemsControlHost()
Visual Basic (Declaration)
Protected Friend Overrides Sub ResetItemsControlHost

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SetBinding Method

[image] [image]

.NET Framework Class Library
Selector..::.SetBinding Method
Selector Class See Also Send Feedback

Overload List

Name | Description
SetBinding(DependencyProperty, BindingBase) | (Inherited from FrameworkElement.)
SetBinding(DependencyProperty, String) | (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
Selector..::.SetValue Method
Selector Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


TransformToAncestor Method

[image] [image]

.NET Framework Class Library
Selector..::.TransformToAncestor Method
Selector Class See Also Send Feedback

Overload List

Name | Description
TransformToAncestor(Visual) | (Inherited from Visual.)
TransformToAncestor(Visual3D) | (Inherited from Visual.)

See Also

Selector Class
Selector Members
DlhSoft.Windows.Controls.Primitives Namespace


Selector Properties

[image] [image]

.NET Framework Class Library
Selector Properties
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDrop | (Inherited from UIElement.)
AlternationCount | Gets or sets then number of alternating item containers in the ItemsControl, which enables alternating containers to have a unique appearance. This is a dependency property. (Inherited from ItemsControl.)
AreAnyTouchesCaptured | (Inherited from UIElement.)
AreAnyTouchesCapturedWithin | (Inherited from UIElement.)
AreAnyTouchesDirectlyOver | (Inherited from UIElement.)
AreAnyTouchesOver | (Inherited from UIElement.)
Background | (Inherited from Control.)
BaseItemsControl | Gets the base ItemsControl used as the core for this control. (Inherited from ItemsControl.)
BindingGroup | (Inherited from FrameworkElement.)
BitmapEffect | Obsolete. (Inherited from UIElement.)
BitmapEffectInput | Obsolete. (Inherited from UIElement.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipToBounds | (Inherited from UIElement.)
CommandBindings | (Inherited from UIElement.)
ContextMenu | (Inherited from FrameworkElement.)
Count | Gets the count of entities managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from FrameworkElement.)
DependencyObjectType | (Inherited from DependencyObject.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DispatcherObject.)
DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
EntityManager | Gets the EntityManager object that is used internally for managing entities displayed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
EntityManagerSource | Gets or sets a custom EntityManager object to use internally within this ItemsControlBase. When this property is set to an entity manager instance the control items collection is ignored. This is a dependency property. (Inherited from ItemsControlBase.)
FlowDirection | (Inherited from FrameworkElement.)
Focusable | (Inherited from UIElement.)
FocusVisualStyle | (Inherited from FrameworkElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
ForceCursor | (Inherited from FrameworkElement.)
Foreground | (Inherited from Control.)
HandlesScrolling | (Inherited from Control.)
HasAnimatedProperties | (Inherited from UIElement.)
HasItems | Gets a value that indicates whether the ItemsControlBase contains items. This is a dependency property. (Inherited from ItemsControlBase.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InheritanceBehavior | (Inherited from FrameworkElement.)
InputBindings | (Inherited from UIElement.)
InputScope | (Inherited from FrameworkElement.)
IsArrangeValid | (Inherited from UIElement.)
IsAsyncPresentationDeferred | Gets (or sets, for inheriters) a value indicating whether the asynchrnous data loading is currently deferred. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabled | Gets or sets a value indicating whether to load managed entities asynchronously within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledMinCount | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsAsyncPresentationEnabledPageSize | Gets or sets the initial entity count to load synchronously within this ItemsControlBase before initiating the asynchronous load mode when IsAsyncPresentationEnabled property is set to true. This is a dependency property. (Inherited from ItemsControlBase.)
IsEnabled | (Inherited from UIElement.)
IsEnabledCore | (Inherited from UIElement.)
IsEntityManagerInternal | Gets a value that indicates whether the current EntityManager is internal. (Inherited from ItemsControlBase.)
IsFocused | (Inherited from UIElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsInitialized | (Inherited from FrameworkElement.)
IsInputMethodEnabled | (Inherited from UIElement.)
IsItemsControlHostInitialized | Gets a value indicating whether the control is initialized and the selector host is available. (Overrides ItemsControlBase..::.IsItemsControlHostInitialized.)
IsKeyboardFocused | (Inherited from UIElement.)
IsKeyboardFocusWithin | (Inherited from UIElement.)
IsLoaded | (Inherited from FrameworkElement.)
IsLoadingEntities | Gets a value indicating whether the control is currently loading entities (asynchronously). This is a dependency property. (Inherited from ItemsControlBase.)
IsManipulationEnabled | (Inherited from UIElement.)
IsMeasureValid | (Inherited from UIElement.)
IsMouseCaptured | (Inherited from UIElement.)
IsMouseCaptureWithin | (Inherited from UIElement.)
IsMouseDirectlyOver | (Inherited from UIElement.)
IsMouseOver | (Inherited from UIElement.)
IsSealed | (Inherited from DependencyObject.)
IsStylusCaptured | (Inherited from UIElement.)
IsStylusCaptureWithin | (Inherited from UIElement.)
IsStylusDirectlyOver | (Inherited from UIElement.)
IsStylusOver | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property.
IsTabStop | (Inherited from Control.)
IsTextSearchCaseSensitive | Gets or sets a value that indicates whether case is a condition when searching for items. This is a dependency property. (Inherited from ItemsControl.)
IsTextSearchEnabled | Gets or sets a value that indicates whether TextSearch is enabled on the ItemsControl instance. This is a dependency property. (Inherited from ItemsControl.)
IsVisible | (Inherited from UIElement.)
Item | Gets the entity in the ItemsControlBase that wraps the specified item. (Inherited from ItemsControlBase.)
ItemBindingGroup | Gets or sets the BindingGroup that is used for each item in the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container for element generated for each item. This is a dependency property. (Inherited from ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style selection logic for a style that can be applied to each generated item container element. This is a dependency property. (Inherited from ItemsControl.)
Items | Gets the collection used to generate the content of this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsControlHost | Gets the ItemsControl host template part used internally by this ItemsControlBase. (Inherited from ItemsControlBase.)
ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
ItemsSource | Gets or sets a collection of items used to generate the content of this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
ItemStringFormat | Gets or sets a composite string that specifies how to format the items in the ItemsControl if they are displayed as strings. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplate | Gets or sets the DataTemplate to be used to display each item. This is a dependency property. (Inherited from ItemsControl.)
ItemTemplateSelector | Allows the application writer to provide custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LayoutTransform | (Inherited from FrameworkElement.)
LoadedEntities | Gets the entities that are currently loaded within this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
LoadedEntitiesSource | Gets or sets the overriding source collection for loaded entities that would be displayed in the items control host of the control. This is a dependency property. (Inherited from ItemsControlBase.)
LogicalChildren | (Inherited from FrameworkElement.)
ManagedEntities | Gets the entity collection managed by this ItemsControlBase. This is a dependency property. (Inherited from ItemsControlBase.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverridesDefaultStyle | (Inherited from FrameworkElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PersistId | Obsolete. (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedEntity | Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.
SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.
SelectedValue | Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property.
SelectedValuePath | Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property.
SelectorHost | Gets the selector host template part used internally by this Selector.
SnapsToDevicePixels | (Inherited from UIElement.)
Style | (Inherited from FrameworkElement.)
StylusPlugIns | (Inherited from UIElement.)
TabIndex | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TemplatedParent | (Inherited from FrameworkElement.)
ToolTip | (Inherited from FrameworkElement.)
TouchesCaptured | (Inherited from UIElement.)
TouchesCapturedWithin | (Inherited from UIElement.)
TouchesDirectlyOver | (Inherited from UIElement.)
TouchesOver | (Inherited from UIElement.)
Triggers | (Inherited from FrameworkElement.)
Uid | (Inherited from UIElement.)
UseLayoutRounding | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
VisibilityFilter | Gets or sets the visibility filter to apply on the managed entities. (Inherited from ItemsControlBase.)
VisualBitmapEffect | Obsolete. (Inherited from Visual.)
VisualBitmapEffectInput | Obsolete. (Inherited from Visual.)
VisualBitmapScalingMode | (Inherited from Visual.)
VisualCacheMode | (Inherited from Visual.)
VisualChildrenCount | (Inherited from FrameworkElement.)
VisualClearTypeHint | (Inherited from Visual.)
VisualClip | (Inherited from Visual.)
VisualEdgeMode | (Inherited from Visual.)
VisualEffect | (Inherited from Visual.)
VisualOffset | (Inherited from Visual.)
VisualOpacity | (Inherited from Visual.)
VisualOpacityMask | (Inherited from Visual.)
VisualParent | (Inherited from Visual.)
VisualScrollableAreaClip | (Inherited from Visual.)
VisualTextHintingMode | (Inherited from Visual.)
VisualTextRenderingMode | (Inherited from Visual.)
VisualTransform | (Inherited from Visual.)
VisualXSnappingGuidelines | (Inherited from Visual.)
VisualYSnappingGuidelines | (Inherited from Visual.)
Width | (Inherited from FrameworkElement.)

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


IsItemsControlHostInitialized Property

[image]

.NET Framework Class Library
Selector..::.IsItemsControlHostInitialized Property
Selector Class See Also Send Feedback

Gets a value indicating whether the control is initialized and the selector host is available.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal override bool IsItemsControlHostInitialized { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property IsItemsControlHostInitialized As Boolean

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


IsSynchronizedWithCurrentItem Property

[image]

.NET Framework Class Library
Selector..::.IsSynchronizedWithCurrentItem Property
Selector Class See Also Send Feedback

Gets or sets a value that indicates whether a Selector should keep the SelectedItem synchronized with the current item in the Items property. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(NullableBoolConverter))]
public Nullable<bool> IsSynchronizedWithCurrentItem { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(NullableBoolConverter))> _
Public Property IsSynchronizedWithCurrentItem As Nullable(Of Boolean)

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedEntity Property

[image]

.NET Framework Class Library
Selector..::.SelectedEntity Property
Selector Class See Also Send Feedback

Gets or sets the first entity in the current selection or returns null if the selection is empty. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Entity SelectedEntity { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedEntity As Entity

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedIndex Property

[image]

.NET Framework Class Library
Selector..::.SelectedIndex Property
Selector Class See Also Send Feedback

Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedIndex As Integer

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedItem Property

[image]

.NET Framework Class Library
Selector..::.SelectedItem Property
Selector Class See Also Send Feedback

Gets or sets the first item in the current selection or returns null if the selection is empty. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedItem As Object

Exceptions

Exception | Condition
System..::.InvalidOperationException | The SelectionMode property is set to Single.

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedValue Property

[image]

.NET Framework Class Library
Selector..::.SelectedValue Property
Selector Class See Also Send Feedback

Gets the value of the SelectedItem, obtained by using SelectedValuePath. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public Object SelectedValue { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedValue As Object

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectedValuePath Property

[image]

.NET Framework Class Library
Selector..::.SelectedValuePath Property
Selector Class See Also Send Feedback

Gets or sets a value that indicates the path used to get the SelectedValue from the SelectedItem. This is a dependency property.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[BindableAttribute(true)]
public string SelectedValuePath { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property SelectedValuePath As String

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectorHost Property

[image]

.NET Framework Class Library
Selector..::.SelectorHost Property
Selector Class See Also Send Feedback

Gets the selector host template part used internally by this Selector.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
protected internal Selector SelectorHost { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property SelectorHost As Selector

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


Selector Events

[image] [image]

.NET Framework Class Library
Selector Events
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Events

Name | Description
ContextMenuClosing | (Inherited from FrameworkElement.)
ContextMenuOpening | (Inherited from FrameworkElement.)
DataContextChanged | (Inherited from FrameworkElement.)
DragEnter | (Inherited from UIElement.)
DragLeave | (Inherited from UIElement.)
DragOver | (Inherited from UIElement.)
Drop | (Inherited from UIElement.)
FocusableChanged | (Inherited from UIElement.)
GiveFeedback | (Inherited from UIElement.)
GotFocus | (Inherited from UIElement.)
GotKeyboardFocus | (Inherited from UIElement.)
GotMouseCapture | (Inherited from UIElement.)
GotStylusCapture | (Inherited from UIElement.)
GotTouchCapture | (Inherited from UIElement.)
Initialized | (Inherited from FrameworkElement.)
IsAsyncPresentationDeferredChanged | Occurs when IsAsyncPresentationDeferred value is changed. (Inherited from ItemsControlBase.)
IsEnabledChanged | (Inherited from UIElement.)
IsHitTestVisibleChanged | (Inherited from UIElement.)
IsKeyboardFocusedChanged | (Inherited from UIElement.)
IsKeyboardFocusWithinChanged | (Inherited from UIElement.)
IsMouseCapturedChanged | (Inherited from UIElement.)
IsMouseCaptureWithinChanged | (Inherited from UIElement.)
IsMouseDirectlyOverChanged | (Inherited from UIElement.)
IsStylusCapturedChanged | (Inherited from UIElement.)
IsStylusCaptureWithinChanged | (Inherited from UIElement.)
IsStylusDirectlyOverChanged | (Inherited from UIElement.)
IsVisibleChanged | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from UIElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostKeyboardFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
LostStylusCapture | (Inherited from UIElement.)
LostTouchCapture | (Inherited from UIElement.)
ManipulationBoundaryFeedback | (Inherited from UIElement.)
ManipulationCompleted | (Inherited from UIElement.)
ManipulationDelta | (Inherited from UIElement.)
ManipulationInertiaStarting | (Inherited from UIElement.)
ManipulationStarted | (Inherited from UIElement.)
ManipulationStarting | (Inherited from UIElement.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseRightButtonDown | (Inherited from UIElement.)
MouseRightButtonUp | (Inherited from UIElement.)
MouseUp | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PreviewDragEnter | (Inherited from UIElement.)
PreviewDragLeave | (Inherited from UIElement.)
PreviewDragOver | (Inherited from UIElement.)
PreviewDrop | (Inherited from UIElement.)
PreviewGiveFeedback | (Inherited from UIElement.)
PreviewGotKeyboardFocus | (Inherited from UIElement.)
PreviewKeyDown | (Inherited from UIElement.)
PreviewKeyUp | (Inherited from UIElement.)
PreviewLostKeyboardFocus | (Inherited from UIElement.)
PreviewMouseDoubleClick | (Inherited from Control.)
PreviewMouseDown | (Inherited from UIElement.)
PreviewMouseLeftButtonDown | (Inherited from UIElement.)
PreviewMouseLeftButtonUp | (Inherited from UIElement.)
PreviewMouseMove | (Inherited from UIElement.)
PreviewMouseRightButtonDown | (Inherited from UIElement.)
PreviewMouseRightButtonUp | (Inherited from UIElement.)
PreviewMouseUp | (Inherited from UIElement.)
PreviewMouseWheel | (Inherited from UIElement.)
PreviewQueryContinueDrag | (Inherited from UIElement.)
PreviewStylusButtonDown | (Inherited from UIElement.)
PreviewStylusButtonUp | (Inherited from UIElement.)
PreviewStylusDown | (Inherited from UIElement.)
PreviewStylusInAirMove | (Inherited from UIElement.)
PreviewStylusInRange | (Inherited from UIElement.)
PreviewStylusMove | (Inherited from UIElement.)
PreviewStylusOutOfRange | (Inherited from UIElement.)
PreviewStylusSystemGesture | (Inherited from UIElement.)
PreviewStylusUp | (Inherited from UIElement.)
PreviewTextInput | (Inherited from UIElement.)
PreviewTouchDown | (Inherited from UIElement.)
PreviewTouchMove | (Inherited from UIElement.)
PreviewTouchUp | (Inherited from UIElement.)
QueryContinueDrag | (Inherited from UIElement.)
QueryCursor | (Inherited from UIElement.)
RequestBringIntoView | (Inherited from FrameworkElement.)
SelectionChanged | Occurs when the selection of a Selector changes.
SizeChanged | (Inherited from FrameworkElement.)
SourceUpdated | (Inherited from FrameworkElement.)
StylusButtonDown | (Inherited from UIElement.)
StylusButtonUp | (Inherited from UIElement.)
StylusDown | (Inherited from UIElement.)
StylusEnter | (Inherited from UIElement.)
StylusInAirMove | (Inherited from UIElement.)
StylusInRange | (Inherited from UIElement.)
StylusLeave | (Inherited from UIElement.)
StylusMove | (Inherited from UIElement.)
StylusOutOfRange | (Inherited from UIElement.)
StylusSystemGesture | (Inherited from UIElement.)
StylusUp | (Inherited from UIElement.)
TargetUpdated | (Inherited from FrameworkElement.)
TextInput | (Inherited from UIElement.)
ToolTipClosing | (Inherited from FrameworkElement.)
ToolTipOpening | (Inherited from FrameworkElement.)
TouchDown | (Inherited from UIElement.)
TouchEnter | (Inherited from UIElement.)
TouchLeave | (Inherited from UIElement.)
TouchMove | (Inherited from UIElement.)
TouchUp | (Inherited from UIElement.)
Unloaded | (Inherited from FrameworkElement.)

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


SelectionChanged Event

[image]

.NET Framework Class Library
Selector..::.SelectionChanged Event
Selector Class See Also Send Feedback

Occurs when the selection of a Selector changes.

Namespace: DlhSoft.Windows.Controls.Primitives
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public event SelectionChangedEventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler

See Also

Selector Class
DlhSoft.Windows.Controls.Primitives Namespace


DlhSoft.Windows.Converters Namespace

[image]

.NET Framework Class Library
DlhSoft.Windows.Converters Namespace
Send Feedback

Classes

Class | Description
DayOfWeekInitialConverter | Converts day of week values to their abbreviated string representation.
MonthYearConverter | Converts month start date values to their string month and year representation.
SizeConverter | Converts values to widths or heights; the converter parameter specifies the value to multiply by (the default value is 16).


DayOfWeekInitialConverter Class

[image]

.NET Framework Class Library
DayOfWeekInitialConverter Class
Members See Also Send Feedback

Converts day of week values to their abbreviated string representation.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
[ValueConversionAttribute(typeof(DateTime), typeof(string))]
public sealed class DayOfWeekInitialConverter : IValueConverter
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
<ValueConversionAttribute(GetType(DateTime), GetType(String))> _
Public NotInheritable Class DayOfWeekInitialConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Converters..::.DayOfWeekInitialConverter

See Also

DayOfWeekInitialConverter Members
DlhSoft.Windows.Converters Namespace


DayOfWeekInitialConverter Members

[image] [image]

.NET Framework Class Library
DayOfWeekInitialConverter Members
DayOfWeekInitialConverter Class Constructors Methods See Also Send Feedback

The DayOfWeekInitialConverter type exposes the following members.

Constructors

Name | Description
DayOfWeekInitialConverter |

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayOfWeekInitialConverter Class
DlhSoft.Windows.Converters Namespace


DayOfWeekInitialConverter Constructor

[image]

.NET Framework Class Library
DayOfWeekInitialConverter Constructor
DayOfWeekInitialConverter Class See Also Send Feedback

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public DayOfWeekInitialConverter()
Visual Basic (Declaration)
Public Sub New

See Also

DayOfWeekInitialConverter Class
DlhSoft.Windows.Converters Namespace


DayOfWeekInitialConverter Methods

[image] [image]

.NET Framework Class Library
DayOfWeekInitialConverter Methods
DayOfWeekInitialConverter Class See Also Send Feedback

The DayOfWeekInitialConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayOfWeekInitialConverter Class
DlhSoft.Windows.Converters Namespace


Convert Method

[image]

.NET Framework Class Library
DayOfWeekInitialConverter..::.Convert Method
DayOfWeekInitialConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DayOfWeekInitialConverter Class
DlhSoft.Windows.Converters Namespace


ConvertBack Method

[image]

.NET Framework Class Library
DayOfWeekInitialConverter..::.ConvertBack Method
DayOfWeekInitialConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DayOfWeekInitialConverter Class
DlhSoft.Windows.Converters Namespace


MonthYearConverter Class

[image]

.NET Framework Class Library
MonthYearConverter Class
Members See Also Send Feedback

Converts month start date values to their string month and year representation.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
[ValueConversionAttribute(typeof(DateTime), typeof(string))]
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public sealed class MonthYearConverter : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(DateTime), GetType(String))> _
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public NotInheritable Class MonthYearConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Converters..::.MonthYearConverter

See Also

MonthYearConverter Members
DlhSoft.Windows.Converters Namespace


MonthYearConverter Members

[image] [image]

.NET Framework Class Library
MonthYearConverter Members
MonthYearConverter Class Constructors Methods See Also Send Feedback

The MonthYearConverter type exposes the following members.

Constructors

Name | Description
MonthYearConverter |

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthYearConverter Class
DlhSoft.Windows.Converters Namespace


MonthYearConverter Constructor

[image]

.NET Framework Class Library
MonthYearConverter Constructor
MonthYearConverter Class See Also Send Feedback

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public MonthYearConverter()
Visual Basic (Declaration)
Public Sub New

See Also

MonthYearConverter Class
DlhSoft.Windows.Converters Namespace


MonthYearConverter Methods

[image] [image]

.NET Framework Class Library
MonthYearConverter Methods
MonthYearConverter Class See Also Send Feedback

The MonthYearConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthYearConverter Class
DlhSoft.Windows.Converters Namespace


Convert Method

[image]

.NET Framework Class Library
MonthYearConverter..::.Convert Method
MonthYearConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

MonthYearConverter Class
DlhSoft.Windows.Converters Namespace


ConvertBack Method

[image]

.NET Framework Class Library
MonthYearConverter..::.ConvertBack Method
MonthYearConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.Data.Controls (in DlhSoft.Data.Controls.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

MonthYearConverter Class
DlhSoft.Windows.Converters Namespace


SizeConverter Class

[image]

.NET Framework Class Library
SizeConverter Class
Members See Also Send Feedback

Converts values to widths or heights; the converter parameter specifies the value to multiply by (the default value is 16).

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
[ValueConversionAttribute(typeof(int), typeof(double))]
[LocalizabilityAttribute(LocalizationCategory.None, Readability = Readability.Unreadable)]
public sealed class SizeConverter : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Integer), GetType(Double))> _
<LocalizabilityAttribute(LocalizationCategory.None, Readability := Readability.Unreadable)> _
Public NotInheritable Class SizeConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Converters..::.SizeConverter

See Also

SizeConverter Members
DlhSoft.Windows.Converters Namespace


SizeConverter Members

[image] [image]

.NET Framework Class Library
SizeConverter Members
SizeConverter Class Constructors Methods See Also Send Feedback

The SizeConverter type exposes the following members.

Constructors

Name | Description
SizeConverter |

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeConverter Class
DlhSoft.Windows.Converters Namespace


SizeConverter Constructor

[image]

.NET Framework Class Library
SizeConverter Constructor
SizeConverter Class See Also Send Feedback

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public SizeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

SizeConverter Class
DlhSoft.Windows.Converters Namespace


SizeConverter Methods

[image] [image]

.NET Framework Class Library
SizeConverter Methods
SizeConverter Class See Also Send Feedback

The SizeConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeConverter Class
DlhSoft.Windows.Converters Namespace


Convert Method

[image]

.NET Framework Class Library
SizeConverter..::.Convert Method
SizeConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SizeConverter Class
DlhSoft.Windows.Converters Namespace


ConvertBack Method

[image]

.NET Framework Class Library
SizeConverter..::.ConvertBack Method
SizeConverter Class See Also Send Feedback

Converts a value.

Namespace: DlhSoft.Windows.Converters
Assembly: DlhSoft.HierarchicalData.Controls (in DlhSoft.HierarchicalData.Controls.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SizeConverter Class
DlhSoft.Windows.Converters Namespace


DlhSoft.Windows.Data Namespace

[image]

.NET Framework Class Library
DlhSoft.Windows.Data Namespace
Send Feedback

Classes

Class | Description
Entity | Represents an entity item object wrapper generated and managed by an EntityManager, aware of the parent collection or entity that owns it.
EntityCollection | Observable collection that owns Entity objects used internally by an EntityManager.
EntityItem | Represents an entity item that can be used as a source object to be wrapped within an Entity and managed using an EntityManager or hosted within a data management control.
EntityManager | Basic object collection management engine that uses an entity collection to wrap the objects internally. Inheriters can provide initialization and change management operations for managing customized collections using the internal entity collection. Use Items property to set your own entity data item collection to manage and use Entities property to access the managed entity collection mapping your items. It is recommended to use a single EntityManager instance for each set of distinct data items and data member properties at any specific time, and to use the Dispose method to release the resources used by an instance that is no longer needed.
NewItemEventArgs | Provides data for the NewItem event.
Node | Represents a node item object wrapper generated and managed by a NodeManager, aware of its indentation in a hierarchical collection.
NodeCollection | Observable collection that owns Node objects used internally by a NodeManager.
NodeItem | Represents a node item aware of its indentation and expansion state (can be expanded or collapsed) that can be used as a source object to be wrapped within a Node and managed using a NodeManager or hosted within a hierarchical data management control. It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.
NodeManager | Object collection management engine that uses a node collection to wrap the objects internally. Provides automatic management of indentation (node hierarchy) and expansion (node visibility) for the collection items. Use Items property to set your own node data item collection to manage and use Nodes property to access the managed node collection mapping your items. It is recommended to set at least these data member properties: IndentationMemberPath. These data member properties can also be set: IsExpandedMemberPath.
ReadOnlyEntityCollection | Read-only observable collection of Entity objects.
ReadOnlyNodeCollection | Read-only observable collection of Node objects.
SimpleEntityItem | Represents a simple entity item that can be used as a data definition object when inserting or adding an Entity using an EntityManager with simple data management mode.
SimpleNodeItem | Represents a simple node item that can be used as a data definition object when inserting or adding a Node using a NodeManager with simple data management mode. It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.

Interfaces

Interface | Description
IEntityItem | Represents the interface of an entity item that can be used as a source object to be wrapped within an Entity and managed using an EntityManager or hosted within a data management control.
INodeItem | Represents the interface of a node item aware of its indentation and expansion state (can be expanded or collapsed) that can be used as a source object to be wrapped within a Node and managed using a NodeManager or hosted within a hierarchical data management control.

Delegates

Delegate | Description
Entity..::.Initialization | Represents a method that provides Entity initialization.
NewItemEventHandler | Represents the method that will handle a NewItem event of the ReadOnlyEntityCollection class.

Enumerations

Enumeration | Description
DataManagementMode | Represents an EntityManager data management mode.


DataManagementMode Enumeration

[image]

.NET Framework Class Library
DataManagementMode Enumeration
See Also Send Feedback

Represents an EntityManager data management mode.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public enum DataManagementMode
Visual Basic (Declaration)
Public Enumeration DataManagementMode

Members

Member name | Description
Standard | Standard data management mode, using two-way data binding to a collection of data items.
Simple | Simple data management mode, requiring adding, updating, and removing entities manually (using Add, Remove method or the indexer of the entity manager object).

See Also

DlhSoft.Windows.Data Namespace


Entity Class

[image]

.NET Framework Class Library
Entity Class
Members See Also Send Feedback

Represents an entity item object wrapper generated and managed by an EntityManager, aware of the parent collection or entity that owns it.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class Entity : DependencyObject, IDisposable
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class Entity _
    Inherits DependencyObject _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.Entity
DlhSoft.Windows.Data..::.Node

See Also

Entity Members
DlhSoft.Windows.Data Namespace


Entity Members

[image] [image]

.NET Framework Class Library
Entity Members
Entity Class Constructors Methods Fields Properties Events See Also Send Feedback

The Entity type exposes the following members.

Constructors

Name | Description
Entity | Overloaded.

Methods

Name | Description
AddRelatedEntity | Adds an entity to the related entities collection of this Entity.
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Dispose | Releases all resources used by the Entity.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDisposing | Called when the Entity is disposed.
OnFilteringVisibilityChanged | Applies visibility changes when filtering visibility changes.
OnInsertedIntoParentCollection | Called after the Entity is inserted into the parent collection.
OnIsFilteringVisibleChanged | Called when the IsFilteringVisible property changes.
OnIsVisibleChanged | Called when the IsVisible property changes.
OnParentEntitySet | Called after the Entity was set as owned by a parent collection.
OnParentManagerInitializeEntitiesComplete | Called when the initialization of the parent EntityManager is completed.
OnPropertyChanged | (Inherited from DependencyObject.)
OnRelatedEntityAdded | Called when an entity is added to the related entities collection.
OnRelatedEntityRemoved | Called when an entity is removed from the related entities collection.
OnRemovingFromParentCollection | Called before the Entity is removed from the parent collection.
OnVisibilityChanged | Raises the VisibilityChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
RemoveRelatedEntity | Removes an entity from the related entities collection of this Entity.
RemoveValue | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateValue | Overloaded.
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IndexProperty | Identifies the Index dependency property.
IsFilteringVisibleProperty | Identifies the IsFilteringVisible dependency property.
IsVisibleProperty | Identifies the IsVisible dependency property.
ItemProperty | Identifies the Item dependency property.
ParentCollectionProperty | Identifies the ParentCollection dependency property.
ParentEntityProperty | Identifies the ParentEntity dependency property.
ParentManagerProperty | Identifies the ParentManager dependency property.
RelatedEntitiesProperty | Identifies the RelatedEntities dependency property.

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
Index | Gets the index of this Entity in the parent collection that owns it. This is a dependency property.
IsDisposed | Gets a value indicating whether the Entity is currently disposed.
IsFilteringVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection based when filtering is applied. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection. This is a dependency property.
Item | Gets (or sets, when using simple data management mode) the object wrapped by this Entity. This is a dependency property.
ParentCollection | Gets the parent collection that owns this Entity. This is a dependency property.
ParentEntity | Gets the parent entity that owns this Entity. This is a dependency property.
ParentManager | Gets the parent manager that owns this Entity. This is a dependency property.
RelatedEntities | Gets the related entities collection of this Entity. This is a dependency property.

Events

Name | Description
Disposing | Occurs when the Entity is disposed.
VisibilityChanged | Occurs when the visibility changes for this Entity.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Entity Constructor

[image] [image]

.NET Framework Class Library
Entity Constructor
Entity Class See Also Send Feedback

Overload List

Name | Description
Entity(Object) | Initializes a new instance of the Entity class.
Entity(Entity, Object) | Initializes a new instance of the Entity class and sets it as owned by a specified parent entity.
Entity(Object, Entity..::.Initialization) | Initializes a new instance of the Entity class.
Entity(Entity, Object, Entity..::.Initialization, Entity..::.Initialization) | Initializes a new instance of the Entity class and sets it as owned by a specified parent entity.
Entity(Object, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization) | Initializes a new instance of the Entity class.

See Also

Entity Class
Entity Members
DlhSoft.Windows.Data Namespace


Entity Constructor (Object)

[image]

.NET Framework Class Library
Entity Constructor (Object)
Entity Class See Also Send Feedback

Initializes a new instance of the Entity class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal Entity(
    Object item
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object _
)

Parameters

item
Type: System..::.Object
Entity item to be wrapped by the Entity.

See Also

Entity Class
Entity Overload
DlhSoft.Windows.Data Namespace


Entity Constructor (Entity, Object)

[image]

.NET Framework Class Library
Entity Constructor (Entity, Object)
Entity Class See Also Send Feedback

Initializes a new instance of the Entity class and sets it as owned by a specified parent entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal Entity(
    Entity parentEntity,
    Object item
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    parentEntity As Entity, _
    item As Object _
)

Parameters

parentEntity
Type: DlhSoft.Windows.Data..::.Entity
The parent Entity that owns this Entity.
item
Type: System..::.Object
Entity item to be wrapped by the Entity.

See Also

Entity Class
Entity Overload
DlhSoft.Windows.Data Namespace


Entity Constructor (Object, Entity.Initialization)

[image]

.NET Framework Class Library
Entity Constructor (Object, Entity..::.Initialization)
Entity Class See Also Send Feedback

Initializes a new instance of the Entity class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal Entity(
    Object item,
    Entity..::.Initialization initialization
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object, _
    initialization As Entity..::.Initialization _
)

Parameters

item
Type: System..::.Object
Entity item to be wrapped by the Entity.
initialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is inserted into the parent collection.

See Also

Entity Class
Entity Overload
DlhSoft.Windows.Data Namespace


Entity Constructor (Entity, Object, Entity.Initialization, Entity.Initialization)

[image]

.NET Framework Class Library
Entity Constructor (Entity, Object, Entity..::.Initialization, Entity..::.Initialization)
Entity Class See Also Send Feedback

Initializes a new instance of the Entity class and sets it as owned by a specified parent entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal Entity(
    Entity parentEntity,
    Object item,
    Entity..::.Initialization parentEntitySetInitialization,
    Entity..::.Initialization disposingInitialization
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    parentEntity As Entity, _
    item As Object, _
    parentEntitySetInitialization As Entity..::.Initialization, _
    disposingInitialization As Entity..::.Initialization _
)

Parameters

parentEntity
Type: DlhSoft.Windows.Data..::.Entity
The parent Entity that owns this Entity.
item
Type: System..::.Object
Entity item to be wrapped by the Entity.
parentEntitySetInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is set as owned by a parent entity.
disposingInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is disposed.

See Also

Entity Class
Entity Overload
DlhSoft.Windows.Data Namespace


Entity Constructor (Object, Entity.Initialization, Entity.Initialization, Entity.Initialization, Entity.Initialization)

[image]

.NET Framework Class Library
Entity Constructor (Object, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization)
Entity Class See Also Send Feedback

Initializes a new instance of the Entity class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal Entity(
    Object item,
    Entity..::.Initialization completingParentManagerInitialization,
    Entity..::.Initialization insertedIntoParentCollectionInitialization,
    Entity..::.Initialization removingFromParentCollectionInitialization,
    Entity..::.Initialization disposingInitialization
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object, _
    completingParentManagerInitialization As Entity..::.Initialization, _
    insertedIntoParentCollectionInitialization As Entity..::.Initialization, _
    removingFromParentCollectionInitialization As Entity..::.Initialization, _
    disposingInitialization As Entity..::.Initialization _
)

Parameters

item
Type: System..::.Object
Entity item to be wrapped by the Entity.
completingParentManagerInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the initialization of the parent EntityManager is completed.
insertedIntoParentCollectionInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is inserted into the parent collection.
removingFromParentCollectionInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is removed from the parent collection.
disposingInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Entity is disposed.

See Also

Entity Class
Entity Overload
DlhSoft.Windows.Data Namespace


Entity Fields

[image] [image]

.NET Framework Class Library
Entity Fields
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Fields

Name | Description
IndexProperty | Identifies the Index dependency property.
IsFilteringVisibleProperty | Identifies the IsFilteringVisible dependency property.
IsVisibleProperty | Identifies the IsVisible dependency property.
ItemProperty | Identifies the Item dependency property.
ParentCollectionProperty | Identifies the ParentCollection dependency property.
ParentEntityProperty | Identifies the ParentEntity dependency property.
ParentManagerProperty | Identifies the ParentManager dependency property.
RelatedEntitiesProperty | Identifies the RelatedEntities dependency property.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IndexProperty Field

[image]

.NET Framework Class Library
Entity..::.IndexProperty Field
Entity Class See Also Send Feedback

Identifies the Index dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty IndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly IndexProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IsFilteringVisibleProperty Field

[image]

.NET Framework Class Library
Entity..::.IsFilteringVisibleProperty Field
Entity Class See Also Send Feedback

Identifies the IsFilteringVisible dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty IsFilteringVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFilteringVisibleProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IsVisibleProperty Field

[image]

.NET Framework Class Library
Entity..::.IsVisibleProperty Field
Entity Class See Also Send Feedback

Identifies the IsVisible dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty IsVisibleProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsVisibleProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ItemProperty Field

[image]

.NET Framework Class Library
Entity..::.ItemProperty Field
Entity Class See Also Send Feedback

Identifies the Item dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty ItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentCollectionProperty Field

[image]

.NET Framework Class Library
Entity..::.ParentCollectionProperty Field
Entity Class See Also Send Feedback

Identifies the ParentCollection dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty ParentCollectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParentCollectionProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentEntityProperty Field

[image]

.NET Framework Class Library
Entity..::.ParentEntityProperty Field
Entity Class See Also Send Feedback

Identifies the ParentEntity dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty ParentEntityProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParentEntityProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentManagerProperty Field

[image]

.NET Framework Class Library
Entity..::.ParentManagerProperty Field
Entity Class See Also Send Feedback

Identifies the ParentManager dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty ParentManagerProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParentManagerProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


RelatedEntitiesProperty Field

[image]

.NET Framework Class Library
Entity..::.RelatedEntitiesProperty Field
Entity Class See Also Send Feedback

Identifies the RelatedEntities dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty RelatedEntitiesProperty
Visual Basic (Declaration)
Public Shared ReadOnly RelatedEntitiesProperty As DependencyProperty

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Entity Methods

[image] [image]

.NET Framework Class Library
Entity Methods
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Methods

Name | Description
AddRelatedEntity | Adds an entity to the related entities collection of this Entity.
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Dispose | Releases all resources used by the Entity.
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDisposing | Called when the Entity is disposed.
OnFilteringVisibilityChanged | Applies visibility changes when filtering visibility changes.
OnInsertedIntoParentCollection | Called after the Entity is inserted into the parent collection.
OnIsFilteringVisibleChanged | Called when the IsFilteringVisible property changes.
OnIsVisibleChanged | Called when the IsVisible property changes.
OnParentEntitySet | Called after the Entity was set as owned by a parent collection.
OnParentManagerInitializeEntitiesComplete | Called when the initialization of the parent EntityManager is completed.
OnPropertyChanged | (Inherited from DependencyObject.)
OnRelatedEntityAdded | Called when an entity is added to the related entities collection.
OnRelatedEntityRemoved | Called when an entity is removed from the related entities collection.
OnRemovingFromParentCollection | Called before the Entity is removed from the parent collection.
OnVisibilityChanged | Raises the VisibilityChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
RemoveRelatedEntity | Removes an entity from the related entities collection of this Entity.
RemoveValue | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateValue | Overloaded.
VerifyAccess | (Inherited from DispatcherObject.)

See Also

Entity Class
DlhSoft.Windows.Data Namespace


AddRelatedEntity Method

[image]

.NET Framework Class Library
Entity..::.AddRelatedEntity Method
Entity Class See Also Send Feedback

Adds an entity to the related entities collection of this Entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void AddRelatedEntity(
    Entity relatedEntity
)
Visual Basic (Declaration)
Public Sub AddRelatedEntity ( _
    relatedEntity As Entity _
)

Parameters

relatedEntity
Type: DlhSoft.Windows.Data..::.Entity
The related entity to add.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
Entity..::.ClearValue Method
Entity Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

Entity Class
Entity Members
DlhSoft.Windows.Data Namespace


Dispose Method

[image]

.NET Framework Class Library
Entity..::.Dispose Method
Entity Class See Also Send Feedback

Releases all resources used by the Entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnDisposing Method

[image]

.NET Framework Class Library
Entity..::.OnDisposing Method
Entity Class See Also Send Feedback

Called when the Entity is disposed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void OnDisposing()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnDisposing

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnFilteringVisibilityChanged Method

[image]

.NET Framework Class Library
Entity..::.OnFilteringVisibilityChanged Method
Entity Class See Also Send Feedback

Applies visibility changes when filtering visibility changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnFilteringVisibilityChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnFilteringVisibilityChanged

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnInsertedIntoParentCollection Method

[image]

.NET Framework Class Library
Entity..::.OnInsertedIntoParentCollection Method
Entity Class See Also Send Feedback

Called after the Entity is inserted into the parent collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void OnInsertedIntoParentCollection()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnInsertedIntoParentCollection

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnIsFilteringVisibleChanged Method

[image]

.NET Framework Class Library
Entity..::.OnIsFilteringVisibleChanged Method
Entity Class See Also Send Feedback

Called when the IsFilteringVisible property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnIsFilteringVisibleChanged(
    bool oldIsFilteringVisible,
    bool newIsFilteringVisible
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsFilteringVisibleChanged ( _
    oldIsFilteringVisible As Boolean, _
    newIsFilteringVisible As Boolean _
)

Parameters

oldIsFilteringVisible
Type: System..::.Boolean
newIsFilteringVisible
Type: System..::.Boolean

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnIsVisibleChanged Method

[image]

.NET Framework Class Library
Entity..::.OnIsVisibleChanged Method
Entity Class See Also Send Feedback

Called when the IsVisible property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnIsVisibleChanged(
    bool oldIsVisible,
    bool newIsVisible
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsVisibleChanged ( _
    oldIsVisible As Boolean, _
    newIsVisible As Boolean _
)

Parameters

oldIsVisible
Type: System..::.Boolean
newIsVisible
Type: System..::.Boolean

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnParentEntitySet Method

[image]

.NET Framework Class Library
Entity..::.OnParentEntitySet Method
Entity Class See Also Send Feedback

Called after the Entity was set as owned by a parent collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void OnParentEntitySet()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnParentEntitySet

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnParentManagerInitializeEntitiesComplete Method

[image]

.NET Framework Class Library
Entity..::.OnParentManagerInitializeEntitiesComplete Method
Entity Class See Also Send Feedback

Called when the initialization of the parent EntityManager is completed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void OnParentManagerInitializeEntitiesComplete()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnParentManagerInitializeEntitiesComplete

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnRelatedEntityAdded Method

[image]

.NET Framework Class Library
Entity..::.OnRelatedEntityAdded Method
Entity Class See Also Send Feedback

Called when an entity is added to the related entities collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnRelatedEntityAdded(
    Entity relatedEntity
)
Visual Basic (Declaration)
Protected Overridable Sub OnRelatedEntityAdded ( _
    relatedEntity As Entity _
)

Parameters

relatedEntity
Type: DlhSoft.Windows.Data..::.Entity
The added related entity.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnRelatedEntityRemoved Method

[image]

.NET Framework Class Library
Entity..::.OnRelatedEntityRemoved Method
Entity Class See Also Send Feedback

Called when an entity is removed from the related entities collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnRelatedEntityRemoved(
    Entity relatedEntity
)
Visual Basic (Declaration)
Protected Overridable Sub OnRelatedEntityRemoved ( _
    relatedEntity As Entity _
)

Parameters

relatedEntity
Type: DlhSoft.Windows.Data..::.Entity
The removed related entity.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnRemovingFromParentCollection Method

[image]

.NET Framework Class Library
Entity..::.OnRemovingFromParentCollection Method
Entity Class See Also Send Feedback

Called before the Entity is removed from the parent collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void OnRemovingFromParentCollection()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnRemovingFromParentCollection

See Also

Entity Class
DlhSoft.Windows.Data Namespace


OnVisibilityChanged Method

[image]

.NET Framework Class Library
Entity..::.OnVisibilityChanged Method
Entity Class See Also Send Feedback

Raises the VisibilityChanged event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual void OnVisibilityChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnVisibilityChanged

See Also

Entity Class
DlhSoft.Windows.Data Namespace


RemoveRelatedEntity Method

[image]

.NET Framework Class Library
Entity..::.RemoveRelatedEntity Method
Entity Class See Also Send Feedback

Removes an entity from the related entities collection of this Entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void RemoveRelatedEntity(
    Entity relatedEntity
)
Visual Basic (Declaration)
Public Sub RemoveRelatedEntity ( _
    relatedEntity As Entity _
)

Parameters

relatedEntity
Type: DlhSoft.Windows.Data..::.Entity
The related entity to remove.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


RemoveValue Method

[image] [image]

.NET Framework Class Library
Entity..::.RemoveValue Method
Entity Class See Also Send Feedback

Overload List

Name | Description
RemoveValue(DependencyProperty) | Clears the local value of a dependency property, specified by its dependency property identifier.
RemoveValue(DependencyPropertyKey) | Clears the local value of a dependency property, specified by its DependencyPropertyKey identifier.

See Also

Entity Class
Entity Members
DlhSoft.Windows.Data Namespace


RemoveValue Method (DependencyProperty)

[image]

.NET Framework Class Library
Entity..::.RemoveValue Method (DependencyProperty)
Entity Class See Also Send Feedback

Clears the local value of a dependency property, specified by its dependency property identifier.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void RemoveValue(
    DependencyProperty dependencyProperty
)
Visual Basic (Declaration)
Protected Friend Overridable Sub RemoveValue ( _
    dependencyProperty As DependencyProperty _
)

Parameters

dependencyProperty
Type: System.Windows..::.DependencyProperty

See Also

Entity Class
RemoveValue Overload
DlhSoft.Windows.Data Namespace


RemoveValue Method (DependencyPropertyKey)

[image]

.NET Framework Class Library
Entity..::.RemoveValue Method (DependencyPropertyKey)
Entity Class See Also Send Feedback

Clears the local value of a dependency property, specified by its DependencyPropertyKey identifier.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void RemoveValue(
    DependencyPropertyKey dependencyPropertyKey
)
Visual Basic (Declaration)
Protected Friend Overridable Sub RemoveValue ( _
    dependencyPropertyKey As DependencyPropertyKey _
)

Parameters

dependencyPropertyKey
Type: System.Windows..::.DependencyPropertyKey

See Also

Entity Class
RemoveValue Overload
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
Entity..::.SetValue Method
Entity Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

Entity Class
Entity Members
DlhSoft.Windows.Data Namespace


UpdateValue Method

[image] [image]

.NET Framework Class Library
Entity..::.UpdateValue Method
Entity Class See Also Send Feedback

Overload List

Name | Description
UpdateValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier, if the specified new value is different than the previous value of that dependency property.
UpdateValue(DependencyPropertyKey, Object) | Sets the local value of a dependency property, specified by its DependencyPropertyKey identifier, if the specified new value is different than the previous value of that dependency property.

See Also

Entity Class
Entity Members
DlhSoft.Windows.Data Namespace


UpdateValue Method (DependencyProperty, Object)

[image]

.NET Framework Class Library
Entity..::.UpdateValue Method (DependencyProperty, Object)
Entity Class See Also Send Feedback

Sets the local value of a dependency property, specified by its dependency property identifier, if the specified new value is different than the previous value of that dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void UpdateValue(
    DependencyProperty dependencyProperty,
    Object value
)
Visual Basic (Declaration)
Protected Friend Overridable Sub UpdateValue ( _
    dependencyProperty As DependencyProperty, _
    value As Object _
)

Parameters

dependencyProperty
Type: System.Windows..::.DependencyProperty
value
Type: System..::.Object

See Also

Entity Class
UpdateValue Overload
DlhSoft.Windows.Data Namespace


UpdateValue Method (DependencyPropertyKey, Object)

[image]

.NET Framework Class Library
Entity..::.UpdateValue Method (DependencyPropertyKey, Object)
Entity Class See Also Send Feedback

Sets the local value of a dependency property, specified by its DependencyPropertyKey identifier, if the specified new value is different than the previous value of that dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual void UpdateValue(
    DependencyPropertyKey dependencyPropertyKey,
    Object value
)
Visual Basic (Declaration)
Protected Friend Overridable Sub UpdateValue ( _
    dependencyPropertyKey As DependencyPropertyKey, _
    value As Object _
)

Parameters

dependencyPropertyKey
Type: System.Windows..::.DependencyPropertyKey
value
Type: System..::.Object

See Also

Entity Class
UpdateValue Overload
DlhSoft.Windows.Data Namespace


Entity Properties

[image] [image]

.NET Framework Class Library
Entity Properties
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
Index | Gets the index of this Entity in the parent collection that owns it. This is a dependency property.
IsDisposed | Gets a value indicating whether the Entity is currently disposed.
IsFilteringVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection based when filtering is applied. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
IsVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection. This is a dependency property.
Item | Gets (or sets, when using simple data management mode) the object wrapped by this Entity. This is a dependency property.
ParentCollection | Gets the parent collection that owns this Entity. This is a dependency property.
ParentEntity | Gets the parent entity that owns this Entity. This is a dependency property.
ParentManager | Gets the parent manager that owns this Entity. This is a dependency property.
RelatedEntities | Gets the related entities collection of this Entity. This is a dependency property.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Index Property

[image]

.NET Framework Class Library
Entity..::.Index Property
Entity Class See Also Send Feedback

Gets the index of this Entity in the parent collection that owns it. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public int Index { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Index As Integer

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IsDisposed Property

[image]

.NET Framework Class Library
Entity..::.IsDisposed Property
Entity Class See Also Send Feedback

Gets a value indicating whether the Entity is currently disposed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal bool IsDisposed { get; }
Visual Basic (Declaration)
Protected Friend ReadOnly Property IsDisposed As Boolean

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IsFilteringVisible Property

[image]

.NET Framework Class Library
Entity..::.IsFilteringVisible Property
Entity Class See Also Send Feedback

Gets or sets a value indicating whether or not this Entity is visible in the collection based when filtering is applied. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsFilteringVisible { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsFilteringVisible As Boolean

See Also

Entity Class
DlhSoft.Windows.Data Namespace


IsVisible Property

[image]

.NET Framework Class Library
Entity..::.IsVisible Property
Entity Class See Also Send Feedback

Gets or sets a value indicating whether or not this Entity is visible in the collection. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsVisible { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsVisible As Boolean

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
Entity..::.Item Property
Entity Class See Also Send Feedback

Gets (or sets, when using simple data management mode) the object wrapped by this Entity. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Item { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Item As Object

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentCollection Property

[image]

.NET Framework Class Library
Entity..::.ParentCollection Property
Entity Class See Also Send Feedback

Gets the parent collection that owns this Entity. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityCollection ParentCollection { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ParentCollection As EntityCollection

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentEntity Property

[image]

.NET Framework Class Library
Entity..::.ParentEntity Property
Entity Class See Also Send Feedback

Gets the parent entity that owns this Entity. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Entity ParentEntity { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ParentEntity As Entity

See Also

Entity Class
DlhSoft.Windows.Data Namespace


ParentManager Property

[image]

.NET Framework Class Library
Entity..::.ParentManager Property
Entity Class See Also Send Feedback

Gets the parent manager that owns this Entity. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager ParentManager { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ParentManager As EntityManager

See Also

Entity Class
DlhSoft.Windows.Data Namespace


RelatedEntities Property

[image]

.NET Framework Class Library
Entity..::.RelatedEntities Property
Entity Class See Also Send Feedback

Gets the related entities collection of this Entity. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public ReadOnlyObservableCollection<Entity> RelatedEntities { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property RelatedEntities As ReadOnlyObservableCollection(Of Entity)

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Entity Events

[image] [image]

.NET Framework Class Library
Entity Events
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Events

Name | Description
Disposing | Occurs when the Entity is disposed.
VisibilityChanged | Occurs when the visibility changes for this Entity.

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Disposing Event

[image]

.NET Framework Class Library
Entity..::.Disposing Event
Entity Class See Also Send Feedback

Occurs when the Entity is disposed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public event EventHandler Disposing
Visual Basic (Declaration)
Public Event Disposing As EventHandler

See Also

Entity Class
DlhSoft.Windows.Data Namespace


VisibilityChanged Event

[image]

.NET Framework Class Library
Entity..::.VisibilityChanged Event
Entity Class See Also Send Feedback

Occurs when the visibility changes for this Entity.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public event EventHandler VisibilityChanged
Visual Basic (Declaration)
Public Event VisibilityChanged As EventHandler

See Also

Entity Class
DlhSoft.Windows.Data Namespace


Entity.Initialization Delegate

[image]

.NET Framework Class Library
Entity..::.Initialization Delegate
Entity Class See Also Send Feedback

Represents a method that provides Entity initialization.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public delegate void Initialization(
    Entity entity
)
Visual Basic (Declaration)
Public Delegate Sub Initialization ( _
    entity As Entity _
)

Parameters

entity
Type: DlhSoft.Windows.Data..::.Entity

See Also

DlhSoft.Windows.Data Namespace


EntityCollection Class

[image]

.NET Framework Class Library
EntityCollection Class
Members See Also Send Feedback

Observable collection that owns Entity objects used internally by an EntityManager.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class EntityCollection : ObservableCollection<Entity>
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class EntityCollection _
    Inherits ObservableCollection(Of Entity)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Entity >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( Entity >)>)
DlhSoft.Windows.Data..::.EntityCollection
DlhSoft.Windows.Data..::.NodeCollection

See Also

EntityCollection Members
DlhSoft.Windows.Data Namespace


EntityCollection Members

[image] [image]

.NET Framework Class Library
EntityCollection Members
EntityCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The EntityCollection type exposes the following members.

Constructors

Name | Description
EntityCollection | Initializes a new instance of the EntityCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
BlockReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
CheckReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ClearItems | Removes all entities from the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Entity >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEntity | Gets the entity that wraps the specified object, or null if such entity doesn't exist.
GetEntityAt | Gets the entity at the specified index.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Entity >)>).)
InsertItem | Inserts an entity to the collection at the specified index and sets it as owned by this EntityCollection. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | (Inherited from ObservableCollection <(Of <( Entity >)>).)
MoveItem | Moves the entity at the specified index to a new location in the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.MoveItem(Int32, Int32).)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveItem | Removes the entity at the specified index of the collection and sets it as not owned by this EntityCollection. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the entity at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Item | Gets the entity at the specified index.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ParentEntity | Gets the parent entity of this collection.
ParentManager | Gets the parent manager of this collection.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entity >)>).)

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


EntityCollection Constructor

[image]

.NET Framework Class Library
EntityCollection Constructor
EntityCollection Class See Also Send Feedback

Initializes a new instance of the EntityCollection class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal EntityCollection(
    EntityManager parentManager
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    parentManager As EntityManager _
)

Parameters

parentManager
Type: DlhSoft.Windows.Data..::.EntityManager
The parent manager of the collection.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


EntityCollection Methods

[image] [image]

.NET Framework Class Library
EntityCollection Methods
EntityCollection Class See Also Send Feedback

The EntityCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
BlockReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
CheckReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ClearItems | Removes all entities from the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Entity >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEntity | Gets the entity that wraps the specified object, or null if such entity doesn't exist.
GetEntityAt | Gets the entity at the specified index.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Entity >)>).)
InsertItem | Inserts an entity to the collection at the specified index and sets it as owned by this EntityCollection. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | (Inherited from ObservableCollection <(Of <( Entity >)>).)
MoveItem | Moves the entity at the specified index to a new location in the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.MoveItem(Int32, Int32).)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveItem | Removes the entity at the specified index of the collection and sets it as not owned by this EntityCollection. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the entity at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entity >)>).)

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


ClearItems Method

[image]

.NET Framework Class Library
EntityCollection..::.ClearItems Method
EntityCollection Class See Also Send Feedback

Removes all entities from the collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


GetEntity Method

[image]

.NET Framework Class Library
EntityCollection..::.GetEntity Method
EntityCollection Class See Also Send Feedback

Gets the entity that wraps the specified object, or null if such entity doesn't exist.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity GetEntity(
    Object item
)
Visual Basic (Declaration)
Public Function GetEntity ( _
    item As Object _
) As Entity

Parameters

item
Type: System..::.Object
Wrapped object to search for.

Return Value

The entity that wraps the specified object, or null if such entity doesn't exist.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


GetEntityAt Method

[image]

.NET Framework Class Library
EntityCollection..::.GetEntityAt Method
EntityCollection Class See Also Send Feedback

Gets the entity at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity GetEntityAt(
    int index
)
Visual Basic (Declaration)
Public Function GetEntityAt ( _
    index As Integer _
) As Entity

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to be get.

Return Value

The entity at the specified index.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


InsertItem Method

[image]

.NET Framework Class Library
EntityCollection..::.InsertItem Method
EntityCollection Class See Also Send Feedback

Inserts an entity to the collection at the specified index and sets it as owned by this EntityCollection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Entity entity
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    entity As Entity _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which the entity should be inserted.
entity
Type: DlhSoft.Windows.Data..::.Entity
The entity to insert.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


MoveItem Method

[image]

.NET Framework Class Library
EntityCollection..::.MoveItem Method
EntityCollection Class See Also Send Feedback

Moves the entity at the specified index to a new location in the collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected override void MoveItem(
    int oldIndex,
    int newIndex
)
Visual Basic (Declaration)
Protected Overrides Sub MoveItem ( _
    oldIndex As Integer, _
    newIndex As Integer _
)

Parameters

oldIndex
Type: System..::.Int32
The zero-based index specifying the location of the entity to be moved.
newIndex
Type: System..::.Int32
The zero-based index specifying the new location of the entity.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


RemoveItem Method

[image]

.NET Framework Class Library
EntityCollection..::.RemoveItem Method
EntityCollection Class See Also Send Feedback

Removes the entity at the specified index of the collection and sets it as not owned by this EntityCollection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to remove.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


SetItem Method

[image]

.NET Framework Class Library
EntityCollection..::.SetItem Method
EntityCollection Class See Also Send Feedback

Replaces the entity at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected override void SetItem(
    int index,
    Entity entity
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    entity As Entity _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to replace.
entity
Type: DlhSoft.Windows.Data..::.Entity
The new value for the entity at the specified index.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


EntityCollection Properties

[image] [image]

.NET Framework Class Library
EntityCollection Properties
EntityCollection Class See Also Send Feedback

The EntityCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Item | Gets the entity at the specified index.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ParentEntity | Gets the parent entity of this collection.
ParentManager | Gets the parent manager of this collection.

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entity >)>).)

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
EntityCollection..::.Item Property
EntityCollection Class See Also Send Feedback

Gets the entity at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity Item[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    index As Integer _
) As Entity

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to be get.

Return Value

The entity at the specified index.

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


ParentEntity Property

[image]

.NET Framework Class Library
EntityCollection..::.ParentEntity Property
EntityCollection Class See Also Send Feedback

Gets the parent entity of this collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Entity ParentEntity { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ParentEntity As Entity

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


ParentManager Property

[image]

.NET Framework Class Library
EntityCollection..::.ParentManager Property
EntityCollection Class See Also Send Feedback

Gets the parent manager of this collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager ParentManager { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property ParentManager As EntityManager

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


EntityCollection Events

[image] [image]

.NET Framework Class Library
EntityCollection Events
EntityCollection Class See Also Send Feedback

The EntityCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

See Also

EntityCollection Class
DlhSoft.Windows.Data Namespace


EntityItem Class

[image]

.NET Framework Class Library
EntityItem Class
Members See Also Send Feedback

Represents an entity item that can be used as a source object to be wrapped within an Entity and managed using an EntityManager or hosted within a data management control.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None)]
[ContentPropertyAttribute("Content")]
public class EntityItem : DependencyObject, IEntityItem
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None)> _
<ContentPropertyAttribute("Content")> _
Public Class EntityItem _
    Inherits DependencyObject _
    Implements IEntityItem

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.EntityItem
DlhSoft.Windows.Data..::.NodeItem

See Also

EntityItem Members
DlhSoft.Windows.Data Namespace


EntityItem Members

[image] [image]

.NET Framework Class Library
EntityItem Members
EntityItem Class Constructors Methods Fields Properties See Also Send Feedback

The EntityItem type exposes the following members.

Constructors

Name | Description
EntityItem | Overloaded.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Provides a string representation of this EntityItem object. (Overrides Object..::.ToString()()().)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
ContentProperty | Identifies the Content dependency property.
TagProperty | Identifies the Tag dependency property.

Properties

Name | Description
Content | Gets or sets the content of this EntityItem. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this EntityItem. This is a dependency property.

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


EntityItem Constructor

[image] [image]

.NET Framework Class Library
EntityItem Constructor
EntityItem Class See Also Send Feedback

Overload List

Name | Description
EntityItem()()() | Initializes a new instance of the EntityItem class.
EntityItem(Object) | Initializes a new instance of the EntityItem class.

See Also

EntityItem Class
EntityItem Members
DlhSoft.Windows.Data Namespace


EntityItem Constructor

[image]

.NET Framework Class Library
EntityItem Constructor
EntityItem Class See Also Send Feedback

Initializes a new instance of the EntityItem class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public EntityItem()
Visual Basic (Declaration)
Public Sub New

See Also

EntityItem Class
EntityItem Overload
DlhSoft.Windows.Data Namespace


EntityItem Constructor (Object)

[image]

.NET Framework Class Library
EntityItem Constructor (Object)
EntityItem Class See Also Send Feedback

Initializes a new instance of the EntityItem class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public EntityItem(
    Object content
)
Visual Basic (Declaration)
Public Sub New ( _
    content As Object _
)

Parameters

content
Type: System..::.Object
Content of this EntityItem.

See Also

EntityItem Class
EntityItem Overload
DlhSoft.Windows.Data Namespace


EntityItem Fields

[image] [image]

.NET Framework Class Library
EntityItem Fields
EntityItem Class See Also Send Feedback

The EntityItem type exposes the following members.

Fields

Name | Description
ContentProperty | Identifies the Content dependency property.
TagProperty | Identifies the Tag dependency property.

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


ContentProperty Field

[image]

.NET Framework Class Library
EntityItem..::.ContentProperty Field
EntityItem Class See Also Send Feedback

Identifies the Content dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty ContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


TagProperty Field

[image]

.NET Framework Class Library
EntityItem..::.TagProperty Field
EntityItem Class See Also Send Feedback

Identifies the Tag dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public static readonly DependencyProperty TagProperty
Visual Basic (Declaration)
Public Shared ReadOnly TagProperty As DependencyProperty

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


EntityItem Methods

[image] [image]

.NET Framework Class Library
EntityItem Methods
EntityItem Class See Also Send Feedback

The EntityItem type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Provides a string representation of this EntityItem object. (Overrides Object..::.ToString()()().)
VerifyAccess | (Inherited from DispatcherObject.)

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
EntityItem..::.ClearValue Method
EntityItem Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

EntityItem Class
EntityItem Members
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
EntityItem..::.SetValue Method
EntityItem Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

EntityItem Class
EntityItem Members
DlhSoft.Windows.Data Namespace


ToString Method

[image]

.NET Framework Class Library
EntityItem..::.ToString Method
EntityItem Class See Also Send Feedback

Provides a string representation of this EntityItem object.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The string representation of the object.

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


EntityItem Properties

[image] [image]

.NET Framework Class Library
EntityItem Properties
EntityItem Class See Also Send Feedback

The EntityItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this EntityItem. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this EntityItem. This is a dependency property.

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


Content Property

[image]

.NET Framework Class Library
EntityItem..::.Content Property
EntityItem Class See Also Send Feedback

Gets or sets the content of this EntityItem. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Content { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Content As Object

Implements

IEntityItem..::.Content

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


Tag Property

[image]

.NET Framework Class Library
EntityItem..::.Tag Property
EntityItem Class See Also Send Feedback

Gets or sets an arbitrary object value that can be used to store custom information about this EntityItem. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Tag { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Tag As Object

See Also

EntityItem Class
DlhSoft.Windows.Data Namespace


EntityManager Class

[image]

.NET Framework Class Library
EntityManager Class
Members See Also Send Feedback

Basic object collection management engine that uses an entity collection to wrap the objects internally. Inheriters can provide initialization and change management operations for managing customized collections using the internal entity collection. Use Items property to set your own entity data item collection to manage and use Entities property to access the managed entity collection mapping your items. It is recommended to use a single EntityManager instance for each set of distinct data items and data member properties at any specific time, and to use the Dispose method to release the resources used by an instance that is no longer needed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
[ContentPropertyAttribute("Items")]
public class EntityManager : DependencyObject,
    ISupportInitializeNotification, IDisposable
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
<ContentPropertyAttribute("Items")> _
Public Class EntityManager _
    Inherits DependencyObject _
    Implements ISupportInitializeNotification, IDisposable

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.EntityManager
DlhSoft.Windows.Data..::.NodeManager

See Also

EntityManager Members
DlhSoft.Windows.Data Namespace


EntityManager Members

[image] [image]

.NET Framework Class Library
EntityManager Members
EntityManager Class Methods Properties See Also Send Feedback

The EntityManager type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerifyAccess | (Inherited from DispatcherObject.)

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)

See Also

EntityManager Class
DlhSoft.Windows.Data Namespace


EntityManager Methods

[image] [image]

.NET Framework Class Library
EntityManager Methods
EntityManager Class See Also Send Feedback

The EntityManager type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerifyAccess | (Inherited from DispatcherObject.)

See Also

EntityManager Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
EntityManager..::.ClearValue Method
EntityManager Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

EntityManager Class
EntityManager Members
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
EntityManager..::.SetValue Method
EntityManager Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

EntityManager Class
EntityManager Members
DlhSoft.Windows.Data Namespace


EntityManager Properties

[image] [image]

.NET Framework Class Library
EntityManager Properties
EntityManager Class See Also Send Feedback

The EntityManager type exposes the following members.

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)

See Also

EntityManager Class
DlhSoft.Windows.Data Namespace


IEntityItem Interface

[image]

.NET Framework Class Library
IEntityItem Interface
Members See Also Send Feedback

Represents the interface of an entity item that can be used as a source object to be wrapped within an Entity and managed using an EntityManager or hosted within a data management control.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public interface IEntityItem
Visual Basic (Declaration)
Public Interface IEntityItem

See Also

IEntityItem Members
DlhSoft.Windows.Data Namespace


IEntityItem Members

[image] [image]

.NET Framework Class Library
IEntityItem Members
IEntityItem Interface Properties See Also Send Feedback

The IEntityItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this IEntityItem.

See Also

IEntityItem Interface
DlhSoft.Windows.Data Namespace


IEntityItem Properties

[image] [image]

.NET Framework Class Library
IEntityItem Properties
IEntityItem Interface See Also Send Feedback

The IEntityItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this IEntityItem.

See Also

IEntityItem Interface
DlhSoft.Windows.Data Namespace


Content Property

[image]

.NET Framework Class Library
IEntityItem..::.Content Property
IEntityItem Interface See Also Send Feedback

Gets or sets the content of this IEntityItem.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
Object Content { get; set; }
Visual Basic (Declaration)
Property Content As Object

See Also

IEntityItem Interface
DlhSoft.Windows.Data Namespace


INodeItem Interface

[image]

.NET Framework Class Library
INodeItem Interface
Members See Also Send Feedback

Represents the interface of a node item aware of its indentation and expansion state (can be expanded or collapsed) that can be used as a source object to be wrapped within a Node and managed using a NodeManager or hosted within a hierarchical data management control.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public interface INodeItem : IEntityItem
Visual Basic (Declaration)
Public Interface INodeItem _
    Implements IEntityItem

See Also

INodeItem Members
DlhSoft.Windows.Data Namespace


INodeItem Members

[image] [image]

.NET Framework Class Library
INodeItem Members
INodeItem Interface Properties See Also Send Feedback

The INodeItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this IEntityItem. (Inherited from IEntityItem.)
Indentation | Gets or sets the indentation level of this INodeItem.
IsExpanded | Gets or sets the expansion indicator of this INodeItem.

See Also

INodeItem Interface
DlhSoft.Windows.Data Namespace


INodeItem Properties

[image] [image]

.NET Framework Class Library
INodeItem Properties
INodeItem Interface See Also Send Feedback

The INodeItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this IEntityItem. (Inherited from IEntityItem.)
Indentation | Gets or sets the indentation level of this INodeItem.
IsExpanded | Gets or sets the expansion indicator of this INodeItem.

See Also

INodeItem Interface
DlhSoft.Windows.Data Namespace


Indentation Property

[image]

.NET Framework Class Library
INodeItem..::.Indentation Property
INodeItem Interface See Also Send Feedback

Gets or sets the indentation level of this INodeItem.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
int Indentation { get; set; }
Visual Basic (Declaration)
Property Indentation As Integer

See Also

INodeItem Interface
DlhSoft.Windows.Data Namespace


IsExpanded Property

[image]

.NET Framework Class Library
INodeItem..::.IsExpanded Property
INodeItem Interface See Also Send Feedback

Gets or sets the expansion indicator of this INodeItem.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
bool IsExpanded { get; set; }
Visual Basic (Declaration)
Property IsExpanded As Boolean

See Also

INodeItem Interface
DlhSoft.Windows.Data Namespace


NewItemEventArgs Class

[image]

.NET Framework Class Library
NewItemEventArgs Class
Members See Also Send Feedback

Provides data for the NewItem event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public class NewItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class NewItemEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
DlhSoft.Windows.Data..::.NewItemEventArgs

See Also

NewItemEventArgs Members
DlhSoft.Windows.Data Namespace


NewItemEventArgs Members

[image] [image]

.NET Framework Class Library
NewItemEventArgs Members
NewItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The NewItemEventArgs type exposes the following members.

Constructors

Name | Description
NewItemEventArgs | Initializes a new instance of the NewItemEventArgs class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the creation of the new item is cancelled.
Item | Gets or sets the newly creating item.
Parameters | Gets the list of parameters that can be used for creating the new item.
ParentEntity | Gets the parent entity of the new item.
ParentItem | Gets the parent item of the new item.

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


NewItemEventArgs Constructor

[image]

.NET Framework Class Library
NewItemEventArgs Constructor
NewItemEventArgs Class See Also Send Feedback

Initializes a new instance of the NewItemEventArgs class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public NewItemEventArgs(
    Entity parentEntity,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parentEntity As Entity, _
    ParamArray parameters As Object() _
)

Parameters

parentEntity
Type: DlhSoft.Windows.Data..::.Entity
The parent entity of the new item.
parameters
Type: array< System..::.Object >[]()[]
List of parameters used for actually creating the new item.

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


NewItemEventArgs Methods

[image] [image]

.NET Framework Class Library
NewItemEventArgs Methods
NewItemEventArgs Class See Also Send Feedback

The NewItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


NewItemEventArgs Properties

[image] [image]

.NET Framework Class Library
NewItemEventArgs Properties
NewItemEventArgs Class See Also Send Feedback

The NewItemEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the creation of the new item is cancelled.
Item | Gets or sets the newly creating item.
Parameters | Gets the list of parameters that can be used for creating the new item.
ParentEntity | Gets the parent entity of the new item.
ParentItem | Gets the parent item of the new item.

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


Cancel Property

[image]

.NET Framework Class Library
NewItemEventArgs..::.Cancel Property
NewItemEventArgs Class See Also Send Feedback

Gets or sets a value indicating whether the creation of the new item is cancelled.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
NewItemEventArgs..::.Item Property
NewItemEventArgs Class See Also Send Feedback

Gets or sets the newly creating item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Object Item { get; set; }
Visual Basic (Declaration)
Public Property Item As Object

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


Parameters Property

[image]

.NET Framework Class Library
NewItemEventArgs..::.Parameters Property
NewItemEventArgs Class See Also Send Feedback

Gets the list of parameters that can be used for creating the new item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Object[] Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As Object()

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


ParentEntity Property

[image]

.NET Framework Class Library
NewItemEventArgs..::.ParentEntity Property
NewItemEventArgs Class See Also Send Feedback

Gets the parent entity of the new item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity ParentEntity { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentEntity As Entity

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


ParentItem Property

[image]

.NET Framework Class Library
NewItemEventArgs..::.ParentItem Property
NewItemEventArgs Class See Also Send Feedback

Gets the parent item of the new item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Object ParentItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentItem As Object

See Also

NewItemEventArgs Class
DlhSoft.Windows.Data Namespace


NewItemEventHandler Delegate

[image]

.NET Framework Class Library
NewItemEventHandler Delegate
See Also Send Feedback

Represents the method that will handle a NewItem event of the ReadOnlyEntityCollection class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public delegate void NewItemEventHandler(
    Object sender,
    NewItemEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub NewItemEventHandler ( _
    sender As Object, _
    e As NewItemEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: DlhSoft.Windows.Data..::.NewItemEventArgs

See Also

DlhSoft.Windows.Data Namespace


Node Class

[image]

.NET Framework Class Library
Node Class
Members See Also Send Feedback

Represents a node item object wrapper generated and managed by a NodeManager, aware of its indentation in a hierarchical collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class Node : Entity
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class Node _
    Inherits Entity

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.Entity
DlhSoft.Windows.Data..::.Node

See Also

Node Members
DlhSoft.Windows.Data Namespace


Node Members

[image] [image]

.NET Framework Class Library
Node Members
Node Class Constructors Methods Fields Properties Events See Also Send Feedback

The Node type exposes the following members.

Constructors

Name | Description
Node | Overloaded.

Methods

Name | Description
AddRelatedEntity | Adds an entity to the related entities collection of this Entity. (Inherited from Entity.)
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses this Node so its child nodes become invisible.
CollapseBranch | Collapses the branch having this Node as root node so that all child nodes of the branch become invisible.
CollapsePath | Collapses the path to this Node so that all ancestor nodes become closed to ensure this node and all its parents that have parents become invisible.
DecreaseIndentation | Decreases the indentation of this Node.
Dispose | Releases all resources used by the Entity. (Inherited from Entity.)
Equals | (Inherited from DependencyObject.)
Expand | Expands this Node so that its child nodes become visible.
ExpandBranch | Expands the branch having this Node as root node so that all child nodes of the branch become visible.
ExpandPath | Expands the path to this Node so that all ancestor nodes become expanded to ensure this node becomes visible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetIsExpansionEnabled | Gets a value indicating whether node expansion is enabled for a specified element such as a node item.
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncreaseIndentation | Increases the indentation of this Node.
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChildrenChanged | Called when the Children property changes.
OnDisposing | Called when the Entity is disposed. (Inherited from Entity.)
OnFilteringVisibilityChanged | Applies visibility changes when filtering visibility changes. (Overrides Entity..::.OnFilteringVisibilityChanged()()().)
OnHasChildrenChanged | Raises the HasChildrenChanged event.
OnHasParentChanged | Raises the HasParentChanged event.
OnHierarchyChanged | Raises the HierarchyChanged event.
OnHierarchyChanging | Raises the HierarchyChanging event.
OnIndentationChanged | Called when the Indentation property changes.
OnInsertedIntoParentCollection | Called after the Entity is inserted into the parent collection. (Inherited from Entity.)
OnIsExpandedChanged | Called when the IsExpanded property changes.
OnIsExpansionEnabledChanged | Called when the IsExpansionEnabled property changes.
OnIsFilteringVisibleChanged | Called when the IsFilteringVisible property changes. (Inherited from Entity.)
OnIsVisibleChanged | Called when the IsVisible property changes. (Inherited from Entity.)
OnParentChanged | Overloaded.
OnParentEntitySet | Called after the Entity was set as owned by a parent collection. (Inherited from Entity.)
OnParentManagerInitializeEntitiesComplete | Called when the initialization of the parent EntityManager is completed. (Inherited from Entity.)
OnPropertyChanged | (Inherited from DependencyObject.)
OnRelatedEntityAdded | Called when an entity is added to the related entities collection. (Inherited from Entity.)
OnRelatedEntityRemoved | Called when an entity is removed from the related entities collection. (Inherited from Entity.)
OnRemovingFromParentCollection | Called before the Entity is removed from the parent collection. (Inherited from Entity.)
OnVisibilityChanged | Raises the VisibilityChanged event. (Inherited from Entity.)
ReadLocalValue | (Inherited from DependencyObject.)
RemoveRelatedEntity | Removes an entity from the related entities collection of this Entity. (Inherited from Entity.)
RemoveValue | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetIsExpansionEnabled | Sets a value indicating whether node expansion is enabled for a specified element such as a node item.
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToggleIsExpanded | Toggles the expansion for this Node so that if the node was collapsed it is expanded and if the node was expanded it is collapsed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateValue | Overloaded.
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
ChildrenProperty | Identifies the Children dependency property.
HasChildrenProperty | Identifies the HasChildren dependency property.
HasParentProperty | Identifies the HasParent dependency property.
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.
IsExpansionEnabledProperty | Identifies the IsExpansionEnabled attached property.
ParentProperty | Identifies the Parent dependency property.

Properties

Name | Description
CanCollapse | Gets a value indicating whether this Node can be collapsed.
CanCollapseBranch | Gets a value indicating whether the branch that has this Node as root node can be collapsed.
CanDecreaseIndentation | Gets a value indicating whether the indentation for this Node can be decreased.
CanExpand | Gets a value indicating whether this Node can be expanded.
CanExpandBranch | Gets a value indicating whether the branch that has this Node as root node can be expanded.
CanIncreaseIndentation | Gets a value indicating whether the indentation for this Node can be increased.
Children | Enumerates the child nodes of this Node in the collection based on indentation. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
HasChildren | Gets a value indicating whether this Node has any child nodes in the collection based on indentation. This is a dependency property.
HasParent | Gets a value indicating whether this Node has a parent node in the collection based on indentation. This is a dependency property.
Indentation | Gets or sets the indentation level of this Node. This is a dependency property.
Index | Gets the index of this Entity in the parent collection that owns it. This is a dependency property. (Inherited from Entity.)
IsDisposed | Gets a value indicating whether the Entity is currently disposed. (Inherited from Entity.)
IsExpanded | Gets or sets the expansion indicator of this Node. This is a dependency property.
IsExpansionEnabled | Gets or sets a value indicating whether expansion is enabled for this node. This is a dependency property.
IsFilteringVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection based when filtering is applied. This is a dependency property. (Inherited from Entity.)
IsSealed | (Inherited from DependencyObject.)
IsVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection. This is a dependency property. (Inherited from Entity.)
Item | Gets (or sets, when using simple data management mode) the object wrapped by this Entity. This is a dependency property. (Inherited from Entity.)
Parent | Gets the parent node of this Node in the collection based on indentation. This is a dependency property.
ParentCollection | Gets the parent collection that owns this Node. This is a dependency property.
ParentEntity | Gets the parent entity that owns this Entity. This is a dependency property. (Inherited from Entity.)
ParentManager | Gets the parent manager that owns this Entity. This is a dependency property. (Inherited from Entity.)
RelatedEntities | Gets the related entities collection of this Entity. This is a dependency property. (Inherited from Entity.)

Events

Name | Description
Disposing | Occurs when the Entity is disposed. (Inherited from Entity.)
HasChildrenChanged | Occurs when the has children property value changes for this Node.
HasParentChanged | Occurs when the has parent property value changes for this Node.
HierarchyChanged | Occurs when the hierarchy changes at this Node.
HierarchyChanging | Occurs when the hierarchy is about to change at this Node.
ParentChanged | Occurs when the parent changes for this Node.
VisibilityChanged | Occurs when the visibility changes for this Entity. (Inherited from Entity.)

See Also

Node Class
DlhSoft.Windows.Data Namespace


Node Constructor

[image] [image]

.NET Framework Class Library
Node Constructor
Node Class See Also Send Feedback

Overload List

Name | Description
Node(Object, Entity..::.Initialization) | Initializes a new instance of the Node class.
Node(Object, String, String) | Initializes a new instance of the Node class.
Node(Object, String, String, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization) | Initializes a new instance of the Node class.

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


Node Constructor (Object, Entity.Initialization)

[image]

.NET Framework Class Library
Node Constructor (Object, Entity..::.Initialization)
Node Class See Also Send Feedback

Initializes a new instance of the Node class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected internal Node(
    Object item,
    Entity..::.Initialization initialization
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object, _
    initialization As Entity..::.Initialization _
)

Parameters

item
Type: System..::.Object
Node item to be wrapped by the Node.
initialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Node is inserted into the parent collection.

See Also

Node Class
Node Overload
DlhSoft.Windows.Data Namespace


Node Constructor (Object, String, String)

[image]

.NET Framework Class Library
Node Constructor (Object, String, String)
Node Class See Also Send Feedback

Initializes a new instance of the Node class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected internal Node(
    Object item,
    string indentationMemberPath,
    string isExpandedMemberPath
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object, _
    indentationMemberPath As String, _
    isExpandedMemberPath As String _
)

Parameters

item
Type: System..::.Object
Source node item to be wrapped by the Node.
indentationMemberPath
Type: System..::.String
Path to an Int32 value on the source node item to serve as the indentation level in the hierarchical collection, or null to indicate that the indentation level is not provided by the source node item.
isExpandedMemberPath
Type: System..::.String
Path to a Boolean value on the source node item to serve as the expansion indicator in the hierarchical collection, or null to indicate that the expansion indicator is not provided by the source node item.

See Also

Node Class
Node Overload
DlhSoft.Windows.Data Namespace


Node Constructor (Object, String, String, Entity.Initialization, Entity.Initialization, Entity.Initialization, Entity.Initialization)

[image]

.NET Framework Class Library
Node Constructor (Object, String, String, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization, Entity..::.Initialization)
Node Class See Also Send Feedback

Initializes a new instance of the Node class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected internal Node(
    Object item,
    string indentationMemberPath,
    string isExpandedMemberPath,
    Entity..::.Initialization completingParentManagerInitialization,
    Entity..::.Initialization insertedIntoParentCollectionInitialization,
    Entity..::.Initialization removingFromParentCollectionInitialization,
    Entity..::.Initialization disposingInitialization
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    item As Object, _
    indentationMemberPath As String, _
    isExpandedMemberPath As String, _
    completingParentManagerInitialization As Entity..::.Initialization, _
    insertedIntoParentCollectionInitialization As Entity..::.Initialization, _
    removingFromParentCollectionInitialization As Entity..::.Initialization, _
    disposingInitialization As Entity..::.Initialization _
)

Parameters

item
Type: System..::.Object
Source node item to be wrapped by the Node.
indentationMemberPath
Type: System..::.String
Path to an Int32 value on the source node item to serve as the indentation level in the hierarchical collection, or null to indicate that the indentation level is not provided by the source node item.
isExpandedMemberPath
Type: System..::.String
Path to a Boolean value on the source node item to serve as the expansion indicator in the hierarchical collection, or null to indicate that the expansion indicator is not provided by the source node item.
completingParentManagerInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the initialization of the parent EntityManager is completed.
insertedIntoParentCollectionInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Node is inserted into the parent collection.
removingFromParentCollectionInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Node is removed from the parent collection.
disposingInitialization
Type: DlhSoft.Windows.Data..::.Entity..::.Initialization
A method to be called when the Node is disposed.

See Also

Node Class
Node Overload
DlhSoft.Windows.Data Namespace


Node Fields

[image] [image]

.NET Framework Class Library
Node Fields
Node Class See Also Send Feedback

The Node type exposes the following members.

Fields

Name | Description
ChildrenProperty | Identifies the Children dependency property.
HasChildrenProperty | Identifies the HasChildren dependency property.
HasParentProperty | Identifies the HasParent dependency property.
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.
IsExpansionEnabledProperty | Identifies the IsExpansionEnabled attached property.
ParentProperty | Identifies the Parent dependency property.

See Also

Node Class
DlhSoft.Windows.Data Namespace


ChildrenProperty Field

[image]

.NET Framework Class Library
Node..::.ChildrenProperty Field
Node Class See Also Send Feedback

Identifies the Children dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty ChildrenProperty
Visual Basic (Declaration)
Public Shared ReadOnly ChildrenProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasChildrenProperty Field

[image]

.NET Framework Class Library
Node..::.HasChildrenProperty Field
Node Class See Also Send Feedback

Identifies the HasChildren dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty HasChildrenProperty
Visual Basic (Declaration)
Public Shared ReadOnly HasChildrenProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasParentProperty Field

[image]

.NET Framework Class Library
Node..::.HasParentProperty Field
Node Class See Also Send Feedback

Identifies the HasParent dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty HasParentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HasParentProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


IndentationProperty Field

[image]

.NET Framework Class Library
Node..::.IndentationProperty Field
Node Class See Also Send Feedback

Identifies the Indentation dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty IndentationProperty
Visual Basic (Declaration)
Public Shared ReadOnly IndentationProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


IsExpandedProperty Field

[image]

.NET Framework Class Library
Node..::.IsExpandedProperty Field
Node Class See Also Send Feedback

Identifies the IsExpanded dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


IsExpansionEnabledProperty Field

[image]

.NET Framework Class Library
Node..::.IsExpansionEnabledProperty Field
Node Class See Also Send Feedback

Identifies the IsExpansionEnabled attached property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty IsExpansionEnabledProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpansionEnabledProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


ParentProperty Field

[image]

.NET Framework Class Library
Node..::.ParentProperty Field
Node Class See Also Send Feedback

Identifies the Parent dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty ParentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParentProperty As DependencyProperty

See Also

Node Class
DlhSoft.Windows.Data Namespace


Node Methods

[image] [image]

.NET Framework Class Library
Node Methods
Node Class See Also Send Feedback

The Node type exposes the following members.

Methods

Name | Description
AddRelatedEntity | Adds an entity to the related entities collection of this Entity. (Inherited from Entity.)
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Collapse | Collapses this Node so its child nodes become invisible.
CollapseBranch | Collapses the branch having this Node as root node so that all child nodes of the branch become invisible.
CollapsePath | Collapses the path to this Node so that all ancestor nodes become closed to ensure this node and all its parents that have parents become invisible.
DecreaseIndentation | Decreases the indentation of this Node.
Dispose | Releases all resources used by the Entity. (Inherited from Entity.)
Equals | (Inherited from DependencyObject.)
Expand | Expands this Node so that its child nodes become visible.
ExpandBranch | Expands the branch having this Node as root node so that all child nodes of the branch become visible.
ExpandPath | Expands the path to this Node so that all ancestor nodes become expanded to ensure this node becomes visible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetIsExpansionEnabled | Gets a value indicating whether node expansion is enabled for a specified element such as a node item.
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncreaseIndentation | Increases the indentation of this Node.
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChildrenChanged | Called when the Children property changes.
OnDisposing | Called when the Entity is disposed. (Inherited from Entity.)
OnFilteringVisibilityChanged | Applies visibility changes when filtering visibility changes. (Overrides Entity..::.OnFilteringVisibilityChanged()()().)
OnHasChildrenChanged | Raises the HasChildrenChanged event.
OnHasParentChanged | Raises the HasParentChanged event.
OnHierarchyChanged | Raises the HierarchyChanged event.
OnHierarchyChanging | Raises the HierarchyChanging event.
OnIndentationChanged | Called when the Indentation property changes.
OnInsertedIntoParentCollection | Called after the Entity is inserted into the parent collection. (Inherited from Entity.)
OnIsExpandedChanged | Called when the IsExpanded property changes.
OnIsExpansionEnabledChanged | Called when the IsExpansionEnabled property changes.
OnIsFilteringVisibleChanged | Called when the IsFilteringVisible property changes. (Inherited from Entity.)
OnIsVisibleChanged | Called when the IsVisible property changes. (Inherited from Entity.)
OnParentChanged | Overloaded.
OnParentEntitySet | Called after the Entity was set as owned by a parent collection. (Inherited from Entity.)
OnParentManagerInitializeEntitiesComplete | Called when the initialization of the parent EntityManager is completed. (Inherited from Entity.)
OnPropertyChanged | (Inherited from DependencyObject.)
OnRelatedEntityAdded | Called when an entity is added to the related entities collection. (Inherited from Entity.)
OnRelatedEntityRemoved | Called when an entity is removed from the related entities collection. (Inherited from Entity.)
OnRemovingFromParentCollection | Called before the Entity is removed from the parent collection. (Inherited from Entity.)
OnVisibilityChanged | Raises the VisibilityChanged event. (Inherited from Entity.)
ReadLocalValue | (Inherited from DependencyObject.)
RemoveRelatedEntity | Removes an entity from the related entities collection of this Entity. (Inherited from Entity.)
RemoveValue | Overloaded.
SetCurrentValue | (Inherited from DependencyObject.)
SetIsExpansionEnabled | Sets a value indicating whether node expansion is enabled for a specified element such as a node item.
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToggleIsExpanded | Toggles the expansion for this Node so that if the node was collapsed it is expanded and if the node was expanded it is collapsed.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateValue | Overloaded.
VerifyAccess | (Inherited from DispatcherObject.)

See Also

Node Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
Node..::.ClearValue Method
Node Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


Collapse Method

[image]

.NET Framework Class Library
Node..::.Collapse Method
Node Class See Also Send Feedback

Collapses this Node so its child nodes become invisible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse

See Also

Node Class
DlhSoft.Windows.Data Namespace


CollapseBranch Method

[image]

.NET Framework Class Library
Node..::.CollapseBranch Method
Node Class See Also Send Feedback

Collapses the branch having this Node as root node so that all child nodes of the branch become invisible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void CollapseBranch()
Visual Basic (Declaration)
Public Sub CollapseBranch

See Also

Node Class
DlhSoft.Windows.Data Namespace


CollapsePath Method

[image]

.NET Framework Class Library
Node..::.CollapsePath Method
Node Class See Also Send Feedback

Collapses the path to this Node so that all ancestor nodes become closed to ensure this node and all its parents that have parents become invisible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void CollapsePath()
Visual Basic (Declaration)
Public Sub CollapsePath

See Also

Node Class
DlhSoft.Windows.Data Namespace


DecreaseIndentation Method

[image]

.NET Framework Class Library
Node..::.DecreaseIndentation Method
Node Class See Also Send Feedback

Decreases the indentation of this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void DecreaseIndentation()
Visual Basic (Declaration)
Public Sub DecreaseIndentation

See Also

Node Class
DlhSoft.Windows.Data Namespace


Expand Method

[image]

.NET Framework Class Library
Node..::.Expand Method
Node Class See Also Send Feedback

Expands this Node so that its child nodes become visible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand

See Also

Node Class
DlhSoft.Windows.Data Namespace


ExpandBranch Method

[image]

.NET Framework Class Library
Node..::.ExpandBranch Method
Node Class See Also Send Feedback

Expands the branch having this Node as root node so that all child nodes of the branch become visible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void ExpandBranch()
Visual Basic (Declaration)
Public Sub ExpandBranch

See Also

Node Class
DlhSoft.Windows.Data Namespace


ExpandPath Method

[image]

.NET Framework Class Library
Node..::.ExpandPath Method
Node Class See Also Send Feedback

Expands the path to this Node so that all ancestor nodes become expanded to ensure this node becomes visible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void ExpandPath()
Visual Basic (Declaration)
Public Sub ExpandPath

See Also

Node Class
DlhSoft.Windows.Data Namespace


GetIsExpansionEnabled Method

[image]

.NET Framework Class Library
Node..::.GetIsExpansionEnabled Method
Node Class See Also Send Feedback

Gets a value indicating whether node expansion is enabled for a specified element such as a node item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static bool GetIsExpansionEnabled(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetIsExpansionEnabled ( _
    element As DependencyObject _
) As Boolean

Parameters

element
Type: System.Windows..::.DependencyObject

See Also

Node Class
DlhSoft.Windows.Data Namespace


IncreaseIndentation Method

[image]

.NET Framework Class Library
Node..::.IncreaseIndentation Method
Node Class See Also Send Feedback

Increases the indentation of this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void IncreaseIndentation()
Visual Basic (Declaration)
Public Sub IncreaseIndentation

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnChildrenChanged Method

[image]

.NET Framework Class Library
Node..::.OnChildrenChanged Method
Node Class See Also Send Feedback

Called when the Children property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnChildrenChanged(
    IEnumerable<Node> oldChildren,
    IEnumerable<Node> newChildren
)
Visual Basic (Declaration)
Protected Overridable Sub OnChildrenChanged ( _
    oldChildren As IEnumerable(Of Node), _
    newChildren As IEnumerable(Of Node) _
)

Parameters

oldChildren
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)
newChildren
Type: System.Collections.Generic..::.IEnumerable <(Of <( Node >)>)

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnFilteringVisibilityChanged Method

[image]

.NET Framework Class Library
Node..::.OnFilteringVisibilityChanged Method
Node Class See Also Send Feedback

Applies visibility changes when filtering visibility changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected override void OnFilteringVisibilityChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnFilteringVisibilityChanged

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnHasChildrenChanged Method

[image]

.NET Framework Class Library
Node..::.OnHasChildrenChanged Method
Node Class See Also Send Feedback

Raises the HasChildrenChanged event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnHasChildrenChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnHasChildrenChanged

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnHasParentChanged Method

[image]

.NET Framework Class Library
Node..::.OnHasParentChanged Method
Node Class See Also Send Feedback

Raises the HasParentChanged event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnHasParentChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnHasParentChanged

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnHierarchyChanged Method

[image]

.NET Framework Class Library
Node..::.OnHierarchyChanged Method
Node Class See Also Send Feedback

Raises the HierarchyChanged event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnHierarchyChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnHierarchyChanged

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnHierarchyChanging Method

[image]

.NET Framework Class Library
Node..::.OnHierarchyChanging Method
Node Class See Also Send Feedback

Raises the HierarchyChanging event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnHierarchyChanging()
Visual Basic (Declaration)
Protected Overridable Sub OnHierarchyChanging

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnIndentationChanged Method

[image]

.NET Framework Class Library
Node..::.OnIndentationChanged Method
Node Class See Also Send Feedback

Called when the Indentation property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnIndentationChanged(
    int oldIndentation,
    int newIndentation
)
Visual Basic (Declaration)
Protected Overridable Sub OnIndentationChanged ( _
    oldIndentation As Integer, _
    newIndentation As Integer _
)

Parameters

oldIndentation
Type: System..::.Int32
newIndentation
Type: System..::.Int32

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnIsExpandedChanged Method

[image]

.NET Framework Class Library
Node..::.OnIsExpandedChanged Method
Node Class See Also Send Feedback

Called when the IsExpanded property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnIsExpandedChanged(
    bool oldIsExpanded,
    bool newIsExpanded
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsExpandedChanged ( _
    oldIsExpanded As Boolean, _
    newIsExpanded As Boolean _
)

Parameters

oldIsExpanded
Type: System..::.Boolean
newIsExpanded
Type: System..::.Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnIsExpansionEnabledChanged Method

[image]

.NET Framework Class Library
Node..::.OnIsExpansionEnabledChanged Method
Node Class See Also Send Feedback

Called when the IsExpansionEnabled property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnIsExpansionEnabledChanged(
    bool oldIsExpansionEnabled,
    bool newIsExpansionEnabled
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsExpansionEnabledChanged ( _
    oldIsExpansionEnabled As Boolean, _
    newIsExpansionEnabled As Boolean _
)

Parameters

oldIsExpansionEnabled
Type: System..::.Boolean
newIsExpansionEnabled
Type: System..::.Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


OnParentChanged Method

[image] [image]

.NET Framework Class Library
Node..::.OnParentChanged Method
Node Class See Also Send Feedback

Overload List

Name | Description
OnParentChanged()()() | Raises the ParentChanged event.
OnParentChanged(Node, Node) | Called when the Parent property changes.

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


OnParentChanged Method

[image]

.NET Framework Class Library
Node..::.OnParentChanged Method
Node Class See Also Send Feedback

Raises the ParentChanged event.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnParentChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnParentChanged

See Also

Node Class
OnParentChanged Overload
DlhSoft.Windows.Data Namespace


OnParentChanged Method (Node, Node)

[image]

.NET Framework Class Library
Node..::.OnParentChanged Method (Node, Node)
Node Class See Also Send Feedback

Called when the Parent property changes.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected virtual void OnParentChanged(
    Node oldParent,
    Node newParent
)
Visual Basic (Declaration)
Protected Overridable Sub OnParentChanged ( _
    oldParent As Node, _
    newParent As Node _
)

Parameters

oldParent
Type: DlhSoft.Windows.Data..::.Node
newParent
Type: DlhSoft.Windows.Data..::.Node

See Also

Node Class
OnParentChanged Overload
DlhSoft.Windows.Data Namespace


RemoveValue Method

[image] [image]

.NET Framework Class Library
Node..::.RemoveValue Method
Node Class See Also Send Feedback

Overload List

Name | Description
RemoveValue(DependencyProperty) | Clears the local value of a dependency property, specified by its dependency property identifier. (Inherited from Entity.)
RemoveValue(DependencyPropertyKey) | Clears the local value of a dependency property, specified by its DependencyPropertyKey identifier. (Inherited from Entity.)

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


SetIsExpansionEnabled Method

[image]

.NET Framework Class Library
Node..::.SetIsExpansionEnabled Method
Node Class See Also Send Feedback

Sets a value indicating whether node expansion is enabled for a specified element such as a node item.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static void SetIsExpansionEnabled(
    DependencyObject element,
    bool isExpansionEnabled
)
Visual Basic (Declaration)
Public Shared Sub SetIsExpansionEnabled ( _
    element As DependencyObject, _
    isExpansionEnabled As Boolean _
)

Parameters

element
Type: System.Windows..::.DependencyObject
isExpansionEnabled
Type: System..::.Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
Node..::.SetValue Method
Node Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


ToggleIsExpanded Method

[image]

.NET Framework Class Library
Node..::.ToggleIsExpanded Method
Node Class See Also Send Feedback

Toggles the expansion for this Node so that if the node was collapsed it is expanded and if the node was expanded it is collapsed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void ToggleIsExpanded()
Visual Basic (Declaration)
Public Sub ToggleIsExpanded

See Also

Node Class
DlhSoft.Windows.Data Namespace


UpdateValue Method

[image] [image]

.NET Framework Class Library
Node..::.UpdateValue Method
Node Class See Also Send Feedback

Overload List

Name | Description
UpdateValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier, if the specified new value is different than the previous value of that dependency property. (Inherited from Entity.)
UpdateValue(DependencyPropertyKey, Object) | Sets the local value of a dependency property, specified by its DependencyPropertyKey identifier, if the specified new value is different than the previous value of that dependency property. (Inherited from Entity.)

See Also

Node Class
Node Members
DlhSoft.Windows.Data Namespace


Node Properties

[image] [image]

.NET Framework Class Library
Node Properties
Node Class See Also Send Feedback

The Node type exposes the following members.

Properties

Name | Description
CanCollapse | Gets a value indicating whether this Node can be collapsed.
CanCollapseBranch | Gets a value indicating whether the branch that has this Node as root node can be collapsed.
CanDecreaseIndentation | Gets a value indicating whether the indentation for this Node can be decreased.
CanExpand | Gets a value indicating whether this Node can be expanded.
CanExpandBranch | Gets a value indicating whether the branch that has this Node as root node can be expanded.
CanIncreaseIndentation | Gets a value indicating whether the indentation for this Node can be increased.
Children | Enumerates the child nodes of this Node in the collection based on indentation. This is a dependency property.
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
HasChildren | Gets a value indicating whether this Node has any child nodes in the collection based on indentation. This is a dependency property.
HasParent | Gets a value indicating whether this Node has a parent node in the collection based on indentation. This is a dependency property.
Indentation | Gets or sets the indentation level of this Node. This is a dependency property.
Index | Gets the index of this Entity in the parent collection that owns it. This is a dependency property. (Inherited from Entity.)
IsDisposed | Gets a value indicating whether the Entity is currently disposed. (Inherited from Entity.)
IsExpanded | Gets or sets the expansion indicator of this Node. This is a dependency property.
IsExpansionEnabled | Gets or sets a value indicating whether expansion is enabled for this node. This is a dependency property.
IsFilteringVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection based when filtering is applied. This is a dependency property. (Inherited from Entity.)
IsSealed | (Inherited from DependencyObject.)
IsVisible | Gets or sets a value indicating whether or not this Entity is visible in the collection. This is a dependency property. (Inherited from Entity.)
Item | Gets (or sets, when using simple data management mode) the object wrapped by this Entity. This is a dependency property. (Inherited from Entity.)
Parent | Gets the parent node of this Node in the collection based on indentation. This is a dependency property.
ParentCollection | Gets the parent collection that owns this Node. This is a dependency property.
ParentEntity | Gets the parent entity that owns this Entity. This is a dependency property. (Inherited from Entity.)
ParentManager | Gets the parent manager that owns this Entity. This is a dependency property. (Inherited from Entity.)
RelatedEntities | Gets the related entities collection of this Entity. This is a dependency property. (Inherited from Entity.)

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanCollapse Property

[image]

.NET Framework Class Library
Node..::.CanCollapse Property
Node Class See Also Send Feedback

Gets a value indicating whether this Node can be collapsed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapse { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapse As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanCollapseBranch Property

[image]

.NET Framework Class Library
Node..::.CanCollapseBranch Property
Node Class See Also Send Feedback

Gets a value indicating whether the branch that has this Node as root node can be collapsed.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanCollapseBranch { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanCollapseBranch As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanDecreaseIndentation Property

[image]

.NET Framework Class Library
Node..::.CanDecreaseIndentation Property
Node Class See Also Send Feedback

Gets a value indicating whether the indentation for this Node can be decreased.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanDecreaseIndentation { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanDecreaseIndentation As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanExpand Property

[image]

.NET Framework Class Library
Node..::.CanExpand Property
Node Class See Also Send Feedback

Gets a value indicating whether this Node can be expanded.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpand { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpand As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanExpandBranch Property

[image]

.NET Framework Class Library
Node..::.CanExpandBranch Property
Node Class See Also Send Feedback

Gets a value indicating whether the branch that has this Node as root node can be expanded.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanExpandBranch { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanExpandBranch As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


CanIncreaseIndentation Property

[image]

.NET Framework Class Library
Node..::.CanIncreaseIndentation Property
Node Class See Also Send Feedback

Gets a value indicating whether the indentation for this Node can be increased.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(false)]
public bool CanIncreaseIndentation { get; }
Visual Basic (Declaration)
<BindableAttribute(False)> _
Public ReadOnly Property CanIncreaseIndentation As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


Children Property

[image]

.NET Framework Class Library
Node..::.Children Property
Node Class See Also Send Feedback

Enumerates the child nodes of this Node in the collection based on indentation. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public IEnumerable<Node> Children { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Children As IEnumerable(Of Node)

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasChildren Property

[image]

.NET Framework Class Library
Node..::.HasChildren Property
Node Class See Also Send Feedback

Gets a value indicating whether this Node has any child nodes in the collection based on indentation. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool HasChildren { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property HasChildren As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasParent Property

[image]

.NET Framework Class Library
Node..::.HasParent Property
Node Class See Also Send Feedback

Gets a value indicating whether this Node has a parent node in the collection based on indentation. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool HasParent { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property HasParent As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


Indentation Property

[image]

.NET Framework Class Library
Node..::.Indentation Property
Node Class See Also Send Feedback

Gets or sets the indentation level of this Node. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public int Indentation { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Indentation As Integer

See Also

Node Class
DlhSoft.Windows.Data Namespace


IsExpanded Property

[image]

.NET Framework Class Library
Node..::.IsExpanded Property
Node Class See Also Send Feedback

Gets or sets the expansion indicator of this Node. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpanded As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


IsExpansionEnabled Property

[image]

.NET Framework Class Library
Node..::.IsExpansionEnabled Property
Node Class See Also Send Feedback

Gets or sets a value indicating whether expansion is enabled for this node. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpansionEnabled { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpansionEnabled As Boolean

See Also

Node Class
DlhSoft.Windows.Data Namespace


Parent Property

[image]

.NET Framework Class Library
Node..::.Parent Property
Node Class See Also Send Feedback

Gets the parent node of this Node in the collection based on indentation. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Node Parent { get; internal set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Parent As Node

See Also

Node Class
DlhSoft.Windows.Data Namespace


ParentCollection Property

[image]

.NET Framework Class Library
Node..::.ParentCollection Property
Node Class See Also Send Feedback

Gets the parent collection that owns this Node. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public NodeCollection ParentCollection { get; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public ReadOnly Property ParentCollection As NodeCollection

See Also

Node Class
DlhSoft.Windows.Data Namespace


Node Events

[image] [image]

.NET Framework Class Library
Node Events
Node Class See Also Send Feedback

The Node type exposes the following members.

Events

Name | Description
Disposing | Occurs when the Entity is disposed. (Inherited from Entity.)
HasChildrenChanged | Occurs when the has children property value changes for this Node.
HasParentChanged | Occurs when the has parent property value changes for this Node.
HierarchyChanged | Occurs when the hierarchy changes at this Node.
HierarchyChanging | Occurs when the hierarchy is about to change at this Node.
ParentChanged | Occurs when the parent changes for this Node.
VisibilityChanged | Occurs when the visibility changes for this Entity. (Inherited from Entity.)

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasChildrenChanged Event

[image]

.NET Framework Class Library
Node..::.HasChildrenChanged Event
Node Class See Also Send Feedback

Occurs when the has children property value changes for this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public event EventHandler HasChildrenChanged
Visual Basic (Declaration)
Public Event HasChildrenChanged As EventHandler

See Also

Node Class
DlhSoft.Windows.Data Namespace


HasParentChanged Event

[image]

.NET Framework Class Library
Node..::.HasParentChanged Event
Node Class See Also Send Feedback

Occurs when the has parent property value changes for this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public event EventHandler HasParentChanged
Visual Basic (Declaration)
Public Event HasParentChanged As EventHandler

See Also

Node Class
DlhSoft.Windows.Data Namespace


HierarchyChanged Event

[image]

.NET Framework Class Library
Node..::.HierarchyChanged Event
Node Class See Also Send Feedback

Occurs when the hierarchy changes at this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public event EventHandler HierarchyChanged
Visual Basic (Declaration)
Public Event HierarchyChanged As EventHandler

See Also

Node Class
DlhSoft.Windows.Data Namespace


HierarchyChanging Event

[image]

.NET Framework Class Library
Node..::.HierarchyChanging Event
Node Class See Also Send Feedback

Occurs when the hierarchy is about to change at this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public event EventHandler HierarchyChanging
Visual Basic (Declaration)
Public Event HierarchyChanging As EventHandler

See Also

Node Class
DlhSoft.Windows.Data Namespace


ParentChanged Event

[image]

.NET Framework Class Library
Node..::.ParentChanged Event
Node Class See Also Send Feedback

Occurs when the parent changes for this Node.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public event EventHandler ParentChanged
Visual Basic (Declaration)
Public Event ParentChanged As EventHandler

See Also

Node Class
DlhSoft.Windows.Data Namespace


NodeCollection Class

[image]

.NET Framework Class Library
NodeCollection Class
Members See Also Send Feedback

Observable collection that owns Node objects used internally by a NodeManager.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class NodeCollection : EntityCollection
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class NodeCollection _
    Inherits EntityCollection

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Entity >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( Entity >)>)
DlhSoft.Windows.Data..::.EntityCollection
DlhSoft.Windows.Data..::.NodeCollection

See Also

NodeCollection Members
DlhSoft.Windows.Data Namespace


NodeCollection Members

[image] [image]

.NET Framework Class Library
NodeCollection Members
NodeCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The NodeCollection type exposes the following members.

Constructors

Name | Description
NodeCollection | Initializes a new instance of the NodeCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
BlockReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
CheckReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ClearItems | Removes all entities from the collection. (Inherited from EntityCollection.)
CollapseAll | Collapses all nodes of the collection so that all child nodes become invisible.
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Entity >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all nodes of the collection so that all child nodes become visible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEntity | Gets the entity that wraps the specified object, or null if such entity doesn't exist. (Inherited from EntityCollection.)
GetEntityAt | Gets the entity at the specified index. (Inherited from EntityCollection.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNode | Gets the node that wraps the specified object, or null if such node doesn't exist.
GetNodeAt | Gets the node at the specified index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Entity >)>).)
InsertItem | Inserts a node to the collection at the specified index and sets it as owned by this NodeCollection. (Overrides EntityCollection..::.InsertItem(Int32, Entity).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | (Inherited from ObservableCollection <(Of <( Entity >)>).)
MoveItem | Moves the entity at the specified index to a new location in the collection. (Inherited from EntityCollection.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveItem | Removes the node at the specified index of the collection and sets it as not owned by this NodeCollection. (Overrides EntityCollection..::.RemoveItem(Int32).)
SetItem | Replaces the entity at the specified index. (Inherited from EntityCollection.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Item | Gets the node at the specified index.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ParentEntity | Gets the parent entity of this collection. (Inherited from EntityCollection.)
ParentManager | Gets the parent manager of this collection.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entity >)>).)

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


NodeCollection Constructor

[image]

.NET Framework Class Library
NodeCollection Constructor
NodeCollection Class See Also Send Feedback

Initializes a new instance of the NodeCollection class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected internal NodeCollection(
    NodeManager parentManager
)
Visual Basic (Declaration)
Protected Friend Sub New ( _
    parentManager As NodeManager _
)

Parameters

parentManager
Type: DlhSoft.Windows.Data..::.NodeManager
The parent manager of the collection.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


NodeCollection Methods

[image] [image]

.NET Framework Class Library
NodeCollection Methods
NodeCollection Class See Also Send Feedback

The NodeCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
BlockReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
CheckReentrancy | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ClearItems | Removes all entities from the collection. (Inherited from EntityCollection.)
CollapseAll | Collapses all nodes of the collection so that all child nodes become invisible.
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Entity >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExpandAll | Expands all nodes of the collection so that all child nodes become visible.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEntity | Gets the entity that wraps the specified object, or null if such entity doesn't exist. (Inherited from EntityCollection.)
GetEntityAt | Gets the entity at the specified index. (Inherited from EntityCollection.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNode | Gets the node that wraps the specified object, or null if such node doesn't exist.
GetNodeAt | Gets the node at the specified index.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Entity >)>).)
InsertItem | Inserts a node to the collection at the specified index and sets it as owned by this NodeCollection. (Overrides EntityCollection..::.InsertItem(Int32, Entity).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Move | (Inherited from ObservableCollection <(Of <( Entity >)>).)
MoveItem | Moves the entity at the specified index to a new location in the collection. (Inherited from EntityCollection.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
RemoveItem | Removes the node at the specified index of the collection and sets it as not owned by this NodeCollection. (Overrides EntityCollection..::.RemoveItem(Int32).)
SetItem | Replaces the entity at the specified index. (Inherited from EntityCollection.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IList..::.Add | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from Collection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from Collection <(Of <( Entity >)>).)

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


CollapseAll Method

[image]

.NET Framework Class Library
NodeCollection..::.CollapseAll Method
NodeCollection Class See Also Send Feedback

Collapses all nodes of the collection so that all child nodes become invisible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void CollapseAll()
Visual Basic (Declaration)
Public Sub CollapseAll

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


ExpandAll Method

[image]

.NET Framework Class Library
NodeCollection..::.ExpandAll Method
NodeCollection Class See Also Send Feedback

Expands all nodes of the collection so that all child nodes become visible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public void ExpandAll()
Visual Basic (Declaration)
Public Sub ExpandAll

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


GetNode Method

[image]

.NET Framework Class Library
NodeCollection..::.GetNode Method
NodeCollection Class See Also Send Feedback

Gets the node that wraps the specified object, or null if such node doesn't exist.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public Node GetNode(
    Object item
)
Visual Basic (Declaration)
Public Function GetNode ( _
    item As Object _
) As Node

Parameters

item
Type: System..::.Object
Wrapped object to search for.

Return Value

The node that wraps the specified object, or null if such node doesn't exist.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


GetNodeAt Method

[image]

.NET Framework Class Library
NodeCollection..::.GetNodeAt Method
NodeCollection Class See Also Send Feedback

Gets the node at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public Node GetNodeAt(
    int index
)
Visual Basic (Declaration)
Public Function GetNodeAt ( _
    index As Integer _
) As Node

Parameters

index
Type: System..::.Int32
The zero-based index of the node to be get.

Return Value

The node at the specified index.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


InsertItem Method

[image]

.NET Framework Class Library
NodeCollection..::.InsertItem Method
NodeCollection Class See Also Send Feedback

Inserts a node to the collection at the specified index and sets it as owned by this NodeCollection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Entity entity
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    entity As Entity _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which the node should be inserted.
entity
Type: DlhSoft.Windows.Data..::.Entity
The node to insert.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


RemoveItem Method

[image]

.NET Framework Class Library
NodeCollection..::.RemoveItem Method
NodeCollection Class See Also Send Feedback

Removes the node at the specified index of the collection and sets it as not owned by this NodeCollection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The zero-based index of the node to remove.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


NodeCollection Properties

[image] [image]

.NET Framework Class Library
NodeCollection Properties
NodeCollection Class See Also Send Feedback

The NodeCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
Item | Gets the node at the specified index.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Entity >)>).)
ParentEntity | Gets the parent entity of this collection. (Inherited from EntityCollection.)
ParentManager | Gets the parent manager of this collection.

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | (Inherited from Collection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from Collection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from Collection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from Collection <(Of <( Entity >)>).)

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
NodeCollection..::.Item Property
NodeCollection Class See Also Send Feedback

Gets the node at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public Node Item[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    index As Integer _
) As Node

Parameters

index
Type: System..::.Int32
The zero-based index of the node to be get.

Return Value

The node at the specified index.

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


ParentManager Property

[image]

.NET Framework Class Library
NodeCollection..::.ParentManager Property
NodeCollection Class See Also Send Feedback

Gets the parent manager of this collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public NodeManager ParentManager { get; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public ReadOnly Property ParentManager As NodeManager

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


NodeCollection Events

[image] [image]

.NET Framework Class Library
NodeCollection Events
NodeCollection Class See Also Send Feedback

The NodeCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ObservableCollection <(Of <( Entity >)>).)

See Also

NodeCollection Class
DlhSoft.Windows.Data Namespace


NodeItem Class

[image]

.NET Framework Class Library
NodeItem Class
Members See Also Send Feedback

Represents a node item aware of its indentation and expansion state (can be expanded or collapsed) that can be used as a source object to be wrapped within a Node and managed using a NodeManager or hosted within a hierarchical data management control. It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None)]
public class NodeItem : EntityItem, INodeItem
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None)> _
Public Class NodeItem _
    Inherits EntityItem _
    Implements INodeItem

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.EntityItem
DlhSoft.Windows.Data..::.NodeItem

See Also

NodeItem Members
DlhSoft.Windows.Data Namespace


NodeItem Members

[image] [image]

.NET Framework Class Library
NodeItem Members
NodeItem Class Constructors Methods Fields Properties See Also Send Feedback

The NodeItem type exposes the following members.

Constructors

Name | Description
NodeItem | Overloaded.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Provides a string representation of this EntityItem object. (Inherited from EntityItem.)
VerifyAccess | (Inherited from DispatcherObject.)

Fields

Name | Description
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Properties

Name | Description
Content | Gets or sets the content of this EntityItem. This is a dependency property. (Inherited from EntityItem.)
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
Indentation | Gets or sets the indentation level of this NodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
IsExpanded | Gets or sets the expansion indicator of this NodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this EntityItem. This is a dependency property. (Inherited from EntityItem.)

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


NodeItem Constructor

[image] [image]

.NET Framework Class Library
NodeItem Constructor
NodeItem Class See Also Send Feedback

Overload List

Name | Description
NodeItem()()() | Initializes a new instance of the NodeItem class.
NodeItem(Object, Int32, Boolean) | Initializes a new instance of the NodeItem class.

See Also

NodeItem Class
NodeItem Members
DlhSoft.Windows.Data Namespace


NodeItem Constructor

[image]

.NET Framework Class Library
NodeItem Constructor
NodeItem Class See Also Send Feedback

Initializes a new instance of the NodeItem class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public NodeItem()
Visual Basic (Declaration)
Public Sub New

See Also

NodeItem Class
NodeItem Overload
DlhSoft.Windows.Data Namespace


NodeItem Constructor (Object, Int32, Boolean)

[image]

.NET Framework Class Library
NodeItem Constructor (Object, Int32, Boolean)
NodeItem Class See Also Send Feedback

Initializes a new instance of the NodeItem class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public NodeItem(
    Object content,
    int indentation,
    bool isExpanded
)
Visual Basic (Declaration)
Public Sub New ( _
    content As Object, _
    indentation As Integer, _
    isExpanded As Boolean _
)

Parameters

content
Type: System..::.Object
Content of this NodeItem.
indentation
Type: System..::.Int32
Indentation level of this NodeItem.
isExpanded
Type: System..::.Boolean
Expansion indicator of this NodeItem.

See Also

NodeItem Class
NodeItem Overload
DlhSoft.Windows.Data Namespace


NodeItem Fields

[image] [image]

.NET Framework Class Library
NodeItem Fields
NodeItem Class See Also Send Feedback

The NodeItem type exposes the following members.

Fields

Name | Description
IndentationProperty | Identifies the Indentation dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


IndentationProperty Field

[image]

.NET Framework Class Library
NodeItem..::.IndentationProperty Field
NodeItem Class See Also Send Feedback

Identifies the Indentation dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty IndentationProperty
Visual Basic (Declaration)
Public Shared ReadOnly IndentationProperty As DependencyProperty

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


IsExpandedProperty Field

[image]

.NET Framework Class Library
NodeItem..::.IsExpandedProperty Field
NodeItem Class See Also Send Feedback

Identifies the IsExpanded dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


NodeItem Methods

[image] [image]

.NET Framework Class Library
NodeItem Methods
NodeItem Class See Also Send Feedback

The NodeItem type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Provides a string representation of this EntityItem object. (Inherited from EntityItem.)
VerifyAccess | (Inherited from DispatcherObject.)

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
NodeItem..::.ClearValue Method
NodeItem Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

NodeItem Class
NodeItem Members
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
NodeItem..::.SetValue Method
NodeItem Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

NodeItem Class
NodeItem Members
DlhSoft.Windows.Data Namespace


NodeItem Properties

[image] [image]

.NET Framework Class Library
NodeItem Properties
NodeItem Class See Also Send Feedback

The NodeItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this EntityItem. This is a dependency property. (Inherited from EntityItem.)
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
Indentation | Gets or sets the indentation level of this NodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.
IsExpanded | Gets or sets the expansion indicator of this NodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.
IsSealed | (Inherited from DependencyObject.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this EntityItem. This is a dependency property. (Inherited from EntityItem.)

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


Indentation Property

[image]

.NET Framework Class Library
NodeItem..::.Indentation Property
NodeItem Class See Also Send Feedback

Gets or sets the indentation level of this NodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public int Indentation { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Indentation As Integer

Implements

INodeItem..::.Indentation

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


IsExpanded Property

[image]

.NET Framework Class Library
NodeItem..::.IsExpanded Property
NodeItem Class See Also Send Feedback

Gets or sets the expansion indicator of this NodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible. This is a dependency property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpanded As Boolean

Implements

INodeItem..::.IsExpanded

See Also

NodeItem Class
DlhSoft.Windows.Data Namespace


NodeManager Class

[image]

.NET Framework Class Library
NodeManager Class
Members See Also Send Feedback

Object collection management engine that uses a node collection to wrap the objects internally. Provides automatic management of indentation (node hierarchy) and expansion (node visibility) for the collection items. Use Items property to set your own node data item collection to manage and use Nodes property to access the managed node collection mapping your items. It is recommended to set at least these data member properties: IndentationMemberPath. These data member properties can also be set: IsExpandedMemberPath.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class NodeManager : EntityManager,
    ISupportInitializeNotification
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class NodeManager _
    Inherits EntityManager _
    Implements ISupportInitializeNotification

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
DlhSoft.Windows.Data..::.EntityManager
DlhSoft.Windows.Data..::.NodeManager

See Also

NodeManager Members
DlhSoft.Windows.Data Namespace


NodeManager Members

[image] [image]

.NET Framework Class Library
NodeManager Members
NodeManager Class Methods Properties See Also Send Feedback

The NodeManager type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerifyAccess | (Inherited from DispatcherObject.)

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)

See Also

NodeManager Class
DlhSoft.Windows.Data Namespace


NodeManager Methods

[image] [image]

.NET Framework Class Library
NodeManager Methods
NodeManager Class See Also Send Feedback

The NodeManager type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DispatcherObject.)
ClearValue | Overloaded.
CoerceValue | (Inherited from DependencyObject.)
Equals | (Inherited from DependencyObject.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from DependencyObject.)
GetLocalValueEnumerator | (Inherited from DependencyObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateProperty | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | (Inherited from DependencyObject.)
ReadLocalValue | (Inherited from DependencyObject.)
SetCurrentValue | (Inherited from DependencyObject.)
SetValue | Overloaded.
ShouldSerializeProperty | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
VerifyAccess | (Inherited from DispatcherObject.)

See Also

NodeManager Class
DlhSoft.Windows.Data Namespace


ClearValue Method

[image] [image]

.NET Framework Class Library
NodeManager..::.ClearValue Method
NodeManager Class See Also Send Feedback

Overload List

Name | Description
ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
ClearValue(DependencyPropertyKey) | (Inherited from DependencyObject.)

See Also

NodeManager Class
NodeManager Members
DlhSoft.Windows.Data Namespace


SetValue Method

[image] [image]

.NET Framework Class Library
NodeManager..::.SetValue Method
NodeManager Class See Also Send Feedback

Overload List

Name | Description
SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
SetValue(DependencyPropertyKey, Object) | (Inherited from DependencyObject.)

See Also

NodeManager Class
NodeManager Members
DlhSoft.Windows.Data Namespace


NodeManager Properties

[image] [image]

.NET Framework Class Library
NodeManager Properties
NodeManager Class See Also Send Feedback

The NodeManager type exposes the following members.

Properties

Name | Description
DependencyObjectType | (Inherited from DependencyObject.)
Dispatcher | (Inherited from DispatcherObject.)
IsSealed | (Inherited from DependencyObject.)

See Also

NodeManager Class
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Class

[image]

.NET Framework Class Library
ReadOnlyEntityCollection Class
Members See Also Send Feedback

Read-only observable collection of Entity objects.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class ReadOnlyEntityCollection : ReadOnlyObservableCollection<Entity>
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class ReadOnlyEntityCollection _
    Inherits ReadOnlyObservableCollection(Of Entity)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.ReadOnlyCollection <(Of <( Entity >)>)
System.Collections.ObjectModel..::.ReadOnlyObservableCollection <(Of <( Entity >)>)
DlhSoft.Windows.Data..::.ReadOnlyEntityCollection
DlhSoft.Windows.Data..::.ReadOnlyNodeCollection

See Also

ReadOnlyEntityCollection Members
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Members

[image] [image]

.NET Framework Class Library
ReadOnlyEntityCollection Members
ReadOnlyEntityCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The ReadOnlyEntityCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyEntityCollection | Initializes a new instance of the ReadOnlyEntityCollection class.

Methods

Name | Description
AddItem | Delegates adding of an item to the bound managed item collection.
AddNewItem | Delegates adding of a new item created based on the specified parameters to the bound managed item collection.
ClearItems | Delegates clearing of all items from the bound managed item collection.
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CreateNewItem | Called when a new item is created in the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new item themselves. Inheriters should return their own item type based on the parameters list provided.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
InsertItem | Delegates inserting of an item to the bound managed item collection.
InsertNewItem | Delegates inserting of a new item created based on the specified parameters to the bound managed item collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
OnNewItem | Raises the NewItem event when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. If the event handlers do not set up a new item (using the Item property setter of the event arguments) creates a new item by calling CreateNewItem method.
OnPropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
RemoveItem | Delegates removing of an item from the bound managed item collection.
RemoveItemAt | Delegates removing of an item from the bound managed item collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
Item | Gets the entity at the specified index.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ParentManager | Gets the parent manager of this collection.

Events

Name | Description
CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
NewItem | Occurs when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type.
PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(T>)>)..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
INotifyCollectionChanged..::.CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsFixedSize | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Constructor

[image]

.NET Framework Class Library
ReadOnlyEntityCollection Constructor
ReadOnlyEntityCollection Class See Also Send Feedback

Initializes a new instance of the ReadOnlyEntityCollection class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public ReadOnlyEntityCollection(
    EntityCollection entities
)
Visual Basic (Declaration)
Public Sub New ( _
    entities As EntityCollection _
)

Parameters

entities
Type: DlhSoft.Windows.Data..::.EntityCollection
Source entity collection to be used by the new read-only entity collection.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Methods

[image] [image]

.NET Framework Class Library
ReadOnlyEntityCollection Methods
ReadOnlyEntityCollection Class See Also Send Feedback

The ReadOnlyEntityCollection type exposes the following members.

Methods

Name | Description
AddItem | Delegates adding of an item to the bound managed item collection.
AddNewItem | Delegates adding of a new item created based on the specified parameters to the bound managed item collection.
ClearItems | Delegates clearing of all items from the bound managed item collection.
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CreateNewItem | Called when a new item is created in the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new item themselves. Inheriters should return their own item type based on the parameters list provided.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
InsertItem | Delegates inserting of an item to the bound managed item collection.
InsertNewItem | Delegates inserting of a new item created based on the specified parameters to the bound managed item collection.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
OnNewItem | Raises the NewItem event when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. If the event handlers do not set up a new item (using the Item property setter of the event arguments) creates a new item by calling CreateNewItem method.
OnPropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
RemoveItem | Delegates removing of an item from the bound managed item collection.
RemoveItemAt | Delegates removing of an item from the bound managed item collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(T>)>)..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


AddItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.AddItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates adding of an item to the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity AddItem(
    Object item
)
Visual Basic (Declaration)
Public Function AddItem ( _
    item As Object _
) As Entity

Parameters

item
Type: System..::.Object
The item to add.

Return Value

The entity wrapping the item added into the bound managed item collection.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


AddNewItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.AddNewItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates adding of a new item created based on the specified parameters to the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity AddNewItem(
    params Object[] parameters
)
Visual Basic (Declaration)
Public Function AddNewItem ( _
    ParamArray parameters As Object() _
) As Entity

Parameters

parameters
Type: array< System..::.Object >[]()[]
List of custom parameters representing values that can be used for creating the new item.

Return Value

The entity wrapping the new item added into the bound managed item collection.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ClearItems Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.ClearItems Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates clearing of all items from the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void ClearItems()
Visual Basic (Declaration)
Public Sub ClearItems

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


CreateNewItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.CreateNewItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Called when a new item is created in the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new item themselves. Inheriters should return their own item type based on the parameters list provided.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected virtual Object CreateNewItem(
    params Object[] parameters
)
Visual Basic (Declaration)
Protected Overridable Function CreateNewItem ( _
    ParamArray parameters As Object() _
) As Object

Parameters

parameters
Type: array< System..::.Object >[]()[]
List of parameters passed from InsertNewItem method used for actually creating the new item. Inheriters can customize this list as their own item type requires.

Return Value

The newly created item.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


InsertItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.InsertItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates inserting of an item to the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity InsertItem(
    int index,
    Object item
)
Visual Basic (Declaration)
Public Function InsertItem ( _
    index As Integer, _
    item As Object _
) As Entity

Parameters

index
Type: System..::.Int32
Zero-based index to insert the item to.
item
Type: System..::.Object
The item to insert.

Return Value

The entity wrapping the item inserted into the bound managed item collection.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


InsertNewItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.InsertNewItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates inserting of a new item created based on the specified parameters to the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity InsertNewItem(
    int index,
    params Object[] parameters
)
Visual Basic (Declaration)
Public Function InsertNewItem ( _
    index As Integer, _
    ParamArray parameters As Object() _
) As Entity

Parameters

index
Type: System..::.Int32
Zero-based index to insert the new item to.
parameters
Type: array< System..::.Object >[]()[]
List of custom parameters representing values that can be used for creating the new item.

Return Value

The entity wrapping the new item created and inserted into the bound managed item collection.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


OnNewItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.OnNewItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Raises the NewItem event when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. If the event handlers do not set up a new item (using the Item property setter of the event arguments) creates a new item by calling CreateNewItem method.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
protected internal virtual Object OnNewItem(
    out bool cancel,
    params Object[] parameters
)
Visual Basic (Declaration)
Protected Friend Overridable Function OnNewItem ( _
    <OutAttribute> ByRef cancel As Boolean, _
    ParamArray parameters As Object() _
) As Object

Parameters

cancel
Type: System..::.Boolean %
Indicates whether the creation of the new item is cancelled.
parameters
Type: array< System..::.Object >[]()[]
List of parameters passed from InsertNewItem method used for actually creating the new item. Inheriters can customize this list as their own item type requires.

Return Value

The newly created item.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


RemoveItem Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.RemoveItem Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates removing of an item from the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void RemoveItem(
    Object item
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    item As Object _
)

Parameters

item
Type: System..::.Object
The item to remove.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


RemoveItemAt Method

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.RemoveItemAt Method
ReadOnlyEntityCollection Class See Also Send Feedback

Delegates removing of an item from the bound managed item collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public void RemoveItemAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveItemAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Zero-based index to remove the item from.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Properties

[image] [image]

.NET Framework Class Library
ReadOnlyEntityCollection Properties
ReadOnlyEntityCollection Class See Also Send Feedback

The ReadOnlyEntityCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
Item | Gets the entity at the specified index.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ParentManager | Gets the parent manager of this collection.

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.Item Property
ReadOnlyEntityCollection Class See Also Send Feedback

Gets the entity at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public Entity Item[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    index As Integer _
) As Entity

Parameters

index
Type: System..::.Int32
The zero-based index of the entity to get.

Return Value

The entity at the specified index.

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ParentManager Property

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.ParentManager Property
ReadOnlyEntityCollection Class See Also Send Feedback

Gets the parent manager of this collection.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public EntityManager ParentManager { get; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public ReadOnly Property ParentManager As EntityManager

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyEntityCollection Events

[image] [image]

.NET Framework Class Library
ReadOnlyEntityCollection Events
ReadOnlyEntityCollection Class See Also Send Feedback

The ReadOnlyEntityCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
NewItem | Occurs when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type.
PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
INotifyCollectionChanged..::.CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


NewItem Event

[image]

.NET Framework Class Library
ReadOnlyEntityCollection..::.NewItem Event
ReadOnlyEntityCollection Class See Also Send Feedback

Occurs when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public event NewItemEventHandler NewItem
Visual Basic (Declaration)
Public Event NewItem As NewItemEventHandler

See Also

ReadOnlyEntityCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Class

[image]

.NET Framework Class Library
ReadOnlyNodeCollection Class
Members See Also Send Feedback

Read-only observable collection of Node objects.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.Ignore)]
public class ReadOnlyNodeCollection : ReadOnlyEntityCollection
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.Ignore)> _
Public Class ReadOnlyNodeCollection _
    Inherits ReadOnlyEntityCollection

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.ReadOnlyCollection <(Of <( Entity >)>)
System.Collections.ObjectModel..::.ReadOnlyObservableCollection <(Of <( Entity >)>)
DlhSoft.Windows.Data..::.ReadOnlyEntityCollection
DlhSoft.Windows.Data..::.ReadOnlyNodeCollection

See Also

ReadOnlyNodeCollection Members
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Members

[image] [image]

.NET Framework Class Library
ReadOnlyNodeCollection Members
ReadOnlyNodeCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The ReadOnlyNodeCollection type exposes the following members.

Constructors

Name | Description
ReadOnlyNodeCollection | Initializes a new instance of the ReadOnlyNodeCollection class.

Methods

Name | Description
AddItem | Delegates adding of an item to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
AddNewItem | Delegates adding of a new item created based on the specified parameters to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
ClearItems | Delegates clearing of all items from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CreateNewItem | Called when a new node item is added to the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new node item themselves. (Overrides ReadOnlyEntityCollection..::.CreateNewItem(array<Object>[]()[]).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
InsertItem | Delegates inserting of an item to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
InsertNewItem | Delegates inserting of a new item created based on the specified parameters to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
OnNewItem | Raises the NewItem event when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. If the event handlers do not set up a new item (using the Item property setter of the event arguments) creates a new item by calling CreateNewItem method. (Inherited from ReadOnlyEntityCollection.)
OnPropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
RemoveItem | Delegates removing of an item from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
RemoveItemAt | Delegates removing of an item from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
Item | Gets the node at the specified index.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ParentManager | Gets the parent manager of this collection. (Inherited from ReadOnlyEntityCollection.)

Events

Name | Description
CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
NewItem | Occurs when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. (Inherited from ReadOnlyEntityCollection.)
PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(T>)>)..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
INotifyCollectionChanged..::.CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsFixedSize | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Constructor

[image]

.NET Framework Class Library
ReadOnlyNodeCollection Constructor
ReadOnlyNodeCollection Class See Also Send Feedback

Initializes a new instance of the ReadOnlyNodeCollection class.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public ReadOnlyNodeCollection(
    NodeCollection nodes
)
Visual Basic (Declaration)
Public Sub New ( _
    nodes As NodeCollection _
)

Parameters

nodes
Type: DlhSoft.Windows.Data..::.NodeCollection
Source node collection to be used by the new read-only node collection.

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Methods

[image] [image]

.NET Framework Class Library
ReadOnlyNodeCollection Methods
ReadOnlyNodeCollection Class See Also Send Feedback

The ReadOnlyNodeCollection type exposes the following members.

Methods

Name | Description
AddItem | Delegates adding of an item to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
AddNewItem | Delegates adding of a new item created based on the specified parameters to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
ClearItems | Delegates clearing of all items from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
CreateNewItem | Called when a new node item is added to the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new node item themselves. (Overrides ReadOnlyEntityCollection..::.CreateNewItem(array<Object>[]()[]).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
InsertItem | Delegates inserting of an item to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
InsertNewItem | Delegates inserting of a new item created based on the specified parameters to the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
OnNewItem | Raises the NewItem event when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. If the event handlers do not set up a new item (using the Item property setter of the event arguments) creates a new item by calling CreateNewItem method. (Inherited from ReadOnlyEntityCollection.)
OnPropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
RemoveItem | Delegates removing of an item from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
RemoveItemAt | Delegates removing of an item from the bound managed item collection. (Inherited from ReadOnlyEntityCollection.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICollection<(Of <(T>)>)..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Add | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Clear | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Contains | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.CopyTo | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IEnumerable..::.GetEnumerator | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IndexOf | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Insert | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Remove | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.RemoveAt | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


CreateNewItem Method

[image]

.NET Framework Class Library
ReadOnlyNodeCollection..::.CreateNewItem Method
ReadOnlyNodeCollection Class See Also Send Feedback

Called when a new node item is added to the collection by calling InsertNewItem method and the event handlers of the NewItem event haven't set up the new node item themselves.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
protected override Object CreateNewItem(
    params Object[] parameters
)
Visual Basic (Declaration)
Protected Overrides Function CreateNewItem ( _
    ParamArray parameters As Object() _
) As Object

Parameters

parameters
Type: array< System..::.Object >[]()[]
List of parameters passed from InsertNewItem method used for actually creating the new node item.

Return Value

The newly created node item.

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Properties

[image] [image]

.NET Framework Class Library
ReadOnlyNodeCollection Properties
ReadOnlyNodeCollection Class See Also Send Feedback

The ReadOnlyNodeCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
Item | Gets the node at the specified index.
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ParentManager | Gets the parent manager of this collection. (Inherited from ReadOnlyEntityCollection.)

Explicit Interface Implementations

Name | Description
IList..::.IsFixedSize | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection<(Of <(T>)>)..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.IsReadOnly | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.IsSynchronized | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList<(Of <(T>)>)..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
IList..::.Item | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)
ICollection..::.SyncRoot | (Inherited from ReadOnlyCollection <(Of <( Entity >)>).)

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


Item Property

[image]

.NET Framework Class Library
ReadOnlyNodeCollection..::.Item Property
ReadOnlyNodeCollection Class See Also Send Feedback

Gets the node at the specified index.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public Node Item[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item ( _
    index As Integer _
) As Node

Parameters

index
Type: System..::.Int32
The zero-based index of the node to get.

Return Value

The node at the specified index.

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


ReadOnlyNodeCollection Events

[image] [image]

.NET Framework Class Library
ReadOnlyNodeCollection Events
ReadOnlyNodeCollection Class See Also Send Feedback

The ReadOnlyNodeCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
NewItem | Occurs when a new item is created in the collection by calling InsertNewItem method to allow the event handlers to create their own item type. (Inherited from ReadOnlyEntityCollection.)
PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

Explicit Interface Implementations

Name | Description
INotifyCollectionChanged..::.CollectionChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)
INotifyPropertyChanged..::.PropertyChanged | (Inherited from ReadOnlyObservableCollection <(Of <( Entity >)>).)

See Also

ReadOnlyNodeCollection Class
DlhSoft.Windows.Data Namespace


SimpleEntityItem Class

[image]

.NET Framework Class Library
SimpleEntityItem Class
Members See Also Send Feedback

Represents a simple entity item that can be used as a data definition object when inserting or adding an Entity using an EntityManager with simple data management mode.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None)]
[ContentPropertyAttribute("Content")]
public class SimpleEntityItem : IEntityItem
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None)> _
<ContentPropertyAttribute("Content")> _
Public Class SimpleEntityItem _
    Implements IEntityItem

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Data..::.SimpleEntityItem
DlhSoft.Windows.Data..::.SimpleNodeItem

See Also

SimpleEntityItem Members
DlhSoft.Windows.Data Namespace


SimpleEntityItem Members

[image] [image]

.NET Framework Class Library
SimpleEntityItem Members
SimpleEntityItem Class Constructors Methods Properties See Also Send Feedback

The SimpleEntityItem type exposes the following members.

Constructors

Name | Description
SimpleEntityItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Provides a string representation of this SimpleEntityItem object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Content | Gets or sets the content of this SimpleEntityItem.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this SimpleEntityItem.

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


SimpleEntityItem Constructor

[image]

.NET Framework Class Library
SimpleEntityItem Constructor
SimpleEntityItem Class See Also Send Feedback

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public SimpleEntityItem()
Visual Basic (Declaration)
Public Sub New

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


SimpleEntityItem Methods

[image] [image]

.NET Framework Class Library
SimpleEntityItem Methods
SimpleEntityItem Class See Also Send Feedback

The SimpleEntityItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Provides a string representation of this SimpleEntityItem object. (Overrides Object..::.ToString()()().)

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


ToString Method

[image]

.NET Framework Class Library
SimpleEntityItem..::.ToString Method
SimpleEntityItem Class See Also Send Feedback

Provides a string representation of this SimpleEntityItem object.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

The string representation of the object.

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


SimpleEntityItem Properties

[image] [image]

.NET Framework Class Library
SimpleEntityItem Properties
SimpleEntityItem Class See Also Send Feedback

The SimpleEntityItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this SimpleEntityItem.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this SimpleEntityItem.

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


Content Property

[image]

.NET Framework Class Library
SimpleEntityItem..::.Content Property
SimpleEntityItem Class See Also Send Feedback

Gets or sets the content of this SimpleEntityItem.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Content { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Content As Object

Implements

IEntityItem..::.Content

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


Tag Property

[image]

.NET Framework Class Library
SimpleEntityItem..::.Tag Property
SimpleEntityItem Class See Also Send Feedback

Gets or sets an arbitrary object value that can be used to store custom information about this SimpleEntityItem.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.Data.Core (in DlhSoft.Data.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public Object Tag { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Tag As Object

See Also

SimpleEntityItem Class
DlhSoft.Windows.Data Namespace


SimpleNodeItem Class

[image]

.NET Framework Class Library
SimpleNodeItem Class
Members See Also Send Feedback

Represents a simple node item that can be used as a data definition object when inserting or adding a Node using a NodeManager with simple data management mode. It is recommended to set at least these data properties: Indentation. These data properties can also be set: IsExpanded.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[LocalizabilityAttribute(LocalizationCategory.None)]
public class SimpleNodeItem : SimpleEntityItem,
    INodeItem
Visual Basic (Declaration)
<LocalizabilityAttribute(LocalizationCategory.None)> _
Public Class SimpleNodeItem _
    Inherits SimpleEntityItem _
    Implements INodeItem

Inheritance Hierarchy

System..::.Object
DlhSoft.Windows.Data..::.SimpleEntityItem
DlhSoft.Windows.Data..::.SimpleNodeItem

See Also

SimpleNodeItem Members
DlhSoft.Windows.Data Namespace


SimpleNodeItem Members

[image] [image]

.NET Framework Class Library
SimpleNodeItem Members
SimpleNodeItem Class Constructors Methods Properties See Also Send Feedback

The SimpleNodeItem type exposes the following members.

Constructors

Name | Description
SimpleNodeItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Provides a string representation of this SimpleEntityItem object. (Inherited from SimpleEntityItem.)

Properties

Name | Description
Content | Gets or sets the content of this SimpleEntityItem. (Inherited from SimpleEntityItem.)
Indentation | Gets or sets the indentation level of this SimpleNodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property.
IsExpanded | Gets or sets the expansion indicator of this SimpleNodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this SimpleEntityItem. (Inherited from SimpleEntityItem.)

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace


SimpleNodeItem Constructor

[image]

.NET Framework Class Library
SimpleNodeItem Constructor
SimpleNodeItem Class See Also Send Feedback

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
public SimpleNodeItem()
Visual Basic (Declaration)
Public Sub New

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace


SimpleNodeItem Methods

[image] [image]

.NET Framework Class Library
SimpleNodeItem Methods
SimpleNodeItem Class See Also Send Feedback

The SimpleNodeItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Provides a string representation of this SimpleEntityItem object. (Inherited from SimpleEntityItem.)

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace


SimpleNodeItem Properties

[image] [image]

.NET Framework Class Library
SimpleNodeItem Properties
SimpleNodeItem Class See Also Send Feedback

The SimpleNodeItem type exposes the following members.

Properties

Name | Description
Content | Gets or sets the content of this SimpleEntityItem. (Inherited from SimpleEntityItem.)
Indentation | Gets or sets the indentation level of this SimpleNodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property.
IsExpanded | Gets or sets the expansion indicator of this SimpleNodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this SimpleEntityItem. (Inherited from SimpleEntityItem.)

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace


Indentation Property

[image]

.NET Framework Class Library
SimpleNodeItem..::.Indentation Property
SimpleNodeItem Class See Also Send Feedback

Gets or sets the indentation level of this SimpleNodeItem. The hierarchy is based on the indentation level values of the nodes, so that a node with a lower index in the collection and having a specific indentation level will become the parent node for the nodes with a higher index in the collection and having an increased indentation level. It is recommended to set this property.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public int Indentation { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property Indentation As Integer

Implements

INodeItem..::.Indentation

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace


IsExpanded Property

[image]

.NET Framework Class Library
SimpleNodeItem..::.IsExpanded Property
SimpleNodeItem Class See Also Send Feedback

Gets or sets the expansion indicator of this SimpleNodeItem. If a parent node is expanded its child nodes become visible. If a parent node is collapsed its child nodes become invisible.

Namespace: DlhSoft.Windows.Data
Assembly: DlhSoft.HierarchicalData.Core (in DlhSoft.HierarchicalData.Core.dll)

Syntax

C#
[BindableAttribute(true)]
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
<BindableAttribute(True)> _
Public Property IsExpanded As Boolean

Implements

INodeItem..::.IsExpanded

See Also

SimpleNodeItem Class
DlhSoft.Windows.Data Namespace